
Chapter 11

Dimensioning the
Drawing Views

After completing this chapter you will be able to:

• Show or erase the dimensions in the drawing views.
• Modify and edit the dimensions.
• Add reference datums to the drawing views.
• Add dimensional and geometric tolerance to the drawing views.
• Edit the geometric tolerance.
• Add notes to the drawing.
• Add balloons to the exploded assembly views.

Learning Objectives
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DIMENSIONING THE DRAWING VIEWS
Once you have generated the drawing views, you need to generate the dimensions in the
drawing views, and add notes, symbols, balloons, and so on. These dimensions are the
dimensions assigned to each of the entities that created the model or to the features associated
with the model. This is done by using the Show / Erase dialog box shown in Figure 11-1. The
Show / Erase dialog box is displayed when you choose the Show and Erase option from the
VIEW menu in the menu bar.

Show / Erase Dialog Box Options
Show
The Show button is chosen to select the options to generate
the various parameters related to the model in the drawing
views. The options that are displayed when you choose this
button are discussed next.

Type Area
The options to display the different parameters will be
available only when you select at least one button from
this area.

Dimension. The Dimension button is
chosen to generate the parametric
dimensions in the drawing views. The

bidirectional associative nature of this software
package is valid when you change the dimension
value generated using this option.

Reference Dimension. The Reference
Dimension button is chosen to generate the
reference dimensions in the drawing views.

Geometric Tolerance. The Geometric
Tolerance button is chosen to display the
geometric tolerances in the dimensions.

Note. The Note button is chosen to display
the notes that were created in the Part
mode. If any change is made to a note in

the Drawing mode, the note in the Part mode is
automatically modified. Similarly, if you modify this note in the Part mode, the
modifications are reflected automatically in the Drawing mode.

Figure 11-1  Show / Erase
dialog box with the Show tab

Tip: The dimensional tolerance will be displayed only when the tol_display is set to
YES in the configuration file. This file is displayed when you choose DRAWING >
Advanced > Draw Setup from the Menu Manager.
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mBalloon. The Balloon button is chosen to display the balloons associated

with an assembly in the drawing views.

Axis. The Axis button is chosen to display the axis of the selected hole or
cylindrical feature in the drawing views.

Symbol. The Symbol button is chosen to display any symbol associated
with the model.

Surface Finish. The Surface Finish button is chosen to display the surface
finish symbols associated with the part in the drawing views.

Datum Plane. The Datum Plane button is chosen to display the reference
datum planes in the drawing views.

Cosmetic Feature. The Cosmetic Feature button is chosen to display the
cosmetic features in the drawing views that are associated with the model.

Show By Area
The options in this area are discussed next.

Feature. The Feature radio button is chosen to display the required annotation of the
selected feature. If the required annotation of the selected feature cannot be displayed in
the view in which the feature was selected then the required annotation will be displayed
in the appropriate views.

Part. The Part radio button is chosen to display all the required annotations of the
selected part. The required annotations are displayed in all the views irrespective of
the view in which the part was selected.

View. The View radio button is chosen to display all the required annotations that can
be displayed in the selected view.

Feat_View. The Feat_View radio button is chosen to display the required annotations
of the selected feature that can be displayed in the selected view.

Part_View. The Part_View radio button is chosen to display all the required annotations
of the selected part that can be displayed in the selected view.

Show All. The Show All button is chosen to show all the required annotations in the
drawing views. When you choose this button all the required annotations that were
used in creating the model are displayed in the drawing views.

Options Tab
The options under this tab of the Show / Erase dialog box are discussed next.

Erased. The Erased check box is selected to display the annotations that were once
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erased. If this check box is cleared, the annotations that were once erased using the
Show / Erase dialog box will not be displayed the next time you wish to display them.

Never Shown. The Never Shown check box is selected to display the annotations that
are never displayed in the drawing views. At least one of the Erased or the Never
Shown check box remains selected while specifying the annotation.

Switch to ordinate. The Switch to ordinate check box is selected to switch to the
ordinate mode of dimensioning. When you select this check box, you will be prompted
to select a dimension that will be the baseline dimension for the other ordinate
dimensions.

Preview Tab
The options under this tab of the Show / Erase dialog box are discussed next.

With Preview. The With Preview check box is selected to allow you to confirm the
placement of the annotation. If this check box is selected then when you show the
annotations, you will be prompted to confirm the annotations that you want to keep
or delete. You can select the annotations to keep, to delete, accept all, or delete all
using the buttons provided under this area. The remaining options under this area
will be available only after you place the annotations. If this check box is cleared then
you will not be prompted to confirm the placement of the annotation. All the displayed
annotations will be automatically placed in the drawing views.

Erase
The options under the Erase button are shown in Figure 11-2. These options are used to erase
the annotations placed using the options under the Show button. The annotations once placed
in the drawing view can also be erased by selecting it. When the selected annotation turns red
in color, right-click and choose the Erase option from the shortcut menu that appears. The
selected annotation gets erased from the drawing view.

Note
The annotations erased using the Erase options are not deleted from the model.

Type Area
The buttons provided under this tab are similar to those under the Type area of the Show
button. The only difference is that here these buttons are used to erase the items.

Erase By Area
The options in this area are discussed next.

Selected Items. If the Selected Items radio button is selected then you can select the
annotations to be erased using the left mouse button.

Feature. If the Feature radio button is selected then all the annotations of the feature
that you select will be erased from all the views.
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Feat_View. If the Feat_View radio button is selected then all the annotations related
to the selected feature will be erased from the selected view.

Part. If the Part radio button is selected then all the annotations related to the selected
part will be erased from all the drawing views.

Part_View. If the Part_View radio button is selected then all the annotations related
to the selected part will be erased from the selected view.

View. The View radio button is selected to erase all the annotations displayed in the
selected view.

Erase All. The Erase All button is chosen to erase all the annotations displayed in all
the views of the current sheet. When you choose this button, you will be prompted to
confirm that all the annotations can be erased.

MODIFYING AND EDITING THE DIMENSIONS
Pro/ENGINEER allows you to edit and modify the dimensions assigned to the drawing views.
There are various methods of editing and modifying these dimensions. Figure 11-3 shows the

Figure 11-2  Show / Erase dialog box with the Erase tab
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dimensioned drawing views. But before these methods are discussed, it is important for you to
learn the terminology used in these methods. Figure 11-4 shows the terminology that is used
in the Drawing mode of Pro/ENGINEER.

Modifying the Dimensions using the Dimension Properties
dialog box
The Properties option is available only when the dimension to be modified is selected on the
drawing sheet. The Dimension Properties dialog box is displayed when you choose the
Properties option from the Edit menu in the menu bar. The Dimension Properties dialog
box can also be displayed when you select the dimension and hold down the right mouse
button to invoke the shortcut menu. Choose the Properties option from the shortcut menu.
The Dimension Properties dialog box is displayed as shown in Figure 11-5. The options in
this dialog box are discussed next.

Properties Tab
Value and Tolerance Area
The options provided under this area are related to the tolerance in the drawing.

Tip: To display the dimensions in a 3D view, first you will have to set the value of
allow_3d_dimensions to YES in the configuration file. If this value is set to NO
then the dimensions will not be displayed in 3D views.

Figure 11-3  Dimensioned drawing views
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Figure 11-5  The Properties tab of the Dimension Properties dialog box

Figure 11-4  Parameters associated with the dimensions
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Tolerance Mode. This drop-down list will be available only when the value of
tol_display is set to YES in the configuration file. The options under this drop-down
list are used to select the type of tolerance mode. Depending upon the option selected
from this drop-down list, the other options in this area change.

Format Area
Decimal. The Decimal radio button is chosen to display the dimensions in the
decimal format. The number of decimal values can be set in the Number of decimal
places edit box.

Fractional. The Fractional radio button is chosen to display the dimensions in the
fractional format. The largest denominator can be set using the Largest denominator
edit box that is displayed when you select the Fractional radio button.

Dual dimension Area
The options under the Dual dimension area will be available only when the value of
dual_dimensioning is set to YES in the configuration file. The options under this area
are used to specify the placement point for the dual dimensioning and the number of the
decimal places.

Display Area
Basic. If the Basic check box is selected then the selected dimension values will be
displayed inside a rectangular box.

Inspection. If the Inspection check box is selected then the selected dimension will
be displayed inside an elliptical box.

Dimension Text Tab
The Dimension Properties dialog box with the options under the Dimension Text tab is
shown in Figure 11-6.

Dimension Text Area
The Dimension text box displays the text of the dimension. You can edit the text using
this box.

Name
The Name edit box display the dimension symbol. You can change the dimension symbol
using this box.

Prefix
The Prefix edit box is used to add some additional text as prefix to the default dimension
text.

Tip: If you modify the nominal value of a dimension in the Value and Tolerance
area, you will have to regenerate the model using the DRAWING > Regenerate >
Model from the Menu Manager to view the effect of modifications.
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Postfix
The Postfix edit box is used to add some additional text as suffix to the default dimension
text.

Move
The Move button is chosen to move the dimension to a new location on the current sheet.
You can also move the dimension by selecting it and then moving it by moving the mouse.

Move Text
The Move Text button is chosen to move the dimension text to a new location on the
screen. Remember that only the text will be moved. The witness lines and the dimension
lines do not move from their original location.

Modify Attach
The Modify Attach button is used to modify the attachment point of dimensions of some
features like draft, round, and chamfer.

Figure 11-6  The Dimension Text tab of the Dimension Properties dialog box

Tip: The modifications made using the Dimension Properties dialog box are applied
dynamically on the dimensions. You can view this in the background by moving the
Dimension Properties dialog box on the side of the screen.
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Sym Palette
The Sym Palette button is chosen to display the Symbol Palette dialog box using which
you can add special symbols to the default dimension text.

Modifying the drawing items using the Shortcut Menu
When you select an item from a drawing view and hold down the right mouse button to invoke
the shortcut menu, various options are displayed in the shortcut menu. The options in the
shortcut menu depends upon the item selected to modify and varies from item to item. Some
of the items related to the drawing that can be modified using the shortcut menu are discussed
next.

Value
You can modify the dimension value. However, to view the effect of the modification, you will
have to regenerate the model using DRAWING > Regenerate > Model from the Menu
Manager. This option is also used to modify the scale of the drawing view and tolerance
values.

Number of Decimal Places
To modify the number of decimal values for the dimension text, choose the Decimal Places
option from the Format menu in the menu bar. You will be prompted to specify the number of
decimal places in the Message Input Window. After you have specified the value, you will be
prompted to select the dimensions to be modified.

Miscellaneous Modifications
The modifications that can be made using the shortcut menu are: move a dimension, flip the
arrows of the dimensions, switch the selected dimension from one view to the other, make a
jog in the witness line, modify the values or text of the dimension, modify the arrow style,
break the witness line, remove the break from the witness line, erase the witness line, show the
erased witness line, or erase the selected dimension from the drawing view.

Text
The parameters that can be modified are the selected text line, the entire text material, text
height, text style, style library for the text, and the current style.

Cleaning Up the Dimensions
Generally, the dimensions displayed in the drawing views are scattered and improperly placed.
This in turn makes the drawing views look very untidy. Pro/ENGINEER allows you to place
these dimensions in proper order using just one single step. The Clean Dimensions dialog
box allows the user to set a standard for displaying the dimensions in the drawing views. When
you choose the Cleanup dimensions option from the Edit menu in the menu bar, the Clean
Dimensions dialog box will be displayed as shown in Figure 11-7 and you will be prompted to
select the dimensions to be cleaned. The options in this dialog box are discussed next.

Placement Tab
The options under this tab of the Clean Dimensions dialog box are used for placing the
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the distance between the view boundary and the
dimension, are set under this tab.

Space Dimensions
The Space Dimensions option is used to maintain
the distance between two dimensions.

Offset
The Offset edit box is used to specify the offset
distance between the first dimension and the
view boundary.

Increment
The Increment edit box is used to specify the offset
distance between the two dimension lines.

Offset Reference Area
View Outline. The View Outline radio button
is selected to specify the offset distances taking
the outline of the view as reference.

Baseline. The Baseline radio button is used
to specify the offset distance taking a selected
flat edge, datum plane, snap line, detail axis
line, or view border as the reference. When
you invoke this option, you will be prompted
to select either of the above-mentioned entities as the reference.

Create Snap Lines
The Create Snap Lines check box is selected to create the snap lines using which the
dimensions will be cleaned. The snap lines will be created at the distances specified using
the Offset and the Increment edit boxes. If this check box is cleared then the snap lines
will not be created.

Break witness lines
The Break witness lines check box is selected to break the witness lines if some dimensions
are overlapping each other.

Cosmetic Tab
The options under the Cosmetic tab of the Clean Dimensions dialog box shown in Figure 11-8
are used for determining a dimension value’s location with the dimension line. The arrows
and the orientation of the dimension text can also be controlled using this tab.

Flip Arrows
The Flip Arrows check box is selected to flip the arrows of the dimensions that are not
easily adjusted inside the dimension lines.

Figure 11-7  The Placement tab of the
Clean Dimensions dialog box
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Center Text
The Center Text check box is selected to place the dimensions at the center of the dimension
lines.

Horizontal/Vertical
These buttons are used to specify the placement of the horizontal or vertical dimension
text outside the dimension line if they do not fit.

Figure 11-9 and Figure 11-10 explain the use of Clean Dimensions dialog box.

ADDING REFERENCE DATUMS TO THE DRAWING VIEWS
Reference datums are used as references for geometric tolerance. Datums are to be set before
adding the geometric tolerance.

To create a reference datum, choose Insert > Datum > Plane from the menu bar. The Datum
dialog box will be displayed, as shown in Figure 11-11. You can rename the selected datum
and then choose the second button from the Type area to enclose the datum inside a feature
control frame. You can place these reference datums freely in the drawing views or in a selected
dimension. Figure 11-12 shows the drawing views with reference datums.

Figure 11-8  The Cosmetic tab of the Clean Dimensions dialog box
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Note
The system does not show a reference datum plane in a drawing view unless it is perpendicular
to the graphics screen.

Figure 11-10  The drawing views with dimensions after cleaning

Figure 11-9  Figure showing the drawing views with dimensions before cleaning
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ADDING TOLERANCES IN THE DRAWING VIEWS
Tolerance is defined as the difference between the maximum and minimum variations in the
dimensions of the selected component. It is almost impossible to manufacture a component to
the exact dimensions that have a very large precision. In such cases, the tolerance value is
added to dimensions to make sure that some variation that occurs during manufacturing can
be taken care of. However, when you actually send a part for manufacturing, there are other
parameters along with the dimension tolerances that vary and that need some tolerances.
Depending upon these factors, the tolerances are divided into two types: the dimensional
tolerances and the geometric tolerances.

Figure 11-11  Datum dialog box

Figure 11-12  Drawing views with reference datums
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These are the variation in the standard dimensional values. The dimensional tolerances can
be easily displayed along with the dimensions in the drawing views by simply setting the value
of tol_display to YES in the configuration file. You can select and modify the type of dimensional
tolerances from the Properties tab of the Dimension Properties dialog box. Figure 11-13
shows the drawing views with the tolerance added to the dimensions.

Geometric Tolerances
When you send a component for manufacturing then you have to provide various other
parameters along with the dimensions and dimensional tolerances. These parameters can be
the geometric condition, the surface profile, the material condition, and so on. All these
parameters are defined using the geometric tolerances. The geometric tolerances (will be
called gtol henceforth) can be added to the drawing using the Geometric Tolerance dialog
box, shown in Figure 11-14. The Geometric Tolerance dialog box is displayed when you
choose Insert > Geometric Tolerance from the menu bar.

The options in the Geometric Tolerance dialog box are discussed next.

Model Refs Tab
The options under this tab are used to select the model or drawing where the gtol have to be
placed and to specify the model references.

Figure 11-13  Figure showing dimensions with tolerances
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Model
This drop-down list is used to select the model on which you need to display the gtol. You
can select the model from this drop-down list or select it by using the Select Model button.

Reference
The options under this area are used to select the reference for adding the gtol. The
reference can be an edge, axis, surface, feature, datum, or an entity. You can select the
reference type from the Type drop-down list or select it using the Select Entity button.

Placement
The options under this area will be available only when you select a reference type for
placing the gtol. These options are used to specify the placement type for the gtol. The
placement type can be selected from the Type drop-down list.

Datum Refs Tab
The options under the Datum Refs tab, shown in Figure 11-15, are used to select the primary,
secondary, or tertiary datum references for the gtol. You can also specify the composite tolerances
to the primary, secondary, or tertiary datum references by using the Composite Reference
check box provided in this area. The Composite Tolerance check box is available only when
the Position or the Surface Profile buttons from the types of gtol buttons available on the left
side of the Geometric Tolerance dialog box are selected. The value of the composite reference
can be specified in the Value edit box that is available only when you select the Composite
Reference check box. The datum reference for the composite tolerance can be selected using
the Datum Reference drop-down list that is available only when you select the Composite
Reference check box.

Tol Value Tab
The options under the Tol Value tab, shown in Figure 11-16, are used to specify the tolerance
value and the material condition for the gtol. You can specify the overall tolerance value or the
per units tolerance value using the options under this tab. You can also specify the material
condition using the Material Condition drop-down list.

Figure 11-14  The Model Refs tab of the Geometric Tolerance dialog box
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Figure 11-16  The Tol Value tab of the Geometric Tolerance dialog box

Symbols Tab
The options under the Symbols tab, shown in Figure 11-17, are used to specify the symbols for
the gtol. The symbols and the modifiers for the gtol can be selected from the Symbols and
Modifiers area and the projected tolerance zone symbol can be selected from the Projected
Tolerance Zone area. The location of the projected tolerance zone symbol and its height can
be specified using the options provided under this area. You can also specify the profile boundary
symbol for the profile gtol from the Profile Boundary area that appears in the place to Projected
Tolerance Zone area. Profile Boundary area is only available if you choose Surface Profile or
Line Profile button.

New Gtol
The New Gtol button is chosen to accept the current gtol and place a new gtol.

Figure 11-15  The Datum Refs tab of the Geometric Tolerance dialog box
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Figure 11-18  The drawing view with reference datums and gtol

Move
The Move button is chosen to change the location of the current gtol.

Figure 11-18 shows the drawing view with reference datums and gtol.

EDITING THE GEOMETRIC TOLERANCES
The gtol added to the drawing views can be edited using the Geometric Tolerance dialog box.
This dialog box is displayed when you select the text of the tolerance from the drawing view

Figure 11-17  The Symbols tab of the Geometric Tolerance dialog box
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mand then right-click to display the shortcut menu. Choose the Properties option from the

shortcut menu to display the Geometric Tolerance dialog box. All the options under the
different tabs of the Geometric Tolerance dialog box are similar to those discussed in the
Geometric Tolerance dialog box for adding the gtol.

ADDING NOTES TO THE DRAWING
The notes added to the model in the Part mode can be easily displayed in the drawing views
using the Show / Erase dialog box. However, when you have not added notes to the model in
the Part mode and still want to add them in the drawing views then you will have to create
them. The notes can be created by choosing Insert > Note from the menu bar. When you
choose this option, the NOTE TYPES submenu will be displayed, see Figure 11-19. In the
NOTE TYPES submenu, choose the type of leader to be used if required. Choose the Make
Note option from this submenu and you are prompted to select the location for the note
placement, choose a point on the screen and enter the text in the Message Input Window and
press ENTER. The note will be placed on the point selected.

Note
You can also browse the text file saved in a .txt format using the NOTE TYPES submenu.

Figure 11-19  NOTE TYPES submenu
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Figure 11-20  Drawing view with balloons and note

ADDING BALLOONS TO THE ASSEMBLY VIEWS
The balloons can be added to the assembly drawing views by choosing Insert > Balloon from
the menu bar. The procedure to place balloons is similar to that used while adding notes to the
drawing. See Figure 11-20.

TUTORIALS

In this tutorial you will generate the drawing views of the part shown in Figure 11-21. Generate
the dimensions in the drawing views. The views to be generated are shown in Figure 11-22.

   (Estimated time: 45 min)

The following steps outline the procedure to create the given drawing:

a. Create the model in the Part mode using the given dimensions and save the file.

b. Open a new drawing file in the Drawing mode and generate the top view and the front
view of the model on the drawing sheet.

Tutorial 1

Tip: The notes or balloons can be modified and edited using the options in the shortcut
menu that is displayed when you select them using the left mouse button and hold down
the right mouse button.
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Figure 11-21  Model for generating the drawing views

Figure 11-22  Drawing views to be created along with the dimensions

c. Generate the dimension to the views and clean them using the Clean Dimensions dialog
box.

d. Add geometric tolerance to the required entities.

Before you start creating the model and the drawing views, set the working directory to
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C:\ProE\c11. Make sure that the c11 directory exists inside the ProE directory. If these directories
do not exist, create them using the Select Working Directory dialog box.

Creating the Model
First, create the given model in the part mode whose views are to be generated later.

1. Open a new object file in the Part mode and name it c11tut1.

2. Create the model in the Part mode and save this model.

Creating a New Drawing File
Create a new drawing file to generate the required views.

1. Choose the Create a new object button from the File toolbar. The New dialog box is
displayed.

2. Select the Drawing radio button from the Type area and enter the name of the drawing as
c11tut1 in the Name edit box.

3. Choose OK from the New dialog box to proceed further. The New Drawing dialog box
is displayed.

4. If the name of the model is not displayed in the Default Model area, choose the Browse
button and select the model. Select the Empty radio button from the Specify Template
area, Landscape button from the Orientation area, and the A4 option from the Standard
Size drop-down list.

5. Choose OK from the New Drawing dialog box to enter the Drawing mode.

You enter the Drawing mode and a new A4 size drawing sheet is displayed on the screen.

Generating the Drawing Views
You need to generate the top view and the front view of the model. Any of the two views can be
generated first. However, you will generate the top view first.

1. Choose the Views option from the DRAWING menu in the Menu Manager to display the
VIEW TYPE submenu.

2. Choose General > Full View > No Xsec > Scale > Done.

3. Specify the placement point for the top view as shown in Figure 11-23. As soon as you
specify the point, the Message Input Window is displayed. Enter the scale factor for the
view as 0.06 and press ENTER. The default view is placed and the Orientation dialog box
is displayed.

4. Choose the TOP option from the Saved Views drop-down list in the Orientation dialog
box.



Dimensioning the Drawing Views      11-23

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
. 

F
. 

F
. 

F
. 

F
. 

F o
r 

e
n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r v
ic

e
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

Figure 11-23  Top view and the front view of the model

5. Choose the Set button. The default view is oriented as the top view.

6. Choose OK to exit the Orientation dialog box.

The text for scale is placed at the corner of the sheet so that it does not interfere with the
other text in the drawing sheet. To move the text perform the next step.

Choose the No Hidden from the Model Display toolbar and repaint the screen using the
Redraw the current view button from the View toolbar.

7. Double-click on the text; the text attaches to the cursor. Move the mouse and place the
text at the bottom right corner of the drawing sheet using the left mouse button.

8. Choose the Add View option from the VIEWS submenu in the Menu Manager to display
the VIEW TYPE submenu.

9. Choose Projection > Full View > No Xsec > No Scale > Done.

10. Specify the placement point for the front view below the top view as shown in Figure 11-23.

The two views are shown in Figure 11-23.

Renaming the Datum Planes
The datum planes are renamed because the gtol values to the inclined surface will be applied
with their reference. This is evident from Figure 11-22.
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1. Choose the Datum plane on/off button from the Datum Display toolbar to display the
datum planes and then repaint the screen.

2. Select the RIGHT datum plane from the top view and when it turns red in color
hold down the right mouse button to display the shortcut menu.

3. Choose the Properties option from the shortcut menu. The Datum dialog box is displayed.

4. Enter A in the Name edit box and then select the second button from the Type area to
enclose the datum in the reference box. Make sure the Free radio button is selected in the
Placement area.

5. Choose OK to exit the Datum dialog box.

6. Repeat steps 3, 4, and 5 to rename TOP and FRONT datum planes to B and C respectively.

Dimensioning the Drawing Views
1. Choose View > Show and Erase from the menu bar. The Show / Erase dialog box is

displayed.

2. Choose the Show button if it is not chosen by default and select the Dimension button
from the Type area in the Show / Erase dialog box.

3. Choose the View radio button from the Show By area in the Show / Erase dialog box.

4. Select the front view (the view at the bottom) to display all the dimensions of this view.

5. Choose Done Sel from the GET SELECT menu.

6. Now, select the top view and then select Done Sel from the GET SELECT menu. All the
dimensions and the dimensions for this view are displayed in the selected view.

Placing the Dimensions in Order
The dimensions displayed in the drawing views are scattered and improperly placed. This in
turn makes the drawing look very untidy. You need to place the dimensions in order using the
Clean Dimensions dialog box.

1. Choose Edit > Cleanup Dimensions from the menu bar to display the Clean Dimensions
dialog box. You are prompted to select the dimensions to clean.

2. Choose the Pick Many option from the GET SELECT 1 menu. Select all the dimensions
from both the views by drawing a rectangle around them. Choose Done Sel from the GET
SELECT 1 menu so that the options in the Clean Dimensions dialog box are available.

3. Enter 0.5 in the Offset edit box and 0.5 in the Increment edit box.
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Figure 11-24  Top and the front views of the model with the dimensions and datum planes

4. Clear the Create Snap Lines check box. Choose Apply and then choose Close to exit the
Clean Dimensions dialog box.

5. After cleaning the dimensions, the drawing views should look similar to the one shown in
Figure 11-24.

Select and move the dimensions if necessary.

Displaying the Geometric Tolerance
Actually the tolerance is created in the Part mode. However, in this chapter you will learn how
the tolerances are represented in the Drawing mode.

1. Choose Insert > Geometric Tolerance from the menu bar to display the Geometric
Tolerance dialog box. You will notice that the name of the model c11tut1.prt is displayed
in the Model drop-down list.

2. Choose the geometric condition as angularity using Angularity button from the
Geometric Tolerance dialog box.

3. Select the Surface option from the Type drop-down list in the Reference area and select
the left inclined edge from the front view.

4. Select Leaders from the Type drop-down list in the Placement area. The ATTACH TYPE
menu is displayed and you are prompted to select an edge for attaching the leader.
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Figure 11-25  Top and the front views of the model with the dimensions, datum planes, and
the geometric tolerances

5. Select the left inclined edge from the front view and then middle-click at a position on the
graphics screen where you want the note to be placed. Even if the note is placed at an
improper position on the graphics screen, you can move its location later.

6. Choose the Datum Refs tab from the Geometric Tolerance dialog box.

7. Select B from the Basic drop-down list under the Primary tab of the Datum References
area.

8. Select the Tol Value tab from the Geometric Tolerance dialog box.

9. Enter 0.001 in the Overall Tolerance edit box.

10. Select LMC from the Material Condition drop-down list.

11. Select the Symbols tab and then select the Statistical Tolerance check box from the Symbols
and Modifiers area in the Geometric Tolerance dialog box.

12. Select the Below Gtol radio button from the Projected Tolerance Zone area and then
select the Zone Height check box. Enter 0.001 in this edit box. Choose OK to exit the
Geometric Tolerance dialog box.

13. The drawing views after adding the gtol should look similar to the one shown in
Figure 11-25.
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Figure 11-26  The required drawing

Tutorial 2

You need to move the note for gtol to a location shown in Figure 11-26 by double-clicking
on it. Similarly, arrange all the dimensions and datums on the drawing sheet as shown in
Figure 11-26.

Saving the Drawing File
You need to save the drawing file that you have created as you might need it later.

1. Choose the Save the active object button from the Top Toolchest. The Message Input
Window is displayed with the name of the drawing file that you had entered earlier.

2. Press ENTER to confirm the saving of the file.

In this tutorial you will generate the drawing views of the model shown in Figure 11-27. The
dimensioned drawing views are shown in Figure 11-28.    (Estimated time: 40 min)

The following steps outline the procedure to create the given drawing:

a. Create the model in the Part mode using the given dimensions and save the file.

b. Open a new drawing file in the Drawing mode and generate the top view, front view,
right-side view, and the detailed view of the model on the drawing sheet.

c. Dimension the views and clean the dimensions using the Clean Dimensions dialog box.
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The working directory was selected in tutorial 1 of this chapter. But, if you still want to change
the working directory set it to C:\ProE\c11.

Creating the Model
First create model whose drawing views are to be generated in the Part mode.

1. Create the model in the Part mode using the given dimensions.

Figure 11-27  Model for generating the drawing views

Figure 11-28  The drawing views to be generated in Tutorial 2
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Creating a New Drawing File
Create a new drawing file to generate the required drawing views.

1. Choose the Create a new object button from the File toolbar. The New dialog box is
displayed.

2. Select the Drawing radio button from the Type area and enter the name of the drawing as
c11tut2 in the Name edit box.

3. Choose OK from the New dialog box to display the New Drawing dialog box. The New
Drawing dialog box is displayed with the name of the model in the Default Model area.

4. If the name of the model is not displayed in the Default Model area, choose the Browse
button and select the model.

5. Select the Empty radio button from the Specify Template, Landscape button from the
Orientation area, and the A4 option from the Standard Size drop-down list.

6. Choose OK from the New Drawing dialog box to enter the Drawing mode. A new drawing
sheet of A4 size is displayed on the screen.

Creating the Drawing Views
First, the top view of the model will be generated and then the front view will be generated by
projecting it from the top view. The right-side view will be projected from the front view. The
detail view will be placed on the drawing sheet by specifying a scale for it.

1. Choose the Views option from the DRAWING menu in the Menu Manager to display the
VIEW TYPE submenu.

2. Choose General > Full View > No Xsec > Scale > Done.

3. Specify the placement point for the top view close to the top left corner of the sheet as
shown in Figure 11-29. As soon as you specify the point, the Message Input Window is
displayed. Enter the scale factor for the view as 0.006 and press ENTER. The Orientation
dialog box is displayed. The default view is placed on the point selected.

4. Choose the TOP option from the Saved Views drop-down list in the Orientation dialog
box.

5. Choose the Set button. The default view is oriented as top view on the drawing sheet.

6. Choose OK to exit the Orientation dialog box. Repaint and move the view if necessary.

The front view of the model is generated from the top view.
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Figure 11-29  The drawing views before adding the dimensions

7. Choose Add View from the VIEWS submenu in the Menu Manager to display the VIEW
TYPE submenu.

8. Choose Projection > Full View > No Xsec > No Scale > Done.

9. Specify the placement point for the front view below the top view as shown in Figure 11-29.

10. Similarly, place the right-side view and the detailed view on the drawing sheet as shown in
Figure 11-29.

Dimensioning the Drawing Views
1. Choose View > Show and Erase from the menu bar.

2. Select the Dimension button from the Type area and then select the  Feature radio button
from the Show By area to display the GET SELECT menu. Select the feature in the
detailed view. All the dimensions related to that feature (the base feature) will be displayed
in all the views. Choose Done Sel from the GET SELECT menu. Another GET SELECT
menu is displayed. Choose the Done Sel option again.

3. Select the View radio button from the Show By area and then select all the three views one
by one to display all the dimensions in the views. Choose Done Sel from the
GET SELECT menu and then close the Show / Erase dialog box by choosing the Close
button.

Placing the Dimensions in Order
The dimensions displayed in the drawing views are scattered and improperly placed. Use the
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1. Choose Edit > Cleanup Dimensions from the menu bar to display the Clean Dimensions
dialog box. You are prompted to select the dimensions to clean.

2. Choose the Pick Many option from the GET SELECT 1 menu. Select all the dimensions
from both the views by drawing a rectangle around them. Choose Done Sel from the GET
SELECT menu so that the options in the Clean Dimensions dialog box are available.

When you select the dimensions, the radius dimensions in the drawing views are not
selected. This means that the radius dimensions will remain unaffected by the values that
you will enter in the Clean Dimensions dialog box.

3. Enter 0.4 in the Offset edit box and 0.3 in the Increment edit box.

4. Clear the Create Snap Lines check box. Choose Apply and then choose Close to exit the
Clean Dimensions dialog box.

5. After cleaning the dimensions, notice that the dimensions are not placed in the order that
is required. Now, you need to manually place the dimensions in order.

To move a dimension, double-click on the dimension and place it at the desired location
on the drawing sheet. Some dimensions are repeated, for example, the diameter of the
hole feature is displayed twice in the drawing view. So, you need to erase the dimensions
that are repeated and that are not needed. To erase the dimensions, select the dimension
and hold down the right mouse button to display the shortcut menu. Choose the Erase
option from the shortcut menu. In some cases the dimensions are displayed in the views
in which you do not want them to be displayed. In such cases you can switch that dimension
to the other views. The Switch View option is available in the shortcut menu that is displayed
when you right-click on a dimension.

After manually placing the dimensions the drawing views should look similar to views
shown in Figure 11-30.



11-32      Pro/ENGINEER for Designers
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

e
ch

n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
. 

F
. 

F
. 

F
. 

F
. 

F o
r 

o
nl

in
e

 t
ra

in
in

g
, 

co
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
o

r 
o

nl
in

e
 t

ra
in

in
g

, 
co

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

o
r 

o
nl

in
e

 t
ra

in
in

g
, 

co
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
o

r 
o

nl
in

e
 t

ra
in

in
g

, 
co

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

o
r 

o
nl

in
e

 t
ra

in
in

g
, 

co
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m

Answer the following questions and then compare your answers to the answers given at the
end of this chapter.

1. The reference datum planes are used to display the geometric tolerances in a drawing
view. (T/F)

2. If you modify a dimension value in the Drawing mode and then regenerate the drawing
view, the modification is applied to the model in the Part mode also. (T/F)

3. The notes created in the Part mode on a model can also be displayed in a drawing view in
the Drawing mode. (T/F)

4. When you select a drawing view to display dimensions, all the dimensions are placed in
proper order in the drawing view. (T/F)

5. Most of the editing operations in a drawing view can be done using the shortcut menu
that is displayed when you right-click on an item to be modified. (T/F)

6. The __________ dialog box is used to display the dimensions in the drawing views.

7. The dimension values can be modified using the __________ option from the Edit menu

Figure 11-30  The required drawing views

Self-Evaluation Test
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8. The __________ dialog box is used to clean the dimensions in the drawing views.

9. You have to set the value of __________ to YES in the configuration file to display the
dimensional tolerance in the drawing views.

10. The configuration file can be opened from __________.

Answer the following questions:

1. Which of the following dialog boxes is used to display dimensions in a drawing view?

(a) Dimension Properties (b) Clean Dimensions
(c) Show / Erase (d) None

2. Which of the following dialog boxes is used to modify properties of text in a drawing view?

(a) Dimension Properties (b) Clean Dimensions
(c) Show / Erase (d) None

3. Which of the following dialog boxes is used to display the geometric tolerances in a drawing
view?

(a) Geometric Tolerance (b) Clean Dimensions
(c) Show / Erase (d) None

4. Which of the following options available in the shortcut menu is used to switch a dimension
from one view to another?

(a) Erase (b) Flip Arrows
(c) Switch View (d) None

5. Which of the following radio button in the Type area is selected in the New dialog box to
open a new drawing file?

(a) Assembly (b) Sketch
(c) Part (d) None

6. The dimensions erased using the Erase option from the shortcut menu are deleted from
the model in the Part mode also. (T/F)

7. The notes or balloons can be modified and edited using the options in the shortcut menu.
(T/F)

Review Questions
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Exercise 1

8. The system does not show a reference datum plane in a drawing view unless it is
perpendicular to the graphics screen. (T/F)

9. Generally, the dimensions displayed in the drawing views are scattered and improperly
placed. (T/F)

10. You cannot move text dynamically on the drawing sheet. (T/F)

In this exercise you will generate the drawing views of the model created in Exercise 2 of
Chapter 6 shown in Figure 11-31 and add dimensions to the views as shown in the figure.

   (Estimated time: 40 min)

Note
In the above drawing views, the center lines are not generated but are created manually. After
creating the center lines you need to define a linestyle and then apply it on the center lines.

Answers to the Self-Evaluation Test
1 - T, 2 - T, 3 - T, 4 - F, 5 - T, 6 - Show / Erase, 7 - Value, 8 - Clean Dimensions, 9 - tol_display,
10 - DRAWING > Advanced > Draw Setup.

Exercise

Figure 11-31  The required drawing views with the solid model


