
Chapter 10

Generating, Editing,
and Modifying the

Drawing Views

After completing this chapter you will be able to:

• Create and retrieve the drawing sheet formats.
• Generate different drawing views of an existing part.
• Edit the existing drawing views and parameters associated with the views.
• Modify the existing drawing views.

Learning Objectives
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THE DRAWING MODE
In the previous chapters you have learned about creating the parts in the Part mode and
assembling different parts in the Assembly mode. One of the major advantages of working
with this software package is its bidirectional associative nature. This is the property that
ensures that if any modifications are made in the model in the Part mode, its drawing views
are updated automatically and if any modifications are made in the dimensions of the drawing
in the drawing views, the model gets updated automatically. In Pro/ENGINEER there are two
types of drafting methods: Interactive drafting and Generative drafting. In this chapter you
will learn about generating the drawing views of the parts or the assemblies that you have
created. In Pro/ENGINEER, the drawing views are generated in the Drawing mode. Choose
the Create a new object button from the File toolbar to display the New dialog box as shown
in Figure 10-1.

Select the Drawing radio button in the New dialog box. Specify the name of the drawing in
the Name edit box and then choose OK to display the New Drawing dialog box shown in
Figure 10-2.

New Drawing Dialog Box Options
Default Model Area
The Default Model area is used to specify the name of the model whose drawing views you
want to generate. You can specify the name of the model in the Name edit box or select the
model using the Open dialog box that is displayed when you choose the Browse button. If a

Figure 10-1  New dialog box
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mmodel exists in another window then the name of the model is displayed by default in the

Name edit box of the Default Model area.

Specify Template Area
The Specify Template area is used to specify that weather you want to use the default templates
available in Pro\ENGINEER, use predefined formats, or use an empty sheet. There are three
radio buttons in this area. The Use template radio button is selected by default. When you
select the Empty with format radio button, the dialog box changes as shown in Figure 10-3.
When you select the Empty radio button, the New Drawing dialog box is modified as shown
in Figure 10-4.

Orientation Area
The Orientation area is available only when you select the Empty radio button from the
Specify Template area. The buttons provided in this area are used to specify the orientation
of the sheet. You can select a standard size sheet with a portrait or a landscape orientation
using the Portrait or the Landscape button. You can also specify a sheet with the user-defined
size by choosing the Variable button. The size of the sheet and its units can be set using the
Size area.

Figure 10-2  New Drawing dialog box with the
Use template radio button selected

Figure 10-3  New Drawing dialog box with
the Empty with format radio button selected
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Size Area
The Size area is available only when you select the
Empty radio button from the Specify Template
area. The drop-down list in this area is used to
specify the sheet size.

Standard Size
This drop-down list is used to select drawing
sheet of a standard size. This drop-down list is
available only when you select the Portrait or
Landscape button from the Orientation area.

Inches/Millimeters
These radio buttons are selected to set the
standards for the user-defined sheets. You can
set the size of the sheet in inches or in
millimeters. These buttons are available only
when you select the Variable button from the
Orientation area.

Width/Height
These edit boxes are used to specify the width
and the height of the user-defined drawing
sheets. These edit boxes are available only when
you select the Variable button from the
Orientation area.

Format Area
The Format area is available only when you select the Empty with format radio button from
the Specify Template area.

Format
The Format drop-down list is used to select the available formats.

Browse
The Browse button is chosen to display the Open dialog box for retrieving the drawing
formats. By default, there are only five standard system formats that can be retrieved.
However, you can create your own user-defined formats that can be retrieved later.

Choose OK from the New Drawing dialog box to proceed to the Drawing mode. A drawing
sheet of the specified size and orientation will be placed on which you can now generate the
drawing views.

Figure 10-4  New Drawing dialog box with
the Empty radio button selected

Tip: If you had not specified any model in the Default Model area of the New
Drawing dialog box and choose OK. When you choose the Views option from the
DRAWING menu in the Menu Manager, the Open dialog box is displayed and you
can select the model from the Open dialog box.
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mGENERATING THE DRAWING VIEWS

To generate drawing views in Pro/ENGINEER, choose the Views
option from the DRAWING menu in the Menu Manager. The
VIEW TYPE submenu is displayed as shown in Figure 10-5. All
the views that can be generated by using the options from the
VIEW TYPE submenu are discussed next.

General View
The General view is generated with the help of two references
and is similar to orienting the model in the Part mode. This
view is also used as the parent view for generating the other
views. You can specify any desired scale factor for these views.
The General option in the VIEW TYPE submenu and some
other options are selected by default as shown in the Figure 10-5.
The other options are discussed later in the chapter. Accept the
default options and choose Done. You are prompted to specify
the center point for the drawing view. After specifying the center
point of the view on the graphics screen, the view is first placed
with the default orientation and then the Orientation dialog
box is displayed as shown in Figure 10-6. You can orient the
view using datum planes or the planar faces of the part or use a
view saved in the Part mode.

Figure 10-5  Selecting the
General option from the VIEW
TYPE submenu

Figure 10-6  Orientation dialog box to orient the General view
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Projection View
The projection views are the orthographic views generated by
projecting the normal lines from an existing general view. The
Projection option shown in Figure 10-7 is available only after you
have generated a general view. The scale factor of these views will
be the same as that of the parent view from which they are
generated. Depending upon the center point of the projection
view with respect to the parent view, the resultant view will be the
top, front, left, or the right view. If there exists more than one view
that can be the parent view of the projection view, then you will be
prompted to specify the parent view for the new view. These views
move along with the parent view if their parent view is moved from
its original location.

Auxiliary View
Auxiliary views are mainly used where you want to show the true
length of an inclined surface. The auxiliary views are created by
projecting normal lines from a specified edge, an axis, or a datum
plane in an existing view. The view scale will be the same as that of
the parent view. The Auxiliary view option is available in the VIEW
TYPE menu as shown in Figure 10-8.

Detailed View
Detailed views are used to provide the enlarged view of a
particular portion of an existing view. When you choose the Detailed
option from the VIEW TYPE menu as shown in Figure 10-9, you
will be prompted to specify the scale for the detailed view. You will
also be prompted to specify the center point and sketch a spline in
the parent view to define the outline of the detailed view. You are
also prompted to specify the name of the detailed view, the boundary
type, and a point to specify the location for the placement of note.

Figure 10-10 shows the different drawing views.

Revolved View
Figure 10-11 shows the Revolved option available in the VIEW TYPE menu. These are the
section views that are generated from an existing view by revolving the section through an
angle of 90 degree about the cutting plane and then projecting it along the length. Remember
that the cutting plane of the revolved section views is normal to the viewing plane.

Graph View
Figure 10-12 shows the Graph option that is available only when you have created a datum
graph in the Part mode of the current drawing. This view is used to display the datum graphs
in the drawing views.

Figure 10-8  Selecting the
Auxiliary option from the
VIEW TYPE submenu

Figure 10-9  Selecting the
Detailed option from the
VIEW TYPE submenu

Figure 10-7  Selecting the
Projection option from the
VIEW TYPE submenu
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You can also combine these standard view types with some more options to generate some
other views. You can use the following options and combine them with the standard view types
to control their visibility. The options are discussed next.

Full View
The Full View option can be combined with any of the view type to generate a drawing view
displaying the complete part.

Half View
The Half View option can be combined with the Projection, Auxiliary, or the General view
type to create a drawing view that displays only half the part. When you place this view, you are
prompted to select a reference plane that will be used to remove half of the drawing view.  The
reference plane can be a datum plane or a planar surface, and must be perpendicular to the
screen in the new view. This option is available only for Projection, Auxiliary, and General

Figure 10-10  The different drawing views

Figure 10-11  Selecting the Revolved
option from the VIEW TYPE submenu

Figure 10-12  Selecting the Graph
option from the VIEW TYPE submenu
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Figure 10-13  The different drawing views

views. This type of view is generated for symmetric parts.

Broken View
The Broken View option can be combined with the Projection or the General view type to
generate a view that is broken along the horizontal or the vertical direction using the horizontal
or vertical lines. This type of view is used for the parts have high length to width ratio. Remember
that if the view is projected vertically, the number of the vertical break lines should be zero in
the view and similarly, if the view is projected horizontally, the number of horizontal break
lines should be zero in the view.

Note
Remember that while creating the Broken view, you cannot zoom or pan even if the size of the
object requires it. Therefore, it is recommended to fit the drawing size on the graphics screen as
required before creating the Broken view.

Partial View
The Partial View option can be combined with the Projection, Auxiliary, Revolved, or General
view type to generate the view that displays a specified portion of the view. When you choose
to place this view, you are prompted to draw a spline that will be the boundary of the portion
of the view you want to display.

Figure 10-13 shows the different views.

SECTIONAL VIEWS
The sectional views are generally used for the views that are complicated from inside. As it is
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mnot possible to display the inside of the part using the conventional views, therefore, these

views are cut (sectioned) using a datum plane or a planar surface and the resultant section view
is displayed. Pro/ENGINEER allows you to generate the following types of section views by
choosing them from the XSEC TYPE menu.

Full Section View
Consider a part that is cut throughout its length, width, or height and the front cut portion
(front half) is removed from the display. The remaining half portion when projected is called
a full section view. When you choose to place a full section view, you are prompted to create a
new cross section or retrieve an existing cross section. This is the most widely used type of
section views. Figure 10-14 shows the full section view.

Half Section View
Consider a part that is cut half way through the length, width, or height and the front cut
portion (front quarter) is removed from the display. This part when projected is called the half
section view. In this view, only half of the part is sectioned and the other half of the part is
displayed as it is. You need to specify the half side of the view that has to be sectioned. Remember
that this option is available only when you select Full View from the VIEW TYPE submenu.
Figure 10-15 shows the half section view.

Local Section View
The Local Section view is used when you want to show a particular portion of the view in
section and at the same time not section the remaining view. The local section area is specified
by drawing a spline around it. Figure 10-16 shows the local section view.

Figure 10-14  Top view, Full section front view, and Full section
isometric view
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Note
As evident from Figure 10-14 and Figure 10-16, to create a sectioned isometric view you have
to define a section plane other than that used to generate the front section view.

Full & Local
The Full & Local view is the combination of the full and local section views. This option
allows you to generate a full and a local section view in the same view.

Advanced Sectioning Options
You can combine the above-mentioned section types with other advanced sectioning options

Figure 10-16  Top view, Local section front view, and Local
section isometric view

Figure 10-15  Top view, Half section front view, and Half section
isometric view
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next.

Total Xsec
The Total Xsec option when selected creates a section view that displays all the visible edges of
the section view in addition to the section area. This option can be combined with the full,
half, local, or the full and local Xsec types. Figure 10-17 shows the front and total sectioned
left view.

Area Xsec
This option when selected displays only that area of the section view that is sectioned. No
other edges of the view are displayed in the area cross section view shown in Figure 10-18. This
option can be combined with only the full Xsec type.

Align Xsec
These views are used to section those features that are created at a certain angle to the main
section planes. Align sections straighten these features by revolving them about an axis that is
parallel to the view plane. Remember that the axis about which the feature is straightened, should
lie on all the cutting planes. These views are similar to the area section views in which only the
portion that is sectioned is displayed. Figure 10-19 and Figure 10-20 show these views.

Total Align
These views are similar to the align section views with the only difference being that these
views display all the visible edges of the section view in addition to the section portion as
shown in Figure 10-21 and Figure 10-22.

Note
The Align Xsec and the Total Align options are available only when you choose the Full option
from the XSEC TYPE menu.

Unfold Xsec
The Unfold Xsec option is also used to generate the align section view but only for the General

Figure 10-17  The front view and the Total
cross section view

Figure 10-18  The front view and the Area cross
section view
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view type. Once you have placed the view and specified the cutting plane, you will be prompted
to specify the orientation of the section view.

Total Unfold
The Total Unfold option is also used to generate the total align section views but only for the
General view type.

CREATING THE SECTION PLANES
Once you have selected all the options for generating the section views and specified the
location of the section view, you need to specify the cutting plane for the section view. You can
either retrieve the cross section created in the Part mode or create the cross section in the
Drawing mode by specifying the cutting plane. Pro/ENGINEER allows you to create two types
of section planes. They are discussed next.

Planar
The Planar option is used to select an existing planar face or the datum plane as the cutting

Figure 10-21  The Total cross section view with
normal lines of projection

Figure 10-22  The Total align cross section view
with aligned lines of projection

Figure 10-19  The Area cross section view with
normal lines of projection

Figure 10-20  The Align cross section view with
aligned lines of projection
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Figure 10-23  The section views created using the offset section plane

plane. You can also make a datum plane that can be used as the cutting plane. However,
remember that you cannot draw a cutting plane using this option.

Offset
The Offset option is used to sketch an offset cutting plane using the sketcher options. When
you invoke this option, you are prompted to specify the name of the cross section. Once you
have specified the name of the cross section, another window appears displaying the part. You
can then follow the Part mode options to draw a line that will act as the cutting plane for
generating the section views. This option is generally used for creating the aligned section
views. Figure 10-23 shows the top view, offset sectioned front view, and the sectioned general
view of a part.

PERSPECTIVE VIEWS
Pro/ENGINEER provides you with an option of creating the perspective drawing views of the
parts or assemblies. The perspective views are generated using two parameters. They are the
eye distance for the view in the model space and the diameter of the view in the paper space.
The eye distance in the model space here refers to the distance of the viewer from the actual
model in the Part mode and the diameter of the view in paper space refers to the size of the
view in the Drawing mode. Figure 10-24 displays a general perspective view.

Tip: You can also create the cross sections in the Part mode and later retrieve those
sections in the Drawing mode and use them for generating the section views.
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The following points should be remembered while creating the perspective views:

1. You cannot use perspective views to generate projection or detailed views.

2. Perspective views do not have dimensions, datum planes, and axes.

3. Perspective views cannot have cross sections.

4. Only general views can be displayed in perspective.

EDITING THE DRAWING VIEWS
Pro/ENGINEER allows you to perform the following types of editing operations on the drawing
views.

Moving the Drawing View
DRAWING > Views > VIEWS > Move View
When you invoke the Move View option, all the drawing views on the sheet are displayed
inside a boundary and you are prompted to select the drawing view to be moved. Remember
that if you select the view that has some child views then the child views will also move along
with the parent view in order to maintain their alignment with the parent view. Also, the
projected views can be moved only in the direction of projection.

Note
The General and Detailed views can be moved to any new location because they are not the
projections of any view.

Figure 10-24  A general perspective view



Generating, Editing, and Modifying the Drawing Views      10-15

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
. 

F
. 

F
. 

F
. 

F
. 

F o
r 

e
n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r v
ic

e
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
mErasing the Drawing View

DRAWING > Views > VIEWS > Erase View
The Erase View option is used to temporarily remove the selected drawing view from the
sheet. However, the view still remains in the memory of the drawing and can be resumed at
any point of time. As the view is not completely removed from the memory, therefore, you can
also erase a view that has some child views associated to it and it will not effect the child view.
Once a view is erased, a box is displayed in place of the view displaying the name of the view.

Note
When you erase a view, the leaders and dimension values that were attached with the view are
also erased. When you select the erased view to resume, the leaders and dimension values are
redisplayed.

Resuming the Drawing Views
DRAWING > Views> VIEWS > Resume View
The Resume View option is used to redisplay the drawing views erased using the Erase option.
This option is available only when you have erased at least one drawing view.

Deleting the Drawing Views
DRAWING > Views > VIEWS > Delete View
The Delete View option is used to permanently remove a selected drawing view from the
sheet. Once the view is deleted, no information related to the deleted view remains in the
memory of the drawing. Remember that the view that has some child views associated with it
cannot be deleted unless all the child views are deleted first. When you select the drawing view
to be deleted, you are prompted to confirm the deletion process.

Adding New Parts or Assemblies to the Current Drawing
DRAWING > Views > VIEWS > Drawing Models > Add Model
You can also add more parts or assemblies in addition to the default part or assembly for
generating the drawing views. This is done using the Add Model option. When you invoke
this option, the Open dialog box is displayed. You can select the new model to be added using
this option. Remember that the latest model added will be the current model and the drawing
views that will be generated now will be of this model. You can change the current model by
choosing DRAWING > Views > VIEWS > Drawing Models > Set Model. Similarly, you can
also delete a model from the current drawing. However, only the model that does not have any
view generated from it can be deleted.

MODIFYING THE DRAWING VIEWS
You can also make the following modifications in the existing drawing views.

Changing the View Type
DRAWING > Views > VIEWS > Modify View > View Type
When you invoke the View Type option, you will be prompted to select the drawing view to be
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modified. However, this should be noted that only the general, projection, and auxiliary view
types can be modified using this option.

Changing the View Scale
DRAWING > Views > VIEWS > Modify View > Change Scale
The Change Scale option is used to change the scale factor of the selected view. You can only
modify the scale factor of the views in which the scale factor has been assigned during generation.

Note
The scale factor represents the drawing to model scaling. For example, if the scale set is 0.25,
Pro/ENGINEER scales the drawing views to one-quarter (1/4) of the actual size of the model.

Changing the View Name
DRAWING > Views > VIEWS > Modify View > View Name
The View Name option is used to change the name of the selected view. View name appears
inside a box when the view is erased using the Erase option. You can change this name by
using this option. When you invoke this option, you will be prompted to select the view whose
name has to be changed.

Reorienting the Views
DRAWING > Views > VIEWS > Modify View > Reorient
The Reorient option is used to reorient the general view. However, if some child view is
associated with the general view then the child view will also be reoriented accordingly. The
Orientation dialog box will be displayed when you select the general view to reorient. You can
use the options from this dialog box to change the orientation of the selected view.

Modifying the Cross Sections
DRAWING > Views > VIEWS > Modify View > X-Section
You can flip the side of sectioning, replace, delete, or rename the X sections in the views using
this option.

Modifying the Boundaries of Views
DRAWING > Views > VIEWS > Modify View > Boundary
The Boundary option is used to modify or resketch the boundary of the broken views, partial
views, or the detailed views.

Adding or Removing the Cross Section Arrows
DRAWING > Views > VIEWS > Modify View > Add Arrows/Del Arrows
The Add Arrows/Del Arrows options are used to add or delete the cross section arrows from
the views. In case the arrows are not displayed, then you will be prompted to select the section
views whose arrows are to be displayed and then the view where the arrows should be displayed.
In case the arrows are to be removed, you will be prompted to select the arrows to be deleted.
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DRAWING > Views > VIEWS > Modify View > Perspective
The Perspective option is used to modify the perspective views. You can modify the eyepoint
distance or the view diameter using this option.

MODIFYING OTHER PARAMETERS
Apart from modifying the drawing views, you can also modify other parameters related to the
drawing views. For example, you can modify the size and the style of the text, scale factor of all
the drawing views, cross section hatching, and so on. All this is done by selecting the item and
right-clicking on it. The shortcut menu is displayed. You can select the options from the
shortcut menu to modify that item.
You can modify any parameter associated with the drawing views. Also the selected drawing
view can be moved by selecting the view and then moving the mouse. Depending upon the
item selected to modify, the options related to it varies. The options in the shortcut menu that
are displayed varies from item to item. For example, if you select any text item associated with
the drawing views then you can move it from its original location, edit the text, edit text style,
and so on. If you select a drawing view and right-click then the modifications that are possible
are; changing the location of the view, changing the view scale, renaming the view, and reversing
the direction of the sectioning or replacing the cross sectioning (in case of section views).

Modifying the Values
The Value option is used to modify any numeric value associated with the drawing views.
The numeric value can be the view scale in case it is provided or changing the dimension
value. You can also change the scale of all the views in case it is not available by modifying the
scale value provided near the lower left corner of the screen. Choose the Value option from
the Edit menu in the menu bar to change the scale factor for all the views in the current sheet.

Editing the Cross Section Hatching
Select the hatching from a drawing view. When the hatching turns red in color, choose the
Properties option from the Edit menu in the menu bar. The MOD XHATCH submenu is
displayed. The parameters related to cross section hatching that can be modified are the
spacing of the hatching, angle of the hatching lines, offset value, and the line style of the
hatching lines. There are also some standard hatch patterns that are available in
Pro/ENGINEER. You can retrieve these standard patterns by using the Open dialog box
displayed upon choosing Retrieve from the MOD XHATCH submenu.

TUTORIALS

In this tutorial you will generate the drawing views of the model created in Exercise 4 of
Chapter 6 shown in Figure 10-25. Select the A4 size drawing sheet and generate all the drawing
views shown in Figure 10-26.    (Estimated time: 40 min)

Tutorial 1
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The following steps outline the procedure to generate the drawing views of the model:

a. Create a new drawing file and select the required drawing sheet.

b. Generate the top view.

Figure 10-26  The drawing views to be generated

Figure 10-25  Part for generating the drawing views
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mc. Generate the front view from the top view.

d. Generate the sectioned right view of the top view by defining a plane in the model.

e. Generate the default 3D view of the model.

f. Generate the detail view from the 3D view.

Before you start generating the drawing views, set the working directory to C:\ProE\c10. Copy
and paste the model c06exr4.prt file in the folder named c10 from c06 folder. The drawing
that you will generate will be saved in the c10 directory with an extension .drw. The .prt file
and the .drw file should lie in the same directory or folder.

Creating New Drawing File
1. Choose the Create a new object button from the File toolbar to display the New dialog

box.

2. Select the Drawing radio button and then enter the name of the file as c10tut1, see
Figure 10-27.

3. Choose OK from the New dialog box to display the New Drawing dialog box.

4. Choose the Browse button to select c06exr4.prt for generating the drawing views.

5. Select the Empty radio button from the Specify Template area.

6. Choose the Landscape button from the Orientation area if it is not chosen by default as
shown in Figure 10-28.

7. Select A4 from the Standard Size drop-down list. Choose OK to proceed to the Drawing
mode.

An A4 size sheet with landscape orientation is displayed on the graphics screen.

Generating the Top View
Generally, you can generate any view as the first view on the drawing sheet. However, in this
tutorial you will generate the top view as the front view.

1. Choose the Views option from the DRAWING menu in the Menu Manager to display the
VIEW TYPE submenu.

2. Choose Add View > General > Full View > No Xsec > Scale > Done. You will be

Tip: If you delete the part file from which the drawing views are generated then the
drawing file will not open. Also, if the part file is removed from the folder where its
drawing file lies, or if you rename the part file after generating the drawing views
then the drawing file will not open.
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prompted to specify the center point for the drawing view.

3. Specify the placement point for the first view close to the top left corner of the sheet as
shown in Figure 10-29. As soon as you specify the point, the Message Input Window is
displayed. Enter the scale factor for the view as 0.075 and press ENTER. The default view
is placed on the selected point

The Orientation dialog box is displayed.

Note
Although the views once placed can be moved on the sheet, yet while specifying the placement
point, try to place the drawing view inside the sheet and also leave space for the other views to be
created.

4. From the Saved Views drop-down list, select the TOP option and choose the Set button.
The default view is oriented as top view.

5. Choose the OK button from the Orientation dialog box.

Figure 10-28  New Drawing dialog box with
the Empty radio button selected

Figure 10-27  New dialog box
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m6. Turn off the display of datum planes, axes, points, and coordinate system by choosing

their respective buttons from the Datum Display toolbar. Also, change the model display
to no hidden by choosing the No Hidden button from the Model Display toolbar.

If in case the view that you have placed on the drawing sheet is not at the proper location
on the drawing sheet then you need to move the drawing view. Select the drawing view
using the left mouse button. The selected drawing view is enclosed in a red box. Select the
view again and move the mouse to place it at the desired location.

Generating the Front View
The front view of the model is generated from the top view that is already placed on the
drawing sheet.

1. Choose the Add View option from the VIEWS submenu in the Menu Manager to display
the VIEW TYPE submenu.

2. The Projection > Full View > No Xsec > No Scale is selected by default. Choose Done.

3. Specify the placement point for the front view below the top view as shown in Figure 10-29.

Generating the Section View
To create a section view, a section must be defined on the model. You will sketch this section to
generate the section view for this tutorial.

1. Choose the Add View option from the VIEWS submenu to display the VIEW TYPE
submenu.

2. Choose Projection > Full View > Section > No Scale > Done to display the XSEC
TYPE submenu.

Figure 10-29  The top and front view
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3. Choose Full > Total Align > Done from the XSEC TYPE submenu.

4. Specify the placement point on the right side of the top view.

5. Choose the Create option from the XSEC ENTER submenu to display the XSEC CREATE
submenu.

6. Choose Offset > Both Sides > Single > Done.

7. Enter the name of the cross section as X in the Message Input Window and press ENTER.
Once you have specified the name of the cross section, a separate window will appear
displaying the part. You are prompted to select a sketching plane.

8. Choose the Datum planes on/off button from the Datum Display toolbar in the original
window to display the datum planes. You need to repaint the screen in the subwindow by
choosing View > Repaint from the menu bar to view the datum planes.

9. Select the TOP datum plane from the subwindow. Choose Okay from the DIRECTION
submenu. The SKET VIEW submenu is displayed.

10. Select the Bottom option from the SKET VIEW submenu and choose the FRONT datum
plane from the subwindow. The References dialog box is displayed. Choose the Close
button to exit the References dialog box.

11. Choose the Create lines. button from the Right Toolchest and draw the lines as shown in
Figure 10-30. These lines create a section plane.

Figure 10-30  Sketch for the Total Align section

Tip: It is recommended to use the Redraw the current view button available in the
View toolbar to remove any temporary information on the graphics screen and to
refresh the screen.
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m12. Align the lines and modify the angular dimension to 120 as shown in Figure 10-30. To

modify the dimension value, press the middle mouse button in the subwindow and then
double-click on the dimension value.

13. Choose Sketch > Done from the menu bar of the subwindow. You are prompted to select
the central axis on the new view about which the section will be aligned. You can turn off
the display of datum planes.

14. Select the central axis on the new view that you have created. Now, you are prompted to
select a view where the section arrows will be placed.

15. Select the top view to display the arrows. You will be prompted to choose a viewing direction.
Choose Okay. The section view is created.

16. Choose Done/Return from the VIEWS menu.

You will notice that the spacing between the hatch lines is large. Therefore, you need to
modify the scale of hatching.

Modifying the Hatching
1. Select the hatching from the drawing sheet. The hatching lines turn red in color.

Press and hold the right mouse button to invoke the shortcut menu. Choose the Properties
option from the shortcut menu.

The MOD XHATCH submenu is displayed.

2. From the MOD XHATCH submenu, choose the Spacing option to display the MODIFY
MODE submenu.

3. The spacing between the hatching lines has to be reduced. Choose the Half option twice
and then choose Done in the MOD XHATCH submenu. Now, the hatching appears to be
more dense as shown in Figure 10-31.

Generating the General View
The General view is created to show a three-dimensional view of the model.

1. Choose Views from the DRAWING menu in the Menu Manager.

2. Choose Add View > General > Full View > No Xsec > Scale > Done from the VIEW
TYPE submenu.

3. Specify the placement point for the general view below the section view as shown in
Figure 10-31.

Tip: If you do not want to display the section arrows in any view, you can use the
middle mouse button (in case of three button mouse) to abort the creation of arrows. If
you have two button mouse, use SHIFT+left mouse button.
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4. Enter the scale for the new view in the Message Input Window as 0.05 and press ENTER.

5. Choose Quit Sel in the GET SELECT menu and then choose OK from the Orientation
dialog box.

Generating the Detail View
As mentioned earlier, the detail view is required to provide details of a particular portion of
the drawing view. In this tutorial you need to give the details of one of the ribs of the model.

1. Choose Add View from the VIEWS submenu in the Menu Manager to display the VIEW
TYPE submenu.

2. Choose Detailed > Full View > No Xsec > Scale > Done.

3. You will be prompted to specify the placement point for the new view. Select a point
between the top view and the sectioned side view using the left mouse button.

4. Enter the value of the view scale as 0.075 in the Message Input Window and press ENTER.

Now, you will be prompted to select a center point. This center point will be the center of
the detailed view. Around this center point you will specify the boundary of the detail view.

5. Select the center point for the detail on one of the ribs in the trimetric view, refer
Figure 10-32.

Figure 10-31  Different drawing views
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m6. Sketch a spline about the center point that you had previously selected. After the spline is

drawn, press the middle mouse button to quit the spline creation.

7. The Message Input Window is displayed. Enter the name of the detail view as A in this
window and press ENTER.

8. Choose Spline from the BOUNDARY TYPE submenu that appears.

Now, you will be prompted to select an attachment point on the spline where the note will
be attached and displayed.

9. Select a point on the sketched spline as the attachment point. You are prompted to select
a location for note.

10. Select the location of the note somewhere near the spline. You may need to move the note
by selecting it and then dynamically moving it. The final sheet after generating all the
views should look similar to the one shown in Figure 10-32.

11. Choose Done/Return from the VIEWS submenu.

Tip: If any of the views or the text on the drawing is overlapping or is not at the
desired place on the sheet, select the view using the left mouse button and move it by
moving the mouse.

Figure 10-32  The drawing views for Tutorial 1
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Saving the Drawing File
You need to save the drawing file that you have created as you may need it later.

1. Choose the Save the active object button from the Top Toolchest. The Message Input
Window is displayed with the name of the drawing file that you had entered earlier.

2. Press ENTER to confirm the saving of the file.

Closing the Drawing File
After you have saved the drawing file that you have created, you need to close the drawing file
and exit the Drawing mode.

1. Choose the Close option from the Window menu in the menu bar. The drawing window
is closed and you have exited the Drawing mode.

In this tutorial you will generate the drawing views of the part created in Tutorial 1 of Chapter 7
shown in Figure 10-33. The drawing views that need to be generated are shown in Figure 10-34.

  (Estimated time: 40 min)

Before you start generating the drawing views, copy the file c07tut1.prt from c07 folder in the
current directory.

The following steps outline the procedure to generate the drawing views of the model:

a. Create a new drawing file and select the size of the drawing sheet.

Tutorial 2

Figure 10-33  Model for generating the drawing views
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b. Generate the top view.

c. Generate the sectioned front view by defining the FRONT datum plane as the section
plane.

d. Generate the right-side view of the sectioned front view by using the No Xsec option.

e. Generate the isometric sectioned view. The section will be defined by drawing a line on
the TOP datum plane.

Before starting to generate the drawing views, set the working directory to C:\ProE\c10. The
.prt file and the .drw file should lie in the same directory or folder.

Creating New Drawing File
Create a new drawing file for generating the drawing views.

1. Choose the Create a new object button from the File toolbar to display the New dialog
box.

2. Select the Drawing radio button and then enter the name of the file as c10tut2.

3. Choose OK from the New dialog box to display the New Drawing dialog box.

4. Choose the Browse button to select c07tut1.prt from c10 for generating the drawing
views.

Figure 10-34  The different drawing views to be generated
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5. Select the Empty radio button from the Specify Template area.

6. Choose the Landscape button from the Orientation area.

7. Select A4 from the Standard Size drop-down list. Choose OK from the New Drawing
dialog box to proceed to the Drawing mode.

Generating the Top View
First the top view will be generated and all the other views except the sectioned isometric view
will be the child views of the top view. You need to generate the top view first because the
required section front view can only be generated from the top view. The right-side view can
be generated independently but then this view will not help to generate any other required
view.

1. Choose Views from the DRAWING menu in the Menu Manager to display the VIEW
TYPE submenu.

2. Choose General > Full View > No Xsec > Scale > Done.

3. Specify the placement point for the first view as shown in Figure 10-35. As soon as you
specify the point, the Message Input Window is displayed. Enter the scale factor for the
view as 0.065 and press ENTER. The default view is placed and the Orientation dialog
box is displayed.

4. Choose the TOP option from the Saved Views drop-down list in the Orientation dialog
box.

5. Choose the Set button. The default view is oriented as top view.

6. Choose OK to exit the Orientation dialog box.

If it is necessary move the view as shown in Figure 10-35 and choose No Hidden from the
Model Display toolbar.

Generating the Sectioned Front View
The sectioned front view of the model is generated from the top view. Before proceeding
further, use the Datum planes on/off button from the Datum Display toolbar to turn on the
display of datum planes and repaint the screen.

1. Choose Add View from the VIEWS submenu in the Menu Manager to display the VIEW
TYPE submenu.

2. Choose Projection > Full View > Section > No Scale > Done to display the XSEC
TYPE submenu.

3. Choose Full > Total Xsec > Done in the XSEC TYPE submenu.
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m4. Specify the placement point for the front view below the top view as shown in Figure 10-35.

5. When you place the view, the XSEC ENTER submenu will be displayed. Choose Create to
display the XSEC CREATE submenu.

6. Choose Planar > Single > Done.

7. Enter the name of the cross section in the Message Input Window as A1 and press ENTER
to display the SETUP PLANE submenu. You are prompted to select a planar surface or a
datum plane.

8. Select the FRONT datum plane (the plane that cuts the part horizontally from the center
of the cylindrical feature in the top view) from the graphics screen. You are prompted to
select a view where you want the arrows to be displayed.

9. Select the top view to display the arrows.

10. Choose Done/Return from the VIEWS submenu.

11. Turn the datum display off and repaint the screen.

Modifying the Hatching
The offset distance between the hatching lines in the front sectioned view is large. You need to
reduce the distance between the hatching lines.

1. Select the hatching from the sectioned front view in the drawing sheet. The hatching lines
turn red in color. Hold down the right mouse button to invoke the shortcut menu. Choose
the Properties option from the shortcut menu.

The MOD XHATCH submenu is displayed.

2. From the MOD XHATCH submenu, choose the Spacing option to display the MODIFY
MODE submenu.

3. The spacing between the hatching lines has to be reduced. Choose the Half option twice
and then choose Done in the MOD XHATCH submenu. Now, the hatching appears to be
more dense.

4. Choose Done from the MODIFY XHATCH submenu and once click on the graphics
screen to unselect the X-hatch.

The sheet after placing these two views should look similar to the one shown in Figure 10-35.

Generating the Right-Side View
The right-side view is the projection of the front sectioned view. However, you will use the No
Xsec option to create a view that is not sectioned. Turn off the display of datum planes.
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Figure 10-35  Drawing sheet after generating the top view and the sectioned front view with
the display of datum planes

1. Choose Views from the DRAWING menu to display the VIEW TYPE submenu.

2. Choose Projection > Full View > No Xsec > No Scale > Done. You are prompted to
specify the placement point for the drawing view.

3. Specify the placement point for the view on the right side of the sectioned front view. The
right-side view of the model is placed as shown in Figure 10-36.

Generating the Isometric Section View
The isometric section view is an independent view and will be generated by using the General
option.

1. Choose the Add View option from the VIEWS submenu in the Menu Manager. The
VIEW TYPE submenu is displayed.

2. Choose General > Full View > Section > Scale > Done from the VIEW TYPE submenu.
The XSEC TYPE submenu is displayed.

3. Choose Full > Total Xsec > Done from the XSEC TYPE submenu.

4. Specify a point to the right of the top view and the Message Input Window is displayed
and you are prompted to specify the scale for the drawing. Enter 0.06 in this window and
press ENTER. The default trimetric view of the model is placed and the Orientation
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dialog box is displayed.

The default view is a trimetric view but you need the isometric view to be displayed.
Therefore, you need to change the preferences of the view.

5. Choose the Preferences option from the Type drop-down list.

6. Choose the Isometric option from the Default Orientation drop-down list. The isometric
view of the model is displayed on the drawing sheet.

7. Choose OK in the Orientation dialog box to exit it. The XSEC ENTER submenu is
displayed.

8. Choose the Create option from the XSEC ENTER submenu to display the XSEC CREATE
submenu.

9. Choose Offset > Both Sides > Single > Done from the XSEC CREATE menu.

10. Enter the name of the section as Z in the Message Input Window that appears and press
ENTER. Once you have specified the name of the section, a separate window will appear
displaying the model.

Figure 10-36  Drawing sheet after generating the top view, the sectioned front view, and the
right-side view
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Note
If the model in the Part mode is opened in another window, then the subwindow will not appear
and you have to manually change the window. Choose the Window menu, and select the part
file that is opened. Now you can continue with the sketcher environment.

11. Select the TOP datum plane from the subwindow. Choose Okay from the DIRECTION
submenu. The SKET VIEW submenu is displayed.

12. Select the Right option from the SKET VIEW submenu and choose the RIGHT datum
plane from the subwindow. The References dialog box is displayed. Choose the Close
button to exit the References dialog box.

13. Choose the Create lines. button from the
Right Toolchest and draw the line as
shown in Figure 10-37. This line create
a section plane.

14. Choose the Constrain option from the
Sketch  menu. The Constraints dialog
box is displayed.

15. Choose the Create same points, points
on entity or collinear constraint button
from the Constraints dialog box. Align
both the ends of the line to the edges.

16. Choose Sketch > Done from the Sketch
menu in the menu bar. Now, you are
prompted to select a view where the section arrows will be placed.

17. Press the middle mouse button. The section view is generated but the direction arrows are
not displayed.

18. Choose Done/Return from the VIEWS submenu.

Note
If the drawing view is placed on the sheet such that it overlaps the boundary of the drawing sheet
then you can move the drawing view. You can move the drawing view by double-clicking on it
and then moving the mouse. As you move the mouse the drawing also moves.

Modifying the Hatching
The spacing between the hatching lines in the sectioned isometric view is large. Therefore,
you need to reduce the distance between the hatching lines.

1. Select the hatching from the drawing sheet. The hatching lines turn red in color.
Hold down the right mouse button to invoke the shortcut menu. Choose the Properties
option from the shortcut menu.

Figure 10-37  Sketch for the section line with
constraint
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2. From the MOD XHATCH submenu, choose the Spacing option to display the MODIFY
MODE submenu.

3. The spacing between the hatching lines has to be reduced. Choose the Half option twice
and then choose Done in the MOD XHATCH submenu. Now, the hatching appears to be
more dense.

4. Choose Done from the MODIFY XHATCH submenu.

The sheet after placing all the views should look similar to the one shown in Figure 10-38.

Saving the Drawing File
You need to save the drawing file that you have created as you may need it later.

1. Choose the Save the active object button from the Top Toolchest. The Message Input
Window is displayed with the name of the drawing file that you had entered earlier.

2. Press ENTER to confirm the saving of the file.

Closing the Drawing File
After you have saved the drawing file that you have created, you need to close the drawing file
and exit the Drawing mode.

Figure 10-38  The different drawing views to be generated
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1. Choose the Close option from the Window menu in the menu bar. The drawing window
is closed and you have exited the Drawing mode.

Answer the following questions and then compare your answers to the answers given at the
end of this chapter.

1. The bidirectional associative nature of a software package means that when one file related
to the part model is modified the corresponding modification can be seen in other related
files. (T/F)

2. General view is the first view that is generated in the sheet. (T/F)

3. The Full Section view is the most widely used type of view. (T/F)

4. The sectional views are generally created for the models that have features that are not
clearly visible from standard view. (T/F)

5. Broken views are used for parts that have high length to width ratio. (T/F)

6. The __________ view is used when you want to show a particular portion of the view in
section and at the same time not section the remaining view.

7. The __________ option allows you to temporarily remove the selected drawing view from
the sheet.

8. The __________ option is used to redisplay the drawing views that are erased using the
Erase View option.

9. The __________ option is used to reorient the general view.

10. The cross section hatching on the sectioned portion can be modified using the __________
submenu.

Answer the following questions:

1. Which of the following options when selected displays all the erased drawing views on the
sheet?

(a) Delete View (b) Resume View
(c) Move View (d) Erase View

Review Questions

Self-Evaluation Test
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m2. Which of the following buttons on the View toolbar is used to refresh the screen?

(a) Zoom Out (b) Zoom In
(c) Redraw the current view (d) None

3. Which of the following options when selected displays only that area of the section view
that is sectioned?

(a) Total Xsec (b) Area Xsec
(c) Align Xsec (d) Total Align

4. Which of the following options is used to permanently remove a drawing view from the
sheet?

(a) Resume View (b) Erase View
(c) Delete View (d) Move View

5. Which of the following options is used to modify any numeric value associated with the
drawing views?

(a) Xhatching (b) Any Item
(c) Value (d) None

6. The view type of an existing view can be changed. (T/F)

7. You can reorient only the general views. (T/F)

8. You can flip the side of the cross section views. (T/F)

9. The Orientation area in the New Drawing dialog box is available only when you select
the Empty radio button from the Specify Template area. (T/F)

10. The orientation of a model saved in the Part mode can be used to orient the drawing view
in the Drawing mode. (T/F)

Generate the drawing views of the model created in Tutorial 3 of Chapter 8 shown in
Figure 10-39. Generate the drawing views that are shown in Figure 10-40 on an A4 size sheet.

   (Estimated time: 40 min)

Exercise

Exercise 1
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Figure 10-40  Drawing views to be generated in Exercise 1

Figure 10-39  Part for generating the drawing views

Answers to the Self-Evaluation Test
1 - T, 2 - T, 3 - T, 4 - T, 5 - T, 6 - Local Section, 7 - Erase View, 8 - Resume View, 9 - Reorient,
10 - MOD XHATCH.


