Chapter 1

Creating Sketches in
the Sketch Mode

Learning Objectives

After completing this chapter you will be able to:

* Use different SKETCHER options for creating a geometry.

* Dimension a sketch using the Normal option.

* Use the Mirror option in a sketch.

* Use the Intent Manager in a sketch.

* Modify a sketch.

* Use Modify Dimensions dialog box when you are using Intent Manager.
* Regenerate a sketch.

* Use drawing display options.
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THE SKETCH MODE

Almost all the models designed in Pro/ENGINEER consists of datums, sketched features and
placed features. Generally, for creating datums and placed features, you do not require sketches.
However, to create a sketched feature, it is necessary to draw a two-dimensional (2D) sketch.
When you enter the Part mode and select the options to create any sketched feature, the
system automatically takes you to the sketcher environment. In the sketcher environment, the
sketch of the feature is created and regenerated, and then you return to the Part mode to
create the required feature. The sketches created in the Sketch mode are stored in .sec format.
You will learn about the datums and placed features in later chapters.

The Sketch mode is used when the design of a product is at its development stage. The designer
can sketch the 2D sketch of the product and assign required dimensions to it. By assigning the
dimensions, the designer can make sure that the 2D sketch of the product or model is satisfying
all the necessary conditions and then continue for the 3D model of the design, that is, the Part
mode.

Using the Sketch Mode

To create any section in the Sketch mode of Pro/ENGINEER, certain basic steps have to be
followed. The following steps outline the procedure to use the Sketch mode:

1. Sketch the required section geometry
The different sketcher tools available in this mode can be used to sketch the required section
geometry.

2. Add the constraints and dimension the sketched section

After sketching the section geometry, the constraints and dimensions are added to the section.
For dimensioning the section there are two options. Either the AutoDim option or the
DIMENSION submenu options available in the Menu Manager can be used. If the Intent
Manager is used for sketching then the sketch will be automatically dimensioned and
constrained. After adding the dimensions you can modify them as required.

3. Add relations to the sketch

The geometry of various entities of the sketch can be controlled by adding relations.

4. Regenerate the section

After dimensioning the sketch, the sketch must be regenerated. Remember that the section is
regenerated only if the minimum constraints of the sketch are satisfied. Pro/ENGINEER has
the capability to analyze the section and if the section is not complete for any reason, the
section will not be regenerated. However, Pro/ENGINEER makes certain assumptions to
regenerate the section.

If the Intent Manager is on while sketching then the sketch is automatically regenerated.

Entering the Sketch Mode

To enter the Sketch mode select New from the File menu or choose the Create a new object
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button from the File toolbar. The New dialog box will be displayed with different
Pro/ENGINEER modes available. When you choose the Sketch radio button a default name of
sketch file appears in the Name edit box. You can change the sketch name as required. Choose
the OK button to enter the Sketch mode.

THE SKETCHER ENVIRONMENT

When you enter the Sketch mode, the initial screen appearance will be similar to the one
shown in Figure 1-1. This figure also shows the Sketcher Tools toolbar. The buttons available
in this toolbar are used to draw a sketch. When you enter the sketcher environment, by default
the Intent Manager is on. It is recommended to use the Intent Manager only if you are an
experienced user of this software. However, if you are a beginner, you should avoid using the
Intent Manager. In later chapters of this book, you will learn to create sketches using the
Intent Manager. You can turn off the Intent Manager by clearing the check mark on the left of
the Intent Manager option that is available in the Sketch menu in the menu bar.
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Figure 1-1 Initial screen appearance afler entering the Sketch mode
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CREATING A SKETCH IN THE SKETCH MODE

If the Intent Manager is off, by default the Sketch option is
selected in the SKETCHER menu and the Mouse
Sketch option is selected in the GEOMETRY submenu. You

can start sketching either using the Intent Manager or without Line
using it. When you are drawing a sketch using the Intent
Rectangle

Manager, the Sketcher Tools toolbar is used. When you are e
not using the Intent Manager to draw a sketch, the
Menu Manager is available with different sketcher options.
The options available under the GEOMETRY submenu are
shown in Figure 1-2. The section geometry can be sketched Figure 1-2 GEOMETRY
using these options and their functions are discussed next. submen, options to draw a sketch

with Intent Manager off

Circle
Ady Geometmy

7>\ Note
\
\' The sketch is saved as .sec file extension. While drawing in the Part mode if you save a drawing
before regenerating it, the part is saved in the .sec file extension.

In later chapters of this book you will create sketches using the Intent Manager. But, you should
learn to draw sketches without using the Intent Manager. This is because the basics of creating
sketches in Pro/ENGINEER are understood only when you draw sketches without using the
Intent Manager.

Drawing a Sketch Using the Mouse Sketch

Using the Mouse Sketch option you can create a desired section. You can draw lines, arcs that
start at the endpoint of any existing geometry, and circles by using the three button mouse.
The Mouse Sketch allows you to continuously draw a sketch without selecting the options
from the GEOMETRY submenu in the Menu Manager. For example, you can draw a line, a
circle, and an arc without selecting these options from the GEOMETRY submenu. The
equivalent of the Mouse Sketch option is not available when the Intent Manager is on. The
different entities that can be drawn using the Mouse Sketch option are discussed next.

Drawing a Line Using the Mouse Sketch
The following steps explain the procedure to sketch a line using the Mouse Sketch option:

1. Using the left mouse button, specify a point on the graphics screen from where you want
the line to start. A red rubber-band line appears, one end of which is fixed at the point you
specified and the other is attached to the cursor. Now, move the cursor on the screen to a
desired point where you want the line to end.

2. Using the left mouse button specify the endpoint of the line. The line ends at this point.
Note that line creation does not end at this point. The next rubber-band line will be
attached to the cursor. The endpoint of the last line will be the start point of this new line.
This process will continue until you terminate line creation.

3. Press the middle mouse button to end line creation. The lines drawn appear in cyan color
and the red rubber-band line disappears.
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"\ Note
\

\ 1o draw a sketch, options are chosen from Menu Manager when the Intent Manager is off
and buttons are chosen from toolbar when the Intent Manager is on.

It is recommended to use a three button mouse while working in Pro/ENGINEER. It becomes
almost impossible to work with a two button mouse.

Drawing a Circle Using the Mouse Sketch
The following steps explain the procedure to sketch a circle using the Mouse Sketch option:

1. Specify the center of the circle you want to draw by pressing the middle mouse button on
the graphics screen. A red rubber-band circle appears having its center at the specified
point. The rubber-band circle is attached to the cursor.

2. You can now move the cursor away from the center point to give the circle a required size.

3. Once you get the appropriate size of the circle, press the middle mouse button. The circle
appears in cyan color. However, if you want to abort the circle, you can do so by pressing
the left mouse button.

Drawing an Arc Using the Mouse Sketch

When you draw an arc using the Mouse Sketch option, the arcis created tangent to the endpoint
of an entity by default. The following steps explain the procedure to sketch an arc using the
Mouse Sketch option:

1. Using the right mouse button, select the endpoint of an entity from where you want to
start the arc. A red rubber-band arc appears with one end attached to the cursor and the
other end tangent to the entity.

2. Now, move the cursor on the graphics screen to size the arc.

3. When you get the required size of the arc, use the right mouse button to complete the arc.
A cyan colored arc is sketched. However, if you want to abort the arc, you can do so by
pressing the middle mouse button.

Note
X_/\ The color of the entities displayed depends on the system settings of the colors you set. The colors
referred to above are the default system colors.

Drawing a Point

The following steps explain the procedure to sketch a point:

1. Choose Sketch from the SKETCHER menu and Point from the GEOMETRY submenu
in the Menu Manager.
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» If the Intent Manager is on, choose the Create points. button available in the Right
Toolchest. When you invoke this option, the system prompts you to select a location
for the point on the graphics screen.

2. As soon as you select a point using the left mouse button, the point is placed on the
graphics screen at the desired location.

Drawing a Line

To create lines, choose Sketch from the SKETCHER menu and
Line from the GEOMETRY submenu in the Menu Manager.
The LINE TYPE submenu appears with different line options Centerling

for drawing a line. Figure 1-3 shows the various options available o a—

Geamety

2 Paoints
in the LINE TYPE submenu.
Parallel
. . Perpendicular
\ If the Intent Manager is on, choose the Create lines. Tangent
button available in the Right Toolchest.
2 Tarngent
. . . . Prit/T angent
You can create two types of lines using the Line option. They Hnriznntjl
are Geometry and Centerline. The Geometry option is used to .
. . . . Vertical
create section sketches. The Centerline option is used for

creating center lines for revolved features, mirroring, and so on. Figure 1-3 Different options
i the LINE TYPE submenu

"\ Note
L When the Intent Manager is on, constraints ave applied automatically to the entities you draw.
Hence, the parallel, tangent, and other options for drawing lines are not required when the
Intent Manager is on. This is the reason, these options are not available to draw lines when the
Intent Manager is on.

If the Intent Manager is on and you press and hold down the right mouse button on the
graphics screen, a shortcut menuw is displayed as shown in Figure 1-4. This menu provides all

the basic sketcher options that can be used to draw a sketch.

Move

Line

Fectangle

Circle

3-Point # Tangent End
Centerline

Fillet

Dimenzion

Undo

Figure 1-4 Shortcut menu that can be invoked
when the Intent Manager is on

The procedures to create lines using the different LINE TYPE submenu options are
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discussed next.

Drawing a Line Using the 2 Points Option
The following steps explain the procedure to create a line using the 2 Points option:

1. Choose SKETCHER > Sketch > Line > Geometry > 2 Points from the Menu
Manager. Select a point on graphics screen to start the line using the left mouse button. A
red rubber-band line appears from the selected point with the other end attached to the
CUTSOT.

2. The system then prompts you to specify the endpoint. Move the cursor on the graphics
screen to give the desired length to the line. Use the left mouse button to specify the
endpoint of the line. The line appears in cyan color. However, the rubber-band line
continues with the second line.

3. Repeatstep 2 until all the lines are drawn. End line creation by pressing the middle mouse
button. If you want to abort line creation, you can press the middle mouse button.

Drawing a Line Using the Parallel Option
You can use the Parallel option to create parallel lines. There must be a line drawn on the
graphics screen to set the direction for creating the parallel line. The following steps explain
the procedure to draw lines using the Parallel option:

1. Choose SKETCHER > Sketch > Line > Geometry > Parallel from the Menu Manager.
You will be prompted to select a line to set the direction for the parallel line.

2. Using the left mouse button, select the line that will act as the reference line to set the
direction for the parallel lines to be created. The color of the selected line changes from
cyan to red.

3. Youwill be prompted to select the start point of the line. Specify the start point of the line
using the left mouse button. A red rubber-band line appears that dynamically changes its
length as you move the mouse. Move the mouse to size the line. Use the left mouse button
to specify the endpoint of the line at the desired point. After creating the required number
of parallel lines, press the middle mouse button to end line creation. The color of the line
selected to set the direction changes from red to cyan.

Drawing a Line Using the Perpendicular Option

You can use this option for drawing perpendicular lines. There must be a line drawn on the
graphics screen to set the direction for the perpendicular line. The following steps explain
the procedure to draw lines using the Perpendicular option:

1. Choose SKETCHER > Sketch > Line > Geometry > Perpendicular from the Menu
Manager. You will be prompted to select a line to which the new line will be perpendicular.

2. Using the left mouse button, select the line that you want to act as reference for the
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perpendicular line. The color of this line changes from cyan to red.

3. You will be prompted to select the start point. A red rubber-band line appears as soon as
you select the start point using the left mouse button. The size of this line changes
dynamically as you move the mouse. Move the mouse to size the line. Use the left mouse
button to specify the endpoint of the line at the desired point. After drawing the required
number of perpendicular lines, press the middle mouse button. The color of the line
selected to set the direction changes from red to cyan.

Drawing a Line Using the Tangent Option
You can use this option to draw a line tangent to an arc, a spline, or a conic. The following
steps explain the procedure to draw lines using the Tangent option:

1. Choose SKETCHER > Sketch > Line > Geometry > Tangent from the Menu Manager.
You will be prompted to select the endpoint of an entity.

2. Select the endpoint of an arc, conic, or a spline using the left mouse button. A red
rubber-band line appears with a cursor. Move the cursor on the graphics screen to size the
line. Press the left mouse button to specify the endpoint of the line. The red rubber-band
line changes its color to cyan. The line is tangent to the entity selected.

Drawing a Line Using the 2 Tangent Option

The 2 Tangent option is used to draw a tangent between two entities such as arcs, circles,
splines, or a combination of these entities. The following steps explain the procedure to draw
a tangent using the 2 Tangent option:

1. Choose SKETCHER > Sketch > Line > Geometry > 2 Tangent from the Menu Manager.
You will be prompted to select two different arcs, circles, or splines.

2. Select the first entity from where the tangent line will be drawn. The color of the entity
changes to red. You will be prompted to select the second entity. As soon as you select the
second entity, a line is drawn which is tangent to both the selected entities.

"\ Note
1t is not always possible to draw a tangent between two selected entities. If a tangent line is not
possible, you are prompted to select set of entities to draw tangent lines.

Drawing a Line Using the Pnt/Tangent Option

You can use this option to draw a line tangent to any entity keeping one end of the tangent
fixed. The following steps explain the procedure to draw a tangent using the Pnt/Tangent
option:

1. Choose SKETCHER > Sketch > Line > Geometry > Pnt Tangent from the
Menu Manager. You will be prompted to select a starting point.

2. Select the starting point of the line at the desired location on the graphics screen. This
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point is fixed as one end of the line. You will be prompted to select an entity other than a
line. As soon as you select the entity, a line will be drawn that is tangent to the entity
selected.

Drawing a Line Using the Horizontal Option

The Horizontal option is used to create a horizontal line. Once you have finished drawing the
horizontal line, the Vertical option is selected and you can continue to draw a vertical line.
The following steps explain the procedure to draw horizontal lines using this option:

1. Select SKETCHER > Sketch > Line > Geometry > Horizontal from the Menu Manager.
You will be prompted to select a start point.

2. Select the start point of the line. When you select the start point using the left mouse
button, a red rubber-band line appears that changes its length dynamically as you move
the cursor. Move the cursor on the graphics screen to size the line. Specify the endpoint of
the line using the left mouse button. The red color of the line changes to cyan and a
horizontal line is drawn. You will notice that a red rubber-band line starts again from the
end of the last line in the direction normal to the previous line and in the LINETYPE
submenu, the Vertical option is selected.

3. Continue step 2 until all the lines are drawn. Press the middle mouse button to end line
creation. It must be noted that if you continue to draw lines using the Horizontal option
then all the lines drawn will be perpendicular to each other. The selection in the LINETYPE
submenu toggles between the Horizontal and Vertical options as you draw the lines.

Drawing a Line Using the Vertical Option

The Vertical option is used to create a vertical line. After the vertical line is drawn you can
continue to draw a horizontal line. The following steps explain the procedure to draw vertical
lines using this option:

1. Select SKETCHER > Sketch > Line > Geometry > Vertical from the Menu Manager.
You will be prompted to select a start point. Specify the start point of the line.

2. Ared rubber-band line appears that changes the size as you move the cursor. Size the line
by moving the cursor on the graphics screen. Use the left mouse button to specify the
endpoint of the line at the desired location. The red color of the line changes to cyan and
a vertical line is drawn. You will notice that the Horizontal option is selected in the
LINETYPE submenu and a red rubber-band line starts again from the endpoint of the
last line in the perpendicular direction. You can use this line to create a horizontal line.

3. Continue step 2 until all the lines are drawn. Press the middle mouse button to end line
creation. It must be noted that if you continue to draw lines using the Vertical option then
all the lines drawn will be perpendicular to each other. The selection in the LINETYPE
submenu toggles between the Horizontal and Vertical options as the lines are drawn.

The second option in the LINE TYPE submenu is Centerline. You can use the Centerline
option in a similar way to draw lines as the Geometry option discussed earlier. As the name
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implies, the lines drawn using this option are the center lines, the only difference is that you
cannot create center lines continuously. This is because you do not require to draw center lines
continuously.

T

e Tip: If you want to create only horizontal lines then create one horizontal line using

// r the Horizontal option and press middle mouse button. Now, you are prompted to
: ?’ specify the start point for creating a horizontal line. Select the start point and then
select the endpoint. Again press middle mouse button to create another horizontal line
without creating a vertical line. Follow the same procedure to create only vertical
lines.

Drawing a Rectangle

The following steps explain the procedure to sketch a rectangle using the Rectangle option:

If the Intent Manager is on, choose the Create rectangle. button available in the
Right Toolchest to create a rectangle.

1. Choose SKETCHER > Sketch > Rectangle from the Menu Manager. You will be prompted
to select two points to indicate the diagonal of box. Select the first point.

2. Asyou select the first point using the left mouse button, a red rubber-band box appears
with the cursor attached to the opposite corner of the box. Move the cursor on the graphics
screen to the desired location to size the diagonal of the rectangle. Use the left mouse
button to select the second point for the diagonal of the rectangle. The red color
automatically changes to cyan on selection of the second point for the diagonal.

Drawing an Arc w ARL TYPE
To draw an arc, choose Sketch from the SKETCHER menu
and Arc from the GEOMETRY submenu in the Menu Concentric
Manager. When you choose the Arc option, the ARC TYPE 3 T angent
submenu appears with the different options. Figure 1-5 show Fillat

different arc options in the ARC TYPE submenu. Center/Ends

Figure 1-6 shows the buttons available to draw arcs when the OFl

Intent Manager is on. Figure 1-5 The different options
i the ARC TYPE submenu

NS Do
Create an arc by 3 J |_ Creste a conic arc.
points or tangent to an
entity &t its endpoint. Creste an arc by
picking itz center and
Creste concertric arc, —— endpaint.

Figure 1-6 Arc options available when the Intent Manager is on

The procedure to draw arcs using different options in the ARC TYPE submenu are discussed
next.
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Drawing an Arc Using the Tangent End Option
The Tangent End option is used to draw arcs that are tangent to any entity. The following
steps explain the procedure to draw arcs using the Tangent End option:

1. Choose SKETCHER > Sketch > Arc > Tangent End from the Menu Manager. You will
be prompted to select an endpoint of an entity to determine tangency.

2. Assoon as you select the endpoint of an entity, a red rubber-band arc appears with one
end attached to the entity and the other end attached to the cursor. Move the cursor on
the graphics screen to the desired position to size the arc. Use the left mouse button to
complete the arc. The red color of the rubber-band arc changes to cyan.

All the arcs created by using this option are tangent to the selected entities. To abort arc
creation press the middle mouse button.

Drawing an Arc Using the Concentric Option

The Concentric option is used to draw an arc concentric to the other arc. You will have to
select an entity to which the arc will be concentric. The entity selected must be an arc or a
circle. The following steps explain the procedure to draw an arc using the Concentric option:

1. Choose SKETCHER > Sketch > Arc > Concentric from the Menu Manager. You will be
prompted to select an entity to determine the center of the arc to be created. The entity to
be selected should be an arc or a circle.

2. Assoon as you select an entity, you are prompted to select the start point of the arc. Select
the start point of the arc. A red rubber-band arc will appear with one end attached to the
start point. The size of the arc will change as you move the cursor. Move the mouse to size
the arc. You will be prompted to select the endpoint of the arc. As soon as you select the
end point of the arc, the red color of the rubber-band arc changes to cyan.

3. Repeat step 2 until you draw the required number of arcs. You can end arc creation by
pressing the middle button of the mouse.

Drawing an Arc Using the 3 Tangent Option
The 3 Tangent option is used to draw a tangent which is passing through three entities. The
following steps explain the procedure to draw an arc using the 3 Tangent option:

1. Choose SKETCHER > Sketch > Arc > 3 Tangent from the Menu Manager. You will be
prompted to select the first entity to which the arc will be tangent.

2. Assoon as you choose the first entity the color of the entity changes to red. Now, you will
be prompted to select the second entity. When you choose the second entity, its color also
changes to red. Similarly, select a third entity. An arc is created instantly when all the three
entities are selected. The arc drawn is tangent to all the three entities selected.

3. Repeatstep 2 until you draw the required number of arcs. If you want to abort arc creation,
you can use the middle mouse button.
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Drawing an Arc Using the Fillet Option
The Fillet option is used for drawing arcs with fillets between two entities. The following steps
explain the procedure to draw fillet arcs:

1. Choose SKETCHER > Sketch > Arc > Fillet from the Menu Manager. You will be
prompted to select the two entities.

2. Select the first entity for filleting using the left mouse button. The cyan color of the first
entity changes to red. Now, select the second entity. As soon as you select the second
entity, a possible fillet is drawn between the two entities selected.

3. Repeat step 2 until the required number of possible fillets are drawn.

"\ Note
b You can draw fillet between any two entities except between two parallel lines.

Drawing an Arc Using the Center/Ends Option

The following steps explain the procedure to draw an arc using the Center/Ends option:

1. Choose SKETCHER > Sketch > Arc > Center/Ends from the Menu Manager. You will
be prompted to select the center of the arc.

2. Using the left mouse button, select a center point for the arc on the graphics screen. A red
colored center mark appears at that point on the graphics screen. Now, you are prompted
to select the start point of the arc. Select the start point of the arc at the desired location.
Ared rubber-band arc appears from the start point. The size of this arc changes dynamically
as you move the mouse.

3. Youwill be prompted to select the endpoint of the arc. Move the mouse to size the arc, and
then select the endpoint of the arc using the left mouse button. An arc is drawn between
the two points selected.

Note that you can draw only one arc with one center. If you want to draw another arc you
will have to select the center again.

Drawing an Arc Using the 3 Point Option
The 3 Point option is used to draw an arc by specifying three points on the graphics screen.
The following steps explain the procedure to draw an arc using the 3 Point option:

1. Choose SKETCHER > Sketch > Arc > 3 Point option from the Menu Manager. You will
be prompted to select the start point of the arc.

2. Select the start point of the arc using the left mouse button at any point on the graphics
screen. As you select the start point, a red rubber-band line appears with one end attached
to the start point and the other to the cursor.
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3. Next, you are prompted to select the endpoint of the arc. Move the mouse to size the arc
at the desired location on the graphics screen. Select the endpoint of the arc using the left
mouse button. A red rubber-band arc appears between the two selected points. The cursor
is attached to the arc and you can move the cursor in between the start point and the
endpoint to size the arc.

4. Next, you are prompted to select the third point. Choose the third point after moving the
mouse on the graphics screen using the left mouse button. The red rubber-band arc changes
its color to cyan and the arc is drawn.

Drawing a Circle

To draw a circle, choose Sketch from the SKETCHER menu
and CIRCLE from the GEOMETRY submenu in the Menu Gearmetry
Manager. When you choose the CIRCLE option, the CIRCLE Canstruction
TYPE submenu is displayed with different options as shown
in Figure 1-7.

Concentric:
3 Tangent
Fillet

2 Paint

You can draw two types of circles using the CIRCLE option.
They are Geometry and Construction. The procedure to
draw circles using the different CIRCLE TYPE submenu
options is discussed next.

Figure 1-7 The various options

i the CIRCLE TYPE :
Drawing a Circle Using the Center/Point Option " ¢/ submen

The Center/Point option is used to draw a circle by defining its center.

The Create a circle by picking the center and a point on the circle. button can be

g used when you are using the Intent Manager. This button is not available when the
Intent Manager is off. The following steps explain the procedure to draw a circle
using the Center/Point option:

1. Choose SKETCHER > Sketch > Circle > Geometry > Center/Point from the Menu
Manager. You are prompted to select the center of the circle.

2. Specify the center point for the circle on the graphics screen using the left mouse button.

3. You are prompted to select a point on the circle to complete it. A red rubber-band circle
appears with the center at the specified point and the cursor attached to it. Move the
cursor to size the circle. Use the left mouse button to complete circle creation. You will
again be prompted to select the center of the circle.

4. Repeat steps 2 and 3 until you draw all the required circles. If you want to abort circle
creation before completing it, press the middle mouse button.

Drawing a Circle Using the Concentric Option
The following steps explain the procedure to draw a circle using the Concentric option:
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The Create concentric circle. button can be used to draw a concentric circle when you
are using the Intent Manager. However, if the Intent Manager is off then this button
is not available.

1. Choose SKETCHER > Sketch > Circle > Geometry > Concentric from the
Menu Manager. You will be prompted to select an arc to determine the centre. You can
select an arc or a circle to use the center point.

2. Using the left mouse button, select an arc or a circle to determine the concentricity of the
circle to be drawn. You will be prompted to use the left mouse button to start dragging the
circle diameter. Select a point on the screen to start drawing the circle.

3. After sizing the circle you can finish circle creation using the left mouse button. Repeat
step 2 until all the concentric circles are drawn. Press the middle mouse button to end
circle creation or to abort it.

Drawing a Circle Using the 3 Tangent Option

The 3 Tangent option is used to draw a circle that is tangent to three other entities. This
option uses the reference entities to draw a circle. The circle drawn using this option
is drawn irrespective of the points selected on the entity. The following steps explain the
procedure to draw a circle using the 3 Tangent option:

1. Choose SKETCHER > Sketch > Circle > Geometry > 3 Tangent from the
Menu Manager. You will be prompted to select the first entity.

2. Choose the first entity using the left mouse button. The color of the entity changes to red.
Similarly, you are prompted to select the second and the third entities. As you select all the
three entities, a circle is drawn that is tangent to all the three entities. You are again
prompted to select the first entity for the second circle if required to be drawn.

3. Repeat step 2 until you draw all the circles. To end the creation of circle using this option
or to abort it, press the middle mouse button.

Drawing a Circle Using the Fillet Option

The Fillet option is used to draw a circle that is tangent to two entities. You will be prompted
to select two entities to draw a fillet circle. If the points selected on the entities do not satisfy
the constraints for the fillet to be drawn, you will get an error message for the invalid selection.
Then you will be again prompted to select the two entities to draw a circle using the Fillet
option. The following steps explain the procedure to sketch a circle using this option:

1. Choose SKETCHER > Sketch > Circle > Geometry > Fillet from the Menu Manager.
You will be prompted to select the first entity.

2. Select the first entity using the left mouse button. The color of the entity changes to red.
Then you are prompted to select the second entity. When the second entity is selected, a
circle is drawn that is tangent to both the entities. You will again be prompted to select the
first entity for the creation of the second circle.
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3. Repeat step 2 until you draw the required number of circles. Press the middle mouse
button to end the creation of the circle or if you want to abort circle creation before the
circle is completed.

"2\ Note
| It is possible to draw a fillet circle between two parallel lines.

Drawing a Circle Using the 3 Point Option

The following steps explain the procedure to draw a circle using the 3 Point option:

1. Choose SKETCHER > Sketch > Circle > Geometry > 3 Point from the Menu Manager.
You will be prompted to specify the first point on the circle.

2. Using the left mouse button, select the first point at the desired location on the graphics
screen. A red rubber-band line appears with the cursor attached to one end of the line and
you will be prompted to select the second point. Move the cursor on the graphics screen to
select the second point.

3. Assoon as you select the second point, a red rubber-band circle appears with the cursor
attached to it. You are prompted to select the third point. Move the mouse to size the
circle. A circle is drawn when you select the third point using the left mouse button. You
will again be prompted to select the first point on the circle to draw the next circle.

4. Repeat step 2 until you draw all the circles. Press the middle mouse button to end circle
creation or to abort circle creation before the circle is completed.

DIMENSIONING THE SKETCH

After you draw a sketch, the next step involves the dimensioning of the sketch. The basic
purpose of dimensioning in Pro/ENGINEER is to control the size of sketch and to locate it
with some reference. In Pro/ENGINEER, a sketch cannot be regenerated until and unless it is
fully dimensioned and constrained.

When the Intent Manager is on, the entities are
dimensioned and constrained automatically. The
Create defining dimension. button is used to

=

Explain

dimension the entities when the Intent Manager is on. Mormal
Perirneter
When the Intent Manager is off, the dimensions and Reference
constraints are not automatically applied. You need to Ko
manually add the dimensions by choosing the Dimension B aseline
option from the SKETCHER menu. A DIMENSION Feplace

submenu appears with different options to dimension the . .
sketch. Figure 1-8 shows different options in the Figurel-8 The different options
DIMENSION submenu. The Normal option is discussed next. of the DIMENSION submenu
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Dimensioning a Sketch Using the Normal Option

The Normal option is used for normal dimensioning of the sketch. The following steps explain
the procedure to dimension a sketch using the Normal option:

1. The Normal option is selected by default in the DIMENSION submenu in the Menu
Manager. Select the entity you want to dimension by pressing the left mouse button. The
color of the entity changes from cyan to red.

2. Place the dimension by pressing the middle mouse button at the desired place. The
dimension appears in symbols such as sd0, sd1, and so on in yellow color. You can modify
the dimension values using the Modify option discussed later in this chapter.

The remaining options in the DIMENSION submenu are discussed in Chapter 2.

WORKING WITH CONSTRAINTS

In Pro/ENGINEER, the entities in a sketch have to be fully specified in terms of size, shape,
orientation, and location. This is achieved by setting constraints. Using constraints in the
sketch reduces the number of dimensions in that sketch. Constraints are the logical operations
that are performed on the selected geometry to make it more accurate in defining its position
with respect to the other geometry. For example, if a line is very nearly parallel to another line
then Pro/ENGINEER constrains the line as parallel to the other line. You can apply constraints
manually only when the Intent Manager is on. You cannot manually apply the constrains after
sketching the entities when the Intent Manager is off. There are two types of constraints in
Pro/ENGINEER, Geometry constraints and Assembly constraints. Here, you will learn about
the Geometry constraints and the Assembly constraints are discussed in later chapters.

When the Intent Manager is on, choose the Impose
#l|  sketcher constraints on the section. button from the Right

Toolchest to display the Constraints dialog box. This dialog 1|~ L

box is shown in Figure 1-9.
i RN

This dialog box is used to apply constraints manually. Although +e| = | ¥
when the Intent Manager is on, as you draw the sketch the I
constraints are applied automatically. Yet if you want to apply the .
constraints manually you can use this dialog box. The constraints ﬂl
that are applied automatically are weak constraints. Weak constraints
appear gray in color. Weak constraints can be made strong. This is

discussed later in this chapter. The various options in the

. . . Figure 1-9 Constraints
Constraints dialog box are discussed next. g

dialog box
Make line or two vertices vertical

1 | This constraint forces the selected line segment to become a vertical line. This constraint
also forces the two vertices to be placed along a vertical line.
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Make line or two vertices horizontal

— | This constraint forces the selected line segment or two vertices that are apart by some
—— distance to become horizontal or to lie in a horizontal line.

Make two entities perpendicular

n This constraint forces the selected entity to become normal to another selected entity.

Make two entities tangent

% This constraint forces the two selected entities to become tangent to each
other. You are prompted to select two entities that you want to make tangent to each other.

Place point on the middle of the line
. | This constraint forces a selected point or vertex to lie on the middle of a line.

Create same points, points on entity or collinear
constraint

This constraint performs three functions. This constraint can be used to force the two

selected points to become coincident, to constraint a point on the selected entity, and

to make two selected entities collinear, so that they lie on the same line. This constraint
aligns two vertices or entities.

Make two points or vertices symmetric about a centerline

e This constraint makes a section symmetrical about the centerline. When you select
' this constraint, you are prompted to select a centerline and two vertices to make
them symmetrical.

Create Equal Lengths, Equal Radii, or Same Curvature
constraint

E This constraint forces any two selected entities to become of equal dimension. When
you select this constraint, you are prompted to select two lines, arcs, circles, or ellipses
to make their radii equal.

Make two lines paraliel

i This constraint is used to force two lines to become parallel. When selected, this
—— | constraint prompts you to select two entities that you want to make parallel. The two
selected entities become parallel to each other.

When the Intent Manager is off and you choose the Constraints

option from the SKETCHER menu, the CONSTRAINTS E:I:;I:

submenu is displayed as shown in the Figure 1-10. The Disable

options available under the CONSTRAINTS submenu when

the Intent Manager is off are discussed next. Figure 1-10 CONSTRAINTS

submenu
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Explain Option

The Explain option of the CONSTRAINTS submenu provides information about the
constraints that are applied to a sketch. The constraints in the sketch are displayed as symbols.
When you select the Explain option, you are prompted to select the constraint symbol on
which you want the explanation. Select the symbol using the left mouse button. The
information about the selected constraint is displayed in the Message Area.

This option is generally helpful when you view a sketch drawn by some other person. By using
the Explain option you can obtain information about the different constraints applied in the
sketch.

Enable Option

The Enable option when selected enables the selected constraints in the sketch. This option is
used mainly after disabling the constraints using the Disable option that is discussed next.

Disable Option

The Disable option under the CONSTRAINTS submenu is used to disable the selected
constraints. This is mainly used when you have to modify a sketch. For example, if two circles
drawn appear of same size to Pro/ENGINEER, it assigns the same dimension to both the
circles by applying the radius constraint. If after regenerating the sketch, the dimension of
one of the circles is modified, the dimension of the other circle is automatically changed. Here
you need the Disable option. By disabling the radius constraint of the circle, you can modify
the dimension of the required circle without affecting the dimension of the other circle.

A constraint can be disabled using the left mouse button. When you select a constraint symbol
to disable, a red \ line appears across the symbol.

Converting a Weak Constraint into a Strong Constraint
when the Intent Manager is On

As discussed earlier; when you draw a sketch with the Intent Manager on, some weak dimensions
are automatically applied to the sketch. As you proceed to complete the sketch, these dimensions
are automatically deleted from the sketch without any confirmation.

Choose aweak dimension or weak constraint from the graphics screen. The selected dimension
or constraint is highlighted in red. Choose Edit > Convert To > Strong from the menu bar.
The color of the selected dimension is changed from gray to yellow, indicating that the selected
constraint or dimension is made permanent.

DIFFERENCE IN WORKING WITH AND WITHOUT THE
INTENT MANAGER

1. With the Intent Manager on, the sketch is automatically dimensioned. Without Intent
Manager, the Dimension option in the SKETCHER menu is used to dimension the sketch.

2. With Intent Manager on, the constraints are applied automatically to the sketch while
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drawing and are displayed at the same time. Without Intent Manager, the constraints
are applied while drawing the sketch but are displayed after the regeneration of the sketch
based on the assumptions made by Pro/ENGINEER.

3. With Intent Manager on, you cannot use the three functions of the three button mouse to
draw a line, circle, and arc. Without Intent Manager, you can use the three mouse button
to draw a line, circle, and arc.

"\ Note
L Although a sketch is automatically dimensioned when the Intent Manager is on, yet it is very
important to learn the procedure to dimension different entities in a sketch.

DIMENSIONING THE BASIC SKETCHER ENTITIES

The procedure to dimension the sketcher entities such as arcs, circles, revolved sections, and
so on when the Intent Manager is off is discussed next.

Dimensioning an Arc

Figure 1-11 explains the method of dimensioning an arc. Select both the ends of the arc using
the left mouse button and then select a point on the arc. Next, place the dimension by using
the middle mouse button at the desired point. The symbolic dimension appears as shown in
the Figure 1-11. You can modify the dimension by using the Modify option that is discussed later.

Diameter Dimensioning

Figure 1-12 shows the diameter dimensioning technique. For diameter dimensioning, select
the entity twice using the left mouse button. Then place the dimension by using the middle
mouse button at the desired place. The diameter dimension appears in the symbolic form as
shown in Figure 1-12. You can modify the dimension using the Modify option from the
Menu Manager. The same diameter dimensioning technique is also used for arcs.

sdl
+
Figure 1-11 Arc dimensioning technique Figure 1-12 Diameter dimensioning technique

Radial Dimensioning
Figure 1-13 shows the radial dimensioning technique. For radial dimensioning, select the
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entity once using the left mouse button. Then place the dimension by using the middle mouse
button at the desired location. The radial dimension appears in the symbolic form as shown in
Figure 1-13. You can modify the dimension using the Modify option.

Dimensioning Revolved Sections

Figure 1-14 shows the dimensioning technique for revolved sections. The need for revolving a
section is discussed in the later chapters of this book. Here you will just learn how to dimension
a revolved section. To dimension a revolved section select the entity to be dimensioned using
the left mouse button. Select the centerline about which you want the section to be revolved.
Using the left mouse button, once again select the original entity that you want to dimension.
Now, place the dimension by pressing the middle mouse button at the desired location. The
dimension appears in the symbolic form as shown in Figure 1-14. This dimension represents
the diameter of a revolved section. You can modify the dimension by using the Modify option.

sd1

%sd\Zﬂ
|

Figure 1-13 Radial dimensioning technique Figure 1-14 Dimensioning technique for
revolved sections

MODIFYING A SKETCH

You can modify a section sketch using the various options in the MOD SKETCH submenu.
Choose Modify from the SKETCHER menu in the Menu Manager. AMOD SKETCH submenu
appears with different options.

Figure 1-15 shows the various MOD SKETCH submenu options.

Note that all the options of the MOD SKETCH submenu are not tod Entity
available in the submenu. The remaining options are available only Scale
when you regenerate the sketch once. The Mod Entity option in Dirag Wi el
the MOD SKETCH submenu is explained next and the Drag Entity
remaining options are discussed in Chapter 2. Drag Vertex
Sk Ao

Mod Entity Option
The Mod Entity option can be used to modify the items such as Figure 1-15 Options in
dimension values, spline shape, and text. The points of the spline MOD SKETCH submenu
through which it passes can be modified using this option to alter

the shape of the spline. Note that to modify a spline that is drawn using the Approx Chain
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option from the TYPE submenu in the ADV GEOMETRY submenu, you first need to delete
the entities that were used to create splines. The ADV GEOMETRY submenu options are
discussed in Chapter 2. Using the Mod Entity option you can also modify the dimension of an
entity by selecting the dimension value using the left mouse button and entering a new value
for the dimension.

Modifying Dimensions when the Intent Manager is On

When the Intent Manager is on, there are four ways to modify the dimensions of a sketch.
These methods are discussed next.

Using the Modify Dimensions dialog box

You can select a dimension or more than one dimension from the sketch to modify. When you
select dimension(s) from a sketch, they are highlighted in red. If you want to select more than
one dimension, hold down the SHIFT key and select the dimensions using the left mouse
button. You can also use CIRL+ALT +A or define a window to select all the dimensions in the
sketch. Use the Modify the values of dimensions, geometry of splines, or text entities. button
from the Right Toolchest to modify. The Modify Dimensions dialog box shown in Figure 1-16
is displayed.

[ =5 [iBE [T |

pﬂegenerate 5 00 O -llilllllll

[ Lock Scale I -! !
Senzitivity

X

Figure 1-16 Modify Dimensions dialog box

"To modify dimensions using this dialog box, you can either enter a value in the edit box or use
the thumbwheel that is available on the right of the edit box. The Sensitivity slider is used to
set the sensitivity of the thumbwheel.

By default the Regenerate check box is selected and any modifications in the dimensions are
automatically updated in the sketch. If you want to delay the modification process of the
sketch based on the new value of the selected dimension, you need to clear this check box. If
this check box is cleared, the dimensions will not be modified until you exit this dialog box.
This means that Pro/ENGINEER allows you to do multiple modifications before updating the
sketch.
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It is recommended to clear the Regenerate check box and then modify the dimensions if you
have to modify more than one dimension.

The Lock Scale check box is used to lock the scale of a selected dimension with respect to the
other selected dimensions. To lock a dimension more than one dimension should be selected.

Edit > Modify

The Modify option is available in the Edit menu in the menu bar. When you choose the
Modify option from the Edit menu, a check mark appears to the left of the Modify option in
the Edit menu. Now, you can select a dimension from the sketch to modify. You can modify
only a single dimension using this option. When you select a dimension, the Modify
Dimensions dialog box is displayed. By default, the Regenerate check box is selected. Therefore,
the sketch will be regenerated dynamically as you modify the dimension.

Modifying a dimension by double-clicking on it

You can modify a dimension by double-clicking on it using the left mouse button. When you
double-click on a dimension, the pop-up text field appears. Enter a new dimension value in
this field and press ENTER or use the middle mouse button. Remember that you can select a
dimension only when you choose Select one item at a time - shift to gather more than one
item. button from the Right Toolchest.

Modifying dimensions dynamically

When the Intent Manager is on, Pro/ENGINEER is always in the selection mode, unless you
have invoked some other tool. When you bring the cursor to an entity, the color of the entity
changes to magenta. Now, if you hold down the left mouse button, a hand appears on the
entity and you can modify the entity by dragging the mouse. You will notice that as the entity
is modified the dimensions referenced to the selected entity will also be modified.

REGENERATING A SKETCH

You need to regenerate a sketch only when the Intent Manager is off. This is because when the
Intent Manager is on, the sketch is regenerated automatically as you modify a dimension.
However, if the Intent Manager is off, the sketch has to be regenerated manually after it is
fully dimensioned and constrained so that you can proceed for the feature creation. The
Regenerate option is available in the SKETCHER menu. If the sketch is underdimensioned,
amessage is displayed after regeneration and you are prompted to complete the dimension of
the sketch. However, if the sketch is overdimensioned, the entities that are not required to be
dimensioned are highlighted after regeneration. You are prompted to delete the dimensions
that are not required. After the section is successfully regenerated, the Unregenerate option
becomes active. The Unregenerate option is used to restore the original state of the section
that was before regeneration.

DELETING OBJECTS

Choose the Delete option from the SKETCHER menu. The DELETION submenu appears
as shown in Figure 1-17. All the options of the DELETION submenu are discussed next.
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Delete Item Option

The Delete Item option is used to delete a single item at a time.
The following steps explain the procedure to use the Delete Item

option: Delste &l
1. The Delete Item option is selected by default in the DELETION Undelete Last

Delete M army

submenu. You are prompted to select a sketched entity, Figure 1-17 DELETION
dimension, constraint, or sketcher reference to delete. submenu
Select any item in the sketch to delete. The item selected disappears instantly from the
graphics screen. You can continue deleting the entities by selecting them one after the other
until all are deleted. After you have deleted the required number of items, select Done
from the SKETCHER menu to end the deletion process.

To delete an item when the Intent Manager is on, select the item by defining a window
using the left mouse button. The color of the selected item changes to red. Right-click on
the graphics screen and hold down the right mouse button until a shortcut menu appears.
Now, choose the Delete option from this menu. The selected item will be deleted.

Delete Many Option

The Delete Many option is used to delete more than one item at a time. The following steps
explain the procedure to use the Delete Many option:

1.

Select Delete Many from the DELETION submenu. You will be prompted to specify two
points to indicate the diagonal of the box.

Specify two points such that all the items to be deleted are fully enclosed within the box.
The selected items are highlighted and appear red in color. Select Done Sel from the
GET SELECT menu to confirm the deletion of the selected items.

Continue step 2 until you delete all the items that needs to be deleted. Choose Done from
the SKETCHER menu to end the deletion.

To delete more than one item from the graphics screen when the Intent Manager is on,
select items using the SHIFT'+left mouse button. You can also select the items by defining
a box so that all the entities that are to be deleted are enclosed inside the box. The color
of all the selected items changes to red. Right-click on the graphics screen and hold down
the mouse button until a shortcut menu appears. Now, choose the Delete option from this
menu. The selected items will be deleted.

"=\  Note

\
\

| When the Intent Manager is on and you need to select an item from a sketch, choose the Select
one item at a time - shift to gather more than one item. button from the Right Toolchest

3 | and then select the required item from the graphics screen. The term “items” used in this chapter

refers to dimensions and entities.
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Delete All Option

The Delete All option is used to delete the entire sketch and dimensions in a single step. As
soon as you select Delete All from the DELETION submenu the entire sketch will be deleted.

Undelete Last Option

The Undelete Last option is used to restore the last deleted item. This option is
J activated only when an item is deleted from the sketch. Select Undelete Last from the

DELETION submenu. The last deleted item in the sketch will be restored. Similarly,
if you have deleted more than one item in the sketch, all the items will be restored in succession
from the last deleted item. This option is not available if the Intent Manager is on.

The Undo Modify Dimensions button, available when the Intent Manager is on, performs
the same function.

GEOM TOOLS w GEOM TOOLS

The GEOM TOOLS submenu contains the basic tools that help a Intersect
designer to draw the section sketches. Select Geom Tools from the Trim
SKETCHER menu. A GEOM TOOLS submenu appears with the Divide
options available in it. Figure 1-18 shows the different GEOM Use Edge
TOOLS submenu options and these options are discussed next. Difset Edge
birrar
P N‘_)te ) ) . . oz Fort
\ Itis evident from Figure 1-18 that all the options are not available Replace
in the GEOM TOOLS submenu. This is because these options are Mave Entity
not needed in the Sketch mode.

Figure 1-18 GEOM
Trim TOOLS option
When creating a design, there are a number of places where
you have to remove the unwanted and extending edges. This
option trims entities that extend beyond a required point of
intersection. The trim option is also used to extend an entity Bound
up to the other entity. You can trim lines, circles, arcs, ellipses, Lenath
etc. using this option. Increm

Corner
Choose Trim from the GEOM TOOLS submenu. The DRAFT Untrim Last
TRIM submenu is displayed with different options available Figure 1-19 Different options
as shown in Figure 1-19. The different options available in this ;.41 DRAFT TRIM submenu

menu are explained next.

Bound Option

The Bound option of the DRAFT TRIM submenu is used for deleting or extending a portion
of an entity by defining a bounding entity. The following steps explain the procedure to use
the Bound option to trim the entities:

1. Choose Trim from the GEOM TOOLS submenu and Bound from the DRAFT TRIM
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submenu. You will be prompted to select a bounding entity to trim to. This is the bounding
limit up to which the line will be deleted or extended. Figure 1-20 shows the line extended
up to a bounding entity.

2. Using the left mouse button, select the
line that you want to be the bounding ‘ ‘
. . . . Bounding entity
entity. When the entity is selected, its /
color changes to red. Now, you are
prompted to select the entity to be
trimmed.

3. Select the line to be trimmed using the
left mouse button. The line is extended
up to the bounding entity. This is shown
in Figure 1-20. You can change the
bounding entity anytime by pressing the
middle mouse button and selecting
another entity as the bounding entity.

Before Trim After Trim

Figure 1-20 The Bound option

Length Option
The Length option is used to trim or extend an entity up to a specified length. The
following steps explain the procedure to trim an entity using the Length option:

1. Choose Trim from the GEOM TOOLS submenu and Length from the DRAFT TRIM
submenu in the Menu Manager. The Message Input Window is displayed. Enter the
required length you want to keep after trimming.

2. After specifying the length, you will be prompted to select the entity to be trimmed. Select
the entity using the left mouse button on the side you want to trim. Depending upon the
original size of the entity, it will be trimmed or extended to modify the original length.

Increm Option

The Increm option is used to extend or shorten the entity in increments specified. To extend
the entity enter a positive increment value and to shorten the entity, enter a negative increment
value. The following steps explain the procedure to trim the entities using the Increm option:

1. Choose Trim from the GEOM TOOLS submenu and Increm from the DRAFT TRIM
submenu. The Message Input Window is displayed. Enter the incremental length.

2. After specifying the incremental length, you will be prompted to select the entity to be trimmed.
Select the side of the entity where you want to extend using the left mouse button. Continue
selecting the entity as much as you want to extend it. The line will be extended according to
the incremental length. Use the middle mouse button to quit the trimming operation.

Corner Option
The Corner option is used to trim two entities at their corners. Note that when you trim
entities using this option, the portion from where you select the entities is retained and the
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other portion is trimmed.

: When the Intent Manager is on, you can use the Trim entities (cut or extend) to
T~ | other entities or geometry. button to trim. The following steps explain the procedure
to trim entities using the Corner option:

1. Choose Trim from the GEOM TOOLS Second selection
submenu and Corner from the DRAFT [
TRIM submenu. You will be prompted
to select two entities to be trimmed.

2. Using the left mouse button, select the First selection
two entities on the sides you want to keep /
after trimming, see Figure 1-21. These
two entities must be intersecting entities.
The entities are trimmed from the point Before Trim After Trim
of intersection.

Figure 1-21 Trimming the lines using the Corner
Untrim Last Option option
The Untrim Last option is available only
after any trimming operation is performed. This option is used to untrim the last entity trimmed.
As soon as you select the Untrim Last option from the DRAFT TRIM submenu the last entity
trimmed is automatically restored.

Mirror

The Mirror option is used to mirror sketched geometries about a centerline. This option
helps reduce the time consumed for creation of symmetrical geometries and the process of
dimensioning the symmetrical entities.

| When the Intent Manager is on, you can use the Mirror selected entities. button to
/A mirror.
The following steps explain the procedure to mirror a sketched geometry when the Intent
Manager is off:

1. Sketch a geometry using the sketcher options. Sketch a center line about which you have
to mirror the geometry.

2. Choose Mirror from the GEOM TOOLS submenu. You will be prompted to select the
center line about which you have to mirror. Select the center line using the left mouse
button. The color of the center line changes to red.

3. You will be prompted to select the entities you want to mirror. The MIRROR menu is
displayed that can be used to select individual entities or all the entities for mirroring. If
you select individual entities, the color of all the entities selected to mirror changes to red.
However, if you select all the entities using the All option, they will be mirrored
automatically.
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4. Choose Done Sel from the GET SELECT submenu. The entities selected are mirrored
about the center line.

—

0w Tip: Incase of symmelrical parts, you can save the time involved in dimensioning the
= y sketch by dimensioning half of the section and then mirroring it. Pro/ENGINEER
= will assume that the mirroved half has the same dimensions as the sketched half.

GET SELECT SUBMENU

The options of the GET SELECT submenu are used as the basic tool
to select the entities on the graphics screen. The different options
available in the GET SELECT submenu are shown in Figure 1-22.

Cluemy Sel

These options are discussed next. Sel By Menu
Done Sel
Pick it Sel

The Pick option is used to select any geometric as well as dimensional g gure 1-22 GET
entity. The picking action is performed by using the left mouse button — ¢pr BT Gbmenu
on the entity you have to select.

Query Sel

The Query Sel option makes the selection process easier

it

and provides an opportunity to rectify the selection any SectEnt
number of times before confirming it. Whenever you sectent
have to select an entity for modification or other Sectnt

purposes select the Query Sel option and then make
the selection. The Query Bin appears with the name of
the entity or entities that are selected. If your selection
is wrong, you can change your selection any number of
times before confirming it. To confirm the selection,
choose the Accept button in the Query Bin.

+ | | Accept |

Figure 1-23 shows the Query Bin that appears on ] '
selecting the entity. Figure 1-23 Query Bin

L,

Tip: You can also use the right mouse button to invoke the Query Sel option. After
viewing your selection in the Query Bin window press the middle mouse button to

v i
= y
, .
&»Z’ ‘ / accept the selection.

Sel By Menu

This option is used mostly in the part mode when you have to select the datum planes and so
on. It will be discussed in later chapters.

Done Sel

This option when selected confirms the selections you made. This is equivalent to pressing the
middle mouse button. Select Done Sel to end your selections.
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Quit Sel

This option is used to quit any selections you have made.

DRAWING DISPLAY OPTIONS

While working with complex sketches, you need to increase the display of a particular portion
of a sketch so that you can work on minute details of the sketch. For example, if you are
drawing a sketch of a piston, you have to work on the minute details of the grooves for the
piston rings. To work on these minute details, you have to enlarge the display of these grooves.
You can enlarge or reduce the drawing display using the various drawing display options
provided in Pro/ENGINEER. Some of these drawing display options are discussed next. The
remaining drawing display options will be discussed in later chapters.

Zoom In

This option enlarges the view of the drawing on the screen. When you choose the
Q Zoom In button, you will be prompted to define a box. The area that you will enclose
inside the box will be enlarged and displayed on the graphics screen. Note that when

you enlarge the view of the drawing, the original size of the entities is not changed.

Zoom Out
This option reduces the view of the drawing on the screen, thus increasing the drawing
& display area.

Refit object to fully display it on the screen

@ This option reduces or enlarges the display such that the entities that comprise the
sketch are fitted inside the current display. Note that the dimensions may not necessarily

be included in the current display.

Redraw the current view
D While working with complex sketches, some unwanted temporary information is
retained on the screen. The unwanted information include the shadows of the deleted
sketched entities, dimensions, and so on. This unwanted information can be removed
from the graphics screen using the Redraw the current view option. This option will be
extensively used while designing in Pro/ENGINEER.

TUTORIALS
Tutorial 1

In this tutorial, you will draw the sketch shown in Figure 1-24 using the basic sketcher options.
You will draw the sketch both without using the Intent Manager and using the Intent Manager.
(Expected time: 30 min)

Sketch Without Using the Intent Manager

The following steps outline the procedure for creating this sketch without using the Intent
Manager:
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Figure 1-24 Sketch for Tutorial 1
a. Start Pro/ENGINEER.
b. Set the working directory and create a new object file.
c.  Turn off the Intent Manager. Draw lines using the sketcher options.
d. Draw an arc and a circle.
e. Dimension the sketch and then modify the dimensions of the sketch.

f.  Regenerate the sketch and then save it.

Starting Pro/ENGINEER
1. Start Pro/ENGINEER by double-clicking on the Pro/ENGINEER icon on the desktop of
your computer or by using the Start menu.

Setting the Working Directory

When Pro/ENGINEER session is started, the first task is to set the working directory. Aworking
directory is a directory on your system where you can save the work done in the current session
of Pro/ENGINEER. You can set any directory existing on your system as the working directory.
Since this is the first tutorial of this chapter, you need to create a folder named c01, if it does
not exist.

1. Choose the Set Working Directory option from the File menu. The Select Working
Directory dialog box is displayed as shown in Figure 1-25.

2. Browse and select C:\ProE. It is assumed that the ProE folder exists.
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L Working Directory
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Figure 1-25 Select Working Directory dialog box

3. Choose the New Directory button in the Select Working Directory dialog box.

The New Directory dialog box is displayed.

4. Iype c01 in the New Directory edit box. Choose OK from the dialog box. You have

created a folder named c0O1 in C:\ProE.

5. Choose OK from the Select Working Directory dialog box. You have set the working
directory to C:\ProE\c01. A message is displayed in the Message Area that the directory

successfully changed to C:\ProE\c0O1 directory.

Creating New Object File

Any sketch drawn in the Sketch mode is saved with file extension .sec. This file format is one

of the file formats available in Pro/ ENGINEER.

1. Choose the Create a new object button from the File toolbar to display the New
dialog box. Select the Sketch radio button from the Type area of the New dialog

box. A default name of the sketch appears in the Name edit box.
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2. Enter c0ltutl-1 in the Name edit box, see Figure 1-26. Choose the OK button.
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Figure 1-26 New dialog box

You will enter the sketcher environment of the Sketch mode. When you enter the
sketcher environment, the Intent Manager is on by default. This is evident from the buttons
available on the Right Toolchest. You can also reconfirm this from the check mark that is
displayed on the left of the Intent Manager option in the Sketch menu in the menu bar.

To exit the Intent Manager, choose the Intent Manager option to clear the check mark.
The Right Toolchest is no more displayed and the Menu Manager is displayed on the
right of the window. The Menu Manager contains all the sketcher options.

Drawing the Lines in the Sketch
You will start drawing the given sketch from the right side of the sketch.

1.

From the GEOMETRY submenu in the Menu Manager, choose the Line option. The
LINE TYPE submenu is displayed.

You will notice that the Geometry and the 2 Points options are selected by default in the
LINE TYPE submenu.

Choose the Vertical option from the LINE TYPE submenu. You will be prompted to
select a start point.

Using the left mouse button, specify the start point on the right of the graphics screen.



1-32 Pro/ENGINEER for Designers

You will notice that a red line is being drawn.

4. Move the cursor down to get an approximate size of the line and using the left mouse
button specify the end point of the vertical line. This is the right vertical line shown in
Figure 1-27.

You will notice that another rubber-band line is being drawn. The start point of this line is
the endpoint of the last line. This line will change its size as you move the cursor. This is
because the endpoint of this line is not defined. Also, note that in the LINE TYPE submenu,
the Horizontal option is highlighted. This means that a horizontal line will be drawn.

5. Move the cursor toward left on the graphics screen. A horizontal rubber-band line is
drawn. Approximately size the line and when you get the desired size, use the left mouse
button to specify the end point of the horizontal line. The horizontal line is shown in
Figure 1-27.

You will notice that a new vertical rubber-band line is being drawn. The start point of this
line is the end point of the last line. Also, note that in the LINE TYPE submenu, the
Vertical option is highlighted. This
means, that a vertical line will be drawn.

6. Move the cursor upwards on the graphics
screen. A vertical red rubber-band line is
drawn. Size the line approximately and
after getting the desired size, use the left
mouse button to specify the end point of
the left vertical line as shown in
Figure 1-27.

7. Press the middle mouse button to end
line creation.

The sketch after drawing the lines is  Figure 1-27 First vertical line, second horizontal
shown in Figure 1-27. line, and third vertical line

8. From the LINE TYPE submenu in the Menu Manager, choose the 2 Points option. You
will be prompted to select a start point.

9. Use the left mouse button to start an inclined line from the endpoint of the last vertical
line. Size the line and specify the end point of the line. The inclined line is shown in
Figure 1-28. Press the middle mouse button to end line creation. The 2 Points option is
still active.

Remember that to start the line from the endpoint of the previous line, the start point of
the line need not be exactly on the endpoint of the previous line. This is because when
you dimension these entities in the sketch, the dimensions will automatically close the
sketch if the points are close to each other. You can also use the Trim > Corner option
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discussed earlier in the chapter to clean the corners.

10. Use the left mouse button to start an
inclined line from the start point of the
first vertical line. Size the line
approximately and specify the endpoint
of the line. Press the middle mouse
button to end line creation. The two
inclined lines are shown in Figure 1-28.

The lines in the sketch are drawn and
now you need to draw an arc and a circle.
If the space on the graphics screen is not
enough to draw the arc, you can modify
the current display using the CTRL +left
mouse button or CTRL+right mouse Figure 1-28 Left and right inclined lines
button.

Drawing the Arc

1. From the GEOMETRY menu in the
Menu Manager, choose Arc > Tangent +
End. You will be prompted to select the
end of an entity to determine tangency.

2. Using the left mouse button, select the
end point of the left inclined line. The
red rubber-band arc appears.

3. Using the left mouse button, select the
endpoint of the right inclined line as the
endpoint of the arc, see Figure 1-29.

Figure 1-29 Arc drawn tangent to the lines
Drawing the Circle
The circle in the sketch is concentric to the arc. This means that the centers of the arc and the
circle lies at the same point. Therefore, you need to use the Concentric option to draw circle.

1. From the GEOMETRY submenu in the Menu Manager, choose the Circle option. The
CIRCLE TYPE submenu is displayed.

2. Choose Geometry > Concentric from this menu. You will be prompted to select an arc.

3. Using the left mouse button, select the arc that you created earlier. Now, you are prompted
to use the left mouse button and drag the mouse.

4. Use the left mouse button to select a point inside the sketch. A red rubber-band circle
appears.
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Size this circle approximately by moving the

mouse and complete it by using the left
mouse button. The circle drawn is shown in @
Figure 1-30.

The sketch is completed and now you will
dimension it.

Linear Dimensioning
All the dimensions that are shown in Figure 1-31
are required to regenerate the sketch. In the figure

you will notice that all the entities of the sketch

are not dimensioned. This is because

dimensioning all the entities is not needed. Figure 1-30 Sketch after drawing all the
Pro/ENGINEER highlights the dimensions that entities

are not needed in the sketch in red color after

you regenerate the sketch.

1.

In the Menu Manager, choose the Dimension option from the SKETCHER menu. The
DIMENSION submenu is displayed.

The Normal option in this submenu is chosen by default.

Using the left mouse button, select the right vertical line from the sketch. The selected
line is highlighted red in color.

Now, place the dimension using the middle mouse button on the right of the sketch, see
Figure 1-31. The dimension appears as sd0. This is the first dimension of the sketch,
therefore it i1s named as sdO.

Using the left mouse button select the bottom horizontal line and place the dimension
below the sketch using the middle mouse button, see Figure 1-31. This dimension appears
as sd1.

Using the left mouse button, select the center point of the circle and then select the bottom
horizontal line. Both the center point and the line turn red in color.

Using the middle mouse button, place the dimension on the right of the sd0 dimension,
see Figure 1-31. This dimension appears as sd2.

Using the left mouse button, select the center point of the circle and then select the left
vertical line. Both the center point and the vertical line turn red in color.

Using the middle mouse button, place the dimension above the sd1 dimension, see
Figure 1-31. This dimension appears as sd3.
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Radial Dimensioning the Arc
The Dimension > Normal option is still active and will remain active until you choose some
other option from the Menu Manager.

1. Select the arc from the graphics screen using the left mouse button. The selected arc turns
red in color.

2. Using the middle mouse button, place the dimension above the sketch, see Figure 1-31.

The arc is radially dimensioned and the dimension is displayed as sd4 in the sketch. The
naming of dimension is done by default. The first dimension you created in the sketch is
sd0, the second dimension is sd1, and so on. But, if you delete a dimension that is already
created and then again dimension it, the dimension number will be incremented by one.

The dimensioning of various entities in the sketch is shown in Figure 1-31

Diameter Dimensioning the Circle
To dimension a circle, if you select it once then the circle is dimensioned radially. However, if
you select it twice then it is dimensioned diametrically.
4
1. Using the left mouse button select the circle Lt
on the graphics screen twice. The selected
circle turns red in color. [

2. Using the middle mouse button, place the
dimension on the right of the sketch below
the sd4 dimension, see Figure 1-31.

The diameter dimension of the circle is i
created and will be displayed as sd5 in the
sketch. =1 —n

sdl

Modifying the Dimensions Figure 1-31 Sketch after applying dimensions
Next, you need to modify all the dimensions that

you applied to the sketch. This is because Pro/ENGINEER assigns some default values to the
entities that were dimensioned. These default dimensions are displayed in the Message Input
Window that is displayed when you select a dimension to modify. Remember that to select a
dimension to modify, the text should be selected using the left mouse button. For example,
the cursor should point on sd0 to modify the sd0 dimension.

1. Choose the Modify option from the SKETCHER menu in the Menu Manager. The MOD
SKETCH submenu is displayed and the Mod Entity option is chosen by default.

2. Select the text of first dimension that by default is named as sd0. The selected dimension
turns red in color and the Message Input Window is displayed with a default value.

3. Enter a value of 3 in the Message Input Window and press ENTER or choose the check
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10.

11.

12.

13.

mark on the Message Input Window. The modified dimension turns white in color and
the dimension value is displayed in place of sd0.

Select the text of second dimension of the bottom horizontal line that by default is named
as sd1. The selected dimension turns red in color and the Message Input Window is

displayed with a default value.

Enter a value of 12 in this window and press ENTER. The modified dimension turns
white in color on the graphics screen.

Select the text sd2. The selected dimension turns red in color and the Message Input
Window is displayed with a default value.

Enter a value of 7 in this window and press ENTER. The modified dimension turns white
in color on the graphics screen.

Select the text sd3. The selected dimension turns red in color and the Message Input
Window is displayed with a default value.

Enter a value of 6 in this window and press ENTER.

Select the text of radial dimension that is by default named as sd4. The selected dimension
turns red in color and the Message Input Window is displayed with a default value.

Enter a value of 4 in this window and press ENTER.

Select diameter dimension that is by default named as sd5. The selected dimension turns
red in color and the Message Input Window is displayed with a default value.

Enter a value of 5 in this window and press ENTER. All the dimensions of the sketch are
modified and now the sketch needs to be regenerated.

Regenerating the Sketch

The sketch in sketcher environment is drawn with 4,00
some default size. Then you apply the dimensions £ a0
and modify them according to the specifications. To T/ 1

resize the sketch according to the given dimensions
you have to regenerate the sketch. If the sketch drawn _)/'
is complete and fully dimensioned and you choose

the Regenerate option from the SKETCHER menu,

the Section regenerated successfully. message is . ;1;,,
displayed in the Message Area. ¢
1. Choose the Regenerate option from the = 00—

SKETCHER menu in the Menu Manager. The .o

M

sketch is regenerated successfully and the sketch
is now complete, see Figure 1-32. Figure 1-32 Skeich afier regeneration
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"\ Note
\

\ If the skeich is not regenerated and you are prompted to add dimensions, dimension the entity
that is highlighted red.

Saving the Sketch

You have to save the sketch because you may need the sketch later.
1. Choose the Save the active object button from the File toolbar. The Message =
Input Window is displayed with CO1TUT1-1.SEC, the name of the sketch. This is

the name that you had entered earlier.

2. Press ENTER or choose the check mark on the Message Input Window. The sketch is
saved.

3. Choose SKETCHER > Done from the Menu Manager to exit the sketcher environment.

Sketch Using the Intent Manager

The following steps outline the procedure for creating this sketch using the Intent Manager.
a. Create a new object file.

b. Draw lines using the tool button for creating lines.

c.  Draw an arc and a circle using respective tool buttons.

d. Dimension the sketch and then modify the dimensions of the sketch.

e. Save the sketch.

Creating New Object File

1. Choose the Create a new object button from the File toolbar. The New dialog box
is displayed. Select the Sketch radio button from the Type area of the New dialog box. A
default name of the sketch appears in the Name edit box.

2. Enter c01tutl-2 in the Name edit box. Choose the OK button.

You will enter the sketcher environment of the Sketch mode. When you enter the
sketcher environment, the Intent Manager is on by default.

Drawing the Lines of the Sketch

You will start drawing the sketch with the right vertical line.
1. Choose the Create lines. button from the Right Toolchest. %

2. Using the left mouse button, specify the start point on right on the graphics screen. One
end of the line is attached to the cursor. Move the cursor down to get an approximate size
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10.

of the line.

You will notice that when the cursor is moved vertically downwards a red colored constraint
named V appears on the graphics screen next to the line. This shows that if you draw a
line now then the vertical constraint will be applied to the line.

Use the left mouse button to specify the end point of the line. The vertical constraint V is
applied to the line and the symbol V appears in yellow. The color of the constraint indicates
that this constraint is strong. This means that you cannot change the orientation of this
line until you delete the constraint that is applied on the line.

Another rubber-band line is attached to the cursor with the start point as the endpoint of
the last line.

Move the cursor horizontally toward left, a horizontal rubber-band line extends to the left
as you move the mouse.

After you get the desired size of the line, use the left mouse button to end the line. You will
notice that a horizontal constraint named H that is yellow in color is applied to the line.

Move the cursor upwards on the graphics screen. A vertical rubber-band line extends as
you move the mouse. As you move the cursor upwards, you will notice that at a particular
point where the length of the left vertical line is equal to the length of the right vertical
line, L, symbol is displayed on both the vertical lines. This symbol suggests that equal
length constraint is applied to the two vertical lines.

When L, constraint appears on the vertical line, use the left mouse button to specify the
end point of the vertical line. You will notice that L, constraint is displayed in gray color as
shown in Figure 1-33. This suggests that it is a weak constraint. The rubber-band line is
still attached to the cursor.

You can also apply the constraints later but to save an extra step of adding the constraints,
you will use the constraints that are applied automatically while drawing.

Move the cursor to size the line and specify the endpoint of the left inclined line, see
Figure 1-33.

Press the middle mouse button to end line creation. You will notice that gray colored
dimensions are applied to the sketch, see Figure 1-33. The color of these dimensions
indicate that these dimensions are weak dimensions. These dimensions are automatically
deleted anytime while you are completing the sketch or when you are adding dimensions
and constraints manually. When deleting the weak dimensions, the system does not confirm
their deletion.

The line option is still active. Move the cursor close to the top end of the right vertical
line. You will notice that as you bring the cursor close to the top end, the cursor snaps to
that point. Select the point using the left mouse button.



Creating Sketches in the Sketch Mode 1-39

11. Size the inclined line and specify the endpoint of the right inclined line. Press the middle

mouse button to end line creation.

Figure 1-34 shows all the lines that you have drawn. Now, the arc and circle is will be drawn.
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Figure 1-33 Lines with weak dimensions Figure 1-34 Partial sketch with weak dimensions

Drawing the Arc

1.

Choose the Create an arc by 3 points or tangent to an entity at its endpoint.
button from the Right Toolchest. You will be prompted to select the start point of N
the arc.

Using the left mouse button, one by one select the top endpoints of the two inclined lines.
Arubber-band arc appears. Move the cursor upwards. As you move the cursor; at a particular
point the tangent constraint is applied at both the ends of the arc. This is evident by a
symbol T that appears on the endpoint of the inclined line.

As the tangent constraint appears, use the left mouse button to end arc creation. You will
notice that the tangent constraint with a symbol T appears at the end points of the arc as
evident from Figure 1-35. Press the middle mouse button to end arc creation.

The tangent constraint T will appear in yellow, which suggests that it is a strong constraint
and the tangency of the inclined line with the arc cannot be modified until you delete the
tangent constraint.

Note that in Figure 1-34 there are some weak dimensions that are not displayed in
Figure 1-35. This is because the weak dimensions are deleted without confirming their
deletion. Hence, after drawing the arc some weak dimensions got deleted automatically.

Drawing the Circle

1.

Choose the black arrow on the right of the Create circle by picking the center
and a point on the circle. button to display the flyout. From this flyout, choose the
Create concentric circle. button. You will be prompted to select an arc.
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Select the arc using the left mouse button. Move the mouse and a circle appears.
Using the left mouse button select a point inside the sketch to define the circle.

Press the middle mouse button to end circle creation. The sketch is complete and appears
similar to that shown in Figure 1-36.

Figure 1-35 Sketch with arc Figure 1-36 Sketch with all the entities, weak
dimensions, and weak constraints

"2\ Note
\ Ifthe tangent constraint symbol is not displayed on any of the inclined lines, apply the constraint

manually using the Constraints dialog box that is displayed when you choose the Impose
sketcher constraints on the section. button from the Right Toolchest.

Dimensioning the Sketch

The right vertical line, the bottom horizontal line, the arc, and the circle are dimensioned
automatically and weak dimensions are applied to them. You will use these dimensions. Hence,
there is no need to dimension these entities again.

1.

Choose the Create defining dimension. button. A

Using the left mouse button, select the center point of the circle and then select the bottom
horizontal line. Both, the center point and the line turn red in color.

Using the middle mouse button, place the dimension on the right of the sketch.

Using the left mouse button, select the center of the circle and then select the left vertical
line. Both, the center and the vertical line turn red in color.

Using the middle mouse button, place the dimension below the sketch as shown in
Figure 1-37. Remember that when you add dimensions while the Intent Manager is on,
the dimension values are displayed instead of dimension symbols.
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Modifying the Dimensions

The sketch is dimensioned with default values. You need to modify these values to the given

values.

1. Choose the Select one item at a time - shift to gather more than one item. button. k

2. Select all the dimensions using the SHIFT +left mouse button.

"\ Note
\\ You can also use CTRL+ALT+A to select the whole sketch with dimensions.

3. When all the dimensions turn red in color, choose the Modify the values

-

of dimensions, geometry of splines, or text entities. button. The Modify i

Dimensions dialog box is displayed.

All the dimensions in the sketch are displayed in this dialog box and each dimension has
a separate thumbwheel and an edit box. You can use the thumbwheel or the edit box to
modify the dimensions. It is recommended to use the edit boxes to modify the dimensions

if the change in dimension value is large.

4. Clear the Regenerate check box and then modify the values of the dimensions. When you
clear this check box, then any modification in a dimension value does not update the
sketch. It is recommended to clear the Regenerate check box when more than one

dimension has to be modified.

You will notice that the dimension you select in the Modify Dimensions dialog box is
enclosed in a yellow box on the graphics screen.

5. After modifying all the
dimensions, ’ CthOSC the
Regenerate the section and
close the dialog button from the Modify
Dimensions dialog box. A message
Dimension modifications successfully
completed. is displayed in the Message
Area.

The sketch is complete and is shown in
Figure 1-37. When you are sketching with
Intent Manager on, the sketch is
automatically regenerated after the
dimensions are modified.

Saving the Sketch

4,00
T T 5,00
T.00G
b Lifv 5 00
i
= 0 ————]
e —

Figure 1-37 Skeich with dimensions and constraints
for Tutorial 1

The sketch will now be saved. You have to save the sketch because you may need the sketch

later.
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1. Choose the Save the active object button from the File toolbar. The Message =
Input Window is displayed with the name of the sketch that you had entered
earlier.

2. Press ENTER. The sketch is saved.

3. After saving the sketch, choose the Continue with the current section. button to v
exit the sketch.

Tutorial 2

In this tutorial you will draw the sketch shown in Figure 1-38. Draw the sketch both without
using the Intent Manager and using the Intent Manager. For your reference, all the entities in
the sketch are assigned alphabetical labels. (Expected time: 30 min)
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Figure 1-38 Sketch for Tutorial 2 with dimensions and labels for
identification

Sketch Without Using the Intent Manager

The following steps outline the procedure for creating this sketch without using the Intent
Manager:

a. Set the working directory and create a new object file.
b. Turn off the Intent Manager. Draw the sketch using the sketcher options.
c¢.  Dimension the sketch and then modify the dimensions of the sketch.

d. Regenerate the sketch.
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Setting the Working Directory

The working directory was selected in Tutorial 1, therefore there is no need to select the
working directory again. But if you still want to select the working directory, choose the Set
Working Directory option from the File menu. The Select Working Directory dialog box is
displayed. Set the working directory to C:\ProE\c01.

Creating New Object File

1.

Choose Create a new object button from the File toolbar. The New dialog box N
is displayed. Select the Sketch radio button from the Type area of the New dialog
box. A default name of the sketch appears in the Name edit box.

Enter cOltut2-1 in the Name edit box. Choose the OK button.
You will enter the sketcher environment of the Sketch mode.
When you enter the sketcher environment the Intent Manager is on. To exit the Intent

Manager, choose the Intent Manager option in the Sketch menu. The Sketch menu is
available on the menu bar.

Drawing the Sketch

The sketch consists of lines only. For easy explanation, all the lines in the sketch are named.

1.

From the GEOMETRY submenu in the Menu Manager, choose the Line option. The
LINE TYPE submenu is displayed. The Geometry and the 2 Points option is selected by
default.

Choose the Horizontal option from the LINE TYPE submenu. You will be prompted to
select a start point.

Start from right on the graphics screen and start drawing line A as discussed in next step.

Using the left mouse button specify the start point of line A on the right side of the
graphics screen. Move the cursor to the left on the graphics screen and size the line.

Using the left mouse button, specify the endpoint of the line as shown in Figure 1-39. You
will notice that when you move the mouse, the red line extends in the vertical direction
only.

Move the cursor upwards to size line B and using the left mouse button specify the end
point of line B as shown in Figure 1-39. Now, when you move the mouse, you will notice

that a red line extends in the horizontal direction only.

Move the cursor to the right on the graphics screen and using the left mouse button
specify the endpoint of line C, see Figure 1-39.

Now, you will draw line D. Move the cursor down and using the left mouse button specify
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10.

11.

12.

13.

14.

15.

16.

17.

18.

19.

the endpoint of line D as shown in Figure 1-39.

Now, you need to end line creation because the next line to be drawn is inclined at an
angle.

Press the middle mouse button to end line creation.

Choose the 2 Points option from the LINE TYPE submenu. You will be prompted to
select a start point.

Using the left mouse button, select the endpoint of line D as the start point for line E.
Move the mouse to size the line.

Using the left mouse button, specify the endpoint of line E, see Figure 1-39.

Now, you have to abort the 2 Points
option because the next line to be drawn
is vertical. Press the middle mouse button
to abort line creation.

Choose the Vertical option from the LINE
TYPE submenu to draw the vertical line
F. You will be prompted to select a start
point.

Using the left mouse button, select the
endpoint of line E as the start point for
line F. Move the mouse to size the line and
use the left mouse button to specify the

endpoint of the line. Line Fis completed  Figyye 1-39 Sketch after drawing lines A to F
as shown in Figure 1-39.

Now, draw line G. Using the left mouse button specify the endpoint of line G. Line G is
completed, see Figure 1-40.

Move the cursor upwards and using the left mouse button specify the endpoint of line H.

Now, press the middle mouse button to end line creation. You need to end line creation
because the next line to be drawn is inclined at an angle.

Choose the 2 Points option from the LINE TYPE submenu. You will be prompted to
specify the start point of the line.

Select the endpoint of line H as the start point for line I. Move the cursor to size the line.

Using the left mouse button, specify the endpoint of line I, see Figure 1-40. A red line is
attached to the cursor. Press the middle mouse button to end line creation. You need to do
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this because the next line to be drawn 1s vertical.

20. Choose the Vertical option to draw line J. Using the left mouse button, specify the
endpoint of line I as the start point for line J.

21. Move the cursor to size the line and using the left mouse button, specify the endpoint of
the line. Line ] is completed as shown in Figure 1-40.

22. Move the cursor to the right of the sketch and using the left mouse button specify the
endpoint of line K as shown in Figure 1-40.

23. Move the cursor downwards. Using the left mouse button, specify the endpoint of line L, see
Figure 1-40.

24. Move the cursor to the right of the sketch and using the left mouse button, specify the
endpoint of line M as shown in Figure 1-40.

25. Move the cursor downwards to draw line
N. Using the left mouse button, specify
the endpoint of line N at the point you
started from. Press the middle mouse
button to end line creation.

The sketch is completed and is shown in
Figure 1-40. But, you will notice that
the endpoints of the lines are not joined.
If you are not able to notice it then use
the Zoom In button from the View
toolbar to zoom a particular area on the
graphics screen. As mentioned in the
previous tutorial, the sketch will be closed ~ Figure 1-40 Sketch after drawing all the lines
when you add the dimension. You can

also trim the corners of the sketch to close the corners of the sketch.

Trimming the Corners
To join all the corners in the sketch, you need to trim the corners formed by lines. A sketch can
have an open section in the Sketch mode but in this sketch you need a closed section.

1. Choose the Geom Tools option from the SKETCHER menu in the Menu Manager. The
GEOM TOOLS submenu is displayed.

2. From the GEOM TOOLS submenu, choose the Trim option. The DRAFT TRIM submenu
is displayed. The Corner option is selected by default in this submenu and you are prompted
to select the two entities to be trimmed.

3. Using the left mouse button, select any two lines that form a corner. The two lines are
joined and the corner is now closed.
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4,

Trim all the corners in the sketch so that the sketch becomes a single closed loop.

ﬁ\ Note

\

\ It is not necessary to trim the corners in the sketch to make the sketch a closed loop. When you
dimension the sketch and then modify the dimension values, the sketch is closed automatically.
Howeves; it is recommended to close the sketch by trimming the corners of the sketch.

When you are not using the Intent Manager to draw a sketch, constraints are applied to the
sketch automatically but you can view these constraints only when you choose SKETCHER >
Constraints or when the sketch is regenerated. You cannot apply constraints
manually; therefore you may need to dimension some entities that have equal dimensions. For
example, lines H and F in Figure 1-36 have equal dimensions but you may need to dimension
both of them.

Dimensioning the Sketch

1.

Choose the Dimension option from the SKETCHER menu in the Menu Manager. The
DIMENSION submenu is displayed. The Normal option is selected by default.

Select line A using the left mouse button. The line turns red in color. Now, using the middle
mouse button, place the dimension below the sketch. The dimension appears as sd0, see
Figure 1-41.

Select line B using the left mouse button. Using the middle mouse button, place the
dimension on the left of the sketch. The dimension appears as sd1, see Figure 1-41.

Select line C. Using the middle mouse button, place the dimension at the top of the
sketch. The dimension appears as sd2.

Select lines D and E using the left mouse vl
button. The selected lines turn red in
color. Now, using the middle mouse Sf g [ w0

button place the dimension close to the
vertex where lines D and E join. The ‘f
dimension appears as sd3.

sl 544 vl |

Select line F. Using the middle mouse
button, place the dimension on the left Zdla
of the sketch but inside the sdl

dimension. The dimension appears as IS ¥
sd4.

o 5 e

5417

Similarly, dimension all the entities that Figure 1-41 Skelch afler applying dimensions
are shown in the sketch in Figure 1-41.

Modifying the Dimensions

1.

Choose the Modify option from the SKETCHER menu. The MOD SKETCH submenu is
displayed. As mentioned earlier; you need to select the text of dimensions to modify them.
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Regenerating the Sketch
1.

Select the dimension named sd0 using 10D, 00

the left mouse button. The Message l
Input Window is displayed. Enter the 1294 {?tgln:m 5.0
required dimension value in this window.
Press ENTER. The selected dimension
1s modified on the screen.

e 30,00

Similarly, modify all the dimension W0k
values as shown in Figure 1-42. l

Choose Regenerate from the SKETCHER SRETR e X RN T

menu. 10—
Figure 1-42 Sketch after modifying dimensions

If the sketch is fully dimensioned and

constrained then the Section regenerated successfully. message is displayed in the Message

Area. Figure 1-42 shows the completed sketch with dimensions and constraints.

"\ Note
\
b If Pro/ENGINEER detects that the sketch contains some extra dimensions that are not required

then these extra dimensions are highlighted red in color. You need to delete these dimensions.

Saving the Sketch

Now, the sketch is finished and you need to save the sketch you have created.

1.

2.

3.

Choose the Save the active object button from the File toolbar. The Message =
Input Window is displayed with CO1TUT2-1.SEC, the name of the sketch. This is
the name that you had entered earlier.

Press ENTER. The sketch is saved.

Choose SKETCHER > Done from the Menu Manager to exit the sketcher environment.

Sketch Using the Intent Manager

The following steps outline the procedure for creating this sketch using the Intent Manager:

a.

b.

C.

d.

Create a new object file.
Draw the sketch using the tool button for creating lines.
Dimension the required entities and then modify the dimensions of the sketch.

Save the sketch.

Creating New Object File

Create a new object file and name it c01tut2-2. The procedure to create a new file is the same
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as discussed earlier.

Drawing the Sketch

1.

Choose the Create lines. button from the Right Toolchest. Using the left mouse
button, select a point on the right of the graphics screen and start drawing horizontal M
line A. Here, you will notice that as you draw line A, H symbol is displayed on the

line. This shows that the line drawn is horizontally constrained. Move the cursor towards left
and specify the endpoint of the line.

Move the cursor vertically upwards so that the V constraint appears on the line. When you
get the appropriate size of the line, use the left mouse button to specify the endpoint of
line B. Line B is completed.

Now, continue drawing the remaining lines that are shown in Figure 1-43. When the
sketch is completed, end line creation by using the middle mouse button. You will notice
that the sketched entities are dimensioned automatically as you draw them. These
dimensions are weak dimensions and appear gray in color.

You do not need to trim the corners when you are using the Intent Manager because when
you draw a line, the cursor snaps to the endpoint of the previous line. Hence, all the
corners will be joined.

Dimensioning the Sketch
Weak dimensions are already applied to the sketch while drawing. You need to dimension only
the angular dimension that is between lines D and E.

1.

Choose the Create defining dimension. button. [
Select lines D and E using the left mouse button. The selected lines turn red in color. Now,
using the middle mouse button, place the dimension close to the vertex where lines D and
E join.

Applying the Constraints to the Sketch

Constraints are applied to the sketch to maintain the design intent of the feature and this
might sometimes result in less dimensions in the sketch.

1.

Choose Impose sketcher constraints on the section. button from the Right
Toolchest. The Constraints dialog box is displayed. =

Choose the Create Equal Lengths, Equal Radii, or Same Curvature constraint EI
button and select lines F and H. The equal length constraint L, is applied to both
the lines. The constraint labels like L, or L, vary from sketch to sketch.

Select lines C and K. The equal length constraint is applied to both the lines.

Now, select lines | and N. The equal length constraint is applied to both the lines.
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Choose the Make line or two vertices horizontal button from the Constraints |
dialog box. You will be prompted to select a line or two vertices.

Select the vertex that is joining lines L. and M and the vertex that is joining lines G and H.
Both the vertices are aligned horizontally as shown in Figure 1-43.

Modifying the Dimensions

1.

2.

Choose the Select one item at a time - shift to gather more than one item. button. k

Select all the dimensions using the SHIFT +left mouse button.

When all the dimensions turn red in color, choose the Modify the values of = —u
dimensions, geometry of splines, or text entities. button. The Modify =
Dimensions dialog box is displayed.

Clear the Regenerate check box and then modify the values of the dimensions. When you
clear this check box, the sketch is not regenerated as you modify the dimensions.

You will notice that the dimension you select in the Modify Dimensions dialog box is
enclosed in a yellow box on the graphics screen.

When all the dimensions are modified, choose the Regenerate the section and
close the dialog button from the Modify Dimensions dialog box. A message
Dimension modifications successfully completed. is displayed in the Message

Area.

The completed sketch is shown in Figure 1-44. When you are sketching with Intent Manager
on, the sketch is automatically regenerated after the dimensions are modified.

Save the sketch as discussed earlier. After saving the sketch, choose the Continue ‘f |
with the current section. button to exit the Sketch mode.

m ) 4 0 1)
. ! — ] Hlg H
Is'-' Y sp. ga | regaanfLifLlz
N
" ¥
Y 31,00
Lyl v v [l2 wo.on ¢ |Lta|v WLy
H H H H
Lifv Lifw
H H
M ld':'.[llll’-l a1 9 00
b JE0.00 ————]

Figure 1-43 Skeich with weak dimensions and — Figure 1-44 Completed sketch with dimensions
weak constraints and constraints
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"\ Note
\

\ You can modify dimensions individually when the Intent Manager is on. Bul, individual
modification of dimension is recommended only when either there is minor change in the dimension
value or when only one dimension is required to be modified.

Tutorial 3

In this tutorial you will draw the sketch shown in Figure 1-45. Draw the sketch both without
using the Intent Manager and using the Intent Manager. For your reference, all the entities in
the sketch are assigned alphabetical labels. (Expected time: 30 min)

@120

@55
R60

| 200

Figure 1-45 Sketch for Tutorial 3 with dimensions and labels for
identification

Sketch Without Using the Intent Manager

The following steps outline the procedure for creating this sketch without using the Intent
Manager:

a. Set the working directory and create a new object file.
b. Turn off the Intent Manager and draw the sketch using the sketcher options.
c.  Dimension the sketch and then modify the dimensions of the sketch.

d. Regenerate the sketch.

Setting the Working Directory

The working directory was selected in Tutorial 1, therefore there is no need to select the
working directory again. But if you still want to select the working directory, choose the Set
Working Directory option from the File menu. The Select Working Directory dialog box is
displayed. Set the working directory to C:\ProE\c01.
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Creating New Object File

1.

Choose the Create a new object button from the File toolbar. The New dialog box [
is displayed. Select the Sketch radio button from the Type area of the New dialog
box. A default name of the sketch appears in the Name edit box.

Enter c01tut3-1 in the Name edit box. Choose the OK button.
You will enter the sketcher environment of the Sketch mode. When you enter the sketcher

environment, the Intent Manager is on. To exit the Intent Manager, choose the Intent
Manager option in the Sketch menu. The Sketch menu is available on the menu bar.

Drawing the Sketch

1. Choose the Circle option from the GEOMETRY submenu in the Menu Manager. The
CIRCLE TYPE submenu is displayed with the Geometry and the Center/Point options
selected by default. You are prompted to select the center of circle.

2. Sketch two circles P and QQ some distance apart as shown in Figure 1-46.

3. Choose the Concentric option from the CIRCLE TYPE submenu. You will be prompted
to select an arc.

4. Select circle P and using the left mouse button select a point inside circle P. A red
rubber-band circle is attached to the cursor. Size the circle and complete it by using the
left mouse button, see Figure 1-46.

5. Press the middle mouse button. Now, you are again prompted to select an arc.

6. Using the left mouse button, select circle Q. Use the left mouse button to select a point
inside circle Q. A red rubber-band circle is attached to the cursor. Size the circle and complete
it by using the left mouse button, see Figure 1-46.

7. Choose the Line option from the GEOMETRY submenu in the Menu Manager. The
LINE TYPE submenu is displayed.

8. Choose the 2 Tangent option from this submenu. Select circles P and Q on the circumference
at the top of the circles. Tangent R is drawn, see Figure 1-47.

9. Similarly, draw tangent S to the circles as shown in Figure 1-47. These two tangents intersect
the circles at the tangent points. The circles are now divided into two entities.

10. Delete the part of the circles that is not required by using the Delete option from the
SKETCHER menu, see Figure 1-47.

"\ Note

\

\ Ifyou draw the tangents using 2 Points option then the circles will not be intersected and hence
you cannot delete the part of the circle shown in the Figure 1-47.
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Delete Delete
P
Q

Figure 1-46 Two sets of circles in the sketch

Dimensioning the Sketch
In order to regenerate the sketch, it should be dimensioned.

1.

2.

Figure 1-47 Tangent lines and the part of the circle
to be deleted

Choose the Dimension option from the SKETCHER menu in the Menu Manager.

Using the left mouse button, select the
left arc and use the middle mouse button
to place the dimension as shown in
Figure 1-48. The dimension appears as
sd0.

Using the left mouse button, select circle
X twice and place the dimension as
shown in Figure 1-48. This dimension
appears as sd1.

Using the left mouse button, select the
right arc and use the middle mouse
button to place the dimension. The
dimension appears as sd2.

wd§
uf2

I 5ddq

Figure 1-48 Dimensions of the sketch

Using the left mouse button, select circle Y twice and place the dimension. This dimension

appears as sd3.

Select the two centers of the circles and using the middle mouse button place the dimension.

The dimension appears as sd4.

Modifying the Dimensions
Choose the Modify option from the SKETCHER menu. The MOD SKETCH submenu is
displayed. The Mod Entity option is selected by default.

1.
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2. Select the text sd0. The Message Input Window appears.
3. Enter a value of 90 in the Message Input Window and press ENTER.

4. Select the text sd1. The Message Input Window appears. Enter a value of 120 in this
window and press ENTER.

5. Select the text sd2. The Message Input Window appears. Enter a value of 60 in this
window and press ENTER.

6. Select the text sd3. The Message Input Window appears. Enter a value of 55 in this
window and press ENTER.

7. Select the text sd4. The Message Input Window appears. Enter a value of 200 in this
window and press ENTER.

Regenerating the Sketch
After all the dimension values are modified,
you need to regenerate the sketch.

15.0F
i1 0n

1. Choose SKETCHER > Regenerate. If the
sketch is fully dimensioned and
constrained the Section regenerated
successfully. message is displayed in the
Message Area.

The sketch after regeneration is shown in

Figure 1-49. Figure 1-49 Skeich with dimensions and

constraints

Saving the Sketch

You have to save the sketch because you may need the sketch later. This sketch is required in
Tutorial 1 of Chapter 2.

1. Choose the Save the active object button from the File toolbar. The Message =
Input Window is displayed with the name of the sketch that you had entered
while creating the file.

2. Press ENTER. The sketch is saved.

3. Choose the Done option to exit the Sketch mode.

Sketch Using the Intent Manager

The following steps outline the procedure for creating this sketch using the Intent Manager:

a. Set the working directory and create a new object file.
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b. Draw the sketch using the sketcher tool buttons.
c.  Dimension the sketch and then modify the dimensions of the sketch.
d. Save the sketch.

The steps Setting the Working Directory and Creating New Object File are the same as
when you work without using the Intent Manager. When you create a new object file, the
system takes you to the sketcher environment and the Intent Manager is on by default. In
this method of sketching, the entities are dimensioned and constraints are applied
automatically as you draw.

Create a new object file with the name c01tut3-2.

Drawing the Arcs

1. Choose the black arrow on the right of the Create an arc by 3 points or tangent to
an entity at its endpoint. button to display the flyout. From this flyout, choose the ﬂ
Create an arc by picking its center and endpoints. button.

2. Select the center of the left arc on the graphics screen, a temporary circle of varying size
appears on the graphics screen.

3. Using the left mouse button, specify the start point of the arc and then specify the endpoint
of the arc. The arc should extend more than a semicircle. You should note that when you
specify the endpoint, the start point and the endpoint should lie vertically in the same
line. For this purpose, a weak constraint is automatically applied. This arc is shown in
Figure 1-50.

4. Similarly, create the right arc. The center of the two arcs should lie on the same horizontal
line. This arc should be less than a semicircle. The start point and the endpoint of this arc
should lie vertically on the same line. This arc is shown in Figure 1-50.

Drawing the Lines
1. Choose the Create lines. button. Draw the two lines that connects the two arcs. \

2. After both the lines are drawn, press the middle mouse button to end line creation. Some
weak dimensions and constraints are applied to the sketch as shown in Figure 1-51.

Applying Constraints

As evident from Figure 1-51, the tangent constraints are applied automatically to some points.
You will apply the tangent constraint to the sketch where required. The tangent constraint is
denoted by symbol T on the graphics screen. You should note that if some constraint is already
applied to a point while sketching and you apply some other constraint on the same point
then the Resolve Sketch dialog box is displayed. This dialog box lists all the constraints that
are conflicting. Using this dialog box you can either undo the constraint you applied or select a
constraint from the list and choose the DELETE button.
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Figure 1-50 The two arcs with weak dimensions

and constraints Figure 1-51 Arcs joined by lines and the

tangent constraint is automatically applied

1. Choose the Impose sketcher constraints on the section. button. The Constraints
dialog box is displayed.

2. Choose the Make two entities tangent button from the dialog box. & |

3. Select line R and arc Q. The tangent constraint is applied to the line and the arc. If the
constraint is already applied, the Resolve Sketch dialog box will be displayed. Choose the
Undo button from this dialog box to undo the constraint.

4. Similarly, select line S and arc Q to apply the constraint. Then select line R and arc P to
apply the constraint and then select line S and arc P.

Drawing the Circles

1. Choose the black arrow on the right of the Create circle by picking the center |
and a point on the circle. button to display the flyout. From this flyout, choose the
Create concentric circle. button. You will be prompted to select an arc.

2. Select arc P and create circle X concentric to the arc. Similarly, select arc Q to create circle
Y.

Dimensioning the Sketch
1. Choose the Create defining dimension. button. had
2. Select the center of two circles and place the dimension at the bottom of the sketch.

Modifying the Dimensions
1. Choose the Select one item at a time - shift to gather more than one item. button. h

2. Select all the dimensions using the SHIFT +left mouse button.
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"2\ Note
| You can also use CTRL+ALT+A from the keyboard to select all the entities and items in the
sketch.
3. When all the dimensions turn red in color, choose the Modify the values of = —u

dimensions, geometry of splines, or text entities. button. The Modify Dimensions
dialog box is displayed.

4. Clear the Regenerate check box and then modify the values of the dimensions.

You will notice, that the dimension you edit in the Modify Dimensions dialog box is
enclosed by a yellow box dimension on the graphics screen.

5. When all the dimensions are modified, choose the Regenerate the section and
close the dialog button from the Modify Dimensions dialog box. A message
Dimension modifications successfully completed. is displayed in the Message
Area.

The sketch is completed and is shown in Figure 1-52.

6. Save the sketch as discussed earlier. After saving the sketch, choose the Continue Vf
with the current section. button to exit the Sketch mode.

2000

120,00 3.0

B

Figure 1-52 Sketch with dimensions and constraints
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Self-Evaluation Test

Answer the following questions and then compare your answers to the answers given at the
end of this chapter.

1. The sketch considers the default sketch constraints when working with the Intent Manager
kept off. (T/F)

2. While working in the Sketch mode of Pro/ENGINEER the section sketch need not be a
closed loop for successful regeneration. (T/F)

3. If the Intent Manager is on and you draw a line then the cursor snaps to the endpoint of
the previous line. (T/F)

4. When you are in the middle of sketch creation you cannot turn on the Intent Manager. (1/F)

5. The options available in the LINE TYPE submenu are different when you select Geometry
and Centerline individually. (T/F)

6. The submenu has the Mirror option in it.

7. controls the design intent of a model.

8. Intent Manager is by default when you enter the Sketch mode.

9. For the Sketch mode the symbolic dimension is represented by symbol.

10. The Sketch mode file is saved as file extension.

Review Questions

Answer the following questions:

1.

2.

What is the need of Sketch mode in Pro/ENGINEER?

What are the four basic steps to create a sketch?

What are the different types of line types you can sketch using the Line option?
Why is it important to select the working directory before creating a new file?

Write all the steps involved in successful regeneration of a sketch when the Intent Manager
is off.

Relations can be added in the Sketch mode. (T/F)
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7. You can use the Create rectangle. button from the Right Toolchest to draw a square. (T/F)
8. The button is used to exit the sketcher environment. (T/F)
9. You cannot undo a previous operation in the sketcher environment. (T/F)

10. You can also use the options to draw a sketch from the Sketch menu in the menu bar. (T/F)

Exercise 1

Create the sketch as shown in Figure 1-53 using the Intent Manager and without using the
Intent Manager.
(Expected time: 30 min)

365

Figure 1-53 Figure for Exercise 1

Exercise 2

Create the sketch shown in Figure 1-54 using the Intent Manager and without using the
Intent Manager. (Expected time: 30 min)
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Figure 1-54 Figure for Exercise 2
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Exercise 3

Create the sketch as shown in Figure 1-55 using the Intent Manager.
(Expected time: 30 min)

Figure 1-55 Figure for Exercise 3

Exercise 4

Create the sketch as shown in Figure 1-56 using the Intent Manager.
(Expected time: 30 min)
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Figure 1-56 Figure for Exercise 4

Answers to Self-Evaluation Test
1-T,2-T,3-T,4-T,5-F 6 - GEOM TOOLS, 7 - Intent Manager, 8 - on, 9 - sd, 10 - .sec



