Chapter 20

Working with Data
Exchange & Object
Linking and Embedding

Learning Objectives

After completing this chapter, you will be able to:

* Import and export .dxf files using the Save As and Open tools
* Attach the raster images to the current drawing
* Edit raster images

* Understand the embedding and linking functions of the OLE feature of Windows
* Learn about the DWG Convert and Content Explorer

Key Terms

* DXF Files
* DWG Convert

* BMP Files e EPS Files

* Draw Order
* Attach Image * OLE Objects

¢ Content Explorer
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UNDERSTANDING THE CONCEPT OF DATA EXCHANGE
IN AutoCAD LT

Different companies have developed different softwares for applications such as CAD, desktop
publishing, and rendering. This non-standardization of softwares has led to the development
of various data exchange formats that enable the transfer (translation) of data from one
data processing software to the other. This chapter will cover various data exchange formats
provided in AutoCAD LT. AutoCAD LT uses the .dwg format to store drawing files. This format
is not recognized by most other CAD software such as Intergraph, CADKEY, and Microstation.
To resolve this issue, AutoCAD LT has provided a data exchange format that is DXF (Data
Interchange Format).

CREATING DATA INTERCHANGE (DXF) FILES

The DXF file format generates a text file in ASCII code from the original drawing. This allows
any computer system to manipulate (read/write) data in a DXF file. Usually, the DXF format is
used for CAD packages based on microcomputers. For example, packages like SmartCAM use
DXEF files. Some desktop publishing packages, such as PageMaker and Ventura Publisher, also
use DXF files.

Creating a Data Interchange File

Using the Save or SaveAs tool, you can create an ASCII file with a .dxf extension from an
AutoCAD LT drawing file. Once you invoke any of these tools, the Save Drawing As dialog
box is displayed. You can also use the -WBLOCK command. The Create Drawing File dialog
box is displayed, where you can enter the name of the file in the File name edit box and select
any version of DXF [*dxf] from the Files of type drop-down list. By default, the DXF file to be
created assumes the name of the drawing file from which it will be created.

Next, choose the Save As button from the File menu; the Save Drawing As dialog box will be
displayed. In the Save Drawing As dialog box, choose the Tools button to display the flyout.
In the flyout, choose Options to display the Saveas Options dialog box, see Figure 20-1. In
this dialog box, choose the DXF Options tab and enter the degree of accuracy for the numeric
values. The default value for the degree of accuracy is sixteen decimal places. You can enter a
value between 0 and 16 decimal places.

A Saveas Options x

DWG Options  DX¥F Options

Format
(®) ASCIl [] Select objects
() BINARY Save thumbnail preview image

Decimal places of accuracy (D to 16)
Cancel Help

Figure 20-1 The Saveas Options dialog box
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In the DXF Options tab, you can also select the Select objects check box, which allows you to
specify the objects to be included in the DXF file. In this case, the definitions of the named
objects such as block definitions, text styles, and so on are not exported.

Select the ASCII radio button. Choose OK to return to the Save Drawing As dialog box. Choose
the Save button here. Now, an ASCII file with a .dxf extension has been created, and this file can
be accessed by other CAD systems. This file contains data on the objects specified. By default,
DXEF files are created in the ASCII format. However, you can also create binary format files by
selecting the BINARY radio button in the Saveas Options dialog box. Binary DXF files are more
efficient and occupy only 75 percent of the ASCII DXF file. You can access a binary format file
more quickly than an ASCII format file.

Information in a DXF File

The DXF file contains data of the objects which are specified using the Select objects check box
in the Saveas Options dialog box. You can change the data in this file as per your requirement.
To examine the data in this file, load the ASCII file in the word processing software. A DXF file
is composed of the following parts.

Header
In this part of the drawing database, all variables in the drawing and their values are displayed.

Classes
This section deals with the internal database.

Tables

All named objects such as linetypes, layers, blocks, text styles, dimension styles, and views are
listed in this part.

Blocks

The objects that define blocks and their respective values are displayed in this part.

Entities
All entities in the drawing, such as lines, circles, and so on, are listed in this part.

Objects

Objects in the drawing are listed in this part.

Converting DXF Files into Drawing Files

You can import a DXF file into a new AutoCAD LT drawing file with the Open tool. After you
invoke the Open tool, the Select File dialog box is displayed. From the Files of type drop-down
list, select DXF [*.dxf]. In the File name edit box, enter the name of the file you want to import
into AutoCAD LT or select the file from the list. Choose the Open button. Once this is done,
the specified DXF file is converted into a standard DWG file, regeneration is carried out, and
the file is inserted into the new drawing. Now, you can perform different operations on this file
just as with the other drawing files.
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f . Tip
Q A data interchange file (DXF) can also be inserted into the current drawing using the Insert tool.

Note
You can import files such as .wmf, .dgn, and .pdf in AutoCAD LT with the help of IMPORT
command.

Importing PDF Files EIV\
Ribbon: Insert > Import > PDF Import Command: PDFIMPORT %“

You can import the geometry, raster images, fills, and true type text objects from a PDF file into
the current drawing as AutoCAD LT objects. To do so, choose the PDF Import tool from the
Import drop-down list in the Import panel of the Insert tab; you will be prompted to select
PDF underlay or file. To import data from a PDF file, choose File from the command prompt;
the Select PDF File dialog box will be displayed. Now select a PDF file from this dialog box and
choose the Open button; the Import PDF dialog box will be displayed, as shown in Figure 20-2.

A Import PDF x
File name: |Machiner3f5 Handbook 29th Edition (2012).pdf |
Page to import Location
Page: Total: 3915 [] Specify insertion point on-screen
Scale: Rotation:
PDF data to import Layers
Vector geometry @) Use PDF layers
Solid fills () Create object layers
TrueType text ) Current layer

[] Raster images

Import opticns
(| Import as block
Join line and arc segments
[] Convert solid fills to hatches
Apply lineweight properties

[1 Infer linetypes from collinear dashes
Page size: 7 x 10 inches PDF scale: 1:1

(o] (o ] (o]

Figure 20-2 The Import PDF dialog box

Enter the page number in the Page edit box in the Page to import area of the Import PDF
dialog box. To specify the scale, rotation, and point of insertion of the imported geometry,
choose the respective options in the Location area. You can also choose the type of data to be
imported using the options available in the PDF data to import area. The options under the
Import options area are discussed next.

You can join 2D solids with the coincident edges and convert them to hatch objects by selecting
the Convert solid fills to hatches check box. Choose the Apply lineweight properties
check box to apply the lineweights of the PDF to the extracted geometry. You can choose the
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Infer linetypes from collinear dashes check box to collect collinear dash and dot segments,
and then replace them with a single polyline. If you uncheck this check box, each segment in
a dashed line will be imported as a seperate polyline. Choose the Options button from the
bottom of the Import PDF dialog box; the Options dialog box will be displayed. In this dialog
box you can specify the file location for image files that are extracted from the PDF and attached
to the drawing.

Creating and Using a Windows Metafile
Application Menu: Export > Other Formats Command: EXPORT, WMFOUT

The Windows Metafile format (WMF) file contains screen vector and raster graphics format. In
the Export Data dialog box or in the Create WMF File dialog box, enter the file name. Select
Metafile [*.wmf] from the Files of type drop-down list. The extension .wmfis appended to the
file name. Next, save the settings and then select the objects you want to save in this file format.

The WMFIN command displays the Import WMF dialog box. Window metafiles are imported
as blocks in AutoCAD LT. Select the .wmf file you want to import and choose the Open button.
Specify an insertion point, rotation angle, and scale factor. Specify the scaling by entering a scale
factor using the corner option to specify an imaginary box whose dimensions correspond to the
scale factor, or by entering xyz to specify 3D scale factors.

Creating and Using a V8 DGN File
Application Menu: Export > DGN Command: EXPORT, DGNEXPORT

The V8 DGN (.DGN) file format is used by the Microstation software. A *.dwg file created in
AutoCAD LT can be exported to Microstation using this format. To do so, choose Export > DGN
from the Application Menu; the Export DGN File dialog box will be displayed. Enter a file
name in the File name edit box. From the Files of type drop-down list, select V8 DGN (*.dgn)
and then choose the Save button; the Export DGN Settings dialog box will be displayed. In
this dialog box, you can specify how the externally referenced files in the current drawing are
taken care of when converting the current drawing into the DGN file. You can also specify the
seed files (standard template files containing the settings for the units to be used for conversion,
working units, resolution of the drawing, and so on) to be used for conversion in this dialog box.

To import a DGN file, choose Open > DGN from the Application Menu; the Import DGN File
dialog box will be displayed. Alternatively, you can use the DGNIMPORT command to import
a DGN file. From the Files of type drop-down list, select the MicroStation DGN [*.dgn] option.
Next, select or enter the name of the design file and choose the Open button; the Import DGN
Settings dialog box will be invoked. You can exchange the data of the drawing files and design
files using the Export/Import DGN Settings dialog box. For example, you can translate DGN
elements to DWG objects, Levels to Layers, Line Styles to Linetypes, Cells to Blocks, Sheet
Model to DWG Layouts, etc. You can save and reuse, modify, rename or delete the mapping
translations using the DGNMAPPING command.
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Creating a BMP File
Application Menu: Export > Other Formats Command: EXPORT, BMPOUT

This is used to create bitmap images of the objects in your drawing. In the Export Data dialog
box, enter the name of the file, select Bitmap [*.bmp] from the Files of type drop-down list
and then choose Save. Select the objects you wish to save as bitmap and press ENTER. Entering
BMPOUT displays the Create Raster File dialog box. Enter the file name and choose Save.
Select the objects to be saved as bitmap. The file extension .bmp is appended to the file name.

RASTER IMAGES

A raster image consists of small square-shaped dots known as pixels. In a colored image, the
color is determined by the color of pixels. The raster images can be moved, copied, or clipped.
They will used as a cutting edge with the Trim tool. They can also be modified by using grips.
You can also control the image contrast, transparency, and quality of the image. AutoCAD LT
stores images in a special temporary image swap file whose default location is the Windows Temp
directory. You can change the location of this file by modifying it under Temporary Drawing
File Location in the Files tab of the Options dialog box.

The images can be 8-bit gray, 8-bit color, 24-bit color, or bitonal. When the image transparency
is set to On, the image file formats with transparent pixels is recognized by AutoCAD LT and
transparency is allowed. The transparent images can be in color or grayscale. AutoCAD LT
supports the formats given next.

Image Type File Extension Description

BMP .bmp, .dib, .rle Windows and OS/2 Bitmap Format

JFIF 5.0 or JPEG  jpg, jpeg Joint Photographics Expert group

PCX pex Picture PC Paintbrush Picture

PNG png Portable Network Graphic

Dimensional

CALS cal Computer Aided Acquisition and
Logistics Support

Uncompressed

TGA 1ga True Vision Raster based Data format

TIFF/LZW uf aff Tagged image file format

When you store images as Tiled Images, that is, in the Tagged Image File Format (TIFF), you
can edit or modify any portion of the image; only the modified portion is regenerated, thus
saving time. Tiled images load much faster as compared to the untiled images.
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Attaching Raster Images

Ribbon: Insert > Reference > Attach
Toolbar: Reference > Attach Image or Insert > Attach Image Command: IMAGEATTACH

Attaching Raster images does not make them part of a drawing. To attach an image, choose
the Attach tool from the Reference panel in the Insert tab; the Select Reference File dialog
box will be displayed, as shown in Figure 20-3. Select the image to be attached; a preview of the
selected image will be displayed in the Preview area of the dialog box. Next, choose the Open
button; the Attach Image dialog box will be displayed, as shown in Figure 20-4. The name of
the selected image is displayed in the Name drop-down list. You can select another file by using
the Browse button. The Name drop-down list displays the names of all the images in the current
drawing. Select the Specify on-screen check boxes to specify the Insertion point, Scale, and
Rotation Angle on the screen. Alternatively, you can clear these check boxes and enter values in
the respective edit boxes. Choosing the Show Details button expands the Attach Image dialog
box and provides the image information such as the Horizontal and Vertical resolution values,
current AutoCAD LT unit, and Image size in pixels and units. Choose OK to return to the
drawing screen.

A Select Reference File *
Loak in: eps v & E} (ﬁ x El Mews + Tools w
=0 Name . Date modified ~ Preview
:J = Snap.tif 8/5/2016 11:24
5] Snap tif 8/5/2016 11:26
m = Snap3.tif 8/5/2016 11:27
|:':] =] Snapd.tif 8/5/2016 11:28
& Snap5.tif 8/5/201611:29
(& Snapb.gif 8/5/2016 11:30
\{ 5] Snap7 tif 8/5/2016 11:34
= Snapd.tif 8/9/2016 10:29
12
€ >
File pame: Snapb tf ~v|  Open ¥
Files of type: | Allimage files ~ Cancel

Figure 20-3 The Select Reference File dialog box

You can also attach and scale an image from the Internet. In the Select Reference File dialog
box, choose the Search the Web button. Once you have located the image file you wish to attach
to the current drawing, enter the URL address in the Look in drop-down list and the image file
name in the Name or URL edit box. Choose the Open button twice. Specify the insertion point,
scale, and rotation angle in the Attach Image dialog box. You can also right-click on the image
you wish to attach to the current drawing and choose Properties from the shortcut menu to
display the Properties window. From here, you can select, cut, and paste the URL address in
the File name edit box of the Select Reference File dialog box.
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A Attach Image *
MName: Snapb it Browse...
Preview Path type Scale
Full path " Specify on-screen
1.0000
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Specify on-screen Rotation
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Show Detals Cancel Help

Figure 20-4 The Attach Image dialog box
Managing Raster Images

Ribbon: View > Palette > External References Palette = Command: IMAGE
Toolbar: Reference > External References Menu Bar: Insert > External References

Choose the External References Palette button from the Palettes panel; the EXTERNAL
ﬁ REFERENCES palette will be displayed (Figure 20-5). If the image has not been inserted

earlier, right-click in the File References area and choose Attach Image from the
shortcut menu. You can view the image information either as a list or as a tree view by choosing the
respective buttons located at the right corner of the File References head of the EXTERNAL
REFERENCES palette. The List View displays the names, loading status, size, date last modified
on, and search path of all images in the drawing. The Tree View displays images in hierarchy,
which shows its nesting levels within blocks and Xrefs. The Tree View does not display the status,
size, or any other information about an image file. You can rename an image file in this dialog
box.

Preview

To display the Preview area, choose the Preview button located at the right corner of the
Details head. In this area, you can see the preview of the image. This area displays the preview
of the image file attached to the current drawing and the file details of the attached image file.
To get the file details, choose the Details button located adjacent to the Preview button. The
information about the image file such as file name, saved path, and so on will be listed, as shown
in Figure 20-6. Once you have referenced the current drawing to an image file, you can replace
it with another image file by using the Saved Path edit box. To do so, choose the Browse [...]
button in the corner of the edit box to display the Select Image File dialog box. Browse and
select the image file and then choose the Open button. Now, the new path will be displayed in
the Saved Path edit box. Also, the location of the image file will automatically be updated in
the Found At edit box.



Working with Data Exchange & Object Linking and Embedding 20-9

W DT

File References = i
Reference ... a | Status Siz

E Drawing Opened

E‘ Tulips Loaded 600

Details BE -
Status Loaded A
Size GG KB

Type IPG

Date 1472009 11:02:32 4

Details B -

< >

[ EXTERNAL REFERENCES
[ EXTERNAL REFEREMCES

Figure 20-5 The EXTERNAL Figure 20-6 The Details area of the
REFERENCES paleite EXTERNAL REFERENCES palette

) Tip
Q You can also use the Command prompt for managing the image files using the -IMAGE
command. Except the Open option, all the other options of the EXTERNAL REFERENCES
palette will be available in the Command prompt.

When you select the name of the attached image and right-click on it, the shortcut menu will
be displayed. The options in this shortcut menu are discussed next.

Open
This option enables you to open the attached image in its default viewing software from its
current location in the AutoCAD LT file.

Attach

This option allows you to attach an image file with the current drawing. You can also attach an
image file by choosing the Attach Image option from the flyout on the upper left corner of the
EXTERNAL REFERENCES palette; the Select Reference File dialog box will be displayed.
Select the file that you want to attach to the drawing and the selected image is displayed in the
Preview box. Choose the Open button; the Attach Image dialog box is displayed. The name of
the file and its path and extension are displayed in the Attach Image dialog box. You can use
the Browse button to select another file. Choose the OK button in the Attach Image dialog box
and specify a point to insert the image. Next, AutoCAD LT will prompt you to enter the scale
factor. You can enter the scale factor or specify a point on the screen.
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Detach
This option detaches the selected and all associated raster images from the current drawing.
Once the image is detached, no information about the image is retained in the drawing.

Reload
The Reload option simply reloads an image. The changes made to the image since the last
insert will be loaded on the screen.

Unload

The Unload option unloads an image. An image is unloaded when it is not needed in the
current drawing session. When you unload an image, AutoCAD LT retains information about
the location and size of the image in the database of the current file. Unloading a file does not
unlink the file from the drawing and the image frame is displayed. If you reload the image, the
image will appear at the same point and in the same size as the image was before unloading.
Unloading the raster images enhances AutoCAD LT performance. Also, the unloaded images
are not plotted. If multiple images are to be loaded and the memory is insufficient, AutoCAD
LT automatically unloads them.

EDITING RASTER IMAGE FILES

Raster image files can be easily edited. The different methods to edit raster image files are
discussed next.

Clipping Raster Images

Ribbon: Insert > Reference > Clip Toolbar: Reference > Clip Image
Menu Bar: Modify > Clip > Image Command: IMAGECLIP

[=| The Clip tool is used to clip the boundaries of images and to provide a desired shape to
‘_-I them. To invoke this tool, select the image to be clipped; the Image tab will be added to

the Ribbon. Choose the Create Clipping Boundary tool; you will be prompted to specify
the boundary. Specify a rectangular or polygonal boundary; the image will be clipped at the
specified boundary. Also, an arrow will be displayed pointing inside the clipping boundary. Click
on the arrow to flip the clipping direction.

You can also invoke this tool by selecting an image to be clipped, right-clicking, and choosing
Image > Clip from the shortcut menu displayed.

After choosing this tool, AutoCAD LT will prompt you to select the image to be clipped. Select
the raster image by selecting the boundary edge of the image. The image boundary must be
visible to select it. The clipping boundary must be specified in the same plane as the image or
a plane that is parallel to it. The following prompt sequence is displayed when you choose the
Clip tool from the Reference panel.

Select Object to clip: Select the image.
Enter image clipping option [ON/OFF/Delete/New boundary] <New>:
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New boundary

This option is used to define a boundary for clipping the image. When you invoke this option,
you will be prompted to specify whether or not you want to delete the old boundary, if a boundary
already exists. If you enter No at the Delete old boundary? [No/Yes] <Yes> prompt, this
command will end. You can enter Yes to specify the new clipping boundary. The boundary can
be defined in a rectangular shape or a polygonal shape.

ON

This option is used to turn the image clipping on. The image will be clipped using the last
boundary.

OFF

This option is used to turn the image clipping off. If you have a clipped image, you can redisplay
the entire image.

Delete
This option is used to delete the existing clipping boundary.

One such clipping is shown in Figures 20-7 and 20-8. Figure 20-7 shows the actual image and
Figure 20-8 shows the clipped image where the clipping boundary is created by using the
midpoints of all the four sides of the image.

Figure 20-7 Image before clipping Figure 20-8 Image afler clipping

¢ . Tip

Q You can improve the performance by twrning on or off the image highlighting visible on selecting
an image. You can also use the IMAGEHLT system variable. By default, IMAGEHLT s set
to 0, that is, only the raster image frame will be highlighted.

Adjusting Raster Images

Ribbon: Insert > Reference > Adjust Menu Bar: Modify > Object > Image > Adjust
Toolbar: Reference > Adjust Image Command: IMAGEADJUST/ADJUST

E The Adjust tool allows you to adjust the brightness, contrast, and fade of a raster image.
®:%  On selecting an attached image, the Image tab will be added to the Ribbon. Adjust the
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brightness, contrast, and fade using the corresponding option in the Adjust panel of the Image
tab.

Alternatively, choose Adjust Image from the Reference toolbar to invoke the Image Adjust
dialog box (Figure 20-9). This dialog box is used to adjust an image. As you adjust the brightness,
contrast, or fade, the changes are dynamically made in the image. If you choose the Reset button,
the values will be returned to the default values (Brightness= 50, Contrast= 50, and Fade= 0).
You can also choose Properties in the shortcut menu to display the Properties palette. In this
palette, you can enter new values of brightness, contrast, and fade. If you choose the Adjust tool
from the Reference panel, you need to set the values in the Command prompt.

A Image Adjust *

Brightness Snap2

Dark 4 Light
Contrast

Low . High
Fade

Mir . Mae Ij|

Reset oK Help

Figure 20-9 The Image Adjust dialog box

Modifying the Image Quality

Menu Bar: Modify > Object > Image > Quality Command: IMAGEQUALITY
Toolbar: Reference > Image Quality

Eﬂ The Quality tool allows you to control the quality of the image that affects the display
Bill performance. To control the quality, choose the Quality tool from Modify > Object >
Image in the Menu bar; you will be prompted to specify the quality of image. A high-quality
image takes a longer time to display. When you change the quality, the display changes
immediately without causing a REGEN. The images are always plotted using a high-quality
display. Although draft quality images appear grainier, they are displayed more quickly.

Modifying the Transparency of an Image

Toolbar: Reference > Image Transparency Command: TRANSPARENCY
Menu Bar: Modify > Object > Image > Transparency

E' When you attach an image with transparent background to a drawing, the transparent
background turns opaque. To control the transparency of the attached image, select it;
the Image tab will be added to the Ribbon. Choose the Background Transparency button

from the Options panel in the Image tab to turn on the transparency of the image; the
background of the image will become transparent. The TRANSPARENCY command can also
be used to control the transparency of an image. Figure 20-10 shows two images one over the
other with the transparency of the top image turned off. Figure 20-11 shows the figure with the
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transparency of the top image turned on. You can also right-click on an image and choose
Properties from the shortcut menu displayed. In the Properties palette, select an option from
the Background Transparency drop-down list displayed under the Misc list.

Note
You have to choose images in such a way that they can give the effect of transparency. Dull and
opaque images will not give the effect of transparency.

| — Transparency OFF Transparency 0N

Figure 20-10 Image before turning the Figure 20-11 Image afier turning the
transparency on transparency on

Controlling the Display of Image Frames

Menu Bar: Modify > Object > Image > Frame Command: IMAGEFRAME
Toolbar: Reference > Image Frame

D The FRAME tool is used to turn the image boundary on or off. This tool can be invoked

from Modify > Object > Image menu. If the image boundary is off, the image cannot

be selected with the pointing device and therefore cannot be accidentally moved or
modified.

CHANGING THE DISPLAY ORDER

Ribbon: Home > Modify > Draw Order drop-down > Bring to Front
Command: DRAWORDER Toolbar: Draw Order

The tools in the Draw Order drop-down (Figure 20-12) of the Modify panel are used to change
the display order of the selected images and other objects.

If you choose the Bring to Front tool, the selected object will be moved to the front of all entities.
If you choose the Send to Back tool, the selected object will be moved behind all entities. If you
choose the Bring Above Objects tool, the selected object will be moved above the referenced
objects. If you choose the Send Under Objects tool, the selected object will be moved under
the referenced objects.

The Bring Text to Front tool can be used to bring all text to the front of all entities. If you
choose Bring Dimensions to Front, all dimensions will come to front of all the entities. The
Send Hatches to Back tool is used to send all the hatches to the back of all entities.
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Figure 20-12 Tools in the Draw
Order drop-down

Other Editing Operations

You can also perform other editing operations such as copy, move, and stretch to edit a raster
image. Remember that you can also use the image as the trimming edge for trimming objects.
However, you cannot trim an image. You can insert the raster image several times or make
multiple copies of it. Each copy can have a different clipping boundary. You can also edit the
image using grips. You can use the Properties window to change the image layer, boundary
linetype, and color, and perform other editing commands such as changing the scale, rotation,
width, and height by entering new values in the respective edit boxes. You can also display an
image or turn off the display by selecting options from the Show Image drop-down list in the
Misc field of the Properties window. If you select Yes, the image is displayed and if you select
No, the display of the image is turned off. You can turn off the display of the image when you
do not need it, thus improving the performance.

Scaling Raster Images

The scale of the inserted image is determined by the actual size of the image and the unit of
measurement (inches, feet, and so on). For example, if the image is 1”7 x 1.26” and you insert
this image with a scale factor of 1, its size on the screen will be 1 AutoCAD LT unit by 1.26
AutoCAD LT units. If the scale factor is 5, the image will be five times larger. The image that
you want to insert must contain the resolution information (DPI). If the image does not contain
this information, AutoCAD LT treats the width of the image as one unit.

DWG Convert

Application Menu: Save As > DWG Convert Command: DWGCONVERT
Menu Bar: File > DWG Convert

The DWG Convert tool is used to convert a single or batch of the AutoCAD LT drawing files
into any previous AutoCAD LT drawing format. You can do the conversion by following the
procedure given next.
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Invoke the DWG Convert dialog box by choosing the DWG Convert tool from the File menu;
the DWG Convert dialog box will be displayed, as shown in Figure 20-13. Choose the Add file
button from the bottom of the Files Tree area; the Select File dialog box will be displayed. Next,
browse to the required location, select the required file/files, and then choose the Open button;
the selected files will be displayed in tree form in the Files Tree area of the DWG Convert dialog
box. Also, a checkbox will be displayed on the left of each drawing file. By default, all the check
boxes are selected. You can clear the check box corresponding to the files that are not to be
converted. You can also view the selected files along with their details such as their path and
location, version, size, date, and so on in the form of a table by choosing the Files Table tab.
If you want to save the current file list, then choose the Save list button; the Save Conversion
List dialog box will be displayed. Save the file list in the desired folder.

A DWG Convert X

51 Curment user: TIET
FHles Tree  Files Table Select a conversion setup

Convert to 2000 folder)
Convert to 2004 (inplace)
Convert to 2007 (inplace)

Convert to 2010 (inplace]
Standard

Setup description

Conversion Setups..

Preview

Included Dfilefs). KB A== =]

View Report Convert Close Help

Figure 20-13 The DWG Convert dialog box

Next, select the version of output file from the Select a conversion setup area; the description
of the conversion setup will be displayed in the Setup description area. You can also specify the
conversion settings, if required, by choosing the Conversion Setups button. This is discussed
in the next head. Now, choose the Convert button at the lower right of the dialog box, the
Conversion Package Creation is in Progress window will be displayed and in a few moments
the files will be converted. Exit the dialog box by choosing the Close button.

You can also open any previously saved file list by using the Open list button. If you choose
this button; the Open Conversion List dialog box will be displayed. Browse to the required file
and choose the Open button; all files in the conversion list will be imported in the Files Tree
area of the DWG Convert dialog box. Later on, you can replace this list with a new list using
the Append List button.

Conversion Setup Options
The Conversion Setup options are used to control the output of the files to be converted. To
modify the conversion settings, choose the Conversion Setups button from the DWG Convert
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dialog box; the Conversion Setups dialog box will be displayed, as shown in Figure 20-14. The
options in this dialog box are discussed next.

A Conversion Setups >

jl Cument user: TIET

Convert to 2000 folder) New
Conwvert to 2004 (inplace)
Convert to 2007 (inplace)
Convert to 2010 imilacei Rename
Standard
Modify...
Delete

Figure 20-14 The Conversion Setups dialog box

New

This button is used to create a new conversion scheme. On choosing this button, the New
Conversion Setup window will be displayed, as shown in Figure 20-15. You can enter the name
of new conversion setup in the New Conversion setup name edit box. Next, select an option
from the Based on drop-down list. Finally, choose the Continue button; the Modify Conversion
Setup dialog box will be displayed. This dialog box is discussed under the Modify button topic.

A New Conversion Setup >

!l Current user: TIET
Mew Conversion setup name

opy of Standard

Based on:
Standard ~

==

Figure 20-15 The New Conversion Setup dialog box

Rename
This button is used to rename the selected conversion setup.

Modify

This button is used to modify the existing conversion settings according to the desired output.
On choosing the Modify button, the Modify Conversion Setup dialog box will be displayed, as
shown in Figure 20-16. Using this dialog box, you can modify conversion settings. The options
in this dialog box are discussed next.
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A Modify Conversion Setup

i Curment user: TIET
Cument conversion setup: Copy of Standard

Conversion type and location
Conversion package type:

Zp "zip)

File Format:

AutoCAD LT 2013/AuteCAD 2012 Drawing Format
Maintain visuzl fidelity for annotative objects  (3)

Conwersion file folder:

Actions

Create backup (*bak) files
[ Convert digialy signed files
[ Check and fix emors
[] Set defautt plotter to none’
[ Bind extemal references

Bind
Insert

‘C ‘\Users\TIETDocumerts V‘ [ e
Conwversion file name: Remove Design Feed
Prompt for a filerame | [JReplace page setups

Page Setups...
Path options

(®) Use organized folder structure
Source root folder
|C \Users\TIET\Documerts ~

() Place all files in one folder
(O Keep files and folders as is

Conversion setup description

Concel | [ Heb

Figure 20-16 The Modify Conversion Setup dialog box

Conversion type and location Area

The options in this area are discussed next.
In-place (overwrite files). This option is used if you want the converted files to be in
the same directory, in which the source files are present. If you want to overwrite the
existing files, this option also allows the software to overwrite the previous files with the
converted new files.

Folder (set of files). This option is used if you want the converted files to be saved in
the specified directory. On selecting this option, the Conversion file folder drop-down
list gets activated. Using this drop-down list, you can browse to the desired folder where
you want to save the converted files.

Zip(*.zip). This option is used to bind all converted drawing files into a zip file, which
can be uncompressed to the specific location later.

Path options Area

The Path options area will be enabled when you select the Folder (set of files) or Zip(*.zip)
option from the Conversion package type drop-down list. In the Path options area, there
are three radio buttons that are explained next.

Use organized folder structure. On selecting this radio button, you can store the
converted files in the specified folder in same organized way as they are present in the
source folder (in Source root folder drop-down).

Place all files in one folder. On selecting this radio button, you can save all converted
files in one folder which is specified as output folder.
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Keep files and folder as is. On selecting this radio button, the files are saved in the
way they were originally present. In other word, the hierarchy remains the same as of
original file location.

Actions Area

In the Actions area, there are 8 check boxes. Description of these check boxes is
given next. Create backup(*.bak) files. This check box will be enabled only when the
In-place (overwrite files) conversion package type is selected. If you select this check box,
then the backup file will also be created with the converted file.

Convert digitally signed files. On selecting this check box, the digitally signed files
will be included in the conversion list.

Check and fix errors. If you select this check box, the errors will automatically be fixed
during the conversion.

Set default plotter to ‘none’. If you select this check box, the plotter for all converted
files will be set to None.

Bind external references. You can bind the external referenced files with the converted
drawing files using this check box. This option has two radio buttons, Bind and Insert.
Bind is used to bind the external referenced file as external object. Insert is used to
bind the external reference as internal object of the drawing.

Purge drawings. Select this check box if you want to purge the drawings.

Replace page setups. Select this check box if you want to replace the page setup of
the converted drawing files with a pre-stored template. To get a pre-stored template,
choose the Page Setups button after selecting the check box; the Page Setups dialog
box will be displayed. Choose the Browse button, and then select a pre-stored template.

Conversion setup description Area
This area is located at the bottom of the dialog box. You can enter the description of the
conversion setup in the Conversion setup description edit box in this area.

Delete
This button is used to delete any of the conversion setup in the list.

WORKING WITH POSTSCRIPT FILES
Command: PSOUT

PostScript is a page description language developed by Adobe Systems. It is mostly used in D'TP
(desktop publishing) applications. AutoCAD LT allows you to work with PostScript files. You
can create and export PostScript files from AutoCAD LT, so that these files can be used for DTP
applications. PostScript images have a higher resolution than raster images. The extension for
these files is .eps (Encapsulated PostScript).
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Creating PostScript Files
As just mentioned, any AutoCAD LI" drawing file can be converted into a PostScript file. This can
be accomplished by using the PSOUT command. When you invoke this command, the Create
PostScript File dialog box is displayed, as shown in Figure 20-17.

Savein:

&

A Create PostScript File

x
r:f‘] Documents - & E} @ b 4 E—,L Miews « Tools
Mame - Date modified Type
AutoCAD LT Sheet Sets 9/2/2016 1200 PM  Filefolder
AutoCAD Sheet Sets 7/4/2016 10:43 AM  Filefolder
Custom Office Templates 772172016 11:08 AM  File folder
SOLIDWORKS Downloads 9/3/2016 10:07 AM  Filefolder
SOLIDWORKSComposer 7/1/2016 12:56 PM File folder
£ >
File name: [Drawing 1.ps| i | Save
Files of type: | "&ps ~ Caneel

Figure 20-17 The Create PostScript File dialog box

In the File name edit box, enter the name of the PostScript (EPS) file you want to create. Select
*.eps from the Files of type drop-down list. Next, choose the Save button to accept the default
setting and create the PostScript file. You can also choose Options from the Tools flyout of the
Create PostScript File dialog box to change the settings through the PostScript Out Options
dialog box (Figure 20-18) and then save the file. The PostScript Out Options dialog box pro-

vides the following options.

Prolog Section Name
In this edit box, you can assign a name for a prolog section to be read from the acad.psf file.

What to plot Area

The What to plot area of the dialog box has the following options.

Display

If you select this radio button when you are in the model space, the display in the current
viewport is saved in the specified EPS file. Similarly, if you are in the layouts, the current
view is saved in the specified EPS file.
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A PostScript Out Options x
Prolog Section Mame: Scale )
Output Drawing
| | Urits Units
1 = N1
What to plot Preview | | | |
(®) Display (®) None Fit to paper
() Extents (OEPSI Paper Size
() Limits OTIFF Width Height
Wiew Pxels |-"‘I'5 | |‘H}5 |
128
View USER 7.50 10.50 ~
256 A g.00 10.50
() Window B B 1000 1600
512 C 1600 2100
Window. .. D 2100 3300
E 3300 4300
Size Units (’; ﬁ% g%
@ Inches O MM 2 o T
Cancel

Figure 20-18 The PostScript Out Options dialog box

Extents

If you use this option, the PostScript file will contain the section of the AutoCAD LI" drawing
that currently holds objects. In this way, this option is similar to the ZOOM Extents option.
If you add objects to the drawing, they are also included in the PostScript file to be created
because the extents of the drawing are also altered. If you reduce the drawing extents by
erasing, moving, or scaling objects, then you must use the ZOOM Extents or ZOOM All
option. Only then does the Extents option of the PSOUT command calculate the extents
of the drawing to be exported. If you are in the model space, the PostScript file is created
in relation to the model space extents; if you are in the paper space, the PostScript file is
created in relation to the paper space extents.

Limits

With this option, you can export the whole area specified by the drawing limits. If the
current view is not the plan view [viewpoint (0,0,1)], the Limits option exports the area just
as the Extents option would.

View

Any view created with the VIEW command can be exported with this option. This option
will be available only when you have created a view using the VIEW command. Choose the
View tool to display the View Name dialog box from where you can select the view.

Window

In this option, you need to specify the area to be exported with the help of a window. When
this radio button is selected, the Window button is also available. Choose the Window button
to display the Window Selection dialog box where you can select the Pick button and then
specify the two corners of the window on the screen. You can also enter the coordinates of
the two corners in the Window Selection dialog box.
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Preview Area

The Preview area of the dialog box has two types of formats to preview images: EPSI and TIFF.
If you want a preview image with no format, select the None radio button. If you select TIFF
or EPSI, you are required to enter the pixel resolution of the screen preview in the Pixels area.
You can select a preview image size of 128 x 128, 256 x 256, or 512 x 512.

Size Units Area
In this area, you can set the paper size units to Inches or MM by selecting their corresponding
radio buttons.

Scale Area

In this area, you can set an explicit scale by specifying how many drawing units are to be output
per unit. You can select the Fit to paper check box so that the view to be exported is made as
large as possible for the specified paper size.

Paper Size Area
You can select a size from the list or enter a new size in the Width and Height edit boxes to
specify a paper size for the exported PostScript image.

OBJECT LINKING AND EMBEDDING (OLE)

With Windows, it is possible to work with different Windows-based applications by transferring
information between them. You can edit and modify the information in the original Windows
application, and then update this information in other applications. This is made possible by
creating links between different applications and then updating those links, which in turn update
or modify the information in the corresponding applications. This linking is a function of the
OLE feature of Microsoft Windows. The OLE feature can also join together separate pieces
of information from different applications into a single document. AutoCAD LT and other
Windows-based applications such as Microsoft Word, Notepad, and Windows WordPad support
the Windows OLE feature.

For the OLE feature, you should have a source document where the actual object is created in
the form of a drawing or a document. This document is created in an application called a server
application. AutoCAD LT for Windows and Paintbrush can be used as server applications. Now
this source document is to be linked to (or embedded in) the compound (destination) document,
which is created in a different application, known as the container application. AutoCAD LT
for Windows, Microsoft Word, and Windows WordPad can be used as container applications.

Clipboard

The transfer of a drawing from one Windows application to another is performed by copying
the drawing or the document from the server application to the Clipboard. The drawing or
document is then pasted in the container application from the Clipboard. Hence, a Clipboard
is used as a medium for storing the documents while transferring them from one Windows
application to another. The drawing or the document on the Clipboard stays there until you
copy a new drawing, which overwrites the previous one, or until you exit Windows. You can save
the information present on the Clipboard with the .c/p extension.



20-22 AutoCAD LT 2017 for Designers

Object Embedding

You can use the embedding function of the OLE feature when you want to ensure that there is
no effect on the source document even if the destination document has been changed through
the server application. Once a document is embedded, it has no connection with the source.
Although editing is always done in the server application, the source document remains
unchanged. Embedding can be accomplished by means of the following steps. In this example,
AutoCAD LT for Windows is the server application and MS Word is the container application.

1. Create a drawing in AutoCAD LT (the server application).
2. Open MS Word (container application).

3. It is preferable to arrange both the container and server windows so that both are visible,
as shown in Figure 20-19.

Model | Toyoutt | Tooud [+ 86707449906 MODEL [lf - = m L G-\ LTI -FE m ERAM- 8-+ | Oximal -0 G- @ &=

Figure 20-19 AutoCAD LT graphics screen with the MS Word window

4. In AutoCAD LT, copy the drawing using the CTRL+C keys; the Copy Clip tool is invoked.
This tool can be used to embed drawings. You can also invoke this tool from the Edit menu,
or by entering COPYCLIP at the Command prompt. The next prompt, Select objects,
allows you to select the entities you want to transfer. You can either select the full drawing
by entering ALL or select some of the entities by selecting them. You can use any of the
object selection methods for selecting objects. With this command, the selected objects are
automatically copied to the Windows Clipboard.

5. After the objects are copied to the Clipboard, make the MS Word window active. To get
the drawing from the Clipboard to the MS Word application (client), you need to paste
it into the Word application. Choose the Paste Special tool from Home > Clipboard >
Paste drop-down (Figure 20-20); the Paste Special dialog box will be displayed, as shown
in Figure 20-21. In this dialog box, select the Paste radio button (default) for embedding,
and then choose OK. The drawing is now embedded in the MS Word window.
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Figure 20-20 Pasting a drawing into the MS Word application

6. Your drawing is now displayed in the MS Word window, but it may not be displayed at the
proper position. You can get the drawing displayed in the current viewport by moving the
scroll bar up or down in the MS Word window. You can also save your embedded drawing
by choosing the Save button in MS Word. On doing so, the Save As dialog box is displayed

where you can enter a file name. Save the file and then exit MS Word.

Paste Special ? X

Source: AutoCAD LT Drawing
AutoCAD LT Drawing

Ast

(®) Paste: AutoCAD LT Drawing Object [ Display as icon
Paste link: Picture (Windows Metafile)
" |Bitmap

Result
E Inserts the contents of the Clipboard into your document so that you can edit it using

Figure 20-21 The Paste Special dialog box

7. Now, youneed to edit the embedded drawing. Editing is performed in the server application,
which in this case is AutoCAD LT You can get the embedded drawing into the server application
(AutoCAD LT) directly from the container application (MS Word) by double-clicking on the
drawing in MS Word. The other method of editing an embedded drawing is by right-clicking
on it and then choosing AutoCAD LT Drawing Object > Edit from the shortcut menu.

8. Now, you are in AutoCAD LT, with your embedded drawing displayed on the screen, but
as a temporary file with a file name such as [Drawing in Document]. Here, you can edit the
drawing by changing the color and linetype or by adding and deleting the text, entities,
and so on. In this example, the cup and plate have been hatched.
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9. Afteryou have finished modifying your drawing, choose File > Update Microsoft Word from
the menu bar in the server (AutoCAD LT), see Figure 20-22. To display the menu bar, click
on the down arrow in the Quick Access Toolbar and select Show Menu Bar. AutoCAD LT
automatically updates the drawing in MS Word (container application). Now, you can exit
this temporary file in AutoCAD LT

vvvvv
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Figure 20-22 Updating the AutoCAD LT drawing in Microsoft Word

7 Note

@ Do not zoom or pan the drawing in the temporary file. If you do so, this will be included in the

‘ updating and the new file will display only that portion of the drawing that lies inside the original
area.

10. This completes the embedding function. Now, you can exit the container application. While
exiting it, a message box asking whether or not to save changes in MS Word is displayed.

Linking Objects

The linking function of OLE is similar to the embedding function. The only difference is that
here a link is created between the source document and the destination document. If you edit
the source, you can simply update the link, which automatically updates the client. This allows
you to place the same document in a number of applications, and if you make a change in
the source document, the clients will also change by simply updating the corresponding links.
Consider AutoCAD LT for Windows to be the server application and MS Word to be the container
application. Linking can be performed by means discussed next.

1. Openadrawing in the server application (AutoCAD LT). If you have created a new drawing,
then you must save it before you can link it with the container application. Next, open MS

Word (container application).

2. Itis preferable to arrange both the container and the server windows so that both are visible.
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3.

In AutoCAD LT, choose Copy Link from the Edit menu of the menu bar to invoke the
COPYLINK command. This command can be used for linking the drawing. This command
copies all objects that are displayed in the current viewport directly to the Clipboard. Here,
you cannot select objects for linking. If you want only a portion of the drawing to be linked,
you can zoom into that view so that it is displayed in the current viewport prior to invoking
the COPYLINK command. This command also creates a new view of the drawing having
aname OLEI.

Make the MS Word window active. To get the drawing from the Clipboard to the MS Word
(container) application, choose the Paste Special tool from Home > Clipboard > Paste
drop-down; the Paste Special dialog box will be displayed. In this dialog box, select the
Paste link radio button for linking. Choose OK. Note that the Paste link radio button in
the Paste Special dialog box will not be available if you have not saved the drawing.

The drawing is now displayed in the MS Word window and is linked to the original drawing.
You can also save your linked drawing by choosing Save from the Quick Access Toolbar in
MS Word. It displays the Save As dialog box where you can enter a file name.

You can now edit your original drawing. Editing can be performed in the server application,
which, in this case, is AutoCAD LT for Windows. You can edit the drawing by changing
the color and linetype or by adding and deleting text, entities, and so on. Next, save your
drawing in AutoCAD LT by using the Save tool. You can now exit AutoCAD LT

You will notice that the drawing is automatically updated, and the changes made in the
source drawing are present in the destination drawing also. If the drawing is not updated
automatically, right-click on the drawing and then choose the Update Link option from
the shortcut menu displayed. Automatic updating is possible if the Automatic radio button
is selected in the Links dialog box (Figure 20-23). The Links dialog box can be invoked by
choosing Linked AutoCAD LT Drawing Object > Links from the shortcut menu displayed
on right clicking on the drawing in the Word application.

Exit the container application after saving the updated file.
Note

The dialog box may be different in your case as it depends on the version of MS Word being used
currently.
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Links ? *

Source file Item Type Update

Cih \Drawingl.dwg AutoCAD LT Drawing Update Mow
Open Source
Change Source...

Break Link

Source information for selected link

Source file: ChUsers\TIET\DesktopiDrawingl.dwg
Item in file: OLE1
Link type:  AutoCAD LT Drawing

Update method for selected link
(® Automatic update
O Manual update
D Locked
Options for selected link
Save picture in document

Preserve formatting after update

Cancel
Figure 20-23 The Links dialog box
Linking Information to AutoCAD LT

Similarly, you can also embed and link information from a server application into an AutoCAD LT
drawing. You can also drag selected OLE objects from another application into AutoCAD LT
provided this application supports Microsoft ActiveX and the application is running and visible
on the screen. Dragging and dropping is like cutting and pasting. If you press the CTRL key
while you drag the object, it is copied to AutoCAD LT. Dragging and dropping an OLE object
into AutoCAD LT embeds it into AutoCAD LT.

Linking Objects to AutoCAD LT

Start any server application such as MS Word and open a document in it. Select the information
you wish to use in AutoCAD LT with your pointing device and choose the Copy tool to copy
this data to the Clipboard. Open the AutoCAD LT drawing to which you want to link this
data. Choose the Paste Special tool from Home > Clipboard > Paste drop-down or use the
PASTESPEC command; the Paste Special dialog box will be displayed (Figure 20-24). In the As
list box, select the data format you wish to use. For example, for an MS Word document, select
Microsoft Office Word Document. Picture format uses a Metafile format. Select the Paste Link
radio button to paste the contents of the Clipboard into the current drawing. If you select the
Paste radio button, the data will be embedded and not linked. Choose OK to exit the dialog
box. Specify the insertion point; the data will be displayed in the drawing.
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Paste Special ? *
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Figure 20-24 The Paste Special dialog box

You can insert objects in the drawing by choosing OLE Object from the Data panel of the Insert
tab, or by choosing the OLE Object tool in the Insert toolbar. This command links an entire file
to a drawing from within AutoCAD LI. On invoking this command, the Insert Object dialog
box is displayed, as shown in Figure 20-25.

Insert Object X
et T
(®) Create New Adobe Acrobat Document A

Adobe LiveCycle Designer Document Cancel
EDrawings Document

O Greate from Fie Microsoft Equation 3.0
Microscft Excel Binary Worksheet
Microsoft Excel Macro-Enabled Work ] Display As |
Microsoft Excel Worksheet splay 7 lcon
Microsoft Graph Chart A

Result
Inserts @ new Adobe Acrobat Document object

into your document.

Figure 20-25 The Insert Object dialog box

Select the Create from File radio button. Also, select the Link check box. Choosing the Browse
button displays the Browse dialog box. Select a file you want to link from the list box or enter a
name in the File name edit box and choose the Open button. The path of the file is displayed
in the File edit box of the Insert Object dialog box. If you select the Display As Icon check box,

an icon is displayed in the dialog box as well as in the drawing. Choose OK to exit the dialog
box; the selected file is linked to the AutoCAD LT drawing.

Whenever the server document changes, AutoCAD LT updates links automatically by default.
But, you can use the Links dialog box (Figure 20-26) to change these settings. This dialog box
can be displayed by choosing OLE Links from the Edit menu. In the Links dialog box, select
the link you want to update and then choose the Update Now button. Next, choose the Close
button. If the server file location changes or if it is renamed, you can choose the Change Source
button in the Links dialog box to display the Change Source dialog box. In this dialog box,
locate the server file name and location and choose the Open button. You can also choose the
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Break Link button in the Links dialog box to disconnect the inserted information from the
server application. This is done when the linking between the two is no longer required.

Links X
Links: Tvpe Update IT'
iEMpte . NCH 05 EXER 04 SLOPRT Part Automatic |

Update Now
Cpen Source

Change Source...

Breal: Link

Source:

Type:

Update: Automatic Manual

Figure 20-26 The Links dialog box

Embedding Objects into AutoCAD LT

Open the server application and select the data you want to embed into the AutoCAD LT drawing.
Copy this data to the Clipboard by choosing the Copy tool in the toolbar or Copy from the Edit
menu. Open the AutoCAD LT drawing and choose Paste from the AutoCAD LT Edit menu. You
can also use the PASTECLIP command. Specify the insertion point; the selected information is
embedded into the AutoCAD LT drawing.

You can also create and embed an object into an AutoCAD LT drawing starting from AutoCAD
LT itself. To do so, choose the OLE Object tool from the Data panel of the Insert tab; the Insert
Object dialog box is invoked (Figure 20-27). In this dialog box, select the Create New radio

button and select the application you wish to use from the Object Type list box. Choose OK.
The selected application opens.

Insert Object >
s
(®) Create New Adobe Acrobat Document A

Adobe LiveCycle Designer Documert Cancel

() Create from File EDrawings Document
Microsoft Equation 3.0
Microgoft Excel Binary Workshest
Microsoft Excel Macro-Enabled Work [ Display As |
Microsoft Excel Worksheet splay ~s lcon
Microsoft Graph Chart hd

Result
Inserts & new Adobe Acrobat Document object

into your document.

Figure 20-27 The Insert Object dialog box
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Now, you can create the information you wish to insert in the AutoCAD LT drawing and save it
before closing the application. You can edit information embedded in the AutoCAD LT’ drawing
by double-clicking on the inserted OLE object; the server application will open. The modifications
made in the server application get automatically reflected in the AutoCAD LT drawing.

Working with OLE Objects

Select an OLE object and right-click to display a shortcut menu. Next, choose Properties from
the shortcut menu; the Properties window will be displayed. Specify a new height value and a
new width value in the Height and Width edit boxes in the Geometry area. Enter a value in
percentage of the current values in the Scale height % and Scale width % edit boxes. If you
select the Yes option in the Lock Aspect field, whenever you change the height or the width
under Scale or Size, the respective width or height changes automatically to maintain the aspect
ratio. If you want to change only the height or the width, select No for this field.

The pointing device can be used to modify and scale an OLE object in the AutoCAD LT drawing.
Selecting the object displays the object frame. The move cursor allows you to select and drag an
object to a new location. The middle handle allows you to select a frame and stretch it. It does
not scale objects proportionately. The corner handles scale an object proportionately.

Select an OLE object and right-click to display a shortcut menu. Choosing Clipboard > Cut
removes an object from a drawing and pastes it on the Clipboard. The Copy option is used to
place a copy of the selected object on the Clipboard and the Erase option is used to remove
an object from a drawing and does not place it on the Clipboard. Choosing OLE displays the
Open, Reset, Text Size, and Convert options. Choosing Convert displays the Convert dialog
box where you can convert objects from one type to another and choosing Open opens an object
in the Server application where you can edit and update it in the current drawing. Choosing
the Reset option restores the selected OLE objects to their original size, that is, the size they
had when inserted. Choose the Text Size option to resize the text. You can set the draw order
by choosing the corresponding option from Draw Order in the shortcut menu.

If you want to change the layer of an OLE object, select the object, and then select the required
layer from the Layer drop-down list in the Layers panel.

The OLEHIDE system variable controls the display of OLE objects in AutoCAD LT. The default
value is 0, which makes all OLE objects visible. The different values and their effects are as follows:

0 All OLE objects are visible
1 OLE objects are visible in paper space only
2 OLE objects are visible in model space only
3 No OLE objects are visible

The OLEHIDE system variable affects both screen display and printing.
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Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1. The is used as a medium of storing documents while transferring them from
one Windows application to the other.

2. You can get an embedded drawing into the Server application directly from the container
application by on the drawing.

3. The Copy Link tool copies a drawing from the to the Clipboard.

4. The DXEF file format generates a text file in ASCII code. (T/F)

5. You can directly open a DXF file in AutoCAD LT by using the Open tool. (T/F)

6. An image attached to AutoCAD LT cannot be detached. (1/F)

7. Afile in the container application is automatically modified only when a link is maintained

between the server application and the container application. (1/F)

Review Questions

Answer the following questions:
1. Which of the following tools can be used to open a DXF format file?

(a) Open (b) New
(c) Save (d) None of these

2. Which of the following tools is used to add an image to the drawing as an external reference?

(a) Attach (b) Insert
(c) Adjust (d) Create Block

3. Inwhich of the following panels, the options are used to modify the brightness of an image?

(a) Options (b) Visual Styles
(c) Clipping (d) Adjust
4. The tool is used to modify frames by retaining only the desired portion of the
images.
5. The tool is used to create an ASCII format file with the .dxf extension from the

AutoCAD LT drawing files.
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6.

10.

11.

12.

13.

14.

Binary DXF files are efficient and occupy only 75 percent of the ASCII DXF
file.

File access for files in binary format is than for the same file in ASCII format.
If the OLEHIDE system variable value is , the OLE objects are visible in the

paper space only.

When you select an image file to attach, the dialog box is displayed where you
can define the insertion point, scale factor, and rotation angle for the image.

The clipping boundary for the raster images can be of or the shape.

In AutoCAD LT, you can clip the boundary of an image and give it to the desired shape.
(L/F)

The scanned files can be imported into the current session of AutoCAD LT using the Attach
tool. (T/F)

You can export an AutoCAD LT drawing into 3D Studio MAX. (1/F)

Raster images can be attached using the Attach tool. (1/F)

Exercise 1

In this exercise, you will create a cup and a plate, refer to Figure 20-28 for dimensions. Assume
the missing dimensions. Below the cup and plate, enter the following text in MS Word: These
objects are drawn in AutoCAD LT. Then using OLE, paste the text into the current drawing.

[
5) |

1.75

Figure 20-28 Dimensions for Exercise 1
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Answers to Self-Evaluation Test
1. Clipboard, 2. double-clicking, 3. current display, 4. T, 5. T, 6. F, 7. T



