Chapter 2

Getting Started with
AutoCAD Map 3D
2016

Learning Objectives

After completing this chapter, you will be able to:
* Start a new drawing

* Open existing drawing

* Add data to the project

* Generate output in different ways

* Create sheet sets
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INTRODUCTION

This chapter aims to introduce you to the interoperability feature of AutoCAD Map 3D. In this
chapter, you will learn to create a new drawing file using a drawing template file. You will also
learn to open an existing drawing file and load various types of GIS data into your drawing
using the Connect tool.

Moreover, you will learn different ways of producing data output such as printing, plotting to a
file, and publishing a map file. This chapter also discusses the procedure to create a standard
sheet set using various methods in AutoCAD Map 3D.

STARTING A NEW DRAWING

To start a new drawing file, choose New > Drawing from the Application Menu, as shown in
Figure 2-1; the Select template dialog box will be displayed, as shown in Figure 2-2. In this
dialog box, browse to the Template folder. Next, select the map2d template file from the list of
drawing templates in this folder, refer to Figure 2-2. Choose Open to apply template settings
to your drawing; the new drawing will be opened in a 2D mapping environment. Similarly, you
can select other drawing templates for mapping based on your project requirement.

Search Commands 4

|_|_|(9'_j Create a new drawing
D Mew 4 [fE. Drawing
Start a new drawing with a selected
drawing templt§e file,
E; Open 4
Sheet Set
=T i Create a sheet set data file that
j DWG Convert manages drawing layouts, file paths,
and project data.
E Save
B Save As 3

Figure 2-1 Choosing the Drawing option from the Application Menu

Q Tip: You can directly invoke the Select template dialog box by choosing the New option from
the Application Menu.

OPENING AN EXISTING DRAWING FILE

You can also start a project by using the data in an existing drawing file. To open a drawing

file, choose the Open button from the Application Menu; the Select File dialog box will
be displayed, as shown in Figure 2-3. In this dialog box, select one of the following file extensions
*.dwg, *.dws, *.dxf, or *.dwt from the Files of type drop-down list. Next, browse to the appropriate
folder containing the required file by using the Look in drop-down list. Once you open the
required folder, select the data file and then choose the Open button; the contents of the selected
file will be displayed in the drawing window.
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Figure 2-2 The Select template dialog box with the map2d drawing template selected
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2-4 Exploring AutoCAD Map 3D

ADDING DATA TO THE PROJECT

AutoCAD Map 3D supports a wide range of GIS and CAD data formats. This interoperability
feature of AutoCAD Map 3D enables you to use various GIS data types and file formats.

In AutoCAD Map 3D, you can use the data available in other CAD files by attaching them as
external reference files. You can also import the data available in other file formats into the
AutoCAD’s .dwg file format. AutoCAD Map 3D has incorporated the FDO data access technology
into Autodesk geospatial products. This technology provides an effective means of data-access
and data-management. Using FDO, you can connect directly to a data source and then work
in its native format without converting into the .dwg format. Some of the methods that are
commonly used to connect data in your drawing are discussed next.

Loading Data by Using the Connect Tool

Ribbon: Home > Data > Connect
Task Pane: Display Manager > Data > Connect to Data

G— You can load various types of data into the Workspace without affecting their structure
L and accuracy by using the Connect tool. This tool allows you to connect raster files,
vector data files, databases, DT'Ms, and other type of data to the Workspace. Figure 2-4
shows the flow diagram of loading data into your Workspace by using the Connect tool. Different
datasets such as vector data, raster data, open geospatial data source, and WMS can be combined
into one group and loaded into the Workspace by using this tool. You can also adjust the settings
of the datasets such as coordinate system, connection name, source folder, and so on as per your
requirement. The method of loading various data types using the Connect tool is discussed
next.

Connact

Assign

coordinate
Feature data system

Raster data

Oracle Server Data Connect

Database Server
Workspace in

Map Server AutoCAD Map 3D

Figure 2-4 Flow diagram displaying the loading of data into the Workspace

Loading SHP Data

You can load SHP data to the current drawing by using the DATA CONNECT wizard. To do so,
choose the Connect tool from the Data panel of the Home tab; the DATA CONNECT wizard
will be displayed, as shown in Figure 2-5. Alternatively, you can invoke this wizard from the
TASK PANE. To do so, choose the Data button from the Display Manager tab; a flyout will be
displayed. Choose the Connect to Data option from the flyout; the DATA CONNECT wizard
will be displayed.
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Figure 2-5 The DATA CONNECT wizard

In this wizard, to connect and add SHP data to the existing drawing, select the Add SHP
Connection option from the Data Connections by Provider list box; the right pane of the wizard
will display the page containing the options for adding data. For example, to load the Land
cover map data (SHP file) into the Workspace, select the Add SHP Connection option from
the Data Connections by Provider list box; the OSGeo FDO Provider for SHP page will be
displayed in the right pane. Enter the name of the connection in the Connection name edit box.

Next, to connect a single SHP file, choose the button to the right of the Source file or
folder edit box with the text SHP; the Open dialog box is displayed. In this dialog box,

select the required SHP file and choose the Open button; the path of the selected SHP file will
be displayed in the Source file or folder edit box and the Connect button will become active.

Choose the Connect button; the selected SHP file will be displayed in the Add Data to Map list
box. In case you want to connect multiple SHP files that are located within the same folder,
choose the Browse button; the Browse For Folder dialog box is displayed. In this dialog E
box, select the folder containing the required SHP files. Next, choose the OK button; the

path of the selected folder will be displayed in the Source file or folder edit box and the
Connect button will become active. Choose the Connect button; the list of all SHP files contained
within the selected folder is displayed in the Add Data to Map list box. The list box displays the
SHP files with their corresponding coordinate system.
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If data is not referenced, you can add the coordinate system manually. To do so, choose the
Edit Coordinate Systems button at the top of the Add Data to Map list box; the Edit Spatial
Context dialog box will be displayed. Specify a coordinate system to georeference the data using
the options in this dialog box. The process of georeferencing the data to a particular coordinate
system is discussed in the next chapter.

After georeferencing the data, you will add the data to the map. To do so, select the check box
corresponding to the required SHP file. Next, choose the Add to Map option from the drop-down
displayed below the Add Data to Map list box; the contents of the SHP file will be displayed
in the drawing window. Note that the name of the added SHP file is displayed in the Display
Manager tab of the TASK PANE.

You can also apply data filters while adding data from the SHP file. To do so, choose the Add
to Map with Query option from drop-down that is displayed below the Add Data to Map list
box; the Create Query window will be displayed. Use this window to frame a spatial or aspatial
query for filtering the data. On framing the query, choose the OK button; the filtered data will
be added to the drawing window and the layers will be displayed in the list box of the Display
Manager in the TASK PANE. Then, close the DATA CONNECT wizard. Next, select the added
layer in the Display Manager list box, and right-click on the feature selected; a shortcut menu
will be displayed. Now, choose the Zoom to Extents option from the shortcut menu; the drawing
window will display the data in the added layers.

Loading Raster Data

Raster data consists of matrix of raster cells arranged in rows and columns. Every raster cell has
a value that represents information. Satellite images, aerial photographs and scanned images
are few examples of raster data. Raster data has the most simple data structure and is widely
used in GIS as background layer.

You can load raster data into your drawing by using the DATA CONNECT wizard. To load the
raster data, invoke the DATA CONNECT wizard by choosing the Connect tool from the Data
panel. In the wizard, choose the Add Raster Image or Surface Connection option from the left
pane; the Autodesk FDO Provider for Raster page will be displayed. In this page, specify the
name for the connection in the Connection name edit box. Next, to load a single raster dataset,
choose the button to the right of the Source file or folder edit box; the Open dialog box will
be displayed. In this dialog box, browse to the location and select the required raster
dataset. Next, choose the Open button in the dialog box; the Open dialog box closes and

the name of the selected raster will be displayed in the Source file or folder edit box of the
DATA CONNECT wizard. Next, choose the Connect button displayed below the Source file or
folder edit box; the Raster Image or Surface page of the DATA CONNECT wizard is displayed.

To connect to multiple raster data from a folder using one connection, choose the button
to the far right of the Source file or folder edit box; the Browse to the folder dialog box

will be displayed. Use this dialog box to browse and select the folder containing the required
raster datasets. Next, choose the OK button; the Browse to the folder dialog box will be closed
and the name of the selected folder will be displayed in the Source file or folder edit box of
the DATA CONNECT wizard. Next, choose the Connect button displayed below the Source
file or folder edit box; the Raster Image or Surface page of the DATA CONNECT wizard will
be displayed. The Schema list in this page will now display a list of all the rasters in the selected
folder.
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Select the required raster data from the Schema list by selecting the check box. Figure 2-6 shows
multiple raster data selected in the Schema list of the DATA CONNECT wizard. If required,
you can assign or modify the coordinate system of the raster data. The method of assigning the
coordinate system to a data is discussed in detail later in this textbook.
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Figure 2-6 Multiple raster data selected in the DATA CONNECT wizard

On selecting the required raster data, choose the Add to Map button displayed below the Schema
list; the selected raster will be added to the drawing. You can also use the Image tool from the
Image panel of the Insert tab to insert raster image into your drawing. The method of inserting
the raster using this tool is discussed later in this book.

Loading SDF Data

SDF is the spatial data file format developed by Autodesk to store different geospatial data. You
can load SDF drawing file into AutoCAD Map 3D. To do so, choose the Connect tool from the
Data panel; the DATA CONNECT wizard will be displayed, refer to Figure 2-5. In this window,
choose the Add SDF Connection option from the Data Connections by Provider list box; the
OSGeo FDO Provider for SDF page will be displayed in the right pane of the wizard. Specify
the name of the connection in the Connection name edit box. Then, choose the button next to
the Source file edit box; the Open dialog box will be displayed. In this dialog box, select the
required file and then choose the Open button; the dialog box will be closed and the file location
will be displayed in the Source file edit box in the OSGeo FDO Provider for SDF page of
the wizard. Next, choose the Connect button. On doing so, the list of data files in the
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source connection will be displayed in the Add Data to Map list box. Select the check box
corresponding to the data that you want to add to the map. Next, choose the Add to Map button
from the drop-down below the Add Data to Map list box. The added data will be displayed in
the drawing window.

Loading WFS Data

WEFS data (Web Feature Service) provides geospatial feature data. AutoCAD Map 3D allows you
to use WFS data using the Connect tool. To do so, choose the Connect tool from the Data panel;
the DATA CONNECT wizard will be displayed. In this window, choose the Add WFS Connection
option from the Data Connections by Provider list box; the OSGeo FDO Provider for WFS
area will be displayed. Specify the name of the connection in the Connection name edit box.
Enter the server name or the URL in the Server name edit box. Alternatively, you can select
the previously used URL from the drop-down list. Select the relevant version from the Version
drop-down list. You can also select the Default version option from the drop-down list. Next,
choose the Connect button; the User Name & Password dialog box will be displayed. Enter
the credentials in the dialog box and choose the Login button; the list of data files in the source
connection will be displayed in the Add Data to Map list box. Select the data that you want to
add to the map from the Add Data to Map list box; the drop-down list below the Combined
Layer Info list box will be activated. Choose the required option from this drop-down list; the
selected data will be added to the drawing window.

Note
When you select the Default version option from the Version drop-down list, AutoCAD
Map 3D will load the latest version of the WFS data.

Loading WMS Data

Using the WMS data (Web Map Service) connection, you can incorporate the raster data that is
published on a public web server into your map. To bring the WMS data into AutoCAD Map 3D,
choose the Connect tool as explained in the previous section; the Data Connect window will be
displayed. In this window, choose the Add WMS Connection option from the Data Connections
by Provider list box; the OSGeo FDO Provider for WMS page will be displayed. Specify the
connection name and server name or URL in the Connection name and Server name or URL
text box, respectively. Next, choose the Connect button; the User Name and Password dialog
box will be displayed. Enter the credentials and choose the OK button. On connecting to the
WMS server, the list of available schema will be displayed in the list box of the OSGeo FDO
Provider for WMS page. Select the required schema from the list box and choose the Add Data
to Map option to load data into the drawing window.

Note
OSGeo FDO Provider for WFS or WMS data of AutoCAD Map 3D provides read only access to
these data types.

Loading Data from Databases

AutoCAD Map 3D provides inbuilt data connections to connect to various databases such as
Microsoft Access, Oracle, MySQL, and ArcSDE. To access data from Microsoft Access, Excel, or
dbase, select the Add ODBC Connection option from the Data Connections by Provider list box;
the OSGeo Provider for ODBC page is displayed in the right pane of the DATA CONNECT
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wizard. In this page, specify the connection name in the Connection name edit box. Select the
relevant source type from the Source type drop-down list. If you select the Data Source Name
(DSN) option from the Source type drop-down list, then you need to enter the name of the data
source. To do so, choose the Browse button next to the Source edit box; the Select Data Source
Name dialog box will be displayed. Select the required data source name from the Data Source
Names list box and then choose the Select button; the source name will added to the Source
edit box. You can also select the Connection String option and add the connection string to
the Source edit box. Next, choose the Test Connection button; the User Name & Password
dialog box will be displayed. Enter the user name and password to login. Now, connect to the
database and add the data to the Map as explained previously. Similarly, you can connect to
the data store in MySQL, Oracle and PostgreSQL. To connect to different data store in these
databases, specify the connection name and service name and then select the data store that
you want to add to the map in the drawing window. To load the data from ArcSDE, you need
to specify the connection name, server name, and the instance name. On doing so, you will be
able to connect to the database and add the data store to the map.

Loading Enterprise Industry Model

Enterprise Industry Models are different types of schemas that are stored in Oracle database.
These models can be for storm water system, wastewater sewage system, or gas pipeline network.
To load the data from the Enterprise Industry Model, choose the Connect tool from the Data
panel; the Data Connect window will be displayed. In this window, choose the Add Enterprise
Industry Model Connection option from the Data Connections by Provider list box; the OSGeo
FDO Provider for Enterprise Industry Models page will be displayed. Specify the connection
name and service name in the Connection name and Service name edit boxes, respectively.
Next, specify the Map 3D or the computer user name and password in the Map 3D Main or
System User name and Map 3D Main or System User password edit boxes, respectively. On
doing so, you can select the relevant industry model from the Industry model drop-down and
add data to the map.

O Tip: Schema defines the structure of the different feature classes. It defines the rules, feature
bype, data type, feature properties, and so on. Also, schema of a particular enterprise industry
model can be edited and updated as per the user requirement in AutoCAD Map 3D.

Loading Data by Using the Map Explorer Tab

You can load drawing data by using the options in the ~Map Explorer tab of the TASK PANE.
In this tab, you can add the drawing data file by using the select, drag, and drop methods. To
do so, choose the Map Explorer tab from the TASK PANE; the options in the Map Explorer
tab will be displayed, as shown in Figure 2-7. Next, open the folder containing the source data
file. Select the source data file, and then drag and drop the file into the Map Explorer tab; the
data source file will become visible at the top of the list in the Map Explorer tab.

You can attach drawings to the Workspace by using the options in the Map Explorer tab. To
do so, right-click on the Drawings folder in the tab; a shortcut menu will be displayed. Choose
the Attach option from the shortcut menu; the Select drawings to attach dialog box will be
displayed. In this dialog box, select the source drawing file and then choose the Add button;
the added drawing files will be displayed in the Selected drawings list box. If the selected file
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is not needed, choose the Remove button to remove the drawing file from the list. Next, choose
the OK button; the list of selected drawings will be displayed under the Drawings node in the
Map Explorer tab of the TASK PANE. Select a file name in Drawings node and right-click on
it; a shortcut menu will be displayed. Next, choose the Zoom Extents option from the shortcut
menu; the selected drawing will be displayed in the drawing window.

TASK PANE

B&s X

Data Schema Table Tools Remove

fé Raster 1
-3 ShapeData

=-f# Current Drawing [Drawingl.cw
£ Drawings
=-E1 Query Library
?, Current Query
2-F1 Object Classes
i) Undefined Classes
£ Data Sources
£ Topologies
£ Link Templates

Figure 2-7 The TASK PANE with the Map Explorer tab chosen

Note
@ You can also attach drawings to the Workspace by using the Attach tool from the Data panel in
the Home tab.

Importing GCP Data by Using the Survey Tab
Q You can import the Ground Control Points (GCP) data or the survey data into the
Workspace by using the Survey tab in the TASK PANE. Before you import a survey
Data  data into your project, you must connect to an existing survey data store that contains
data. You can also create a new survey data store to reposit survey data. To do so, choose the
Data button in the Survey tab; a flyout will be displayed. From this flyout, choose the New
Survey Data Store button; the New Data Store dialog box will be displayed, as shown in
Figure 2-8.
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Figure 2-8 The New Data Store dialog box

In this dialog box, choose the Browse button in the File Location area; the Create new
Survey Data Store dialog box will be displayed. In this dialog box, browse to the required
location and specify a name for the new data store in the File name edit box and then choose
the OK button; the Create new Survey Data Store dialog box will be closed and the path for
the data store will be displayed in the File Location text box of the New Data Store dialog box.
In the Coordinate System Assignment area of the New Data Store dialog box, select a suitable
Coordinate Reference System (CRS), either by entering a value in the Enter Code edit box or
by using the Browse button located on the right of the Enter Code edit box. Next, choose
the OK button in the New Data Store dialog box; a survey data store will be created. The
created data store is displayed in the Display Manager tab and the Map Explorer tab of the
TASK PANE. The created data store is also selected in the Current Data Store drop-down in
the Survey tab and the Survey Data Store node is added to the list box of this tab. To import
points to this data store, right-click on the Survey Data Store node; a shortcut menu is displayed.
Choose the Import LandXML or the Import ASCII Points option from the shortcut menu to
import point data into the project. Next, right-click on the Survey Data Store node; a shortcut
menu is displayed. Choose the Zoom to Extents option from this menu; the survey data will be
displayed in the drawing window.

Importing an External File Format Data by Using the Map
Import Tool

Ribbon: Insert > Import > Map Import
Command: MAPIMPORT

Using the data import feature of AutoCAD Map 3D, a Map 3D user can import spatial
% data into the Map 3D environment. Using this feature, you can import spatial data
Map available in various file formats such as ASCII, ESRI shape file, MapInfo TAB, TIFF,
Impert GML, and DGN into the Map 3D environment. To import the datasets into the AutoCAD
Map 3D, choose the Map Import tool from the Import panel in the Insert tab; the Import
Location dialog box will be displayed. In this dialog box, select the required file extension from
the Files of type drop-down list. Next, browse and select the required dataset and then choose
the OK button; the Import Location dialog box will be closed and the Import dialog box will
be displayed. Figure 2-9 shows the Import dialog box for a .shp file.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Note
The options displayed in the Import dialog box will depend on the type of data file selected in the
Import Location dialog box.

In this dialog box, for importing the SHP file, the Current drawing coordinate system area
displays the coordinate system of the drawing. You can change the coordinate system of the
drawing using the Assign Global Coordinate System dialog box. To invoke this dialog box,
choose the button in the Current drawing coordinate system area of the Import dialog
box. While importing the data, you can also set the spatial filter, which can be used to
import data within a required region. To set a spatial filter, select a radio button corresponding
to the required option in the Spatial filter area of the Import dialog box. The table in the Import
properties for each layer imported area allows you to manage the imported data. You can
specify properties such as the layer drawing for the imported data. You can also choose whether
to include or exclude the object data in the drawing. While including the object data, AutoCAD
Map 3D allows you to assign the table name and manage its field content.

Cument drawing coordinate system Spatial fitter
No coordinate system assigned to cument drawing. @ None
Coordinate conversion will not be performed.
() Current display
Driver options

Changing these options may affect the layout Define window

Driver Options... of the import properties table.

Import properties for each layer imported:

Input Layer | Drawing Layer | Object Class |Input Coordinat| Data Points
AustinTx_Add AustinTX_Addres|=None: THXB3-CF <None= <ACAD _POINT=

Saved profiles

Load... [ import palygons as clased potdines

Current profile:
Use class defaults for out of range values

[ ok || cancel || Hep

Figure 2-9 The Import dialog box

After specifying the required parameters in the Import dialog box, choose the OK button to
add the imported layer with default settings. The options used in the Import dialog box are
discussed later in this book.

DATA OUTPUT METHODS

AutoCAD Map 3D allows you to generate the output of your project in several ways, such as
saving the file in various formats, sending mail through web services, publishing the map using
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various mediums, and so on. In this section, you will learn about the data output methods such
as saving files, exporting data, printing data, plotting and publishing, and sending files through
web services. These methods are discussed next.

Generating Data by Using the Save As Option

You can save a drawing file in AutoCAD Map 3D’s native file format .DWG or in various other
formats by using the Application Menu. To save a drawing file in the AutoCAD file format,
choose the Save As option from the Application Menu; the Save Drawing As dialog box will be
displayed. In this dialog box, browse to the location where you want to save the file. Next, enter
a name in the File name edit box and select the file format from the Files of type drop-down
list. Choose the Save button to save the file with assigned name and file type.

Generating Data by Using the Export Option
You can use the Export option in the Application Menu for exporting a drawing file into different
file formats. Different file formats in the Export option are discussed next.

AutoCAD Map 3D uses the DWF (Design Web Format) to distribute data efficiently. Drawings
can be exported into the DWF format by using the Export option. To do so, choose Export >
DWF from the Application Menu; the Save As DWF dialog box will be displayed, as shown in
Figure 2-10. In the Save As DWF dialog box, the export file properties such as Type, Override
Precision, Layer Information, and so on will be displayed in the Current Settings area. To
change these user settings for the file to be exported, choose the Options button in this area;
the Export to DWF/PDF Options dialog box will be displayed. The user settings are categorized
as General DWF/PDF Options and DWF data options. Specify the required settings and then
choose the OK button to apply the settings to the file being exported.

| Save As DWF (23]
Savein: "E Computer v] « B @ ¥ 5 Views =  Tools =
» Cument Settings
- | N T
B YEE Type: Mutisheet file
Hard Disk Drives (2) Bhvenide Precigion: None
j:b—“ 05(C) Local Disk Layer Information: Include
J‘_ =5 ca DATA (D) Local Disk Merge Control: Lines overwrite
P
w7 Devices with Removable Storage (2) Password Protection: Disabled
l_i-;]D‘u‘D RW Drive (E:) CD Drive Block Information: Dont include
[l] l_i-;]BD-ROM Drrive (F:) CD Drive
' 3z Other (1)
) Autodesk 360 (Explorin... System Folder St
]~ v Open in viewer when done
; [ Include plot stamp
s Soot. "
| il % Page Setup Ovemide...
File name: MyDrawing - Save
Fles of type: | DWF Files ("dwf) v [ cancel |

Figure 2-10 The Save As DWF dialog box
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The options in the Output Controls area of the Save As DWF dialog box are used to set the
display properties of an export file. To display a file in a viewer after exporting it, select the
Open in viewer when done check box. To apply plot stamp to the export file, select the Include
plot stamp check box. To modify the plot stamp settings, choose the Plot [r
Stamp Settings button located on the right of the Include plot stamp option; the Plot £
Stamp dialog box will be displayed. Modify the settings as per your requirements in this dialog
box, and then choose the OK button to apply the settings and close the Plot Stamp dialog box.
To choose the extents for the file to be exported, select the desired option from the Export
drop-down list. To export the entire content of the drawing, select the Extents option from the
drop-down list. On selecting the Display option, all the objects that are visible in the current
drawing window will be exported. To export the objects in a particular region, select the Window
option from the Export drop-down list; the Select Window button on the right of this
option will be activated. Next, choose the Select Window button; the Save As DWF dialog

box is closed. Select the area in the drawing window to be exported. On selecting the area, the
Save As DWF dialog box will be displayed again. To change the page settings of the export file,
select the Override option from the Page Setup drop-down list; the Page Setup Override button
will become active. To modify the page settings, choose the Page Setup Override button; the
Page Setup Override dialog box will be displayed. In this dialog box, apply the page settings
as required. Choose the OK button to apply the settings and close the Page Setup Override
dialog box.

In the Save As DWF dialog box, enter the name of the exported file in the File name edit box,
and then choose the Save button; the file will be saved as a DWF file at the specified location.
Using the similar exporting process, you can create files with the DWFx and PDF file extensions.
More file extensions are available in the dialog box when you choose the Other GIS Format
option to export the drawing from the Application Menu.

Generating Data by Using the DWG Convert Option

The DWG Convert option in the Application Menu is used to change drawings from one AutoCAD
drawing type to another. To convert a drawing, choose DWG Convert from the Application Menu;
the DWG Convert dialog box will be displayed, as shown in Figure 2-11. Different options in
this dialog box are discussed next.

Files Tree and Files Table Tabs

In the DWG Convert dialog box, the Files Tree tab is chosen by default. This tab displays the
list of drawings in a hierarchical order. The selected check box against the file name indicates
that the file will be converted. Clear the check box to exclude the file from conversion. To add
files to the list, drag and drop the required files into the list or use the Add file button displayed
below the list. The Files Table tab displays the list of drawing files to be converted into a table
format. Five buttons are located at the bottom of the Files Tree and Files Table tabs. The use
of these buttons is discussed next.

Add file

@ The Add file button is used to add drawing files for conversion process. To do so,
choose this button; the Select File dialog box will be displayed. In the dialog box,

browse to the folder containing the required drawing file. Next, select the file/s and then

choose the Open button; the dialog box will be closed and the selected file/s will be added

to the list in the DWG Convert dialog box.
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Figure 2-11 The DWG Convert dialog box

New list
The New list button clears the existing list in the tab and starts a fresh list. On

=1 choosing the New List button, the DWG Convert message box will be displayed. To
save the existing list, choose the Yes button in the message box; the message box will be
closed and the Save Conversion List dialog box will be displayed. In the dialog box, enter
a name in the File name edit box and then choose the Save button; the list will be saved
with an extension.

Open list

ﬁ The Open list button is used to open an existing conversion list of drawing files. To
do so, choose the Open list button; the Open Conversion List dialog box will be

displayed. In the dialog box, select the desired list/s from the folder and then choose the

Open button; the selected list will be added to the active tab.

Append list

==|| The Append list button is used to add an existing list to the current list of drawings.
=*|  To do so, choose the Append list button; the Append Batch Control List dialog box

will be displayed. In the dialog box, select an option from the list box and then choose the

Open button; the dialog box will be closed and the drawings in the selected list will be added

to the current list of drawings in the active tab.

Save list

The Save list button is used to save the current list in the form of a batch conversion
list (*.bcl).
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Select a Conversion Setup

The Select a conversion setup area displays a list of conversion setup. These setups contain
the settings that will be used while converting the drawing files. Choose the required option
from the list box and then choose the Convert button to begin the file conversion process. To
modify or create the conversion settings, choose the Conversion Setups button in this area; the
Conversion Setups dialog box will be displayed, as shown in Figure 2-12.

& Conversion Setups

}1 Cument user: CADCIM

Convert to 2000 folder)

Convert to 2004 {inplace)
Convert to 2007 {inplace)
Convert to 2010 imilacei Rename
Standard

[ Close ] [ Help ]

Figure 2-12 The Conversion Setups dialog box

Using the options in this dialog box, you can create, rename, modify, or delete a conversion
setup. To create a new conversion setup, choose the New button from the dialog box; the New
Conversion Setup window will be displayed. In the window, enter a name in the New Conversion
setup name edit box and select an option from the Based on drop-down list. Next, choose the
Continue button; the window will be closed and the Modify Conversion Setup dialog box will
be displayed. Customize the settings based on your requirement in this dialog box and then
choose the OK button to close it. Then, choose the Close button to close the Conversion Setups
dialog box.

After specifying all options in the Files Tree and Files Table tabs, and the Select a conversion
setup area, choose the Convert button; the selected drawing file or entire list of drawing files
will be converted into the specified file format.

Generating Data by Using the Printing Tools

Printing paper copies of the drawing is another way of providing the project output. The
Application Menu provides various useful options such as Page Setup, Manage Plotters, Manage
Plot Styles and Plot for managing printing processes. Some of the printing tools available in
the Application Menu are discussed next.

Plot Tool

You can use the options in the Plot dialog box to specify the settings for plotting. To invoke
this dialog box, choose the Print option from the Application menu; a cascading menu will
be displayed. Next, choose the Plot tool from the displayed menu; the Plot dialog box will be
displayed. Figure 2-13 shows the Plot-Model dialog box. The options in the Plot dialog box
are discussed next.
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Figure 2-13 The Plot-Model dialog box

Page setup Area

In the Page setup area, the Name drop-down list displays the name of the current page
setup. To select a previously saved page setup, choose the required option from the Name
drop-down list. You can also import the page setup. To do so, choose the Import option in
the Name drop-down list; the Select Page Setup From File dialog box will be displayed.
You can use the options in this dialog box to browse and open the required page setup.

To save the current page setup for future reference, choose the Add button in the Page
setup area; the Add Page Setup dialog box will be displayed. Specify a name for the page
setup in the text box and choose the OK button. The page setup will be saved and the name
of the saved page setup will be added to the Name drop-down list of the Plot dialog box.

Printer/plotter Area

The options in the Printer/plotter area are used to modify the properties of the selected
printer or plotter template. When you select a page setup from the Name drop-down list,
the Properties button will get activated. You can use the Properties button to modify the
settings of the printer/plotter template as per your requirement. If you need to apply settings
from an existing template file, select a template from the Name drop-down list; the Name,
Where, and Description properties of the page setup will be displayed in the Printer/plotter
area. Also, the preview of the modified settings will appear in the display box below the
Properties button. You can select the Plot to file check box to plot the drawing to a file,
instead of printing on a paper.
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Paper size Area

The drop-down list in the Paper size area is used to specify standard paper dimensions. You
can modify the existing paper dimension of a standard template by selecting the required
option from the drop-down list in this area. You can specify the number of copies to be
printed using the Number of copies spinner.

Plot area

The option in the Plot area is used to specify the area in the drawing for plotting. To do
so, select an option from the What to plot drop-down list. If you select the Window option
from this drop-down list, the cursor will change to a crosshair. You can use the crosshair to
select the required plot region in the drawing. Selecting the Limits option from the What to
plot drop-down list will plot all the drawing objects in the selected paper area of the current
layout. You can select the Display option to plot all the drawing objects that are currently
displayed in the drawing window.

Plot offset Area

The options in the Plot offset (origin set to printable area) are used to set the position
of the drawing with respect to the printing paper. To specify the distance along x and y
directions from the lower left corner of the paper, enter the values in the X and Y edit boxes,
respectively. To keep the drawing file at the center of the paper source, select the Center
the plot check box.

Plot scale Area

The options in the Plot scale area are used to adjust the scale of the drawing up to the
extents of the paper. Select the Fit to paper check box to fit the drawing proportionally to
the paper source. Alternatively, you can apply custom settings for the plot scale by clearing
the Fit to paper check box. On doing so, the Scale drop-down list and other options will
become active. Now, you can specify the required scale by selecting an option from the Scale
drop-down list and entering the required values in the corresponding edit boxes.

After specifying the properties in the Plot dialog box, choose the OK button; the plotter will
begin plotting the specified file. But, in case you have selected the Plot to file check box in
the Plot dialog box, the Browse for the Plot File dialog box will be displayed on choosing the
OK button. Specify the plot file location and name in the Browse for Plot File dialog box and
choose the Save button.

Note
@ You will notice a message box on the lower right corner in the Application Status bar displaying
" the information about the plotting process. 1o view the details of the printing process, click on the
link in the message box.

O Tip: You can also preview the result of plotting by choosing the Preview button in the Plot
dialog box.

Batch Plot Tool

The Batch Plot tool in the Print panel of the Application Menu is used to publish multiple
sheets or drawings. To invoke this tool, choose Print > Batch Plot from the Application Menu;
the Publish dialog box will be displayed, as shown in Figure 2-14.
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Figure 2-14 The Publish dialog box

In this dialog box, select the required sheet set data file from the Sheet List drop-down list.
Alternatively, you can select the sheet set data by choosing the Load Sheet List button on
the right of this drop-down list. Next, to apply a file format for publishing the sheet set

data file, select an option from the Publish to drop-down list. Additionally, select the
Automatically load all open drawings check box to add all the currently open drawings to the
publishing list.

On applying the required settings, the information regarding the file to be published will appear
in the Publish Options Information display area. To edit the user publishing details, choose
the Publish Options button; the Publish Options dialog box will be displayed. Change the user
settings by modifying the settings in this dialog box and then choose the OK button.

O Tip: You can also invoke the Publish dialog box by choosing the Batch Plot tool from the
Plot panel of the Output tab in the ribbon.

To add a sheet set to the publishing list, choose the Add Sheets button above the sheet

list box. On doing so, the Select Drawings dialog box will be displayed. Next, browse to
the location of the required file/s and choose the Select button; the selected file/s will be displayed
in the list box showing the added sheet set for publishing. The options in the Publish Output
area are used to set the property for publishing the sheet set data. To change the number of
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copies of a published set, specify the value in the Number of copies spinner. To add plot stamp
to the sheet set data, select the Include plot stamp check box in the Publish Output area. To
modify the plot stamp settings, choose the Plot Stamp Settings button. Select the Publish E
in background check box to hide the Publish Job Progress dialog box while publishing
selected sheets. If you select the Open in viewer when done check box, the sheet set will be
displayed in a viewer when it is published. The details of the properties of the sheet set file
selected will be displayed in the Selected Sheet Details display box.

After specifying the required settings in the Publish dialog box, choose the Publish
button; the Publish Job Progress dialog box will be displayed. This dialog box will display the
progress of publishing. In case the Publish in background check box is selected in the Publish
dialog box, the Plot - Processing Background Job dialog box will be displayed. Choose the Close
button to close this dialog box. Note that the plot processing will continue in the background.

Page Setup Tool

You can specify the settings for the page setup by using the Page Setup tool. To do so, choose
Print > Page Setup from the Application Menu; the Page Setup Manager dialog box will be
displayed, as shown in Figure 2-15. The options in this dialog box are discussed next.

Page setups Area

The options in the Page setups area are used to create a new page setup template, modify
an existing template, and remove an unused template. To create a new page setup, choose
the New button on the right of the Current page setup list box; the New Page Setup dialog
box will be displayed. In this dialog box, enter the desired name of the page setup in the
New page setup name edit box and then choose the OK button; the Page Setup - Model
dialog box will be displayed. In this dialog box, apply all required printer settings and then
choose the OK button; the Page Setup - Model dialog box will be closed and the newly
created page setup will be added to the Current page setup list box of the Page Setup
Manager dialog box.

Selected page setup details area
The Selected page setup details area displays the settings of a selected page setup such as
device name, plotter, plot size, and description.

To modify the settings in an existing page setup file, select the name of the page setup in the
Current page setup list box and then choose the Modify button; the Page Setup dialog box will
be displayed, as shown in Figure 2-16. Some of the options in this dialog box are same as those
discussed in the Plot dialog box. The remaining options in this dialog box are discussed next.

Plot style table (pen assignments) Area

The options in the Plot style table (pen assignments) area are used to change the plotting
style of drawings and layers in layouts. To apply the standard plot style table to the current
layout, select the required option from the Plot style table drop-down list. You can modify
the plot style table settings as per your requirements. To do so, choose the Edit button
next to the Plot style table drop-down list; the Plot Style Table Editor dialog box will be
displayed. Specify the required values in this dialog box and then choose the Save & Close
button to apply the settings and to close the dialog box. To display the plot style settings in
the drawing, select the Display plot styles check box in this area.
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Figure 2-15 The Page Setup Manager dialog box

Shaded viewport options Area

The options in the Shaded viewport options area are used to specify the values for the
shading of the layout. To specify how the plot should be viewed, select the required option
from the Shade plot drop-down list. To adjust the quality of the view in the layout, select
an option from the Quality drop-down list.

Plot options Area

The Plot options area is used to set plotting styles in a layout. To ignore line weights while
plotting objects, clear the Plot object lineweights check box. To plot the layout by using
the chosen plot style, select the Plot with plot styles check box. To plot objects in paper
source before styling objects in model space, clear the Plot paper source last check box. To
hide objects in paper space while plotting, select the Hide paperspace objects check box.
You can also apply transparency to the plot style. To do so, select the Plot transparency
check box in this area.

Drawing orientation Area

The Drawing orientation area is used to orient the drawing layout to the paper layout. To
apply the portrait or landscape orientation to the drawing layout, select the Portrait or
Landscape radio button. To plot the drawing layout upside down with respect to the plotting
paper, select the Plot upside-down check box.
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Figure 2-16 The Page Setup dialog box

After specifying the properties in the Page Setup dialog box, choose the OK button to apply the
settings and close the dialog box. The newly created page setup will be added to the Current
page setup list box of the Page Setup Manager dialog box. Next, choose the Close button to
close the Page Setup Manager dialog box.

Manage Plotters Tool

The Manage Plotters tool is used to edit or modify the settings of the added plotters. To invoke
this tool, choose Print > Manage Plotters from the Application Menu; the Plotters Manager
dialog box will be displayed. In this dialog box, edit and adjust the plotter settings as per your
requirement.

Manage Plot Styles Tool

The Manage Plot Styles tool is used to create and edit the plot styles. To invoke this tool, choose
Print > Manage Plot Styles from the Application Menu; the Plot Styles Manager dialog box
will be displayed. Set the required options in this dialog box to create a new plot style.

Note
The Plotter Manager and Plot Style Manager dialog boxes will be available for editing only
after you install a plotter.
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View Plot and Publish Details Tool

The View Plot and Publish Details tool is used to interpret the details of plotting and publishing.
To know the details of plotting and publishing, choose Print > View Plot and Publish Details
from the Application Menu; the Plot and Publish Details dialog box will be displayed. The
options in this dialog box are used to check the details of plotting or plotting errors, as shown
in Figure 2-17.

Plot and Publish Deta et
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Figure 2-17 The Plot and Publish Details dialog box with plot and publish details

In the Plot and Publish Details dialog box, you can display the details of all printing jobs or
the one that encountered errors while executing printing by selecting the All or Errors Only
option from the View drop-down list. To copy the displayed information from the Plot and
Publish Details dialog box, choose the Copy to Clipboard button. You can now paste the text
in any text editing application such as Notepad or Wordpad.

Q Tip: You can also invoke the Plot and Publish Details dialog box by choosing the View
Details tool from the Plot panel of the Output tab.

Generating Data Using the Publish Option

The Publish option in the Application Menu allows the user to generate AutoCAD Map 3D
output using various tools and techniques. These data sharing techniques in the Publish option
are discussed next.

Using the Publish to Map Server Tool

AutoCAD Map 3D allows user to publish the native DWG file directly to the Autodesk
Infrastructure Map Server, without the loss of attribute data or visual styling of the DWG drawing
file. This enables the user to share the data quickly and cost eftectively through a web browser.
To publish a drawing to the AutoCAD Infrastructure Map Server, choose Publish > Publish to
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Map Server tool from the Application Menu; the Publish to Infrastructure Map Server dialog
box will be displayed. In this dialog box, you can select and configure the schema, classes, and
attributes of the drawing to be published. To do so, select the required drawing features in the
Configure DWG Element For list box and then, choose the browse button next to the Select
Destination Folder edit box; the Select Destination Folder dialog box will be displayed. In
this dialog box, enter the address of the map server in the Connect to site text box and choose
the Connect button; the Connect to Infrastructure Map Server Site dialog box is displayed.
Enter the login credentials in this dialog box and choose the OK button. The contents of the
map server repository will be displayed in the Select Destination folder list box of the Select
Destination Folder dialog box. Select the folder from the list box and choose the OK button;
the Select Destination Folder dialog box will be closed. In the Publish to Infrastructure Map
Server dialog box, select the Show map in web browser after publishing check box to display
the map after publishing. Next, choose the Publish button; the map will be published and the
default web browser will display the published map.

Using the Send to 3D Print Service Tool

The Send to 3D Print Service tool is used to send 3D solid objects or 3D water tight meshes to
a 3D printer service. To invoke this tool, choose Publish > Send to 3D Print Service from the
Application Menu; the 3D Printing - Prepare Model for Printing window will be displayed. In
this window, choose the Continue option; the cursor will change into a selection box. Now, you
can select 3D objects or water tight meshes by using the selection box. For example, if you select
a 3D box object from a drawing by using the selection box and then press ENTER, the Send to
3D Print Service dialog box will be displayed, as shown in Figure 2-18.

The 3D objects in the drawing can be selected by using the options in the Objects area. To select
more objects, choose the Select objects button in this area; the Send to 3D Print Service dialog
box will be closed. Select the required object in the drawing area by clicking on individual objects
or by drawing a selection box. Next, press ENTER; the Send to 3D Print Service dialog box
will be displayed again. The selected 3D objects will be displayed in the Output preview area of
this dialog box. Use the zoom controls at the top of the display box to adjust the display extent
of the selected 3D objects. The true dimensions of the selected 3D objects will be displayed in
the Output dimensions area. The Scale edit box displays the scale of the selected object. The
Length, Width, and Height edit boxes display the length, width, and height of the selected
3D object, respectively. You can change the dimensions in the Output dimensions area. Next,
choose the OK button; the Create SLT File dialog box will be displayed. Specify the SLT file
name and location in the dialog box and choose the Save button to save the file. You need to
send this SLT file to the 3D printing service for printing.
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Figure 2-18 The Send to 3D Print Service dialog box displaying a 3D object

Using the Archive Tool

The Archive tool is used to store the entire sheet or a part of it. To invoke this tool, choose
Publish > Archive from the Application Menu; the Archive a Sheet Set dialog box will be
displayed, as shown in Figure 2-19.

[A Archive a Sheet Set

~
PE.E Current sheet set: Mew Shest Set (1)

Sheets | Files Tree | Files Table

Enter notes to include with this archive:

| -~

[ View Report ] [ Modify Archive Setup... ] [ Help l

Figure 2-19 The Archive a Sheet Set dialog box

In the Archive a Sheet Set dialog box, the Sheets tab displays the added sheet set data. The
Files Tree tab shows the list of files in the sheet set. To add files in the files list of the sheet set,
choose the Files Tree tab and then choose the Add File button located at the lower right corner
of the list box; the Add File to Archive dialog box will be displayed. In this dialog box, select
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the required file and choose the Open button; the selected file will be added to the list of files.
To see details of the files in the sheet set data, choose the Files Table tab. Files can be added in
this table as well. To do so, choose the Add a File button from the lower right corner of the list
box; the Add File to Archive dialog box will be displayed. In this dialog box, select the required
file and choose the Open button; the selected file will be added to the list of files.

You can also add notes related to sheet set data in the Enter notes to include with this archive
text box below the Sheets tab in the Archive a Sheet Set dialog box. To view details of a sheet
set file, choose the View Report button; the View Archive Report dialog box will be displayed.
This dialog box displays the properties of the sheet set such as Archive Report, Sheet Set, Files,
and Sheet Set Data File. To change the setup of the archive, choose the Modify Archive Setup
button; the Modify Archive Setup dialog box will be displayed. In this dialog box, you can modify
the archive package type, file format, file location/path, file name, and include options as per
your requirement. Choose the OK button to apply the settings and close the Modify Archive
Setup dialog box. Next, choose the OK button to close the Archive a Sheet Set dialog box; the
Specify Zip File dialog box will be displayed. Specify the archive file name and location for
saving the file in this dialog box. Next, choose the Save button; the archive file will be created
and saved at the specified location.

Sending Files as Packages

This is an additional feature available in AutoCAD Map 3D. This option enables you to transfer
data files in form of different packages. The different methods for sending the file package
through web services are discussed next.

Sending Files by Using the eTransmit Tool

The eTransmit tool is used to create a package by adding data and dependent files to it. This
package can be transmitted through internet. To create an eTransmit data package, choose Send
> eTransmit from the Application Menu; the Create Transmittal dialog box will be displayed,
as shown in Figure 2-20.

By default, the Files Tree tab is chosen in the Create Transmittal dialog box. To add data files
to a package, choose the Add File button located at the lower right corner of the Files Tree tab;
the Add File to Transmittal dialog box will be displayed. In this dialog box, select the required
file and then choose the Open button; the selected file will be displayed in the Files Tree list
box. To check details of each file added in the package, choose the Files Table list box. You
can also add data file by choosing the Add File button located at the lower right corner of the
Files Table list box.

A list of transmittal setup is available in the Select a transmittal setup list box. To apply a
transmittal setup to the current drawing, select the required option from the Select a transmittal
setup list box; the information about the transmittal setup will be displayed in the Setup
description display box. To create a new setup or modify an existing setup, choose the Transmittal
Setups button located at the bottom of the Select a transmittal setup area; the Transmittal Setups
dialog box will be displayed. The options in this dialog box are used to create a new transmittal
setup or modify an existing transmittal setup. On modifying or creating a new setup, choose
the Close button in the Transmittal Setups dialog box to close it. You can enter the description
of the package in the Enter notes to include with this transmittal package text box below the
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Tree Files list box. The Preview display box shows the preview of the drawing selected in the
Tree Files or Files Table tabs. To read the details of the transmittal package, choose the View
Report button at the bottom left of the Create Transmittal dialog box. After specifying all the
required parameters of the transmittal package, choose the OK button to create the transmittal
package (zip file).

|& Create Transmittal @
ﬁ Cument Drawings): jl Cument user: CADCIM
Files Tree | Files Table Select a transmittal setup
= Curent Drawing

(8 W Block dwg

Setup description:

[ Transmittal Setups...

Included 1 filz(s). 51KB Add File... Preview

Enter notes to include with this transmittal package:

| -

o] (s ) o)

Figure 2-20 The Create Transmittal dialog box displaying an added data file

Sending E-mail with Compressed File Attachment

The Email tool is used to attach the transmittal package as an attachment with a mail. To use this
tool, you must set up the User profile using the Mail tool in the Control Panel of the Windows
operating system. After creating the User profile, choose Send > Email from the Application
Menu; the MS Outlook window with transmittal package zip file attached to the mail will be
displayed. You can send this mail as a normal e-mail with an attachment.

UNDERSTANDING THE CONCEPT OF SHEET SETS

A sheet is a layout formed from a drawing file. A sheet set is an organized collection of

sheets from several drawing files. A sheet set organizes maps systematically and efficiently
by providing easy access to various drawing files. It is very easy to plot and publish all drawings
in a sheet set. You can manage and create sheet sets by using the SHEET SET MANAGER
window. To invoke the SHEET SET MANAGER window, choose the Sheet Set Manager button
from the Palettes panel in the View tab. Alternatively, press CIRL+4 keys; the SHEET SET
MANAGER window will be displayed. In this window, you can set the properties of the sheet
set data.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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In AutoCAD Map, you can create a sheet set in two different ways by using either an example
sheet set or an existing drawing. Both these methods are discussed next.

Creating a Sheet Set by Using an Example Sheet Set

To create a sheet set by using an example sheet set, choose New > Sheet Set from the Application
Menu; the Create Sheet Set wizard will be displayed. By default, the Begin page will be displayed
in the wizard, as shown in Figure 2-21. Alternatively, to invoke the Create Sheet Set wizard, choose
the New Sheet Sets tool from the SheetSet drop-down in the SHEET SET MANAGER window.

Q Tip: You can also use the NEWSHEETSET command to invoke the Create Sheet Set wizard.

Create Sheet Set - Begin (=)

P Begin

Sheet Set Example
Create a sheet set using

Sheet Set Details

Canfirm

© Existing drawings

This option uses an existing sheet set to provide the organizational
structure and default settings forthe new sheet set. The option wil
not copy any sheets from the existing sheet set. After you create a
sheet set with this option, you can import layouts or create sheets
individually.

Figure 2-21 The Begin page of the Create Sheet Set wizard

Select the An example sheet set radio button from the Begin page of the Create Sheet Set
wizard, and then choose the Next button; the Sheet Set Example page of the wizard will be
displayed, as shown in Figure 2-22.

In this page, the Select a sheet set to use as an example radio button is selected by default.
The list box below this radio button displays a list of default sheet sets. By default, Architectural
Imperial Sheet Set is selected in the list. The title and the description of the selected sheet set
are displayed at the lower portion of the Create Sheet Set wizard.
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Create Sheet Set - Sheet Set Bample (2]
Begin (@) Select a sheet set to use as an example
) Sheet Set BExample Architectural Imperial Sheet Set

Architectural Metric Sheet Set

Sheet Set Details Civil Imperial Sheet Set
Civil Metric Sheet Set

Corfirm Manufacturing Imperial Shest Set
Manufacturing Metric Sheet Set
New Sheet Set

() Browse to another sheet set to use as an example

map 3d 2016%20.1"enu template\Architectural Imperial Sheet Set.dst || ...

Title: Architectural Imperial Sheet Set

Description: Use the Architectural Imperial Sheet Set to create a new shest
set with a default sheet size of 24 x 36 inches.

[ <Back |[ Net> | [ Cancel |

Figure 2-22 The Sheet Set Example page of the Create Sheet Set wizard

You can also select a custom sheet set located in other location. To do so, select the Browse to
another sheet set to use as an example radio button; the edit box below this radio button will
be activated. Next, enter the location of the sheet set in the edit box or choose the browse button
next to it; the Browse for Sheet Set dialog box will be displayed. Using this dialog box, you can
locate the sheet set file, which is saved with the .dst extension. After selecting the sheet set file
to be used as an example, choose the Next button; the Sheet Set Details page of the wizard will
be displayed, as shown in Figure 2-23.

Specify the name of the new sheet set in the Name of new sheet set edit box. Optionally, you
can specify some information about the sheet set in the Description (optional) text box. The
Store sheet set data file (.dst) here edit box displays the location where the sheet set data file
will be stored. You can modify the default location by entering a new location or by selecting
the folder using the Browse for Sheet Set Folder dialog box that is displayed on choosing the
Browse button.

The sheet set properties such as name, storage location, template, and description can be
modified by using the Sheet Set Properties button. To do so, choose the Sheet Set Properties
button from the Sheet Set Details page; the Sheet Set Properties dialog box will be displayed
with the sheet name. To edit the values under the Sheet Set Custom Properties head of the
dialog box, choose the Edit Custom Properties button; the Custom Properties dialog box will
be displayed. Now, add or delete the required properties and choose the OK button to exit
this dialog box. Next, choose the OK button to exit the Sheet Set Properties dialog box. After
specifying the parameters in the Sheet Set Details page of the Create Sheet Set wizard, choose
the Next button; the Confirm page of the wizard will be displayed, as shown in Figure 2-24.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com



Evaluation Copy. Do not reproduce. For information visit www.cadcim.com

2-30 Exploring AutoCAD Map 3D

Begin Sheet Set Preview:

Siz=igiEETiE 5 New Sheet Set (1)
IQJ‘ General

IgJ‘ Architectural

b Corfim @ Structural

EJJ‘ Electrical

IQJ‘ Mechanical
IQJ‘ Plumbing

@ Fire Protection
B gy

E—_ll Landscape

Sheet Set Details

Mote: References to sheets in the source sheet set are not copied.

Sheet Set Copied

Architectural Imperial Sheet Set

Sheet set data file copied:

ChUsers\CADCIM appdatalocal autodesk \autodesk autocad map 3d
2016420 1'enu template Architectural Imperial Sheet Set dst

New Sheet Set

Sheet set name:

[ <Back [ Fnmsh | [ Canesl

Figure 2-24 The Confirm page of the Create Sheet Set wizard

This page shows the detailed structure of the sheet set and also lists its parameters and properties.
Choose the Finish button; the Create Sheet Set wizard will be closed and the Sheet Set Manager
window will be displayed with the new sheet added to the drop-down list. The Sheet List tab of
the Sheet Set Manager window will display the new sheet structure. To view the sheet, choose the
Sheet List tab. Next, right-click in the blank space; a shortcut menu will be displayed. Choose the
Preview/Details Pane option from the shortcut menu; the Details pane will be displayed with the
details of the new sheet set. To view the model, choose the Model Views tab; the details of the
model will be displayed in the Details pane. Also, you can add new drawing or folder location
in this tab. To do so, choose the Add New Location node and right-click; a shortcut menu will
be displayed. Choose the Add New Location option from the shortcut menu; the Browse for
Folder dialog box will be displayed. Select the required drawing or folder and choose the Open
button; the location will be added to the tab.

Note
The path of the file shown in Figures 2-22, 2-23, and 2-24 may vary from user to user, depending
wpon the location of the sheet set data saved.

Creating a Sheet Set by Using Existing Drawings

As mentioned earlier, this type of sheet set is used to organize and archive an existing set of drawings.
To create this sheet set, select the Existing drawings radio button from the Begin page of the
Create Sheet Set wizard and then choose the Next button; the Sheet Set Details page of the
wizard will be displayed. On the Sheet Set Details page, enter the name and description of
the sheet set. After setting the required parameters on this page, choose the Next button; the
Choose Layouts page will be displayed. Choose the Browse button from this page and browse
to the folder in which the files to be included in the sheet set are saved. All drawing files along
with their initialized layouts will be displayed in the list box below the Browse button.
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TUTORIALS

General instructions for downloading tutorial files:
Before starting the tutorials, you need to download the tutorial data to your computer. To do
so, follow the steps given below:

1. Log on to www.cadcim.com and browse to Textbooks > Civil/GIS > Map 3D > Exploring AutoCAD
Map 3D 2016. Next, select c02_m3d_2016_tut.zip file from the Tutorial Files drop-down list.
Next, choose the corresponding Download button to download the data file.

2. Extract the contents of the zip file to the following location:
C:\m3d_2016

Notice that the ¢02_m3d_2016_tut folder is created in the m3d_2016 folder.

Tutorial 1 Using the Connect Tool- |

In this tutorial, you will connect various datasets to your drawing by using the Connect tool.
(Expected time: 30 min)
The following steps are required to complete this tutorial:

a. Create a new drawing file.
b. Load the image and shape files by using the Connect tool.
c. Save the drawing file.

Creating a New Drawing File
1. Choose New > Drawing from the Application Menu; the Select template dialog box is
displayed.

2. In this dialog box, ensure that the map2d.dwt template file is selected. Choose the Open
button; the map2d.dwt template settings are applied to the modeling space.

Loading the Data Using the Data Connect Wizard
In this part of the tutorial, you will load dataset to the drawing by using the Connect tool.

1. Choose the Connect tool from the Data panel in the Home tab; the DATA CONNECT
wizard is displayed.

2. In the DATA CONNECT wizard, select the Add Raster Image or Surface Connection
option from the Data Connection by Provider list box; the Autodesk FDO Provider for
Raster page is displayed in the right pane of the wizard.

3. In this page, enter Base Map in the Connection name edit box, and then choose the
button next to the Source file or folder edit box; the Open dialog box is displayed.

4. In the Open dialog box, browse to the following location:

C:\m3d_2016\c02_m3d_2016_tut\c02_tut01

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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®

Select the AustinTX . jpg file and then choose the Open button in this dialog box; the Open
dialog box is closed. Also, in the DATA CONNECT wizard, the Connect button is activated
and the path of the selected file is displayed in the Source file or folder edit box.

Next, choose the Connect button; the Raster Image or Surface page is

displayed in the right pane of the wizard, as shown in Figure 2-25.

Data Connections by Provider [?] Data Connect help
Fd Add ArcSDE Connection Raster Image or Surface

4 Add Enterprise Industry Model | Raster_1 (C:\m3d_2016\c02_m3d_2016_tuticD2_tt03AustinTX jpg)

fd Add ODBC Connection

2 Add Oracle Connection Available sources in this connection. Select ltems to add to the map as la
Yl Add PostgreSOL Connection (0 Edit Coordinate Systems

& Add Raster Image or Surface Co

4 Add SDF Connection = [v] JPG

54 Add SHP Connection Chm3d_20164%02_m3d_2016_tuthc02_tutd AustinTd jpg <

-0 Add SOL Server Spatial Connect
ﬂ Add 50Lite Connection

A Add WFS Connecticn

3 Add WMS Connection

£ >

Py -
[] Combine into ene layer: % Add to Map
Map Coordinate System
< unknown =

< unknown =
< unknown =

Te reconfigure this cennection, disconnect, and TFezrrmea:
< > then edit the information.

Figure 2-25 The Raster Image or Surface page of the DATA CONNECT wizard

Choose the Add to Map button; the image file AustinTX.jpg is added
to the drawing and is displayed in the drawing window. Note that the
AustinTX layer is added to the list box in the Display Manager tab of the TASK PANE.

< Add to Map -

Next, you will add SHP data to the drawing using the DATA CONNECT wizard. To do so,
open the DATA CONNECT wizard in case you have closed it.

In the DATA CONNECT wizard, select the Add SHP Connection option from the Data
Connections by Provider list box; the OSGeo FDO Provider for SHP page is displayed in
the right pane of the wizard.

Enter ShapeData in the Connection name edit box. Next, choose the button displayed next
to the SHP button from the OSGeo FDO Provider for SHP area; the Browse For
Folder dialog box is displayed.
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10.

11.

12.

13.

14.

Browse to C:\m3d_2016\c02_m3d_2016_tut and then select the ¢c02_tut01 folder. Next, choose
the OK button in the Browse For Folder dialog box; the dialog box is closed. Also, the path
of the selected folder is displayed in the Source file or folder edit box and the Connect
button is also activated in the wizard.

Next, choose the Connect button; the SHP page is displayed in the right
pane of the wizard.

Notice that the list box in this page displays the list of all the SHP files available in the
selected folder. The coordinate system of the SHP data is also displayed in the list box.

Select the check box corresponding to the SHP files AustinTX_Address, AustinTX_
BuildingFootprints, and AustinTX_street in the list box.

Next, choose the Add to Map button; the shape files are added into the =Z
drawing. Close the DATA CONNECT wizard to see the data in the
drawing window.

Add to Map -

The Display Manager tab of the TASK PANE displays the name of the shape data added
to the drawing, as shown in Figure 2-26.

TASK PANE

S =

Data Style Table Tools Maps

= [¥] (1 ShapeData
:
I AustinTX_E
() AustinTX !
- Map Base
| Default

AustinTX_§

Figure 2-26 The Display Manager tab showing the added SHP file data

Saving the Drawing File

1.

Choose the Save As tool from the Application Menu; the Save Drawing As dialog box is
displayed.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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2. Inthe Save Drawing As dialog box, browse to the location C:\m3d_2016\c02_m3d_2016_tut\cO2_
tut01 and enter c02_TutO0la.dwg in the File name edit box.

3. Choose the Save button; the drawing file is saved.

Tutorial 2 Using the Connect Tool - lI

In this tutorial, you will connect and load the data from a WMS. You will also query and add
vector data to the drawing using the Connect tool. (Expected time: 25 min)

The following steps are required to complete this tutorial:

a. Create a new drawing file.

b. Connect to the link given below using the Connect tool.
hitp://eusoils.jrc.ec.europa.ew/wrb/wms_Threats.asp?

¢.  Add data from WMS and SHP files using the Connect tool.

d. Save the drawing file.

Creating a New Drawing File
1. Choose New > Drawing from the Application Menu; the Select template dialog box is
displayed.

2. Inthe Select template dialog box, select the map2d template file from the list box below the
Look in drop-down list, and then choose the Open button; the map2d template is applied
to the modeling space.

Loading Data from Web Map Service (WMS) Data and SHP File

In this section, you will connect and load data from a web map service using the WMS client in
AutoCAD Map 3D.

1. Choose the Connect tool from the Data panel in the Home tab; the DATA CONNECT
wizard is displayed.

2. In the Data Connect wizard, select the Add WMS Connection option from the Data
Connection by Provider list box; the OSGeo FDO Provider for WMS page is displayed in
the right pane of the wizard.

3. In this page, enter WMS_EuropeanSoilPortal in the Connection name edit box. Next, in
the Server name or URL edit box, enter the link given below:

hitp://eusoils.jre.ec.europa.eu/wrb/wms_Threats.asp?

4. Ensure that the Default version option is selected in the Version drop-down list and then
choose the Connect button; the User Name & Password dialog box is displayed. The
selected WMS is a free resource and no login credentials are required to access the data.

5. Choose the Login button; the User Name & Password dialog box is closed and the
Connecting message box is displayed. On establishing a connection with the web map server,
the WMS page is displayed in the DATA CONNECT wizard. The list box in this page shows
various schemas available in the selected WMS, refer to Figure 2-27.
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Schema
WMS_Schema
B[] € Soil Threats

] £ sail pH in Europe

1)) Organic carbon c..
O e Soil Erosion int/...

O G Natural Seil Susc..,
[[] £ Saline and Sodic ...

Image Fermat

png
png
png
png
png
png

Server C§ Code

EP5G:4326
EP5G:4326
EP5G:4326
EP5G:4326
EP3G:4326
EP5G:4326

Style

<Default>
<Default>
<Default>
<Default>
<Default>
<Default>

Background

[ ] Transparent
|:| Transparent
[ ] Transparent
[ ] Transparent
|:| Transparent
[ ] Transparent

Figure 2-27 The list of schemas available on the web map server

6. Select the check boxes corresponding to Organic carbon content, Soil 27 Add to Map ~
Erosion in t/ha/yr and soil pH in Europe and then choose the Add to
Map button; Map 3D will communicate with the WMS and add the selected data into the

map.

Note

¥ Loading data from WMS may require some time depending on your internet speed and the volume
~ of data traffic on the web map server.

When the loading process is completed, the map is displayed in the drawing window, as shown

in Figure 2-28, and the name of the added layers is displayed in the Display Manager tab of

the TASK PANE. You can toggle the display of layers in the drawing by selecting the check box

corresponding to the layer name that you want to display.

Figure 2-28 The WMS data displayed in the drawing window

Next, you will add the vector map of Europe to your map.

7. In the DATA CONNECT wizard, select the Add SHP Connection option from the Data
Connections by Provider list box; the OSGeo FDO Provider for SHP page is displayed in
the right pane of the wizard.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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8.

©

—
=

11.

12.

13.

In this page, enter Europe in the Connection name edit box. Next, choose the SHP
button from the OSGeo FDO Provider for SHP area; the Open dialog box is displayed. ——

Browse to the C:\m3d_2016\c02_m3d_2016_tut| c02_tut02 and choose the Country.shp file.

. Next, choose the Open button in the Open dialog box; the dialog box is closed and the

path of the selected SHP file is displayed in the Source file or folder edit box. Notice that
the Connect button has also been activated.

Next, choose the Connect button; the SHP page is displayed in the right
pane of the wizard.

Choose the Add to Map with Query tool from the drop-down
displayed below the list box; the Create Query window is
displayed.

‘o> Add to Map with Query ~

Enter Continent = ‘Europe’ in the edit window, as shown in the Figure 2-29, and choose
the OK button in the Create Query window; the query is executed and the filtered map
objects are added to the drawing window. Next, close the DATA CONNECT wizard.

Create Query @

E.%. 5k . % M. B . G.E.

Property  Operator Math Function  Text Function  Date Function Locate on Map Geometric  Conversion

&R +=2s ERBIZED

Continent = 'Europe'|

(2}
o Validate £% Clear |[Q] Zoom Extents Show Location |[& Options ~ Getting Started

[ oK [ camesl || Help

Figure 2-29 The Create Query window displaying the query

Saving and Closing the Drawing File

1.

2.

Choose the Save tool from the Application Menu; the Save Drawing As dialog box is
displayed.

In this dialog box, enter c02_Tut02a.dwg in the File name edit box.
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3. Select the AutoCAD 2013 Drawing (*.dwg) option in the Files of type drop-down list located
at the bottom of the Save Drawing As dialog box, if not selected by default.

4. Choose the Save button; the drawing file is saved.

Tutorial 3 Using the eTransmit Tool
In this tutorial, you will transfer drawing files through web services by using the eTransmit
tool. (Expected time: 20 min)

The following steps are required to complete this tutorial:

a. Open the drawing file.

b. Create a transmittal package by using the eTransmit tool.
c.  Send an e-mail with transmittal package attached to it.

Opening the Drawing File

1. Choose the Open button from the Quick Access Toolbar; the Select File dialog box is
displayed.

2. In this dialog box, browse to the following location:

C:\m3d_2016\c02_m3d_2016_tutlc02_tut03

3. Select the c02_Tut03 file from the c02_tut03 folder and then choose the Open button in
this dialog box; the drawing is displayed in the drawing window.

Creating the Transmittal Package by Using the eTransmit Tool
In this section of the tutorial, you will create a zip file (transmittal package) for sharing data.

1. Choose Send > eTransmit from the Application Menu; the eTransmit - Save Changes
message box is displayed prompting you to save the drawing before continuing.

2. Choose the Yes button in this message box; the Create Transmittal dialog box is displayed,
as shown in Figure 2-30.

3. In this dialog box, expand the JPG File node in the Files Tree tab; the files in this node
are displayed.

4. Clear the check box corresponding to the AustinTX.jpg subnode.

5. Choose the OK button in the Create Transmittal dialog box; the Specify Zip File dialog
box is displayed.

6. In this dialog box, browse to the following location:

C:\m3d_2016\c02_m3d_2016_tutlc02_tut03

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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' Create Transmittal

E Cument Drawing(s):

Files Tree | Files Table

= P& Cument Drawing
S W c02_Tut03 dwg
1] ¥ML Document
® JPEG Image
| ] JGW File
[mi Autodesk Spatial Data File
|| MAP Fie
i PNG Image

(5
g Cument user: CADCIM
Select a transmittal setup

Setup description:

[ Transmittal Setups...

Included 12 file(s), 15554KB

Add File... Preview

Enter notes to include with this transmittal package:

Figure 2-30 Partial view of the Create Transmittal dialog box with files available for

transmittal

7. Enter c02_Tut03a in the File name edit box and then choose the Save button; the Archive
Package Creation is in Progress message box is displayed showing the progress of the file
creation process. After completion of the process, the message box automatically closes and
the compressed file is saved in the specified folder.

Sending the E-mail with the Current Drawing File Attached to It
1. Choose Send > Email option from the Application Menu, the Microsoft Outlook window

will open, refer to Figure 2-31.

= d = Untitled - Message (HTML) ?2 5 0O %
FILE MESSAGE INSERT OPTIONS FORMAT TEXT REVIEW o
A 2 alz] &% ] . " FollowUp~
Ao [_I Yo 4 .
! HighImportance
Paste B I U 3 A Address Check  Attach Attach Signature Zoom
- Book Names  File Tem= - ¥ LowImportance
Clipboard = Basic Text MNames Include Tags ra  Zoom -~

To..

Send Con

Subject

Attached 02 Tut03.dwa (50 KB}

Figure 2-31 Partial view of the Microsoft Outlook window
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Note
10 send a file using the Email tool in the Application Menu of AutoCAD Map 3D, you need to
install and configure Microsoft Outlook.

2. Enter the email address of the recipients and then send the mail. Close the drawing by
choosing Close from the Application Menu.

Tutorial 4 Loading Survey Data in the Data Store

In this tutorial, you will load the Ground Control Points (GCP) file or the survey point data by
using the Survey tab in the TASK PANE. (Expected time: 30 min)

The following steps are required to complete this tutorial:

a. Start a new drawing file.

b. Create a Data Store with the name Map-3D-2016_Data-Store and assign a coordinate system.
c.  Import the survey point file.

d. Save the file.

Starting a New Drawing File
1. Choose New > Drawing from the Application Menu; the Select template dialog box is
displayed.

2. Inthis dialog box, select the map2d template file in the list box below the Look in drop-down
list, and then choose the Open button; the map2d template is applied to the modeling
space.

Creating a New Data Store
In this section of the tutorial, you will create a survey data store for repositing survey data.

1. Choose the Survey tab in the TASK PANE, if not chosen by default.

2. Choose the Data button in the Survey tab of the TASK PANE; a pop-up menu is Q
displayed. Data

3. From this pop-up menu, choose the New Survey Data Store option; the New Data Store
dialog box is displayed, as shown in Figure 2-32.

& New Data Store IEI

File: Location

Coordinate System Assignment
Enter Code:

- (@)

Dlescription:

[ cencel || Help ]

Figure 2-32 The New Data Store dialog box
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4.

10.

11.

12.

13.

Importing the Survey Data into the Survey

In this dialog box, choose the browse button in the File location area; the Create New
Survey Data Store dialog box is displayed.

In this dialog box, browse to the following location:
C:\m3d_2016\c02_m3d_2016_tut\c02_tut04
Enter Map-3D-2016_Data-Store in the File name edit box.

Select the SDF files (*.sdf) option from the Save as type drop-down, list if not selected by
default.

Choose the OK button; the Create new Survey Data Store dialog box is closed and the
path of the file to be saved is displayed in the File location edit box of the New Data Store
dialog box.

Next, choose the Select Global Coordinate button in the Coordinate System
Assignment area in the dialog box; the Coordinate System Library dialog box is
displayed.

In this dialog box, type zone 43 N in the Search edit box; a list of available coordinate
systems for the specified search parameter will be displayed in the list box below the Search
edit box.

In the list box, select the UTM84-43N code with the description UTM-WGS 1984 datum,
Zone 43 North, Meter; Cent. Meridian 75d E, if not selected by default.

Choose the Select button in the dialog box; the
Coordinate System Library dialog box is closed and
the UTM84-43N code is displayed in the edit box of
the Coordinate System Assignment area in the New
Data Store dialog box. Also, the coordinate description
is displayed below the edit box in the Coordinate
System Assignment area.

TASK PANE

Data Table Toeols Edit Display

Map-3D-2016_Data- v
| 5= Survev Data Store NG
“MEH Show Point Table

?Q Zoom to Data Store

(=)

Display Man

Next, choose the OK button in the New Data Store
dialog box; the Map-3D-2016_Data-Store is created
and added to the Current Data Store drop-down list
in the Survey tab of the TASK PANE. Also, the Survey
Data Store node is added to the list box in the Survey
tab of this pane.

@ Mew Project

Map Explorer

T Impert LandXML...

Impeort ASCIl Peints...

[Z  Paste

M= Hain

Figure 2-33 Choosing the Import
ASCII Points option from the shortcut
menu

Data Store

In this section, you will import the survey data into the survey data store.

1.

In the Survey tab of the TASK PANE, right-click on the Survey Data Store node; a shortcut
menu is displayed.

Choose the Import ASCII Points option from the shortcut menu, as shown in Figure 2-33;
the Import ASCII Points dialog box is displayed.
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3.

In this dialog box, choose the Browse button in the File location area; the Import ASCII

File dialog box is displayed.

In the Import ASCII File dialog box, select the CHIK_TotalStation.asc file from the following

location:

C:\m3d_2016\c02_m3d_2016_tutlc02_tut04

Next, choose the OK button; the Import ASCII File dialog box is closed. Notice that the
path of the selected file is displayed in the File Location edit box of the Import ASCII
Points dialog box. Also, preview of the selected data is displayed in the Preview area, as

shown in Figure 2-34.

File Location

Chm3d_2016%02_m3d_20716_tut\c02_tutD\CHIK_Total Station asc

Formatting
Select Formatting: Z-Unit:

Autodesk Uploadable Fiie v| [ Metes

Preview:

2197346.007  541205.515 95.05 S5T-B6
2197931.977 541245634 34822 5T-78
2197934 6177 5412370538 959117 BUL

Poirt Mumber  {Morthing) ¥[Easting) Z{Blevation) Pairt Descrip...

Coordinate System Assignment

Enter Code:
<! Description: UTM-WGS 1984
UTM84-43N (Last Used) v datum, Zone 43 North, Meter;
Cent. Meridian 75d E

Figure 2-34 The Import ASCII Points dialog box displaying the preview of the selected data

Choose the OK button; the Import ASCII Points dialog box is closed and the survey points
or the Ground Control Points are displayed in the drawing window, as shown in Figure 2-35.

@ Note

If the survey data is not displayed in the drawing window, then right-click on the
Map-3D-2016_Data-Store vector layer in the Display Manager tab of the TASK PANE; a
shortcut menu will be displayed. From this shortcut menu, choose the Zoom to Extents option; the

survey data will be displayed in the drawing window.
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Figure 2-35 The Ground Control Points displayed in the drawing window

Saving the Drawing File

1. Choose the Save As tool from the Application Menu; the Save Drawing As dialog box is
displayed.
2. In this dialog box, enter c02_Tut04a.dwg in the File name edit box.
3. Select the AutoCAD 2013 Drawing (*.dwg) option from the Files of type drop-down list
located at the bottom of the Save Drawing As dialog box if not selected by default.
4. Choose the Save button; the drawing file is saved.
Tutorial 5 Exporting DWG data as SDF data

In this tutorial, you will export the DWG data from the AutoCAD drawing file to SDF data
format. (Expected time: 45 min)

The following steps are required to complete this tutorial:

a.

b.

C.
d.
e.

Open a drawing file with the name m3d_c02_Tut05.dwg.

Create and export the drawing objects as SDF feature classes using the MADDWGTOSDF
command.

Start a new drawing file

Explore the exported SDF file.

Save the file as c02-m3d-2016-TutO5a.dwg.

Opening the Drawing File

1.

2.

Choose Open > Drawing from the Application Menu; the Select file dialog box is displayed.

In the Select file dialog box, select the m3d_c02_Tut05.dwg file from the following location:
C:\m3d_2016\c02_m3d_2016_tut\c02_tut05
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3. Next, choose the Open button; the drawing file is displayed in the drawing window.

Creating Feature Classes

In this section, you will create a set of feature classes using the drawing objects from the drawing

file.

1. Enter the command MAPDWGTOSDF in the command line and press ENTER; the Export

Location dialog box is displayed.

2. In this dialog box, enter New SDF File in the File name edit box. Next, browse to the

following location:

C:\m3d_2016\c02_m3d_2016_tut\c02_tut05

3. Now, choose the OK button; the dialog box is closed and the Export dialog box is displayed
with the Selection tab chosen, as shown in Figure 2-36.

Selection | Feature Class | Options |

Select objects to export

(@ Select all () Select manually
Fiter selection
Layers:
Object classes
Select polygon topology to export
Name: <Nonez
Group complex polygons
Saved profiles
e Coren ot
[ ok | [ cacdl | [ Heb

Automatic selection

Figure 2-36 The Export dialog box with the Selection tab chosen

4. In the Select objects to export area of the Selection tab, choose the Select manually radio

button.

5. Next, choose the button next to the Select manually radio button; the Export
dialog box closes and you are prompted to select objects to be exported.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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®

©

10.

11.

Draw a selection box in the drawing window to select all the drawing objects. Press ENTER
to end selection; the Export dialog box is displayed again.

The objects for creating SDF data have now been selected. Next, you need to specify how
these objects will be mapped in the SDF data.

Choose the Feature Class tab in the Export dialog box. In the Object to Feature Class
Mapping area of this tab, select the Create multiple classes based on a drawing object
radio button.

Note that all the layers in the drawing are displayed in the list box.

Next, clear the check box corresponding to 0 drawing object in the Export dialog box.

Click in the Geometry cell corresponding to the Internal Road drawing object; a drop-down
list will be displayed.

Next, select the Line option from this drop-down list.

Repeat the procedure given in steps 9 and 10 and select the Polygon and Line geometry
options for the Parcels and Utility Lines drawing objects respectively, refer to Figure 2-37.

Selection  Feature Class |Option5 |

Choose how to organize the selected drawing objects

Object to Feature Class Mapping
(") Create a single class from all selected objects
(@ Create multiple classes based on a drawing object

Drawing object to use:  Layer -

Select Attrbutes g;l:;spropeﬂies and attributes to export to all feature

Drawing Object

Feature Class

Geometry

o

0

Point+Line+Polygon

Internal Roads

Internal Roads

Line

Parcels

Parcels

Polygon

Utility Lines

Utility Lines

Line

[7] Show schema names

Saved profiles

Figure 2-37 Partial view of the Export dialog box showing the Geom-
etry option selected for the drawing object
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12. Choose the Select Attributes button in the Export dialog box; the Select Attributes dialog
box is displayed. Expand the node Object Properties > AcDbEntity > General. Select
the check box corresponding to the Color, Linetype, and Lineweight options, refer to
Figure 2-38.

| Select Attributes
Expression:

=[5 AcDbEntity ~

[z 30 Visualization

=¥ 2 General W Cancel

] @ Class Name

& Color

-] ® Layer Help

@ Linetype

[ ] @ Linetype scale

D @ Plot style

[ @ Lineweight

] @ Transparency

-] & Hyperink

=+ 3DS0LID

& INSERT

=+ BODY
ArDhCirwe

S

m

a[m|u]s|

Figure 2-38 The Select Attributes dialog box showing various options selected
13. Next, choose the OK button; the dialog box is closed.

14. Next, click on the Internal Roads cell of the Feature Class column in the table; a browse
button is displayed in the cell, as shown in Figure 2-39.

Selection  Feature Class |Option5 |

Choose how to organize the selected drawing objects

Object to Feature Class Mapping
() Create a single class from all selected objects

(@ Create muttiple classes based on a drawing object

Figure 2-39 The partial view of the Export dialog box showing the browse button displayed in

Drawing object to use:

Select Attributes ...

Layer -

Select properties and attributes to export to all feature

classes
Drawing Object Feature Class Geometry
o 0 Point+Line+Polygon
Internal Roads Internal Roads = | Line
Parcels Parcels Polygon
Utility Lines Utility Lines Line

the Internal Roads cell

15. Choose the displayed Browse button; the Feature Class Property Mapping - Internal Roads

dialog box is displayed.
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16.

17.

18.

19.

20.

21.

In this dialog box, choose the Select Attributes button; the Select Attributes dialog box
is displayed. In this dialog box, expand the Object Data node and then select the Roads
check box.

Now, choose the OK button; the Select Attributes dialog box is closed. Note that the data
columns in the Roads object data table are displayed in the Feature Class Property Mapping
- Internal Roads dialog box.

Next, choose the OK button from the Feature Class Property Mapping - Internal Roads
dialog box; the dialog box is closed.

Repeat the procedure given in steps 14 to 18 and create feature classes for the Parcels and
Utility Lines. In the Select Attributes dialog box, select the Parcels check box for the
Parcels feature class and the Waterlines check box for the Utility Lines feature class.
The drawing objects are now mapped to the feature class. Now, you need to specify the
options for exporting.

Choose the Options tab in the Export dialog box. In the Other area of this tab, select the
Treat closed polylines as polygons check box.

Next, choose the OK button; the Export dialog box is closed and the Export Process
message box is displayed showing the progress of the data being exported.

Starting a New Drawing File

1.

Choose New > Drawing from the Application Menu; the Select template dialog box is
displayed.

In the Select template dialog box, select the map2d template file in the list box below the
Look in drop-down list and then choose the Open button; the map2d template is applied
to the modeling space.

Exploring the Exported SDF file

1.

Choose the Connect tool from the Data panel in the Home tab; the DATA CONNECT
wizard is displayed.

In the DATA CONNECT wizard, select the Add SDF Connection option from the Data
Connections by Provider list box; the OSGeo FDO Provider for SDF page is displayed in
the right pane of the wizard.

In this page, enter New SDF in the Connection name edit box and then choose the
browse button next to the Source file edit box; the Open dialog box is displayed. —

In the dialog box, browse to the location C:\m3d_2016\c02_m3d_2016_tut\c02_tut05 and
select New SDF File. Next, choose the Open button from this dialog box; the path of the
selected file is displayed in the Source file edit box.
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5. Choose the Connect button; the SDF page is displayed TASK PANE
in the right pane of the wizard. 0
6. Next, select the Schemal check box in this page and [ 9 o E
then choose the Add to Map button; the New SDF file g Style Table Tocls Maps
is displayed in the drawing window. Figure 2-40 shows [
the Display Manager tab of the TASK PANE with the
SDF data file. Next, close the DATA CONNECT wizard.
« [¥] 21 NewSDF
Saving and Closing the Drawing File Utility Line
1 Choose the Save As tool from the Application Menu; [ Percels
the Save Drawing As dialog box is displayed.
Internal Ro
2. In the Save Drawing As dialog box, enter c02_Tut05a. : Map Base
dwg in the File name edit box. Figure 2-40 Partial view of the
Display M tab in the TASK
3. Choose the Save button; the drawing file is saved. P;lsl{)’Ea y Hlamager 1ab wm te

Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1.

Which of the following data connections is used to access Autodesk’s spatial data
format?

(a) Add SDF Connection
(c) Add WFS Connection

(b) Add SHP Connection
(d) Add WMS Connection

Which of the following tabs in the TASK PANE displays the layer of the feature data in the
map?

(a) Survey (b) Map Book
(c) Display Manager (d) Map Explorer

Which of the following tools in the Application Menu is used to edit or modify the settings
of the added plotters?

(a) Plot Preview (b) Plot
(c) Page Setup (d) Manage Plotters

Which of the following tools in the Map Setup tab is used to assign coordinate system to
the drawing?

(a) Define (b) Assign
(c) Attach (d) Connect
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5.

10.

11.

12.

13.

14.

15.

Which of the following data connections is used to access the shape file format?

(a) Add SDF Connection (b) Add SHP Connection
(c) Add WFS Connection (d) Add WMS Connection
You can load the survey Ground Control Points by using the tab from the

TASK PANE.

You can use the tools in the panel of the Insert tab to bring the data into your

map.
The tool in the Application Menu creates a zip file for the drawing and its
dependencies.

The tool in the Application Menu is used to publish drawings in the Autodesk
Infrastructure Map Server.

Using the option in the DATA CONNECT wizard, you can filter data that is to
be added to the map.

You can create a sheet set by using an example sheet set or by using the existing drawings.
(1T/F)

You can load various datasets such as raster, vectors and database file into the Workspace
by using the Connect tool. (T/F)

You can use the Display Manager, Map Explorer, Map Book or Survey tab to create a new
survey data store. (T/F)

The Page Setup tool is used to set the properties of the plotting device, paper size, and
page layout for plotting. (1/F)

You can publish data to the online server using the tools in the Publish option of the
Application Menu. (1/F)

Answer the following questions:

1.

Which of the following tools in the Output tab of the ribbon is used to publish drawings
using plotters?

(a) Preview (b) Plot
(c) Page Setup Manager (d) Plotter Manager



Getting Started with AutoCAD Map 3D 2016 2-49

2. Which of the following tools in the Home tab is used to attach a drawing file to the current

drawing?
(a) Export (b) Assign
(c) Attach (d) Connect
3. ’lo insert a georeferenced image into the drawing space, use the tool from the

Image panel of the Insert tab.

4. To export data to several external file formats, use the option from the Application
Menu.

5. You can set the printing and plotting settings as per the user requirement. (1/F)
6. Using the Connect tool, you can combine raster data and vector data. (1/F)

7. You can use the Connect button in the Map Explorer tab of the TASK PANE as an alternative
to the Connect tool in the ribbon. (1/F)

8. The coordinate system used for conducting survey can be different from the one used in
the drawing window. (1/F)

9. A drawing file can be saved with only *.dwg extension. (1/F)

10. You can create a new sheet style using the options in the Sheet Set Manager window. (1/F)

Exercise 1 Loading Shape File

Download the c02_exr01 folder from www.cadcim.com and then load the Municipal.shp shape
file from the downloaded folder by using the Connect tool. Next, save the file as a drawing file.
Create a transmittal file using the eTransmit tool. (Expected time: 45 min)

Exercise 2 Loading Survey Data

Download the c02_exr02 folder from www.cadcim.com. Next, create a survey data store and
then load the c02-m3d-2016-exr02.txt file from the folder c02_exr02 into the model space by
using the options in the Survey tab. (Expected time: 30 min)
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Exercise 3 Exporting drawing As SDF

Download the c02_exr03 folder from wwuw.cadcim.com. Next, open the c02-m3d-2016-exr03.dwg
file from the c02_exr03 folder. Use the MAPDWGTOSDF command to export the file as an
SDF file. Save the file with the name c02-m3d-2016-exr03a. (Expected time: 30 min)

Answers to Self-Evaluation Test
1. a, 2. ¢, 3. d, 4. b, 5. b, 6. Survey, 7. Import, 8. eTrasmit, 9. Publish to Map Server,
10. Add to Map with Query, 11. T, 12. T, 13. F, 14. T, 15. T



