
•  Solid Primitives

•  Box

•  Cone

•  Cylinder

•  Sphere

•  Torus

•  Wedge

•  Pyramid

•  Polysolid

•  Helix

•  Visual Styles

•  Region

•  Union

•  Intersect

•  Intersect

•  INTERFERE

•  3D Snap

•  Dynamic UCS

•  Extrude

•  Mode

•  Revolve

•  Sweep

•  Loft

•  Solid

•  Surface

•  Presspull

 Key Terms         

Chapter 3
Creating Solid Models

Learning Objectives
After completing this chapter, you will be able to:
• Create standard solid primitives and polysolids
• Create regions 
• Use Boolean operations
• Modify the visual styles of solids
• Define new UCS using the DUCS, ViewCube, and Ribbon
• Use the Extrude and Revolve tools to create solid models 
• Create complex solid models using the Sweep and Loft tools
• Use the Presspull tool
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WHAT IS SOLID MODELING?
Solid modeling is the process of building objects that have all attributes of an actual solid 
object. For example, if you draw a wireframe or a surface model of a bushing, it is sufficient 
to define the shape and size of the object. However, in engineering, the shape and size alone 
are not enough to describe an object. For engineering analysis, you need more information 
such as volume, mass, moment of inertia, and material properties (density, Young’s modulus, 
Poisson’s ratio, thermal conductivity, and so on). When you know these physical attributes of 
an object, it can be subjected to various tests to make sure that it performs as required by the 
product specifications. It eliminates the need for building expensive prototypes and makes 
the product development cycle shorter. Solid models also make it easy to visualize the objects 
because you always think of and see the objects as solids. With computers getting faster and 
software getting more sophisticated and affordable, solid modeling has become the core of the 
manufacturing process. AutoCAD solid modeling is based on the ACIS solid modeler, which 
is a part of the core technology.

CREATING PREDEFINED SOLID PRIMITIVES
The Solid primitives form the basic building blocks for a complex

Figure 3-1  Tools in the Solid 
Primitives drop-down

 
solid. ACIS has seven predefined solid primitives that can be used 
to construct a solid model such as Box, Wedge, Cone, Cylinder, 
Pyramid, Sphere, and Torus. The number of lines in a solid 
primitive is controlled by the value assigned to the ISOLINES 
variable. These lines are called tessellation lines. The number of 
lines determines the number of computations needed to generate 
a solid. If the value is high, it will take significantly more time to 
generate a solid on the screen. Therefore, the value assigned to 
the ISOLINES variable should be realistic. When you invoke tools 
for creating solid primitives, AutoCAD Solids will prompt you to 
enter information about the part geometry. The height of the 
primitive is always along the positive Z axis and perpendicular to 
the construction plane. Similar to surface meshes, solids are also 
displayed as wireframe models unless you hide, render, or shade 
them. The FACETRES system variable controls the smoothness 
in the shaded and rendered objects and its value can go up to 10. 
The tools to create solid primitives are grouped in the Solid 
Primitives drop-down in the Modeling panel, as shown in 
Figure 3-1. 

Creating a Solid Box
 Ribbon: Home > Modeling > Solid Primitives Drop-down > Box	    	       	     
 Menu Bar: Draw > Modeling > Box 			   Toolbar: Modeling > Box    
 Command: BOX								           

The Box tool is used to create a solid rectangular box or a cube. Start a new file with 
the Acad3d.dwt template. In 3D drawing templates, you can dynamically preview the 
operations that you perform. The methods to create a solid box are discussed next.
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Creating a Box Dynamically
To create a box dynamically, choose the Box tool from the Modeling panel. Specify the first 
corner point of the box and then specify the diagonally opposite corner point for defining the 
base of the box, refer to Figure 3-2. Now, specify the height of the box by moving the cursor 
away from the base. After getting the desired height, click in the drawing window to create 
the box or specify the height of the box in the dynamic input box, see Figure 3-2.

Figure 3-2  Box created dynamically

Two Corner Option
This is the default selected option. You can use this option to create a solid box by defining 
the first corner of the box and then its other corner (Figure 3-3). Note that the length of the 
box will always be taken along the X axis, the width along the Y axis, and the height along 
the Z axis. Therefore, in this case, when you specify the other corner, the value along the X 
axis will be taken as the length of the box, the value along the Y axis will be taken as the width 
of the box, and the value along Z axis will be taken as height of the box. Given below is the 
prompt sequence to draw a box of length 5 units and height 4 units.

Specify first corner or [Center] <0,0,0>: Specify start point.
Specify other corner or [Cube/Length]: Drag the cursor in any one of the quadrants and type 
5 (Planar face of length 5 units is displayed).
Specify height or [2Point]: 4

Center-Length Option
The center of the box is the point where the center of gravity of the box lies. This option is 
used to create a box by specifying the center of the box followed by the length, width, and 
height of the box (Figure 3-4). The following prompt sequence is displayed when you choose 
the Box tool:

Specify first corner or [Center] <0,0,0>: C
Specify center <0,0,0>: 4,4 
Specify corner or [Cube/Length]: L 
Specify length: 8 
Specify width: 6 
Specify height or [2point]: 3 
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Figure 3-4  Creating a box using 
the Center-Length option

Figure 3-3  Creating a box using the Two 
Corner option

Note
The Corner-Length option is similar to the Center-Length option with the only difference that 
in the Corner-Length option, you will define the first corner of the box and then the length, 
width, and height of the box. 

In the Two Corner option, you need to specify the height of the box by specifying 2 points using 
the pointing device. 

Corner-Cube Option
This option is used to create a cube starting from a specified corner, as shown in Figure 3-5. 
You are creating a cube, and therefore, you will be prompted to enter the length of the cube, 
that will also act as the width and height. The prompt sequence for creating the cube using 
the Corner-Cube option is given next.

Specify first corner or [Center] <0,0,0>: 2,2
Specify other corner or [Cube/Length]: C
Specify length: 5

Figure 3-5  Creating a cube using the Corner-Cube option
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Note
The Center-Cube option is similar to the Corner-Cube option, with the only difference that in 
the Center-Cube option, you will have to define the center and the length of the cube.

Creating a Solid Cone
 Ribbon: Home > Modeling > Solid Primitives drop-down > Cone     			    
 Menu Bar: Draw > Modeling > Cone 			   Toolbar: Modeling > Cone	  
 Command: CONE    									       

The Cone tool  creates a solid cone with an elliptical or circular base. This tool provides 
you with the option of defining the cone height or the location of the cone apex. 
Defining the location of the apex will also define the height of the cone and the 

orientation of the cone base from the XY plane. 

Figure 3-6  Cone created dynamically

To create a cone, start a new file with the 
Acad3d.dwt template file and choose the Cone 
tool from the Modeling panel and specify the 
center point and the radius of the base, as 
shown in Figure 3-6. Next, specify the height 
of cone by moving the cursor away from the 
base. After getting the desired height, click in 
the drawing window to create the cone. You 
can also enter all parameters defining the 
cone in the dynamic input box. Figure 3-6 
shows a cone created dynamically. 

Different methods to create a cone are discussed next.
 
Creating a Cone with Circular Base
The options for defining the circular base are Center Radius, Center Diameter, 3 Point, 2 
Point, and Tangent Radius. The prompt sequence that will be displayed when you choose the 
Cone tool is given next.

Specify center point of base or [3P/2P/Ttr/Elliptical]: Specify the center of the base.

The default option to define a cone with circular base is Center Radius. In this option, after 
specifying the center point, enter the radius value and then the height of the cone. If you need 
to enter the diameter value, then enter D at the Specify base radius or [Diameter] prompt 
and specify the diameter value followed by the height. The prompt sequence for using this 
option is given below.

Specify center point of base or [3P/2P/Ttr/Elliptical]: Specify the center of the base.
Specify base radius or [Diameter] <default>: Specify the radius or enter D to specify the 
diameter of the cone.
Specify height or [2Point/Axis endpoint/Top radius]<default>: Specify the height of the 
cone or enter an option or press the ENTER key to accept the default value.
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If you want to create a cone by specifying two ends of the circular base, then type 2P at the 
Specify base radius or [Diameter] Specify center point for base or [3P/2P/Ttr/Elliptical] 
prompt and then specify the two ends of the diameter. Similarly, if the base of the cone is 
tangent to two circles, choose Ttr at the Specify base radius or [Diameter] Specify center 
point for base or [3P/2P/Ttr/Elliptical] prompt, select the circles in succession, and then 
specify the radius. 

Figure 3-7  An elliptical cone

Creating a Cone with Elliptical 
Base
To create a cone with elliptical base, choose 
the Elliptical option at the Specify center 
point for base of cone or [3P/2P/Ttr/
Elliptical] prompt. On selecting this option, 
the Specify endpoint of first axis or [Center] 
prompt will be displayed. Now, you can 
create the elliptical base by specifying the 
endpoints of axis, the location of the minor 
axis, and then the height. If you know the 
centerpoint of the ellipse, enter C at the Specify endpoint of first axis or [Center] prompt 
and specify the centerpoint, endpoint of the other two axes in succession, and finally the 
height; a cone with elliptical base will be created, as shown in Figure 3-7.

Creating a Cone with Apex
To create a cone with apex, first specify the base of the cone. Then, specify the height of the 
cone by choosing an option at the Specify height or [2Point/Axis endpoint/Top radius] 
prompt. By default, you will be prompted to specify the height of the cone. Enter the height 
of the cone or specify a location in the drawing area; the cone will be created.

To specify the height using the 2Point option, enter 2P at this prompt and specify two points 
in the drawing area. The distance between these two specified points will be considered as the 
height of the cone. The prompt sequence that will follow is given next.

Specify height or [2Point/Axis endpoint/Top radius] <current>: 2P
Specify first point: Specify the first point.   
Specify second point: Specify the second point on the screen.

To specify the height using the Axis endpoint option, choose the Axis endpoint option at the 
Specify height or [2Point/Axis endpoint/Top radius] prompt. On selecting this option, you 
can specify the endpoint of the axis, whose start point is the center of the base. Apart from 
fixing the height of the cone, this option is also used to specify the orientation of the cone 
in 3D space. This means you can also create an inclined cone, see Figure 3-8. The prompt 
sequence is as follows:

Specify axis endpoint: Specify the location of the apex or axis endpoint of the right circular cone 
in 3D space.



3-7Creating Solid Models

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Creating the Frustum of a Cone
To create the frustum of a cone, choose the Top radius option at the Specify height or [2Point/
Axis endpoint/Top radius] prompt; you will be prompted to specify the top radius. Specify the 
radius of the top of the frustum as the top radius; you will be prompted to specify the height. 
Specify the height as discussed earlier; a frustum of a cone will be created, see Figure 3-9. The 
prompt to create a frustum of a cone is given next.

Specify top radius <default>: Specify the radius for the top of the cone frustum.
Specify height or [2Point/Axis endpoint] <default>: Specify the height of the frustum or 
choose an option.

Figure 3-9  Creating  a cone using the Top 
radius option

Figure 3-8  Creating a cone using the Axis 
endpoint option

Tip
In AutoCAD, when you select a primitive shape, grips are displayed on it. You can modify the 
dimensions of the primitive by dragging these grips.

Creating a Solid Cylinder
 Ribbon: Home > Modeling > Solid Primitives drop-down > Cylinder  			       
 Menu Bar: Draw > Modeling > Cylinder                              Toolbar: Modeling > Cylinder                                         
 Command: CYLINDER 									             

To create a cylinder, start a new file with the Acad3d.dwt template file and choose the 
Cylinder tool from the Solid Primitives drop-down of the Modeling panel. Next, 
specify the center point of the base and then specify the radius of the base, as shown 

in Figure 3-10. Now, specify the height of the cylinder by moving the cursor away from the 
base. After getting the desired height, click in the drawing window to create the cylinder. You 
can also enter all parameters in the dynamic input box to define the cylinder.  

Similar to the Cone tool, this tool provides you with two options for creating the cylinder: 
circular cylinder and elliptical cylinder (Figures 3-10 and 3-11). This tool also allows you to 
define the height of a cylinder dynamically or specify the height by using the 2Point or Axis 
endpoint options. On selecting the Axis endpoint option, you can specify the endpoint of the 
axis, whose start point is the center of the base. Apart from fixing the height of the cylinder, 
this option is also used to specify the orientation of the cylinder in 3D space. This means you 
can also create an inclined cylinder, as shown in Figures 3-12 and 3-13. 
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	 Figure 3-13  Creating an inclined 		
cylinder with elliptical base

Figure 3-11  Creating an elliptical cylinder

Figure 3-12  Creating an inclined cylinder with 
circular base 

Figure 3-10  Creating a circular cylinder

Creating a Solid Sphere
 Ribbon: Home > Modeling > Solid Primitives drop-down > Sphere   			    
 Menu Bar: Draw > Modeling > Sphere			   Toolbar: Modeling > Sphere	  
 Command: SPHERE   									       

To create a sphere, choose the Sphere tool from the Modeling panel; you will be 
prompted to specify the center of the sphere. After specifying the center, you can 
create the sphere by defining its radius or diameter, as shown in Figure 3-14. Instead 

of specifying the center of the sphere, you can specify its circumference by choosing any one 
of the 3P/ 2P/Ttr options as discussed earlier.
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Figure 3-14  Solid sphere created

Creating a Solid Torus
  Ribbon: Home > Modeling > Solid Primitives drop-down > Torus			  	  
  Menu Bar:  Draw > Modeling > Torus			   Toolbar:   Modeling > Torus	  
  Command:  TORUS									       

You can use the Torus tool to create a torus, refer to Figure 3-15. A torus is centered 
on the construction plane. The top half of the torus is above the construction plane 
and the other half is below it. To create a torus, choose the Torus tool from the 

Modeling panel; you will be prompted to enter the diameter or the radius of the torus and 
the diameter or the radius of tube (Figure 3-16). The radius of torus is the distance from the 
center of the torus to the center-line of the tube. This radius can have a positive or a negative 
value. If the value is negative, the torus will have a rugby-ball like shape (Figure 3-17). A torus 
can be self-intersecting. If both the radii of the tube and the torus are positive and the radius 
of the tube is greater than the radius of the torus, the resulting solid looks like an apple 
(Figure 3-18). Instead of specifying the radius or diameter of the torus, you can specify the 
points through which the circumference of the torus will pass by choosing any one of the 3P, 
2P, and Ttr options. These options are discussed earlier.

 

Figure 3-16  Parameters associated with a torusFigure 3-15  Torus created dynamically
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Figure 3-18  Torus with radius of tube more 
than the radius of torus

Figure 3-17  Torus with a negative radius value 

Creating a Solid Wedge
 Ribbon: Home > Modeling > Solid Primitives drop-down > Wedge   			    
 Menu Bar: Draw > Modeling > Wedge			   Toolbar: Modeling > Wedge 	  
 Command: WEDGE									       

You can create a solid wedge by using the Wedge tool. To create a wedge by using this 
tool, you need to specify the start point, the diagonally opposite point, and the height 
of the wedge, refer to Figure 3-19. The other options to create a wedge are similar to 
those that are used to create a box.

Figure 3-19  Parameters of a wedge

Creating a Pyramid
 Ribbon: Home > Modeling > Solid Primitives drop-down > Pyramid   		          	  
 Menu Bar: Draw > Modeling > Pyramid			  Toolbar: Modeling > Pyramid  	  
 Command: PYRAMID								                	

The Pyramid tool is used to create a solid pyramid where all faces, other than the 
base, are triangular and converge at a point called apex (Figure 3-20). The base of a 
pyramid can be any polygon, but is typically a square. To create a pyramid, choose 

the  Pyramid tool from the Modeling panel and follow the prompt sequence given next. 



3-11Creating Solid Models

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Specify center point of base or [Edge/Sides]: Specify the center point.
Specify base radius or [Inscribed] <Current Value>: Specify the base radius.
Specify height or [2Point/Axis endpoint/Top radius] <Current Value>: Specify the height to 
create the pyramid, refer to Figure 3-20.
Different methods for creating a solid pyramid are discussed below.

Figure 3-20  Parameters associated with a 
pyramid

On invoking the Pyramid tool, you need to 
specify the center point of the base polygon or 
the length of the edges, or the number of sides 
of the polygon. If you select the Edge option in 
the Command prompt, you will be prompted 
to pick two points from the drawing area that 
determine the length and orientation of the 
edge of the base polygon. If you select the 
Sides option, you will be prompted to specify 
the number of sides of the base polygon. Note 
that in AutoCAD, the number of sides of a 
pyramid can vary from 3 to 32.

Next, you need to specify the base radius of the 
circle in which the base polygon is created. The base polygon is either circumscribed around 
a circle or inscribed within a circle. By default, the base of the pyramid is circumscribed. 
After specifying the base radius, you need to specify the height of the pyramid or select an 
option. 

The options to specify the height are same as for cone or cylinder. 

You can also create the frustum of a pyramid by selecting the Top radius option at the Specify 
height or [2Point/Axis endpoint/Top radius] Command prompt. On selecting this option, 
you are prompted to specify the radius of the top of the pyramid frustum. Then, you need 
to specify the height of the frustum either dynamically or by selecting the 2Point or the Axis 
endpoint option.

Creating a Polysolid
  Ribbon:  Home > Modeling > Polysolid	            Menu Bar: Draw > Modeling > Polysolid	  
  Command:  POLYSOLID or PSOLID        							    

The Polysolid tool is similar to the Polyline tool with the only difference that this tool 
is used to create a solid with a rectangular cross-section of a specified width and height. 
This tool can also be used to convert existing lines, 2D polylines, arcs, and circles to 

a polysolid feature. To create a polysolid, choose the Polysolid tool from the Modeling panel 
and follow the prompt sequence given next.

Height = current, Width = current, Justification = current
Specify start point or [Object/Height/Width/Justify]<Object>: Specify the start point for 
the profile of the polysolid. Else, press the ENTER key to select an object to convert it to a polysolid 
or enter an option. 
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The options available at the Command prompt are discussed next.

Next Point of Polysolid
When you specify the start point for the profile of the solid, this option is displayed. This 
option is used to specify the next point of the current polysolid segment. If additional polysolid 
segments are added to the first polysolid, AutoCAD automatically makes the endpoint of the 
previous polysolid, the start point of the next polysolid segment. The prompt sequence is 
given next.

Specify start point or [Object/Height/Width/Justify] <Object>: Specify the start point.
Specify next point or [Arc/Undo]: Specify the endpoint of the first polysolid segment.
Specify next point or [Arc/Close/Undo]: Specify the endpoint of the second polysolid segment 
or press the ENTER key to exit the tool.

Arc. This option is used to switch from drawing linear polysolid segments to drawing curved 
polysolid segments. The prompt sequence that will follow is given next.

Specify next point or [Arc/Close/Undo]: A 
Specify end point of the arc or [Close/Direction/Line/Second point/Undo]: Specify the 
endpoint of the arc or choose an option to create the arc.

The Close option closes the polysolid by creating an arc shaped trajectory from the most recent 
endpoint to the initial start point and exits the Polysolid tool. Usually, the arc drawn with 
the Polysolid tool is tangent to the previous polysolid segment. This means that the starting 
direction of the arc is the ending direction of the previous segment. The Direction option 
allows you to specify the tangent direction of your choice for the arc segment to be drawn. 
You can specify the direction by specifying a point. The Line option switches the command 
to the Line mode. The Second point option selects the second point of the arc in the 3P arc 
option. The Undo option reverses the changes made in the previously drawn polysolid.

Close. This option is available when at least two segments of the polysolid are drawn. It closes 
the polysolid segment by creating a linear polysolid from the recent endpoint to the initial 
point.

Undo. This option is used to erase the most recently drawn polysolid segment. You can use 
this option repeatedly until you reach the start point of the first polysolid segment.

Object
This option is used to convert an existing 2D object into a polysolid. The 2D objects that can 
be converted into a polysolid include lines, 2D polylines, arcs, and circles. Figure 3-21 shows 
a polysolid object created by converting a 2D polyline. Note that the polysolid is displayed 
in the Realistic visual style by default, but for clarity, it has been displayed in the Wireframe 
visual style. The prompt sequence for using this option is given next.

Specify start point or [Object/Height/Width/Justify]<Object>:  
Select object: Select an object to convert it into a polysolid.
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Figure 3-21  Object converted to a polysolid by 
using the Object option

Height
This option is used to specify the height of the rectangular cross-section of the polysolid. The 
value that you specify will be set as the default value for this tool. The prompt sequence for 
this option is given next.

Specify start point [Object/Height/Width/Justify]<Object>: H   
Specify height <current>: Specify the value of the height or press the ENTER key to accept the 
current value.
Specify start point [Object/Height/Width/Justify]<Object>: Specify the start point of the 
polysolid or choose an option.

Width
This option is used to specify the width of the rectangular cross-section of a polysolid. The 
prompt sequence for this option is given next.

Specify start point [Object/Height/Width/Justify]<Object>: W   
Specify width <current>: Specify the width or press the ENTER key to accept the current 
value.
Specify start point [Object/Height/Width/Justify]<Object>: Specify the start point of the 
polysolid or choose an option.

Justify
The justification option determines the position of the created polysolid with respect to the 
starting point. The three justifications that are available for a Polysolid tool are Left, Center, 
and Right.

Left. This justification produces a polysolid with its left extent fixed at the start point and the 
width added to the right of the start point, when you view the polysolid from the direction of 
its creation, see Figure 3-22.

Center. This justification produces a polysolid with its center fixed at the start point and the 
width added equally to both the sides of the start point when you view the polysolid from the 
direction of its creation, see Figure 3-22.



3-14 AutoCAD 2015:  A Problem-Solving  Approach
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Right. This justification produces a polysolid with its right extent fixed at the start point and 
the width added to the left of the start point, when you view the polysolid from the direction 
of its creation, see Figure 3-22. 

Figure 3-22  Start point for the Left, Right, and Center justifications of a polysolid

Creating a Helix
  Ribbon:  Home > Draw > Helix		 Toolbar: Modeling > Helix  	  
  Menu Bar: Draw > Helix		  Command:  HELIX		

The Helix tool is used to create a 3D helical curve. To generate a helical curve, you 
need to first specify the center for the base of the helix. Next, you need to specify the 
base radius, radius at the top of the helix, and height of the helix. A helix of 

converging or diverging shape can also be generated by specifying different values for the 
base and top radius. You can also control the number of turns in a helix and specify whether 
the twist will be in the clockwise direction or counter clockwise direction. Figure 3-23 shows a 
helix with the parameters to be defined. 

The prompt sequence displayed on choosing the Helix tool is given next.
 

Specify center point of base: Specify a point for the center of the helix base.
Specify base radius or [Diameter] <1.0000>: Specify the value for the base radius, enter D 
to specify the diameter, or press the ENTER key to select the default value for the radius.
Specify top radius or [Diameter] <current>: Specify the value for the top radius of the helix, 
enter D to specify the diameter, or press the ENTER key to select the current value of the base 
radius.
Specify helix height or [Axis endpoint/Turns/turn Height/tWist] <default>: Specify the 
height of the helix, press the ENTER key to select the default value or choose an option.
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Figure 3-23  Helix with associated parameters

The options available at the Command prompt are discussed next.

Axis endpoint
To specify the height using the Axis endpoint option, choose the Axis endpoint option at the 
Specify helix height or [Axis endpoint/Turns/turn Height/tWist] prompt. Using this option, 
you can specify the endpoint of the axis, whose start point is assumed to be at the center of 
the base of the helix. Apart from specifying the height of the helix, this option is also used 
to specify the orientation of the helix in 3D space or in other words, you can also create an 
inclined helix, see Figure 3-24.

Turns
To specify the number of turns in the helix, choose the Turns option at the Specify helix 
height or [Axis endpoint/Turns/turn Height/tWist] prompt. Using this option, you can 
change the number of turns in the helical curve. The default number of turns for the Helix 
tool is three.

Figure 3-24  Helix created using the Axis endpoint option

Note
In a helical curve, the number of turns cannot be more than 500. 
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turn Height
To specify the pitch of the helix, choose the turn Height option at the Specify helix height or 
[Axis endpoint/Turns/turn Height/tWist] prompt. Using this option, instead of specifying the 
whole height of the helix, you can specify the height of one complete single turn of the helix. 
The helical curve will be generated with the total height equal to the turn height multiplied 
by the number of turns. 

tWist
To specify the starting direction of the helical curve, choose the tWist option from the shortcut 
menu at the Specify helix height or [Axis endpoint/Turns/turn Height/tWist] prompt. By 
using this option, you can specify whether the curves will be generated in the clockwise or 
the counterclockwise direction. Figure 3-25 shows a helix with counterclockwise turns and 
Figure 3-26 shows a helix with clockwise turns. The default value for the starting direction of 
the helical curve is counterclockwise.  

Figure 3-26  Helix created 
using the CW option

Figure 3-25  Helix created 
using the CCW option

Tip
You can use the generated helix as a trajectory for the Sweep tool. This tool will be discussed later 
in this chapter.

MODIFYING THE VISUAL STYLES OF SOLIDS
  Ribbon: Home > View > Visual Styles > Visual Styles Manager			    
  Menu Bar:  Tools > Palettes > Visual Styles	 Command: VISUALSTYLES	

AutoCAD provides you with various predefined modes of visual styles. These visual styles 
are grouped together in the Visual Styles Manager, see Figure 3-27. To invoke the VISUAL 
STYLES MANAGER, select the Visual Styles Manager option from the Visual Styles 
drop-down list in the View panel. Alternatively, click on the inclined arrow at the bottom right 
of the Visual Styles panel in the Visualize tab. There are ten visual styles available in the 
Available Visual Styles in Drawing rollout of the VISUAL STYLES MANAGER. To apply a 
visual style, you need to double-click on it. Alternatively, select the desired visual style from 
the Visual Styles drop-down list in the View panel; the model will be updated automatically 
to the new visual style. 
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Figure 3-27  The VISUAL STYLES 
MANAGER

The properties of the selected visual style will 
be displayed below the Available Visual Styles 
in Drawing rollout. You can modify these 
properties depending upon your requirement. 
You can also create a user-defined visual style 
based on the current visual style applied to the 
model. To do so, choose the Create New Visual 
Style button from the tool strip at the bottom of 
the Available Visual Styles in Drawing rollout; 
the Create New Visual Style dialog box will be 
displayed. Enter a new name and description 
for the newly created visual style. Next, choose 
OK; a new visual style will be created. Set the 
properties of the new visual style by modifying 
the default properties. Alternatively, set the 
properties of the visual style and then select 
Save as a New Visual Style from the Visual 
Styles drop-down list in the Visualize tab; you 
will be prompted to specify a name to save the 
current visual style. Enter a name and press 
ENTER; the new visual style will be saved. 

Tip
In AutoCAD, you can also use the In-canvas 
Viewport controls displayed on the top left 
corner of the drawing area for changing the 
visual style of a solid. 

Available Visual Styles in 
Drawing
The options available in this rollout are discussed next.

2D Wireframe
On applying this visual style, all hidden lines will be displayed along with the visible lines in 
the model. Sometimes, it becomes difficult to recognize the visible lines and hidden lines, if 
you set this visual style for complex models.

Conceptual
In this visual style, the model will be displayed as shaded and the edges of the visible faces of 
the model will also be displayed. 

Hidden
On applying this visual style, the hidden lines in the model will not be displayed, and only 
the edges of the faces that are visible in the current viewport will be displayed.
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Realistic
This visual style is the same as Conceptual, but with a more realistic appearance. Moreover, 
if materials are applied to a model, this visual style will display the model along with the 
materials applied.

Shaded
In this visual style, smooth shading is applied to the faces of a model. In this case, the edges 
of the visible faces are not visible.

Shaded with edges 
In this visual style, smooth shading is applied to the faces of a model and the edges of the 
visible faces are visible.

Shades of Gray 
In this visual style, a single shade (grey) is applied to all faces of a model.

Sketchy 
In this visual style, a model appears as if it is hand sketched. 

Wireframe 
This visual style is used to display a solid model as a wireframe model. You can see through 
the solid model while the model is being rotated in the 3D orbit view.

X-Ray 
This visual style is used to display the model with shading and mild transparency. In this case, 
the hidden lines will be visible.

2D Wireframe options
The options in this area are discussed next.

Contour Lines
The lines that are displayed on the curved surface of  a solid are  known as contour lines. The 
default value for the number of contours to be displayed on each curved surface is 4 and it is 
controlled by system variable ISOLINES. Figure 3-28 shows a cylinder with 4 contour lines 
and Figure 3-29 shows a cylinder with 8 contour lines. 

Draw true silhouettes
This option is used to specify whether or not to display the true silhouette edges of a model 
when it is hidden by using the Hide tool. If you select Yes from this drop-down list, the 
silhouette edges will be displayed when you hide the model, see Figure 3-30. However, when 
you select No from this drop-down list, the silhouette edges will not be displayed when you 
hide the model, see Figure 3-31.
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Figure 3-29  Cylinder with 8 contour linesFigure 3-28  Cylinder with 4 contour lines

Figure 3-31  Model with the true silhouette 
edges off

Figure 3-30  Model with the true silhouette 
edges on

2D Hide - Occluded Lines
The options in this area are used to set the linetype and color of the hidden lines (also called 
occluded lines).

Linetype
This drop-down list is used to set the linetype for the obscured lines. You can select the desired 
linetype from this drop-down list. The linetype of the hidden lines can also be modified using 
the OBSCUREDLTYPE system variable. The default value of this variable is 0. As a result, the 
hidden lines are suppressed when you invoke the Hide tool. You can set any value between 
0 and 11 for this system variable. The following table gives the details of the different values 
of this system variable and the corresponding linetypes that will be assigned to the hidden 
lines:

	 Value		  Linetype				    Sample

	    0		  Off					     None
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	    1		  Solid				  
	
	    2		  Dashed
	
	    3		  Dotted
	
                4		  Short Dash
	
  	    5		  Medium Dash			 
	
	    6		  Long Dash
	
	    7		  Double Short Dash
	
	    8		  Double Medium Dash
	
	    9		  Double Long Dash
	   
               10		  Medium Long Dash
	
	   11		  Sparse Dot

Figure 3-32 shows a model with a hidden linetype changed to dashed lines and Figure 3-33 
shows the same model with hidden lines changed to dotted lines.

Figure 3-33  Model with hidden lines changed 
to double long dashed lines

Figure 3-32  Model with hidden lines changed to 
dashed lines

Color
The Color drop-down list is used to define the color for the obscured lines. If you define a 
separate color, the hidden lines will be displayed with that color, when you invoke the Hide 
tool. You can select the required color from this drop-down list. This can also be done by 
using the OBSCUREDCOLOR system variable. Using this variable, you can define the color 
to be assigned to the hidden lines. The default value is 257. This value corresponds to the 
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ByEntity color. You can enter the number of any color at the sequence that will follow when 
you enter this system variable. For example, if you set the value of the OBSCUREDLTYPE 
variable to 2, and that of the OBSCUREDCOLOR to 1, the hidden lines will appear in red 
dashed lines, when you invoke the Hide tool.

Note
The linetype and the color for the hidden lines defined using the previously mentioned variables 
are valid only when you invoke the Hide tool. They do not work if the model is regenerated.

2D Hide - Intersection Edges
The options in this area are used to display a 3D curve at the intersection of two surfaces. 
Note that the 3D curve is displayed only after invoking the Hide tool. These options are 
discussed next.

Show
If you select Yes from the Show drop-down list, a 3D curve will define the intersecting portion of 
the 3D surfaces or solid models.

Color
The Color drop-down list is used to specify the color of the 3D curve that is displayed at the 
intersection of the 3D surfaces or solid models.

2D Hide - Miscellaneous
This head in the Visual Styles Manager is used to set the percentage for halo gap.

Halo gap %
The Halo gap % area is used to specify the distance in terms of percentage of unit length 
by which the edges that are hidden by a surface or solid model will be shortened, see 
Figures 3-34 and 3-35. 

Figure 3-35  Hiding lines with halo gap % as 
40

Figure 3-34  Hiding lines with halo gap % as 0
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Note
The obscured linetype in Figures 3-34 and 3-35 is changed to dashed.

Display resolution
The options in this area are used to set the resolutions for the curves, splines, and solids. 
These options are discussed next.

Arc/Circle Smoothing
This option is used to vary the smoothness of the curved surfaces of a 3D model. By default  
the value for smoothing of the curves or circles is 1000. You can change the value as per your 
requirement and this smoothness is controlled by the system variable VIEWRES. 

Spline Segments
This option is used to set the number of segments in a polyline that can be fitted in the spline 
curve. By default, the number of segments that are displayed in a spline are 8. You can also 
set the number of segments by using the SPLINESEGS variable.  

Solid Smoothness
The Solid Smoothness area is used to specify the smoothness of the surfaces of the 3D model. 
By default 0.5 is specified as the smoothness value for the surfaces and you can change 
this value from 0.1 to 10. This Solid smoothness can also be controlled by system variable 
FACETRES.

Similarly, you can specify the settings for faces, edges, and environment required for other 
visual styles. These settings are discussed next.

Controlling the Settings of Edges 
You can control display settings of the edges by using the Edge Settings rollout in the Available 
Visual Styles in Drawing palette. Figure 3-36 shows different types of edge display. The 
Show field in this rollout has three options: None, Isolines, and Facet Edges. On selecting 
the Isolines option, the contour lines on the surface of the solid will be displayed. Also, the 
Always on Top field will be available in the Edge Settings rollout Show field. On selecting 
the Yes option in this field, all isolines in the model will be displayed. If you do not want the 
edges to be displayed, choose None in the Show field. On selecting the Facet Edges option 
in the Show field, the edges between the planar surfaces will be displayed. You can also set 
other options in the sub rollout. Note that some of the sub rollouts will not be available for 
the Shaded and Realistic visual styles.

The Occluded Edges sub rollout is used to control the display of hidden edges. Select the 
Yes option in the Show field to display the hidden edges. You can also set the color and the 
line type of the hidden edges in the Color and Linetype fields, respectively. 

The options in the Intersection Edges sub rollout are used to control the display of the 
resulting curve when two surfaces intersect. Select the Yes option in the Show field to display 
the curve at the intersection. You can also set the color and the line type of the resulting curve 
in the Color and Linetype fields, respectively.
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Figure 3-36  Different types of edge display

The Silhouette Edges sub rollout is used to control the display of the silhouette edges. Select 
the Yes option in the Show field to display the silhouette edges. You can set the width of the 
silhouette edges in the Width field. This value ranges from 1 to 25.

The Edge Modifiers sub rollout is used to assign special effects such as Line Extensions and 
Jitter to edges. Both the effects exhibit a hand-drawn effect with the only difference that the 
sketches drawn in Line Extensions extend beyond the model, whereas in Jitter, the edges 
look as if they were drawn using pencil and has multiple lines. Note that you need to choose 
the Line Extension edges and Jitter edges buttons from the title bar of the sub rollout to 
enable these options. You can set the value for the extension line from the vertices by using 
the Line Extensions spinner. Similarly, you can control the effect of jitter by using the options 
in the Jitter drop-down list. Figure 3-37 shows the effect of line extensions and jitter edges. 
The Crease angle field will be displayed only if you choose the Facets Edges option in the 
Edge Settings rollout. Note that the Facets edges will be displayed only if the angle between 
the facets is smaller than the specified crease angle.

Figure 3-37  The Line Extensions and Jitter effects of the edges 
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Controlling the Face Display
AutoCAD enables you to control the display of faces by providing options to apply color effects 
and shading to solids or surfaces. The shading of models can be controlled by using the Face 
style field. The options in this field are Realistic, Gooch, and None, refer to Figure 3-38. By 
default, the Realistic option is chosen and therefore gives a real world effect to the model. 
The Gooch effect enhances the display by using light colors, instead of dark colors. If the 
None option is chosen, then no style will be applied to the model and only the edges will be 
displayed. 

Figure 3-38  Different face styles     

You can also control the appearance of faces in solids or surfaces using the Lighting quality field. 
The options available in this field are Faceted, Smooth, and Smoothest. On selecting the 
Faceted option, the color is applied to each face, thereby making the object to appear flat. 
On selecting the Smooth option, the color applied is the gradient between the two vertices 
of the face. This option is selected by default. On selecting the Smoothest option, the color 
is calculated for per pixel lighting.

You can apply different color settings to faces by selecting an option from the Color drop-down 
list in the Face Settings rollout. The options in this drop-down list are Normal, Monochrome, 
Tint, and Desaturate. No face color will be applied if the Normal option is selected. If you 
select the Monochrome option, all faces will be shaded with a single color. If you want to use the 
same color to shade all faces by changing the hue and saturation values of the color, then select 
the Tint option. The hue and saturation values can be changed by using the Tint drop-down 
list. Select the Desaturate option to soften the color by reducing the saturation by 30%.

You can also control the opacity of solid models by choosing the Opacity button in the title 
bar of the Facet Settings rollout. On doing so, the Opacity field will be enabled. Specify the 
desired transparency level. Figure 3-39 shows an object with different opacity values. 

The shininess of an object is set by using the options in the Lighting rollout. To set the 
shininess, choose the Highlight intensity button on the title bar of this rollout and set the 
required value in the Highlight intensity spinner. Note that you cannot set this value when 
a material is applied on it. 
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Figure 3-39  An object with different opacity values

Shadows provide a real effect at rendering. Shadows are generated when light is applied. Lights 
can be user-defined lights or the sunlight. The options in this drop-down list are Off, Ground 
Shadow, and Mapped Object shadows. The Ground Shadows are the shadows that an object 
casts on the ground. The Mapped Object shadows are the shadows cast by one object on other 
objects. Shadows appear darker when they overlap. Use of shadows can slow down the system 
performance. So, you need to turn off the shadows while working, and turn them on when 
you need shadows. You can set the display of the shadow by using the Properties palette. The 
options under the Shadow area of the Properties palette are Casts and Receives Shadows, 
Casts shadows, Receives shadows and Ignore shadows. The shadows will be explained in 
detail in later chapters.

Controlling the Backgrounds 
You can control the display of background by using the option in the Environment Settings 
rollout. You can turn on or off the background by using the Backgrounds drop-down list in 
this rollout. The background can be a single solid color, a gradient fill, an image, or the sun 
and the sky. This is explained in detail in Chapter 8 (Rendering and Animating Designs). 

Note
In AutoCAD, the default visual style applied to a model is Realistic. However, in this textbook, 
the Wireframe visual style is applied to models for the clarity of printing.

CREATING COMPLEX SOLID MODELS
Until now you have learned how to create simple solid models using the standard solid 
primitives. However, the real-time designs are not just the simple solid primitives, but 
complex solid models. These complex solid models can be created by modifying the standard 
solid primitives with the Boolean operations or directly by creating complex solid models 
by extruding or revolving the regions. All these options of creating complex solid models are 
discussed next.
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Creating Regions
  Ribbon: Home > Draw > Region		  Menu Bar: Draw > Region   	  
  Command: REGION							              	

The Region tool is used to create regions from the selected loops or closed entities. 
Regions are the 2D entities with properties of 3D solids. You can apply the Boolean 
operation on the regions and you can also calculate their mass properties.  Bear in 

mind that the 2D entity you want to convert into a region should be a closed loop. Once you 
have created regions, the original object is deleted automatically. However, if the value of the 
DELOBJ system variable is set to 0, the original object is retained. The valid selection set for 
creating the regions are closed polylines, lines, arcs, splines, circles, or ellipses. The current 
color, layer, linetype, and lineweight will be applied to the regions.

CREATING COMPLEX SOLID MODELS BY APPLYING 
BOOLEAN OPERATIONS
You can create complex solid models by applying the Boolean operations on the standard solid 
primitives. The Boolean operations that can be performed are union, subtract, intersect, and 
interfere. The tools used to apply these Boolean operations are discussed next.

Combining Solid Models
  Ribbon: Home > Solid Editing > Solid, Union	 Menu Bar: Modify > Solid Editing > Union	
  Command:  UNION									            

The Solid, Union tool is used to apply the Union Boolean operations on the selected 
set of solids or regions. You can create a composite solid or region by combining them 
using this tool. You can combine any number of solids or regions. When you invoke 

this tool, you will be prompted to select the solids or regions to be added. Figure 3-40 shows 
two solid models before union and Figure 3-41 shows the composite solid created after 
union.

Figure 3-41  Composite solid created after unionFigure 3-40  Solid models before union



3-27Creating Solid Models

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Subtracting One Solid From the Other
  Ribbon: Home > Solid Editing > Solid, Subtract					     
  Menu Bar:  Modify > Solid Editing > Subtract 					      
  Toolbar: Modeling > Subtract 				    Command: SUBTRACT	

The Substract tool is used to create a composite solid by removing the material common 
to the selected set of solids or regions. On invoking this tool, you will be prompted to 
select the set of solids or regions to subtract from. After selecting it, Select a solid or 

region and press ENTER; you will be prompted to select the solids or regions to subtract. The 
material common to the first selection set and the second selection set is removed from the 
first selection set. The resultant object will be a single composite solid, see 
Figures 3-42 and 3-43.

Figure 3-43  Composite solid created after 
subtracting

Figure 3-42  Solid models before subtracting

Intersecting Solid Models
  Ribbon: Home > Solid Editing > Solid, Intersect		 			     
  Menu Bar: Modify > Solid Editing > Intersect					       
  Toolbar: Modeling > intersect            			   Command:  INTERSECT	  

The Solid, Intersect tool is used to create a composite solid or region by retaining 
the material common to the selected set of solids or regions. When you invoke this 
tool, you will be asked to select the solids or regions to intersect. The material common 

to all the selected solids or regions will be retained to create a new composite solid (Figures 3-44 
and 3-45).

Figure 3-45  Solid model created after 
intersecting

Figure 3-44  Solid models before intersecting
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Checking Interference in Solids
  Ribbon: Home > Solid Editing > Interfere	       		   			    
  Menu Bar:  Modify > 3D Operations > Interference Checking	 Command: INTERFERE	

The Interfere tool is used to create a composite solid model by retaining the material 
common to the selected sets of solids. This tool is generally used for analyzing 
interference between the mating parts of an assembly.  On invoking this tool, you will 

be prompted to select the first set of objects. Once you have selected them, Select the first set 
of objects and press ENTER; you will be prompted to select the second set of objects. Select 
the second set of objects and press ENTER; the Interference Checking dialog box will be 
displayed. Also, the interference will be highlighted in the drawing area. The Interfering 
objects area in this dialog box displays the number of objects selected in both the first and 
second sets and the number of interferences found between them. Choose the Previous or 
the Next button in the Highlight area to view the previous or next interferences. If the Zoom 
to pair check box is selected in this area, the interference is zoomed while cycling through 
the interference objects. You can also use the navigation tools in the Interference Checking 
dialog box to view the interfering area clearly. Clear the Delete interference objects created 
on close check box, if you need to retain the interference objects after closing the dialog box. 
Close this dialog box by choosing the Close button. 

If you clear the Delete interference objects created on Close check box and then close the 
Interference Checking dialog box, you can move the interfering objects by using the Move 
tool. Figure 3-46 shows two mating components of an assembly with interference between 
them and Figure 3-47 shows the interference solid created and moved out.

Figure 3-47  Interference solid created using the 
Interfere tool

Figure 3-46  Two mating components with 
interference

You can also specify the visual style and color for the interfering objects. To do so, invoke the 
Interfere tool, type S at the Select first set of Objects or [Nested selection/Settings] prompt 
and press ENTER; the Interference Settings dialog box will be displayed. In this dialog box, 
specify the required parameters. 
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Example 1
In this example, you will create the solid model shown in Figure 3-48.

Figure 3-48  Solid model for Example 1

1.	 Increase the drawing limits to 100,100. Zoom to the limits of the drawing.

2.	 Enter UCSICON at the Command prompt. The following prompt sequence is 
displayed:

Enter an option [ON/OFF/All/Noorigin/ORigin/Properties] <ON>: N

3.	 Right-click on the ViewCube and then choose the Parallel option.

4.	 Invoke the ortho mode, if it is not turned on.

5.	 Choose Wireframe from Home > View > Visual Styles drop-down to set the visual style 
as Wireframe.

6.	 Choose the Box tool from Home > Modeling > Solid Primitives drop-down and follow 
the prompt sequence given next.

	 Specify first corner or [Center] <0,0,0>: 10,10
Specify other corner or [Cube/Length]: L
Specify length: (Move the cursor along Y axis) 80
Specify width: 42
Specify height: 48

7.	 Again, invoke the Box tool and follow the prompt sequence given below.
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Specify first corner or [Center] <0,0,0>: 10,10, 18
Specify other corner or [Cube/Length]: L
Specify length: (Move the cursor along X axis) 42
Specify width: 15
Specify height: 30

8.	 Right-click on the 3D Object Snap button in the Status Bar and then choose the Midpoint 
on edge option. Clear the other options in this shortcut menu.

9.	 Turn the 3D Object Snap on by choosing it, if it is not already on.

10.	 Move the new box inside the old box by snapping the midpoint on edge of both the 
boxes. 

11.	 By using the Copy tool and the Vertex option of the 3D Object Snap, copy the new box 
to the other side of the box, refer to Figure 3-49.

12.	 Choose the Solid, Subtract tool from the Solid Editing panel and follow the prompt 
sequence given next.

Select solids and regions to subtract from.
Select objects: Select the bigger box.
Select objects: 
Select solids and regions to subtract.
Select objects: Select one of the smaller boxes.
Select objects: Select other smaller boxes.
Select objects: 

13.	 Change the visual style to Hidden from the In-canvas Visual Style controls. The model 
after subtracting the boxes should look similar to the one shown in Figure 3-50.

Figure 3-49  Boxes moved inside the bigger 
box using midpoints

Figure 3-50  Model after subtracting the 
smaller boxes

14.	 Again, change the visual style to Wireframe. Then, choose the Box tool and follow the 
prompt sequence given next.
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Specify first corner or [Center] <0,0,0>: 21,10, 9
Specify other corner or [Cube/Length]: L
Specify length: (Move the cursor along the X axis) 20
Specify width: 80
Specify height: 29

15.	 Invoke the Move tool and select the box created in the previous step.

16.	 Specify the midpoint of the lower edge as the base point; the Specify second point or 
<use first point as displacement> prompt is displayed.

17.	 Enter From and press ENTER; you are prompted to specify the base point.

18.	 Specify the midpoint of the lower edge of the solid created by using the Subtract tool.

19.	 Move the cursor vertically upward. Enter 9 at the Command prompt and press ENTER; 
the box is moved, as shown in Figure 3-51.

20.	 Choose the Solid, Subtract tool from the Solid Editing panel and follow the prompt 
sequence.

Select solids and regions to subtract from.
Select objects: Select the model.
Select objects: 
Select solids and regions to subtract.
Select objects: Select the box.
Select objects: 

	 The model after changing the visual style to Hidden should look similar to the one shown 
in Figure 3-52.

Figure 3-52  Model after subtractionFigure 3-51  Model before subtraction

21.	 Right-click on the 3D Object Snap button in the Status Bar and choose the Center of face 
option. Clear the other options in this shortcut menu. 
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22.	 Choose the Cylinder tool from Home > Modeling > Solid Primitives drop-down and follow 
the command sequence given next to create the cylinder, as shown in Figure 3-53.

Specify center point of base or [ 3P / 2P / Ttr/ Elliptical]: Move the cursor on top face of the 
model and snap the center of the top face.
Specify base radius or [Diameter]: 7
Specify height or [2Point / Axis endpoint]: Move the cursor vertically downward and 
enter -10
  

23.	 Subtract this cylinder from the existing model, refer to Figure 3-54.

24.	 Create a new UCS on the front face of the model.

25.	 Choose Cylinder from Home > Modeling > Solid Primitives drop-down in the Ribbon. 
The following command sequence will be displayed:

Specify center point of base or [3P / 2P / Ttr/ Elliptical]: Use the From option to specify the center 
point of the cylinder at a distance of 27 units from the midpoint of the longer edge of the base. 
Specify base radius or [Diameter]: 15
Specify height or [2Point / Axis endpoint]: -42

Figure 3-54  Model after subtractionFigure 3-53  Model before subtraction

26.	 Subtract this cylinder from the model and change the visual style to Shades of Gray.  The 
final model should look similar to the one shown in Figure 3-55.

Figure 3-55  Final solid model for Example 1
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Exercise 1
In this exercise, you will create the solid model shown in Figure 3-56. Save this drawing with 
the name Ch-3_Exercise1.dwg.

Figure 3-56  Solid model for Exercise 1

DYNAMIC UCS
This option is used to temporarily align the XY plane of the current UCS with the selected 
face of an existing solid. Choose the Allow / Disallow Dynamic UCS toggle button from the 
Status Bar to turn it on. Now, invoke a tool and move the cursor near the face on which you 
want to create the new sketch or solid; the face will be highlighted in dashed lines. Click the 
left mouse button on the desired face; the XY plane of the UCS will automatically be aligned 
with the selected face. Now, you can create the sketch or solid at the selected face. After the 
completion of the sketch or feature, the UCS will again move automatically to its original 
position. 

For example, if you want to create a cylinder on the slant face of the model shown in Figure 3-57, 
choose the Dynamic UCS button from the Status Bar to turn it on. Then, choose the Cylinder 
tool from the Solid Primitives drop-down in the Modeling panel. Next, move the cursor near 
the slant face of the model; the slant face of the model will be highlighted. Next, left-click on 
that face and create the cylinder, as shown in Figure 3-58.

Figure 3-58  UCS dynamically moved on the 
slant face of the model

Figure 3-57  Model with UCS at the origin
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If you want a better visualization of how the X, Y, and Z axes of the UCS will be oriented, 
right-click on the DUCS button and choose the Display crosshair labels option from the 
shortcut menu. This will enable you to see the X, Y and Z labels attached with the axes and 
they will keep on changing as you move the cursor to different faces. 

Note
The option of DUCS works only when any tool is active.  

Tip
To toggle between the on and off states of the DUCS button, use the F6 function key. To 
temporarily deactivate the DUCS button, press and hold the SHIFT+Z keys. 

DEFINING THE NEW UCS USING THE ViewCube AND 
THE RIBBON
In the earlier chapters, you learned how to create new UCS using the UCS tool. You can 
also define a new UCS  whose XY plane is parallel to the current viewing plane by using the 
ViewCube and the Ribbon. To define a new UCS whose XY plane is parallel to the current 
viewing plane, click on a hotspot in the ViewCube; the view corresponding to the hotspot 
will become normal to screen. Next, choose WCS > New UCS from the WCS flyout in the 
ViewCube; you will be prompted to specify the origin. Enter V at the Command prompt and 
press ENTER; a new UCS will be created at the current viewing plane. Now, if you draw a 
sketch, it will be in the new UCS. To save the new UCS, choose the UCS, Named UCS tool 
from the Coordinates panel in the View tab; the UCS dialog box will be displayed with the 
Unnamed option. Rename it and choose OK; the new name of the UCS will be saved and 
also displayed in the WCS flyout of the ViewCube.

To define a new UCS using the Ribbon, choose any one of the predefined orthographic views 
from the Views drop-down list in the Views panel of the View tab; the model will orient to 
that view. Also, you will notice that the ViewCube is also oriented according to the selected 
view, but Top is displayed as the view and Unnamed is displayed at the WCS flyout. Now, if 
you draw a sketch, it will be in the new UCS. However, if there are different faces parallel to 
the new UCS, you can draw sketches on those faces.

CREATING EXTRUDED SOLIDS
 Ribbon:  Home > Modeling > Solid Creation drop-down > Extrude 		   
 Menu Bar: Draw > Modeling > Extrude		  Toolbar:  Modeling > Extrude	  
 Command: EXTRUDE								      

Sometimes, the shape of a solid model is such that it cannot be created by just applying 
the Boolean operations on the standard solid primitives. In such cases, you can use 
the tools from the Solid Creation drop-down, as shown in Figure 3-59. These tools 

are also available in the Solid panel of the Solid tab. Using these tools, you can create solid 
models of any complex shape.

The Extrude tool is used to create a complex solid/surface model by extruding a 2D entity 
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or a region along the Z axis or any specified direction or about a specified path. On invoking 
this tool, following prompt sequence will be displayed.

Figure 3-59  Tools in the 
Solid Creation drop-down

Select objects to extrude or [MOde]: _MO Closed profiles 
creation mode 
[SOlid/SUrface] <Solid>: _SO
Select objects to extrude or [MOde]:

In AutoCAD, you can specify mode to extrude an object. There 
are two modes available: Solid and Surface. If you need to change 
the mode, enter MO at the Select objects to extrude or [MOde] 
prompt and specify the mode. Note that if the original entity is 
a closed loop or a region, you can extrude it as a solid/surface 
model. If the 2D entity is an open loop, then you can extrude it 
as a surface only. After specifying the mode, select the objects to 
be extruded and press ENTER; the Specify height of extrusion 
or [Direction/Path/Taper angle/Expression] prompt will be 
displayed. Specify the depth of extrusion or select other options 
to specify the depth. Different methods to extrude an object by 
using the options at the Command prompt are discussed next.

Extruding along the Normal
This is the default option and is used to create a model by extruding a 2D entity or a region 
along the normal. Figure 3-60 shows the region to be converted into an extruded solid and 
Figure 3-61 shows the solid created on extruding the region. The prompt sequence that will 
be displayed when you choose the Extrude tool is given next.

Select objects to extrude: Select the region.
Select objects to extrude: 
Specify height of extrusion or [Direction /Path /Taper angle]: Specify the height.

Figure 3-61  Solid created on extrudingFigure 3-60  Region for extruding

Extruding with a Taper Angle
You can specify the taper angle for an extruded solid/surface by selecting the Taper angle 
option at the Specify height of extrusion or [Direction/Path/Taper angle] prompt. The 
positive value of the taper angle will taper in from the base object and the negative value will 
taper out of the base object (Figure 3-62).
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Extruding along a Direction
This option is used to create a solid by extruding a 2D entity or a region in any desired direction 
by specifying two points. You can create an inclined extruded object by selecting a start point 
and an endpoint. The distance between the start point and endpoint acts as the height of 
the extrusion. Figure 3-63 shows an object extruding along a direction.

Figure 3-63  Object extruding along a directionFigure 3-62 Results of various taper angles

Extruding along a Path
This option is used to extrude a 2D entity or a region about a specified path. Bear in mind that 
the path of extrusion should be normal to the plane of the base object. If the path consists of 
more than one entity, all of them should be first joined using the Edit Polyline tool so that the 
path remains a single entity. This option is generally used for creating complex pipelines and 
also by architects and interior designers for creating beadings. The path used for extrusion 
can be a closed entity or an open entity and the valid entities that can be used as path are 
lines, circles, ellipses, polygons, arcs, polylines, or splines. You cannot specify the taper angle 
when you use a path. Figure 3-64 shows a base object and a path about which the base object 
has to be extruded and Figure 3-65 shows the solid created upon extruding the base entity 
about the specified path.

Figure 3-65  Solid model created on extruding the 
base entity about the specified path

Figure 3-64  The base object and the path for 
extrusion
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Extruding using Expressions
This option is used to specify the extrusion depth in terms of formula or equations, as you 
have created parametric drawings.

CREATING REVOLVED SOLIDS
 Ribbon:  Home > Modeling > Solid Creation drop-down >  Revolve	  		   
 Menu Bar: Draw > Modeling > Revolve			    Toolbar:  Modeling > Revolve	  
 Command: REVOLVE									       

The Revolve tool is used to create a complex model by revolving 2D entities or regions 
about a specified revolution axis. The entire 2D entity should be on one side of the 
revolution axis. Self-intersecting and crossed entities cannot be revolved using this tool. 

Remember that the direction of revolution is determined using the right-hand thumb rule. 
The axis of rotation is defined by specifying two points, using the X or Y axis of the current 
UCS, or using an existing object. Similar to the Extrude tool, you can create a solid/surface 
model by specifying the mode after invoking the Revolve tool. On specifying the mode and 
selecting the object, the Specify axis start point or define axis by [Object/X/Y/Z] prompt will 
be displayed. Specify the axis of revolution. After setting the revolution axis option, you will 
be prompted to specify the angle of revolution. The default value is 360°. You can enter the 
required value at this prompt. 

The options that are used to specify the axis are discussed next.

Start Point for the Axis of Revolution
This option is used to define the axis of revolution using two points: the start point and the 
endpoint of the axis of revolution. The positive direction of the axis will be from the start point 
to the endpoint and the direction of revolution will be defined using the right-hand thumb 
rule. Before revolving, make sure the complete 2D entity is on one side of the axis of revolution.

Object
This option is used to create a revolved model by revolving a selected 2D entity or a region 
about a specified object. The valid entities that can be used as an object for defining the axis 
of revolution can be a line or a single segment of a polyline. If the polyline selected as the 
object consists of more than one entity, then AutoCAD draws an imaginary line from the start 
point of the first segment to the endpoint of the last segment. This imaginary line is then 
taken as the object for revolution.

X
This option uses the positive direction of the X axis of the current UCS for revolving the 
selected entity. If the selected entity is not completely on one side of the X axis, it will give 
you an error message that it cannot revolve the object.

Y
This option uses the positive direction of the Y axis of the current UCS as the axis of revolution 
for creating the revolved solid.
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Z
This option uses the positive direction of the Z axis of the current UCS as the axis of revolution 
for creating the revolved solid.

Figure 3-66 shows the entity to be revolved and the revolution axis along with the revolved 
solid. Figure 3-67 shows the same solid revolved through an angle of 270°. 

Figure 3-67 Solid revolved to an angleFigure 3-66  Creating a revolved solid

CREATING SWEPT SOLIDS
 Ribbon:  Home > Modeling > Solid Creation drop-down > Sweep  	   	  
 Menu Bar:  Draw > Modeling > Sweep    		  Command: SWEEP	

The Sweep tool is used to sweep an open or a closed profile along a path. This tool is 
also available in the Solid panel of the Solid tab. To create this model by using this 
tool, you need an object and a path. The object is a cross-section for the sweep feature 

and the path is the course taken by the object while creating the swept solid. Figure 3-68 shows 
the object to be swept and the path to be followed and Figure 3-69 shows  the resulting sweep 
feature.

Figure 3-69  Resulting sweep featureFigure 3-68  Object to be swept and the path  
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The path specified for the profile and the object for the cross-section of the swept model 
can be open or closed. If the object for the cross-section is open, or closed but not forming a 
single region, the generated feature will result in a surface sweep. If the object for the section 
is closed and it forms a single region, the generated feature will be a solid. Figure 3-70 shows 
the object and the closed path and Figure 3-71 shows the resulting sweep feature.

Figure 3-71  Resulting sweep featureFigure 3-70  Object to be swept with a closed path

Note
The path selected for the Sweep tool should not form a self-intersecting loop.

You can select more than one section at a time to be swept along a path, but all these sections 
should be drawn on the same plane. To create a sweep draw the cross section profile, path, 
and select the Sweep tool. Then, follow the prompt sequence given next.

Select objects to sweep or [MOde]: Select the object to be swept.
Select objects to sweep or [MOde]: Select more objects to be swept or press ENTER.
Select sweep path or [Alignment/Base point/Scale/Twist]: Select the path to be followed by 
the object or enter an option.

Figure 3-72  Object and path for 
sweep command

Depending on your requirement, you can invoke 
the following options at the Select sweep path or 
[Alignment/Base point/Scale/Twist] prompt:

Alignment
This option is used to specify whether the object will 
be oriented normal to the curve at the start point. By 
default, the sweep feature is created with a section 
normal to the path at the start point. To avoid this, 
choose No from the shortcut menu at the Align sweep 
object perpendicular to path before sweep [Yes/No] 
prompt. Figure 3-72 shows the object and the path for 
the sweep tool. Figure 3-73 shows the resulting sweep 
feature on choosing the aligned option Yes and 
Figure 3-74 shows the resulting sweep feature on 
choosing the aligned option No.
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Figure 3-74  Swept solid with the aligned 
option No

Figure 3-73  Swept solid with the aligned 
option Yes

Base Point
This option is used to specify a point on the object that will be attached to the path while 
sweeping it. You can specify the location of the cross-section while sweeping it when prompted 
to specify the base point. Figure 3-75 shows the path and the cross-section with base points 
P1 and P2. Figure 3-76 shows the resulting sweep feature with P1 as the base point and 
Figure 3-77 shows the resulting sweep feature with P2 as the base point.

Figure 3-76  Sweep with P1 as base pointFigure 3-75  Path with object and P1 and P2 as 
base points 

Scale
This option is used to scale an object uniformly from the start of the path to the end of the 
path while sweeping it. Note that the size of the start section will remain the same and then 
end section will be scaled by the specified value. Also, the transition from the beginning to the 
end is smooth. Figure 3-78 shows a pentagon swept along a path with a scale factor of 0.25.  

Twist
You can rotate an object about a path uniformly from the start to the end with a specified 
angle. The value of the twist should be less than 360 degrees. Figure 3-79 shows a sweep 
feature with 300 degrees of twist.
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Figure 3-77  Sweep with P2 as the base point

Note
A helix can also be used as the path for the Sweep tool. Figure 3-80 shows the object and a 
helical path generated using the Helix tool and Figure 3-81 shows the resulting swept solid.

Figure 3-79  Sweep with the Twist optionFigure 3-78  Sweep with the Scale option

 

Figure 3-81  Sweep feature with the 
helical path

Figure 3-80  Helical path and object to 
be swept
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CREATING LOFTED SOLIDS
 Ribbon:  Home > Modeling > Solid Creation drop-down >  Loft   		     	  
 Menu Bar:  Draw > Modeling > Loft          		  Command: LOFT	

The Loft tool is used to create a feature by blending two or more similar or dissimilar 
cross-sections together to get a free form shape. These similar or dissimilar cross-sections may 
or may not be parallel to each other. To create a loft feature, choose the Loft tool from the 
Solid panel (Figure 3-82); the following prompt sequence will be displayed:

Figure 3-82  Selecting the 
Loft tool from the Sweep/Loft 
drop-down in the Solid panel

	 Select cross sections in lofting order or [POint/Join multiple 
edges/MOde]: _MO 

	 Closed profiles creation mode [SOlid/SUrface] <Solid>: 
_SO

	 Select cross sections in lofting order or [POint/Join multiple 
edges/MOde]

Next, select at least two sections in a sequence in which you 
want to blend them. The prompt sequence that will be followed 
after choosing the Loft button is given next.

	 Select cross sections in lofting order or [POint/Join multiple 
edges/MOde]: 1 found

	 Select cross sections in lofting order or [POint/Join multiple edges/MOde]: 1 found, 2 
total

	 Select cross sections in lofting order or [POint/Join multiple edges/MOde]:  2 cross sections 
selected

	 Enter an option [Guides/Path/Cross sections only/Settings] <Cross sections only>: 

Note
As you are prompted to select cross-sections while creating a loft, you can select open or closed 
sections. Note that if you select an open section first, all subsequent sections should be open. 
The model thus created will be a surface. Similarly, if you select a closed section, all subsequent 
sections should be closed. The model created using these sections can be solid/surface. By default, 
a loft model is solid. Therefore, if cross sections selected are closed profiles and you need a surface 
model, then first you need to change the mode by entering MO at the Select cross sections in 
lofting order or [POint/Join multiple edges/MOde] prompt.

After specifying the mode, you can select the cross sections, an imaginary point as the start 
point of the loft, or multiple edges on a solid model. These options are discussed next.

POint
In AutoCAD, you can start a loft such that it begins from an imaginary point and passes 
through different sections. To do so, enter PO at the Select cross sections in lofting order or 
[POint/Join multiple edges/MOde] prompt and specify the start point of the loft, as shown in 
Figure 3-83. Next, select the cross sections in succession and press ENTER after selecting all 
cross sections; the preview of the loft feature will be displayed. Also, a Look up grip near the last 
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cross section and the Enter an option [Guides/Path/Cross sections only/Settings/COntinuity/
Bulge magnitude] <Cross sections only> prompt will be displayed. Select the Cross sections 
only option and press ENTER; the loft will be created, as shown in Figure 3-84. 

Figure 3-84  Loft feature created by using the PO 
option

Figure 3-83  Sections and the imaginary start 
point to be selected

Join multiple edges
In AutoCAD, you can create a loft feature between the edges of a solid model and a profile. 
To do so, enter J at the Select cross sections in lofting order or [POint/Join multiple edges/
MOde] prompt; the cursor will have the symbol of solid and you will be prompted to select 
edges that are into be joined to a single cross section. Select the edges in succession (See 
Figure 3-85) and press ENTER. Then, select the cross sections and press ENTER; the preview 
of the loft will be displayed. One look up grip at the start of the loft surface and other look 
up grip near the base of the model will be displayed. The Look up grip at the start of the 
loft will have the surface continuity symbol (See Figure 3-86) and the other Look up grip will 
have the Loft symbol. Click on the Look up grip that has the surface continuity symbol and 
select the required option from the flyout displayed. The options in the other look up grip 
will be discussed later. 

Given below is the prompt sequence to select the edges on the top face of the cuboid and a 
circle as the cross section.

	 Select cross sections in lofting order or [POint/Join multiple edges/MOde]: J 
	 Select edges that are to be joined into a single cross section: (Select the first edge)1 found
	 Select edges that are to be joined into a single cross section: (Select the second edge) 1 found, 

2 total
	 Select edges that are to be joined into a single cross section: (Select the third edge) 1 found, 

3 total
	 Select edges that are to be joined into a single cross section: (Select the fourth edge) 1 found, 

4 total
	 Select edges that are to be joined into a single cross section: 
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	 Select cross sections in lofting order or [POint/Join multiple edges/MOde]: 1 found
	 Select cross sections in lofting order or [POint/Join multiple edges/MOde]: 
	 2 cross sections selected 
	 Enter an option [Guides/Path/Cross sections only/Settings/COntinuity/Bulge magnitude] 

<Cross sections only>:  (Preview of the loft will be displayed with grips (See Figure 3-86). 
Press ENTER; the loft surface will be created, (Figure 3-87).

After selecting all cross sections and on pressing ENTER, the Enter an option [Guides/
Path/Cross sections only/Settings/COntinuity/Bulge magnitude] <Cross sections only> 
prompt will be displayed. The COntinuity and Bulge magnitude options will be displayed 
in the Command prompt only if you have selected the edges of a model, as one of the cross 
sections. Depending on requirement, you can invoke any one of those options. These options 
are discussed next.

Figure 3-86  Look up grips displayedFigure 3-85  Edges and the profile to be selected

Figure 3-87  Loft surface created

Guide
AutoCAD enables you to select guide curves between the sections of the loft feature. These 
guide curves define the shape of the material addition between the selected sections for 
the loft feature. Guide curves also specify the points of different sections to be joined while 
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adding material between them. This reduces the possibility of an unnecessary twist in the 
resulting feature. You can select as many guide curves as you require. But these guide curves 
should pass through or should touch each section that you selected for loft feature. Also the 
guides should start from the first section and terminate at the last section. Figure 3-88 shows 
three sections for the loft feature. Figure 3-89 shows the resulting loft feature. Figure 3-90 shows 
the sections to be lofted and the guide curves and Figure 3-91 shows the resulting model.

Figure 3-89  Resulting loft featureFigure 3-88  Three section curves for the loft 
feature

Figure 3-91  The loft feature created by using 
the guide curve

Figure 3-90  Sections and guide curves for the 
loft feature

Path
The path option is used to create a loft feature by blending more than one section along 
the  direction specified by the path curve. Note that you can select only one path curve. The 
selected path curve may or may not touch all sections, but it should pass through all sketching 
planes of the sections. Figure 3-92 shows the sections and the path along which the blending 
of material will propagate and Figure 3-93 shows the resulting loft feature. 
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Figure 3-93  Resulting loft feature after 
using the Path option

Figure 3-92  Sections and path to be used for 
the Loft option

Cross sections only
This is the default option displayed at the Enter an option [Guides/Path/Cross sections 
only/Settings/COntinuity/Bulge magnitude] <Cross sections only> prompt. If you need 
to create a loft without a guide or path, press ENTER; the loft feature will be created by using 
the cross sections only.

Settings
When you select Settings, the Loft Settings dialog box will be displayed, as shown in Figure 3-94. 
This dialog box is used to control the shape of the material addition between sections without 
specifying any guide curve or path. You can also select these options from the Look up grip 
displayed along with the preview. Various options in the Loft Settings dialog box are discussed 
next.  

Ruled
If you select the Ruled radio button, a straight blend will be created by connecting different 
sections with straight lines. The loft feature created by this option will have sharp edges at the 
sections. Figure 3-95 shows the loft feature when the Ruled radio button is selected.

Smooth Fit
If you select the Smooth Fit radio button, a smooth loft will be created between sections. 
The loft feature created by this option will have smooth edges at the intermediate section. 
Figure 3-96 shows the loft feature when the Smooth Fit radio button is selected.
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Figure 3-94  The Loft Settings dialog box

Figure 3-96  Loft solid with the Smooth Fit 
radio button selected

Figure 3-95  Loft solid with the Ruled radio 
button selected 

Normal to
This option controls the shape of the loft between the sections. When you select this radio 
button, the drop-down list will be enabled. The following options are available in this drop-down 
list: 
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Start cross section. In this option, the normal of the lofted feature is normal to the start 
section. The loft feature starts normal to the start section and follows a smooth polyline as 
it approaches the next section. Figure 3-97 shows the section selected to create the loft and 
Figure 3-98 shows the loft created by specifying the Start cross section option.

Figure 3-98  Loft solid created by blending 
material normal to the start section

Figure 3-97  Start and end sections to create loft  

End cross section. In this option, the normal to the blending material is normal to the 
end section. At the second last section, the blending material starts along a spline and while 
reaching up to end section, it becomes normal to it, as shown in Figure 3-99.

Start and End cross sections. In this option, the normal to the blending material is normal 
to both the start and end sections. 

All cross sections. In this option, the normal to the blending material always remains normal 
to all cross-sections, as shown in Figure 3-100.

Figure 3-100  Loft solid created by 
blending material normal to all sections 

Figure 3-99  Loft solid created by 
blending material normal to the end 
section

Draft angles
In this option, you can define the angle at the start section and the end section of the loft. 
Remember that you cannot define an angle for the intermediate sketches. You can also specify 
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the distance up to which the blending material will follow this draft angle before bending 
toward the intermediate sections. The various options for specifying the draft angle are 
discussed next. 

Start angle. This edit box is used to specify the draft angle at the start section of the loft. 
Figure 3-101 shows the two sections to be blended and Figure 3-102 shows the loft with the 
start and end angles as 0-degree. Figures 3-103 and 3-104 show the loft feature with the start 
angle as 90-degree and 180-degree, respectively.

Figure 3-104  Loft feature with 180-degree start 
angle and 90-degree end angle

Figure 3-103  Loft feature with 90-degree start 
and end angles

Figure 3-102  Loft feature with 0-degree start 
and end angles 

Figure 3-101  Start and end sections of the 
loft feature

Start magnitude. The value specified in this region signifies the distance up to which 
the blending material will follow the start angle before bending toward the next section. 
Figure 3-105 shows a loft feature with 180-degree as the start and end angles, and 15 as the 
start magnitude. Figure 3-106 shows a loft feature with 180-degree as the start and end angles 
and 2 as the start magnitude. Notice the difference in the extent up to which the blended 
material follows the start angle in the two figures. 

End angles. This edit box is used to specify the draft angle at the end section of the loft. 
Figure 3-101 shows two sections to be blended and Figure 3-102 shows the loft with the start 
and end angles as 0-degree. Figure 3-103 and Figure 3-104 show the loft feature with the end 
angle as 90-degree.
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End magnitude. The value specified in this region signifies the distance up to which the 
blending material will follow the end angle before approaching the last section. Figure 3-105 
shows a loft feature with 180-degree as the start and end angles, and 2 as the end magnitude. 
Figure 3-106 shows a loft feature with 180-degree as the start and end angles, and 10 as the 
end magnitude. Notice the difference in the extent up to which the blended material follows 
the end angle in the two figures.

Figure 3-106  Loft feature with 180-degree as 
the start and end angles, 2 as the start magnitude, 
and 10 as the end magnitude

Figure 3-105  Loft feature with 180-degree as the 
start and end angles, 15 as the start magnitude, 
and 2 as the end magnitude

Close surface or solid
The Close surface or solid check box is selected to close a loft feature by joining the end 
section with the start section. Figure 3-107 shows a loft feature created with this check box 
cleared and Figure 3-108 shows the same sections lofted by this check box selected.

Figure 3-108  Loft solid with the Close
surface or solid check box selected

Figure 3-107  Loft solid with the Close
surface or solid check box cleared

Note
To visualize the effect of the Close surface or solid option, the loft feature should contain at 
least three sections. Otherwise, the extra blending material will be added at the same location 
where the loft feature would have been created without selecting this check box, thereby resulting 
in no change.
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Periodic (smooth ends). If this check box is selected, the seam of the closed surface will not 
buckle, if you alter the shape of the surface.

Tip
You can also use a point as a section for the loft feature, but it should always be the start section 
or the end section of the loft feature.

Continuity
Continuity defines the smoothness of the loft surface between two cross sections, if one of the 
cross sections is an edge of a model. Continuity can be set to G0 (position continuity), G1 
(tangency continuity), or G2 (curvature continuity). G0 maintains the position of the selected 
edges, G1 maintains tangency of the loft surface where it meets edges, and G2 maintains the 
same curvature. By default, the continuity is set to G0. To edit the continuity setting of a loft, 
enter CON at the Enter an option [Guides/Path/Cross sections only/Settings/COntinuity/
Bulge magnitude] <Cross sections only> prompt and press ENTER; you will be prompted 
to specify the continuity. Enter the required option and press ENTER.

You can also set the surface continuity by using the Continuity grip.

Bulge magnitude
The bulge magnitude determines the roundness or the amount of bulge between two cross 
sections, if one of the cross sections is an edge of a model. By default, the bulge magnitude is 
set to 0.5. If you want to edit the bulge magnitude, enter B at the Enter an option [Guides/
Path/Cross sections only/Settings/COntinuity/Bulge magnitude] <Cross sections only> 
prompt and press ENTER; you will be prompted to enter the loft bulge magnitude at the 
start. Enter a value and press ENTER. If there is only one solid edge as a cross section, then 
the bulge will be created. If there are two solid edges as cross sections (one at the start and 
the other at the end), then you will be prompted to enter the bulge magnitude at the start 
and end. Type a value and press ENTER; the bulge will be created. If you need to change the 
bulge magnitude while creating, then click the Bulk magnitude Look up grip; a dot with a 
leader will be displayed. Drag the dot dynamically to change the bulk magnitude.

You can modify the bulk magnitude value after the loft is created. To do so, select the loft; 
three grips will be displayed on it. Right-click on the loft feature and choose the Properties 
option from the shortcut menu displayed; the Properties palette will be displayed with the 
settings of the loft feature. Using this palette, you can modify the bulge magnitude and other 
parameters.

Figure 3-109 shows the edges on the top faces of two solids as well as the region which needs 
to be selected for creating a loft feature. Figure 3-110 shows the preview of the loft feature with 
grips. Figure 3-111 shows the loft feature with bulge magnitude added at the start and end. 

Note
You can also set the surface continuity and the bulge continuity in the Loft Settings dialog 
box.
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Figure 3-110  Preview of the loft and the grips 
displayed

Figure 3-109  Two solids and a region to create a 
loft

Figure 3-111  Loft surface created

CREATING PRESSPULL SOLIDS
  Ribbon: Home > Modeling > Presspull		  Toolbar: Modeling > Presspull	  
  Command: PRESSPULL							     

The Presspull tool is used to remove or add material of any desired shape in a model. 
As the name presspull indicates, if you press a closed boundary inside an existing 
model, it will remove the material of the shape of the closed boundary. However, if 

you pull a closed boundary outside an existing model, it will add material to the model. To 
perform this operation, choose the Presspull tool from the Modeling panel. Next, click inside 
a closed boundary that you want to press or pull and then move the mouse in the desired 
direction. You can specify the desired height by entering a value or by clicking the mouse. 
Figure 3-112 shows the solid model with the closed area to be presspulled. Figure 3-113 shows 
the model created by pressing the closed region and Figure 3-114 shows the model created 
by pulling the closed area.

Given below is the prompt sequence displayed while creating the presspull feature. 
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	 Select object or bounded area : Select any closed bounded area that you want to presspull
	 Specify extrusion height or [Multiple] : Click anywhere to specify the height of extrusion
	 Select object or bounded area : 

If the sketch that you select to press or pull has nested loops, as shown in Figure 3-115, the 
inner closed loops will be deleted from the outer loop, as shown in Figure 3-116. The closed 
area you select for the presspull should consist of lines, polylines, 3D face, edges, regions, and 
faces of a 3D solid. But all these entities should form a coplanar closed area.

Tip
To perform the presspull operation without choosing the Presspull tool, press and hold the 
CTRL+ALT keys and then click inside the closed area to be pressed or pulled.

Figure 3-112  Model with closed area to be presspulled

Figure 3-114  Model with closed area pulledFigure 3-113  Model with the closed area pressed 
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Figure 3-116  The model after the presspull 
operation is performed

 Figure 3-115  Area to be presspulled with closed    	
 boundary inside it

Example 2
In this example, you will create the solid model shown in Figure 3-117.

Figure 3-117  Solid model for Example 2

1.  	 Start a new file using the Acad3d.dwt template.

2.	 Turn off the grid display, increase the limits to 120,120 and then zoom to the limits of 
the drawing.

3.	 Set the view to SE Isometric by using the ViewCube. Then, right-click on the ViewCube 
and choose the Parallel option.

4.	 Switch on the ortho mode. Using lines and arc, create the base of the model with the 
dimensions shown in Figure 3-118. 
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Figure 3-118  Base for the solid model

5.	 Choose the Region tool from the Draw panel in the Home tab and follow the prompt 
sequence given next to convert the sketch drawn into a region.

Select objects: Select the complete base.
Select objects: 
1 loop extracted.
1 Region created.

Note
You can also use the Polyline tool to create this sketch. In that case, you do not need to convert 
it into a region.

6. 	 Choose the Extrude tool from Home > Modeling > Solid Creation drop-down and 
follow the prompt sequence given next to extrude the region.

	 Current wire frame density:  ISOLINES=4, Closed profiles creation mode = Solid
	 Select objects to extrude or [MOde]: _MO Closed profiles creation mode [SOlid/SUrface] 

<Solid>: _SO
	 Select objects to extrude or [MOde]: Select the region 
	 1 found
	 Select objects to extrude or [MOde]: 
	 Specify height of extrusion or [Direction/Path/Taper angle/Expression]: 16

7.	 Change the visual style to Wireframe by choosing the Wireframe option from the Visual 
Styles drop-down list in the In-canvas Viewport control.

8.	 Choose the Wedge tool from Home > Modeling > Solid Primitives drop-down and 
follow the prompt sequence given next to create the next feature.

Specify first corner or [Center]: Pick a point on the screen.
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Specify other corner or [Cube/Length]: L
Specify length: 40
Specify width: 12
Specify height or [2Point]: 28

9.	 Move this wedge and align it with the base. Use the Vertex option of the 3D Object 
Snap to snap the vertex. The model after applying the Hidden visual style is shown in 
Figure 3-119.

Figure 3-119  Wedge aligned with the base

10.	 Orient the view to Front by clicking on Front in the ViewCube and choose WCS > New 
UCS from the drop-down list below it; you are prompted to specify the origin.

11.	 Enter V at the Specify origin of UCS or [Face/NAmed/OBject/Previous/View/World/X/
Y/Z/ZAxis] <World> prompt and press ENTER.

12.	 Draw the profile shown in Figure 3-120 at any place in the drawing area and then convert 
it into a region. 

13.	 Choose the Extrude tool from Home > Modeling > Solid Creation drop-down and 
extrude the region to a depth of 42 units.

14.	 Move this extrude feature and align it with the wedge feature. Use the Vertex option of 
the 3D Object Snap to snap the vertex of the wedge feature.

	 The isometric view of the model after aligning the extrude feature is shown in 
Figure 3-121.

15.	 Orient the view to Right by clicking Right in the ViewCube and choose WCS > New UCS 
from the drop-down list below it; you are prompted to specify the origin.

16.	 Enter V at the Specify origin of UCS or [Face/NAmed/OBject/Previous/View/World/X/
Y/Z/ZAxis] <World> prompt and press ENTER.

17.	 Draw the profile shown in Figure 3-122 at any place in the drawing area and then convert 
it into a region.
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Figure 3-121  Solid aligned with the baseFigure 3-120  The region to be extruded

18.	 Extrude the region to a depth of 16 units and then move it so that it is properly aligned 
with the base, see Figure 3-123.

Figure 3-123  Solid aligned with the baseFigure 3-122  The region before extrusion

19.	 Choose the Solid, Union tool from the Solid Editing panel and follow the prompt sequence 
given next:

Select objects: Select all objects.
Select objects: 

20.	 Change the visual style by selecting the Shades of Gray option from the Visual Styles 
drop-down list in the In-canvas Viewport Controls. The final solid model should look 
similar to the one shown in Figure 3-124.
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Figure 3-124  Solid model for Example 2

Example 3
In this example, you will create the solid model shown in Figure 3-125.

Figure 3-125  Solid model for Example 3

1.  	 Start a new file in the Acad3d.dwt template.

2.	 Turn off the grid display, increase the limits to 75,75, and then zoom to the limits of the 
drawing.

3.	 Orient the view to Left by choosing Left in the ViewCube and choose WCS > New UCS 
from the drop-down list below it; you are prompted to specify the origin.

4.	 Enter V at the Specify origin of UCS or [Face/NAmed/OBject/Previous/View/World/X/
Y/Z/ZAxis] <World> prompt and press ENTER.
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5.	 Right-click on the ViewCube and choose the Parallel option.

6.	 Draw the cross section and path of the sweep feature, as shown in Figure 3-126.

7. 	 Choose the Region tool from the Draw panel in the Home tab and follow the prompt 
sequence given next to convert the sketch into a region.
Select objects: Select both the circles.
Select objects: 
2 loop extracted.
2 Region created.

8.  	 Choose the Subtract tool from the Solid Editing panel in the Home tab and follow the 
prompt sequence:

	 Select objects: Select the region of diameter 29.
Select objects: 
Select solids and regions to subtract.
Select objects: Select the region of diameter 21.
Select objects: 

9.	 Change the visual style to Wireframe by selecting the Wireframe option from the Visual 
Styles drop-down list in the View panel.

10. 	Choose the Sweep tool from Home > Modeling > Solid Creation drop-down and follow 
the prompt sequence given next to sweep the region along the path.

	 Current wire frame density:  ISOLINES=4, Closed profiles creation mode = Solid
	 Select objects to sweep or [MOde]: _MO Closed profiles creation mode [SOlid/SUrface] 

<Solid>: _SO
	 Select objects to sweep or [MOde]: Select the region created in Step 8 
	 1 found
	 Select objects to sweep or [MOde]: 
	 Select sweep path or [Alignment/Base point/Scale/Twist]: Select the arc created in Step 6.

11.  Set the view to SE Isometric by choosing the appropriate hotspot in the ViewCube. Also, 
select the Realistic option in the Visual Styles drop-down list in the View panel. The 
resulting model should look similar to the one shown in Figure 3-127.

12.	 Choose the Top option from the Views panel in the View tab and draw the sketch with 
the dimensions shown in Figure 3-128. 

13.	 Change the view to SE Isometric. The model after drawing the sketch and turning off 
the dimension is shown in Figure 3-129.
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Figure 3-126  Sketch for base pipe feature Figure 3-127  Resulting sweep feature

Figure 3-129  Location of the sketch Figure 3-128  Sketch for the area to Press/Pull

14.  Choose the Presspull tool from the Modeling panel and then click inside the rectangular 
area at the location shown as Area A in Figure 3-130. Next, move the mouse in the upward 
direction, enter the value 5 at the Command prompt, and press ENTER.

15. 	Again, choose the Presspull tool and pull the area shown as Area B in Figure 3-130 by 
the same value as specified in Step14. The resulting model should look similar to the one 
shown in Figure 3-131.

16.	 Similarly, create the flange for the other face of the pipe. The resulting model should be 
similar to the one shown in Figure 3-132.

17. 	Choose the Solid Union tool from the Solid Editing panel in the Home tab and follow 
the  prompt sequence given next.
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Figure 3-131  Resulting model after Step 15Figure 3-130  Two areas to presspull

Select objects: Select all objects.
Select objects: 

The final solid model should look similar to the one shown in Figure 3-133.

Figure 3-133  Final model after UnionFigure 3-132  Resulting model after Step 16

  Self-Evaluation Test	
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The Cone tool can be used to create a solid cone with a circular and an elliptical base. 
(T/F)

2.	 Open entities can be converted into regions. (T/F)
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3.	 An ellipse can be converted into a polysolid. (T/F)

4.	 You can twist a cross-section while sweeping it. (T/F)	

5.	 The __________ tool can be used to add as well as remove material from a model.

6.	 In AutoCAD, you can create a pyramid of maximum 42 sides. (T/F)

7.	 The __________ tool is used to generate a helical curve.	

8.	 The number of paths for a loft feature cannot be more than __________ .

9.	 At least __________ cross-sections are required to create a loft feature.

10.	 You can extrude the selected region about a path using the __________ option of the 
Extrude tool.

  Review Questions   
Answer the following questions:
 
1.	 You can revolve an open entity. (T/F)

2.	 You cannot apply Boolean operations on regions. (T/F)

3.	 The entity to be revolved should lie completely on one side of the revolution axis. (T/F)

4.	 You cannot apply the Presspull tool on an open object. (T/F)

5.	 There cannot be more than one guide for the loft feature. (T/F)

6.	 A curve generated by the Helix tool can be used as a path for the swept solids. (T/F)

7.	 Which of the following values for the taper angle is used to taper the extruded model 
from the base?

		  (a) Positive				    (b) Negative
		  (c)  Zero	 			   (d) None of these

8.	 Which of the following tools is used to create a cube?

		  (a) Box					    (b) Cuboid
		  (c) Polygon				    (d) Cylinder
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9.	 Which of the following commands is used to check the interference between the selected 
solid models?

		  (a) INTERFERE			   (b) INTERSECT
		  (c) INTERFERENCE		  	 (d) CHECK

10.	 The Presspull tool is used for which of the following functions?  

		  (a) Add material			   (b) Remove material
		  (c) Both add and remove material	 (d) Neither add nor remove material

11.	 The __________ direction is known as the extrusion direction.

12.	 The __________ tool is used to create an apple-like structure.

13.	 The __________ tool is used to create a revolved solid.

14.	 Guides for the Loft tool should always __________ the cross-section. 

15.	 The __________ option of the Revolve tool is used to select a 2D entity as the revolution 
axis.

Exercise 1
In this exercise, you will create the solid model shown in Figure 3-134. Assume the missing 
dimensions.

Figure 3-134  Model for Exercise 1

Problem-Solving Exercise 1
In this exercise, you will create the solid model with dimensions shown in Figure 3-135 and 
Figure 3-136.  



3-64 AutoCAD 2015:  A Problem-Solving  Approach
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 3-136  Views for Problem-Solving Exercise 1

Figure 3-135  Solid model for Problem-Solving Exercise 1

 Answers to Self-Evaluation Test   
1. T, 2. F, 3. F, 4. T, 5. Presspull, 6. F, 7. Helix, 8. one, 9. two, 10. Path


