Chapter 1

Introduction to
Adobe Flash
Professional CS5.5

Learning Objectives

After completing this chapter, you will be able to:

* Understand the Adobe Flash Professional CS5.5 interface

* Work with various panels in Adobe Flash Professional CS5.5
* Import images and sounds

* Undo and redo steps in Adobe Flash Professional CS5.5

* Save and preview artwork

* Find online resources for Adobe Flash Professional CS5.5
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INTRODUCTION

Adobe Flash Professional CS5.5 is a multimedia platform for creating digital animation, rich
web applications, websites, movies as well as content for mobile phones and other embedded
devices. It is frequently used for creating advertisements and games. Some of the most popular
games made in Flash are Minesweeper, Pac Man, Tetris, and Bejewelled. Flash has also been
used to create many popular movies and series such as Off-Mikes, Gotham Girls, CrimeTime,
and Homestar Runner.

In this chapter, you will learn to start Adobe Flash Professional CS5.5, create a new Flash CS5.5
document, and get familiar with Adobe Flash Professional CS5.5 interface. You will also learn
how to work with various panels.

STARTING Adobe Flash Professional CS5.5

To start Adobe Flash Professional CS5.5, choose the Start button on the taskbar; the Start menu
will be displayed. Next, choose All Programs > Adobe Master Collection CS5.5 > Adobe
Flash Professional CS5.5 from the Start menu , as shown in Figure 1-1; the ADOBE FLASH
PROFESSIONAL CS5.5 welcome screen will be displayed, as shown in Figure 1-2. To create a
new Flash CS5.5 document, choose ActionScript 3.0 from the Create New area of the welcome
screen. Alternatively, choose File > New from the menubar; the New Document dialog box is
displayed. In this dialog box, choose ActionScript 3.0 from the General tab and then choose
the OK button, refer to Figure 1-3; a new flash file will be created.
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Figure 1-1 Starting Adobe Flash Professional CS5.5 using the Start menu
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Figure 1-2 The ADOBE FLASH PROFESSIONAL CS5.5 welcome screen

Mew Document

General Templates

Type:

T Actionscript 3.0

Tl ActionScript 2.0

T ar

'ﬁ AIR for Android

T arforios

Tl Flash Lite 4

i Adobe Device Central
| ActionScript 3.0 Class
1| ActionScript 3.0 Interface
| ActionScript File

"E ActionScript Communication File
"E Flash JavaScript File

"E Flash Project

Height:

Ruler units:| Pixels | »

Frame rate: 24.00 fps

Background color:[l

Auto-Save:[ ] 10 minutes

Make Default

Description:

Create a new FLA file (*.fla) in the Flash Document window.
The Publish Settings will be set for ActionScript 3.0, Use FLA
files to set up the media and structure for SWF files published
for Adobe Flash Flayer.

Figure 1-3

The New Document dialog box
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EXPLORING THE Adobe Flash Professional CS5.5
INTERFACE

The interface of Flash CS5.5 consists of a Stage, TOOLS panel, TIMELINE panel,
PROPERTIES panel, menubar, and application bar, as shown in Figure 1-4. Using the tools in
this interface, you can create interactive websites and digital animations as well as edit and add
elements to your movie. You can also import files from Adobe Illustrator, Adobe Photoshop,
and Adobe After Effects in Flash CS5.5. Various components of Flash CS5.5 interface are
discussed next.
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Figure 1-4 The default Flash CS5.5 screen with various panels

Workspace

In Flash CS5.5, the main screen is called the Application screen. You can arrange panels based
on your requirement and save the current interface as your workspace. To save the current
arrangement of panels as your workspace, choose the Workspace switcher button from the
Application bar; a flyout will be displayed. In this flyout, choose the New Workspace option, as
shown in Figure 1-5. The New Workspace dialog box will be displayed. Next, type the name of
the workspace in the Name text box and then choose the OK button; the current arrangements
of panels will be saved with the name that you specified in the dialog box and it becomes the
active workspace. You can also choose the preset workspace from the workspace flyout.
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Figure 1-5 Choosing New Workspace from the workspace flyout

Stage

Stage is an area where all activities are performed that the viewers see when a movie is being
played. The gray area surrounding the Stage is called Pasteboard. Anything in the Pasteboard
is not visible in the final output. You can change the color and size of the Stage by using the
options in the New Document dialog box and the PROPERTIES panel, refer to Figures 1-6

and 1-7.
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Figure 1-6 Options for changing the Stage properties in the New Document dialog box
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Figure 1-7 Options for changing the Stage properties in the PROPERTIES panel

TOOLS Panel

The TOOLS panel is divided into four sections, refer to Figure 1-8. The top section consists
of the selection, drawing, painting, typing, and editing tools. The other sections consist of
view tools, color tools, and option tools. The Options section of the TOOLS panel displays
the options for the selected tool. The Color section consists of tools that are used to specify
the color of the border and fill inside an object.

In Flash, the outline of an object is called stroke and the color filled inside an object is called
fill. The black triangle next to a tool indicates that there are some more hidden tools in the
respective tool category. These tools are called hidden tools. To display the hidden tools, press
and hold the left mouse button on that tool; a flyout will be displayed with all hidden tools.
The various tools in the TOOLS panel are discussed next.

Selection Tool
The Selection Tool is used to select an object, group of objects, strokes, and fills. To
k select an object, choose the Selection Tool and then click on the object. Alternatively,
invoke the tool and marquee select the object. The options displayed in the Options
section of the TOOLS panel on invoking the Selection Tool are discussed next.

Snap to Objects
m On choosing the Snap to Objects option, the objects that you move in the Stage
jump to the edge of the nearest object.
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Smooth m—
.. The Smooth option is used to smoothen the outlines
? of the selected object. R
%]
Straighten Q:
»{ The Straighten option is used to straighten the o
outlines of the selected object. 3
Subselection Tool T
N The Subselection Tool is used to change the shape of N
an object. Ul —— .
2| |Selection, Drawing,
Free Transform Tool f Si:{;ﬂg%ﬁ,‘fﬁ ng. and
M The Free Transform Tool is used to rotate, move, skew, i
“ and distort an object. The options displayed in the 79
Options section of the TOOLS panel on invoking the &,
Free Transform Tool are discussed next. #
&
Rotate and Skew a7
—  The Rotate and Skew option is used to rotate and o
. . S . Q | |View tools
give an oblique direction to the selected object. _
.?
Scale |
=]  The Scale option is used to scale the selected ol I
object. = Color tools
Distort »
-~ The Distort option is used to deform the shape |
of an object by dragging individual transform ,) S
points. Each transform point can be moved (| |Options section

individually in all directions. —
Figure 1-8 The TOOLS panel

Envelope
:w.:  The Envelope option is used to manipulate the shape of an object. It creates an
T envelope of transform points around the object. Each transform point can move

independently with respect to other transform points.

Gradient Transform Tool
— The Gradient Transform Tool is used to scale, rotate, and change the direction of
“ the gradient fill in an object.

3D Rotation Tool
Q The 3D Rotation Tool is used to create an impression of 3D in Flash CS5.5. With the
*  help of this tool, you can position the object at an angle and rotate it about any axis,
refer to Figure 1-9. Note that the 3D Rotation Tool and 3D Translation Tool work
only on a movie clip symbol. You will learn about symbols in detail in later chapters.
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3D Translation Tool
A The 3D Translation Tool is used to create a 3D perspective view and depth. You can
“  create the depth by manipulating the distance between the object and the viewer by
moving the object about the Z axis, as shown in Figure 1-10. The option displayed in
the Option section of the TOOLS panel on invoking the 3D Rotation Tool and 3D Translation
Tool are the Global Transform (default) and the Local Transform.

Figure 1-9 Rotating the movie Figure 1-10 Translating the
clip about the Y-axis movie clip about the Z-axis

Global Transform

= The Global Transform button toggles between Global Transform option and
Local Transform option. Global transform make transformations that are relative
to the Stage coordinate system and Local Transform make transformations relative

to the object itself. To switch to Local Transform option, choose the Global Transform

button (button raised). You will learn the usage of the 3D tools in the later chapters.

Lasso Tool
= The Lasso Tool is used to select an object or a part of it by creating outlines. The
options displayed on invoking the Lasso Tool are discussed next.

Magic Wand
3, The Magic Wand option is used to select the areas that contain the similarly colored
areas.

Magic Wand Settings
s The Magic Wand Settings option is used to specify the values for the Threshold
N and Smoothing options of the Magic Wand option.

Polygon Mode
-S:ﬂ The Polygon Mode option is used to select an object or an area by creating linear
and interconnected lines.
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Pen Tool
1& The Pen Tool is used to draw shapes and paths. All the path and shape objects are
*  built from a series of anchor points. You can modify the path by clicking on the path
and then manipulating the anchor points.

Add Anchor Point Tool
¢+ The Add Anchor Point Tool is used to add an anchor point to the path. For adding a
* new anchor point on a path, select the path and then choose the Add Anchor Point
Tool. Next, click on the point in the path where you want to add a new anchor
point.

Delete Anchor Point Tool
‘&_ The Delete Anchor Point Tool is used to delete anchor points. To delete an anchor
« point, choose the Delete Anchor Point Tool and then click on the anchor point that
you want to delete.

Convert Anchor Point Tool

The Convert Anchor Point Tool is used to break the handle of an anchor point into
two handles that can be moved independently with respect to each other. To do so,
choose the Convert Anchor Point Tool. Next, select the anchor point and then click
on the endpoint of the handle to convert it into two independent handles.

Fl

Text Tool
T The Text Tool is used to write text as a vector object. To create a text object, choose
the Text Tool and then drag the cursor in the Stage; a text box will be displayed in
the Stage. Now, you can write the text in the text box.

Line Tool

N The Line Tool is used to draw a straight line segment. To create a line, choose the
Line Tool, press and hold the left mouse button, and drag the cursor in the Stage; a
straight line segment will be created in the Stage.

Rectangle Tool
The Rectangle Tool is used to draw a rectangular shape. To draw a rectangular shape,
choose the Rectangle Tool, press and hold the left mouse button, and then drag the
cursor in the Stage; a rectangle will be created in the Stage.

Oval Tool
e The Oval Tool is used to draw an oval shape. To draw an oval shape, choose the Oval
« Tool, press and hold the left mouse button, and then drag the cursor in the Stage; an
oval shape will be created in the Stage.

. Note
@ When you invoke a tool, the properties of that tool arve displayed in the PROPERTIES
panel.
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Rectangle Primitive Tool
Similar to the Rectangle Tool, the Rectangle Primitive Tool is also used to draw a
* rectangular shape with the only difference the corner radius of the rectangular shape
drawn by this tool is modifiable. To draw a rectangle, choose the Rectangle Primitive
Tool. Next, press and hold the left mouse button and then drag the cursor in the Stage; a
rectangular shape will be created in the Stage. You can change its corner radius by specifying
values in the Rectangle corner radius edit box in the RECTANGLE OPTIONS area of the
PROPERTIES panel, as shown in Figure 1-11.

]] Rectangle Primitive Tool k
&
=7 FILL AND STROKE g
2 . &[] o
Stroke: L———— Q
Style: [Solid |~] & "[“
Scale: [ Hinting AN
Cap: =| ¥
Joins B|v  Miter: 3,00 & | Rectangle Primitive
.| Tool
> RECTANGLE OPTIONS 3;?
€ b == |
L oo | A oo | &‘ Rectangle cormer
N S — f‘ radius edit box

Figure 1-11 The RECTANGLE OPTIONS area of the Rectangle Primitive Tool

Oval Primitive Tool
- The Oval Primitive Tool, like the Oval Tool, is also used to create an oval shape with

* the only difference that you can change the start angle, end angle, and inner radius

of the oval shape by specifying the options in the OVAL OPTIONS area of the
PROPERTIES panel.

Tool Settings
Polystar Tool Styte:
- The Polystar Tool is used to draw the polygon and star Number of Sides: 5

Fl

shaped objects. On invoking this tool, the Options
button is displayed in the PROPERTIES panel. On
choosing the Options button, the Tool Settings dialog box
will be displayed, refer to Figure 1-12. Using the options
in this dialog box you can change the style, number of sides,
and star point size of the polygon and star shaped ob-
jects.

Star point size: 050

Figure 1-12 The Tool Settings
dialog box



Introduction to Adobe Flash Professional CS5.5 1-11

Pencil Tool
The Pencil Tool is used to draw lines and shapes. The options displayed in the Options
section on invoking the Pencil Tool are discussed next.

Straighten
,  The Straighten mode is used to draw straight lines.

Smooth
S The Smooth mode is used to draw smooth curved lines.

Ink
4 The Ink mode is used to draw freehand lines.

@
L o .
Brush Tool - -
7 The Brush Tool is used to draw C ; [ |
«  brush-like strokes. The options | ® 4 Paint Normal ;"'L = |
displayed on invoking the Brush © Paint Fills : L Q (]
Tool are Brush Mode, Brush Size, and O Paint Behind a e = /
Brush Shape. You can change the mode, © paint selection | [ ] =3 V4
size, and shape of the brush by using (3 Paint Inside | L@ -]
these options, refer to Figure 1-13. Brush Mode Brush 5ize  Brush Shape

Figure 1-13 The Brush Tool options
Spray Brush Tool
8 The Spray Brush Tool is used to spray a pattern of shape in the Stage. By default, a
“ dot pattern is sprayed. You can also choose other shapes in the form of Movie clip or
Graphic symbols from the LIBRARY panel. The Spray Brush Tool will be discussed
in detail in the later chapters.

Deco Tool
& The Deco Tool is used to create complex patterns and decorations easily and quickly.
. You will learn the usage of the Deco Tool in the later chapters.

Bone Tool

The Bone Tool is used to create bones for objects so that the complex movements of
the objects look natural when they are animated. You can easily make smooth character
animations with the help of this tool.

a

Bind Tool

{;? The Bind Tool is used to edit and control the connections between bones.

a
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Paint Bucket Tool
& The Paint Bucket Tool is used to apply the fill (solid, gradient, or bitmap) in a closed
* path or area.

Ink Bottle Tool
> The Ink Bottle Tool is used to change the color, width, and style of the stroke.

Eyedropper Tool
# The Eyedropper Tool is used to pick the fill and stroke hexadecimal values.

Eraser Tool

The Eraser Tool is used to erase a section of the | R
artwork in the Stage. There are several options * 4

of the Eraser Tool, refer to Figure 1-14. : E
/ Note — : = . -a
@ When the Faucet (£ ) option of the Eraser Tool 6 Erm :_:rma %l . 24

- . . . rase rills

is selected, then on clicking even on a part of the D Erce Lines ® m o

~ . ~ . L= ‘

stroke or fill, the entire str.oke.or Sill is erased. So, @) Erase Selected Fils I =
make swre the Faucet option is not selected unless © Erase Inside ] .

you want to delete entire fill or stroke. Eraso Modo Eraser Shape

Hand Tool Figure 1-14 The Eraser Tool options

W The Hand Tool is used to move the Stage in
all directions without changing the magnification. This tool allows you to pan the Stage
along the X and Y axes.

Zoom Tool
Q The Zoom Tool is used to magnify (zoom in) and demagnity (zoom out) the Stage.
The options displayed on invoking the Zoom Tool are discussed next.

Enlarge
R The Enlarge option is used to zoom in the Stage.

Reduce
Q The Reduce option is used to zoom out the Stage.

Stroke Color
The Stroke Color swatch is used to define the color of the stroke. In Flash, the outline
o of an object is called stroke. To define the color of the stroke, select the stroke by using
the Selection Tool and then select the required color from the flyout that is displayed
on choosing the Stroke Color swatch. You can also select the color first and then draw the
stroke.
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Fill Color
My The Fill Color swatch is used to define the color of the fill. In Flash, the color filled
N inside an object is called the fill. To define the color of the fill, select the color from
the flyout that is displayed on choosing the Fill Color swatch and then apply it in the
required area. To change the color of the fill of a shape, select the entire fill using the Selection
Tool and then select the required color.

Black and white
m The Black and white tool is used to redefine the stroke color as black and the fill color
as white.

Swap colors
> The Swap colors tool is used to swap the stroke color to fill color and vice-versa.

TIMELINE Panel

The animations and drawings in the Stage or Pasteboard reflect automatically in the Timeline.
The TIMELINE panel consists of layers, frames, Playhead, and few other components, as
shown in Figure 1-15.

Show or Hide All Layers

Lock ar Unlock All Layers Erame View button

Timeline Header

Layers area

Show All Layers as Outlines

TIMELINE

o

Blank frame

Center Frame PEyeEE

Loop
Playback controls Cinion Skin Edit Multiple Frames
[Omom Skin Qutlines Modify Markers
| 1> b b e as [-}—‘.}. #00fe 0.0s I ¥

Delete 130 tolast frame Current  Frarme Elapsed Time
New Folder Step forward one frame  Frame Rate

Pl
Mew Layer =

Step backward one frame

Go to first frame

Figure 1-15 The TIMELINE panel

The Timeline Header in the TIMELINE panel displays the frame numbers and the Playhead
indicates the current frame displayed in the Stage. Various options in the TIMELINE panel
are discussed next.

New Layer
The New Layer button is used to create a new layer.

New Folder
The New Folder button is used to create a new folder that can be used to organize layers.

t www.cadcim.com
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Delete
The Delete button is used to delete the selected layer.

Go to first frame
The Go to first frame button is used to place the Playhead on frame 1 in the TIMELINE
panel.

Step backward one frame
The Step backward one frame button is used to move the Playhead backward by one frame
from the current frame.

Play

The Play button is used to play the animation in the Stage.

Step forward one frame
The Step forward one frame button is used to move the Playhead forward by one frame from
the current frame.

Go to last frame
The Go to last frame button is used to place the Playhead on last frame of the animation in
the TIMELINE panel.

Center Frame
The Center Frame option is used to center the Timeline on the current frame.

Loop

The Loop button is used to specify a range of frames to play repeatedly during animation.

Onion Skin

The Onion Skin button is used to view the number of frames simultaneously in the Stage. By
default, you can see the contents of only the current frame in the Stage. The button is also
used to view the progress of an animation. All the frames between Start Onion Skin and End
Onion Skin markers are superimposed as one frame, refer to Figure 1-16.

Onion Skin Outlines

The Onion Skin Outlines button is used to display the objects on the frames between Start
Onion Skin and End Onion Skin markers as outlines, refer to Figure 1-17. The Onion Skin
Outlines mode is used for long and detailed animations.
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Figure 1-16 The frames in the Onion Figure 1-17 The frames in the Onion
Skin mode Skin Outlines mode

Edit Multiple Frames
The Edit Multiple Frames button is used to enable editing of all frames between Onion Skin
markers.

Always Show Markers
Modify Markers

. . . . Anchor Mark
The Modify Markers option are part of the Onion Skin. It is used reneriETEE

to control the number of frames before and after the current Marker Range 2
frame that will be displayed in Onion Skin overlay. On choosing Marker Range 5
this button, a flyout is displayed, as shown in Figure 1-18. In this Marker Range All

flyout, choose the required range of markers. The options in this g gure 1-18 The Modify
flyout are discussed next. Markers flyout
Always Show Markers

The Always Show Markers option is used to display the Onion Skin markers whether
or not the Onion Skin is on.

Anchor Markers
The Anchor Markers option is used to lock the Onion Skin markers to their current
position in the Timeline Header.

Marker Range 2
The Marker Range 2 option is used to apply markers on two frames on either side of the
current frame.

Marker Range 5
The Marker Range 5 option is used to apply markers on five frames on either side of
the current frame.

Marker Range All
The Marker Range All option is used to apply markers to all frames.
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Current Frame
The Current Frame option displays the frame on which the Playhead is placed. You can also
scrub the Current Frame option to place the Playhead on the required frame.

Frame Rate
The Frame Rate option is used to specify the speed at which the movie will be played. By

default, the frame rate is set to 24 frames per second. You can change the frame rate from the
PROPERTIES panel, TIMELINE panel and New Document dialog box.

Elapsed Time
The Elapsed Time option is used to display the time that has elapsed in your animation at
the frame that you have selected.

Show or Hide All Layers
The Show or Hide All Layers button is used to display or hide the contents of the layers.

Lock or Unlock All Layers
The Lock or Unlock All Layers button is used to freeze or defreeze the layers.

, Note
@ If a layer is frozen in the TIMELINE panel, no changes can be made in that layer.

Show All Layers as Outlines

The Show All Layers as Outlines button is used to display only the outline of the contents of
the layers. You can also change the layer properties using the Layer Properties dialog box,
refer to Figure 1-19. To open the Layer Properties dialog box, double-click on the layer icon
(") located on the left of the layer name in the Layer area of the TIMELINE panel.

Layer Properties @
Name:| ENISa1 | [ox |
™ show [ Lock

Type: (&) Normal
() Mask
() Masked
) Folder
O Guide

Outline color:[ ]

[ view layer as outlines

Layer height:| 100% | »

Figure 1-19 The Layer Properties dialog box
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Working with Library

The library in Flash stores all the media files such as bitmaps, graphics, sound files, and video
clips that you import and symbols that you create in a Flash document. You can organize items
in the library into folders and sort them by their type. You can also open the library of the other
Flash documents in the current document to make the library items available from that file.

LIBRARY Panel
By default, the LIBRARY panel is located next to the PROPERTIES panel in the ESSENTIALS
workspace.

, Note
@ In Flash CS5.5, every workspace has its own settings of panels.

To display the LIBRARY panel, choose Window > Library from the menubar. The various
parts of the LIBRARY panel, as shown in Figure 1-20, are discussed next.

LIBRARY

c03_tut_03.fla H'T (B

=

I

Mewy library panel
Fin current library

ltem Preview window

Search text box

Titem ¥el R
Name | Linkage

cricket ball

oegRT T

\:Delete
Properties
Mew Folder

Mew Symbol

Figure 1-20 The LIBRARY panel

Item Preview window
The Item Preview window displays the selected item in the LIBRARY panel.

Pin current library
The Pin current library button is used to pin the LIBRARY panel to make it stay active across
multiple Flash documents.

New library panel
The New library panel button is used to create a new LIBRARY panel that will stay across
multiple Flash documents but is active only in the document in which it is created.
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New Symbol
The New Symbol button displays the Create New Symbol dialog box that is used to create
a new symbol.

New Folder
The New Folder button is used to create a new folder in the LIBRARY panel.

Properties
The Properties button displays the Symbol Properties dialog box of the selected symbol.

Delete
The Delete button is used to delete the selected symbol or folder.

IMPORTING IMAGES

You can import images of different formats such as PNG, GIF, JPG, JPEG, and so on in Flash
CS5.5 with filename extensions. To import an image in the Stage, choose File > Import >
Import to Stage from the menubar; the Import dialog box will be displayed. In this dialog box,
browse and select the required image and then choose the Open button. If you choose File >
Import > Import to Library from the menubar, the image will be saved in the LIBRARY
panel. You can drag and drop images from the LIBRARY panel to the Stage.

IMPORTING SOUND

To import sound in Flash CS5.5, choose File > Import > Import to Library from the menubar;
the Import to Library dialog box will be displayed. Browse and select the sound and choose
the Open button. To add a sound to the Timeline, choose Insert > Timeline > Layer from
the menubar, as shown in Figure 1-21; a new layer is added in the TIMELINE panel to import
sound. Drag and drop the sound from the LIBRARY panel in the Stage; the sound will be
added to the current layer.

E Modify Text Commands Control  Debug  Window
Mew Symbaol... Ctrl+F&

Maotion Tween
Shape Tween

Classic Tween

Timeline 3 Layer

I’\\? Layer Folder

Scene

Frame F5

Keyframe
Blank Keyframe

Figure 1-21 The Timeline submenu
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Flash CS5.5 consists of a sound library containing different sounds that can be used for sound
effects. To open the sound library, choose Window > Common Libraries > Sounds from the
menubar. The sound formats that Flash CS5.5 supports are ASND, WAV, mp3, AIFF, Sun AU,
and Sound Only QuickTime movies.

Note
@ The ASND (Adobe Sound Document) is the native sound format of Adobe Soundbooth.

UNDO AND REDO IN FLASH CS5.5

In Flash CS5.5, you can undo and redo the actions performed by using the Undo and Redo
commands. To undo an action performed earlier, choose Edit > Undo from the menubar or
press CI'RL+Z. Similarly to redo an action, choose Edit > Redo from the menubar or press
CTRL+Y. You can also use the History panel to undo multiple steps. To display the History
panel, choose Window > Other Panels > History from the menubar, as shown in Figure 1-22.
You can set the number of maximum undo commands based on your requirement. To do so,
choose Edit > Preferences from the menubar; the Preferences dialog box will be displayed.
You can set the undo levels from 2 to 9999 in the levels edit box of the Undo area. Next,
choose the OK button.

[Window | Help | | Essenials »
i Duplicate Window Ctrl+Alt+K ﬁ
Toolbars y & 4. M
v Timeline Ctrl+Alt+T -
Motion Editor
v | Tools Ctrl+F2
v Properties Ctrl+F3
Library Ctrl+L
Common Libraries 3
Motion Presets
Project Shift+F8
Actions F3 —

Code Snippets

Behaviors Shift+F3
Compiler Errors Alt+F2 L
Debug Panels 3
Movie Explorer Alt+F3 4
Output F2
Align Cirl+K
Color Alt+Shift+F9
Info Ctrl+]
Swatches Ctrl+F3
Transform Ctrl+T
Components Ctrl+F7 )
1 Compenent Inspector Shift+F7 | | »
i Other Panels 3 Accessibility Alt+Shift+F11
Extensions E} ' History Ctrl+F10
Scene Shift+F2
arEE D Strings Chrl+F11
Hide Panels R WebSenvices  Ctrl+Shift+F10

3 v 1Untitled-1 I on

Figure 1-22 The Other Panels submenu
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SAVING FLASH DOCUMENT

To save a Flash file, choose File > Save or Save as from the menubar; the Save As dialog
box will be displayed. Next, specify the name for the file and choose the Save button, refer
to Figure 1-23. The default format for saving a flash file is FLLA. However, you can change it
to the XFL format.

Save As @
X i b ~
@uvl- Desktop » - | 4 | Search Desktop e |
Organize « New folder == - @
W0 Favorites = =EES | e
4. Downloads L _lIJ System Folder

m

= Recent Places

Bl Desktop 1 Homegroup
q System Folder

n

4 Libraries | 4

B CADCIM
| Documents % Systemn Folder
J’ Music
=] Pictures L] | Computer
B videos = J,' System Folder
i e e
File name: Untitled-1.fla -
Save as type: ’Flash C55.5 Document (*.fla) v]
= Hide Folders [ Save ] l Cancel l
Figure 1-23 The Save As dialog box
Note

®

The XFL file format is used to represent a flash document as XML document. You can open
and work on XFL file in Flash CS5.5. After working on XFL file in Flash Professional CS5.5,
you can save it in the FLA or XFL file format.

You can also save a Flash file by using the Save as Template option. To do so, choose File >
Save as Template from the menubar; the Save As Template Warning message box will
be displayed with a message that the SWF history data will be cleared if the file is saved as
template, refer to Figure 1-24. In this message box, choose the Save as Template button; the
Save as Template dialog box will be displayed, as shown in Figure 1-25. The Save as Template
option is useful when you have created a file such as a website that you want to use later. It
does not save the undo/change history of a file. As a result, the size of the file saved on your
system is reduced.
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Flash lets you save the file as a template that can be used later in other Flash documents.
In the Save as Template dialog box, specify a name for the file and select the category. You
can select the preset categories or create your own category. Next, give the description of the
category (optional) and then choose the Save button.

Save As Template Warning

| SWF history data will be cleared if saved as template.
M

Y

[] Dan't show again.

| Save As Template | | Cancel |

Figure 1-24 The Save As Template Warning message box

Save as Template @
Name:| | Preview:
Category: H?J_
Description: Advertlsmg
AlR for Android
Animation
Banners

Media Playback
Presentations

Sample Files

| Save || Cancel

Figure 1-25 The Save as Template dialog box

PREVIEWING YOUR WORK

You can preview your work in Flash CS5.5 to check whether you are getting the required
output. To see how the final output will appear to viewers, choose Control > Test Movie >
in Flash Professional from the menubar or press CI'RL+ENTER; the Untitled-1 output
window will be displayed, refer to Figure 1-26. The Untitled-1 file has the .swf extension and
is the rendered output of the Flash document. When you press CI'RL+ENTER, the SWF file
is created and saved.

t www.cadcim.com

1on visi

Evaluation Copy. Do not reproduce. For informat



1-22

Adobe Flash Professional CS5.5: A Tutorial Approach

=% Untitled-1

File View Control Debug

F=3(EoR(>)

CADCIM

Figure 1-26 The Untitled-1 preview window

Note

@ For complete information about using Flash CS5.5, choose Help > Flash Help from the
menubay;, refer to Figure 1-27 or press the FI1 key. On doing so, you will be connected to Adobe
Community Help. Make sure that you have access to the internet. With Adobe Community

Help, you can search Flash Help and support documents.

Help |
i Flash Help

1
Flash Support %enter
Adobe Product Improvernent Program...

Flash Exchange
Omniture

Manage Extensions...
Adobe Online Forums

Product Registration...
Deactivate...

Updates...

About Adobe Flash Professional

Figure 1-27 Invoking the Help menu from menubar
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Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1. The is used to create complex patterns and decorations quickly and easily.
2. The is used to scale, rotate, and change the direction of gradient fill in an
object.

3. The gray area surrounding the Stage is called

4. is the keyboard shortcut for previewing the work.

5. The is the native sound format of Adobe Soundbooth.

6. The Zoom Tool is used to pan the Stage along the X and Y coordinates. (1/F)
7. The color filled inside an object is called stroke. (T/F)

8. The Color tools consists of the tools that are used to change the color of the stroke and
fill inside an object. (T/F)

9. The Ink Bottle Tool is used to pick the attributes of the fill and stroke from an object to
apply on another object. (1/F)

10. The Magic Wand Settings option is used to specify the value for the Threshold and
Smoothing options of the Magic Wand option. (1/F)

Review Questions

Answer the following questions:

1. Which of the following options is displayed on invoking the Lasso Tool?

(a) Magic Wand (b) Magic Wand Settings
(c) Polygon Mode (d) All of these
2. The is used to draw a rectangular shape in which you can change the corner

radius of the rectangular shape.
3. The key is the keyboard shortcut for accessing Flash Help.
4. The displays the frame numbers.

5. The window displays the selected item in the LIBRARY panel.
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6. The option in the TIMELINE panel represents the current frame that is
displayed in the Stage.

7. The Bind Tool is used to create bones. (1/F)

8. The Pen Tool is used to draw shapes and paths. (1/F)
9. The Subselection Tool is used to change the shape of an object. (T/F)
10. The Pin current library button is used to pin the LIBRARY panel to make it stay active

across multiple Flash documents. (T/F)

Answers to Self-Evaluation Test
1. Deco Tool, 2. Gradient Transform Tool, 3. Pasteboard, 4. CTRL+ENTER, 5. ASND, 6. F,
7.F,8.T,9.F, 10. T



