
Chapter 3

 Introduction to 
Polygon Modeling

 Learning Objectives 
After completing this chapter, you will be able to:
• Create polygon primitives
• Work with various polygon modeling tools
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INTRODUCTION
In the previous chapters, you learned to create 3D objects and shapes using the spline modeling 
techniques. In CINEMA 4D, primitive objects can be modified at the basic level by editing the 
edit points and parameters in the Attribute Manager. You can also modify the objects at an 
advanced level by converting them into editable polygons. The converted objects consist of 
sub-objects that can be modified using the Move, Rotate, and Scale tools. The sub-objects are 
points, edges, and polygons. In this chapter, you will learn to modify the objects at basic as well 
as advanced level by converting them into polygons.

TUTORIALS
Before you start the tutorials of this chapter, you need to download the c03_cinema4d_R25_tut.zip 
file from www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual 
Effects > MAXON CINEMA 4D > MAXON CINEMA 4D R25: A Tutorial Approach

Next, you need to browse to \Documents\c4dR25 and create a new folder in it with the name c03. 
Next, extract the contents of the zip file in this folder.

 Tutorial 1                                                                             
In this tutorial, you will create the 3D model of a table lamp, as shown in Figure 3-1, using the 
edit points and parameters in the Attribute Manager.	                    (Expected time: 20 min)

Figure 3-1  The model of a table lamp

The following steps are required to complete this tutorial:
	
a.   	Create base of the table lamp.
b.	 Create body of the table lamp.  
c.   	Create shade of the table lamp.
d.	 Change color of the table lamp.
e.	 Change the background color of the scene.
f.	 Save and render the scene.
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Creating Base of the Table Lamp		
In this section, you will create base of the table lamp using the Cylinder tool.

1. 	 Make sure the Perspective viewport is selected and then choose Create > Mesh Primitive from 
the main menu; a cascading menu is displayed. Next, choose Cylinder from it; a cylinder is 
created in the Front viewport and Cylinder is added to the Object Manager.  Choose Display 
> Gouraud Shading from the Menu in editor view; a Cylinder is displayed in the shading 
mode.

2.	 In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. 
In this area, enter base in the Name text box; Cylinder is renamed as base in the Object 
Manager. 

3.	 Make sure base is selected in the Object Manager. In the Attribute Manager, choose the 
Object button; the Object Properties area is displayed. In the Object Properties area, set 
the parameters as follows:

	 Height: 15				    Height Segments: 5	
	 Rotation Segments: 30

4.    In the Attribute Manager, choose the Caps button; the Caps area is displayed. In the Caps 
area, make sure the Caps check box is selected and then select the Fillet check box; fillet is 
applied to base. Figure 3-2 displays base in the Perspective viewport.

Figure 3-2  The base displayed in the Perspective viewport

Creating Body of the Table Lamp		
In this section, you will create body of the table lamp using the Cylinder and Torus tools.

1. 	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. Next, 
choose Cylinder from it; a cylinder is created and Cylinder is added to the Object Manager.

2. 	 In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. 
In this area, enter body in the Name text box; Cylinder is renamed as body in the Object 
Manager. 

3.	 Make sure body is selected in the Object Manager. In the Attribute Manager, choose the 
Object button; the Object Properties area is displayed. In the Object Properties area, enter 
8 in the Radius spinner.
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Note
To make the segments visible on the objects, choose Display > Gouraud Shading (Lines) from 
the Menu in editor view. 

4. 	 In the Attribute Manager, choose the Coord button. Next, enter 108.682 in the P . Y spinner; 
body is moved on the top of base, refer to Figure 3-3. 

                                                                                                                                                                                                                                                                                                            
                           

Figure 3-3 The body moved on the top of base

	

	 Next, you will create design on the body of the table lamp.

5.	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. 
Next, choose Torus from it; a torus is created and Torus is added to the Object Manager.

6. 	 In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. 
In this area, enter bodydesign1 in the Name text box; Torus is renamed as bodydesign1 in 
the Object Manager. 

7.	 Make sure bodydesign1 is selected in the Object Manager. In the Attribute Manager, choose 
the Object button; the Object Properties area is displayed. In the Object Properties area, 
set the parameters as follows:

	 Ring Radius: 11	    	 	 Pipe Radius: 8

8.	 Move bodydesign1 on the top of base. Figure 3-4 shows bodydesign1 in the Perspective viewport.

Figure 3-4  bodydesign1 displayed in the Perspective viewport

9. 	 Make sure bodydesign1 is selected in the viewport. Next, press and hold the CTRL key and 
drag the cursor upward; a copy of bodydesign1 is created with the name bodydesign1.1. Next, 
place it at the top of bodydesign1.
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10.	 Zoom in on bodydesign1.1 and move both the edit points of bodydesign1.1 so that it is scaled 
down. Next, align bodydesign1.1, as shown in Figure 3-5. 

Figure 3-5  Edit points of bodydesign1.1 moved

11.	 Make sure bodydesign1.1 is selected in the viewport. Next, press and hold the CTRL key and 
drag the cursor upward; copy of bodydesign1.1 is created with the name bodydesign1.2. Next, 
place it at the top of bodydesign1.1.

12. 	Zoom in on bodydesign1.2 and move both its edit points such that it is scaled down. Next, 
align bodydesign1.2, as shown in Figure 3-6. 

Figure 3-6  Edit points of bodydesign1.2 moved

Creating Shade of the Table Lamp
In this section, you will create shade of the table lamp using the Cone and Torus tools.

1.	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. 
Next, choose Cone from it; a cone is created and Cone is added to the Object Manager.

2. 	 In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. 
In this area, enter shade in the Name text box; Cone is renamed as shade in the Object 
Manager. 

3.	 Make sure shade is selected in the Object Manager. In the Attribute Manager, choose the 
Object button; the Object Properties area is displayed. In the Object Properties area, set 
the parameters as follows:

	 Top Radius: 27	    	 	 Bottom Radius: 98
	 Height: 100				   Rotation Segments: 42
	
4.	 In the Attribute Manager, choose the Coord. button. Next, enter 238 in the P . Y spinner; 

shade is moved on the top of body, refer to Figure 3-7(a). 
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5.	 In the Attribute Manager, choose the Caps button. Next, clear the Caps check box in the 
Caps area; caps are removed from shade.

Figure 3-7(a)  The shade moved on the top of body

	 Next, you need to connect body with shade. First, you will convert shade to a transparent 
mode so that you can create connecting parts easily. 

6.	 Make sure shade is selected. In the Attribute Manager, choose the Basic button. In the Basic 
Properties area, select the X-Ray check box; shade is now visible in the transparent mode. 

 
7.	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. 

Next, choose Torus from it; a torus is created and Torus is added to the Object Manager.

8. 	 In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. 
In this area, enter bodyconnect1 in the Name text box; Torus is renamed as bodyconnect1 in 
the Object Manager. 

9.	 Make sure bodyconnect1 is selected in the Object Manager. In the Attribute Manager, choose 
the Object button; the Object Properties area is displayed. In the Object Properties area, 
set the parameters as follows:

	 Ring Radius: 8	    	 	 Pipe Radius: 3

10.	 In the Attribute Manager, choose the Coord button. Next, enter 209 in the P . Y spinner; 
bodyconnect1 is moved on the top of body, refer to Figure 3-7(b). 

Figure 3-7(b) The bodyconnect1 moved on the top of body
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Note 
You can also hide shade so that bodyconnect1 is visible properly. To hide shade, you need to click 
twice on the upper dot available in the Object Manager next to the shade so that the dot turns red. 
Later, to make it visible again, you need to click on the same dot.

	
11. 	Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. Next, 

choose Cylinder from it; a cylinder is created and Cylinder is added to the Object Manager.

12. 	In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. In 
this area, enter bodyconnect2 in the Name text box; Cylinder is renamed as bodyconnect2 in 
the Object Manager. 

13.	 Make sure bodyconnect2 is selected in the Object Manager. In the Attribute Manager, choose 
the Object button; the Object Properties area is displayed. In the Object Properties area, 
set the parameters as follows:

	 Radius: 1.5	    	 	 Height: 64

14.	 In the Attribute Manager, choose the Coord. button. Next, enter 225 in the P . Y spinner; 
bodyconnect2 is moved on the top of body. 

15.	 Choose MoGraph > Cloner from the main menu; Cloner is added to the Object Manager. 

16.	 Select bodyconnect2 in the Object Manager. Next, press and hold the left mouse button and 
then drag it on Cloner; bodyconnect2 is connected to Cloner. 

17.	 Select Cloner in the Object Manager. In the Attribute Manager, make sure the Object button 
is chosen. In the Object Properties area, select Radial from the Mode drop-down list and 
XZ from the Plane drop-down list. Also, enter 4 and 32 in the Count and Radius spinners, 
respectively. 

18.	 In the Attribute Manager, choose the Transform button and enter 225 in the P . Y spinner 
in the Transform area. Next, enter -55  in the R . P spinner. Cloner is placed on bodyconnect1, 
as shown in Figure 3-8(a). 

Figure 3-8(a)  cloner placed on bodyconnect1
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19.	 Select shade in the Object manager; In the Attribute Manager, choose the Basic button. In 
the Basic Properties area, clear the X-Ray check box; shade is now visible in shaded mode. 

	 Next, you will create design on shade.

20.	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. 
Next, choose Torus from it; a torus is created and Torus is added to the Object Manager.

21. 	In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. 
In this area, enter shadedesign1 in the Name text box; Torus is renamed as shadedesign1 in 
the Object Manager. 

22.	 Make sure shadedesign1 is selected in the Object Manager. In the Attribute Manager, choose 
the Object button; the Object Properties area is displayed. In the Object Properties area, 
set the parameters as follows:

	 Ring Radius: 97	    	 	 Pipe Radius: 2
	 Ring Segments: 54			   Pipe Segments: 20

23.	 Place Shadedesign1 on shade, as shown in Figure 3-8(b). 

Figure 3-8(b)  Placing shadedesign1 on shade

24.  Make sure shadedesign1 is selected in the viewport. Next, press and hold the CTRL key and 
drag the cursor upward; a copy of shadedesign1 is created with the name shadedesign1.1. Next, 
place it on shade, refer to Figure 3-9.

Figure 3-9  Placing shadedesign1.1 on shade

25.	 Zoom in on shadedesign1.1 and move the inner edit point of shadedesign1.1 so that it is scaled 
down and fits on shade, refer to Figure 3-10. 
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26.	 Similarly, create two more copies of shadedesign1.1, edit their inner edit points and place them 
on shade, as shown in Figure 3-11. If needed, move the shape designs so that the distance 
between them remains same.  

Figure 3-11  Copies of Shapedesign1.1 placed

Changing Color of the Table Lamp
In this section, you will change the color of the parts of table lamp using the parameters in the 
Attribute Manager.

1.	 Choose base from the Object Manager. Next, choose the Basic button in the Attribute 
Manager.  

2.	 Select On from the Display Color drop-down list; the color swatch below this drop-down 
list is activated. 

3. 	 Click on the Color swatch; the Color Picker dialog box is displayed. In this dialog box, set 
the values as follows and then choose the OK button. 

	 H: 350			   S: 90			   V: 35

	 Color of base is changed. 

4. 	 Assign same color as that of base to body, bodyconnect1, shadedeisgn1, shadedesign1.1, 
shadedesign1.2, and shadedesign1.3. 

5. 	 Choose shade from the Object Manager. Next, choose the Basic button in the Attribute 
Manager.  

6.	 Select On from the Display Color drop-down list; the color swatch below this drop-down 
list is activated. 
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7. 	 Click on the Color swatch; the Color Picker dialog box is displayed. In this dialog box, set 
the values as follows and then choose the OK button. 

	 H: 58			   S: 22			   V: 100

	 Color of shade is changed. 

8. 	 Assign same color as that of shade to bodydesign1, bodydesign1.1, and bodydesign1.2.

Changing the Background Color of the Scene
To change the background color of the scene to white in the final output, follow the steps given 
in Tutorial 1 of Chapter 2.

Saving and Rendering the Scene
In this section, you will save and render the scene. You can also view the final render of the scene 
by downloading the file c03_cinema4d_R25_rndr.zip from www.cadcim.com. The path of the file is 
mentioned at the beginning of the chapter. 

1. 	 Choose File > Save Project as from the main menu; the Save File dialog box is displayed. 
In this dialog box, browse to the location \Documents\c4dR25\c03.

2. 	 Enter c03tut1 in the File name text box and then choose the Save button.

3.	 In the Perspective viewport, set the camera angle using the Viewport Navigation Tools. Next, 
choose the Render to Picture Viewer tool from the Command Palette. Alternatively, press 
SHIFT+R; the Picture Viewer window is displayed.

4.	 In the Picture Viewer window, choose File > Save Image as; the Save dialog box is displayed.

5.	 In the Save dialog box, choose the OK button; the Save Dialog dialog box is displayed. 
Next, browse to \Documents\c4dR25\c03. In the File Name text box, type c03_tut1_rndr. 
Next, choose the Save button; the file is saved at the desired location.

	 Figure 3-1 displays the final output.

 Tutorial 2                                                                             
In this tutorial, you will create 3D model of a computer mouse, as shown in Figure 3-12, using 
the polygon modeling techniques.		    	                    (Expected time: 40 min)

The following steps are required to complete this tutorial:
	
a.   	Create the body of the computer mouse.
b.	 Create the left-click and right-click buttons of the mouse.  
c.   	Create the scroll wheel of the mouse.
d.	 Create the bottom of the mouse.
e.	 Create the USB cable of the mouse.  
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f.	 Change the background color of the scene.
g.	 Save and render the scene.							     

Figure 3-12  The model of a computer mouse

Creating the Body of the Computer Mouse
In this section, you will create the body of the computer mouse using the Cube tool. 

1. 	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. 
Next, choose Cube from it; a cube is created in the Perspective viewport, as shown in Figure 
3-13. and Cube is added to the Object Manager. 

Figure 3-13  Cube created in the Perspective viewport

2.	 In the Attribute Manager, make sure the Object button is chosen. In the Object Properties 
area, set the parameters as follows:

	 Size . X: 91		  Size . Y: 37 		  Size . Z: 137  	
	 Segments X: 6	 Segments Y: 4		  Segments Z: 6
				  
	 The Size . X, Size . Y, and Size . Z parameters in the Object Properties area are used to set 

width, height, and depth, respectively of the cube. 	

3.	 In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. In 
this area, enter Computer mouse in the Name text box; Cube is renamed as Computer mouse in 
the Object Manager. 		
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4.	 Make sure Computer mouse is selected in the Object Manager and choose the Make Editable 
tool from the Modes Palette; Computer mouse is converted into a polygon object.

Note
After converting Computer mouse into a polygon object, you will notice that when you hover the 
cursor over it in the Object Manager, the name of the Computer mouse changes to Polygon Object 
[Computer mouse]. Also, the icon of the Cube object changes into a triangle.

5. 	 Press F2; the Top viewport is maximized. Choose the Points tool from the Modes Palette; 
the Computer mouse is displayed in the points mode.

6.	 Invoke the Live Selection tool from the Command Palette. The shape of the cursor changes. 
To increase or decrease the size of the cursor, press the } or { key, respectively. In the Attribute 
Manager, make sure the Options button is chosen. In the Options area, clear the Visible 
Only check box, if not already cleared.

	 The Visible Only check box is cleared to select the polygons that are behind the visible 
sub-objects.

7.	 Using the Live Selection tool and the SHIFT key, select the corner points of Computer mouse, 
as shown in Figure 3-14.

8.	 Invoke the Scale tool from the Command Palette and scale the selected points uniformly 
in the Top viewport, as shown in Figure 3-15.

Figure 3-15  Scaling the selected points of 
Computer mouse

Figure 3-14  The corner points of Computer mouse 
to be selected
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9.	 Deselect the corner points of Computer mouse by clicking on the empty area of the viewport. 
Invoke the Live Selection tool from the Command Palette and select the center points of 
Computer mouse in the Top viewport by dragging the cursor on them, as shown in Figure 3-16.

10.	 Invoke the Scale tool from the Command Palette and scale the selected points in the Top 
viewport, as shown in Figure 3-17.

Figure 3-17  Scaling the selected 
points of Computer mouse

Figure 3-16  The points to be selected

11.	 Press and hold the 9 key on the main keyboard to temporarily invoke the Live Selection 
tool and then select the center points of Computer mouse in the Top viewport, as shown in 
Figure 3-18. Now, release the 9 key.

	 On releasing the 9 key, the Scale tool is activated which is the last used tool.

12.	 Scale the selected points inward in the Top viewport, as shown in Figure 3-19.

Figure 3-18  The center points to be selected Figure 3-19  Scaling the selected 
points of Computer mouse
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13.	 Press and hold the 9 key and select the top and bottom points of Computer mouse by using 
the SHIFT key, as shown in Figure 3-20. Next, release the 9 and SHIFT keys. Now, scale the 
selected points along the Z-axis, as shown in Figure 3-21.

Figure 3-20  The selected points of Computer 
mouse

Figure 3-21  Scaling the selected 
points of Computer mouse

14.	 Press and hold the 9 key and select the top and bottom center points of Computer mouse using 
the SHIFT key, as shown in Figure 3-22.

15.	 Scale the selected points along the Z-axis in the Top viewport, as shown in Figure 3-23.

Figure 3-22  The top and bottom center points 
of Computer mouse selected

Figure 3-23  Scaling the selected points of 
Computer mouse

16.	 Press F3; the Right viewport is maximized. Invoke the Live Selection tool from the Command 
Palette. In the Attribute Manager, make sure the Options button is chosen. In the Options 
area, make sure that the Visible Only check box is cleared.
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17.	 Using the Live Selection tool, select the center points of Computer mouse in the Right viewport, 
as shown in Figure 3-24. Next, move the selected points upward in the Right viewport, as 
shown in Figure 3-25.

Figure 3-24  The points to be selected

 Figure 3-25  Moving the selected points of Computer mouse

18.	 Select the top points of Computer mouse in the Right viewport, as shown in Figure 3-26. Next, 
move the selected points upward in the Right viewport, as shown in Figure 3-27.

Figure 3-26   The selected points of Computer mouse

19.	 Select the top center points of Computer mouse, as shown in Figure 3-28. Move the selected 
points upward in the Right viewport, as shown in Figure 3-29.
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Figure 3-27  Moving the selected points of Computer mouse

Figure 3-28  The top center points of Computer mouse selected

  Figure 3-29  Moving the selected points of Computer mouse

20.	 Select the points of Computer mouse in the Right viewport, as shown in Figure 3-30.

21.	 Invoke the Rotate tool from the Command Palette and rotate the selected points along the 
YZ axis in the Right viewport, as shown in Figure 3-31.

22.	 Select the points of Computer mouse in the Right viewport using the 9 key, as shown in 
Figure 3-32. Next, rotate the selected points along the YZ axis in the Right viewport, as 
shown in Figure 3-33.
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Figure 3-30  The points to be selected

Figure 3-31  Rotating the selected points of Computer mouse

Figure 3-32  The points to be selected

Figure 3-33  Rotating the selected points of Computer mouse
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23.	 Press F4; the Front viewport is maximized. Invoke the Live Selection tool from the Command 
Palette. In the Attribute Manager, make sure the Options button is chosen. In the Options 
area, make sure that the Visible Only check box is cleared.

24.	 Select the center points of Computer mouse in the Front viewport, as shown in Figure 3-34. 
Next, move the selected points upward in the Front viewport, as shown in Figure 3-35.

Figure 3-34  The points to be selected

Figure 3-35  Moving the selected points upward

25.	 Select the points of Computer mouse using the 9 key, as shown in Figure 3-36. Next, move the 
selected points upward in the Front viewport, as shown in Figure 3-37.

26.	 Select the points of Computer mouse using the 9 and SHIFT keys, as shown in Figure 3-38. 
Next, move the selected points upward in the Front viewport, as shown in Figure 3-39.

27. 	Press F1; the Perspective viewport is maximized. Choose the Edges tool from the Modes 
Palette; Computer mouse is displayed in the edge mode.
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Figure 3-36  The selected points of Computer 
mouse

Figure 3-37  Moving the selected 
points of Computer mouse

Figure 3-38  The points to be selected Figure 3-39  Moving the selected points of 
Computer mouse

28.	 Select the edges of Computer mouse in the Top viewport using the 9 and SHIFT keys, as shown 
in Figure 3-40.

29.	 Invoke the Scale tool from the Command Palette and scale down the selected edges to 95 
percent along the x-axis, as shown in Figure 3-41.

30.	 Press F3; the Right viewport is maximized. Choose the Points tool from the Modes Palette; 
the Computer mouse is displayed in the points mode. 

31.	 Select the points of Computer mouse in the Right viewport using the 9 key, as shown in 
Figure 3-42.
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Figure 3-40   The selected edges in the Perspective viewport

Figure 3-41  Scaling down the edges of Computer mouse in 
the Perspective viewport

32.	 Invoke the Move tool from the Command Palette and move the selected points upward in 
the Right viewport, as shown in Figure 3-43.

Figure 3-42  The points to be selected Figure 3-43  Moving the selected points of 
Computer mouse
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33.	 Select the center points of Computer mouse using the 9 key, as shown in Figure 3-44. 

Figure 3-44  The points to be selected

34.	 Invoke the Scale tool from the Command Palette. Scale the selected points downward along 
the Y-axis and then move them downwards to get a straight line in the Right viewport, as 
shown in Figure 3-45.

35.	 Select the points of Computer mouse using the 9 key, as shown in Figure 3-46. Next, scale the 
selected points along the Y axis to 87.2 percent in the Right viewport, as shown in Figure 3-47.

Figure 3-45  Scaling and moving the points 
of Computer mouse

Figure 3-46  The points of Computer mouse to be 
selected

36.	 Invoke the Move tool from the Command Palette and move the selected points downward 
in the Right viewport, as shown in Figure 3-48.

Figure 3-47  Scaling the points of  
Computer mouse 

Figure 3-48 Moving the selected points in the Right 
viewport

37.	 Select the bottom points of Computer mouse using the 9 key, refer to Figure 3-49. Next, invoke 
the Scale tool and scale the selected points to get a straight line in the Right viewport, if 
they are not straight, as shown in Figure 3-49.



3-22			                                 MAXON CINEMA 4D R25: A Tutorial Approach
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om Figure 3-49  Scaling the points of Computer mouse

Creating the Left-Click and Right-Click Buttons of the Mouse
In this section, you will create the left-click and the right-click buttons of Computer mouse.

1. 	 Press F1; the Perspective viewport is maximized. Choose the Edges tool from the Modes 
Palette; the Computer mouse is displayed in the edge mode.

2.	 Right-click in the empty area of the Perspective viewport; a shortcut menu is displayed. 
Choose Loop/Path Cut from the shortcut menu; the Loop/Path Cut tool settings are displayed 
in the Attribute Manager. In the Options area, make sure Loop is selected in the Mode 
drop-down list.

3.	 Make sure the Enable Snap tool is deactivated in the Modes Palette. In the Options area, 
make sure the Restrict to Selection check box is cleared and then click on the right of the 
middle edge loop of the Computer mouse in the Perspective viewport, as shown in Figure 3-50; 
a new edge is created next to it, as shown in Figure 3-51.

Figure 3-50  Clicking on the right of the 
middle edge loop

Figure 3-51  A new edge loop added to the 
Computer mouse

	 When you create an edge loop using the Loop/Path Cut tool, you can interactively slide the 
edge loop using the slider that appears at the top of the viewport, refer to Figure 3-52. 



Introduction to Polygon Modeling	 3-23

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Note
1. A green line is displayed when you add an edge using the Loop/Path Cut tool. This line has 
a green dot at its one end. 

2. The slider has 3 buttons at its right. The first button is used to get the pointer exactly at the center 
of the slider that allows you to create an edge at the center of the green line, refer to Figure 3-52. 
The second button is used to add one more edge to the edges created using the Loop/Path Cut tool. 
The third button is used to remove an edge from the edges created using the Loop/Path Cut tool.
          

Figure 3-52 The slider displayed at the 
top of the viewport

4.	 Again, create three new edge loops using the Loop/Path Cut tool, refer to Figures  3-53 and 3-54.

Figure 3-53  A new edge added 
to Computer mouse

5.	 Choose the Live Selection tool from the Command Palette and then choose the Poly-
gons tool from the Modes Palette; the Computer mouse is displayed in the polygon mode. 
In the Attribute Manager, choose the Options button; the Options area is displayed. In 
this area, select the Visible Only check box, if not already selected. Next, using the Live 
Selection tool, select the polygons of Computer mouse in the Perspective viewport, as shown 
in Figure 3-55. If required, decrease the size of the selection cursor.
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mouse

Figure 3-55  The polygons selected

6.	 In the Perspective viewport, right-click on the selected polygons of Computer mouse; a shortcut 
menu is displayed. Choose Extrude from the shortcut menu; the Extrude tool settings 
are displayed in the Attribute Manager. Choose the Options button; the Options area is 
displayed. Specify the value -1 in the Offset spinner and then press ENTER; the selected 
polygons of Computer mouse are extruded, as shown in Figure 3-56.

7.	 Right-click on the empty area of the Perspective 

Figure 3-56  The extruded polygons
of Computer mouse

viewport; a shortcut menu is displayed. Choose 
Loop/Path Cut from the shortcut menu; the Loop/
Path Cut tool settings are displayed in the Attribute 
Manager. In the Options area, make sure that Loop 
is selected in the Mode drop-down list.

8.	 Using the Loop/Path Cut tool, create an edge, refer 
to Figure 3-57.

9.	 Add two more edges, refer to Figures 3-58 and 3-59. Figure 3-60 shows the edges.

10.	 To smoothen the surface of the Computer mouse, choose the Subdivision Surface tool from 
the Command Palette; Subdivision Surface is added to the Object Manager. Next, select 
Computer mouse in the Object Manager and press and hold the left mouse button and then 
drag it on the Subdivision Surface; the Computer mouse is connected to the Subdivision 
Surface and the smoothened result is displayed, as shown in Figure 3-61.

Figure 3-58  An edge loop added to Computer 
mouse

Figure 3-57  An edge loop added to Computer 
mouse
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Figure 3-60  The edges added to Computer 
mouse

Figure 3-59 An edge loop added to Computer 
mouse

Figure 3-61  The smoothened Computer mouse

Creating the Scroll Wheel of the Mouse
In this section, you will create the scroll wheel of the Computer mouse.

1.	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. 
Next, choose Torus from it; a torus is created in the Perspective viewport and Torus is added 
to the Object Manager. 

2.	 In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. 
In this area, enter Scroll wheel in the Name text box; Torus is renamed as Scroll wheel in the 
Object Manager. 

3.	 In the Attribute Manager, choose the Object button; the Object Properties area is displayed. 
In this area, set the parameters as follows:

	 Ring Radius: 6 		  Pipe Radius: 2 		         Pipe Segments: 7    
	 Orientation: -X		

4.	 Make sure that Scroll wheel is selected in the Object Manager. Invoke the Move tool from the 
Command Palette and place Scroll wheel on Computer mouse, as shown in Figure 3-62.
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Creating the Bottom of the Mouse
In this section, you will create the bottom of Computer mouse.

1. 	 Choose Cameras in Menu in editor view in the Perspective viewport; a flyout is displayed. 
Choose Bottom from the flyout; the Bottom viewport is displayed.

2.	 Select the Computer mouse in the Object Manager. Make sure the Polygons tool is chosen 
from the Modes Palette; the Computer mouse is displayed in the polygon mode. Make sure the 
Live Selection tool is chosen from the Standard palette. In the Attribute Manager, choose 
the Options button; the Options area is displayed. In this area, make sure the Visible Only 
check box is selected. Select the polygons of Computer mouse, as shown in Figure 3-63.

Figure 3-62  The Scroll wheel 
placed on Computer mouse

Figure 3-63 The selected polygons 
of Computer mouse

3.	 In the Bottom viewport, right-click on the selected polygons of Computer mouse; a shortcut 
menu is displayed. Choose Extrude Inner from the shortcut menu; the Extrude Inner tool 
settings are displayed in the Attribute Manager. Choose the Options button; the Options 
area is displayed. Specify the value 3 in the Offset spinner and then press ENTER; the 
selected polygons of the Computer mouse are extruded.

4.	 In the Perspective viewport, right-click on the selected polygons of Computer mouse; a shortcut 
menu is displayed. Choose Extrude from the shortcut menu; the Extrude tool settings 
are displayed in the Attribute Manager. Choose the Options button; the Options area is 
displayed. Specify the value 1.5 in the Offset spinner and then press ENTER; the selected 
polygons of the Computer mouse are extruded.

5.	 Choose Cameras from the Menu in editor view; a flyout is displayed. Choose Perspective 
from the flyout; the Perspective viewport is maximized.

Creating the USB Cable of the Mouse
In this section, you will create the USB cable of Computer mouse using the Sweep NURBS tool.

1.	 Choose Create > Spline Primitive from the main menu; a cascading menu is displayed. 
Next, choose Circle from it; a circle is created in the Perspective viewport and Circle is added 
to the Object Manager. 
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2.	 Make sure that Circle is selected in the Object Manager. In the Attribute Manager, make sure 
the Object button is chosen. In the Object Properties area, enter 2 in the Radius spinner.

 
3.	 In the Attribute Manager, choose the Coord button; the Coord area is displayed. In this 

area, enter -80 in the P . Z spinner; the Circle is positioned in the Perspective viewport.

4.	 Press F2; the Top viewport is maximized. Choose the Spline 

Figure 3-64  Spline created in the 
Top viewport

Pen tool from the Command Palette. Next, create a curve 
in the Top viewport, as shown in Figure 3-64. Press ESC 
to exit the Spline Pen tool.

5.	 Press and hold the left mouse button on the 
Subdivision Surface tool from the Command Palette; 
a flyout is displayed. Choose the Sweep tool from the 
flyout; the Sweep is added to the Object Manager.	

6.	 In the Object Manager, press and hold the left mouse 
button on Spline and drag it to Sweep; the Spline is 
connected to Sweep. Next, press and hold the left mouse 
button on Circle and drag it to Sweep; Circle is connected 
to Sweep. You will notice that a wire is created in the Top 
viewport.

	 Next, you will create the USB port of Computer mouse.

7.	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. 
Next, choose Cube from it; a cube is created in the Top viewport and a Cube is added to the 
Object Manager.

8.	 Make sure that Cube is selected in the Object Manager. In the Attribute Manager, choose 
the Object button; the Object Properties area is displayed. In this area, set the parameters 
as follows:

	 Size . X: 28  		  Size . Y: 8	    	 Size . Z: 62
	 Segments X: 10   		  Segments Y: 10		  Segments Z: 10
 
9.	 Invoke the Move tool from the Command Palette and move Cube in the Top viewport to 

place it, as shown in Figure 3-65.
	 		
10.	 Make sure Cube is selected in the Object Manager. Next, choose the Make Editable tool 

from the Modes Palette; the Cube is converted into a polygonal object.

11.	 Choose the Edges tool from the Modes Palette; Cube is displayed in the edge mode. Choose 
the Live Selection tool from the Command Palette. In the Attribute Manager, make sure 
the Visible Only check box is cleared in the Options area. Next, select the edges of Cube 
in the Top viewport, as shown in Figure 3-66.
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Figure 3-65  Cube placed in 
the Top viewport

Figure 3-66  The edges to be 
selected in the Top viewport

12.	 Invoke the Scale tool from the Command Palette and scale down the selected edges to 70 
percent uniformly.

13. Choose the Points tool from the Modes Palette; Cube is displayed in the points mode. Select 
the points of Cube using the 9 and SHIFT keys, as shown in Figure 3-67.

14.	 Scale down the selected points along the X axis to get the shape, as shown in Figure 3-68.

Figure 3-67  The points to be selected Figure 3-68  Scaling the selected points

15.	 Choose the Edges tool from the Modes Palette; Cube is displayed in the edge mode. Choose 
the Live Selection tool from the Command Palette. In the Attribute Manager, select the 
Visible Only check box in the Options area. Select the edges of Cube in the Top viewport, 
as shown in Figure 3-69.

16. 	Scale down the selected edges along the X and Y axis to get the shape, as shown in Figure 3-70.
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Figure 3-69  The edges selected Figure 3-70  Scaling the selected edges

17.	 Press F1; the Perspective viewport is maximized. Choose the Polygons tool from the Modes 
Palette; Cube is displayed in the polygon mode. Select the polygons of Cube using the 9 key, as 
shown in Figure 3-71. Make sure the Only Selected Visible Elements check box is cleared.

18.	 Right-click on the selected polygons of Computer mouse; a shortcut menu is displayed. Choose 
Extrude from the shortcut menu; the Extrude tool settings are displayed in the Attribute 
Manager. In the Extrude tool settings area, specify the value 10 in the Offset spinner and 
then press ENTER; the selected polygons of Computer mouse are extruded, as shown in 
Figure 3-72.

Figure 3-71  The polygons to be selected Figure 3-72  The extruded edge loop

19.	 Choose the Polygons tool from the Modes Palette. Right-click on the Perspective viewport; 
a shortcut menu is displayed. Choose Loop/Path Cut from the shortcut menu; the Loop/
Path Cut tool settings are displayed in the Attribute Manager. In the Attribute Manager, 
make sure Loop is selected in the Mode drop-down list. Next, add two edges, as shown in 
Figure 3-73.

20.	 Choose the Polygons tool from the Modes Palette; Cube is displayed in the polygon mode. 
Select the polygons of Cube using the Live Selection tool, as shown in Figure 3-74. Next, 
delete the selected polygons of Cube, refer to Figure 3-75.
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Figure 3-73  The edges to be added

Figure 3-74  The polygons to be selected

Figure 3-75  The selected polygons

21.	 Again, select the polygons of Cube using the Live Selection tool, refer to Figure 3-75. Next, 
delete the selected polygons of Cube, refer to Figure 3-76.
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Figure 3-76  The deleted polygons

Changing the Background Color of the Scene
To change the background color of the scene to white in the final output, follow the steps given 
in Tutorial 1 of Chapter 2.

Saving and Rendering the Scene
In this section, you will save and render the scene. You can also view the final render of the scene 
by downloading the file c03_cinema4d_R25_rndr.zip from www.cadcim.com. The path of the file is 
mentioned at the beginning of the chapter. 

1. 	 Choose File > Save Project as from the main menu; the Save File dialog box is displayed. 
In this dialog box, browse to the location \Documents\c4dR25\c03.

2. 	 Enter c03tut2 in the File name text box and then choose the Save button.

3.	 In the Perspective viewport, set the camera angle using the Viewport Navigation Tools. Next, 
choose the Render to Picture Viewer tool from the Command Palette. Alternatively, press 
SHIFT+R; the Picture Viewer window is displayed.

4.	 In the Picture Viewer window, choose File > Save Image as; the Save dialog box is displayed.

5.	 In the Save dialog box, choose the OK button; the Save Dialog dialog box is displayed. 
Next, browse to \Documents\c4dR25\c03. In the File Name text box, type c03_tut2_rndr. 
Next, choose the Save button; the file is saved at the desired location.

	 Figure 3-12 displays the final output.

 Tutorial 2                                                                             
In this tutorial, you will create the model of a computer table, as shown in Figure 3-77, using 
the polygon modeling technique.	          	                                 (Expected time: 40 min)
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Figure 3-77  The model of computer table

The following steps are required to complete this tutorial:
	
a.   	Create the base of the computer table.
b.	 Create the support for the CPU.  
c.	 Create the support for the keyboard.
d.	 Create the base for the monitor.
e.	 Create the top shelves of the computer table.
f.	 Create the bottom shelf of the computer table.
g. 	 Create the magazine stand.
h.	 Change the background color of the scene.
i.	 Save and render the scene.	

Creating the Base of the Computer Table	
In this section, you will create the base of the computer table.

1.	 Press F2; the Top viewport is maximized. Choose Create > Mesh Primitive from the main 
menu; a cascading menu is displayed. Next, choose Cube from it; a cube is created in the 
Top viewport and Cube is added to the Object Manager. 

2.	 In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. In 
this area, enter Computer table in the Name text box; Cube is renamed as Computer table in 
the Object Manager. 

3.	 Make sure Computer table is selected in the Object Manager. In the Attribute Manager, choose 
the Object button; the Object Properties area is displayed. In the Object Properties area, 
set the parameters as follows:

	 Size . X: 743	     Size . Y: 18	                 Size . Z: 295
	 Segments X: 6   	     Segments Y: 6     	    Segments Z: 6

	 Select the Fillet check box and enter 3 in the Fillet Radius spinner. 
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4.	 Press F1; the Perspective area is maximized. Choose the Make Editable tool from the Modes 
Palette; Computer table is converted into a polygonal object. 

    	 Figure 3-78 displays Computer table in the Perspective viewport.     

Figure 3-78  The Computer table in the Perspective viewport

5.	 Choose the Edges tool from the Modes Palette; the Computer table is displayed in the edge 
mode. Choose Select > Loop Selection from the main menu and then right-click in the 
Perspective viewport; a shortcut menu is displayed. Choose Loop/Path Cut from the shortcut 
menu; the Loop/Path Cut tool settings are displayed in the Attribute Manager. 

	
6.	 Choose the Enable Snap tool from the Modes Palette. Next, click on Computer mouse, refer 

to Figure 3-79; an edge loop is added to Computer table. Again, create two new edge loops 
using the Loop/Path Cut tool, as shown in Figure 3-80.

Figure 3-79  Adding an edge loop



3-34			                                 MAXON CINEMA 4D R25: A Tutorial Approach
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 3-80  The edge loops added 

	 Next, you will create the supports for Computer table.

7.	 Choose the Polygons tool from the Modes Palette; the Computer table is displayed in the 
polygon mode. Choose Cameras > Bottom from the Menu in editor view; the Bottom view-
port is maximized. Choose the Live Selection tool from the Command Palette and make 
sure that the Visible Only check box is selected. Next, enter 1 in the Radius spinner. Now, 
select the polygons of Computer table, as shown in Figure 3-81, using the Live Selection tool 
and the SHIFT key. 

Figure 3-81  The selected polygons of Computer table
8.	 Choose Cameras > Perspective from the Menu in editor view; the Perspective viewport is 

maximized. Right-click in the Perspective viewport; a shortcut menu is displayed. Choose 
Extrude from the shortcut menu; the Extrude tool settings are displayed in the Attribute 
Manager. In the Extrude tool settings area, set the value 400 in the Offset spinner and 
then press the ENTER key. Set the value 4 in the Subdivision spinner and then press the 
ENTER key.

	 After entering the value, the selected polygons are extruded in the Perspective viewport, as 
shown in Figure 3-82.
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Figure 3-82  The selected polygons extruded in the Perspective viewport

Creating the Support for the CPU
In this section, you will create the support for the CPU.

1.	 Choose the Edges tool from the Modes Palette; Computer table is displayed in the edge 
mode. Right-click in the Perspective viewport; a shortcut menu is displayed. Choose Loop/
Path Cut from the shortcut menu; the Loop/Path Cut tool settings are displayed in the 
Attribute Manager. Make sure Loop is selected in the Mode drop-down list and the Restrict 
to Selection check box is cleared.

 
2.	 Make sure the Enable Snap tool is deactivated in the Modes Palette. Next, click at a point, 

refer to Figure 3-83; a new edge loop is added to Computer table. 

Figure 3-83  Clicking on edge to create a new edge loop

3.	 Choose the Polygons tool from the Modes Palette; Computer table is displayed in the polygon 
mode. Choose the Live Selection tool from the Command Palette and make sure that the 
Visible Only check box is selected. Now, select the polygons of Computer table, as shown in 
Figure 3-84.
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Figure 3-84  The selected polygons of Computer table

4.	 Right-click in the Perspective viewport; a shortcut menu is displayed. Choose Extrude from 
the shortcut menu; the Extrude tool settings are displayed in the Attribute Manager. In the 
Attribute Manager, choose the Options button; the Options area is displayed. In this area, 
set the parameters as follows:

	 Offset: 200			   Subdivision: 6

	 After entering the values, the selected polygons are extruded in the Perspective viewport, 
as shown in Figure 3-85.

Figure 3-85  The selected polygons extruded in the Perspective viewport

5.	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. 
Next, choose Cube from it; the Cube object is added to the Object Manager.
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6.	 In the Attribute Manager, choose the Object button; the Object Properties area is displayed. 
In this area, set the parameters as follows:

	
	 Size . X: 10 		     Size . Y: 118 		     Size . Z: 291 

	 Segments X: 4   	     Segments Y: 3    	    Segments Z: 3   

7.	 Align Cube in the Perspective viewport, as shown in Figure 3-86.

Figure 3-86  Cube aligned in the Perspective viewport

	 Next, you will create design of the side support of Computer table.

8.	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. Next, 
choose Cube from it; a cube is created in the Perspective viewport and the Cube.1 object is 
added to the Object Manager. 

9.	 In the Attribute Manager, make sure the Object button is chosen. In the Object Properties 
area, set the parameters as follows:

	 Size . X: 53	  		  Size . Y: 37

	 Segments X: 5		  Segments Y: 3		  Segments Z: 3

  	 Select the Fillet check box and enter 5 in the Fillet Radius spinner. 

10.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. In 
this area, set the parameters as follows:

	 P . X: -345.355 		  P . Y: -89.77   
   	  
	 Figure 3-87 displays Cube.1 positioned in the Perspective viewport.
	 Next, you will create a copy of Cube.1.
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Figure 3-87  Cube.1 positioned in the Perspective viewport

11.	 Make sure the Cube.1 object is selected in the Object Manager. Press and hold the left mouse 
button and the CTRL key and then drag the cursor above Cube.1 in the Object Manager. 
Next, release the left mouse button; the Cube.2 object is added to the Object Manager.

12.	 Make sure Cube.2 is selected in the Object Manager. In the Attribute Manager,  make sure 
the Coord button is chosen. In the Coordinates area, enter -168.162  in the P . Y spinner; 
the Cube.2 object is positioned in the Perspective viewport.

13.	 Make sure the Cube.2 is selected in the Object Manager. Press and hold the left mouse button 
and the CTRL key and then drag the cursor above Cube.2 in the Object Manager. Next, 
release the left mouse button; the Cube.3 is added in the Object Manager.

14.	 Make sure Cube.3 is selected in the Object Manager. In the Attribute Manager, make sure 
the Coord button is chosen. In the Coordinates area, enter -255.253 in the P . Y spinner; 
the Cube.3 object is positioned in the Perspective viewport.

15.	 Select Cube.1, Cube.2, and Cube.3 using the CTRL key in the Object Manager. Next, press 
ALT+G; the Null object is added to the Object Manager. Rename it as left side. Figure 3-88 
displays left side positioned in the Perspective viewport.

16.	 Choose Create > Generator from the main menu; a cascading menu is displayed. Next, 
choose Boole from it; the Boole object is added to the Object Manager. 

17.	 In the Object Manager, press and hold the left mouse button on left side and drag it on Boole. 
Now, release the left mouse button; the left side is connected to Boole in the Object Manager.

18.	 In the Object Manager, press and hold the left mouse button on Computer table and 
drag it on Boole; the Computer table is connected to Boole in the Object Manager, 
as shown in Figure 3-89 and holes are created in Computer table, as shown in Figure 3-90.



Introduction to Polygon Modeling	 3-39

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 3-88  Left side positioned in the Perspective viewport

Figure 3-89  Boole connected to Computer table

Figure 3-90  The holes created in the side support of the Computer table
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Creating the Support for the Keyboard
In this section, you will create support for the keyboard.

1.	 Press F4; the Front viewport is maximized. Choose the Edges tool from the Modes Palette; 
Computer table is displayed in the edges mode. 

2.	 Right-click in the Front viewport; a shortcut menu is displayed. Choose Plane Cut from the 
shortcut menu; the Plane Cut tool settings are displayed in the Attribute Manager. In the 
Front viewport, drag the cursor to create a cut, refer to Figure 3-91. 

Figure 3-91  Creating an edge using the Plane Cut tool

3.	 Click and drag again to create second cut below the first cut that you created earlier, refer to 
Figure 3-91; two new edge loops are added to Computer table. Similarly, create two more cuts 
using the Plane Cut tool. Figure 3-92 displays four new edge loops added to the Computer 
table.

Figure 3-92  Four new edge loops added to the Computer table

4. 	 Press F1; the Perspective viewport is maximized. Choose the Polygons tool from the Modes 
Palette; Computer table is displayed in the polygon mode. Choose the Live Selection tool 
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from the Command Palette and make sure that the Visible Only check box is selected. Now, 
select the polygons of both sides of Computer table, as shown in Figure 3-93.

Figure 3-93  The selected polygons of Computer table

5.	 Right-click in the Perspective viewport; a shortcut menu is displayed. Choose Extrude from 
the shortcut menu; the Extrude tool settings are displayed in the Attribute Manager. In the 
Attribute Manager, choose the Options button; the Options area is displayed. In this area, 
set the value 30 in the Offset slider and then press the ENTER key.

	 Figure 3-94 displays the selected polygons extruded in the Perspective viewport.

Figure 3-94  The selected polygons extruded in the Perspective viewport
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6.	 Press F2; the Top viewport is maximized. Choose Create > Mesh Primitive from the main 
menu; a cascading menu is displayed. Next, choose Cube from it; a cube is created in the 
Top viewport and the Cube.1 object is added to the Object Manager. 

7.	 In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. In 
this area, enter Keyboard support in the Name text box; Cube is renamed as Keyboard support in 
the Object Manager. 

		
8.	 Make sure Keyboard support is selected in the Object Manager. In the Attribute Manager, 

choose the Object button; the Object Properties area is displayed. In the Object Properties 
area, set the parameters as follows:

	
	 Size . X: 429.61 		  Size . Y: 10 		  Size . Z: 284
	 Segments X: 6   		  Segments Y: 2    	 Segments Z: 6

	 Select the Fillet check box and enter 3 in the Fillet Radius spinner. 

9.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. In 
this area, set the parameters as follows:

	 P . X: -123.684          	  P . Y: -44.68    		   P . Z: 0 

	 Press F1; the Perspective viewport  is maximized. Figure 3-95 displays Keyboard support in 
the Perspective viewport.       

Figure 3-95  The Keyboard support of Computer table

Creating the Base for the Monitor
In this section, you will create the base for the monitor.

1. 	 Make sure Computer table is selected in the Object Manager. Choose the Edges tool from the 
Modes Palette; Computer table is displayed in the edges mode. 
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2.	 Right-click in the Perspective viewport; a shortcut menu is displayed. Choose Loop/Path 
Cut from the shortcut menu; the Loop/Path Cut tool settings are displayed in the Attribute 
Manager. 

3.	 Make sure the Enable Snap tool is not chosen in the Modes Palette. Next, click to create a 
new edge loop, refer to Figure 3-96. Again, create one more edge loop using the Loop/Path 
Cut tool, as shown in Figure 3-97.

Figure 3-96  New edge loop created

Figure 3-97  Another edge loop added to the Computer table

4.	 Choose the Polygons tool from the Modes Palette; the Computer table is displayed in the 
polygon mode. Choose the Live Selection tool from the Command Palette and make sure 
that the Visible Only check box is selected. Now, select the polygons of Computer table, as 
shown in Figure 3-98.

5.	 Right-click in the Perspective viewport; a shortcut menu is displayed. Choose Extrude from 
the shortcut menu; the Extrude tool settings are displayed in the Attribute Manager. In the 
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Attribute Manager, make sure the Options button is chosen. In the Options area, set the 
parameters as follows:

	 Offset: 40			   Subdivision: 4

	 Figure 3-99 displays the selected polygons extruded in the Perspective viewport.

Figure 3-98  The selected polygons of Computer table

Figure 3-99  The selected polygons extruded in the Perspective viewport

6.	 Choose the Live Selection tool from the Command Palette and make sure that the 
Visible Only check box is selected. Now, select the polygons of Computer table, as shown in 
Figure 3-100.

7.	 Right-click in the Perspective viewport; a shortcut menu is displayed. Choose Extrude from 
the shortcut menu; the Extrude tool settings are displayed in the Attribute Manager. In the 
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Attribute Manager, choose the Options button; the Options area is displayed. In this area, 
set the parameters as follows:

	 Offset: 345			   Subdivision: 8

                                                                                                                                                                                                                                                                                                            
         

Figure 3-100  The selected polygons of Computer table

	

	 Figure 3-101 displays the selected polygons extruded in the Perspective viewport.

Figure 3-101  The selected polygons extruded in the Perspective viewport

Creating the Top Shelves of the Computer Table
In this section, you will create the top shelves of the computer table.

1.	 Make sure the polygon mode is activated. Choose the Live Selection tool from the Command 
Palette and make sure that the Visible Only check box is selected. Now, select the polygons 
of Computer table, as shown in Figure 3-102.
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2.	 Right-click in the Perspective viewport; a shortcut menu is displayed. Choose Extrude from 
the shortcut menu; the Extrude tool settings are displayed in the Attribute Manager. In the 
Attribute Manager, make sure the Options button is chosen. In the Options area, enter the 
value 160 in the Offset spinner and then press ENTER.

Figure 3-102  The selected polygons of Computer table

	 Figure 3-103 displays the selected polygons extruded in the Perspective viewport.

Figure 3-103  The selected polygons extruded in the Perspective viewport

3.	 Choose the Edges tool from the Modes Palette; Computer table is displayed in the edges 
mode.

4.	 Right-click in the Perspective viewport; a shortcut menu is displayed. Choose Loop/Path 
Cut  from the shortcut menu; the Loop/Path Cut tool settings are displayed in the Attribute 
Manager. 
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5.	 Make sure the Enable Snap tool is deactivated in the Modes Palette. Next, click on the edge, 
refer to Figure 3-104; a new edge loop is added to Computer table. Again, create an edge loop 
using the Loop/Path Cut tool, refer to Figure 3-105.

Figure 3-104  Clicking on edge to create a new edge loop

Figure 3-105  Two new edge loops added to the Computer table

6.	 Choose the Polygons tool from the Modes Palette; the Computer table is displayed in the 
polygon mode. Choose the Live Selection tool from the Command Palette and make sure 
that the Visible Only check box is selected. Now, select the polygons of Computer table, as 
shown in Figure 3-106.

7.	 Right-click in the Perspective viewport; a shortcut menu is displayed. Choose Extrude from 
the shortcut menu; the Extrude tool settings are displayed in the Attribute Manager. Make 
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sure the Options button is chosen in this manager. In the Options area, set the parameters 
as follows:

	 Offset: 335		  Subdivision: 12

Figure 3-106  The selected polygons of Computer table

	 Figure 3-107 displays the selected polygons extruded in the Perspective viewport.

Figure 3-107  The selected polygons extruded in the Perspective viewport

8.	 Make sure the polygon mode is activated. Choose the Live Selection tool from the Command 
Palette and make sure that the Visible Only check box is selected. Now, select the four 
polygons of Computer table, as shown in Figure 3-108.
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Figure 3-108  The selected polygons of Computer table

9.	 Right-click in the Perspective viewport; a shortcut menu is displayed. Choose Extrude from 
the shortcut menu; the Extrude tool settings are displayed in the Attribute Manager. Choose 
the Options button in this manager; the Options area is displayed. In this area, enter 160 
in the Offset spinner.

 	 Figure 3-109 displays the selected polygons extruded in the Perspective viewport.

Figure 3-109  The selected polygons extruded in the Perspective viewport

10.	 Choose the Edges tool from the Modes Palette; the Computer table is displayed in the edges 
mode.

11.	 Right-click in the Perspective viewport; a shortcut menu is displayed. Choose Loop/Path 
Cut  from the shortcut menu; the Loop/Path Cut  tool settings are displayed in the Attribute 
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Manager. Make sure Loop is selected in the Mode drop-down list and then clear the Restrict 
to Selection check box. 

12.	 Make sure the Enable Snap tool is deactivated in the Modes Palette. Next, click to create an 
edge loop, refer to Figure 3-110; a new edge loop is added to Computer table. Again, create 
an edge loop using the Loop/Path Cut tool, refer to Figure 3-111.

Figure 3-110  Clicking on edge to create a new edge loop

Figure 3-111  The new edge loop added to the Computer table

13.	Make sure the polygon mode is activated. Choose the Live Selection tool from the Command 
Palette and make sure that the Visible Only check box is selected. Now, select the polygons 
of Computer table, as shown in Figure 3-112.

14.	 Right-click in the Perspective viewport; a shortcut menu is displayed. Choose Extrude from 
the shortcut menu; the Extrude tool settings are displayed in the Attribute Manager. Choose 
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the Options button in this manager; the Options area is displayed. In this area, enter 335 
in the Offset spinner.

	 Figure 3-113 displays the selected polygons extruded in the Perspective viewport.

Figure 3-112 The selected polygons of Computer table

Figure 3-113 The selected polygons extruded in the Perspective viewport

Creating the Bottom Shelf of the Computer Table
In this section, you will create the bottom shelf of Computer table.

1.	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. 
Next, choose Cube from it; a cube is created in the Perspective viewport and Cube is added 
to the Object Manager. 



3-52			                                 MAXON CINEMA 4D R25: A Tutorial Approach
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

2.	 In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. 
In this area, enter Shelf1 in the Name text box; Cube is renamed as Shelf1 in the Object 
Manager. 

3.	 In the Attribute Manager, choose the Object button; the Object Properties area is displayed. 
In this area, set the parameters as follows:

	
	 Size . X: 254.61  		  Size . Y: 15 		  Size . Z: 280 

	 Segments X: 6   		  Segments Y: 4   		 Segments Z: 6

	 Select the Fillet check box and enter 3 in the Fillet Radius spinner. 

4.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. In 
this area, set the parameters as follows:

	 P . X: 234.854          	  P . Y: -119.37 		   P . Z: 0 

	  Figure 3-114 displays Shelf1 positioned in the Perspective viewport.   

    

Figure 3-114  Shelf1 positioned in the Perspective viewport

5.	 Make sure the Shelf1 is selected in the Object Manager. Press and hold the left mouse button 
and the CTRL key and then drag the cursor above Shelf1 in the Object Manager. Next, 
release the left mouse button; the Shelf1.1 object is added in the Object Manager.

6.	 Make sure the Shelf1.1 object is selected in the Object Manager. In the Attribute Manager, 
make sure the Coord button is chosen. In the Coordinates area, enter -291.892 in the P . Y 
spinner; the Shelf1.1 object is positioned in the Perspective viewport, as shown in Figure 3-115.
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Figure 3-115  Shelf1.1 positioned in the Perspective viewport

Creating the Magazine Stand
In this section, you will create the magazine stand of Computer table by using the Polygon Pen 
tool.

1. 	 Choose Model from the layout tabs located at the top of the interface; the Model layout is 
displayed with the Modeling Tool Palette displayed at the lower portion of the interface, 
refer to Figure 3-116.

Figure 3-116  Choosing the Polygon Pen tool from the Modeling Tool Palette

2.  	 Choose the Polygon Pen tool from the Modeling Tool Palette and then hover the cursor 
on the polygon of the Computer table, as shown in Figure 3-117; the highlighted polygon is 
displayed in the Perspective viewport.
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 3. 	 Hold the CTRL key and drag the highlighted polygon, as shown in Figure 3-118.

Figure 3-117  The highlighted polygon

Figure 3-118  Dragging the highlighted polygon 
4.	 Hover the cursor on the top polygon; the polygon is highlighted, as shown in 

Figure 3-119. Next, hold the CTRL key and drag the highlighted polygon, as shown in 
Figure 3-120.

5.	 Rotate the viewport using the ALT key and then hover the cursor on the polygon; the 
polygon is highlighted, as shown in Figure 3-121. Next, hold the CTRL key and drag the 
highlighted polygon, as shown in Figure 3-122.
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Figure 3-119  The highlighted polygon of magazine stand

Figure 3-120  Dragging the highlighted polygon

Figure 3-121  Highlighted polygon
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Figure 3-122  Dragging the highlighted polygon

	 Next, you will create the edges on the magazine stand surface.

6.	 Choose the Edges tool in the Mode palette and make sure the Polygon Pen tool is chosen in 
the Modeling Tool Palette. Next, click on an edge, as shown in Figure 3-123 and then click 
again on another edge; a new edge is created, as shown in Figure 3-124. Similarly, create 
two more edges, refer to Figure 3-125.

Figure 3-123 Clicking on an edge

7.	 Hover the cursor on the polygon; the polygon is highlighted, as shown in Figure 3-126. Next,  hold 
the CTRL key and drag the highlighted polygon downward, as shown in Figure 3-127.

	 Next, you will create a design on the magazine support.

8.  	 Choose the Edges tool in the Mode palette. Make sure the Polygon Pen tool is chosen in the 
Modeling Tool Palette. Next, click on the bottom-left point, as shown in Figure 3-128 and 
then click on the top-right corner point; a new edge is created, as shown in Figure 3-129.
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Figure 3-124  Clicking on second edge to create a new edge

Figure 3-125  Three new edges added to the magazine stand

Figure 3-126  Highlighted polygon
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Figure 3-127  Dragging the highlighted polygon downward

Figure 3-128   Clicking on the corner point

Figure 3-129   The new edge created
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9. 	 Hover the cursor over the created edge. Press and hold the CTRL+SHIFT keys and then 
drag (do not click, just drag); the shape of the edge is changed to an arc shape, refer to 
Figure 3-130.

Figure 3-130  The edge converted to an arc shape

10.	 Hover the cursor on the polygon; the polygon is highlighted, as shown in Figure 3-131. Next, hold 
the CTRL key and drag the highlighted polygon; the selected polygon is extruded, as shown 
in Figure 3-132.

Figure 3-131  Highlighted polygon
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Figure 3-132  The extruded polygon
Changing the Background Color of the Scene
To change the background color of the scene to white in the final output, follow the steps given 
in Tutorial 1 of Chapter 2.

Saving and Rendering the Scene
In this section, you will save and render the scene. You can also view the final render of the 
model by downloading the file c03_cinema4d_R25_rndr.zip from www.cadcim.com. The path of 
the file is mentioned at the beginning of the chapter. 

1. 	 Choose File > Save Project as from the main menu; the Save File dialog box is displayed. 
In this dialog box, browse to the location \Documents\c4dR25\c03.

2. 	 Enter c03tut3 in the File name text box and then choose the Save button.

3.	 In the Perspective viewport, set the camera angle using the Viewport Navigation Tools located 
at the extreme top right of the Perspective viewport. Next, choose the Render to Picture 
Viewer tool from the Command Palette. Alternatively, press SHIFT+R; the Picture Viewer 
window is displayed.

4.	 In the Picture Viewer window, choose File > Save Image as; the Save dialog box is displayed. 

5.	 In the Save dialog box, choose the OK button; the Save Dialog dialog box is displayed. 
Next, browse to \Documents\c4dR25\c03. In the File Name text box, type c03_tut3_rndr. 
Next, choose the Save button; the file is saved at the desired location. 

	 Figure 3-77 displays the final output.

 Tutorial 3                                                                             
In this tutorial, you will create the model of a vase, as shown in Figure 3-133, using the Cloner, 
Volume Builder, and Volume Mesher tools.	                                    (Expected time: 20 min)
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Figure 3-133  Model of a vase

The following steps are required to complete this tutorial:
	
a.   	Create the vase.
b.	 Create groove on the vase.  
c.	 Create design on the vase.
d.	 Change the background color of the scene.
e.	 Save and render the scene.	

Creating the Vase
In this section,  you will create vase using the Sphere tool.

1. 	 Press F4; the Front viewport is activated. Choose Create > Mesh Primitive from the main 
menu; a cascading menu is displayed. Next, choose Sphere from it; a sphere is created in 
the Front viewport and Sphere is added to the Object Manager.  Choose Display > Gouraud 
Shading from the Menu in editor view; Sphere is displayed in the shading mode.

2.	 In the Attribute Manager, choose the Basic button; the Basic Properties area is displayed. In 
this area, enter vase in the Name text box; Sphere is renamed as vase in the Object Manager. 

3.	 Make sure vase is selected in the Object Manager. In the Attribute Manager, choose the 
Object button; the Object Properties area is displayed. In the Object Properties area, set 
the parameters as follows:

	 Radius: 200	   	 	 Segments: 48   

4.	 Choose the Coord. button and enter 1.5 in the S.Y spinner; vase is displayed, as shown in 
Figure 3-134. 

5.	 Make sure vase is selected in the Front viewport. Now, choose the Make Editable tool from 
the Modes Palette; vase is converted into a polygonal object. 

6.	 Choose the Live Selection tool from the Command Palette and then choose the Polygons 
tool from the Modes Palette; vase is displayed in the polygon mode. In the Attribute Manager, 
make sure the Options button is chosen. In the Options area, clear the Visible Only check 
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box. Next, choose the Live Selection tool and select the polygons of vase in the Front 
viewport, as shown in Figure 3-135. If required, decrease the size of the cursor for selection.

Figure 3-134  vase displayed in the Front viewport Figure 3-135  Selected polygons

7.	 Scale down the selected polygons uniformly, refer to Figure 3-136. Next scale the polygons 
only along Y-axis to set them on the upper edge of vase, refer to Figure 3-137. 

Figure 3-136  Selected polygons scaled uniformly Figure 3-137  Selected polygons scaled along  
Y-axis

8.	 Choose the Move tool from the Command Palette and move the selected polygons downward, 
as shown in Figure 3-138.

9.	 Right-click in the Front viewport; a shortcut menu is displayed. Choose Extrude from the 
shortcut menu; the Extrude tool settings are displayed in the Attribute Manager. In the 
Extrude tool settings area, make sure the Options button is chosen. In the Options area, 
set -230 as the value in the Offset spinner and then press the ENTER key; the selected 
polygons are extruded in the Perspective viewport, as shown in Figure 3-139.

10.	 Choose the Live Selection tool and select the bottommost polygons of vase, as shown in 
Figure 3-140. Next, activate the Scale tool and scale these polygons along Y-axis, as shown 
in Figure 3-141.

11.	 Make sure the scaled polygons are selected. Next, right-click in the Front viewport; a 
shortcut menu is displayed. Choose Bevel from the shortcut menu; the Bevel tool settings 
are displayed in the Attribute Manager. In the Bevel tool settings area, make sure the Tool 
Option button is chosen. Next, set -40 in the Offset spinner and 4 in the Subdivision 
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spinner and then press the ENTER key; the selected polygons are beveled in the Perspective 
viewport, as shown in Figure 3-142.

Figure 3-138  Selected polygons moved 
downward

Figure 3-139   Selected polygons extruded

Figure 3-140   Bottommost polygons selected Figure 3-141  Selected polygons scaled along 
y-axis

Creating Groove on the Vase
In this section, you will create groove on vase using the Torus, Volume Builder, and Volume 
Mesher tools. 
  
1. 	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. 

Next, choose Torus from it; a torus is created in the Front viewport and Torus is added to 
the Object Manager. 

2.	 Double-click on Torus in the Object Manager; a text box is displayed. Enter ring in the text 
box; Torus is renamed as ring.

3.	 Make sure ring is selected in the Object Manager. In the Attribute Manager, choose the 
Object button; the Object Properties area is displayed. In the Object Properties area, enter 
20 in the Pipe Radius spinner.

4.	 Choose the Coord. button and enter 51 in the P.Y spinner; Torus moves upward, as shown 
in Figure 3-143. 
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Figure 3-142  Selected polygons beveled Figure 3-143  Torus moved upward

5.	 Choose Volume > Volume Builder from the main menu, as shown in Figure 3-144; Volume 
Builder is added to the Object Manager. 

6.	 Select vase in the Object Manager. Next, press and hold the left mouse button and then drag 
it on Volume Builder; vase is connected to Volume Builder. Next, select ring in the Object 
Manager and press and hold the left mouse button 

Figure 3-144  Choosing Volume Builder 
from the Volume menu

and then drag it on Volume Builder; ring is also 
connected to Volume Builder. Notice that vase and 
ring turn white and both objects are converted into 
voxel objects, refer to Figure 3-145.

7.	 Select Volume Builder in the Object Manager. In 
the Attribute Manager, make sure the Object 
button is chosen. In the Object Properties area, 
enter 1 in the Voxel Size spinner; vase and ring 
are smoothened, refer to Figure 3-146.

Figure 3-145  Voxel objects displayed Figure 3-146  Voxel objects smoothened

8.	 Select Subtract from the Mode drop-down list located next to ring, as shown in Figure 3-147; 
groove is created on vase, as shown in Figure 3-148.
                                                                                                                                          

9.	 Choose Volume > Volume Mesher from the main menu; Volume Mesher is added to the 
Object Manager. 

10.	 Select Volume Builder in the Object Manager. Next, press and hold the left mouse button 
and then drag Volume Builder on Volume Mesher; Volume Builder is connected to Volume Mesher   
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and vase is converted into a polygon object. Also, notice that the color of vase turns dark 
grey, refer to Figure 3-149.

Figure 3-147  Choosing Subtract from the 
Mode drop-down list

   

Figure 3-148  Groove created on vase Figure 3-149  vase turns dark grey
	

Next, you will smoothen vase.

11.	 Select Volume Builder in the Object Manager.	 In the Attribute Manager, make sure the Object 
button is chosen. In the Objects area, select ring from the list displayed and then choose 
the SDF Smooth button; the SDF Smooth layer is added to the list in the Objects area, as 
shown in Figure 3-150.

Figure 3-150  The SDF Smooth layer added to the ObjectProperties area
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12.	 In the Attribute Manager, make sure SDF Smooth layer is selected in the Objects area. In 
the Filter area, enter 4 in the Voxel Distance spinner and enter 2 in the Iterations spinner; 
vase is smoothened, as shown in Figure 3-151. 

Creating Design on the Vase
In this section, you will create design on vase using the Cloner and Volume Builder tools. 

1.	 Choose Create > Mesh Primitive from the main menu; a cascading menu is displayed. 
Next, choose Cube from the cascading menu; a cube is created in the Front viewport and 
Cube is added to the Object Manager. 

2.	 Make sure Cube is selected in the Object Manager. In the Object Properties area of the 
Attribute Manager, enter 25 in the Size.X, Size.Y spinners, and 10 in the Size.Z spinner.

3.	 Choose MoGraph > Cloner from the main menu, as shown in Figure 3-152; Cloner is added 
to the Object Manager. 

Figure 3-151  vase smoothened Figure 3-152 Choosing Cloner from 
the MoGraph menu

4.	 Select Cube in the Object Manager. Next, press and hold the left mouse button and then 
drag it on Cloner; Cube is connected to Cloner. 

5.	 Select Cloner in the Object Manager. In the Attribute Manager, make sure the Object button 
is chosen. In the Object Properties area, select Radial from the Mode drop-down list 
and XZ from the Plane drop-down list. Also, enter 12 and 194 in the Count and Radius 
spinners, respectively. 
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6.	 In the Attribute Manager, choose the Transform button and enter -67 in the P.Y spinner 
in the Transform area. Next, enter -6 and -45  in the R.P and R.B spinners, respectively. 
Cloner is placed on vase, as shown in Figure 3-153. 

7.	 Make sure that Cloner is selected in the Object Manager. Now, create a copy of Cloner by 
pressing both the CTRL key and the left mouse button. Now, drag the cursor and release 
the left mouse button; a copy of Cloner is created in the Object Manager with the name 
Cloner.1.

8.	 Make sure Cloner.1 is selected in the Object Manager. In the Attribute Manager, choose the 
Object button. Next, enter 174 in the Radius spinner.

9.	 Choose the Transform button and enter -145 in the P. Y spinner. Also, enter -20 in the R. P 
spinner; Cloner.1 is placed on vase, as shown in Figure 3-154.

Figure 3-153  Cloner placed on vase Figure 3-154  Cloner.1 placed on vase

10.	 Select Cloner in the Object Manager. Next, press and hold the left mouse button and then 
drag it on Volume Builder; Cloner is connected to Volume Builder. Next, select Cloner.1 in the 
Object Manager and press and hold the left mouse button and then drag it on Volume Builder; 
Cloner.1 is also connected to Volume Builder. Figure 3-155 shows vase displayed in the viewport 
and Figure 3-156 shows list of all the objects in the Object Manager.

Figure 3-155  vase displayed in the viewport
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Figure 3-156  List of all the objects in the Object Manager

Changing the Background Color of the Scene
To change the background color of the scene to white in the final output, follow the steps given 
in Tutorial 1 of Chapter 2.

Saving and Rendering the Scene
In this section, you will save and render the scene. You can also view the final render of the 
model by downloading the file c03_cinema4d_R25_rndr.zip from www.cadcim.com. The path of 
the file is mentioned at the beginning of the chapter. 

1. 	 Choose File > Save Project as from the main menu; the Save File dialog box is displayed. 
In this dialog box, browse to the location \Documents\c4dR25\c03.

2. 	 Enter c03tut3 in the File name text box and then choose the Save button.

3.	 In the Perspective viewport, set the camera angle using the Viewport Navigation Tools 
located at the extreme top right of the Perspective viewport. Next, choose the Render to 
Picture Viewer tool from the Command Palette. Alternatively, press SHIFT+R; the Picture 
Viewer window is displayed.

4.	 In the Picture Viewer window, choose File > Save Image as; the Save dialog box is displayed. 

5.	 In the Save dialog box, choose the OK button; the Save Dialog dialog box is displayed. 
Next, browse to \Documents\c4dR25\c03. In the File Name text box, type c03_tut3_rndr. 
Next, choose the Save button; the file is saved at the desired location. 

	 Figure 3-133 displays the final output.
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 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.   Which of the following tools in the Command Palette is used to select points, edges, or 
polygons by creating a rectangular frame around the object?

		  (a) Move	  		  (b) Rectangle Selection
  		  (c) Use Point Mode	 	 (d) Live Selection

2.	 The __________ tool in the Select menu is used to select the edge loop to modify a polygonal 
object.

3.	 The __________ tool in the Select menu is used to select elements that form a ring shape. 

4.	 The ___________ tool is used to cut polygon objects. 

5.	 The ___________ layer is used to smoothen the object that is created using the Volume   
Builder and Volume Mesher options.

 Review Questions 
Answer the following questions:

1.	 Which of the following combinations of shortcut keys is used to display the Picture 
Viewer window? 

	
		  (a) CTRL+B	  	 (b) SHIFT+ R  		
		  (c) CTRL+C		  (d) CTRL+V

2.	 Which of the following functional keys is used to maximize the Perspective viewport?

		  (a) F1	  		  (b) F5 		
		  (c) F4			   (d) F6

3.	 The Loop option in the Mode drop-down list located in the Loop/Path Cut tool settings is 
used to create edge loops in a polygonal object. (T/F)

EXERCISE 
The rendered output of the model used in the exercise can be accessed by downloading 
the c03_cinema4d_R25_exr.zip file from www.cadcim.com. The path of the file is as follows: 
Textbooks > Animation and Visual Effects > MAXON CINEMA 4D > MAXON CINEMA 4D R25: A 
Tutorial Approach
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 Exercise 1                                                                     
Using the polygon modeling tools, create the model of the chair, as shown in Figure 3-157.	
							         (Expected time: 30 min)

Figure 3-157  The model of a chair

 									       

.Answers to Self-Evaluation Test
1. b, 2. Loop Selection, 3. Ring Selection, 4. Loop/Path Cut 5. SDF Smooth


