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Chapter 2
Getting Started with 

AutoCAD

 Chapter OBJECTIVES

In this chapter, you will learn:

•	 To draw lines using the LINE command and its options.

•	 Various coordinate systems used in AutoCAD.

•	 To clear the drawing area by using the ERASE command.

•	 The two basic object selection methods: Window and Crossing.

•	 To draw circles using the options of the CIRCLE command.

•	 To use the ZOOM and PAN display commands.

•	 To set up units using the UNITS command. 

•	 To set up and determine limits for a given drawing.

•	 To plot drawings using the basic plotting options.

•	 To use the Options dialog box to specify settings.
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Drawing Lines in AutoCAd
  Ribbon: Home > Draw > Line	 Toolbar: Draw > Line	 Menu Bar: Draw > Line	     
  Tool Palettes: Draw > Line	 Command: LINE or L				       

A line is defined as a straight curve. The most fundamental object in 
a drawing is line. In AutoCAD, a line is drawn between two points by 
using the LINE command. You can invoke the LINE command by 
choosing the Line button from the Draw panel of the Home tab in 
the Ribbon, as shown in Figure 2-1. Besides this, you can choose the 
Line button from the Draw tab of the Tool Palettes. To invoke the Tool 
Palettes, choose View > Palettes > Tool Palettes from the Ribbon, as 
shown in Figure 2-2. Alternatively, you can invoke the LINE command 
by choosing the Line button from the Draw toolbar, as shown in Figure 
2-3. However, the Draw toolbar is not displayed by default. To invoke 
this toolbar, choose Tools > Toolbars > AutoCAD > Draw from the 
menu bar. 

You can also invoke the LINE command by entering LINE or L (L is the command alias of  the 
LINE) at the Command prompt. On invoking the LINE command, you will be prompted to 
specify the starting point of the line. Select a point using the mouse or enter its coordinates at 
the command prompt. After specifying the first point, you will be prompted to enter the second 
point. Specify the second point; a line will be drawn. Now, you may continue to specify points 
and draw lines or terminate the LINE command by pressing ENTER, ESC, or SPACEBAR. 
You can also right-click to display the shortcut menu and choose the Enter or Cancel options 
to exit from the LINE command. After terminating the LINE command, AutoCAD will again 
display the Command prompt. The prompt sequence for the drawing shown in Figure 2-4 is 
given next.

Start a new file with the acad.dwt template in the 2D Drafting & Annotation or AutoCAD 
Classic workshop.

Command: LINE 

Specify first point: Move the cursor (mouse) and left-click to specify the first point.

Specify next point or [Undo]: Move the cursor and left-click to specify the second point.

Specify next point or [Undo]: Specify the third point.

Specify next point or [Close/Undo]: (Press ENTER to exit the LINE command.) 

Note
When you select the start point of the line by pressing the left mouse button, a rubber-band line 
stretches between the selected point and the current position of the cursor. This line is sensitive 
to the movement of the cursor and helps you to select the direction and the placement of the next 
point for the line.  

Figure 2-1  The Line 
button in the Draw panel

Figure 2-2  Invoking Tool Palettes from the 
Ribbon.

Figure 2-3  The LINE button 
in the Draw toolbar
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To clear the drawing area and draw new drawings, choose the Erase button from the Modify 
panel in the Home tab of the Ribbon or type ERASE at the Command prompt and press EN-
TER. The crosshairs will change into a box called pick box and you will be prompted to select 
objects. You can select an object by positioning the pick box on it and then by pressing the left 
mouse button. After selecting the objects, press ENTER to terminate the ERASE command and 
the selected objects will be erased. If you enter All at the Select objects prompt and press EN-
TER, all objects in the screen will be erased. You can use the U (undo) command to undo the 
last command. Alternatively, choose the Undo button from the Quick Access toolbar to undo 
the last command. (See “Erasing Objects” discussed later in this chapter.)

The LINE command has the following two options and are discussed next:

Close	 Undo
 
The Close Option
After drawing two continuous lines using the Line command, you will notice the Close option 
is displayed at the Command prompt. The Close option is used to join the current point to the 
start point of the first line when two or more continuous lines are drawn. If you are specifying 
the endpoint using the mouse, then click at the start point of the first line or enter C at the 
command prompt as given in the Command prompt given below.

Command: LINE 

_line Specify first point: Pick first point.

Specify next point or [Undo]: Pick second point.

Specify next point or [Undo]: Pick third point.

Specify next point or [Close/Undo]: Pick fourth point.

Specify next point or [Close/Undo]: C  (Joins the fourth point with the first point) See Fig-
ure 2-5.

You can also choose the Close option from the shortcut menu, which appears when you right-click 
in the drawing area.

Figure 2-4  Drawing lines using the LINE command
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Tip
After exiting the LINE command, you may want to draw another line starting from the endpoint 
of the previous line. In such cases, press Enter twice; a new line will start from the endpoint of the 
previous line. You can also type the @ symbol to start the line from the last point.  For example, 
if you have drawn a circle and then immediately start the Line command, the @ will snap to 
the center point of the circle.

The Undo Option
While drawing a line, if by mistake you have specified a wrong endpoint, then you can remove 
that line using the Undo option of the LINE command. You can use this option multiple times 
and remove as much as line you want. To use this option, type Undo (or just U) at the Specify 
next point or [Undo] prompt. You can also right-click to display the shortcut menu and choose 
the Undo option. 

Note
By default, whenever you open a new drawing, you need to modify the drawing display area. 
To modify the display area, type ZOOM at the Command prompt and press ENTER. In the 
command sequence, type ALL and press ENTER; the drawing display is modified. You will 
learn more about the ZOOM command later in this chapter.

Coordinate Systems
In AutoCAD the location of a point is specified in terms of Cartesian coordinates. In this sys-
tem, each point in a plane is specified by a pair of numerical coordinates. To specify a point in 
a plane, take two mutually perpendicular lines as references. The horizontal line is called the 
X axis, and the vertical line is called the Y axis. The X and Y axes divide the XY plane into four 
parts, generally known as quadrants. The point of intersection of these two axes is called the 
origin and the plane is called XY plane. he origin has the coordinate values of X = 0, Y = 0. The 
origin is taken as the reference for locating a point on the XY plane. Now, to locate a point, say 
P, and draw a vertical line such that it intersects the X axis. The horizontal distance between the 
origin and the intersection point is called as X coordinate of P. It will be denoted as P(x). The X 
coordinate specifies how far the point is to the left or right from the origin along the X axis. Now, 
draw a horizontal line such that it intersects the Y axis. The vertical distance between the origin 
and the intersection point is called as Y coordinate of P. It is denoted by P(y). The Y coordinate 
specifies how far the point  is to the top or bottom from the origin along the Y axis. The coordi-
nates of the point is denoted as P(x,y). T The X coordinate is positive, if measured to the right 
of the origin, and negative if measured to the left of the origin. The Y coordinate is positive, if 
measured above the origin, and negative if measured below the origin, see Figure 2-6.

Figure 2-5  Using the Close option with the LINE command   
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In AutoCAD, the default origin is located at the lower left corner of the drawing area. AutoCAD 
uses the following coordinate systems to locate a point in an XY plane.

1. Absolute coordinates
2. Relative coordinates
	 a. Relative rectangular coordinates
	 b. Relative polar coordinates
3. Direct distance entry

If you are specifying a point by entering its location at the Command prompt then you need to 
use any one of the coordinate system.

Absolute Coordinate System
In the absolute coordinate system, the points are located with respect to the origin (0,0). For 
example, a point with X = 4 and Y = 3 is measured 4 units horizontally (distance along the X 
axis) and 3 units vertically (distance along the Y axis) from the origin, as shown in Figure 2-7. 
In AutoCAD, the absolute coordinates are specified at the Command prompt by entering X 
and Y coordinates, separated by a comma. However, remember that if you are specifying the 
coordinates using the Dynamic Input mode, you need to add # as the suffix to the X coordinate 
value. For example, enter #1,1 in the dynamic input boxes to use absolute coordinate system. 
The following example illustrates the use of absolute coordinates at the Command prompt to 
draw the rectangle shown in Figure 2-8.

Figure 2-6  Cartesian coordinate system

Figure 2-7  Absolute coordinate system Figure 2-8  Lines created using the absolute 
coordinates
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Figure 2-9  Drawing a figure using the absolute coordinates

Start a new file with the acad.dwt template in the 2D Drafting & Annotation or AutoCAD 
Classic workspace. Once the coordinates of the points are known, you can draw the sketch by 
using the LINE command. But before you proceed with drawing the object, you need to turn 
off the Dynamic Input mode, if it is on by default, so that you can view the command you are 
entering in the command window. The prompt sequence is given next.
		
	 Choose the Dynamic Input button from the Status Bar, if it is already chosen.

Command: ZOOM 

Specify corner of window, enter a scale factor (nX or nXP), or [All/Center/Dynamic/Ex-
tents/Previous/Scale/Window/Object] <real time>: All 

Command: LINE 

_line Specify first point: 3,1 	 (Start point.)

Point	 Coordinates        

1			    3,1

2			    3,6	

3	          	  4,6	

4		             	  4,2 

Point	 Coordinates

5	          	  5,2

6	          	  6,3             

7	          	  7,3 

Command: LINE 

_line Specify first point: 1,1 	  (X = 1 and Y = 1.)

Specify next point or [Undo]: 4,1    (X = 4 and Y = 1.) 

Specify next point or [Undo]: 4,3 

Specify next point or [Close /Undo]: 1,3 

Specify next point or [Close/Undo]: C 

Example 1 				       	 Absolute Coordinate System

Draw the profile shown in Figure 2-9 by using the Absolute Coordinate system. The absolute 
coordinates of the points are given in the following table. Save the drawing under the name 
C01_Exam1.dwg.
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Figure 2-10  Drawing for Exercise 1

Specify next point or [Undo]: 3,6 

Specify next point or [Undo]: 4,6 

Specify next point or [Close/Undo]: 4,2 

Specify next point or [Close/Undo]: 5,2 

Specify next point or [close/Undo]: 6,3 

Specify next point or [close/Undo]: 7,3 

Specify next point or [close/Undo]: 7,1 

Specify next point or [close/Undo]: C 

Choose the Save button from the Quick Access toolbar to display the Save Drawing As dialog 
box. Enter the name Exam1 in the File name edit box to replace Drawing1.dwg and then choose 
the Save button. The drawing will be saved with the specified name in the default Documents 
folder.

Exercise 1 				             Absolute Coordinate System

Draw the profile shown in Figure 2-10. The distance between the dotted lines is 1 unit. Enter 
the absolute coordinates of the points given in the following table. Then, use these coordinates 
to draw the same figure.

Point	 Coordinates

1			    2, 1

2			    _________

3			    _________

4			    _________

5			    _________

Point	 Coordinates

6			    _________

7			    _________

8			    _________

9			    _________

			    	   

Relative Coordinate System
There are two types of relative coordinates: relative rectangular and relative polar. 
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Relative Rectangular Coordinates
In the relative rectangular coordinate system, the location of a point is specified with respect to 
the previous point and not with respect to the origin. To enter the coordinate values in terms 
of the Relative Rectangular Coordinate system,  check whether the Dynamic Input is on or not. 
If the Dynamic Input is turned on, then by default the profile will be drawn using the Rela-
tive Rectangular Coordinate system. Therefore, in this case, enter the X coordinate, then type 
comma (,), and then enter the Y coordinate. However, if the Dynamic Input is turned off, the 
coordinate values has to be prefixed by the symbol @. Then, the profile will be drawn using the 
Relative Rectangular Coordinate system. For example, to draw a rectangle (see Figure 2-11) of 
length 4 units and width 3 units and the lower left corner at the point (1,1) using the Relative 
Rectangular Coordinate system, you need to use the following prompt sequence:

Command: LINE 

_line Specify first point: 1,1    (Start point)

Specify next point or [Undo]: @4,0  

Specify next point or [Undo]: @0,3 

Specify next point or [Close/Undo]:@-4,0 

Specify next point or [close/Undo]: @0,-3 

Specify next point or [close/Undo]: 

Remember that if Dynamic Input is on, you need to use a comma (,) after entering the first value 
in the Dynamic Input boxes. Else, AutoCAD will take coordinates in relative polar form.

Sign Convention. As just mentioned, in the relative rectangular coordinate system the 
distance along the X and Y axes are measured with respect to the previous point. To 
understand the sign convention, imagine a horizontal line and a vertical line passing 
through the previous point so that you get four quadrants. If the new point is located 
in the first quadrant, then both the distances (DX and DY) will be specified as positive 
values. If the new point is located in the third quadrant, then both the distances (DX 
and DY) will be specified as negative values. In other words, the point will have a pos-
itive coordinate value, if it is located above or right of the an axis. Similarly, the point 
will have a negative coordinate value, if it is located below or left of an axis.

Example 2   			             Relative Rectangular Coordinates

Draw the profile shown in Figure 2-12 using the relative rectangular coordinates. The coordinates 
of the points are given in the table below.

Figure 2-11  Drawing lines using the relative 
rectangular coordinates



2-9Gett ing  Started  with  AutoCAD
C

h
a

p
te

r
 2

Point	 Coordinates

1			    3,1

2			    @4,0

3	         	  @0,1

4	         	  @-1,0

5	         	  @1,1

6	         	  @0,2

7			    @-1,0

Point	 Coordinates

8			    @-1,-1

9	         	  @-1,1

10	         	  @-1,0

11	         	  @0,-2

12	              	  @1,-1

13	         	  @-1,0

14	         	  @0,-1

Start a new file with the acad.dwt template in the 2D Drafting & Annotation or AutoCAD Clas-
sic workspace. Before you proceed, you need to make sure the Dynamic Input is turned on.

Command: ZOOM 

Specify corner of window, enter a scale factor (nX or nXP), or

[All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real time>: All 

Command: LINE 

_line Specify first point: Type 3,1 in the dynamic input boxes and press        (Start point)

Specify next point or [Undo]: Type 4,0 in the dynamic input boxes and press 

Specify next point or [Undo]: Type 0,1 in the dynamic input boxes and press 

Specify next point or [close/Undo]: Type -1,0 in the dynamic input boxes and press 

Specify next point or [Close/Undo]: Type 1,1 in the dynamic input boxes and press 

Specify next point or [Close/Undo]: Type 0,2 in the dynamic input boxes and press 

Specify next point or [Close/Undo]: -1,0 and press 

Specify next point or [Close/Undo]: -1,-1 and press 

Specify next point or [Close/Undo]: -1,1 and press 

Specify next point or [Close/Undo]: -1,0 and press 

Specify next point or [Close/Undo]: 0,-2 and press 

Specify next point or [Close/Undo]: 1,-1 and press 

Figure 2-12  Profile for Example 2
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Point	 Coordinates

1			    2, 1

2			    ____________

3			    ____________

4			    ____________

5			    ____________

6			    ____________

7			    ____________

8			    ____________

9			    ____________

10			    ____________

11			    ____________

Point	 Coordinates

12			    ____________

13			    ____________

14			    ____________

15			    ____________

16			    ____________

17			    ____________

18			    ____________

19			    ____________

20			    ____________

21			    ____________

22			    ____________

Relative Polar Coordinates
In the relative polar coordinate system, the location of a point is specified by defining the distance 
of the point from the current point and the angle between the two points with respect to the 
positive X axis. The prompt sequence to draw a line of length 5 units whose start point is at 1,1 
and inclined at an angle of 30-degree to the X axis, as shown in Figure 2-14, is given below. 
		

Figure 2-13  Drawing for Exercise 2

Specify next point or [Close/Undo]: -1,0 and press 

Specify next point or [Close/Undo]: 0,-1 and press 

Specify next point or [Close/Undo]: 

Exercise 2   					         	  Absolute Coordinates

For Figure 2-13, enter the relative rectangular coordinates of the points given in the following 
table. Then, use these coordinates to draw the figure. The distance between the dotted lines is 
1 unit.
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	 Command: LINE  
	 Specify first point: 1,1 
	 Specify next point or [Undo]: @5<30 

If the Dynamic Input mode is on, by default the relative 
polar coordinate mode is activated. Therefore, when you 
choose the LINE command and specify the start point; 
two input boxes will be displayed. The second input box 
shows the angle value, preceded by the < symbol. Now, 
enter the distance value, then press the TAB key to shift 
to the second input box, and then enter the angle value.  
Sign Convention .  By default, in the relative 
polar coordinate system, the angle is measured from 
the horizontal axis as the zero degree. Also, the angle 
is positive if measured in a counterclockwise direction 
and negative if measured in a clockwise direction. Here, 
it is assumed that the default setup of the angle measurement has not been changed.

Note
You can modify the default settings of the angle measurement direction using the UNITS 
command, which is discussed later.

Example 3			    	    Relative Rectangular Coordinates

Draw the profile shown in Figure 2-15 using the relative polar coordinates. The relative coordi-
nate values of each point is given in the table. The start point is located at 1.5, 1.75. Save this 
drawing as Exam3.dwg. The dimensions and the numbering are for reference only.

Point	 Coordinates

1			   1.5,1.75	  

2			   @1.0<90  

3			   @2.0<0  

4			   @2.0<30

5			   @0.75<0

6			   @1.25<-90 (or <270)

Point	 Coordinates

7			   @1.0<180

8			   @0.5<270

9			   @1.0<0

10			   @1.25<270

11			   @0.75<180

12			   @2.0<150

Figure 2-15  Drawing for Example 3

Figure 2-14  Drawing a line using rela-
tive polar coordinates  
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Start a new file with the acad.dwt template in the 2D Drafting & Annotation or AutoCAD Clas-
sic workspace. Now, you need to modify the drawing display area. To do so, choose the Zoom 
Extents button from the Heads-Up toolbar. Next, turn off the dynamic input by choosing the 
Dynamic Input button from the Status Bar.

Command: LINE 

_line Specify first point: 1.5,1.75 	 (Start point)

Specify next point or [Undo]: @1<90 

Specify next point or [Undo]: @2.0<0 

Specify next point or [Close/Undo]: @2<30 

Specify next point or [Close/Undo]: @0.75<0 

Specify next point or [Close/Undo]: @1.25<-90 

Specify next point or [Close/Undo]: @1.0<180 

Specify next point or [Close/Undo]: @0.5<270 

Specify next point or [Close/Undo]: @1.0<0 

Specify next point or [Close/Undo]: @1.25<270 

Specify next point or [Close/Undo]: @0.75<180 

Specify next point or [Close/Undo]: @2.0<150 

Specify next point or [Close/Undo]: C (Joins the last point with the first point.)

Save this drawing by choosing the Save button from the Quick Access toolbar. The Save Draw-
ing As dialog box will be displayed. Enter the name Exam3 in the File name edit box and then 
choose the Save button. The drawing will be saved with the specified name in the My Documents 
folder.

Exercise 3	

Draw the profile shown in Figure 2-16 by specifying  the points using the absolute, relative 
rectangular, and relative polar coordinate systems. Do not dimension the profile. They are for 
reference only.

Figure 2-16  Drawing for Exercise 3

Direct Distance Entry
The easiest way to draw a line in AutoCAD is by using the Direct Distance Entry method. To draw 
a line by using this method, ensure that the Dynamic Input button is chosen in the Status Bar 
and choose the Line button; you will be prompted to specify the start point. Enter the coordinate 
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values in the text box and press ENTER; you will be prompted to specify the next point. Now 
enter the absolute length of the line and its angle with respect to the current position of the 
cursor in the corresponding text boxes, as shown in Figure 2-17. Note that you can use the TAB 
key to toggle between the text boxes. If the Ortho mode is on, while drawing lines using this 
method, you can position the cursor only along the X or Y axis. If the Dynamic Input button is 
not chosen, then you need to enter the length of the line at the Command prompt. Therefore, 
position the cursor at the desired angle and type the length at the Command prompt and press 
ENTER, as given below.

Figure 2-17  Drawing lines using the Direct 
Distance Entry method

Command: LINE 

_line Specify first point: Start point.

Specify next point or [Undo]: Position the cursor and then enter distance.

Specify next point or [Undo]: Position the cursor and then enter distance.

Example 4    					              Direct Distance Entry

In this example, you will draw the profile shown in Figure 2-18, using direct distance entry 
method. The starting point is 2,2.

Figure 2-18  Drawing for Example 4

In this example, you will use the polar tracking option to draw lines. The polar tracking option 
allows you to track lines that are drawn at the specified angles. The default angle that is speci-
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fied for polar tracking is 90-degree. Therefore, by default you can track lines at an angle that 
are in multiples 90, such as 90, 180, 270, and 360. In this example, you need to draw lines at 
angles that are in multiples of 45-degree such as 45, 90, 135, and so on. So, first you need to 
set the polar tracking angle as 45-degree.

Note
You will learn more about polar tracking in Chapter 4, Working with Drawing Aids.

1. 	 Start a new file with the acad.dwt template in the 2D Drafting & Annotation or AutoCAD 
Classic workspace. 

2. 	 To add a 45-degree angle to polar tracking, right-click on the Polar Tracking button on the 
Status Bar and choose 45 from the shortcut menu. Again choose the Polar Tracking button 
in the Status Bar to turn the polar tracking on. 

3. 	 Choose the Line button from the Draw panel of the Home tab; you are prompted to specify 
the start point.

4. 	 Enter 2,1 at the command prompt and press ENTER; you are prompted to specify next 
point. 

5.	 Move the cursor horizontally toward the right and when the tooltip appears as polar angle 
0, type 2 and press ENTER; you are prompted to specify next point.

6.  	 Move the cursor at an angle close to 45-degree and when the tooltip appears as polar angle 
45, type 0.7071 and press ENTER; you are prompted to specify next point

7.   	Move the cursor vertically upward and when the tooltip appears as polar angle 90, type 1 
and press ENTER; you are prompted to specify next point.

8. 	 Move the cursor horizontally toward the left and when the tooltip appears as polar angle 
180, type 3 and press ENETR; you are prompted to specify next point.

9. 	 Move the cursor vertically downward and when the tooltip appears as polar angle 90, type 
1 and press ENTER; you are prompted to specify next point.

10. 	Type C and press ENTER.

Tip
To add the angular values other than those in the shortcut menu of the polar tracking, choose 
Settings from the shortcut menu. Next, select the Additional angles check box in the Polar 
Angle Settings area and choose the New button. Enter a new value in the field that appears 
and then press ENTER. Choose OK to close the dialog box.

Exercise 4   					              Direct Distance Entry

Use the direct distance entry method to draw a parallelogram. The base of the parallelogram 
equals 4 units, the side equals 2.25 units, and the angle equals 45-degree. Draw the same par-
allelogram using the absolute, relative, and polar coordinates. Note the differences and the 
advantages of using Direct Distance Entry.
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Erasing Objects
   Ribbon: Home > Modify > Erase			   Toolbar: Modify > Erase		   
   Menu Bar: Modify > Erase			   Tool Palettes: Modify > Erase	  
   Command: ERASE or E								      

After drawing some objects, you may need to erase some of them. 
Erasing unwanted objects is done using the ERASE command. This 
command is used exactly the same way as an eraser is used in manual 
drafting to delete the unwanted lines. To erase, choose the Erase 
button from the Modify panel of the Ribbon, see Figure 2-19. You 
can also choose the Erase button from the Modify toolbar, as shown 
in Figure 2-20. To invoke the Modify toolbar, choose Tools > Tool-
bars > AutoCAD > Modify from the menu bar. When you invoke 
the ERASE command, a small box, known as pick box, replaces the 
screen cursor. To erase an object, select the object using the pick box 
(see Figure 2-21); the selected object is displayed in dashed lines and the Select objects prompt 
returns. You can either continue selecting the objects or press Enter to terminate the object 
selection process and erase the selected objects. The prompt sequence is given next.

Figure 2-20  The Erase 
button in the Modify toolbar

Figure 2-21  Selecting object by positioning the 
pick box at the top of the object

Command: ERASE 

Select objects: Select first object.

Select objects: Select second object.

Select objects: 

If you enter All at the Select objects prompt, all objects in the drawing are will be selected, 
even if the objects are outside the display area. Now, if you press ENTER, all selected objects 
will be erased.

You can also first select the objects to be erased from the drawing and then right-click in the draw-
ing area to display the shortcut menu. From this shortcut menu, choose the Erase option.

CANCELING AND UNDOING A COMMAND
If you erase an object by mistake, then to restore the erased object enter the OOPS or UNDO 
command. The OOPS command is used to restore the erased objects immediately ERASE com-
mand, refer to Figure 2-24. The U (Undo) command is used to undo any command.

To cancel or exit from a command, press the ESC (Escape) key on the keyboard.

Figure 2-19  The Erase 
button in the Ribbon
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Object Selection Methods
The usual method to select objects is selecting them individually. But this will be time-consuming, 
if you have a number of objects to select. This problem can be solved by creating a selection set that 
enables you to select several objects at a time. The selection set options can be used with those 
commands that require object selection, such as ERASE and MOVE. There are many object 
selection methods, such as All, Last, Add, and so on. In this chapter, you will learn two options: 
Window and Crossing. The remaining options are discussed in Chapter 5.

The Window Option
The window option is one of the selection options in which an object or group of objects are 
selected by drawing a window. The objects that are completely enclosed within the window are 
selected and those objects that lie partially inside the boundaries of the window are not selected. 
To select the objects using the Window option after invoking a command, type W at the Select 
objects prompt and press ENTER; you will prompted to specify the first corner of the window. 
Select the first corner and then move the cursor to specify the opposite corner. As you move the 
cursor, a blue color window of continuous line is displayed that changes in size as you move the 
cursor. Specify the opposite corner of the window; the objects that are enclosed in this window 
are displayed as dashed objects. Figure 2-22 shows a window drawn to select the objects by using 
the Window option. The objects that are to be selected are shown in dashed lines.

Figure 2-22  Selecting objects using the Window option 

You can also invoke the Window option without entering W at the Command prompt. To do so, 
select a blank point on the screen at the Select objects prompt. This is considered as the first 
corner of the window. Moving the cursor to the right will display a blue shaded window. After 
enclosing the required objects to be selected, specify the other corner of the window. The objects 
that are completely enclosed within the window will be selected and displayed in dashed line. The 
following is the prompt sequence for automatic window selection with the ERASE command.

Command: ERASE 

Select objects: Select a blank point as the first corner of the window.

Specify opposite corner: Drag the cursor to the right to select the other corner of the window.

Select objects: 

Tip
In AutoCAD, the entities are highlighted when you move the cursor over them. This feature is 
known as the selection preview. To set the selection preview, invoke the Options dialog box, then 
choose the Selection tab, and then the Visual Effects Settings button in the Selection Preview 
area; the Visual Effect Settings dialog box will be displayed. Set the type of selection preview by 
selecting the appropriate radio button in the Line Highlighting area of this dialog box. 
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The Crossing Option
The crossing option is one of the selection methods in which an object or group of objects that 
are partially enclosed by the selection window are selected. The objects to be selected should 
be touching the window boundaries or completely enclosed within it. To select the objects  by 
using the crossing option after invoking a command, type C at the Select objects prompt and 
press ENTER; you are prompted to select the first corner of the window. Select the first corner 
and then move the cursor to specify the opposite corner. As you move the cursor, a green color 
window of dashed line is displayed that changes in size as you move the cursor. Specify the 
opposite corner of the window; the objects that touches the window boundaries and that are 
enclosed by this window are selected as displayed as dashed objects. Figure 2-23 shows a window 
drawn to select the objects by using the Crossing option. The objects that are to be selected are 
shown in dashed lines.

Figure 2-23  Selecting objects using the Crossing 
option 

You can also invoke the Crossing option without entering C at the Command prompt. To do 
so, specify a point in the drawing area at the Select objects prompt and move the cursor to the 
left. The first point you selected becomes the first corner of the crossing window and you will be 
prompted to select the other corner. As you move the cursor, a green color window of dashed 
lines is displayed that changes in size as you move the cursor. Specify the opposite corner of the 
window; the objects that touches the window boundaries and that are enclosed by this window 
are selected as displayed as dashed objects. The prompt sequence for automatic crossing option 
when you choose the Erase command is given next.

Select objects: Select a blank point as the first corner of the crossing window.

Specify opposite corner: Drag the cursor to the left to select the other corner of the crossing 
window.

Select objects: 

Tip
You can also select the objects using the window or crossing options before invoking a command. 
To do so, specify the start point of the selection window and drag the cursor to enclose the objects 
in a window. If you have moved the cursor to the left of starting point, crossing option will be 
activated and that objects that are touched by the window boundaries and that are enclosed by this 
window are selected. Similarly, if you have moved the cursor to the right of the starting point, the 
window option is activated and the objects that are enclosed in this window are selected. 
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Drawing Circle
  Command: 	 CIRCLE or C			   Toolbar: 	 Draw > Circle	     
   Menu Bar: 	 Draw > Circle			   Tool Palettes: 	 Draw > Circle            
   Ribbon: 	 Home > Draw > Center, Radius					        

A circle is drawn using the CIRCLE command. In AutoCAD, 
you can draw a circle by using six different buttons. All these 
buttons are grouped together in the Draw panel of the Rib-
bon. To view all these buttons, choose the down arrow next to 
the Center,Radius button in the Draw panel of the Ribbon; 
all buttons will be listed in a flyout, as shown in Figure 2-24. 
Note that the button that was last chosen will be displayed 
in the Draw panel. You can also invoke CIRCLE command 
by choosing the Circle button from the Draw toolbar or the 
Tool Palettes. The different methods to draw a circle are 
discussed next.

Drawing Circle by Specifying the Center and Radius
   Ribbon: 	 Home > Draw > Center, Radius 	

To draw a circle by specifying the center and the radius of the circle, ensure the Dynamic Input 
button is chosen and choose the Center, Radius button from the Draw panel; you will be prompted 
to specify the center. Type the coordinates and press ENTER or specify the center using the left 
mouse button. After specifying the center point of the circle and move the cursor to define its 
radius. The current radius of the circle will be displayed in the dimension input box, as shown 
in Figure 2-25. This radius value will change as you move the cursor. Type a radius value in the 
dimension input box or click to define the radius; a circle is drawn of specified radius value.

Drawing a Circle by Specifying the Center and Diameter
   Ribbon: 	 Home > Draw > Center, Radius 	 > Center, Diameter	  

To draw a circle by specifying the center and the diameter of the circle, ensure the Dynamic 
Input button is chosen and choose Center, Radius > Center, Diameter from the Draw panel; 
you will be prompted to specify the center. Type the coordinates and press ENTER or specify 
the center using the left mouse button. After specifying the center point of the circle, move the 
cursor to define its diameter. The current diameter of the circle will be displayed in the dimen-
sion input box, as shown in Figure 2-26. This diameter value will change as you move the cursor. 
Type a diameter value in the dimension input box or click to define the diameter; a circle is 
drawn of specified diameter value.

Figure 2-25  Drawing a circle by specifying 
the center and radius

Figure 2-26  Drawing a circle by specifying 
the center and diameter

Figure 2-24  The Circle button in 
the Ribbon
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Drawing a Circle by Specifying Two Diametrical Ends
    Ribbon: 	 Home > Draw > Center, Radius > 2-Point	  
    Command:  	 C >  2P					   

You can also draw a circle, by specifying two diametrical ends of a circle, see Figure 2-27. To do 
so, ensure the Dynamic Input button is chosen and choose Center, Radius > 2-Point from the 
Draw panel; you will be prompted to specify the first end of the diameter. Type the coordinates 
and press ENTER or specify the center using the left mouse button. After specifying the center 
point of the circle, move the cursor to define its diameter. Now, you can type the coordinates or 
diameter in the dimension input box.

Drawing a Circle by Specifying Three Points on a Circle
    Ribbon: 	 Home > Draw > Center, Radius > 3-Point 	       
   Command:  	 C >  3P					          

To draw a circle by specifying three points that are on the periphery of a circle, choose Center, 
Radius > 3-Point from the Draw panel and specify the three points in succession. You can type 
the coordinates of the points or specify using the left mouse button. The prompt sequence to 
type the three coordinates on choosing the 3-Point button is given below.

Specify center point for circle or [3P/2P/Ttr(tan tan radius)]: _3p Specify first point on 
circle: 3,3

Specify second point on circle: #3,1

Specify third point on circle: #4,2 (see Figure 2-28)

You can also use relative rectangular coordinates to define the points.

Drawing a Circle Tangent to Two Objects 
  Ribbon:      Home > Draw > Center, Radius > Tan,Tan,Tan	           Command:  	  C > Ttr	                

A tangent is an object (line, circle, or arc) that contacts the circumference of a circle at only 
one point. To draw a circle of specific radius and tangent to two objects, ensure the Dynamic 
Input button is chosen and choose Center, Radius > Tan,Tan, Radius from the Draw panel; 
you will be prompted to specify a point on object for first tangent of circle. Move the cursor 
near a object that is to be tangent to the circle; a tangent symbol will be displayed. Specify the 
first point; you will be prompted to specify a point on object for second tangent of circle. Move 
the cursor near the second object that is to be tangent to the circle; a tangent symbol will be 
displayed. Specify the second point; you will be prompted to specify the radius. Type the radius 

Figure 2-28  A circle drawn using the 
Three-point option

Figure 2-27  A circle drawn using the 
Two-Point option
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in the dimension input box and press ENTER; a circle will be drawn of specified radius and 
tangent to two objects.

In Figures 2-29 through 2-32, the dotted circles represent the circle that is tangent to two objects. 
The circle actually drawn depends on how you select the objects that are to be tangent to the new 
circle. The figures show the effect of selecting different points on the objects.  If you specify too 
small or large radius, you may get unexpected results or the “Circle does not exist” prompt.

Figure 2-30  Drawing a circle tangent 
to two objects

Figure 2-29  Drawing a circle tangent to two 
objects

Figure 2-31  Drawing a circle tangent to 
two objects

Figure 2-32  Drawing a circle tangent 
to two objects

Drawing a Circle Tangent to Three Objects
   Ribbon: 	 Home > Draw > Center, Radius > Tan,Tan,Tan	

You can also draw a circle that is tangent to three objects. To do so, ensure the Dynamic Input 
button is chosen and choose Center, Radius > Tan,Tan,Tan from the Draw panel and select 
three objects in succession to which the resulting circle is to be tangent; the circle will be drawn, 
as shown in Figure 2-33.

Figure 2-33  Drawing a circle tangent to three objects
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Exercise 5  						               Line and Circle

Draw Figure 2-34 using various options of the LINE and CIRCLE commands. Use absolute, 
relative rectangular, or relative polar coordinates for drawing the triangle. The vertices of the 
triangle will be used as the center of the circles. The circles can be drawn using the Center, 
Radius, Center, Diameter, or Tan, Tan, Tan options. Do not apply dimensions; they are for 
reference only.

Figure 2-34  Drawing for Exercise 4

BASIC Display Commands
Sometimes while drawing a sketch, it will be very difficult to view and alter minute details. You 
can overcome this problem by viewing only a specific portion of the drawing. This is done us-
ing the ZOOM command. This command lets you enlarge or reduce the size of the drawing 
displayed on the screen. Similarly, you may need to slide the drawing view. This is done using 
the PAN command. These are called as display command. 

Zooming Drawings
The Zoom command is used to enlarge or reduce the view of a 
drawing on the screen, without affecting the actual size of entities. 
In AutoCAD 2011, the ZOOM options grouped together and are 
available in the Navigator Bar. To invoke the different ZOOM 
options, press the down arrow next to the Zoom Extents button 
in the Navigator Bar; all options of the ZOOM command will be 
displayed in the flyout,  as shown in Figure 2-35. You can also invoke 
the ZOOM command by choosing View > Zoom from the menu 
bar.  To display the menu bar, left-click on the arrow in the Quick 
Access toolbar and then select Show Menu Bar. Some ZOOM 
commands are also available in the Standard toolbar. 

Zoom Extents
Choose the Zoom Extents button to increase or decrease 
the drawing display area so that all sketched entities or 
dimensions are fitted inside the current view.

Zoom Window
This is the most commonly used option of the ZOOM com-
mand. On choosing this option, you need to draw a window 

Figure 2-35  The Zoom op-
tions in the Navigator Bar
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by specifying its two opposite corners. The center of the zoom window becomes the center of 
the new display area and the objects in this window are magnified. 

Zoom Realtime
The Zoom Realtime option is used to dynamically zoom into or out of the drawing. When 
you choose this option, the cursor will be replaced by the zoom cursor. To zoom out of 
a drawing, press and hold the left mouse button and drag the cursor in the downward 

direction. Similarly, to zoom into a drawing, press and hold the left mouse button and drag the 
cursor in the upward direction. As you drag the cursor, the drawing display will be modified 
dynamically. After you get the desired view, exit this tool by right-clicking and choosing Exit 
from the shortcut menu or by pressing the ESC key. If you have a mouse with scroll wheel, then 
scroll the wheel to zoom into/out of the drawing.

Zoom Previous
While working on a complex drawing, you may need to zoom multiple times into a 
drawing to edit some minute details. After completing the editing if you want to view 
the previous views, choose the Previous option. You can view up to the last ten views 

using the Previous option.

Zoom In / Zoom Out
Choose the Zoom In / Zoom Out options to double the view of the image size or 
decrease the view of the image size by half, respectively.

Note
You will learn about the other options of the ZOOM command in detail in Chapter 6. 

Moving the View
You can use Pan command to move the view, by sliding the view and placing it at the 
required position. To pan a drawing view, invoke the command from the Navigator Bar; 
an image of a hand is displayed. Drag the cursor in any direction to move the drawing. 

To exit Pan command, right-click and choose Exit. You can also press ESC or the ENTER key 
to exit the command.

Setting Units Type and Precision
    Application Menu:    Drawing Utilities > Units		  Command:     UNITS	               

In the previous chapter, you learned to set units while starting a drawing by using the Use a 
Wizard option in the Startup dialog box. But, if you are drawing a sketch in an existing template 
or a new template, you need to change the format of the units for distance and angle measure-
ments. This is done using the UNITS command. To set the units format, enter UNITS at the 
Command prompt; the Drawing Units dialog box will be displayed, as shown in Figure 2-36. 
You can also invoke this dialog box by choosing Drawing Utilities > Units from the Applica-
tion Menu or by choosing  Format > Units from the menu bar. The procedure to change the 
units format is discussed next. 

Specifying the Format
In the Drawing Units dialog box, you can select a desired format of units from the Type 
drop-down list. You can select one of the following five formats.

Architectural (0’-01/16”)	 Decimal (0.00)  	 Engineering (0’-0.00”)		
Fractional (0 1/16)	 Scientific (0.00E+01) 
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If you select the scientific, decimal, or fractional format, you can enter the distances or coordinates 
in any of these three formats, but not in engineering or architectural units. If you choose the 
engineering or architectural format, you can enter the distances or coordinates in any of the 
five formats. 

Note
The inch symbol (“) is optional. For example, 1’1-3/4“ is the same as 1’1-3/4, and 3/4“ is the 
same as 3/4.

Specifying Angle Format
You can select one of the following five angle measuring formats.

1. Decimal Degrees (0.00)			   2. Deg/min/sec (0d00’00”)
3. Grads (0.00g)			   4. Radians (0.00r)
5. Surveyor’s Units (N 0d00’00” E) 

If you select any one of the first four measuring formats, you can enter the angle in the Deci-
mal, Degrees/minutes/seconds, Grads, or Radians system, but you cannot enter the angle in 
Surveyor’s Units. However, if you select Surveyor’s Units, you can enter the angles in any of 
the five systems. To enter the value in another system, use the appropriate suffixes and symbols, 
such as r (Radians), d (Degrees), or g (Grads). If you enter an angle value without any indicating 
the symbol of a measuring system, it is taken in the current system. 

In Surveyor’s units, you must specify the angle that the line makes with the north-south direction, 
as shown in Figure 2-37. For example, if you want to define an angle of 60-degree with north, 
in the Surveyor’s units the angle will be specified as N 60d E. Similarly, you can specify angles 
such as S 50d E, S 50d W, and N 75d W, refer to Figure 2-43. You cannot specify an angle that 
exceeds 90-degree (N 120 E). The angles can also be specified in radians or grads, for example, 
180-degree is equal to π (3.14159) radians. You can convert degrees into radians or radians into 
degrees using the equations given below.	

radians = degrees X 3.14159/180;  
degrees = radians X 180/3.14159

Figure 2-36  The Drawing Units dialog box
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Grads are generally used in land surveys. There are 400 grads or 360-degree in a circle. 90-
degree angle is equal to 100 grads. 

In AutoCAD, if an angle is measured in the counterclockwise direction, then it is positive. Also, 
the angles are measured from the positive X axis, see Figure 2-38. If you want the angles to be 
measured as positive in the clockwise direction, select the Clockwise check box from the Angle 
area. You can specify the precision for the length and angle in the respective Precision drop-
down lists in this dialog box. 

Setting the Direction for Angle Measurement
As mentioned above the angles are measured about the positive X axis. This means that base 
angle (0-degree) is set along the east direction, see Figure 2-39. To change this, choose the 
Direction button in the Drawing Units dialog box, the Direction Control dialog box will be 
displayed, as shown in Figure 2-40. Select the appropriate radio button to specify the direction 
for the base angle (0-degree). 

If you select the Other option, you can set your own direction for the base angle (0-degree) by 
entering a value in the Angle edit box or by choosing the Pick an Angle button and picking 
two points to specify the angle. After specifying the base angle direction choose the OK button 
to apply the settings.

Tip
If you are entering the values using the dimension input boxes that is displayed when Dynamic 
Input option is chosen, then you no need to set the base angle. 

Figure 2-37  Specifying angle in Surveyor’s 
Units

Figure 2-38  Measuring angles

Figure 2-39  North, South, East, 
and West directions

Figure 2-40  The Direction Control 
dialog box
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Specifying the Units for the Drawing or Block to be Inserted
To set the units for a block or a drawing that has to be inserted, select a unit from the Units 
to scale inserted content drop-down list. Now, if you insert a block or a drawing from the 
DesignCenter, the specified unit will be applied to the . Even if the block was created using a 
different measuring unit, AutoCAD scales it and inserts it using the specified measuring unit. 
If you choose Unitless from the drop-down list, then the units specified in the Insertion Scale 
area in the User Prefernces tab of the Options dialog box will be used.

Note
The insertion of blocks into a drawing is discussed in detail in Chapter 16.

Sample Output
The Sample Output area in this dialog box shows an example of the current format of the units 
and angles. When you change the type of length and angle measure in the Length and Angle 
areas of the Drawing Units dialog box, the corresponding example is displayed in this Sample 
Output area.

Specifying the Unit for Lighting
You can also specify the units to be used for the measurement of intensity of the photometric 
lights. The photometric lights are used for the rendering of the drawings. Select the desired 
unit system from the Units for specifying the intensity of lighting drop-down list in the Light-
ing area of the Drawing Units dialog box. While using the photometric lights in rendering, 
you cannot use the Generic unit for the measurement of the intensity of light. The concept of 
rendering and lights is discussed in Chapter 30. 

Example 5   							          Setting Units                     

In this example, you will set the units of a drawing according to the given specifications  and 
then draw Figure 2-41. You also need to do the following.

a. 	 Set the units of length to fractional, with the denominator of the smallest fraction equal to 
32.

b. 	 Set the angular measurement to surveyor’s units, with the number of fractional places for 
display of angles equal to zero.

c. 	 Set the base angle (0-degree) to North and the direction of measurement of angles to 
clockwise.

Figure 2-41  Drawing for Example 5
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 The procedure of completing this example is given in the following steps.

1.	 Start a new file with the acad.dwt template in the 2D Drafting & Annotation or the Auto-
CAD Classic workspace and invoke the Drawing Units dialog box by choosing the  Draw-
ing Utilities > Units from the Application Menu. You can also invoke this dialog box by 
entering UNITS at the Command prompt.

2.	 In the Length area of the dialog box, select Fractional from the Type drop-down list. From 
the Precision drop-down list, select 0 1/32.

3.	 In the Angle area of the dialog box, select Surveyor’s Units from the Type drop-down list. 
From the Precision drop-down list, select N 0d E, if it is not already selected. Also, select 
the Clockwise check box to set the clockwise angle measurement as positive.

4.	 Choose the Direction button to display the Direction Control dialog box. Next, select the 
North radio button. Choose the OK button to exit the Direction Control dialog box.

5.	 Choose the OK button to exit the Drawing Units dialog box. 

6.	 With the units set, draw Figure 2-41 using the relative polar coordinates. Here, the units 
are fractional and the angles are measured from north (90-degree axis). Also, the angles 
are measured as positive in the clockwise direction and negative in the counterclockwise 
direction. 

7.	 To modify the drawing display area, choose the Zoom All button from the Navigator Bar.

8.	 Turn off the dynamic input. The prompt sequence to complete the sketch is as follows:
Command: LINE 

Specify first point: 2,2

Specify next point or [Undo]: @2.0<0 

Specify next point or [Undo]: @2.0<60 

Specify next point or [Close/Undo]: @1<180

Specify next point or [Close/Undo]: @1<90 

Specify next point or [Close/Undo]: @1<180 

Specify next point or [Close/Undo]: @2.0<60 

Specify next point or [Close/Undo]: @0.5<90 

Specify next point or [Close/Undo]: @2.0<180 

Specify next point or [Close/Undo]: C 

SETTING Limits OF THE DRAWING
  Command: 	 LIMITS   

In AutoCAD, the limits represent the drawing area and it is endless. Therefore, you need to 
define the drawing area before starting the drawing. In the previous chapter, you learned to set 
the limits while starting a drawing by using the Use a Wizard option in the Startup dialog box. 
If you are working in a drawing using the default template, you need to change the limits. For 
example, the template like acad.dwt has the default limits 12,9. To draw a rectangle of dimen-
sion 150x75 in this template, you need to change its limits to 200x100. This will done using the 
LIMITS command. The following is the prompt sequence of the LIMITS command for setting 
the limits to 24,18 for the acad.dwt template, which has the default limits 12,9
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Command: LIMITS 

Reset Model space limits:

Specify lower left corner or [ON/OFF]<0.0000,0.0000>: 0,0 

Specify upper right corner <12.0000,9.0000>: 24,18 

Tip
Whenever you reset the drawing limits, the display area does not change automatically. You need 
to use the All option of the ZOOM command to display the complete drawing area.

The limits of the drawing area are usually determined by the following factors.

1.	 The actual size of the drawing.
2.	 The space needed for adding the dimensions, notes, bill of materials, and other necessary 

details.
3.	 The space between various views so that the drawing does not look cluttered.
4.	 The space for the border and title block, if any.

Setting Limits
To get a good idea of how to set up limits, it is always better to draw a rough sketch of the draw-
ing. This will help in calculating the drawing area needed. For example, if an object has a front 
view size of 5 X 5, a side view size of 3 X 5, and a top view size of 5 X 3, the limits should be set 
so that they can accommodate the drawing and everything associated with it. In Figure 2-42, 
the space between the front and side views is 4 units and between the front and top views is 3 
units. Also, the space between the border and the drawing is 5 units on the left, 5 units on the 
right, 3 units at the bottom, and 2 units at the top. (The space between the views and between 
the borderline and the drawing depends on the drawing.)

After knowing the size of different views, the space required between views, between the border 
and the drawing, and between the borderline and the edges of the paper, you can calculate the 
space you need as follows.

		  Space along (X axis) = 1 + 5 + 5 + 4 + 3 + 5 + 1 = 24
	 Space along (Y axis) = 1 + 3 + 5 + 3 + 3 + 2 + 1 = 18

Thus, the limits you need to set for this drawing is 24 X 18. Once you have determined the 
space, select the sheet size that can accommodate your drawing. In the case just explained, you 
will select a D size (34 X 22) sheet. Therefore, the actual drawing limits will be 34,22.

Figure 2-42  Setting limits in a drawing
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Tip
To display the grid, choose the Grid Display button in the Status Bar. By default, the grid will 
be displayed beyond the limits. To display the grid up to the limits, use the GRID command and 
set the Display grid beyond Limits [Yes/No] <Yes>: option to No. Now, the grids will be 
displayed only up to the limits set.

Limits for Architectural Drawings
Most architectural drawings are drawn at a scale of 1/4” = 1’, 1/8” = 1’, or 1/16” = 1’. You 
must set the limits accordingly. The following example illustrates how to calculate the limits in 
architectural drawings.

Given
	 Sheet size = 24 X 18
	 Scale is 1/4” = 1’
Calculate limits
	 Scale is 1/4” = 1’
	     or 1/4” = 12”
          or 1” = 48”
       X limit = 24 X 48
                  = 1152” or 1152 Units
                   = 96’
      Y limit  = 18 X 48
                  = 864” or 864 Units
                   = 72’
Thus, the scale factor is 48 and the limits are 1152”,864”, or 96’,72’.

Example 6    							          Setting Limits

In this example, you will calculate the limits and determine an appropriate drawing scale 
factor for Figure 2-43. The drawing is to be plotted on a 12” X 9” sheet. Assume the missing 
dimensions.

The calculation for the scale factor is given next.

Given or known
	
	 Overall length of the drawing = 31’
	 Length of the sheet = 12”

Figure 2-43  Drawing for Example 6
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	 Approximate space between the drawing and the edges of the paper = 2”

Calculate scale factor
To calculate the scale factor, you have to try various scales until you find one that satisfies the 
given conditions. After some experience, you will find this fairly easy to do. For this example, 
assume a scale factor of 1/4” = 1’.

	 Scale factor 1/4” = 1’ 	       or 1” = 4’

Thus, a line 31’ long will be = 31’/4’ = 7.75” on paper. Similarly, a line 21’ long = 21’/4’ = 
5.25”.	 Approximate space between the drawing and the edges of paper = 2”

Therefore, total length of the sheet = 7.75 + 2 + 2 = 11.75”

Similarly, total width of the sheet = 5.25 + 2 + 2 = 9.25”

Because you selected the scale 1/4” = 1’, the drawing will definitely fit on the given sheet of 
paper (12” x 9”). Therefore, the scale for this drawing is 1/4” = 1’.

Calculate limits
	 Scale factor = 1” = 48” or 1” = 4’
	 The length of the sheet is 12”
	 Therefore, X limit = 12 X 4’ = 48’ and Y limit = 9 X 4’ = 36’

Limits for Metric Drawings
When the drawing units is in metric, you must use standard metric size sheets or calculate the 
limits in millimeters (mm). For example, if the sheet size you decide to use is 24 X 18, the lim-
its, after conversion to the metric system, will be 609.6,457.2 (multiplying length and width by 
25.4). You can round these numbers to the nearest whole numbers 610,457. Note that metric 
drawings do not require any special setup, except for the limits. Metric drawings are like any 
other drawings that use decimal units. Similar to architectural drawings, you can draw metric 
drawings to a scale. For example, if the scale is 1:20, you must calculate the limits accordingly. 
The following example illustrates how to calculate the limits for metric drawings.

Given
	 Sheet size = 24” X 18”
	 Scale = 1:20

Calculate limits
	 Scale is 1:20
	 Therefore, scale factor = 20
	 X limit = 24 X 25.4 X 20 = 12192 units
	 Y limit = 18 X 25.4 X 20 = 9144 units

Exercise 6    					          Setting Units and Limits

Set the units of the drawing according to the following specifications and then make the drawing 
shown in Figure 2-44 (leave a space of 3 to 5 units around the drawing for dimensioning and 
title block). The space between the dotted lines is 1 unit.

1.	 Set UNITS to decimal units, with two digits to the right of the decimal point.
2.	 Set the angular measurement to decimal degrees, with the number of fractional places for 

display of angles equal to 1.
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3.	 Set the direction to 0-degree (east) and the direction of measurement of angles to 
counterclockwise (angles measured positive in a counterclockwise direction).

4.	 Set the limits leaving a space of 3 to 5 units around the drawing for dimensioning and title 
block.

Introduction to Plotting Drawings
    Ribbon: 	 Output > Plot > Plot		  Toolbar:    Quick Access > Plot	  
    Application Menu: 	 Print > Plot		  Command: 	 PLOT or PRINT	

After creating a drawing such as an architectural plan or a mechanical component, you may 
need to send it to the client or have a hard copy for reference. To do so, you need to plot the 
drawing. To plot a drawing, choose Plot from the Quick Access toolbar; the Plot dialog box will 
be displayed. If the dialog box is not expanded by default, choose the More Options button at 
the lower right corner of the dialog box to expand it, as shown in Figure 2-45. 

Basic Plotting
In this section, you will learn to set up the basic plotting parameters. Later, you will learn about 
the advance options to plot according your plot drawing specifications. Basic plotting involves 
selecting the correct output device (plotter), specifying the area to plot, selecting paper size, 
specifying the plot origin, orientation, and the plot scale.

To learn the basic plotting, we will plot the drawing drawn in Example 3 of this chapter. It is 
assumed that AutoCAD is configured for two output devices: Default System Printer and Lino-
tronic 300v52.3.

1.	 Invoke the Plot dialog box by choosing the Plot button in the Quick Access toolbar. 

2.	 The name of the default system printer is displayed in the Name drop-down list in the Printer/
plotter area. Select Linotronic 300v52.3 in the Name drop-down list. 

3.	 Select the Window option from the What to plot drop-down list in the Plot area area. The dialog 
box is temporarily closed and the drawing area will appear. Now, select two opposite corners to define 
a window such that it specifies the area you want to plot. Note that the complete drawing, along with 
the dimensions should be enclosed in the window. Once you have defined the two corners, the Plot 
dialog box will reappear.

Figure 2-44  Drawing for Exercise 6
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4.	 To set the size of the plot, you need to select a paper size from the drop-down list in the Paper size 

area. Once you select a paper size, you need to set the orientation of the paper. To set the orientation, 
expand the Plot dialog box by choosing the More Options button at the lower right corner of the 
dialog box. You can set the orientation as Landscape or Portrait by selecting the appropriate radio 
button from the Drawing orientation area. The sections in the Plot dialog box related to paper 
size and orientation are automatically revised to reflect the new paper size and orientation. For this 
example, you will specify A4 paper size and Portrait orientation.

5.	 You can also modify values for the plot offset from the Plot offset area; the default values for X and 
Y are 0. For this example, you can select the Center the plot check box to get the drawing in the 
center of the paper. 

6.	 In AutoCAD, you can enter values for the plot scale from the Plot scale area. Clear the Fit to paper 
check box, if selected and then click the Scale drop-down list in the Plot scale area to display vari-
ous scale factors. From this list, you can select a scale factor that you want to use. For example if you 
select the scale factor 1/4” = 1’-0”, the edit boxes below the drop-down list will show 0.25 inches = 
12 units. If you want the drawing to be plotted so that it fits on the specified sheet of paper, select the 
Fit to paper check box. When you select this check box, AutoCAD will determine the scale factor 
and display it in the edit boxes. For this example, we will plot the drawing so that it scales to fit the 
paper. Therefore, select the Fit to paper check box and notice the change in the edit boxes. You can 
also enter your own values in the edit boxes. 

7.	 To preview a plot, choose the Preview button; you can preview the plot on the specified paper size. 
In the preview window, the realtime zoom icon will be displayed. If needed, you can zoom into or 
zoom out of the preview image for better visualization. 

8.	 If the plot preview is satisfactory, you can plot your drawing by choosing Plot from the shortcut 
menu. If you want to make some changes in the settings, choose Exit in the shortcut menu or press 

Figure 2-45  The Plot dialog box
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the ESC or the ENTER key to get back to the dialog box. Change the parameters and choose the 
OK button in the dialog box to plot the drawing.

Modifying AutoCAD Settings Using the Options 
Dialog Box
   Application Menu: 	 Options		 Command: 	 OPTIONS	       

You can use the Options dialog box to change the default settings customize them to your 
requirements. For example, you can use this dialog box to turn off the settings to display the 
shortcut menu, change the display color of the objects, or specify the support directories that 
contain the files you need. 

To invoke the Options dialog box, right-click at the Command prompt or in the drawing area 
when no command is active or no object is selected and choose Options from the shortcut menu; 
the dialog box is displayed, as shown in Figure 2-46. The current profile and current drawing 
names are displayed below the name of the title bar. You can save a set of custom settings in a 
profile to be used later for other drawings.  

Files
This tab stores the directories in which AutoCAD looks for the driver, support, menu, project, 
template, and other files. It uses three icons: folder, paper stack, and file cabinet. The folder 
icon is for a search path, the paper stack icon is for files, and the file cabinet icon is for a specific 
folder. Suppose you want to know the path of the font mapping file. You can select the Text 
Editor, Dictionary, and Font File Names folder and then select the Font Mapping Files icon to 
display the path, see Figure 2-46. Similarly, you can define a custom hatch pattern file and then 
add its search path.     

Figure 2-46  The Options dialog box
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Display
This tab controls the drawing and window settings like screen menu display and scroll bar. For 
example, if you want to display the screen menu, select the Display screen menu check box in 
the Window Elements area. You can change the color of the graphics window background, 
layout window background, command line background, and also the color of the command 
line text by using the Drawing Window Colors dialog box that is displayed on choosing the 
Colors button. In this tab you can specify the parameters to set the display resolution and dis-
play performance. You can also set the smoothness and resolutions of certain objects such as 
the circle, arc, rendered object, and polyline curve. You can also toggle on and off the display 
performance such as the pan and zoom with raster images, apply the solid fills, and so on. In 
this tab, you can toggle on and off the various layout elements such as the layout tabs on the 
screen, margins, paper background, and so on.  

Open and Save
This tab controls the parameters related to opening and saving of files in AutoCAD. You can 
specify the file type for saving while using the SAVEAS command. The various formats are 
AutoCAD 2010 Drawing (*.dwg), AutoCAD 2007 Drawing (*.dwg), AutoCAD 2004/LT 2004 
Drawing (*.dwg), AutoCAD 2000/LT2000 Drawing (*.dwg), AutoCAD R14/LT98/LT97 Draw-
ing (*.dwg), AutoCAD Drawing Template(*.dwt), AutoCAD 2007 DXF (*.dxf), AutoCAD 2004/
LT2004 DXF (*.dxf), AutoCAD 2000/LT2000 DXF(*.dxf), AutoCAD R12/LT2 DXF (*.dxf),  
and so on. You can also set the various file safety precautions such as the Automatic Save fea-
ture, or the creation of a backup copy. To add a password and digital signatures to your drawing 
while saving, choose the Security Options button in the File Safety Precautions area and set 
the password. On selecting the Display digital signature information check box, you can view 
the digital signature information when a file with a valid digital signature is opened. You can 
change the number of recently saved files to be displayed in the File Open area. You can also 
set the various parameters for external references and the ObjectARX applications.

Plot and Publish
The options in this tab controls the parameters related to the plotting and publishing of the 
drawings in AutoCAD. You can set the default output device and also add a new plotter. You 
can set the general parameters such as the layout or plot device paper size and the background 
processing options while plotting or publishing. It is possible to select the spool alert for the 
system printer and also the OLE plot quality. You can also set the parameters for the plot style 
such as using the color-dependent plot styles or the named plot styles. 

System
This tab contains AutoCAD system settings options such as the 3D graphics display and pointing 
device settings options where you can choose the pointing device driver. Here you can also set the 
system parameters such as the single drawing mode instead of MDE, the display of the Startup 
option while opening a new session of AutoCAD and the OLE Properties dialog box, and beep 
for wrong user input. You also have options to set the parameters for database connectivity. 

User Preferences
The parameters in this tab is used to control the settings such as the right-click customization to 
change the shortcut menus according to the user preferences. You can set the units parameters 
for the blocks or the drawings that are inserted as well as the priorities for various coordinate 
data entry methods. You can also set the order of object sorting methods and also set the lin-
eweight options.
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Drafting
The options in this tab are used to control the settings such as the autosnap settings and the 
aperture size. Here you can also set the toggles on and off for the various autotracking set-
tings. Using this tab, you can also set the tool tip appearance in the Model tab and layouts for 
Dynamic Input mode.

3D Modeling
This tab controls settings related to 3D modeling, such as the display of cursor in the 3D model-
ing environment, visual styles, 3D navigation, and so on.

Selection
This tab controls settings related to the methods of object selection such as the grips, which 
enable you to change various grip colors and the grip size. You can also set the toggles on or 
off for the various selection modes.

Profiles
This tab saves and restores the system settings. To save a profile and have different settings,  
choose the Add to List button; the Add Profile dialog box will be displayed. Enter the profile 
name and description. Then choose the Apply & Close button. Next, make the new profile 
current and then change the settings in each tab. The settings are saved in the new profile and 
can be restored anytime by making the profile current.

Note
The options in various tabs of the Options dialog box have been discussed throughout the book 
wherever applicable.

Tip
Some options in the Options dialog box have a drawing file icon in front of them. For example, 
the options in the Display resolution area of the Display tab have drawing file icons. This speci-
fies that these parameters are saved with the current drawing only and therefore it affects only 
that drawing. The options without the drawing file icon are saved with the current profile and 
affect all drawings present in that AutoCAD session or future sessions.

Example 7    			         	       Modifying the Default Options

In the following example, you will use the Options dialog box to create a profile that contains 
the specified settings.

1.	 Choose Options from the Application Menu to invoke the Options dialog box. Alternatively, 
right-click in the drawing area to display the shortcut menu and choose Options to invoke 
this dialog box. 

2.	 Choose the Profiles tab and then choose the Add to List button to display the Add Profile 
dialog box. Enter the name of the new profile as CADCIM and Profile created for chapter 
2, Tutorial 8 as the description of the new profile, and then choose the Apply & Close 
button to exit.

3.	 Select the CADCIM profile and then choose the Set Current button to make this current. 
You will notice that the Current Profile name above the tabs displays CADCIM.

4.	 Choose the Display tab and then choose the Colors button; the Drawing Window Col-
ors dialog box is displayed. Select the 2D model space in the Context area and Uniform 
background in the Interface element area. Select White from the Color drop-down list, 



2-35Gett ing  Started  with  AutoCAD
C

h
a

p
te

r
 2

see Figure 2-60. This changes the color of the model tab background to white. Choose the 
Apply & Close button to return to the Options dialog box. Notice that the screen color 
changes to white.

5.	 Choose the Drafting tab and change the AutoSnap Marker Size to the maximum using the 
slider bar. Choose the Apply button and then the OK button to exit the dialog box. 

6.	 Draw a line and then choose the Object Snap button from the Status Bar. Again, invoke the 
LINE command and move the cursor on the previously drawn line; a marker is displayed 
at the endpoint. Notice the size of the marker now.

7.	 Invoke the Options dialog box again and choose the Profiles tab. Double-click on the de-
fault profile to reload the default settings. The screen settings will change as specified in 
the default profile.

  Self-Evaluation Test	

Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 You can draw a line by specifying the length of the line and its direction, using Direct Dis-
tance Entry method. (T/F)

2.	 While using the Crossing method of object selection, the objects that are completely enclosed 
within the boundaries of the crossing box are selected. (T/F)

3.	 The 3-Point option of the CIRCLE command lets you draw a circle by specifying the two 
endpoints of the circle’s diameter. (T/F)

4.	 If you choose the engineering or architectural format for units in the Drawing Units dialog 
box, you can enter the distances or coordinates in any of the five formats. (T/F)

5.	 You can erase a previously drawn line using the __________ option of the LINE 
command.

6.	 The __________option of the CIRCLE command can be used to draw a circle, if you want 
the circle to be tangent to two previously drawn objects.

7.	 The __________ command enlarges or reduces the view of the drawing without affecting 
the actual size of the entities. 

8.	 After increasing the drawing limits, you need to choose the __________ button from the 
Navigator Bar to display the complete area inside the drawing area.

9.	 In __________ units, you must specify the bearing angle that the line makes with the 
north-south direction.

10.	 You can preview the plot before the actual plotting using the __________ button in the Plot 
dialog box.  
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 Review Questions	

Answer the following questions:

1.	 In the Relative rectangular coordinate system, the displacements along the X and Y axes 
(DX and DY) are measured with respect to the previous point and not with respect to the 
origin. (T/F)

2.	 In AutoCAD, by default the angles are measured along the positive X axis and it will be 
positive if measured in the counterclockwise direction. (T/F)

3.	 You can also invoke the PLOT command by choosing Plot from the shortcut menu, which 
is displayed by right-clicking on the Command window. (T/F)

4.	 The Files tab of the Options dialog box stores the directories, in which AutoCAD looks for 
the driver, support, menu, project, template, and other files. (T/F)

5.	 Which of the following keys on the keyboard is used to terminate the LINE command at 
the Specify next point or [Close/Undo]: prompt?

			   (a) SPACEBAR			   (b) BACKSPACE
			   (c) ENTER			   (d) ESC

6.	 Which of the following ZOOM commands, zooms to the drawing limits or the extents, 
whichever is greater?

			   (a) Zoom Previous		  (b) Zoom Window
			   (c) Zoom All			   (d) Zoom Realtime

7.	 How many formats of units can you choose from the Drawing Units dialog box?

			   (a) Three			   (b) Five
			   (c) Six				    (d) Seven

8.	 Which of the following input methods cannot be used to invoke the OPTIONS command 
that displays the Options dialog box?

			   (a) Menu			   (b) Toolbar
			   (c) Shortcut menu		  (d) Command prompt

9.	 When you define the direction by specifying the angle, the output of the angle does not 
depend on which one of the following factors?

			   (a) Angular units		  (b) Angle value
			   (c) Angle direction		  (d) Angle base 

10.	 The __________ option of the LINE command can be used to join the current point with 
the initial point of the first line when two or more lines are drawn in continuation.

11.	 The __________ option of drawing the circle cannot be invoked by entering the command 
at the Command prompt. 

12.	 When you select any type of unit and angle in the Length or Angle area of the Drawing 
Units dialog box, the corresponding example is displayed in the __________ area of the 
dialog box.
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13.	 If you want the drawing to be plotted so that it fits on the specified sheet of paper, select the 
__________ option in the Plot dialog box.

14.	 The __________ tab in the Options dialog box stores the details of all profiles available in 
the current drawing.

15.	 You can use the __________ command to change the settings that affect the drawing 
environment or the AutoCAD interface.

Exercise 7	   	    Relative Rectangular and Absolute Coordinates

Use the following relative rectangular and absolute coordinate values  in the LINE command 
to draw an object. 

 Point	 Coordinates           

1			    3.0, 3.0	 

2	       	  	  @3,0  	

3			    @-1.5,3.0

4			    @-1.5,-3.0

Point	 Coordinates  

5			    @3.0,5.0

6			    @3,0

7			    @-1.5,-3

8			    @-1.5,3

Exercise 8	       	       Relative Rectangular and Polar Coordinates

Draw the profile shown in Figure 2-47, using the relative rectangular and relative polar coordinates 
of the points in the following table. The distance between the dotted lines is 1 unit. Save this 
drawing as C02_E xer8.dwg.	

Figure 2-47  Drawing for Exercise 8

Point	 Coordinates  

1			    3.0, 1.0  

2			    ________

3			    ________

4			    ________

5			    ________

6			    ________

Point	 Coordinates 

7			    ________

8			    ________

9			    ________

10			    ________

11			    ________

12			    ________

Point	 Coordinates

13			    ________

14			    ________

15			    ________

16			    ________
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Figure 2-48  Drawing for Exercise 9

Figure 2-49  Drawing for Exercise 10

Exercise 9				         	    Relative Polar Coordinates

For the drawing shown in Figure 2-48, enter the relative polar coordinates of the points in the fol-
lowing table. Then use these coordinates to draw the figure. Do not dimension the drawing.

Point	 Coordinates           

1			    1.0, 1.0  

2			    _______

3			    _______

4			    _______

5			    _______	  

Point	 Coordinates

6			    _______

7			    _______

8			    _______

9			    _______	

Exercise 10					        	          Line and Circle

Draw the sketch shown in Figure 2-49, using the LINE and CIRCLE commands. The distance 
between the dotted lines is 1.0 units.
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Figure 2-50  Drawing  for Exercise 11

Figure 2-51  Drawing for Exercise 13

Exercise 11		              Line and Circle Tangent to Two objects

Draw the sketch shown in Figure 2-50 using the LINE command and the Ttr option of the 
CIRCLE command.

Exercise 12			              			      Setting Units

Set the units for a drawing according to the following specifications.
1.	 Set the UNITS to architectural, with the denominator of the smallest fraction equal to 16.
2.	 Set the angular measurement to degrees/minutes/seconds, with the number of fractional 

places for display of angles equal to 0d00’.
3.	 Set the direction to 0-degree (east) and the direction of measurement of angles to 

counterclockwise (angles measured positive in a counterclockwise direction).

Exercise 13			              			      Setting Units

Based on Figure 2-51, determine and set the limits of the drawing. The scale for this drawing 
is 1/4” = 1’. Leave enough space around the drawing for dimensioning and title block. (HINT: 
Scale factor = 48; sheet size required is 12 x 9; therefore, the limits are 12 X 48, 9 X 48 = 576, 
432. Use the ZOOM command and then select the All option to display the new limits.)
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Figure 2-52  Drawing for Exercise 14

 Exercise 14	      				         Using Architectural Units

Draw the sketch shown in Figure 2-52. The distance between the dotted lines is 10 feet. Determine 
the limits for this drawing and use the Architectural units with 0’-01/32” precision.

Figure 2-53  Drawing for Exercise 15

 Exercise 15	      				            Using Fractional Units

Draw the object shown in Figure 2-53. The distance between the dotted lines is 5 inches. 
Determine the limits for this drawing and use the Fractional units with 1 1/16 precision.

Exercise 16	      				            Using Decimal Units

Draw the object shown in Figure 2-54. The distance between the dotted lines is 1 unit. Determine 
the limits for this drawing and use the Decimal units with 0.00 precision.
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Figure 2-54  Drawing for Exercise 16

Figure 2-55  Drawing for Exercise 17

Exercise 17	      				          Using Engineering Units

Draw the object shown in Figure 2-55. The distance between the dotted lines is 10 feet. Determine 
the limits for this drawing and use the Engineering units with 0’0.00” precision.

Problem-Solving Exercise 1	

Draw the object shown in Figure 2-56, using the LINE and CIRCLE commands. In this 
exercise only the diameters of the circles are given. To draw the lines and small circles (Dia 0.6), 
you need to find the coordinate points for the lines and the center points of the circles. For 
example, if the center of concentric circles is at 5,3.5, then the X coordinate of the lower left 
corner of the rectangle is 5.0 - 2.4 = 2.6.
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Figure 2-56  Drawing for Problem-Solving Exercise 1

Problem-Solving Exercise 2	

Draw the object shown in Figure 2-57 using various options of the CIRCLE and LINE commands. 
In this exercise, you have to find the coordinate points for drawing the lines and circles. Also, 
you need to determine the best and easiest method to draw the 0.85 diameter circles along the 
outermost circle.

Figure 2-57  Drawing for Problem-Solving Exercise 2

Problem-Solving Exercise 3	

Draw the object shown in Figure 2-58 using the absolute, relative rectangular, or relative polar 
coordinate system. Draw according to the dimensions shown in the figure, but do not dimension 
the sketch. The dimensions are only for your reference.



2-43Gett ing  Started  with  AutoCAD
C

h
a

p
te

r
 2

  Answers to Self-Evaluation Test	

1. T, 2. F, 3. F, 4. T, 5. Undo, 6. Tan, Tan, Radius, 7. ZOOM, 8. All, 9. Surveyor’s, 10. Preview

Figure 2-58  Drawing for Problem-Solving Exercise 3




