
Chapter 2

Creating Sketches in 
the Sketch Mode-I

 Learning Objectives 
After completing this chapter, you will be able to:
• Use various tools to create geometry
• Dimension a sketch
• Apply constraints to a sketch
• Modify a sketch
• Use the Modify Dimensions dialog box
• Edit the geometry of a sketch by trimming
• Mirror a sketch
• Insert standard/user-defined sketches
• Use the drawing display options
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THE SKETCH MODE
A sketch is a 2D entity that graphically captures an idea using lines, curves, constraints, and 
dimensions. To create a three-dimensional (3D) feature, it is necessary to draw or import a 
two-dimensional (2D) sketch. Almost all models designed in Creo Parametric consist of datums, 
sketched features, and placed features. When you enter the Part mode and select options to 
create any sketched feature, the system automatically takes you to the sketcher environment. In 
the sketcher environment, the sketch of the feature is created, dimensioned, and constrained. 
The sketches created in the Sketch mode are stored in the .sec format. After creating the sketch, 
you need to return to the Part mode to create the required feature. 

Note
You will learn about datums and placed features in later chapters.

In Creo Parametric, a sketch can be drawn using the Sketch mode in the sketcher environment 
or can be imported from other softwares. You can draw a 2D sketch of the product and assign 
the required dimensions and constraints to capture the design intent. By assigning dimensions 
and constrains to sketches, you can ensure predictable results when a model is modified. 

Working with the Sketch Mode
To create any sketch in the Sketch mode of Creo Parametric, certain basic steps have to be 
followed. The following points outline the steps to draw a sketch in the Sketch mode:

1. Sketch the Required Section 
The different tools available in this mode can be used to sketch the required geometry. 

2. Add Constraints and Dimensions to the Sketched Section
While sketching the section geometry, weak dimensions are automatically added to the section. 
The sketch can also be dimensioned and constrained manually. The dimensions that are applied 
manually are called strong dimensions. After adding the dimensions, you can modify them as 
required. 

Invoking the Sketch Mode
To invoke the Sketch mode, choose New from the File menu or choose the New button from the 
Data group in the Home tab of the Ribbon; the New dialog box will be displayed with different 
Creo Parametric modes in the Type area. Select the Sketch radio button to start a new file in 
the Sketch mode, refer to Figure 2-1; a default name of the sketch file appears in the File name 
edit box. You can change the sketch name as required and then choose the OK button to enter 
the Sketch mode.
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Figure 2-1 The New dialog box

THE SKETCHER ENVIRONMENT
When you invoke the Sketch mode, the initial screen displayed is similar to the one shown in 
Figure 2-2. The Sketch tab is chosen by default in the Ribbon. The drawing tools are available 
in the Sketching group of the Sketch tab. 

Figure 2-2 Initial screen appearance in the Sketch mode

The navigator is displayed on the left of the drawing area. In navigator, the Folder Browser tab 
is activated by default. It covers a part of the drawing area and therefore the drawing area 
is decreased. You can increase the drawing area by choosing the Show Navigator button, 
which is available at the bottom left corner of the window.
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Note
1. Datum planes are not displayed in the Sketch mode.

2. The Folder Browser tab is divided into two areas, Common Folders and Folder Tree. The 
functions of the Common Folders and Folder Tree areas have already been discussed in Chapter 1.

WORKING WITH A SKETCH IN THE SKETCH MODE
When you invoke the sketcher environment, the One-by-One selection filter is selected by 
default in the Select drop-down list of the Operations group. You can select other selection 
filters from the Select drop-down list. Other selection filters available in this drop-down list are 
Chain, All Geometry, and All. By using the One-by-One selection filter, you can select each 
individual entity from the drawing area. By using the Chain selection filter, you can select a 
complete chain of entities linked with the selected entity. If the All Geometry selection filter is 
selected then all the geometric entities available in the drawing area are selected automatically. 
If you selected the All selection filter is selected then all entities available in the drawing area 
are selected automatically.

Note
1. The One-by-One selection filter is activated by default. If you activate another selection filter, then 
that selection filter will be deactivated automatically after using once, and again the One-by-One 
selection filter will be activated automatically.

2. A sketch in Creo is saved with .sec file extension.

3. You can create a simple sketch by using the options available in the shortcut menu which is 
displayed by pressing and holding the right mouse button in the drawing area. Once the shortcut 
menu is displayed, the right mouse button can be released.

DRAWING A SKETCH USING THE TOOLS AVAILABLE IN 
THE SKETCH TAB
In the sketcher environment, the Sketch tab is active in the Ribbon by default. There are various 
groups in this tab which contain tools to draw and modify a sketch and its dimensions. In this 
section, you will draw sketched entities using the tools available in the Sketch tab.

Creating a Point 
Points are used to specify locations. You can use a point as reference for creating other geometric 
elements. In the sketcher environment of Creo, you can create construction points and geometry 
points. The procedures of creating these points are discussed next.

Creating a Construction Point
  Ribbon:  Sketch > Sketching > Point  

The construction points can be used only in the sketcher environment. To create a 
construction point, choose the Point tool from the Sketching group and click in the drawing 
area to place the point at the specified location.
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Creating a Geometric Point
  Ribbon:  Sketch > Datum > Point  

The Point tool available in the Datum group is used to create a geometric point. The points 
created by using this tool can also be used as a reference point in the Part modeling 

environment . The procedure to create a geometric point by using the Point tool from the Datum 
group is similar to the procedure of creating point from the Sketching group.

Note
1. To increase the number of visible command prompt lines in the message area, select the upper 
boundary line of the message area using the left mouse button and drag it upward, toward the screen.

2. When you place a single point, no dimension appears. But when you place two points, they are 
dimensioned with respect to each other.

Drawing Lines
You can draw a line by using the tools available in the Line drop-down. The Line Chain tool is 
used to create a line or chain of lines by selecting two points in the drawing area and the Line 
Tangent tool is used to create a tangent line between two entities. 

The procedure to create lines by using these tools is discussed next.

Drawing a Line Using the Line Chain Tool
  Ribbon:  Sketch > Sketching > Line drop-down > Line Chain  

The Line Chain tool is used to create a line or chain of lines. The following steps explain 
the procedure to create a line using the Line Chain tool available in the Line drop-down:

1.	 Choose the Line Chain tool or press the L key from the keyboard to invoke the tool. Click 
in the drawing area to start the line; a rubber-band line appears starting from the selected 
point with the other end attached to the cursor. 

2.	 After specifying the start point of the line, move the cursor in the drawing area to the desired 
location. You will notice that the sketcher begins to dynamically apply constraints in your 
sketch. For example, if you sketch the line approximately vertical or horizontal, sketcher 
dynamically applies a vertical or horizontal constraint to that line, helping you to lock its 
position. Next, click to specify the endpoint of the line. The rubber-band line continues 
and you can draw the second line. 

3.	 Repeat step 2 until all lines are drawn. You can end the line creation by pressing the middle 
mouse button. To abort the line creation, press the middle mouse button again. The start 
point and end point of the line or line chain are displayed in red colored dots. 

Note
1. After drawing a line, when you press the middle mouse button twice to end the line creation, 
the line drawn is highlighted in green color. In the sketcher environment, the green color of an 
entity indicates that it is selected. If you press the DELETE key, the line will be erased from the 
drawing area.
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2. After drawing a line, weak dimensions are applied to the sketch and they appear in light 
blue color. These weak dimensions are applied automatically to the sketched entities as you 
draw them. The concept of weak dimensions is discussed later in this chapter.

Drawing a Line Using the Line Tangent Tool
  Ribbon:  Sketch > Sketching > Line drop-down > Line Tangent  

The Line Tangent tool is used to draw a tangent line between two entities such as arcs, 
circles, or ellipses. The following steps explain the procedure to draw a tangent using this 
tool:

1.	 Choose the Line Tangent tool from the Line drop-down in the Sketching group; you will 
be prompted to select the start point on an arc, a circle, or an ellipse.

2.	 Select the first entity from where the tangent line will be drawn; a rubber-band line appears 
with the cursor. Also, you will be prompted to select the end point on an arc, a circle, or an 
ellipse. On selecting the second entity, a line tangent to both the selected entities will be 
drawn. 

Note
You can draw a tangent line only if there are two or more than two arcs, circles, or ellipses already 
drawn in drawing area.

Drawing a Centerline
You can draw a centerline by using the tools available in the Centerline drop-down. Click on 
the down arrow on the right of the Centerline tool; a menu will appear with two tools. The 
first tool is the Centerline tool which is used to create a centerline by selecting two points in 
the drawing area. A centerline is used for creating revolved features, mirroring, and so on. The 
second tool is the Centerline Tangent tool that enables you to create a tangent centerline which 
can be referenced in the sketcher environment. The procedures to draw centerlines using these 
two tools are discussed next.

Drawing a Centerline Using the Centerline Tool
  Ribbon:  Sketch > Sketching > Centerline drop-down > Centerline  

You can draw horizontal, vertical, or inclined centerlines using the Centerline tool. The 
centerline in a sketch is used as an axis of rotation for mirroring, aligning, and dimensioning 
entities. 

The steps to draw a centerline are discussed next.

1.	 In the Sketching group, choose the Centerline tool from the Centerline drop-down; you 
will be prompted to select the start point.

2.	 Click in the drawing area to specify the start point; you will be prompted to select the end 
point.
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3.	 Click in the drawing area to specify the endpoint; a centerline of infinite length is drawn.

Drawing a Centerline Using the Centerline Tangent Tool
  Ribbon:  Sketch > Sketching > Centerline drop-down > Centerline Tangent  

The Centerline Tangent tool is used to draw a centerline tangent to two entities such as 
arcs, circles, ellipses or a combination of them. To draw a tangent centerline using this 
tool, you need to follow the steps given below:

1.	 Choose the Centerline Tangent tool from the Centerline drop-down in the Sketching 
group; you will be prompted to select the start location on arc or circle.

2.	 Select the first entity from where the tangent line has to be drawn; a rubber-band line with 
the cursor will appear. Also, you will be prompted to select the end point on an arc or circle. 
As soon as you select the second entity, a centerline with infinite length tangent to both the 
selected entities is drawn.

Drawing a Geometry Centerline
  Ribbon:  Sketch > Datum > Centerline  

The Centerline tool available in the Datum group is used to create centerlines as a part 
of the geometry. The centerline created by using this tool can be referenced outside the 

sketcher environment. The procedure to create a centerline by using the Centerline tool from 
the Datum group or from the Sketching group is same. The only difference between them is 
that the centerline created by using the Centerline tool is a geometric entity, not a sketch. To 
draw a geometric centerline, choose the Centerline tool from the Datum group. Next, specify 
the start and end points of the geometry centerline; a centerline of infinite length will be created 
in the drawing area.

Drawing a Rectangle
  Ribbon:  Sketch > Sketching > Rectangle drop-down  

In Creo Parametric, there are four tools available in the Rectangle drop-down that can be used 
to draw different types of rectangles. These tools are Corner Rectangle, Slanted Rectangle, 
Center Rectangle, and Parallelogram which are explained next.

Note
When a non-overlapping closed sketch is drawn then it appears to be filled with light orange color. 
It indicates that the sketch is closed. This happens because the Shade Closed Loops button in the 
Inspect group of the Sketch tab is chosen by default. You can deactivate this button by clicking on it.

Creating a Corner Rectangle
  Ribbon:  Sketch > Sketching > Rectangle drop-down > Corner Rectangle  

You can create a rectangle by using the two corner points. To create a rectangle by using 
the Corner Rectangle tool, you need to follow the steps given below: 
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1.	 Invoke the Corner Rectangle tool from the Rectangle drop-down; you will be prompted to 
select two points as corners of the rectangle. Click to specify the first point; a rubber-band 
box appears with the cursor attached to the opposite corner of the box.

2.	 Move the cursor diagonally in the drawing area and then click to specify the second point 
for the diagonal of the rectangle.

Creating a Slanted Rectangle
  Ribbon:  Sketch > Sketching > Rectangle drop-down > Slanted Rectangle  

You can create an inclined rectangle by using the Slanted Rectangle tool. To create an 
inclined rectangle, you need to follow the steps given next.

1.	 Invoke the Slanted Rectangle tool from the Rectangle drop-down; you will be prompted 
to click LMB to define the start point of the first side of the parallelogram. Click to specify 
the first point; an orange rubber-band line will be displayed with the cursor attached to the 
end point of the line.

2.	 Next, click at any point to create the end point of first side of the box; you will be prompted 
to specify the end point of the second side.

3.	 Move the cursor perpendicular to the first line in the drawing area and then click to specify 
the second side for the rectangle.

Creating a Center Rectangle
  Ribbon:  Sketch > Sketching > Rectangle drop-down > Center Rectangle  

You can create a rectangle with the help of a center and end points by using the Center 
Rectangle tool. To create a rectangle by using the Center Rectangle tool, you need to 
follow the steps given next:

1.	 Invoke the Center Rectangle tool from the Rectangle drop-down available in the Sketching 
group; you will be prompted to specify the center point of the rectangle. Click to specify 
the center point; an orange rubber-band box appears with the cursor attached to the end 
point of the diagonal of the box.

2.	 Click at any desired point in the drawing area to create the rectangle.

Creating a Parallelogram
  Ribbon:  Sketch > Sketching > Rectangle drop-down > Parallelogram  

You can create a parallelogram by using the Parallelogram tool. To create a parallelogram, 
you need to follow the steps given next:

1.	 Invoke the Parallelogram tool from the Rectangle drop-down available in the Sketching 
group; you will be prompted to define the start point of the first side of parallelogram. 
Click to specify the start point; an orange rubber-band line will be displayed with the cursor 
attached to the end point of the line.

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om



Creating Sketches in the Sketch Mode-I             				           2-9

2.	 Click at any desired point to draw the first side of parallelogram; an orange rubber-band 
box will be displayed with the cursor attached to the end point of the second side of the 
parallelogram. Also, you will be prompted to specify the end point of the second line.

3.	 Click at any desired point to create the parallelogram.	

Drawing a Circle
In Creo Parametric, you can draw circles by using the Center and Point, Concentric, 3 Point, 
and 3 Tangent tools. These tools are available in the Circle drop-down of the Sketching group. 
The procedure to create a circle using these tools is discussed next.

Drawing a Circle Using the Center and Point Tool
  Ribbon:  Sketch > Sketching > Circle drop-down > Center and Point  

The Center and Point tool is used to draw a circle by specifying the center of the circle 
and a point on its circumference. The following steps explain the procedure to draw a 
circle using this tool.  

1.	 Choose the Center and Point tool; you will be prompted to select the center of the circle.

2.	 Click in the drawing area to specify the center point of the circle; you will be prompted to 
select a point on the circumference of the circle. Also, an orange rubber-band circle will be 
displayed with the center at the specified point and the cursor attached to its circumference.

3.	 Move the cursor to specify the size of circle. Click at a desired point to complete the creation 
of the circle; you will be prompted again to select the center of the circle. 

4.	 Repeat steps 2 and 3 if you want to draw more circles, else press the middle mouse button 
to abort the process.

Drawing a Circle Using the Concentric Tool
  Ribbon:  Sketch > Sketching > Circle drop-down > Concentric  

The following steps explain the procedure to draw a concentric circle using the 
Concentric tool:

1.   Choose the Concentric tool from the Circle drop-down in the Sketching group; you will 
be prompted to select an arc to determine the center. You can select any arc or a circle to 
specify the center point.

2.	 Click on an arc or a circle to determine the concentricity of the circle to be drawn. Move 
the cursor and click at the required location to specify the size of circle.

3.	 To finish the creation of the circle, press the middle mouse button.
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Drawing a Circle Using the 3 Point Tool

  Ribbon:  Sketch > Sketching > Circle drop-down > 3 Point  

The following steps explain the procedure to draw a circle using the 3 Point tool:

1.	 Choose the 3 Point tool from the Circle drop-down; you will be prompted to specify the 
first point on the circle.

2.	 Click to specify the first point at the desired location in the drawing area; you will be 
prompted to select the second point on the circle. Move the cursor and click to specify the 
second point in the drawing area.

3.	 As you select the second point, an orange rubber-band circle appears with the cursor attached 
to it and you are prompted to select the third point. Move the mouse to size the circle and 
click to specify the third point; a circle is drawn and you are prompted again to select the 
first point on the circle to draw the next circle.

4.	 To abort the process of circle creation, you can press the middle mouse button at any stage.

Drawing a Circle Using the 3 Tangent Tool
  Ribbon:  Sketch > Sketching > Circle drop-down > 3 Tangent  

The 3 Tangent tool is used to draw a circle tangent to three existing entities. This tool 
references other entities to draw a circle. The circle created using this tool 

is drawn irrespective of the points selected on the entities. The following steps explain the 
procedure to draw a circle using the 3 Tangent tool:

1.	 Choose the 3 Tangent tool from the Circle drop-down; you will be prompted to select the 
start location on an arc, circle, or line.

2.	 Select the first entity; the color of the entity changes to green and you will be prompted to 
select the end location on an arc, circle, or line. Select the second tangent entity; you will 
be prompted to select the third location on an arc, circle, or line. Select the third tangent 
entity; a circle tangent to these three entities is drawn. 

3.	 To end the process of circle creation, press the middle mouse button.

Drawing an Ellipse
You can draw an ellipse by using the tools available in the Ellipse drop-down. The tools available 
in this drop-down are Axis Ends Ellipse and Center and Axis Ellipse. The steps to draw ellipse 
using these tools are discussed next.

Drawing an Ellipse Using the Axis Ends Ellipse Tool
  Ribbon:  Sketch > Sketching > Ellipse drop-down > Axis Ends Ellipse  

The following steps explain the procedure to draw an ellipse by using the Axis Ends 
Ellipse tool:
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1.	 Choose the Axis Ends Ellipse tool from the Ellipse drop-down; you will be prompted to 
select the start point of the major axis of the ellipse.

2.	 Click in the drawing area to specify the start point of the major axis; you will be prompted 
to select the endpoint of the major axis. 

3.	 Click in the drawing area to specify the endpoint; an orange rubber-band ellipse will appear 
with the cursor attached to it. Also, you will be prompted to select a point on the minor axis 
to define the ellipse.

4.	 Click to specify the point; an ellipse will be created. You can press the middle mouse button 
to end the creation of the ellipse.

Drawing an Ellipse Using the Center and Axis Ellipse Tool

  Ribbon:  Sketch > Sketching > Ellipse drop-down > Center and Axis Ellipse  

The following steps explain the procedure to draw an ellipse by using the Center and Axis 
Ellipse tool:

1.	 Choose the Center and Axis Ellipse tool from the Ellipse drop-down; you will be prompted 
to specify the center of the ellipse.

2.	 Click at the desired location in the drawing area to specify the center point; you will be 
prompted to select the endpoint of the major axis of the ellipse. Click in the drawing area 
to specify the point; an orange rubber-band ellipse will appear with the cursor attached to 
the ellipse. Move the cursor in the drawing area to size the ellipse.

3.	 Specify the endpoint on the minor axis of the ellipse; the ellipse is drawn. After exiting the 
command, the dimensions for the major radius and the minor radius will be displayed in 
light blue color. The light blue color indicates that the dimensions are weak.

Drawing an Arc
Creo Parametric provides five tools to draw an arc. These tools can be invoked from the Arc 
drop-down in the Sketching group. The procedures to draw arcs using these tools are discussed 
next.

Drawing an Arc Using the 3-Point / Tangent End Tool
  Ribbon:  Sketch > Sketching > Arc drop-down > 3-Point / Tangent End  

The 3-Point / Tangent End tool is used to draw arcs that are tangent from the endpoint 
of an existing entity, or by defining three points in the drawing area.

When you choose this tool to draw an arc from an endpoint, the Target symbol is displayed as 
you select an endpoint. The Target symbol is a green colored circle that is divided into four 
quadrants. The following steps explain the procedure to draw an arc from the endpoint of an 
existing entity by using this tool:
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1.	 Choose the 3-Point / Tangent End tool from the Arc drop-down; you will be prompted to 
select the start point of the arc.

2.	 Specify three points in the drawing area to draw an arc. If you want to draw an arc from the 
endpoint of an existing entity, select the endpoint of that entity. As you select the endpoint, 
the Target symbol appears at the endpoint of the entity. Move the cursor along the tangent 
direction through a small distance, a rubber-band arc appears with one end attached to the 
endpoint of the entity and the other end attached to the cursor. Note that when you move the 
cursor out of the Target symbol perpendicular to the endpoint, an arc is drawn by specifying 
three points. In this case, the rubber-band arc does not appear, refer to Figure 2-3.

	 On the other hand, if you move the cursor out horizontally from one of the quadrants of 
the Target symbol, an arc is drawn tangent to the endpoint, as shown in Figure 2-4.

3.	 Move the cursor to the desired position in the drawing area to size the arc. Use the left 
mouse button to complete the arc.

Figure 2-3 Cursor moved out of the Target 
symbol perpendicular to the endpoint

Figure 2-4 Cursor moved out of the Target 
symbol along the tangent direction 

Tip
If you do not want to draw a tangent arc, move the cursor out of the Target symbol perpendicular 
to the endpoint.

Drawing an Arc Using the Center and Ends Tool
  Ribbon:  Sketch > Sketching > Arc drop-down > Center and Ends  

The following steps explain the procedure to draw an arc using the Center and Ends tool:

1.	 Choose the Center and Ends tool from the Arc drop-down; you will be prompted to select 
the center of the arc.

2. 	 Click to specify a center point for the arc in the drawing area; a violet colored center mark 
will appear at that point and you will be prompted to select the start point of the arc. As 
you move the cursor, a dotted circle appears attached to the cursor.

3.	 Specify the start point of the arc on the circumference of the dotted circle; an orange 
rubber-band arc will appear from the start point. The length of the arc will change 
dynamically as you move the cursor and you will be prompted to select the endpoint of the 
arc.
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4.	 Move the cursor to specify the arc length and then click to select the endpoint of the arc; 
an arc will be drawn between the two specified points.

Note
You can draw only one arc with one center. If you want to draw another arc, you will have to 
select the center again. 
 

Drawing an Arc Using the 3 Tangent Tool
  Ribbon:  Sketch > Sketching > Arc drop-down > 3 Tangent  

The 3 Tangent tool is used to draw an arc that is tangent to three selected entities. The 
following steps explain the procedure to draw an arc using this tool:

1.	 Choose the 3 Tangent tool from the Arc drop-down; you will be prompted to select the start 
location on an arc, circle, or line.

2.	 As you move the cursor on the first entity or select the first entity, the color of the entity 
gets changed to green and you are prompted to select the end location on an arc, circle, or 
line.

3.	 On selecting the end location, you will be prompted to select a third location on an arc, 
circle, or line. Select the third entity; an arc is drawn tangent to the three selected entities.

You can continue drawing arcs or press the middle mouse button to abort arc creation.

Drawing an Arc Using the Concentric Tool
  Ribbon:  Sketch > Sketching > Arc drop-down > Concentric  

The Concentric tool is used to draw an arc concentric to an existing arc. The entity selected 
must be an arc or a circle. The following steps explain the procedure to draw an arc using 
this tool:

1.	 Choose the Concentric tool from the Arc drop-down; you will be prompted to select an arc 
to determine the center of the arc to be created. 

2.	 On moving the cursor on the first entity or selecting the entity a dotted circle will appear 
on the screen and you will be prompted to select the start point of the arc. Click to specify 
the start point; an orange rubber-band arc will appear with one end attached to the start 
point. As you move the cursor, the length of the arc will change and you will be prompted 
to select the endpoint of the arc.

3.	 Click to specify the endpoint; the arc will be created. 

You can continue drawing another arc or end the arc creation by pressing the middle mouse 
button.
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Drawing an Arc Using the Conic Tool
  Ribbon:  Sketch > Sketching > Arc drop-down > Conic  

The Conic tool is used to draw a conic arc. The following steps explain the procedure to 
draw a conic arc using this tool:

1.	 Choose the Conic tool from the Arc drop-down; you will be prompted to specify the start 
point of the conic entity.

2.	 Click to specify the start point in the drawing area; you will be prompted to specify the 
endpoint of the conic entity.

3.	 Click to specify the endpoint; a centerline will be drawn between the two points and you 
will be prompted to specify the shoulder point of the conic. Specify a point on the screen; 
the conic arc will be drawn.

Note
1. If the conic arc is the only entity in the drawing area, then you cannot delete its centerline.

2. If you delete the centerline of the conic arc, the arc will not be deleted.

Drawing Construction Geometries
  Ribbon:  Sketch > Sketching > Construction Mode  

Construction geometries are used to reference the solid geometries in sketches. 
Construction geometries can be dimensioned and constrained in the same manner as 

solid geometries. In Creo Parametric, the Construction Mode tool is used to toggle between 
the mode of creating solid geometry and construction geometry. When the Construction Mode 
is activated, any new geometry will be created as construction geometry. Note that you can also 
convert any solid sketched geometry entity into construction geometry and vice versa. To do so, 
select any sketched geometry and choose the Construction button from the mini toolbar. 

DIMENSIONING THE SKETCH			                
The basic purpose of dimensioning is to locate and control the size of geometric entities with 
some reference. Dimensions are created to capture the design intent because these dimensions 
are displayed when you edit the model and when you create drawings of the model. 

In Creo Parametric, sketched entities are dimensioned and

Figure 2-5 The Dimension 
group

constrained automatically while sketching. However, you need to 
add some additional dimensions and constraints to the sketch to 
make it fully constrained. The dimensioning tools are available in 
the Dimension group of the Sketch tab, refer to Figure 2-5. The 
Dimension tool in this group is used to manually dimension the 
entities. 
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Note
If you do not want the weak dimensions to be applied automatically, then clear the Show weak 
dimensions check box from File > Options > Sketcher > Object display settings.
 

Converting a Weak Dimension into a Strong Dimension
As discussed earlier when you draw a sketch, some weak dimensions are automatically applied 
to the sketch. These dimensions are displayed in light blue color. As you proceed to manually 
dimension the sketch, these weak dimensions are automatically deleted without any confirmation.

When you select a weak dimension from the drawing area the selected

Figure 2-6 The Strong 
option in the dimension 
mini popup toolbar

 
dimension will be highlighted in green color and a mini popup toolbar 
will be displayed near the selected dimension. From the mini popup 
toolbar, choose the Strong option, as shown in Figure 2-6, and press 
the middle mouse button; the select dimension will be converted into 
strong dimension. Alternatively, press CTRL+T to convert the selected 
dimension into a strong dimension. Note that a strong dimension is 
displayed in violet color. 

Dimensioning a Sketch Using the Dimension Tool
  Ribbon:  Sketch > Dimension > Dimension  

The Dimension tool in the Dimension group of the Sketch tab is used for dimensioning 
the sketched entities, refer to Figure 2-5. The following steps explain the procedure to 
dimension a sketch using this option:

1.	 Choose the Dimension tool from the Dimension group. Click on the entity you want to 
dimension; the color of the entity changes from orange to green.

2.	 Move the cursor and place the dimension at a desired place by double-clicking the middle 
mouse button. Before placing the dimension, you can change its value by clicking MMB 
once and then specifying the value.

Note that you can also change the dimension value using the Modify option that will be discussed 
later in this chapter. 

Tip 
You can also manually dimension the entities by using the dimensioning options available in 
the mini popup toolbar which appears when you select one or more sketched geometries.

Dimensioning the Sketched Entities
To dimension the sketched entities, you need to choose the Dimension tool from the Dimension 
group of the Sketch tab and follow the procedures given below.

Linear Dimensioning of a Line
You can dimension a line by selecting its endpoints or by selecting the line itself. After selecting 
the two endpoints or the line, press the middle mouse button twice to place the dimension at 
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desired location. If the line is inclined and you select the two endpoints to dimension, then the 
location where you press the middle mouse button defines the orientation of the dimension 
that will be displayed on the screen.

Figure 2-7 shows the three possible orientations of dimension that can be displayed when you 
dimension a line.

Note
It is not possible to dimension a line in three orientations simultaneously in the sketcher environment. 
The dimensions in Figure 2-7 are shown for explanation purpose only.

Figure 2-7 Approximate locations of the cursor to achieve different dimensions 
between the end points of a line

Dimensioning of an Arc
An arc is dimensioned by specifying the arc length or arc angle. To add angular dimension 
to an arc, select one end, centre point, and then select the other end of the arc. Next, place 
the dimension at the desired point by pressing the middle mouse button twice, as shown in 
Figure 2-8. If you select both ends of an arc and then select the arc itself, the dimension placed 
will be length of the arc, as shown in Figure 2-9. If you want to convert the angular dimension 
into arc length and vice versa, then select the dimension and choose the Angle or Length option 
from the mini popup toolbar.
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Figure 2-8 Angular dimension of an arc Figure 2-9 Dimensioning of arc length

Dimensioning of a Conical Arc
A conic is dimensioned by specifying its rho value that represents its conical sections. The rho 
value varies from 0 to 1. If the value is less than 0.5, the section will be elliptical; if rho value is 
0.5, the section will be parabola; and if rho is greater than 0.5, the section will be hyperbola. To 
add rho dimension to a conical arc, select the conical arc. Next place the dimension at desired 
point by pressing the middle mouse button twice, as shown in Figure 2-10.

Figure 2-10 Conical dimensioning

Note that in Creo Parametric, you can enter the dimension value for a conical section varies 
from 0.05 to 0.95.
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Diameter Dimensioning
For diameter dimensioning, click on a circle. Then place the dimension at the desired location by 
pressing the middle mouse button twice. The diameter dimension will be displayed, as shown in 
Figure 2-11. Alternatively, you can also click on the circle and choose the Diameter option from 
the mini toolbar, as shown in Figure 2-12. This method can also be used for dimensioning arcs.

Figure 2-11 Diameter dimensioning Figure 2-12 Dimensioning using the Diameter option 
of the mini toolbar

Radial Dimensioning
For radial dimensioning, click on the arc once. Then, place the dimension at the desired location 
by pressing the middle mouse button twice. The radial dimension will be displayed, as shown 
in Figure 2-13. 

Dimensioning of Revolved Sections
Revolved sections are used to create revolved features such as flanges, couplings, and so on. To 
dimension a revolved section, click on the entity to be dimensioned. Next, select the centerline 
about which you want the section to be revolved and again, select the original entity that you want 
to dimension. Now, place the dimension at the desired location by pressing the middle mouse 
button twice. Figure 2-14 shows the dimension placed in a revolved section. This dimension 
represents the diameter of a revolved section.

Figure 2-13 Radial dimensioning Figure 2-14 Dimensioning the revolved sections
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Angular Dimensioning
To specify angular dimensions, you need to select two lines and then place the dimension at the 
desired location in the drawing area by pressing the middle mouse button twice. Note that the 
location where you press the middle mouse button specifies the outer or inner angle between 
the lines.

WORKING WITH CONSTRAINTS
Constraints are rules that are enforced on the sketched geometries. In other words, constraints 
are the logical operations that are performed on the selected geometries to fully define their 
size, shape, orientation, and location with respect to other geometries. One of the key benefits 
of using constraints in a sketch is that it reduces the number of dimensions that are required to 
fully constraint that sketch.

Creo Parametric automatically applies some constraints to geometries while sketching. For 
example, if you are creating a line which is nearly parallel to another line, Creo Parametric will 
automatically place and highlight the parallel constraint symbol on the line being created. If 
you confirm the line creation, a line will be drawn parallel to the other line. Alternatively, you 
can also apply constraints manually. The procedure to do so is discussed next.

Types of Constraints
There are two types of constraints in Creo Parametric: Geometry and Assembly. In this chapter, 
you will learn about the Geometry constraints only and the Assembly constraints will be discussed 
in later chapters.

The geometric constraints are available in the Constrain group of the Sketch tab. The tools 
available in this group are shown in Figure 2-15.

Figure 2-15 The constraints in the Constrain 
group

Note
In Creo Parametric, the name of tools in several workbenches is displayed only in high screen 
resolution systems, such as 1900*1200 and 2880x1800. If the resolution is low, then only symbols 
are displayed.

The constraints in this group are used to apply constraints manually. Although, some 
constraints are applied automatically as you draw the sketch. You can use the tools in this 
group to manually apply additional constraints to the sketch. The constraints in the group are 
discussed next.
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Vertical
This constraint forces the selected line segment to become a vertical line. This constraint 
also forces the two vertices to be placed along a vertical line.

Horizontal
This constraint forces the selected line segment or two vertices that are apart by some 
distance to become horizontal or to lie in a horizontal line.

Perpendicular
This constraint forces the selected entity to become normal to another selected entity.
 

Tangent
This constraint forces the two selected entities to become tangent to each other. 

Mid-point
This constraint forces a selected point or vertex to lie on the middle of a line.
 

Coincident
This constraint can be used to force the two selected points to become coincident. You can 
also apply this constraint to make two selected entities collinear, so that they lie on the 
same line.

Symmetric
This constraint makes a section symmetrical about the centerline. When you select this 
constraint, you will be prompted to select a centerline and two vertices to make them 
symmetrical.

Equal
This constraint forces any two selected entities to become equal in dimension. When you 
select this constraint, you will be prompted to select two lines to make their lengths equal, 
or you will be prompted to select two arcs, circles, or ellipses to make their radii equal. 

Parallel
This constraint is used to force two lines to become parallel. When selected, this constraint 
prompts you to select two entities that you want to make parallel. 

Disabling the Constraints
The need to disable a constraint arises while drawing an entity. For example, consider a case 
where you want to draw a circle at some distance apart from another circle. While drawing it, 
the system tends to apply the equal radius constraint when the sizes of the two circles become 
equal. At this moment, if you do not want to apply the equal radius constraint, right-click twice 
to disable the equal radius constraint; a cross  will appear with the constraint notifying that 
the constraint is disabled. However, if you right-click once, the constraint will get locked and a 
lock symbol  will appear with the constraint. 
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Tip 
You can also press and hold the SHIFT key to disable the snapping of new constraint during 
sketching. If there are more than one snapping constraints while sketching, you can use the 
TAB key to toggle between the constraints.

MODIFYING THE DIMENSIONS OF A SKETCH
There are three ways to modify the dimensions of a sketch. These methods are discussed next.

Using the Modify Tool
  Ribbon:  Sketch > Editing > Modify  

You can select one or more dimensions from the sketch to modify them. When you select 
dimension(s) from a sketch, they are highlighted in green. If you want to select more than 

one dimension, hold the CTRL key and select the dimensions by clicking on them. You can also 
use the CTRL+ALT+A keys or define a window to select all dimensions in the sketch. After 
selecting the dimension(s), choose the Modify tool from the Editing group; the Modify 
Dimensions dialog box will be displayed, as shown in Figure 2-16. 

To modify dimensions by using the Modify Dimensions dialog box, you can either enter a value 
in the edit box or use the thumbwheel available on the right of the edit box. The Sensitivity 
slider is used to set the sensitivity of the thumbwheel.

By default, the Regenerate check box is selected. As a result, any modifications in the dimensions 
are automatically updated in the sketch. If you want to modify the dimensions of the sketch 
without regenerating the sketch, you need to clear this check box. If this check box is cleared, the 
dimensions will not be modified until you exit this dialog box. This means that Creo Parametric 
allows you to make multiple modifications before updating the sketch.

Figure 2-16 The Modify Dimensions dialog box

The Lock Scale check box is used to lock the scale of the selected dimensions. After locking the 
scale, if you modify any dimension, all other dimensions will also be modified by the same scale.
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Tip 
If you need to modify more than one dimension or when the dimensions you specify vary 
drastically with the original ones, it is recommended that you clear the Regenerate check box 
and then modify the dimensions.

Modifying a Dimension by Double-Clicking
You can also modify a dimension by double-clicking on it. When you double-click on a dimension, 
the pop-up text field appears. Enter a new dimension value in this field and press ENTER or 
use the middle mouse button. Remember that you can select a dimension only when you choose 
the One-by-One selection filter.

Modifying Dimensions Dynamically 
In the sketcher environment, Creo Parametric is always in the selection mode, unless you have 
invoked some other tool. When you bring the cursor to an entity, the color of the entity changes 
to green. Now, if you hold down the left mouse button, you can modify the entity by dragging the 
mouse. You will notice that as the entity is modified, the dimensions referenced to the selected 
entity are also modified.

Tip 
In Creo Parametric, you can modify the dimensions by using the mini popup toolbar which 
appears when you select any dimension(s) or entity(s). 

LOCKING DIMENSIONS AND ENTITIES
By locking of dimensions and entities, you can avoid modifications made to the sketches by 
accidentally dragging a vertex or an entity. In the locked state, the dimension(s) or entity(-ies) 
remains unchanged when you quit or re-enter the Sketch mode. To lock or unlock dimension(s) 
or entity(-ies), select dimension(s) or entity(-ies) and choose the Toggle Lock option from the 
mini popup toolbar; the dimension(s) or entity(-ies) will be locked. The locked dimension is 
highlighted in red color. You can also set the Sketch mode to lock all user-defined dimensions 
automatically by selecting the Lock user defined dimensions check box in the Sketcher tab 
of the Creo Parametric Options dialog box. After setting this option, all dimensions that you 
subsequently create or modify will be locked automatically. 

RESOLVE SKETCH DIALOG BOX
While applying constraints or dimensions, sometimes the system may prompt you to delete 
one or more highlighted dimensions or constraints. This is because while adding dimensions 
or constraints, some strong dimensions or constraints conflict with the existing dimensions 
or constraints. As the conflict occurs, the Resolve Sketch dialog box is displayed, as shown in 
Figure 2-17. When you select a dimension or a constraint from the Resolve Sketch dialog box, 
the corresponding dimension or constraint in the drawing area is enclosed in a blue box.
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Figure 2-17 The Resolve Sketch dialog box

 

The buttons in the Resolve Sketch dialog box are discussed next.

Undo
When you choose the Undo button, the section is brought back to the state that it was in just 
before the conflict occurred.

Delete
The Delete button is used to delete a selected dimension or constraint that is enclosed within 
the blue box. To delete a dimension or a constraint, select it from the blue box and choose the 
Delete button from the Resolve Sketch dialog box.

Dim > Ref
On choosing the Dim > Ref button, the selected dimension is converted to a reference dimension.

Note
The reference dimensions are used only for reference and are not considered in feature creation.

Explain
When you choose the Explain button, the system provides you with the information about the 
selected constraint or dimension. The information will be displayed in the message area. 

DELETING THE SKETCHED ENTITIES
To delete one or more sketched entities, select entities and hold down the right mouse button in 
the drawing area to invoke a shortcut menu. Next, choose the Delete option from this menu to 
delete the selected item. You can also delete multiple items by specifying a window. To specify 
a window, press and hold the left mouse button and drag the cursor to the opposite corner in 
the drawing area. The entities that are enclosed inside the window will get selected and the 
color of the selected entities changes to green. After selecting the entities, hold down the right 
mouse button in the drawing area to invoke a shortcut menu and choose the Delete option to 
delete the selected item.
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You can also delete one or more than one items from the drawing area by using the DELETE 
key. To do so, press and hold the CTRL key and click on the entities to be deleted. Next, press 
the DELETE key to delete the selected entities. Alternatively, you can specify a window around 
the selected entities and then press the DELETE key to delete entities. 

Note
It is necessary to be in the selection mode while selecting the items. The term “items” used in this 
chapter refers to dimensions and entities. The Sketcher Geometry, Dimension, and Constraint 
filters are available in the drop-down list located in the Status Bar. These filters narrow down 
your search and help you to select the exact item. This means if you want to select all constraints 
in the sketch, choose the Constraint filter and specify a window to select. You will notice that only 
the constraints are selected in the sketch.

TRIMMING THE SKETCHED ENTITIES
While creating a design, there are a number of places where you need to remove the unwanted 
and extended entities. You can do this by using the trimming tools that are available in the 
Editing group. These tools are discussed next.

Delete Segment
  Ribbon:  Sketch > Editing > Delete Segment  

This tool is used to trim the entities that extend beyond the point of intersection. You can 
also use this tool to delete the selected entities. To trim or delete any entity, choose the 

Delete Segment tool from the Editing group and click on the entity to be trimmed or deleted. 
With the help of this tool, you can also trim and delete the entities dynamically. To do so, press 
and hold the left mouse button and move the cursor over the entities to be trimmed or deleted, 
refer to Figure 2-18 and Figure 2-19. 

Figure 2-18 Trimming the entities dynamically Figure 2-19 The resulting sketch
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Corner
  Ribbon:  Sketch > Editing > Corner  

The Corner tool is used to trim two entities at the corners. Note that when you trim entities 
using this option, the portion from where you select the entities is retained and the other 

portion is trimmed. The following steps explain the procedure to trim entities using this button:

1.	 Choose the Corner tool from the Editing group; you will be prompted to select two entities 
to be trimmed. 

2.	 Click to select the two entities on the sides that you want to keep after trimming, refer to 
Figure 2-20. These two entities must be intersecting entities. The entities are trimmed from 
the point of intersection.

Figure 2-20 Trimming the lines by using the Corner tool

Divide
 Ribbon:  Sketch > Editing > Divide  

The Divide tool is used to divide an entity into a number of parts by specifying points on 
the selected entity.  

 
The following steps explain the procedure to divide an entity:

1.	 Choose the Divide tool from the Editing group; you will be prompted to specify a point on 
an entity.

2.	 Select a point on an entity to divide it. The divided entities can now be treated as two separate 
entities. Similarly, you can break other entities like circles or arcs into several small entities.

MIRRORING THE SKETCHED ENTITIES
  Ribbon:  Sketch > Editing > Mirror  

The Mirror tool is used to mirror the sketched geometries about a centerline. This tool 
helps you to reduce the time utilized in creating symmetrical geometries and dimensions. 
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The procedure to mirror the sketched geometry is explained next:

1.	 Sketch a geometry and then sketch a centerline about which you need to mirror the geometry.

2.	 Select the entities that you need to mirror; the selected entities turn green in color.

3.	 Choose the Mirror tool from the Editing group; you will be prompted to select the 
centerline about which you need to mirror. Select the centerline; the selected entities will 
be mirrored about the centerline.

Tip 
In case of symmetrical parts, you can save time involved in dimensioning and constraining a 
sketch by dimensioning half of the section and then mirroring it. Creo Parametric will assume 
that the mirrored half has the same dimensions and constraints as the sketched half.

INSERTING STANDARD/USER-DEFINED SKETCHES
  Ribbon:  Sketch > Sketching > Palette     

The Palette enables you to quickly insert commonly used basic shapes, such as polygons, 
profiles, shapes, stars, and other previously created sketches in the Sketch mode, thus 
minimizing the time for repetitive sketching.

The steps that explain the procedure to insert a 

Figure 2-21 The Sketcher Palette dialog 
box

foreign entity in the Sketch mode are given next.

1.	 Choose the Palette tool from the Sketching 
group; the Sketcher Palette dialog box will be 
displayed, as shown in Figure 2-21. The options 
in this dialog box are used to insert a previously 
created sketch.

2.	 To insert a sketch from the sketcher palette 
in the current sketch, drag and drop it, or 
double-click on the required sketch from the 
list in the dialog box. Next, click anywhere in 
the drawing area; the Import Section tab will 
be displayed in the Ribbon. Also, the move , 
rotate , and scale  handles will be displayed 
on the imported sketch automatically. 

3.	 In the Import Section tab, enter the scale value in 
the Scale edit box and the rotational angle value 
in the Rotate edit box. Alternatively, left-click on 
the required handle on the sketch and drag; the 
corresponding action will take place dynamically. The move handle also acts as the pivot 
point for rotation and scale. However, you can relocate the pivot point. To move the pivot 
point, right-click on the pivot point and drag it to the required location and then release 
the right-click; the pivot point will be relocated. 
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4.	 Next, choose the OK button to exit.

5.	 Choose the Close button from the Sketcher Palette dialog box to accept the sketch inserted. 
Else, repeat the steps 2 - 4 to continue inserting more sketches in the drawing area.

	 Similarly, you can add the sketches from the Polygons, Profiles, Shapes, and Stars tabs.

Note
If you have selected a working directory which contains only .sec files, a tab with the name of 
the working directory is displayed in the Sketcher Palette dialog box and also will be chosen by 
default. On the other hand, if you have selected a working directory which contains other types 
of files, the same tab will be displayed in the end and the Polygons tab will be chosen by default, 
refer to Figure 2-21.

DRAWING DISPLAY OPTIONS
While working with complex sketches, sometimes you need to increase the display of a particular 
portion of a sketch so that you can work on the minute details of the sketch. For example, you 
are drawing sketch of a piston and you have to work on the minute details of the grooves for the 
piston rings. To work on these minute details, you have to enlarge the display of these grooves. 
You can enlarge or reduce the drawing display using various drawing display tools provided in 
Creo Parametric. These tools are available in the Graphics toolbar as well as in the View tab. 
Some of these drawing display options are discussed next, and the remaining drawing display 
options will be discussed in later chapters.

Zoom In
  Ribbon:  View > Orientation > Zoom In  

This tool is used to enlarge the view of the drawing on the screen. After choosing the Zoom 
In tool from the Orientation group, you will be prompted to define a box. The area that 

you will enclose inside the box will be enlarged and displayed in the drawing area. Note that 
when you enlarge the view of the drawing, the original size of the entities will not be changed. 
To exit the Zoom In tool, right-click in the drawing area.

Zoom Out
  Ribbon:  View > Orientation > Zoom Out  

This tool is used to reduce the view of the drawing on the screen, thus increasing the 
drawing display area. Each time you choose this button, the display of the sketch in the 
drawing area is reduced. This button is available in the Orientation group.

Tip
You can use the mouse scroll wheel to zoom in and out the view. One more method to zoom in 
and out is to use the middle mouse button and the CTRL key. To zoom in and zoom out, press 
and hold CTRL+middle mouse button and drag the mouse downward and upward.

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om



2-28	   			                    	          Creo Parametric 8.0 for Designers

Refit
  Ribbon:  View > Orientation > Refit  

This tool is available in the Orientation group. This tool is used to reduce or enlarge the 
display such that all entities that comprise the sketch are fitted inside the current display. 
Note that the dimensions may not be necessarily included in the current display.

Repaint
  Ribbon:  View > Display > Repaint  

While working with complex sketches, some unwanted temporary information is retained 
on the screen. The unwanted information may include the shadows of the deleted sketched 

entities, dimensions, and so on. This unwanted information can be removed from the drawing 
area by using the Repaint button available in the Display group or from the Graphics toolbar 
in model display. 

Sketcher Display Filters
While working with the sketches, sometimes you need to disable the display of some of the 
sketcher components such as dimensions, constraints, vertices, and so on. To disable or enable 
their display, you can use the toggle buttons available in the Graphics toolbar. These buttons 
are discussed next.

Dimensions Display
  Ribbon:  View > Display > Dimensions Display  

You can use this button to enable or disable the display of dimension on the screen.

Constraints Display
  Ribbon:  View > Display > Constraint Display  

You can use this button to enable or disable the display of geometric constraints.

Vertices Display
  Ribbon:  View > Display > Vertex Display  

You can use this button to enable or disable the display of vertices on a sketch or a model.

Grid Display
  Ribbon:  View > Display > Grid Display  

You can use this button to enable or disable the display of sketching grid. Sometimes you 
may not be able to see the grid as it becomes very dense. To see the grid in such cases, you 
need to zoom in the screen.
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Locks Display
  Ribbon:  View > Display > Locks Display  

You can use this button to enable or disable the display of locks on a sketch.

Note
1. To remove the temporary information, you can repaint the screen by choosing the Repaint tool 
from the Graphics toolbar or pressing the CTRL+R keys. 

2. In the Sketch mode, you can pan the sketch using the middle mouse button but in the Part 
mode, use SHIFT + middle mouse button to pan the model.

TUTORIALS
Tutorial 1

In this tutorial, you will draw the sketch for model shown in Figure 2-22. The sketch of the model 
is shown in Figure 2-23.						          (Expected time: 30 min)

Figure 2-22 Model for Tutorial 1 Figure 2-23 Sketch of the model

	 The following steps are required to complete this tutorial:

a.	 Start Creo Parametric session.
b.	 Set the working directory and create a new sketch file.
c.	 Draw lines by using the Line Chain tool.
d.	 Draw an arc and a circle.
e.	 Dimension the sketch and then modify the dimensions of the sketch.
f.	 Save the sketch and close the file.

Starting Creo Parametric
1.	 Start Creo Parametric by double-clicking on the Creo Parametric icon on the desktop of 

your computer.
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Setting the Working Directory
	 After the Creo Parametric session is started, the first task is to set the working directory. A 

working directory is a directory on your system where you can save the work done in the 
current session of Creo Parametric. You can set any existing directory on your system as the 
working directory. Since it is the first tutorial of this chapter, you need to create a folder 
with the name c02.

1.	 Choose the Select Working Directory option from the Manage Session flyout of the File 
menu; the Select Working Directory dialog box is displayed.   

2.	 In this dialog box, browse to C:\Creo_8.0 folder. If this folder does not exist, create this folder 
before setting the working directory.

      	For selecting C:\Creo_8.0, click on the arrow at the right of the C: option in the top address 
box of the Select Working Directory dialog box; the folders in the C drive are displayed 
in a flyout. Now, choose Creo_8.0 from the flyout, refer to Figure 2-24. Alternatively, you 
can use the Folder Tree node available at the bottom left corner of the screen to set the 
working directory. To do so, click on the Folder Tree node; the Folder Tree expands. In the 
Folder Tree, browse to the desired location using the

Figure 2-24 The Creo_8.0 folder chosen 
from the flyout

 
nodes corresponding to the folders. Select the 
required folder and choose the OK button; the 
selected folder will become the current working 
directory.

3.	 Choose the Organize button from the top pane 
of the Select Working Directory dialog box to 
display the flyout. From the flyout, choose the 
New Folder option; the New Folder dialog box 
is displayed.

4.	 Enter c02 in the New directory edit box and 
choose the OK button from the New Folder 
dialog box; a new folder named c02 is created at C:\Creo_8.0 location.

5.	 Choose the OK button from the Select Working Directory dialog box to set the working 
directory to C:\Creo_8.0\c02; the message Successfully changed to C:\Creo_8.0\c02 directory 
is displayed in the message area. 

Starting a New Object File 
	 Any sketch drawn in the Sketch mode is saved with the .sec file extension. This file format 

is one of the file formats available in Creo Parametric.

1.	 Choose the New button from the Data group in the Ribbon or Quick Access toolbar  
or press CTRL+N; the New dialog box is displayed. In this dialog box, select the 
Sketch radio button from the Type area; the default name of the sketch appears in 
the File name edit box.
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2.	 Enter c02tut01 in the File name edit box and choose the OK button.

     	 You are in the sketcher environment of the Sketch mode. When the Sketch mode is invoked, 
the Show Navigator is displayed on the left in the drawing area.

3.	 Choose the Show Navigator button available at the bottom left corner of the screen to  
close the Show Navigator. On closing the tree, the drawing area is increased.

Drawing the Lines of the Sketch
	 You need to start drawing the sketch with the right vertical line.

1.	 Choose the Line Chain tool from the Line drop-down available in the Sketching  
group.

2.	 Specify the start point by clicking on the right in the drawing area. One end of the line is 
attached to the cursor. Move the cursor down to an approximate length.

	 Notice that when the cursor moves vertically downward, a blue colored symbol  appears in 
the drawing area, next to the line. Now, if you draw a line, the vertical constraint will be 
applied to it. 

3.	 Click to specify the endpoint of the line. The vertical constraint is applied to the line, but 
it is not visible in the drawing area until the line creation is active.

	 Also, another rubber-band line is attached to the cursor with its start point at the endpoint 
of the last line.

4.	 Move the cursor horizontally toward the left; a horizontal rubber-band line extends to the 
left as you move the mouse.

	 Notice that when the cursor moves horizontally toward the left, a blue colored symbol  
appears in the drawing area next to the line. Now, if you draw a line, a horizontal constraint 
will be applied to it.

5.	 After getting the desired size of the line created, click to end the line. The horizontal 
constraint is applied to the line, but it is not visible in the drawing area until the line creation 
is active.

6.	 Move the cursor upward in the drawing area; a vertical rubber-band line extends as you 
move the mouse. As you move the cursor upward, you will notice that at a particular point 
where the length of the left vertical line is equal to the length of the right vertical line, a 

 symbol is displayed on the vertical line being created and the right line is highlighted 
in blue color. This symbol suggests that the equal length constraint is applied to the two 
vertical lines. 

7.	 When equal constraint appears on the vertical line, click to specify the endpoint of the 
vertical line. The rubber-band line is still attached to the cursor.
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	 You can also apply constraints later. However, to save an extra step of adding the constraints, 
you will use the constraints that are applied automatically while drawing.

8.	 Move the cursor to size the line and specify the endpoint of the left inclined line, as shown 
in Figure 2-25.

9.	 Press the middle mouse button to end the line creation.

10.	 The line option is still active. Move the cursor close to the top end of the right vertical line; 
the cursor snaps to the point that is at equal length of the left vertical line. Select the point 
by clicking.

11.	 Size the inclined line and specify the endpoint of the right inclined line. Press the middle 
mouse button twice; lines are created and all the constraints that you have applied become 
visible, refer to Figure 2-26. Now, you need to draw the arc and the circle.

Figure 2-25 Sketch with left inclined 
line

Figure 2-26 Sketch of the line 
drawn with weak dimensions

Note
1. The numbers in blue color with the constraint symbols refer to the label assigned to same type 
of constrained geometries in the sketch.

2. The horizontal  and equal constraint  appear in blue color when selected. The label with 
the constraint appears in blue color which indicates that the constraint is strong. This means you 
cannot change the orientation of the line until you delete the constraint applied to the line.

Drawing the Arc
1.	 Choose the 3-Point/Tangent End tool from the Arc drop-down in the Sketching group; you 

are prompted to select the start point of the arc.

2.	 Select the endpoint of the left inclined line; the Target symbol appears in green color.

3.	 Move the cursor along the tangent direction through a small distance; a rubber-band arc 
that is tangent to the inclined line appears. Move the cursor to the endpoint of the right 
inclined line and click on the end point of the right inclined line to create the arc. As you 
exit the Arc tool, the tangent constraint is applied to the end points of the arc which is 
indicated by the symbol . 
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Note
1. The weak dimensions in Figure 2-26 are not displayed in Figure 2-27 because after an arc is 
drawn, some of the weak dimensions automatically get deleted. 

2. If the tangent constraint symbol is not displayed on any of the inclined lines, apply the constraint 
manually by choosing the Tangent button from the Constrain group.

Drawing the Circle
1.	 Choose the Concentric tool from the Circle drop-down; you are prompted to select 

an arc.

2.	 Select the arc by clicking on it. Move the mouse; a circle appears.

3.	 Click to select a point inside the sketch to draw the circle.

4.	 Press the middle mouse button to end the circle creation. The sketch is completed.

Dimensioning the Sketch
	 The right vertical line, the bottom horizontal line, the arc, and the circle are dimensioned 

automatically and the weak dimensions are applied to them. You will use these dimensions. 
Hence, there is no need to dimension these entities again.

1.	 Choose the Dimension tool from the Dimension group. 

2.	 Select the center of the arc and then the bottom horizontal line; the center turns red and 
the line turns green in color.

3.	 Place the dimension on the right of the sketch by pressing the middle mouse button twice.

4.	 Select the center of the arc and then the left vertical line; the center turns red and the vertical 
line turns green in color.

5.	 Press the middle mouse button to place the dimension below the sketch, refer to Figure 2-28.

Figure 2-27 Sketch with arc Figure 2-28 Sketch with all the entities, weak 
dimensions, and weak constraints
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Modifying the Dimensions
	 The sketch is dimensioned with default values. You need to modify these values to the given 

values.

1.	 Select all dimensions by specifying a window around them.
 

Note
You can also use CTRL+ALT+A to select the entire sketch with dimensions.
 

2.	 When all dimensions turn green in color, choose the Modify tool from the Editing group; 
the Modify Dimensions dialog box is displayed.

	 All dimensions in the sketch are displayed in this dialog box. Each dimension has a separate 
thumbwheel and an edit box. You can use the thumbwheel or the edit box to modify the 
dimensions. It is recommended that you use the edit boxes to modify the dimensions, if 
the change in the dimension value is large.

3.	 Clear the Regenerate check box and then modify the values of the dimensions.

	 Once you clear this check box, any modification in a dimension value is not updated in the 
sketch. It is recommended that you clear the Regenerate check box when more than one 
dimension has to be modified.

	
	 Notice that the dimensions that you select in the Modify Dimensions dialog box get enclosed 

in a violet box in the drawing area. 

4.	 Modify all dimensions according to the dimensions shown in Figure 2-23. After modifying 
the dimensions, choose the OK button from the Modify Dimensions dialog box; the message 
Dimension modifications successfully completed is displayed in the message area.

Tip 
You can modify the location of the dimensions as they appear on the screen by selecting and 
dragging them to a new location.

The completed sketch is shown in Figure 2-29.

Saving the Sketch
	 Now, the sketch needs to be saved because you may need the sketch later in the Part mode 

to create a 3D model.

1.	 Choose the Save button from the Quick Access toolbar; the Save Object dialog box  
is displayed with the name of the sketch that you had entered earlier.

2.	 Choose the OK button; the sketch is saved.

3.	 After saving the sketch, choose the Close button from the Quick Access toolbar.  
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Figure 2-29 The complete sketch with dimensions and constraints 

Tutorial 2

In this tutorial, you will draw the sketch for the model shown in Figure 2-30. The sketch of 
the model is shown in Figure 2-31. For your reference, all entities in the sketch are labeled 
alphabetically.			       			       	       (Expected time: 30 min)

Figure 2-30 Model for Tutorial 2 Figure 2-31 Sketch of the model

	 The following steps are required to complete this tutorial:

a.	 Set the working directory and create a new sketch file.
b.	 Draw the sketch by using the Line Chain tool.
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c.	 Dimension the required entities and then modify the dimensions of the sketch.
d.	 Save the sketch and close the file.

Setting the Working Directory
	 The working directory was selected in Tutorial 1, therefore you need not to select the 

directory again. But, if a new session of Creo Parametric is started, you need to set the 
working directory again by following the steps given next.

1.	 Open the Navigator (if it is in collapsed state) by clicking on the Show Navigator button 
on the bottom left corner of the Creo Parametric main window; the Navigator slides out. At 
the bottom of the Navigator, the Folder Tree is displayed in the Folder Browser tab. Click 
on the Folder Tree; the Folder Tree expands.

2.	 Click on the arrow adjacent to the Creo_8.0 folder in the Navigator; the contents of the 
Creo_8.0 folder are displayed.

3.	 Now, right-click on the c02 folder to display a shortcut menu. From the shortcut menu, 
choose the Set Working Directory option; the working directory is set to c02.

4.	 Close the Navigator by clicking on the Show Navigator button located at the bottom left 
corner of the main window; the Navigator slides in.

Starting a New Object File 
1.	 Choose the New button from the Data group; the New dialog box is displayed. Select  

the Sketch radio button from the Type area of the New dialog box; the default name 
of the sketch appears in the File name edit box.

2.	 Enter c02tut02 in the File name edit box and choose the OK button; you are in the sketcher 
environment of the Sketch mode.

Drawing the Sketch
	 The sketch in Figure 2-31 consists of only lines. For ease of understanding, all lines in the 

sketch are labeled alphabetically.

1.	 Choose the Line Chain tool from the Line drop-down of the Sketching group. Select  
a point close to the lower right corner of the drawing area by clicking and start drawing 
the horizontal line A. You will notice that as you draw line A, the  symbol is displayed on 
the line. This indicates that the line is horizontally constrained. Move the cursor toward left 
and specify the endpoint of the line.

2.	 Move the cursor vertically upward so that the  constraint appears on the line. When you get 
the appropriate size of the line, click to specify the endpoint of line B; line B is completed.

3.	 Move the cursor to the right in the drawing area and click to specify the endpoint of line 
C.

4.	 Now, to draw line D, move the cursor down and click to specify the endpoint of line D.
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5.	 Move the cursor to size the line and click to specify the endpoint of the inclined line E. 

6.	 The next line you need to draw is line F. Move the cursor vertically downward and click to 
specify the endpoint of line F.

7.	 Now, to draw line G, move the cursor horizontally toward the right and click to specify the 
endpoint of line G.

8.	 Move the cursor vertically upward and click to specify the endpoint of line H.

9.	 Now, continue drawing the remaining lines that are shown in Figure 2-31. When the sketch 
is complete, end the line creation by pressing the middle mouse button twice. Notice that 
the sketched entities are dimensioned automatically as you draw them. These dimensions 
are weak dimensions and appear in light blue color.

Applying Constraints to the Sketch
	 Constraints are applied to the sketch to maintain the design intent of the feature and this 

might sometimes result in less dimensions in the sketch.

1.	 Choose the Equal tool from the Constrain group and select lines F and H. The equal
length constraint 1 is applied to both the lines. The constraint labels such as 1 or 2 
vary from sketch to sketch.

2.	 Now, select lines J and N; the equal length constraint is applied to both the lines. Press the 
middle button to make other selections.

3.	 Select lines C and K; the equal length constraint is applied to both the lines. Press the middle 
mouse button to make other selections.

4.	 Select lines A and B; the equal length constraint is applied to both the lines. Press the middle 
mouse button twice to exit.

5.	 Choose the Horizontal tool from the Constrain group; you are prompted to select a 
line or two points.

6.	 Select the vertex that is joining the lines L and M. Now, select the vertex that is joining the 
lines G and H. For the placement of lines, refer to Figure 2-31. Both the vertices are aligned 
horizontally, as shown in Figure 2-32.

7.	 Select the vertex that is joining lines C and D and the vertex that is joining lines J and K, 
refer to Figure 2-30. Both the vertices are aligned horizontally, refer to Figure 2-32.
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Figure 2-32 Vertices aligned horizontally

Dimensioning the Sketch
	 Weak dimensions have already been applied to the sketch while drawing. In this sketch, you 

need to dimension only the angle between lines D and E and lines J and I.

1.	 Choose the Dimension tool from the Dimension group. 	                 	        

2.	 Select lines D and E by using the left mouse button;

Figure 2-33 Sketch after applying dimensions

 
the selected lines turn green in color. Now, press 
the middle mouse button twice to place the 
dimension close to the vertex where lines D and 
E join.

3.	 Similarly, dimension the angle between lines J 
and I.

	 Figure 2-33 shows the sketch after applying 
dimensions. If your sketch does not have all 
dimensions shown in this figure, apply them 
by using the Dimension tool.

Modifying the Dimensions
	 The dimensions that are applied to the sketch 

need modification in dimension values.

1.	 Select all dimensions by specifying a window around them. 

2.	 When dimensions turn green in color, choose the Modify tool; the Modify Dimensions  
dialog box is displayed.

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om



Creating Sketches in the Sketch Mode-I             				           2-39

3.	 Clear the Regenerate check box and then modify the values of the dimensions. On clearing 
this check box, the sketch is not regenerated while you modify the dimensions.

	
	 Notice that the dimension that you select in the Modify Dimensions dialog box is enclosed 

in a violet box in the drawing area.

4.	 When all dimensions are modified, choose the OK button from the Modify Dimensions 
dialog box; the message Dimension modifications successfully completed is displayed in 
the message area. The completed sketch is shown in Figure 2-34.

Figure 2-34 Complete sketch with dimensions and constraints

5.	 Save the sketch as discussed earlier. Next, choose the Close button from the File menu to 
exit the Sketch mode.

Note
You can also modify dimensions individually. However, individual modification of dimensions 
is recommended only when there is a minor change in the dimension value or when only one 
dimension is required to be modified.

Tutorial 3
In this tutorial, you will draw the sketch of the model shown in Figure 2-35. The sketch of the 
model is shown in Figure 2-36. For your reference, all entities in the sketch are labeled 
alphabetically. Also, you have to print the sketch.			       (Expected time: 30 min)	
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Figure 2-35 Model for Tutorial 3 Figure 2-36 Sketch of the model

	 The following steps are required to complete this tutorial:

a.	 Set the working directory and create a new sketch file.
b.	 Draw the sketch by using the sketcher tools.
c.	 Dimension the sketch and then modify the dimensions of the sketch. 
d.	 Save the sketch and print it.

Setting the Working Directory
	 The working directory was selected in Tutorial 1, therefore, you do not need to select the 

working directory again. But if a new session of Creo Parametric is started, then you have 
to set the working directory again by following the steps given next.

1.	 Open the Navigator by sliding it out. In the Navigator, the Folder Tree is displayed at the 
bottom. Click on the black arrow available on the right of the Folder Tree; the Folder Tree 
expands. Click on the arrow adjacent to the Creo_8.0 folder in the Navigator; the contents 
of the Creo_8.0 folder are displayed.

2.	 Now, right-click on the c02 folder to display a shortcut menu. From the shortcut menu, 
choose the Set Working Directory option; the working directory is set to c02. Close the 
Navigator.

Starting a New Object File 
1.	 Choose the New button from the Data group; the New dialog box is displayed. Select

the Sketch radio button from the Type area of the New dialog box; the default name 
of the sketch appears in the File name edit box.

2.	 Enter c02tut03 in the File name edit box. Choose the OK button to enter the sketcher 
environment of the Sketch mode. 

Drawing the Circles
1.	 Choose the Center and Point tool from the Circle drop-down in the Sketching group  

and specify the center of the circle. 

2.	 Move the cursor to size the circle and then click to complete the circle.
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3.	 Draw another circle whose center is collinear with the center of the previous circle.

	 Figure 2-37 shows the two collinear circles drawn by using the Center and Point tool.

Drawing the Tangent Lines
1.	 Choose the Line Tangent tool from the Line drop-down in the Sketching group; you

are prompted to select the start location on the arc or the circle.

2.	 Select the left circle at the top; a rubber-band line appears whose one end is attached to the 
circle and the other end is attached to the cursor.

3.	 Click on the top of the right circle; a tangent connecting the two circles is drawn.

4.	 Similarly, draw a tangent by selecting the two circles at the bottom.

	 Figure 2-38 shows the sketch after drawing the tangent lines.

Figure 2-37 Two collinear circles drawn 
using the Centre and Point tool

Figure 2-38 Circles joined by tangent 
lines

Trimming the Circles
	 As evident from Figure 2-37, the tangents that are drawn intersect the circles at the point 

where they meet the circle. Therefore, the part of the circle that is not required can be 
dynamically trimmed.

1.	 Choose the Delete Segment tool from the Editing group. 

2.	 Select the two circles individually to trim them at the locations shown in Figure 2-39.

	 Figure 2-40 shows the two circles after deleting the unwanted portions of the circle.

Figure 2-39 Locations to trim Figure 2-40 Sketch after trimming
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Drawing the Circles
1.	 Choose the down arrow on the right of the Center and Point tool to display the flyout.  

Choose the Concentric tool from the flyout; you are prompted to select an arc. 

2.	 Select the left arc and create a circle concentric to the arc. Similarly, select the right arc to 
create a concentric circle (refer to Figure 2-36).

	 Notice that the radius dimension is applied to the two arcs, whereas the diameter dimension 
is applied to the circles. It is so because the arcs are applied with radius dimension and 
circles are applied with diameter dimension by default.

Dimensioning the Sketch
	 In order to fully define a sketch, you need to dimension it.
  
1.	 Choose the Dimension tool. 						               

2.	 Select the centers of the two circles and place the dimension at the bottom of the sketch.

Modifying the Dimensions
1.	 Select all dimensions by defining a window.						    

Note
You can also use CTRL+ALT+A from the keyboard to select all entities and items in the sketch. 

2.	 When all dimensions turn green in color, choose the Modify tool; the Modify  
Dimensions dialog box is displayed.

3.	 Clear the Regenerate check box and then modify the values of the dimensions. You will 
notice that the dimension that you edit in the Modify Dimensions dialog box is enclosed 
by a violet box in the drawing area.

4.	 When all dimensions are modified, choose the OK button from the Modify Dimensions 
dialog box; the message Dimension modifications successfully completed is displayed in 
the message area.

	 The completed sketch is shown in Figure 2-41.

5.	 Save the sketch as discussed earlier. Next, you need to print the sketch.

Figure 2-41 Complete sketch with dimensions and constraints
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Printing the Sketch Using the Plot Option
1.	 Choose the Print option from the File menu or press CTRL+P; the Printer  

Configuration dialog box is displayed, as shown in Figure 2-42.

2.	 Choose the Commands and Settings button from this dialog box; a shortcut menu is  
displayed, as shown in Figure 2-43.

Figure 2-42 The Printer Configuration 
dialog box

Figure 2-43 Commands and 
Settings shortcut menu

3.	 Choose the Add Printer Type option from the shortcut menu; the Add Printer Type dialog 
box is displayed.

4.	 From the printers listed in the Add Printer Type dialog box, select the printer that is installed 
on your system and choose the OK button. 

5.	 From the Printer Configuration dialog box, choose the Page tab and select the A option 
from the Size drop-down list, if not already selected; the dimensions of the sheet are set, by 
default. 

6.	 Also, select the desired image resolution and the image depth from the dialog box under 
the Resolution area of the Printer Configuration dialog box. 
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7.	 Next, choose the OK button from the Printer Configuration dialog box to complete the 
printing.

Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The Modify tool is located in the__________ group of the Ribbon.

2.	 A sketch can be modified by changing its __________. 

3.	 There are two types of constraints in Creo Parametric: __________ and __________.

4.	 In the Sketch mode, a weak dimension is highlighted by __________ color. 

5.	 The file created in the Sketch mode is saved with a __________ file extension.

6.	 When you draw a sketch, the dimensions and constraints are automatically applied to it. 
(T/F)

7.	 In Creo Parametric, you can create lines that are tangent to two circles. (T/F)

8.	 You can convert a solid geometry into a construction geometry. (T/F)

9. 	 You can convert a weak dimension into strong dimension by using the mini popup toolbar 
that is displayed when you click on the dimension. (T/F)

10.	 For drawing a circle, first you need to specify its diameter. (T/F)

Review Questions
Answer the following questions:

1.	 The tools available in the ___________ group are used to apply constraints manually.

2.	 You can dynamically modify the geometry of a sketch. (T/F)

3.	 You can use the Rectangle tool from the Sketching group to draw a square. (T/F)

4.	 You cannot undo a previous operation in the sketcher environment. (T/F)

5.	 You can use the options in the shortcut menu to draw a sketch, when no other tool is chosen. 
(T/F)

6.	 You cannot disable constraints in the Sketch mode. (T/F)

7.	 Construction points are used to specify locations in sketch. (T/F)
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8.	 Two types of lines can be sketched by using the tools available in the Sketching group. (T/F)

9.	 The Dimension tool is used for normal dimensioning of the sketch. (T/F)

10.	 You can select one or more dimensions from the sketch to modify them. (T/F)

EXERCISES
Exercise 1 

In this exercise, you will draw the sketch of the model shown in Figure 2-44. The dimensions of the 
model are shown in Figure 2-45.                                                            (Expected time: 30 min)

Figure 2-44 Solid model for Exercise 1 Figure 2-45 Dimensions of the model

Exercise 2
In this exercise, you will draw the sketch of the model shown in Figure 2-46. The dimensions 
of the model are shown in Figure 2-47.                                                (Expected time: 30 min)

Figure 2-46 Solid model for Exercise 2 Figure 2-47 Dimensions of the model
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Exercise 3
In this exercise, you will draw the sketch of the model shown in Figure 2-48. The dimensions of 
the model are shown in Figure 2-49.                             		        (Expected time: 30 min)

Figure 2-48 Solid model for Exercise 3 Figure 2-49 Dimensions of the model

Exercise 4
In this exercise, you will draw the sketch of the model shown in Figure 2-50. The dimensions of 
the model are shown in Figure 2-51. 			         	       (Expected time: 30 min)

Figure 2-50 Solid model for Exercise 4 Figure 2-51 Dimensions of the model
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Exercise 5
In this exercise, you will draw the sketch of the model shown in Figure 2-52. The dimensions 
of the model are shown in Figure 2-53.                                                (Expected time: 30 min)

Figure 2-52 Solid model for Exercise 5 Figure 2-53 Dimensions of the model

Exercise 6
In this exercise, you will draw the sketch of the model shown in Figure 2-54. The dimensions of 
the model are shown in Figure 2-55. 			                      (Expected time: 30 min)

Figure 2-54 Solid model for Exercise 6 Figure 2-55 Dimensions of the model
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Answers to Self-Evaluation Test
1. Editing, 2. dimensions, 3. Geometry, Assembly, 4. light blue, 5. .sec, 6. T, 7. T, 8. T, 9. T, 
10. F
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