
Chapter 4

NURBS Modeling 
 Learning Objectives 
After completing this chapter, you will be able to:
• Understand NURBS editing techniques
• Convert NURBS objects to polygons
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INTRODUCTION
NURBS stands for Non Uniform Rational B-Spline. NURBS are used for creating 3D curves and 
surfaces, and complex 3D organic models having smooth surfaces and curves. In the previous 
chapter, you have learned about different methods of creating NURBS surfaces. In this chapter, 
you will learn about various editing techniques used for modifying NURBS surfaces. 

WORKING WITH NURBS TOOLS
The NURBS tools are used to edit NURBS surfaces. The most commonly used tools in NURBS 
modeling are discussed next.

Duplicate NURBS Patch
Menubar:	 Surfaces > Edit NURBS Surfaces > Duplicate NURBS Patch

The Duplicate NURBS Patch tool is used to create new surface 

Figure 4-1  Choosing Surface Patch 
from the marking menu

from an existing NURBS patch. To understand the working 
of this tool, choose Create > Objects > NURBS Primitives 
> Sphere from the menubar and create a NURBS sphere 
in the viewport. Press and hold the right mouse button 
over the sphere and then choose Surface Patch from the 
marking menu displayed, as shown in Figure 4-1; the 
surface patch component of the NURBS sphere will be 
activated. Now, select the surface patch that you want to 
duplicate. Choose Surface > Edit NURBS Surfaces > 
Duplicate NURBS Patch from the menubar; a duplicate 
surface patch will be created. Invoke Move Tool from the 
Tool Box and move the duplicate surface patch away from 
the NURBS sphere. Note that the pivot point of the 
duplicate surface patch will remain at the same position 
as that of the NURBS sphere. To reset the pivot point to 
the center of the duplicate patch, choose Modify > Pivot 
> Center Pivot from the menubar; the pivot point will be 
reset.

Project Curve on Surface
Menubar:	 Surfaces > Edit NURBS Surfaces > Project Curve on Surface

The Project Curve on Surface tool is used to project a NURBS curve on a NURBS surface. To 
understand the working of this tool, choose Create > Objects > NURBS Primitives > Square 
from the menubar and create a square in the front-Z viewport. Now, choose Surfaces > Create > 
Planar from the menubar to create a NURBS surface. Next, choose Create > Curve Tools > 
EP Curve Tool from the menubar to create a curve, as shown in Figure 4-2 and make sure the 
NURBS curve is selected. Press and hold the SHIFT key and select the NURBS surface. Now, 
choose Surfaces > Edit NURBS Surfaces > Project Curve on Surface from the menubar 
to project the curve on the surface and activate the persp viewport; the NURBS curve will be 
projected over the NURBS surface, as shown in Figure 4-3.
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Note
The curve will be projected at the exact position as visible through the camera of that particular 
viewport.

Figure 4-3  The NURBS curve projected 
on the NURBS surface

Figure 4-2  The NURBS curve created

Intersect
Menubar:	 Surfaces > Edit NURBS Surfaces > Intersect

The Intersect tool is used to create a new segment at the

Figure 4-4  The aligned surfaces and 
selection handles

 
intersection of two NURBS surfaces. To understand the 
working of this tool, consider two surfaces, as discussed 
earlier, and align them such that they intersect each 
other, refer to Figure 4-4. Select both the surfaces and 
choose Surfaces > Edit NURBS Surfaces > Intersect 
from the menubar to create a new segment at the location 
where the two planes intersect. Choose the Move Tool 
from the Tool Box; the selection handles will be displayed 
at the intersection point, refer to Figure 4-4. You can 
now move these handles to align the intersection point 
anywhere on the NURBS surface.

Trim Tool
Menubar:	 Surfaces > Edit NURBS Surfaces > Trim Tool

The Trim Tool is used to hide a particular area from the NURBS surface defined by curves. To 
understand the working of this tool, consider a curve projected on a surface as discussed in the 
Project Curve on Surface section. Next, select the NURBS surface in the viewport and choose 
Surfaces > Edit NURBS Surfaces > Trim Tool from the menubar; the NURBS surface will be 
displayed in the wireframe mode with a dotted outline. Select the part that you want to retain 
from the surface and press ENTER; the surface will be trimmed. You can also change the settings 
of Trim Tool as required. To retain the selected part from the NURBS surface and trim the 
unselected part from the NURBS surface, choose Surfaces > Edit NURBS Surfaces > Trim 
Tool > Option Box from the menubar; the Tool Settings (Trim Tool) panel will be displayed on 
the viewport, as shown in Figure 4-5. The Keep radio button is used to retain the original surface 
after the trimming is performed. The Discard radio button is used to trim the selected part 
from the NURBS surface and keep the unselected part intact.
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Figure 4-5  The Tool Settings (Trim Tool) panel

Untrim
Menubar:	 Surfaces > Edit NURBS Surfaces > Untrim

The Untrim tool is used to untrim the last trimmed surface. To understand the working of this 
tool, select the trimmed surface and choose Surfaces > Edit NURBS Surfaces > Untrim from 
the menubar; the surface sets back to its original untrimmed state.

Attach
Menubar:	 Surfaces > Edit NURBS Surfaces > Attach

The Attach tool is used to attach two selected NURBS surfaces. To understand the working of 
this tool, create two NURBS surfaces in the viewport, as shown in Figure 4-6. Next, select the 
two surfaces and choose Surface > Edit NURBS Surfaces > Attach > Option Box from the 
menubar; the Attach Surfaces Options window will be displayed, as shown in Figure 4-7. By 
default, the Blend radio button is selected in the Attach method area. Choose the Apply button; 
the selected surfaces will be connected, as shown in Figure 4-8. You can also select the Connect 
radio button from the Attach method area to connect the end of a surface to the end of another 
surface, as shown in Figure 4-9.

Figure 4-6  The two NURBS surfaces Figure 4-7  The Attach Surfaces Options window

Note
The Attach Surfaces tool does not attach trimmed surfaces. In such cases, surfaces need to be 
untrimmed before attaching them using this tool.
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Figure 4-9  The surfaces connected on 
selecting the Connect radio button

Figure 4-8  Surfaces connected on selecting 
the Blend radio button 

Tip
You can make changes in the attached surfaces by using the attachSurface1 tab in the Attribute 
Editor. To do so, choose Window > Editors > General Editors >  Attribute Editor from 
the menubar; the Attribute Editor will be displayed. Choose the attachSurface# tab from 
the Attribute Editor; the attributes of the attached surface will be displayed, as shown in 
Figure 4-10. You can apply different styles on the surface by using the parameters in the 
Attribute Editor.

Figure 4-10  The attachSurface1 tab in the Attribute Editor

Attach Without Moving
Menubar:	 Surfaces > Edit NURBS Surfaces > Attach Without Moving

The Attach Without Moving tool is used to attach two NURBS surfaces or curves by selecting 
their respective isoparms. To understand the working of this tool, create two NURBS surfaces 
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and select two isoparms, one each from the two surfaces. Now, choose Surfaces > Edit NURBS 
Surfaces > Attach Without Moving from the menubar; the two surfaces will be attached along 
with the two isoparms.

Align
Menubar:	 Surfaces > Edit NURBS Surfaces > Align

The Align tool is used to align the selected NURBS surfaces tangentially. To understand the 
working of this tool, select the NURBS surfaces that you want to align. Choose Surfaces > 
Edit NURBS Surfaces > Align > Option Box from the menubar; the Align Surfaces Options 
window will be displayed, as shown in Figure 4-11. Now, you can use different options in this 
window to align the selected NURBS surfaces as required.

Figure 4-11  The Align Surfaces Options window

Detach
Menubar:	 Surfaces > Edit NURBS Surfaces > Detach

The Detach tool is used to break NURBS surfaces into parts. To understand the working of 
this tool, select the isoparm of a surface and then choose Surfaces > Edit NURBS Surfaces > 
Detach from the menubar; the surface will get detached from the selected isoparm.

Open/Close
Menubar:	 Surfaces > Edit NURBS Surfaces > Open/Close

The Open/Close tool is used to open or close the NURBS surfaces. To open a closed surface, 
select the closed surface and choose Surfaces > Edit NURBS Surfaces > Open/Close from 
the menubar; the closed surface will be opened, as shown in Figure 4-12. Similarly, to close an 
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open surface, select the opened surface in the viewport and choose Surfaces > Edit NURBS 
Surfaces > Open/Close from the menubar; the opened surface will change into a closed surface, 
as shown in Figure 4-13.

Figure 4-13  The closed NURBS surfaceFigure 4-12  The opened NURBS surface

Extend
Menubar:	 Surfaces > Edit NURBS Surfaces > Extend

The Extend tool is used to extend a NURBS surface. To extend a NURBS surface, select a NURBS 
surface in the viewport. Then, press and hold the right mouse button on the NURBS surface and 
choose Isoparm from the marking menu displayed. Now, select the isoparm that you want to 
extend from the NURBS surface and choose Surfaces > Edit NURBS Surfaces > Extend from 
the menubar; the selected surface will be extended. To set the attributes of the extended surface, 
choose Surfaces > Edit NURBS Surfaces > Extend > Option Box from the menubar; the 
Extend Surface Options window will be displayed, as shown in Figure 4-14. Modify the values 
in the window to make changes in the working of the Extend tool. Figures 4-15 and 4-16 display 
a hut roof before and after using the Extend tool, respectively. Any change made in the original 
surface will also be displayed in the offset surface created.

Figure 4-14  The Extend Surface Options window
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Figure 4-16  The hut roof after using the 
Extend Surfaces tool

Figure 4-15  The hut roof before using the 
Extend Surfaces tool

Insert Isoparms
Menubar:	 Surfaces > Edit NURBS Surfaces > Insert Isoparms

The Insert Isoparms tool is used to insert an isoparm on a

Figure 4-17  The yellow dotted line 
displayed on the NURBS surface

 
NURBS surface. To understand the working of this tool, 
select a NURBS surface. Next, press and hold the right mouse 
button on the NURBS surface and choose Isoparm from the 
marking menu; the isoparms will be highlighted on the 
selected NURBS object. Now, press and hold the left mouse 
button on any NURBS isoparm and drag the mouse to 
specify the position for the new isoparm; a yellow dotted line 
will appear over the NURBS surface, as shown in Figure 4-17. 
Next, choose Surfaces > Edit NURBS Surfaces > Insert 
Isoparms from the menubar; a new isoparm will be inserted 
in place of the yellow dotted line.

Tip
To create multiple isoparms, press and hold the SHIFT key over a NURBS isoparm and 
then drag the mouse; multiple yellow dotted lines will appear on the NURBS surface. 
Now, choose Surfaces > Edit NURBS Surfaces > Insert Isoparms from the menubar; 
multiple isoparms will be created.

Offset
Menubar:	 Surfaces > Edit NURBS Surfaces > Offset

The Offset tool is used to create a copy of the selected surface by creating an offset at a specified 
distance. To understand the working of this tool, select a NURBS surface in the viewport and then 
choose Surfaces > Edit NURBS Surfaces > Offset from the menubar; a copy of the selected 
NURBS surface will be created. To set the properties of the Offset tool, choose Surfaces > 
Edit NURBS Surfaces > Offset > Option Box from the menubar; the Offset Surface Options 
window will be displayed, as shown in Figure 4-18. The Offset distance attribute in the window 
is used to specify the distance of the copied surface from the original surface.
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Figure 4-18  The Offset Surface Options window

Rebuild
Menubar:	 Surfaces > Edit NURBS Surfaces > Rebuild

The Rebuild tool is used to rebuild the NURBS surface by changing the parameters of the surface, 
or by increasing or decreasing the number of U and V spans on a selected NURBS surface. To 
understand the working of this tool, select the NURBS surface that you want to rebuild and 
choose Surfaces > Edit NURBS Surfaces > Rebuild > Option Box from the menubar; the 
Rebuild Surface Options window will be displayed, as shown in Figure 4-19. The options in 
this window are discussed next.

Figure 4-19  The Rebuild Surface Options window

Rebuild type
The radio buttons corresponding to the Rebuild type attribute are used to select the rebuild type. 
On selecting a rebuild type, various options related to it are displayed in the window. Various 
rebuild types are discussed next. You need to specify the Rebuild type attribute by selecting 
any of the following radio buttons:

Uniform
The Uniform radio button is used to rebuild the surface with uniform parameterization. 
On selecting this radio button, you can modify the number of U and V spans and their 
degree as required.
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Reduce
The Reduce radio button is used to remove the knots from the selected NURBS surface.

Match knots
The Match knots radio button is used to match the curve degree, knot values, number of 
spans, and sections of other surfaces. 

No multiple knots
The No multiple knots radio button is used to remove the extra knots formed while 
rebuilding a surface.

Non-rational
The Non-rational radio button is used to convert a rational surface into a non-rational 
surface.

End conditions
The End conditions radio button is used to rebuild the positioning of the CVs and knots 
of the selected NURBS surface.

Trim convert
The Trim convert radio button is used to convert a trimmed NURBS surface into a non-trim 
NURBS surface.

Bezier
The Bezier radio button is used to rebuild a NURBS surface as a bezier surface.

Parameter range
The radio buttons in the Parameter range attribute are used to specify how the U and V 
parameters will be affected while rebuilding a surface. These three radio buttons are discussed 
next.

0 to 1
The 0 to 1 radio button is used to specify the U and V parameters from 0 to 1 of the rebuild 
surface.

Keep
The Keep radio button is used to match the U and V parameters with that of the original 
surface.

0 to #spans
The 0 to #spans radio button is used to get the rebuild surface spans to have integers knot 
values.

Direction
The radio buttons in this area are used to determine the parametric direction of the surface for 
removing the knots in the U, V, or both U and V directions.
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Keep
The Keep attribute is used to ensure that some particular characteristics of the original object 
or surface are retained while creating a new surface. Select the Corners, CVs or NumSpans 
radio button to retain the corresponding characteristics.

Rebuild Method
The Rebuild Method radio buttons are activated only when the Match Knots radio button is 
selected from the Rebuild type parameter. The radio buttons in this area are used to rebuild the 
surface by specifying the quality of the new surface. Select the Classic radio button to get the 
surface quality similar to that obtained with the version 5.0 and earlier versions of Maya. Select 
the Match radio button to get a better quality for surfaces having multiple knots at the end.

Number of spans U and Number of spans V
The Number of spans U and Number of spans V options are used to set the number of spans 
in the U and V directions of the rebuilt surface respectively.

Degree U and Degree V
The Degree U and Degree V attributes are used to set the degree of the rebuilt surface.
 
Keep original
The Keep original check box is used to keep the original surface and rebuild a new surface.

Use tolerance
The Use tolerance area will be available only on selecting the Non-Rational or Reduce radio 
button in the Rebuild type area. The radio buttons in this area are used to set the distance 
between a point on the original and rebuilt surfaces. The Global radio button is used to set the 
positional value as the original value. The Local radio button is used to enter the tolerance 
value manually. The smaller the tolerance value, the more the rebuild surface will resemble the 
original surface.

Output geometry
The Output geometry attribute is used to specify the geometry type for the rebuilt surface. You 
can select the NURBS or Polygons radio button to specify the output geometry.

Reverse Direction
Menubar:	 Surfaces > Edit NURBS Surfaces > Reverse Direction

The Reverse Direction tool is used to reverse or swap the U and V directions of a selected surface. 
To understand the working of this tool, select a NURBS surface in the viewport and then choose 
Surfaces > Edit NURBS Surfaces > Reverse Direction > Option Box from the menubar; the 
Reverse Surface Direction Options window will be displayed, as shown in Figure 4-20. Select 
the required radio button from the Surface direction area of this window and then choose the 
Reverse button to reverse or swap the surface direction.
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Sculpt Geometry Tool
Menubar:	 Surfaces > Edit NURBS Surfaces > Sculpt Geometry Tool

The Sculpt Geometry is used to sculpt a NURBS or polygon object manually in the viewport. 
On invoking this tool, the cursor will change into a brush icon. To sculpt an object, select 
the NURBS surface in the viewport and choose Surfaces > Edit NURBS Surfaces > Sculpt 
Geometry Tool > Option Box from the menubar; the Tool Settings (Sculpt Geometry Tool) 
panel will be displayed on the viewport, as shown in Figure 4-21. 

Figure 4-21 Partial view of the Tool Settings (Sculpt Geometry Tool) panel

The more the number of segments on an object, the better sculpting can be done on it using 
the Sculpt Geometry Tool. You can sculpt an object using seven different options: Push, Pull, 
Smooth, Relax, Pinch, Slide and Erase. All these methods are discussed next.
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Push
The Push option is used to push down the selected NURBS

Figure 4-22  The Sculpt 
Geometry Tool cursor

 
mesh. To do so, consider a NURBS plane in the viewport. 
Next, choose Surfaces > Edit NURBS Surfaces > Sculpt 

Geometry Tool > Option Box from the menubar; the Tool 
Settings (Sculpt Geometry Tool) panel will be displayed on the 
viewport, refer to Figure 4-21. Choose the Push button in the 
Sculpt Parameters area; the cursor will be displayed, as shown 
in Figure 4-22. Press and hold the left mouse button and move 
the cursor over the NURBS plane to sculpt the NURBS plane. 
Figure 4-23 shows a NURBS plane before sculpting and 
Figure 4-24 shows the NURBS plane sculpted using the Push tool.

Figure 4-24  The NURBS plane sculpted 
using the Push tool

Figure 4-23  The NURBS plane before sculpting

Pull
The Pull tool is used to pull the NURBS

Figure 4-25  The NURBS plane sculpted using 
the Pull tool

 
mesh from the surface. This tool works 
similar to the Push tool and the method 

to apply it on a NURBS plane is same as that of 
the Push tool. Figure 4-25 shows a NURBS plane 
sculpted using the Pull tool.

Smooth
The Smooth tool is used to paint on a mesh to give it a smoother look. To use this tool, 
follow the same procedure as discussed in the Push tool and choose the Smooth button 
from the Sculpt Parameters area of the Tool Settings (Sculpt Geometry Tool) panel. 

Figure 4-26 shows a surface before smoothening and Figure 4-27 shows the surface after 
smoothening.

Relax
The Relax tool works similar to the Smooth tool. It is used to relax the bumps over the 
surface, thus maintaining the overall shape of the mesh. 
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Figure 4-26  Surface before smoothening Figure 4-27  Surface after smoothening

Pinch
The Pinch tool is used to pull selected vertices toward each other. It helps in 
bringing the vertices closer in order to make sharp or well defined creases.

Slide
The Slide tool is used to slide the vertices of the surface in the direction of the stroke 
Figure 4-28 shows a surface before sliding the vertices and Figure 4-29 shows the surface 
after sliding the vertices.

Figure 4-28  Surface before sliding Figure 4-29  Surface after sliding

Erase
The Erase tool is used to erase the changes made on the surface by using the other Sculpt 
Geometry tools like Push or Pull. Figure 4-30 shows a surface before erasing changes on it and 
Figure 4-31 shows the surface after erasing changes on it.

 

Figure 4-31  Surface after erasingFigure 4-30  Surface before erasing
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CONVERTING OBJECTS
In Maya, you can convert the form of an object. To do so, select an object in the viewport and 
choose Modify > Objects > Convert from the menubar; a cascading menu will be displayed. 
Choose the conversion type from the cascading menu to specify the output geometry for the 
selected object. The most commonly used options in this cascading menu are discussed next.

Converting NURBS to Polygons
Menubar:	     Modify > Objects > Convert > NURBS to Polygons

The NURBS to Polygons conversion tool is used to convert a NURBS mesh into a polygonal 
object. To do so, select a NURBS mesh to be converted and then choose Modify > Objects 
Convert > NURBS to Polygons > Option Box from the menubar; the Convert NURBS to 
Polygons Options window will be displayed in the viewport, as shown in Figure 4-32. You can 
use this window to set the options for the conversion of the object from NURBS to polygons. 
Some of the options in this window are discussed next.

Figure 4-32  The Convert NURBS to Polygons Options window

Type
The Type attribute is used to set the output of the geometry after the conversion has taken 
place. If you select the Triangles radio button, then three-sided polygons will be created on the 
surface, as shown in Figure 4-33. If you select the Quads radio button, then four-sided polygons 
will be created on the surface, as shown in Figure 4-34. 

Tessellation method
The Tessellation method attribute is used to convert a NURBS mesh into a set of polygons. In 
Maya, there are four tessellation methods that are discussed next. You can select a radio button 
corresponding to this parameter to specify the tessellation method to be used.
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Figure 4-33 Surface created on selecting the 
Triangles polygon type radio button

Figure 4-34  Surface created on selecting the 
Quads polygon type radio button

General
The General radio button is used to define the number of polygons in the U or in the V 
direction. On selecting this radio button, various options for setting the tessellation are 
displayed. 

Standard fit
The Standard fit radio button is selected by default. This method is used to determine when 
to stop the tessellation by setting the fractional tolerance value. On selecting this radio 
button, the options related to it are displayed. 

Count
The Count radio button is used to specify the polygon count in the mesh after 
the mesh has been converted into polygons. The more the count value, the smoother will 
be the object.

Control points
The Control points radio button is used to create a new mesh while matching its CVs to the 
original NURBS surface. The resulting polygons will be quads by default.

Converting NURBS to Subdiv
Menubar:	 Modify > Objects > Convert > NURBS to Subdiv

The NURBS to Subdiv conversion tool is used to convert a NURBS mesh into a subdiv mesh. 
To do so, select the NURBS object in the viewport and choose Modify > Objects > Convert > 
NURBS to Subdiv > Option Box from the menubar; the Convert NURBS/Polygons to Subdiv 
Options window will be displayed, as shown in Figure 4-35. Some of the options in the Convert 
NURBS/Polygons to Subdiv Options window are discussed next.

Figure 4-35  The Convert NURBS/Polygons to Subdiv Options window
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Maximum base mesh faces
The Maximum base mesh faces attribute is used to set the maximum number of faces that the 
original surface can have, such that it can be successfully converted into a subdivision surface.

Maximum edges per vertex
The Maximum edges per vertex attribute is used to set the maximum number of edges that 
each vertex can have in the original surface, such that it can be successfully converted into a 
subdivision surface.

Keep original
The Keep original check box is used to keep the original NURBS object mesh after creating 
the new subdivision surface.

TUTORIALS
 Tutorial 1    					      	
In this tutorial, you will create the model of a cowboy hat, as shown in Figure 4-36, using 
NURBS. 			                                                             (Expected time: 15 min)

Figure 4-36  The model of a cowboy hat

The following steps are required to complete this tutorial:

a.	 Create a project folder.
b.	 Create a NURBS cylinder.
c.	 Add details to the hat.
d.	 Change background color of the scene.
e.	 Save and render the scene.

Creating a Project Folder
Create a new project folder with the name c04_tut1 at \Documents\maya2022 and then save the 
file with the name c04tut1, as discussed in Tutorial 1 of Chapter 2.

Creating a NURBS Cylinder
In this section, you will create a NURBS cylinder to form the base structure of the cowboy hat.

1.	 Maximize the top-Y viewport and then choose Create > Objects > NURBS Primitives > 
Cylinder > Option Box from the menubar; the NURBS Cylinder Option window is 
displayed on the viewport. Set the values of the parameters, as shown in Figure 4-37.
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Figure 4-37  The NURBS Cylinder Options window

2.	 Select nurbsCylinder1 on the viewport and rename nurbsCylinder1 to hat. 

3.	 In the front-Z viewport, press and hold the right mouse button on the hat; a marking menu 
is displayed. Choose Control Vertex from the marking menu; the vertex selection mode is 
activated. Now, select the vertices, as shown in Figure 4-38. Next, invoke Scale Tool from the 
Tool Box and scale up the vertices uniformly in the front-Z viewport, as shown in Figure 4-39.

4.	 Make sure the vertices of hat are selected. Select the green handle of Scale Tool and scale the 
selected vertices downward along the Y-axis; the mesh gets modified, as shown in Figure 4-40.

Figure 4-39  Scaling the selected vertices 
uniformly

Figure 4-38  Vertices to be selected
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Figure 4-40  Scaling the selected vertices along the Y axis

Adding Details to the Hat
In this section, you will add details to the hat to give it the look of a cowboy hat.

1.	 Maximize the top-Y viewport. Next, press and hold the SHIFT key and marquee-select the 
vertices, refer to Figure 4-41. Choose Scale Tool from the Tool Box, and scale the selected 
vertices inward along the Z-axis using the yellow handle; the mesh gets scaled, as shown in 
Figure 4-42.

Figure 4-42  Scaled meshFigure 4-41  The vertices selected

2.	 Maximize the side-X viewport. Next, marquee-select the vertices using the SHIFT key, as 
shown in Figure 4-43. Next, choose Move Tool and move the vertices downward along the 
Y-axis, as shown in Figure 4-44.

Figure 4-44  The modified mesh 
after moving the vertices

Figure 4-43  Vertices to be selected

3.	 Maximize the persp viewport. Press and hold the right mouse button over the lower part 
of hat; a marking menu is displayed. Next, choose Object Mode from the marking menu; 
the object selection mode is activated.
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4.	 Select the model in the persp viewport. Next, press and hold the right mouse button over 
the lower part of hat and choose Isoparm from the marking menu; the color of the edges 
of hat turns blue.

5.	 In the persp viewport, select the isoparm, as shown in Figure 4-45. Drag the isoparm outward; 
a dotted isoparm is displayed on hat. Next, choose the Modeling menuset from the Menuset 
drop-down list in the Status Line and then choose Surfaces > Edit NURBS Surfaces > 
Insert Isoparms from the menubar; a new isoparm is added, as shown in Figure 4-46.

6.	 Make sure hat is selected. Next, choose Edit > Delete > Delete All by Type > History from 
the menubar; the history of all actions performed on the model is deleted.

7.	 Maximize the side-X viewport. Next, press and hold the right mouse button on hat; a marking 
menu is displayed. Choose Control Vertex from the marking menu; the vertex selection 
mode is activated. Next, marquee-select the vertices of hat by using the SHIFT key, as shown 
in Figure 4-47. Next, invoke Move Tool from the Tool Box, and move the vertices upward 
along the Y axis, as shown in Figure 4-48.

Figure 4-46  A new isoparm addedFigure 4-45  Selecting an isoparm

Figure 4-48  The modified meshFigure 4-47  Vertices to be selected

8.	 Press and hold the right mouse button over hat and choose Object Mode from the marking 
menu displayed; the object selection mode is activated. Maximize the top-Y viewport. Choose 
View > Predefined Bookmarks > Bottom from the Panel menu; the bottom viewport is 
activated.

9.	 Insert two new isoparms on hat, as discussed in steps 4 and 5. Figure 4-49 displays two 
isoparms added to hat in the bottom viewport. 
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10.	 Press and hold the right mouse button over the cylinder and 

Figure 4-49  The two new
isoparms added

choose Control Vertex from the marking menu displayed; 
the vertex selection mode is activated. Next, select the 
vertices using the SHIFT key, as shown in Figure 4-50.

11.	 Choose View > Predefined Bookmarks > Right Side from 
the Panel menu; the right side-X viewport is activated. 
Choose Move Tool from the Tool Box and move the selected 
vertices upward along the Y axis to get the final output, refer 
to Figure 4-51.

Changing the Background Color of the Scene
In this section, you will change the background color of the scene.

1.	 Choose Windows > Editors > Outliner from the menubar; the Outliner window is displayed. 
Select the persp camera in the Outliner window; the perspShape tab is displayed in the 
Attribute Editor. 

Figure 4-50  Selecting vertices Figure 4-51  The final output

2.	 In the perspShape tab, expand the Environment area and drag the Background Color 
slider bar toward right to change the background color to white.

Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can view 
the final rendered image of this scene by downloading the c04_maya_2022_rndr.zip file from 
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > 
Maya > Autodesk Maya 2022: A Comprehensive Guide

1.	 Choose File > Save Scene from the menubar. 

2.	 Maximize the persp viewport if not already maximized. Choose the Display render setting 
button from the Status Line; the Render Settings window is displayed. In this window, select  
Maya Software in the Render Using drop-down list and then close the window. Choose 
the Render the current frame button from the Status Line to render the scene, refer to 
Figure 4-36.



4-22			                                    Autodesk Maya 2022: A Comprehensive Guide
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

 Tutorial 2  					      	
In this tutorial, you will create the model of a ship, as shown in Figure 4-52, using the NURBS 
and polygon tools.					                        (Expected time: 30 min)

Figure 4-52  Model of a ship

The following steps are required to complete this tutorial:

a.	 Create a project folder.
b.	 Create the hull of the ship.
c.	 Create railings.
d.	 Create the deck.
e.	 Create the chimney.
f.	 Change the background color of the scene.
g.	 Save and render the scene.

Creating a Project Folder
Create a new project folder with the name c04_tut2 at \Documents\maya2022 and then save the 
file with the name c04tut2, as discussed in Tutorial 1 of Chapter 2.

Creating the Hull of the Ship
In this section, you will create the hull of the ship using the NURBS curves and the loft method.

1.	 Maximize the side-X viewport and choose Create > Objects > Curve Tools > EP Curve 
Tool > Option Box from the menubar; the Tool Settings (EP Curve Tool) window is 
displayed on the left of the viewport. In this window, select the 5 radio button from the 
Curve Degree attribute. Next, create a curve for the base of the ship in the side-X viewport, 
as shown in Figure 4-53. 

	 To get the exact shape, select the curve and right-click on it to display a marking menu. 
Next, choose Control Vertex from the marking menu; the vertex mode is activated. 
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Figure 4-53  Curve created for the base of the ship

	 Now, you can select a vertex and modify the shape by using Move Tool.

2.	 Choose Move Tool from the Tool Box. Next, press and hold the d key and set the pivot 
point to the right end of the curve by moving the manipulators.

3.	 Make sure the curve is selected. Choose Edit > Duplicate > Duplicate Special > Option 
Box from the menubar; the Duplicate Special Options window is displayed, refer to 
Figure 4-54. Enter the values in the window, as shown in Figure 4-54, and then choose the 
Duplicate Special button; duplicate curves are created in the viewport.

Figure 4-54  The Duplicate Special Options window

4.	 Select the duplicate curves one by one and rotate them along the Z axis using Rotate Tool, 
as shown in Figure 4-55. 

5.	 Press and hold the SHIFT key and then select all the curves in the viewport one by one from 
bottom to top. 
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6.	 Choose Surfaces > Create > Loft from the menubar; a surface is created defining half of 
the ship base, as shown in Figure 4-56.

Figure 4-55  The duplicate curve rotated Figure 4-56  Surface created

7.	 Make sure the lofted surface is selected and then choose Move Tool. Next, press and hold 
the D key and set the pivot point to the right end of the surface by moving the manipulators. 

8.	 Choose Window > Editors > Outliner from the menubar; the Outliner window is displayed. 
In the Outliner window, select all the curves by using the SHIFT key. Next, choose Display > 
Object > Hide > Hide Selection from the menubar; the selected curves are hidden. Close 
the Outliner window.

9.	 In the side-X viewport, select the NURBS surface. Now, choose Surfaces > Edit NURBS 
Surfaces > Rebuild > Option Box from the menubar; the Rebuild Surface Options window 
is displayed. Set the parameters in this window, as shown in Figure 4-57, and then choose 
the Rebuild button; the selected surface is rebuilt.  

Figure 4-57  The Rebuild Surface Options window
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10.	 Make sure the rebuilt surface is selected. Next, press and hold the right mouse button over 
it and choose Control Vertex from the marking menu displayed; the vertex selection mode 
is activated. Next, marquee-select the vertices using the SHIFT key, as shown in Figure 4-58. 
Move the vertices downward to create tail of the ship, as shown in Figure 4-59.

Figure 4-59  Vertices moved downward to create 
the tail of the ship

Figure 4-58  Selecting vertices

11.	 Maximize the persp viewport. Press and hold the right mouse button; a marking menu 
is displayed. Choose Object Mode from the marking menu; the object selection mode is 
activated. Select the surface of the ship and choose Edit > Duplicate > Duplicate Special > 
Option Box from the menubar to create a copy of the half part of the ship; the Duplicate 
Special Options window is displayed. In this window, select the Copy radio button and make 
sure -1 is entered in the first Scale edit box and enter 1 in the Number of copies edit box.

Next, choose the Duplicate Special button; a copy of the selected surface is created in the 
persp viewport, refer to Figure 4-60.

12.	 Make sure the copy of the surface is selected. Next, choose Curves > Reverse Direction from 
the menubar; the curve direction of the selected surface is reversed, as shown in Figure 4-60.

 
13.	 Make sure that one of the surfaces is selected. Press and hold the right mouse button over 

the surface; a marking menu is displayed. Choose Isoparm from the marking menu; the 
isoparm selection mode is activated.

14.	 Press and hold the right mouse button over another surface; a marking menu is displayed. 
Choose Isoparm from the marking menu; the isoparm selection mode is activated. Next, 
press SHIFT and select the topmost isoparm of both the surfaces, as shown in Figure 4-61. 
Next, choose Surfaces > Create > Loft from the menubar; a surface is created between the 
selected isoparms.

Figure 4-61  The two selected isoparms Figure 4-60  The duplicate surface created



4-26			                                    Autodesk Maya 2022: A Comprehensive Guide
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

15.	 Make sure the newly created surface is selected and choose Surfaces > Edit NURBS 
Surfaces > Rebuild > Option Box from the menubar; the Rebuild Surfaces Options 
window is displayed. In this window, make sure 8 is entered in the Number of spans U edit 
box. Next, choose the Rebuild button; the newly created surface is rebuilt.

16.	 Maximize the top-Y viewport and press and hold the right mouse button on the selected 
surface; a marking menu is displayed. Choose Isoparm from the marking menu displayed 
and insert the two isoparms using the SHIFT key, as shown in Figure 4-62. Now, choose 
Surfaces > Edit NURBS Surfaces > Insert Isoparms from the menubar; two new isoparms 
are added to the surface.

17.	 Maximize the side-X viewport. Invoke Move Tool and move the newly created surface up 
along the Y axis.

18.	 In the side-X viewport, press and hold the right mouse button over the newly created 
surface; a marking menu is displayed. Choose Control Vertex from the marking menu; 
the vertex selection mode is activated. Select all the vertices of the newly created surface. 
Next, maximize the top-Y viewport and deselect the center vertices by pressing the SHIFT 
key and select all the corner vertices, as shown in Figure 4-63. 

Figure 4-62  Inserting isoparms Figure 4-63  The vertices selected

19. Maximize the persp viewport and then choose Move Tool from the Tool Box and move the 
selected vertices downward along the Y axis, as shown in Figure 4-64.

Creating Railings
In this section, you will create railings for the ship by using the NURBS cylinder and then align 
the cylinders on a curve. 

1.	 Maximize the top-Y viewport. Choose Create > Objects > Curve Tools > EP Curve Tool 
from the menubar and create a curve, refer to Figure 4-65. Now, move the curve using Move 
Tool. Figure 4-65 displays the position of the NURBS curve in all viewports.
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Figure 4-64  Moving the vertices along the Y axis

2.	 Maximize the persp viewport and choose Create > Objects > NURBS Primitives > Cylinder 
from the menubar and create a cylinder in the viewport. Next, select the upper cap of the 
cylinder and delete it. Similarly, delete the lower cap of the cylinder.

Figure 4-65  The NURBS curve aligned in all viewports  

3.	 Select the cylinder. In Channel Box / Layer Editor, expand makeNurbCylinder1 node in 
the INPUTS area and set the following parameters of the cylinder:

	
	 Radius: 0.2		  Sections: 10	       Height Ratio: 10

4.	 Select the Animation menuset from the Menuset drop-down list in the Status Line. Next, 
select the curve and then press and hold the SHIFT key and select the cylinder. Choose 
Constrain > Motion Paths > Attach to Motion Path > Option Box from the menubar; the 
Attach to Motion Path Options window is displayed in the viewport. 
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5.	 In this window, choose Start/End radio button in the Time range attribute and make sure 
30 is entered in the End Time edit box. Next, choose the Attach button; the cylinder gets 
attached to the curve.

6.	 Choose Visualize > Snapshot > Create Animation Snapshot > Option Box from the 
menubar; the Animation Snapshot Options window is displayed in the viewport. Enter 
30 in the End Time edit box, 2 in the Increment edit box, and then choose the Snapshot 
button; the cylinders are aligned on the curve surface, as shown in Figure 4-66.

Note
The value in the End Time edit box may vary depending on the size of the NURBS surface 
created.

7.	 Maximize the front-Z viewport and choose Create > Objects > NURBS Primitives > Circle 
from the menubar and create a circle on the curve in the viewport, refer to Figure 4-67. Make 
sure the circle is selected in the front-Z viewport. In the Channel Box / Layer Editor, enter 
90 in the Rotate X and -38 in the Rotate Y edit boxes. Next, expand makeNurbCircle1 
node in the INPUTS area of the Channel Box / Layer Editor and set the radius of the 
circle to 0.3.

Figure 4-66  The cylinders aligned on the 
curve surface

Figure 4-67  The handrail created

8.	 Select the Modeling menuset from the Menuset 

Figure 4-68  The handrail aligned

drop-down list in the Status Line. Now, select the 
circle and then the curve from the viewport. Choose 
Surfaces > Extrude > Option Box from the 
menubar; the Extrude Options window is displayed. 
In this window, make sure the Tube radio button 
corresponding to the Style attribute is selected. 
Also, select the At path radio button corresponding 
to the Result position attribute and Component 
radio button corresponding to the Pivot attribute. 
Next, choose the Extrude button; the circle is 
extruded and the handrail is created, refer to 
Figure 4-68.
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9.	 Maximize the persp viewport. Next, invoke the Move Tool and move the handrail up along 
the Y axis to align it, refer to Figure 4-68. Now, press CTRL+D; a copy of handrail is created 
and then align it using Move Tool, as shown in Figure 4-68.

10.	 Choose Windows > Editors > Outliner from the menubar; the Outliner window is displayed. 
In the Outliner window, select the curve5 and the nurbsCircle1 curve; the nurb circle and 
the handrail curve is selected in the viewport. Next, choose Display > Object > Hide > 
Hide Selection from the menubar to hide the selected curves. 

11.  Select the complete railing and press CTRL+G; the selected railing is grouped. Choose 
Edit > Delete > Delete by Type > History from the menubar; the history of the surfaces 
created earlier is deleted. Next, choose Modify > Transform > Freeze Transformations 
from the menubar and then press D to set pivot at the center of the ship if not at the center. 

12.	 Make sure the complete railing is selected and choose Edit > Duplicate > Duplicate Special 
from the menubar; a copy of the railings is created and gets placed on the other half of 
the ship. Next, choose Curves > Edit >Reverse Direction from the menubar; the curve 
direction of the copied railing surface is reversed, as shown in Figure 4-69.

Figure 4-69  Copied railing surface is reversed

Creating the Deck
In this section, you will create the deck of the ship using the polygon modeling method.

1.	 Maximize the top-Y viewport. Choose Create > Objects >

Figure 4-70  The shape of the 
deck created

 
Polygon Primitives > Cube from the menubar. Next, create 
a cube in the viewport. In the Channel Box / Layer Editor, 
expand the polyCube1 node of the INPUTS area and set the 
parameters as follows:

	
	 Width: 5		  Subdivisions Width: 2
	 Height: 1		  Subdivision Depth: 4
	 Depth: 5

2.	 Press and hold the right mouse button on the cube; a marking 
menu is displayed. Choose Vertex from the marking menu 
displayed. Next, choose Scale Tool from the Tool Box and 
adjust the vertex of the cube to form the shape, as shown in 
Figure 4-70.
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3.	 Maximize the persp viewport. Press and hold the right mouse button on the cube; a marking 
menu is displayed. Choose Object Mode from the marking menu displayed. Next, select 
the cube and choose Edit > Duplicate > Duplicate from the menubar; a copy of the cube 
is created. Similarly, create one more duplicate of the deck. Choose Move Tool and then 
Scale Tool to align the duplicated decks on the ship, as shown in Figure 4-71.

Figure 4-71  The duplicate decks aligned together

Creating the Chimney
In this section, you will create the chimney for the ship using the Polygon Cylinder tool.

1.	 Maximize the top-Y viewport. Choose Create > Objects > Polygon Primitives > Cylinder 
from the menubar and create three cylinders in the viewport. The cylinders will act as 
chimneys for the ship. In the Channel Box / Layer Editor, set the parameters as given next.

Cylinder Radius Height

Cylinder1 0.8 8

Cylinder2 0.6 6

Cylinder3 0.4 4
Note
The radius and height of the cylinders may vary depending on the size of the ship. Therefore, you 
need to set the respective values accordingly.

2.	 Maximize the persp viewport and align the cylinders to create the chimneys, as shown in 
Figure 4-72.

Changing the Background Color of the Scene
In this section, you will change the background color of the scene.

1.	 Choose Windows > Editors > Outliner from the menubar; the Outliner window is 
displayed. Select the persp camera in the Outliner window; the perspShape tab is displayed 
in the Attribute Editor. 
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Figure 4-72  The chimneys created

2.	 In the perspShape tab, expand the Environment area and drag the Background Color 
slider bar toward right to change the background color to white.

Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can view 
the final rendered image of this scene by downloading the c04_maya_2022_rndr.zip file from 
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > Maya > 
Autodesk Maya 2022: A Comprehensive Guide.

1.	 Choose File > Save Scene from the menubar. 

2.	 Maximize the persp viewport if not already maximized. Choose the Display render setting 
button from the Status Line; the Render Settings window is displayed. In this window, select  
Maya Software in the Render Using drop-down list and then close the window. Choose 
the Render the current frame button from the Status Line to render the scene, refer to 
Figure 4-52.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following tools is used to create a new segment at the intersection of two 
surfaces?

		  (a) Intersect Surfaces			   (b) Untrim Surfaces
		  (c) Attach Surfaces			   (d) None of these

2.	 Which of the following tools is used to paint a mesh to give it a smoother look?

		  (a) Pull					    (b) Push
		  (c) Smooth				    (d) Relax
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3.	 The __________ tool is used to rebuild the U and V spans.

4.	 The __________ tool is used to undo the last trim operation.

5.	 The __________ tool is used to reverse the U and V directions of selected surface.

6.	 The __________ Geometry Tool is used to sculpt a NURBS or polygon object manually in 
the viewport.

7.	 The NURBS to Subdiv conversion tool is used to convert a NURBS mesh into a subdiv 
mesh. (T/F)

8.	 The Sculpt Geometry Tool is used to sculpt a NURBS or polygon object manually in the 
viewport. (T/F)

9.	 The Offset Surfaces tool is used to create copy of a selected surface at a particular distance. 
(T/F)

10.	 The Insert Isoparms tool is used to insert an isoparm into an existing NURBS surface. (T/F)

 Review Questions 
Answer the following questions:

1.	 Which of the following operations is used to relax bumps over a surface?

		  (a) Push 	 			   (b) Pull
		  (c) Relax	 			   (d) Erase

2.	 Which of the following tools is used to create a copy of the selected surface by creating an 
offset at a specified distance?

		  (a) Offset Surface 	 		  (b) Attach Surface 
		  (c) Align Surface 			   (d) Detach Surface

3.	 The __________ tool is used to extend an edge of the NURBS surface.

4.	 The __________ radio button is used to remove extra knots formed while rebuilding a surface.

5.	 The Pinch operation is used to pull the selected vertices toward each other while using the 
Sculpt Geometry Tool. (T/F)

6.	 The Extend Surfaces tool is used to extend the edge of a NURBS surface. (T/F)

7.	 The Reverse Surface Direction tool is used to reverse or swap the U and V directions of a 
selected surface. (T/F)
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8.	 The Erase operation is used to push the NURBS mesh inside a surface. (T/F)

9.	 The Extend Surfaces tool is used to rebuild a NURBS surface. (T/F)

10.	 The Detach tool is used to detach a surface by selecting isoparm. (T/F)

EXERCISES 
The rendered output of the models used in the following exercises can be accessed by downloading 
the c04_maya_2022_exr.zip from www.cadcim.com. The path of the file is as follows: Textbooks > 
Animation and Visual Effects > Maya > Autodesk Maya 2022: A Comprehensive Guide.

 Exercise 1                                                                   
Use various NURBS modeling techniques to create the model of a handbag, as shown in 
Figure 4-73.                 					                        (Expected time: 45 min)

Figure 4-73  The model of a handbag

 Exercise 2                                                                   
Use various NURBS modeling techniques to create the model of a chair, as shown in 
Figure 4-74. 							           (Expected  time: 30 min)

Figure 4-74  The model of a chair
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Answers to Self-Evaluation Test
1. a, 2. c, 3. Rebuild Surfaces, 4. Untrim Surfaces, 5. Reverse Surface Direction, 6. Sculpt, 
7. T, 8. T, 9. T, 10. T


