Chapter 2

Structural Modeling in
STAAD.Pro

Learning Objectives

After completing this chapter, you will be able to:
* Create structures using Editor

* Create structures using STAAD GUI
* Create structures using the Structure Wizard
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INTRODUCTION

Before erecting a structure, you need to run a stability check for the structure. To check the
structural stability, you need to model the structure virtually. The virtual structural models
comprise of various components such as beams, columns, walls, slabs, and so on. In STAAD.Pro,
you can model a structure and then check its structural stability. A structural model in STAAD.Pro
is represented as a line structure which consists of nodes and members. Before modeling a
structure, you need to determine the nodes and the connection between them.

In STAAD.Pro, nodes are the joints which are capable to resist forces and moments. A node is
located at the end of beams, columns, or plates. A node is always represented by a node number.
To create nodes, you need to determine its coordinates in the XYZ space. After creating nodes,
you can form members or plate elements by connecting the nodes. A member may be a column,
beam, or truss, which is generated by connecting two nodes and is represented by a member
number. Figure 2-1 shows the nodes and members in a portal frame structure.
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Figure 2-1 Nodes and members in a portal frame structure

A plate element is formed by connecting three or four nodes and is represented by a plate
number. A plate element can be triangular or quadrilateral. These members and plate elements
are represented by member number and element number.

In STAAD.Pro, you can create a structure model by using any of the following methods:
1) Using STAAD Editor

2) Using STAAD GUI

3) Using Structure Wizard

4) Building planner

These methods are discussed next.
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STRUCTURAL MODELING USING STAAD EDITOR

In STAAD.Pro, the STAAD Editor window contains a list of commands required to model,
analyze, and design a structure. These commands are the instructions related to the analysis
and design of a structure and are executed consecutively. To open the STAAD Editor window,
choose the Command File Editor tool from the Edit panel of the Utilities tab. Figure 2- 2 shows
the STAAD Editor window with default commands entered in it.
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Figure 2-2 The STAAD Editor window

To start the structure geometry, the nodes must be created first and then other elements can be
created like beams, plates and solids. The command for creating the nodes is discussed next.

Creating Nodes

Nodes are created by specifying the X, Y, and Z coordinates of the joints in a structure. The
command used for specifying the coordinates is JOINT COORDINATES. This command will be
specified after specifying the unit command. The general format for specifying the coordinates
is given below:

JOINT COORDINATES
nxyz

In the above command, n represents the node number and x, y, and z represent the coordinates of
the joints nodes in a structure. To create nodes, first you need to specify the command JOINT
COORDINATES in the STAAD Editor window. Next, you will specify the node number and
coordinates for the first node. After specifying the first node, you need to put a semi-colon and
then specify the node number and coordinates of the second node, and so on. After specifying
the command, choose the Save button from the toolbar in the STAAD Editor window and then
close the window. You can view the node numbers of the created nodes by pressing SHIFT'+N.
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Note

The JOINT COORDINATE command is not case sensitive. You can also write the initial three
letters for the command. For example, enter JOI COO for this command. In case, you forget to
choose the Save button before closing the window then the Save dialog box will automatically be
displayed and you can save the changes by choosing the Yes button.

You can also generate multiple nodes at a time by using the REPEAT and REPEAT ALL
commands. These commands generate the nodes in a repetitive pattern.

Note

@ The REPEAT command repeats the previous line of input n number of times with the increments
specified in x, v, and z divections. The REPEAT ALL command repeats all the previously specified
inputs. When you use REPEAT command afier REPEAT or REPEAT ALL then the REPEAT
command is only applicable for the last created node.

The general format for specifying the REPEAT and REPEAT ALL commands is given below:

JOINT COORDINATES
nxyz

REPEAT n X, Vy, 2z,
REPEAT ALL n X, y, 2,

In the above command, n represents the number of times the nodes will be repeated and x,, y,,
and z, represent increments in the x, y, and z coordinates.

Note

@ 1. In this chapter, you need to download the c02_staad_connect_exm.zip file for the examples from
hitps:/fwww.cadcim.com. The path of the file is as follows: Textbooks > Civil/GIS > Bentley STAAD.
Pro > Exploring Bentley STAAD.Pro CONNECT Edition, V22 > Example Files drop-down.

2. Before starting the examples, you need to create a folder with the name STAAD Examples in
C: drive and then extract the downloaded zip folder to this folder

Example 1

In this example, you will create nodes for a portal frame structure. This structure will be created
as a space frame structure.

Steps required to complete this example are given below:

Step 1: Start STAAD.Pro CONNECT Edition and choose the New option from the left pane of
the user interface screen; the Model Information page is displayed. In this page, specify the
name c02_staad_connect_exI in the File Name edit box and browse to the location C:\STAAD
Examples\c02_staad_connect_exm by clicking the Browse button next to the Location edit box.

Step 2: Select Analytical in the Type area and Metric in the Units area. Choose the Create
button from the left pane of the user interface screen; the file is loaded. Choose the Command
File Editor tool from the Edit panel of the Utilities tab; the STAAD Editor Window will open.
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Step 3: In this window, specify the commands, as shown in Figure 2-3.
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Figure 2-3 Commands specified in the STAAD Editor window

Step 4: Choose the Save button from the File menu in the STAAD Editor window and then
close the STAAD Editor; the nodes are generated. Press SHIFT'+N to view the node numbers,

refer to Figure 2-4.
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Figure 2-4 Nodes created using commands

Step 5: Choose the Close button from the File menu; the current file is closed.
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Example 2

In this example, you will create the nodes for a structure using the REPEAT and REPEAT ALL
commands. The structure will be created as a space frame structure.

Steps required to complete this example are given below:

Step 1: Start STAAD.Pro CONNECT Edition and choose the New option from the left pane of
the user interface screen; the Model Information page is displayed. In this page, specify the
name c02_staad_connect_ex2 in the File Name edit box and browse to the location C:\STAAD
Examples\c02_staad_connect_exm by clicking the Browse button next to the Location edit box.

Step 2: Select Analytical in the Type area and Metric in the Units area. Choose the Create
button from the left pane of the user interface screen; the file is loaded. Choose the Command

File Editor tool from the Edit panel of the Utilities tab; the STAAD Editor Window will open.

Step 3: In the STAAD Editor window, specify the commands, as shown in Figure 2-5.
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Figure 2-5 Commands in the STAAD Editor window

Step 4: Choose the Save button from the File menu in the STAAD Editor window and then
close the window; the nodes are generated. Press SHIFT+N to view the node numbers, refer
to Figure 2-6.

Step 5: Close the file by choosing the Close option from the File menu.
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Note

@ Whenever you will save a project in STAAD.Pro, the REPEAT and REPEAT ALL commands
will be converted into comments and the coordinates of each node will be generated in the STAAD
Editor window.
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Figure 2-6 Nodes of the space frame structure

Creating Members

You can create members by specifying their start and end nodes. The command for creating
member is MEMBER INCIDENCES. The general format for creating members is given below:

MEMBER INCIDENCES
mij

Here, m represents the member number and i, j represents the start and end nodes, respectively.
After creating nodes, you need to create members by specifying the connectivity between
nodes. The REPEAT and REPEAT ALL commands can also be used for easy generation of the
members. The general format to use the REPEAT and REPEAT ALL commands for creating
members is given below:

MEMBER INCIDENCES
mij

REPEAT n i, j,
REPEAT ALL n i, j,

In the above command, n represents the number of times, the previously created member will
be repeated, i, represents the member number increment and j, represents the node number
increment.

In this case, the REPEAT command will create the previously created member for specified
number of times with specified increment in node numbers and member numbers. The
REPEAT ALL command will create all the previously created members for specified number
of times with specified increment in node numbers and member numbers.
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Note
10 use the REPEAT and REPEAT ALL commands for creating members, you need to number
the members in a consecutive order.

Example 3

In this example, you will create the members to form a complete portal frame structure. The
file used in this example is c02_staad_connect_ex1 .std.

Steps required to complete this example are given below:

Step1: Choose the Open option from the left pane in the user interface of STAAD.Pro; the Open
screen is displayed. In this screen, use Open Other Models to browse to the location: C:| STAAD
Examples\c02_staad_connect_exm and select the c02_staad_connect_ex1.std file and then choose the
Open button; the user interface screen is displayed with the nodes. Press SHIFT+N to view the
node numbers, refer to Figure 2-7.
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Figure 2-7 Node numbers for the nodes

Step 2: Choose the Command File Editor tool from the Edit panel of the Utilities tab; the
STAAD Editor Window will open. Now specify the commands for creating the members, as
shown in Figure 2-8.
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Figure 2-8 Commands for creating the members in the STAAD Editor window

Step 3: Choose the Save button from the File menu in the STAAD Editor window and then
close the window; the members are generated. Press SHIFT+B to view the member numbers,

refer to Figure 2-9.

Figure 2-9 Members created to complete the structure

Step 4: Choose the Save As option from the File menu; the Save As page is displayed. In this page,
specify the name ¢02_staad_connect_ex3 in the File name edit box and save it at an appropriate

location. Choose the Save button; the file is saved with the new name.
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Step 5: Close the file by choosing the Close option from the File menu.

Example 4

In this example, you will create members using the REPEAT and REPEAT ALL commands to
form a complete space frame structure. The file used in this example is c02_staad_connect_ex2.std.

Steps required to complete this example are given below:

Step 1: Open the c02_staad_connect_ex2.std file, as discussed in Example 2. Choose the Geometry
tab and press SHIFT+N to view the node numbers.

Step 2: Choose the Command File Editor tool from the Edit panel of the Utilities tab; the
STAAD Editor Window will open. Now specify the commands given below after the Joint
Coordinates command:

MEMBER INCIDENCES
1117

Step 3: After specifying the above command, choose the Save button from the File menu and
close the STAAD Editor window; the member 1 will be created, as shown in Figure 2-10. Click
on working area. Press SHIFT+B to view the member number.
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Figure 2-10 Member 1 created using commands

Step 4: Specify the REPEAT command after specifying the command in step 2 in the STAAD
Editor window, as given below. After specifying the command, choose the Save button and close
the STAAD Editor window; the members are created, as shown in Figure 2-11.

REPEAT 3 1 1
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Figure 2-11 Members created using the REPEAT command
Step 5: Specify the next command given below in the STAAD Editor window. Next, choose
the Save button and close the STAAD Editor window; the members are created, as shown in

Figure 2-12.
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Figure 2-12 Members created using the REPEAT ALL command

Step 6: Next, create the horizontal members by specifying the command in the STAAD Editor
which are given next.

17 17 18
REPEAT 2 1 1
REPEAT ALL 3 3 4

Step 7: Choose the Save button and close the STAAD Editor window; the members are created,
as shown in Figure 2-13.



2-12 Exploring Bentley STAAD.Pro CONNECT Edition, V22

Figure 2-13 Horizontal members created

Step 8: Next, specify the command in the STAAD Editor window, as shown in Figure 2-15,
to create the remaining members as given below and the structure is completed, as shown in
Figure 2-14.

29 17 21
REPEAT 3 1 1
REPEAT ALL 2 4 4

Figure 2-14 The complete structure after creating members

Step 9: Choose the Save option from the File menu and then close the STAAD Editor window.
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Figure 2-15 Commands for creating members in the STAAD Editor window

Step 10: Choose the Save As option from the File menu; the Save As page is displayed. In
this page, specify the name c02_staad_connect_ex4 in the File Name edit box and save it at an
appropriate location.

The commands for creating members can also be written as given below:

MEMBER INCIDENCES
1117 4

REPEAT ALL 3 4 4
17 17 18 19
REPEAT ALL 3 3 4
29 17 21 32
REPEAT ALL 2 4 4

Step 11: Choose the Close option from the File menu to close the open file.

In the first line of the above command, the span of the member 1 is from node 1 to node 17 and
the new members will be generated with the member number increment and the node number
increment as 1. Thus, the spans of the members numbered as 2, 3, and 4 are from nodes 2 to
18, 3 to 19, and 4 to 20, respectively.

Similarly, in the third and fourth line of the command, the members 17 to 19 and 29 to 32 will
be formed.
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Creating Plate Elements

In STAAD.Pro, a plate is a thin shell with multi-noded shape. It can have three or four nodes.
A plate is used to model a floor slab, roof, or wall that does not need to be designed as a shear
wall. A plate element in STAAD.Pro can be of uniform or non-uniform thickness. To model a
slab, roof, or wall, you need to create several plates which can be done by meshing. The process
of meshing will be discussed later in this chapter.

To create a plate, first you need to create nodes. The process of creating nodes is already discussed
earlier. Next, identify connectivity between the nodes and create the plates. The command for
creating a plate is given next.

ELEMENT INCIDENCES
p il i2 i3 i4

In the above command, p represents plate number, i, i,, i;, and i,represent node numbers. The
order of these node numbers can be clockwise or anti-clockwise

If the plate is 3-noded, then i, node is not needed. Note that, if you have created members in the
project then the member numbers and element numbers must be distinct. You can also create
plate elements by using the REPEAT and REPEAT ALL commands. The general format for
using these commands is given below:

ELEMENT INCIDENCES
pi i,i, i,
REPEAT n e, j,
REPEAT ALL n e, j,

In the above command, n represents no. of times the plate will be repeated, e, represents the
element number increment and j; represents the node number increment.

In this case, the REPEAT and REPEAT ALL commands will generate the previously created
plate n number of times, with the specified plate and node number increment.

Example 5

In this example, you will create plate elements for the plane structure using the REPEAT and
REPEAT ALL commands.

Steps required to complete this example are given below:

Step 1: Create a new file in STAAD.Pro with the name ¢02_staad_connect_ex5 and then invoke
the STAAD Editor window, as discussed earlier. Specify the commands to create nodes and
members, as shown in Figure 2-16.

Step 2: Choose the Save button and close the STAAD Editor window; the nodes and members
are created, as shown in Figure 2-17. Press Shift+N and Shift+B to view the no of nodes and
beams respectively.
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Step 3: Next, choose the Command File Editor tool from the Edit panel of the Utilities tab; the
STAAD Editor Window will open. Now specify the command for creating plates, as given below:

ELEMENT INCIDENCES
181 2 65
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Figure 2-16 Commands for creating nodes and members

Figure 2-17 Nodes and members created
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Step 4: Specify the commands in the STAAD Editor window as given below to create the
remaining plates, as shown in Figure 2-18. Press SHIFT + P to view the plate numbers.

REPEAT 2 1 1
REPEAT ALL 1 3 4
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Figure 2-18 Plales created using commands

The commands used for creating plates can also be written as given below:

ELEMENT INCIDENCES
181 2 6 5 TO 20
REPEAT ALL 1 3 4

In the first line of the above command, the plate number 18 is formed by connecting the nodes
1, 2, 6, and 5. Plate number 19 and 20 are formed by connecting the node numbers 2, 3, 7, 6
and 3, 4, 8, 7. The node number and plate number increment is 1.

Step 5: Choose the Save option from the File menu to save the file and then close it by choosing
the Close option from the File menu.

Creating Solid Elements

In STAAD.Pro, solid elements are used to analyze the structures which include 3 dimensional
stresses such as concrete gravity dams. A solid element is an eight-noded element and has three
translational degrees of freedom per node. To create solid elements, first you need to create the
nodes. The command for creating the solid elements is given below:

ELEMENT INCIDENCES SOLID
cii,i,i,i,i,1i,1,
REPEAT n, e, j,

REPEAT ALL n_ e, j,
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Here, c is the element number or solid number. i, to iy represents node numbers, n represents no.
of times the solid will be repeated, e, represents the element number increment and j, represents
the node number increment.

Example 6

In this example, you will create the solid block element in space frame by using the STAAD
Editor commands.

Steps required to complete this example are given below:

Step 1: Create a new STAAD file with the name ¢02_staad_connect_ex6.std and invoke the STAAD
Editor window from the Utilities panel of the Utilities tab. Specify the commands for creating
nodes as given below:

UNIT METER KN
JOINT COORDINATES
10003300
40026302
REPEAT ALL 1 0 2 O

Step 2: Next, specify the commands for creating solid elements as given below:

ELEMENT INCIDENCES SOLID
14511101287 TO 2

In the above command, 1 represents the solid number which will be created by connecting
the eight nodes in a sequence and TO represents the solid number 2 which will be created
automatically by connecting its corresponding nodes in the same manner.

Step 3: Choose the Save button and close the STAAD Editor window; the solid elements are
created, as shown in Figure 2-19. Press SHIFT+C to view the solid element numbers.

Note
You can view the element in the Rendered View window. The Rendered View window can be
invoked by choosing the 3D Rendering tool from the Windows panel of the View tab.
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Figure 2-19 Solid elements created using commands

Step 4: Choose the Save option from the File menu to save the file and then close it by choosing
the Close option from the File menu.

STRUCTURAL MODELING USING STAAD GUI

You can model the structural geometry using the STAAD Graphical User Interface (GUI).
The STAAD GUI comprises of various graphical tools that are used to generate the structure.
Whenever you model the structure using the graphical tools, the STAAD Editor window will be
automatically updated with the associated commands. Thus, the graphical model generation and
the command file methods are interrelated. The changes made in the former will be reflected
in the latter and vice-versa. It is essential for the users to learn both the methods so that they
can easily make any change and update it in the model. There are various tools and methods
available for modeling a structure. Some important methods are discussed next.

Creating Nodes and Members Using Snap
Node/Beam Method

In the Snap Node/Beam method, the nodes and members are generated simultaneously. In this
method, to create nodes and members, first you need to specify the grid and snap settings. The
options related to the grid and snap settings will be available in the Snap Node/Beam window.
You can invoke the Snap Node/Beam window by choosing the Beam Grid tool from the Grids
drop-down in the Structure panel of the Geometry tab.

In this window, the Create button is used to create new grids. The Edit button is used to configure
the settings of an existing grid. The Delete button is used to remove an existing grid from the
window. The Copy button is used to create a copy of an existing grid. You can change the name
of the grid by using the Rename button. You can import a grid setting created in AutoCAD by
using the Import button.
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In the Snap Node/Beam window, you need to specify
the settings of construction lines for creating nodes
and members. In STAAD.Pro, there are three grid
systems which can be used for specifying the
settings of the construction lines namely Linear
grid, Radial grid and Irregular grid. By default,
the linear grid system is defined in the window,
refer to Figure 2-20. In this window, the active grid
system will be selected and highlighted. The three
different grid systems available in STAAD.Pro are
discussed next.

Linear Grid

In the linear grid system, the construction lines
are perpendicular to each other. You can also
create a new linear, radial, and irregular grid
system. To create a linear grid system, choose the
Create button in the Snap Node/Beam window;
the Linear dialog box will be displayed, as shown
in Figure 2-21.

In the Linear dialog box, the Linear option will be
selected by default in the drop-down list available
at the top of the dialog box. You can specify the
name of the grid system in the Name edit box.
Specify the required plane for the grid lines in
which the structure will be drawn from the Plane
area. For example, if a structure is to be drawn in
the XY plane, select the X-Y radio button. Specity
the angle of rotation of a plane about an axis in
the corresponding edit box in the Angle of Plane

area. Next, specify the coordinates of the origin of
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Figure 2-20 The Snap Node/Beam window

the grid in the X, Y, and Z edit boxes in the Grid Origin area. In the Construction Lines area,
you can adjust the settings of the construction lines. To display the coordinates on the negative
direction of X and Y axes, specify the required values in the Left column of the X and Y edit
boxes by using the spinner. Specify the spacing between the grids in the Spacing edit box. To
place the axes at an angle, specify the required value in the edit boxes corresponding to Skew.

Figure 2-22 shows a linear grid system.
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Figure 2-21 The Linear dialog box Figure 2-22 The linear grid

Radial Grid

In a radial grid system, the construction lines will appear in a spider-web style. In this grid
style, you can create circular structures by creating small linear members. To create a radial grid
system, choose the Create button from the Snap/Node Beam window; the Linear dialog box will
be displayed, refer to Figure 2-21. Select the Radial option from the drop-down list available
at the top; the Radial dialog box will be displayed and the options related to the radial grid
system will be displayed, as shown in Figure 2-23.

In the Radial dialog box, you can specify the plane, angle of plane, and grid origin for the radial
grid system in the same way as discussed for the linear grid system. In the Construction Lines
area, specify the start angle of the grid in the Start Angle edit box. Specify the total angle of
sweep in the Sweep edit box. Specify the inner and outer radius in the Radius 1 and Radius 2
edit boxes, respectively. Specify the number of bays in the Bays edit box. Figure 2-24 shows the
radial grid system.

Note
Increasing the number of bays in the first Bays edit box produces a better circular structure.
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Figure 2-23 The Radial dialog box

Irregular Grid

Figure 2-24 The radial grid system

In the irregular grid system, you can create the grid lines with unequal spacing. The process of
creating an irregular grid is the same as discussed above for the linear and radial grid system.
In this case, you can specify the relative grid distance in the X and Y edit boxes of the Relative

gridline distances area in the Irregular dialog box, refer to Figure 2-25.

After creating the required grid system, choose the OK button; the Snap Node/Beam window
will be displayed. Using this window, you can choose the desired grid system in which you want
to work. For example, to create a linear structure, select the check box corresponding to the
linear grid system. Next, choose the Snap Node/Beam button, if not chosen by default; a plus
cursor will appear on the grids displayed in the main window area. Next, to create the nodes,
click on the intersection point of the grids; the members will also be created along with the

nodes. Figure 2-26 shows an irregular grid system.
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Figure 2-25 The Irregular dialog box Figure 2-26 The Irregular Grid System
Example 7

In this example, you will create a structure, as shown in Figure 2-27, using the Snap Node/
Beam method.
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Figure 2-27 Portal frame structure

Steps required to complete this example are given next:

Step 1: Start STAAD.Pro CONNECT Edition and select the New option from the left pane; the
Model Information page is displayed. In this page, specify the name c02_staad_connect_ex7 in
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the File Name edit box and browse to the location C:\STAAD Examples\c02_staad_connect_exm
by clicking the button next to the Location edit box. Select Analytical from the Type area and
Metric from the Units area. Next, choose the Create button from the left pane of the user
interface screen; the file is loaded.

Step 2: Choose the Beam Grid tool from the Grids drop-down in the Structure panel of the
Geometry tab; the Snap Node/Beam window is displayed. In this window, choose the Edit
button; the Linear dialog box is displayed.

Step 3: In this dialog box, ensure that spacing between grids is 1 and other default settings are
retained. Choose the OK button to close the dialog box.

Step 4: Place the cursor at the origin and click; nodel is created and a member is attached to
the cursor, refer to Figure 2-28.
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Figure 2-28 Node 1 created at the origin

Step 5: Next, move the cursor in the Y direction and click at (0,3) coordinates; the node 2 is
created along with the member 1, refer to Figure 2-29.

Step 6: Now, move the cursor in the X direction and click at the coordinates (3,3); the node 3
is created along with the member 2, refer to Figure 2-29.

Step 7: Move the cursor in the negative Y direction and create node 4 at coordinates (3,0), along
with member 3, refer to Figure 2-29.

Figure 2-29 Nodes 2, 3, and 4 created along with the members
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Step 8: Now, press the ESC key to deactivate the Snap Node/Beam mode.

Step 9: Again, choose the Snap Node/Beam button from the Snap Node/Beam window; the
Snap Node/Beam mode will be activated and repeat the previous steps to create nodes 5, 6, 7,
and 8 with members 4, 5, 6, and 7, refer to Figure 2-27.

Step 10: Next, close the Snap Node/Beam window; the structure is created, as shown in
Figure 2-27.

Next, press SHIFT + N to show node numbers and SHIFT + B to show beam numbers.

Step 11: Choose the Save option from the File menu to save the file and then close it by choosing
the Close option from the File menu.

Creating Plate Elements Using the
Snap Node/Plate Method

In the Snap Node/Plate method, you can create
nodes and plates simultaneously. Before creating
the nodes and the plates, first you need to specify
the grid and snap settings. For creating a
quadrilateral (4 noded) plate, choose the Quad
Plate Grid tool from the Grids drop-down in the
Structure panel of the Geometry tab; the Snap
Node/Plate window will be displayed, as shown in
Figure 2-30. In this window, you can specify the grid
and snap settings, which are same as discussed
above.

Snap Node/Beam n

Default Grid (Linear]

Note

While working in an existing drawing, the Snap
Node/Plate window will not be displayed. In
that case, choose the Quad Plate Grid tool from
the Grids drop-down in the Structure panel of
the Geometry tab.

Create... Edit Delete

Copy. Rename Import

Now, choose the Snap Node/Plate button to create
the plates. To specify the coordinates for the nodes,
click at the appropriate places in the clockwise or
anti-clockwise direction in the grid.

To create triangular (3 noded) plates, choose the
Triangular Plate Grid tool from the Grids drop-
down in the Structure panel of the Geometry tab;
the Snap Node/Plate window for triangular plates
is displayed. Now, using this window, you can create
triangular (3 noded) plates.

Active Grid Labels Setup
[JLocal Coordinate

[JRel.Coords [ |Axis Ids Font
End(s) Freg.

x (s ][ B OOV [z
vosen ][ x z

|:| Snap to existing nodes too

Snap Node/Beam Close

Figure 2-30 The Snap Node/Plate window
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Creating Solid Elements Using the Snap Node/Solid Method
You can create the solid elements by using the Snap Node/Solid method. To do so, choose the
Solid Grid tool from the Grids drop-down in the Structure panel of the Geometry tab; the
Snap Node/Solid window is displayed. In this window, specify the required settings for the grid
system and choose the Snap Node/Solid button; the plus cursor appears in the main window.
Next, click at the appropriate places in the grid to create solid elements. Note that, if you click
at the random places then the created solid element will be irregular in shape. So, you need
to specify the nodes in a proper order. Figure 2-31 shows an irregular solid element which has
been created by specifying the nodes randomly.

1
/ 4
1
Figure 2-31 An irregular solid element

Example 8

In this example, you will create plate elements using the Snap Node/Plate method. Figure 2-32
shows the structure to be created in this example.
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Figure 2-32 The ro0f slab
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Steps required to complete this example are given below:

Step 1: Create a new file in STAAD.Pro with the name c02_staad_connect_ex8.std and browse to
the location C:\STAAD Examples\c02_staad_connect_exm by clicking the button next to the Location
edit box. Select Analytical from the Type area and Metric from the Units area; choose the
Create button; the user interface screen is displayed. Choose the Quad Plate Grid tool from the
Grids drop-down in the Structure panel of the Geometry tab. The Snap Node/Plate window
is displayed in data area.

Step 2: In this window, choose the Edit button; the Linear dialog box is displayed. In this dialog
box, select the X-Z radio button in the Plane area to activate the XZ plane.

Step 3: Next, enter 8 in the X and Z edit boxes in the Right column edit box/spinner of the
Construction Lines area and choose the OK button to apply the changes.

Step 4: Now, place the cursor at the origin and click; the first node is created.
Step 5: Next, move the cursor in the Z direction and click at 2m; the node 2 is created.

Step 6: Move the cursor in the X direction and click at the coordinates (2,0,2); the node 3 is
created.

Step 7: Again, move the cursor in the negative Z direction and click at the coordinates (2,0,0);
node 4 and plate 1 is created, as shown in Figure 2-33. Press the ESC key to exit the tool selection.
Press SHIFT+N and SHIFT+P to view the nodes and plates respectively.
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Figure 2-33 Plate 1 created
Step 8: Choose the Snap Node/Plate button and then and then click at (4,0,2); node 5 is created.

Step 9: Next, move the cursor in negative Z direction and click at the coordinate (4,0,0); node
6 is created.

Step 10: Move the cursor and click on node 2 and then move the cursor and click on node 3
respectively; plate 2 is created.
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Step 11: Repeat the previous steps and create plates 2 to 16, refer to Figure 2-32.

Step 12: Choose the Save option from the File menu to save the file and then close it by choosing
the Close option from the File menu.

Example 9

In this example, you will create the solid block element using the Snap Node/Solid method.
Figure 2-34 shows the concrete block to be created.

—
,—",—1/"

1
Figure 2-34 The concrete block

Steps required to complete this example are given below:

Step 1: Create a new file in STAAD.Pro with the name c02_staad_connect_ex9.std and browse to
the location C:\STAAD Examples\c02_staad_connect_exm by clicking the button next to the Location
edit box. Select Analytical from the Type area and Metric from the Units area in the Model
Information page and then, choose the Create button; the user interface screen is displayed.
Choose the Solid Grid tool from the Grids drop-down in the Structure panel of the Geometry
tab; the Snap Node/Solid window is displayed.

Step 2: Move the cursor at the coordinates (0, 0) and click to create node 1.
Step 3: Move the cursor in the X direction and click at the coordinates (4, 0) to create node 2.

Step 4: Similarly, click at the coordinates (4, 4) and ( 0, 4) to create nodes 3 and 4, respectively.

Step 5: Next, choose the Edit button from the Snap Node/Solid window; the Linear dialog
box is displayed.

Step 6: In this dialog box, specify -4 in the Z edit box under the Grid Origin area and then
choose the OK button; the grid is moved to a new location, as shown in Figure 2-35.
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Step 7: Now, repeat the steps 2 through 4 to create nodes 5, 6, 7, and 8; the solid element is
created, refer to Figure 2-34. Press the ESC button to exit the command. Press SHIFT+N and
SHIFT+C to view the node and solid number, respectively.
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Figure 2-35 Grids moved to the new location

Step 8: Choose the Save option from the File menu to save the file and then close it by choosing
the Close option from the File menu.

STRUCTURAL MODELING USING THE STRUCTURE
WIZARD

Structure Wizard contains pre-defined prototype models and templates such as truss models,
frame models, surface/plate models, solid models, and so on. Using these templates and prototype
models, you can create a structural model by specitying the parameters such as length, width,
height, radius, and so on. After creating the model in Structure Wizard, you can transfer or
import it into STAAD.Pro to start a project. To access the Structure Wizard, choose the Structure
Wizard option from the Structure panel of the Geometry tab; the default.stp - StWizard window
will be displayed, as shown in Figure 2-36.
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Figure 2-36 The default.stp - StWizard window

In this window, you can access both type of models, the prototype models and the models
saved by the user. To access the prototype models, select the Prototype Models radio button.
A list of different prototype models will be displayed in the Model Type drop-down list such
as trusses, frames, solids, surfaces/plate, and so on. To access the saved user models, select the
Saved User Models radio button. Before generating a structure, you need to specify the units.
To do so, choose the Select Units option from the File menu; the Select Units dialog box will
be displayed. In this dialog box, select the appropriate unit and choose the OK button. The
process of generating various types of structures is discussed next.

Truss Models

In the Structure Wizard window, you can create truss models. To do so, select the Truss Models
option from the Model Type drop-down list of the default.stp - StWizard window; various
prototype truss models will be displayed in the left pane of the window. In this pane, select an
desired truss template by double-clicking. For example, select the Howe Bridge truss template
and double-click on it; the Select Parameters dialog box will be displayed, as shown in Figure 2-37.

Select Parameters *

Model Name ‘HDWE Bridge |

Length m Mo, of bays along length: l:l
Width: il Mo, of bays along width:

Apphy Cancel

Figure 2-37 The Select Parameters dialog box for Howe Bridge
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In this dialog box, specify the name for the truss
model in the Model Name edit box. Next, specify
the length, width, height, and no. of bays in their
corresponding edit boxes. Choose the Apply
button; the structure will be generated and
displayed in the Structure Wizard window.
Figure 2-38 shows the Howe bridge model created
with the default values.

Next, choose the Merge Model with STAAD.Pro
Model option from the File menu; the StWizard
message box will be displayed. In this message
box, choose the Yes button; the Paste Prototype
Model dialog box will be displayed, as shown in
Figure 2-39.

Figure 2-38 The Howe Bridge model created

Paste Prototype Model X

Move prototype model by:
() By distance between following two nodes

Node2: O Cancol

Help
(@ By the following X, ¥ and Z values

Figure 2-39 The Paste Prototype Model
dialog box for a new model

Note

@ The Paste Prototype Model dialog box will be displayed only when there is no existing structure
in STAAD. Pro. If theve is already a structure in STAAD.Pro, then the Paste Prototype Model
dialog box will be displayed with the Reference Pt button added, as shown in Figure 2-40.

In this dialog box, you can specify the coordinate values to move the prototype model. To move
the model by a specified distance, select the By distance between following two nodes radio
button; the Nodel and Node2 edit boxes will be enabled. Specify the desired values and choose
the OK button to merge the model. To move the model to a specified coordinate, select the
By the following X, Y, and Z values radio button; the X, Y, and Z edit boxes will be enabled.
Specify the required values and choose the OK button to apply the changes. If you merge a
new model with an existing one then the STAAD.Pro CONNECT Edition message box will be
displayed, as shown in Figure 2-41.
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Paste Prototype Model *

Move prototype model by:
(O By distance between following two nodes

Node2: 0 Cancel
Help

(@) By the following X, ¥ and Z values
Rz F STAADPro CONMECT Edition X

| . Duplicate nodes ignored

Figure 2-40 The Paste Prototype Model dialog Figure 2-41 The STAAD.Pro CONNECT
box for an existing model Edition message box

Choose the OK button to close the message box. You can choose the Reference Pt button in
case of merging one model with other. In that case, you need to specify the node which will
act as the reference point. Choose the OK button to close the dialog box. On doing so, all the
members and nodes will be generated automatically.

Frame Models

You can create the frame models by selecting the Frame Models option from the Model Type
drop-down list in the Structure Wizard window. On selecting this option, various prototype
frame models will be displayed in the left pane of the window. Using these models, you can
create different structures such as continuous beam, bay frame, cylindrical structure, circular
beam, floor grid, and so on. In the left pane, double-click on the required prototype model; the
Select Parameters dialog box for the selected model will be displayed, refer to Figure 2-42. In
this dialog box, specify the desired values and choose the Apply button; the dialog box closes
and the structure is created. Figure 2-43 shows a bay frame structure created with default values.

Select Parameters X

hdodel Name ‘Elay Frame |

Length m Mo, of bays along length: l:l .
Height: il Mo, of bays along height: .
Width: il Mo, of bays along width: D .

Ay Cancel

Figure 2-42 The Select Parameters dialog box for the bay frame structure

Next, you can transfer the model in STAAD.Pro by following the same method as discussed for
the truss model.
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Figure 2-43 The bay frame structure

Surface/Plate Models

Using the Structure Wizard window, you can create surface/plates models like quadrilateral
plates, cylindrical surfaces, polygonal plates with holes, spherical surface, cooling tower, and
so on. To do so, select the Surface/Plate Models option from the Model Type drop-down list
in the Structure Wizard window; various prototype models will be displayed in the left pane of
the window. In the left pane, double-click on the required model; the dialog box related to the
selected model will be displayed. Note that the dialog box displayed for each prototype model
will be different. Figure 2-44 shows the dialog box for the Polygonal Plate With Holes model.

Define Mesh Region X

@ X

B Palygonal Plate X Y z Div. Bias
E-@ Boundary 0.000 0.000 0.000
£ @ HOLES 10.000 0.000 0.000 10 1.000
L@ Hole 10.000 10.000 0.000 10 1.000

0.000 10 000 0.000 10 1.000
0.000 0.000 0.000 10 1.000

Cancel Feset

Figure 2-44 The Define Mesh Region dialog box for the Polygonal Plate With Holes model

In this dialog box, the parameters for the boundary will be displayed by default. You can
consider the default values or can change them as per your requirement. Specify the locations
for corners of the boundary, number of divisions for each side, and bias for each side division
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in their respective cells. You can also add a new row in the right pane by choosing the Add New
Row button available at the top right in the dialog box. To delete a row, first select it and then
choose the Delete Row button.

Next, click on the Hole sub node under the HOLES
node in the left pane; the corresponding parameters A A N I e o
will be displayed in the right pane. Using the options
in this pane, you can create circular, polygonal, and
elliptical holes. To do so, select the desired option |

from the Region Type drop-down list in the right pane N ".: e
of the dialog box; various parameters will be displayed I T 1_3,_ “_.'_" .«
in the left pane of the dialog box. The options : e s R e
displayed in the dialog box depend upon the options | = L N e o
selected from the Region Type drop-down list. Specify 1ol P

-
¥ & W % @ X & = = W

the values as required and choose the OK button; the
structure will be created and displayed in the right
pane of the window. Figure 2-45 shows the polygonal f
plate with hole created using the default values. Now, Figure 2-45 Polygonal plate with hole
merge the model in STAAD.Pro as discussed before.

Solid Models

You can also generate solid block models using the Structure Wizard. To do so, select the Solid
Models option from the Model Type drop-down list; the Solid Block prototype model will
be displayed in the left pane. Double-click on the Solid Block option; the Select Meshing
Parameters dialog box will be displayed, as shown in Figure 2-46.

In this dialog box, specify the length and division along the axes in their corresponding edit
boxes. Then, choose the Apply button; the solid block is created. Next, transfer it to STAAD.Pro
by following the same process as discussed before. Figure 2-47 shows the solid block created
using the default values.
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Figure 2-46 Parial view of the Select Meshing Figure 2-47 The solid block created

Parameters dialog box
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Composite Models

You can also generate composite models such as bunker or silo using Structure Wizard. To do so,
select the Composite Models option from the Model Type drop-down list; the Bunker or Silo
prototype model will be displayed in the left pane of the window. Double-click on the Bunker or
Silo option; the Select Meshing Parameters dialog box will be displayed, as shown in Figure 2-48.

Select Meshing Parameters

s

ModelName  |Bunker or Sila

Vertical Portion

Length ()

Width (w)

Height (k)

Divn. along length
Divn. along width

Divn. alang height

Allunits arein - m

[]Enable Edge Beam Generatian
[1Enable Camer Calumn Generation

Ht. of Calumn from Top

=

Hopper Bottom

Depth (h1)
Opening

Length (1)
Widh (w1)
Location of centroid w.rt. axis

of symenetry

Divn. along height

Cancel

Figure 2-48 The Select Meshing Parameters dialog box

In this dialog box, you can define the geometry of the vertical portion. To do so, specify the
required values in the corresponding edit boxes in the Vertical Portion area. Similarly, you can
specify the depth of the hopper bottom in the corresponding edit boxes in the Hopper Bottom
area. After specifying all the parameters, choose the Apply button; the structure will be created,

as shown in Figure 2-49.
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Import CAD Models

Using the Import CAD Models option, you can import the AutoCAD models, which are saved in
DXF format. To do so, select the Import CAD Models option from the Model Type drop-down
list; the Scan DXF and STAAD Model options will be displayed in the left pane of the window.
To import the AutoCAD models, double-click on the Scan DXF option in the right pane; the
Open dialog box will be displayed. In this dialog box, browse to the required location, select the
.dxf file, and then choose the OK button; the model will be displayed in the right pane. Using
this option, you can import line, 3D-Polyline, and 3D-Face.

To import STAAD models, double-click on the STAAD Model option in the right pane; the
Open dialog box will be displayed. In this dialog box, browse to the required location, select
the file, and then choose the OK button; the file will be displayed in the window.

VBA Macro Models

Using the VBA Macro Models option, you can create models such as stadium roof. To do so,
select the VBA-Macro Models option from the Model Type drop-down list; the Stadium Roof
and A Simple Tower options will be displayed in the left pane of the window. Using these two
options, you will be able to model a stadium roof and tower. The procedures to create a stadium
roof and a tower are discussed next.

To create a stadium roof, select the Stadium Roof option from the left pane of the
default.stp - StWizard window and drag it to the right pane; the Stadium Roof dialog box will be
displayed, as shown in Figure 2-50. In this dialog box, you can specify the length, width, depth,
number of panels along length and number of panels along width in their corresponding edit
boxes. Next, choose the OK button; the stadium roof is created and displayed in the window.
Figure 2-51 shows the stadium roof model created using default values.

& stadium Roof x

Length of the Roof:
Width of the Roof: 0

Depth of the Roof: 0

No. of panels along Length: | 10

1111

No. of panels along Width: 7

| ]

Figure 2-50 The Stadium Roof dialog box
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Figure 2-51 Stadium roof created with default values

To create a tower, select the A Simple Tower option from the left pane of the default.stp - StWizard
window and drag it to the right pane; the Tower Parameters dialog box will be displayed, as
shown in Figure 2-52. In this dialog box, you can specify the base dimension, top dimension,
height, and number of bays along height in their corresponding edit boxes. Next, choose the
OK button; the dialog box is closed and the tower will be created. Figure 2-53 shows a simple
tower modeled using default values.

m Tower Parameters X

Base Dimension:
Top Dimension:

© Height: 50

No. of Bays Along
Heinht:

: 111

Cancel ‘ 0
z

Figure 2-52 The Tower Parameters dialog box Figure 2-53 A simple tower created using
default values
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Example 10

In this example, you will create Howe Bridge in Structure Wizard and transfer it to STAAD.Pro.
Figure 2-54 shows the structure of Howe Bridge to be created in this example.

.

Figure 2-54 The Howe Bridge model

Steps required to complete this example are given below:

Step 1: Create a new file in STAAD.Pro with the name ¢02_staad_connect_ex10.std and browse to
the location C:\STAAD Examples\c02_staad_connect_exm by clicking the button next to the Location
edit box. Select Analytical from the Type area and Metric from the Units area in the Model
Information page.Next, choose the Create button; the user interface screen is displayed. Select
Structure Wizard from the Structure panel of the Geometry tab; the default.stp - StWizard
window is displayed.

Step 2: In this window, ensure that the Truss Models option is selected in the Model Type
drop-down list.

Step 3: Double-click on the Howe Bridge option in the left pane; the Select Parameters dialog
box is displayed.

Step 4: In this dialog box, specify the length, height, width, and number of bays parameters,
as shown in Figure 2-55.
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Select Parameters X

Model Mame: |HDWE! Eridge |

Length: m Mo. of bays along length: D
Height: m
Width: m Mo. of bays along width:

Apply Cancel

Figure 2-55 The Select Parameters dialog box

Step 5: Choose the Apply button; the model is created and displayed in the window, as shown
in Figure 2-56.

Figure 2-56 The Howe bridge model

Step 6: Choose the Add/Paste Model in STAAD.Pro option from the Edit menu in the StWizard
window; the StWizard message box appears.

Step 7: Choose the Yes button; the Paste Prototype Model dialog box is displayed. Choose the OK
button; the model is displayed in the main area of the STAAD.Pro window, refer to Figure 2-54.

Step 8: Choose the Save option from the File menu to save the file and then close it by choosing
the Close option from the File menu.
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Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this

chapter:

1. The command is used for creating nodes.

2. The command repeats the previous line of input specified in the STAAD Editor
window.

3. Inthe grid system, the construction lines are perpendicular to each other.

4. The command is used for creating solid elements.

5. In STAAD.Pro, plates are used to model slabs and shear walls. (T/F)

6. You can create nodes and members simultaneously using the Snap/Node Beam method.
(T/F)

7. In STAAD.Pro, the Structure Wizard contains the prototype models. (T/F)

Review Questions

Answer the following questions:

1.

Which of the following commands is used to create members?

a) Joint Coordinates b) Element Incidences
¢) Member Incidences d) None of these

Which of the following commands repeats all the previously defined inputs?

a) Finish b) Repeat
¢) Repeat All d) All of the above

Which of the following methods is used to create nodes and members simultaneously?

a) Snap/Node Plate b) Snap/Node Beam
¢) Snap/Node Solid d) None of these

Which of the following grid styles can be used to create circular structures?

a) Radial b) Linear
¢) Irregular d) All of these
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5. In STAAD.Pro, you can create members before creating the nodes. (T/F)
6. Solid elements are the eight-noded elements. (1/F)

7. The Truss Models template contains various prototype truss models. (T/F)

Answers to Self-Evaluation Test
1. Joint Coordinates, 2. Repeat, 3. Linear, 4. Element Incidences Solid, 5. 1, 6.1, 7. T



