
Chapter 4

Working with Splines-I 
 Learning Objectives 
After completing this chapter, you will be able to:
• Create 2D shapes
• Modify splines
• Change bezier splines
• Work with transform centers
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INTRODUCTION
In 3ds Max, splines are used to create various shapes. The advantage of using splines in place of 
primitive objects is that they require less number of segments to create an object. In this chapter, 
you will learn to create and modify different types of splines using the Edit Spline modifier. 

TUTORIALS
 Tutorial 1
In this tutorial, you will create different 2D splines such as a line, circle, rectangle, arc, and text. 
You will modify the vertices and segments, and also adjust the splines using bezier handles. In 
addition, you will transform the shapes using different transform centers.            

(Expected time: 25 min)

The following steps are required to complete this tutorial:

a.	 Create the project folder.
b. 	 Create 2D Shapes.
c.	 Modify vertices, segments, and splines.
d.	 Change bezier splines.
e.	 Lock handles.
f.	 Create and modify splines.
g.	 Copy an object.

Creating the Project Folder
Create a project folder with the name c04_tut1 in the 3dsmax 2021 folder as discussed in Tutorial 
1 of Chapter 2.

Creating 2D Shapes
In this section, you will create 2D shapes in the form of spline polygons.
	
1.	 Activate the Top viewport and then invoke the Maximize Viewport Toggle tool from the 

viewport navigation controls to maximize the Top viewport.

2.	 Invoke the 2D Snap tool from the Snaps Toggle flyout in the Main Toolbar to turn  
on snaps. Right-click on the 2D Snap tool; the Grid and Snap Settings dialog box 
is displayed. In the Snaps tab, make sure that only the Grid Points check box is 
selected and then close the dialog box.

3.	 Choose Create > Shapes in the Command Panel. Next, invoke the Line tool from 
the Object Type rollout.

4.	 Click at a point in the viewport to create the first vertex. Next, move the mouse and click at 
points where you need to create the rest of the vertices; a line is created in the Top viewport, 
refer to Figure 4-1 (top-left). Now, right-click to exit the tool.
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5.	 Invoke the Zoom tool from the viewport navigation controls. Click near the center  
of the viewport and drag the cursor vertically downward. Release the mouse button 
after increasing the drawing display area.

6.	 Invoke the Rectangle tool from the Object Type rollout.

7.	 Press and hold the mouse button at a point and then drag the cursor to select the diagonally 
opposite corner; a rectangle is created, refer to Figure 4-1. You can press and hold the CTRL 
key to make a square. Right-click to exit the tool.

8.	 Invoke the Circle tool from the Object Type rollout. Next, press and hold the mouse button 
at a point as the center of the circle and then drag the cursor to set the radius, refer to 
Figure 4-1.

                                                                                                                                              
9.	 Invoke the Arc tool from the Object Type rollout. Press and hold the mouse button at a 

point to create the first endpoint of the arc. Next, drag to create the second point and then 
release the left mouse button. Now, drag and click again in the viewport to specify the third 
and fourth points to set the radius of the arc, refer to Figure 4-1.

Figure 4-1  Different spline shapes created in the Top viewport

10.	 Invoke the Text tool from the Object Type rollout. In the Parameters rollout, select Arial 
from the drop-down list, if it is not already selected. Next, select MAX Text from the Text 
edit box and then enter G.

11.	 Click at a point in the viewport to position the text, refer to Figure 4-1. Invoke the Select 
and Move tool from the Main Toolbar. Next, press and hold the left mouse button and 
drag the cursor to move the text and place it on the screen at a proper position. You can 
also scale the text as required by using the Select and Uniform Scale tool.
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12.	 Click on the empty area of the viewport to deselect any selected shape.

13.	 Invoke the Zoom Extents tool from the viewport navigation controls to view the text clearly 
in the viewport. Next, choose Edit > Hold from the menu bar to copy the current scene to 
a buffer. This can be retrieved later using the Fetch option.

Modifying Vertices, Segments, and Splines
In this section, you will convert the alignment of vertices from linear to curved and vice versa.

1.	 Select the text object and then select the circle using the CTRL key. 

2.	 Choose the Modify tab in the Command Panel. Select Edit Spline from the Modifier
List drop-down list. Next, choose the Vertex button in the Selection rollout; the Edit 
Spline modifier is applied to the shapes and the Vertex sub-object mode is activated. 
The vertices of both the shapes are displayed in the viewport.

	
3.	 Right-click on the vertex on the right side of the circle; a quad menu is displayed. Choose 

Corner from the upper-left quadrant of the quad menu, as shown in Figure 4-2.

Figure 4-2  Choosing Corner from the upper-left quadrant of the quad menu  

4.	 Make sure the text is selected and right-click on the vertex on the left side of the text.  Choose 
Corner from the upper-left quadrant of the quad menu displayed; the curved vertices are 
changed to corner, as shown in Figure 4-3.

5.	 Right-click on the vertex on the right side of the circle; the quad menu is displayed.  Choose 
Smooth from the upper-left quadrant of the quad menu to make the circle smooth. Choose 
the Vertex button to exit the sub-object mode. Now, select the rectangle.
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Figure 4-3  The curved vertices changed to corner

Note
You cannot select a new shape when you are in the sub-object mode.
	

6.	 Select Edit Spline from the OBJECT-SPACE MODIFIERS section in the Modifier List 
drop-down list. Next, choose the Vertex button in the Selection rollout; the Edit Spline 
modifier is applied to the rectangle and the Vertex sub-object mode is activated. Also, the 
vertices are displayed in the viewport.

7.	 Right-click on the lower-left vertex of the rectangle; quad menu is displayed. Choose Smooth 
in the upper-left quadrant of the quad menu. Now, right-click on the upper-right vertex 
of the rectangle and then choose Smooth from the quad menu displayed; the two linear 
vertices become curved resulting in a curved shape, as shown in Figure 4-4. Similarly, you 
can convert the linear segments into curved segments and vice versa.

Figure 4-4  Two corners of the rectangle changed to smooth curves
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8.	 Choose the Segment button in the Selection rollout; the Segment sub-object mode of 
the Edit Spline modifier of the rectangle is activated.

                                                                                                                                                      
9.	 Drag a selection window around the rectangle to select all segments. The segments turn 

red. Right-click anywhere on the rectangle to display the quad menu. Choose Line from 
the upper-left quadrant; the curved segments become linear and the rectangle is restored, 
as shown in Figure 4-5. You can also convert the linear spline into a curved spline and vice 
versa.

Figure 4-5  The rectangle restored to its original shape

10.	 Choose the Segment button in the Selection rollout to exit the sub-object mode.
	
11.	 Select the object created using the Line tool. Next, make sure the Modify tab is chosen  

in the Command Panel. In the Selection rollout, choose the Spline button to enter 
the Spline sub-object mode.

Note
There is no need to apply the Edit Spline modifier to the shapes that were created using the Line tool. 

12.	 Right-click on the spline; the quad menu is displayed. Choose Curve from the upper-left 
quadrant of the quad menu; the whole spline becomes curved, as shown in Figure 4-6.

Changing Bezier Splines
There are two types of bezier vertices: the Bezier vertex and the Bezier Corner vertex. In this 
section, you will adjust spline curvature with the help of bezier handles.

1.	 Choose Edit > Fetch from the menu bar; the About to Fetch. OK? message box is displayed, 
as shown in Figure 4-7. Choose the Yes button from the message box to restore the scene 
from buffer.
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Figure 4-6  The curved line spline

Figure 4-7  The About to Fetch. OK? 
message box 

2.	 Select the rectangle in the viewport and then make sure the Modify tab is chosen in the 
Command Panel. Select Edit Spline from the OBJECT-SPACE MODIFIERS section in the 
Modifier-List drop-down list; the Edit Spline modifier is applied. Next, choose the Vertex 
button in the Selection rollout to enter into the Vertex sub-object mode.

3.	 Right-click on the top-left vertex of the rectangle; a quad menu is displayed. Choose Bezier 
from the upper-left quadrant of the quad menu; two vector handles are displayed in a straight 
line forcing the left segment into a curve. 

4.	 Invoke the Select and Move tool from the Main Toolbar. Next, invoke the 2D Snap tool 
again from the Snaps Toggle flyout in the Main Toolbar to turn it off. Drag one of the 
handles to form the shape shown in Figure 4-8; both handles move such that the vertex 
remains tangent to the segments.
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Note
On choosing the transform gizmo button, an axis constraint is set. Therefore, it is often difficult 
to move the handles as desired while the transform gizmo is active. You may need to turn off the 
transform gizmo while working with bezier handles. To turn off the transform gizmo, choose 
Views > Show Transform Gizmo from the menu bar.  On choosing Show Transform Gizmo 
again, the transform gizmo will be restored in the viewport.
	

Figure 4-8  Shape of the rectangle after dragging one of the handles

5.	 Press and hold the SHIFT key and move the left handle up toward the left direction; the 
SHIFT key breaks the tangent by allowing you to move the selected handle converting the 
bezier vertex into a bezier corner vertex; only the segment associated with this handle is 
affected whereas the other handle remains unchanged, as shown in Figure 4-9.

6.	 Right-click on the same vertex again to display the quad menu and choose Bezier from it; 
the changed segment automatically assumes its previous shape forcing the moved handle 
to be in a straight line with the unchanged handle.

Locking Handles
For any vertex, there are two bezier handles that are used to set the tangency. By selecting the 
Lock Handles check box in the Selection rollout and selecting the Alike radio button, you can 
simultaneously transform all similar bezier handles (all lead-in handles or all lead-out handles) 
for the  selected vertices. When the All radio button is active, you can simultaneously move both 
handles for all the selected vertices. In this section, you will explore the use of the Lock Handles 
check box and the radio buttons discussed above.

1.	 Choose Edit > Fetch from the menu bar; the About to Fetch. OK? message box is displayed.

2.  	 Choose the Yes button in this message box; the original shape of the rectangle is 
restored.	
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Figure 4-9  Curved line segments of the spline 

3.	 Select the rectangle and apply the Edit Spline modifier, as discussed earlier.

4.	 Choose the Vertex button in the Selection rollout and select all the vertices in the shape by 
dragging a selection window around the rectangle; the bezier handles are displayed on all 
the vertices.

5.	 In the Selection rollout, clear the Lock Handles check box if it is selected.        
	
6.	 Invoke the Select and Move tool. Next, select the lower handle of the top-left vertex. Now, 

drag it to left; only the selected handle is affected and only the segment connected to it 
changes, as shown in Figure 4-10.

7.	 Choose the Undo button to reverse the changes. In the Selection rollout, select the Lock 
Handles check box. Also, make sure the Alike radio button is selected. Select all vertices in 
the rectangle in the viewport.

8.	 Select the lower handle of the top-left corner vertex and drag it to left; the selected handle 
and all other lead-in handles for the selected vertices are affected, and all segments connected 
to them are changed, as shown in Figure 4-11.
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Figure 4-10  Adjusting the bezier handles

Figure 4-11  All similar bezier handles affected by the Lock Handles check 
box and the Alike radio button 

9.	 Press CTRL + Z to reverse the changes. In the Selection rollout, select the All radio button.

10.	 Select the lower handle of the top-left corner vertex and drag it to left. Release the left mouse 
button; all the handles are affected and all the segments are changed, refer to Figure 4-12.
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Figure 4-12  All bezier handles affected on selecting the All radio button 

Creating and Modifying Splines
In this section, you will create some more splines and modify them using options in the rollouts.

1.	 Choose File > New > New All from the File menu; the Autodesk 3ds Max 2021 message 
box is displayed, as shown in Figure 4-13. Choose the Don’t Save button; all shapes are 
removed and a blank screen is displayed. But the viewport layout, which contains maximized 
Top viewport, is retained.

Figure 4-13  The Autodesk 3ds Max 2021 message box

2.	 Choose Create > Shapes in the Command Panel. Next, invoke the Ellipse tool from the 
Object Type rollout. Create an ellipse in the Top viewport.

3.	 Invoke the Rectangle tool from the Object Type rollout. Press and hold the CTRL key and 
draw a square, as shown in Figure 4-14.

4.	 Invoke the Select Object tool, press and hold the CTRL key, and select the ellipse and 
square.
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Figure 4-14  The ellipse and square created in the Top viewport 

5.	 Choose the Modify tab in the Command Panel. Select Edit Spline from the OBJECT-SPACE 
MODIFIERS section in the Modifier List drop-down list; the Edit Spline modifier is applied 
to both shapes.

6.	 Choose the Segment button in the Selection rollout.

7.	 Select the lower-right segment of the ellipse. Press and hold the CTRL key and select the 
left and lower side of the square as well; all three segments turn red indicating that they are 
selected.

8.	 Choose the Delete button in the Geometry rollout or press the DELETE key; the selected 
segments are deleted from the shapes and the ellipse and the square become two open 
splines, as shown in Figure 4-15.

9.	 Choose the Spline button in the Selection rollout.
	
10.	 Click anywhere on the remaining portion of the square; the spline turns red indicating 

selection. Notice that the ellipse is not selected.
	
11.	 Choose the Close button in the Geometry rollout; the end vertices of the two remaining 

segments are joined by a curved segment and the spline is closed, as shown in Figure 4-16.

12.	 Choose the Undo button to reverse the changes. Next, choose the Vertex button in the 
Selection rollout.
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Figure 4-15  Selected segments deleted from the shapes

Figure 4-16  The closed spline

13.	 Choose the Connect button in the Geometry rollout. Next, select the end vertex of the square 
segment and then drag the cursor toward the other end vertex. When you move the cursor 
over the other end vertex, the cursor icon gets changed. Also, a dashed line is attached to 
the cursor while dragging, as shown in Figure 4-17.

14.	 Release the mouse button; the two vertices are joined by a straight segment, as shown in 
Figure 4-18.
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Figure 4-17  A dashed line attached to the end vertices

Figure 4-18  The two vertices joined by a straight segment

15.	 Choose the Undo button to reverse the changes. Next, choose the Insert button in the 
Geometry rollout.

16.	 Move the cursor and place it near the middle of the top segment of the remaining square; 
the cursor icon changes.

17.	 Click anywhere in the top segment to insert the vertex and then move the cursor down. 
Click again to position the vertex.
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18.	 Move the cursor to the left and click to place another vertex, refer to Figure 4-19. Right-click 
to complete the command.

Figure 4-19  New vertices added to the segment

19.	 Choose the Undo button to reverse the changes. Next, invoke the Select Object tool  
and select the white colored end vertex. The direction of the spline runs from the first 
vertex to the last vertex. The first vertex is yellow in color.

20.	 Choose the Make First button in the Geometry rollout; the selected vertex becomes yellow 
in color indicating that now it is the first vertex. Since the vertex is selected, it is red in color.

21.	 Choose the Insert button in the Geometry rollout. Next, move the cursor and place it 
near the middle of the top segment of the remaining portion of the square; the cursor icon 
changes.

22.	 Click to place the vertex and then move it down. Click again to position the vertex.

23.	 Move the cursor to the right and click again to place another vertex. Right-click to complete 
the command.

	
	 As the direction of the spline has changed, the resulting shape is different from the one 
	 created previously by adding vertices, refer to Figure 4-20.

	 Next, you will work with transform centers. There are three types of transform centers: pivot 
point, selection, and transform coordinate. The effect on objects due to rotation and scale 
transforms differs depending on the type of transform center selected.

24.	 Choose File > New > New All from the File menu; the Autodesk 3ds Max 2021 message 
box is displayed. Choose the Don’t Save button; all shapes are removed.
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Figure 4-20  The resulting shape created after changing the direction of the spline

25.	 Invoke the Zoom Extents tool. Next, choose Create > Shapes in the Command 
Panel. Next, invoke the Rectangle tool. Draw a small rectangle near the upper-left 
corner of the Top viewport.

26.	 Invoke the Ellipse tool and draw a small ellipse close to the rectangle, as shown in Figure 4-21.
 

Figure 4-21  A rectangle and an ellipse created 
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27.	 Choose Edit > Hold from the menu bar to copy the current state to a buffer. This can be 
retrieved later using the Fetch option.

28.	 Make sure the Snaps Toggle tool is turned off. Next, invoke the Select and Rotate tool and 
make sure the Transform Gizmo Z Constraint button is chosen. 

29.	 Make sure the ellipse is selected and then invoke the Angle Snap Toggle tool to turn the 
angle snap on.

                                                                                                                                            
	 The Use Pivot Point Center tool in the Main Toolbar is invoked by default.               

30.	 Rotate the ellipse until 0.00, 0.00, 90.0 is displayed in the coordinate display; the ellipse is 
rotated about its pivot point which is at the center of the ellipse, as shown in Figure 4-22.

Figure 4-22  The ellipse rotated to 90 degrees 

31.	 Invoke the Select and Uniform Scale tool from the Main Toolbar and make sure the 
Transform Gizmo XY Plane Constraint button is chosen in the Axis Constraints toolbar. 
Select the rectangle and scale it until 50, 50, 50 is shown in the coordinate display; the 
rectangle is scaled about its pivot point which is at the center of the rectangle, as shown in 
Figure 4-23.

32.	 Choose Edit > Fetch from the menu bar to retrieve the original drawing; the About to 
Fetch. OK message box is displayed. Choose the Yes button in this dialog box; the original 
shape of the rectangle and the ellipse is restored.

33.	 Invoke the Select and Rotate tool and make sure the Transform Gizmo Z Constraint button 
is chosen. Make sure the Snaps Toggle tool is deactivated and the Angle Snap Toggle tool 
is invoked.
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Figure 4-23  The rectangle scaled to its pivot point

34.	 Use the CTRL key to select both the ellipse and the rectangle. Make sure the Use selection 
Center tool is invoked in the Use Pivot Point Center flyout of the Main Toolbar which shows 
the transform gizmo at the center point of the combined selection.

35.	 Rotate both objects until 0.00, 0.00, 40.00 is shown in the coordinate display and in the 
viewport display; the objects are rotated about their combined center point, as shown in 
Figure 4-24.

Figure 4-24  Both objects rotated around the center of their combined center point 
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36.	 Restore the original drawing by choosing the Undo button. Make sure the Select and Rotate 
tool is invoked in the Main Toolbar.

37.	 Select only the ellipse. Next, invoke the Use Transform Coordinate Center tool from
the Use Selection Center flyout. Also, select World from the Reference Coordinate 
System drop-down list located next to the Select and Place tool. Note that the axis 
tripod moves to the world origin, which is probably near the center of the viewport.

	
38.	 Make sure that the Angle Snap Toggle tool is invoked in the Main Toolbar and then rotate 

the ellipse until 0.00, 0.00, -90.00 is shown in the coordinate display; the ellipse is rotated 
with respect to the origin of the world space, as shown in Figure 4-25.

Figure 4-25  The rotated ellipse after selecting World from the Reference Coordinate System 
drop-down list

Copying an Object
In this section, you will use the SHIFT key with the transform commands to make a copy of the 
original object.
	
1.	 Choose File > New > New All from the File menu; the Autodesk 3ds Max 2021 message 

box is displayed. Choose the Don’t Save button; all the shapes are removed and a blank 
Top viewport is displayed.

2.	 Choose Create > Shapes in the Command Panel. Next, invoke the Rectangle tool from the 
Object Type rollout. Expand the Keyboard Entry rollout and set the values as given next:

	 Length: 100			   Width: 100 

	 Choose the Create button; a square is created in the center of the Top viewport.
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3.	 Invoke the Select and Rotate tool and make sure the Transform Gizmo Z Constraint button 
is chosen. Select View from the Reference Coordinate System drop-down list if it is not 
already selected. Make sure the Use Pivot Point Center tool is also invoked. Also, ensure 
that the snap is turned off and the Angle Snap Toggle tool is invoked.

4.	 Press and hold the SHIFT key and make sure the square is selected and then rotate it, as 
shown in Figure 4-26. Next, release the mouse button and the SHIFT key when the square 
is rotated about 45 degrees; the Clone Options dialog box is displayed. Notice that the 
original square remains at its position, while its copy is rotated about its pivot point.

Figure 4-26  Rotating the square at an angle of 45 degrees

5.	 Make sure that the Copy radio button is selected in the Object area of the Clone Options 
dialog box. Choose the OK button in the dialog box; a copy of the square rotated at an 
angle of 45 degrees is created, as shown in Figure 4-27.

6.	 Invoke the Select and Uniform Scale tool from the Main Toolbar. Next, press and hold the 
left mouse button and the SHIFT key. Now, select the original square and scale it up to 50 
percent of its original size and release the left mouse button and the SHIFT key; the Clone 
Options dialog box is displayed.

7.	 Choose the OK button in the Clone Options dialog box; a copy of the square scaled down 
to half of its original size is created inside the two overlapping squares.

8.	 Select the first square that you cloned, press and hold the SHIFT key, and scale the square 
to 50 percent of its original size. Choose OK in the Clone Options dialog box; a copy of 
the rotated square, scaled down to half its size, is created, as shown in Figure 4-28.
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Figure 4-27  A copy of the square created by rotating it at 45 degrees

Figure 4-28  Both squares copied and scaled down to 50 percent of their original size
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 Tutorial 2
In this tutorial, you will create model of a table lamp using splines, as shown in Figure 4-29.          	
				                                                             (Expected time: 25 min)

Figure 4-29  The model of a lamp

						                  
The following steps are required to complete this tutorial:

a.	 Create the project folder.
b.	 Create base of the table lamp.
c.	 Create body of the table lamp.
d.	 Create shade and wire of the table lamp.
e.	 Save and render the scene.

Creating the Project Folder
Create a project folder with the name c04_tut2 in the 3dsmax 2021 folder as discussed in Tutorial 
1 of Chapter 2.

Creating Base of the Table Lamp
In this section, you will create base of the table lamp using the Circle tool and the Chamfer 
modifier.

1.	 Activate the Top viewport and then choose Create > Shapes in the Command Panel; the 
Splines option is displayed in the drop-down list located below it. Next, invoke the Circle 
tool from the Object Type rollout.

2.	 Expand the Keyboard Entry rollout and set the value 10 in the Radius spinner. Next, 
expand the Interpolation rollout and set the value 16 in the Steps spinner. Now, choose 
the Create button in the Keyboard Entry rollout; a circle is created in all viewports. 

3.	 Enter base in the Name and Color rollout. Invoke the Zoom Extents All tool; base is zoomed 
in all viewports, as shown in Figure 4-30.



Working with Splines-I		        4-23

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 4-30  The base zoomed in all viewports

4.	 Choose the Modify tab in the Command Panel. Next, select the Extrude option from the 
OBJECT-SPACE MODIFIERS section in the Modifier List drop-down list; the Extrude 
modifier is applied to base and displayed in the modifier stack. Also, various rollouts of this 
modifier are displayed in the Command Panel.

5.	 In the Parameters rollout, set the value 2 in the Amount spinner and 4 in the Segments 
spinner. Next, press the ENTER key; base is extruded, as shown in Figure 4-31. 

6.	 Activate the Perspective viewport and press F4. Notice that edges of base are now visible in 
the Perspective viewport.

7.	 Make sure the Modify tab is chosen and then select the Chamfer modifier from the 
OBJECT-SPACE MODIFIERS section in the Modifier List drop-down list; the Chamfer

	 modifier is displayed in the modifier stack and the Parameters rollout is displayed in the 
Command Panel.

8.	 In the Chamfer Options area of the Parameters rollout, set 0.2 in the Amounts spinner 
and 2 in the Segments spinner; base is smoothened, as shown in Figure 4-32.

Creating Body of the Table Lamp
In this section, you will create body of the table lamp using the Ellipse and Circle tools.

1.	 Activate the Top viewport and then choose Create > Shapes in the Command Panel; the 
Splines option is displayed in the drop-down list located below it. Next, invoke the Circle 
tool from the Object Type rollout.
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Figure 4-31  The base zoomed in all viewports

	 	

Figure 4-32  The base smoothened

2.	 Expand the Keyboard Entry rollout and set the value 2 in the Radius spinner. Next, 
expand the Interpolation rollout and make sure 16 is displayed in the Steps spinner. 
Now, choose the Create button in the Keyboard Entry rollout; a circle is created in all 
viewports with the name Circle001. 
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3.	 Choose the Modify tab in the Command Panel. Next, select the Extrude option from the 
OBJECT-SPACE-MODIFIERS section in the Modifier List drop-down list; the Extrude 
modifier is applied to Circle001 and displayed in the modifier stack. Also, various rollouts 
of this modifier are displayed in the Command Panel.

4.	 In the Parameters rollout, set the value 1 in the Amount spinner and make sure 4 is displayed 
in the Segments spinner. Next, press the ENTER key; Circle001 is extruded. 

5.	 Activate the Front viewport. Next, choose the Select and Move tool from the Main Toolbar  
and move Circle001, as shown in Figure 4-33. 

Figure 4-33  The Circle001 object moved

6.	 Make sure the Front viewport is activated. Next, choose Create > Shapes in the Command 
Panel; the Splines option is displayed in the drop-down list located below it. Next, invoke 
the Ellipse tool from the Object Type rollout.

7.	 Expand the Keyboard Entry rollout and set the value 12 in the Length spinner and 5 in 
the Width spinner. Next, expand the Interpolation rollout and make sure 16 is displayed in 
the Steps spinner. Now, choose the Create button in the Keyboard Entry rollout; an ellipse 
is created in all viewports with the name Ellipse001. 

8.	 Expand the Rendering rollout and select the Enable in Renderer and Enable in Viewport 
check boxes. Also, make sure that the Radial radio button is selected and set the value 0.5  
in the Thickness spinner. 

9.	  Align Ellipse001 on the top of Circle001, as shown in Figure 4-34. 

10.	 Make sure Ellipse001 is selected. Next, press and hold the SHIFT key and drag the cursor 
in the Y direction. Now, release the left mouse button; the Clone Options dialog box is 
displayed. In this dialog box, make sure the Copy radio button is selected. Also, set the 
value in the Number of Copies spinner to 2 and then choose the OK button; the copies of 
Ellipse001 are created with the names Ellipse002 and Ellipse003.
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Figure 4-34  Ellipse001 aligned

11. 	Select Ellipse002. Make sure the Modify tab is chosen in the Command Panel. In the 
Parameters rollout, set the value 16 in the Length spinner and 6 in the Width spinner. 

12.	 Select Ellipse003. Make sure the Modify tab is chosen in the Command Panel. In the 
Parameters rollout, set the value 20 in the Length spinner and 8 in the Width spinner. 

13. Align Ellipse002 and Ellipse003 in all viewports, as shown in Figure 4-35.

Figure 4-35  Ellipse002 and Ellipse003 aligned
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14.	 Activate the Top viewport and then choose Create > Shapes in the Command Panel; the 
Splines option is displayed in the drop-down list located below it. Next, invoke the Circle 
tool from the Object Type rollout.

15.	 Expand the Keyboard Entry rollout and set the value 1.25 in the Radius spinner. Next, 
expand the Interpolation rollout and make sure 16 is displayed in the Steps spinner. Now, 
choose the Create button in the Keyboard Entry rollout; a circle is created in all viewports. 
with the name Circle002. 

16.	 Choose the Modify tab in the Command Panel. Next, select the Extrude option from the 
OBJECT-SPACE MODIFIERS section in the Modifier List drop-down list; the Extrude 
modifier is applied to Circle002 and displayed in the modifier stack. Also, various rollouts 
of this modifier are displayed in the Command Panel.

17.	 In the Parameters rollout, set the value 12 in the Amount spinner and make sure 4 is 
displayed in the Segments spinner. Next, press the ENTER key; Circle002 is extruded. 

18.	 Activate the Front viewport. Next, choose the Select and Move tool from the Main Toolbar  
and align Circle002, as shown in Figure 4-36. 

Figure 4-36  Circle002 aligned

	 Next, you need to select all the objects excluding base and create a group.

19.	 Select Circle001, Circle002, Ellipse001, Ellipse002, and Ellipse003 using the CTRL key. Next, 
choose Group > Group from the menu bar; the Group dialog box is displayed. Enter body  
in the Group name edit box and choose the OK button to close the dialog box.
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20.	 Make sure that the group body is selected. Change the color of body to grey or black by using  
the color swatch in the Name and Color rollout of the Command Panel.

Creating Shade of the Table Lamp
In this section, you will create shade using the Circle tool.

1.	 Activate the Top viewport and then choose Create > Shapes in the Command Panel; the 
Splines option is displayed in the drop-down list located below it. Next, invoke the Circle 
tool from the Object Type rollout.

2.	 Expand the Keyboard Entry rollout and set the value 12 in the Radius spinner. Next, 
expand the Interpolation rollout and make sure 16 is displayed in the Steps spinner. Now, 
choose the Create button in the Keyboard Entry rollout; a circle is created in all viewports. 
with the name Circle003. 

3.	 Enter shade in the Name and Color rollout to rename it.

4.	 Choose the Modify tab in the Command Panel. Next, select the Extrude option from the 
OBJECT-SPACE MODIFIERS section in the Modifier List drop-down list; the Extrude 
modifier is applied to shade and displayed in the modifier stack. Also, various rollouts of 
this modifier are displayed in the Command Panel.

5.	 In the Parameters rollout, set the value 14 in the Amount spinner and 4 in the Segments 
spinner. Next, press the ENTER key; shade is extruded. 

6.	 Activate the Front viewport. Next, choose the Select and Move tool from the Main Toolbar  
and align shade, as shown in Figure 4-37. 

Figure 4-37  The shade object aligned
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7.	 Make sure the Modify tab is chosen and then select the Chamfer modifier from the 
OBJECT-SPACE MODIFIERS section in the Modifier List drop-down list; the Chamfer 
modifier is displayed in the modifier stack and the Parameters rollout is displayed in the 
Command Panel.

8.	 In the Chamfer Options area of the Parameters rollout, set 0.65 in the Amounts spinner 
and 2 in the Segments spinner; shade is smoothened, as shown in Figure 4-38.

Figure 4-38  The shade object smoothened

9.	 Make sure the Modify tab is chosen and then select the Edit Poly modifier from the 
OBJECT-SPACE MODIFIERS section in the Modifier List drop-down list; the Edit Poly

	 modifier is displayed in the modifier stack and various rollouts are displayed in the Command 
Panel.

10.	 In the modifier stack, click on the arrow sign on the left of the Edit Poly modifier to view 
all the sub-object levels and then select the Polygon sub-object level. 

	 Next, you will activate the Bottom viewport.

11.	 Click on the POV viewport label in the Top viewport; a flyout is displayed. Choose the Bottom 
option; the Top viewport is switched to the Bottom viewport. Now, select the polygon in the 
Bottom viewport and delete it, refer to Figure 4-39.
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Figure 4-39  The selected polygon

Saving and Rendering the Scene
In this section, you will save the scene that you have created and 

Figure 4-40  The rendered image 

then render it. You can also view the final rendered image of 
this model by downloading the c04_3dsmax_2021_rndr.zip file 
from www.cadcim.com. The path of the file is as follows: Textbooks 
> Animation and Visual Effects > 3ds Max > Autodesk 3ds Max 
2021 for Beginners: A Tutorial Approach

1.	 Change the background color of the scene to white by 
following the steps as given in Tutorial 1 of Chapter 2.

2.	 Choose Save from the File menu.

3.	 Activate the Perspective viewport. Next, invoke the Render 
Production tool from the Main Toolbar; the rendered 
image is displayed, refer to Figure 4-40.

Tutorial 3
In this tutorial, you will create the model of a vase by converting a 2D spline into a 3D 
mesh object and then place a flower plant in it, as shown in Figure 4-41.    
							        (Expected time: 25 min) 

The following steps are required to complete this tutorial:

a.	 Create the project folder.
b.	 Create a line spline for the vase.
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c.	 Apply the Lathe modifier. 
d.	 Assign the material to the vase.
e.	 Create a stand for the vase.
f.	 Save and render the scene.

Figure 4-41  The model of a vase with 
flower plant

Creating the Project Folder
Create a project folder with the name c04_tut3 in the 3dsmax 2021 folder as discussed in Tutorial 
1 of Chapter 2.

Creating a Line Spline for the Vase
In this section, you will create a profile similar to one-half of the vase using the Line tool. 

1.	 Activate the Front viewport and choose Create > Shapes in the Command Panel; the Splines 
option is selected by default in the drop-down list below the Shapes button. Now, choose 
the Line tool from the Object Type rollout.

2.	 In the Creation Method rollout, select the Corner radio button in both the Initial Type 
and Drag Type areas.

  	
3.	 Create a line spline as discussed in Tutorial 1. This spline should be similar to one-half of 

the vase, refer to Figure 4-42.

4.	 Choose the Modify tab and select the Vertex sub-object level in the modifier stack; all vertices 
of the line spline are displayed in the viewport. Next, select the vertices one by one in the 
viewport and modify the shape by moving them to get a perfect shape.

Applying the Lathe Modifier
In this section, you will apply the Lathe modifier to convert the 2D spline into the 3D mesh object. 

1.	 Select the first vertex of the spline in the Front viewport, as shown in Figure 4-43.  

2.	 Choose Modifiers > Patch/Spline Editing > Lathe from the menu bar; the 2D line spline 
is converted into a 3D mesh object.
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Figure 4-42  A line spline created for the vase Figure 4-43  The first vertex of the line 
spline selected in the Front viewport 

3.	 Name the new 3D mesh object as vase. Also, click anywhere in the viewport to deselect the 
vase.  

4.	 Choose the Zoom Extents All tool; the entire vase is displayed in the viewports, as shown 
in Figure 4-44. 

Figure 4-44  The vase geometry after applying the Lathe modifier 

Assigning Material to Vase
In this section, you will assign the material to vase using the Material Editor tool as discussed 
in Tutorial 1 of this chapter.

1.	 Choose Rendering > Material Editor > Compact Material Editor from the menu bar; the 
Material Editor dialog box is displayed.
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2.	 Select the 2-Sided check box in the Shader Basic Parameters rollout of the Material Editor 
dialog box. This enables you to view both sides of vase in the final output. Also, in the Blinn 
Basic Parameters rollout, choose the Diffuse color swatch; the Color Selector: Diffuse 
Color dialog box is displayed. In this dialog box, enter the values as follows:

	 Red: 177			   Green: 88			   Blue: 27

	 Choose the OK button in the Color Selector: Diffuse Color dialog box; the selected color 
is displayed in the Diffuse color swatch.	

3.	 Make sure that vase is selected in the viewports. Next, choose the Assign Material to
Selection button in the Material Editor dialog box; the selected material is assigned 
to vase in the viewport. Next, choose the Show Shaded Material in Viewport button 
in the same dialog box to view the material in viewport. Next, close the Material 
Editor dialog box.  

	 Next, you need to use the Foliage tool to place a plant in vase.

4.	 Activate the Top viewport. Choose Create > Geometry in the Command Panel; a drop-down 
list is displayed below the Geometry button. Select AEC Extended from the drop-down list 
and then choose the Foliage tool from the Object Type rollout.

5.	 In the Favorite Plants rollout, double-click on the Society Garlic foliage; the foliage is 
displayed in the viewports. 

6.	 In the Name and Color rollout, change the name of foliage to plant and press ENTER.

7.	 Make sure that plant is still selected. Choose the Modify tab in the Command Panel; the 
Parameters rollout is displayed.

8.	 In the Parameters rollout, set a value in the Height spinner to adjust the height of plant 
according to vase.

9.	 Choose the Select and Move tool and align plant with vase in the viewports, refer to 
Figure 4-45.	 

10.	 Select plant and vase in the viewports and group them as flower vase.   	

	 Next, you need to create a stand for flower vase. 

Creating a Stand for the Flower Vase
In this section, you will create a stand for the flower vase. 

1.	 Select flower vase and right-click on it; a quad menu is displayed. Choose the Hide Selection 
option from it; flower vase disappears temporarily from the viewports. Now, you can work 
easily in the viewports.
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Figure 4-45  Alignment of plant with vase in viewports

2.	 Activate the Top viewport. Choose Create > Shapes in the Command Panel; the Splines 
option is selected by default in the drop-down list below the Shapes button. Now, choose 
the Circle tool from the Object Type rollout and create a circular spline. 

3.	 In the Parameters rollout, set the radius of the circle to 11.662 in the Radius spinner.

	  You may need to modify the radius according to the scene in the later section.
  
4.	 Expand the Rendering rollout and select the Enable In Renderer and Enable In Viewport 

check boxes. Select the Radial radio button, if it is not already selected. Also, make sure 
that the Auto Smooth check box is selected. Now, enter the values as follows:

	 Thickness: 2.0		  Sides: 15			   Angle: 0.99	
	
5.	 The circular spline is automatically named as Circle001. Now, change its color by entering 

the values as follows:
	
	 Red: 193			   Green: 193			   Blue: 193	

6.	 Create another circle in the Top viewport. It is automatically named as Circle002.
 
7.	 In the Parameters rollout, set the radius value of Circle002. This radius should be double 

the size of radius of Circle001.
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8.	 Change the color of Circle002 to black.
	
9.	 Choose the Zoom Extents All tool and align both the circles using the Select and Move 

tool, as shown in Figure 4-46.

Figure 4-46  Alignment of the circles in viewports

10.	 Choose the Line tool from Create > Shapes > Splines > Object Type rollout.  

11.	 In the Creation Method rollout, select the Corner radio button in the Initial Type and Drag 
Type areas.  	

12.	 Activate the Top viewport. Next, create four line splines to join both the circles, as shown 
in Figure 4-47.

13.	 Assign black color to all line splines.
 
14.	 Select the line splines and both the circles in any viewport by dragging a selection box 

around them, and then group them as upper portion.  

15.	 Select upper portion and hide it temporarily as described earlier. 

	 Next, you need to create the legs for the stand using the Line tool.     

16.	 Activate the Front viewport. Next, choose the Line tool from Create > Shapes > Splines > 
Object Type rollout.  
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Figure 4-47  The line splines created to join both the circles

17.	 In the Creation Method rollout, select the Smooth radio button in both the Initial Type 
and Drag Type areas.  	

18.	 Create a line spline in the Front viewport, as shown in Figure 4-48. It uses the same parameters 
from the Rendering rollout that you had set earlier.

Figure 4-48  The line spline for the leg of stand

19. In the Rendering rollout, make sure that the Enable In Renderer and Enable In Viewport 
check boxes are selected. Select the Rectangular radio button and enter the values as follows:

	 Length: 2.0		     Width: 1.5		  Angle: 0.0
	
20.	 Name the line spline as leg01 and change its color to black.
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21.	 Right-click in any of the viewports; a quad menu is displayed. Choose the Unhide by Name 
option; the Unhide Objects dialog box is displayed. Select upper portion from the list given 
in this dialog box and choose the Unhide button; upper portion is now displayed in the 
viewport. Choose the Zoom Extents All tool.

Note
You can resize leg01 according to the size of the upper portion using the Select and Uniform 
Scale tool.

22.	 Align upper portion and leg01 in viewports, as shown in Figure 4-49.

Figure 4-49  Alignment of upper portion and leg01 in viewports

	 Next, you need to copy the leg01 to create other legs.

23.	 Create three copies of leg01; they are automatically named as leg002, leg003, and leg004. 

24.	 Align leg01, leg002, leg003, and leg004 using the Select and Move and Select and Rotate 
tools, as shown in Figure 4-50.   

25.	 Select all the objects in the viewport and group them as vase stand.

26.	 Right-click on the viewport; a quad menu is displayed. Choose the Unhide All option; all 
the hidden objects are displayed in the viewports. 

27.	 Align flower vase and vase stand and choose the Zoom Extents All tool, refer to Figure 4-51. 
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Note
You can adjust the size of the flower vase according to the size of the vase stand using the Select 
and Uniform Scale tool.

Figure 4-50  Alignment of leg01, leg002, leg003, and leg004 in viewports

Figure 4-51  Alignment of flower vase and vase stand in viewports
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Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can also 
view the final rendered image of this model by downloading the c04_3dsmax_2021_rndr.zip file 
from www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > 
3ds Max > Autodesk 3ds Max 2021 for Beginners: A Tutorial Approach

1.	 Change the background color of the scene to white by following the steps as given in 
Tutorial 1 of Chapter 2.

2.	 Choose Save from the File menu.

3.	 Activate the Perspective viewport. Next, invoke the Render Production tool from the Main 
Toolbar; the rendered image is displayed, refer to Figure 4-41.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:
	
1.	 Which of the following options is used to convert a curved spline into a linear spline?

		  (a)    Bezier	 			   (b)    Bezier Corner 	 	
		  (c)    Corner	 			   (d)    Smooth

2.	 Which of the following buttons is chosen to enter the spline sub-object mode?

		  (a) Spline				    (b) Line
		  (c) Vertex				    (d) None

3.	 You need to choose __________ from the Edit menu to copy the existing state on the screen 
to a buffer.	

4.	 When you choose the Vertex button in the Selection rollout to turn it on, the __________ 
of the selected shape are displayed.

	
5.	 You can change the curvature through a vertex by manipulating the __________ of 

the 	vertex.

6.	 There are two types of bezier vertices, Bezier and __________.
	
7.	 The two bezier handles at any vertex are used to move the lead in and out of the vertex. 

(T/F)

8.	 When the Connect button in the Geometry rollout (in the Vertex sub-object mode) is used, 
the two vertices of a spline are joined by a curved segment. (T/F)
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9.	 The first vertex in a spline has white color. (T/F)

10.	 The Edit Spline modifier need not to be applied to the shapes created using the Line tool. 
(T/F)

 Review Questions 
Answer the following questions:

1. 	 Which of the following tools is used to bring the transform gizmo to the center point of the 
selected object?

		  (a) Use Transform Coordinate Center		  (b) Use Pivot Point Center  
		  (c) Use Selection Center			   (d) Select and Uniform Scale

2. 	 Which modifier is used to modify the shape of the splines?

		  (a) Edit Poly					     (b) Edit Spline 
		  (c) Edit Mesh					     (d) None of these

3.	 The __________ option is used to convert a linear spline into a curved spline.

4.	 The __________ option is used to restore the previously saved state from the buffer.

5.	 To turn the transform gizmo on and off, choose __________ from the Views menu.

6.	 The __________ button is used to bring the transform gizmo to the center point of the 
selected object.

7.	 The Edit Spline modifier helps you to modify the shape of splines. (T/F)

8.	 When the Use Selection Center tool becomes active on using the Rotate command, the 
selected objects are rotated along their individual pivot points. (T/F)

9.	 The first vertex of the spline is always yellow colored. (T/F)

10.	 You cannot select a new shape when you are in the sub-object mode. (T/F)

EXERCISES
The rendered output of the model used in the following exercises can be accessed by 
downloading the c04_3dsmax_2021_exr.zip from www.cadcim.com. The path of the file is as follows: 
Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds Max 2021 for Beginners: A Tutorial 
Approach
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Exercise 1
Draw the following shapes by using the dimensions of your choice, refer to Figure 4-52. Create 
their copies and transform them as required.			         (Expected time: 20 min)

Figure 4-52  Drawing different shapes

 Exercise 2
Create the model of a street lamp, as shown in Figure 4-53, by applying dimensions of your 
choice. 	     	       						             (Expected time: 30 min)

Figure 4-53  The model of a street lamp
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Answers to Self-Evaluation Test
1. c, 2. a, 3. Hold, 4. vertices, 5. bezier handles, 6. Bezier Corner, 7. T, 8. F, 9. F, 10. T


