Chapter 9

Material Editor:
Texture Maps-Il

Learning Objectives

After completing this chapter, you will be able to:
* Create transparent materials
* Apply transparency maps to objects

* Create procedural maps
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INTRODUCTION

In this chapter, you will create materials using opacity and procedural maps. An opacity map is
used to control the transparency of a material. It can be applied to a simple 3D object to give it
the appearance of a complex shape. Unlike a bitmap which contains a fixed number of pixels,
a procedural map is generated in two or three dimensions by using a mathematical algorithm.

TUTORIAL

Before starting the tutorial, you need to download the ¢09_3dsmax_2020_tut.zip file from
www.cadcim.com. 'The path of the file is as follows: Textbooks > Animation and Visual Effects > 3ds
Max > Autodesk 3ds Max 2020 for Beginners: A Tutorial Approach

Extract the contents of the zip file and save them in the Documents folder.

Tutorial 1

In this tutorial, you will create materials using special texture maps. You will use the opacity and
diffuse color maps to make a square block look like a flower, refer to Figure 9-1.
(Expected time: 20 min)

Figure 9-1 Materials applied to models

The following steps are required to complete this tutorial:

Create the project folder.

Open the file.

Create a new material library.
Create the vase material.

Create the flower material.
Create the wood block material.
Assign the material to the objects.
Save and render the scene.
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Creating the Project Folder
Create the project folder with the name c09_tutl in the 3dsmax 2020 folder as discussed in
earlier chapters.

Opening the File
1. Open Windows Explorer and then browse to |Documents\c09_3dsmax_2020_tut. Next, copy
all the image files to \Documents\3dsmax 2020\c09_tutl\sceneassets\images.

2. Choose Open from the File menu; the Open File dialog box is displayed. In this dialog box,
browse to the location |Documents\c09 3dsmax_2020 tut and select the c09_tutl_start.max
file from it. Choose the Open button to open the file, refer to Figure 9-2.

J[Camesa-Flowes ] [Standard ] [Defauk Shading ]

s
.

Figure 9-2 The c09_tutl_start file

3. Choose Save As from the File menu; the Save File As dialog box is displayed. Browse
to the location \Documents\3dsmax 20201¢09_tutl\scenes. Save the file with the name
c09tutl.max at this location.

Creating a New Material Library
In this section, you will create a new material library which contains materials created in the scene.

1. Choose Rendering > Material Editor > Compact Material Editor from the menu bar;
the Material Editor dialog box is displayed. You will notice that in the first slot, there is a
material named Stem which is applied to the flower stems.

2. Choose the Get Material button in the Material Editor dialog box; the Material/Map
Browser dialog box is displayed. -

3. Choose the Material/Map Browser Options button from the Material/Map Browser dialog
box; a flyout is displayed. Choose New Material Library from this flyout; the Create New
Material Library dialog box is displayed.
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As the project folder is already set, the materiallibraries folder of this project is displayed in
the Save in drop-down list of this dialog box.

Enter Still-Life in the File name text box as the new name for the material library and
choose the Save button; the new Still-Life material library is created in the Material/Map

Browser dialog box.

Close the Material/Map Browser dialog box to return to the Material Editor dialog box.

Creating the Vase Material
In this section, you will create the transparent vase material by setting different parameters in
the Material Editor dialog box.

1.

Select the second material sample slot in the Material Editor dialog box to make it the
current sample.

In the Shader Basic Parameters rollout, select Blinn from the drop-down list, if it is not
already selected.

In the Blinn Basic Parameters rollout, unlock the Ambient and Diffuse color swatches.
Next, choose the Ambient color swatch; the Color Selector: Ambient Color dialog is
displayed.

In the Color Selector: Ambient Color dialog box, set the values as given next:
Red: 133 Green: 166 Blue: 47

The ambient color is set to green. Choose the OK button to close the Color Selector:
Ambient Color dialog box.

Choose Rendering > Environment from the menu bar or press 8; the Environment and
Effects dialog box is displayed. In the Global Lighting area of the Common Parameters
rollout, choose the Ambient color swatch; the Color Selector: Ambient Light dialog box
is displayed. In this dialog box, set the value 75 in the Value spinner and then choose the
OK button to close the dialog box. Next, close the Environment and Effects dialog box.

This ambient light will bring out the ambient portion of the material color, which was added
in the previous steps. If the ambient light value remained at 0, the ambient color settings

would have no effect on the appearance of the material.

In the Material Editor dialog box, choose the Diffuse color swatch; the Color Selector:
Diffuse Color dialog box is displayed.

In this dialog box, set the values as given next and then choose the OK button to close this
dialog box:

Red: 153 Green: 175 Blue: 255
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10.

11.

12.

13.

14.

15.

In the Material Editor dialog box, choose the Specular color swatch; the Color Selector:
Specular Color dialog box is displayed.

In this dialog box, set the values as given next:
Red: 255 Green: 255 Blue: 255

Close the Color Selector: Specular Color dialog box.

In the Specular Highlights area of the Blinn Basic Parameters rollout, set the value 60 in
the Specular Level spinner.

Set the value 40 in the Glossiness spinner and 30 in the Opacity spinner.
Note that smaller the opacity value, more transparent the material will be.
Choose the Background button located in the right side of the Material Editor dialog

box; the background is displayed in the selected sample slot. This helps to view the
effect of transparency settings in a better way; refer to Figure 9-3.

-

Figure 9-3 The background displayed in the material
sample slot in the Material Editor dialog box

Next, you will name the material and save it in the material library.

Choose the Put to Library button in the Material Editor dialog box; a flyout is displayed.
Choose Still-Life.mat from the flyout; the Put To Library dialog box is displayed.

If the Material Editor message box is displayed prompting to put the entire material/
map tree to the library, choose the Yes button. If you are at the root level of the material
definition, the Material Editor message box does not appear because the entire tree is added
by default.

Enter Vase as the name of the new material in the Put To Library dialog box and choose
the OK button; the material is assigned the name Jase and is added to the Still-Life material
library.
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Creating the Flower Material
In this section, you will create the flower material using the opacity maps.

1.

10.

In the Material Editor dialog box, select the third material sample slot. Various rollouts are
displayed in the Material Editor dialog box to modify the Standard material.

Expand the Maps rollout. Next, choose the Diffuse Color map button, currently labeled
No Map; the Material/Map Browser dialog box is displayed showing the types of maps that
may be added.

Choose the Bitmap map from the Maps > General rollout and choose the OK button; the
Select Bitmap Image File dialog box is displayed.

In this dialog box, make sure All Formats is selected in the Files of type drop-down list. As
the project folder is already set, the images folder of this project is displayed in the Look in
drop-down list of this dialog box. Select the daisy.tif file and choose the Open button; the
image file is loaded and the parameters are displayed for the map in the Material Editor
dialog box.

In the Material Editor dialog box, click and hold the Sample Type button located on @
the right side of the material slots. Now, choose the Square button from the flyout
displayed; the sample slot in the Material Editor dialog box changes into square shape.

In the Coordinates rollout, make sure the Use Real-World Scale check box is cleared and
the value 1 is set in the U: Tiling and V: Tiling spinners.

The material uses daisy flower image. When the material is applied to an object, you want
the background portion of the image to be transparent. This can be done with an opacity
map. The map consists of another image of the daisy with the daisy portion completely
white (opaque) and the background portion completely black (transparent).

Choose the Go to Parent button in the Material Editor dialog box to move one
level up; the root level of the material is displayed.

In the Maps rollout, choose the Opacity map button that is currently labeled as No Map;
the Material/Map Browser dialog box is displayed showing the types of maps that can be
added.

Select the Bitmap map from the Maps > General rollout and choose the OK button; the
Select Bitmap Image File dialog box is displayed.

In this dialog box, make sure All Formats is selected in the Files of type drop-down list. As
the project folder is already set, the images folder of this project is displayed in the Look in
drop-down list of this dialog box. Select the daisy-o.tga file and choose the Open button;
the image file is loaded and the parameters are displayed for the map in the Material Editor
dialog box.
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11.

12.

You will notice that the preview of image displayed in the Select Bitmap Image File dialog
box has black and white areas. The white area will be opaque while the black area will be
transparent when the material is rendered.

In the Coordinates rollout, make sure the Use Real-World Scale check box is cleared and
set the value 1.0 in the U: Tiling and V: Tiling spinners.

Choose the Background button in the Material Editor dialog box; the material sample slot
reflects the effect of opacity map, as shown in Figure 9-4.

Figure 9-4 The material sample slot displayed in
the Material Editor dialog box

/ Note
@ The transparent area of the material will still accept specular highlights. In other words, it will

13.

14.

look like a clear glass. If you want the transparent areas of the material to be completely invisible,
you can set 0 in the Specular Level spinner of the Blinn Basic Parameters rollout or add a
specular level map that matches the opacity map.

Next, you will name the material and save it in the material library.

Choose the Put to Library button in the Material Editor dialog box; a flyout is displayed.
Next, choose Still-Life.mat from the flyout; the Put To Library dialog box is displayed.

If the Material Editor message box is displayed prompting to put the entire material/map
tree to the library, choose the Yes button, refer to Figure 9-5. If you are at the root level
of the material definition, the Material Editor message box does not appear because the
entire tree is added by default.

Enter Daisy as the name of the new material in the Put To Library dialog box and then
choose the OK button; the material is assigned the name Daisy and is added to the Still-Life
material library.
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0 Do you want to put the entire materialfmap tree to the library?

Yes : No Cancel

Figure 9-5 The Material Editor message box

Creating the Wood Block Material

In this section, you will create a wood procedural map.

1.

2.

Select the fourth material sample slot in the Material Editor dialog box.
Expand the Maps rollout. Next, choose the Diffuse Color map button that is currently

labeled as No Map; the Material/Map Browser dialog box is displayed, showing the types
of maps that can be added.

Choose Advanced Wood from the Maps > General rollout and choose the OK button; the
Material/Map Browser dialog box is closed and the parameters for the Advanced Wood map

are displayed in the Material Editor dialog box.

Various settings in the rollouts of the Material Editor dialog box allow you to control the
appearance of the wood material.

You can set the parameters in these rollouts as per your requirement.

Make sure Base is selected. Choose the Modify tab. Next, apply the UVW Map modifier to
it. In the Parameters rollout, select the Box radio button. Next, enter 400 in the Length
spinner.

As you change parameters, the material sample is dynamically updated.

Next, you will name the material and save it in the material library.

Choose the Go to Parent button twice in the Material Editor dialog box to move one g
level up; the root level of the material is displayed. Next, choose the Put to Library
button in the Material Editor dialog box; a flyout is displayed.

Choose Still-Life.mat from the flyout; the Put To Library dialog box is displayed.

Enter Wood as the name of the new material in the Put To Library dialog box and choose
the OK button; the material is assigned the name Wood and is added to the Still-Life material

library.

Next, you will save the Still-Life material library.
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Choose the Get Material button in the Material Editor; the Material/Map Browser
dialog box is displayed. e

Right-click on the Still-Life.mat in the Material/Map Browser dialog box; a flyout is
displayed. Choose Save from the flyout, as shown in Figure 9-6.

StillLifemat still-Life.mat Options | = | |

. Vase {8t AU T ——

| Bl S A\Users\CADCIMADocu ... \5till-Life.mat ¥ Reload

. Daisy (Sl

.de (g Edit Group Color .. Save b
—7% Rename Group ... Save As ..

[l checkere  Sort Alphabetically

| ECOCRE Update Scene Materials from Library
Bl CheckerR .t elected haterialshdaps
Il checker B Get All Scene Materials/Maps .

- signal.mat Show Subtree =
I Red light Display Material Library As »
Ml vl lin o, LW B S .

Figure 9-6 Saving the material library

10. Close the Material/Map Browser dialog box.

Assigning Materials to the Objects

In this section, you will assign materials to the objects in the scene.

1.

2.

Activate the Camera-Flower [Standard] [Default-Shading] viewport.

Invoke the Render Production tool from the Main Toolbar; the rendered image is displayed,
refer to Figure 9-7.

You will notice that all the objects except the stems are currently assigned a default material.
Notice that the flowers are created as simple 3D boxes. The opacity map on Daisy material
will give the flowers their shape. The stems already have an appropriate material assigned.
Also, the required mapping coordinates have already been applied to the objects.

Close the rendered image. Next, invoke the Select Object tool from the Main Toolbar.
Next, select Jase in the Camera-Flower [Standard] [Default Shading] viewport; the object is
highlighted and Jase is displayed in the Name and Color rollout.

In the Material Editor dialog box, select the material sample slot which is named e
as Jase and then choose the Assign Material to Selection button; the Jase material
is assigned to Jase. Next, choose the Show Shaded Material in Viewport button to

display the material on Jase in the viewport.

t www.cadcim.com
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Figure 9-7 The rendered image

5. Similarly, assign Daisy material to the two boxes representing the daisies. Also, assign Advanced
Wood material to Base. Next, choose the Show Shaded Material in Viewport button to display
the material on Base in the viewport.

The two boxes for the daisy flowers are a single object.
6. Select the first material sample slot in the Material Editor dialog box.
7. Choose the Diffuse Map button that is labelled as M.

8. Select the field located next to Bitmap in the Bitmap Parameters area; the Select Bitmap
Image File dialog box is displayed.

9. In this dialog box, navigate to the C:\Users\CADCIM|Documents\3dsmax 2020\c09_tutl\
sceneassets\images tolder and select EVERGREEN from it. Next, choose the Open button;
the map for the stem material is relinked.

10. Close the Material Editor dialog box.

Saving and Rendering the Scene

In this section, you will save the scene that you have created and then render it. You can also
view the final rendered image of this model by downloading the c09_3dsmax_2020_rndr.zip file
from www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects >
3ds Max > Autodesk 3ds Max 2020 for Beginners: A Tutorial Approach

1. Change the background color of the scene to light grey.

2. Choose Save from the File menu.
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3. Make sure the Camera-Flower [Shaded] viewport is activated. Next, invoke the Render
Production tool from the Main Toolbar; the rendered image is displayed, refer to Figure 9-8.

Figure 9-8 The rendered image with materials assigned to the objects

Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1. Which of the following maps is used to control transparency of the material?

(a) Opacity (b) Procedural
(c) Mix (d) None of these

2. Which of the following maps can be created to represent a solid piece of wood?

(a) Opacity (b) Procedural
(c) Mix (d) None of these

3. Which of the following buttons is used to move one root level up in the Material Editor
dialog box?

(a) Go to Parent (b) Get Material
(c) Material/Map Navigator (d) Put Material to Scene

4. Inan opacity map, the pixels will be completely transparent and the
pixels will be opaque.
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5. The lower the value in the Opacity spinner, the higher will be the transparency of the
material. (T/F)

6. Asyou change the parameters of the material types in the Material Editor dialog box, the

material sample is dynamically updated. (T/F)

Review Questions

Answer the following questions:

1. Which of the following buttons in the Material Editor is used to display the opacity effect?

(a) Background (b) Make Preview
(c) Backlight (d) None of these
2. The opacity maps help control the of a material.
3. The button in the Main Toolbar is used to render the current frame.

4. Ifyou apply a procedural map to an object with a whole cut in it, the texture will still appear
correct. (T/F)

EXERCISES

The rendered output of the models used in the following exercises can be accessed by download-
ing the ¢c09_3dsmax_2020_exrzip from www.cadcim.com. The path of the file is as follows: Textbook
> Animation and Visual Effects > 3ds Max > Autodesk 3ds Max 2020 for Beginners: A Tutorial Approach.

Exercise 1

Extract the contents of the ¢c09_3dsmax_2020 _exrzip and then open ¢09_exr01_start.max. Next,
create materials and assign them to three glasses placed on a tray, as shown in Figure 9-9. You
will require three transparent materials with different opacity settings.

(Expected time: 20 min)

Figure 9-9 Three glasses with assigned materials
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Exercise 2

Open c09_exr02_start.max. Create materials needed to assign to a scene displaying a broken piece
of marble and a wooden board with a notch cut in it, as shown in Figure 9-10. In this exercise,
you need to create two procedural map materials. (Expected time: 15 min)

Figure 9-10 Broken piece of marble and a wooden board
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Answers to Self-Evaluation Test
1. a, 2. b, 3. a, 4. black, white, 5. T, 6. T



