
•  Wireframe

•  Surface

•  Solids

•  ViewCube

•  DDVPOINT

•  3D Coordinate 
System

•  ELEV

•  Hide

•  3D Polyline

•  3D Face

•  PFACE

•  3DMESH

•  Edit Polyline

•  SteeringWheel

•  Orbit

•  3DCLIP

•  Nudge

 Key Terms 

Chapter 2
Getting Started 

with 3D

 Learning Objectives 
After completing this chapter, you will be able to:
• Start 3D workspace in AutoCAD for creating models
• Use three-dimensional (3D) drawing
• Use various types of 3D models
• Know conventions used in AutoCAD
• Use the Viewpoint Presets tool to view objects in 3D space
• Use the ViewCube to view objects easily in 3D space
• Know various types of 3D coordinate systems
• Set thickness and elevation for objects
• Dynamically view 3D objects using the Orbit tool
• Use the SteeringWheel for viewing a model
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STARTING THREE DIMENSIONAL (3D) MODELING IN 
AutoCAD
In AutoCAD, you can start the 3D Modeling in a separate workspace. All tools required to create 
the 3D design are displayed in this workspace by default. To start a new file in the 3D workspace, 
invoke the Select template dialog box and select the acad3D.dwt template. This template file 
supports the 3D environment. The other template files that support the 3D workspace are 
acadiso3D.dwt, acad -Named Plot Styles3D.dwt, and acadISO -Named Plot Styles3D.dwt. Next, select 
the 3D Modeling option from the Workspace drop-down list available at the right in the Status 
Bar. Figure 2-1 shows the 3D Modeling workspace of AutoCAD.

Figure 2-1  The 3D Modeling workspace of AutoCAD 

USE OF THREE-DIMENSIONAL DRAWING
The real world, and literally whatever you see around it, is three-dimensional (3D). Each and 
every design idea you think of is 3D. Before the development of 3D software packages, it was not 
possible to materialize these ideas in the design industry due to the lack of the third dimension. 
This is because the drawings were made on the drawing sheets, which are two dimensional 
objects with only X and Y coordinates. Therefore, it was not possible to draw the 3D objects. As 
prototyping is a very long and costly affair, therefore, the designers had to suppress their ideas 
and convert the 3D designs into 2D drawings. 

The use of computers and the CADD (Computer Aided Design & Drafting) Technology has 
brought a significant improvement in materializing the design ideas and creating the engineering 
drawings. You can create a proper 3D object in the computer using the CADD Technology. This 
technology allows you to create models with the third coordinate called the Z coordinate, in 
addition to the X and Y coordinates. Apart from materializing the design ideas, the 3D models 
have the following advantages: 

1. Generate the drawing views: Once you have created a 3D model, its 2D drawing views can 
be automatically generated.
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2. Provide realistic effects: You can provide realistic effects to the 3D models by assigning a 
material and providing light effects to them. For example, an architectural drawing can be made 
more realistic and presentable by assigning the material to the walls and interiors and adding 
lights to it. You can also create its bitmap image and use it in presentations.

3. Create the assemblies and check them for interference: You can assemble various 3D 
models and create the assemblies. Once the components are assembled, you can check them for 
interference to reduce the errors and material loss during manufacturing. You can also generate 
the 2D drawing views of the assemblies.

4. Create an animation of the assemblies: You can animate the assemblies and view the animation 
to provide the clear display of the mating parts.

5. Apply Boolean operations: You can apply Boolean operations to the 3D models.

6. Calculate the mass properties: You can calculate the mass properties of the 3D models.

7. Cut Sections: You can cut sections through the solid models to view the shape at that 
cross-section.

8. NC Programs: You can generate an NC program with the help of 3D models by using a CAM 
software.

TYPES OF 3D MODELS
In AutoCAD, depending on their characteristics, the 3D models are divided into the following 
three categories:

Wireframe Models
Wireframe models are created using simple AutoCAD entities such as lines, polylines, rectangles, 
polygons, or some other entities such as 3D faces, and so on. To understand the wireframe 
models, consider a 3D model made up of match sticks or wires. These models consist of edges 
only, therefore you can see through them. You cannot apply the Boolean operations on these 
models and cannot calculate their mass properties. Wireframe models are generally used in 
frame building of vehicles. Figure 2-2 shows a wireframe model.

Surface Models
Surface models are made up of one or more surfaces. They have a negligible wall thickness and 
are hollow inside. To understand these models, consider a wireframe model with a cloth wrapped 
around it. You cannot see through it. These models are used in the plastic molding industry, such as 
shoe manufacturing, utensils manufacturing, and so on. 

You can directly create a surface or a mesh. Alternatively, you can create  wireframe model and 
then convert it into a mesh or surface model. Remember that you cannot perform the Boolean 
operations in surface models. Figure 2-3 shows a surface model created using a single surface 
or a mesh and Figure 2-4 shows a surface model created using a combination of surfaces.



2-4  	                   Advanced AutoCAD 2021: A Problem-Solving Approach (3D and Advanced)
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Solid Models
Solid models are the solid filled models having mass properties. To understand a solid model, 
consider a model made up of metal or wood. You can perform Boolean operations on these 
models such as cutting a hole through them, or even cutting them into slices. Figure 2-5 shows 
a solid model.

Figure 2-2  A wireframe model Figure 2-3  A surface model created using a 
single surface

Figure 2-4  A semi-finished surface model 
created using more than one surface

Figure 2-5  A solid model

CONVENTIONS FOLLOWED IN AutoCAD
It is important for you to know the conventions in AutoCAD before you proceed with 3D. 
AutoCAD follows these three conventions:

1.	 By default, any drawing you create in AutoCAD will be in the world XY plane.

2.	 The right-hand thumb rule is followed in AutoCAD to identify the X, Y, and Z axis directions. 
This rule states that if you keep the thumb, index finger, and middle finger of the right hand 
mutually perpendicular to each other, as shown in Figure 2-6(a), then the thumb of the right 
hand will represent the direction of the positive X axis, the index finger will represent the 
direction of the positive Y axis, and the middle finger of the right hand will represent the 
direction of the positive Z axis, refer to Figure 2-6(b). 

3.	 The right-hand thumb rule is followed in AutoCAD to determine the direction of rotation 
or revolution in the 3D space. The right-hand thumb rule states that if the thumb of the 
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right hand points in the direction of the axis of rotation, then the direction of the curled 
fingers will define the positive direction of rotation, refer to Figure 2-6(c).

This rule will be used during the rotation of 3D models or the UCS and also, during the creation 
of revolved surfaces and revolved solids.

Figure 2-6(b)  Orientation of the X, Y, and Z 
axes

Figure 2-6(a)  The orientation of fingers as 
per the right-hand thumb rule

Figure 2-6(c)  Right-hand thumb rule showing the axis and 
direction of rotation

CHANGING THE VIEWPOINT TO VIEW 3D MODELS	

Until now, you have been drawing only the 2D entities in the XY plane and in the Plan view. 
But in the Plan view, it is very difficult to find out whether the object displayed is a 2D entity 
or a 3D model, refer to Figure 2-7. In this view, the cuboid displayed appears as a rectangle. 
The reason for this is that, by default, you view the objects in the Plan view from the direction 
of the positive Z axis. You can avoid this confusion by viewing the object from a direction that 
also displays the Z axis. In order to do that, you need to change the viewpoint so that the object 
is displayed in the space with all three axes, as shown in Figure 2-8. In this view, you can also 
see the Z axis of the model along with the X and Y axes. It will now be clear that the original 
object is not a rectangle but a 3D model. The viewpoint can be changed by using the ViewCube 
available in the drawing area or by using the options in the View panel.
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Figure 2-7  Cuboid looking like a 
rectangle in the Plan view

Figure 2-8  Viewing the 3D model after 
changing the viewpoint

Tip
Remember that changing the viewpoint does not affect the dimensions or the location of the 
model. When you change the viewpoint, the model is not moved from its original location. 
Changing the viewpoint only changes the direction from which you view the model.

Changing the Viewpoint Using the ViewCube
You can change the view of the models easily and quickly using the ViewCube. The ViewCube 
is displayed when the 3D Modeling workspace is enabled and it allows you to switch between 
the standard and isometric views, roll the current view, or return to the Home view of a model. 
ViewCube consists of Cube, Home, Compass, and WCS menu. When you move the cursor over 
the ViewCube, it becomes active and the area at the pointer tip gets highlighted. The highlighted 
area can be a face, a corner, or an edge of the ViewCube. These highlighted areas are called 
hotspots. There are 6 faces, 12 edges, and 8 corners on a cube, refer to Figure 2-9. So, you can 
get 26 views by using the ViewCube. You can select the required hotspot 

Figure 2-9  The ViewCube

to restore a view. You can also go back to the Home view by clicking 
on the Home icon of the ViewCube. You can set any existing view as 
the Home view by choosing the Set Current View as Home option 
from the shortcut menu that is displayed on right-clicking on the 
ViewCube. By default, a model is displayed in the perspective view. 
To display a model in parallel projection, right-click on the ViewCube 
and choose Parallel from the shortcut menu. 

The compass on the ViewCube indicates the geographic location of a model. The N, E, S, and 
W alphabets on the compass indicate the North, East, South, and West directions of a 3D model. 
You can pick and drag the compass ring to rotate the current view in the same plane. You can 
choose between the UCS and WCS from the WCS menu and even create a new UCS from the 
menu. When you right-click on the ViewCube, a shortcut menu will be displayed. Choose the 
ViewCube Settings option from it; the ViewCube Settings dialog box will be displayed, refer to 
Figure 2-10. This dialog box allows you to adjust the display of the compass ring and UCS menu, 
size, appearance, and location of the ViewCube.
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Figure 2-10  The ViewCube Settings dialog box

Note
In AutoCAD, you can change the current viewport by using the In-canvas Viewport controls, 
displayed as [-][Custom View][Realistic]. It is available at the top left corner of the drawing 
area. When you choose the [Custom View] option, a flyout is displayed, refer to Figure 2-1. You 
can select the desired view from the flyout.

Changing the Viewpoint Using the Ribbon or the Toolbar
You can also set the viewpoint either by using the Named Views panel in the Visualize tab of 
the Ribbon or by using the View toolbar.

The Restore View drop-down list in the Named Views  panel consists of six preset orthographic 
views: Top, Bottom, Left, Right, Front, and Back; and four preset isometric views: SW Isometric, 
SE Isometric, NE Isometric, and NW Isometric, refer to Figure 2-11. This drop-down list also 
allows you to retrieve the previously set views or any previously created named views. All the 
above-mentioned controls are also available in the View Manager dialog box that is invoked on 
selecting the View Manager option from the Restore View drop-down list.
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Choose the New button from the View Manager dialog box to create a new view; the 
New View / Shot Properties dialog box will be displayed, as shown in Figure 2-12.

Figure 2-11  The Restore 
View drop-down list

Figure 2-12  The New View / Shot Properties dialog box

Enter a name in the View name edit box to save the view. You can save different types of views 
into different categories using the options in this dialog box. The different types of views available 
in the View type drop-down list are Still, Cinematic, and Recorded Walk. But only Still is used 
for creating views and the other two are used for creating shots. The View Properties tab of 
this dialog box has three main areas: Boundary, Settings, and Background. The Boundary 
area allows you to save the current display or you can select an area of display by choosing the 
Define window radio button. In the Settings area, you can control the position of UCS to save 
the view, select the section of the view, and control the display of the model. The drop-down list 
in the Background area is used to select the type of background to save the view. The preview 
of the selected background is displayed in the preview area next to the drop-down list. You need 
to select the Save sun properties with view check box to save the view with the sun properties.

Tip 
When you select any of the preset orthographic views from the View drop-down list, the UCS 
is also aligned to that view.
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Changing the Viewpoint Using the Viewpoint Presets Dialog 
Box
  Menu Bar:    View > 3D Views > Viewpoint Presets  	 Command:  DDVPOINT (VPOINT)                 

You can invoke the Viewpoint Presets dialog box using the VPOINT command for setting the 
viewpoint to view 3D models. The viewpoint is set with respect to the angle from the X axis and 
the angle from the XY plane. Figure 2-13 shows different view direction parameters.

Figure 2-13  View direction parameters

Viewpoint Presets Dialog Box Options
The options in the Viewpoint Presets dialog box  are discussed next, refer to Figure 2-14.

Absolute to WCS. This radio button is selected by default and used to set the viewpoint with 
respect to the world coordinate system (WCS).

Relative to UCS. This radio button is selected to set the viewpoint with respect to the current 
user coordinate system (UCS).

Note
The WCS and UCS have already been discussed in Chapter 1.

From: X Axis. This edit box is used to specify the angle in the XY plane from the X axis. You 
can directly enter the required angle in this edit box or select the desired angle from the image 
tile, refer to Figure 2-15. There are two arms in this image tile, and by default, they are placed 
one over the other. One arm displays current viewing angle and the other displays new viewing 
angle. On selecting a new angle from the image tile, it is automatically displayed in the X Axis 
edit box. This value can vary between 0 and 359.9.

From: XY Plane. This edit box is used to specify the angle from the XY plane. You can directly 
enter the desired angle in it or select the angle from the image tile, as shown in Figure 2-16. This 
value can vary from -90 to +90. 
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Figure 2-14  The Viewpoint Presets 
dialog box

Figure 2-15  The image 
tile for selecting the angle 
from X axis

Figure 2-16  The image 
tile for selecting the angle 
from the XY plane

Set to Plan View. This button is chosen to set the viewpoint to the Plan view of the WCS or 
the UCS. If the Absolute to WCS radio button is selected, the viewpoint will be set to the Plan 
view of the WCS. If the Relative to UCS radio button is selected, the viewpoint will be set to 
the Plan view of the current UCS. Figures 2-17 and 2-18 show the 3D models from different 
viewing angles.

Figure 2-17  Viewing the 3D model with the  
angle in the XY plane as 225 and the angle 
from the XY plane as 30

Figure 2-18  Viewing the 3D model with the angle 
in the XY plane as 145 and the angle from the XY 
plane as 25

Tip
1. If you set a negative angle from the XY plane, the Z axis will be displayed as a dotted line, 
indicating a negative Z direction, refer to Figures 2-19 and 2-20.

2. In case of confusion in identifying the direction of X, Y, and Z axes, use the right-hand 
thumb rule.
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Figure 2-19  Viewing the 3D model with the 
angle in the XY plane as 315 and the angle 
from the XY plane as -25

Figure 2-20  Viewing the 3D model with the angle 
in the XY plane as 225 and the angle from the XY 
plane as -25

Changing the Viewpoint Using the -VPOINT Command
  Menu Bar:  View > 3D Views > Viewpoint 		  Command:  -VPOINT	

The -VPOINT command is used to set the viewpoint for viewing the 3D models. Using this 
command, the users can specify a point in the 3D space that will act as the viewpoint. 

Specifying a Viewpoint
This is the default option and is used to set a viewpoint by specifying its location (of viewer) 
using the X, Y, and Z coordinates of that particular point. AutoCAD follows a convention of the 
sides of the 3D model for specifying the viewpoint. The convention states that if the UCS is at 
the World position (default position), then

1.	 The side at the positive X axis direction will be taken as the right side of the model.
2.	 The side at the negative X axis direction will be taken as the left side of the model.
3.	 The side at the negative Y axis direction will be taken as the front side of the model.
4.	 The side at the positive Y axis direction will be taken as the back side of the model.
5.	 The side at the positive Z axis direction will be taken as the top side of the model.
6.	 The side at the negative Z axis direction will be taken as the bottom side of the model.

Some standard viewpoint coordinates and the view they display are given next.
	
Value 	 View		  	 Value 	 View			   Value 	 View
1,0,0	 Right side 		  -1,0,0	 Left side		  0,1,0	 Back		
0,-1,0	 Front 			   0,0,1	 Top view		  0,0,-1	 Bottom view		
1,1,1	 NE Isometric		  -1,1,1	 NW Isometric		  1,-1,1	 SE Isometric
-1,-1,1	 SW Isometric		  1,1,-1	 Right, Back, Bottom	 -1,1,-1	 Left, Back, Bottom 
1,-1,-1	 Right, Front, Bottom	 -1,-1,-1	Left, Front, Bottom

You can also enter the values in decimal, but the resultant views will not be the standard views. 
Figures 2-21 through 2-24 show a 3D model from different viewpoints.



2-12  	                   Advanced AutoCAD 2021: A Problem-Solving Approach (3D and Advanced)
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 2-21  Viewing the model from the 
viewpoint -1,-1,1

Figure 2-22  Viewing the model from the 
viewpoint 1,1,1

Figure 2-23  Viewing the model from the 
viewpoint 1,-1,1

Figure 2-24  Viewing the model from 
the viewpoint -1,1,1

Compass and Tripod
When you choose View > 3D Views > Viewpoint from the menu bar, a compass and an axis 
tripod are displayed, as shown in Figure 2-25. You can directly set the viewpoint using this compass 
and can select any point on this compass to specify the viewpoint. The compass consists of two 
circles, a smaller circle and a bigger circle. Both these circles are divided into four quadrants: 
first, second, third, and fourth. The resultant view will depend upon the quadrant and the circle 
on which you select the point. In the first quadrant, both the X and Y axes are positive; in the 
second quadrant, the X axis is negative and the Y axis is positive; in the third quadrant, both 
the X and Y axes are negative; and in the fourth quadrant, the X axis is positive and the Y 
axis is negative. Now, if you select a point inside the inner circle, it will be in the positive Z axis 
direction. If you select the point outside the inner circle and inside the outer circle, it will be 
in the negative Z axis direction. Therefore, if the previously mentioned statements are added, 
the following is concluded.

1.	 If you select a point inside the smaller circle in the first quadrant, the resultant view will be 
the Right, Back, or Top view. If you select a point outside the smaller circle and inside the 
bigger circle in this quadrant, the resultant view will be the Right, Back, or Bottom view,

       refer to Figure 2-26. 

2.	 If you select a point inside the smaller circle in the second quadrant, the resultant view will 
be the Left, Back, or Top view. If you select a point outside the smaller circle and inside 
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the bigger circle in this quadrant, the resultant view will be the Left, Back, or Bottom view, 
refer to Figure 2-26. 

3.	 If you select a point inside the smaller circle in the third quadrant, the resultant view will 
be the Left, Front, or Top view. If you select a point outside the smaller circle and inside 
the bigger circle in this quadrant, the resultant view will be the Left, Front, or Bottom view, 
refer to Figure 2-26.

4.	 If you select a point inside the smaller circle in the fourth quadrant, the resultant view will 
be the Right, Front, or Top view. If you select a point outside the smaller circle and inside 
the bigger circle in this quadrant, the resultant view will be the Right, Front, or Bottom view, 
refer to Figure 2-26.

Figure 2-25  The axis tripod and the compass Figure 2-26  The directions of the compass

 

Rotate
This option is similar to setting the viewpoint in the Viewpoint Presets dialog box, which 
is displayed by invoking the  -VPOINT command. When you select this option, you will be 
prompted to specify the angle in the XY plane and the angle from the XY plane. The angle in 
the XY plane will be taken from the X axis.

IN-CANVAS VIEWPORT CONTROL
The In-canvas Viewport control enables you to control the viewport as well as visual style. By 
default, the In-canvas Viewport control is displayed as [-][Custom View][Realistic] in the top 
left corner of the drawing area. The tools available in this viewport control are discussed next.

[-]
When you choose the [-] button in the In-canvas Viewport control,

Figure 2-27  Flyout displayed 
on choosing the [-] button

 
a flyout will be displayed, as shown in Figure 2-27. Options in this 
flyout are discussed next.

Restore Viewport
When you choose this option, the drawing screen is displayed with 
four equal partitions. In each of these partitions, a [+] button is 
displayed in the upper left corner. When you click on the [+] button, 
a flyout will be displayed with the Maximize Viewport option. Using 
this option, you can maximize the partition window.
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Viewport Configuration List                                                                  
When you choose this option, a flyout will be displayed, as shown in

Figure 2-28  The Viewport 
Configuration List flyout

 
the Figure 2-28. In this flyout, 12 options are available for viewport 
settings. Using these options, you can set as many partitions as 
needed to be created and their position in the drawing area.

Viewcube, SteeringWheels, and Navigation Bar
ViewCube is used to minimize the time required in changing the 
view of the model, while the SteeringWheels and Navigation Bar are 
used to minimize the navigation time. Using the ViewCube from the 
Viewport Controls flyout, you can toggle the display of the ViewCube. 
As you choose the SteeringWheels option, SteeringWheels will get 
attached to the cursor. SteeringWheels will be discussed in detail later 
in this chapter. Using the Navigation Bar option, you can toggle 
the display of the Navigation Bar in the right of the drawing screen. 

View Controls
The View Controls flyout contains various options to change your

Figure 2-29  The 
View Controls flyout

 
current view or to create a new view. This flyout is displayed on choosing 
the Custom View button from the In-canvas Viewport controls, refer  
to Figure 2-29. The options in this flyout are used for setting view 
controls and are discussed next. 

•	 Custom Model Views: This flyout consists of custom views created 
by using the View Manager.

•	 Views: There are 10 view options available in this flyout to set 10 
different views. When you change the view, the UCS gets reoriented 
according to the view selected.

•	 View Manager: Using this option, you can create a new view or 
edit the view settings of an existing view.    

•	 Parallel and Perspective: These options are used to control the 
projection. If you choose the Parallel option, the drawing will be 

Figure 2-30  The Visual 
View Controls flyout

displayed parallel to the screen. If you choose the Perspective 
option, the drawing will be displayed in a perspective view.         

Visual Style Controls
The Visual Style Controls flyout is used to control the visual style of 
the model. This flyout is displayed when you select the Realistic button 
from the Visual Style Controls, as shown in Figure 2-30. The options 
in this flyout are used for setting visual styles and are discussed next.

•	 Custom Visual Styles. When you click on this option, a flyout 
is displayed. This flyout displays the visual styles that you have  
created.
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•	 Visual Styles. There are 10 options that enable you to select the required visual style.

•	 Visual Styles Manager. This option is used to create a new visual style as well as to change 
the settings of the current visual style.

3D COORDINATE SYSTEMS
Similar to 2D coordinate systems, there are two types of 3D coordinate systems. They are 
discussed next.

Absolute Coordinate System
This type of coordinate system is similar to the 2D absolute coordinate system in which the 
coordinates of the point are calculated from the origin (0,0). The only difference here is that, 
along with the X and Y coordinates, the Z coordinate is also included. For example, to draw a 
line in 3D space starting from the origin to a point say 10,6,6, the procedure to be followed is 
given next.

Command: Choose the Line tool from the Draw panel.
Specify first point: 0,0,0
Specify next point or [Undo]: 10,6,6
Specify next point or [Undo]: 

Figure 2-31 shows the model drawn using the absolute coordinate system.

Figure 2-31  Drawing a line from origin to 10,6,6

Relative Coordinate System
The following are the three types of relative coordinate systems in 3D:

Relative Rectangular Coordinate System
This coordinate system is similar to the relative rectangular coordinate system of 2D, except that 
in 3D you also have to enter the Z coordinate along with the X and Y coordinates. The syntax 
of the relative rectangular system for the 3D is @X coordinate, Y coordinate, Z coordinate.
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Relative Cylindrical Coordinate System
In this coordinate system, you can locate the point by specifying its distance from the 
reference point, the angle in the XY plane, and its distance from the XY plane. The syntax of 
the relative cylindrical coordinate system is @Distance from the reference point in the XY 
plane < Angle in the XY plane from the X axis, Distance from the XY plane along the Z axis. 
Figure 2-32 shows the components of the relative cylindrical coordinate system.

Relative Spherical Coordinate System
In this coordinate system, you can locate the point by specifying its distance from the 
reference point, the angle in the XY plane, and the angle from the XY plane. The 
syntax of the relative spherical coordinate system is @Length of the line from the 
reference point < Angle in the XY plane from the X axis < Angle from the XY 
plane. Figure 2-33 shows the components of the relative spherical coordinate system. 

Figure 2-32  Various components of the 
relative cylindrical coordinate system

Figure 2-33  Various components of the 
relative spherical coordinate system

Tip
The major difference between the relative cylindrical and relative spherical coordinate systems is 
that in the relative cylindrical coordinate system, the specified distance is the distance from the 
reference point in the XY plane. On the other hand, in the relative spherical coordinate system, 
the specified distance is the total length of the line in the 3D space.
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Example 1 			       Relative Coordinate System
In this example, you will draw the 3D wireframe model shown in Figure 2-34. Its dimensions 
are given in Figure 2-35.

Figure 2-34  The 3D Wireframe model for Example 1

Figure 2-35  Orthographic views of the Wireframe model

1.	 Start a new acad3D.dwt file in the 3D Modeling workspace and select the SW Isometric option 
from the Restore View drop-down list in the View panel of the Home tab. Alternatively, select 
the SouthWest top corner hotspot on the ViewCube, refer to the compass of the ViewCube 
to get the SouthWest view of the model.

2.	 As the start point of the model is not given, you can start the model from any point. Choose 
the Line tool from the Draw panel of the Home tab and follow the prompt sequence 
given next.

Specify first point: 4,2,0
Specify next point or [Undo]: @0,0,2
Specify next point or [Undo]: @3,0,0
Specify next point or [Close/Undo]: @0,0,2
Specify next point or [Close/Undo]: @3,0,0
Specify next point or [Close/Undo]: @2<0<315
Specify next point or [Close/Undo]: @2<0<45
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Specify next point or [Close/Undo]: @3,0,0
Specify next point or [Close/Undo]: @0,0,-2
Specify next point or [Close/Undo]: @3,0,0
Specify next point or [Close/Undo]: @0,0,-2
Specify next point or [Close/Undo]: C

3. Choose the Line tool again and follow the prompt sequence given next.

Specify first point: 4,2,0
Specify next point or [Undo]: @0,8,0
Specify next point or [Undo]: @0,0,2
Specify next point or [Close/Undo]: @3,0,0
Specify next point or [Close/Undo]: @0,0,2
Specify next point or [Close/Undo]: @3,0,0
Specify next point or [Close/Undo]: @2<0<315
Specify next point or [Close/Undo]: @2<0<45
Specify next point or [Close/Undo]: @3,0,0
Specify next point or [Close/Undo]: @0,0,-2
Specify next point or [Close/Undo]: @3,0,0
Specify next point or [Close/Undo]: @0,0,-2
Specify next point or [Close/Undo]: @0,-8,0
Specify next point or [Close/Undo]: 

4. Complete the model by joining the remaining edges using the Line tool.

5. The final 3D wireframe model should look similar to the one shown in Figure 2-36.

Figure 2-36  The final 3D wireframe model for Example 1

DIRECT DISTANCE ENTRY METHOD
In AutoCAD, you can directly create models in 3D space. This method is similar to that in 2D. 
The easiest way to draw a model by using the Line tool in 3D space of AutoCAD is by using 
the Direct Distance Entry method. Before drawing a model by using this method, ensure that 
the Dynamic Input button is chosen in the Status Bar. Next choose the Line tool; you will 
be prompted to specify the start point. Enter the coordinate values in the text box and press 
ENTER; you will be prompted to specify the next point. Move the cursor along the direction in 
which you need to draw the line and  enter the absolute length of the line and its angle in the 
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corresponding text boxes, with respect to the previous point. Note that you can use the TAB 
key to toggle between the text boxes. 

To draw a line along the Z axis, move the cursor along the Z axis; you will notice that the tool 
tip displays Ortho: (current length) < +Z, if the ortho mode is on. Type the absolute distance 
and the angle, and press ENTER. If the ortho mode is not chosen, position the cursor at the 
desired angle, type the length at the Command prompt, and then press ENTER. If necessary 
change the UCS as discussed earlier. 

Example 2 				         Direct Distance Entry
In this example, you will draw the 3D wireframe model shown in Figure 2-37.

Figure 2-37  3D wireframe model for Example 2

1.	 Start a new acad3D.dwt file in the 3D Modeling workspace and make sure the Ortho Mode and 
Dynamic Input buttons are chosen. Then, change the drawing view by using the ViewCube. 
The view needed is SW Isometric. The Southwest view of the ViewCube has three hotspots: 
bottom, edge, and top. You need to select the top hotspot to get the required view. Refer to 
Figure 2-38 for the SW Isometric hotspot. However, you can check different hotspots and 
view the model in different angles by using the ViewCube.

2.	 Choose the Line tool from the Draw panel and specify the start point at 2,2,0.

3.	 Move the cursor along the positive X axis. Then, type 6 and press ENTER; a line of length 
6 units is drawn along the X axis.

4.	 Move the cursor along the positive Y axis, type 4, and press ENTER; a line of length 4 units 
is drawn along the Y axis.

5.	 Draw the other two lines to create the closed profile at the bottom of the model.
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Figure 2-38  ViewCube showing the SW Isometric

6.	 From the start point of the model, move the cursor along the positive Z axis. You will notice 
that the tooltip displays Ortho: (current length) < +Z, as shown in Figure 2-39.

7.	 Type 2 at the Command prompt and press ENTER; a line of length 2 units is drawn.

8. 	 Move the cursor along the positive X axis, type 6, and press ENTER; a line of length 6 units 
is drawn.

9.	 Similarly, draw other lines to complete the model. The final model should look similar to 
the one shown in Figure 2-40. 

Figure 2-39  Tooltip displayed on moving the 
cursor along the positive Z axis

Figure 2-40  Final 3D model for Example 2
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Exercise 1
In this exercise, you will draw the 3D wireframe model shown in Figure 2-41. Its dimensions are 
given in the same figure. You can start the model from any point.

Figure 2-41  Wireframe model for Exercise 1

TRIM, EXTEND, AND FILLET TOOLS
In AutoCAD, you can use the trim, extend, and fillet tools in 3D workspace. You can also use the 
PROJMODE and EDGEMODE variables. The PROJMODE variable sets the projection mode 
for trimming and extending. The value of 0 implies True 3D mode, that is, no projection. In 
this case, the objects must intersect in 3D space to be trimmed or extended. It is similar to using 
the None option of the Project mode of the Extend and Trim tools. A value of 1 projects onto 
the XY plane of the current UCS and is similar to using the UCS option of the Project option of 
the Trim or Extend tools. A value of 2 projects onto the current view plane and is like using the 
View option of the Project option of the Trim or Extend tools. The value of the EDGEMODE 
system variable controls the cutting or trimming boundaries. A value of 0 considers the selected 
edge with no extension. You can also use the No extend option of the Edge option of the Trim 
or Extend tools. A value of 1 considers an imaginary extension of the selected edge. This is 
similar to using the Extend option of the Edge option of the Trim or Extend tools.

You can fillet coplanar objects whose extrusion directions are not parallel to the Z axis of the 
current UCS, by using the Fillet tool. The fillet arc exists on the same plane and has the same 
extrusion direction as the coplanar objects. If the coplanar objects to be filleted exist in opposite 
directions, the fillet arc will be on the same plane but will be inclined toward the positive Z axis.
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SETTING THICKNESS AND ELEVATION FOR NEW 
OBJECTS
You can create the objects with a preset elevation or thickness using the ELEV command. This 
command is discussed next.

The ELEV Command
  Command: ELEV    

This is a transparent command and is used to set elevation and thickness for new objects. The 
following prompt sequence is displayed when you invoke this command:

Specify new default elevation <0.0000>: Enter the new elevation value.
Specify new default thickness <0.0000>: Enter the new thickness value.

Elevation
This option is used to specify the elevation value for new objects. Setting the elevation is 
nothing but moving the working plane from its default position. By default, the working 
plane is on the world XY plane. You can move this working plane by specifying the new value 
for elevation using the ELEV command. However, remember that the working plane can be 
moved only along the Z axis, refer to Figure 2-42. The default elevation value is 0.0 and you 
can set any positive or negative value. All objects that will be drawn hereafter will be with the 
specified elevation. The ELEV command sets the elevation only for the new objects and the 
existing objects are not modified using this option.

Thickness
This option is used to specify the thickness values for new objects. It can be considered as another 
method of creating surface models. Specifying the thickness creates extruded surface models. 
The thickness is always taken along the Z axis direction, refer to Figure 2-43. The 3D faces will be 
automatically applied on the vertical faces of the objects drawn with a thickness. The Thickness 
option sets the thickness only for the new objects and the existing objects are not modified.

Note
By default, the model will be displayed in the Realistic visual style. To change it to wireframe, 
choose the 2D Wireframe from the Visual Style Controls flyout in the In-canvas Viewport 
Controls. You can suppress the hidden edges in the model by using the Hide tool. The Hide tool 
is discussed in the next section.
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Figure 2-42  Object drawn with elevation Figure 2-43  Object drawn with thickness

                                                         

Tip 
1 . The elevation value will be reset to 0.0 when you change the coordinate system to WCS. 

2. The rectangles drawn using the Rectangle tool do not consider the thickness value set by 
using the ELEV command. To draw a rectangle with thickness, use the Thickness option of 
the Rectangle tool.

3. Figure 2-44 shows a point, line, polygon, circle drawn with a thickness of 5 units. 

4. To write text with thickness, first write a single line text and then change its thickness using 
any of the commands that modify its property, refer to Figure 2-45.

Figure 2-44  A point, line, polygon, and circle drawn 
with a thickness of 5 units

Figure 2-45  Text with and without thickness
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SUPPRESSING THE HIDDEN EDGES
  Menu Bar:  View > Hide	 Toolbar: Render > Hide		  Command:  HIDE     

Whenever you create a surface or a solid model, the edges that lie at the back, called 
the hidden edges too, also become visible. As a result, the model appears like a wireframe 
model. You need to manually suppress the hidden lines in the 3D model using the Hide 

command. When you invoke this tool, all objects on the screen are regenerated. Also, the 3D 
models are displayed with the hidden edges suppressed. If the value of the DISPSILH 
system variable is set to 1, the model is displayed only with the silhouette edges. The internal 
edges that have facets will not be displayed. The hidden lines are again included in the drawing 
when the next regeneration takes place. Figure 2-46 shows the surface models displaying the 
hidden edges. Figure 2-47 shows surface models without the hidden edges.

Figure 2-46  3D models with hidden edges Figure 2-47  Models without hidden edges 	 	
 

Tip 
The Hide command considers Circles, Solids, Traces, Polylines with width, Regions, and 3D 
Faces as opaque surfaces that will hide objects. 

CREATING A 3D POLYLINE	
  Ribbon:  Home > Draw > 3D Polyline	    Menu Bar:   Draw > 3D Polyline	  
  Command: 3DPOLY								      

The 3DPolyline tool is used to draw straight polylines in a 2D plane or a 3D space. This 
tool is similar to the Polyline tool except the fact that you can draw polylines in a plane 
other than the XY plane also by using this tool. However, this tool does not provide the 

Width option or the Arc option; and therefore you cannot create a 3D polyline with a width or 
an arc. The Close and Undo options of this tool are similar to those of the Polyline tool.

Tip 
You can fit a spline curve about the 3D polyline using the Edit Polyline tool. Use the Spline 
curve option to fit the spline curve and the Decurve option to remove it.



Getting Started with 3D 					                		           2-25

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

CONVERTING WIREFRAME MODELS INTO SURFACE 
MODELS
You can convert a wireframe model into a surface model using the 3DFACE command and the 
PFACE command. These tools are discussed next.

Creating 3D Faces
  Menu Bar:   Draw > Modeling > Meshes > 3D Face 		  Command:  3DFACE      

The 3D Face tool is used to create 3D faces in space. You can create three-sided or  
four-sided faces using this tool. You can specify the same or a different Z coordinate 
value for each point of the face. On invoking this tool, you will be prompted to specify 

the first, second, third, and fourth points of the 3D face. Once you have specified the first four 
points, it will again prompt you to specify the third and fourth points. In this case, it will take 
the previous third and fourth points as the first and second points, respectively. This process 
will continue until you press ENTER at the Specify third point or [Invisible] <exit> prompt. 
Keep in mind that the points must be specified in the natural clockwise or the 
counterclockwise direction to create a proper 3D face. Figure 2-48 shows 3D faces created on 
the 3D wireframe model. 

Figure 2-48  3D faces created on the 3D wireframe model

However, in case of complex wireframe models, refer to Figure 2-49, it is not easy to apply 3D 
faces. This is because when you apply a 3D face, it generates edges about all points that you 
specify. These edges will be displayed on the wireframe model, as shown in Figure 2-49. You 
can avoid these unwanted visible edges by applying the 3D faces with invisible edges using the 
Invisible option. It is very important to note here that the edge that will be created after you 
enter I at the Specify next point or [Invisible] <exit> prompt will not be the invisible edge. 
The edge that will be created after this edge will be the invisible edge. Therefore, to make the 
P3 edge and P4 edge invisible, specify P1 as the first point and P2 as the second point. Before 
specifying P3 as the third point, enter I at the Specify third point or [Invisible] <exit> prompt. 
Similarly, follow the same procedure for creating the other invisible edges, refer to Figure 2-50.
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Figure 2-49  Wireframe model with edges Figure 2-50  Wireframe model without edges

Creating Polyface Meshes
 Command:  PFACE    

The PFACE command is similar to the 3D Face tool. This command also allows you to create a 
mesh of any desired surface shape by specifying the coordinates of the vertices and assigning the 
vertices to the faces in the mesh. The difference between them is that on using the 3D Face tool, 
you do not select the vertices that join another face twice. With the PFACE command, you need 
to select all the vertices of a face, even if they are coincident with the vertices of another face. In 
this way, you can avoid generating unrelated 3D faces that have coincident vertices. Also, with 
this command, there is no restriction on the number of faces and vertices the mesh can have.

Command: PFACE
Specify location for vertex 1: Specify the location of the first vertex.
Specify location for vertex 2 or <define faces>: Specify the location of the second vertex.
Specify location for vertex 3 or <define faces>: Specify the location of the third vertex.
Specify location for vertex 4 or <define faces>: Specify the location of the fourth vertex.
Specify location for vertex 5 or <define faces>: Specify the location of the fifth vertex.
Specify location for vertex 6 or <define faces>: Specify the location of the sixth vertex.
Specify location for vertex 7 or <define faces>: Specify the location of the seventh vertex.
Specify location for vertex 8 or <define faces>: Specify the location of the eighth vertex.
Specify location for vertex 9 or <define faces>: 

After defining the locations of all the vertices, press ENTER and assign vertices to the first face.

Face 1, vertex 1: Specify the location of the first vertex.
Enter a vertex number or [Color/Layer]: 1
Face 1, vertex 2:
Enter a vertex number or [Color/Layer] <next face>: 2
Face 1, vertex 3:
Enter a vertex number or [Color/Layer] <next face>: 3
Face 1, vertex 4:
Enter a vertex number or [Color/Layer] <next face>: 4

Once you have assigned the vertices to the first face, give a null response at the next prompt. 
Similarly, assign vertices to all faces, refer to Figure 2-51. To view the faces, select the Realistic 
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option from the Visual Styles drop-down list in the View panel of the Home tab. To make an 
edge invisible, specify a negative number for its first vertex. The display of the invisible edges 
of 3D solid surfaces is governed by the SPLFRAME system variable. If SPLFRAME is set to 0, 
invisible edges are not displayed. If this variable is set to a number other than 0, all invisible 
edges are displayed after regeneration using the REGENALL command.

Figure 2-51  Faces of block and assigned vertices

Controlling the Visibility of the 3D Face Edges
  Command:  EDGE    

The EDGE command is used to control the visibility of the edges created by using the 3D 
Face tool. You can hide the edges of the 3D faces or display them using this command, 
refer to Figures 2-52 and 2-53. On invoking this command, you will be prompted to specify the 
3D face edge to toggle its visibility or display. To hide an edge, select it. To display the edges, 
enter D at the Specify edge of 3dface to toggle visibility or [Display] prompt. You can display 
all invisible 3D face edges or the selected edges using this option.

Figure 2-52  Model with the visible 3D face edges Figure 2-53  Model after hiding the edges 

Exercise 2 							           3D Face
In this exercise, you will apply the 3D faces to the 3D wireframe model created in Example 2.
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CREATING PLANAR SURFACES
  Ribbon:  Surface > Create > Planar	    Toolbar:  Modeling > Planar Surface	  
  Command:  PLANESURF							     

The Planar tool is used to generate 2D surfaces on the working plane by specifying two 
diagonally opposite points. These two points specify the rectangular shape area to be 
covered by this planar surface, refer to Figure 2-54. The prompt sequence displayed on 
choosing the Planar tool from the Create panel in the Surface tab is discussed next.

Specify first corner or [Object] <Object>: Specify the first corner point of the planar surface.
Specify other corner: Specify the diagonally opposite point of the planar surface.  

You can also convert an existing object to a surface by entering O at the  Specify first corner or 
[Object] <Object> prompt. While selecting the object, you can directly select a closed boundary 
or a number of individual objects that result in a closed boundary, refer to Figure 2-55.

The number of lines displayed in the surface is controlled by the SURFU and SURFV 
system variables. The SURFU variable controls the number of lines to be displayed in the 
M direction and the SURFV variable controls the number of lines to be displayed in the N 
direction. These M and N directions are taken parallel to X and Y axis of the UCS respectively.

Figure 2-54  Planar surface created by specifying 
corner points

Figure 2-55  Planar surface created by selecting 
an object

THE 3DMESH COMMAND
  Command:  3DMESH    

The 3DMESH command is used to create a free-form polygon mesh by using a matrix of M X 
N size. When you invoke this command, you will be prompted to specify the size of the mesh in 
the M direction and the N direction, where M X N is the total number of vertices in the mesh. 
The values of M and N can be 2 to 256. Once you have specified the size, you need to specify 
the coordinates of each and every vertex individually. For example, if the size of the mesh in 
the M and N directions is 12 X 12, then you will have to specify the coordinates of all the 144 
vertices. You can specify any 2D or 3D coordinates for the vertices. Figure 2-54 shows a freeform 
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mesh. This command is mostly used for programming. The 3D polygon mesh is always open 
in the M and N directions. You can edit the mesh created using the 3DMESH command with 
the help of the Edit Polyline tool. 

EDITING THE SURFACE MESH
The polyface or polygon meshes can be edited using the Edit Polyline tool as discussed next.

The Edit Polyline Tool
  Ribbon:  Home > Modify > Edit Polyline            Menu Bar:  Modify > Object > Polyline	     
  Toolbar:  Modify II > Edit Polyline		  Command: PEDIT			      

To edit a polyface or polygon mesh, invoke the Edit Polyline tool from the Modify panel. 
You can also select the Polyline Edit option from the shortcut menu displayed on selecting 
the surface mesh and right-clicking on it, to edit a polyface or polygon face. The prompt 

sequence that will be followed on choosing the Edit Polyline tool and selecting the mesh is given 
next.

Select polyline or [Multiple]: Select the 3D mesh.
Enter an option [Edit vertex/Smooth surface/Desmooth/Mclose/Nclose/Undo]: Select an 
option.

Edit Vertex	
This option is used for the individual editing of vertices of the mesh in the M direction or the 
N direction. On invoking this option, a cross will appear on the first point of the mesh and the 
following sub-options will be provided. Change the visual style to Wireframe by selecting the 
Wireframe option from the Visual Styles drop-down list in the View panel of the Home tab, 
so that you can view the vertices clearly.

Next. This sub-option is used to move the cross to the next vertex.

Previous. This sub-option is used to move the cross to the previous vertex.

Left. This sub-option is used to move the cross to the previous vertex in the N direction of the 
mesh.

Right. This sub-option is used to move the cross to the next vertex in the N direction of the mesh.

Up. This sub-option is used to move the cross to the next vertex in the M direction of the mesh.

Down. This sub-option is used to move the cross to the previous vertex in the M direction of 
the mesh.

Move. This sub-option is used to redefine the location of the current vertex. You can define a 
new location by using any of the coordinate systems or can directly select the location on the 
screen, refer to Figures 2-56 and 2-57.
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Figure 2-56  Vertex before moving Figure 2-57  Vertex after moving

REgen. This sub-option is used to regenerate the 3D mesh.

eXit. This sub-option is used to exit the Edit Vertex option.

Smooth surface
This option is used to smoothen the surface of the 3D mesh by fitting a smooth surface, as 
shown in Figures 2-58 and 2-59. The smoothness of the surface will depend upon the SURFU 
and SURFV system variables. The value of these system variables can vary between 0 and 200.

Figure 2-58  3D mesh before fitting 
the smooth surface

Figure 2-59  3D mesh after fitting 
the smooth surface

The type of the smooth surface to be fitted is controlled by the SURFTYPE system variable. If 
you set the value of the SURFTYPE system variable to 5, it will fit a Quadratic B-spline surface. 
If you set the value to 6, it will fit a Cubic B-spline surface. If you set the value to 8, it will fit a 
Bezier surface.

Desmooth
This option is used to remove the smooth surface that was fitted on the 3D mesh using the 
Smooth surface option and restore to the original mesh.

Mclose
This option is used to close the 3D mesh in the M direction, as shown in Figures 2-60 and 2-61.

Nclose
This option is used to close the 3D mesh in the N direction, as shown in Figures 2-60 and 2-61.
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Figure 2-60  3D mesh open in the M 
and N directions

Figure 2-61  3D mesh closed in the M 
and N directions

Mopen
This option will be available if the 3D mesh is closed in the M direction. It is used to open the 
3D mesh in the M direction, refer to Figures 2-60 and 2-61.

Nopen
This option will be available if the 3D mesh is closed in the N direction. It is used to open the 
3D mesh in the N direction, refer to Figures 2-60 and 2-61.

Undo
This option is used to undo all the operations done by the Edit Polyline tool.

DYNAMIC VIEWING OF 3D OBJECTS
Ribbon:  View > Navigate > SteeringWheels (Customize to add)		                  
Navigator Bar:  Full Navigation Wheel       Command:  NAVSWHEEL	                 

The options available in the Full Navigation Wheel make the entire process of the solid 
modeling very interesting. You can dynamically rotate the solid models on the screen 
to view them from different angles. You can also define clipping planes and then rotate 

the solid models such that whenever the models pass through the cutting planes, they are 
sectioned just to be viewed. The original model can be restored as soon as you exit these 
commands or tools. The tools and their options that are used to perform all these functions are 
discussed next.

Using the SteeringWheels
The SteeringWheels enables you to easily view and navigate through your 3D models. It is an 
ideal tool for navigating through your models. It includes not only the common navigating 
tools such as Zoom, Pan, and Orbit but also an option to move the user specified center of the 
model to the center of the display window. Using this tool, you can also rewind and get back 
your previous views. It is a time saving tool, since it combines many common navigation tools 
into a single tool.						               

The SteeringWheel is divided into different sections known as Wedges. Each wedge on a wheel 
represents a command. You can activate a particular navigation option by clicking on the 
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respective wedges and then modify the view of the model by

Figure 2-62  The SteeringWheel

 
dragging the cursor, refer to Figure 2-62. The navigation tools 
available in the SteeringWheels are discussed next.

ZOOM
This wedge is used in the same way as you use camera’s zoom 
lens. It makes the object appear closer or far away, without 
changing the position of the camera. To invoke the ZOOM 
tool, move the cursor to the ZOOM wedge, press and hold left 
mouse button; a magnifier will be attached to the cursor that 
allows you to zoom in or out with reference to a base point. Now, drag to zoom in and zoom out. 
However, you can change the base point or pivot point to zoom in or zoom out of the model 
by choosing the CENTER wedge. You can even enable the incremental zoom of 25 percent on 
a single click from the Zoom area of the SteeringWheels Settings dialog box. To invoke this 
dialog box, right-click on the SteeringWheels; a shortcut menu will be displayed. Choose the 
SteeringWheels Settings option from the shortcut menu; the SteeringWheels Settings dialog 
box will be displayed. You can even choose the Fit to Window option from the shortcut menu 
of the SteeringWheels to view the entire drawing in the viewport.

REWIND
This wedge enables you to quickly restore the previous views. To invoke this tool, move the cursor 
to the REWIND wedge and click; a series of frames from the previous view orientation are 
displayed. You can now quickly pick the required view and control the thumbnail previews 
generated on changing various views using the Rewind thumbnail area of the SteeringWheels 
Settings dialog box.

PAN
This wedge allows you to drag the view to a new location in the drawing window. To invoke 
this tool, move the cursor to the PAN wedge, press and hold left mouse button; a plus arrow is 
attached to the cursor, enabling you to drag the view in any direction. Now, drag your mouse to 
pan in model space. You can choose the Fit to Window option from the shortcut menu of the 
SteeringWheels to view the entire drawing in the viewport.

ORBIT
This wedge allows you to visually maneuver around the 3D objects to obtain different views. When 
you move your cursor to the ORBIT wedge press and hold left mouse button; a circular arrow 
is attached to the cursor. Now, you can rotate the model with respect to a base point. Similar to 
the ZOOM option, in this case also, you can specify the required center point of the view and 
rotate the model using the CENTER wedge option. You can also set the viewpoint upside down 
using the options in the SteeringWheels Settings dialog box. Moreover, you can choose the Fit 
to Window option to view the full drawing view.

CENTER
This wedge helps you specify the pivot or center point of the view to orbit or zoom a model. 
When you move your cursor to this wedge and drag, a pivot ball is attached to the cursor.  You can 
now adjust your center or target point by placing the cursor at the required point. However, you 
can restore the center of the viewport by choosing the Restore Original Center option from 
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the shortcut menu of the SteeringWheels. You can also restore the home view of the model by 
choosing the Go Home option from the shortcut menu.

LOOK
This tool works similar to turning the camera on a tripod without changing the distance between 
the camera and the target. This means the source remains the same, but the target changes. To 
invoke this tool, move the cursor to the LOOK wedge; an arc is attached to the cursor which 
enables you to change your view direction. You can also invert the vertical direction of the Look 
tool by selecting the Invert vertical axis for Look tool check box from the SteeringWheels 
Settings dialog box. You can choose the Fit to Window option to view the entire drawing in 
the viewport.

WALK
This tool moves the camera around the model as if you are walking away or towards the focus 
direction of the camera. In the walk 3D navigation, the camera moves parallel to the XY plane 
and gives the effect as if you are walking. To invoke this tool, move the cursor to the WALK 
wedge. An arrow is attached to the cursor showing the direction of the camera. You can drag 
the cursor to move around the model and also control the walk speed using the options in the 
Walk Tool area of the SteeringWheels Settings dialog box. Using this dialog box, you can also 
constraint the walk angle to the ground plane.

UP/DOWN
This option slides the view along the Y-axis of the screen,  which is like being in an elevator. When 
you move your cursor to the UP/DOWN wedge, a vertical slider is attached to the cursor. You 
can slide from up to down in the slider to view the model from up to down. Using the options 
in the shortcut menu of the SteeringWheels, you can go back to the original view, restore the 
original center, or fit the entire drawing in the viewport.

Modes of SteeringWheels
There are four working modes of SteeringWheels, refer to Figure 2-63. These working modes 
are discussed next.

Figure 2-63  Different modes of the SteeringWheels

2D Wheel
You can invoke the SteeringWheel that has only the 2D navigation tools. To do so, choose the 
2D tool from View > Navigate > SteeringWheels drop-down; the 2D SteeringWheel with the 
PAN, ZOOM, and REWIND tools will be displayed.
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Basic View Object Wheel
This mode contains only the viewing tools such as CENTER, ZOOM, REWIND, and ORBIT. 
You can invoke this mode by choosing Basic Wheels > View Object Wheel from the shortcut 
menu of the SteeringWheels or by choosing Basic View Object Wheel from the flyout that is 
displayed on clicking the down-arrow in the SteeringWheels group in the Navigation bar.

Basic Tour Building Wheel
This mode is ideal for navigating inside a building. It contains the FORWARD, REWIND, LOOK, 
and UP/DOWN tools. You can invoke this mode by choosing Basic Wheels > Tour Building 
Wheel from the shortcut menu of the SteeringWheels or by choosing Mini Tour Building 
Wheel from the flyout that is displayed on clicking on the down-arrow in the SteeringWheels 
group in the Navigation bar.

Full Navigation Wheel
This mode contains both the view and the navigating tools. It enables you to select a variety of 
tools from a single wheel. You can invoke this mode by choosing the Full Navigation Wheel 
option from the shortcut menu of the SteeringWheels or from the Navigation bar.

The SteeringWheels are of two types: Big Wheels and Mini Wheels. Both the wheels have the 
same functioning modes. The Big Wheels mode is displayed by default, whereas the Mini Wheels 
mode is invoked by choosing the Mini View Object Wheel, Mini Tour Building Wheel, or Mini 
Full Navigation Wheel option from the shortcut menu of the SteeringWheels or by choosing 
option from the SteeringWheels drop-down in the Navigation bar or by choosing option from 
the SteeringWheels drop-down in the Navigate panel of the View tab. You can customize the 
size, appearance, and behavior of the Steering Wheel using the SteeringWheels Settings dialog 
box, refer to Figure 2-64. 

Figure 2-64  The SteeringWheels Settings dialog box
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You can control the size and opacity of the Big Wheels and Mini Wheels with the help of a slider 
available next to the wheels. Also, using this dialog box you can control the tooltips and messages 
that are displayed when you move the cursor over any wedge.

Dynamically Rotating the View of a Model
 Ribbon:  View > Navigate > Orbit 		  Navigation Bar: Orbit	      	   
 Toolbar:  3D Navigation > Constrained Orbit        Command:  3DO(3DORBIT) 	  

The Orbit tool allows you to visually maneuver around 3D objects to obtain different 
views. This is one of the most important tools for the advanced 3D viewing options. All 
other advanced 3D viewing options can be invoked inside this tool or using the 3D 

Navigation toolbar. This tool activates a 3D Orbit view in the current viewport. You can click 
and drag your pointing device to view the 3D object from different angles. In 3D orbit viewing, 
the target is considered stationary and the camera location is considered to be moving around it. 
The cursor looks like a sphere encircled by two arc shaped arrows. This is known as Orbit mode 
cursor, and clicking and dragging the pointing device allows you to rotate the view freely. You 
can move the Orbit mode cursor horizontally, vertically, and diagonally. If you drag the pointing 
device horizontally, the camera will move parallel to the XY plane of the WCS. If you move your 
pointing device vertically, then the camera will move along the Z axis. This tool is a transparent tool 
and can be invoked inside any other tool. You can select individual objects or the entire drawing 
to view before you invoke the Orbit tool.

Tip 
Press and hold the SHIFT key and the middle mouse button to temporarily enter the 
constrained orbit mode. 

You can invoke the other advanced viewing options using the shortcut menu that is displayed 
on right-clicking in the drawing window when you are inside the Orbit tool. The shortcut menu 
with other advanced viewing options is shown in Figure 2-65. The options of the shortcut menu 
are discussed next.

Exit
This option is used to exit the Orbit tool. You can also exit this tool by pressing ESC.

Current Mode
This option displays the currently active navigation mode in which you obtained this shortcut 
menu. 

Other Navigation Modes
This option enables you to choose the other navigation modes of the 3D Navigation toolbar. In 
this way, you can toggle between the navigation modes without exiting the tool. The sub-options 
provided by the Other Navigation Modes are as follows:
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Free Orbit. This sub-option can be invoked by choosing the Free Orbit tool from View >   
Navigate > Orbit drop-down in the View Tab of the Ribbon, refer to Figure 2-66; 3D 

orbit view will be activated in the current viewport. When you invoke the Free Orbit tool, an 
arcball appears. This arcball is a circle with four smaller circles placed such that they divide the 
bigger circle into quadrants. The UCS icon is replaced by a shaded 3D UCS icon. In the 3D 
orbit viewing, the target is considered stationary and the camera location is considered to be 
moving around it. The target is the center of the arcball. The Free Orbit tool is a transparent 
tool and can be invoked inside any other tool.

The cursor icon changes as you move the cursor over the 3D Orbit view. The different icons 
indicate the different directions in which the view is being rotated. They are as follows.

Figure 2-65  The shortcut menu displayed when the 3DORBIT 
command is active

Figure 2-66  The tools in 
the Orbit drop-down

Orbit mode. When you move the cursor within the arcball, the cursor looks like a sphere 
encircled by two lines. This icon is the Orbit mode cursor, and clicking and dragging 
the pointing device allows you to rotate the view freely as if the cursor was grabbing a 
sphere surrounding the objects and moving it around the target point. You can move 
the Orbit mode cursor horizontally, vertically, and diagonally.

Roll mode. When you move the cursor outside the arcball, it changes to look like a 
sphere encircled by a circular arrow. When you click and drag, the view is rotated around 
an axis that extends through the center of the arcball, perpendicular to the screen.
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Orbit Left-Right. When you move the cursor to the small circles placed on the left and 
right of the arcball, it changes into a sphere surrounded by a horizontal ellipse. When 
you click and drag, the view is rotated around the Y axis of the screen.

Orbit Up-down. When you move the cursor to the circles placed in the top or bottom 
of the arcball, it changes into a sphere surrounded by a vertical ellipse. Clicking and 
dragging the cursor rotates the view around the horizontal axis or the X axis of the 
screen, and passes it through the middle of the arcball.

Figure 2-67 shows a model being rotated using the Free Orbit tool.

Figure 2-67  Model being rotated using the Free 
Orbit tool

Tip
1 . Press and hold the SHIFT+CTRL keys and the middle button of the mouse to temporarily 
enter the Free Orbit navigation mode.

2 . If you are in the 3D Orbit navigation mode, press and hold the SHIFT key to temporarily 
enter the Free Orbit navigation mode.

 
Continuous Orbit. This tool allows you to set the objects you select in a 3D view into continuous 

motion in a free-form orbit. You can invoke this tool by choosing the Continuous Orbit 
tool from View > Navigate > Orbit drop-down. While using this tool, the cursor icon 
changes to the continuous orbit cursor. Clicking in the drawing area and dragging the 

pointing device in any direction starts to move the object(s) in the direction you have dragged 
it. When you release the pointing device button, that is, stop clicking and dragging, the object 
continues to move in its orbit in the direction you specified. The speed at which the cursor is 
moved determines the speed at which the objects spin. You can click and drag again to specify 
another direction for rotation in the continuous orbit. While using this sub-option, you can 
right-click in the drawing area to display the shortcut menu and choose the other sub-options 
without exiting the tool. Choosing Pan, Zoom, Orbit, Adjust Clipping Plane ends the continuous 
orbit.

 Adjust Distance. This sub-option can be invoked by choosing Other Navigation Modes > 
Adjust Distance from the shortcut menu displayed on right-clicking in the drawing area. 
Alternatively, choose View > Camera > Adjust Distance from the menu bar. This 
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sub-option is similar to taking the camera closer to or farther away from the target object. 
Therefore, it makes the object appear closer or farther away. You can press the left button and 
drag the mouse to adjust the distance between the target and the camera. This option is used 
to reduce the distance between the camera and the object when the object rotates by a large 
angle.

Swivel Camera. This sub-option can be invoked by choosing View > Camera > Swivel from 
the menu bar. It works similar to turning the camera on a tripod without changing the 
distance between the camera and the target. You can press the left mouse button and 
drag the mouse to swivel the camera.

Walk. This sub-option can be invoked by choosing the Walk tool from Visualize > Animations> 
 Walk drop-down after customizing. It is similar to the Walk option in the SteeringWheel. 
This sub-option is used to move the camera around a model with the help of the keyboard, 
as if you are walking away or toward the focus direction of the camera. In walk 3D 

navigation, the camera moves parallel to the XY plane and this seems as if you are walking. 
Choose the Walk button; the POSITION LOCATOR window, showing the top view of the model 
with the location of the camera indicated by a red spot, will be displayed. The POSITION 
LOCATOR window shows a dynamic preview of the location and movement of the camera with 
respect to the object, refer to Figure 2-68. The following keys are used to control the location of 
the camera with respect to the object.

Motion Type	 Key

Move the camera in the forward direction UP ARROW or W key

Move the camera in the backward direction DOWN ARROW or S key

Move the camera in the left direction LEFT ARROW or A key

Move the camera in the right direction RIGHT ARROW or D key

Change the focus direction of the camera Press and hold the left mouse button in the 
drawing area and drag the mouse in the 
desired direction   

Change the orientation of the XY plane Press and hold the middle mouse button in 
the drawing area and drag the mouse in the 
desired direction

Change the distance of the camera Move the cursor to the green triangular area 
in the POSITION LOCATOR window and 
pan to the desired location

Change the coverage area of the camera Move the cursor onto the camera in the 
POSITION LOCATOR window and pan the 
camera
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Fly.    This sub-option can be invoked by choosing the Fly tool from Visualize > Anima> Walk 
drop-down after customizing. This sub-option is used to move the camera through a 
model with the help of the keyboard as if you are flying away or toward the focus direction, 
refer to Figure 2-68 of the camera. In the fly 3D navigation, the camera can even move 

at an inclination with the XY plane and this seems as if you are flying around the object. The 
POSITION LOCATOR window will be displayed on the screen while using the Fly tool also. The 
position of the camera with respect to the object can be controlled by using the same procedure 
as discussed in the Walk tool.

Figure 2-68  The POSITION LOCATOR window

Note
1. To control the settings related to walk and fly, invoke the tool and right-click in the drawing 
area. Next, choose the Walk and Fly Settings option; the Walk and Fly Settings dialog box will 
be displayed. You can specify the settings in this dialog box.

2. The Walk and Fly 3D navigation modes can be activated only in the perspective view. 
Activating the Walk or Fly 3D navigation mode in the parallel projection will display a warning 
window, as shown in Figure 2-69.  
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Figure 2-69  Warning displayed on activating the Walk 
and Fly 3D navigation modes in the parallel projection 

Tip 
You can toggle between the 3D navigation modes from the shortcut menu or by entering the 
number displayed in front of each option in the shortcut menu at the Command prompt.

Zoom. This sub-option can be invoked by choosing View > Zoom from the menu bar. It is 
similar to the ZOOM option in the SteeringWheel and functions like the camera’s zoom lens. 
You can invoke the other options of the Zoom by entering 3DZOOM at the Command prompt. 
Alternatively, the options can also be displayed by right-clicking in the drawing area when you 
are inside this tool.

Pan. The Pan sub-option is invoked by choosing View > Pan from the menu bar. It is similar to 
the PAN option in the SteeringWheel. This tool also starts the 3D interactive viewing. You can 
right-click in the drawing area, when you are inside this tool, to display a shortcut menu that 
displays all the 3D Orbit options.

Enable Orbit Auto Target
This option, if chosen, ensures that the target point is focused on the object while rotating the 
view. If this option is cleared, the target point is set at the center of the viewport, in which the 
Orbit tool is invoked.

Animation Settings
This option, if chosen, displays the Animation Settings dialog box, refer to Figure 2-70. Using 
this dialog box, you can change the settings for visual style, resolution, number of frames to be 
captured in one second, and the format in which you want to save the file while creating the 
animation of 3D navigation. Creating animations will be discussed in the next chapter.

Zoom Window/Extents/Previous
These options are used to zoom the solid model using a window, zoom the objects to the extents, 
or retrieve the previous zoomed views of the model.

Parallel
This option is chosen to display the selected model using the parallel projection method. It is 
the default method when a new AutoCAD file is started with 2D templates. In this method, no 
parallel lines in the model converge at any point.
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Perspective
This option is chosen to use the one point perspective method to display a model. It is the default 
method when a new AutoCAD file is started with 3D templates. In this method, all parallel lines 
in the model converge at a single point, thus providing a realistic view of the model when viewed 
with the naked eye, refer to Figure 2-71.

Figure 2-70  The Animation Settings dialog box Figure 2-71  Viewing the model using the 
perspective projection

Reset View
This option, when chosen automatically, restores the view that was current when you started 
rotating the solid model in the 3D orbit. Note that you will not exit the Orbit tool if you choose 
this option.

Preset Views
This option is used to select any of the six standard orthogonal views or four isometric views. 

Named Views
If you have created some views using the VIEW command, then the existing named views will 
be displayed as the sub-options under the Named Views option in the 3D Orbit shortcut menu. 
Use this option to activate the saved view.

Visual Aids
The Orbit tool provides you with three visual aids for the ease of visualizing the solid model 
in the 3D orbit view. These visual aids are Compass, Grid, and UCS Icon. A check mark is 
displayed in front of the options you have selected. You can select none, one, two, or all three of 
the visual aids. Choosing Compass displays a sphere drawn within the arcball with three lines. 
These lines indicate the X, Y, and Z axis directions. Choosing the Grid displays a grid at the 
current XY plane. You can specify the height by using the ELEVATION system variable. The 
GRID system variable controls the display options of the Grid before using the Orbit tool. The 
size of the grid will depend upon the limits of the drawing. Choosing the UCS Icon displays 
the UCS icon. If this option is not selected, then AutoCAD turns off the display of the UCS 
icon. While using any of the 3D Orbit options, interactive 3D viewing is on and a shaded 3D 
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view UCS icon is displayed. The X axis is red, the Y axis is green, and the Z axis is blue or cyan. 
Figure 2-72 shows a realistic shaded solid model displaying the compass, grid, and UCS icon.

Figure 2-72  Realistic shaded solid model 
showing the compass, grid, and UCS icon 

Clipping the View of a Model Dynamically
  Command:  3DCLIP    

The 3DCLIP command is used to adjust the clipping planes for sectioning the selected solid 
model. Note that the actual solid model is not modified by this command. This command is 
used only for the purpose of viewing. The original solid model will be restored when you exit this 
command. With this option, you can adjust the location of the clipping planes. When you choose 
this option, the Adjust Clipping Planes window will be displayed, as shown in Figure 2-73. In 
this window, the object appears rotated at 90-degree to the top of the current view in the window. 
This facilitates the display of cutting planes. Setting the location of the front and back clipping 
planes in this window is reflected in the result in the current view. The various options of the 
3DCLIP command are displayed in the Adjust Clipping Planes toolbar in the window. There 
are seven buttons provided in this window. The functions of these buttons are discussed next.

Adjust Front Clipping. This button is chosen to locate the front clipping plane, which is defined 
by the line located in the lower end of the Adjust Clipping Planes window. You can see 
the result in the 3D Orbit view if the front clipping is on. 

Adjust Back Clipping. This button is chosen to locate the back clipping plane, which is defined by 
the line located in the upper end of the Adjust Clipping Planes window. You can see the 
result in the 3D Orbit view if the back clipping is on. 

Create Slice. Choosing this button causes both the front and back clipping planes to move 
together. The slice is created between the two clipping planes and is displayed in the 
current 3D view. You can first adjust the front and the back clipping planes individually 
by choosing the respective options. Next, by choosing the Create Slice button, activate 
both the clipping planes simultaneously and display the result in the current view.

Pan.  Displays the pan cursor that you can use to pan the object in Adjust Clipping Planes 
window. Hold down the left mouse button and drag it in any direction. The pan cursor 
stays active until you click another button.
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Zoom. Displays a magnifying-glass cursor that you can use to enlarge or reduce the clipping 
plane. To do so, choose the Zoom tool and hold the left mouse button and drag it in up or 
down direction.

Front Clipping On/Off. Turns on or off the sectioning of a solid model using the front 
clipping plane, refer to Figure 2-74.

Back Clipping On/Off. Turns on or off the sectioning of the solid model using the back  
clipping plane, refer to Figure 2-74.

Figure 2-73  The Adjust Clipping 
Planes window

Figure 2-74  Model with the front and back 
clipping on

NUDGE FUNCTIONALITY
Nudge functionality gives you the freedom to move any kind of object by 2 pixels in any direction 
orthogonal to screen. When the snap mode is ON, the object moves to the distance specified 
in the Snap spacing edit box in the Drafting Settings dialog box. To nudge any object, select 
the object and press CTRL + arrow key corresponding to the direction in which you want to 
move the object. 

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The __________ and __________ commands can be used to change the viewpoint for viewing 
models in the 3D space.

2.	 Using the Viewpoint Presets dialog box, you can set the viewpoint with respect to __________ 
and __________.

3.	 The two types of 3D coordinate systems are __________ and __________.
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4.	 To view 3D clipping on an object, the __________ command is used.

5.	 The VPOINT command is used to change the viewpoint to view a solid model. (T/F)

6.	 The wireframe models can be converted into surface models as well as solid models. (T/F)

7.	 In AutoCAD, the right-hand thumb rule is followed to identify the direction of the X, Y, and 
Z axes. (T/F)

8.	 In AutoCAD, the right-hand thumb rule is followed to find the direction of rotation in the 
3D space. (T/F)

9.   Once you exit the 3DCLIP command, the original solid model is restored. (T/F) 

10.	 When you change the viewpoint, the 3D model moves from its default position. (T/F)

 Review Questions 
Answer the following questions:

1.	 In which of the following views a model is displayed by default in 3D Modeling workspace? 

		  (a) Perspective View		  (b) Parallel View
		  (c) Top View			   (d) None of these

2.	 Which of the following tools is used to create a 3D polyline?

	 (a) Polyline			   (b) 3D Poly
	 (c) 3D Polyline			   (d) Polyline 3D

3.	 Which of the following commands is used to set the elevation and thickness for new objects?

	 (a) ELEVATION		  (b) THICKNESS
	 (c) ELEV			   (d) THICK

4.	 Which of the following commands is used to suppress the hidden edges in a 3D model?

	 (a) SUPPRESS			   (b) HIDE
	 (c) 3DHIDE			   (d) EDGE

5.	 Which of the following views is set by default when you open a new drawing?

	 (a) SE Isometric View		  (b) SW Isometric View
	 (c) Custom View			  (d) Bottom View

6.    For the Sphere and Torus meshes if the MESHTYPE system variable is set to 0, the resulting 
surface will be a __________ mesh.
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7.   The highlighted area in a ViewCube that is used to change a view is called __________.

8.    A 3D model can be rotated continuously using the 3D Orbit tool. (T/F)

9.	 The ELEV command is a transparent command. (T/F)

10.	 You can directly write a text with thickness. (T/F)

Exercises 3 and 4
In these exercises, you will create the models shown in Figures 2-75 and 2-76. Assume the 
missing dimensions.

Figure 2-75  Model for Exercise 3 

Figure 2-76  Model for Exercise 4 
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Answers to Self-Evaluation Test
1. VPOINT, -VPOINT, 2. the angle in the XY plane from the X axis, angle from the XY plane, 
3. absolute, relative coordinate systems  4. 3DCLIP, 5. T, 6. F, 7. T, 8. T, 9. T, 10. F


