
Chapter 3

Editing and Modifying 
Sketches

  Learning Objectives 
After completing this chapter, you will be able to:
• Edit sketches using various editing tools
• Create rectangular patterns of sketched entities
• Create circular patterns of sketched entities
• Write text in the sketching environment
• Modify sketched entities
• Modify sketches by dynamically dragging sketched entities
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EDITING SKETCHED ENTITIES
In SOLIDWORKS, there are various tools that can be used to edit the sketched entities. These 
tools are used to trim, extend, offset, or mirror the sketched entities. You can also perform 
various other editing operations by using these tools. Various editing operations and the tools 
used to perform them are discussed next.

Trimming Sketched Entities
  CommandManager:	 Sketch >  Trim Entities flyout > Trim Entities	  
  SOLIDWORKS menus:	Tools > Sketch Tools > Trim			    
  Toolbar:  		  Sketch >  Trim Entities flyout > Trim Entities	

The Trim Entities tool is used to trim the unwanted entities

Figure 3-1  The Trim 
PropertyManager

 
in a sketch. You can use this tool to trim a line, arc, ellipse, 
parabola, circle, spline, or centerline intersecting another 

line, arc, ellipse, parabola, circle, spline, or centerline. You can 
also extend the sketched entities using the Trim Entities tool. 
To trim an entity, choose the Trim Entities button from the 
Sketch CommandManager; the Trim PropertyManager will be 
displayed, as shown in Figure 3-1.

The options in this PropertyManager to trim the sketched entities 
are discussed next.

Message Rollout
The Message rollout in this PropertyManager informs you about 
the procedure of trimming and extending the sketched elements, 
depending upon the option selected in the Options rollout of 
the Trim PropertyManager.  

Options Rollout
The Options rollout displays all the options that are used to trim 
the sketched entities. These options are discussed next.

Power trim
When the Power trim button is chosen in the Options rollout, 
the Message rollout in this PropertyManager will inform you 
about the procedure of trimming and extending the sketched 
elements using this option. To trim the unwanted portion of a sketch using this option, press 
and hold the left mouse button and drag the cursor. You will notice that a gray-colored drag 
trace line is displayed along the path of the cursor. When you drag the cursor across the 
unwanted sketched entity, it will be trimmed and a small red-colored box will be displayed 
in its place. You can continue trimming the entities by dragging the cursor across them. 
After trimming all the unwanted entities, release the left mouse button.

	 To extend or shorten an entity dynamically using this tool, click once on the entity and then 
move the cursor; the entity will extend or shorten dynamically depending upon the direction 
of movement. Move the cursor up to the level to which the entity has to be extended or 
shortened. Press the left mouse button to complete the operation.
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To extend a line or a curve such that it intersects with other entity, select the first entity and 
then select the second entity; the first entity will extend and intersect the second entity. 
While extending, if the first entity cannot intersect the second entity then the first entity 
will extend up to the apparent intersection point.

Note
If the first entity cannot be extended to intersect the second entity then a tooltip will be displayed 
informing you about it.

Corner
The Corner button in the Options rollout is used to trim or extend the sketched entities in 
such a way that the resulting entities form a corner. To trim the unwanted elements using 
this option, choose the Corner button from the Options rollout; you will be prompted to 
select an entity. Select the entity from the geometry area; you will be prompted to select 
another entity. When you move the cursor over the second entity, the preview of the resulting 
entity will be displayed in a different color. In the second entity, select the portion to be 
retained, as shown in Figure 3-2. The selected portions of the entities will be retained and 
the resulting entities will form a corner, as shown in Figure 3-3.

Figure 3-2  Entities to be selected for trimming Figure 3-3  Entities after trimming

You can also extend the entities using this tool. To do so, choose the Corner button from 
the Options rollout. Select the entities to be extended; the selected entities will be extended 
to their apparent intersection, refer to Figures 3-4 and 3-5.

Figure 3-4  Entities selected to extend Figure 3-5  Sketch after extension
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Trim away inside
The Trim away inside button in the Options rollout is used to trim the portion of a 
selected entity that lies inside two bounding entities. To trim the sketched entities using 
this tool, invoke the Trim PropertyManager and choose the Trim away inside button 
from the Options rollout; the Message rollout will be displayed informing you to select the 
two bounding entities, and then to select the entities to be trimmed. Select the bounding 
entities from the drawing area, refer to Figure 3-6. Now, select the entities to be trimmed 
from the drawing area. As you select an entity to be trimmed, the portion of the entity inside 
the bounding entities will be removed and the portion outside the bounding entities will be 
retained, refer to Figure 3-6.

Trim away outside
The Trim away outside button in the Options rollout is used to trim the portion of an 
entity that extend beyond the bounding entities. To trim the entities using this tool, invoke 
the Trim PropertyManager and choose the Trim away outside button from the Options 
rollout; the Message rollout will inform you to select the two bounding entities, and then to 
select the entities to be trimmed. Select the bounding entities from the drawing area, refer 
to Figure 3-7. Now, select the entities to be trimmed from the drawing area. As soon as you 
select an entity to be trimmed, the portion that lies outside the bounding entities will be 
removed and the portion lying inside will be retained, refer to Figure 3-7.

Figure 3-6  Entity trimmed using the Trim away 
inside button

Figure 3-7  Entity trimmed using the Trim away 
outside button

Trim to closest	
The Trim to closest button is used to trim the selected entity to its closest intersection. To 
trim the entities using this tool, invoke the Trim PropertyManager and then choose the 
Trim to closest button from the Options rollout; the cursor will be replaced by the trim 
cursor. Move the trim cursor near the portion of the sketched entity to be removed. The 
entity or the portion of the entity to be removed will be highlighted. Press the left mouse 
button to remove the highlighted entity. Figure 3-8 shows the entities to be trimmed and 
Figure 3-9 shows the sketch after trimming the entities.
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Figure 3-8  Entities to be trimmed Figure 3-9  Sketch after trimming the entities

You can also use this option to extend the sketched entities. To do so, move the trim cursor 
to the entity to be extended. When the sketched entity turns orange, press the left mouse 
button and drag the cursor to the entity up to which it has to be extended. You will notice 
the preview of the extended entity. Release the left mouse button when the preview of the 
extended entity appears; the entity will be extended.

Extending Sketched Entities	
  CommandManager:	 Sketch > Trim Entities flyout > Extend Entities	  
  SOLIDWORKS menus:	Tools > Sketch Tools > Extend	   		   
  Toolbar:  		  Sketch > Trim Entities flyout > Extend Entities	

The Extend Entities tool is used to extend the sketched entity

Figure 3-10  Tools in the 
Trim Entities flyout

 
to intersect the next available entity. The tool is used to extend 
a line, arc, ellipse, parabola, circle, spline, or centerline to 

intersect another line, arc, ellipse, parabola, circle, spline, or centerline. 
The sketched entity is extended up to its intersection with another 
sketched entity or a model edge. To do so, choose the Extend Entities 
button from the Trim Entities flyout in the Sketch CommandManager, 
as shown in Figure 3-10 and move the extend cursor close to the portion 
of the sketched entity that is to be extended. The entity to be extended 
will be highlighted and the preview of the extended entity will also be 
displayed. Click once to complete the extend operation. Figure 3-11 shows the sketched entities 
to be extended and Figure 3-12 shows the sketched entities after extension. 

Tip
If the preview of the sketched entity to be extended is shown in the wrong direction, move the 
extend cursor to a position on the other half of the entity and observe the new preview. 
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om Figure 3-11  Sketched entities to be extended Figure 3-12  Sketched entities after extension

Tip
You can toggle between the Trim Entities and Extend Entities tools using the shortcut menu 
that will be displayed on right-clicking when any one of these tools is active.

Convert Entities				  
  CommandManager:	 Sketch > Convert Entities flyout > Convert Entities	  
  SOLIDWORKS menus:	Tools > Sketch Tools > Convert Entities	   		   
  Toolbar:  		  Sketch > Convert Entities flyout > Convert Entities	

The Convert Entities tool is used to generate sketch entities by projecting existing edges 
of the model on to the current sketching plane. To generate the sketch entities, choose 
the Convert Entities tool from the Sketch CommandManager; the Convert Entities 

PropertyManager will be displayed, as shown in Figure 3-13. Select the face/faces or edge/edges 
of the solid/surface model; the projected curves of the selected entities will be generated on the 
current sketching plane. Figure 3-14 shows a model with the curves generated by projecting the 
edges of the model onto the current sketching plane. 

The Select chain check box is used to select the entire chain of contiguous sketched entities. 
You can select the Inner loops one by one check box to select the required loops. The Select 
all inner loops button available below these check boxes will be activated only when internal 
loops are present in the selected face of the model. You can choose this button to convert all 
internal loops into sketched entities.

Figure 3-13  The Convert Entities 
PropertyManager

Figure 3-14  The model with its projection curves on 
the sketching plane
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Intersection Curves				  
  CommandManager:	 Sketch > Convert Entities flyout > Intersection Curve	  
  SOLIDWORKS menus:	Tools > Sketch Tools > Intersection Curve  		   
  Toolbar:  		  Sketch > Convert Entities flyout > Intersection Curve	

The Intersection Curve tool is used to generate sketch entities or curves at the intersection 
of two objects. The intersection curves can be generated for the combination of following 
objects:

1.	 A plane and a surface/face
2.	 Two surfaces
3.	 A surface and a face
4.	 A plane and a part
5.	 A surface and a part

To generate the curves at the intersection, choose the Intersection Curve tool from the Convert 
Entities flyout in the Sketch CommandManager; the Intersection Curves PropertyManager 
will be displayed, as shown in Figure 3-15. Select the intersecting entities from the graphics area. 
Next, choose the OK button from the PropertyManager; the intersection curve will be created 
at the intersection of the entities selected, refer to Figure 3-16.

Figure 3-15  The Intersection 
Curves PropertyManager

Figure 3-16  The intersection curve 
projected on sketching plane

Filleting Sketched Entities
  CommandManager:	 Sketch >  Sketch Fillet flyout > Sketch Fillet	  
  SOLIDWORKS menus:	Tools > Sketch Tools > Fillet			    
  Toolbar:  		  Sketch >  Sketch Fillet flyout > Sketch Fillet	

A fillet creates a tangent arc at the intersection of two sketched entities. It trims or extends 
the entities to be filleted, depending on the geometry of the sketched entity. You can 
apply a fillet to two nonparallel lines, two arcs, two splines, an arc and a line, a spline 

and a line, or a spline and an arc. A fillet between two arcs, or between an arc and a line depends 
on the compatibility of the geometry to be extended or filleted along the given radius. You can 
first choose the Sketch Fillet tool from the Sketch CommandManager, and then select the 
entities to be filleted or select the vertex formed at the intersection of the two entities to be 
filleted. Alternatively, you can hold the CTRL key and select the two entities to be filleted and 
then invoke this tool. 
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When you invoke the Sketch Fillet tool, the Sketch Fillet

Figure 3-17  The Sketch Fillet 
PropertyManager

 
PropertyManager will be displayed, as shown in Figure 3-17. 
Next, select the entities; the preview of the fillet with default 
radius will be displayed. You can drag the fillet preview to resize 
it to the required radius or set the radius in the Fillet Radius 
spinner and press ENTER; a fillet will be created and the Sketch 
Fillet PropertyManager will be displayed even after applying a 
fillet. This enables you to create multiple fillets in a sketch. The 
consecutive fillets with the same radius are not dimensioned 
individually. An automatic equal radii relation is applied to all 
fillets. However, if you need to dimension each fillet then, select 
the Dimension each fillet check box. If you need to create 
multiple fillets of same dimension, then it is recommended that 
this check box should be cleared. If the Keep constrained 
corners check box is selected, the dimension and geometric 
relations applied to the sketch with respect to the corner to be 
filleted will not be deleted. If you clear the Keep constrained 
corners check box, then a message box will be displayed with the message: The corner to be 
filleted has geometry relations which will be deleted if the fillet is created. Do you want to 
continue? Choose the Yes button from the message box; the fillet will be created. Choose the 
OK button to exit the Sketch Fillet PropertyManager. 

Figure 3-18 shows the intersecting entities before and after applying the fillet. You can also 
select the non-intersecting entities for creating a fillet. In this case, the selected entities will be 
extended to form a fillet, as shown in Figure 3-19. 
 

Figure 3-18  Intersecting entities before and 
after applying a fillet

Figure 3-19  Non-intersecting entities before 
and after applying a fillet

Tip
You can also create a fillet between two entities by drawing a window around them after 
invoking the Sketch Fillet tool. To fillet the entities using this method, invoke the Sketch 
Fillet tool. Set the Radius spinner to the required value. Now, drag the cursor to create a 
window around the two entities to be filleted such that they are enclosed inside the window; 
preview of the fillet will be displayed. Choose the OK button; the fillet will be created.
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Note
The fillet creation between two splines, a spline and a line, and a spline and an arc depends on 
the compatibility of the spline to be trimmed or extended. 

Chamfering Sketched Entities
  CommandManager:	 Sketch > Sketch Fillet flyout > Sketch Chamfer	  
  SOLIDWORKS menus:	Tools > Sketch Tools > Chamfer		         	  
  Toolbar:  		  Sketch > Sketch Fillet flyout > Sketch Chamfer	

The Sketch Chamfer tool is used to apply a chamfer to the adjacent sketch entities at 
the point of intersection. A chamfer can be specified by two lengths or an angle and a 
length from the point of intersection. You can apply a

Figure 3-20  The Sketch Chamfer 
Property Manager

 
chamfer between two nonparallel lines that may be intersecting 
or non-intersecting. The creation of a chamfer between two 
non-intersecting lines depends on the length of the lines and 
the chamfer distance. To create a chamfer, choose the Sketch 
Chamfer button from the Sketch Fillet flyout of the Sketch 
CommandManager; the Sketch Chamfer PropertyManager 
will be displayed, as shown in Figure 3-20. Next, select the 
two entities to be chamfered. You can also select the two 
entities before invoking the Sketch Chamfer tool. The options 
in the Sketch Chamfer PropertyManager are discussed next.

Angle-distance 
The Angle-distance radio button is selected to create a chamfer by specifying the angle and the 
distance. When you select this radio button, the Direction 1 Angle spinner will be displayed 
below the Distance 1 spinner. Specify the distance and angle values in the Distance 1 and 
Direction 1 Angle spinners, respectively. Next, select the two entities to which the chamfer 
needs to be applied; a chamfer will be created, as shown in Figure 3-21(a). Note that the angle 
will be measured from the first entity you have selected.

Distance-distance
When you invoke the Sketch Chamfer PropertyManager, the Distance-distance radio button 
and the Equal distance check box are selected by default. Clear this check box to specify two 
different distances for creating chamfer, refer to Figure 3-21(b). When you clear this check box, 
the Distance 2 spinner will be displayed below the Distance 1 spinner to set the value of the 
distance in the second direction. Specify the distance value in both the spinners. Next, select the 
two entities that need to be chamfered; the chamfer will be created, as shown in Figure 3-21(b). 
Note that the distance 1 value will be measured along the first entity that you have selected and 
the distance 2 value will be measured along the second entity.

Equal distance
When you invoke the Sketch Chamfer PropertyManager, the Distance-distance radio button 
and the Equal distance check box are selected by default. As a result, you can create an equal 
distance chamfer between the selected entities. Specify the distance value in the Distance 1 
spinner and select the entities; the chamfer will be created, as shown in Figure 3-21(c). 

You can also invoke the shortcut menu to choose the options discussed to create a chamfer. 
Choose the OK button from the PropertyManager to exit the tool.
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Figure 3-21  Chamfer and its parameters

Offsetting Sketched Entities
  CommandManager:	 Sketch > Offset Entities 		              
  SOLIDWORKS menus:	Tools > Sketch Tools > Offset Entities	  
  Toolbar:		  Sketch > Offset Entities			 

Offsetting is one of the easiest methods to draw parallel

Figure 3-22  The Offset Entities 
PropertyManager

 
lines or concentric arcs and circles. You can select the 
entire chain of entities as a single entity or select an 

individual entity to be offset. You can offset the selected 
sketched entities, edges, loops, and curves. You can also select 
the parabolic curves, ellipses, and elliptical arcs to be offset. 
When you choose the Offset Entities button from the Sketch 
CommandManager, the Offset Entities PropertyManager will 
be displayed, as shown in Figure 3-22. The options in the Offset 
Entities PropertyManager are discussed next.

Offset Distance
The Offset Distance spinner is used to set the distance through 
which the selected entity needs to be offset. You can set the 
value of the offset distance in this spinner or set the value by 
dragging the offset entity in the drawing area.

Add dimensions
The Add dimensions check box is selected by default in the Parameters rollout. Therefore, a 
dimension showing the offset distance between the parent entity and the resulting offset entity 
will be displayed on creating offset entities.
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Reverse
The Reverse check box is used to change the direction of the offset. Note that while offsetting 
the entities by dragging, you do not need this check box as the direction of the offset can be 
changed by dragging the entities in the required direction.

Select chain
The Select chain check box is used to select the entire chain of continuous sketched entities 
that are in contact with the selected entity. When you invoke the Offset tool, the Select chain 
check box will be selected by default. If you clear this check box, only the selected sketched 
entity will be offset.

Bi-directional
The Bi-directional radio button is used to create an offset of the selected entity in both the 
directions of the selected entity. If the Bi-directional check box is selected, the Reverse check 
box will be deactivated in the Parameters rollout.

Cap ends
The Cap ends check box will be available only when the sketch to be offset is an open sketch. 
On selecting this check box, the ends of the bidirectionally offset entities will be closed. You can 
select the Arcs or Lines radio button to specify the type of cap to close the ends. Note that if 
you are offsetting a closed entity in both the directions, this option will not be available.

Base geometry
The Base geometry check box is used to convert the parent entity into a construction entity.

Offset geometry
The Offset geometry check box is used to convert an offset entity into a construction entity.

Figure 3-23 shows a new chain of entities created by offsetting the chain of entities and Figure 3-24 
shows the offsetting of a single entity. 

Tip
While performing any kind of editing operation, if you want to clear the current selection set, 
right-click in the drawing area and choose Clear Selections from the shortcut menu displayed.

Figure 3-23  Offsetting a chain of entities Figure 3-24  Offsetting a single entity
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Offsetting Edges or Face of a Model				 
  CommandManager:	 Sketch > Offset On Surface 		           
  SOLIDWORKS menus:	Tools > Sketch Tools > Offset On Surface	         
  Toolbar:		  Sketch > Offset On Surface(Customize to add)                                                          

The Offset On Surface tool is used to offset edges

Figure 3-25  The Offset On Surface 
PropertyManager

 
or faces of a model in a 3D sketch. To offset model 
edges or faces, choose the Offset On Surface tool 

from the Sketch CommandManager; the Offset On Surface  
PropertyManager will be displayed, as shown in Figure 3-25. 
The options in the Offset On Surface PropertyManager 
are discussed next.

Offset Distance
The Offset Distance spinner is used to specify the distance 
through which the selected entity needs to be offset. You 
can set the value of the offset distance in this spinner.

Add dimensions
The Add dimensions check box is selected by default in the Parameters rollout. Therefore, a 
dimension showing the offset distance between the parent entity and the resulting offset entity 
will be displayed on creating offset entities.

Reverse
The Reverse check box is used to offset an entity to the opposite face of the edge selected. Note 
that this check box will be available only if the selected edge is connected to the contiguous 
faces which are part of the same model.

Make offset construction
The Make offset construction check box is used to convert the offset entity into construction 
entity.

Figure 3-26 shows the face of a model selected to offset and the offset entity created. 

Figure 3-26  Face selected for offsetting 
and offset created
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Note
For using the Offset On Surface tool, you first need to create solid or surface models. Also, 
offset entities created will be included in a 3D sketch. You will learn about creating 3D sketches  
and models in later chapters.

Mirroring Sketched Entities                                          
  CommandManager:	 Sketch > Mirror Entities		   
  SOLIDWORKS menus:	Tools > Sketch Tools > Mirror	  
  Toolbar:	             Sketch > Mirror Entities		

The Mirror Entities tool is used to create a mirror image

Figure 3-27  The Mirror 
PropertyManager

 
of the selected entities. The entities are mirrored about 
a centerline, face or plane. When you create the mirrored 

entity, SOLIDWORKS applies the symmetric relation between 
the sketched entities. If you change the entity, its mirror image 
will also change. To mirror the existing entities, choose the Mirror 
Entities button from the Sketch CommandManager; the Mirror 
PropertyManager will be displayed, as shown in Figure 3-27. 
Also, you will be prompted to select the entities to be mirrored. 
Select the entities from the drawing area; the name of the selected 
entities will be displayed in the Entities to mirror selection box. 
After selecting all entities to be mirrored, click once in the Mirror 
about selection box in the Mirror PropertyManager. Alternatively, 
pause the mouse after selecting an entity; the Select symbol will 
be displayed below the cursor. Right-click when this symbol is 
displayed; the Mirror about selection box will be activated 
automatically and you will be prompted to select a line, linear 
model edge, or a planar entity to mirror about. Select a line, 
centerline, or a planar entity from the drawing area; the preview 
of the mirrored entities will be displayed. You need to make sure that the Copy check box is 
selected in the Mirror PropertyManager. If you clear this Copy check box, the parent selected 
entities will be removed and only the mirror image will be retained when you mirror the sketched 
entities. Choose the OK button from the Mirror PropertyManager.

Figure 3-28 shows the sketched entities with the centerline and Figure 3-29 shows the resulting 
mirror image of the sketched entities.  

Figure 3-28  Selecting the sketched entities and 
the centerline

Figure 3-29  Sketch after mirroring the geometry
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Mirroring Entities Dynamically 
  CommandManager:	 Sketch > Dynamic Mirror Entities		 (Customize to add)	
  SOLIDWORKS menus:	Tools > Sketch Tools > Dynamic Mirror				  
  Toolbar:		  Sketch > Dynamic Mirror Entities		 (Customize to add)	

The Dynamic Mirror Entities tool is used to mirror the entities dynamically about a 
symmetry line while sketching. This tool is recommended when you are drawing the 
symmetric sketches. You need to add this tool to the Sketch CommandManager by using 

the Customize dialog box, as discussed earlier. To mirror the entities while sketching, choose 
the Dynamic Mirror Entities button from the Sketch CommandManager; the Mirror 
PropertyManager will be displayed, as shown in Figure 3-30. The Message rollout in the Mirror 
PropertyManager informs that you need to select a sketch line or a linear model edge to mirror 
about. Select a line, a centerline, or a model edge from the drawing area that will be used as a 
symmetry line; the symmetry symbols appear at both the ends of the centerline to indicate that 
the automatic mirroring is activated, as shown in Figure 3-31.

Figure 3-30  The Mirror PropertyManager Figure 3-31  The centerline and the symmetry symbols

Now, start drawing the sketch. The entity that you draw on one side of the centerline will 
automatically be created on the other side of the mirror line (centerline). As evident from 
Figure 3-32, the entities are mirrored automatically while sketching. Figure 3-33 shows the 
complete sketch with automatic mirroring. After completing the sketch using the automatic 
mirroring option, you need to choose the Dynamic Mirror Entities tool again to exit the tool.

Figure 3-32  Sketch drawn using the Dynamic 
Mirror Entities tool

Figure 3-33  Complete sketch drawn 
using the Dynamic Mirror Entities tool
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Moving Sketched Entities
  CommandManager:	 Sketch >  Move Entities	 flyout > Move Entities	
  SOLIDWORKS menus:	Tools > Sketch Tools > Move			    
  Toolbar:  		  Sketch >  Move Entities flyout > Move Entities	

The Move Entities tool in the Sketch CommandManager

Figure 3-34  The Move 
PropertyManager

 
is used to move an entity from one location to other. To 
move an entity, invoke this tool from the Sketch 

CommandManager or select the entities, right-click, and then 
choose the Move Entities option from the shortcut menu. 
Remember that this tool will be available only when at least one 
sketched entity is drawn. When you invoke this tool, the Move 
PropertyManager will be displayed, as shown in Figure 3-34, 
and you will be prompted to select the sketched items or the 
annotations to be moved. The options in this PropertyManager 
are discussed next.

Entities to Move Rollout
The options in this rollout are used to select the entities to be 
moved. You will notice that the Sketch items or annotations 
selection box is active in this rollout. The names of the entities 
selected to be moved will be displayed in this selection box. To 
remove an entity from the selection set, select it again from the 
drawing area. Alternatively, you can select its name from the 
Sketch items or annotations selection box and right-click to display the shortcut menu. Choose 
the Delete option from the shortcut menu. If you choose the Clear Selections option from the 
shortcut menu, all the entities in the selection set will be removed. You will notice that by default, 
the Keep relations check box is selected. If you move the sketched entities with this check box 
cleared, the relations applied to the entities to be moved will be removed. If you select this check 
box and then move the entities, then the relations applied to the sketched entities are retained 
even if you move the entities. You will learn more about relations later in this chapter.

Parameters Rollout
The Parameters rollout is used to specify the origin and destination positions of the entities 
selected to move. The options in this rollout are discussed next.

From/To
The From/To radio button is selected by default. So, you can move the selected entities 
from one point to another. To move the selected entities using this option, click once in the 
Base point selection box; you will be prompted to define the base point. Click anywhere in 
the drawing area to specify the base point; a yellow circle will be displayed where the start 
point is specified and you will be prompted to define the destination point. Select a point 
anywhere in the drawing area to place the selected entities. 
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X/Y 
The X/Y radio button is selected to move the selected entities by specifying the relative 
coordinates of X and Y. On selecting this radio button, the Delta X and Delta Y spinners 
will be displayed below this radio button. Set the values of the destination coordinates in 
these spinners with respect to the current location.

Repeat
If the Repeat button is chosen, the entities will move further with the incremental distance 
specified in the Delta X and Delta Y spinners.

Figure 3-35 shows the selected entities being moved using the Move Entities tool. In this figure, 
the selected rectangle is moved from its selected base point to the new location.

Figure 3-35  Moving the selected entities

Rotating Sketched Entities
  CommandManager:	  Sketch > Move Entities flyout > Rotate Entities	
  SOLIDWORKS menus:  Tools > Sketch Tools > Rotate			 
  Toolbar:	 	  Sketch > Move Entities flyout > Rotate Entities	

To rotate the sketched entities, choose the Rotate Entities tool from the Move Entities 
flyout in the Sketch CommandManager, as shown in Figure 3-36. On doing so, the Rotate 
PropertyManager will be displayed, as shown in Figure 3-37, and you will be prompted 

to select the sketched items or annotations. Alternatively, to display this Property Manager, 
right-click in the drawing area and choose Rotate Entities from the shortcut menu displayed. 
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Figure 3-36  Tools in the 
Move Entities flyout

Figure 3-37  The Rotate 
PropertyManager 

Select the entities to be rotated; the names of the selected entities will be displayed in the Sketch 
items or annotations selection box of the Entities to Rotate rollout. Next, click in the Base 
point selection box in the Parameters rollout; you will be prompted to specify the center point 
of rotation. As soon as you specify the center point, the Angle spinner in the Parameters rollout 
will be highlighted. You can specify the angle of rotation using this spinner. You can also drag 
the mouse on the screen to define the angle of rotation.

Figure 3-38 shows a rectangle being rotated by dragging the cursor to define the angle of rotation. 
The lower right vertex of the rectangle is taken as the center point of rotation.

Figure 3-38  Dragging the cursor to rotate the rectangle        
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Scaling Sketched Entities
  CommandManager:	 Sketch > Move Entities flyout > Scale Entities	
  SOLIDWORKS menus:	Tools > Sketch Tools > Scale			    
  Toolbar:  		  Sketch > Move Entities flyout > Scale Entities	

To resize the entities, choose the Scale Entities tool from the

Figure 3-39  The Scale 
PropertyManager

 
Move Entities flyout in the Sketch CommandManager; 
the Scale PropertyManager will be displayed, as shown 

in Figure 3-39, and you will be prompted to select the sketched 
items or annotations. You can also invoke this PropertyManager 
by right clicking in the drawing area to display a shortcut menu 
and then choosing the Scale Entities tool from it. 

Select the entities to be resized; the names of the selected entities 
will be displayed in the Sketch items or annotations selection 
box of the Entities to Scale rollout. After selecting the entities to 
be scaled, right-click; you will be prompted to specify the point 
about which to scale. Specify the base point in the drawing area 
by clicking the left mouse button.

After specifying the base point, specify the magnification factor in 
the Scale Factor spinner of the Parameters rollout. The entities 
will be resized based on the value set in this spinner. 

If you need to create the copies of the selected entities, select the Copy check box. Else, choose 
the OK button from the Scale PropertyManager; the selected entities will be resized. If you 
select the Copy check box, the Number of Copies spinner will be displayed. Set the number 
of instances in this spinner and choose the OK button from the Scale PropertyManager; the 
entities will be resized and their copies will be created with an incremental scale factor with 
respect to the original entities selected.

Note
If in a selected set, geometric dimensions are assigned to entities, then those entities will not be 
modified. 

Stretching Sketched Entities
  CommandManager:	 Sketch > Move Entities flyout > Stretch Entities	  
  SOLIDWORKS menus:	Tools > Sketch Tools > Stretch Entities		    
  Toolbar:  		  Sketch > Move Entities flyout > Stretch Entities	  

To stretch the entities, choose the Stretch Entities tool from the Move Entities flyout in 
the Sketch CommandManager; the Stretch PropertyManager will be displayed, as shown 
in Figure 3-40, and you will be prompted to select the entities to stretch. Select the entities 

to be stretched by using the cross-window selection method, refer to Figure 3-41; the name of 
the entities selected will be displayed in the Entities To Stretch rollout of the Stretch 
PropertyManager. Click in the Stretch about selection box in the Parameters rollout and specify 
a point in the drawing area as the base point, refer to Figure 3-42. Now, move the cursor to the 



Editing and Modifying Sketches                            				           3-19                                                               

 E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

desired location; the selected entities will be stretched to the specified location. Figure 3-43 
shows the stretched sketch. 

Figure 3-40  The Stretch PropertyManager Figure 3-41  Selecting entities for stretching

Figure 3-42  Selecting the corner point for stretching Figure 3-43  The sketch after stretching

You can also stretch entities along X and Y axes. To do so,

Figure 3-44  The Parameters rollout

 
select the X/Y radio button from the Parameters rollout; 
the Parameters rollout will be modified, as shown in 
Figure 3-44. Now, set the desired distance values in the 
Delta X and Delta Y spinners; the dynamic preview of the 
selected entities to be stretched will be displayed in the 
drawing area. Once you are done, choose the OK button 
from the PropertyManager.
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Copying and Pasting Sketched Entities
  CommandManager:	 Sketch > Move Entities flyout > Copy Entities	
  SOLIDWORKS menus:	Tools > Sketch Tools > Copy			    
  Toolbar:  		  Sketch > Move Entities flyout > Copy Entities	

The Copy Entities tool allows you to copy the selected sketched entity and paste it to 
other location. Note that if dimensions are also selected along with the entities to be 
copied, then the dimensions will also be copied along with the sketched entities. To copy 
and paste the sketched entities, choose the Copy Entities tool from the Move Entities 

flyout in the Sketch CommandManager; the Copy

Figure 3-45  The  Copy 
PropertyManager

 
PropertyManager will be displayed, as shown in Figure 3-45.

Select the entities that you want to copy and then select the 
From/To radio button, if it is not selected by default. Next, 
click once in the Base point selection box and then specify 
the base point. Now, move the cursor; you will notice that the 
preview of the entities to be copied will be attached to the 
cursor. Click at a location in the drawing area to place the 
copied entities. If you need to create multiple copies, left-click 
at different locations. Else, right-click to invoke the shortcut 
menu and then choose the OK option from it to exit the tool. 
On selecting the X/Y radio button in the Parameters rollout 
of the Copy PropertyManager, you need to specify the X and 
Y coordinates of the new entities with respect to their current 
location and choose the OK button. Note that on selecting 
the X/Y  radio button, you cannot create multiple copies of 
the selected entities.

CREATING PATTERNS
Sometimes, while creating a base feature, you may need to place the sketched entities in a 
particular arrangement such as along linear edges or around a circle. Figures 3-46 and 3-47 show 
the base features with slots. These slots are created with the help of linear and circular patterns 
of the sketched entities. The tools that are used to create the linear and circular patterns of the 
sketched entities are discussed next.

Figure 3-46  Base feature with slots 
created along the linear edges

Figure 3-47  Base feature with slots 
created in circular pattern
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Creating Linear Sketch Patterns
  CommandManager:	 Sketch > Pattern flyout > Linear Sketch Pattern	
  SOLIDWORKS menus:	Tools > Sketch Tools > Linear Pattern	             	
  Toolbar:		  Sketch > Pattern flyout > Linear Sketch Pattern	

In SOLIDWORKS, the linear pattern of the sketched

Figure 3-48  The Linear Pattern 
PropertyManager

 
entities is created using the Linear Sketch Pattern tool. 
To create the linear pattern, select the sketched entities 

from the drawing area. Then, choose the Linear Sketch 
Pattern tool from the Pattern flyout in the Sketch 
CommandManager; the Linear Pattern PropertyManager 
will be displayed, as shown in Figure 3-48. Also, the preview 
of the linear pattern will be displayed in the drawing area and 
the arrow cursor will be replaced by the linear pattern cursor. 
Note that if you have not selected the sketched entities to be 
patterned before invoking this tool, you will have to select 
them one by one using the linear pattern cursor. The names 
of the selected entities are displayed in the Entities to Pattern 
rollout. You cannot draw a window to select entities by using 
the linear pattern cursor. 

The options in this PropertyManager are discussed next.

Direction 1 Rollout
The options in the Direction 1 rollout are used to define 
the first direction, distance between instances, number of 
instances, and the angle of pattern direction.

When the Linear Pattern PropertyManager is invoked, you will notice that only the options in 
the Direction 1 rollout are active. Select the sketched entities to be patterned; a callout will be 
attached to the direction arrow. The edit boxes in this callout are used to define the number of 
instances and the distance between the instances to be created. Alternatively, you can define these 
values in the Spacing and Number spinners in the Direction 1 rollout. You can also define the 
distance between the instances by dragging the select point provided on the tip of the direction 
arrow. By default, direction 1 is parallel to the X-axis. If you need to select any existing line or a 
model edge to define direction 1, click in the selection box in the Direction 1 rollout and select 
a line or an edge of the existing feature. Click on the direction arrow or choose the Reverse 
direction button from this rollout to reverse the pattern direction, if required. The Angle 
spinner is used to define the angle of the direction of the pattern. By default, the direction of 
the pattern is set to 0-degree. Select the Fix X-axis direction check box to constrain the angle of 
the pattern defined in the Angle spinner. If the Dimension X spacing check box is selected, the 
dimension will be attached between the parent instance and the first instance of the pattern. On 
selecting the Display instance count check box, the number of instances will be displayed in 
the resulting sketch pattern. Select this check box, if you need to create configurations in sketch 
patterns using the Design Table. Creating configurations using the Design Table is discussed 
in the later chapters.
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Figure 3-49 shows the preview of the linear pattern with instances along the direction 1. 
Figure 3-50 shows a linear pattern at an angle of 30 degrees.

Figure 3-49  Preview of the linear pattern with four instances 
along direction 1 and one instance along direction 2

Figure 3-50  Preview of the linear pattern at an angle of 30 
degrees along direction 1

Direction 2 Rollout
The options in the Direction 2 rollout are used to create pattern of the selected entities in the 
second direction. You will notice that the preview is not displayed in the second direction. This 
is because the value of the number of instances is set to 1 in the Number spinner. This means by 
default, only one instance will be created in the second direction and that is the parent instance. 
If you set the value of the number of instances to more than 1, then the options in this rollout 
will be enabled. All options in this rollout are the same, except the Dimension angle between 
axes check box. Select this check box to apply an angular dimension to the reference direction 
lines of both directions. Figure 3-51 shows a linear pattern created by specifying instances in 
both directions.
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Figure 3-51  Preview of the linear pattern at an angle 
of 45 degrees along direction 2

Tip
You can also specify the spacing and angle values dynamically in the preview of the linear 
pattern. To do so, press the left mouse button on a control point displayed at the end of the 
arrow in the pattern preview and drag the cursor. After placing the arrow at the desired 
location, release the left mouse button; the new spacing and angle value will be displayed in 
the respective spinner.

           
Instances to Skip Rollout
The Instances to Skip rollout is used to remove some of the instances from the pattern 
temporarily. By default, this rollout is not invoked. To invoke it, click on the down-arrow on 
the right side of the rollout. As soon as you activate the selection box in this rollout, pink dots 
will be displayed at the center of each pattern instance. To remove an instance from a pattern 
temporarily, move the cursor on the pink dot; a hand symbol will be displayed and its location 
will be displayed in the tooltip below the hand symbol in the matrix format. Click at the pink 
dot to remove a particular instance; the display of the instance will be turned off and its location 
will be displayed in the selection box. Also, the pink dot will change to an orange dot. Similarly, 
remove as many instances that you do not want to include in the pattern.

To restore the temporarily removed instances, select the orange dot displayed after hiding the 
instances. Alternatively, you can select the name of the instances from the Instances to Skip 
rollout and then press the DELETE key.

Tip
You can also add entities to the current selection set by selecting them using the linear pattern 
cursor. To remove an entity from the selection set, select the entity from the selection box in the 
Entities to Pattern rollout, right-click, and then choose Delete from the shortcut menu. As 
you add or remove instances, the effect can be seen dynamically in the preview of the pattern.
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Creating Circular Sketch Patterns
  CommandManager:	 Sketch > Pattern flyout > Circular Sketch Pattern		
  SOLIDWORKS menus:	Tools > Sketch Tools > Circular Pattern			    
  Toolbar:		  Sketch > Pattern flyout > Circular Sketch Pattern		

In SOLIDWORKS, the circular pattern of the sketched entities is created using the 
Circular Sketch Pattern tool. To create the circular pattern of an entity, select it and then 
choose the Circular Sketch Pattern tool from the Pattern flyout in the Sketch 

CommandManager; the Circular Pattern PropertyManager will be displayed, as shown in 
Figure 3-52, and the preview of the circular pattern will be  displayed. Also, the arrow cursor 
will be replaced by the circular pattern cursor and the names of the selected entities will be 
displayed in the Entities to Pattern rollout.

The options in the Circular Pattern PropertyManager are discussed next.

Parameters Rollout
The options in the Parameters rollout are used to define the centerpoint of the circular pattern, 
coordinates of the centerpoint of the reference circle, number of instances, angle between the 
instances or the total angle of pattern, radius of the reference circle, and so on. Figure 3-53 shows 
the parameters associated with the circular pattern. The options to define all these parameters 
are discussed next.

Figure 3-52  The Circular 
Pattern PropertyManager

Figure 3-53  Parameters associated with the circular pattern
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The Reverse Direction button is used to reverse the default direction of the circular pattern. 
The selection box on the right of this button is used to select the centerpoint of the circular 
pattern. By default, the origin is selected as the center of the circular pattern. You can modify this 
location by using the Center X and Center Y spinners. Alternatively, click once in the selection 
box and select the point that you want to be the new centerpoint or drag the center point to 
the new point. You can set the value of the number of instances using the Number of Instances 
spinner. By default, the Equal spacing check box is selected and the value of angle in the Angle 
spinner is set to 360-degree. When this check box is selected, the specified number of instances 
are equi-spaced radially. If you modify the default value in the Angle spinner, the angle between 
the instances will be adjusted accordingly. However, if the Equal Spacing check box is cleared, 
then you need to specify the incremental angle between the instances using the Angle spinner. 

The Radius spinner is used to modify the radius of the reference circle around which the circular 
pattern will be created. The Arc Angle spinner provided in this rollout is used to modify the angle 
between the centerpoint of the original pattern instance and the center of the reference circle. 

The Dimension radius and Dimension angular spacing check boxes are used to display the 
radius and angle between the pattern instances of the circular pattern. On selecting the Display 
instance count check box, the number of instances will be displayed in the resulting sketch 
pattern. Select this check box, if you need to create configurations in sketch patterns by using the 
Design Table. Creating configurations using the Design Table is discussed in the later chapters.

Note
If you know the location of the centerpoint of the circular pattern then it is recommended to drag 
the tip of the arrow to the center of the reference circle for defining the center of the circular pattern.

Instances to Skip Rollout
The Instances to Skip rollout is used to remove instances temporarily from the pattern. The 
procedure to skip instances is the same as discussed while creating the linear pattern.

Figure 3-54 shows the preview of the circular pattern with a 75-degree incremental angle 
between two successive instances. Figure 3-55 shows a circular pattern with the angle and spacing 
dimension values displayed in the pattern.

Tip
You can modify the total angle between instances by pressing the left mouse button on the tip 
of the direction arrow and then dragging the cursor. 
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Figure 3-54  Creating circular pattern by defining 
incremental angle between individual instances

Figure 3-55  Spacing and angle values placed 
in circular pattern

EDITING PATTERNS
You can edit the patterns of the sketched entities by using the

Figure 3-56  Partial view of 
the shortcut menu displayed

 
shortcut menu that will be displayed when you right-click on 
any instance of the pattern. Depending on whether you right-
click on the instance of the linear or circular pattern, the Edit 
Linear Pattern or Edit Circular Pattern option will be 
available in the shortcut menu. Figure 3-56 shows the partial 
view of the shortcut menu that will be displayed when you 
right-click on one of the instances of a circular pattern.

Depending on whether you choose the option to edit a linear 
pattern or a circular pattern, the Linear Pattern Property 
Manager or the Circular Pattern PropertyManager will be 
displayed. Note that only the parameters will be available in 
these PropertyManagers.

By using the Circular Pattern PropertyManager, you can 
edit the parameters of the patterns. If the distance between 
the instances or the angular dimension between the instances 
is displayed, then to change it without invoking a shortcut 
menu, double-click on the corresponding value; the Modify 
dialog box will be displayed. Enter a new value in the Modify dialog box and press ENTER. 
Similarly, if the number of instances is displayed in the sketch pattern, you can edit it by double-
clicking on it and entering a new value in the edit box displayed. Note that if you are changing 
the number of instances, then the distances between the instances and the angle between the 
instances will be deleted. However, you can add the dimensions using the Smart Dimension 
tool and this procedure is discussed in later chapters.
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WRITING TEXT IN THE SKETCHING ENVIRONMENT
CommandManager:	 Sketch > Text	 	
SOLIDWORKS menus:	 Tools > Sketch Entities > Text
Toolbar:		  Sketch > Text	 	

You can also write text in the sketching environment of

Figure 3-57  The Sketch Text 
PropertyManager

 
SOLIDWORKS and use it later to create extrude or cut 
features. To write the text, choose the Text button from 

the Sketch CommandManager ;  the Sketch Text 
PropertyManager will be displayed, as shown in Figure 3-57. 
Enter the text in the Text box in the Text rollout; the text will 
start from the sketch origin. To place the text at a specified 
location, exit the Sketch Text PropertyManager after writing 
the text. You will notice a dot at the start of the text. Drag the 
text and place at the required location. You can also change 
the format, font, justification, and so on using the options in 
the Text rollout. Figure 3-58 shows the text created using the 
Text tool.

You can also create the text along a curve. To do so, first you 
need to create a curve. The curve can be an arc, a spline, a 
line, or a combination of a line, arc, and spline. Next, choose 
the Text button to invoke the Sketch Text PropertyManager. 
Select the curve or curves along which you need to create the 
text. Now, enter the text in the Text edit box; you will observe 
that the text is created along the arc. You can use the Flip 
Horizontal and Flip Vertical buttons to modify the position 
of the text. Figure 3-59 shows the text created along an arc.

To change the font size, clear the Use document font check box 
and set the value in the Width Factor and Spacing spinners. You 
can also choose the Font button to change the font and text size.

Figure 3-58  Text created using the Text tool

Figure 3-59  Text created along an arc

Note
In SOLIDWORKS, you can link the sketch text with the file properties by choosing the Link to 
Property button in the Text rollout.
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Tip
If the text that you write appears reversed, you can draw a line from left to right and then use 
it as an element to align the text.

MODIFYING SKETCHED ENTITIES
Most of the sketches require modification at some stages of design. Therefore, it is important 
for a designer to understand the process of modification in SOLIDWORKS. Modification of 
various sketched entities is discussed next.

Modifying a Sketched Line
You can modify a sketched line by using the Line Properties PropertyManager. This 
PropertyManager is displayed when you select a line using the Select tool. Note that if the 
selected line is a part of a rectangle, polygon, or parallelogram, the entire object will be modified 
as you modify the line. This is because relations are applied to all lines of a rectangle, polygon, 
and a parallelogram.

Similarly, you can also modify a centerline using the Line Properties PropertyManager, which 
will be displayed when you select the centerline.

Modifying a Sketched Circle 
To modify a sketched circle, select it using the Select tool; the Circle PropertyManager will be 
displayed with the coordinate values of the centerpoint of the circle and the value of the radius 
in the Parameters rollout. You can modify the values in the respective edit boxes.

Tip
The status of the sketched entity that you select for modification is displayed in the Existing 
Relations rollout of the PropertyManager which is displayed on selecting an entity. For example, 
if the selected entity is fully defined, it will be displayed in the PropertyManager and if the entity 
is underdefined, the PropertyManager will display a message that the entity is underdefined.

Modifying a Sketched Arc
To modify a sketched arc, select it using the Select tool; the Arc PropertyManager will be 
displayed with the coordinate values of the centerpoint, start point, and endpoint. The values 
of the radius and the included angle will also be displayed. You can modify the values in the 
respective edit boxes.

Modifying a Sketched Polygon
To modify a sketched polygon, right-click on any one edge of the polygon to display the 
shortcut menu. Choose the Edit polygon option from the shortcut menu to display the Polygon 
PropertyManager. You can modify the selected polygon using the options in the Polygon 
PropertyManager.

Note
If you right-click on the reference circle that is automatically drawn when you draw a polygon, the 
Edit polygon option will not be available in the shortcut menu.



Editing and Modifying Sketches                            				           3-29                                                               

 E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Modifying a Spline
You can perform four types of modification on a spline. The first is the modification of the 
coordinates of the selected control point. The second modification is by using the Spline Handles. 
The third type of modification is by using the Control polygons. The fourth type of modification 
is the addition of a curvature control symbol. These  modifications are discussed in detail next.

Modifying a Spline by using the Control Points
To modify the location of the control points of a spline, select the spline; the Spline 
PropertyManager will be displayed. The control points of the spline will be displayed with a 
square. The number of the current control point and its coordinates will also be displayed in 
the Parameters rollout of the Spline PropertyManager, as shown in Figure 3-60. When you set 
the value in the Spline Point Number spinner, the corresponding control point will be selected 
in the spline. Now, you can modify its coordinates using the X Coordinate and Y Coordinate 
spinners. Alternatively, you can select and drag a control point to place it on  desired location. 

Figure 3-60  The Parameters rollout of the 
Spline PropertyManager

You can also add more control points to a spline. To do so, choose Tools > Spline Tools > Insert 
Spline Point from the SOLIDWORKS menus. Alternatively, select the spline and right-click 
to invoke the shortcut menu. In this menu, choose the Insert Spline Point option. Now, specify 
a location on the spline where you need to add the control point; a point and a spline handle 
will be displayed at the point specified on the spline. The spline handles are discussed in the 
next section. Similarly, you can add as many control points as needed. After adding the required 
number of control points, invoke the Select tool and select the spline again. You will notice that 
the boxes of control points are displayed on all points including the newly added points. 

      
Modifying a Spline by using the Spline Handles
A spline handle is a line with diamond handle, arrow, and circular handle on both its endpoints. 
The spline handles will be displayed when you select a spline using the Select tool. The default 
spline handles will be displayed in gray, which implies that they are not selected. When you move 
the cursor over a spline handle, it will be highlighted in orange. Additionally, a rotate symbol 
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will be displayed if you move the cursor near the diamond handle. A black colored arrow symbol 
will be displayed, if you move the cursor near the arrow. If you move the cursor near the circular 
handle, both the symbols will be displayed, as shown in Figure 3-61.

 
Move the cursor near the diamond handle, arrows,

Figure 3-61  The spline and the spline handle

 
or circular handle; it will be highlighted. On 
selecting any of these entities, the number of 
respective control points and their coordinates 
will be displayed in the Parameters rollout. 
Select and drag the diamond handle to 
dynamically modify the direction of the tangent. 
As you drag the diamond handle, the value in 
the Tangent Radial Direction spinner will 
change dynamically. When you drag the cursor 
the Tangent Driving check box is also selected 
automatically. After modifying the shape of the 
spline, click anywhere in the drawing area to 
exit the current selection set. You will notice that the currently modified spline handle is displayed 
in blue, which implies that the default setting of this spline handle is modified. Select and drag 
the arrowhead to modify the tangent weighting. As you drag the arrowhead, the value in the 
Tangent Weighting spinner will change dynamically. If you press the ALT key while dragging 
the arrowhead, the spline will get deformed symmetrically. Similarly, you can edit the spline 
using the circular handle. In this case, both the symbols will be displayed. So, the values in the 
Tangent Radial Direction and Tangent Weighting spinners will change dynamically. 

Choose the Reset This Handle button to reset the current handle to the original position. 
Choose the Reset All Handles button to reset all handles to the default position. To create a 
smooth curvature after editing the handles, choose the Relax Spline button.

To add more spline handles, select the spline and right-click to invoke the shortcut menu. 
Choose the Add Tangency Control option from the shortcut menu; a spline handle will be 
attached to the selected spline. Move the cursor to the location where you want to place the 
spline handle and click on that location. A spline control point will also be added along with 
the spline handle. You can also apply relations to the spline handles. You will learn more about 
relations in the later chapters. You can also delete the spline handles by selecting the control 
point and pressing the DELETE key.

You can also apply dimensions to the spline handles to shape a spline accurately. You will learn 
more about dimensioning in the later chapters.

Modifying a Spline by using the Control Polygon
To display the control polygon, select a spline and right-click; a shortcut menu will be displayed. 
Choose the Display Control Polygon option; the control polygons will be displayed, as shown 
in Figure 3-62. When you select a control polygon, the Spline Polygon PropertyManager will 
be displayed. You can also set the location of the control points by using the X Coordinate and 
Y Coordinate spinners in the Spline Polygon PropertyManager. You can modify the location 
of a control point by dragging it. To turn off the display of the control polygon, select a spline, 
invoke the shortcut menu, and choose Display Control Polygon again.
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Adding the Curvature Control
You can also add a curvature control to a spline to modify

Figure 3-62  Control point of the 
control polygon

 
its curvature. To add a curvature control, move the cursor 
over the spline and invoke the shortcut menu. Choose the 
Add Curvature Control option from it; the curvature 
control will be attached to the selected spline. Move the 
cursor to the location where you want to place the curvature 
control symbol and click; the curvature control will be 
added. Also, a spline handle will be placed at the location 
where the curvature control symbol is attached tangent to 
the spline. Now, select and drag the dot symbol at the end 
of this curvature control symbol. You will notice that the 
curvature of the spline is modified dynamically as you drag 
the cursor. After modifying the shape of the spline, release 
the left mouse button. You can also delete the curvature 
control symbol by selecting it and pressing the DELETE 
key.

Modifying the Coordinates of a Point
To modify the location of a point, select it using the Select tool; the Point PropertyManager will 
be displayed. You can modify the coordinates of the sketched point using this PropertyManager.

Modifying an Ellipse or an Elliptical Arc
To modify an ellipse or an elliptical arc, select it using the Select tool; the Ellipse 
PropertyManager will be displayed. You can modify the parameters of the ellipse using the 
options in this PropertyManager.

Modifying a Parabola
To modify a parabola, select the parabola using the Select tool; the Parabola PropertyManager 
will be displayed. Modify the parameters of the parabola from this PropertyManager.

Dynamically Modifying and Copying Sketched Entities 
In the sketching environment of SOLIDWORKS, you can relocate the sketched entities by 
dynamically dragging them using the left mouse button. For example, consider a case where you 
create the sketch of a rectangle and you want to increase the size of the rectangle. You simply have 
to select any of the lines or vertices of the rectangle and hold the left mouse button to drag the 
cursor. Drag the sketch according to your requirement and then release the left mouse button; all 
the segments in the rectangle will be dragged. However, if you choose Tools > Sketch Settings 
> Detach Segment on Drag from the SOLIDWORKS menus and select a line of a rectangle to 
drag, the line segment will be detached from the rectangle. As this option is not activated by 
default, the segments of the selected entities are not detached on dragging.

You can also copy the sketched entities dynamically. To do so, select the sketched entity or 
entities to be copied. Press and hold the CTRL key and then drag the selected entity or entities; 
preview of the copied entities will be displayed. Release the left mouse button at the location 
where you want to place the new entities. You can make multiple copies of the selected entities 
by repeating this procedure.
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Splitting Sketched Entities
  CommandManager:	 Sketch > Split Entities	 	 (Customize to add)	
  SOLIDWORKS menus:	Tools > Sketch Tools > Split Entities			 
  Toolbar:		  Sketch > Split Entities	 	 (Customize to add)	

The Split Entities tool is used to split a sketched entity into two or more entities. To split 
an entity, invoke the Split Entities tool from the Sketch CommandManager; the Split 
Entities PropertyManager will be displayed. Move the cursor to a location from where 

you want to split the sketched entity. When the cursor snaps to the entity, press the left mouse 
button to add a split point. Next, right-click to display the shortcut menu and then choose the 
OK option from the shortcut menu. Select the sketched entity using the select cursor. You will 
notice that the sketched entity gets divided in two entities and a split point is added between 
the two sketched entities. You can add as many split points as you need. Remember that to split 
a circle, a full ellipse, or a closed spline, you need to split them at least at two points.

You can also delete the split points to convert a split entity into a single entity. To delete a split 
point, select the split point and press the DELETE key. 

Creating Segments in Sketched Entities
  CommandManager:	 Sketch > Segment	 	 (Customize to add)	
  SOLIDWORKS menus:	Tools > Sketch Tools > Segment				 
  Toolbar:		  Sketch > Segment	 	 (Customize to add)	

The Segment tool is used to create equidistant point and

Figure 3-63  The Segment 
PropertyManager

 
segments in a sketched entity. To create segments in an 
entity, invoke the Segment tool from the Sketch 

CommandManager; the Segment PropertyManager will be 
displayed, as shown in Figure 3-63. Select the sketch entity on 
which you need to add segments; the selected entity will be 
displayed in the Select single entity(Arc, line, circle) selection 
box in the Segment Parameters rollout. Also, preview of segments 
points created on the selected sketch entity is displayed. You can 
change the number of segments points using the edit box 
provided. Next, select the Sketch points radio button if you need 
to add equidistant point on the sketched entity or else select the 
Sketch segments radio button to split the sketch entity into equal 
segments. Choose the OK button from the Segment 
PropertyManager; the segments will be created.
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TUTORIALS
Tutorial 1

In this tutorial, you will draw the base sketch of the model shown in Figure 3-64. The sketch of 
the model is shown in Figure 3-65. You will draw the sketch with a mirror line and a mirror tool. 
After drawing the sketch, you will modify it by dragging the sketched entities.
								              (Expected time: 30 min)

	 The following steps are required to complete this tutorial:

a.	 Start SOLIDWORKS and then start a new part document.
b.	 Invoke the sketching environment.
c.	 Create centerlines and convert one of the centerlines to mirror line using the Dynamic 

Mirror Entities tool.
d.	 Create the sketch in the third quadrant; the sketch will automatically be mirrored on the 

other side of the mirror line, refer to Figure 3-66.
e.	 Mirror the entire sketch along the second mirror line, refer to Figure 3-67.
f.	 Modify the sketch by dragging the sketched entities, refer to Figure 3-68.

Figure 3-64  Solid model for Tutorial 1 Figure 3-65  Sketch for Tutorial 1

Starting SOLIDWORKS and then a New SOLIDWORKS Document
1.	 Start SOLIDWORKS by double-clicking on the shortcut icon of SOLIDWORKS 2018 on the 

desktop of your computer; the SOLIDWORKS 2018 window along with the WELCOME- 
SOLIDWORKS 2018 dialog box will be displayed. 

	
2.	 Choose the Part button available in the New area of the Home tab in the Welcome - 

SOLIDWORKS 2018 dialog box. A new SOLIDWORKS part document starts. 

	 Next, you need to invoke the sketching environment.
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3.	 Choose the Sketch tab from the CommandManager, if it is not selected by default.  
Next, choose the Sketch button from the Sketch CommandManager; the Edit 
Sketch PropertyManager is invoked and you are prompted to select the plane to 
create the sketch. 

4.	 Select the Front Plane; the sketching environment is invoked and the plane is oriented 
normal to the view.

Modifying the Grid and Snap Settings and the Dimensioning Units
Before drawing the sketch, you need to modify the grid and snap settings to make the cursor 
jump through a distance of 10 mm.

1.	 Choose the Options button from the Menu Bar; the System Option - General dialog  
box is displayed.

	 While installing SOLIDWORKS, if you have selected a unit other than millimeter to measure 
the length then you need to select millimeter as the unit for the current drawing by following 
the next two steps.

2. 	 Choose the Document Properties tab and select the Units option from the area on the 
left-side of the Document Properties - Drafting Standard dialog box. 

3.	 Next, select the MMGS (millimeter, gram, second) radio button in the Unit system area 
and select degrees from the drop-down list in the cell corresponding to the Angle row and 
the Unit column, if it is not selected by default.

4.	 Next, click on the Grid/Snap option from the area on the left in the dialog box. Set the 
values 100 and 10 in the Major grid spacing spinner and the Minor-lines per major spinner, 
respectively.

	 On invoking the sketching environment, if the grid is displayed by default, you can turn off 
its display by clearing the Display grid check box in the Grid area.

5.	 Choose the Go To System Snaps button and select the Grid check box. Next, clear the Snap 
only when grid is displayed check box, if it is selected.

6. 	 After making the necessary settings, choose the OK button.

	 The coordinates displayed close to the lower right corner of the SOLIDWORKS window 
show an increment of 10 mm when you move the cursor in the drawing area after exiting 
the dialog box.	

Drawing the Centerlines and Converting Them into Mirror Lines
	 It is recommended that you draw symmetrical sketches about an axis by using any of the 

mirroring tools. In this tutorial, you will draw the sketch using the Line, Dynamic Mirror, 
and Mirror Entities tools. However, you can also complete this tutorial by using the Line 
and Dynamic Mirror tools. 
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1. 	 Choose the Centerline button from the Line flyout available in the Sketch 
CommandManager.

2.	 Move the line cursor to a location whose coordinates are 0 mm, 100 mm, and 0 mm. You 
may need to zoom in the drawing to locate that point.

3.	 Specify the start point of the centerline at this point, move the cursor vertically downward 
and draw a line of 200 mm length. You may need to zoom and pan the drawing to draw a 
line of this length.

4.	 Now, double-click anywhere on the screen to end the current chain or right-click anywhere 
in the drawing area to invoke the shortcut menu and choose the End chain option from it.

5.	 Move the line cursor to a location whose coordinates are -100 mm, 0 mm, and 0 mm.

6.	 Specify the start point of the centerline and move the cursor horizontally toward the right 
to draw a line of 200 mm length. Pan the drawing, if required.

7.	 Press F to fit the drawing on the screen. Right-click and choose the Select option from the 
shortcut menu; the line cursor is replaced by the select cursor.

8.	 Select the vertical centerline.

9.	 Choose Tools > Sketch Tools > Dynamic Mirror tool from the SOLIDWORKS  
menus; the vertical centerline is converted into a mirror line and the dynamic mirror 
option is activated. 

	 You can confirm the creation of the mirror line and the activation of the dynamic mirror 
option by observing the symmetrical symbol displayed on both ends of the centerline.

Drawing the Sketch
	 Next, you need to draw the sketch of the base feature. You will draw the sketch in the third 

quadrant and the same sketch will be created automatically on the other side of the mirror 
line. The symmetrical relation is applied between the parent entity and the mirrored entity.

1.	 Press the L key on the keyboard; the Line tool is invoked.

2.	 Move the line cursor to a location whose coordinates are 0 mm, -100 mm, and 0 mm.

3.	 Specify this point as the start point of the line and move the cursor horizontally toward the 
left.

4.	 Specify the endpoint of the line when 80 is displayed above the line cursor.

	 You will notice that as soon as you specify the endpoint of the line, a mirror image is 
automatically created on the other side of the mirror line. The line drawn as the mirrored 
entity gets merged with the line drawn on the left. Therefore, the entire line becomes a 
single entity. Remember that the lines will merge only if one of the endpoints of the line 
drawn is coincident with the mirror line.
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5.	 Move the cursor vertically upward and click to specify the endpoint of the line when the 
length of the line above the line cursor shows the value 30.

	 You will notice that as soon as you specify the endpoint of the line, a mirror image is created 
automatically on the other side of the mirror line.

6.	 Move the line cursor toward the right and click to specify the endpoint of the line when 
the length of the line above the line cursor shows the value 30; a mirror image is created 
automatically on the other side of the mirror line.

7.	 Move the line cursor vertically upward and click to specify the endpoint of the line when 
the line cursor snaps the horizontal centerline. Exit the Line tool. The sketch after drawing 
the lines is shown in Figure 3-66.

Mirroring the Entire Sketch
	 After creating one-half of the sketch, you need to mirror the entire sketch about the horizontal 

centerline. But, first you need to disable automatic mirroring.

1.	 Right-click and choose Recent Commands > Dynamic Mirror Entities from the shortcut 
menu to disable dynamic mirroring. 

2.	 Use the box selection method to select all the lines sketched earlier and also the horizontal 
centerline. Make sure you do not select the vertical centerline. 

3.	 Choose the Mirror Entities tool from the Sketch CommandManager; the entire  
sketch is mirrored about the horizontal centerline. The sketch after mirroring the 
sketched entities is shown in Figure 3-67.

Figure 3-66  Sketch after drawing the lines Figure 3-67  Sketch after mirroring sketched 
entities
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Modifying the Sketch by Dragging Entities
	 Next, you need to modify the sketch by dragging. While dragging the entities, you will 

observe that the corresponding mirrored entity is also being modified.

1.	 Select the lower right vertical line; the Line Properties PropertyManager is displayed on 
the left of the drawing area. You will notice that the value in the Length spinner is 30. 

2.	 As the required length of this line is 20, set the value in the Length spinner to 20 in the 
Parameters rollout. You will observe that all the dependent lines are also modified. This is 
because they are created as mirror images.

3.	 Choose the Close Dialog button or click once in the drawing area.

4.	 Select  the midpoint of the right vertical line that

Figure 3-68  Final sketch for Tutorial 1

 
passes through the horizontal centerline; the Point 
PropertyManager is displayed. You will notice that 
the coordinates of this point are 50,0.

5.	 Press and hold the left mouse button and drag 
the point toward the origin; the value in the X 
Coordinate spinner of the Parameters rollout 
changes dynamically.

6.	 Release the left mouse button when the X 
Coordinate spinner shows the value 10. The final 
sketch after modifying the sketched entities by 
dragging them is shown in Figure 3-68.

Saving the Sketch
1.	 Choose the Save button from the Menu Bar to invoke the Save As dialog box.

2.	 Choose the New Folder button from the Save As dialog box. Enter the name of the folder 
as c03 and press ENTER. Enter the name of the document as c03_tut01 in the File name 
edit box and choose the Save button. 

3.	 Press CTRL+W to close the file.

Tutorial 2
In this tutorial, you will create the sketch of the model shown in Figure 3-69. The sketch of 
the model is shown in Figure 3-70. Do not dimension the sketch as the solid model and the 
dimensions are given for your reference only. 			         (Expected time: 30 min)

	 The following steps are required to complete this tutorial:

a.	 Start a new part document.
b.	 Invoke the sketching environment.
c.	 Create a centerline.
d.	 Draw and edit the sketch using the Mirror Entities and Trim Entities tools, refer to 

Figure 3-72.
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e.	 Offset the entire sketch, refer to Figure 3-73.
f.	 Complete the final editing of the sketch using the Extend Entities and Trim Entities tools, 

refer to Figures 3-74 and 3-75.

Figure 3-69  Solid model for Tutorial 2 Figure 3-70  Sketch for Tutorial 2

Starting a New Document
1.	 Choose the New button from the Menu Bar to invoke the New SOLIDWORKS  

Document dialog box.

2.	 The Part button is chosen by default in the New SOLIDWORKS Document dialog box. 
Choose the OK button.

3.	 Choose the Sketch button from the Sketch CommandManager and select Front Plane  
to invoke the sketching environment. 

4.	 Invoke the Document Properties - Units dialog box and change the units to MMGS 
(millimeter, gram, second) if it is not selected by default.

5.	 Invoke the Document Properties - Grid/Snap dialog box. Now, set 100 in the Major grid 
spacing spinner and 10 in the Minor-lines per major spinner. Choose the Ok button.

Drawing the Centerline 
	 Before drawing the sketch, you need to draw a centerline that will act as a reference for the 

other sketched entities. This centerline will also be used for mirroring.
 
1. 	 Choose the Centerline button from the Line flyout in the Sketch CommandManager.

2.	 Move the cursor to a location whose coordinates are -70 mm, 0 mm, and 0 mm.

3.	 Specify this point as the start point and move the cursor horizontally toward the right.

4.	 Specify the endpoint of the centerline by clicking at a location when the value of the length 
of the centerline above the line cursor is 140.
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5.	 Double-click anywhere in the drawing area to end the line creation and exit the Centerline tool.

Drawing the Outer Loop of the Sketch 
	 Next, you need to draw the outer loop of the sketch using the sketch tools. As it is evident 

from Figure 3-70, the sketch needs to be drawn using the Circle and Line tools.

1.	 Press and hold the right-mouse button and drag the cursor to the right; the mouse gesture 
is displayed with sketching tools. Move the cursor over the Circle tool; the Circle tool is 
invoked and the Circle PropertyManager is displayed.

2.	 Make sure that the Circle button is chosen in the Circle Type rollout in the Circle 
PropertyManager. Move the circle cursor to the origin and click when an orange circle is 
displayed to specify the center point of the circle.

3.	 Move the cursor horizontally toward the right and draw a circle of 100 mm diameter.

4.	 Choose the Zoom to Fit button from the View (Heads-Up) toolbar to increase the display 
of the sketch.

5.	 Choose the Line button from the Sketch CommandManager and move the cursor to a 
location whose coordinates are -60 mm, 10 mm, and 0 mm. Specify the start point of the 
line at this location. 

6.	 Move the cursor horizontally toward the right and click to specify the endpoint of the line 
when the line cursor snaps the circle. Exit the Line tool. 

7.	 Press and hold the SHIFT key and then using the left mouse button, select the centerline,  
and the horizontal line created in the last step. 

8.	 Choose the Mirror Entities button from the Sketch

Figure 3-71  Line button in mouse 
gesture

 
CommandManager; the mirror image of the horizontal 
line is created on the other side of the centerline.

9.	 Choose the Line button using the mouse gesture, refer to 
Figure 3-71 and then move the cursor to the left endpoint 
of the upper horizontal line. Click to specify the start point 
of the line when the orange circle is displayed.

10.	 Move the cursor vertically downward. Click in the drawing 
area when the cursor snaps to the left endpoint of the lower 
horizontal line. Exit the Line tool.

11.	 Choose the Trim Entities button from the Sketch 
CommandManager; the Trim PropertyManager is displayed. 

12.	 Choose the Power trim button from the PropertyManager. Press and hold the left mouse 
button and drag the cursor over the portion to be removed. Choose the Close Dialog button 
from the PropertyManager. The sketch after removing the unwanted portion is shown in 
Figure 3-72.
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Tip
If you have trimmed the centerline, invoke the shortcut menu and choose the Extend Entities 
option. Then, move the cursor over one end of the centerline and press the left mouse button 
to extend the line. Alternatively, perform the undo operation.

Offsetting the Entities
	 After drawing the outer loop of the sketch, you need to draw the inner loop. The first step 

for drawing the inner loop of the sketch is offsetting the entire sketch inward.

1.	 Choose the Offset Entities button from the Sketch CommandManager; the Offset  
Entities PropertyManager is displayed on the left in the drawing area. 

2.	 Set the value of the Offset Distance spinner to 4. Select the Add dimensions and Select 
chain check boxes, if they are not selected. Select any one entity of the sketch; the entire 
sketch is selected.

	 When you select the sketch, the preview of the offset sketch is displayed in the drawing area. 
The direction of the offset is outward. However, the direction of the offset should be inward 
of the sketch. Therefore, you need to flip the direction.

3.	 Move the cursor inside the sketch and press the left mouse button to offset the sketch inside 
the original sketch; a dimension with the value 4 is displayed with the sketch.

	 The sketch after offsetting the outer loop is shown in Figure 3-73.

Figure 3-72  The sketch after removing the 
unwanted portion

Figure 3-73  Sketch after offsetting the outer loop

Extending and Trimming the Entities
1.	 Choose the Extend Entities button from the Trim Entities flyout in the Sketch  

CommandManager; the select cursor is replaced by the extend cursor.

2.	 Move the cursor close to the left end of the lower horizontal line of the inner loop. You can 
preview the extended line appearing in orange. 
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	 You need to move the cursor a little toward the left if the preview of the extended line 
appears on the right. 

3.	 Press the left mouse button to extend the line.

4.	 Similarly, extend the upper horizontal line of the inner sketch. The sketch after extending 
the lines is shown in Figure 3-74.

5.	 Right-click and choose the Trim Entities option from the shortcut menu; the extend cursor is 
replaced by the trim cursor.

6.	 Trim the unwanted entities as discussed earlier and exit the trim command. The final sketch 
is shown in Figure 3-75.

Figure 3-74  Sketch after extending the lines Figure 3-75  Final sketch for Tutorial 2

Tip
 You can turn on/off the display of the relation symbols on the sketched entities by choosing the 
Hide/Show Items > View Sketch Relations button from the View (Heads-Up) toolbar.

Saving the Sketch
1.	 Choose the Save button from the Menu Bar to invoke the Save As dialog box.

2.	 Enter c03_tut02 as the name of the document in the File name edit box and then choose 
the Save button. 

3.	 Close the file by choosing File > Close from the SOLIDWORKS menus.
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Tutorial 3
In this tutorial, you will create the base sketch of the model shown in Figure 3-76. The sketch 
of the model is shown in Figure 3-77. You will create the sketch of the base feature by using 
the sketch tools. Also, you will modify and edit the sketch using various modifying options. Do 
not create the center marks and centerlines as they are for your reference only.  
								              (Expected time: 30 min)

Figure 3-76  Solid Model for Tutorial 3 Figure 3-77  Sketch for Tutorial 3

	 The following steps are required to complete this tutorial:

a.	 Start a new part document.
b.	 Invoke the sketching environment.
c.	 Draw the outer loop of the sketch, refer to Figures 3-78 and 3-79.
d.	 Create a circle to define the hole in the outer loop.
e.	 Use the Circular Sketch Pattern tool to create a circular pattern of circles in the outer loop, 

refer to Figure 3-79.

Starting a New Document
1.	 Choose the New button from the Menu Bar to invoke the New SOLIDWORKS Document 

dialog box.

2.	 In this dialog box, the Part button is chosen by default. Choose the OK button.

	 Next, you need to invoke the sketching environment.

3.	 Choose the Sketch button from the Sketch CommandManager; the Edit Sketch 
PropertyManager is invoked and you are prompted to select the plane to create the sketch. 

4.	 Select the Front Plane as the sketching plane; the sketching environment is invoked and 
the plane is oriented normal to the view.
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5.	 Choose the Options button from Menu Bar; the System Option - General dialog box is 
displayed. 

6.	 Choose the Document Properties tab from this dialog box and select the Units option from 
the area on the left. Set the units to millimeters by selecting the MMGS (millimeter, gram, 
second) option from the Units system area.

7.	 Next, choose the Grid/Snap option from the area on the left. Set the value of the Minor-lines 
per major spinner to 20 and the Major grid spacing spinner to 100. 

8. 	 Choose the OK button after making the necessary settings.

Drawing the Outer Loop of the Sketch
It is evident from Figure 3-77 that the sketch consists of the outer loop and inner cavities. It 
is recommended that you create the outer loop of the sketch first and then the inner cavities.

The origin of the sketching environment is in the middle of the drawing area and you need 
to create the sketch in the first quadrant. Therefore, it is recommended that you modify the 
drawing area by relocating the origin.

1.	 Press the CTRL key and the middle mouse button and then drag the cursor in such a way 
that the origin of the sketch is moved near the lower left corner of the drawing area.

2.	 Press and hold the right mouse button and drag the cursor to the right; the sketching tools 
are displayed in the mouse gesture. Move the cursor over the Circle tool; the Circle tool is 
invoked and the Circle PropertyManager is displayed.

3.	 Make sure that the Circle button is chosen in the Circle Type rollout of the Circle 
PropertyManager.

4.	 Move the cursor to a location whose coordinates are 70 mm, 70 mm, and 0 mm.

5.	 Click to specify the center point of the circle at this location and move the cursor horizontally 
toward the right. Click when the radius above the circle cursor shows the value 50.

6.	 Choose the Zoom to Area button from the View (Heads-Up) toolbar. Press and hold  
the left mouse button and drag the cursor to define a window such that the sketched 
circle and the origin are placed in the window.

7.	 Release the left mouse button; the display area of the sketch is increased.

8.	 Invoke the Circle tool by using the mouse gesture and move the cursor to the right quadrant 
of the circle. All the quadrants of the circle are displayed and the right quadrant on which 
you have placed the cursor is displayed in orange. Also, the symbol of coincident constraint 
is displayed below the cursor.

9.	 Specify the center point of the circle at this location and move the cursor horizontally toward 
the right. When the value of the radius above the circle cursor shows 10, press the left mouse 
button.
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10.	 Press the S key from the keyboard; a toolbar is displayed. Choose the Trim Entities button;  
the Trim PropertyManager is displayed. Next, choose the Trim to closest button from this 
PropertyManager.

11.	Trim the sketch such that it looks similar to the one shown in Figure 3-78. Exit the Trim 
tool.

12.	Select the trimmed circle of radius 10 mm and

Figure 3-78  Sketch after trimming the 
unwanted entities

 
choose the Circular Sketch Pattern button from 
the Pattern flyout in the Sketch CommandManager; 
the Circular Pattern PropertyManager is 
displayed and the preview of the circular pattern 
with the default setting is displayed in the drawing 
area.	

	 On doing this, you will notice that the center 
of the circular pattern is placed at the origin 
and an arrow is displayed, indicating that the 
origin is the center of the circular pattern. 
But, in this sketch, the center of the circular 
pattern is not at the origin, so you need to modify 
it. This can be done by setting the coordinates of 
the point in the Center X and Center Y spinners 
in the Parameters rollout of this PropertyManager. However, it is recommended that you 
drag the arrow displayed at the center of the pattern to the required location.

13.	Move the circular pattern cursor to the control point available at the end of the arrow.

14.	Press and hold the left mouse button at the control point and drag it to the center of the 
100 mm diameter circle. Release the left mouse button when an orange circle is displayed 
at the center point of the circle.

	 You will notice that both the Center X and Center Y spinners display the value 70 mm. 
This is because the center of the 100 mm diameter circle is located at a distance of 70 mm 
along the X and Y axis directions.

15.	Set 6 in the Number of Instances spinner. 

16.	Clear the Dimension angular spacing  check box if it is selected. 

17.	Select the Display instance count check box. Accept the remaining default values and 
choose the OK button to create the pattern.

18.	 Trim the unwanted portion of the 100 mm diameter circle using the Trim Entities tool. You 
need to use the Trim to closest button for this trimming. 

19.	 Choose OK from the Trim PropertyManager after trimming. The outer loop of the sketch 
is created, as shown in Figure 3-79.
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Sketching the Holes 
	 Next, you need to draw the sketch of the holes. It is evident from Figure 3-77 that you need 

to create six circles. After drawing the first circle, you need to create the other five circles 
by creating a circular pattern of the parent circle. 

1.	 Invoke the Circle tool by using the mouse gesture.

2.	 Select the center point of the 10 mm radius arc on the left quadrant of the larger circle as 
the center point of the new circle. 

3.	 Press and hold the CTRL key and then draw a circle of diameter close to 10. Make sure you 
press the CTRL key so that the cursor does not snap to the points or grid.

4.	 Set 5 in the Radius spinner in the Circle PropertyManager.

Creating the Circular Pattern of the Holes
1.	 Choose the Circular Sketch Pattern button from the Pattern flyout in the Sketch 

CommandManager; the Circular Pattern PropertyManager is displayed and the preview 
of the circular pattern is displayed with an arrow at the center.

2.	 Move the circular pattern cursor to the control point that is available at the end of the arrow 
head indicating the center point of the pattern. Press and hold the left mouse button at 
the control point and drag it to the center of the 100 mm diameter circle. Release the left 
mouse button when an orange circle is displayed at the center point of the circle.

3.	 Set 6 in the Number of Instances spinner. 

4.	 Clear the Dimension angular spacing check box. 

5. 	 Select the Display instance count check box. Accept the remaining default values and 
choose the OK button to create the pattern.

    The final sketch of the model is shown in Figure 3-80. In this figure, all the relations are 
hidden for clarity.

Figure 3-79  Outer loop of the sketch Figure 3-80  Final sketch for Tutorial 3
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Saving the Sketch
1.	 Choose the Save button from the Menu Bar to invoke the Save As dialog box.

2.	 Enter the name of the document as c03_tut03 in the File name edit box and choose the 
Save button.

	 The document is saved at the location /Documents/SOLIDWORKS/c03.

3.	 Close the file by choosing File > Close from the SOLIDWORKS menus.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The __________ tool is used to create a linear pattern in the sketching environment of 
SOLIDWORKS. 

2.	 The __________ tool is used to create a circular pattern in the sketching environment of 
SOLIDWORKS.

3.	 To modify a sketched circle, select it using the __________ tool.

4.	 The __________ tool is used to invoke dynamic mirroring.

5.	 The Trim Entities tool is also used to extend the sketched entities. (T/F)
 
6.	 In the sketching environment, you can apply fillets to two parallel lines. (T/F)
 
7.	 You can apply a fillet to two nonparallel and non-intersecting entities. (T/F)

8.	 You cannot offset a single entity using the Offset Entities tool. (T/F)

9.	 You can choose Insert > Customize from the SOLIDWORKS menus to display the Customize 
dialog box. (T/F)

10.	The design intent is not captured in the sketch created using the mirror line. (T/F) 

 Review Questions 
Answer the following questions:

1.	 Which of the following PropertyManagers is displayed when you choose the Sketch Fillet 
button from the Sketch CommandManager?

		  (a) Sketch Fillet				   (b) Fillet
	 	 (c) Surface Fillet			   (d) Sketching Fillet
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2.	 Which of the following PropertyManagers is displayed on the left of the drawing area when 
you choose Tools > Sketch Tools > Chamfer from the SOLIDWORKS menus?

		  (a) Sketch Chamfer			   (b) Sketcher Chamfer
	 	 (c) Sketching Chamfer			   (d) Chamfer

3.	 Which of the following tools is used to create an automatic mirror line?

		  (a) Dynamic Mirror Entities		  (b) Mirror 
		  (c) Automatic Mirror			   (d) None of these

4.	 Which of the following tools is used to break a sketched entity into two or more entities?

		  (a) Split Entities			   (b) Trim Sketch
	 	 (c) Break Curve				   (d) Trim Curve

5.	 Which of the following tools is used to create a circular pattern in SOLIDWORKS?

		  (a) Pattern				    (b) Circular Sketch Pattern
		  (c) Array				    (d) None of these	

6.	 You cannot trim a sketched entity using the Trim Entities tool. (T/F)

7.	 The preview of an entity to be extended is displayed in red. (T/F)

8.	 There are four types of slot tools available in SOLIDWORKS. (T/F)

9.	 The sketched entities can be mirrored without using a centerline. (T/F)

10.	 The Add angle dimension between axes check box in the Linear Pattern PropertyManager 
is used to display the angular dimension between the two directions of a pattern. (T/F)
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EXERCISES
Exercise 1

Create the sketch of the model shown in Figure 3-81. The sketch of the model is shown in 
Figure 3-82. The solid model and dimensions are given for reference only.
								                          (Expected time: 30 min)

Figure 3-81  Solid model for Exercise 1 Figure 3-82  Sketch for Exercise 1

Exercise 2
Create the sketch of the model shown in Figure 3-83. The sketch of the model is shown in 
Figure 3-84. This model is created using a revolved feature. Therefore, you will create the sketch 
on one side of the centerline. The solid model and dimensions are given for reference only.	
					                                                                   (Expected time: 30 min)

Figure 3-83  Solid model for Exercise 2 Figure 3-84  Sketch for Exercise 2
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Exercise 3
Create the sketch of the model shown in Figure 3-85. The sketch of the model is shown in 
Figure 3-86. The solid model and its dimensions are given only for reference. Create the sketch 
on one side and then mirror it on the other side. Make sure you do not use the Dynamic Mirror 
tool to draw this sketch. This is because if you draw the sketch using this tool, some relations are 
applied to the sketch. These relations interfere while creating fillets.     	    			 
					                                                                (Expected time: 30 min)

Figure 3-85  Solid model for Exercise 3 Figure 3-86  Sketch for Exercise 3

Exercise 4
Create the sketch of the model shown in Figure 3-87. The sketch of the model is shown 
in Figure 3-88. The solid model and dimensions are given only for reference. Create the 
sketch using the sketching tools and then edit the sketch using the Circular Pattern and 
Trim tools. 							             (Expected time: 30 min)
 

Figure 3-87  Solid model for Exercise 4 Figure 3-88  Sketch for Exercise 4
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Exercise 5
Create the sketch of the model shown in Figure 3-89. The sketch of the model is shown in 
Figure 3-90. The solid model and dimensions are given only for reference. Create the sketch 
using the Offset Entities tool. Make sure that the Reverse check box is selected.	    		
    		                                                                                                   (Expected time: 30 min)	

Figure 3-89  Solid model for Exercise 5 Figure 3-90  Sketch for Exercise 5

Exercise 6
Draw the sketch of the model shown in Figure 3-91. The sketch to be drawn is shown in 
Figure 3-92. Do not dimension the sketch. The solid model and its dimensions are given for 
your reference only.						             (Expected time: 30 min)

Figure 3-91  Solid model for Exercise 6 Figure 3-92  Sketch for Exercise 6

Answers to Self-Evaluation Test
1. Linear Sketch Pattern, 2. Circular Sketch Pattern, 3. Select, 4. Dynamic Mirror Entities, 
5. T, 6. F, 7. T, 8. F, 9. F, 10. F


