
Chapter 12

Working With Drawing
Views-I

After completing this chapter you will be able to:
• Generate standard three views.
• Generate Named Views.
• Generate Relative Views.
• Generate Predefined Views.
• Generate Empty Views.
• Generate Projected Views.
• Generate Section Views.
• Generate Aligned Section Views.
• Generate Broken-out Section Views.
• Generate Auxiliary Views.
• Generate Detail Views.
• Generate Crop Views.
• Generate Broken Views.
• Generate Alternate Position Views.
• Generate the View of an Assembly in Exploded State.
• Work with Interactive Drafting.
• Edit the Drawing Views.
• Change the Scale of the Drawing Views.
• Delete Drawing Views
• Modify the Hatch Pattern of the Section Views.
• Apply Hatch Patterns to the Section Views.

Learning Objectives
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THE DRAWING MODE
After you have created the solid models of the parts, or an assembly, you will have to generate the
drawing views. A 2D drawing is the life line of all the manufacturing systems because at the shop
floor or machine floor, the machinist mostly needs the 2D drawing for manufacturing. Therefore,
SolidWorks has provided a specialized environment known as the Drawing mode. The Drawing
mode has all the tools that are required to generate the drawing views, modify the drawing views,
and add dimensions and annotations to the drawing views. In other words, you can get the final
shop floor drawing using this mode of SolidWorks. You can also create the 2D drawings in the
Drawing mode of SolidWorks using the sketching tools provided in this mode. In other words,
there are two types of drafting methods available in SolidWorks: Generative drafting and Interactive
drafting. Generative drafting is a technique of generating the drawing views using a solid model
or an assembly. Interactive drafting is a technique in which you use the sketching tools to sketch
a drawing view in the Drawing mode. In this chapter, you will learn about generating the drawing
views of parts or assemblies. One of the major advantage of working in SolidWorks is that this
software is bidirectionally associative in nature. This property ensures that if the modifications
are made in a model in the Part mode, the same modification will be reflected in the Assembly
mode and the Drawing mode, and vice versa.

For creating a new document in the Drawing mode, invoke the New SolidWorks Document
dialog box. Choose the Drawing template from the Templates tab as shown in Figure 12-1
and choose the OK button.

Figure 12-1  The New SolidWorks Document dialog box

Tip. When you select the Drawing template from the Templates tab, the Create
RapidDraft Drawing check box is displayed at the lower right corner of the
dialog box. You will learn more about rapid draft drawings later.
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When you choose the OK button from the New SolidWorks Document dialog box, a new
Drawing document is invoked. The Sheet Format To Use dialog box is also displayed.
Figure 12-2 shows the initial screen of the drawing document with the Sheet Format to Use
dialog box.

The Sheet Format To Use dialog box is used to specify the sheet and the format of sheet to be
used. The options available in the this dialog box are discussed next.

Standard sheet format
The Standard sheet format radio button is selected by default. Using this option you can
select the predefined standard sheet formats available in SolidWorks. You can select the sheet
size from the drop-down list available below the Standard sheet format radio button.

Custom sheet format
The Custom sheet format radio button is used to add a user-defined sheet format to the
drawing sheet. Select the Custom sheet format radio button and choose the Browse button
to invoke the Open dialog box. From the Open dialog box, you can select and open a

Figure 12-2  The initial screen of the drawing document with the Sheet Format To Use dialog box

c12-solidworks-2003.p65 5/12/2003, 8:23 AM3



12-4 SolidWorks for Designers

user-defined sheet format. You will learn more about creating a user-defined sheet format in
later chapters.

No sheet format
The No sheet format radio button is selected if you want to use an empty sheet, without any
margin lines or title block. Select this radio button and select the size of sheet from the
drop-down list available below the No sheet format radio button and choose the OK button.

Figure 12-3 shows a drawing document created using A4 standard sheet format from the
drop-down list available below the Standard sheet format radio button.

Figure 12-3  Drawing document with A4 standard sheet format

Tip. If you choose the Cancel button from the Sheet Format To Use dialog box, a
blank sheet of B size in landscape orientation will be inserted in the drawing
document.
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TYPE OF VIEWS
In SolidWorks, you can generate nine types of views. Generally, you first need to generate a
standard view such as the top view or the front view and then use this view to derive the
remaining views. After generating a standard view, you can generate or derive the following
views from the standard view(s).

Projected View
The projected view is generated by taking an existing view as the parent view. This view is
generated by projecting the lines normal to the parent view. The resultant view will be an
orthographic view.

Section View
A section view is generated by chopping a part of an existing view using a plane and then
viewing the parent view from a direction normal to the section plane.

Aligned Section View
An aligned section view is used to section those features that are created at a certain angle to
the main section planes. Align sections straighten these features by revolving them about an
axis that is normal to the view plane. Remember that the axis about which the feature is
straightened should lie on the cutting planes.

Auxiliary View
An auxiliary view is generated by projecting the lines normal to a specified edge of an existing
view.

Detail View
A detail view is used to display the details of a portion of an existing view. You can select the
portion whose detailing has to be shown in the parent view. The portion that you have selected
will be magnified and will be placed as a separate view. You can control the magnification of
the detail view.

Broken View
A broken view is used to display a component by removing a portion of it from between,
keeping the ends of the drawing view intact. This type of view is used to display the components
whose length to width ratio is very high. This means that either the length is very large as
compared to the width or the width is very large as compared to the length. The broken view
will break the view along the horizontal or vertical direction such that the
drawing view fits the area you require.

Broken-out Section
A broken-out section view is used to remove a part of the existing view and display the area of
the model or the assembly that lies behind the removed portion. This type of view is generated
using a closed sketch that is associated with the parent view.
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Crop View
A crop view is used to crop an existing view enclosed in a closed sketch associated to that view.
The portion of the view that lies inside the associated sketch is retained and the remaining
portion is removed.

Alternate Position View
The alternate position view is used to create a view in which you can show the maximum and
minimum range of motion of the assembly. The main position is displayed in the drawing
view in continuous lines and the alternate position of the assembly is shown in the same view
in dashed lines (phantom lines).

GENERATING THE DRAWING VIEWS
The methods of generating various types of drawing views are discussed next.

Generating the Standard Drawing Views
The various options of generating the standard views are discussed next.

Generating the Three Standard Views

Using the Standard 3 View option, you can generate three default orthographic views
of the part or the assembly. For creating the three standard views, choose the Standard
3 View button from the Drawing toolbar or choose Insert > Drawing View > Standard

3 View from the menu bar. The Standard View PropertyManager will be displayed as shown
in Figure 12-4 and the select cursor is replaced by the part selection cursor. The Message
rollout available in the Standard View PropertyManager lists the various options that you
can use to select the model whose views are to be generated. The various options of selecting
the model whose views are to be generated are discussed next.

From File
After invoking the Standard View PropertyManager, right-click in the drawing area to
invoke the shortcut menu. Choose the Insert From File option from the shortcut menu.
The Open dialog box will be displayed. Browse and select the part or assembly document
to generate the drawing views and choose the Open button from the Open dialog box.
The Tangent Edge Display dialog box is displayed. Choose OK from this. You will learn
more about this dialog box later. The three standard orthographic views of the selected
models are generated.

Selecting the model from the graphics area of another window
To select the model for generating the three drawing views using this option, you first
need to open the part document from which you need to generate the views. Choose
Window > Tile Horizontally/Tile Vertically to tile the part and the drawing documents.
If the drawing document is not active, select the title bar of the drawing window once
to activate it. Now, choose the Standard 3 View button from the Drawing toolbar, and

Toolbar: Drawing > Standard 3 View
Menu: Insert > Drawing View > Standard 3 View
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Figure 12-4  The Standard View PropertyManager

move the cursor in the drawing area of the part document and pick a point. Choose OK
from the Tangent Edge Display dialog box that is displayed. The three standard views of
the selected model are generated in the drawing document. You can also generate the
three standard views of an assembly using the same procedure.

Selecting the model from the FeatureManager Design Tree of another window
Open the part document whose drawing views are to be generated and tile the window
horizontally or vertically. Now, choose the Standard 3 View button from the Drawing
toolbar, and move the cursor to the FeatureManager Design Tree of the part window.
Select the name of the part displayed on the top of the FeatureManager Design Tree and
choose OK from the Tangent Edge Display dialog box. The three standard orthographic
views are generated in the drawing document.

Selecting a view containing the model
This option is used only if another view is generated on the drawing view. If one view is
available in the drawing view, choose the Standard 3 View button from the Drawing
toolbar and select the view from the drawing area. The three standard orthographic views
will be generated in the drawing document.

Figure 12-5 shows the three standard views of a model created using the Standard 3 View
tool.
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Figure 12-5  Three standard views created using the Standard 3 View tool

Tip. If the generated view overlaps the title block, you need to move it. To move a
view, move the cursor over it. The bounding box of the view is displayed in gray
color. At this point, left-click to select the view. Now, move the cursor to the boundary
of the selected view; the cursor is replaced by the move cursor. Press and hold down
the left mouse button and drag the cursor to move the view. Remember that if you
move the front view, all the views are moved.

If the bounding box of the view appears in red dashed lines, you need to set the
dynamic view activation option from the System Options dialog box. Choose Tools
> Options from the menu bar to display the System Options - General dialog
box. Select the Drawing option to display the settings related to the Drawing
mode. Select the Dynamic drawing view activation check box.

Note
You will observe that the name of the part document whose drawing views are generated is
displayed in the DWG NO. text box of the title block. The size of the sheet is also displayed at the
lower right corner of the title block. You will also learn to generate all the information like draw
by, check by, and so on as you generate the drawing views later.
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Generating the Standard View Using the Named View Tool

The Named View tool is used to create a standard view, such as front, right, top,
bottom, isometric, and so on. The type of view is defined while placing the view in the
drawing document. To create a named view, open the part or assembly document and

drawing document and tile the windows horizontally or vertically. Choose the Named View
button from the Drawing toolbar or choose Insert > Drawing View > Named View from the
menu bar. The Named View PropertyManager is invoked, which lists the various methods of

Figure 12-6  Standard views generated in third angle projection

Toolbar: Drawing > Named View
Menu: Insert > Drawing View > Named View

Tip. By default, the views in the drawing document of SolidWorks are generated
using the First Angle projection. If you need to create the views in the Third
Angle projection, then before generating the views select Sheet 1 from the
FeatureManager Design Tree and invoke the shortcut menu. Choose the
Properties option; the Sheet Setup dialog box is displayed. Select the Third
angle radio button from the Type of projection area and choose OK. You will
learn more about the other options available in the Sheet Setup dialog box later.
Figure 12-6 shows the standard orthographic views in the Third Angle projection.
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Figure 12-7  The Named PropertyManager

selecting the part, and the select cursor is replaced by the part selection cursor. Select the part
or the assembly from the document window. Select the Maximize button from the drawing
document to maximize the drawing document. The cursor is replaced by the place view
cursor. The View Orientation and the Custom Scale rollouts are displayed in the Named
View PropertyManager as shown in Figure 12-7.

By default, the Isometric option is selected in the View Orientation area. Therefore, if you
place the view in the drawing document, the isometric view will be generated. If you need the
front view of the model, select the Front option from View Orientation area and place the
view in the drawing view. The other options available in this PropertyManager will be discussed
later.

Tip. If you suppress the features of a model whose drawing views are generated, the
suppressed features will not be displayed in the drawing views. As you unsuppress
the feature, it will be displayed in the drawing views.

When you hide or suppress the components of an assembly, the hidden or suppressed
components are not displayed in the drawing views.
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Note
If you select the Preview button available in the View Orientation rollout, the preview of the
view to be placed will be displayed in the drawing area.

If you choose the Current Model View option from the View Orientation area, the view of the
current orientation of the model in the part document will be placed in the drawing document.
When you place the view using the Current Model View option, the SolidWorks dialog box
will be displayed. This dialog box prompts you that this view may need Isometric (True) dimensions
instead of standard Projected dimensions. Do you want to switch the view to use Isometric
dimensions? It is always recommended to use isometric dimensions in a 3D view. You will learn
more about dimensions in the later chapters.

Generating the Standard View Using the Relative View Tool

The Relative View tool is used to generate an orthographic view. The orientation of
the view is defined by selecting the reference planes or the planar faces of the model.
This option is very useful if you need the orientation of the parent view other than

the default orientations. To create a relative view open the documents and tile them
vertically or horizontally. Choose the Relative button from the Drawing toolbar or choose
Insert > Drawing View > Relative To Model from the menu bar. If the Relative button
is not available in the Drawing toolbar, you need to customize the toolbar. The Relative
View PropertyManager is displayed, which prompts you to select the model.

Select the model or the assembly using the face that you want to use to orient the resultant
view. The Drawing View Orientation dialog box is displayed as shown in Figure 12-8.

Now from the drop-down list in this dialog box select the option toward which the selected
face will be oriented. Choose the OK button. Next, select another face and then select the
option toward which the second selected face will be oriented. Move the cursor in the
drawing document; the cursor will be replaced by the place view cursor. The preview of
the view of is also displayed in the drawing document. Place the view at an appropriate
place in the drawing document.

Figure 12-9 shows the faces of the model selected to generate a standard view and
Figure 12-10 shows the resultant view.

Toolbar: Drawing > Relative View (Customize to Add)
Menu: Insert > Drawing View > Relative To Model

Figure 12-8  The Drawing View Orientation dialog box
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Figure 12-9  Faces to be selected

Figure 12-10  Resultant view

Generating the Standard View Using the Predefined View Tool

The Predefined View tool is used to create empty views with the specified orientation.
After creating all the predefined views, populate them by dragging the part from the
other window. All the predefined views will be populated. This option is basically

used to add the empty views in the drawing document and then save it as a drawing template.
Next time when you open a new drawing document using that template, you just need to drag
and drop the part from other window; all the predefined views will be populated. You will

Toolbar: Drawing > Predefined View
Menu: Insert > Drawing View > Predefined
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Figure 12-11  The Predefined View PropertyManager

learn more about creating a drawing template in the later chapters. To create the predefined
views, choose the Predefined View button from the Drawing toolbar or choose Insert >
Drawing > Predefined from the menu bar. An empty view is attached to the cursor. Specify a
point in the drawing document to place the predefined view. The view will be placed in the
drawing document and the Predefined View PropertyManager is displayed as shown in
Figure 12-11.

Select the view orientation from the View Orientation area of the View Orientation rollout
and choose the OK button from the Predefined View PropertyManager. To add the next
predefined view, you need to define the alignment option while placing the view. To create
additional predefined view, invoke the Predefined View tool and place the view in the drawing
sheet. The bounding box of the view is displayed. Right-click inside the bounding box and
choose Alignment > Align Horizontal by Center/Align Vertical by Center. Now select the
previous predefined view to align the corresponding view. Similarly, add other predefined
views using this tool.

After creating all the predefined views open a part or an assembly document and tile the
documents windows horizontally or vertically. Now, drag the component from the part
document and drop in the drawing document; all the predefined views will be populated.
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Figure 12-13  Views created after populating the predefined views

Figure 12-12  Different predefined views

Tip. You can add the views of different parts and assemblies in each predefined
view. In this way, you can have the dimensions of different parts and assemblies in
a single drawing document. For adding different parts in each predefined view,
select the predefined view and choose the Browse button from the Insert Model
rollout of the Predefined View PropertyManager. The Open dialog box is
displayed and you can select the part or the assembly to be inserted in the selected
predefined view.

Figure 12-12 shows the selected predefined views with the orientation in which the views are
created. Figure 12-13 shows the drawing document after drooping the part in the drawing
document. Note that in these figures, the views are not aligned to each other.
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Note
When you generate the views in the Drawing mode of SolidWorks, the views are scaled
automatically depending upon the size of the sheet.

In case of predefined view, if the drawing contains more than one predefined view, the views will
be scaled automatically.

If only one predefined view is placed in the drawing document, the view will be scaled with
respect to the Custom Scale value if specified. Otherwise, the view will be scaled with the
default scale factor of the drawing sheet. You can change the view scale using the Sheet Setup
dialog box. You will learn more about scaling the views in later chapters.

Empty View

The Empty View tool is used to create an empty view. The empty views are used to
create the sketches in the drawing document. This option is used in interactive drafting.
Interactive drafting is discussed later in this chapter. To create an empty view, choose

the Empty View button from the Drawing toolbar or choose Insert > Drawing View >
Empty option from the menubar. If the Empty View button is not available in the Drawing
toolbar, then you need to customize the toolbar. An empty view is attached to the cursor.
Select a point at the desired location in the drawing document to place an empty view.

Generating the Derived Views
All the views that are generated from a view already placed in the drawing document are
known as derived views. The various types of derived views that are generated from the standard
views are

1. Projected view
2. Section view
3. Aligned Section view
4. Broken-out Section view
5. Auxiliary view
6. Detail view
7. Crop view
8. Broken view
9. Alternate Position view

The methods of generating the various derived drawing views are discussed next.

Toolbar: Drawing > Empty View (Customize to Add)
Menu: Insert > Drawing View > Empty
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Generating Projected Views

As mentioned earlier, the projected views are generated by projecting the normal
lines from an existing view. To generate a projected view, choose the Projected View
button from the Drawing toolbar or choose Insert > Drawing View > Projected

from the menu bar. The Projected View PropertyManager is displayed and it prompts you to
select a drawing view from which you need to project the normal lines. The select cursor is
replaced by the view cursor. Select the parent view and move the cursor vertically to generate
a top view or a bottom view or move the cursor toward the left or right to create a right view
or left view. Specify a point on the drawing sheet to place the view. For creating more than one
projected view, choose the Keep Visible button to pin the Projected View PropertyManager.
Figure 12-14 shows the front view generated from the top view.

Toolbar: Drawing > Projected View
Menu: Insert > Drawing View > Projected

Figure 12-14  Front view generated from the top view

Tip. When you generate a projected drawing view, the drawing view is aligned to
the parent view. To place the projected view that is not in alignment with the parent
view, press and hold down the CTRL key before placing the view. Now move the
cursor to the desired location and place the view.

All the standard views and derived views that include projected views, section
view, detailed view, and so on are linked to their parent view by a Parent-Child
relationship. If you select the child view, the boundaries of the parent view will be
displayed in yellow.

Select the child view and invoke the shortcut menu and choose the Jump to Parent
View option from the shortcut menu. The parent view will be selected automatically.
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Toolbar: Drawing > Section View
Menu: Insert > Drawing View > Section

Generating Section Views

As mentioned earlier, section views are generated by chopping a portion of an existing
view using a cutting plane and then viewing the parent view from the direction normal
to the cutting plane. To create a section view, you first need to activate the view in

which you need to create the section line or cutting plane. To invoke the drawing view, move
the cursor to the drawing view. The view symbol will be displayed below the cursor and the
bounding box of the view is displayed. Left-click to activate the drawing view. Now, choose the
Section View button from the Drawing toolbar or choose Insert > Drawing > Section from
the menu bar. The Section View PropertyManager is displayed and it prompts you to sketch
a line to continue view creation. You can zoom using the Zoom tool to increase the display
area of the activated view. Draw a line that will define the section plane. As soon as you specify
the endpoint of the section line the Section View PropertyManager is displayed. The section
view is also displayed in the drawing area and the name of the section view is displayed on the
section line. Move the cursor and specify a point on the  drawing sheet to place the section
view. The name and the scale factor of the drawing view is displayed below the section view.
The Section View PropertyManager is still available in the drawing document as shown in
Figure 12-15.

You can use the Flip direction check box to flip the direction of the section view. The view will
be automatically modified in the drawing sheet. The Scale with model check box is used to

Figure 12-15  The Section View PropertyManager
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Figure 12-16  The section view

scale the drawing view if the model is scaled in the part document. You will learn more about
scaling the model in the later chapters. Choose OK from the Section View PropertyManager.
Figure 12-16 shows the top view and the section view of a model.

To create a half section view, make the section lines extended beyond the parent view, see
Figure 12-17.

Figure 12-17  The half section view
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Note
You will observe that by default the spacing of the hatch is not what is required. Therefore, you
may need to increase the spacing of the hatch pattern. You will learn more about editing the
hatch pattern later in this chapters.

There are some other options available in the Section View PropertyManager using which
you can create partial section view and the surface section view. The options are discussed next

Creating the Partial Section View
If the section line does not cut through the model, the SolidWorks information box will
be displayed. This dialog box prompts you that the section line does not completely cut
through the bounding box of the model in this view. Do you want this to be a partial
section cut? For creating the partial section view, choose the Yes button from this dialog
box. If you choose the No button from this dialog box, then the complete section view
will be created. Figure 12-18 shows a partial section view generated from the top view.

Creating the Surface Section View
A surface section view is the one in which only the sectioned surface is displayed in the
section view. All the other edges or faces are not displayed in the surface section view. For
creating a surface section view first you need to create the section view and then choose
the Display only surface check box from the Section View PropertyManager. Choose
the OK button from the PropertyManager. You can also replace the section view by a

Tip. When you create a section view and move the cursor to place the section view,
you will observe that the view is aligned to direction of arrows on the section line.
If you need to remove this alignment to place the section view, press and hold down
the CTRL key and move the view to the desired location. Select a point in the
drawing sheet to place the view.

Figure 12-18  A partial section view
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Figure 12-19  A surface section view

surface section view by selecting the view to invoke the Section View PropertyManager.
Select the Display only surface check box from the Section View PropertyManager.
Figure 12-19 shows a surface section view.

Generating the Section View of an Assembly
According to the drawing standards when you create the section view of an assembly, some
components such as fasteners, shafts, keys, and so on should not be sectioned. Therefore,
when you create the section view of an assembly, the Section View dialog box is displayed as
shown in Figure 12-20. Select the components that should not be sectioned from the parent
view. You can also select the component by invoking the FeatureManager Design Tree flyout
and expanding the parent drawing view. Then expand the assembly to display all the
components of the assembly. The name of the selected component is displayed in the Excluded
components display area. The Auto hatching check box is used to automatically define the
hatch patterns. You can even change the hatch pattern. Applying the hatch pattern and
changing the hatch pattern is discussed later.

If you have more than one instance of the component in the assembly, and you need to
exclude all the instances of the components from the section view, select the component from
the drawing sheet and select the name of the component from the Exclude components
display area. Click two times the Don’t cut all instances check box from the Section Scope
tab. All the instances of the selected component will be excluded from the section
view, see Figure 12-21.
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Figure 12-20  The Section View dialog box

Figure 12-21  Section view of an assembly with some of the
components excluded from the section scope

Tip. You can add or remove the components that are sectioned by right-clicking the
drawing view and choosing Properties from the shortcut menu. Now, choose the
Section Scope tab and add or remove the components.
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Figure 12-22  Aligned section view

Toolbar: Drawing > Aligned View (Customize to Add)
Menu: Insert > Drawing View > Aligned Section

Generating Aligned Section Views

This tool is used to generate a section view of the component in which at least one of
the feature is at an angle. In the aligned section view, the section portion revolves
about an axis normal to the viewing plane such that it is straightened. For example,

refer to Figure 12-22. This figure explains the concept of an aligned section view of a model.
Notice that the inclined feature that is sectioned in this view is straightened. As a result, the
section view is longer than the parent view. To create the aligned section view, activate the
view. Choose the Aligned Section button from the Drawing toolbar or choose Insert > Drawing
View > Aligned Section from the menu bar. Draw the sketch that defines the section line.
The aligned section view will be attached to the cursor; place the view at an appropriate
location in the drawing sheet. Note that the resultant view will be projected normal to the line
that is drawn in the end in the section sketch. Therefore, to get the aligned section view
similar to that shown in Figure 12-22, the inclined line in the section sketch should be drawn
first than the vertical line. Figure 12-23a shows the aligned section view in which the vertical
line in the section sketch is drawn first. This is the reason the section view is projected normal
to the inclined line that is drawn last. On the other hand, Figure 12-23b shows the views in
which the inclined line is drawn first.
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Note
You can also create a sketch associated to a view. This sketch can be selected as the section plane
for generating the section view. To create an associated sketch, active the view and draw the
sketch that defines the section plane using the Line tool.

If you create a sketch to define the section plane for the aligned section view before invoking the
Aligned Section View tool, the view will be projected normal to the line that you select last.
However, if you select the sketch to define section plane by dragging a window around it, the
view will be projected normal to the line that was drawn last.

Generating Broken-out Section Views

This tool is used to create a broken-out section view. A broken-out section view is used
to remove a part of the existing view and display the area of the model or the assembly
behind the removed portion. This type of view is generated using a closed sketch that

is associated with the parent view. To create a broken-out section view, activate the view on
which you need to create the broken out section view. Choose the Broken-out Section button
from the Drawing toolbar or choose Insert > Drawing View > Broken-out Section from the
menu bar. The Broken-out Section PropertyManager is displayed and it prompts you to
create the closed spline to continue section creation. The cursor will be replaced by the
spline cursor. Create a closed sketch using the spline cursor. If you do not want a spline
profile, select a closed profile before choosing the Broken-out Section button. Figure 12-24
shows an associated sketch created for creating a broken-out section view.

When you create a closed sketch, some options are displayed in the Broken-out Section
PropertyManager as shown in Figure 12-25 and it prompts you to specify the depth of the
broken-out section. Choose the Preview check box to preview the broken-out section view.

Figure 12-23a  Aligned section view Figure 12-23b  Aligned section view

Toolbar: Drawing > Broken-out Section
Menu: Insert > Drawing View > Broken-out Section
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The Auto hatching check box is used to define the hatch pattern automatically to the
section drawing view of the assembly. If you are creating the broken-out section view of a part,
then the Auto hatching check is not available in the Broken-out Section PropertyManager.
Figure 12-26 shows the preview of the broken-out section view.

Figure 12-24  Sketch for creating the broken-out section view

Figure 12-25  The Broken-out Section PropertyManager
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Set the value of the depth of the broken-out section in the Depth spinner. The preview of the
section will be modified dynamically in the drawing view. After setting the value of the depth
of the broken-out section, choose the OK button from the Broken-out Section
PropertyManager. Figure 12-27 shows a broken-out section view.

Figure 12-27  Broken-out section view

Figure 12-26  Preview of the broken-out section view
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Figure 12-28  The Auxiliary View PropertyManager

Generating Auxiliary Views

This tool is used to generate an auxiliary view. An auxiliary view is a drawing view that
is generated by projecting the lines normal to a specified edge of an existing view. To
create an auxiliary view, choose the Auxiliary View button from the Drawing toolbar

or choose Insert > Drawing View > Auxiliary from the menu bar. The Auxiliary View
PropertyManager is displayed and it prompts you to select a reference edge to continue.
Select the edge that will be the reference to generate the auxiliary view. A view will be attached
to the cursor and some options are displayed in the Auxiliary View PropertyManager as
shown in Figure 12-28. Now, the Auxiliary PropertyManager prompts you to select a location
of new view. Select a point on the drawing sheet to place the auxiliary view.

The Display View Arrow check box available in the Display View Arrow rollout is used to
display the arrow of the viewing plane in the drawing views. The name of the auxiliary view is
specified in the Label edit box. Using the Flip Direction check box you can flip the viewing
direction for creating the auxiliary view. Figure 12-29 shows the reference edge to be selected
to create the auxiliary view. Figure 12-30 shows the auxiliary view created with the default
viewing direction. Figure 12-31 shows the auxiliary view created with the Flip Direction check
box selected.

Note
You can also create a sketch using the sketch tools available in the Sketch Tools toolbar to select
as a reference edge for generating the auxiliary view.

Toolbar: Drawing > Auxiliary View
Menu: Insert > Drawing View > Auxiliary
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Figure 12-29  Reference edge to be selected to create the auxiliary view

Figure 12-30 Auxiliary view created with the
Flip Direction check box cleared

Figure 12-31 Auxiliary view created with the
Flip Direction check box selected

Generating Detail Views

This tool is used to generate the detail view. A detail view is used to display the details
of a portion of an existing view. You can select the portion whose detailing has to be
shown in the parent view. The portion that you select will be magnified and placed as

a separate view. You can control the magnification of the detail view. To create a detail view,
you first need to activate the view from which you will generate the detail view. Choose the
Detail View button from the Drawing toolbar or choose Insert > Drawing View > Detail

Toolbar: Drawing > Detail View
Menu: Insert > Drawing View > Detail
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Figure 12-32  The Detail View PropertyManager

from the menu bar. The Detail View PropertyManager is displayed and it prompts you to
sketch a circle to continue view creation. The cursor is replaced by a circle cursor. Create the
circle on the portion of the view that is to be displayed in the detail view.

As soon as you draw the circle, the detail view is attached to the cursor and some options are
displayed in the Detail View PropertyManager as shown in Figure 12-32. You are also prompted
to select a location for the new view. Specify a point on the drawing sheet to place the view.
The options available in the Detail View PropertyManager are discussed next.

Tip. You can also create closed profile other than circle for creating the detail view.
For this you need to create the closed profile in the current active view before invoking
the Detail View cursor. After creating the closed profile, select the profile and
invoke the Detail View tool.

c12-solidworks-2003.p65 5/12/2003, 8:23 AM28



Working With Drawing Views-I       12-29

Circle Options
The Circle Options rollout is used to define the options to display the circle of the detail
view. Using the options available in the rollout, you can also apply the leader to the detail
view. The options available in this rollout are discussed next.

Style
The Style area has the Style drop-down list to specify the style of the closed profile.
By default, the Circle radio button is selected below the Style drop-down list.
Therefore, the portion of the parent view that is shown in the detail view is highlighted
in circle. If you have created a closed profile for defining the portion to be shown in
the detail view, select the Profile radio button. The options available in the Style
drop-down list are discussed next.

Per Standard. The Per Standard option is used to create the detail view as per
default standards.

Broken Circle. The Broken Circle option is used to display the area of the parent
view to be displayed in the detailed view in a broken circle.

With Leader. The With Leader option is used to add the leader to the callout of
the detail view.

No Leader. The No Leader option is used to remove the leader from the callout
of the detail view.

Connected. This option is used to create a line that connects the detail view with
the closed profile in the parent view.

View Options
The View Options rollout is used to set the parameters of the detail view. The various
options available in this rollout are discussed next.

Full outline
The Full outline check box is used to display the complete outline of the closed
profile in the detail view.

Pin position
The Pin position check box is used to pin the position of the detail view.

Scale hatch pattern
The Scale hatch pattern check box is used to scale the hatch pattern with respect to
the scale factor of the detail view when you create a detail view of a section view.

Figure 12-33 shows the detail view created using the Detail View tool.
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Figure 12-33  Detail views

Toolbar: Drawing > Crop View (Customize to Add)

Tip. When you create a detail view, by default the detail view is scaled as 1:1. You
can define the scale factor in the System Options dialog box so that whenever you
create a detail view, it will be created with the scaling factor provided by you. To
specify the scale factor for the detail view, invoke the System Options dialog box
and select the Drawings option from the left of this dialog box. Set the value of the
scale factor of the detail view in the Detail View Scaling edit box and choose the
OK button. Hence forth, the detail view will be created of the scale factor defined in
the System Options dialog box.

If you need to scale a detail view in the current drawing sheet, select the view and
select the Custom Scale check box. Specify the scale factor in the Custom Scale
rollout and choose the OK button from the Detail View PropertyManager. The
scaling of other views is discussed later in this chapter.

Cropping Drawing Views

This tool is used to crop an existing view using a closed sketch associated to that view.
The portion of the view that lies inside the associated sketch is retained and the
remaining portion is removed. To crop the view, you first need to create a closed

profile associated to the view that defines the area of the view that will be displayed. The area
of the view outside this closed profile will not be displayed when you crop the view. Select the
closed profile and choose the Crop View (Customize to Add) button from the Drawing toolbar.
Figure 12-34 shows the closed profile used to crop the view. Figure 12-35 shows a crop view.
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Broken View
A broken view is used to display a component by removing a portion of it from between,
keeping the ends of the drawing view intact. This type of view is used for displaying the
components whose length to width ratio is very high. This means that either the length is very
large as compared to the width or the width is very large as compared to the length. The
broken view will break the view along the horizontal or vertical direction such that the drawing
view fits the area you require. To create a broken view, you first need to define the break line.
Select the view you need to break and choose Insert > Horizontal Break/Vertical Break
depending on the direction in which you need to break the component. Two break lines will
be displayed on the selected view as shown in Figure 12-36.

After adding the break lines, you need to move the break lines to define the gap in the broken
view. Select the break lines and move them away from each other as shown in Figure 12-37.
Now, select the view and invoke the shortcut menu. Choose the Break View option from the
shortcut menu. The broken view will be created as shown in Figure 12-38.

Tip.  You can remove the cropping of view by selecting the crop view and invoking
the shortcut menu. Choose Crop View > Remove Crop from the shortcut menu.
The initial view will be displayed in the drawing sheet.

If you need to edit the closed profile of the crop view, select the crop view and invoke
the shortcut menu. Choose Crop View > Edit Crop from the shortcut menu. The
sketch of the closed profile and the complete view is displayed in the drawing sheet.
Edit the closed profile and choose the Rebuild button from the Standard toolbar
or use CTRL+B from the keyboard.

Figure 12-34 Closed profile to crop the view Figure 12-35 Resultant crop view
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Figure 12-37 Extended gap between break lines Figure 12-38 Resultant broken view

Note
Select the break line to increase or decrease the gap between the broken view. As you move the
break line, the broken view is modified dynamically.

If you generate a projected view from a broken view, the resultant projected view is also a broken
view.

You can also break an isometric view; the procedure of breaking an isometric view or any 3D
view is the same as discussed earlier. Figure 12-39 shows a broken isometric view.

If you break a 3D view placed horizontally, the two parts of the view as a result of the Broken
View tool will lose their alignment.

Figure 12-36  Break lines added to the view
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Alternate Position View

The alternate position view is used to create a view in which you can show the maximum
and minimum range of motion of an assembly. The main position is displayed with
continuous lines in the drawing view and the alternate position of the assembly is

shown in the same view with dashed (phantom) lines. To create an alternate position view,
first you need to activate and select the view of the assembly drawing on which you need to
create the alternate position view. Choose the Alternate Position View (Customize to Add)
button from the Drawing toolbar or choose Insert > Drawing View > Alternate Position
from the menu bar. The Alternate Position PropertyManager is displayed as shown in
Figure 12-40.

Tip. You can change the style of the break line by selecting the break line and
invoking the shortcut menu. The various break line styles available are straight
cut, curve cut, zig zag cut, and small zig zag cut.

To unbreak the broken view, select the view and invoke the shortcut menu. Choose
the Un-Break View option from the shortcut menu.

Select the view and invoke the shortcut menu. Choose the Break View option to
again break the view.

If you select the break lines and press the DELETE key from the keyboard, the
broken view will be replaced by the parent view.

Figure 12-39  A broken isometric view

Toolbar: Drawing > Alternate Position View (Customize to Add)

Menu: Insert > Drawing View > Alternate Position
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Figure 12-40  The Alternate Position PropertyManager

The Alternate Position PropertyManager prompts you to select New configuration, click OK
or Enter and define the new configuration parameters. Or Select Existing configuration and
click OK or Enter. But you have not created any configurations yet. Therefore, the New
Configuration radio button is automatically selected to create a new configuration. Enter the
name of the configuration in the edit box given below. Choose the OK button from the
Alternate Position PropertyManager to create a new configuration. Choose OK from the
Tangent Edge Display dialog box

The assembly document is invoked and the Move Component PropertyManager is displayed
in the assembly document. The Move Component PropertyManager prompts you to move
the desired components to the position to be shown in the alternate view. Note that the
component or components that you need to move to show in the alternate view should have
that particular degree of freedom free to move. These components should not be fully defined
in the assembly. Select and drag the cursor to move the components to the desired location.
After defining the alternate position of the components, choose the OK button from the
Move Component PropertyManager. You will return to the drawing document automatically.
The alternate position of the components that are moved will be displayed in phantom lines
in the drawing view, see Figure 12-41.

You can also create the alternate position view of an isometric view or of any 3D view. The
procedure of creating the alternate position view of a 3D view is the same as that discussed
earlier. Figure 12-42 shows the alternate position view of an isometric view.
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Note
When you create an alternate view of an assembly, a new configuration is created inside the
assembly document with the same name that is specified to the configuration while creating the
alternate position view. Open the assembly document and invoke the ConfigurationManager;
you will observe that a new configuration is created along with the default configuration. By
default, the newly created configuration is selected. Therefore, the assembly is displayed with the
component moved to their extreme positions. To switch back to the default configuration, select
Default from the ConfigurationManager and invoke the shortcut menu. Choose the Show
Configuration option from the shortcut menu. You will observe that the assembly will be displayed
with the moved components back at their original positions. If the Show Configuration option
is not available in the shortcut menu, the assembly is at the default configuration.

Figure 12-41  Alternate position view

Figure 12-42  Alternate view of an isometric view.
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Figure 12-43  Drawing view of the exploded state with explode lines

Tip. If currently the assembly in the assembly document is in the exploded state,
then if you drag and drop the assembly to generate the drawing views, all the views
of the assembly will be generated in the exploded state.

If you need to switch to the collapse state in the drawing view, select the model and
clear the Show in exploded state check box from the Drawing View Properties
dialog box.

Creating the Drawing view of the Exploded State of the Assembly
You can create the drawing view of the exploded state of the assembly. To generate the view of
the exploded state of an assembly, you need to have an exploded state defined in the assembly
document. Generate the isometric view of the assembly on the drawing sheet. Select the view
and invoke the shortcut menu. Choose the Properties option from the shortcut menu. The
View Properties tab of the Drawing View Properties dialog box is displayed. Select the Show
in exploded state check box from the Configuration information area and choose the OK
button from the Drawing View Properties dialog box. Figure 12-43 shows the drawing view
of the exploded state of assembly with explode lines.

WORKING WITH INTERACTIVE DRAFTING IN
SOLIDWORKS
As mentioned earlier, you can also sketch the 2D drawings in the drawing document of
SolidWorks. In technical terms, sketching 2D drawings is known as interactive drafting. Before
starting the drawing, it is recommended that you insert an empty view and start creating the
drawing in the empty view after activating that view. The 2D drawings are sketched using the
standard sketching tools available in the Sketch Tools toolbar.
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EDITING THE DRAWING VIEWS
In SolidWorks, you can edit the drawing views using the PropertyManager. You can also
change the orientation of the generated views using the Named Views option. To change
the orientation, select the parent view that was created using the Named View option; the
Named View PropertyManager is displayed. Double-click the view orientation that you want
to be made current from the View Orientation rollout as shown in Figure 12-44. The orientation
of the selected view will be modified. Choose the OK button from the Named View
PropertyManager. You will notice that all the views derived from the parent view will also
change their orientation when you change the orientation of the parent view.

CHANGING THE SCALE OF THE DRAWING VIEWS
In SolidWorks, you can also change the scale of the drawing views. To change the scale of the
drawing views, select the drawing view and then select the Custom Scale check box to invoke
this rollout available in the PropertyManager. The Custom Scale rollout is displayed in
Figure 12-45. Set the scale of the drawing view in the Custom Scale rollout and choose the
ENTER key. The view will be scaled using the current scale factor.

Note
When you scale a view, the view is scaled independently. This is the reason that if you scale the
parent view, the views derived from the parent view will not be scaled. You can also change the
scale factor of the derived view independent of its parent view.

DELETING THE VIEWS
The unwanted views are deleted from the drawing sheet using the FeatureManager Design
Tree or directly from the drawing sheet. Select the view to be deleted from the FeatureManager
Design Tree and invoke the shortcut menu. Choose the Delete option from the shortcut
menu as shown in Figure 12-46. The Confirm Delete dialog box will be displayed. Choose
the Yes button from this dialog box. You can also delete a view by selecting it directly from the

Figure 12-45  The Custom Scale rollout

Figure 12-44  The View Orientation rollout
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Figure 12-46  Selecting the Delete option from the
shortcut menu

drawing sheet and pressing the DELETE key from the keyboard. The Confirm Delete dialog
box is displayed; choose the Yes button from this dialog box.

Note
When you delete a parent view, the projected views are not deleted. If you delete the parent view
from which a section view or a detail view is generated, the name of the dependent view is also
displayed in the Confirm Delete dialog box. If you choose Yes, the dependent views are also
deleted.

MODIFY THE HATCH PATTERN OF THE SECTION VIEW
As discussed earlier, when you generate a section view of an assembly, a default hatch pattern
is automatically defined in the section view. If you need to modify the default hatch pattern,
select the hatch pattern from the section view and invoke the shortcut menu. Choose the
Properties option from the shortcut menu; the Area Hatch/Fill dialog box is displayed as
shown in Figure 12-47. The various options available in this dialog box are discussed next.

Tip. You can also rotate a drawing view in the 2D plane. To rotate a drawing
view, select the view and choose the Rotate View button from the View toolbar.
The Rotate Drawing View dialog box is displayed. You can enter the value or
rotation angle in this dialog box or you can also dynamically rotate the drawing
view. If you select the Dependent views update to change in orientation check
box, the views dependent on the rotated view will also change their orientation.

You can also copy and paste the drawing view in the drawing sheet. Select the view
to copy and press CTRL+C from the keyboard. Now, select any where in the drawing
sheet to select the sheet and press CTRL+V from the keyboard to paste the drawing
view.
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Figure 12-47  The Area Hatch/Fill dialog box

Preview
The Preview area is used to preview the hatch pattern with the current setting of the hatch
pattern.

Properties
The Properties area is used to define the type of hatch pattern and the properties of the
hatch pattern. The options available in this area are discussed next.

None
The None radio button is selected if you donot need to apply any hatch pattern in the section
view.

Solid
The Solid radio button is used to apply the solid filled hatch pattern to the section view. By
default, black color is applied as solid filled hatch pattern.

Hatch
The Hatch radio button is selected to apply the standard hatch patterns to the section view.
When you select this button, some options available in this dialog box are invoked to define
the properties of the hatch pattern. The options available to define the properties of the
hatch pattern are discussed next.
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Figure 12-48  Hatch patterns available in the Pattern drop-down list

Pattern
The Pattern drop-down list is used to define the style of the standard hatch pattern you
need to apply to the section view. Some of the standard hatch patterns available in this
drop-down list are shown in Figure 12-48. The preview of the hatch pattern selected from
this drop-down list is displayed in the Preview area of the Area Hatch/Fill dialog box.

Scale
The Scale spinner is used to specify the scale factor of the standard hatch pattern selected
from the Pattern drop-down list. When you change the scale factor using this spinner, the
preview displayed in the Preview area updates dynamically.

Angle
The Angle spinner is used to define the angle to the selected hatch pattern.

Apply to
The Apply to drop-down list is used to define whether you need to apply this hatch pattern to
the selected region or to the entire view. If you are editing the hatch pattern of a section view
of an assembly, then you can also specify if you need to apply the hatch pattern to the
component.

The Always show dialog on creation check box is used to invoke this dialog box when you
apply the hatch pattern  next time.
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APPLYING A HATCH PATTERN

You can also apply the hatch pattern to a 2D sketch created using interactive drafting.
To apply the hatch pattern to a closed sketch you just need to select any one entity of
the closed sketch and then choose the Area Hatch/Fill button from the Drawing

toolbar or choose Insert > Area Hatch/Fill from the menu bar. The Area Hatch/Fill dialog
box will be displayed. Set the properties of the hatch pattern in this dialog box and choose
the OK button from the Area Hatch/Fill dialog box.

You can also apply the hatch pattern to a face of the model in the drawing view. To apply the
hatch pattern to the face of the model in the drawing view, activate the drawing view and
select the face on which you need to apply the hatch pattern. Invoke the Area Hatch/Fill
dialog box to apply the hatch pattern. Figure 12-49 shows the hatch pattern applied to the
planar face of the model in the drawing view and a hatch pattern applied to a closed sketch
created in the drawing view.

Figure 12-49  Hatch pattern applied to the 2D sketch and the planar
face

Toolbar: Drawing > Area  Hatch/Fill
Menu: Insert > Area  Hatch/Fill

Tip. To change the color of the hatch or solid, select it and then choose the Line
Color button from the Line Format toolbar. Select the required color from the Edit
Line Color dialog box. It should be noted that you cannot change the color of the
hatch patterns of the generated section view.
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TUTORIALS

Tutorial 1
In this tutorial you will generate the top view, front view, right view, aligned section view,
detail view, and isometric view of the model created in the Tutorial 2 of Chapter 7. Use the
Standard A4 Landscape sheet format for generating the views.     (Expected time: 30 min)

The steps to be followed to complete this tutorial are discussed next:

a. Copy the model whose drawing views you want to generate in the current directory.
b. Create a new drawing document in the standard A4 Landscape sheet format and generate

the parent view using the named view tool, refer to Figures 11-50 and 11-51.
c. Generate the projected views using the Projected View tool, refer to Figure 11-52.
d. Generate the aligned section view using the Aligned Section View tool, refer

to Figures 11-53 through 11-56.
e. Generate the detail view and the isometric view, refer to Figure 11-57.

Copying the Model in the Current Directory
First, you need to copy the model whose drawing views are to be generated in the current
directory.

1. Create a directory with the name c12 in the SolidWorks directory and copy c07tut02.sldprt
from the /My Document/SolidWorks/c07 directory to this directory.

Opening the New Drawing Document
As mentioned earlier in the description, you need to create a new drawing document with
standard A4 sheet.

1. Create a new SolidWorks document in the drawing mode.

The Sheet Format To Use dialog box is displayed. The Standard sheet format radio
button is selected by default.

2. Choose the A4 Landscape sheet from the Standard sheet format drop-down list and
choose the OK button from the Sheet Format To Use dialog box.

The new drawing document is created with standard A4 sheet size as shown in Figure 12-50.

As discussed earlier, by default the new drawing document starts with first angle projection.
But you need to generate the drawing views in the third angle projection. Therefore, you
need to change the type of projection from first angle to third angle.

3. Select the Sheet 1 option from the FeatureManager Design Tree and invoke the shortcut
menu. Choose the Properties option from the shortcut menu.

The Sheet Setup dialog box is displayed.
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Figure 12-50  New drawing document created with A4 standard sheet format

4. Select the Third angle radio button from the Type of projection area of the Sheet Setup
dialog box and choose the OK button to exit the dialog box.

Generating the Parent View and the Projected Views
First, you will generate the parent view in the drawing sheet. After generating the base
view, you can use it to generate the other views such as the projected view, detail view,
section view, and so on. The parent view will be generated using the Named View tool.

1. Choose the Named View button from the Drawing toolbar and right-click in the
drawing sheet to invoke the shortcut menu.

2. Choose Insert From File; the Open dialog box is displayed.

3. Select c07tut01.sldprt and choose the Open button from the Open dialog box.

The cursor is replaced by the view placement cursor and the Named View
PropertyManager is displayed. The Front option is selected in the View Orientation
rollout. Therefore, if you place the view, it will generate the front view. But the parent
view that you need to generate is the top view.
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4. Select the Top option from the View Orientation rollout.

5. Move the cursor close to the upper left corner of the drawing sheet and specify a point at
this location to place the view.

6. If the Tangent Edge Display dialog box is displayed, select the Don’t ask me again check
box and choose the OK button from the Tangent Edge Display dialog box.

Figure 12-51 shows the top view generated using the Named View tool bar. This view is
generated at 1:1 scale.

Next, you need to generate the projected view from the parent view generated earlier,
which is the top view.

7. Select the parent view and choose the Projected View button from the Drawing
toolbar.

The cursor replaces the place view cursor.

8. Move the cursor below the parent view and specify a point to place the projected view.

9. Next, select the newly generated view and choose the Projected View cursor from the
Drawing toolbar.

Tip. When you generate the drawing views in SolidWorks, if there is any cylindrical
feature in the drawing view then the centermarks are automatically displayed in
the drawing view containing the cylindrical feature.

Figure 12-51  Top view generated using the Named View tool
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Figure 12-52  Projected views derived from the top view

10. Move the cursor horizontally toward the right and specify a point on the screen to place
the view. Figure 12-52 shows the views generated from the parent view using the Projected
View tool.

Generating the Aligned Section View
Next, you need to create the aligned section view. But before creating the aligned section
view, you need to create a sketch that will define the section sketch for creating the aligned
section view. Remember that the view is projected normal to the line sketched last.

1. Click on the top view to activate the view.

2. Using the Line tool draw the sketch and apply the relations and dimensions to the sketch
as shown in Figure 12-53.

3. Select the dimension and invoke the shortcut menu. Choose the Hide option from the
shortcut menu.

4. Now, select the inclined line and then the vertical line. Note that if you select
the inclined line in the end, the view is generated normal to the inclined line.
Now, choose the Aligned Section View button from the Drawing toolbar or choose
Insert > Drawing View > Aligned Section from the menu bar.

The Section View PropertyManager is displayed and you will observe that the aligned
section view will be attached to the cursor as you move the cursor on the drawing sheet.
The view generated is normal to the vertical line of the section sketch and the direction of
viewing the section creation is the reverse to the required direction. Therefore, first you
need to flip the viewing direction of section view.
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5. Select the Flip direction check box from the Line Options rollout of the Section View
PropertyManager.

6. Place the aligned section view on the drawing sheet as shown in Figure 12-54.

Modifying the Hatch Pattern of the Aligned Section View
The gap between the hatching line in the aligned section view is large; therefore, you
need to modify the spacing.

Figure 12-53  Sketch to be used as section sketch for the aligned
section view

Figure 12-54  Sheet after generating the aligned section view
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1. Select the hatch pattern and right-click to invoke the shortcut menu. Choose Properties
to display the Area Hatch/Fill dialog box.

2. Set the value of the Scale spinner to 2 and select View from the Apply to drop-down list.
Choose OK to close the dialog box.

Generating the Detail View
Next, you need to generate the detail view of the right circular feature of the model.
Before invoking the Detail View tool to generate the detail view, you need to activate a
view from which you will drive the detail view.

1. Activate the top view.

2. Choose the Detail View button from the Drawing toolbar. The Detail View
PropertyManager is displayed and you are prompted to sketch a circle to continue
the view creation.

The cursor will be replaced by the circle cursor.

3. Create a small circle on the right circular feature of the model in the top view, refer to
Figure 12-55.

As you create the circle, the detail view is attached to the cursor; place the view on the
right of the drawing sheet.

4. Set the value of the scale factor of the detail view to 3:1 and choose the OK button from
the Detail View PropertyManager.

Figure 12-55 shows the detail view derived from the top view.

Figure 12-55  The detail view derived from the top view
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Figure 12-56  The detail view derived from the top view

Generating the Isometric View
The last view that you need to generate is the isometric view. You will generate the isometric
view using the Named View tool.

1. Choose the Named View button from the Drawing toolbar. The Named View
PropertyManager is displayed and it lists various options of selecting the model
to generate the drawing view.

The cursor will be replaced by the select model cursor.

2. Select any of the view from the drawing sheet to select the model.

A view is attached to the cursor.

3. The Isometric option is selected from the Orientation View rollout. Place the view close
to the top right corner of the drawing sheet and choose the OK button from the Named
View PropertyManager.

Figure 12-56 shows the final drawing sheet after generating all the models.

Saving the Drawing
Next, you need to save the drawing.

1. Choose the Save button from the Standard toolbar and save the drawing with the name
given below and close the file.

\My Documents\SolidWorks\c12\c12-tut01.SLDDRW.
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Tutorial 2
In this tutorial you will generate the drawing view of the Bench Vice assembly created in
Chapter 10. You will generate the top view, section front view, right view, and isometric view
of the assembly in the exploded state.    (Expected time: 45 min.)

The steps to be followed to complete this tutorial are discussed next:

a. Copy the Bench Vice directory from Chapter 10 to the current directory.
b. Create the exploded state of the Bench vice assembly, refer to Figure 12-57.
c. Create the drawing document in the standard A4 Landscape sheet format and generate

the parent view using the named view tool, refer to Figure 12-58.
d. Generate the section views using the Section View tool, refer to Figure 12-59.
e. Generate the right projection view using the Projected View tool, refer to Figure 12-60.
f. Generate the isometric view and change the state of the isometric view to the exploded

state, refer to Figure 12-61.

Copying the Model in the Current Directory
First, you need to copy the Bench Vice assembly and its parts to the current directory.

1. Copy the Bench Vice directory from the /My Document/SolidWorks/c10 directory to the
current directory.

Creating the Exploded View of the Assembly
Before proceeding further to create the drawing views of the assembly, you need to create
the exploded state of the assembly in the assembly mode.

1. Open the Bench Vice assembly and create the exploded state and the explode lines as
shown in Figure 12-57. It is recommended that whenever you create an exploded state of

Figure 12-57  Exploded view of the assembly with explode lines
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an assembly, you must revert to the collapse state. If you save the assembly in the exploded
state, everytime you generate the drawing views of the assembly, it will generate views
with the exploded state.

2. Right-click Bench Vice Configutarion(s) > Default in the ConfigurationManager and
choose Collapse to unexplode the assembly.

3. Save and close the assembly.

Opening the New Drawing Document
As mentioned earlier in the description, you need to create a new drawing document with
standard A4 sheet.

1. Create a new SolidWorks document in the drawing mode.

The Sheet Format To Use dialog box will be displayed. The Standard sheet format radio
button is selected by default.

2. Select the A4 Landscape sheet from the Standard sheet format drop-down list and choose
the OK button from the Sheet Format To Use dialog box.

3. Change the projection type from first angle to third angle.

Creating the Parent View
The parent view generated in this tutorial is the top view. This view will be generated
using the Named View tool.

1. Choose the Named View tool and invoke the Open dialog box.

2. Open the Bench vice assembly.

3. Select the Top option from the View Orientation rollout and place the view close to the
upper left corner of the drawing sheet.

When you place the view, you will notice that the view placed is larger in size. The size of
the view is not that is required. Therefore, you need to scale the view.

4. Select the Custom Scale check box to invoke this rollout.

5. Set the value of the scale factor to 1:2 and choose the OK button from the Named View
PropertyManager.

You may also need to move the view. Figure 12-58 shows the parent view placed in the
drawing sheet.
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Creating the Sectioned Front View
The next view that you need to generate is the sectioned front view that is derived from
the parent view.

1. Activate the top view and choose the Section View button from the Drawing
toolbar.

The Section View PropertyManager is displayed and it prompts you to sketch a line to
continue view creation. The cursor will be replaced by the line cursor.

2. Create a horizontal line such that it passes through the center of the Bench vice assembly.

As soon as you create the line, the Section View dialog box is displayed. This dialog box
is used to exclude the components from the section cut.

3. Invoke the FeatureManager Design Tree flyout and expand Drawing View1 from the
flyout.

4. Now, expand the Bench vice assembly from the flyout.

5. Select the component that will be excluded from the section cut. The components that
will be excluded from the section cut are Screw Bar, Bar Globes, Jaw Screw, Oval Fillister,
Set Screw1, and Set Screw2.

6. Select the Auto hatching check box and choose the OK button from the Section View
dialog box.

Figure 12-58  Top view generated using the Named View tool
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The preview of the section view is displayed on the drawing sheet as you move the cursor
up and down. The direction of viewing of section view is the same as required. Therefore,
you need to flip the viewing direction of section view.

7. Select the Flip direction check box and place the section view below the parent view.
Choose the OK button from the Section View PropertyManager.

Figure 12-59 shows the section view generated using the Section View tool.

Generating the Right-Side View
The next view that you need to generate is the right-side view derived from the front
section view and will be generated using the Projected View tool.

1. Select the sectioned front view and invoke the Projected View tool.

2. Move the cursor to the right of the sectioned front view and place the view on the right of
the sectioned front view as shown in Figure 12-60.

Creating the Isometric View in the Exploded State
The last view that you need to generate is the isometric view in the exploded state.

1. Using the Named View tool, generate the isometric view and place the view near the
upper right corner of the drawing sheet.

2. Set the scale factor of the drawing view to 1:2.

Figure 12-59  Section view generated using the Section View tool
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3. Select the view and invoke the shortcut menu. Choose the Properties option from the
shortcut menu.

The Drawing View Properties dialog box is displayed.

4. Select the Show in exploded state check box from the Drawing View Properties dialog
box and choose the OK button.

You may need to move the view. Figure 12-61 shows the final drawing sheet after generating
all the drawing views.

Figure 12-60  Right view generated using the Projected View tool

Figure 12-61  Final drawing sheet
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Saving the Drawing
Next, you need to save the drawing.

1. Choose the Save button from the Standard toolbar and save the drawing with the name
given below and close the file.

\My Documents\SolidWorks\c12\c12-tut02.SLDDRW.

SELF-EVALUATION TEST
Answer the following questions and then compare your answers with the answers given at
the end of this chapter.

1. The Standard sheet format radio button is selected by default in the Sheet Format To
Use dialog box. (T/F)

2. The No sheet format radio button is selected if you want to use the empty sheet, without
any margin lines or title block. (T/F)

3. The Relative View tool is used to generate an orthographic view; the orientation of the
view is defined by selecting the reference planes or the planar faces of the model. (T/F)

4. An auxiliary view is a drawing view that is generated by projecting the lines normal to a
specified edge of an existing view. (T/F)

5. You cannot change the style of the break line in a broken view. (T/F)

6. In technical terms, creating a 2D drawing in the drawing document is known as __________.

7. To create the predefined views choose the __________ button from the Assembly toolbar.

8. The __________ check box available in the View Options rollout is used to display the
complete outline of the closed profile in the detail view.

9. For changing the scale of the drawing views select the drawing view and select the
__________ check box to invoke this rollout available in the PropertyManager.

10. For rotating a drawing view, select the view and choose the __________ button from the
View toolbar.
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REVIEW QUESTIONS
Answer the following questions:

1. Choose the __________ button from the Drawing toolbar to create an alternate position
view.

2. The __________ dialog box is used to apply the hatch pattern to a closed profile.

3. The __________ check box is used to scale the hatch pattern.

4. A __________ view is a section view in which only the sectioned surface is displayed in the
section view.

5. The __________ dialog box is displayed to confirm the deletion of the views.

6. The views that are generated from a view already placed in the drawing sheet are known
as?

(a) Child views (b) Derived views
(c) Predefined views (d) Empty views

7. Which rollout is used to set the parameters of the detail view in the Detail View
PropertyManager?

(a)  View Options (b) View Parameters
(c) Parameters (d) Options

8. In which edit box the name of the auxiliary view is specified?

(a) Label (b) View name
(c) Name (d) Detail view label

9. Which drop-down list is used to define whether you need to apply this hatch pattern to
the selected region or to the entire view?

(a) Define (b) Apply to
(c) Name view (d) None of these

10. From which rollout can you select the view orientation in the Named View
PropertyManager?

(a) View Orientation (b) Define View
(c) Specify View (d) Scale View
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EXERCISE

Exercise 1
In this exercise you will generate the front view, section right view, isometric view, and the
alternate position view on the isometric view of Exercise 1 of Chapter 11. You need to scale
the parent view to the scale factor of 1:3. The views that you need to generate are shown in
Figure 12-62.    (Expected time: 30 min.)

Answers to Self-Evaluation Test
1. T, 2. T, 3. T, 4. T, 5. F, 6. Interactive drafting, 7. Predefined View, 8. Full outline, 9.
Custom Scale, 10. Rotate View

Figure 12-62  Views of Exercise 1
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