
Chapter 11

Assembly Modeling-II

After completing this chapter you will be able to:
• Create Subassemblies.
• Delete the Components and Subassemblies.
• Edit the Assembly Mates.
• Replace the Mate Entities.
• Edit Components and Subassemblies.
• Dissolve Subassemblies.
• Replace Components in Assemblies.
• Create Patterns of the Components in the Assembly.
• Create Mirrored Components.
• Hide and Suppress Components in Assemblies.
• Change the Transparency Condition of the Assembly.
• Create Assembly Envelope
• Check the Interference in the Assembly.
• Create Assemblies for Mechanism.
• Detect the Collision while the Assembly is in Motion.
• Create the Exploded State of the Assembly.
• Create the Explode Line Sketch.

Learning Objectives
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CREATING SUBASSEMBLIES
In the previous chapter, you learnt to place the components in the assembly document and
apply the assembly mates to the components. In this chapter you will learn how to create the
subassemblies and place the subassemblies in the main assembly.

For placing the subassemblies in the main assembly, there are two approaches that are followed
in the assembly design environment. These two approaches are discussed next.

Bottom-up Subassembly Design
In the Bottom-up Subassembly design approach, the subassembly is created in the assembly
environment and then it is saved as an assembly file. When you need to place the subassembly
in the main assembly, open the main assembly document and choose Insert > Component >
From File from the menu bar. The Open dialog box is displayed; choose Assembly (*.asm,
*.sldasm) from the Files of Type drop-down list. All the assemblies saved in the current location
will be displayed in the display area. Select the subassembly from the display area and choose
the Open button from the Open dialog box. Select a point in the drawing area to place the
subassembly. Now, using the assembly mates, assemble the subassembly with the main assembly.
Figure 11-1 shows a subassembly of piston and articulated rod. Figure 11-2 shows the main
assembly of the piston and master rod. Figure 11-3 shows the main assembly after assembling
the subassembly with the main assembly.

Top-down Subassembly Design
The Top-down Subassembly design approach is the most flexible subassembly design
approach. In this, you create a new subassembly in the main assembly document. This approach
is generally used in conceptual design or while managing a large assembly. To create a new
subassembly in the assembly document, choose Insert > Component > New Assembly from
the menu bar. The Save As dialog box is displayed; save the subassembly in the current
location. You can drag and place the components in the new subassembly from the
FeatureManager Design Tree. You will learn more about this approach while discussing the
editing of assemblies and subassemblies.

Figure 11-1  A subassembly Figure 11-2  A main assembly
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Figure 11-3  Main assembly after assembling the subassemblies

Tip. You can also place a subassembly in the main assembly using the drag and
drop method that was discussed in the previous chapter.

When you place a subassembly in the main assembly, an assembly icon will be
displayed with the name of the subassembly in the FeatureManager Design Tree.
If you expand the subassembly in the FeatureManager Design Tree, all the parts
assembled in the subassembly will be displayed.

You can also create a subassembly of the components that are already placed in an
assembly file. Press and hold down the CTRL key and select the components either
from the drawing area or from the FeatureManager Design Tree. Invoke the
shortcut menu and choose Form New Sub-assembly Here from the menu bar or
choose Assembly from [Selected] Components from the menu bar. The Save As
dialog box is displayed; you need to enter the name of the subassembly and save it
in the current location. You will observe that the selected components will be combined
and an assembly icon will be displayed in the FeatureManager Design Tree.

DELETING COMPONENTS AND SUBASSEMBLIES
After creating the assembly, at a certain stage of your design cycle you may need to delete any
component or the subassembly. To delete a component of the assembly, select the component
either from the drawing area or from the FeatureManager Design Tree. Invoke the shortcut
menu and expand it; choose the Delete option from the shortcut menu. You can also delete
the selected component by pressing the DELETE key from the keyboard. When you delete a
component, the Confirm Delete dialog box is displayed. The name of the component and
the items dependent on that component are displayed in this dialog box. Choose the Yes
button from the Confirm Delete dialog box.
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If you need to delete the subassembly, select the subassembly from the FeatureManager Design
Tree and press the DELETE key. The Confirm Delete dialog box is displayed, choose the
YES button from this dialog box. You should note that when you delete the subassembly, all
the components of the subassembly are deleted.

EDITING ASSEMBLY MATES
Generally, after creating the assembly or during the process of assembling the components,
you need to edit the assembly mates. The editing operations that can be performed on the
assembly mates are modifying the type of assembly mate, modifying the angle and offset
values, changing the component to which the mate was applied, and so on. In SolidWorks,
for editing the mates, you first need to expand the Mates option available at the bottom of
the FeatureManager Design Tree. Now, select the mate that you need to modify and invoke
the shortcut menu. Choose the Edit Definition option from the shortcut menu. The Mate
PropertyManager will be displayed. The name of the Mate PropertyManager will depend
on the name and sequence of the mate applied. Figure 11-4 shows the Mate PropertyManager
to edit the Concentric mate. You can edit the entities to mate, type of mate, value of offset,
value of angle, and so on using this PropertyManager.

Figure 11-4  The Mate PropertyManager to edit the Concentric mate
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Replacing the Mated Entities

As discussed, you can edit the mate entities using the Mate PropertyManager. The
mate entities can also be modified using the Mated Entities PropertyManager. Select
the Mate option from the FeatureManager Design Tree and invoke the shortcut

menu. Choose the Replace Mate Entities option from the shortcut menu. The Mated Entities
PropertyManager is displayed as shown in Figure 11-5. You can customize the Assembly
toolbar and place the Replace Mate Entities button in the Assembly toolbar.

Figure 11-5  The Mated Entities PropertyManager

Tip. When you move the cursor on a mate in the FeatureManager Design Tree,
the entities used in the mate are highlighted in red color in the drawing area. When
you select the mate from the FeatureManager Design Tree, the entities used in
the selected mate will be highlighted in green color in the drawing area.

Toolbar: Assembly > Replace Mate Entities
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When you invoke the Mated Entities PropertyManager, you are prompted to select the entity
to be replaced. Select the entity from the Mate Entities display area. You can also expand the
entity tree to edit the individual mate. After selecting, the selected face will be highlighted in
green color in the drawing area. The name of the selected the entity will be displayed in the
Replacement Mate Entity display area. You are prompted to select entity to be mated. Select
the entity that will replace the previously selected entity. If the selected entity overdefines the
mate, or the mating is not possible between the entities then the SolidWorks dialog box will
be displayed. You will be informed about the possible cause of error.

The Flip Mate Alignment button is used to flip the direction of mate. The Disable Preview
button is used to disable the preview of the assembly after replacing the mate entity. The
Show All check box is used to display all the mated entities.

EDITING THE COMPONENTS

After placing and mating the components in the assembly document, at some stage
of design cycle you may need to edit the components. The editing of components
includes editing the features, editing the sketches, and editing the sketch planes. For

editing the components, you first need to select the component and invoke the part modeling
environment in the assembly document. Select the component either from the drawing area
or from the FeatureManager Design Tree. Now, choose the Edit Part button from the Assembly
toolbar. The part modeling environment will be invoked and the complete assembly except
the selected component will be displayed in transparent. The name of the component to be
edited will be displayed in red in the FeatureManager Design Tree. Select the desired feature
to edit, and invoke the shortcut menu. The PropertyManager relative to that feature will be
displayed and you can easily edit the parameters of the feature. You can also add new features
to the component. This type of edit is technically termed as Editing in the Context of Assembly.
After editing the component, again choose the Edit Part button from the Assembly tool to
return to the assembly environment.

Note
If you need to edit components separately in their part documents, select the component and
invoke the shortcut menu. Choose Open“part name” from the shortcut menu. The part document
of the selected component will be opened. You can edit the component individually in the part
document. After editing the component, save the part and close the part document and return to
the assembly document. The SolidWorks 2003 dialog box will be displayed as shown in
Figure 11-6. This dialog box prompts you that the models contained within the assembly have
changed. Would you like to rebuild the assembly now? Choose the Yes button from this dialog box.

Tip. Select the Mate option from the FeatureManager Design Tree, and invoke
the shortcut menu. Choose the Parent/Child Relationship option from the shortcut
menu. The Parent Child Relationship dialog box will be displayed. You can
display the child and parent relationship of any component placed in the assembly
using the Parent Child Relationship dialog box.

Toolbar: Assembly > Edit Part
Menu: Edit > Part
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Figure 11-6  The SolidWorks 2003 dialog box

EDITING THE SUBASSEMBLIES

To edit the subassemblies, select the subassembly from the FeatureManager Design
Tree and choose the Edit Part button from the Assembly toolbar. The entire assembly
except the selected subassembly will be displayed in transparent. You can add

components in the subassembly, modify the mates, and replace the components while in
the editing mode. After editing the subassembly, choose the Edit Part button to exit the editing mode.

Note
For editing a component of the subassembly, select the component from the drawing area and
invoke the shortcut menu. Choose the Edit Part option from the shortcut menu. The part
editing mode will be invoked in the assembly document.

To select the component of the subassembly from the FeatureManager Design Tree, you need
to expand the subassembly. All the components assembled in that subassembly will be displayed
when you expand the subassembly.

DISSOLVING THE SUBASSEMBLY
Dissolving the subassembly means the components of the subassembly become the components
of the current assembly. When you dissolve a subassembly, the subassembly is removed from
the main assembly and the components of the subassembly become the components of the
main assembly. To dissolve a subassembly, select the subassembly from the FeatureManager

Tip. You can also modify the dimensions of a component assembled or placed in the
assembly by double-clicking the feature of that component. All the dimensions of
that feature will be displayed in the drawing area. Invoke the Modify dialog box by
double-clicking the dimension to modify. Enter the new dimension in the Modify
dialog box and choose the ENTER key from the key board. Since the dimension is
modified, but the geometry of the feature has not changed, therefore, you need to
rebuild the assembly. Choose the Rebuild button from the Standard toolbar to
rebuild the entire assembly. You can also rebuild the assembly using CTRL+B key
from the keyboard.

While in the part editing mode in the assembly document, you can use the Move/Size
Features tool to edit the features dynamically using editing handles.

Toolbar: Assembly > Edit Part
Menu: Edit > Part
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Design Tree and invoke the shortcut menu. Choose the Dissolve Sub-assembly option from
the shortcut menu. The subassembly will be removed from the FeatureManager Design Tree
and the components of the subassembly will be displayed as the components of the main
assembly in the FeatureManager Design Tree.

REPLACING THE COMPONENTS

Sometimes, in the assembly design cycle you may need to replace a component of
the assembly with some other component. To replace a component, select the
component to replace and invoke the shortcut menu. Choose the Replace option

from the shortcut menu. The Replace PropertyManager will be displayed as shown in
Figure 11-7. You can also invoke the Replace PropertyManager by choosing the Replace
button from the Assembly toolbar after customizing it.

When you invoke the Replace PropertyManager, you are prompted to select components to
be replaced. Select the component to be replaced. If the component is already selected before
invoking this tool, then that component will be selected automatically. The name of the selected
component is displayed in the Components to be Replaced display area. Next, you need to
specify the replacement component. Choose the Browse button from the Selection rollout;
the Open dialog box will be displayed. Select the replacement component and choose the

Figure 11-7  The Replace PropertyManager

Toolbar: Assembly > Replace (Customize to Add)
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Open button from the Open dialog box. The name and location of the replacement component
is displayed in the Replacement Component area.

The Re-attach mates check box is selected by default. This option is used to invoke the Mate
Entities PropertyManager after you choose the OK button from the Replace
PropertyManager. Using the Mate Entities PropertyManager, you can replace the mate entities.

If this check box is cleared, the Rebuild Errors dialog box is displayed after you exit the
Replace PropertyManager. The Rebuild Errors dialog box informs you the name of the
mates that contain errors. Therefore, you need to redefine the mates. For redefining the
mates, expand the Mates option from the FeatureManager Design Tree. Select the mate that
contains    symbol on the left. Invoke the shortcut menu and choose the Edit Definition
option. The Mate PropertyManager will be displayed and you can edit the mate entities.

The All instances check box available in the Selection rollout is used to replace all the instances
of the selected component. The options available in the Configuration area are used to define
the selection procedure of the configurations. You will learn more about configurations later.

Figure 11-8 shows the assembly in which the bolt is to be replaced by a pin. Figure 11-9 shows
the faces of the pin to be used as mate entities after replacing the component. Figure 11-10
shows the isometric view of the assembly after bolts are replaced by pins.

Figure 11-8  Bolt to be replaced by a pin Figure 11-9  Mating entities to be replaced
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Figure 11-10  Bolt replaced by pin in the assembly

Tip. If     symbol is displayed on the Mates option in the FeatureManager
Design Tree, this means that this mate group has some errors. Expand the mate
group; the mate that displays     sign will have some errors. Select that mate and
invoke the shortcut menu. Choose Whats Wrong? from the shortcut menu to display
the Rebuild Errors dialog box. The possible cause of error will be displayed in the
Rebuild Errors dialog box.

If you select the Mate Diagnostic option from the shortcut menu, the Diagnostics
PropertyManager will be displayed. The Analyze button is used to display the
entities that are the cause of errors in the mate. Choose the Analyze button; the
name of the mate and the entity will be displayed in the Analyze Problem rollout.

Select the Mates mategroup with error symbol from the FeatureManager Design
Tree and invoke the shortcut menu. You can choose the Whats Wrong? or Mate
Diagnostics option to analyze all the mates having errors.

CREATING PATTERNS OF THE COMPONENTS IN AN
ASSEMBLY

While working in the assembly design environment of SolidWorks, you may need to assemble
more than one instance of the component about a specified arrangement. Consider the case
of a flange coupling where you have to assemble eight instances of the nut and bolt to fasten
the coupling. Therefore, you need to make the instances of the nut and bolt and then assemble
all the eight nuts and the eight bolts manually. However, this is a very tedious and
time-consuming precess. Therefore, to reduce the time in the assembly design cycle,

Menu: Insert > Component Pattern
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Figure 11-11  The Pattern Type dialog box

SolidWorks has provided a tool to create the patterns of the components. There are two types
of component patterns provided in SolidWorks. These are discussed next.

Derived Pattern
The Derived Pattern option is used to pattern the instances of the components using an
existing pattern feature. For creating a derived pattern, choose Insert > Component Pattern
from the menu bar. The Pattern Type dialog box is displayed as shown in Figure 11-11 and
the Use an existing feature pattern (Derived) radio button is selected by default.

Choose the Next button from the Pattern Type dialog box. The Derived Component Pattern
dialog box will be displayed as shown in Figure 11-12. The selection mode is active in the
Seed Component(s) area. Select the component or components to pattern from the drawing
area or from the FeatureManager Design Tree. Now, click once in the Pattern Feature area to
invoke the selection mode and select any one instance of an existing pattern feature. Choose
the Finish button from the Derived Component Pattern dialog box.

Figure 11-13 shows the components to be selected to pattern and an instance of an existing
pattern feature to be selected. Figure 11-14 shows the assembly after creating the derived
pattern feature.
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Figure 11-13  Components and the instance of
the pattern feature to be selected

Figure 11-14  Assembly after creating the derived
component pattern

Figure 11-12  The Derived Component Pattern dialog box

Note
If you change the number of instances of the pattern feature using which the derived component
pattern is created, the number of instances of the component pattern are automatically modified.
This displays the associative and parametric nature of the derived component pattern.

After editing the number of entities in the pattern feature, you may have to choose the Rebuild
button.

Remember that if the feature that was used to assemble the seed component is deleted while
reducing the number of features in the pattern, you will have to modify the mates. This is
because the original feature on which the mates were applied does not exist any more and so the
mates give an error.
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Tip. If you need to skip some instances while creating the pattern of a component,
then first create the component pattern as discussed above. After creating the pattern
you will observe that the DerivedCirPattern1 feature will be displayed in the
FeatureManager Design Tree. If the derived pattern creates a rectangular pattern
of the components, the name of the feature will be DerivedLPattern1. The number
at the last of the feature display the sequence number of the derived pattern feature.

When expand this feature, all the instances of the patterned component are displayed.
Select the instance to be deleted from the FeatureManager Design Tree and press
the DELETE key. The Confirmation dialog box will be displayed; choose the Yes
button from the dialog box.

If you need to restore the deleted pattern instance, then select the derived pattern
from the FeatureManager Design Tree and invoke the shortcut menu. Choose
the Edit Definition option from the shortcut menu. The Derived Component
Pattern dialog box will be displayed. The number of the deleted instance will be
displayed in the Positions To Skip area. Select the instance from the Position To
Skip area and press the DELETE key to restore the deleted pattern instance. Choose
the Finish button from the Derived Component Pattern dialog box.

Local Pattern
You can also create the patterns of the components individually even if there is no pattern
feature. This type of component pattern is known as local pattern. You can create two types of
local pattern: first is the linear pattern and the other is the circular pattern. Both the types of
local patterns are discussed next.

Linear Pattern
For creating the local linear pattern, invoke the Pattern Type dialog box. Select the Define
your own pattern (Local) radio button from the Pattern Type dialog box. The Arrange in
straight lines (Linear) radio button and the Arrange in a circular fashion (Circular) radio
buttons are invoked. The Arrange in straight lines (Linear) radio button is selected by default.
Choose the Next button from the Pattern Type dialog box. The Local Component Pattern
dialog box for the linear pattern is displayed as shown in Figure 11-15.

The options available in this dialog box are used to create a linear local component pattern.
The options of creating the linear pattern are the same as those discussed in Chapter 9.

Circular Pattern
For creating a local circular component pattern, invoke the Pattern Type dialog box. Select
the Define your own pattern (local) radio button; next select the Arrange in a circular
fashion (Circular) radio button. The Local Component Pattern dialog box for creating a
circular component pattern will be displayed as shown in Figure 11-16.

The options available in this dialog box to create a circular pattern are the same as those
discussed in Chapter 7 to create a circular pattern feature.
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Figure 11-16  The Local Component Pattern dialog box for circular pattern

Tip. If one instance of the component pattern is modified or edited, the other instances
of the component will also be modified.

You can also create the component pattern of a component pattern feature.

Figure 11-15  The Local Component Pattern dialog box for linear pattern
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Menu: Insert > Mirror Components

MIRRORING THE COMPONENTS

In the assembly design environment of SolidWorks, you can also mirror a component to place
the new instance of the component in the assembly document. For mirroring the component,
choose Insert > Mirror Components from the menu bar. The Mirror Components
PropertyManager is displayed as shown in Figure 11-17.

Select the planar face or plane that act as mirror plane as shown in Figure 11-18. Now, select
the component to mirror; you will observe that the name of the component with a check box
is displayed in the Components to Mirror area. Leave this check box cleared and choose the
Next button from the Mirror Components PropertyManager. The preview of the mirrored

Figure 11-17  The Mirror Components PropertyManager
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component is displayed as shown in Figure 11-19. The Orientation rollout is displayed and
using the options available in this rollout you can change the orientation of the mirrored
component. Choose the OK button from the Mirror Components PropertyManager. The
mirrored instance of the selected component is displayed in the drawing area as shown in
Figure 11-20.

If you select the check box available with the name of the selected component in the
Components to Mirror area, a new component that is mirrored along the selected mirror
plane  and saved in a specified location is created. Select the check box available along the
name of the selected component and choose the Next button. The Filenames rollout is
displayed; choose the Browse button available in the Filenames rollout. This button is used
to specify the name and location where the file will be saved. Using the Place files in one
folder check box, you can save all the mirrored instances in one folder. Using the Add
drop-down list, you can  add a suffix or a prefix to the file name.

Figure 11-20  Instance created by mirroring the component

Figure 11-18  Face to be selected as mirror plane Figure 11-19  Preview of the mirrored component
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SIMPLIFYING THE ASSEMBLIES USING VISIBILITY
OPTIONS
When you are assembling the components, whether it be a large assembly or a small assembly,
you may need to simplify the assembly using the visibility options. By simplifying, you can
hide the components at any stage of the design cycle. You can also set the transparency of any
component for simplifying the assembly. You can also suppress and unsuppress the components
at any stage of the design cycle. The various methods of simplifying the assembly are discussed
next.

Hiding the Components

If you need to hide the component placed in the assembly, choose the component
from the drawing area or from the FeatureManager Design Tree. Using the CTRL
key you can select more than one component to hide. Right-click to invoke the shortcut

menu and choose the Hide Components option from the shortcut menu. The component
will disappear from the drawing area. The icon of the component is displayed in transparent
in the FeatureManager Design Tree. To unhide the hidden component, select the icon of the
component from the FeatureManager Design Tree and invoke the shortcut menu. Choose
the Show Components option from the shortcut menu. The hidden component will be
redisplayed in the drawing area. You can also use the Hide/Show Component button from
the Assembly toolbar to hide or show the components. But if this button is not available by
default, then you have to customize the Assembly toolbar to add this button.

Tip. You will observe that the Lightweight check box is provided in the Open
dialog box. If you select this check box before opening the assembly file, the assembly
will be opened with lightweight components.

A lightweight component is a component in which the feature information is available
in the part document and only the graphical representation of the component is
displayed in the assembly document. Therefore, the assembly environment becomes
light. An icon of a lightweight component is displayed as a feather attached to the
component icon in the FeatureManager Design Tree.

To get the feature information of the lightweight component, you need to resolve the
component to normal state. Therefore, select the component from the drawing area
or from the FeatureManager Design Tree and invoke the shortcut menu. Choose
the Set to Resolve option from the shortcut menu. If you need to set a resolved
component to a lightweight component, select the component and invoke the shortcut
menu. Choose Set to Lightweight from the shortcut menu.

Toolbar: Assembly > Hide/Show Component
Menu: Edit > Hide > This Configuration
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Suppressing the Components

You can also suppress the components placed in the assembly to simplify the assembly
representation. To suppress a component, select the component from the drawing
area or from the FeatureManager Design Tree. Invoke the shortcut menu and choose

Suppress. The component will not be displayed in the assembly document and the icon of
the suppressed component will be displayed in grey in the FeatureManager Design Tree. To
unsuppress the suppressed component, select the component to be resolved from the
FeatureManager Design Tree and invoke the shortcut menu. Choose the Set to Resolve
option from the shortcut menu.

You can also suppress the component using the Change Suppression State button from the
Assembly toolbar. If this button is not available in the Assembly toolbar, you need to customize
the toolbar. Using the Change Suppression State button, you can suppress the selected
component as well as set the selected component to lightweight. When you select the
component and choose the Change Suppression State button from the Assembly toolbar, a
flyout is displayed. This flyout has three buttons. The first button is the Suppress button, the
second button is the Lightweight button, and the third button is the Resolve button. The
Resolve button is used to set the suppressed or lightweight components to resolve state.

Changing the Transparency Conditions
In SolidWorks you can change the transparency of the components or selected faces to simplify
the assembly. First, you will learn how to change the transparency of the components. Select
the component to change its transparency and invoke the shortcut menu. Choose the
Component Properties option from the shortcut menu. The Component Properties dialog
box will be displayed. Choose the Color button available in this dialog box. The Assembly
Instance Color dialog box is displayed as shown in Figure 11-21.

Figure 11-21  The Assembly Instance Color dialog box

Toolbar: Assembly > Change Suppression State
Menu: Edit > Suppress > This Configuration
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Figure 11-22  The Advanced Properties dialog box

Choose the Advanced button from this dialog box. The Advanced Properties dialog box is
displayed as shown in Figure 11-22. You can set the transparency of the component from the
Transparency slider. You can also set the various other advanced color settings such as Ambient,
Diffuse, Specularity, Shininess, and Emission from this dialog box.

You can also change the transparency of a selected face. To set the transparency of a face,
select the face and invoke the shortcut menu and choose the Face Properties option from the
shortcut menu. The Entity Property dialog box is displayed. Choose the Advanced button
from this dialog box to invoke the Advanced Properties dialog box. Using this dialog box
you can set the transparency of the selected face.

CREATING THE ASSEMBLY ENVELOPE

The assembly envelope is an option that is used to simplify the selection of the components in
a complex assembly. An envelope is basically a box that is created around a specified component,
see Figure 11-23. You can select all the components that lie in and around this box. To create
an assembly envelope, choose Insert > Envelope > New from the menu bar. The Save As
dialog box is displayed; save the envelope in the location where all the other components of
that assembly are saved. The select cursor is replaced by the part placement cursor. Place the
component on any one of the assembly default planes or on a planar face of the components
of the assembly. The Edit Part button is chosen and the entire assembly is changed to
transparent. The sketching environment is invoked with the placement plane or face of the
assembly envelope as the sketching plane. You can exit the sketching plane and select
another sketching plane for creating the sketch of the envelope. Create the sketch of the

Menu: Insert > Envelope > New/ From File

Tip.  The face that is made transparent cannot be selected by clicking. You need to
select some other faces and then choose the Select Other option from the shortcut
menu. Right-click until the desired face is highlighted. Once the desired face is
highlighted, left-click to select it. Now, right-click anywhere in the drawing window
to display the shortcut menu.
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envelope. Generally, the envelope is in the form of a cube or a cuboid, i.e., an extruded
rectangle or extruded square. Create the sketch of the envelope and extrude the sketch. The
sketch will be extruded on one side or on both the sides of the sketching plane, depending on
the geometry of the assembly. Choose the Edit Part button from the Assembly toolbar to exit
the part modeling environment. The assembly envelope will be displayed in the transparent
blue color. The icon of the envelope is displayed with the name of the envelope in the
FeatureManager Design Tree. Figure 11-23 shows an assembly with an assembly envelope.

Selecting the Components Using the Assembly Envelope
For selecting the components using the assembly envelope, choose the ConfigurationManager
tab from the bottom of the FeatureManager Design Tree to invoke the ConfigurationManager.
Select Envelope1 from the ConfigurationManager and invoke the shortcut menu. Choose
the Select using envelope option from the shortcut menu. The Apply Envelope dialog box
is displayed as shown in Figure 11-24. The various options available in this dialog box are
discussed next.

Figure 11-23  An assembly with an assembly envelope

Figure 11-24  The Apply Envelope dialog box
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Inside envelope
The Inside envelope check box is selected to select the components that are placed completely
inside the assembly envelope.

Outside envelope
The Outside envelope check box is selected to select the components that are placed
completely outside the assembly envelope.

Crossing envelope
The Crossing envelope check box is selected to select the components that are placed partially
inside the envelope or that cross the boundary of the assembly envelope.

Select Components in Top Assembly Only
The Select Components in Top Assembly Only check box is selected to select the components
of the top assembly only. In this case it considers the subassemblies as a single component.
For example, consider a case in which a single part of subassembly is outside the assembly
envelope. Now, if you select Inside envelope from the Apply Envelope dialog box, the entire
subassembly will be selected.

Advanced Hide/Show the Components Using the Envelope
You can hide the components displayed in the assembly environment and also show the
hidden components using the envelope. To hide/show the components using the envelope,
select the envelope from the ConfigurationManager and invoke the shortcut menu. Choose
the Show/Hide using envelope option from the shortcut menu. The Apply Envelope dialog
box will be displayed as shown in Figure 11-25.

By default, the Show part components radio button is selected in the Apply Envelope dialog
box. The Hide it radio button is selected by default in the If a component does not meet
criteria, then area. You can select the options from the Criteria area to define the components
that should be affected. The options available in this area are discussed earlier. Therefore,
with the current combination of selections the components that meet the criteria of the option

Figure 11-25  The Apply Envelope dialog box
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selected in the Criteria area will be shown as the other components will be defined in the
hidden state. The Hide part components radio button is used to hide the components that
meet the criteria of the option selected in the Criteria area. If the Leave its show/hide state
as it is radio button available in the If component does not meet criteria, then area is selected,
the current hide/show state of the components is maintained for the components that do not
meet the option selected in the Criteria area.

CHECKING THE INTERFERENCES IN THE ASSEMBLY
After creating the assembly design, the first and the most essential step is to check the
interference between the components of the assembly. If there is interference between the
components, the components may not assemble properly after the they are out from the
machine shop or tool room. Therefore, before sending the part file and assembly for the
detailing and drafting purpose, it is essential to check the interference. To check the
interference, choose Tools > Interference Detection from the menu bar. The Interference
Volumes dialog box is displayed as shown in Figure 11-26.

The name of the current assembly is displayed in the Selected components display area. You
can also check the interference between two or more than two components. To select the
components, first clear the current selection set and select the components from the assembly.
Choose the Check button from this dialog box to check the interference. If there is any
interference between the components in the assembly, it will be displayed in the assembly and
all the interferences are also displayed in the Interference results area. Select the interference
from the Interference results area; the components between which the interference is detected
will be displayed in the Component 1 and Component 2 display area. Also, as you select
the interference, the components are highlighted in the assembly and the amount of interfering
component is displayed in the assembly. The Treat coincidence as interference check box is
used to display the coincident mates as interference. After analyzing the assembly
you can edit or modify the part.

Figure 11-26  The Interference Volumes dialog box
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CREATING THE ASSEMBLIES FOR MECHANISM
As mentioned earlier, there are two types of assemblies. The first one is a fully defined assembly
in which the relative movement of all the components is contained. The second type of assembly
is that in which the components are not fully defined and some degree of freedom is kept
unconstrained. As a result they can move in certain direction with respect to the surroundings
of the assembly. This flexibility in turn helps you to create the mechanisms and then you can
move the assembly to check the mechanism that you have designed. Consider the case of a
Bench Vice in which you are assembling the vice jaw with the vice body. For this assembly to
work, the linear movement of the Vice Jaw when placed on the vice body should be free.
Therefore, while creating this assembly for mechanism, you should not apply the mates for
constraining the linear motion of the Vice Jaw with respect to the vice body. Figure 11-27
shows the degree of freedom that has to be free to create an assembly for motion.

After creating the assembly for mechanism by defining minimum mates, invoke the Move
tool. Select one of the face of the component that you need to move and drag the cursor to
move the assembly. While moving the assembly for mechanism design, there are some options
available for analyzing the assembly. These options of analyzing the assembly are discussed next.

Analyzing the Collisions Using the Collision Detection Tool
In SolidWorks, you can also analyze if there is any collision between the components of the
assembly while the assembly is in motion. To analyze the collision when the assembly is in
motion, invoke the Move PropertyManager and invoke the Options rollout as shown in

Figure 11-27  Direction in which the degree of freedom should be free

Tip. You can also select a part created earlier as an envelope and place and assemble
it in the assembly file for advanced selection or show/hide options. Choose Insert
> Envelope > From File from the menu bar. The Open dialog box is displayed;
browse and open the part to be used as envelope and assemble using the assembly
mates.
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Figure 11-28  The Options rollout of the
Move PropertyManager

Figure 11-28. Select the Collision Detection radio button from the Options rollout. The
Check between area is displayed; the options available in this area are used to specify the
components between which the collision will be detected. The options available in the Check
between area are discussed next.

All components
The All components radio button is selected to check the collision between all the components
when the assembly is in motion.

These components
The These components radio button is selected to check the collision only between the selected
components when the assembly is in motion. When you select the These components radio
button, the Components for Collision Check display area  and the Resume Drag button are
displayed in the Options rollout as shown in Figure 11-29. After selecting the components
between which the collision has to be detected, the name of the components is displayed in
the Components for Collision Check display area. After selecting the components, choose
the Resume Drag button from the Options rollout and drag the cursor to move the assembly.

Stop at collision
The Stop at collision check box is selected to stop the motion of the assembly when one of
the component collides with another component during the assembly motion.

Dragged part only
The Dragged part only check box is selected when you need to detect the collision only
between the components that you selected to move. If you do not select this check box, the
components that you selected to move and any other component that moves because of mates
with the selected components are detected for collision.

After setting the options in the Options rollout, drag the assembly either using the Move tool
or using the Rotate tool. You can also use the Rotate tool to move the assembly. To use the
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Figure 11-29  The Options rollout of the
Move PropertyManager with the These components
radio button selected from the Check between area

Rotate tool invoke the Rotate rollout and drag the assembly to move. If a component of the
assembly collides with another component while the assembly is in motion, the faces of the
components that collide with each other will be displayed in green color. If the Stop at collision
check box is selected, the motion of the assembly will be stopped when one of the components
collides with another component of the assembly.

Consider the assembly shown in Figure 11-30. In this assembly you need to move the slider in
the given direction. Invoke the Move PropertyManager and select the Collision Detection
radio button from the Options rollout. Drag the slider to move in the given direction.
Figure 11-31 shows that the slider collides with the extrusion feature created in the vertical
column of the base component. The faces of the component that collides is displayed in
green color. If the Stop at collision check box is selected, you cannot move the component
further after it collides with one of the components of the assembly.

Once the collision is detected in the assembly, you can edit and modify the components that
collide during the assembly motion.
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CREATING THE EXPLODED STATE OF THE ASSEMBLY
In SolidWorks, you can also create an exploded state of the assembly. The explode state of the
assembly is created using the Assembly Exploder dialog box. To invoke this dialog box, first
you need to invoke the ConfigurationManager. Select the Default option from the
ConfigurationManager and invoke the shortcut menu. Choose the New Explode View option
from the shortcut menu. The Assembly Exploder dialog box will be displayed as shown in
Figure 11-32.

There are two options to create an exploded state of the assembly. The first option is to create
the exploded state automatically. To create an automatic explode state, choose the Auto
Explode button from the Assembly Exploder dialog box. The components of the assembly
will be exploded and will be placed arbitrarily in the assembly document. Figure 11-33 shows
an automatic exploded view of an assembly.

Creating the Systematic Explode State
To create a systematic explode state of the assembly, choose the New button from the
Assembly Exploder dialog box. The Assembly Exploder dialog box will expand
and some more options are displayed as shown in Figure 11-34.

Figure 11-32  The Assembly Exploder dialog box

Figure 11-30  Direction in which the slider will be
moved inside the base

Figure 11-31  The faces of the components
highlighted in green after collision

c11-solidworks-2003.p65 5/12/2003, 12:05 PM26



Assembly Modeling-II       11-27

As you expand this dialog box, you are prompted to create a new explode step. The selection
is active in the Direction to explode along display area. Therefore, you need to select the
direction in which you need to explode the component. Select an edge, face, plane, axis, or a
sketch to define the direction along which the components will be exploded. After selecting
the explode direction, the selection mode in the Components to explode area is activated.
Select the components to be exploded in the current direction. Specify the explode distance
using the Explode spinner. You can also reverse the direction of explode using the Reverse

Figure 11-34  The expanded Assembly Exploder dialog box

Figure 11-33  An assembly exploded using the Auto Explode tool
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direction check box. The Explode related components together check box is selected to
explode all the components that related with the selected component using the assembly
mates.

After exploding the components in a particular direction with same distance, you need to
explode the other components. Therefore, you need to create another explode step. Choose
the New button from the Assembly Exploder dialog box. Now, using the same procedure,
explode the other set of components. You can create as many explode steps as you want
while exploding the assembly.

After creating all the explode steps choose the OK button from the Assembly Exploder
dialog box to complete the explode state creation. If you need to switch back to the unexplode
state, expand the Default option from the ConfigurationManager and select ExplView1.
Invoke the shortcut menu and choose Collapse from the shortcut menu. You can also edit
each explode step by expanding ExplView1 and select the explode step to be modified.
Invoke the shortcut menu and choose the Edit Definition option from the shortcut menu.
The Assembly Exploder dialog box is displayed and you can modify the parameters of the
explode step. Figure 11-35 shows the systematic exploded view of an assembly.

Creating the Explode Line Sketch

Explode lines are the parametric axes that display the direction of explosion of the
components in the exploded state. Figure 11-36 shows an exploded assembly with
explode lines.

To create the explode line sketch, choose the Explode Line Sketch button from the Drawing

Figure 11-35  The systematic exploded state of an assembly

Toolbar: Assembly > Explode Line Sketch
Menu: Insert > Explode Line Sketch
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Figure 11-37  The  RouteLine PropertyManager

toolbar or choose Insert > Explode Line Sketch from the menu bar. The Route Line
PropertyManager is displayed as shown in Figure 11-37. You are prompted to select cylindrical
face, planar face, vertex, point, arc, or line entities. One by one select the cylindrical faces of
the two components to create an explode line between them. For example, to create an explode
line between the oval fillister and the vice jaw, select the cylindrical face of the oval fillister
that goes inside the vice jaw. Now, select the cylindrical hole of the vice jaw. The preview of
the explode line appears. Choose OK to create the explode line. The names of the selected
faces are displayed in the Items To Connect display area. As you select an entity to create an

Figure 11-36  Explode line sketch created on an exploded assembly
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explode line, an arrow is also displayed with the line. You can use that arrow to reverse the
direction of explode line creation. You can also choose the Reverse check box from the Options
rollout of the Route Line PropertyManager to reverse the direction of the explode line creation.
After creating the explode line in all the components, choose the OK button from the Explode
Line Sketch PropertyManager.

TUTORIALS

Tutorial 1
In this tutorial you will create the assembly shown in Figure 11-38. This assembly will be
created in two parts, one will be the main assembly and the second will be the subassembly.
You will also create the exploded state of the assembly and then create the explode line
sketch. The explode state of the assembly is displayed in Figure 11-39. The views and
dimensions of all the components of this assembly are displayed in Figures 11-40 through
11-43.                                  (Expected time: 3 hrs)

Figure 11-38  The radial engine subassembly

Tip. After creating all the explode lines, you need to exit the sketching environment
using the Confirmation Corner.

You can add jog lines using the Jog Line tool.
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Figure 11-40  Views and dimensions of Master rod

Figure 11-39  Exploded view of the assembly
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Figure 11-42  Views and dimensions of the Piston

The steps to be followed to complete this tutorial are discussed next:

Since this assembly is a large assembly, therefore, you need to divide this assembly in two
parts. One will be the master assembly and the second will be the subassembly. First, you need
to  create the subassembly, which consists of Articulation Rod, Piston, Piston Rings, Piston
Pin, Rod Bush Upper, Rod Bush Lower, and Piston Pin Plug. After creating this subassembly
you will create the master assembly in which you will assemble the Master Rod with the Piston,
Piston Rings, Piston Pin, Rod Bush Upper, and Piston Pin Plug. After assembling the
components in the master assembly you will insert the subassembly in the master assembly
and assemble it.

a. Create all the components of the assembly in the Part mode and save the components in
a directory named Radial Engine Subassembly.

c11-solidworks-2003.p65 5/12/2003, 12:05 PM32



Assembly Modeling-II       11-33

Figure 11-43  Views and dimensions of other components

b. Open a new assembly file and assemble the components to create a subassembly.
c. Open a new assembly file and assemble the components of the master assembly.
d. Insert the subassembly in the master assembly and assemble it with the master assembly.
e. Create the exploded view of the assembly and then create the explode lines.

Creating the Components
1. Create a directory with the name Radial Engine Subassembly in the /My Documents/

SolidWorks/C11 directory. Create all the components in the individual part files and save
them in this directory.
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Figure 11-41  Views and dimensions of the Articulated rod

Note
When you create the Master Rod, remember that the holes on the left of the Master Rod should
be created using the sketch-driven pattern. This is done because while assembling the Link Pin
you will create the derived pattern of the Link Pin using the sketch driven pattern feature.

Creating the Subassembly
As discussed earlier, you will first create the subassembly. After that, you will assemble the
subassembly with the master assembly.

1. Open a new assembly document and save it with the name Piston Articulation Rod
Subassembly in the same directory in which the parts are created.

2. First place the Articulated Rod at the origin of the assembly and then place the other
components such as Piston, Piston Pin, Piston Pin Plug, Rod Bush Upper, and Rod Bush
Lower in the assembly document.

3. Apply the required mates to assemble these components.  The assembly after assembling
the Articulated Rod, Piston, Piston Pin, Piston Pin Plug, Rod Bush Upper, and Rod Bush
Lower is shown in Figure 11-44.

It is clear from the assembly that you need to assemble four instances of Piston Ring. You
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will only assemble one instance of the Piston Ring at the uppermost groove of the ring.
After assembling this instance, you will create the local pattern of the Piston Ring.

4. Insert the Piston Ring in the assembly document and assemble the Piston Ring at the
uppermost groove of the Piston using the assembly mates, see Figure 11-45. In this figure,
the color of Piston Ring is changed by selecting it and choosing the Component Properties
option from the shortcut menu. From the Component Properties dialog box, choose the
Color button to change the color.

Figure 11-44  Assembly of Articulated Rod, Piston, Piston Pin, Piston
Pin Plug, Rod Bush Upper, and Rod Bush Lower

Figure 11-45  First instance of the Piston Ring assembled with the Piston
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Figure 11-46  Subassembly after patterning the Piston ring

Next, you need to create the local pattern of the Piston Ring.

5. Choose Insert > Component Pattern from the menu bar. The Pattern Type dialog box is
displayed.

6. Select the Define your own pattern (Local) radio button from this dialog box.

7. The Arrange in straight lines (Linear) radio button is selected by default. Choose the
Next button from the Pattern Type dialog box. The Local Component Pattern dialog
box will be displayed.

8. Select the Piston Ring from the assembly document; the name of the Piston Ring is
displayed in the Seed Component(s) display area.

9. Now, click once in the Along Edge/Dim display area to activate the selection mode in this
area.

10. Select any one of the horizontal edges of the Articulation Rod to define the direction of
pattern creation.

11. Select the Reverse Direction check box to reverse the direction of pattern creation.

12. Set the value of the Spacing spinner to 5 and set the value of the Instances spinner to 4.

13. Choose the Finish button from the Local Component Pattern dialog box.

The subassembly after patterning the Piston Ring is shown in Figure 11-46
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The subassembly is completed. Save the assembly document.

Creating the Master Assembly
Next, you will create the master assembly. After creating the master assembly you will
place and assemble the subassembly with the master assembly.

1. Open a new assembly document and save it with the name Radial Engine Subassembly
in the same directory in which the parts are created.

2. First, place the Master rod at the origin of the assembly and then place the Piston, Piston
Pin, Piston Pin Plug, Piston Ring, Rod Bush Upper, and Master Rod Bearing in the assembly
document.

3. Using the assembly mates and local pattern option assemble all the components of the
master assembly.

The components after assembling in the master assembly are displayed in Figure 11-47.

Assembling the Subassembly With the Master Assembly
Now, you will place the subassembly in the mater assembly and then assemble it with the
subassembly.

1. Choose Insert > Component > From File from the menu bar. The Open dialog box is
displayed.

2. Choose Assembly (*.asm, *.sldasm) from the Files of type drop-down list.

3. Double-click on Piston Articulated Rod Subassembly.SLDASM and place the subassembly in
the master assembly.

Figure 11-47  Components assembled in the Master assembly.
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Figure 11-49  Assembly structure

Figure 11-48 shows the subassembly placed in the master assembly.

4. Using the assembly mates assemble the subassembly with the master assembly. Refer to
Figure 11-49, which shows you the assembly structure that will help you in assembling the
instances of the subassembly.

Figure 11-48  Subassembly placed in the master assembly

Tip. You can create more than one instance of the subassembly by holding down the
CTRL key; select and drag the subassembly from the FeatureManager Design
Tree. Release the left mouse button to place the assembly in the assembly document.
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Figure 11-50 shows all the instances of the subassembly assembled with the master assembly.

Assembling the Link Pin
After assembling the other components you need to assemble the Link Pin with the master
assembly.

1. Place the Link Pin in the assembly document and using the assembly mates, assemble the
Llink Pin with the master assembly. Figure 11-51 shows the first instance of Link Pin
assembled with the master assembly.

Figure 11-50  Subassembly assembled to the Master assembly

Figure 11-51  First instance of the Link pin assembled with the
master assembly
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Figure 11-52  The final assembly

As discussed earlier, the other instances of the Link Pin will be assembled as derived
pattern using the sketch-driven pattern feature of the holes created on the left of the
master rod.

2. Choose Insert > Component Pattern from the menu bar. The Pattern Type dialog box
will be displayed.

The  Use an existing feature pattern (Derived) radio button is selected by default in the
Pattern Type dialog box.

3. Choose the Next button from the Pattern Type dialog box. The Derived Component
Pattern dialog box is displayed.

The selection mode is active in the Seed Component(s) display area.

4. Select the Link Pin from the master assembly. The name of the Link Pin is displayed in
the Seed Component(s) display area.

5. Click once in the Pattern Feature display area to activate the selection mode in this area.

6. Select any one of the hole instance created using the sketch-driven pattern. The name of
the sketch pattern feature will be displayed in the Pattern Feature display area.

7. Choose the Finish button from the Derived Component Pattern dialog box.

Figure 11-52 displays the final assembly.
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Exploding the Assembly
After creating the assembly you need to explode the assembly using the
Assembly Exploder tool.

1. Invoke the ConfigurationManager. Select the Default option from the
ConfigurationManager and invoke the shortcut menu. Choose the New Exploded View
option from the shortcut menu.

The Assembly Exploder dialog box is displayed.

2. Choose the New button from the Assembly Exploder dialog box.

3. Select any vertical edge from the assembly to define the direction in which the components
will be exploded.

4. Select the Component part only radio button on the right of the Components to explode
area.

5. Select all the Piston Pin Plugs from the assembly.

6. Set the value of the Distance spinner to 170 and choose the Apply button from
the Assembly Exploder dialog box.

All the instances of the Piston Pin Plug are exploded.

7. Choose the New button from the Assembly Exploder dialog box to create a
new assembly exploder step.

8. Select any vertical edge from the assembly to define the direction of explode.

9. Select all the instances of the Piston Pin from the assembly.

10. Set the value of the Distance spinner to 140 and choose the Apply button to end
the explode step creation.

Similarly, explode the other components of the assembly. The assembly after exploding
the components is shown in Figure 11-53.

Creating the Explode Line Sketch
After exploding the assembly, you need to create the explode line sketch of the exploded
state of the assembly.

1. Choose the Explode Line Sketch button from the Assembly toolbar. The Route
Line PropertyManager is displayed and you are prompted to select cylindrical
face, planar face, vertex, point, arc, or line entities.
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Figure 11-54  Faces to be selected to create explode line sketch

2. Choose the Keep Visible button from the Route Line PropertyManager if it is not chosen
automatically to keep it visible on the screen.

3. Select the cylindrical face as shown in Figure 11-54 as the first selection. The name of the
selected face will be displayed in the Items To Connect display area. The preview of the
explode line sketch is displayed at the center of the selected face.

4. Refer to Figure 11-54 and select the cylinderical faces to create the explode line sketch.

Figure 11-53  Final assembly
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5. After selecting all the faces, choose the OK button. An exploded line will be created.

Similarly, create the explode lines to connect the other parts of the assembly. Figure 11-55
shows the assembly after adding the explode line sketch.

6. Invoke the ConfigurationManager and expand the Default option. Select ExplView1
and invoke the shortcut menu. Choose the Collapse option from the shortcut menu to
switch back to the collapse state of the assembly.

7. Save the assembly.

Tutorial 2
In this tutorial you will modify the assembly created in Tutorial 1 (Bench vice) of Chapter 10,
Assembly Modeling-I. You will modify the design of the components of the assembly and then
suppress some mates that enable the assembly to move along a particular degree of freedom.
After that you will check the assembly for collision detection when the assembly is in motion
and then you will modify the assembly and check the interference.           (Expected time: 1 hr)

The steps that will be followed to complete this tutorial are discussed next:

a. Save the Bench Vice assembly directory in c11 directory and then open the Bench Vice
assembly.

b. Modify the design of the components within the context of assembly.
c. Suppress the mate to enable the vice jaw to move along the slide ways of the vice jaw.
d. Check the new assembly design for collision detection when the assembly is in motion.

Modify the design if there is any collision between the components.
e. Check the interference in the modified assembly.

Figure 11-55  Explode line sketch added to the exploded state of the assembly
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Opening the Bench Vice Assembly
The assembly created in the Tutorial 1 of Chapter 10 is the Bench vice assembly; You
need to copy and save that assembly in the current directory of Chapter 11.

1. Copy the directory in which the Bench vice assembly is saved and then paste it in the c11
directory.

2. Invoke the Open dialog box and browse the Bench Vice assembly document. Double-click
on it to open the assembly document.

Modifying the Design of the Components of Bench Vice Assembly
Because of some alteration in the design of some of the components of the assembly, you
need to modify the components of the assembly. You will modify and edit the components
in the context of assembly.

Before you start modifying the components, it is recommended that you hide some of the
components to simplify the assembly. Hiding the components will simplify the assembly
and facilitate in selection while editing and modifying the components.

1. Hold down the CTRL key from the keyboard and select the Clamping Plate, Base Plate,
Set Screw 1, Set Screw 2, Oval Fillister, Screw Bar, and Jaw Screw from the FeatureManager
Design Tree.

2. Invoke the shortcut menu and choose the Hide components option from the shortcut
menu.

The selected components are hidden and are not displayed in the assembly document.

With the design alteration, you need to create a through slot on the right face of the Vice
Jaw. For modifying the design of the Vice Jaw, first you need to enable the part editing
environment.

3. Select the Vice Jaw from the assembly and then choose the Edit Part button from
the Assembly toolbar. The part modeling environment is invoked in the assembly
document and the Vice Body is displayed in transparent as shown in Figure 11-56.

4. Select the right face of the Vice jaw and invoke the sketching environment.

5. Create the sketch of the slot as shown in Figure 11-57.

6. Choose Insert > Cut > Extrude from the menu bar. The Cut-Extrude PropertyManager
is displayed.

7. Create the cut feature using the Through All option.

8. Choose the Edit Part button to exit the edit part environment.
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Figure 11-58 shows the assembly after modifying the design of the Vice jaw.

9. Similarly modify the design of the Vice body. You need to create an extruded boss feature
on the right face of the component.

Figure 11-56  Vice Jaw in the part edit mode in the assembly document

Figure 11-57  Sketch of the slot
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Figure 11-58  Modified Vice Jaw

Figure 11-59  Sketch of the extruded boss feature Figure 11-60  Modified assembly

The sketch of the feature is shown in Figure 11-59. You need to extrude the sketch to a
distance of 60. Figure 11-60 shows the assembly after exiting the edit part environment.

10. Choose the Save button from the Standard toolbar. The SolidWorks information box is
displayed and you are informed that some models referenced in the document are modified
and they must be saved. Choose Yes to save the referenced models also.

Suppressing the Mate to Make the Movement of Vice jaw Free in a
Specified Direction

To analyze the movement of the Bench vice assembly, you need to make the movement of
the Vice jaw free in the X direction. By doing so the Vice Jaw will slide on the sideways of
the Vice body.
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1. Expand the Mates mategroup from the FeatureManager Design Tree and select Distance1
mate. The planar faces of the Vice jaw and the Vice body are highlighted in green because
this mate is applied to these faces.

2. Select this mate and invoke the shortcut menu. Choose the Suppress option from the
shortcut menu.

Now, the degree of freedom in the X direction is free.

3. Choose the Move button from the Assembly toolbar and select a horizontal edge of the
Vice jaw. When you drag the cursor, you will observe that you can move the Vice jaw in the
X direction.

4. Drag the Vice jaw back to its original position.

Analyzing the Collision Between the Components When the
Assembly is in Motion
Next, you will analyze the collision between the components of the assembly when the assembly
is in motion.

1. Choose the Move Component button from the Assembly toolbar. The Move
Component PropertyManager is displayed. Select the Collision Detection radio
button from the Options rollout.

2. Select Vice jaw and drag the cursor to move it in the direction as shown in Figure 11-61.

3. When you move the Vice jaw in the specified direction, you will observe that the right face
of the Vice jaw and the extrusion feature of the Vice body are highlighted in green as
shown in Figure 11-62.

Figure 11-61  Direction in which the Vice jaw will be moved
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Figure 11-62  Faces of the Vice jaw and the Vice body highlighted in green

This indicates that the Vice jaw collides with the Vice body. Leave the assembly at this
location.

4. Choose the OK button from the Move Component PropertyManager.

Since the collision is detected in the assembly, you need to modify the design of one of
the components. In this case, you will modify the dimensions of the extruded boss feature.

5. Double-click the newly created extruded boss feature of the Vice body. The dimensions of
the newly created feature will be displayed.

6. Double-click the dimension that has a of value 6; the Modify dialog box is displayed; set
the value of the dimension to 4 and choose the ENTER key.

7. Press CTRL+B to rebuild the assembly.

8. Choose Tools > Interference Detection from the menu bar. The Interference Volumes
dialog box is displayed. Choose the Check button from the Interference Volumes dialog
box.

9. You will observe that 0 Interference is displayed in the Interference results display area.

10. Choose the Close button from the Interference Volumes dialog box.

Next, you need to need to unhide all the components.

11. Hold the CTRL key and select the hidden components from the FeatureManager Design
Tree and invoke the shortcut menu. Choose the Show components option from the
shortcut menu.
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12. Save the assembly document and all the referenced part documents.

SELF-EVALUATION TEST
Answer the following questions and then compare your answers with the answers given at
the end of this chapter.

1. You can create subassemblies in the assembly environment of SolidWorks. (T/F)

2. You cannot create a subassembly of the components that are already placed in an assembly
file.  (T/F)

3. When you move the cursor on a mate in the FeatureManager Design Tree, the entities
used in the mate are highlighted in red color in the drawing area. (T/F)

4. You cannot edit the assembly mates. (T/F)

5. While in the part editing mode in the assembly document, you can use the Move/Size
Features tool to edit the features dynamically using editing handles. (T/F)

6. The component patterns created individually without the use of any existing pattern
feature are known as __________ pattern.

7. The component patterns created using an existing pattern feature are known as __________
pattern.

8. In __________ component, the feature information is available in the part document and
only the graphical representation of the component is displayed in the assembly document.

9. After selecting the component, choose the _________ option from the shortcut menu to
change the transparency condition of the selected component.

10. To create the explode line sketch, choose the __________ button from the Drawing toolbar.

REVIEW QUESTIONS
Answer the following questions:

1. When you select the component and invoke the shortcut menu and choose the Open
“part name” from the shortcut menu, which option is used to edit a component separately
in its part document?

(a) Modify “part name” (b) Edit “part name”
(c) Open “part name” (d) None of these
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2. Which option is used to define whether a component collides with another component of
the assembly or not?

(a) Collision Detection (b) Interference Detection
(c) Mass Properties (d) None of these

3. Which check box is selected in the Open dialog box to open an assembly with light
weight parts?

(a) Lightweight (b) Open Lightweight
(c) Lightweight parts (d) Lightweight assembly

4. Which button available in the Assembly toolbar is used to suppress a component?

(a) Change Suppression State (b) Suppress
(c) Hide/Show Component (d) Move Component

5. Which option is used to select the component placed partially inside and partially outside
the assembly envelope?

(a) Inside Envelope (b) Outside Envelope
(c) Crossing Envelope (d) None of these

6. The __________ radio button is used to create a local linear pattern.

7. To unhide the hidden component, select the icon of the component from the
FeatureManager Design Tree and invoke the shortcut menu. Choose the __________
option from the shortcut menu.

8. The __________ option is used to pattern the instances of the components using an existing
pattern feature.

9. The explode state of the assembly is created using the ___________ dialog box.

10. The __________ check box is selected to stop the motion of the assembly when one of the
component collides with another component when the assembly is in motion.

EXERCISE

Exercise 1
Create the assembly as shown in Figure 11-63. Make sure that when you create this assembly,
the back plate should be fixed and the entire assembly can move in the Y direction with
respect to the back plate. Keep the rotational degree of freedom of the screw rod free so that
it can also rotate on its axis. After creating the assembly you need to explode the assembly
and create the explode line sketch. The exploded view of the assembly with explode line
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sketch is shown in Figure 11-64. The dimensions of the model are given in Figures 11-65
thought 11-69.                                  (Expected time: 4 hrs)

Figure 11-64  Exploded view of the Shaper tool holder assembly with explode lines

Figure 11-63  Shaper tool holder assembly
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Figure 11-65  Views and dimensions of Back Plate
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Figure 11-66  Views and dimensions of Vertical Slide
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Figure 11-67  Views and dimensions of Swivel Plate
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Figure 11-68  Views and dimensions of the components
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Figure 11-69  Views and dimensions of the components

Answers to Self-Evaluation Test
1. T, 2. F, 3. T, 4. F, 5. F, 6. Local, 7. Derived, 8. Lightweight, 9. Component Properties, 10.
Explode Line Sketch
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