
Chapter 10

Assembly Modeling-I

After completing this chapter you will be able to:
• Create Bottom-up Assemblies.
• Add the Mates to the Assemblies.
• Create Top-down Assemblies.
• Move the Individual Components.
• Rotate the Individual Components.

Learning Objectives
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ASSEMBLY MODELING
An assembly design is defined as a design consisting of two or more components assembled
together at their respective work positions. The components are assembled together in the
Assembly mode using parametric relations. In SolidWorks, these relations are called mates.
These mates allow you to constrain the degrees of freedom of the components on their
respective work positions. To proceed to the Assembly mode of SolidWorks, invoke the New
SolidWorks Document dialog box and select the Assembly template from the Templates tab
as shown in Figure 10-1. Choose the OK button to create a new assembly document.

The assembly environment will be activated. The screen display of SolidWorks in the
Assembly mode is shown in Figure 10-2. The Assembly toolbar is also invoked as displayed
in Figure 10-2.

Note
When you invoke the Assembly mode, you will notice that some of the options in the Assembly
toolbar are not available. All these options will be available once you insert a component or
create a component in the assembly file.

Types of Assembly Design Approach
In SolidWorks, the assemblies are created using two types of design approaches. The first
design approach is the bottom-up approach, and the second design approach is the top-down
approach. Both these design approaches are discussed next.

Figure 10-1  The New SolidWorks Document dialog box
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Figure 10-2  Screen display in the Assembly mode

Bottom-up Assembly Design Approach
The bottom-up assembly design approach is the traditional and the most widely preferred
approach of assembly design. In this assembly design approach, all the components are created
as separate part files and these parts are placed and referenced in the assembly as external
components. In this type of approach, the components are created in the Part mode as (.sldprt)
file. After creating all the components of the assembly, you will open an assembly file (.sldasm)
and insert all the components using the tools provided in the Assembly mode. After inserting
the components, they are assembled using the assembly mates.

The main advantage of this assembly design approach is that as the components are designed
individually, you can maintain the relationships between the features easily. Hence, this
approach allows you to pay more attention and to focus more on the individual components.
This approach is preferred while handling large assemblies.

Top-down Assembly Design Approach
In the top-down assembly design approach, all the components are created in the same
assembly file. Therefore, the top-down assembly design approach is entirely different from
the bottom-up design approach. In this approach you will start your work in the assembly file
and the geometry of one part helps you to define the geometry of the other.
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Note
You can also create an assembly with a combination of the bottom-up and the top-down assembly
approaches.

CREATING BOTTOM-UP ASSEMBLIES
As mentioned earlier, the bottom-up assemblies are the assemblies in which, the components
are created as separate part files in the Part mode. After creating the components, they are
inserted in the assembly and then assembled using the assembly mates. For starting an assembly
design with this approach, you need to insert the first component in the assembly. It is
recommended that the first component should be placed at the origin of the assembly file.
The default planes of the assembly and the part will coincide and the component will be in
the same orientation. When you place the first component in the assembly, that component is
fixed at its placement position. The techniques used to place the components in the assembly
file are discussed next.

Placing Components in the Assembly File
In SolidWorks, there are various options to place the components in the assembly. These
options are discussed next.

Placing the Components Using the Open     Dialog Box

The first method of placing the components in the assembly is using the Open dialog box. To
insert a component, choose Insert > Component > From File from the menu bar. The Open
dialog box is displayed; browse the location where the component is saved. Select the
component and choose the Open button. The cursor is replaced by the component cursor
and you are prompted to select a point in the assembly view to place the component. It is
recommended that the origin of the first component should be aligned with the assembly
origin. Sometimes the assembly origin is not displayed in the drawing area. Therefore, you
need to choose View > Origins from the menu bar to display the origin. Move the cursor to
the assembly origin in the drawing area. A symbol appears below the component cursor. This
symbol implies that the origin of the component is coincident with the assembly origin. Press
the left mouse button to place the component.

To place the second component, choose Insert > Component > From File from the menu
bar. Select the component from the Open dialog box. You are again prompted to select a

Menu: Insert > Component > From File

Tip. Only the information about the mates is stored in the assembly file. The feature
information of the parts is stored in the individual part files. Therefore, the size of
the assembly file is small.

It is recommended that all the parts of an assembly be saved in the same directory in
which the assembly is saved. This is because if the location of the parts is changed,
the component will not be displayed in the assembly and assembly file will show
errors.
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point in the assembly view to place the component. Select a point anywhere in the drawing
area to place the second component. Similarly, place the remaining components in the assembly.

Placing the Components Using the Opened Document Window
The second and the most widely used method of adding the components in the assembly is
using the existing opened document windows. For example, the assembly that you are going
to create consists of three components. Open the part documents of all the parts in the
SolidWorks window and create a new assembly document. Now, choose Window > Tile
Horizontally or Tile Vertically from the menu bar. All the SolidWorks document windows
will be tilled vertically or horizontally, depending on the option selected. You first need to
place the first component in the assembly and this need to be placed at the origin of the
assembly. Move the select cursor on the name of the first component to be placed in the
FeatureManager Design Tree of the window of that component. Press and hold down the left
mouse button at this location. Drag the cursor to the assembly origin in the assembly window.
When the coincident symbol appears below the component cursor, place the component in
the assembly. Similarly, place the other components in the assembly. Figure 10-3 displays
placing a first component from an existing opened document window to the assembly document
window. If another existing assembly document is opened, you can also drag and drop the
part from that assembly document.

Figure 10-3  Placing a component in the assembly file from an existing window
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Placing the Components by Dragging from Windows Explorer
You can also place the components in the assembly file by dragging them from Windows
Explorer. Open Windows Explorer and browse the location where the part documents are
saved. Tile the Windows Explorer window and the SolidWorks window such that you can view
both the windows. Move the cursor on the icon of the part document in Windows Explorer.
Press and hold down the left mouse button and drag the cursor to the assembly document
window. Drop the part in the assembly document. Similarly, place the other parts by dragging
from Windows Explorer and dropping them in the assembly document. When you place the
components using this method, the part origin will not coincide with the assembly origin. You
need to manually add the constraint to coincide the origin of the part with the assembly
origin. Figure 10-4 shows the part being dropped in the assembly window.

Placing the Components from Internet Explorer
You can also place the components from Internet Explorer. For placing the components from
Internet Explorer, you need Internet Explorer 4.0 or later. Browse the location of the
SolidWorks part file link on the Web. Drag the hyperlink and drop it in the drawing area of
the assembly document. The Save As dialog box will be displayed; save the part document at
the desired location.

Placing the Additional Instances of Existing Component in the
Assembly
Sometimes, you need more than one instance of the component to be placed in the assembly
document. Press and hold down the CTRL key from the keyboard. Select the component in
the assembly file and drag the cursor to the location where you want to place the instance of
the selected component. Release the left mouse button to drop the new instance of the
component. Similarly, you can place as many instances of the existing component as you want
by following the above-mentioned procedure.

Tip. When you place the first component in the assembly, the component is displayed
in the FeatureManager Design Tree. The nomenclature of the name of the first
component is displayed as (f) Name of Component <1>. In this nomenclature
(f) implies that the component is fixed. You cannot move a fixed component. You
will learn more about fixed and floating components later in this chapter. After this
the name of the component is displayed. After the name of the component, <1>
symbol is displayed. This implies the serial number of the same component in the
assembly.

The (-) symbol implies the component is floating and is under defined. And you
need to apply the required constraints to that component to fully define the component.
You will learn more about constraints later in this chapter.

The (+) symbol implies that the component is fully defined.

If no symbol appears before the name of the component, the component is fully
defined.
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Figure 10-4  Dropping the part in the assembly window

Placing the Component Using the Feature Pallet Window
You can also place a component in the assembly file from the Feature Pallet window. If you
have saved components in the Feature Pallet window, you can place that component by
dragging and dropping from this window. Feature Pallet window is invoked by choosing
Insert > Feature Pallet from the menu bar. You will learn more about the Feature Pallet
window in later chapters.

Assembling the Components
After placing the components in the assembly document, you need to assemble them. By
assembling the components, you will constrain the degree of freedom of the components. As
mentioned earlier, the components are assembled using the mates. Mates help you to precisely
place and position the component with respect to the other components and the surroundings
in the assembly. You can also define the linear and rotatory movement of the component with
respect to the other components. In addition, you can create a dynamic mechanism and
check the stability of the mechanism by precisely defining the combination of mates. There
are two methods of adding mates to the assembly. The first method is using the
Mate PropertyManager. The second and the most widely used method of adding the mates
to the assembly is Smart Mates. Both methods are discussed next.
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Assembling Components Using the Mate PropertyManager

In SolidWorks, the mates can be applied using the Mate PropertyManager. Choose
the Mate button available in the Assembly toolbar or choose Insert > Mate from the
menu bar. The Mate PropertyManager is invoked as shown in Figure 10-5. You are

prompted to select two entities to be mated.

Select a planar face, curved face, axis, or point on the first component and then select the
entity from the second component. The selected entities will be highlighted in green. The
names of the selected entities are displayed in the Entities to Mate display area. The most
suitable mates to be applied to the current selection set are displayed in the Mate Settings
rollout of the Mate PropertyManager. The most appropriate mate will be selected by default.
You can select the mates from the given list of the most appropriate mates. After selecting the
button of the required mate choose the preview button to view the effect of the mate applied.
Choose the OK button to apply the selected mate. The various types of mates that can be
applied are discussed next.

Toolbar: Assembly > Mate
Menu: Insert > Mate

Figure 10-5  The Mate PropertyManager

Tip. If you choose the Keep Visible button from the Mate PropertyManager, the
Mate PropertyManager will not disappear after you select the OK button.
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Figure 10-6  Table displaying the combinations for applying Coincident mate

Coincident
The Coincident mate is generally applied to make the two planar faces coplanar.
But you can also apply the Coincident mate to other entities. The details of the
geometries on which the Coincident mate can be applied is shown in Figure 10-6.

When you choose the Coincident button from the Mate Settings rollout, the Closest
radio button is selected by default. This radio button automatically orients the model in
the aligned or anti-aligned direction, depending on the current orientation of the model.
Choose the Preview button to display the preview of the coincident mate on the selected
entities. The Anti-Aligned or the Aligned radio button will be selected automatically
depending on the orientation of the model after applying the Coincindent mate.
Figure 10-7 displays the faces to be selected to apply the coincident mate. Figure 10-8
shows the resultant mate applied with the default option, that is, Anti-Aligned selected.
Figure 10-9 shows the coincident mate applied with the Aligned radio button selected.

Concentric
The Concentric mate is generally used to align the central axis of one component
with the central axis of the other. You generally need to select the circular faces to
apply the concentric mate. You can also apply the Concentric mate between a

point and a circular face or edge. The other combinations of applying the Concentric

c10-solidworks-2003.p65 5/12/2003, 12:01 PM9



10-10 SolidWorks for Designers

Figure 10-7  Faces to be selected

Figure 10-8  Coincident mate applied with the
Anti-Aligned radio button selected

Figure 10-9  Coincident mate applied with the
Aligned radio button selected

mate are displayed in the table given in Figure 10-10. For applying a Concentric mate,
invoke the Mate PropertyManager. Select the two entities from two different components.
The names of the selected entities will be displayed in the Entities to Mate display area. The
Concentric button will be chosen in the Mate Settings rollout. If the Concentric button
is not chosen by default, you need to manually select this button. Choose the Preview
button from the Mate Settings rollout. You can toggle between the Aligned and
Anti-Aligned radio button according to the requirement. Choose the OK button from
the Mate PropertyManager.
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Figure 10-10  Table displaying the combinations for applying Concentric mate

Figure 10-11  Faces to be selected

Figure 10-11 shows the faces to be selected to apply the concentric mate. Figure 10-12
shows the concentric mate applied with the Aligned radio button selected. Figure 10-13
shows the concentric mate applied with the Anti-Aligned radio button selected.
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Figure 10-12  Concentric mate applied with the
Aligned radio button selected

Figure 10-13  Concentric mate applied with the
Anti-Aligned radio button selected

Figure 10-14  Table displaying the combinations for applying Distance mate

Distance
The Distance button is chosen to apply the Distance mate between the
components. To apply the Distance mate, invoke the Mate PropertyManager
and select the entities from both the components. Choose the Distance button

from the Mate Settings rollout. Set the value of the distance in the Distance spinner.
Choose the Preview button to display the preview of the Distance mate. If needed,
toggle between the Aligned radio button and the Anti-Aligned radio button. Figure 10-14
shows the combinations of components to apply the distance mate. Figure 10-15 shows
the faces to be selected. Figure 10-16 shows the Distance mate applied between two
components. You can also toggle between the Aligned and Anti-Aligned options.
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Figure 10-15  Concentric mate applied with the
Aligned radio button selected

Figure 10-16  Concentric mate applied with the
Anti-Aligned radio button selected

Figure 10-17  Table displaying the combinations for applying Angle mate

Angle
The Angle button is used to apply the Angle mate between two components. The
Angle mate is used to specify the angular position between the selected plane,
planar face, or edges of two components. To apply this mate, invoke the Mate

PropertyManager and select the entities from two components. Choose the Angle button
from the Mate Settings rollout. The Angle spinner is invoked and you can set the value of
the angle in this spinner. Choose the Preview button to preview the Angle mate applied
to the selected entities. You can also toggle between the Aligned radio button and the
Anti-Aligned radio button. Choose the OK button from the Mate PropertyManager.
Figure 10-17 shows the table of combinations for applying the angle mate.
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Figure 10-18 shows the faces to be selected to apply the angular mate. Figure 10-19 shows
the assembly after applying the Angular mate with the angle value of 90º.

Parallel
The Parallel button available in the Mate Settings rollout is used to apply the
Parallel mate between the two components. To apply the Parallel mate, invoke
the Mate PropertyManager and select the two entities from the two components.

Choose the Parallel button to apply the mate constraint. You can also toggle between the
Align radio button and the Anti-Aligned radio button. Choose the OK button from the
Mate PropertyManager. Figure 10-20 shows the combination of components on which
you can apply the Parallel mate. Figure 10-21 shows the entities to be selected to apply
the Parallel mate. Figure 10-22 shows the assembly after applying the parallel mate.

Figure 10-18  Face to be selected to apply the
angle mate

Figure 10-19  Assembly after applying the angle
mate
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Figure 10-20  Table displaying the combinations for applying Parallel mate

Figure 10-21  Entities to be selected to apply the
parallel mate

Figure 10-22  Assembly after applying the parallel
mate
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Figure 10-23  Entities and the plane to be selected
to apply the symmetric mate

Figure 10-24  Assembly after applying the
symmetric mate

Symmetric
The Symmetric button available in the Mate Settings rollout is used to apply the
Symmetric mate between two components. Using this mate, a symmetric relation
is applied between two components. To apply the Symmetric mate, invoke the

Mate PropertyManager. Next, you need to select a plane or a planar face as a symmetry
plane. The Symmetry Plane callout is attached to the symmetry plane. Now, select two
entities from two components. You can select edges, vertices, planar faces, or planes.
The Symmetric button will be selected in the Mate Settings rollout. Choose the Preview
button to preview the Symmetric mate applied to the assembly. Choose the OK button
from the Symmetric PropertyManager. Figure 10-23 shows the entities and the plane to
be selected to apply the Symmetric mate. Figure 10-24 shows Symmetric mate applied
to the assembly.

Perpendicular
The Perpendicular button available in the Mate Settings rollout is used to apply
the Perpendicular mate between two components. Invoke the Mate
PropertyManager and select two entities from two components. Choose the

Perpendicular button from the Mate Settings rollout. You can also toggle between the
Aligned radio button and the Anti-Aligned radio button. Choose the OK button from
the Mate PropertyManager. Figure 10-25 shows the table displaying the combinations
for applying the Perpendicular mate. Figure 10-26 shows the entities to be selected.
Figure 10-27 shows the Perpendicular mate applied to the assembly.
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Figure 10-25  Table displaying the combinations for applying Perpendicular mate

Figure 10-26  Entities to be selected to apply the
perpendicular mate

Figure 10-27  Assembly after applying the
perpendicular mate
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Figure 10-29  Entities to be selected to apply the
tangent mate

Figure 10-30  Assembly after applying the
tangent mate

Tangent
The Tangent button available in the Mate Settings rollout is used to apply the
Tangent mate between the two components. Figure 10-28 shows the table
displaying the combination for applying the tangent mate. Figure 10-29 shows

the entities to be selected to apply the tangent mate. Figure 10-30 shows the tangent
mate applied to the assembly.

Figure 10-28  Table displaying the combinations for applying Tangent mate
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Assembling Components Using Smart Mates

The Smart Mates is the most attractive feature of the assembly design environment
of SolidWorks. The Smart Mates technology is the patent of SolidWorks Corporation.
This also speeds up the design process in the assembly environment of SolidWorks.

To add smart mates to the components that are placed in the assembly, choose the Smart
Mates button from the Assembly toolbar. The SmartMates PropertyManager is displayed as
shown in Figure 10-31.

The select cursor is replaced by the move cursor. The SmartMates button is chosen by default
in the Move rollout. You need to double-click the entity of the first component to add a mate.
The component will be displayed in transparent. The cursor will be replaced by the smart
mates cursor. Press and hold down the left mouse button on the selected entity and drag the
cursor to the entity with which you want to mate the previously selected entity. The symbol of
the constraint that can be applied between two entities will be displayed below the smart
mates cursor. You can use the TAB key to toggle between the aligned and the anti-aligned
option while applying Smart Mates. When the symbol of the mate is displayed below the
cursor, release the left mouse button. Figure 10-32 shows the face to be selected to apply
smart mate. Figure 10-33 shows the component being dragged.

Toolbar: Assembly > SmartMates

Figure 10-31  The SmartMates PropertyManager
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Figure 10-32  Face to be selected to apply smart
mate

Figure 10-33  Component being dragged to apply
smart mate

Figure 10-34  Concentric symbol appears below the smart mates
cursor

Figure 10-34 shows that the coincident symbol appears below the smart mates cursor when
the cursor is placed near a circular face of the other component.

Figure 10-35 shows a planar face selected to apply smart mate. You can use the TAB key to
toggle between the aligned and anti-aligned mates. Figure 10-36 shows that the concentric
symbol appears below the cursor after the component being dragged. Figure 10-37 shows the
assembly after applying coincident mate using the smart mate.

Note
You cannot define a Distance mate using smart mates. In other words, you cannot give an
offset distance between two mating surfaces using smart mates.
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Figure 10-35  Planar face to be selected to apply
a mate using smart mates

Figure 10-36  Coincident symbol appears after
dragging the component near another planar face

Figure 10-37  Coincident mate applied to the assembly using smart
mates

Tip. You can also add smart mates without dragging the component. To add a
smart mate without dragging, choose the Smart Mates button from the Assembly
toolbar. Double-click the entity from the first component. The component will be
displayed in transparent. Now, select the entity from the second component. The
most appropriate mate will be applied between the two components.

Note
When you drag a component for applying a smart mate, the selected entity of the first component
will snap all the corresponding entities of the second component. You can press the ALT key from
the keyboard to exit the snap. To again enter the snap mode press the ALT key from the key board.

c10-solidworks-2003.p65 5/12/2003, 12:02 PM21



10-22 SolidWorks for Designers

Tip. You can add the geometry-based mates between two linear edges, two planar
faces, two vertices, two conical faces, two axes, between an axis and a conical face,
and between two circular edges.

Geometry-Based Mates
In the assembly design environment of SolidWorks, you can also add geometry-based mates.
Geometry-based mates are also a type of smart mates, and are applied while you are placing
a component in the assembly environment. Consider a case in which the first component is
already placed in the assembly environment. Now, open the part document of the second
component. Choose Window > Tile Horizontal or Tile Vertical from the menu manager.

Suppose, you need to insert the revolved feature of the second component in the circular slot
of the first component. Also, the same time you also need to align the larger bottom face of
the second component with the upper face of the first component. Press and hold down the
left mouse button on the edge of the second component as shown in Figure 10-38. Drag the
cursor to the assembly window near the upper edge of the circular slot of the first component.
The second component mated with the first component will be displayed in temporary graphics
as shown in Figure 10-39. The coincident symbol is also displayed below the smart mates
cursor. You can also toggle the direction of placement of the component. Figure 10-40 shows
that the direction of placement is flipped using the TAB key. Again press the TAB key to
return to the default direction. Release the left mouse button to place the component. If you
expand the Mates option from the FeatureManager Design Tree, you will notice that two
mates are applied to the assembly. One is the coincident mate and the second is the concentric
mate. Figure 10-41 shows the assembly after adding the geometry-based smart mates.

Feature-Based Mates
In the assembly design environment of SolidWorks, you can also add feature-based mates. For
adding feature-based mates, one of the feature of first component must be a circular base or

Figure 10-38  Edge of the second component to be
selected.

Figure 10-39  Component being dragged into
the assembly window for applying geometry-based
mates
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Figure 10-40  The placement direction of
component is flipped using the TAB key

Figure 10-41  Assembly after adding a
geometry-based mate

boss feature and the second component must have a hole or a circular cut feature. The feature
can be an extruded or a revolved feature. In the assembly document one of the feature must
be placed earlier. Open the part document of the component to be placed using feature-based
mates. Tile both the document windows horizontally or vertically. In the FeatureManager
Design Tree of the part document select the extruded or revolved feature and drag it to the
assembly window. Place the cursor at a location where you need to place the component. The
mate symbol will be displayed below the cursor. The preview of the part mates with the second
component will be displayed in temporary graphics. You can also change the alignment or
direction of placement using the TAB key. Release the left mouse button to drop the component.
Figure 10-42 shows the component being dragged by selecting the revolved feature from the
FeatureManager Design Tree of part document. Figure 10-43 shows the preview of the
component being inserted into the hole of the second component using feature-based mates.
Figure 10-44 shows the component assembled using feature-based mates.

Pattern-Based Mates
Pattern-based mates are used to assemble the components that have a circular pattern created
on the circular feature. The best example of this type of component is the flange or a shaft
coupling. Remember that to create pattern-based mates, all the components that will
be assembled must have a circular pattern on the mating faces. To create pattern-based mates,
select the outer edge of the second component and drag it to the circular edge of the first
component that is already placed in the assembly document. The preview of the component

Tip. Feature-based mates are applied only to the components having cylindrical or
conical features. You cannot add feature-based mates using features other than
cylindrical or conical geometry. If you are adding feature-based mates to a component
having a conical face, the second component must have a conical face. You cannot
add a feature-based mate if the geometry of the feature of one component is cylindrical
and that of the second component is conical.

If you are adding feature-based mates using the features having conical geometry,
there must be a planar face adjacent to the conical face of both features.
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Figure 10-42  Component being dragged by selecting the revolved feature

Figure 10-43  Preview of the component being
inserted using feature-based mates

Figure 10-44  Component assembled using
feature-based mates

assembled with the first component will be displayed. Using the TAB key you can switch the
part with respect to the pattern instances. Release the left mouse button to drop the part.
Figure 10-45 shows the component being dragged to the assembly document window.
Figure 10-46 shows the preview of the component being assembled. Figure 10-47 shows the
component assembled using pattern-based mates.

Assembling Components Using Mate Reference
In SolidWorks you can define the mate reference to the Part in the part mode or in the
Assembly mode. The mate references allow you to define the mating references such as
planar surfaces, axis, edges, and so on before assembling the component.

If is recommended that the mate reference should be added to the component in the Part
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Figure 10-45  Component being dragged into the assembly document

Figure 10-46  Preview of the component being
assembled using pattern-based mates

Figure 10-47  Component assembled using
pattern-based mates

mode. The mate references are created using the Mate Reference PropertyManager. The
Mate Reference PropertyManager is invoked by choosing Insert > Mate Reference from
the menu bar. The Mate Reference PropertyManager is shown in Figure 10-48.

The Mate Reference Name edit box is used to define the name of the mate reference. The
Primary Reference Entity rollout is used to define the primary mate reference. The Mate
Reference Type drop-down list is used to define the type of mate. The Mate Reference
Alignment drop-down list is used to define the type of alignment.

The Secondary Reference Entity rollout is used to define the secondary mate reference. The
Tertiary Reference Entity rollout is used to define the tertiary mate reference.

To assemble a component using the mate reference, you need to define the mate reference to
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both the components. The names of the mate reference should be the same for both the
components. After defining mate references to both the components, you need to place the
first component coincident with the origin in the assembly document. Now, drag the second
component and you will notice that the second component is aligned to the references that
were defined as mate references. Therefore, you do not need to apply mates in the assembly
environment.

CREATING THE TOP-DOWN ASSEMBLIES
As mentioned earlier, top-down assemblies are the assemblies in which all the components
are created in the same assembly file. However, to create the components, you require an
environment in which you can draw the sketches or the sketched features and the environment
where you can convert the sketches into features. In other words, you can say that to create the
components in the assembly file you need a sketcher environment as well as a part modeling
environment in the assembly file. In SolidWorks, you can invoke the sketcher environment
and the part modeling environment in the assembly document itself. The basic procedure to
create the components in the assembly or in other words to create the top-down assembly is
discussed next.

Figure 10-48  The Mate Reference PropertyManager
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Creating the Component in the Top-Down Assembly
Before creating the first component in the top-down assembly, you first need to save the
assembly document. After creating a new assembly document, choose the Save button from
the Standard toolbar to save the assembly file. It is recommended that you create a new folder
and save the assembly file and the other referenced file in the same folder.

Now, choose Insert > Component > New Part from the menu bar. The Save As dialog box is
displayed and you need to specify the name and location to save the new component. Enter
the name of the new component in the File name edit box and choose the Save button. The
select cursor will be replaced by the new component cursor. Now, you need to place the new
component in the assembly document. Using the left mouse button place the component on
either one of the three default assembly planes displayed in the FeatureManager Design
Tree. The plane on which you place the component is selected as the sketching plane and the
sketcher environment is invoked automatically. You will notice that the Edit Part button available
in the Assembly  toolbar  is selected. This means that the part modeling environment is
invoked in the assembly document. You can draw the sketch of the base feature in the
current sketching environment or you can also exit the sketching environment and select any
other sketching plane to create the sketch. After creating the sketch of the base feature, exit
the sketching environment. Now, as the Features toolbar is not available by default in the
sketching environment, you need to invoke it. Use the tools in the Features toolbar to convert
the sketch into a model. Similarly, create the remaining features in the model.

After creating all the features, choose the Edit Part button from the Assembly toolbar to exit
the part modeling environment. The newly created component will have an Inplace mate
with the default assembly plane on which it was placed earlier. Therefore, the newly created
component is fixed. Using the procedure mentioned above, create other components.

Whenever you create a component in a top-down assembly, the component is fixed using the
Inplace mate. You can also delete this mate by selecting the Inplace mate by expanding the
Mates option available in the FeatureManager Design Tree. After selecting the mate use the
DELETE key to delete the mate. Now, this component is floating, and you can move this
component. You can also assemble this component according to your requirement. You will
learn more about fixed and floating components later in this chapter.

Note
As discussed earlier, when you place the first component in the assembly in bottom-up assembly
design approach, that component is fixed by default. Therefore, you cannot apply any mates to
a fixed component. If you need to add some mates to that component, you first need to float that

component. Select the component either from the drawing area or from the FeatureManager
Design Tree. Right-click to invoke the shortcut menu and choose the Float option from the
shortcut menu. When you place the components other than the first component, the component
is a floating component by default. If you need to fix that component, select the component and
invoke the shortcut menu. Choose the Fix option from the shortcut menu.

c10-solidworks-2003.p65 5/12/2003, 12:02 PM27



10-28 SolidWorks for Designers

MOVING THE INDIVIDUAL COMPONENTS

SolidWorks allows you to move the individual unconstrained components in the
assembly document without affecting the position and location of the other
components. The Move Component tool is used to move components. Choose the

Move Component button from the Assembly toolbar or choose Tools > Component > Move
from the menu bar. The Move Component PropertyManager is invoked. You will notice that
the Free Drag option is selected in the Move drop-down list. Therefore, you are prompted to
select a component and drag it to move. The select cursor is replaced by the move cursor;
select the component and drag the cursor to move the component. Release the left mouse
button to drop the component on the desired location. The other options available in the
Move drop-down list to move the component are discussed next.

Along Assembly XYZ
Using the Along Assembly XYZ option from the Move drop-down list, you can move the
component dynamically along the X, Y, and Z axis of assembly document. Choose the Along
Assembly XYZ option from the Move drop-down list. An assembly coordinate system in red
color is displayed in the drawing area and you are prompted to select a component and drag
parallel to an assembly axis to move along that axis. Select the component and drag to move
it along any of the assembly axis.

Along Entity
The Along Entity option available in the Move drop-down list is used to move the component
along the direction of the selected entity. When you invoke this option, the Selected item
display area is displayed. You are prompted to select an entity to drag along and then select
a component and drag to move it. Select an entity to define the direction in which you need
to move the component. The name of the selected entity is displayed in the Selected item
display area. Now, select and drag the component to move.

By Delta XYZ
The By Delta XYZ option available in the Move drop-down list is used to move the selected
component to a given distance in a specified direction. When you select this option, the
Delta X, Delta Y, and Delta Z spinners are invoked and you are prompted to select a component
and enter the distance to move in the PropertyManager. Select the component to move and
specify the distance in the spinners in the direction in which you need to move the component.
Choose the Apply button to move the component.

To XYZ Position
The To XYZ Position option is used to specify the coordinates of the origin of the part where
the component will be placed after moving. When you select this option, the X Coordinate,
Y Coordinate, and the Z Coordinate spinners are invoked and you are prompted to select a
component and enter the XYZ coordinates for the part’s origin. Select the component and
enter the coordinates in the spinners and choose the Apply button.

Toolbar: Assembly > Move Component
Menu: Tools > Component > Move
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ROTATING THE INDIVIDUAL COMPONENTS

SolidWorks allows you to rotate the individual unconstrained components in the
assembly document without affecting the position and location of the other
components. The Rotate Component tool is used to rotate component. Choose the

Rotate Component button from the Assembly toolbar or choose Tools > Component >
Rotate from the menu bar. The Rotate Component PropertyManager is invoked. You will
notice that the Free Drag option is selected in the Rotate drop-down list. Therefore, you are
prompted to select a component and drag to rotate it. The select cursor is replaced by the
rotate cursor; select the component and drag the cursor to rotate the component. The other
options available in the Rotate drop-down list to rotate the component are discussed next.

Along Entity
The Along Entity option available in the Rotate drop-down list is used to rotate the component
with respect to the selected entity. The selected entity is defined as the rotational axis. When
you invoke this option, the Selected item display area is displayed and you are prompted to
select an axis entity to rotate about. Select an entity to define the rotational axis. The name of
the selected entity is displayed in the Selected item display area. Now, select and drag the
component around the selected axis.

By Delta XYZ
The By Delta XYZ option available in the Rotate drop-down list is used to rotate the selected
component to a given incremental angle along the specified axis. When you select this option,
the Delta X, Delta Y, and Delta Z spinners are invoked and you are prompted to select a
component and enter the desired rotation in the PropertyManager. Select the component to
rotate and specify the rotation angle in the spinners in the direction in which you need to
rotate the component. Choose the Apply button to rotate the component.

Toolbar: Assembly > Rotate Component
Menu: Tools > Component > Rotate

Tip: You  can toggle between the Move PropertyManager, Rotate
PropertyManager, and the SmartMates PropertyManager. If you invoke the
Move PropertyManager, invoke the Rotate rollout to switch to the Rotate
PropertyManager. If you select the SmartMates button, then the system will
switch you to the SmartMates PropertyManager. From the Rotate or
SmartMates PropertyManager, if you invoke the Move rollout, the system will
switch you to the Move PropertyManager
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TUTORIALS

Tutorial 1
In this tutorial you will create all the components of the Bench Vice and then assemble them.
The bench vice assembly is shown in Figure 10-49. The dimensions of the various components
are given in Figures 10-50 through 10-53.         (Expected time: 2 hrs 45 min)

Figure 10-50  Views and dimensions of the Vice Body

Figure 10-49  Bench Vice assembly
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Figure 10-51  Views and dimensions of Vice Jaw
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Figure 10-52  Views and dimensions of Clamping plate, oval fillister, Set screw 1, and Set screw 2

The steps to be followed to complete the assembly are listed below:

a. Create all the components in individual part documents and save them. The part
documents will be saved in /My Documents/SolidWorks/c10/Bench Vice.

b. Open Vice Body and Vice Jaw part documents and define the mate references in both the
part documents.

c. Create a new assembly document and open all the part documents. Place the first
component, which is Vice Body, by dragging and dropping from the part document window.
Now, drag and drop the Vice Jaw in the assembly document. It will automatically assemble
with the Vice Jaw because the mate references are already defined in both the part
documents, refer to Figures 10-57 and 10- 58.

d. Drag and drop the jaw screw in the assembly document. Apply the required mates, refer
to Figures 10-60 through 10-65.

e. Next, analyze the assembly for degrees of freedom.
f. After analyzing the assembly, apply the required mates to constrain all the degrees of

freedom, refer to Figures 10-66 and 10-67.
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g. Next, assemble the Clamping Plate, refer to Figure 10-69 through Figure 10-71.
h. Next, assemble the Oval Fillister using the feature based mates, refer to Figure 10-72.
i. Similarly, assemble the other components.

Creating the Components
1. Create all the components of the Bench Vice assembly as separate part documents. Specify

the names of the files as shown in Figures 10-50 through 10-53. The files should be saved
in the directory /My Documents/SolidWorks/c10/Bench Vice.

Creating the Mate References
In this tutorial you will assemble the first two components of the assembly using the mate
references. For assembling the components using the mate references, first you need to
create the mate reference. Therefore, you need to open the part documents in which you
will add the mate references.

Figure 10-53  Views and dimensions of Clamping plate, Jaw screw, Screw bar, and Bar globes
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1. Choose the Open button from the Standard toolbar. The Open dialog box is
displayed.

2. Double click the vice body.

The vice-body part document is opened in the SolidWorks window.

3. Choose Insert > Mate Reference from the menu bar.

The Mate Reference PropertyManager is invoked. The selection mode in the Primary
Reference Entity display area is active.

4. Select the planar face shown in Figure 10-54 of the model as the primary reference. The
selected planar face will be highlighted in green.

5. Select the Coincident option from the Mate Reference Type drop-down list.

The selection mode in the Secondary Reference Entity display area is active.

6. Select the planar face shown in Figure 10-54 of the model as the secondary reference.
The selected face will be highlighted in red.

7. Select the Coincident option from the Mate Reference Type drop-down list.

The selection mode in the Tertiary Reference Entity display area is active.

8. Select the planar face of the model shown in Figure 10-54 as the tertiary reference. The
selected face will be highlighted in brown.

Figure 10-54  Faces to be selected as mate references
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Figure 10-55  Faces to be selected as mate references

9. Select the Parallel option from the Mate Reference Type drop-down list.

10. Enter Vice Mate Reference as the name of mate reference in the Mate Reference edit
box available in the Reference Name rollout.

11. Choose the OK button from the Mate Reference PropertyManager.

12. Similarly, create the mate reference in the Vice Jaw part document. The faces to be selected
as reference are displayed in Figure 10-55. The names of the mate references should be
same in both the part documents.

Assembling First Two Components of the Assembly
After creating the mate references to the part documents, you need to assemble the
components. For assembling the components you need to create a new assembly document.
After creating the new assembly document open all the part documents of bench vice
assembly and tile all the documents vertically or horizontally.

1. Create a new assembly document. If the origin is not displayed in the drawing area,
choose View > Origin from the menu bar to display the origin.

2. Open the part documents of Vice Body and Vice Jaw and choose Window > Tile
Horizontal/Vertical.

As discussed earlier, the first component should be placed coincident to the origin of the
assembly document. Therefore, you will drag and drop the first component at the origin
of the assembly.

3. Move the cursor on the name of the vice body part document in the FeatureManager
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Figure 10-56  First component being dropped at the origin of the assembly document

Design Tree and press and hold down the left mouse button.

4. Drag the cursor in the drawing area of the assembly document. Release the left mouse
button to drop the part when the cursor snaps to the origin of the assembly document.

Figure 10-56 shows the part being dropped into the assembly document.

Next, you need to place the second component in the assembly. As discussed earlier, the
second component of the assembly, which is the Vice Jaw, will be assembled with the vice
body using the mate references.

5. Expand the assembly document window. Move the cursor to the title bar of the assembly
document. The cursor will be replaced by the window expand cursor. Drag the cursor to
expand the assembly document window.

6. Move the cursor on the name of the vice jaw part document in the FeatureManager
Design Tree. Press and hold down the right mouse button and drag the cursor to the
assembly document.
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Figure 10-57  Second component being dragged

When you drag the cursor close to the vice body in the assembly document, the preview
of the vice jaw assembled with the vice body is displayed in the assembly document.

7. Drag the component at the required location. The mates specified in the mate references
will be applied between the vice jaw and the vice body.

Figure 10-57 shows the second component being dragged in the assembly document.
Figure 10-58 shows the vice jaw assembled with the vice body.

It is recommended that you close the part documents from which the parts are placed in
the assembly document.

8. Close the part document windows of the parts that are placed in assembly document.

Tip. The mates that are defined in the mate reference are applied to the components
when you place the components in the assembly. You can view the mates applied to
both the components by expanding the Mates option from the FeatureManager
Design Tree of the assembly document.
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Figure 10-58  Vice jaw assembled with the Vice Body

Assembling the Jaw screw
Now, you need to place the Jaw Screw in the assembly document.

1. Open the part file of Jaw Screw and drag and drop the Jaw Screw in the assembly document.

2. Close the part document and maximize the assembly document.

Figure 10-59 shows the Jaw Screw placed arbitrarily in the assembly document. Next, you
need to add the assembly mates to assemble the components placed in the assembly.

3. Choose the SmartMates button from the Assembly toolbar or invoke the shortcut

Figure 10-59  Jaw Screw placed in the assembly document
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Figure 10-60  Face to be selected Figure 10-61  Jaw screw being dragged

Figure 10-62  Concentric mate applied between the Jaw Screw and the Vice Body

menu, and choose the SmartMates option from the shortcut menu. The SamrtMates
PropertyManager is displayed and the select cursor is replaced by the move cursor.

4. Move the cursor to the cylindrical face of the jaw screw as shown in Figure 10-60.
Double-click the face. The jaw screw is displayed as  transparent.

The move cursor is replaced by the smart mates cursor.

5. Hold the Jaw Screw close to the bottom end and drag it to the hole in the vice body as
shown in Figure 10-61. The symbol of concentric mate will be displayed below the cursor.

6. Drop the jaw screw at this location to add a concentric mate between the cylindrical face
of the Jaw Screw and the hole on the Vice Body. Figure 10-62 shows the Jaw Screw assembled
to the Vice Body.
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Figure 10-63  Face to be selected Figure 10-64  Face to be selected

Next, you need apply the coincident mate between the planar faces of the jaw screw and
the vice jaw.

7. Choose the Mate button from the Assembly toolbar to invoke the Mate
PropertyManager. You are prompted to select the entities to be mated.

8. Rotate the model and select the face of the vice jaw as shown in Figure 10-63. Next, select
the face of the jaw screw as shown in Figure 10-64.

As soon as you select the faces, the Coincident button is displayed as selected in the Mate
PropertyManager.

9. Choose the OK button from the Mate PropertyManager. The assembly after adding
the Coincident mate is displayed in Figure 10-65.

In real world, there are two types of assemblies. First one is the fully defined assembly in
which all the degrees of freedom of all components are restricted. The other type of
assemblies are those in which some degrees of freedom of the components are left free so
that they can move or rotate. This type of assemblies are used for mechanism, which you
will learn in the next chapter.

After adding the Coincident mate, you need to move the assembly to analyze the degree
of freedom of  the assembly. After analyzing the assembly you will add the mates to
constrain that degree of freedom.

10. Choose the Move button from the Assembly toolbar. The Move PropertyManager
is displayed.

11. Select the jaw screw from the drawing area and drag the cursor.

You will notice that the jaw screw is rotating on its axis and moving along the X axis. Also,
it is forcing the Vice Jaw to move along the X axis. Originally, this degree of freedom of
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Vice Jaw and Jaw Screw needs to be left free so that the assembly can function. But in this
chapter you will restrict this degree of freedom also to create a fully defined assembly.

12. Invoke the Mate PropertyManager and select the faces shown in Figures 10-66 and 10-67.

13. Choose the Distance button from the Mate Settings rollout and set the Distance spinner
value to 10.

14. Choose the Keep Visible button from the Mate PropertyManager and then choose the
OK button.

15. Invoke the FeatureManager Design Tree flyout and select the Top assembly plane. Now,
expand the jaw-screw from the FeatureManager Design Tree and select the Top plane.

Figure 10-66  Face to be selected Figure 10-67  Face to be selected

Figure 10-65  After applying the coincident mate to the jaw screw
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16. Choose the Angle button from the Mate Settings rollout and set the value of the Angle
spinner to 45.

17. Choose the Keep Visible button and then choose the OK button from the Mate
PropertyManager to close it.

Assembling the Clamping Plate
Now, you need to assemble the Clamping Plate with the assembly.

1. Open the part document of the Clamping Plate and drag and drop it into the assembly
document.

2. Rotate the assembly such that the bottom face of the assembly is displayed as shown in
Figure 10-68.

3. Choose the Rotate button from the Assembly toolbar and select the clamping
plate.

4. Drag the cursor to rotate the clamping plate as shown in Figure 10-69.

5. Apply the Concentric mate between the two cylindrical faces of the clamping plate and
the two holes of the vice jaw, refer to Figure 10-70. You may have to move the Clamping
Plate after applying the first mate.

Figure 10-68  Rotated assembly Figure 10-69  Clamping after rotating

Tip. If you need two or more than two instances of a component in the assembly,
press and hold down the CTRL key and select the component. Now, drag the cursor
and place the instance at a suitable location in the assembly document.

While adding the mates to the assembly, if a component is placed inside another
component or in the assembly, choose the Move button and select the component
from the FeatureManager Design Tree and drag the cursor to move the component.
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Figure 10-71  Faces to be selected to apply mate

Using the Move Component tool, move the Clamping Plate. Now, apply the Coincident
mate between the faces of the clamping plate and the vice jaw as shown in Figure 10-71.

Similarly, assemble the Screw Bar, Support Plates, and Bar Globes. The assembly after
assembling all these components is shown in Figure 10-72.

Figure 10-70  Faces to be selected to apply mate

Tip. While assembling the Screw Bar you need to apply a coincident mate between
the Right plane of the Screw Bar and the Top plane of the Jaw Screw. For applying
this mate you need to invoke the FeatureManager Design Tree flyout for selecting
the planes.
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Assembling the Remaining Components
Next, you need to assemble the Oval Fillister, Set Screw 1, and Set Screw 2. These fasteners
will be assembled using feature-based mates.

1. Close the part file of all the components, if open.

2. Open the part files of Oval Fillisters, Set Screw 1, and Set Screw 2.

3. Choose Window > Tile Horizontal from the menu bar to rearrange the windows.

4. Select the Revolve feature from the FeatureManager Design Tree of the Oval fillister
part document. Drag the cursor to place the component in the assembly as shown in
Figure 10-73.

5. Drop the component when the coincident symbol is displayed below the cursor.

Similarly, assemble the Set Screw 1 and Set screw 2 using feature-based mates. You may
have to use the TAB key to reverse the directions. The assembly after assembling all the
components is shown in Figure 10-74.

6. Choose the Save button to save the assembly.

Figure 10-72  Assembly after assembling the Vice Body, Vice Jaw,
Jaw Screw, Screw Bar, Clamping Plate, Base Plate, Bar Globes
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Figure 10-74  Final assembly

Figure 10-73  Dragging the Oval Fillisters in the assembly using feature-based mates
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Tutorial 2
In this tutorial you will create all the components of the Pipe Vice and then assemble them.
The pipe vice assembly is shown in Figure 10-75. The dimensions of the various components
are given in Figures 10-76 and 10-77.                      (Expected time: 2 hrs 45 min)

Figure 10-75  Pipe vice assembly
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Figure 10-76  Views and dimensions of the base

The steps to be followed to complete the assembly are listed below:

You need to create all the components of the Pipe Vice assembly as separate part documents.
After creating the parts you will assemble the parts in the assembly file. Therefore, in this
tutorial you are using the bottom-up approach for creating the assembly.

a. Create all the components in individual part documents and save them. The part
documents will be saved in /My Documents/SolidWorks/c10/Pipe Vice.

b. Open an assembly document. Place the base at the origin of the assembly.
c. Place the Moveable Jaw and the screw in the assembly. Apply the mates between Moveable

Jaw and the Screw, refer to Figures 10-78 through 10-80.
d. Now, assemble the Screw with the Base.
e. Place the other components in the assembly and apply the required mates to the assembly,

refer to Figure 10-81.
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Creating the Components
1. Create all the components of the Pipe Vice assembly as separate part documents. Specify

the names of the files as shown in Figures 10-76 and 10-77. The files should be saved in
the directory /My Documents/SolidWorks/c10/Pipe Vice.

Inserting the First Component in the Assembly
After creating all the components of the pipe vice assembly, you need to create a new
assembly document and place the first component using the Insert menu. In this tutorial,
you will add the components using the Insert menu.

1. Create a new assembly document and choose View > Origins from the menu bar to
display the origin.

Figure 10-77  Views and dimensions of the screw, handle, moveable jaw, and handle screw
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2. Choose Insert > Component > From File from the menu bar. The Open dialog box is
displayed. Double click on Base.SLDPRT.

3. The select cursor will be replaced by the part cursor. Move the cursor to the origin; the
symbol of coincident mate is displayed below the cursor. Place the component at this
location.

4. Choose the Isometric button from the Views toolbar to set the current view to isometric
view.

5. Choose View > Origins from the menu bar to turn off the display of origin.

Inserting and Assembling the Moveable Jaw and the Screw
After placing the first component in the assembly document, you need to place the
moveable jaw and the screw in the assembly document. After placing these components
you will apply the required mates.

1. Choose Insert > Component > From File from the menu bar. The Open dialog box is
displayed.

2. Double-click on Moveable Jaw.SLDPRT. Place the component anywhere in the assembly
document such that it does not interfere with existing components.

3. Similarly, place the screw in the assembly document. Figure 10-78 shows the Moveable Jaw
and screw placed in the assembly document.

First, you need to assemble the Screw with the Moveable Jaw. Therefore, for assembling
the Screw with the Moveable Jaw you need to fix the Moveable Jaw.

Figure 10-78  The Moveable Jaw and Screw placed in the assembly document

c10-solidworks-2003.p65 5/12/2003, 12:02 PM49



10-50 SolidWorks for Designers

4. Select the Moveable Jaw from the drawing area or from the FeatureManager Design
Tree. Right-click to invoke the shortcut menu.

5. Choose the Fix option from the shortcut menu. The Moveable Jaw is fixed and you
cannot move or rotate the Moveable Jaw.

6. Choose the SmartMates button from the Assembly toolbar. Double-click the lowermost
cylindrical face of the Screw. The Screw will be displayed in transparent.

7. Drag the cursor to the hole located on the top of the Moveable Jaw. Release the left
mouse button as soon as the concentric symbol is displayed below the cursor.

8. Select the Screw and move it up so that it is not inside the Moveable Jaw.

9. Right-click in the drawing area and choose Clear Selections to clear the current selection.

10. Rotate the model and double-click the lower flat face of the Screw; the Screw will be
displayed in transparent.

11. Again, rotate the model and select the top planar face of the Moveable Jaw. Choose the
OK button from the SmartMates PropertyManager. Figure 10-79 shows the Screw after
applying the mates.

Next, you need to assemble the Screw and the Moveable Jaw with the Base.

12. Select the Moveable Jaw and invoke the shortcut menu. Choose the Float option from the
shortcut menu.

Now, the Moveable Jaw and the Screw assembled to it can be moved.

13. Using smart mates, mate the cylindrical face of the screw and the hole created at the top
face of the Base.

14. Invoke the Mate PropertyManager and select the front planar face of the Moveable Jaw
and the front planar face of the base.

15. Choose the Parallel button from the Mate Settings rollout.

16. Choose the Keep Visible button from the Mate PropertyManager and then choose the
OK button.

17. Next, select the faces as shown in the Figure 10-80.

18. Choose the Distance button from the Mate Settings rollout. Set the value of the Distance
spinner to  35.
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19. Choose the Keep Visible button from the Mate PropertyManager and then choose the
OK button to close it.

Similarly, assemble the other components of Pipe Vice. Figure 10-81 shows the final pipe
vice assembly.

20. Choose the Save button to save the assembly file.

Figure 10-80  Faces to be selectedFigure 10-79  The screw assembled to the moveable
jaw

Figure 10-81  Final pipe vice assembly
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SELF-EVALUATION TEST
Answer the following questions and then compare your answers with the answers given at
the end of this chapter.

1. The bottom-up assembly design approach is the traditional and the most widely preferred
approach of assembly design. (T/F)

2. In the top-down assembly design approach, all the components are created in the same
assembly file. (T/F)

3. The Coincident mate is generally applied to make the two planar faces coplanar. (T/F)

4. The most suitable mates that can be applied to the current selection set are displayed in
the Mate Settings rollout of the Mate PropertyManager. (T/F)

5. Feature-based mates are applied only to the components having cylindrical or conical
features. (T/F)

6. Pattern-based mates are used to assemble the components that have a circular pattern
created on the circular feature. (T/F)

7. Choose the __________ button from the Assembly toolbar to invoke the Rotate Component
PropertyManager.

8. The __________ option available in the Rotate drop-down list is used to rotate the selected
component to a given incremental angle along the specified axis.

9. The __________ mate is generally used to align the central axis of one component with
the central axis of the other.

10. The __________ option available in the Move drop-down list is used to move the component
along the direction of the selected entity.

REVIEW QUESTIONS
Answer the following questions:

1. The names of the selected entities are displayed in the __________ display area of the
Mate PropertyManager.

2. Choose __________ from the menu bar to place a component in the assembly document.

3. Using the __________ option from the Move drop-down list, you can move the component
dynamically along the X, Y, and Z axis of assembly document.

4. The __________ button available in the Mate Settings rollout is used to make the two
selected entities normal to each other.
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5. The __________ option is used to specify the coordinates of the origin of the part where
the component will be placed after moving.

6. If you are adding feature-based mates using the features having conical geometry, then
there must be a __________ face adjacent to the conical face of both the features.

7. The most widely used method of adding the mates to components in the assembly in
SolidWorks is

(a) Smart Mates (b) Mate PropertyManager
(c) By dragging from part document (d) None of these

8. Which button is used to make the Mate PropertyManager available after applying a mate
to the selected entities?

(a) Help (b) OK
(c) Keep Visible (d) Cancel

9. Which option available in the Rotate drop-down list is used to rotate the component with
respect to the selected entity?

(a) Along Entity (b) Selected Edge
(c) Reference Entity (d) None of these

10. Which option is used to specify the coordinates of the origin of the part where the
component will be placed after moving?

(a) To XYZ Position (b) Reference Position
(b) Along Entity (c) None of these

EXERCISE

Exercise 1
Create the Plummer Block assembly as shown in Figure 10-82. The dimensions of the
components of this assembly are shown in Figure 10-83 through Figure 10-85.
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Figure 10-82  Plummer Block assembly

Figure 10-83  Views and dimensions of Casting
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Figure 10-84  Views and dimensions of Cap
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Figure 10-85  Views and dimensions of Brasses, Nut, Lock Nut, and Bolt

Answers to Self-Evaluation Test
1. T, 2. T, 3. T, 4. T, 5. T, 6. T, 7. Rotate Component, 8. By Delta  XYZ, 9. Coincident, 10.
Along Entity
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