Chapter 9

Advanced Modeling
Tools-IlI

Learning Objectives

After completing this chapter you will be able to:
* Create Sweep Feature.

* Create Loft Feature.
* Create 3D Sketches.

* Edit 3D Sketches.

* Create Curves.

* Create Draft Feature.
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ADVANCED MODELING TOOLS

Some of the advanced modeling tools were discussed in earlier chapters. The remaining
advanced modeling tool are discussed in this chapter. The advanced modeling tools that are
discussed in this chapter include sweep, loft, draft, extruding the text, curves, 3D sketches,
and so on.

Creating the Sweep Feature

Toolbar: Features > Sweep
Menu: Insert > Bose/Base > Sweep

% One of the most important advanced modeling tool is the Sweep tool. This tool is
used to extrude a closed profile along an open or closed path. Therefore, to create a
sweep feature you need at least two sketches. The first sketch is the section for the
sweep feature and the second section is the path along which the section will be swept. An
example of the sketches for creating the sweep feature is shown in Figure 9-1. Choose the
Sweep button from the Features toolbar to invoke the Sweep PropertyManager. You can also
invoke this tool by choosing Insert > Bose/Base > Sweep from the menu bar. The Sweep
PropertyManager is shown in Figure 9-2.

Figure 9-1 Sketches to create a sweep feature

After invoking the Sweep PropertyManager, you are prompted to select the sweep profile.
Select from the drawing area the sketch that is created as the profile for the sweep feature. As
soon as you select the sketch, the sketch is highlighted in green and the profile callout is
displayed. Now, you are prompted to select the path for the sweep feature. Select the sketch
that is created as the path of the sweep feature. When you select the sketch, it is highlighted in
red and the path callout is displayed in the drawing area. The sweep feature is displayed in
temporary graphics in the drawing area. Choose the OK button from the Sweep
PropertyManager to end feature creation. Figure 9-3 shows a sweep feature.
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Figure 9-2 The Sweep PropertyManager

Figure 9-3 Sweep feature

It is not necessary that the sketch created for the profile of the sweep feature intersect the
sketch created for the path of the sweep feature. However, the plane on which the profile is
drawn should lie at one of the endpoints of the path. Figure 9-4 shows the nonintersecting
sketches of profile and path. Figure 9-5 shows the resultant sweep feature. Figure 9-6 shows
the sketch of the profile and the closed path. Figure 9-7 shows the resultant sweep feature.
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Figure 9-4 Nonintersecting sketches of profile and Figure 9-5 The resultant sweep feature
path
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Figure 9-6 Sketch of the profile and the closed path Figure 9-7 The resultant sweep feature

The various other options available in the Sweep PropertyManager to create advanced sweep
features are discussed next.

Sweep Using the Follow Path and Keep Normal Constant options
When you are creating a sweep feature, by default, the Follow Path option is selected in the
Orientation/Twist Control drop-down list available in the Options rollout. When you create
a sweep feature using this option, the section will follow the path to create the sweep feature.
If you select the Keep normal constant option from the Orientation/Twist Control drop-down
list, the section will be swept along the path with a normal constraint. The section will not
change its orientation along the sweep path. Therefore, the starting face and the end face of
the sweep feature will be parallel. Figure 9-8 shows the sketches of the path and profile for the
sketch feature. Figure 9-9 shows the sweep feature created using the Follow Path option.
Figure 9-10 shows the sweep feature created using the Keep normal constant option. The
other options available in the Orientation/Twist Control drop-down list are discussed later in
this chapter.
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Figure 9-7 Sweep feature with the Follow Path ~ Figure 9-10 Sweep feature with the Keep
option selected from the Orientation/Twist normal constant option selected from the
Control drop-down list Orientation/Twist Control drop-down list

Maintain Tangency

The Maintain Tangency check box is available in the Orientation/Twist Type area of the
Options rollout. This option is used when the sweep section has tangent entities and you
want the corresponding surfaces to be tangent in the resultant sweep feature.
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Tip. The model edges can also be selected as a path for creating the sweep feature.
When you select a model edge as the sweep path, the Tangent Propagation check
box is displayed in the Options rollout. If this check box is selected, the edges
tangent to the selected edge ave selected automatically as the path of the sweep
feature.
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Advanced Smoothing

The Advanced smoothing check box is available in the Orientation/Twist Type area of the
Options rollout. This option is used if the sweep section has circular or elliptical arcs and you
want a smooth surface to be created in the sweep feature.

Show Preview

The Show preview check box available in the Options rollout is used to display the preview of
the sweep feature in the drawing area. This check box is selected by default. If you clear this
check box, the preview of the sweep feature will not be displayed in the drawing area.

Merge Results

The Merge results check box is available only when you have at least one feature in the
current document. This check box is selected by default. If you clear this check box, it will
result in creating the sweep feature as a separate body.

Align with End Faces

The Align with end faces option is available in the Options rollout only when at least one
teature has already been created in the current document. When this option is selected, the
sweep feature is extended or trimmed to align with end faces. Figure 9-11 shows the profile
and path for creating the sweep feature. Figure 9-12 shows the resultant sweep feature created
with the Align with end faces check box cleared. Figure 9-13 shows the resultant sweep
feature created with the Align with end faces check box selected.

Path

Profile

Figure 9-11 Skelches for the sweep feature

. Note
; % If the sweep feature does not merge, you need to reduce the size of the profile.
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Figure 9-12  Resultant sweep feature with the  Figure 9-13 Resultant sweep feature with the
Align with end faces check box cleared Align with end faces check box selected

Sweep with Guide Curves

The sweep using guide curves is the most important option in the Advanced Modeling tools.
In this sweep feature, the section of the sweep profile varies according to the guide curves
along the sweep path. To create this type of feature, you need to create the sketch of the
profile, path, and the guide curves. A Pierce relation must be applied between the guide
curves and the profile of the sweep feature. The Pierce relation allows the profile to change
shape and size along the sweep path. After creating the sketch of profile, path, and guide
curves, invoke the Sweep PropertyManager. Select the sketches of the profile and the path;
the preview of the sweep feature is displayed in the drawing area. Click on the black arrow on
the right of the Guide Curves rollout to open this rollout. The Guide Curves rollout is shown
in Figure 9-14.

Guide Curyves -

A
Move Up— —Guide Curves
Miove Duwn—

¥ tderge smooth faces

Shiowy Sections—@ |1 j—Section Murmbers

Figure 9-14 The Guide Curves PropertyManager

Select the sketch of the guide curve; the selected guide curve is displayed in brown and a
Guide Curve callout is also displayed attached to the guide curve. The preview of the sweep
feature is also displayed in the drawing area in temporary graphics. Choose the OK button
from the Sweep PropertyManager. Figure 9-15 shows the sketch for the sweep feature with
guide curve. Figure 9-16 shows the resultant sweep feature creation.

In the previous case the path of the sweep feature is a straight line and the guide curve is an
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Figure 9-15 Sketches for the sweep feature with Figure 9-16 Resultant sweep feature
guide curves

arc. In the next case, the arc is selected as the path of the sweep feature and the straight line
is selected as the guide curve. Figure 9-17 shows the sketches for the sweep feature. Figure 9-18
shows the resultant sweep feature.

Figure 9-17 Skelches for the sweep feature Figure 9-18 Resultant sweep feature

Move Up and Move Down
The Move Up button and the Move Down button available on the left of the Guide
Curves display area are used to change the sequence of the selected guide curve.

Merge smooth faces

The Merge smooth faces check box available in the Guide Curves rollout is selected by
default. This option is used to merge all the smooth faces together, resulting in a smooth
sweep feature. When you clear this check box, the Sweep Preview Warning dialog box is
displayed as shown in Figure 9-19. In this dialog box you are prompted that the feature
you are creating may fail because of change in smooth face option. Choose Yes from this
dialog box if you want to accept the change option. When you create a sweep feature with
guide curves and this option cleared, the resulting feature do not merge the smooth faces
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Sweep Preview Warning

Downstream features may fail due to chanaging the merge smooth faces option. Do you want to
accept the change?
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[ Don't show meszage again for this operation

Figure 9-19 The Sweep Preview Warning dialog box

together. This results in a sweep feature with noncontinuous curvature surface. Figure 9-20
shows a sweep feature created with the Merge smooth faces check box selected. Figure 9-21
shows the same sweep feature with the Merge smooth faces check box cleared.

Figure 9-20 Sweep feature with the Merge smooth ~ Figure 9-21 Sweep feature with the Merge
faces check box selected smooth faces check box cleared

&‘ Note

o J Remember that the if you create the sweep feature with the Merge smooth faces check box
£ N . . . . .
g cleared, the resultant feature will be generated faster and the adjacent faces and edges are easily
merged. Also the lines and arcs in the guide curve match accurately while creating the sweep
feature.

Show Sections

The Show Sections button available in the Guide Curves rollout is used to display the
intermediate sections while creating the sweep feature with guide curves. To display the
intermediate profiles or sections along the sweep path, choose the Show Section button
from the Guide Curves rollout. The Section Number spinner is invoked. Using this
spinner you can view the sections of the profile along the sweep path. Figure 9-22 shows
a section being displayed using the Show Section tool along the sweep path.

Sweep Feature Using the Follow Path and 1st Guide Curve Option

When you create a sweep feature with guide curve using the Follow path and 1st guide curve
option, the profile follows the path and the 1st guide curve to create the feature. For creating
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Path{Sketchl)

Guide Curve(Sketch3)

Figure 9-22 Section being displayed using the Show Section tool

ProfilerSketchd)

a sweep feature using this option invoke the Sweep PropertyManager and select the profile,
path, and guide curve(s). By default, the Follow path option is selected in the Orientation/
Twist Control drop-down list. Select the Follow path and 1st guide curve option from the
Orientation/Twist Control drop-down list. Choose the OK button from the Sweep
PropertyManager to end feature creation.

Sweep Feature Using the Follow 1st and 2nd Guide Curves Option
Using this option, the profile of the sweep feature follows the 1st and 2nd guide curves to
create the resultant sweep feature. For creating this type of sweep feature select the Follow 1st
and 2nd guide curves option from the Orientation/Twist Control drop-down list. Choose
the OK button from the Sweep PropertyManager to end feature creation.

Figure 9-23 shows the sketches of the profile, path, and guide curves for creating a sweep
feature. Figure 9-24 shows the sweep feature created using the Follow path and 1st guide
curves option. Figure 9-25 shows the sweep feature created using the Follow 1st and 2nd
guide curves option.

Start/End Tangency

The Start/End Tangency rollout available in the Sweep PropertyManager is used to define
the tangency conditions on the start and the end of the feature. This rollout is invoked by
clicking one of the arrow provided on the right of the rollout. The Start/End Tangency rollout
is displayed in Figure 9-26. The various options available in the Start/End Tangency rollout
are discussed next.

Start tangency type

The Start tangency type drop-down list is used to specify the options to define the tangency
at the start of the sweep feature. The various options available in this drop-down list are
discussed next.
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Figure 9-23 Skelches or profile, path, and guide curves

Figure 9-24 Sweep feature using the Follow path Figure 9-25 Sweep feature using the Follow
and 1st guide curve option Ist and 2nd guide curves option
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Figure 9-26 The Start/End Tangency rollout

None
The None option is selected by default and is used to create a sweep feature without
applying any start tangency.
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Path Tangent
The Path Tangent option is used to maintain the sweep feature normal to the path at
the start.

Direction Vector

When you use the Direction Vector option, the starting of the sweep feature will be
tangent to a virtual normal created from the selected entity. When you select this
option a display area is also displayed and you need to select a linear edge, axis,
planar face, or plane.

All Faces

The All Faces option is used to sweep the feature tangent to the adjoining faces of
the existing geometry at the start. This option is available only when the sweep feature
is attached to a surface or existing feature or geometry.

The options available in the End tangency type drop-down list are the same as
those discussed above. The only diftference is that the options in this drop-down list
are applied to the end of the sweep feature. Figure 9-27 shows the sketches and the
references to create the sweep feature with start and end tangency using the Direction
Vector option. Figure 9-28 shows the resultant sweep feature.

Profile

Back face to be selected
far end tangency direction
vector

Face to be selected

far start tangency
direction vector

Figure 9-27 Profile, path, and references for tangency using the
Direction Vector option

Creating a Thin Sweep Feature

You can also create a thin sweep feature by specifying the thickness using the Thin Feature
rollout. This rollout is invoked by selecting the check box provided at the left of the Thin
Features rollout. The Thin Features rollout is shown in Figure 9-29. The options available in
this rollout are the same as those discussed in the earlier chapters in which extruding and
revolving thin features have been discussed. Figure 9-30 shows a thin sweep feature.
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Figure 9-28 Resultant sweep feature
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Figure 9-29 The Thin Feature rollout

Figure 9-30 Thin sweep feature
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Tip. As discussed earlier; the Pierce velation should be applied between the profile
and the guide curves. If the profile consists of a line or an arc then the coincident
relation will also serve the purpose of the Pierce relation. If the profile is created
using spline or ellipse then you have to apply the Pierce relation.

Creating Cut Sweep Features

Menu: Insert > Cut > Sweep

You can also remove material from an existing feature or model using the sweep feature. To
create a cut-sweep feature, choose Insert > Cut > Sweep from the menu bar to invoke the
Cut-Sweep PropertyManager as shown in Figure 9-31. The options available in the Cut-Sweep
PropertyManager are the same as those discussed in the Sweep PropertyManager with the
only difference being that it is meant for cut operation. Figure 9-32 shows the sketched profile
and path. Figure 9-33 shows the resultant sweep feature created using the Cut-Sweep
PropertyManager.

i Cut-Sweep
100

Profile and Fath Y

Orientationdtwist Type:

| Fllow Path =

[ Maintain tangency
[T advanced smoothing
W Show preview

¥ align with end faces

GudeCuves ~ |
Stat/End Tangency ¥ |

Figure 9-31 The Cut-Sweep PropertyManager
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Path

Profile

Figure 9-32 Sketches for the cut sweep feature

Figure 9-33 Resultant cut sweep feature

Creating the Loft Feature

Toolbar: Features > Loft
Menu: Insert > Bose/Base > Loft

@ The lofted features are created by blending more than one similar or dissimilar
geometries together to get a free form type of shape. These similar or dissimilar
geometries may or may not be parallel to each other. The sketches for lofts should be

closed sketches.
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In SolidWorks, the loft features are created using the Loft PropertyManager. The Loft
PropertyManager is invoked by choosing the Loft button from the Features toolbar or by
choosing Insert > Boss/Base > Loft from the menu bar. The Loft PropertyManager is shown
in Figure 9-34.
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Figure 9-34 The Loft PropertyManager

After creating the sketches when you invoke the Loft PropertyManager, you are prompted to
select at least two profiles. Select the profiles from the drawing area. As you select the profiles,
the preview of the loft feature is displayed in the drawing area in temporary graphics. Choose
the OK button from the Loft PropertyManager to end feature creation.
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%', Note

% d The geometry aﬂd the shape of the loft feature depends on the sequence of selection and the
selection point of the sketches.

Figures 9-35 and 9-37 show the sequence and the selection point for selecting the sections to
create a loft feature. Figures 9-36 and 9-38 show the resultant loft features.

:Third selection
Second selection
First selection

Figure 9-35 Three sketches for the lofi feature Figure 9-36 Resultant loft feature
Third seect%
Second selection
First selection -
Figure 9-37 Sketches for the loft feature Figure 9-38 Resultant loft feature

Start/End Tangency

The Start/End Tangency rollout available in the Loft PropertyManager is used to define the
tangency at the start and end sections of the loft feature. This rollout is invoked by clicking
once on the black arrow provided at the left of this rollout. By default, the None option is
selected. This means that tangency is not applied to the loft feature. The other options available
in this rollout are discussed next.

Normal to Profile

The Normal to Profile option is used to define the tangency normal to profile. When you
invoke this option, you are provided with a spinner to specify the length of tangent. A
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Reverse Direction button is also provided to flip the direction of tangent. The Start/End
Tangency rollout with Normal to Profile options selected in the Start Tangency Type
and the End Tangency Type drop-down list is shown in Figure 9-39.

Start/End T angency -

Start tahgency thpe:
INu:urmaI to Profile j

Reverse Tangent Directinn—@ |1.IZIIZIIZIDDD i’—Start Tangency Length

End tangency type:

INDrmaI to Prafile j

Reverse Tangent Directinn—@ |1_Dguggg j—End Tangent Length

Figure 9-39 The Start/End Tangency rollout with the Normal to Profile option selected

Direction Vector

The Direction Vector option is used to define the tangency at the start and at the end of
the loft feature by defining a direction vector. When you invoke this option you are provided
with the Direction Vector display area and the spinners to define the length of tangents.
You need to select the direction vectors to specity the tangent at the start and at the end
of the loft feature. You can also specify the length of the tangents using the spinners
provided in the Start/End Tangent rollout. The Start/End Tangent rollout with the
Direction Vector option selected is displayed in Figure 9-40.

Start/End T angency Y

Start tangency type:
IDirectiDn Wector j

2 | —UDirection Yectar

Reverse Tangent Directinn—@ [0ooaoo < Start Tangent Length

End tangency type:

IDirectiu:un Wector j

2 ——Direction “ectar
Reverse Tangent Directinn—@ Wﬂ—End Tangent Length

Figure 9-40 The Start/End Tangency rollout with the Direction Vector option selected

Figure 9-41 shows the section for the loft feature. Figure 9-42 shows the initial preview of
the loft feature. Figure 9-43 shows the preview of the loft feature with tangent at the start
of the loft. Figure 9-44 shows the tangent at the start and at the end of the loft. Figure 9-45
shows the final loft feature.
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Figure 9-42 Preview of the loft feature
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Figure 9-44 Tangent applied at start and end
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Tip. You can also define the tangent length dynamically by dragging the red arrows
provided at the start and at the end of the loft feature. As you drag the arrow the
preview of the tangent and the value in the spinner modify dynamically.

Guide Curves

You can also define the guide curve between the profiles of the loft feature to define the path
of transition of the loft feature. The sketches created for the guide curve must have a pierce
relation with the sketches that define the loft section. All the other options available in the
Guide Curves rollout are the same as those discussed earlier. The Guide Curves rollout is
displayed in Figure 9-46.

Guide Curves FS

1
M ove Up— —Guide Curves
hfowe ann—

¥ Merge smooth faces

Show Sectinns—@ |1 ijection Murmber

Figure 9-46 The Guide Curves rollout

Figure 9-47 shows the profiles and the guide curves for creating a loft feature with guide
curves. Figure 9-48 shows the resultant loft feature created using the guide curves.

Figure 9-47 Profiles and guide curves Figure 9-48 Resultant loft feature

Options

The Options rollout of the Loft PropertyManager is provided with many options to improve
the creation of the loft feature. All the options available in this rollout are the same as
those discussed earlier while discussing the sweep option. An additional option provided in
this rollout is discussed next.
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Close Loft

The Close loft option is used to created a close loft feature. A closed loft feature is created
by joining the end section with the start section of the loft feature. Figure 9-49 shows a loft
teature created with the Close loft check box cleared. Figure 9-50 shows the loft feature
created with the Close loft check box selected.

- _'—\_—_—_—__""— .

6/”“‘““ ‘gﬂ\“\
V

Figure 9-49 Loft feature with the Close Loft Figure 9-50 Lofi feature with the Close loft
check box cleared check box selected

Centerline Parameters

The Centerline Parameters rollout is used to create a loft feature by blending two or more
than two sections along a specified path. The path that specifies the transition is called
centerline. You can invoke this rollout by clicking once on the arrow provided at the right of
this rollout. The Centerline Parameters rollout is displayed in Figure 9-51.

The various options available in this rollout are discussed next.

Centerline Parameters -

[je l ——LCenterline

Mumber of zectionz:

Show Sectinns—@ |1 j—Sectinn Mumber

Figure 9-51 The Centerline Parameters rolloul

Centerline

After invoking the Centerline Parameters rollout you need to define the centerline.
Therefore, select the sketch that defines the centerline for the loft feature. The name of
the sketch will be displayed in the Centerline display area.

‘ c09-solidworks-2003.p65 21 5/11/2003, 5:46 PM



9-22 SolidWorks for Designers

Number of sections

The Number of sections slider bar provided in the Centerline Parameters rollout is
used to define the number of intermediate sections. These intermediate sections define
the accuracy and the smoothness of the surfaces generated to create the loft feature.

The Show Sections button and the Section Number spinner available in the Centerline
Parameters rollout are used to display the intermediate sections as discussed earlier.
Figure 9-52 shows the sketches of the profiles and the centerline used to create the loft
feature. Figure 9-53 shows the resultant loft feature.

Centerline

Figure 9-52 Skelches of profiles and the Figure 9-53 The resultant loft feature
centerline

Tip. Create a lofi feature such that one profile is created using the circle and the

e / other is created using a polygon. Since, circles and ellipses do not have any endpoint

Q/ and the polygons do have endpoints, the lofi feature will blend the polygon and

circle or ellipse approximately. But for better accuracy for blending you can split

the sketch using the Split Curve option. Afler splitting the circle or ellipse, you can
create a more accurate loft feature.

You can also create a thin loft feature by defining the thin parameters using the Thin Feature
rollout. Figure 9-54 shows a thin loft feature created using the Thin Features rollout available
in the Loft PropertyManager.

The Cut Loft PropertyManager is used to create a cut loft feature. This option is invoked by
choosing Insert > Cut > Loft from the menu bar.
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Figure 9-54 A thin loft feature

Creating 3D Sketches

Toolbar: Sketch > 3DSketch
Menu: Insert > 3D Sketch

£I In previous chapters you have learned how to create 2D sketches. In this chapter
you will learn how to create 3D sketches. The 3D sketches are used to create 3D paths
for the sweep features, 3D curves, and so on. Figure 9-55 shows a chair frame created

by sweeping a profile along a 3D path.

Figure 9-55 A chair frame created by sweeping a profile along a 3D path
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To create a 3D sketch choose the 3D Sketch button from the Sketch toolbar or choose Insert
> 3D Sketch from the menu bar. When you choose this option, the 3D sketching environment
is invoked and the origin is displayed in red color. For creating a 3D sketch, you do not need
to select a sketching plane. When you invoke the 3D sketching environment some of the
sketching tools are activated in the Sketch Tools toolbar. You can use only some of the sketching
tools in the 3D sketching environment. The sketching tools that can be used in the 3D sketching
environment are discussed next.

Line

For creating lines in the 3D sketching environment, first you have to orient the drawing
M area in the isometric view. Choose the Isometric button from the Standard Views

toolbar to orient the drawing area to isometric. Now, choose the Line button from the
Sketching Tools toolbar to invoke the line tool. The select cursor will be replaced by the line
cursor with XY displayed at the bottom of the line cursor. This means that the sketch will be
created in the XY plane by default. You can toggle between the planes using the TAB key
from the keyboard. Move the cursor to the origin to start the sketch or to the location from
where you want to start the sketching. Press and hold down the left mouse button at this
location and you are provided with a space handle. The space handle includes a coordinate
system in the current plane.

If you toggle the plane using the TAB key then the coordinate system will change with respect
to the current plane. Now, drag the cursor to a location where you want to define the endpoint
of the line. Release the left mouse button at this location. Once you complete sketching the
first line, move the cursor to the endpoint of the line created earlier. When the line cursor
turns yellow in color, toggle the plane using the TAB key. Drag the cursor to create another
line. Figures 9-56 through 9-58 show sketching in different planes in the 3D sketching
environment.

Sketching in the XY plane h
Sketching in the YZ plane

Figure 9-56 Skelching in the XY plane Figure 9-57 Sketching in the YZ plane
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Space handle

Sketching in the 7 plane

Figure 9-58 Sketching in the ZX plane

Figure 9-59 shows an example of a 3D sketch.

Figure 9-59 A 3D skelch created using the line tool

Spline
~ You can also create a spline in the 3D sketching environment. To create a 3D spline
choose the Spline button from the Sketching Tools toolbar. The select cursor will be
replaced by the spline cursor. Move the cursor to the desired location from where you
want to start the sketching. Specify the start point of the spline; the space handle is displayed.
You can toggle between the planes using the TAB key. Move the cursor where you want to
specify the second point of spline and specify the second point of spline. As you specify the
second point of spline, the space handle will be displayed and you toggle between the planes
using the TAB key. After creating the spline, right-click and choose the Select option from
the shortcut menu to end spline creation. Figure 9-60 shows a power cord with a knot; the
cable of the power cord is created using the spline in the 3D sketching environment.
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Figure 9-60 Power cord with a knot

Point
You can also create points in the 3D sketching environment of SolidWorks. To create
ﬂ a 3D point, first you have to invoke the 3D sketching environment and orient the
drawing area to isometric view. Choose the Point button from the Sketch Tools toolbar
to invoke the point tool. The select cursor will be replaced by the point cursor. Use the left
mouse button to create points.

Centerline
j You can also create centerlines in the 3D sketching environment. Invoke the 3D
i sketching environment and orient the drawing view to isometric view. Choose the
Centerline button from the Sketch Tools toolbar to create a centerline. The select
cursor will be replaced by the line cursor. The procedure of creating the centerline is the same
as that discussed for creating the lines.

The dimensioning of 3D sketches is the same as the dimensioning of 2D sketches.

Editing the 3D Sketches

The editing operations that can be performed on 3D sketches are discussed next

Jog Line
The Jog Line tool is used to jog the sketched lines. When you create a jog line,
automatic parallel and perpendicular relations are applied to the parent sketch. To
create a jog line, choose the Jog Line button from the Routing toolbar or choose
Tools > Sketch Tools > Jog Line from the menu bar. Now, select the start point of the jog
line; a rectangle will be attached to the cursor. Using the TAB key you can toggle between the
plane in which the jog line is being created. Move the cursor to define the size of the jog line
and specify the endpoint of the jog line. You can also create jog lines in the 2D sketching
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Tip. If the Routing toolbar is not available in the SolidWorks window then you
need to display the toolbar. To display the toolbar; choose View > Toolbars >
Routing from the menu bar. The Routing toolbar will be displayed in the Solid Works
window. The other method of invoking the Routing toolbar is to move the cursor to
any toolbar and right-click to invoke the shortcut menu. Choose the Routing toolbar
from the shortcut menu.

Using the above method you can invoke any toolbar that is not displayed in the
SolidWorks window.

environment. Figure 9-61 shows the start point of the jog line. Figure 9-62 shows the cursor
being moved to create the jog line. Figure 9-63 shows the resultant jog line.

Start point of
the jog line

Figure 9-61 Sclecting the start point of the Figure 9-62 Moving the mouse to specify the
jog line size of the jog line

Figure 9-63 The resultant jog line
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Other Editing Operations

You can perform a number of editing operations on 3D sketches. These editing operations
include Convert Entities, Intersection Curves, Sketch Chamfer, Sketch Trim, Fit Spline,
Sketch Trim, Sketch Extends, and Split Curve. All these tools except Intersection Curves
are discussed in the earlier chapters. The Intersection Curves tool will be discussed later.

Creating Curves

You can also create different types of curves in SolidWorks. Curves are used to create complex
shapes generally using the sweep and loft tools. The types of curves that can be created in
SolidWorks are discussed next.

Creating Projection Curve

Toolbar: Curves > Projection
Menu: Insert > Curve > Projected

ﬁl] This option allows you to project a sketched entity on one or more than one planar or
curved faces. You can also project a sketched entity on another sketched entity to
create a 3D curve. To create a projected curve, you first need to create at least two
sketches or a sketch and at least one feature and then choose the Projection button from the
Curves toolbar or choose Inset > Curve > Projected from the menu bar. When you choose
the Projection button, the Projected Curve PropertyManager is displayed as shown in
Figure 9-64. The confirmation corner is also displayed in the drawing area. The two different
options to create projected curves are discussed next.

1010

Selectionz -

ISketch onhto Sketch j——F’rDjECtiDn Type

L/

—~Sketches to Project

"

Figure 9-64 The Projected Curve PropertyManager

Sketch onto Sketch

When you invoke the Projected Curve PropertyManager, the Sketch onto Sketch option
is selected by default in the Projection Type drop-down list. You are prompted to select
two sketches to project onto one another. Select two sketches to project them onto one
another. When you select the sketches, the names of the sketches are displayed in the
Sketches to Project display area. The preview of the projected curve is also displayed in
the drawing area. Choose the OK button from the Projected Curve PropertyManager or
choose the OK option from the confirmation corner. Figure 9-65 shows the two
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sketches selected to create a projected curve. Figure 9-66 shows the preview of the projected
curve. Figure 9-67 show the resultant projected curve.

Selection 1
ﬁ/ |
Selection 2

‘ c09-solidworks-2003.p65

Figure 9-65 Skelches to be selected Figure 9-66 Preview of the projected curve

—

Figure 9-67 Resultant projected curve

Sketches onto Faces

The Sketches onto Faces option is available in the Projection Type drop-down list. This
option is used to project a sketch on a planar or a curved face. When you choose this
option, the Sketch to Project and the Projection Faces display areas are displayed in the
Selections rollout. You are also provided with a Reverse Projection check box in the
Selections rollout. The Projected Curve PropertyManager with Sketches onto Faces
option selected is displayed in Figure 9-68. When you choose this option, you are prompted
to select a sketch to project and the face on which to project. Now, you need to select the
sketch from the drawing area and the face or faces on which you want to project the
sketch. The selected sketch is highlighted in green and the selected face is highlighted in
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Projected Curve

1010

Selections s

ISketch onto Face(s) j——F'rDjECtiDn Type

Lé’ II —Sketch to Project

N

—Frojection Faces

7] Reverze Projection

Figure 9-68 The Projected Curve PropertyManager with the
Sketches onto Faces option selected

red. You are also provided with a Reverse Projection arrow in the drawing area. This
arrow is used to reverse the direction of projection. You can also reverse the direction
of projection using the Reverse Projection check box. Choose the OK button from the
Projected Curve PropertyManager or choose the OK option from the confirmation corner.
Figure 9-69 shows the sketch to be selected for projection and the face to be selected on
which the sketch will be projected. Figure 9-70 shows the resultant projected sketch.

Sketch to be

selected
Faceto be

selectad

Figure 9-69 Sketch and the face to be selected Figure 9-70 Resultant projected curve
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Creating Split Lines
Toolbar: Curves > Split Line

Menu: Insert > Curve > Split Line

E The Split Line tool is used to project a sketch on a planar or a curved face and in turn

it splits or divides the single face into two or more than two faces. To create a split line

to divide the faces, you need to invoke the Split Line PropertyManager. Choose the

Split Line button from the Curves toolbar or choose Insert > Curve > Split Line from the
menu bar to invoke the Split Line PropertyManager as shown in Figure 9-71. There are two
methods of creating a split line, which are discussed next.
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Figure 9-71 The Split Line PropertyManager

Silhouette

Using this option you can split a cylindrical or circular face by creating the silhouette line
at the intersection of the projection of plane and the cylindrical face. When you invoke
the Split Line PropertyManager, the Silhouette option available in the Types of Split
rollout is selected by default. You are prompted to change the type or select the direction
of pull and faces to split. You need to select a plane that defines the direction of pull.
Select the plane; the selected plane will be highlighted in red color. Now, select the
cylindrical or circular face; the selected face will be highlighted in green color. Choose
the OK button from the Split Line PropertyManager or choose the OK option from the
confirmation corner. The cylindrical or circular face will be divided in two or more faces.
Figure 9-72 shows the plane and the face to be selected. Figure 9-73 shows the resultant
split line created to split the selected face.

Projection

Using this option you can project a sketched entity onto a planar or a curved face to
create a split line on that face. The split line tends to split the selected face on which the
sketch is projected. To use this option invoke the Split Line PropertyManager and choose
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P “‘\
Plans to be
selected \\

Faceto be
selectad

Figure 9-72 Plane and the face to be selected Figure 9-73 Resultant split line

the Projection option from the Types to Split rollout. The Split Line PropertyManager
with the Projection option selected is shown in Figure 9-74. You are prompted to change

V(%2

Type of Split -
............. ('“5||h.;.ueue
{*' PFrojection
v,
SHEE | ecscsnssn =
|_§ II———Sketch to Project
|

——Faces to Split

[T Single direction

[T Reverse direction

S

Figure 9-74 The Split Line PropertyManager with
the Projection option selected

the type or select the sketch to project, direction, and faces to split. Select the sketch and the
selected sketch will be displayed in green. Now, you need to select the face to split. Select the face;
the selected face will be displayed in green and the preview of the split line will also be displayed
in the drawing area. Choose the OK button from the confirmation corner. The selected face or
taces will split into two or more than two faces. Figure 9-75 shows the sketch and face to be selected.
Figure 9-76 shows the resultant split line created to split the selected face.
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Sketch to be
selected

Face to be
selected

Figure 9-75 Sketch and the face to be selected Figure 9-76 Resultant split line

The other options available in the Selections rollout of the Split Line PropertyManager
are discussed next.

Single direction

While creating a split on a cylindrical face, if the sketching plane on which the sketch
is created lies within the model, the split line will be created on two sides of the
cylindrical face. The Single direction check box available in the Selections rollout is
used to create the split line only in one direction. The Reverse direction check box is
available only if the Single direction check box is selected. The Reverse direction
check box is used to reverse the direction in which the split line should be created.
Figure 9-77 shows the split line created on both sides of the model. Figure 9-78 shows
the split line created on single side of the model.

Figure 9-77 Split line created on both sides Figure 9-78 Split line created on single side
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Creating Composite Curve

Toolbar: Curves > Composite Curve
Menu: Insert > Curve > Composite

E The Composite Curve option is used to create a curve by combining other curves,

sketched entities, and edges into a single curve. The composite curve is mainly used

while creating a sweep or a loft feature. To create a composite curve you need to

invoke the Composite Curve PropertyManager. Choose the Composite Curve button from

the Curves toolbar or choose Insert > Curve > Composite from the menu bar to invoke the

Composite Curve PropertyManager. The Composite Curve PropertyManager is shown in
Figure 9-79.

Composite Curve
1010

Entities ta Jain Fs

Sketches, Edges, and
Cures to Join

Figure 9-79 The Composite Curve PropertyManager

When you invoke the Composite Curve PropertyManager you are prompted to select a
continuous set of sketches, edges, and/or curves. Select the edges, curves, or sketched entities
to create a continuous curve. Choose the OK button to end curve creation. The entities to be
selected should form a continuous chain, otherwise the composite curve will not be created.

Creating Curve Through Free Points

Toolbar: Curves > Curve Through Free Points
Menu: Insert > Curve > Curve Through Free Points

The Curve Through Free Points option is used to create a curve by specifying the
E coordinate points. To create a curve using this option, choose the Curve Through

Free Points button from the Curves toolbar or choose Insert > Curve > Curve
Through Free Points from the menu bar. The Curve File dialog box is displayed as shown in
Figure 9-80. Double-click the first column under the X area to invoke the first row to enter the
coordinates for the start point for the curve. Double-click in the column below the first column
to enter the coordinates for the second point for creating the curve. Similarly, specify the
coordinates of the other points of the curve, see Figure 9-81. When you enter the coordinates
of the points the preview of the curve is displayed in the drawing area. Choose the OK button
from the Curve File dialog box to complete the feature creation, see Figure 9-82.

You can also save the current set of coordinates using the Save button available in the Curve
File dialog box. When you choose this button to save the current set of coordinates, the Save
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Figure 9-80 The Curve File dialog box
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Figure 9-81 Coordinates entered in the Curve Figure 9-82 Resultant 3D curve
File dialog box
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As dialog box is displayed. Browse the directory in which you need to save the coordinates
and enter the name of the file in the File name message area and choose the Save button.
The curve file is saved with extension .sldcrv. Using the Save As button you can save the
current set of coordinates with some other name.

Using the Browse button, you can open an existing curve file. Invoke the Curve File dialog
box and choose the Browse button. The Open dialog box will be displayed. You can browse
the previously saved curve file to specify the coordinate points. You can also write the
coordinates in a text (notepad) file and save it. In the Open dialog box, choose the Text Files
(*.txt) option from the Files of type drop-down list and browse the text file to specify the
coordinates.

o

Tip. You can select a row and using the DELETE key from the keyboard you can
delete the entire row. Using the SHIFT key select the entire row and using the
Insert button, you can add a row between two rows.
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Creating Curve Through Reference Points

Toolbar: Curves > 3D Curve
Menu: Insert > Curve > Curve Through Reference Points

& The Curve Through Reference Points option enables you to create a curve by selecting
the sketched points, vertices, origin, endpoints, or center points. To create a curve
through reference points, you have to invoke the Curve Through Reference Points
PropertyManager. Choose the 3D Curve button from the Curves toolbar or choose Insert >
Curve > Curve Through Reference Points from the menu bar. The Curve Through Reference
Points PropertyManager is shown in Figure 9-83.

i@
(v)(%)(2)

Through Faint: -

Curve Through
Reference Points

[ Clozed curve

Figure 9-83 The Curve Through Reference Points
PropertyManager

When you invoke this tool, you are prompted to select vertices to define the through points
for the curve. Select the points to define the curve. As you define the points, the preview of
the resultant curve created using the selected points is displayed in the drawing area. After
specifying all the points, choose the OK button or choose the OK option from the confirmation
corner. You can also use the Closed curve check box to create a closed curve. Figure 9-84
shows the vertices to be selected to create the curve through reference points. Figure 9-85
shows the resultant 3D curve.

3rd

WVertices to
sslected
4th

Werices to
be selected

Sth
' Verices to

Tth be selected

Figure 9-84 Venrtices to be selected

Figure 9-85 Resultant 3D curve
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Creating Helical Curve

Toolbar: Curves > Helix
Menu: Insert > Curve > Helix/Spiral

E The Helical Curve option is used to create a helical curve or a spiral curve. The
helical or spiral curve is used as the sweep path to create springs, threads, spiral coils,
and so on. Figure 9-86 shows a spring created by sweeping a profile along a helical

path. Figure 9-87 shows a spiral coil created by sweeping a profile along a spiral path.

Figure 9-86 Spring Figure 9-87 Spiral coil

To create a helix in SolidWorks you first have to create a sketch of the circle that defines the
diameter of the helical curve. If you are creating a spiral, the sketch will define the starting
diameter of the spiral curve. You can invoke the Helix tool while you are in the sketching
environment. If you are not in the sketching environment, you first have to select the sketch
and then invoke this tool. Choose the Helix button from the Curves toolbar or choose Insert
> Curve > Helix/Spiral from the menu bar. The Helix Curve dialog box will be displayed as
shown in Figure 9-88.

Helix Curve E3

Defined by: IF'itch and Revaolution j (1] I
Height; IED 0rnm ﬂ Cancel |

Pitch: |5U. 00 ﬂ Help |
Byt |1 000000 ﬂ

Starti e |135.DDE|E.' 2
[~ Taper Helix i d ;I

= [” Reverse direction
-ﬁnEﬂEiID.DDdeg j

% Clockwize
I Tiaper outward " Counterclockwise

Figure 9-88 The Helix Curve dialog box
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The preview of the helix curve is displayed in the drawing area with the default values. There
are various methods to specify the parameters of the helical curve. These methods are discussed
next.

Pitch and Revolution

The Pitch and Revolution option available in the Defined by drop-down list is selected
by default. Using this option, you can specify the pitch of the helical curve and the number
of revolutions. When this option is selected, the Pitch spinner and the Revolution spinner
are available in the Helix Curve dialog box to define the value of pitch and number of
revolutions.

Height and Revolution

The Height and Revolution option available in the Defined by drop-down list is used to
define the parameters of the helix curve in the form of the total helix height and the
number of revolutions. When you choose this option, the Height and Revolution spinners
are displayed to specify the required parameters.

Height and Pitch

The Height and Pitch option available in the Defined by drop-down list is used to define
the parameters of the helix curve in terms of the height and the pitch of the helix. When
you select this option, the Height and Pitch spinners are displayed to specify the required
parameters.

When you specify the parameters to create the helix curve, the preview in the drawing
area modifies dynamically. Figure 9-89 shows a helix.

You can also create a tapered helix using the Taper Helix check box available in the
Helix Curve dialog box. The procedure of creating a taper helical curve is discussed next.

Taper Helix

The Taper Helix check box is selected to create a tapered helical curve. To create a
tapered helical curve, select the Taper Helix check box from the Helix Curve dialog
box. The Angle spinner and the Taper outward check box are enabled. Using the Angle
spinner you can specify the value of the angle of taper. The Taper outward check box is
used to create an outward taper. When you specify the parameters to create a tapered
helical curve, the preview of the helical curve updates automatically in the drawing area.
Figure 9-90 shows a tapered helical curve. Figure 9-91 shows a tapered helical curve
created with the Taper outward check box selected.

Using the Start angle spinner you can specify the start angle of the helical curve. The
Reverse direction check box is selected to reverse the direction of helical curve creation.

By default, the helical curve is created in the clockwise direction. Therefore, the Clockwise
radio button is selected in the Helix Curve dialog box. If you need to create the helical
curve in the counterclockwise direction, you need to select the Counterclockwise radio
button. After setting all the parameters, choose the OK button from the Helix Curve
dialog box.
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Figure 9-89 Helical Curve

Figure 9-90 lupered helical curve Figure 9-91 ‘lupered helical curve with the Taper
outwards option selected

Creating the Spiral Curve

For creating a Spiral Curve first you have to create a sketched circle. The circle will define
the inner diameter of the spiral coil. Select the Spiral option from the Defined by
drop-down list available in the Helix Curve dialog box. The preview of the spiral curve
will be displayed in the drawing area. You can define the pitch and the number of
revolutions in the Pitch spinner and the Revolution spinner, respectively. The other
options except Taper Helix are available while creating a spiral curve. These options are
the same as those discussed earlier. After specifying all the required parameters, choose
the OK button. Figure 9-92 shows a spiral curve.
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Figure 9-92 Spiral curve

Creating Draft Features

Toolbar: Features > Draft
Menu: Insert > Features > Draft

! The Draft tool is used to taper the selected faces of the model. One of the main
application of the draft feature is to taper the faces of the parts to be moulded or
casted so that it is easier to remove them from the mould or die. To create a draft

teature you need to invoke the Draft PropertyManager. Choose the Draft button from the

Features toolbar or choose Insert > Features > Draft from the menu bar to invoke the Draft

PropertyManager. The Draft PropertyManager is shown in Figure 9-93.

After invoking this tool, you are prompted to select a neutral plane and the faces to draft. You
will notice that the Neutral Plane option is selected by default in the Types of Draft drop-down
list in the Types of Draft rollout. Therefore, you need to select a neutral plane for creating
the draft feature. Select a planar face or a plane that acts as a neutral plane. The selected face
will be displayed in red with the Neutral Plane callout. A Reverse Direction arrow is also
displayed in the drawing area. Now, click in the Faces to Draft display area in the Faces to
Draft rollout to activate the selection mode. Select the faces to apply the draft. The selected
taces will be displayed green in color with the Draft Face callout. Now, set the value of the
draft angle in the Draft Angle spinner available in the Draft Angle rollout. Choose the OK
button from the Draft PropertyManager or choose the OK option from the confirmation
corner.

Figure 9-94 shows the neutral face and the faces to be selected to add the draft. Figure 9-95
shows the resultant draft feature. The other options in the Draft PropertyManager are
discussed next.
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Figure 9-93 The Draft PropertyManager
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Figure 9-94 Fuces to be selected

Reverse Direction

Figure 9-95 Resultant draft feature

The Reverse Direction button available on the left of the Neutral Plane display area in
the Neutral Plane rollout is used to reverse the direction of draft creation. You can also
reverse the direction of draft creation by selecting the Reverse Direction arrow from the

drawing area.
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Face propagation
The options available in the Face Propagation drop-down list are used to extend the
draft feature to the other faces. The options available in this drop-down list are discussed next.

None
The None option is selected by default. This option is used when you do not need to
apply any type of face propagation.

Along Tangent
The Along Tangent option is used to apply the draft to the faces tangent to the
selected face.

All Faces
The All Faces option is used to apply the draft to all the faces attached to the neutral
plane or face.

Inner Faces
This option is used to draft all the faces inside the model that are attached to the
neutral plane or face.

Outer Faces
This option is used to draft all the outside faces of the model that are attached to the
neutral plane or face.

Creating the Draft Using the Parting Line

To create a draft feature using the Parting Line option, you first need to create a parting
line using the split curve option. The Split Curve option was discussed earlier in this
chapter. You can also select the model edges as split curve. Now, invoke the Draft
PropertyManager and select the Parting Line option from the Type of Draft drop-down
list. The Draft PropertyManager with the Parting Line option selected is displayed in
Figure 9-96. You are prompted to select the direction of pull and the parting lines.

Select a planar face, plane, or an edge as the pull direction for creating the draft feature.
The Direction of Pull callout and the Reverse Direction arrow are displayed in the
drawing area. Click once in the Parting Line area to invoke the selection mode and select
the parting lines. The direction arrows will be displayed with the selected parting lines.
Using the Other Face button, you can reverse the direction of the selected parting line.
Set the value of the angle in the Draft Angle spinner and end feature creation.

Figure 9-97 shows the pull direction and the parting lines to be selected. Figure 9-98
shows the resultant draft feature creation.

Allow reduced angle

When applying the draft feature using the Parting Line, a smaller draft angle is
applied to some portions of the draft feature because of geometric conditions.
Therefore, the Allow reduced angle check box available in the Type of Draft rollout
is used to maintain the consistency in the draft feature.

‘ c09-solidworks-2003.p65 42 5/11/2003, 5:47 PM



Advanced Modeling Tools-III 9-43

1010

IF'arting Line j——T}-‘pE of Draft

[T &llow reduced angle
.

DraftAngle o -~

A z
L} IEB-UUdEQ j—Draﬁ Angle
Directionof Pull ... -
@ II —Direction of Pull
Farting Lines e

——Farting Lines
Face propagation:
|None j——Face Propagation
o

Figure 9-96 The Draft PropertyManager with the Parting Line
option selected from the Type of Draft drop-down list
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Figure 9-97 Fuace and the parting lines to be selected Figure 9-98 Resultant draft feature
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Creating the Step Draft
The Step Draft option available in the Type of Draft drop-down list is used to create a

step draft. The Draft PropertyManager with the Step Draft option selected is shown in
Figure 9-99.
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Figure 9-99 The Draft PropertyManager with the Step Draft
option selected from the Type of Draft drop-down list

You are prompted to select the direction of pull and the parting line. Select the direction
of pull; the Reverse Direction arrow and the Direction of Pull callout are displayed.
Select the parting lines to create the step draft. As discussed you can change the direction
of the parting lines using the Other Face option. Set the value of the angle in the Draft
Angle spinner and choose the OK button from the Draft PropertyManager. Figure 9-100
shows the face selected to define the direction of pull. Figure 9-101 shows the step draft
teature created.

You will notice that the Tapered steps radio button is selected by default in the Type of
Draft rollout. Some of the faces of the step draft created will include a taper. If you select
the Perpendicular steps radio button, the steps created will be perpendicular. Figure 9-102
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Figure 9-100 Fuce and the parting lines to be selected ~ Figure 9-101 Resultant step draft featwre

shows the step draft created with the Tapered steps radio button selected. Figure 9-103
shows the step draft created with the Perpendicular steps radio button selected.

Figure 9-102 Step draft created with the Figure 9-103 Step drafl created with the
Tapered steps radio button selected Perpendicular steps radio button selected

TUTORIALS

Tutorial 1

In this tutorial you will create the model shown in Figure 9-104. The dimensions of model are
shown in Figure 9-105. (Expected time: 45 min)

The steps to be followed to complete this tutorial are given next:
a. The base feature of the model is a sweep feature. First, you need to create the path of the

sweep feature on the front plane. Next, you need to create a plane normal to the path of
the sweep feature. Select the newly created plane as the sketching plane and create the
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Figure 9-105 Views and dimensions of the model for Tutorial 1
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profile of the sweep feature. You will create a thin sweep feature because the base feature
of the model is a hollow feature, refer to Figures 9-106 through 9-108.

Create the extrude features on both ends of the sweep feature, refer to Figure 9-109.
Create a plane at an offset distance from the right face of the model. Create the circular
teature by extruding the feature using the Up To Next option.

Create the hole using the Simple Hole PropertyManager, refer to Figure 9-109.

Create the pattern of the hole feature, refer to Figure 9-109.

Create the counterbore hole using the cut revolve option, refer to Figure 9-109.

Creating the Path for the Sweep Feature

As discussed earlier, the base feature of the model is a sweep feature. To create the sweep
teature, you first need to create the path of the sweep feature. This path will be created on
the Front plane.

Start SolidWorks and open a new part document from the Template tab of the New
SolidWorks Document dialog box.

Draw the sketch of the path of the sweep feature on the Front plane and add the required
relations and dimensions to the sketch as shown in Figure 9-106. Exit the sketching
environment and change the view to isometric view.

Creating the Profile of the Sweep Feature

‘ c09-solidworks-2003.p65

After creating the path of the sweep feature, you will create the profile of the sweep
teature. For creating the profile, first you need to create a reference plane normal to the
path. The newly created plane will be selected as the sketching plane for creating the
profile of the sweep feature.

Invoke the Plane PropertyManager and using the Normal to Curve option, create
a plane normal to the path as shown in Figure 9-107.

<

O

+
55
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&
Planel
Figure 9-106 Sketch of the path Figure 9-107 Plane created normal to path
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2. Invoke the sketching environment by selecting the newly created plane as the sketching
plane.

3. Create the sketch of the profile of the sweep feature using the circle tool. The diameter of
the profile of the sweep feature is 97.

4. After creating the profile of the sweep feature exit the sketching environment.

Creating the Sweep Feature

The sweep feature that you are going to create is a thin sweep feature. You will use the
Thin Feature rollout to specify the parameters of the thin feature.

Choose the Sweep button from the Features toolbar. The Sweep PropertyManager %
is invoked and you are prompted to select the sweep profile.

Select the profile of the sweep feature. The selected profile will be highlighted in green
and the Profile callout will also be displayed.

After selecting the profile, you are prompted to select the path.
Select the path of the sweep feature. The selected path will be highlighted in red and the
Path callout is also displayed. The preview of the sweep feature is also displayed in the

drawing area.

Select the Thin Feature check box available on the left of the rollout. The Thin Feature
rollout is invoked.

Set the value of thickness in the Thickness spinner to 16.

Since the wall thickness added to the model is reverse to the required direction, therefore,
you need to reverse the direction of creation of thin feature.

Choose the Reverse Direction button from the Thin Features rollout. Choose the OK
button from the Sweep PropertyManager or choose OK from the confirmation corner.

The base feature created by sweeping a profile along a path is shown in Figure 9-108.

Tip. Instead of creating a thin sweep feature, you can also create a solid sweep
feature and then add a shell feature to hollow the base feature.

Creating the Remaining Features

Create the remaining join features of the model using the extrude option. Using the
Simple Hole PropertyManager create the holes and pattern them using the circular
pattern tool. Create the counterbore hole using the Hole Wizard or using the revolve cut
option.
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Figure 9-108 Base feature of the model

The final solid model of Tutorial 1 is shown in Figure 9-109. The model tree of the model
is shown in Figure 9-110.

Figure 9-109 Final model of Tutorial 1

Saving the Model

Next, you need to save the model.

1. Choose the Save button from the Standard toolbar and save the model with the E |
name given below:
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\My Documents\Solid Works\cO9\c09-tut01.SLDPRT .

2. Choose File > Close from the menu bar to close the file.
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Figure 9-110 The FeatureManager Design Tree for the model

Tutorial 2

In this tutorial you will create the chair frame shown in Figure 9-111. The dimensions of the
chair frame are shown in Figure 9-112.

(Expected time : 30 min)

The steps to be followed to complete this tutorial are discussed next:

a. The chair frame is created by sweeping a profile along a 3D path. The 3D path will be
created in the 3D sketching environment. Therefore, you need to invoke the 3D sketching
environment and then create the sketch of the 3D path. You will create only the left half
of the 3D path in the 3D sketching environment, refer to Figure 9-113.

b. Create a plane normal to the 3D path. Selecting the newly created plane as the sketching

environment create the sketch of the profile.

c. Sweep the profile along the 3D path using the Thin Feature option, refer to Figure 9-114.
d. Mirror the sweep feature using the Front plane, refer to Figure 9-115.

Creating the Path of Sweep Feature Using 3D Sketching

Environment

It is evident from Figure 9-111 that the model is created by sweeping a profile along a 3D
path. Therefore, you need to create a path of the sweep feature in the 3D sketching

environment.
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Figure 9-111 Model of Tutorial 2
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Figure 9-112 Views and dimensions of the model for Tutorial 2
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1.

2.

10.

11.

12.

Create a new document in the Part mode.
Create a plane at an offset distance of 40mm from the Front plane.

Change the current view to isometric using the Isometric button from the Standard [E_:j
Views toolbar. .

Choose Insert > 3D Sketch from the menu bar to invoke the 3D sketching J‘E
environment. You can also use the 3D Sketch button from the Sketch toolbar to =2
invoke the 3D sketching environment. You will need to customize this button

using the Customize toolbar.

The 3D sketching environment is invoked and the sketch origin is displayed in red. You
are also provided with the confirmation corner on the top right of the drawing area. The
sketching tools that can be used in the 3D sketching environment are also invoked.

Invoke the Line tool. The select cursor is replaced by the line cursor. The XY
that is displayed below the line cursor suggests that by default it will sketch in the XY
plane.

The first line you need to create is in the ZX plane. Therefore, you will toggle the plane
before you start creating the sketch.

Choose the TAB key from the key board twice to switch to ZX plane.

Move the line cursor to the origin. When the cursor turns yellow in color, press and hold
down the left mouse button. A space handle will be displayed at the origin that indicate
the direction of X, Y, and Z.

Drag the cursor toward the left. You will notice that the Z symbol is displayed below the
cursor as you drag the cursor. This indicates that you are creating the line in the Z
direction. Release the left mouse button when the value of the length of line displays a
value close to 40.

Move the cursor to the endpoint of the previous line and when the cursor turns yellow in
color, press and hold down the right mouse button.

Drag the cursor to the right. The X symbol is displayed below the cursor, which indicates
that the line is being created in the X direction. Release the left mouse button when the
length of the line above the line cursor shows a value close to 100.

Move the cursor to the endpoint of the previous line. When the cursor snaps to the
endpoint, press and hold down the left mouse button.

Press the TAB key to switch to the XY plane. Drag the cursor vertically upwards. The Y
symbol will be displayed below the cursor, suggesting that the line is being created in the
Y direction.
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13. Release the left mouse button when the value above the cursor shows a value close to 85.

14. Similarly, create the remaining sketch and add the required relations and dimensions to
the sketch. The final sketch is displayed in Figure 9-113.

Figure 9-113 Sketch of the 3D path

15. Add a Coincident relation between the upper point of the 3D sketch and Planel.

16. Exit the sketching environment.

Creating the Profile of the Sweep Feature
As discussed earlier, the sweep feature will be created by sweeping the profile along a 3D
path. You have created the path and now you need to create the profile of the sweep
feature.

1. Select the Front plane as the sketching plane and invoke the sketching environment.
Since the Front plane is normal to the 3D path, therefore, you do not need to create a
reference plane. If any one of the default plane is not normal to the sweep profile, then

you need to create a reference plane normal to the path.

2. Create the sketch of the profile of sweep feature and add the required dimension to the
sketch. Refer to Figure 9-112.

3. Exit the sketching environment.

Sweeping the Profile Along the 3D Path

After creating the 3D path and the profile of the sweep feature, you need to sweep the
profile along the 3D path using the Sweep tool.
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Choose the Sweep button from the Features toolbar. The Sweep PropertyManager %
is invoked and you are prompted to select the sweep profile.

Select the sketch of the profile. The selected profile will be displayed green in color and
the profile callout is also displayed.

You are prompted to select the path of the sweep feature.
Select the path of the sweep feature. The path will be displayed in red color and the path
callout is also displayed. The preview of the sweep feature is also displayed in the drawing

area.

As evident from Figure 9-112, the frame of the chair is made from a hollow pipe. Therefore,
you need to create a thin sweep feature to create a hollow chair frame.

Invoke the Thin Feature rollout and set the value of the Thickness spinner to 1.

Choose the Reverse Direction button from the Thin Features rollout to reverse the
direction of thin feature creation.

Choose the OK button from the Sweep PropertyManager to end feature creation.

The model after creating the sweep feature is displayed in Figure 9-114.

Figure 9-114 Sweep featwre created by sweeping a profile along a 3D path

7. Using the mirror tool, mirror the sweep feature along the Front plane. The model after

mirroring is displayed in Figure 9-115. The FeatureManager Design Tree of the model
is shown in Figure 9-116.
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Figure 9-115 The final model
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Figure 9-116 The FeatureManager Design Tree for
Tutorial 2

Saving the Model

Next, you need to save the model.

1. Choose the Save button from the Standard toolbar and save the model with the E |
name given below and close the file

\My Documents\SolidWorks\cO9\c09-tut02.SLDPRT .

Tutorial 3

In this tutorial you will create the spring shown in Figure 9-117. The dimensions of the spring
are shown in Figure 9-118. (Expected time: 45 min)

The steps to be followed to complete this tutorial are discussed next:
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Figure 9-117 Model for Tutorial 3

Height of Spring= 72.5mm
Pitch of Spring= 10mm
Diameter of Spring= 50mm
Diameter of Coil= 7mm

25

Figure 9-118 Views and dimensions of the model for Tutorial 3
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a. First you need to create the helical path of the spring, refer to Figure 9-119.

b. Create the side clips of the spring, refer to Figure 9-122.

c.  Combine the end clips and the helical curve to create a single curve using the Composite
Curve option, refer to Figure 9-123.

d. Create the profile on the plane normal to the curve and sweep the profile along the

curve, refer to Figures 9-124 and 9-125.

Creating the Helical Curve

For creating this model first you need to create the helical path of the spring. For creating
the helical path first you need to create a circular sketch. This sketch will define the
diameter of the spring.

Start a new SolidWorks document in the Part mode and invoke the sketching environment.

Draw a circle of diameter 50. Change the view to isometric view.

Choose the Helix button from the Curves toolbar or choose Insert > Curve > E
Helix from the menu bar.

The Helix Curve dialog box is displayed and the preview of the helical curve with the
default values is displayed in the drawing area.

Select the Height and Pitch option from the Defined by drop-down list of the Helix
Curve dialog box.

Set the value of the Height spinner to 72.5 and the value of the Pitch spinner to 10.

You will observe that the preview of the helical curve is updated automatically when you
modify the values in the spinners.

Set the value of the Starting angle spinner to 0 and choose the OK button from the Helix
Curve dialog box.

The helical curve created using the above steps is shown in Figure 9-119.

Creating the Sketch of the End Clips of the Spring

‘ c09-solidworks-2003.p65

After creating the helical curve, you need to create the sketch that defines the path of the
end clips. There are two end clips in this spring, and each end clip is created using two
sketches. First, you will create the right end-clip and then the left end-clip.

Select the Front plane as the sketching plane and invoke the sketching environment.

The first sketch of the right end-clip consists of two arcs. The first arc will be created using
the Centerpoint Arc tool and the second arc will be created using the 3 Pt Arc tool.

Choose the Centerpoint Arc button from the Sketch Tools toolbar and specify )
the centerpoint of the arc at the origin.
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10.

Figure 9-119 Helical curve

Move the cursor toward the right and specify the start point of the arc when the radius of
the reference circle shows a value close to 25.
e |

Choose the 3 Pt Arc button from the Sketch Tools toolbar. Specify the start point of the
arc on the endpoint of the previous arc. Create the arc as shown in Figure 9-120.

Move the cursor in the counterclockwise direction. Specify the endpoint of the
arc when the value of the angle above the cursor shows a value close to 75.

Add the Pierce relation between the start point of the first arc and the helical path. Add
the other relations and the dimensions to fully define the sketch. The fully defined sketch
is shown in Figure 9-120.

Exit the sketching environment.

After creating the first sketch of the right end-clip, you need to create the second sketch
of the right end-clip. The second sketch of the right end-clip will be created on the Right
plane.

Select the Right plane and invoke the sketching environment.

Create the sketch as shown in Figure 9-121. You need to apply the Pierce relation between
the helical curve and the end point of left arc of the sketch.

Add a Tangent and Coincident relation between the left arc of the sketch and the sketch
created previously. Add the required relations and dimensions to the sketch. Sketch after
applying all the relations and dimensions is shown in Figure 9-121.
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Figure 9-120 First sketch of right end-clip

&0

Figure 9-121 Second sketch of right end-clip

Similarly, create the sketch of the left end-clip. Figure 9-122 shows the path of the spring
after creating the helical curve, right end-clip, and the left end-clip.

Creating the Composite Curve

c09-solidworks-2003.p65

After creating all the required sketches and the helical curve, you need to combine them
from a single curve. This is done because while creating the sweep feature you cannot
select more than one curve or sketch as a path.

Choose the Composite Curve button from the Curves toolbar or choose Insert EI

> Curve > Composite from the menu bar. The Composite Curve
PropertyManager is displayed and the confirmation corner is also available.
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2. Select all the sketches and the helical curve either from the drawing area or from the
FeatureManager Design Tree flyout.

3. Choose the OK button from the Composite Curve PropertyManager or choose OK
from the confirmation corner.

The composite curve is created. The composite curve created is displayed in Figure 9-123.

Figure 9-122 Final path of the spring Figure 9-123 Composite curve
Creating the Profile for the Sweep Feature
Now, you need to create the profile of the sweep feature. The profile of the sweep feature
will be created on a plane normal to the curve on the endpoint of the right end-clip.

1. Create a plane normal to the path and at the endpoint of the right end-clip.

2. Create the profile of the sweep feature and add the Pierce relation between the center of
the circle and the composite curve. Add the required dimension to the sketch.

3. Exit the sketching environment. Figure 9-124 shows the profile and path of the sweep
feature.

Creating the Sweep Feature
You will create a sweep feature to complete the creation of spring.

1. Invoke the Sweep PropertyManager and you are prompted to select the sweep profile.
2. Select the sweep profile from the drawing area.
You are prompted to select the sweep path.

3. Select the path and choose the OK button from the Sweep PropertyManager.

c09-solidworks-2003.p65 60 5/11/2003, 5:47 PM



Advanced Modeling Tools-III 9-61

Figure 9-124 Profile and path of the sweep feature

The spring created after sweeping the profile along the path is shown in Figure 9-125.
The FeatureManager Design Tree of the spring is shown in Figure 9-126.

Figure 9-125 Final model

Saving the Model

c09-solidworks-2003.p65

Next, you need to save the model.

Choose the Save button from the Standard toolbar and save the model with the name
given below and close the file

\My Documents\SolidWorks\c09\c09-tut02.SLDPRT.
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Figure 9-126 FeatureManager Design Tree

SELF-EVALUATION TEST

Answer the following questions and then compare your answers with the answers given at
the end of this chapter.

1. You need a profile and a path to create a sweep feature. (T/F)

2. The loft feature need at least two sections to create the feature. (T/F)
3. You cannot sweep a closed profile along a closed path. (T/F)

4. You cannot create a thin sweep feature. (1/F)

5. You can also create a loft feature using open sections. (1/F)

6. The PropertyManager is used to create a loft feature.

7. The option is used to create a curve by joining the continuous chain of existing
sketches, edges, or curves.

8. You have to apply relation between the sketch and the guide curve while
sweeping a profile along a path using guide curves.

9. option is used to create a curve by defining coordinates.

10. PropertyManager is invoked to create a cut sweep feature.

REVIEW QUESTIONS

Answer the following questions:

1. Using the rollout you can define the tangency at the start and end in the
sweep feature.
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2. The rollout is used to create a thin loft feature.

3. You need to invoke dialog box to create a spiral curve.

4. The PropertyManager is invoked to create a curve projected on a surface.
5. The dialog box is used to specify the coordinates to create the curve.

6. Which button is selected to invoke the 3D sketching environment?

(a) 2D Sketch (b) 3D Sketching Environment
(c) 3D Sketch (d) Sketch

7. Which rollout available in the Sweep PropertyManager is used to define the tangency?

(a) Start/End Tangency (b) Tangency
(c) Options (d) None of these

8. Which button available in the Features PropertyManager is used to invoke the Draft
PropertyManager?

(a) Draft (b) Taper Angle
(c) Draft Feature (c) Draft Angle

9. Inwhich rollout you can define the pull direction while creating a draft feature using the
parting line option?

(a) Pull Direction (b) Direction of Pull
(c) Reference Direction (d) Options

10. Which button available in the Guide Curves rollout is used to display the sections while
creating the sweep feature with guide curves.

(a) Preview Sections (b) Show Sections
(c) Sections (d) Preview

EXERCISES

Exercise 1

Create the model shown in Figure 9-127. The dimensions of the model are shown in
Figure 9-128. (Expected time: 1 hr)
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Figure 9-128 Views and Dimensions of the model for Exercise 1
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! \031 Tip. This model is divided in three major parts. The first part is the base and is
created by extruding the sketch to a distance of §0mm using the Mid Plane option.

The second part of this model is the right portion of the discharge venturi. This
portion is created using the sweep feature. The path of the sweep feature will be
created on the right plane. You need to create a plane at the left endpoint of the path
and will be normal to the path.

The third part of this model is the lefi portion of the discharge ventwri. This will be
created using the loft feature. You need to create the first section of the loft feature
on the planar face of the sweep feature created earlier. The second section will be
created on a plane at an offset distance from the planar face of the sweep feature
created earlier: Create a loft feature using the two section created earlier. The other
features needed to complete the model are fillets, hole, circular pattern and so on.

Exercise 2

Create the model shown in Figure 9-129. The dimensions of the model are shown in
Figure 9-130. (Expected time: 1 hr)

Figure 9-129 Model for Exercise 2
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Section A—A

Figure 9-130 Views and dimensions of the model for Exercise 2

Answer to Self-Evaluation Test
1.T,2.T, 3. F, 4. F, 5. T, 6. Loft, 7. Composite Curve, 8. Pierce, 9. Curve Through Free Points,

10. Cut-Sweep
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