
Chapter 8

Editing Features

After completing this chapter you will be able to:
• Edit the Features.
• Edit the Sketches of the Sketched Feature.
• Edit the Sketch Plane.
• Edit using the Move/Size Features option.
• Cut, Copy, and Paste the Features and Sketches.
• Copy Features using the Drag and Drop Method.
• Delete the Features.
• Delete the Bodies.
• Suppress and Unsuppress the Features.
• Move/Copy Bodies.
• Reorder the Features.
• Roll Back the Model.
• Rename the Features.
• Create the Folders.
• Use What’s Wrong? Functionality.

Learning Objectives
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EDITING THE FEATURES OF THE MODEL
Editing is one of the most important aspect of the product design cycle. Almost all the designs
require editing either during their creation or after they are created. As discussed earlier,
SolidWorks is a feature-based parametric software. Therefore, the design created in SolidWorks
is a combination of individual features integrated together to form a solid model. All these
features can be edited individually. For example, Figure 8-1 shows a base plate with some
holes.

Now, if you have to replace the four inner holes with four counterbore holes, all you need to
do is to use one editing operation. Using the editing operation, you will change the drilled
holes to the counterbore holes. For editing the holes, you have to select the hole feature and
right-click to invoke the shortcut menu. Then you will have to choose the Edit Definition
option from the shortcut menu to invoke the Hole Definition dialog box. Finally you have to
set the new parameters and end feature creation. The drilled holes will be automatically
replaced by the counterbore holes. Figure 8-2 shows the base plate with drilled holes modified
to the counterbore holes.

Similarly, you can also edit reference geometry and the sketches of the sketched features.
The feature created using the reference geometry also modify automatically when you modify
the reference geometry. For example, if you create a feature on a plane at some angle and
then edit the angle of the plane, the resultant feature is automatically modified. In SolidWorks,
you can perform editing tasks using various methods. All the methods of editing are discussed
as under.

Editing Using Edit Definition Option
The editing using the Edit Definition option is the most commonly used method of editing
in SolidWorks. To edit any feature of the model using this option, select that feature either
from the FeatureManager Design Tree or from the drawing area. After selecting the feature,
right-click to invoke the shortcut menu and choose the Edit Definition option from the shortcut
menu as shown in Figure 8-3. Depending on the feature selected, the PropertyManager or
dialog box will be invoked and you can modify the parameters of that feature. The

Figure 8-1  Base plate with drilled holes Figure 8-2  Modified base plate
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PropertyManager will also have the sequence number of the feature. The Extrude
PropertyManager is displayed in Figure 8-4 with sequence number 1. After editing the
parameters, choose the OK button to complete feature creation. The feature will be modified
automatically.

Figure 8-3  Selecting the Edit Definition option from the shortcut menu

Figure 8-4  The Extrude PropertyManager
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Editing the Sketches of the Sketched Features
In SolidWorks, you can also edit the sketches of the sketched entities using the Edit Sketch
option. To edit the sketch of a sketched feature select the feature either from the
FeatureManager Design Tree or from the drawing area and right-click to invoke the shortcut
menu. Choose the Edit Sketch option from the shortcut menu. When you choose this option,
you will enter the sketching environment. Using the standard sketching tools, edit the sketch
of the sketched feature. After editing the sketch, exit the sketching environment. To exit the
sketching environment you can also select the Rebuild button from the Standard toolbar or
choose View > Rebuild from the menu bar. Using this you will exit the sketching environment
and the model will also be rebuilt. You can also choose CTRL+B to rebuild the model.

Changing the Sketch Plane of the Sketches
You can also change the sketch plane of the sketches of the sketched features. To edit the
sketch plane, expand the sketched feature by clicking on the + sign on the left of that feature
in the FeatureManager Design Tree. Select the sketch icon in the FeatureManager Design
Tree. Right-click to invoke the shortcut menu and choose the Edit Sketch Plane option from
the shortcut menu. Figure 8-5 shows the Edit Sketch Plane option being chosen from the
shortcut menu. The Sketch Plane PropertyManager will be displayed as shown in Figure 8-6.
The name of the current sketch plane is displayed in the Sketch Plane/Face display area.
Now, select any other plane or face as the sketching plane. After selecting the new sketching
plane, choose the OK button from the Sketch Plane PropertyManager.

Editing by Double-Clicking the Entities and Features
You can also edit a feature, a reference geometry, or a sketch by double-clicking the feature
either from the FeatureManager Design Tree or from the drawing area. For example, if you
double-click an extrude feature, all the dimensions of the feature and the sketch of the feature
are displayed in the drawing area. Remember that all the dimensions of the sketch will be
displayed in black color and all the dimensions of the feature will be displayed in blue color.
Move the cursor on the dimension to be modified, the dimension will be displayed enclosed
in a red box. Double-click the dimension to invoke the Modify dialog box. Set the new value
in the Modify dialog box and press the ENTER key from the keyboard or choose the Save the
current value and exit the dialog button from the dialog box. You will notice that the value
of the dimension is modified but the model is not modified relative to the modified value.
Therefore, you have to rebuild the model using the Rebuild option. To rebuild the model,
choose the Rebuild button from the Standard toolbar or choose Edit > Rebuild from the
menu bar. You can also rebuild the model using CTRL+B from the keyboard.

Tip. You can also use the + sign available on the left of a sketched feature to
expand that sketched feature in the FeatureManager Design Tree. The sketch
icon will be displayed when you expand a sketched feature. Select the sketch icon
and invoke the shortcut menu. Select the Edit Sketch option from the shortcut

Tip. If you select a sketch plane on which the relations and dimensions do not find
any reference to be placed, the Rebuild Errors dialog box will be displayed. You,
will have to undo the last step using the Undo button from the Standard toolbar,
invoke the Sketch Plane PropertyManager again, and then select the appropriate
plane. You will learn more about the Rebuild Errors dialog box later in this
chapter.
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Figure 8-5  The Edit Sketch Plane option being selected

Figure 8-6  The Sketch Plane PropertyManager

Editing Using the Move/Size Features

Using this option you can dynamically modify the feature and the sketch of the sketched
feature without invoking the sketching environment. To edit the feature or sketch
using this option, choose the Move/Size Features button from the Features toolbar.

You will notice that the Move/Size Features button is chosen in the Features toolbar. Select
any face of the feature to modify. The selected face will be highlighted in green and if the
selected feature is a sketched feature then the sketch of that feature will also be highlighted in

Toolbar: Features > Move/Size Features
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green. You will be provided with the resize handle, rotate handle, and the move handle.
Figure 8-7 shows the move handle, resize handle, and the rotate handle provided for the
selected feature.

To resize the feature, move the cursor to the resize handle; the select cursor will be replaced
by the resize cursor and the name of the resize cursor will be displayed as the tooltip. Press
and hold down the left mouse button at this location and drag the cursor to resize the feature.
The feature will be resized with an increment of 10. Release the left mouse button when you
have resized the feature. You will notice that the feature will be dynamically resized. Figure 8-8
shows the cursor being dragged to resize the feature. Figure 8-9 shows the resultant modified
feature.

Figure 8-7  Feature selected with Move/Size Features button selected

Figure 8-8  Dragging the resize handle to resize
the feature

Figure 8-9  Resultant modified feature
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Figure 8-11  Preview of feature being rotated Figure 8-12  Resultant rotated feature

Figure 8-10  The Move Confirmation dialog box

The rotate handle is used to rotate the selected feature. To rotate the feature using the rotate
handle, move the cursor to the rotate handle and press and hold down the left mouse button.
Drag the cursor to rotate the feature. You can drag the feature clockwise or counterclockwise.
The preview of the feature will be displayed in the drawing area. The feature will be rotated
with an increment of 10º. Release the left mouse button after rotating the feature to a specified
location.

Note
If you rotate a sketched feature in which the sketch of the feature is fully defined or partially
defined using relations and dimensions, the Move Confirmation dialog box will be displayed.
The Move Confirmation dialog box is displayed in Figure 8-10. This dialog box informs you
that the external constraints in the feature are being moved, do you want to delete those constraints
or keep the constraints by recalculating or make them dangling. Those relations or dimensions
that do not find the external reference after the placement are made dangling.

After rotating the feature, if the Move Confirmation dialog box is invoked then you have to
choose either the Delete button or the Keep button, based on the geometric and dimensional
conditions. Figure 8-11 shows the preview of rotating the feature. Figure 8-12 shows the resultant
rotated feature.
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To move a feature using the move handle, select a face of the feature and move the cursor to
the move handle. Press and hold down the left mouse button and drag the cursor to move the
feature. Release the left mouse button after moving the feature to the required position. If the
dimensions or relation of the feature are not able to be defined after moving the feature, the
Move Confirmation dialog box will be displayed. Choose the options available in this dialog
box. Using this option, you can also change the placement plane of the feature or the sketch
plane of the feature. Figure 8-13 shows the feature being moved to another face. Figure 8-14
shows the resultant moved feature.

You can also modify the sketches of the sketched feature using this option. To modify the
sketch, move the cursor to the sketch highlighted in light green color. A vertical line appears
on the right of the cursor. Press and hold down the left mouse button and drag the cursor.
After modifying the sketch to the required size, release the left mouse button. Figure 8-15
shows the preview of the sketch being modified. Figure 8-16 shows the resultant modified
model.

Figure 8-13  The feature being moved Figure 8-14  Resultant moved feature

Tip. When you resize, move, or rotate a feature using the Move/Size Features
tool, the feature(s) that has a relationship with that feature will also be modified. In
other words, if a child-parent relationship is established between the features, the
child features will also be modified when you modify the parent feature.

Tip. To unselect the selected feature, click once anywhere in the drawing area or
choose the ESC key from the keyboard. You will notice that the Move/Size Features
button is still chosen in the Features toolbar, which indicates that the dynamic
move/size features option is still active. To exit this option you have to choose the
Move/Size Features button again.
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Figure 8-15  Preview of the sketch being modified Figure 8-16  Resultant modified model

Figure 8-17  Preview of the sketch being modified

Editing the Sketches With the Move/Size Features Tool
Active
When the Move/Size Features tool is active and you choose the Edit Sketch option to edit the
sketch of the sketched feature you will enter the sketching environment. The feature whose
sketch you have to modify will be displayed in transparent yellow temporary graphics as
shown in Figure 8-17.

Now, modify the sketch according to the requirement. Consider a case in which two circles are
added to the model and the height of the inclined line is increased. The model shown in
temporary graphics will be modified dynamically in the sketcher environment. Therefore,
you can have a better understanding of the model, that how it will be displayed after modifying
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the sketch. Note that the temporary graphic will show the preview of the feature created by
the section you add only if you drag one of the entity in the sketch. Otherwise, the new
addition will not be display as a preview in the temporary graphics. It is recommended that
you invoke the Modify/Size Features button before modifying the sketch. After modifying
the sketch exit the sketcher environment. If the sketch of the model is dimensioned then you
can modify the sketch by modifying the dimension. Figure 8-18 shows two circles added to the
model and the length of the inclined line being increased. Figure 8-19 shows the resultant
modified model.

Editing the Features and Sketches by Cut, Copy, and Paste
SolidWorks allows you to adapt the windows functionality of cut, copy, and paste to copy and
paste the features. The method of using this functionality is the same as used in other
windows-based applications. Select the feature or sketch to cut or copy. To cut the selected
item, choose Edit > Cut from the menu bar or use the shortcut key, CTRL+X. The Delete
Confirmation dialog box is displayed because when you cut the selected item, it is deleted
from the document. Choose Yes button from this dialog box. You will learn more about deleting
later in this chapter. After you cut an item, select the placement plane or placement reference
where you want to place the feature. Choose Edit > Paste from the menu bar or use the
shortcut key CTRL+V from the keyboard. Sometimes the Copy Confirmation dialog box is
displayed as shown in Figure 8-20. In that dialog box, you are prompted either to delete the
external constraints or leave them dangling. This dialog box is displayed only when the item
to paste has some external references in the form of relations and dimensions. The feature
will be pasted on the selected reference.

Figure 8-18  Sketch being modified Figure 8-19  Resultant modified model

Tip. If you want to modify the sketch by dragging and the sketch is fully or partially
defined using dimensions, the Override Dims on Drag/Move option should be
selected. To select this option choose Tools > Sketch Settings > Override Dims
on Drag/Move from the menu bar. If this option is not selected, you cannot move
or drag a dimensioned sketched entity.
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Figure 8-20  The Copy Confirmation dialog box

If you copy and paste an item, the selected item will remain at its position and a copy of that
item will be pasted on the selected reference. To copy an item, select the feature or sketch.
Choose Edit > Copy from the menu bar or press CTRL+C from the keyboard. Select the
reference where you want to paste the selected item and choose Edit > Paste from the menu
bar or press CTRL+V from the keyboard to paste. You can paste the selected item any number
of times. If you select another item and copy on the clipboard, the last copied item will be
deleted from the memory of the clipboard.

Cut, Copy, and Paste Features and Sketches from One
Document to the Other
You can also cut or copy the features and sketches from one document and paste them in
another document. For example, you have to copy a sketch created in the current document
and paste it in a new document. You just need to select the sketch and use CTRL+C from
keyboard to copy the item to the clipboard. Create a new document in the Part mode and
select the plane on which you want to paste the sketch. Press CTRL+V from the keyboard to
paste the sketch on the selected plane. Using the same procedure, you can also copy features
from one document to the other.

Copying Features Using Drag and Drop
SolidWorks also provides you with drag drop functionality of windows to copy and paste the
item within the document. Press and hold down the CTRL key from the keyboard and select
and drag that item from the drawing area or from the FeatureManager Design Tree. Drag
the cursor to a location where you want to paste the item and release the left mouse button on
that location. If the item to be pasted is defined using the dimensions or relations, the Copy
Confirmation dialog box will be displayed to delete or make those constraints dangle.
Figure 8-21 shows the feature being dragged. Figure 8-22 shows the resultant pasted feature.

Dragging and Dropping Features from One Document to Other
You can also drag and drop features and sketches from one document to the other. For pasting
the items from one document to the other, you should open both the documents in the

Tip. For pasting a selected sketch, you have to select a plane or a planar face as the
reference. For pasting a sketched feature, a simple hole, or a hole created using the
hole wizard, you have to select a plane or a planar face as the reference. For pasting
chamfers and fillets, you have to select an edge or edges as the references.

c08-solidworks-2003.p65 5/12/2003, 11:54 AM11



8-12 SolidWorks for Designers

Figure 8-23  Fillet feature being dragged to be pasted in the second document

SolidWorks session. Choose Windows > Tile Vertical/Tile Horizontal from the menu bar.
Display both the documents at the same time in the SolidWorks window. Press and hold down
the CTRL key from the keyboard, select and drag the feature or sketch to the other document,
and place it on the required reference. Figure 8-23 shows the fillet feature being dragged to
be applied on the edge of the model in the second document.

Figure 8-21  Feature being dragged Figure 8-22  Resultant pasted feature
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Figure 8-24  The Confirm Delete dialog box

Deleting the Features
You can delete the unwanted features from the model by selecting the feature either from the
FeatureManager Design Tree or from the drawing area. After selecting the feature to be
deleted, choose the DELETE key from the keyboard or right-click to invoke the shortcut
menu and choose the Delete Feature option. If you delete a sketched feature or a feature that
acts as the parent feature for the other feature, the Confirm Delete dialog box is displayed as
shown in Figure 8-24. This dialog box informs you that all the dependent features to this
parent feature will also be deleted. Choose the Yes button if you want to delete all the features
or else choose the No button to cancel the delete operation. You can also delete a selected
feature by choosing Edit > Delete from the menu bar. When you delete a feature, the absorbed
feature related to that feature will not be deleted. For example, if you delete a boss feature the
sketch feature is not deleted. If you need to delete the absorbed feature when you delete the
parent feature select the Also delete absorbed features check box from the Confirm Delete
dialog box.

Deleting the Bodies

As discussed earlier, the multi-body environment is supported in SolidWorks.
Therefore, you can create multiple disjoint bodies in SolidWorks. You can also delete
the unwanted bodies. The bodies to be deleted can be solid bodies or surface bodies.

You will learn more about surface bodies in later chapters. To delete a body, choose the
Delete Solid/Surface button from the menu bar or choose Insert > Features > Delete Body
from the menu bar. The Delete Body PropertyManager is invoked as shown in Figure 8-25.
You are prompted to select the solid and/or surface bodies to be deleted. Select the body or
bodies to be deleted from the drawing area or from the Solid Bodies folder available in the
FeatureManager Design Tree flyout. The selected body is displayed in green and the edges
of the selected body are highlighted in yellow. The name of the selected body is displayed in

Toolbar: Features > Delete Solid/Surface (Customize to Add)

Menu: Insert > Features > Delete Body
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the Bodies to Delete display area. Choose the OK button from the Delete Body
PropertyManager. A new item with the name Body-Delete1 appears in the FeatureManager
Design Tree. This item stores the deleted bodies. Therefore, at any point of your design cycle
you can delete or suppress this item to resume the deleted body back in your design. You will
learn more about suppressing the feature later in this chapter.

Suppressing the Features

Sometimes, you do not want a feature to be displayed in the model or in the drawing
views of that model. Instead of deleting those features, they can be suppressed. When
you suppress a feature, it is neither visible in the model nor in the drawing views. If

you create an assembly using that model, the suppressed feature will not be displayed even in
the assembly. You can anytime resume the feature by unsuppressing it. When you suppress a
feature, the features that are dependent on the suppressed feature are also suppressed. To
suppress a feature, select it from the FeatureManager Design Tree or from the drawing area.
Choose the Suppress button from the Features toolbar or right-click and choose the Suppress
option from the shortcut menu. The suppressed feature will be removed from the model and
the icon of the feature will be displayed in gray in the FeatureManager Design Tree.

Note
You can work with different configurations in a single document of SolidWorks. Therefore, you
have to specify in which configuration you are suppressing a feature. This is specified when you
choose the suppress option from the menu bar. You will learn more about configurations later in
this book.

Toolbar: Features > Suppress (Customize to Add)

Menu: Edit > Suppress > This Configuration

Tip. You can also choose the Delete Body option from the shortcut menu. To delete
a body using the shortcut menu select the body and right-click to invoke the shortcut
menu. Choose the Delete Body option from the shortcut menu. The Delete Body
PropertyManager will be displayed. Choose the OK button from the Delete Body
PropertyManager to delete the body.

Figure 8-25  The Delete Body PropertyManager
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Toolbar: Features > Unsuppress (Customize to Add)

Menu: Edit > Unsuppress > This Configuration

Toolbar: Features > Unsuppress with Dependents (Customize to Add)

Menu: Edit > Unsuppress with Dependents > This Configuration

Unsuppressing the Features

The suppressed features can be unsuppressed using this option. To resume the
suppressed feature, select the suppressed feature from the FeatureManager Design
Tree and choose the Unsuppressed button from the Features toolbar or choose Edit

> Unsuppressed from the menu bar. You can also choose this option from the shortcut menu
after selecting the suppressed feature. As discussed earlier, when you suppress a feature, the
dependent features are also suppressed. But when you resume a suppressed feature, the
dependent features remain suppressed. Therefore, you have to unsuppress all the features
independently. Resuming the parent feature and the dependent features using a single option
is discussed next.

Unsuppressing Features With Dependents

Using this option you can resume the suppressed feature along with the dependents
of the suppressed parent feature. To resume the suppressed feature using this option,
select the suppressed feature from the FeatureManager Design Tree. Choose

Unsuppress with Dependents > This Configuration from the Features toolbar. You will
observe that the dependent suppressed features are also unsuppressed.

Hiding the Bodies
While working in the multibody environment, you can also hide the bodies. The hidden body
is not displayed in the model and assembly, and drawing views. The bodies that are dependent
on the hidden body do not hide. To hide a body, expand the Solid Bodies folder available in
the FeatureManager Design Tree and select the body to hide. Right-click to invoke the shortcut
menu and choose the Hide Solid Body option from the shortcut menu. The selected body
will disappear from the drawing area. The icon of the hidden body is displayed in wireframe
in the Solid Bodies folder. Select the hidden body from that folder and choose the Show
Solid Body option from the shortcut menu to show the hidden body.

Move/Copy Bodies

In SolidWorks you can also move or copy the bodies. To move or copy the bodies
choose the Move/Copy Bodies button from the Features toolbar or choose Insert >
Features > Move/Copy Bodies from the menu bar. The Move/Copy Body

PropertyManager will be displayed as shown in Figure 8-26. The confirmation corner is also
displayed in the drawing area. You will observe a filled square at the document origin. The
various options available in the Move/Copy Body PropertyManager are discussed next.

Toolbar: Features > Move/Copy Bodies (Customize to Add)

Menu: Insert > Features > Move/Copy Bodies
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Figure 8-26  The Move/Copy Body PropertyManager

Bodies to Move/Copy
The Bodies to Move/Copy rollout is used to define the body to copy or move. When you
invoke the Move/Copy Body PropertyManager, you are prompted to select the bodies to
move/copy and set the options. Move the cursor to the body to be selected. The cursor will be
replaced by the body selection cursor and the edges of the body are highlighted in red. The
name of the body is also displayed in the tooltip. Use the left mouse button to select the body.
The selected body is highlighted in green and the edges of the body are displayed in yellow.
The name of body is displayed in the Solid and Surface or Graphics Bodies to Move/Copy
display area. You can also select the body from the Solid Bodies folder after invoking the
FeatureManager Design Tree flyout.

Copy
Since the Copy check box is cleared by default, you can move the selected body only after
setting the options. If you select the Copy check box, you can create the copies of the
selected body. When you select this check box the Number of Copies spinner is displayed
below the Copy check box. Set the number of copies using this spinner.

Translate
The Translate rollout available in the Move/Copy Body PropertyManager is used to define
the translational parameters to move the selected body. Set the value of the destination in the
Delta X, Delta Y, and Delta Z spinners. When you set the value, the preview of moved body is
displayed in temporary graphics in the drawing area. You can also move or copy the selected
body between points. To move or copy a body by specifying two points, select the Translation
Reference (Linear Entity, Coordinate System, Vertex) display area. The selection mode in
this area is active. Select the vertex from which you want the translation to start. When you
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select the first vertex as translation reference, the Delta X, Delta Y, and Delta Z spinners are
replaced by the To Vertex display area. The selection mode in the To Vertex display area is
active. Select the second translation reference. You will observe the preview of the body move
between two selected vertices. The placement of the body also depends on the sequence of
selection of vertices. Therefore, you have to be very careful while selecting the two vertices.
Figure 8-27 shows the sequence for the selection of references. Figure 8-28 shows the resultant
copied body.

Rotate
The Rotate spinner available in the Move/Copy Body PropertyManager is used to define the
parameters to rotate the body. To open this rollout, click once on the black arrow provided at
the right of this rollout. The Rotate rollout is shown in Figure 8-29.

As discussed earlier, a filled square is placed at the origin when you invoke the Move/Copy
PropertyManager. This filled square is clearly visible if you hide the origin by choosing View
> Origin from the menu bar. It indicates the origin along which the selected body will be
rotated. You can adjust the position of this temporary moveable origin using the X Rotation
Origin spinner, Y Rotation Origin spinner, Z Rotation Origin spinner. The X Rotation

Figure 8-29  The Rotate rollout

Figure 8-27  Sequence of selection Figure 8-28 Resultant copied feature
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Figure 8-30  The SolidWorks warning message dialog box

Angle spinner is used to set the value of the angular increment to rotate or copy the body
along x-axis. The Y Rotation Angle spinner is used to rotate or copy the body along y-axis.
The Z Rotation Angle spinner is used to rotate or copy the body along z-axis.

To rotate or copy the selected body along an edge, click once in the Rotation Reference
(Linear Entity, Coordinate System, Vertex) display area to invoke the selection. Select the
edge along which you want to rotate the selected body. When you select an edge, all the other
spinners disappear from the rollout and the Angle spinner is invoked in the Rotate rollout.
Set the value of the angular increment in this spinner.

Instead of selecting an edge, you can also select a vertex along which the body will rotate or
copy. Then you have to specify the axis along which you want to rotate the body.

Reordering the Features
Reordering the features is defined as a process of changing the position of the features created
in the model. Sometimes, after creating a model it may be required to change the order in
which the features of the model were created. For reordering the features, the features are
dragged and placed before or after another feature in the FeatureManager Design Tree.

For reordering the features, select the feature in the FeatureManager Design Tree and drag
the feature to the required position. When you drag the feature to reorder, the bend arrow
pointer       is displayed, that suggests that feature dragging is possible. If you drag the child
feature above the parent feature, the reorder error pointer       will be displayed. If you drag
a child feature above a parent feature, the SolidWorks warning message dialog box will be
displayed as shown in Figure 8-30. Choose OK from this dialog box.
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Figure 8-32  Shell feature added to the model

Figure 8-31  Model created creating a pattern of the holes on the base feature

Consider a case in which you have created a rectangular block and a pattern of through holes
are created on the base feature as shown in Figure 8-31. Now, if you create a shell feature and
remove the top face, the front face, and the right face of the model, the model will appear as
shown in Figure 8-32. But this was not the desired result. This, is the reason you need to
reorder the shell feature before the holes. Select the shell feature in the FeatureManager
Design Tree and drag it above the holes. All the features will be automatically adjusted in the
new order as shown in Figure 8-33.
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Figure 8-34  The rollback bar of the
FeatureManager Design Tree

Rolling Back the Model
Rolling back the model is defined as a process in which you rollback the model to an earlier
stage. When you rollback a feature or features, those features are suppressed and you can add
new features when the model is in the rollback state. The newly added features are added
before the features that are rolled back. While working with a multifeatured model you want
to edit a feature that was created at the starting of the design cycle of the model. It is
recommended that you should rollback the model up to that feature. This is because after
each editing operation the time of regeneration will be minimized. Rolling back is done using
the Rollback Bar available in the FeatureManager Design Tree as shown in Figure 8-34.

Figure 8-33  Model after reordering the features.
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Using the select tool select the Rollback Bar; after selection it will be changed to blue color
and the select cursor will be replaced by the hand pointer Drag        the hand pointer to the
feature upto which you want to rollback the model and release the pointer. To resume or roll
the model, drag the Rollback Bar to the last feature of the model. You can also rollback using
the menu bar. Select the feature up to which you want to rollback the model and choose Edit
> Rollback from the menu bar.

Renaming the Features
The name of the features is displayed in the FeatureManager Design Tree. By default the
naming of the features is done according to the sequence in which the features are created.
You can also rename the features according to your convenience. To rename a feature, select
the feature from the FeatureManager Design Tree and click once on the selected feature. An
edit box will be displayed in the FeatureManager Design Tree. Enter the name of the feature
and press the ENTER key or anywhere on the screen.

Creating Folders in the FeatureManager Design Tree
You can also add the folders in the FeatureManager Design Tree and the features displayed
in the FeatureManager Design Tree are added in the folder. This is done to reduce the
length of the FeatureManager. Consider a case in which the base of the model consists of
more than one feature. You can add a folder named Base Feature and add all the features
used to create the base in that folder. To add a folder in the FeatureManager Design Tree
select any feature and right-click to invoke the shortcut menu. Choose the Create New Folder
option from the shortcut menu. A new folder is created above the selected feature. Now, you
can drag and drop the features to the newly created folder. You can also rename the folder by
selecting it and then clicking it once. Now, enter the name in the edit box and press the
ENTER key.

To add the selected feature in a new folder, choose Add to New Folder from the shortcut
menu. A new folder will be created in the FeatureManager Design Tree and the selected
feature will be added to the newly created folder. You can also delete the folder by selecting
the folder and invoking the shortcut menu. Select the Delete option from the shortcut menu.
Using the options in this shortcut menu you can also rollback and suppress the features
available in the selected folder.

What’s Wrong? Functionality
When you modify a sketch or a feature and rebuild the model, sometimes the model does not
rebuild properly because of the geometric errors resulting the modification. Therefore, you
are provided with a Rebuild Errors dialog box as shown in Figure 8-35. The possible error in
the feature are displayed in this dialog box.

Tip. If you want to roll the model to the previous step choose Edit > Roll to
Previous from the menu bar. If you want to roll the entire model to its original
position, choose Edit > Roll to End from the menu bar.

You can also choose Roll Forward, Roll Previous, Roll End options from the
shortcut menus invoked by selecting the features placed below the Rollback Bar.
These options are used to control the roll and rollback of the model.
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Figure 8-36  The FeatureManager Design Tree with a feature having errors

The Display errors at every rebuild check box is selected by default and is used to display
the errors at every rebuild of the model unless the error is fixed. The Display full message
check box is used to display the complete error message in the Rebuild Errors dialog box.
After reading the error from this dialog box, choose the Close button to exit the dialog box.
The errors are also displayed in the FeatureManager design Tree. The FeatureManager
Design Tree with an error in a feature is displayed in Figure 8-36.

Figure 8-35  The Rebuild Errors dialog box
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Figure 8-37  Model for Tutorial 1

Tip. You can also invoke the Rebuild Errors dialog box by selecting the feature
having errors from the FeatureManager Design Tree and choose the What’s
Wrong? option from the shortcut menu. To view all the errors in a model, select the
name of the document from the top of the FeatureManager Design Tree and
invoke the Rebuild Errors dialog box. All the errors in the model are displayed in
the Rebuild Errors dialog box.

While creating the features, if there are some geometrical constraints in creating
the feature, the Rebuild Errors dialog box is displayed.

TUTORIALS

Tutorial 1
In this tutorial you will create the model shown in Figure 8-37. After creating some of the
features of the model you will dynamically modify the model and then undo the modification.
The dimensions of the model are shown in Figure 8-38.                  (Expected time: 30 min)

The steps to be followed to create the model are discussed next:

a. Create the base feature of the model by extruding the profile to a given distance, refer to
Figures 8-39 and 8-40.

b. Add the fillets to the base feature, refer to Figures 8-41 and 8-42.
c. Add the shell feature to the model and remove the top face of the base feature, refer to

Figures 8-43 and 8-44.
d. Dynamically modify the model, refer to Figures 8-45 through 8-47.
e. Create the cuts on the sides of the model, refer to Figure 8-48.
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f. Create the slots on the lower part of the base and add the fillet to the slots feature, refer
to Figure 8-48.

g. Pattern the slots and the fillet feature, refer to Figure 8-48.
h. Create a plane at an offset distance from the Top plane.
i. Create the standoffs of the soap case using the extrude and fillet tool and pattern the

same, refer to Figure 8-49.

Creating the Base Feature
First, you will create the base feature of the model by extruding a sketch using the Mid Plane
option created on the Front plane.

1. Start SolidWorks and open a new part document from the Template tab of the New
SolidWorks Document dialog box.

2. Draw the sketch of the base feature on the Front plane and add the required relations and
dimensions to the sketch as shown in Figure 8-39.

Figure 8-38  Views and dimensions of the model for Tutorial 1
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Figure 8-39  Sketch for the base feature

Figure 8-40  Base feature of the model

3. Extrude the sketch to a distance of 35mm using the Mid Plane option.

The base feature of the model is shown in Figure 8-40.

Filleting the Edges of the Base Feature
After creating the base feature you will fillet the lower edges of the base feature.

1. Invoke the Fillet PropertyManager, rotate the model, and select the edges of the base
feature as shown in Figure 8-41.
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Figure 8-43  Face to be selected Figure 8-44  Shell feature added to the model

2. Set the value of the radius spinner to 2.5 and choose the OK button from the Fillet
PropertyManager.

The model after filleting the edges of the model is shown in Figure 8-42.

Shelling the Model
After creating the fillet feature, you need to shell the model using the Shell tool.

1. Orient the model in the isometric view and invoke the Shell PropertyManager.

2. Select the top planar face of the model as shown in Figure 8-43.

3. Set the value of the Thickness spinner to 1 and choose the OK button from the Shell
PropertyManager.

The model after adding the shell feature is shown in Figure 8-44.

Figure 8-41  Edges to be selected Figure 8-42  Fillet added to the model
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Figure 8-45  Editing handles for editing the base feature

Dynamically Editing the Features
After creating and shelling the base of the model you will learn how to edit the features
dynamically using the Move/Size Features tool.

1. Choose the Move/Size Features button from the Features toolbar to invoke the
dynamic dragging tool.

2. Select the right planar face of the base feature from the drawing area. The selected face
will be highlighted in green. The sketch of the selected feature is also displayed in the
drawing area along with various editing handles as shown in Figure 8-45.

3. Select the Resize handle from the drawing area and drag the cursor to resize the feature.

The preview of the resized feature and the dimension of the feature is displayed in the
drawing area. As you drag the cursor the preview and the dimension updates automatically.

4. Release the left mouse button after dragging the feature to some distance.

Figure 8-46 shows the preview of the dragged feature. Figure 8-47 shows the edited feature.

5. Select the Move/Size Features button again to disable the dynamic editing tool and click

Tip. You can also select the feature to be edited from the FeatureManager Design
Tree.

If you want to edit the sketches using the Move/Size Features tool, then you need
to select the Override Dimension option by choosing Tools > Sketch Settings >
Override Dims on Drag/Move from the menu bar. If a check mark is displayed at
the left of this option in the menu bar, then the option is already selected.
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anywhere in the drawing area to clear all the selections from the selection set.

You have edited the model by dynamically dragging, the feature needs to have the required
dimension of 35mm. Therefore, now you will again edit the feature to retain the depth of
the feature.

6. Double-click the base feature in the FeatureManager Design Tree or from the drawing
area. All the dimensions of the feature are displayed in the drawing area.

7. Double-click the dimension that reflects the depth of the base feature.

8. The Modify dialog box will be displayed. Set the value of the Dimension spinner to 35
and press the ENTER key from the keyboard.

9. Choose the Rebuild button from the Standard toolbar or choose CTRL+B from the
keyboard to rebuild the model.

Using the Cut-Extrude, Fillet, and Linear Pattern tools create the remaining features of
the model. The model after creating the features using these tools is displayed in
Figure 8-48.

Creating the Standoffs of the Model
After creating all the features of the model, you need to create the standoffs of the model.
It is created by extruding a sketch created on a sketch plane at an offset distance from the
Top plane. You also need to specify a draft angle while creating this feature.

1. Create a reference plane at an offset distance of 10.5mm from the Top plane. You need to
select the Reverse direction check box from the Plane PropertyManager.

2. Select the newly created sketching plane and create the sketch of the standoff and apply
the required relations and dimensions. The sketch consists of a circle of diameter 1mm.
For more dimensions refer to Figure 8-38.

Figure 8-46  Dragging the Resize handle Figure 8-47  Resultant edited feature

c08-solidworks-2003.p65 5/12/2003, 11:54 AM28



Editing Features       8-29

Figure 8-48  Model after creating other features

Figure 8-49  Rotated and zoom view of the model

3. Extrude the sketch using the Up To Next option with an outward draft angle of 10-degree.
Hide the newly created plane.

4. Rotate the model and add a fillet of radius 0.25 to the extruded feature.

The rotated and zoom view of complete standoff is displayed in Figure 8-49.
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Figure 8-51  The FeatureManager Design Tree of the model

5. Pattern the extruded and filleted feature using the Linear Pattern tool. The isometric
view of the final model is shown in Figure 8-50. The FeatureManager Design Tree of the
model is shown in Figure 8-51.

Figure 8-50  Final model
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Saving the Model
Next, you need to save the model.

1. Choose the Save button from the Standard toolbar and save the model with the
name given below:

\My Documents\SolidWorks\c08\c08-tut01.SLDPRT.

2. Choose File > Close from the menu bar to close the file.

Tutorial 2
In this tutorial you will create the model shown in Figure 8-52. After creating the model you
will edit the model with Move/Size Features option selected. The views and dimensions of the
model are shown in Figure 8-53.    (Expected time:  45 min)

The steps to be followed to complete this tutorial are discussed next:

a. Create the base feature of the model by revolving the sketch along the central axis of the
sketch, refer to Figures 8-54 and 8-55.

b. Create the sketch of the second feature on the top face of the base feature and extrude it
 to the given distance, refer to Figures 8-56 and 8-57.

c. Create the revolve cut feature, refer to Figures 8-58 and 8-59.
d. Create the holes using the Simple Hole tool and pattern the hole using the Circular

Pattern tool, refer to Figure 8-59.
e. Create a drilled hole feature using the Hole Wizard tool, refer to Figure 8-59.
f. Mirror the hole feature along the Right plane, refer to Figure 8-59.
g. Create the fillet feature, refer to Figure 8-59.

Figure 8-52  The dimetric view of the model for Tutorial 1
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Creating the Base Feature
First, you will create the base feature of the model by revolving the sketch created on the
Front plane.

1. Start SolidWorks and open a new part document from the Template tab of the New
SolidWorks Document dialog box.

2. Draw the sketch of the base feature on the Front plane and add the required relations and
dimensions to the sketch as shown in Figure 8-54.

3. Invoke the Revolve PropertyManager.

Since the default value in the Angle spinner is the same as required, therefore you do not
need to set any parameters in this PropertyManager.

Figure 8-53  Views and dimensions of the model for Tutorial 1
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4. Choose the OK button from the Revolve PropertyManager.

The base feature created after revolving the sketch is shown in Figure 8-55.

Creating the Second Feature
The second feature of this model is an extruded feature. This feature is created by extruding
a sketch created on the top planar face of the base feature.

1. Select the top planar face of the base feature and invoke the sketching environment.

2. Create the sketch of the second feature and apply the required relations and dimensions
to the sketch as shown in Figure 8-56. Make sure the sketch is symmetrical about the axis.
If it is not, the sketch will not be properly mirrored.

Figure 8-55  Dimetric view of the base featureFigure 8-54  Sketch for the base feature

Figure 8-56  Sketch for the second feature
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Figure 8-57  Second feature added to the model

3. Extrude the sketch to a distance of 75mm.

The isometric view of the model after creating the second feature is displayed in
Figure 8-57. Make sure the skectch is symmetrical about the axis. If it is not, the sketch
will not be properly mirrored.

Creating the Third Feature
The third feature of the model is created by revolving a sketch using the cut option. The
sketch for this feature will be created on the Front plane.

1. Select the Front plane and invoke the sketching environment.

2. Create the sketch for the revolve cut feature and apply the required relations and
dimensions to the sketch as shown in Figure 8-58.

3. Invoke the Cut-Extrude PropertyManager and create a revolved cut feature by specifying
an angle on 360-degree.

Creating the Remaining Features
1. Create the other features of the model by referring to Figure 8-53.

The isometric view of the model after creating all the other features is displayed in
Figure 8-59.
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Figure 8-58  Sketch for the revolve cut feature

Editing the Sketch of the Model With the Move/Size Features Option
Active

After creating the model, you will edit the sketch of the second feature with the Move/
Size Features option active. Therefore, before proceeding further you have to invoke this
option.

1. Choose the Move/Size Features button from the Features toolbar to invoke the
Move/Size Features option.

Figure 8-59  Final model
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Figure 8-60  Sketch and the preview of the second feature

2. Select the second feature from the drawing area and right-click to invoke the shortcut
menu.

3. Choose the Edit Sketch option from the shortcut menu.

The sketch of the second feature with the preview of the feature in temporary graphics is
displayed in the drawing area as shown in Figure 8-60.

Now, you will modify the sketch by dragging the sketch entities. You will observe that the
preview of the second feature that is displayed in temporary graphics is also modified.

4. Choose Tools > Sketch Settings > Override Dims on Drag/Move option from the menu
bar, if it is not selected.

5. Select the centerpoint of the right arc of sketch and drag the cursor towards the right. As
you drag the cursor the preview of the feature is also modified dynamically. Release the
left mouse button. The new dimension appears on the sketch. Continue this process until
the value of the distance between the center of the arcs shows a value close to 135.

Figure 8-61 shows the sketch being dragged. Figure 8-62 shows the final dragged sketch.

After modifying the sketch by dragging, now you will retain the previous dimensions.

5. Double-click the linear dimension and enter 75 in the Modify edit box and press the
ENTER key.

Similarly, edit the other two dimensions using the Modify edit box.
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Figure 8-61  Dragging the sketch Figure 8-62  Sketch after dragging

6. Use CTRL+B from the keyboard to rebuild the model.

The FeatureManager Design Tree of the model is shown in Figure 8-63.

Saving the Model
Now, you need to save the model.

1. Choose the Save button from the Standard toolbar and save the model with the
name given below:

\My Documents\SolidWorks\c08\c08-tut02.SLDPRT.

2. Choose File > Close from the menu bar to close the file.

Figure 8-60  The FeatureManager Design Tree
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Figure 8-64  Model for Tutorial 3

Tutorial 3
In this tutorial you will create the model shown in Figure 8-64. While creating the model you
will also perform some editing operations to the model. The views and dimensions of the
model are displayed in Figure 8-65.     (Expected time: 45min)

The steps to be followed to complete this tutorial are discussed next:

a. Create a base feature of the model by revolving the sketch created on the Front plane,
refer to Figures 8-66 and 8-67.

b. Shell the model using the Shell tool, refer to Figure 8-68
c. Create the sketch on the Top plane and extrude it to the given distance, refer to Figure 8-69.
d. Pattern the extrude feature using the Circular Pattern tool, refer to Figure 8-70.
e. Edit the circular pattern, refer to Figure 8-71.
f. Create a cut feature on the top planar face of the base feature, refer to Figure 8-72.
g. Pattern the cut feature using the Linear Pattern tool, refer to Figure 8-73.
h. Unsuppress the suppressed features and create the remaining features of the model.

refer to Figures 8-74 and 8-75.

Creating the Base Feature
First, you need to create the base feature of the model by revolving the sketch created on
the Front plane.

1. Start SolidWorks and open a new part document from the Template tab of the New
SolidWorks Document dialog box.
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2. Draw the sketch of the base feature on the Front plane and add the required relations and
dimensions to the sketch as shown in Figure 8-66.

3. Using the Revolve tool create the base feature of the model. The base feature of the
model is shown in Figure 8-67.

Shelling the Base Feature
After creating the base feature, you need to shell the model using the Shell tool. You will
also remove the bottom face of the base feature, leaving behind a thin walled model.

1. Invoke the Shell PropertyManager and set the value of the Thickness spinner to 2.5 mm.

2. Rotate the model and select the bottom face of the model to remove.

Figure 8-65  Views and dimensions of the model for Tutorial 3
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Figure 8-68  Shell feature added to the model

3. Choose the OK button from the Shell PropertyManager. The shelled model is displayed
in Figure 8-68.

Creating the Third Feature
After adding the shell feature to the model, you need to create the third feature of the
model, which is an extruded feature. The sketch for this feature will be created on the
Top plane.

1. Select the Top plane from the FeatureManager Design Tree and invoke the sketching
environment.

2. Orient the model in the top view using the View toolbar.

Figure 8-66  Sketch for the base feature Figure 8-67  Base feature of the model
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Figure 8-69  Sketch of the third feature

3. Create the sketch of the third feature and add the required relations and dimensions to
the sketch as shown in Figure 8-69.

4. Extrude the sketch to the a depth of 5mm.

Patterning the Third Feature
After creating the third feature of the model, you need to pattern this feature. This feature
will be patterned using the Circular Pattern tool. Before proceeding further you need to
display the temporary axis. The central temporary axis of the model will be selected as
pattern axis.

1. Choose View > Temporary Axes from the menu bar to display the temporary axis.

2. Invoke the Circular Pattern PropertyManager and select the central axis of the model as
the  pattern axis.

3. Select the third feature created earlier from the drawing area. The preview of the pattern
feature is displayed in the drawing area.

4. Set the value of the Number of Instances spinner to 5 and choose OK from the Circular
Pattern PropertyManager.

5. Choose View > Temporary Axes from the menu bar to remove the temporary axis from
the current display.

The model after creating the pattern feature is displayed in Figure 8-70.
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Editing the Pattern Feature
The pattern created is not the same as required, refer to Figure 8-65. As a result you need
to edit the pattern feature.

1. Select CirPattern1 from the FeatureManager Design Tree or select any one of the pattern
instance other than the parent instance from the drawing area. Right-click and choose
the Edit Definition option from the shortcut menu.

The CirPattern1 PropertyManager is displayed. Presently, the number of instances in
the pattern feature is 5, but the required number of instances is 3. Therefore, you will edit
the number of instances.

2. Set the value of the Number of Instances spinner to 3 and choose the OK button from
the FeatureManager Design Tree.

The model after editing the features is shown in Figure 8-71.

Suppressing the Features
As discussed earlier, sometimes you may need to suppress some features to reduce the
complications in the model. The suppressed features are actually not deleted; their display
is just turned off. When you suppress a feature, the child features associated with that
feature are also suppressed.

1. Select the Extrude1 feature, which is the third feature of the model, from the
FeatureManager Design Tree. Right-click and choose the Suppress option from the
shortcut menu.

Figure 8-70  Pattern feature added to the model
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Figure 8-71  The edited pattern feature

The circular pattern feature is the child feature of the extrude feature, therefore, it is also
suppressed. Both the features are not displayed in the drawing area. The Extrude1 and
the CirPattern1 features are displayed in gray in the FeatureManager Design Tree,
indicating that both the features are suppressed.

Creating the Cut Feature
The next feature that you are going to create is a cut feature. The sketch for this feature
will be created on the top planar face of the base feature.

1. Select the top planar face of the base feature as the sketching plane and invoke the sketching
environment.

2. Create the sketch of the cut feature and add the required relations and dimensions to the
sketch as shown in Figure 8-72.

3. Invoke the Cut-Extrude PropertyManager and extrude the sketch using the Through
All option.

4. Choose the OK button from the Cut-Extrude PropertyManager.
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Figure 8-73  Model after patterning the cut feature

5. Now, using the Linear Pattern tool create a linear pattern of the cut feature. You can
select the dimension 18 as the directional reference. The model after creating the linear
pattern is shown in Figure 8-73.

6. Create the other features of the model. For dimensions, refer to Figure 8-65. The model
after creating the other features is shown in Figure 8-74.

Figure 8-72  Sketch for the cut feature
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Unsuppressing the Features
After completing the model, you need to unsuppress the features that you suppressed
earlier.

1. Press and hold down the CTRL key from the keyboard and select the suppressed features
from the FeatureManager Design Tree.

Note
If you select only the parent suppressed feature and unsuppress it then the child feature will not
be unsuppressed. Therefore, you have to select the parent feature and the suppressed child features.

Instead of selecting all the features from the FeatureManager Design Tree select only the
parent feature and choose Edit > Unsuppress with Dependents > All Configurations from
the menu bar. You will learn more about the configurations in the later chapters.

If you unsuppress the child feature then the parent feature will be unsuppressed automatically.

2. Right-click and choose the Unsuppress option from the shortcut menu.

The suppressed features will be restored in the model. The final model after unsuppressing
the features is shown in Figure 8-75. The FeatureManager Design Tree of the model is
shown in Figure 8-76.

Saving the Model
Now, you need to save the model.

1. Choose the Save button from the Standard toolbar and save the model with the
name given below:

\My Documents\SolidWorks\c08\c08-tut03.SLDPRT.

Figure 8-74  Model after creating other features.
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2. Choose File > Close from the menu bar to close the file.

SELF-EVALUATION TEST
Answer the following questions and then compare your answers with the answers given at
the end of this chapter.

1. You cannot edit the sketch of a sketched feature. (T/F)

Figure 8-75  The final model

Figure 8-76  The FeatureManager Design Tree
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2. The Edit Definition option is used to edit any feature. (T/F)

3. You cannot rename the feature in the FeatureManager Design Tree. (T/F)

4. You cannot edit the sketch plane of the sketch of a sketched feature. (T/F)

5. Using the Move/ Size Features option you cannot edit the sketches. (T/F)

6. The __________ dialog box is displayed when you edit a dimension.

7. The process of changing the position of a feature in the FeatureManager Design Tree is
known as __________.

8. Using __________ PropertyManager you can delete the bodies.

9. The __________ PropertyManager is used to move or copy the bodies.

10. The __________ dialog box is displayed when there is any error in a feature.

REVIEW QUESTIONS
Answer the following questions:

1. The __________ PropertyManager is invoked to delete a body.

2. You can rotate a body using __________ PropertyManager.

3. __________ key is used from the keyboard to copy a feature or a sketch.

4. The __________ key is used from the keyboard to cut a feature or sketch.

5. When __________ tool is active then the preview of the feature is displayed in temporary
graphics while editing the sketches.

6. The __________ PropertyManager is displayed to edit the sketch plane of a sketch.

7. To add the selected feature in a new folder choose Add to New Folder from the shortcut
menu. (T/F)

8. For reordering the features, select the feature in the FeatureManager Design Tree and
drag the feature to the required position. (T/F)

9. The Modify dialog box is invoked using a single click on the dimension to modify. (T/F)

10. If you want to modify the sketch by dragging the fully or partially defined sketch the
Override Dims on Drag/Move option should be selected. (T/F)
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Figure 8-77  Views and dimensions of the model for Exercise 1

EXERCISES

Exercise 1
Create the model that is shown in section in Figure 8-77. The dimensions of the model are
also given in the same figure. The complete model is shown in Figure 8-78.

    (Expected time: 45 min)
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Figure 8-78  Model for Exercise 1

Exercise 2
Create the model shown in Figure 8-79. The dimensions of the model are shown in Figure 8-80.

                 (Expected time: 30 min)

Figure 8-79  Model for Exercise 2
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Answer to Self-Evaluation Test
1. F, 2. T, 3. F, 4. F, 5. F, 6. Modify, 7. Reordering, 8. Delete Body, 9. Move/Copy Body, 10.
Rebuild Errors

Figure 8-80  Views and dimensions of the model for Exercise 2
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