
Chapter 7

Advanced Modeling
Tools-II

After completing this chapter you will be able to:
• Mirror the features, faces and bodies.
• Create Linear Pattern.
• Create Circular Pattern.
• Create Sketch Driven Pattern.
• Create Curve Driven Pattern.
• Create Table Driven Pattern.
• Create Rib Feature.
• Create Dome Feature.
• Display the section view of the model.

Learning Objectives
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ADVANCED MODELING TOOLS
Some of the advanced modeling options were discussed in Chapter 6, Advanced Modeling
Tools-I. In this chapter you will learn about some more advanced modeling tools using which
you can capture the design intent of the model. The rest of the advanced modeling tools are
discussed in later chapters.

Creating Mirror Feature

The Mirror tool is used to create a mirror image of the selected feature, face, or body
using a mirror plane. The mirror plane that is used to mirror a feature, face, or body
can be a reference plane or a planar face. To use this tool, choose the Mirror button

from the Features toolbar or choose Insert > Pattern/Mirror > Mirror to invoke the
Mirror PropertyManager. The confirmation corner is also displayed in the drawing area.
The Mirror PropertyManager is displayed in Figure 7-1.

Using this tool you can mirror features, faces, and bodies. The options that are used to mirror
features, faces, and bodies are discussed next.

Mirroring Features
Using this option you can mirror the selected feature along the specified mirror plane or
face. To mirror the features, invoke the Mirror PropertyManager. You are prompted to select
a plane or a planar face about which to mirror, followed by the features to mirror. Select a
plane or a planar face that will act as mirror plane or mirror face. After selecting the mirror

Toolbar: Features > Mirror
Menu: Insert > Pattern/Mirror > Mirror

Figure 7-1  The Mirror PropertyManager
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Figure 7-2  The features and the plane to be selected

plane or face, the selection mode of the Features to Mirror display area is invoked and you
are prompted to select features to mirror. Select the feature or features from the display area
or display the FeatureManager Design Tree flyout and select the features from the design
tree. When you select the features to be mirrored, the preview of the mirrored image is displayed
in the drawing area. After selecting all the required features, choose the OK button from the
Mirror PropertyManager. Figure 7-2 shows the mirror plane and features to be mirrored and
Figure 7-3 shows the resultant mirrored features.

Figure 7-3  The resultant mirror feature

Tip. You can also preselect the mirror plane or mirror face and the features to be
mirrored before invoking the Mirror PropertyManager.
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Mirroring with and without Geometric Pattern
When you are creating a mirror feature you are provided with an option known as geometric
pattern. This option is available in the Options rollout as shown in Figure 7-4.

By default, the Geometry Pattern check box is cleared. Therefore, if you create a mirror
image of a feature that is related to some other entity, the same relationship will be
applied to the mirrored feature. Consider a case in which an extruded cut is created using
the Offset From Surface option. If you mirror the cut feature along a plane, the same
relationship will be applied to the mirrored cut feature. The mirrored cut feature will be
created with the same end condition of termination of feature creation at an offset distance
from the selected surface. Figure 7-5 shows a hole feature created on the right and mirrored
along Plane 1 with the Geometry Pattern check box cleared.

If you select the Geometry Pattern check box, the mirror feature created will not depend
on the relational references. It will just create a replica of the selected geometry. Figure 7-6
shows the mirror feature created with the Geometry Pattern check box selected.

Mirroring Faces
Using this option you can mirror the faces along a mirror plane or mirror face. To use this
option, invoke the Mirror PropertyManager. You are prompted to select a plane or a planar
face about which to mirror. Select the planar face or a plane about which the selected faces
will be mirrored. Now, open the Faces to Mirror rollout and select the faces to be mirrored.
The selected faces must form a closed body. If the selected faces do not form a closed body,

Figure 7-5  Mirror feature created with Geometry Pattern check box cleared

Figure 7-4  The Options rollout
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Figure 7-6  Mirror feature created with Geometry Pattern check box selected

Figure 7-7  Plane and faces selected to mirror

feature creation is not possible. Use the OK button from the Mirror PropertyManager to end
feature creation. Figure 7-7 shows the faces and the mirror plane to be selected. Figure 7-8
shows the resultant mirror feature creation.
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Figure 7-8  The resultant mirror creation

Note
Following are some of the factors that should be considered while creating a mirror feature by
mirroring the faces along the selected plane or planar face:

1. If the replica of the faces is not coincident to the parent part body, SolidWorks will give error
while creating the mirror feature.

2. If the replica of the faces exists on the faces other than the original face, SolidWorks will give
error while creating the mirror feature.

3. If the selected faces form a complex geometry, SolidWorks will give error while creating the
mirror feature.

4. If the mirrored faces exist on more than one face, SolidWorks will give error while creating the
mirror feature.

5. The selected faces should form a closed body. If the selected faces do not form a closed body,
SolidWorks will give error while creating the mirror feature.

Mirroring Bodies
As discussed in the earlier chapters, the multi-bodies environment is supported in SolidWorks.
Therefore, using the mirror tool you can also mirror the disjoint bodies. To mirror a body
along a plane, invoke the Mirror PropertyManager and select a plane or a planar face that
will act as mirror plane. Open the Bodies to Mirror rollout and select the body from the
drawing area or invoke the FeatureManager Design Tree flyout and select the body to mirror
from the Solid Bodies folder. The name of the selected body is displayed in the Solid/Surface
Bodies to Mirror display area. The preview of the mirrored body is displayed in the drawing
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Figure 7-9  Selecting the mirror plane and body to be mirrored

Figure 7-10  Resultant mirror feature

area. Choose the OK button from the Mirror PropertyManager. Figure 7-9 shows the plane
and the body selected to mirror. Figure 7-10 shows the resultant mirror feature.

The options available in the Options rollout, as shown in Figure 7-11, while mirroring the
bodies are discussed next.

Merge solids
The Merge solids option is used to merge the mirrored body with the parent body. For
example, consider a case in which you mirror a body along a selected plane or a planar
face of the same body and the resultant mirrored body is joined to the parent body. In this
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case if you select the Merge solids check box, the resultant mirrored body will merge with
the parent body to become a single body. If the Merge solids check box is cleared, the
resultant body will be joined with the parent body but it will not merge with the parent
body and results in two separate bodies.

Knit surfaces
If you mirror a surface body, then the Knit Surface check box is selected to knit the
mirrored and the parent body together. You will learn more about surfaces and surface
bodies in the later chapters.

Creating Linear Pattern Feature

As discussed in earlier chapters, you can arrange the sketched entities in a particular
arrangement or pattern. In the same manner you can also arrange the features, faces,
and bodies in a particular pattern. In SolidWorks, you are provided with various types

of patterns such as linear patterns, circular patterns, sketch driven pattern, curve driven
pattern, and table driven pattern. In this section you will learn how to create linear patterns.
The other type of patterns are discussed later in this chapter.

To create a linear pattern, choose the Linear Pattern button from the Features toolbar or
choose Insert > Pattern/Mirror > Linear Pattern from the menu bar. The Linear Pattern
PropertyManager is invoked and the confirmation corner is also displayed. The Linear Pattern
PropertyManager is displayed in Figure 7-12.

The various options available in the Linear Pattern PropertyManager are discussed next.

Linear Pattern in One Direction
When you invoke the Linear Pattern PropertyManager, the Direction 1 rollout and the
Features rollout are invoked by default. Also, you are prompted to select edge or axis for
direction reference and face of feature for pattern features. Therefore, first you need to select

Figure 7-11  The Options rollout

Tip. As discussed earlier, the design intent is captured in the model using the
mirror option. Therefore, if you modify the parent feature, face, or body the same
will be reflected on the mirrored feature, face, or body.

If you want to mirror all the features of the model using the Features to Mirror
option, you have to select all the features. But if you use the Bodies to Mirror
option, you have to select the body from the Solid Bodies folder. By selecting the
body, all the features are added to the mirror image.

Toolbar: Features > Linear Pattern
Menu: Insert > Pattern/Mirror > Linear Pattern
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Figure 7-12  The Linear Pattern PropertyManager

an edge or an axis as a direction reference. Select an edge or an axis as the direction reference.
The name of the selected reference will be displayed in the Pattern Direction display area of
the Direction 1 rollout. The selected reference is displayed in yellow and the Direction 1
callout is attached to the selected reference. The Direction 1 callout has two edit boxes to
define the number of instances and the spacing. You are also provided with the Reverse
Direction arrow along with the selected reference. Now, select a face of the feature to be
patterned. The name of the selected feature will be displayed in the Features to pattern area
of the Features to Pattern rollout. The preview of the pattern is displayed in the drawing area
with the default values. Set the value of the center to center spacing between the pattern
instances in the Spacing spinner. Set the value of the number of instances to be patterned in
the Number of Instances spinner. You can also set these values in the Direction 1 callout.
Using the Reverse Direction button from the PropertyManager or using the Reverse Direction

Tip. When you select the feature to be patterned, the dimensions of the feature are
also displayed in the drawing area. You can also select the dimensions as the
directional reference.

As discussed earlier that you can mirror the faces and bodies, you can also pattern
the faces and bodies. It should be noted that the selected faces must form a closed
body, otherwise the patterning of faces will give an error.
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Figure 7-13  Edge and the feature to be selected

Figure 7-14  Linear pattern created using the Direction 1 option

arrow from the drawing area you can reverse the direction of pattern feature creation.
Figure 7-13 shows the model before pattern and Figure 7-14 shows the model after pattern.

Linear Pattern in Two Directions
As discussed earlier you can create a linear pattern of features, faces, and bodies by defining
a single direction using the Direction 1 rollout. You can also define the parameters in the
Direction 2 rollout to define the pattern in the second direction. The Direction 2 rollout is
shown in Figure 7-15. When you define the pattern in the second direction the entire row
created by specifying the parameters in the first direction is patterned in the second direction.
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Figure 7-15  The Options rollout

Figure 7-16  References and feature to be selected

To create a pattern by specifying the parameters in both the directions, invoke the Linear
Pattern PropertyManager. Select the feature to be patterned and select the first directional
reference. Next, specify the parameters in the Direction 1 rollout. Now, select the second
directional reference. The Direction 2 callout is also displayed. If the Direction 2 rollout is
not invoked in the Linear Pattern PropertyManager, the black arrow in the Direction 2
callout is used to invoke the rollout. The options available in the Direction 2 rollout are the
same as those discussed in the Direction 1 rollout. Figure 7-16 shows the directional references
and feature to be selected. Figure 7-17 shows the linear pattern created using the Direction 1
and Direction 2 rollouts.

By default, all the rows of the instances created in the first direction are patterned in the
second direction also. This is because the Pattern seed only check box in the Direction 2
rollout is cleared. You can select this check box to pattern only the original selected feature
(also called seed feature) in the second direction. Figure 7-18 shows the pattern created with
the Pattern seed only check box selected.

c07-solidworks-2003.p65 5/11/2003, 5:06 PM11



7-12 SolidWorks for Designers

Figure 7-17  Linear pattern created using the Direction 1 and
Direction 2 rollouts

Instances to Skip
Using the Instances to Skip option you can skip some of the instances from the pattern. The
instances that are skipped are not actually deleted. These are only skipped from the pattern
feature and you can resume these instances at any time of your design cycle. To skip the
pattern instances, invoke the Instances to Skip rollout from the Linear Pattern
PropertyManager. The Instances to Skip rollout is displayed in Figure 7-19. As soon as you
invoke this rollout, yellow dots are displayed at the center of all pattern instances except the
parent instance. Therefore, you cannot skip the parent instance. Now, move the cursor to the
yellow dot of the instance to be skipped. The cursor will be replaced by the instance to skip

Figure 7-18  Linear pattern created with the Pattern to seed check box selected
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Figure 7-19  The Instances to Skip rollout

cursor and the position of that instance in the form of matrix is displayed in tooltip below this
cursor. Use the left mouse button to skip that instance. The yellow dot will be replaced by as
red dot and the preview of that instance will disappear from the drawing area. The position of
the skipped instance is displayed in the Instances to Skip display area of the Instances to
Skip rollout. Figure 7-20 shows a pattern created with some instances skipped.

You can resume the skipped instances by deleting the position of the instance from the
Instances to Skip display area or select the red dot from the drawing area.

Pattern Using Varying Sketch
The Vary Sketch option is used in pattern where the shape and size of each pattern instance
is controlled by the relations and dimension of the sketch of that feature. In this type of
pattern, the dimension of the sketch of the feature to be patterned is selected as the
directional reference. The dimension selected as the dimensional reference drives the shape
and size of the sketch of the feature to be patterned. In Figure 7-21 a cut feature is created on
the base feature. Figure 7-22 shows the linear pattern created using the varying sketch option.
For creating this type of pattern, the sketch of the feature to be patterned should be in relation
with the geometry along which it will vary. The dimensions of the sketch should allow the
sketch to change the shape and size easily. You should also provide a linear dimension that
will drive the entire sketch and will be the directional reference. From the FeatureManager
Design Tree select the feature to be patterned and then invoke the Linear Pattern

Figure 7-20  Linear pattern created with some instances skipped
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Figure 7-21  Cut feature created on the base feature

Figure 7-22  Linear pattern created with the Vary sketch check box selected

PropertyManager. Now, select the dimension to specify the directional reference and set the
value of spacing and the number of instances. Invoke the Options rollout and select the Vary
sketch check box. As you select the Vary sketch check box, the preview of the pattern disappears
from the drawing area. Choose the OK button from Linear PropertyManager to end feature
creation.

The Geometry pattern option available in the Options rollout of the Linear Pattern
PropertyManager is the same as discussed earlier in Mirror PropertyManager.
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Creating     Circular Pattern Feature

As discussed in earlier chapters, you can arrange the sketched entities in a circular
pattern using the Circular Sketch Step and Repeat option. In this section, you will
learn how to create the circular pattern of a feature, face, or a body. You can create the

circular pattern of a feature, face, or a body using the Circular Pattern tool. To invoke this
tool, choose the Circular Pattern button from the Features toolbar or choose Insert >
Pattern/Mirror > Circular Pattern from the menu bar. The Circular Pattern PropertyManager
is invoked and the confirmation corner is displayed as shown in Figure 7-23.

After invoking the Circular Pattern PropertyManager, you are prompted to select an edge
or an axis for direction reference, and a face of the feature to be patterned. If the base feature
of the model is a circular feature, the temporary axis is created automatically at the center of
the model. Choose View > Temporary Axes from the menu bar to display the temporary
axis. Otherwise, before invoking the circular pattern tool, you have to create an axis. Now,
select the axis that will act as the pattern axis. The preview of the pattern feature with the
default values is displayed in the drawing area. The Direction 1 callout is displayed with the

Figure 7-23  The Circular Pattern PropertyManager

Toolbar: Features > Circular Pattern
Menu: Insert > Pattern/Mirror > Circular Pattern
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Figure 7-24  The reference to be selected for creating circular pattern

Reverse Direction arrow in the drawing area. By default, the Equal Spacing check box is
selected. Therefore, you have to set the value of the total angle in the Total Angle spinner. Set
the value of number of instances to pattern in the Number of Instances spinner. As the Equal
Spacing check box is selected and you have entered the value of total angle, therefore, it will
automatically calculate the angular spacing between the instances. If you clear the Equal
Spacing check box, the Total Angle spinner is replaced by the Angle spinner. You have to
enter the angular spacing between instances in the Angle spinner. The Reverse Direction
button available on the left of the Pattern Axis display area is used to change the direction of
rotation while creating the pattern feature. By default, the direction of pattern creation is
clockwise. If you choose this button then the resultant pattern will be created in the
counterclockwise direction. You can also change the direction of pattern creation using the
Reverse Direction arrow from the drawing area. Figure 7-24 shows the feature and the
temporary axis being selected. Figure 7-25 shows the resultant pattern feature.

Tip. Instead of setting the value of angle and number of instances in the respective
spinners, you can also enter the values in the callout. To enter the values in the
callout is a better and time-saving practice.

It is always a good practice to create pattern of features instead of creating complex
sketches or repeatedly creating the same feature again and again. It also helps in
capturing the design intent of the model. The patterns created in Part mode are
very useful in the assembly modeling. You will learn more about assembly modeling
in later chapters.
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Figure 7-25  Resultant circular pattern 

Figure 7-26  Dimensions displayed after selecting the feature to be patterned

Circular Pattern Using Dimensional Reference
You can also create circular pattern by selecting an angular dimension as angular reference.
For create a pattern using this option you have to create an angular dimension in the sketch
of the feature that is to be patterned. Invoke the Circular Pattern PropertyManager and
select the feature to be patterned. The dimensions of the feature to be patterned will be
displayed in the drawing area as shown in Figure 7-26. Now, select the angular dimension and
set the value of total angle and spacing in the Circular Pattern PropertyManager. Figure 7-27
shows the pattern created by selecting the angular dimension as angular reference.
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The other options available in the Circular Pattern PropertyManager are the same as
those discussed earlier for the Linear Pattern PropertyManager.

Creating Sketch Driven Pattern

The sketch driven pattern is created when the features, face, or bodies are to be
arranged in a nonuniform manner, which is neither rectangular nor circular. For
creating a sketch driven pattern, first you have to create an arrangement of the sketch

points in a single sketch. This arrangement of sketch points will drive the instances in the
pattern feature. After creating the sketch and the feature to pattern, invoke the Sketch Driven
Pattern PropertyManager as shown in Figure 7-28. You are prompted to select a sketch for
pattern layout, and face of feature to pattern.

Select the feature or features to be patterned. Now, click in the Reference Sketch display box
in the Selections rollout and select any one of the sketched point from the drawing area. You
can also invoke the flyout and select the sketch from the FeatureManager Design Tree to
select the sketch for the pattern layout. Choose the OK button from the Sketch Driven Pattern
PropertyManager.

Figure 7-27  Circular pattern created by selecting the angular
dimension as the angular reference

Toolbar: Features > Sketch Driven Pattern
Menu: Insert > Pattern/Mirror > Sketch Driven Pattern
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Figure 7-28  The Sketch Driven Pattern PropertyManager

Figure 7-29  The feature and the sketch point to be selected

Figure 7-29 shows the feature and the sketch point selected and Figure 7-30 shows the resultant
pattern.
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Figure 7-30  The resultant pattern feature

The options available in the Sketch Driven Pattern PropertyManager are discussed next.

Sketch Driven Pattern Using Centroid
When you invoke the Sketch Driven Pattern PropertyManager, the Centroid radio button is
selected by default in the Reference Point area of the Selections rollout. Therefore, the
pattern created is with reference to the centroid.

Sketch Driven Pattern Using Selected point
If you select the Selected point radio button from the Reference Point area of the Selections
rollout, the pattern created is with reference to the selected point. When you select this radio
button, a Reference Vertex display area is displayed. Select a vertex; the pattern will be
created in reference to that vertex.

Creating Curve Driven Pattern

The Curve Driven Pattern option is used to pattern the features, faces, or bodies
along a selected reference curve. The reference curve can be a sketched entity or an
edge and can be an open profile or a closed loop. To create a pattern using this

option, choose the Curve Driven Pattern button from the Features toolbar or choose Insert
> Pattern/Mirror > Curve Driven Pattern from the menu bar. When you choose this button,
the Curve Driven Pattern PropertyManager is displayed as shown in Figure 7-31. Figure 7-32
shows the feature and the curve that will be used to create the pattern. Figure 7-33 shows the
curve driven pattern created.

After invoking the Curve Driven Pattern PropertyManager, you are prompted to select edge,
curve or sketch segment for pattern layout and select face of feature to be patterned. Select

Toolbar: Features > Curve Driven Pattern
Menu: Insert > Pattern/Mirror > Curve Driven Pattern
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Figure 7-31  The Curve Driven Pattern PropertyManager

Figure 7-32  The feature and curve to be used
to create the curve driven pattern

Figure 7-33  The resultant pattern feature
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the reference curve along which the feature, face, or body will be patterned. When you select
the reference curve, the name of curve is displayed in the Pattern Direction display area and
the Direction 1 callout is displayed. As discussed earlier, the Direction 1 callout is divided in
two areas. Select the feature to pattern; the preview of the pattern is displayed in the drawing
area. Set the various parameters available in the Direction 1 rollout and choose the OK
button from the Curve Driven Pattern PropertyManager.

The various options available in the Direction 1 rollout are discussed next.

Equal Spacing
The Equal Spacing check box is used to accommodate all the instances of the pattern along
the selected curve. By default, this check box is cleared. Therefore, you have to specify the
distance between the instances and the total number of instances to be created along the
selected curve. When you select this check box, the Spacing spinner is not available and you
have to specify only the total number of instances. The distance between the instances is
calculated automatically.

Curve method and Alignment method
The Curve method area of the Direction 1 rollout is used to specify the type of curve method
to be followed while patterning along the curve. The two options available in this area are in
the form of radio buttons. The option are Transform curve method and the Offset curve
method. The Alignment method area of the Direction 1 rollout is used to specify the type of
alignment method to be applied. The two alignment methods are the Tangent to curve
method and the Align to seed method. Figure 7-34 shows the curve driven pattern created
with the Transform curve and Tangent to curve radio buttons selected. Figure 7-35 shows
the curve driven pattern created with the Transform curve and Align to seed radio buttons
selected.

Figure 7-36 shows the curve driven pattern created with the Offset curve and Tangent to
curve radio buttons selected. Figure 7-37 shows the curve driven pattern created with the
Offset curve and Align to seed radio buttons selected.

Figure 7-34  Pattern created with Transform
curve and Tangent to curve radio buttons selected

Figure 7-35  Pattern created with Transform
curve and Align to seed radio buttons selected
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Figure 7-36  Pattern created with Offset curve
and Tangent to curve radio buttons selected

Figure 7-37  Pattern created with Offset curve
and Align to seed radio buttons selected

Other options available in the Curve Driven PropertyManager are the same as those discussed
earlier for the mirror and other pattern features. By selecting the check box available in the
Direction 2 rollout you can also specify the parameters in the second direction. Figure 7-38
shows the curve driven pattern feature created with pattern defined in direction 1 and in
direction 2.

Figure 7-38  A curve driven pattern created by specifying parameters
in both the directions

Tip. In SolidWorks you can pattern a pattern feature. You can also pattern a
mirror feature. The mirror of the pattern feature is also possible in SolidWorks.
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Figure 7-39  The Table Driven Pattern dialog box

Creating Table Driven Pattern

The Table Driven Pattern is created by specifying the X and Y coordinates with
reference to a coordinate system. The instances of the selected features, faces, or
bodies are created at the points specified using the X and Y coordinates. For creating

this type of pattern, you first need to create a coordinate system using the Coordinate System
button from the Reference Geometry toolbar. The coordinate system defines the direction
along which the selected feature will be patterned. Choose the Table Driven Pattern button
from the Features toolbar or choose Insert > Pattern/Mirror > Table Driven Pattern from
the menu bar. The Table Driven Pattern dialog box is displayed as shown in Figure 7-39.

Select the feature to be patterned and the coordinate system from the drawing area or from
the FeatureManager Design Tree. Enter the coordinates for creating the instances in the
Coordinate points area of the Table Driven Pattern dialog box. As you enter the coordinates
for the instances, the preview of the pattern is displayed in the drawing area. After entering

Toolbar: Features > Table Driven Pattern
Menu: Insert > Pattern/Mirror > Table Driven Pattern
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Figure 7-40  Feature and the coordinate system
to be selected for creating a table driven pattern

Figure 7-41  Resultant pattern after specifying
the coordinate points

all the coordinate points, choose the OK button from the Table Driven Pattern dialog box.
Figure 7-40 shows the feature and the coordinate system to be selected. Figure 7-41 shows the
table driven pattern created after entering the coordinate values in the Table Driven Pattern
dialog box.

You can also save the table driven pattern file and retrieve the same coordinates by simply
browsing the saved file using the Browse button from the Table Driven Pattern dialog box.
You can also simply write the coordinates in a text file and browse the same file while creating
a table driven pattern. The other options available in this dialog box are the same as discussed
earlier.

Creating the Rib Feature

Ribs are defined as thin walled structures that are used to increase the strength of the
entire structure of the component so that it does not fail under an increased load. In
SolidWorks, the ribs are created using an open sketch as well as a closed sketch. To

create a rib feature, draw a sketch for the rib feature and invoke the Rib tool without exiting
the sketching environment. The Rib tool is invoked by choosing the Rib button from the
Features toolbar or by choosing Insert > Features > Rib from the menu bar. When you
invoke this tool, the Rib PropertyManager is displayed as shown in Figure 7-42.

Toolbar: Features > Rib
Menu: Insert > Features > Rib

Tip. If you exit the sketching environment after creating the sketch for a rib feature,
you have to first select the sketch from the FeatureManager Design Tree. The
Rib button in the Features toolbar is available only when you select a sketch. After
selecting the sketch invoke the Rib PropertyManager to create the rib feature.
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Figure 7-43  Sketch for the rib feature Figure 7-44  Resultant rib feature

When you invoke the Rib PropertyManager the preview of rib feature with direction arrow
and the confirmation corner are displayed in the drawing area. Figure 7-43 shows the sketch
created for the rib feature and Figure 7-44 shows the resultant rib feature. The various options
available in the Rib PropertyManager are discussed next.

Thickness
The Thickness area of the Parameters rollout is used to specify the side of the rib thickness
and the thickness of the rib feature. The buttons available in this area are used to control the
side on which you want to add the rib thickness. By default, the Both Sides button is chosen.
Therefore, the rib is created on both the sides of the sketch. The Rib Thickness spinner in
this area of the Parameters rollout is used to specify the rib thickness. You can choose the
First Side or Second Side buttons to create ribs on either side of the sketch. The thickness of
the rib is specified using the Rib Thickness spinner.

Figure 7-42  The Rib PropertyManager
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Figure 7-45  Sketch for the rib feature Figure 7-46  Resultant rib feature

Extrusion direction
The Extrusion direction area of the Parameters rollout is used to specify the method of
extruding the closed or open sketch. When you invoke the Rib PropertyManager, by default
the option that is suitable for creating the rib feature will be active, depending on the geometric
conditions. The options available in this area are discussed next.

Parallel to Sketch
The Parallel to Sketch option is used to extrude the sketch in a direction that is parallel
to the sketch as well as parallel to the sketching plane. When you invoke the Rib
PropertyManager and the sketch created for the rib feature is a continuous single entity
open sketch, then this option is selected by default. Figure 7-45 shows an open sketch
suitable for creating a rib using the Parallel to Sketch option. Figure 7-46 shows the rib
feature created using that sketch.

Normal to Sketch
The Normal to Sketch option is generally used to create a rib feature when the sketch of
the rib feature is a closed loop sketch or it consists of multiple sketched entities. The
sketch with multiple entities can be closed loops or open profiles. If you create a sketch
with a closed loop or a sketch with multiple sketched entities and invoke the rib tool, the
Normal to Sketch button will be selected by default. You can also choose the Normal to
Sketch button from the Extrusion Direction area to use this option. Figure 7-47 shows a
multiple entity sketch for the rib feature. Figure 7-48 shows the resultant rib feature.

When this option is selected, the Type area is displayed under the Draft Angle spinner.
The options available in the Type area are discussed next.

Type
The Type area is available only when you choose the Normal to Sketch button from
the Extrusion direction area of the Parameters rollout. The Type area is provided
with two radio buttons: Linear and Natural. These options are used if the endpoints
of the open sketch for the rib are not coincident with the faces of the existing feature.
If the Linear Radio button is selected, the rib is created by extending the sketch
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Figure 7-49  Sketch for the rib feature

normal to the sketched entity direction. The sketch will be extended up to a point
where it meets a boundary.

On the other hand, if the Natural radio button  is selected, the rib feature is created
by extending the sketch along the direction of sketched entities. For example,
consider the sketch shown in Figure 7-49. This figure shows a multiple entity sketch
created for the rib feature.

Figure 7-50 shows a rib feature created by extending the sketch normal to the arc and
the line. This is because the Linear radio button is selected. Similarly, in Figure 7-51,

Tip. You will observe that the endpoints of the sketched lines created in Figure 7-47
do not merge with the model edges. But the rib created using this sketch merges with
the model edges. This is because while creating the sketch for the rib feature you do
not have to create a complete sketch. The ends of the rib feature automatically
extend to the next surface.

Figure 7-47  Sketch for the rib feature Figure 7-48  Resultant rib feature
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the feature is created by extending the sketch along the line and arc using the Natural
radio button. This is the reason a circular feature is created at the end where the
sketch has the arc.

Flip material side
The Flip material side check box is selected to reverse the direction of material addition
while creating the rib feature. You can also reverse the direction of material addition using
the Flip material side arrow available in the drawing area.

Draft On/Off
The Draft On/Off button is used to add the taper to the faces of the rib feature. When you
choose the Draft On/Off button, the Draft Angle spinner is invoked. If you are creating a rib
feature using multiple sketch entities, you can add only a simple draft to the rib feature.
Figure 7-52 shows the draft angle added to the rib feature. By default, the draft is added
inwards to the rib feature.

Figure 7-50  Rib feature created with Linear
radio button selected from the Type area of the
Rib PropertyManager

Figure 7-51  Rib feature created with Natural
radio button selected from the Type area of the
Rib PropertyManager

Figure 7-52  Draft angle added to the rib feature
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Figure 7-55  Arrow displaying the reference for
adding the draft angle

Figure 7-56  Resultant rib feature

Using the Draft outward check box you can add the draft outwards. If the rib feature to be
created consists of a single continuous sketch and if you choose the Draft On/Off button, the
Next Reference button is displayed below the Draft Angle spinner. A reference arrow is also
displayed in the drawing area. Using the Next Reference button you can cycle through the
reference along which you want to add the draft angle.

Figure 7-53 shows the preview of the rib feature and the arrow displaying the reference for
adding the draft angle. Figure 7-54 shows the resultant rib feature.

Figure 7-55 shows the preview of the rib feature and the arrow displaying the reference for
adding the draft angle. Figure 7-56 shows the resultant rib feature.

Figure 7-53  Arrow displaying the reference for
adding the draft angle

Figure 7-54  Resultant rib feature
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Toolbar: Features > Dome (Customize to Add)
Menu: Insert > Features > Dome

Figure 7-58  Planar face to be selected Figure 7-59  Resultant dome feature

Creating the Dome Feature

Using the Dome tool you can create a dome feature on the selected planar face. The
dome is a material addition and material removal process depending upon the options
selected. To create a dome feature choose the Dome button from the Features toolbar

or choose Insert >Features > Dome from the menu bar. When you choose this button the
Dome dialog box is displayed as shown in Figure 7-57. The various options available in the
Dome tool are discussed next.

After invoking the Dome dialog box, select a planar face on which you want to add the dome
feature. The name of the selected face will be displayed in the Dome face display area. The
preview of dome feature is also displayed in the drawing area. Using the Height spinner you
can set the height of the dome feature. The preview of the dome feature modifies dynamically
when you modify the height using the Height spinner. The height of the dome feature is
calculated from the centroid of selected face to the top of the dome feature. After specifying
all the parameters, choose the OK button from the Dome dialog box. Figure 7-58 shows the
planar face to be selected for the dome feature. Figure 7-59 shows the resultant dome feature
created.

Figure 7-57  The Dome dialog box
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Figure 7-62  A dome feature created with the Reverse direction check box

If the selected planar face belongs to a circular or an elliptical feature, the Elliptical dome
check box is displayed below the Dome face display area. If you select this check box then you
can create an elliptical dome. Figure 7-60 shows the circular dome created by selecting a
circular planar face. Figure 7-61 shows the elliptical dome created by selecting a circular
planar face.

The Reverse direction check box available in the Dome dialog box is used to remove the
material by creating a cavity in the form of a dome. For removing the material using the dome
feature, select the Reverse direction check box. Figure 7-62 shows the dome feature created
with the Reverse direction check box selected.

Figure 7-60  Circular dome Figure 7-61  Elliptical dome
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Displaying the Section View of the Model

The Section View option is used to display the section view of the model by cutting
the model using a plane or face. You can also create the section of the model using
the current viewing plane. To create the section of a model choose the Section View

button from the View toolbar or choose View > Display > Section View from the menu bar.
When you invoke this tool the Section View dialog box is displayed as shown in Figure 7-63.

When you invoke the Section View dialog box, the Front plane is selected by default as a
section plane. The name of the Front view is displayed in the Section Plane(s)/Face(s) display
area. The various options available in this dialog box are discussed next.

Section Position
The Section Position spinner available in the Section View tab of the Section View dialog
box is used to specify the distance of the section plane from the selected plane or face.

Section Plane(s)/Face(s)
The Section Plane(s)/Face(s) display area is used to select the planes or faces to create the
section view. The selected planes or faces are displayed in this area.

Flip the Side to View
The Flip the Side to View check box is selected to reverse the direction of creating the section
view.

Use viewing plane
The Use viewing plane check box is selected to section the model using the current viewing
plane. The viewing plane is an imaginary plane parallel to the screen and normal to the eye
view. When you select this check box, the Section Plane(s)/Face(s) display area is not available.
If you rotate the model, the viewing plane is replaced by the current viewing plane. But the
preview is displayed when you choose the Display button.

Toolbar: View > Section View (Customize to Add)

Menu: View > Display > Section View

Figure 7-63  The Section View dialog box
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Tip. You can view the half section view of the model by selecting two planes or faces
of the model that intersect each other.

Figure 7-64  Section view of a model

Preview
The Preview check box is selected to display the preview of the section view before confirming
the creation of the section view.

Display
The Display button is used to preview the section view with the current settings.

After setting all the parameters in the Section View dialog box, choose the OK button to
create the section view. You will observe that the Section View button is still chosen. If you
want to toggle back to the full view, you have to choose the Section View button again.
Figure 7-64 shows the section view of a model.

TUTORIALS

Tutorial 1
In this tutorial you will create the model shown in Figure 7-65. The dimensions of the model
are shown in Figure 7-66.     (Expected time: 30 min)

The steps to be followed to complete this tutorial are discussed next:

a. Create the base feature of the model by extruding a rectangle of 69mm x 45mm created
on Right plane to a depth of 10mm, refer to Figure 7-67.
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Figure 7-65  Solid model for Tutorial 1

Figure 7-66  Views and dimensions of the model for Tutorial 1
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Figure 7-67  Base feature of the model

b. Create the second feature, which is created by extruding the sketch created on the back
face of the base feature, refer to Figure 7-68 (a).

c. The third feature of the model is a circular feature, refer to Figure 7-68 (b).
d. Create a hole feature placed concentric to the circular feature.
e. Create the hole on the specified BCD and then pattern the hole feature using the circular

pattern option.
f. Create the hole feature on the base feature, refer to Figure 7-69.
g. Create a fillet feature to add the required fillets, refer to Figures 7-70 and 7-71.
h. Create the rib feature, refer to Figures 7-72 and 7-73.

Creating the Base Feature
1. Start SolidWorks and then open a new part file from the Template tab of the New

SolidWorks Document dialog box.

It is evident from the model that the sketch of the base feature of model is created on the
right plane. Therefore, using the left mouse button select the Right plane from the
FeatureManager Design Tree and invoke the sketching environment.

2. Draw the sketch of the base feature of the model. The sketch of the base feature consists
of a rectangle of dimensions 69mm x 45mm.

3. Add the required relations and dimensions to the sketch. After creating the sketch of the
base feature you need to extrude the sketch to the given distance.

4. Invoke the Extrude PropertyManager and extrude the sketch to a depth of 10mm.

The base feature of the model is shown in Figure 7-67.
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Creating the Second Feature of the Model
The second feature of the model is also an extruded feature. Create the sketch for the
second feature on the back face of the base feature and extrude this sketch to the given
depth.

1. Select the back face of the base feature as the sketching plane and invoke the sketching
environment.

2. Create the sketch of the second feature and add the required relations and dimensions.

3. Invoke the Extrude PropertyManager and select the Reverse Direction button from
the PropertyManager.

4. Set the value of the Depth spinner to 38 and end feature creation.

The model created after adding the second feature is shown in Figure 7-68 (a).

Note
You can also create the first and second feature using the contour selection method.

Creating the Third Feature
The third feature of this model is a circular extruded feature. This feature is created by extruding
a circular sketch on both the sides of the sketching plane. The sketch for this feature is created
on the right planar face of the second feature.

1. Select the right planar face of the second feature as the sketching plane and invoke the
sketching environment.

2. Create the sketch using the circle tool. Add the required relations and dimensions to the
sketch.

3. Invoke the Extrude PropertyManager and set the value of the Depth spinner available
in the Direction 1 rollout to 12. Since you have to extrude the sketch in both the directions
with variable values, therefore, you have to invoke the Direction 2 rollout. Set the value of
the  Depth spinner available in the Direction 2 rollout to 13 and end feature creation.

Figure 7-68 (b) shows the model after adding the third feature.

Creating the FFFFFourth Fourth Fourth Fourth Fourth Featureeatureeatureeatureeature
The fourth feature of this model is a hole feature. You will create a hole using the Simple
Hole option on the right face of the third feature. To create a hole using this option, you
first need to create a point on which the hole will be placed.

1. Select the right face of the third feature as the sketch plane for creating the sketched
point and invoke the sketching environment. The center point of the hole that will be
created using the Hole PropertyManager will be placed coincident to sketched point.
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2. Create a point on the right face of the circular feature.

3. Add the Concentric relation between the sketched point and the circular edge of the
third feature and exit the sketching environment.

4. Now, select the face on which the point is placed. Choose the Simple Hole button
from the Features toolbar or choose Insert > Features > Hole > Simple from
the menu bar to invoke the Hole PropertyManager.

5. Choose the Through All option from the End Condition drop-down list and set the
value of the Hole Diameter spinner to 16.

6. Select the centerpoint of the hole feature and drag the cursor to the sketched point
created earlier. Release the left mouse button when the cursor is displayed in yellow color.

7. Choose the OK button from the Hole PropertyManager.

Creating the Fifth Feature
1. Using the procedure given in previous sections, create the fifth feature, which is also a

hole feature placed on the same placement plane. This hole feature is created using the
Through All option with the diameter of the hole as 4. After creating the hole feature
define the placement of the feature by adding the required relations and dimensions.

Patterning the Hole Feature
After creating the fifth feature, which is a hole feature, you will pattern it using the Circular
Pattern tool.

1. Choose the Circular Pattern button from the Features toolbar to invoke the
Circular Pattern PropertyManager.

You are prompted to select an edge or an axis for direction reference; select a face of the
feature for pattern features.

Figure 7-68 (a)  Second feature added to the Figure 7-68 (b)  Third feature added to the model

c07-solidworks-2003.p65 5/11/2003, 5:06 PM38



Advanced Modeling Tools-II       7-39

As discussed in the earlier chapters, when you create a circular feature a temporary axis
is automatically created passing through the center of the circular feature. The temporary
axis can be displayed by choosing View > Temporary Axes from the menu bar. Therefore,
first you will display the temporary axis.

2. Choose View > Temporary Axes from the menu bar.

Temporary axes are displayed in the model.

3. Select the temporary axis that passes through the center of the first hole feature.

The Direction 1 callout is displayed and is attached to the selected axis.

4. Click in the Features to Pattern display area to invoke the selection mode.

5. Select the smaller hole from the drawing area or invoke the FeatureManager Design
Tree flyout and select the Hole2 feature from the flyout.

The preview of the pattern feature is displayed with the default settings.

6. Click anywhere on the drawing area to exit the flyout.

7. Select the Equal spacing check box if cleared and set the value of the Number of
Instances spinner to 6. Choose the OK button from the PropertyManager.

8. Choose View > Temporary Axes to hide the temporary axes.

Creating the Seventh Feature
1. The seventh feature of this model is also a hole feature. This hole feature will be placed

on the right planar face of the base feature. Therefore, after selecting the right planar
face of the base feature, place the hole feature. After placing the hole feature define the
placement of the hole feature by adding the required relations and dimensions.
Figure 7-69 shows the model after adding the hole features.

Creating the Fillet Feature
Next, you need to add the fillet feature to the model. It is evident from the model that the
fillets to be added to the model are of different radii. In SolidWorks you can specify
different radii to individual selected edges, faces, or loops in a single fillet feature.

1. Choose the Fillet button from the Features toolbar to invoke the Fillet
PropertyManager.

You are prompted to select edges, faces, features, or loops to fillet.

2. Select the Multiple radius fillet check box from the Items to Fillet rollout of the Fillet
PropertyManager.
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Figure 7-70  Edges to be selected Figure 7-71  Model after adding fillet feature

3. Select the edges to fillet as shown in Figure 7-70. As the Multiple radius fillet check box
is selected, therefore, each selected edge is having a separate radius callout.

4. Modify the value of the radii as required in the radius callouts attached to the selected
edges.

5. Choose the OK button from the Fillet PropertyManager.

The isometric view of the model after adding the fillet feature is shown in Figure 7-71.

Creating the Rib     Feature
The next feature that you are going to create is a rib feature. The sketch of the rib feature
will be created on a sketching plane created at an offset distance from the back planar

Figure 7-69  Model after adding all the hole features
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face of the model. Therefore, first you need to create a reference plane at an offset distance
from the back planar face of the model.

1. Choose the Plane button from the Reference Geometry toolbar or choose Insert
> Reference Geometry > Plane from the menu bar to invoke the Plane
PropertyManager.

2. Rotate the model and select the back planar face of the model. Choose the Reverse
direction check box under the Distance spinner and set the value of the Distance spinner
to 19.

3. Choose the OK button from the Plane PropertyManager to end feature creation.

A new plane is created at an offset distance from the back planar face of the model.

4. Using the newly created plane as the sketching plane, invoke the sketching environment.

5. Create the sketch for the rib feature and add the required relations and dimensions to the
sketch as shown in Figure 7-72.

6. Choose the Rib button from the Features toolbar or choose Insert > Features > Rib
from the menu bar to invoke the Rib PropertyManager.

The preview of the rib feature is displayed in the drawing area and you will observe that
the direction of material addition is displayed using the arrow in the drawing area. The
direction of material addition is opposite to the required direction. Therefore, you need
to flip the direction of material addition.

Figure 7-72  Sketch for the rib feature
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7. Select the Flip material side check box to flip the direction of material addition.

Since the default value of the rib thickness is 10, which is the required value, you do not
need to change the value of the rib thickness.

8. Choose OK from the Rib PropertyManager. Also, hide the newly created plane.

The last feature of the model is the fillet feature. Add the fillet feature on the left edge of
the rib using the fillet tool. Figure 7-73 shows the isometric view of the final model. The
FeatureManager Design Tree of the model is shown in Figure 7-74.

Saving the Model
1. Choose the Save button from the Standard toolbar and save the model with the

name given below:

\My Documents\SolidWorks\c07\c07-tut01.SLDPRT.

2. Choose File > Close from the menu bar to close the file.

Figure 7-73  The final solid model
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Figure 7-74  The FeatureManager Design Tree

Tutorial 2
In this tutorial you will create the model shown in Figure 7-75. The dimensions of the model
are shown in Figure 7-76.     (Expected time: 30 min)

Figure 7-75  Model for Tutorial 2
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Figure 7-76  Front view and aligned section view with dimensions

The steps to be followed to complete this tutorial are discussed next:

a. Create the base feature of the model. The base feature will be created by revolving the
sketch along a centerline, refer to Figures 7-77 and 7-78.

b. Create the second feature by extruding the sketch from the sketching plane to a selected
surface, refer to Figures 7-79 and 7-80.

c. Place a counterbore hole feature using the hole wizard.
d. Pattern the second and third features along the temporary axis using the circular pattern

tool, refer to Figure 7-81.
e. Create the rib feature, refer to Figure 7-82.
f. Pattern the rib feature along a temporary axis using the circular pattern tool, refer to

Figure 7-83.

Creating the Base Feature
Create a new SolidWorks part document. First you need to create the base feature of the
model. The base feature of the model will be created by revolving the sketch along the
centerline. The sketch for the base feature will be drawn on the Right plane.

1. Select the Right plane as the sketching plane and invoke the sketching environment.

2. Create the sketch for the base feature and add the required relations and dimensions to
the sketch as shown in Figure 7-77.

3. Invoke the Revolve PropertyManager and set the value of the Angle spinner to 360.
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4. Choose the OK button from the Revolve PropertyManager.

The base feature created after revolving the sketch is shown in Figure 7-78.

Creating the Second Feature
The second feature is an extruded feature created by extruding a sketch upto the selected
surface.

Figure 7-77  Sketch for the base feature

Figure 7-78  Base feature of the model
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Figure 7-79  Face to be selected Figure 7-80  Surface to be selected

1. Select the face shown in Figure 7-79 as the sketching plane and invoke the sketching
environment.

2. Create the sketch of the second feature and add the required relations and dimensions to
the sketch.

3. Using the Up To Surface option extrude the sketch. The surface to be selected is shown
in Figure 7-80.

4. Choose the OK button from the Extrude PropertyManager.

Creating the Hole Feature
It is evident from Figure 7-76 that a counterbore hole needs to be added to the model.
The counterbore hole will be added using the Hole Wizard. Before invoking this tool,
first you need to select the placement plane for the hole feature.

1. Select the top face of the second feature as the placement plane for the hole feature.

2. Choose the Hole Wizard button from the Features toolbar to invoke the Hole
Definition dialog box.

The preview of the hole feature with the default settings in the Hole Definition area is
displayed in the drawing area.

3. Invoke the Counterbore tab and select the Ansi Metric option from the Standard
drop-down list to specify the standard to be used.

4. Select the M3 option from the Size drop-down list to specify the size of the fastener to be
used in the hole. Leave all the default options as they are and choose the Next button
from the Hole Definition dialog box.

The Hole Placement dialog box is displayed.
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5. Invoke the Add Relations PropertyManager and apply a concentric relation between the
centerpoint of the hole feature and the circular edge of the second feature.

6. Choose the Finish button from the Hole Placement dialog box to end feature creation.

Patterning the Features
After creating the second feature and the third feature, you need to pattern both the
features around the temporary axis using the circular pattern tool.

1. Choose the Circular Pattern button from the Features toolbar to invoke the
Circular Pattern PropertyManager.

Since you are creating a circular pattern, you need to define an axis as the directional
reference. Therefore, display the temporary axis by choosing  View > Temporary Axes
from the menu bar.

2. Select the temporary axis and invoke the selection mode in the Features to Pattern area.
The Direction 1 callout is displayed.

3. Select the second and third features from the drawing area or from the FeatureManager
Design Tree flyout.

4. Set the value of the Number of Instances spinner to 3 and make sure the Equal spacing
check box is selected. Choose the OK button from the Circular Pattern PropertyManager.

The model after patterning the features is shown in Figure 7-81.

Figure 7-81  Model after patterning the features
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Figure 7-82  Sketch for the rib feature

Creating the Rib Feature
The next feature is a rib. The sketch for the rib feature will be created on the Front plane.

1. Select the Front plane from the FeatureManager Design Tree and invoke the sketching
environment.

2. Set the display model to wireframe and create the sketch for the rib feature and add the
required relations as shown in Figure 7-82.

3. Choose the Rib button from the Features toolbar and set the value of the Rib Thickness
spinner to 2. Leave all the other default options as they are and choose the OK button
from the Rib PropertyManager.

4. Change the model display mode to shaded.

5. Using the Circular Pattern tool, pattern the rib feature with 6 instances of the rib feature.
The final model after creating all the features is shown in Figure 7-83. The FeatureManager
Design Tree of the model is shown in Figure 7-84.

Saving the Model
1. Choose the Save button from the Standard toolbar and save the model with the

name given below:

\My Documents\SolidWorks\c07\c07-tut02.SLDPRT.

2. Choose File > Close from the menu bar to close the file.
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Tutorial 3
In this tutorial you will create the cylinder head of a two-stroke automobile engine shown in
Figure 7-85. The dimensions of the model are shown in Figure 7-86. After creating the model
you will also create a section view of the model using the section view tool.

        (Expected time: 1 hr)

The steps to be followed to complete this tutorial are discussed next:

a. Create the base feature of the model by extruding a polygon to the given depth, refer to
Figure 7-87.

b. Add the fillet features to the base feature.

Figure 7-83  Final solid model

Figure 7-84  The FeatureManager Design Tree
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Figure 7-86  Top view and the section front view with dimensions

Figure 7-85  Cylinder head of a two-stroke automobile engine
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c. Create the circular feature at the bottom face of the base feature.
d. Create the revolve cut feature to create the dome of the cylinder head, refer to Figures 7-88

and 7-89.
e. Create the leftmost fin of the cylinder head by extruding the sketch. The sketch for this

feature should be carefully dimensioned and defined, refer to Figure 7-90.
f. Pattern the fin to get the required number of fins. This pattern feature will be created

using the vary sketch option, refer to Figure 7-91.
g. Create other cut and extrude features to complete the creation of the model, refer to

Figure 7-92.
h. Add a tap hole using the hole wizard, refer to Figure 7-93.
i. Create the section view of the model, refer to Figure 7-94.

Creating the Base Feature
1. Create a new SolidWorks part document.

The base feature of the model will be created by extruding the sketch created on the
Top plane.

2. Select the Top plane as the sketching plane and invoke the sketching environment.

3. Create the sketch for the base feature and add the required relations and dimensions to
the sketch as shown in Figure 7-87.

4. Invoke the Extrude PropertyManager and extrude the sketch to a depth of 4mm.

Creating the Second Feature
The second feature of the model is the fillet feature. You have to fillet the vertical edges
of the base feature using the given radius.

Figure 7-87  Sketch for the base feature
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1. Invoke the Fillet PropertyManager and set the value of the Radius spinner to 15 and
select the vertical edges of the base feature to add the fillet feature.

2. Choose the OK button from the Fillet PropertyManager.

Creating the Third Feature
After creating the base and adding the fillet to the base, now you will create the third
feature of the model, which is a circular extruded feature. This feature will be created by
extruding a sketch created on the bottom face of the base feature. The sketch will be
extruded to the given depth.

1. Select the bottom face of the base feature as the sketching plane and invoke the sketching
environment.

2. Create a circle of 55mm diameter and add the required relations.

3. Extrude the sketch to a depth of 4mm.

Creating the Fourth Feature
The fourth feature is a revolved cut feature. The sketch for the revolved cut feature will be
created on the Front plane. After creating the sketch, apply the required relations and
dimensions to the sketch.

1. Select the Front plane from the FeatureManager Design Tree and then invoke the
sketching environment.

2. Create the sketch for the revolved cut feature and add the required relations and dimensions
as shown in Figure 7-88. You may need to apply the vertical relation between the center of
the arc and the origin to fully define the sketch.

Figure 7-88  Sketch for the revolve cut feature
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Note
When you create the sketch for the revolved cut feature, create a horizontal centerline such that
the start point of the centerline will be merged with the upper endpoint of the arc. After creating
the centerline add a tangent relation between the arc and the centerline. This is done to maintain
the tangency of the arc.

3. Select the vertical centerline and invoke the Cut-Revolve PropertyManager. Set the value
of the Angle spinner to 360.

4. Choose the OK button from the Cut-Revolve PropertyManager.

The rotated model after creating the fourth feature is shown in Figure 7-89.

Creating the Fifth Feature
Next, you will create the leftmost fin of the cylinder head. It will be created by extruding
a sketch to both the directions. The sketch of this feature is created on the Front plane
and the sketch will be dimensioned and defined such that the length of the fin is driven
by a construction arc and a horizontal dimension. The procedure of creating, dimensioning,
and defining the sketch is discussed next in detail.

1. Select the Front plane from the FeatureManager Design Tree and invoke the sketching
environment.

2. Using the line tool create the triangle and then create a vertical centerline that passes
through the upper vertex to the triangle, refer to Figure 7-90.

3. Choose the 3 Pt Arc button from the Sketch Tools toolbar and create the arc as

Figure 7-89  Cut revolve feature added to the model
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Figure 7-90  Sketch for the fin of the cylinder head

shown in Figure 7-90. Select the arc and select the For Construction check box from the
Options rollout of the Arc PropertyManager.

4. Invoke the Add Relations PropertyManager and add the coincident relation between
the upper vertex of the triangle and the centerline.

5. Add the midpoint relation between the lower endpoint of the centerline and the horizontal
line of the triangle. Also, add the vertical relation to the centerline, if it is missing.

6. Add the coincident relation between the upper vertex of the triangle and the arc.

7. Add the required dimensions and relations to fully define the sketch as shown in
Figure 7-90.

8. Invoke the Extrude PropertyManager and extrude the sketch in both the directions
using the Through All option. You will notice that the feature extends out of the base
feature at both the ends. This error will be removed later in this tutorial.

Patterning the Fifth Feature
Now, you will pattern the fin created earlier using the Linear Pattern tool. This pattern
feature will be using the vary sketch option. In this type of pattern feature, the geometry
of each instance of the pattern vary according to the driven dimension and the relation
added to the sketch of the feature to be patterned.

Tip. It is evident from Figure 7-86 that one of the horizontal dimension is having
a value of 6.155. By default the primary unit precision is set to two decimal places.
Therefore, for defining a dimension with a value in which the decimal places are
more you have to select that dimension and select the precision value from the
Primary Unit Precision drop-down list from the Dimension PropertyManager.
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Figure 7-91  Model after patterning the fin of the cylinder head

1. Choose the Linear Pattern button from the Feature toolbar to invoke the Linear
Pattern PropertyManager.

You are prompted to select the directional reference.

2. Invoke the selection mode in the Features to Pattern rollout and select the fifth feature,
which is an extrude feature, from the drawing area.

3. Select the horizontal dimension with the value of 6.155 as the directional reference.

4. Set the value of the Spacing spinner to 9. Set the value of the Number of Instances
spinner to 13. Choose the Reverse Direction button.

5. Invoke the Options rollout and select the Vary Sketch check box from this rollout.

The preview of the pattern will not be displayed in the drawing area when you choose the
Vary Sketch check box from the Options rollout.

6. Choose the OK button from the Linear Pattern PropertyManager.

The model after adding the pattern feature is shown in Figure 7-91.

Creating the Cut Feature
The next feature that you are going to create is a cut feature. Using the rotate tool rotate
the solid model and you will observe that the fins of the cylinder head that you patterned
in the last feature are extending beyond the boundary of the base feature. Therefore, in
order to trim the extended portion of the fins you will create a cut feature and trim the
extended portion.
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1. Select the top planar face of the base feature as the sketching plane and invoke the sketching
environment.

2. Create the sketch using the standard sketch tools. The sketch for this feature will be the
outer profile of the base feature.

3. Invoke the Cut-Extrude PropertyManager. Choose the Reverse Direction button from
the Direction 1 rollout and select the Through All option from the End Condition
drop-down list.

Since the direction of the side from which material has to be removed is the opposite to
the required direction, therefore, you need to flip the direction of material removal.

4. Select the Flip side to cut check box from the Direction 1 rollout and choose the OK
button from the Cut-Extrude PropertyManager.

5. Using the cut and extrude options, shape the model as shown in Figure 7-92.

Figure 7-92  Model after adding other extrude and cut features

Tip. The sketch sharing option is also available in SolidWorks. You can use the
sketch used to create a sketch feature to create any other sketch feature. For sharing
the sketch select the sketch from the FeatureManager Design Tree. You need to
expand the sketched feature to select the sketch from the FeatureManager Design

Tip. You can create the sketch using the outer profile of the base feature using the
Convert Entities tool. Select the lower flat face of the base feature and choose the
Convert Entities button from the Sketch Tools toolbar. You will notice that the
sketch similar to the outer boundary of the base feature will be placed on the sketching
plane.
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Patterning the Remaining Features
After creating all the features now you have to pattern the cut, extrude, and hole features
created at the lower left corner of the model.

1. Invoke the Linear Pattern PropertyManager and select the cut, extrude, and hole features,
created on the lower left corner of the model.

2. Select the two directional references to pattern the features in both the directions and set
the values of the distances between the instances and the number of instances.

3. Choose the OK button from the Linear PropertyManager.

Creating a Tapped Hole
The last feature of the model is a hole feature. You will create a tapped hole using the Hole
Wizard and then define the placement of the hole.

1. Select the top face of the middle circular extrude feature as the placement plane for the
hole feature.

2. Invoke the Hole Definition dialog box and select the Tap tab from the Hole Definition
dialog box. Select ANSI Metric from the Standard drop-down list.

3. Select the M18x1.5 option from the Size drop-down list to define the size of the tap hole.

4. Select the Through All option from the Tap Drill Type drop-down list. Also, select the
Through All option from the Thread Type and Depth drop-down list.

5. Select the Add Cosmetic thread with thread callout option from the Add Cosmetic
Thread drop-down list. Choose the Next button from the Hole Definition dialog box.
The Hole Placement dialog box is displayed.

The tapped hole will be placed by default on the placement plane; therefore, you will
define the placement of the tapped hole.

6. Invoke the Add Relations PropertyManager and add the Concentric relation between
the centerpoint of the tapped hole and the circular extruded feature in the middle of the
model.

Tip. You will observe that the cosmetic thread is displayed with the tapped hole
feature. If you orient the model in the top view you will observe the thread convention
in the top view. If you orient the model in the front, back, right, or left views then
you will view the side convention of the thread.

You can also hide the cosmetic thread by selecting the cosmetic thread from the
drawing area and invoking the shortcut menu. Choose the Hide option from the
shortcut menu to hide the cosmetic thread.
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Figure 7-93  Final solid model

7. Choose the Finish button from the Hole Placement dialog box to end feature creation.

The rotated final model is shown in Figure 7-93.

Displaying the Section View of the Model
Next, you will display the section view of the model. The section view of the model is
created using the Section View dialog box.

1. Orient the model in the isometric view.

2. Choose View > Display > Section View from the menu bar to invoke the Section View
dialog box.

The Front view is selected by default. The name of the Front view is also displayed in the
Selection Plane(s)/Face(s) display area.

3. Select the Preview check box to display the preview of the section view.

Since side to view the section view is opposite to the required side, therefore, you have to
flip the side of viewing the section view.

4. Select the Flip the Side to View check box. The preview of the section view is modified
automatically.

5. Choose the OK button from the Section View dialog box to create the section view.

6. Click anywhere in the drawing area to remove the Front plane from the selection set. The
section view of the model is shown in Figure 7-94.
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Figure 7-94  Section view of the model

7. Choose the Section View option again from the View menu to return to the full view
mode. The FeatureManager Design Tree is shown in Figure 7-95.

Figure 7-95  The FeatureManager Design Tree
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Saving the Model
Since the document has not been saved once until now, therefore, when you choose
the Save button from the Standard toolbar, the Save As dialog box will be
displayed. You can enter the name of the document in this dialog box.

1. Choose the Save button from the Standard toolbar and save the model with the name
given below:

\My Documents\SolidWorks\c07\c07-tut03.SLDPRT.

2. Choose File > Close from the menu bar to close the file.

SELF-EVALUATION TEST
Answer the following questions and then compare your answers with the answers given at
the end of this chapter.

1. To invoke the Mirror PropertyManager choose View > Pattern/Mirror > Mirror from
the menu bar. (T/F)

2. If you modify the parent feature then the same change will not reflect on the mirrored
feature. (T/F)

3. You cannot preselect the mirror plane and the feature to pattern before invoking the
mirror tool. (T/F)

4. You can mirror single face using the mirror tool. (T/F)

5. You can also pattern a pattern feature. (T/F)

6. The  __________ dialog box is used to view the section view.

7. Using __________ check box you can remove the material using the dome tool.

8. __________ option is used to create a pattern by specifying the coordinates.

9. __________ option is used to create a pattern with respect to the sketched points.

10. Using the __________ rollout you can delete the pattern instances.

REVIEW QUESTIONS
Answer the following questions:

1. The __________ check box is used to accommodated all the instances of pattern along
the selected curve.
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2. Enter the coordinates for creating the instances in the __________ area of the Table
Driven Pattern dialog box.

3. You have to invoke __________ to create a rib feature.

4. __________ check box is selected to create an elliptical dome feature.

5. Using __________ check box from the Section View dialog box you can create a section
using an invisible plane normal to the eye view as the section plane.

6. When you choose the Mirror button from the Features tool, which PropertyManager is
displayed?

(a) Mirror Feature PropertyManager (b) Mirror All PropertyManager
(c) Mirror PropertyManager (d) Copy/Mirror PropertyManager

7. Which option is used to mirror the exact geometry of the feature independent of the
relationships between the geometries?

(a) Same Mirror (b) Geometry Pattern
(c) Geometry Copy (d) Copy Geometry

8. Which pattern is created along the sketched lines, arcs, or splines?

(a) Curve driven pattern (b) Sketch driven pattern
(c) Geometry driven pattern (d) Linear Pattern

9. Which dialog box is invoked to create a pattern by specifying the coordinate points?

(a) Sketch Driven Pattern (b) Table Driven Pattern
(c) Mirror (d) None of these

10. Which plane is selected by default when you invoke the Section View dialog box to create
a section view?

(a) Right (b) Top
(c) Front (d) Plane 1
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EXERCISES

Exercise 1
Create the model shown in Figure 7-96. The dimensions of the model are shown in Figure 7-97.

        (Expected time: 1 hr)

Figure 7-96  Solid model for Exercise 1
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Figure 7-97  Views and dimensions of the model for Exercise 1

Exercise 2
Create the model shown in Figure 7-98. The dimensions of the model are shown in Figure 7-99.

        (Expected time: 1 hr)
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Figure 7-99  Views and dimensions of the model for Exercise 2

Figure 7-98  Solid model for Exercise 2

c07-solidworks-2003.p65 5/11/2003, 5:06 PM64



Advanced Modeling Tools-II       7-65

Figure 7-100  Solid model for Exercise 3

Figure 7-101  Section view of the model

Exercise 3
Create the model shown in Figure 7-100. After creating the model create the section view of
the model using the Right plane. Figure 7-101 shows the  section view of the model. The
dimensions of the model are shown in Figure 7-102.     (Expected time: 45 min)
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Figure 7-102  Views and dimensions of the model for Exercise 3

Answers to Self-Evaluation Test
1. F, 2. F, 3. F, 4. F, 5. T, 6. Section View, 7. Reverse Direction, 8. Table Driven Pattern, 9.
Sketch Driven Pattern, 10. Instances to Skip
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