
Chapter 1

Drawing Sketches for
the Solid Models

After completing this chapter you will be able to:
• Understand the requirement of the sketching environment.
• Open a new part document.
• Understand the various terms used in sketching environment.
• Work with various sketching tools.
• Use the drawing display tools.
• Delete the sketched entities.

Learning Objectives
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THE SKETCHING ENVIRONMENT
Most of the products designed using SolidWorks are a combination of sketched features,
placed features, and derived features. The placed and derived features are created without
creating a sketch but the sketched features require a sketch to be created first. Generally, the
base feature of any design is a sketched feature and is created by drawing the sketch. However,
once you are conversant with the various options of SolidWorks, you can also use a derived
feature or a derived part as the base feature. Therefore, while creating any design, the first
and foremost point is to draw the sketch for the base feature. Once you have drawn the sketch
for the base feature, you can convert it into the base feature and then add the other sketched,
placed, and derived features to complete the design. In this chapter you will learn to create
the sketch for the base feature using the various sketcher entities.

In general terms, a sketch is defined as the basic contour for the feature. For example, consider
the spanner shown in Figure 1-1.

This spanner consists of a base feature, a cut feature, a mirror feature (cut on the back face),
fillets, and an extruded text feature. The base feature of this spanner is shown in Figure 1-2.
This base feature is created using a single sketch shown in Figure 1-3. This sketch is drawn in
the sketching environment using the various sketching tools. Therefore, to draw the sketch of
the base feature, you first need to invoke the sketching environment where you will draw the
sketch.

Figure 1-1  Solid model of a spanner
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The sketching environment of SolidWorks can be invoked any time in the Part mode, Assembly
mode, and Drawing mode. You just have to specify that you want to draw the sketch of a
feature. This is done by choosing the Sketch button from the Sketch toolbar, see Figure 1-4.
This toolbar is available by default on the right of the drawing window. When you choose this
button, the sketching environment will be invoked. You can draw the sketch in this environment
and then proceed to the part modeling environment for converting the sketch into a solid
model.

Figure 1-2  Base feature of the spanner

Figure 1-3  Sketch for the base feature of the spanner
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Figure 1-5  Tip of the Day dialog box

Figure 1-4  Choosing the Sketch button from the Sketch
toolbar to invoke the sketching environment

OPENING A NEW DOCUMENT
When you start SolidWorks, the Tip of the day dialog box will be displayed as shown in
Figure 1-5.

Choose the Close button from this dialog box. You will notice that the Welcome to
SolidWorks 2003 window is displayed as shown in Figure 1-6. This window can be used to
open a new file, open an existing file, and use the various types of helps available in SolidWorks
to start working with this 3D solid modeling tool. This window is also used to visit the website
of the SolidWorks partners.

Tip. When you choose any option from the Welcome to SolidWorks 2003 window,
it is not closed. It is minimized on the screen and you can restore this window to
open an existing file, open a new file, or use any other option.

Tip. If the Tip of the Day dialog box is not displayed when you start the SolidWorks
session then choose Help > Tip of the Day from the menu bar. The Tip of the
Day dialog box is displayed. Select the Show tips at startup option from this
dialog box. By selecting the Show tips at startup option, the Tip of the Day
dialog box will be displayed every time when you start SolidWorks session. You get
valuable tips from the Tip of the Day dialog box. The tips displayed in this dialog
box are helpful in the full utilization of this CAD package.
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Figure 1-7  New SolidWorks Document dialog box

Choose New Document from the Welcome to SolidWorks 2003  window. The New SolidWorks
Document dialog box is displayed as shown in Figure 1-7. The various options available in
this dialog box are discussed next.

Figure 1-6  Welcome to SolidWorks 2003 window
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Template Tab
The Template tab displays the three default templates for opening a new part, assembly, or
drawing file. These three default templates are discussed next.

Part Template
Select the Part template and choose OK from the New SolidWorks Document dialog box to
open a new part document for creating the solid models or sheet metal component. When
you open a new part document, you will enter the Part mode and Plane 1 is selected by
default for sketching. As mentioned earlier, choose the Sketch button from the Sketch toolbar
and you will enter the sketching environment where you can draw the sketch of the base
feature.

Assembly Template
Select the Assembly template and choose OK from the New SolidWorks Document dialog
box to open a new assembly document. In an assembly document, you will assemble various
components created in the various part files. You can also create the components in the
assembly document.

Drawing Template
Select the Drawing template and choose OK from the New SolidWorks Document dialog
box to open a new drawing document. In a drawing document, you can generate or create
the drawing views of the parts created in the part document or the assemblies created in the
assembly documents. When you select the Drawing template, the Create RapidDraft Drawing
check box is displayed on the lower left corner of the New SolidWorks Document dialog
box. This check box is selected to create the rapid draft drawings. A rapid draft drawing is
the one that can be opened and edited without loading the part or the assembly file in the
memory of SolidWorks.

Note
The concept of rapid draft is discussed in detail in later chapters.

Tutorial Area
The Tutorial tab also displays the three default templates for opening a new part, assembly,
or drawing file. The only difference between the default templates in the Template tab and
the default templates in the Tutorial area is the drawing template. If you choose the drawing
template from the Tutorial tab, a standard A-Landscape format sheet will be displayed in
the current document, whereas if you choose the drawing template from the Template tab
then you can choose a drawing sheet of any size. Therefore, it is recommended that you
always select the templates from the Template tab.

In addition to the Template area, this dialog box also provides you with three buttons and
the Preview area. These options are discussed next.
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Large Icon button
The Large Icon button is used to display the templates in the Templates area in the
form of large icons. This button is chosen by default.

List button
The List button is used to list the three templates in the Template area in the form of
small icons.

List Details button
The List Details button is chosen to list the details of the templates in the Templates
area. When you choose this button, the Template area is divided into three columns:
Name, Size, and Modified. These columns display the name, size, and the date when

the template was modified.

Preview Area
The Preview area is used to preview the template to be used.

Note
You can customize the templates in the New SolidWorks Document dialog box according to
your need and add a tab with the customized templates in this dialog box. Creation and
customization of the templates is discussed later in the book.

THE SKETCHING ENVIRONMENT
When you choose the Part template, a new part file will be opened in the part modeling
environment. As mentioned earlier, you will have to choose the Sketch button from the Sketch
toolbar to invoke the sketching environment. The default screen appearance of a SolidWorks
part document in the sketching environment is shown in Figure 1-8.

SETTING UP THE DOCUMENT OPTIONS
When you install SolidWorks on your system, you are prompted to specify the dimensioning
standards and units for measuring linear distances. You can specify these options at that
time. The settings specified at that time are made the default settings and whenever you
open a new SolidWorks document, the new file will have those settings. However, if you want
to modify these settings for a particular file, you can easily do it using the Document Properties
dialog box. To invoke this dialog box, choose Tools > Options. When you invoke this option,
the System Options dialog box will be displayed. In this dialog box, choose the Document
Properties tab. The name of this dialog box is changed to Document Properties dialog box.
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Modifying the Dimensioning Standards
To modify the dimensioning standards, invoke the System Options dialog box and then
choose the Document Properties tab. You will notice that the Detailing option is selected by
default from the area on the left to display the detailing options as shown in Figure 1-9.

The default dimensioning standard that was selected while installing SolidWorks will be
selected in the drop-down list provided in the Dimensioning standard area. You can select
the required dimensioning standard from this drop-down list. The standards that are available
in this drop-down list are ANSI, ISO, DIN, JIS, BSI, GOST, and GB. You can select any one of
these dimensioning standards for the current document.

Figure 1-8  Screen display of a part document in the sketcher environment

Tip. When you open a new SolidWorks document, it is not maximized in the
SolidWorks window. This is the reason the area of the new document is not maximum.
To maximize the document, choose the Maximize button provided on the upper
right corner of the document. You can also maximize the document window by
double-clicking the blue bar on top of the document window.
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Modifying the Linear and Angular Units
To modify the linear and angular units, invoke the System Options dialog box and then
choose the Document Properties tab. In this tab, select the Units option from the area on
the left to display the options related to linear and angular units as shown in Figure 1-10. The
default option for measuring the linear distances that was selected while installing SolidWorks
will be various in the drop-down list provided in the Linear units area. The various types of
units that you can select from this drop-down list are angstroms, nanometers, microns,
millimeters, centimeters, meters, microinches, mils, inches, feet, and feet & inches. You can
also change the units for angular dimensions by selecting it from the drop-down list in the
Angular units area. The various types of angular units that can be selected from this drop-down
list are degrees, deg/min, deg/min/sec, and radians.

Figure 1-9  Setting the dimensioning standards

c01-solidworks-2003.p65 5/12/2003, 9:52 AM9



1-10             SolidWorks for Designers

Modifying the Snap and Grid Settings
When you switch to the sketching environment of SolidWorks, you will notice that the
cursor jumps through a distance of 10 units. This is evident from the coordinates of
the current location of the cursor displayed close to the lower left corner of the

SolidWorks window. You will notice that as you move the cursor, the coordinates change. This
change in coordinate values is in the increment of 10 units. Therefore, if you draw a sketched
entity, its length will change in the increment of 10. The reason for this is that the default
ratio between the major and minor grid spacing in the sketching environment is 10. However,
if you want that the coordinates should change in any other increment, you will have to
modify the ratio of major and minor lines in the grid accordingly. For example, if you want
that the coordinates should change in the increment of 5 units, you will have to make the
ratio of major and minor lines to 5. To do this, choose the Grid button from the Sketch
toolbar. The Document Properties - Grid/Snap dialog box will be displayed as shown in
Figure 1-11.

Note that the value of the Major grid spacing spinner is 100 and that of the Minor-lines per

Figure 1-10  Setting the dimensioning units
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major spinner is 10. This means that the ratio between the major and minor lines is 10
because of which the cursor jumps through a distance of 10mm. To make the cursor jump
through a distance of 5mm, set the value of the Major grid spacing spinner to 50. The cursor
will now jump through a distance of 5mm.

Note
Remember that this setting will only be for the current documents. When you open another
document, it will again have the settings that were defined while installing SolidWorks.

Tip. If you want to display the grid in the sketching environment, select the Display
grid check box from the Grid area of the Document Properties - Grid/Snap
dialog box. If you do not want the cursor to snap to a point, clear the Snap to
points check box from the Snap area.

Figure 1-11  Modifying the Grid and Snap settings
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LEARNING ABOUT SKETCHER TERMS
Before you learn about the various sketching tools, it is important for you to understand
some terms that are used in the sketching environment. These terms are discussed next.

Origin
The origin is a red color icon that is displayed in the middle of the sketching environment
screen. This icon consists of two arrows displaying the X and the Y axis direction. The point
of intersection of these two axes is the origin point and the coordinates of this point are 0,0.

Inferencing Lines
The inferencing lines are the temporary lines that are used to track a particular point on the
screen. These lines are dashed lines and are automatically displayed when you select a sketching
tool in the sketcher environment. These lines are created from the endpoint of a sketched
entity or from the origin. For example, if you want to draw a line from the point where two
imaginary lines intersect, you can use the inferencing lines to locate the point and then draw
the line from that point. Figure 1-12 shows the use of inferencing lines to locate the point of
intersection of two imaginary lines.

Figure 1-13 shows the use of inferencing lines to locate the center of an arc. Notice that the
inferencing lines are created from the endpoint of the line and from the origin.

Note
The inferencing lines that are displayed on the screen will be either blue or brown in color. The
blue inferencing lines suggest that the relations are not added to the sketched entity and the
brown inferencing lines suggest that the relations are added to the sketched entity. You will learn
about various relations in later chapters.

Figure 1-12  Using inferencing lines to locate a point

Tip. You can also turn off the automatic inferencing lines by choosing Tools >
Sketch Settings > Automatic Inferencing Lines from the menu bar.
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Select Tool

The Select tool is used to select a sketched entity or exit any sketching tool that is
active. You can select the sketched entities by picking them one by one using the left
mouse button. You can also define a window by holding the left mouse button down

and dragging the cursor around the sketched entities to select them. Remember that only
those entities will be selected that lie completely inside the window that you have defined.

Note
You can also invoke the Select tool or exit a sketching tool by pressing the ESC key.

Once you are familiar with these terms, you will learn about various sketcher tools available
in SolidWorks. The various sketcher tools are discussed next.

DRAWING LINES

The lines are one of the basic sketching tools available in SolidWorks. In general
terms, a line is defined as the shortest distance between two points. As mentioned
earlier, SolidWorks is a parametric solid modeling tool. This property allows you to

draw a line of any length and at any angle and then later force it to the desired length and
angle. To draw a line in the sketcher environment of SolidWorks, choose the Line tool. You
will notice that the cursor that was an arrow earlier is replaced by the line cursor. The line
cursor is actually a pencil-like cursor with a small inclined line below the pencil.

Figure 1-13  Using inferencing lines to locate the center of an arc

Menu: Tools > Select
Toolbar: Sketch > Select

Menu: Tools > Sketch Entity > Line
Toolbar: Sketch Tools > Line
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In SolidWorks, there are two methods to draw lines. The first method is to draw continuous
lines and the second method is to draw individual lines. Both these methods are discussed
next.

Drawing Continuous Lines
This is the default method of drawing lines. In this method you just have to specify the
startpoint and the endpoint of the line using the left mouse button. As soon as you specify
the startpoint of the line, the Line PropertyManager will be displayed on the left of the
screen. However, when you are drawing continuous lines, the options in the Line
PropertyManager will not be available.

When you specify the startpoint and the endpoint of the line using the left mouse button, a
line will be drawn between the two points. You will notice that the line is green in color and
has square boxes at the two ends. The line is displayed in green color because it is still
selected. As soon as you draw another line, choose the Select tool, or choose another tool, the
line turns to blue in color and the new line is displayed in green color.

You will notice that after you have drawn the first line, another line is displayed on the
screen. The startpoint of this line is the endpoint of the last line and the length of this line
will increase or decrease as you move the mouse. This line is called a rubber-band line and
the reason it is a called a rubber-band line is that this line will stretch like a rubber-band as
you move the cursor. The point that you specify next on the screen will be taken as the
endpoint of the second line and a line will be drawn such that the endpoint of the first line is
taken as the startpoint of the new line and the point you specify is taken as the endpoint of
the new line. Now, a new rubber-band line is displayed starting from the endpoint of the last
line. This is a continuous process and you can draw as many continuous lines as you need by
specifying the points on the screen using the left mouse button.

You can exit the continuous line drawing process by pressing the ESC key from the keyboard,
by choosing the Select tool, or by double-clicking the screen. You can also right-click to
display the shortcut menu and choose the End Chain option from the shortcut menu.
Figure 1-14 shows a sketch drawn using continuous lines.

Note
When you exit the line drawing process by double-clicking the screen or by choosing End chain
from the shortcut menu, the current chain is ended but the Line tool is still active and you can
draw additional lines.

Drawing Individual Lines
This is the second method of drawing lines. Using this method you can draw individual lines
and the startpoint of the next line will not necessarily be the endpoint of the last line. To
draw individual lines, you need to press and hold down the left mouse button and drag the
cursor from the startpoint of the line to the endpoint. Once you have dragged the cursor to
the endpoint, release the left mouse button. A line will be drawn between the point from
where you started dragging the mouse and the point where you released the mouse.
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To make the process of sketching in SolidWorks easy, you are provided with the
PropertyManager. The PropertyManager is a table that is displayed on the left of the screen
as soon as you select the first point of any sketch entity. The PropertyManager has all the
parameters related to the sketched entity such as the startpoint, endpoint, angle, length, and
so on. You will notice that as you start dragging the mouse, the Line PropertyManager is
displayed on the left of the drawing window. All the options in the Line PropertyManager
will be available when you release the left mouse button. Figure 1-15 shows partial display of
the Line PropertyManager.

Note
The Line PropertyManager will also display addition options about relations. You will learn
more about relations in later chapters.

After you have drawn the line, modify the parameters in the Line PropertyManager to force
the line to the desired length and angle. You can also dynamically modify the line by holding
the square boxes at the endpoints of the line and dragging them.

When you draw lines in the sketcher environment of SolidWorks, you will notice that a numeric
value is displayed above the line cursor, see Figure 1-16. This numeric value indicates the
length of the line that you draw. This value is the same as that in the Length spinner of the
Line PropertyManager. The only difference is that in the Line PropertyManager, the value
will be displayed with more precision.

Figure 1-14  Sketch drawn with the help of continuous lines
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The other thing that you will notice while sketching is that sometimes when you are drawing
vertical or horizontal lines, a V or an H symbol is displayed below the line cursor. These are
the symbols of the Vertical and Horizontal relations. SolidWorks automatically applies
these relations to the lines. These relations ensure that the lines that you draw are vertical
or horizontal and not inclined. Figure 1-17 shows the symbol of the Vertical relation on a line
and Figure 1-18 shows the symbol of the Horizontal relation on a line.

Figure 1-15  Partial display of the Line PropertyManager

Figure 1-16  The length of the line displayed on the screen while drawing the line
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Note
In addition to the Horizontal and Vertical relations, you can also apply a number of other
relations such as Tangent, Concentric, Perpendicular, Parallel, and so on. You will learn
about all these relations in later chapters.

The other options of the Line PropertyManager will be discussed in later chapters.

Drawing Construction Lines

Construction lines are the ones that are drawn only for the aid of sketching. These
lines are not considered while converting the sketches into features. You can draw a
construction line similar to the sketched line by using the Centerline tool. You will

notice that when you draw a construction line, the For Construction check box in the Line
PropertyManager is selected. You can also draw a construction line by sketching the line
using the Line tool and then selecting the For Construction check box available in the Line
PropertyManager. You will notice that when you choose this check box, the line is turned
into a centerline.

DRAWING CIRCLES

In SolidWorks, the circles are drawn by specifying the centerpoint of the circle using
the left mouse button and then moving the mouse on the screen to define the radius
of the circle. Similar to the lines, as soon as you specify the center of the circle, the

Circle PropertyManager is displayed. However, note that the options in the Circle
PropertyManager will be available only after you have defined the radius of the circle.
Figure 1-19 shows the Circle PropertyManager.

To draw the circle, choose the Circle button. You will notice that the arrow cursor is replaced
by the circle cursor. The circle cursor consists of a pencil and two concentric circles below the
pencil. Specify the centerpoint of the circle and then move the cursor to define the radius of

Menu: Tools > Sketch Entity > Centerline
Toolbar: Sketch Tools > Centerline

Figure 1-18  Symbol of the Horizontal relationFigure 1-17  Symbol of the Vertical relation

Menu: Tools > Sketch Entity > Circle
Toolbar: Sketch Tools > Circle
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Tip. To convert a construction entity back to the sketched entity, invoke the select
tool and then select the construction entity. The entity will turn green in color and
the PropertyManager will be displayed on the left of the drawing window. From
the PropertyManager, clear the For Construction check box. The construction
entity will again be changed into a sketched entity and will be displayed with
continuous line.

the circle. The current radius of the circle is displayed above the circle cursor. This radius will
change as you move the cursor. You can define any arbitrary radius of the circle and then
modify it to the desired value by using the Circle PropertyManager. Figure 1-20 shows a
circle being drawn using the Circle tool.

Sketching a Construction Circle
If you want to sketch a construction circle, draw the circle using the Circle tool and then
select the For Construction check box available in the Circle PropertyManager.

Figure 1-19  Circle PropertyManager
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Menu: Tools > Sketch Entity > Tangent Arc
Toolbar: Sketch Tools > Tangent Arc

Figure 1-20  Sketching a circle

DRAWING ARCS
In SolidWorks, you can draw the arcs using three methods: Tangent Arc, Centerpoint Arc,
and 3 Point Arc. All these methods can be invoked separately by choosing their respective
buttons from the Sketch Tools toolbar. All these three methods to draw arcs are discussed
next.

Drawing Tangent Arcs

The tangent arcs are the ones that are drawn tangent to an existing sketched entity.
The existing sketched entities include sketched and construction lines, arcs, and
splines. As soon as you invoke this tool, the arrow cursor is replaced by the arc cursor.

An arc cursor consists of a pencil and an arc below the pencil.

To draw a tangent arc, invoke the Tangent Arc tool and then move the arc cursor close to the
endpoint of the entity that you want to select as the tangent entity. You will notice that the
entity selected as the tangent entity is turned green in color and the color of the pencil in the
cursor is changed to yellow. Also, an orange-colored box is displayed below the pencil. This
suggests that the endpoint of the entity is selected. Now, press the left mouse button once
and move the cursor to size the arc. The arc will start from the endpoint of the tangent entity
and its size will change as you move the cursor. Note that the angle and the radius of the
tangent arc are displayed above the arc cursor, see Figure 1-21.

As soon as you start moving the cursor, the Arc PropertyManager is displayed. However, the
options in the Arc PropertyManager are not available at this stage. These options are enabled
only after you have completed drawing the tangent arc. When you complete a tangent sketch
by specifying its endpoint, the SolidWorks information box is displayed as shown in
Figure 1-22. This dialog box will inform you to select the endpoint of a sketched entity to
draw another tangent arc.
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Menu: Tools > Sketch Entity > Centerpoint Arc
Toolbar: Sketch Tools > Centerpoint Arc

You can draw an arbitrary tangent arc and then modify its value using the Arc
PropertyManager. Figure 1-23 shows a partial view of the Arc PropertyManager.

Note
When you select a tangent entity to draw a tangent arc, the Tangent relation is applied between
the startpoint of the arc and the tangent entity. Therefore, if you change the coordinates of the
startpoint of the arc, the tangent entity will also be modified accordingly.

Drawing Centerpoint Arcs

The centerpoint arcs are the ones that are drawn by defining the centerpoint,
startpoint, and endpoint of the arc. When you invoke this tool, the arrow cursor is
replaced by the arc cursor. As mentioned earlier, an arc cursor consists of a pencil

and an arc below the pencil.

To draw a centerpoint arc, invoke the Centerpoint Arc tool and then move the arc cursor to
the point that you want to specify as the centerpoint of the arc. Press the left mouse button

Figure 1-21  Drawing tangent arc

Figure 1-22  SolidWorks information box prompting you
to select the endpoint of another sketched entity
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once at the location of the centerpoint and then move the cursor to the point from where you
want to start the arc. You will notice that a dotted circle is displayed on the screen. This size
of this circle will modify as you move the mouse. This circle is drawn for your reference and
the centerpoint of this circle lies at the point that you specified as the center of the arc. Press
the left mouse button once at the point that you want to select as the startpoint of the arc.
Next, move the mouse to specify the endpoint of the arc. You will notice that the reference
circle is no more displayed and an arc is being drawn with the startpoint as the point that
you specified  after specifying the centerpoint. Also, the Arc PropertyManager similar to the
one that is shown in the tangent arc is displayed on the left of the drawing window. Note that
the options in the Arc PropertyManager will not be available at this stage.

Figure 1-23  Arc PropertyManager
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Figure 1-25  Moving the cursor to specify the startpoint and the endpoint of the arc

If you move the cursor in the clockwise direction, the resultant arc will be drawn in the
clockwise direction. However, if you move the cursor in the counterclockwise direction, the
resultant arc will be drawn in the counterclockwise direction. Specify the endpoint of the arc
using the left mouse button. Figure 1-24 shows the reference circle that is drawn when you
move the mouse button after specifying the centerpoint of the arc and Figure 1-25 shows the
resultant centerpoint arc.

Drawing 3 Point Arcs

The 3 point arcs are the ones that are drawn by defining the startpoint and endpoint
of the arc, and a point somewhere on the arc. When you invoke this tool, the arrow

Menu: Tools > Sketch Entity > 3 Point Arc
Toolbar: Sketch Tools > 3 Pt Arc

Figure 1-24  Specifying the centerpoint and the startpoint of the centerpoint arc
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Figure 1-26  Specifying the startpoint and the endpoint of the arc

Figure 1-27  Specifying the point on arc to draw it

cursor is replaced by the arc cursor.

To draw a 3 point arc, invoke the 3 Pt Arc tool and then move the arc cursor to the point that
you want to specify as the startpoint of the arc. Press the left mouse button once at the
location of the startpoint and then move the cursor to the point that you want specify as the
endpoint of the arc. As soon as you start moving the cursor after specifying the startpoint, a
reference arc will be drawn and the Arc PropertyManager will be displayed. However, the
options in the Arc PropertyManager will  not be available at this stage.

Using the left mouse button, specify the endpoint of the arc. You will notice that the reference
arc is no more displayed. Instead a solid arc is displayed and the cursor is attached to the arc.
As you move the cursor, the arc will also be modified dynamically. Using the left mouse
button, specify a point on the screen to create the arc. The last point that you specify will
determine the direction of the arc. The options in the Arc PropertyManager will be displayed
after you have drawn the arc. You can modify the properties of the arc using the Arc
PropertyManager. Figure 1-26 shows the reference arc that is drawn by specifying the startpoint
and the endpoint of the arc and Figure 1-27 shows the resultant 3 point arc.
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Figure 1-28  Drawing a tangent arc using the Line tool

Invoking the Options to Draw an Arc from within the Line
Tool
SolidWorks allows you to invoke the options to draw tangent and normal arcs while you are
drawing continuous lines using the Line tool. Note that the option to draw an arc can be
invoked only if at least one sketched line, arc, or spline exists on the screen. To draw an arc
tangent to the last line drawn using the current Line tool sequence, move the cursor away
from the endpoint of the line and then move it back close to the endpoint. You will notice
that the line cursor is replaced by the arc cursor and the Line PropertyManager is replaced
by the Arc PropertyManager. Similarly, if you want to draw an arc tangent to an existing
sketched entity using the Line tool, invoke this tool and select the endpoint of the sketched
entity. Now, move the cursor away from the endpoint and then move it back close to the
endpoint. You will switch to the arc mode.

Now, if you want to draw an arc tangent to the previous line, move the cursor along the line
through a small distance. A dotted line will be drawn. Next, move the cursor in the direction
in which the arc should be drawn. You will notice that a tangent arc is drawn. Specify the
endpoint of the tangent arc using the left mouse button. Figure 1-28 shows an arc tangent to
an existing line.

If you want to draw an arc normal to the previous line, move the cursor away from the
endpoint and then move it back to the endpoint to switch to the arc mode. Next, move the
cursor normal to the existing line and then move the cursor in the direction in which the arc
should be drawn. You will notice that a normal arc is being drawn. Figure 1-29 shows a
normal arc being drawn using the Line tool.

Figure 1-29  Drawing a normal arc using the Line tool
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Figure 1-30  Drawing a rectangle by specifying two opposite corners

After drawing an arc using the Line tool, the next entity that will be drawn in the same
sequence is the line. If you want to draw another arc, use the procedure that was followed
while drawing the first arc. Note that if you want to switch back to the line mode, click once at
the endpoint of the previous entity using the left mouse button. You can also toggle between
the line and the arc mode by pressing the A key from the keyboard or by using the option in
the shortcut menu that is displayed when you right-click in the drawing area.

DRAWING RECTANGLES

In SolidWorks, the rectangles are drawn by specifying two opposite corners of the
rectangle. To draw a rectangle, invoke the Rectangle tool. The arrow cursor will be
replaced by the rectangle cursor. Move the cursor to the point that you want to specify

as the first corner of the rectangle. Press the left mouse button once at the first corner and
then move the cursor and specify the other corner of the rectangle using the left mouse
button. You will notice that the length and width of the rectangle are displayed above the
rectangle cursor. The length is measured along the X axis and the width is measured along
the Y axis. Figure 1-30 shows a rectangle being drawn by specifying two opposite corners.

Menu: Tools > Sketch Entity > Rectangle
Toolbar: Sketch Tools > Rectangle
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Note
When you draw a rectangle, the PropertyManager will not be displayed. This is because a
rectangle is considered as a combination of four individual lines. Therefore, after drawing the
rectangle, if you select one of the lines of the rectangle using the Select tool, the Line
PropertyManager will be displayed. You can modify the parameters of the selected line using
the Line PropertyManager.

Remember that since the relations are applied to all the four corners of the rectangle, if you
modify the parameters of one of the lines using the Line PropertyManager, the other three
lines will also be modified accordingly.

You can convert a rectangle into a construction rectangle by selecting all the lines together using
a window and then selecting the For Construction check box from the PropertyManager.

DRAWING PARALLELOGRAM

In SolidWorks, the Parallelogram tool can be used to draw a parallelogram and also to draw
a rectangle at an angle. The methods to draw both these entities are discussed next.

Drawing a Rectangle at an Angle
A rectangle at an angle is drawn by first defining one of the edges of the parallelogram using
two points. Since the edge is defined using two points, you can specify the points at an angle,
thus forcing the edge to be at an angle. After defining one of the edges at an angle, you will
move the cursor to define the width of the rectangle. The width of the rectangle will be
defined normal to the first edge. Therefore, you will specify a total of three points in defining
a parallelogram.

To draw a rectangle at an angle, invoke the Parallelogram tool from the menu bar. The
cursor will be replaced by the parallelogram cursor. Move the cursor to the point that you
want to select as the startpoint of one of the edges of the rectangle. Press the left mouse
button once at this point and move the cursor to size the edge. You will notice that a reference
line is being drawn. Based on the current position of the cursor, the reference line will be
horizontal, vertical, or aligned. The current length of the edge and its angle will be displayed
above the parallelogram cursor. Using the left mouse button, specify the endpoint of the
edge such that the resultant reference line is at an angle.

Next, move the cursor to specify the width of the rectangle. You will notice that a reference
rectangle is drawn at an angle. Also, irrespective of the current position of the cursor, the
width will be specified normal to the first edge, either above or below. Using the left mouse
button, specify a point on the screen to define the width of the rectangle. The reference
rectangle will be converted into a sketched rectangle. Figure 1-31 shows a rectangle drawn at
an angle.

Drawing Parallelograms
The process of drawing a parallelogram is similar to that of drawing a rectangle at an angle.

Menu: Tools > Sketch Entity > Parallelogram
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The only difference is that while specifying the third point to define the width, press the
CTRL key from the keyboard. The width will no more be added normal to the first edge.
Therefore, you can draw a parallelogram.

To draw a parallelogram, invoke the Parallelogram tool from the menu bar. The cursor will
be replaced by the parallelogram cursor. Specify two points on the screen to define one edge
of the parallelogram. Next, press the CTRL key from the keyboard once and then move the
mouse to define the width of the parallelogram. You will notice that the width is no more
added normal to the first edge. As you move the mouse, a reference parallelogram will be
drawn. The size and the shape of the reference parallelogram will depend upon the current
location of the cursor.

Specify the point on the screen to define the parallelogram. Figure 1-32 shows a parallelogram
drawn at an angle.

Note
Similar to the rectangles, each edge of a parallelogram is considered as a separate line. Also, in
case of parallelograms, the PropertyManager is not displayed while you are drawing it.

DRAWING POLYGONS

A polygon is defined as a multisided geometric figure in which the length of all the
sides and the angle between all the sides are the same. In SolidWorks, you can draw
a polygon with the number of sides ranging from 3 to 40. The dimensions of a polygon

are controlled using the diameter of a construction circle that is either inscribed inside the
polygon or circumscribed about the polygon. If the construction circle is inscribed inside the

Menu: Tools > Sketch Entity > Polygon
Toolbar: Sketch Tools > Polygon

Figure 1-31  Rectangle at an angle
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polygon, the diameter of the construction circle is taken from the edges of the polygon. If the
construction circle is circumscribed about the polygon, the diameter of the construction circle
is taken from the vertices of the polygon.

To draw a polygon, invoke the Polygon tool. When you invoke this tool, the Polygon
PropertyManager will be displayed as shown in Figure 1-33. Set the parameters such as the
number of sides, inscribed or circumscribed circle, and so on in the Polygon PropertyManager.
You can also modify these parameters after drawing the polygon. When you invoke this tool,
the arrow cursor will be replaced by the polygon cursor. Press the left mouse button at the
point that you want to select as the centerpoint of the polygon and then move the cursor to
size the polygon. The length of each side and the rotation angle of the polygon will be
displayed above the polygon cursor as you drag it. Using the left mouse button, specify a
point on the screen after you get the desired length and rotation angle of the polygon. You
will notice that based on whether you selected the Inscribed circle or the Circumscribed
circle radio button in the Polygon PropertyManager, a construction circle will be drawn
inside or outside the polygon. After you have drawn the polygon, you can modify the
parameters such as the centerpoint of the polygon, the diameter of the construction circle,
the angle of rotation of the polygon, and so on using the Polygon PropertyManager. If you
want to draw another polygon, choose the New polygon button provided below the Angle
spinner in the Polygon PropertyManager.

Figure 1-34 shows a six-sided polygon with the construction circle inscribed inside the polygon
and Figure 1-35 shows a five-sided polygon with the construction circle circumscribed outside
the polygon. Notice that the reference circle is retained with the polygon. Remember that
this circle will not be considered while converting the polygon into a feature.

Figure 1-32  Parallelogram at an angle
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Figure 1-34  Six-sided polygon with construction circle inscribed inside the polygon

Figure 1-33  Polygon PropertyManager
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DRAWING SPLINES

In SolidWorks, the splines can be drawn using two methods. In the first method,
which is the default method, you can draw a spline by continuously specifying the
endpoints of the spline segments using the left mouse button. This method of drawing

splines is similar to the method of drawing continuous lines.

In the second method of drawing a spline, you have to specify the first point of the spline and
then press and hold the left mouse button and drag the cursor to define the second point of
the spline. After specifying the second point, release the left mouse button. One segment of
the spline will be drawn. To draw the next segment, move the cursor close to the endpoint of
the first spline segment. The pencil in the spline cursor will turn yellow in color and an
orange-colored box will be displayed below the pencil. This suggests that the endpoint is
selected. When the orange box is displayed, press and hold the left mouse button down and
drag the cursor. The endpoint of the last segment will be taken as the startpoint of the
second segment and the point where you release the cursor will be taken as the endpoint of
the second segment. Repeat the procedure to draw as many segments of the spline.

The number of points you specify in a spline are taken as the handles of the spline. Therefore,
after drawing a spline, if you select it using the Select tool, all the points that you specified
are displayed on the spline inside square boxes. These points are called the handles or the
control points and you can modify the shape of a spline using these handles. Figure 1-36
shows a sketched spline.

Note
Irrespective of the number of segments in a spline, it will be considered as a single entity.

Figure 1-35  Five-sided polygon with construction circle circumscribed outside the polygon

Menu: Tools > Sketch Entity > Spline
Toolbar: Sketch Tools > Spline
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DRAWING POINTS

To draw a point, choose the Point tool and then specify the point on the screen where
you want to place the point. The Point PropertyManager will be displayed with the X
and Y coordinates of the current point. You can modify the location of the point by

modifying its X and Y coordinates in the Point PropertyManager.

DRAWING ELLIPSES

In SolidWorks, the ellipse is drawn by specifying the centerpoint of the ellipse and then
specifying the two ellipse axes by moving the mouse. To draw an ellipse, invoke this tool from
the menu bar. The arrow cursor will be replaced by the ellipse cursor. Move the cursor to the
point that you want to select as the centerpoint of the ellipse. Press the left mouse button
once at the centerpoint of the ellipse and then move the cursor to specify one of the ellipse
axis. You will notice that a reference circle is drawn and two values are displayed above the
ellipse cursor, see Figure 1-37. The first value that shows R = * is the radius of the first axis
that you are defining and the second value that shows r = * is the radius of the other axis.

Menu: Tools > Sketch Entity > Ellipse

Figure 1-36  Sketched spline with startpoint at the origin

Tip. As you start drawing a spline, the Spline PropertyManager is displayed.
However, the options in it are not available. These options will be available when
you select an existing spline using the Select tool. The current handle will be
displayed with a filled square and its number and the corresponding X and Y
coordinates will be displayed in the Spline PropertyManager. You can modify
these coordinates to modify the selected spline.

Menu: Tools > Sketch Entity > Point
Toolbar: Sketch Tools > Point
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While you are defining the first axis, the second axis is taken equal to the first axis. This is the
reason a reference circle is drawn and not a reference ellipse.

Specify a point on the screen to define the first axis. Next,
move the cursor to size the other ellipse axis. You will notice
that the Ellipse PropertyManager is displayed. Figure 1-38
shows a partial view of the Ellipse PropertyManager.

The second value above the ellipse cursor that shows r = *
will change dynamically as you move the cursor on the screen.
Using the left mouse button, specify a point on the screen to
define the second axis of the ellipse, see Figure 1-39.

Figure 1-37  Dragging the cursor to define the first axis

Figure 1-38  Partial view of the
Ellipse PropertyManager

Figure 1-39  Define the second axis of the ellipse
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DRAWING ELLIPTICAL ARCS

In SolidWorks, the process of drawing an elliptical arc is similar to that of drawing an ellipse.
You will follow the same process of defining the ellipse first. The point that you specify on the
screen to define the other axis of the ellipse is taken as the startpoint of the elliptical arc. You
can define the endpoint of the elliptical arc by specifying a point on the screen as shown in
Figure 1-40.

You can also set the parameters of the elliptical arc in the Ellipse PropertyManager shown in
Figure 1-41.

DRAWING A PARABOLIC CURVE

In SolidWorks, you will draw a parabolic curve by specifying the focal point of the parabola
and then specifying two points on the guide lines of the parabolic curve. To draw a parabolic
curve, invoke this tool from the menu bar. The cursor will be replaced by the parabola cursor.
Move the cursor to the point that you want to specify as the focal point of the parabola. Press
the left mouse button once at the focal point and then move the cursor to define the apex
point and size the parabola. You will notice that a reference parabolic arc is displayed. As you
move the cursor away from the focal point, the parabola is flattened. After you get the basic
shape of the parabolic curve, specify a point on the screen using the left mouse button. This
point is taken as the apex of the parabolic curve. Next, specify two point on the screen with

Menu: Tools > Sketch Entity > Parabola

Menu: Tools > Sketch Entity > Centerpoint Ellipse

Figure 1-40 Drawing the elliptical arc

c01-solidworks-2003.p65 5/12/2003, 9:52 AM33



1-34             SolidWorks for Designers

respect to the reference parabola to define the guide lines of the parabolic curve, see
Figure 1-42.

As you move the mouse after specifying the focal point of the parabola, the Parabola
PropertyManager will be displayed. But the options in the Parabola PropertyManager will
not be available. These options will be available only after you have drawn the parabola.
Figure 1-43 shows a partial view of the Parabola PropertyManager.

Figure 1-41  Ellipse PropertyManager
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DRAWING DISPLAY TOOLS
The drawing display tools are one of the most important tools provided in any of the solid
modeling software. These tools allow you to modify the display of the drawing by zooming or
panning the drawing. Some of the drawing display tools that are available in SolidWorks are
discussed in this chapter. The remaining tools are discussed in the later chapters.

Figure 1-42  Drawing the parabola

Figure 1-43  Partial view of the Parabola
PropertyManager
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Zoom to Fit

The Zoom to Fit tool is used to increase or decrease the drawing display area so that
all the sketched entities or dimensions are fitted inside the current view.

Zoom to Area

The Zoom to Area tool is used to magnify a specified area so that the part of the
drawing inside the magnified area can be viewed in the current window. The area is
defined by a window that is created by dragging the cursor and specifying two opposite

corners of the window. When you choose this tool, the cursor is replaced by a magnifying
glass cursor. Press and hold the left mouse button down and drag the cursor to specify two
opposite corners of the window. The area enclosed inside the window will be magnified.

Zoom In/Out

The Zoom In/Out tool is used to dynamically zoom in or out of the drawing. When
you invoke this tool, the cursor is replaced by the zoom cursor. To zoom out of a
drawing, press and hold the left mouse button down and drag the cursor in the

downward direction. Similarly, to zoom in a drawing, press and hold the left mouse button
down and drag the cursor in the upward direction. As you drag the cursor, the drawing
display will be modified dynamically. After you get the desired view, exit this tool by choosing
the Select tool from the Sketch toolbar. You can also exit this tool by right-clicking and
choosing Select from the shortcut menu or by pressing the ESC key.

Zoom to Selection

The Zoom to Selection tool is used to modify the drawing display area such that the
selected entity is fitted inside the current display. This tool will be available only
when you select an entity using the Select tool. After selecting the entity, choose the

Zoom to Selection button. The drawing display area will be modified such that the selected
entity fits inside the current view.

Menu: View > Modify > Zoom to Fit
Toolbar: View > Zoom to Fit

Menu: View > Modify > Zoom to Area
Toolbar: View > Zoom to Area

Menu: View > Modify > Zoom In/Out
Toolbar: View > Zoom In/Out

Menu: View > Modify > Zoom to Selection
Toolbar: View > Zoom to Selection

Tip. You can also use the keyboard shortcuts to invoke some of the drawing display
tools. For example, to invoke the Zoom to Fit tool, press the F key. Similarly, to
zoom out of a drawing, press the Z key and to zoom in, press SHIFT+Z key.
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Pan

The Pan tool is used to drag the view in the current display. This process is similar to
changing the view by using the scroll bars available in the drawing window.

Redraw

The Redraw tool is used to refresh the screen. Sometimes when you draw a sketched
entity, some unwanted elements remain on the screen. To remove these unwanted
elements from the screen, choose this tool. The screen will be refreshed and all the

unwanted elements will be removed. You can also invoke this tool by pressing CTRL+R keys
from the keyboard.

DELETING THE SKETCHED ENTITIES
You can delete the sketched entities by selecting them using the Select tool and then pressing
the DELETE key from the keyboard. You can select the entities by picking them individually
or select more than one entity by defining a window around the entities. When you select the
entities, they turn green in color. When they turn green, press the DELETE key from the
keyboard. You can also delete the sketched entities by selecting them and choosing the Delete
option from the shortcut menu that is displayed upon right-clicking.

TUTORIALS

Tutorial 1
In this tutorial you will draw the sketch of the model shown in Figure 1-44. The sketch is
shown in Figure 1-45. You will not dimension the sketch. The solid model and the dimensions
are given only for your reference.     (Expected time: 30 min)

The steps that will be followed to complete this tutorial are listed below:

a. Start SolidWorks and then open a new part file.
b. Maximize the part file document and then switch to the sketching environment.
c. Draw the sketch of the model using the Line and the Circle tools, refer to Figure 1-48

through Figure 1- 50.
d. Save the sketch and then close the file.

Menu: View > Modify > Pan
Toolbar: View > Pan

Menu: View > Redraw
Toolbar: Standard > Rebuild

Tip. You can also invoke the Pan tool using the CTRL key and the arrow keys on
the keyboard. For example, to pan toward the right, press the CTRL key and then
press the right arrow key a few times. Similarly, to pan upward, press the CTRL
key  and then press the up arrow key a few times.
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Starting SolidWorks and Opening a New Part Document
1. Start SolidWorks by choosing Start > Programs > SolidWorks 2003 > SolidWorks 2003

or by double-clicking the shortcut icon of SolidWorks available on the desktop of your
computer.

The Tip of the Day dialog box will be displayed. If the Tip of the Day dialog box is not
displayed when you start the SolidWorks session then you need to set the option to
display the Tip of the Day dialog box when you start the new SolidWorks session.

2. Choose Help > Tip of the Day from the menu bar. The Tip of the Day dialog box is
displayed. Select the Show tips at startup check box from this dialog box.

Figure 1-44  Solid model for Tutorial 1

Figure 1-45  Sketch of the model
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Figure 1-46  New SolidWorks Document dialog box

By selecting the Show tips at startup check box, the Tip of the Day dialog box will be
displayed every time you start the SolidWorks session. You can get many valuable tips
from the Tip of the Day dialog box. The tips displayed in this dialog box are helpful to
make the full utilization of this CAD package.

3. Close the Tip of the Day dialog box by choosing the Close button. The Welcome to
SolidWorks 2003 window is displayed. Choose the New Document option from this
window.

The New SolidWorks Document dialog box is displayed.

4. Select the Part option and then choose the OK button from the New SolidWorks
Document dialog box as shown in Figure 1-46.

A new SolidWorks part document will be opened. But the part document window will not
be maximized in the SolidWorks window.

Tip. If the shortcut icon of SolidWorks is not created automatically on the desktop
of your system when you install SolidWorks, you can create it manually. To create
the shortcut icon on the desktop, choose Start > Programs > SolidWorks 2003
to display the SolidWorks cascading menu. Right-click SolidWorks 2003 in the
cascading menu and then choose Send To > Desktop (create shortcut) from the
shortcut menu.
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5. Choose the Maximize button available on the upper right corner of the part document
window to maximize the document window.

When you open a new part document, the part modeling environment is active by default.
Since you first need to draw the sketch of the feature, you need to invoke the sketching
environment.

6. Choose the Sketch button from the Sketch toolbar to invoke the sketching
environment.

You will notice that the origin that was displayed with gray color earlier is changed to red
color, indicating the sketching environment. The default screen appearance of the
sketching environment of SolidWorks is shown in Figure 1-47.

Figure 1-47  Screen display in the sketcher environment

Tip. If the grid is displayed on the screen when you invoke the sketching environment
for the first time, then you can set the option to turn off the grid display. Choose
Tools > Options from the menu bar. The System Options - General dialog box
is displayed. Choose the Document Properties tab from this dialog box. Select the
Grid/Snap option from the left of this dialog box. Clear the Display grid check
box from the Grid area and choose the OK button from this dialog box.
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Setting the Units and Grid
It is assumed that while installing SolidWorks, you selected the option of measuring the
length in millimeters. This is the reason the length will be measured in millimeter in the
current file. However, if you selected some other units, you need to make some initial
settings of changing the linear and angular units before you proceed with drawing the
sketch.

1. Choose Tools > Options from the menu bar to invoke the System Options - General
dialog box.

2. Choose the Document Properties tab. The name of the dialog box will be changed to
the Document Properties - Detailing dialog box.

3. Select the Units option from the area on the left to display the options related to linear
and angular units.

4. Select Millimeters from the drop-down list available in the Linear units area. Also, select
the Degrees option from the drop-down list provided in the Angular units area.

Note
If you selected Millimeters as the units while installing SolidWorks, you can skip the points
discussed earlier in this section.

5. Select Grid/Snap from the area on the left. Set the value of the Major grid spacing
spinner to 100 and the value of the Minor-lines per major spinner to 10.

6. Select the Snap to points check box if it is cleared. Choose OK to exit the dialog box.

Drawing the Outer Loop of the Sketch
It is a good practice to draw the sketch on one side of the origin, preferably in the first
quadrant. This is because while generating the part program for manufacturing the part,
you will have a reference for work origin in advance.

The sketch of the model consists of an outer loop, two circles inside the outer loop, and
a cavity. Therefore, it will be drawn using the Line and the Circle tools. You will first
draw the outer loop and then the inner entities. Note that in the sketcher environment,
the lower right corner of the SolidWorks window displays three areas. The first area
displays the X, Y, and Z coordinates of the current location of the cursor. These coordinates
will modify as you move the cursor around the drawing area. You will use the coordinate
display to draw the sketch of the model.

You will start drawing the sketch from the lower left corner of the sketch and the outer
loop will be drawn using the continuous lines.

1. Choose the Line button from the Sketch Tools toolbar to invoke the Line tool.

The arrow cursor will be replaced by the line cursor.
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2. Move the cursor in the first quadrant close to the origin. The coordinates of the point
will be displayed close to the lower right corner of the screen.

3. Press the left mouse button at the point whose coordinates are 10mm 10mm 0mm and
then move the cursor horizontally toward the right.

You will notice that the symbol of Horizontal relation is displayed below the line cursor
and the length of the line is displayed above the line cursor.

Since the length of the first horizontal line at the lower left corner is 10mm, you will
move the mouse until the length of the line is shown as 10 above the line cursor.

4. Press the left mouse button when the length of the line that is displayed above the line
cursor shows a value of 10.

The first horizontal line is drawn. Since you are drawing continuous lines, the endpoint
of the last line will be automatically selected as the startpoint of the next line.

5. Move the line cursor vertically upward. The symbol of Vertical relation will be displayed
below the line cursor and the length of the line will be displayed above the line cursor.

6. Press the left mouse button when the length of the line displayed above the line cursor
shows a value of 10.

A vertical line of length 10mm will be drawn and will be displayed in green color. Also,
since this is the line that is selected, the previous line will no more be highlighted and
therefore will be displayed in blue color.

7. Move the line cursor horizontally toward the right. Press the left mouse button when the
length of the line above the line cursor shows a value of 10.

This draws the next horizontal line of 10mm length.

8. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor shows a value of 10.

9. Move the line cursor horizontally toward the right and press the left mouse button when
the length of the line on the line cursor shows a value of 30.

10. Move the line cursor vertically upwards and press the left mouse button when the length
of the line on the line cursor shows a value of 10.

11. Move the line cursor horizontally toward the right and press the left mouse button when

Tip. If by mistake you invoke the arc mode while drawing lines, move the cursor
back to the endpoint of previous line and press the left mouse button. The line mode
will be invoked again.
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the length of the line on the line cursor shows a value of 10.

12. Move the line cursor vertically downwards and press the left mouse button when the
length of the line on the line cursor shows a value of 10.

13. Move the line cursor horizontally toward the right and press the left mouse button when
the length of the line on the line cursor shows a value of 10.

14. Move the line cursor vertically upwards and press the left mouse button when the length
of the line on the line cursor displays a value of 40.

The next line that you will draw is an inclined line that makes an angle of 135-degree. To
draw this line, you will move the cursor in a direction that makes an angle of 135-degrees.
It is not necessary to make sure that the line you draw is exact. You can draw a line at
some other angle and then modify the values from the Line PropertyManager.

The aligned length of the line is not given for this line. Instead, the delta X and delta Y
values are given. Therefore, you will draw a line at this point such that the delta X and
delta Y value of this line is 10mm. These values can be viewed in the Line
PropertyManager. The last spinners in the Line PropertyManager are for the delta
values.

15. Move the line cursor such that the line is drawn at an angle of 135-degree. The current
angle will be displayed in the spinner above the delta spinners in the Line PropertyManager.

16. Press the left mouse button when the delta X value in the Delta X spinner shows a value
of 10 and the value of delta Y in the Delta Y spinner displays a value of 10 in the Line
PropertyManager.

The length of the line will be displayed as 14.14 above the line cursor and also in the
Length spinner in the Line PropertyManager.

17. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 50.

You will notice that some blue and brown inferencing lines are displayed when you move
the cursor.

18. Move the line cursor in the direction of 225-degree angle.

You will notice that two blue inferencing lines are displayed. The first one originates
from the startpoint of the first inclined line and the other one from the startpoint of the
first line of the sketch.

19. Press the left mouse button at the point where the two inferencing lines intersect.

You will notice that at this point, the length of the line on the line cursor shows a value of
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14.14. Also, the delta X and delta Y values in the Line PropertyManager are displayed
as 10 each and the angle is shown as 225.00-degree.

20. Move the cursor vertically downwards to the startpoint of the first line.

You will notice that when you move the cursor close to the startpoint of the first line, the
line cursor turns yellow in color and an orange-colored box is displayed below the line
cursor. Also, the length of the line shows a value of 40.

21. Press the left mouse button when the line cursor turns yellow in color. Right-click to
display the shortcut menu and choose the Select option to exit the Line tool.

This completes the sketch of the outer loop. You will notice a the sketch of a very small
size is displayed since the display area shows the area in all the four quadrants. Therefore,
you need to modify the drawing display area such that the sketch fits the screen. This is
done using the Zoom to Fit tool.

22. Choose the Zoom to Fit button from the View toolbar to fit the current sketch on
the screen.

The outer loop of the sketch is completed and is shown in Figure 1-48.

Drawing Circles
The circles will be drawn using the Circle tool. You will use the inferencing line generating
from the endpoints of the inclined lines to specify the centerpoint of the circles. The
point where the inferencing lines meet is the centerpoint of the circle. As mentioned
earlier, the cursor in the sketching environment jumps through a distance of 10mm by

Figure 1-48  Outer loop of the sketch
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default. Therefore, when you move the cursor to define the radius of the arc, the minimum
value that can be set is 10mm. This is the reason you need to modify the document
settings so that the cursor jumps through a distance of 5mm.

1. Choose the Grid button from the Sketch toolbar. The Document Properties -
Grid/Snap dialog box will be displayed.

2. Set the value of the Major grid spacing spinner to 50 and choose OK.

Setting this value to 50 will force the cursor to jump through a distance of 5mm instead
of 10mm. Therefore, when you move the cursor now, the values shown on the cursor and
the coordinates of the points shown close to the lower right corner of the SolidWorks
window will be in the increment of 5mm.

3. Choose the Circle button from the Sketch Tools toolbar to invoke the Circle
tool.

Since the Select tool was active earlier, the cursor earlier was the arrow cursor. But when
you invoke the Circle tool, the arrow cursor will be replaced by the circle cursor.

4. Move the circle cursor close to the lower endpoint of the right inclined line and then
move it toward the left. Remember that you will not press the left mouse button at this
moment.

The inferencing line will be displayed generating from the lower endpoint of the right
inclined line. When you move the cursor toward the left, you will notice that at the point
where the cursor is vertically in line with the upper endpoint of the right inclined line,
another inferencing line will be generated from the upper endpoint of the right inclined
line. This inferencing line will intersect the inferencing line generated from the lower
endpoint of the inclined line.

5. Press the left mouse button at the point where the inferencing lines from both the
endpoints of the inclined lines meet and then move the circle cursor toward the left to
define a circle.

6. Press the left mouse button when the radius of the circle displayed above the circle cursor
shows a value of 5.

7. Similarly, draw the circle on the left using the inferencing lines generating from the
endpoints of the left inclined line. The sketch after drawing the two circles inside the
outer loop is shown in Figure 1-49. Exit the Circle tool.

Drawing the Sketch of the Inner Cavity
Next, you will draw the sketch of the inner cavity. To draw the sketch of the inner cavity,
you will start drawing with the lower horizontal line.

1. Choose the Line button from the Sketch Tools toolbar.
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The arrow cursor will be replaced by the line cursor.

2. Move the line cursor to a location whose coordinates are 30mm 25mm 0mm.

3. Press the left mouse button at this point and move the cursor horizontally toward the
right. Press the left mouse button when the length of the line above the line cursor shows
a value of 30.

4. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 10.

5. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 10.

6. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor displays a value of 5.

7. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 10.

8. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 5.

9. Move the line horizontally toward the left and press the left mouse button when the
length of the line on the line cursor displays a value of 10.

10. Move the line cursor vertically downward to the startpoint of the first line. Press the left
mouse button when the line cursor turns yellow in color. The length of the line at this
point will show a value of 10.

Figure 1-49  Sketch after drawing the two inner circles
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11. Choose the Select button from the Sketch toolbar. This completes the sketch
for Tutorial 1. The final completed sketch for Tutorial 1 is shown in Figure 1-50.

Note
By default, the entity points are displayed at the endpoints when you sketch an entity. The entity
points are dots at the end points of lines, arcs, splines etc. If you do not want the entity points to
be displayed then choose Tools > Options from the menu bar to invoke the System Options -
General dialog box. Select the Sketch option from the left of this dialog box to display the
option related to sketch. Select the Display entity points in part/assembly sketches check box
and choose the OK button from this dialog box.

Saving the Sketch
It is recommended that you create a separate directory for saving the tutorial files of this
book. When you invoke the option to save a document, the default directory that is
displayed is /My Documents. You will create a directory with the name SolidWorks in this
directory and then create the directories of each chapter inside the SolidWorks directory.
As a result, you can save the tutorials of a chapter in the directory of that chapter.

1. Choose the Save button from the Standard toolbar to invoke the Save As dialog box.
Create SolidWorks directory inside the /My Documents directory and then create c01 directory
inside the SolidWorks directory.

2. Enter the name of the document as c01-tut01.sldprt in the File name edit box and choose
the Save button. The file will be saved in the /My Documents/SolidWorks/c01 directory.

3. Close the file by choosing File > Close from the menu bar.

Figure 1-50  Final sketch for Tutorial 1
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Tutorial 2
In this tutorial you will draw the basic sketch for the revolved solid model shown in Figure 1-51.
The sketch for the revolved solid model is shown in Figure 1-52. Do not dimension the sketch
as the solid model and the dimensions are given only for your reference.

    (Expected time: 30 min)

Figure 1-52  Sketch for the revolved model

Figure 1-51  Revolved model for Tutorial 2

Tip. If you open a document that was saved in the sketching environment, it will
be opened in the sketching environment only and not in the part modeling
environment.
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The steps that will be followed to complete this tutorial are listed below:

a. Open a new part file.
b. Maximize the part file document and then switch to the sketching environment.
c. Modify the settings of the snap and grid so that the cursor jumps through a distance of

5mm instead of 10mm.
d. Draw the sketch of the model using the Line tool, refer to Figure 1-53.
e. Save the sketch and then close the file.

Opening a New File
1. Choose the New button from the Standard toolbar to invoke the New

SolidWorks Document dialog box.

2. Select the Part option and then choose the OK button from the New SolidWorks
Document dialog box.

A new SolidWorks part document will be opened. But the part document window will not
be maximized in the SolidWorks window.

3. Choose the Maximize button available on the upper right corner of the part document
window to maximize the document window.

As mentioned earlier, when you open a new part document, the part modeling
environment is active by default. However, since you first need to draw the sketch of the
revolved model, you need to invoke the sketching environment.

4. Choose the Sketch button from the Sketch toolbar to invoke the sketching
environment.

The origin will turn red in color and the Sketch Tools toolbar will be displayed below the
Sketch toolbar. Also, the confirmation corner will be displayed with the Exit Sketch and
the Delete Sketch options on the upper right corner of the drawing area. This suggests
that the sketching environment is activated.

Modifying the Snap and Grid Settings and the Dimensioning Units
Before you proceed with drawing the sketch, you need to modify the grid and snap
settings so that you can make the cursor jump through a distance of 5mm instead of
10mm, which is the default value.

1. Choose the Grid button from the Sketch toolbar. The Document Properties -
Grid/Snap dialog box is displayed.

2. Set the value of the Major grid spacing spinner to 50. Make sure the value of the
Minor-lines per major spinner is 10.

The coordinates displayed close to the lower left corner of the SolidWorks window will show
an increment of 5mm instead of the default increment of 10mm when you exit the dialog box.

c01-solidworks-2003.p65 5/12/2003, 9:52 AM49



1-50             SolidWorks for Designers

3. Make sure the Snap to point check box in the Snap area is selected.

If you selected units other than millimeter to measure the length while installing
SolidWorks, you need to select the units for the current drawing.

4. Select the Units option from the area on the left of the Document Properties - Grid/
Snap dialog box.

5. Select Millimeter from the drop-down list available in the Linear units area and Degrees
from the drop-down list available in the Angular units area.

6. Choose the OK button after making the necessary settings.

Drawing the Sketch
As evident from Figure 1-52, the sketch will be drawn using the Line tool. You will start
drawing the sketch from the lower left corner of the sketch.

1. Choose the Line button from the Sketch Tools toolbar. The arrow cursor will be
replaced by the line cursor.

2. Move the line cursor to a location whose coordinates are 40mm 0mm 0mm.

An inferencing line originating from the origin will be displayed.

3. Press the left mouse button down at this point and move the cursor horizontally toward
the right. Press the left mouse button again when the length of the line above the line
cursor shows a value of 20.

4. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 20.

5. Move the cursor horizontally toward the left and press the left mouse button when the
length of the line on the line cursor displays a value of 5.

6. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 25.

7. Move the line cursor horizontally toward the right and press the left mouse button when
the length of the line on the line cursor displays a value of 20.

8. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 5.

9. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 50.
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10. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor displays a value of 5.

11. Move the line cursor horizontally toward the right and press the left mouse button when
the length of the line on the line cursor displays a value of 20.

12. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor displays a value of 25.

13. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 5.

14. Move the line cursor vertically downward to the startpoint of the first line. Press the left
mouse button when the line cursor turns yellow in color.

The length of the line at this point will be 20mm.

15. Choose the Select button from the Sketch toolbar.

The sketch is completed but does not fit the screen. Therefore, you need to modify the
display area such that the sketch fits the screen.

16. Choose the Zoom to Fit button from the View toolbar to fit the sketch on the
screen. The completed sketch for Tutorial 2 is shown in Figure 1-53.

Figure 1-53  Final sketch for Tutorial 2

Tip. You will notice that the bottom horizontal line in the sketch is black in color
and the remaining lines are blue in color. In the next chapter, you will learn about
the reason why some entities in the sketch are different in color.
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Saving the Sketch
1. Choose the Save button from the Standard toolbar to invoke the Save As dialog

box.

2. Enter the name of the document as c01-tut02.sldprt in the File name edit box and choose
the Save button.

The document will be saved in the /My Documents/SolidWorks/c01 directory.

3. Close the file by choosing File > Close from the menu bar.

Tutorial 3
In this tutorial you will draw the basic sketch of the model shown in Figure 1-54. The sketch
to be drawn is shown in Figure 1-55. Do not dimension the sketch as the solid model and the
dimensions are given only for your reference.     (Expected time: 30 min)

The steps that will be followed to complete this tutorial are listed below:

a. Start SolidWorks and then open a new part file.
b. Maximize the part file document and then switch to the sketching environment.
c. Modify the settings of the snap and grid so that the cursor jumps through a distance of

5mm instead of 10mm.
d. Draw the outer loop of the sketch using the Line and the Tangent Arc tool, refer to

Figure 1-56.
e. Draw the inner circle using the Circle tool, refer Figure 1-57
f. Save the sketch and then close the file.

Figure 1-54  Solid model for Tutorial 3
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Opening a New File
1. Choose the New button from the Standard toolbar to invoke the New

SolidWorks Document dialog box.

2. Select the Part option and then choose the OK button from the New SolidWorks
Document dialog box.

A new SolidWorks part document will be opened. However, as mentioned earlier, the
part document window will not be maximized in the SolidWorks window.

3. Choose the Maximize button available on the upper right corner of the part document
window to maximize the document window.

Since you first need to draw the sketch of the revolved model, you need to invoke the
sketching environment.

4. Choose the Sketch button from the Sketch toolbar to invoke the sketching
environment.

The origin turns red in color and the Sketch Tools toolbar is displayed below the Sketch
toolbar. Also, the confirmation corner with the Exit Sketch and Delete Sketch options
will be displayed on the upper right corner of the drawing area. This suggests that the
sketching environment is activated.

Modifying the Snap and Grid Settings and Dimensioning Units
Since the dimensions in the sketch are in the multiples of 5mm, you need to modify the
grid and snap settings so that you can make the cursor jump through a distance of 5mm
instead of 10mm.

Figure 1-55  Sketch for Tutorial 3
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1. Choose the Grid button from the Sketch toolbar. The Document Properties -
Grid/Snap dialog box will be displayed.

2. Set the value of the Major grid spacing spinner to 50 and make sure that the value of the
Minor-lines per major is 10. Also make sure that the Snap to points check box in the
Snap area is selected.

The coordinates displayed close to the lower left corner of the SolidWorks window will
show an increment of 5mm instead of the default increment of 10mm when you close the
dialog box.

3. If you selected units other than millimeter to measure the length while installing
SolidWorks, select the Units option from the area on the left of the Document Properties
- Grid/Snap dialog box. Select Millimeter from the drop-down list available in the Linear
units area and Degrees from the drop-down list available in the Angular units area.

4. Choose OK to close the dialog box.

Drawing the Outer Loop
As evident from Figure 1-55, the sketch will be drawn using the Line, Tangent Arc, and
the Circle tools. You will start drawing from the lower left corner of the sketch. Since the
length of the lower horizontal line is 150mm, therefore, you will have to modify the
drawing display area such that the drawing area in the first quadrant is increased. This
can be done using the Pan tool.

1. Choose the Pan button from the View toolbar. The arrow cursor will be replaced
by the pan cursor.

2. Press and hold the left mouse button down and drag the cursor toward the bottom left
corner of the screen.

You will notice that the origin also moves toward the bottom left corner of the screen,
thus increasing the drawing area in the first quadrant.

3. After dragging the origin close to the lower left corner, release the left mouse button.

4. Choose the Line button from the Sketch Tools toolbar.

The pan cursor will be replaced by the line cursor.

5. Move the line cursor to a location whose coordinates are 40mm 0mm 0mm.

An inferencing line originating from the origin will be displayed.

6. Press the left mouse button down at this point and move the cursor horizontally toward
the right. Press the left mouse button again when the length of the line above the line
cursor shows a value of 150.
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7. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 40.

The next entity that has to be drawn is a tangent arc. As mentioned earlier, you can draw
the tangent arc using the Line tool also. Drawing arcs from within the Line tool is a
recommended method when you need to draw a sketch that is a combination of lines and
arcs. This increases the productivity by reducing the time taken in invoking the tools for
drawing an arc and then invoking the Line tool to draw lines.

8. Move the line cursor away from the endpoint of the last line and then move it back to the
endpoint.

The arc mode will be invoked and the line cursor will be replaced by the arc cursor. Also,
the Arc PropertyManager will be displayed in place of the Line PropertyManager.

9. Move the arc cursor vertically upward to a small distance. A dotted reference line will be
displayed.

10. When the dotted line is displayed, move the cursor toward the left.

You will notice that a tangent arc is being drawn. The angle of the tangent arc and its
radius will be displayed above the arc cursor.

11. Press the left mouse button when the angle value above the arc cursor shows a value of
180 and the radius shows a value of 30 to complete the arc.

The required tangent arc is drawn. As mentioned earlier, the line mode is automatically
invoked after you have drawn the arc using the Line tool. Therefore, the arc cursor will
be replaced by the line cursor and the Arc PropertyManager will be replaced by the
Line PropertyManager.

12. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor displays a value of 20.

13. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 30.

14. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor displays a value of 5.

15. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 25.

16. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 5.
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17. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 35.

18. Move the line cursor to the startpoint of the first line. Press the left mouse button when
the line cursor turns yellow in color.

The length of the line at this point will be 20mm.

19. Right-click and choose Select from the shortcut menu to exit the Line tool.

20. Choose the Zoom to Fit button to fit the sketch on the screen. This completes the
outer loop of the sketch. The sketch after drawing the outer loop is shown in
Figure 1-56.

Drawing the Circle
The circle in the sketch will be drawn using the Circle tool. The centerpoint of the circle
will be the centerpoint of the arc, which is displayed by a cross. This cross is automatically
drawn when you draw the arc. You can select this centerpoint to draw the circle.

1. Choose the Circle button from the Sketch Tools toolbar to invoke the Circle
tool.

The arrow cursor will be replaced by the circle cursor.

2. Move the circle cursor close to the centerpoint of the arc and when the pencil in the
circle cursor turns yellow in color, press the left mouse button.

3. Move the cursor toward the left and when the radius of the circle above the circle cursor
shows a value of 15, press the left mouse button.

Figure 1-56  Sketch after drawing the outer loop

c01-solidworks-2003.p65 5/12/2003, 9:52 AM56



Drawing Sketches for the Solid Models        1-57

A circle of 15mm radius will be drawn.

4. This completes the sketch for Tutorial 3. Right-click and choose the Select option from
the shortcut menu to exit the Circle tool.

The final sketch for Tutorial 3 is shown in Figure 1-57.

Saving the Sketch
1. Choose the Save button from the Standard toolbar to invoke the Save As dialog box.

2. Enter the name of the document as c01-tut03.sldprt in the File name edit box and choose
the Save button.

3. Close the file by choosing File > Close from the menu bar.

Tutorial 4
In this tutorial you will draw the sketch of the model shown in Figure 1-58. The sketch for the
model is shown in Figure 1-59. Do not dimension the sketch as the dimensions and the solid
model are given only for your reference.     (Expected time: 30 min)

The steps that will be followed to complete this tutorial are listed below:

a. Start SolidWorks and then open a new part file.
b. Maximize the part file document and then switch to the sketching environment.
c. Modify the settings of the snap and grid so that the cursor jumps through a distance of

5mm instead of 10mm.
d. Draw the outer loop of the sketch using the Line and the Tangent Arc tool, refer to

Figure 1-60.
e. Save the sketch and then close the file.

Figure 1-57  Final sketch for Tutorial 3
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Opening a New File
1. Choose the New button from the Standard toolbar to invoke the New

SolidWorks Document dialog box.

2. Select the Part option and then choose the OK button from the New SolidWorks
Document dialog box.

3. Choose the Maximize button available on the upper right corner of the part document
window to maximize the document window.

Figure 1-59  Sketch for Tutorial 4

Figure 1-58  Model for Tutorial 4
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Since you first need to draw the sketch of the model, you need to invoke the sketching
environment.

4. Choose the Sketch button from the Sketch toolbar to invoke the sketching
environment.

Modifying the Snap and Grid Settings and Dimensioning Units
As evident in Figure 1-59, the dimensions in the sketch are in the multiples of 5mm.
Therefore, you need to modify the grid and snap settings so that the cursor jumps through
a distance of 5mm instead of 10mm.

1. Choose the Grid button from the Sketch toolbar. The Document Properties -
Grid/Snap dialog box will be displayed.

2. Set the value of the Major grid spacing spinner to 50 and the Minor line per major
spinner to 10. Also, select the Snap to points check box if not selected.

You will notice that the coordinates displayed close to the lower left corner of the
SolidWorks window shows an increment of 5mm instead of the default increment of
10mm.

3. If you selected units other than millimeter to measure the length while installing
SolidWorks, select the Units option from the area on the left of the Document Properties
- Grid/Snap dialog box. Select Millimeter from the drop-down list available in the Linear
units area and Degrees from the drop-down list available in the Angular units area.

4. Choose OK to close the dialog box.

Drawing the Sketch
The sketch will be drawn using the Line tool. The arc in the sketch will also be drawn
using the same tool. You will start drawing from the lower left corner of the sketch.

1. Choose the Line button from the Sketch Tools toolbar.

The arrow cursor will be replaced by the line cursor.

2. Move the line cursor to a location whose coordinates are 30mm 0mm 0mm.

An inferencing line originating from the origin will be displayed.

3. Press the left mouse button at this point and move the cursor horizontally toward the
right. Press the left mouse button again when the length of the line above the line cursor
shows a value of 60.

The bottom horizontal line of 60mm length will be drawn.
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4. Choose the Zoom to Fit button from the View toolbar to increase the display of
the line that is drawn.

As mentioned earlier, you can invoke the drawing display tools while you are inside a tool
also. After modifying the drawing display, the tool that was active before invoking the
drawing display tool will be restored and you can continue using that tool. Therefore,
after the drawing display area is modified, the Line tool will be restored and you can
continue drawing lines.

5. Move the line cursor along a direction that makes an angle close to 98-degree with the
positive X axis direction. The angle can be checked from the spinner above the Delta X
spinner in the Line PropertyManager.

6. When the Delta X spinner shows a value of 5 and Delta Y spinner shows a value of 35,
press the left mouse button.

The length of the line at this point will be 35.36.

7. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line above the line cursor shows a value of 10.

8. Move the line cursor vertically downward and press the left mouse button when the
length of the line above the line cursor shows a value of 10.

9 Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line above the line cursor shows a value of 5.

Next, you need to draw the arc that is normal to the last line.

10. Move the line cursor away from the endpoint of the last line and then move it back close
to the endpoint.

The arc mode will be invoked and the line cursor will be replaced by the line cursor. Also,
the Line PropertyManager will be replaced by the Arc PropertyManager.

11. Move the arc cursor vertically downward through a small distance.

A dotted line will be displayed.

12. When the dotted line is displayed, move the arc cursor toward the left.

You will notice that a normal arc is being drawn.

13. Press the left mouse button when the angle value on the arc cursor is 180 and the radius
value is 10.

An arc normal to the last line will be drawn and the line mode will be activated.
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14. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor shows a value of 5.

15. Move the line cursor vertically upward and press the left mouse button when the  length
of the line on the line cursor shows a value of 10.

16. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor shows a value of 10.

17. Move the line cursor to the startpoint of the first line and when the line cursor turn
yellow in color, press the left mouse button.

18. Right-click to display the shortcut menu and choose Select to exit the Line tool.

This completes the sketch. However, you need to modify the drawing display area such
that the sketch fits the screen.

19. Choose the Zoom to Fit button from the View toolbar to modify the drawing
display area. The final sketch for Tutorial 4 is shown in Figure 1-60.

Saving the Sketch
1. Choose the Save button from the Standard toolbar to invoke the Save As dialog box.

2. Enter the name of the document as c01-tut04.sldprt in the File name edit box and choose
the Save button.

3. Close the file by choosing File > Close from the menu bar.

Figure 1-60  Final sketch for Tutorial 4
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SELF-EVALUATION TEST
Answer the following questions and then compare your answers with the answers given at
the end of this chapter.

1. The base feature of any design is a sketched feature and is created by drawing the sketch.
(T/F)

2. You can also invoke the 3Pt Arc tool from within the Line tool. (T/F)

3. By default, the cursor jumps through a distance of 5mm. (T/F)

4. When you save a file in the sketching environment, it is opened in the part modeling
environment when you open it for the next time. (T/F)

5. You can convert a sketched entity into a construction entity by selecting the __________
check box provided in the PropertyManager.

6. To draw a rectangle at an angle, you need to use the __________ tool.

7. The __________ are the temporary lines that are used to track a particular point on the
screen.

8. You can also invoke the __________ tool or exit a sketching tool by pressing the ESC key.

9. When you select a tangent entity to draw a tangent arc, the __________ relation is applied
between the startpoint of the arc and the tangent entity.

10. Irrespective of the number of segments in a spline, it will be considered as a __________
entity.

REVIEW QUESTIONS
Answer the following questions:

1. The 3 point arcs are the ones that are drawn by defining the startpoint of the arc, the
endpoint of the arc, and a point on the arc. (T/F)

2. You can also delete the sketched entities by selecting them and choosing the Delete
option from the shortcut menu that is displayed upon right-clicking. (T/F)

3. The origin is a blue-colored icon that is displayed in the middle of the sketcher screen.
(T/F)

4. In SolidWorks, the circles are drawn by specifying the centerpoint of the circle and
then pressing and entering the radius of the circle in the dialog box that is displayed.
(T/F)
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5. When you open a new SolidWorks document, it is not maximized in the SolidWorks
window. (T/F)

6. In SolidWorks, a rectangle is considered as a combination of which of the following entities.

(a) Lines (b) Arcs
(c) Splines (d) None

7. Which one of the following options is not displayed in the New SolidWorks Document
dialog box?

(a) Part (b) Assembly
(c) Drawing (d) Sketch

8. Which one of the following entities will not be considered while converting a sketch into
a feature?

(a) Sketched Circles (b) Sketched Lines
(c) Construction Lines (d) None

9. When you select a line of the rectangle, which one of the following PropertyManager
will be displayed?

(a) Line PropertyManager (b) Line/Rectangle PropertyManager
(c) Rectangle PropertyManager (d) None

10. While drawing an elliptical arc, which one of the following PropertyManager will be
displayed?

(a) Arc PropertyManager (b) Ellipse PropertyManager
(c) Elliptical Arc PropertyManager (d) None
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Figure 1-62  Sketch for Exercise 1

Figure 1-61  Solid model for Exercise 1

EXERCISES

Exercise 1
Draw the sketch of the model shown in Figure 1-61. The sketch to be drawn is shown in
Figure 1-62. Do not dimension the sketch as the solid model and the dimensions are given
only for your reference.     (Expected time: 30 min)
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Figure 1-64  Sketch for Exercise 2

Figure 1-63  Solid model for Exercise 2

Exercise 2
Draw the sketch of the model shown in Figure 1-63. The sketch to be drawn is shown in
Figure 1-64. Do not dimension the sketch as the solid model and the dimensions are given
only for your reference.     (Expected time: 30 min)
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Answers to Self-Evaluation Test
1. T, 2. T, 3. F, 4. F, 5. For Construction, 6. Parallelogram, 7. inferencing lines, 8. Select,
9. Tangent, 10. single
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