
Chapter 12

Other Drawing Options

After completing this chapter you will be able to:
• Sketch in the Drawing mode.
• Create a user-defined drawing format for the drawing sheets.
• Add or remove the sheets from the current drawing.
• Create the tables in the current sheet.
• Use the assembly Bill Of Material in the assembly drawing views.

Learning Objectives
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SKETCHING IN THE DRAWING MODE
Sketching is one of the most important tools available in the Drawing mode. Sketching in the
Drawing mode is called Drafting. As discussed earlier, there are two types of drafting in
Pro/ENGINEER: Generative drafting and Interactive drafting. Any item on the drawing sheet
that is not generated from a model is called a draft entity or a draft item. Drafting is extensively
used for creating user-defined formats, drawing tables, and also for drawing the title blocks in
the formats. The sketching in the Drawing mode is almost similar to the sketching in the other
modes of Pro/ENGINEER. The sketching can be done by using the Sketch menu in the menu
bar or the tool buttons available in the Drawing Sketcher Tools toolbar from the Right
Toolchest. The tools available in the Drawing Sketcher Tools toolbar and the options available
in the Sketch menu that are used to sketch in the Drawing mode are discussed next.

Select Items
The Select one item at a time - shift to gather more than one item. button in the
Right Toolchest is used to select drawing views, sketched entities, dimensions, notes,
and so on from the drawing views. This button is used extensively to move drawing
views or the items in the drawing view. If you select any option from the Menu Manager

then this button is selected automatically.

Line
The Line option in the Sketch menu in the menu
bar or the Create lines. button from the Right
Toolchest is used to create line segments. When

you choose this option, the Snapping References dialog
box is displayed as shown in Figure 12-1. The options in
this dialog box are discussed next.

Select references button
When you choose the Select references button from the
Snapping References dialog box, the GET SELECT
menu is displayed and you are prompted to select an
entity to which you want the line to be snapped.

Remove
The Remove button is used to remove a selected entity
from the Snapping References dialog box.

Circle
The Circle option or the Create circle. button is used to create circles.

Tip: To delete an entity or an item from a drawing view, you can select the item and
then press the DELETE key. You can also select the entity and use the Delete option
from the shortcut menu that is displayed when you hold down the right mouse button.

Figure 12-1  Snapping References
dialog box
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The Arc option or the Create an arc by 3 points or tangent to an entity at its endpoint.
button is used to create arcs.

The other geometric entities that you can draw using the tools available in the Right Toolchest
are splines, construction circles and lines, ellipses, and points. You can also create a fillet
and a chamfer between two entities.

Chain
The Enable sketching chain. button is used when the object you want to draw consists
of more than one entity. You can create the object as a chain by choosing this button
and then drawing the entities by using the required buttons. The chain can be ended

by pressing the middle mouse buttons.

MODIFYING THE SKETCHED ENTITIES
The sketched entities can be modified by using the options
under the TOOLS submenu that is displayed when you choose
DRAWING > Tools from the Menu Manager, see Figure 12-2.
The options available under this submenu are discussed next.

Translate
The Translate option is used to move the selected entity from
its actual location. The new location can be specified using
the GET VECTOR and GET POINT submenus displayed
upon selecting the entity to move.

Rotate
The Rotate option is used to rotate the selected entity from its
actual location. You will be prompted to specify the center
point for the rotation. The default direction of rotation will be
in the counterclockwise direction. However, you can rotate the
selected entity in the clockwise direction by specifying a
negative rotation angle in the Message Input Window.

Rescale
The Rescale option is used to rescale the selected entity. You will be prompted to select the
origin point for scaling when you select the entity. The new scale factor can be specified in
the Message Input Window. A positive scale factor will increase the size of the selected entity
and a negative scale factor will reduce the size of the selected entity.

Copy
The Copy option is used to copy the selected entity. When you select this option, you will be
prompted to specify the method of copying the selected item. You can copy an entity by
specifying the linear values or by specifying the angular values. You can also copy an entity

Figure 12-2  TOOLS submenu
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from another drawing using this option.

Mirror
The Mirror option is used to mirror the selected entity using an existing sketched line.

Trim
The Trim option is used to trim two selected entities. The options of trimming the entities are
the same as those in the Sketch mode.

Intersect
The Intersect option is used to break two sketched entities at their point of intersection.

Stretch
The Stretch option is used to stretch a sketched entity by selecting it using a window. The
vertices of the sketched entity that will be included inside the window will be moved from their
original location and stretched and the remaining vertices will be stationary.

Divide
The Divide option is used to divide the selected entity into a specified number of equal
length segments. It automatically calculates the length of the selected entity and divides it into
a specified number of segments.

Group
The Group option is used to create, suppress, resume, delete, or modify the groups.

Offset
The Offset option is used to offset the selected entity. You can offset a single entity or select
the entire chain to offset. By default, the direction of offset will be in the direction of the arrow.
However, you can also offset the selected entities in the other direction by entering a negative
value in the Message Input Window.

Use Edge
The Use Edge option is selected to draw a copy of the selected edge in the drawing view. This
option will be available only when you have at least one drawing view in the current drawing
sheet.

Draft View
The Draft View option is used to add or remove the selected sketched entity to a view. If the
sketched entity is added to the view and the view is deleted, the sketched entity will also be
deleted along with the view. In case of more than one drawing view, you can set the selected
view as the current view using this option.
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The Relate Obj option is used to add or remove notes, surface symbols, or gtols from the
selected dimension.

USER-DEFINED DRAWING FORMATS
Pro/ENGINEER provides you with some standard drawing formats for generating the drawing
views. These standard formats have standard sheet sizes, tables, and title blocks. However,
sometimes you may need to create a user-defined drawing format that is specifically designed
as per your requirements. This format can include the sheet size, tables, and title block specified
as per your requirements. Choose the Create a new object button to display the New dialog
box. In this dialog box, select the Format radio button from the Type area and then specify
the name of the format in the Name edit box to proceed for creating the user-defined format.
When you choose OK, the New Format dialog box will be displayed, see Figure 12-3.

You can set the size and the orientation of the format sheet using this dialog box. Choose OK
in this dialog box after setting the parameters for the format to proceed to the Format mode.
You can create the desired entities in this format by using the Drawing Sketcher toolbar. You
can also add the text material to the format by using the Note option from the Insert menu in
the menu bar. Figure 12-4 shows a user-defined format created using the A4 size sheet. This
format consists of the user-defined title block. Figure 12-5 shows the drawing views generated
on the user-defined format.

Figure 12-3  New Format dialog box
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Figure 12-4  A user-defined format

Figure 12-5  Drawing views generated using a user-defined format
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Tip: The user-defined format that you create is saved in the .frm format. The location
of this format will be the working directory that was selected at the time when the
format was created.

RETRIEVING THE USER-DEFINED FORMATS IN THE
DRAWINGS
For generating the drawing views you can also retrieve the user-defined format. Once you
have created the user-defined formats, you can use them in the Drawing mode as sheets for
generating the drawing views. To retrieve the user-defined format, select the Empty with
format radio button and choose the Browse button from the New Drawing dialog box to
invoke the Open dialog box. A folder named System Formats will be displayed in the Open
dialog box. Some predefined formats are given in this folder. You can retrieved these predefined
formats or browse the location where you have saved the user-defined format created earlier.

ADDING AND REMOVING SHEETS IN THE DRAWING
To add sheets in the current drawing, choose Drawing > Sheets > Add from the Menu
Manager. A new sheet is displayed on the screen. At the bottom of the screen, the sheet number
is displayed. You can generate different views of a model on multiple sheets. These all drawing
views on different sheets are contained in a single drawing file.

To remove sheets from a drawing, choose Drawing > Sheets > Remove from the Menu
Manager. The Message Input Window is displayed. Enter the sheet number that you want to
remove.

The following points should be remembered while dealing with multisheets:

1. If you move a projected view to another sheet, the parent-child relationship of the two
views is broken. That means, if you move the projected view on one sheet the source view
on the other sheet does not move.

2. The scale of the drawing views on different sheets can be controlled independently.

3. If you erase a drawing view on one sheet, it can be resumed on the other sheet.

CREATING TABLES
You can easily create any kind of tabular representation in the Drawing mode by using the
options available under the TABLE submenu in the Menu Manager. To invoke this submenu,
choose DRAWING > Table, see Figure 12-6.

Tip: You can add or replace the formats in drawing by using the options available
under the SHEETS submenu that is displayed when you choose DRAWING >
Sheets > Format from the Menu Manager. You can add another sheet of the same
format or some other format using these options.
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Figure 12-7  TABLE MODIFY submenu

TABLE submenu Options
The options that are available under this submenu are
discussed next.

Create
The Create option is used to create a table. The table can be
created in the ascending or descending order of the rows
progress and in the right or the left direction. The length and
width of the cells can be specified by picking the points on the
screen or by specifying the value of their length and width.
When you choose this option, the TABLE CREATE submenu
is displayed and you can select the options for creating the
table from this submenu.

Delete
The Delete option is used to delete the entire table. When
you choose this option, you will be prompted to select the table to be deleted. As soon as you
select the table, you will be prompted to confirm the deletion process using the message in the
Message Input Window.

Move
The Move option is used to move the selected table from its default location. The table is
moved using any of the four corners of the table.

Enter Text
The Enter Text option is used to enter text in the selected cell. When you invoke this option,
you will be prompted to select the cell in which the text has to be placed. It is recommended
that before entering the text in the cells you first define the justification for the rows or columns
so that a uniformity is maintained in entering the text in the cells. The justification can be
defined by using the Mod Rows/Cols option provided under the TABLE submenu. You can
modify the text by simply overwriting it in the selected cell.

Copy
The Copy option is used to copy the text content of a cell or the entire table. If you want to
copy the content of the cell then you have to first select the cell to copy and then specify the
new cell in which this content has to be copied.

Modify Table
The Modify Table option is used to modify the
selected table. When you choose this option, the
TABLE MODIFY submenu will be displayed as
shown in Figure 12-7.

TABLE MODIFY submenu options
Merge. This option is used to merge the
selected rows, columns, or rows and

Figure 12-6  TABLE submenu
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cells selected to merge can contain the text.

Remesh. This option is used to remesh the cells merged using the merge option.
Here also the same rule applies, that is, at the maximum, only one cell can contain the
text.

Origin. This option is used to locate the origin of the selected table. The origin can be
defined at any of the four corners of the table. This origin will remain stationary
during the addition of the rows or columns in the selected table. This origin is also
used as the center point during the rotation of the table.

Rotate. This option is used to rotate the selected table by 90 degree in the
counterclockwise direction about the origin of the table.

Line Display. This option is used to modify the display of the lines in the selected
table. You can remove the display of the selected line and make it blank or unblank.

Mod Rows/Cols
The Mod Rows/Cols option is used to modify the
rows and columns of the selected table. When you
choose this option, the ROW/COL OPTS submenu
is displayed as shown in Figure 12-8.

ROW/COL OPTS submenu Options
Insert. This option is used to insert a row or
a column in the table. To insert a row or
a column, pick on the border of the cell
where it has to be added.

Remove. This option is used to remove the selected row or column. You will be
prompted to confirm the deletion process when you choose this option.

Change Size. This option is used to change the size of the selected row or column.
The new size can be specified in terms of the length of the cell or by picking two
points on the screen.

Figure 12-8  ROW/COL OPTS submenu

Tip: In Drawing mode, nearly all the modifications and editing can be done using
the shortcut menu that is displayed when you select the item to modify and then
hold down the right mouse button. The options in this menu vary and depend upon
the item selected.

Tip: It is advised that you use the options under the TABLE submenu to create the
title blocks in the formats. The text can be easily added to the title block by using the
Enter Text option from the TABLE submenu.
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Figure 12-9  The drawing view of the assembly showing the BOM and balloons

Justify. This option is used to specify the text justification for the columns. It has to be
kept in mind that the justification can be specified only for the columns.

USING THE ASSEMBLY BILL OF MATERIAL IN THE
DRAWINGS
The Bill Of Materials for the assembly created in the Assembly mode can be directly used in
the Drawing mode if it was saved in the .bom format. To use the assembly BOM, choose Insert
> Note > File from the menu bar. Select the other options for placing the BOM and then
enter the name of the file that was saved in the .bom format in the Assembly mode. You can
modify the BOM and you can also sketch a table around the BOM using the sketcher tools.

TUTORIALS

In this tutorial you will create a format of size A and add the title block in the format. Then you
will retrieve the format in the Drawing mode and generate the exploded isometric view of the
Pedestal Bearing assembly created in Tutorial 2 of Chapter 9. Also, add the assembly Bill of
Material and the Balloons to the drawing view as shown in Figure 12-9.

   (Estimated time: 45 min)

The following steps outline the procedure to complete this tutorial:

a. Open a new file in the Format mode, create the format of the drawing, and add the title
block in the format.

Tutorial 1
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mb. Save the format file and then close it.

c. Open a new drawing file in the Drawing mode, select the Pedestal Bearing as the model,
and retrieve the format that you had created.

d. Create and save the BOM.

e. Generate the exploded isometric view of the assembly, and add BOM and balloons to
the drawing.

Before you start creating the drawing view, you need to set the working directory. Set the
working directory to C:/ProE/c12. Since this is the first tutorial of this chapter, you need to
create the c12 folder inside the ProE folder.

Copy all the components of the Pedestal Bearing assembly and the assembly file named
pedestalbearing.asm from the c09 folder in the current working directory. This is because the
assembly file with all the files of the components should lie in the folder in which the drawing
file will be stored.

Creating the Format File
As evident from Figure 12-9, the exploded view of the Pedestal bearing is generated on a
drawing sheet with a format. Hence, you need to create a format before generating the drawing
view and then this format will be retrieved later.

1. Choose the Create a new object button from the Top Toolchest, the New dialog box is
displayed.

2. Select the Format radio button from the Type area in the New dialog box and name the
file as Format1. Choose OK from the New dialog box.

The New Format dialog box is displayed.

3. The Empty radio button in the Specify Template area and the Landscape button in the
Orientation area of the New Format dialog box are selected by default. If they are not
selected then you need to select them.

4. Select A from the Standard Size drop-down list in the Size area and then choose OK to
proceed to the Format mode. Note, that a sheet of size A is displayed on the screen. This
is evident from the text displayed below the sheet on the screen.

Creating Format
1. Choose FORMAT > Tools > Offset > Ent Chain from the Menu Manager and then

select one by one all the four border lines of the format. Choose Done Sel from the GET
SELECT submenu after you have made the selection.

2. An arrow is displayed pointing outwards. The arrow displays the direction of offset. Since
you need to offset the lines in the opposite direction, therefore, enter -0.25 in the Message
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Figure 12-10  Format with the title block

Input Window and press ENTER. Choose Done/Return from the TOOLS submenu.

3. Choose FORMAT > Table > Create from the Menu Manager to display the TABLE
CREATE submenu.

4. Choose Ascending > Leftward > By Length from the TABLE CREATE submenu in the
Menu Manager and then choose Vertex from the GET POINT submenu.

5. Select the lower right corner of the new rectangle created by offsetting the border lines.
The corner of the new rectangle is selected because the title block will be created such that
it is attached to the new rectangle. Now, you need to enter the dimensions for the title
block.

6. Enter the width of the first column as 1.2 in the Message Input Window and press ENTER.
Similarly, enter the width of the second column as 2 and for the third column as 1.2 in the
Message Input Window and press ENTER. You are prompted to enter the width for next
column. Press ENTER.

Now, you are prompted to enter the height for the first row.

7. Enter the height of the first row as 0.5, the second as 0.5, and the third as 0.5 in the
Message Input Window. Press ENTER twice. Choose Done/Return from the TABLE
submenu.

The title block created will be similar to the one shown in Figure 12-10. Note that the title
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mblock created is not as required. Therefore, you need to modify it.

8. Choose FORMAT > Table > Modify Table to display the TABLE MODIFY submenu.

9. Choose Merge from this submenu, the Rows & Cols option is selected by default in the
TABLE MERGE submenu. Select the first column and the second column of the top row
to merge. Similarly, merge the third column of the top row with the new bigger column.

10. Now, merge the second column of the second row with the second column of the third row.
The table after merging the rows and columns should look similar to the one shown in
Figure 12-11.

11. Choose Mod Rows/Cols option from the TABLE submenu in the Menu Manager to display
the ROW/COL OPTS submenu. Choose the Justify option from the ROW/COL OPTS
submenu. Now, you need to specify the alignment of the text that will be entered later in
the title block.

12. Select Left > Middle from the HOR JUST TXT submenu and then one by one select all
the three columns of the second row. Choose Done/Return from the TABLE submenu.

Saving the Format File
You need to save the format file that you have created so that you can use it as a template in the
Drawing mode where you will generate the exploded drawing view of the Pedestal Bearing.
The file will be stored in the .frm file format.

Figure 12-11  Modified title block
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1. Choose the Save the active object button from the Top Toolchest. The Message Input
Window is displayed with the name of the file that you had entered earlier. Press ENTER.

2. Close the current window by choosing Window > Close from the menu bar.

Creating a New Drawing File
You need to create a new drawing file to generate the exploded drawing view of the Pedestal
Bearing.

1. Choose the Create a new object button to display the New dialog box. Select the Drawing
radio button and specify the name of the drawing as c12tut1 and then choose OK. The
New Drawing dialog box is displayed.

2. If in the Default Model area the PEDESTALBEARING.ASM is not displayed then choose
the Browse button and select the assembly file named pedestalbearing.asm.

3. Select the Empty with format radio button from the Specify Template area in the New
Drawing dialog box.

4. Select FORMAT1 from the Format drop-down list. If the FORMAT1 is not available in
the drop-down list, choose the Browse button to locate the FORMAT1. Choose OK to
exit the New Drawing dialog box.

Generating the Exploded Drawing View
In Tutorial 2 of Chapter 9 you created the exploded view of the Pedestal Bearing in the
Assembly mode. The name of the exploded view that you created was EXP1. Hence, the
exploded view of the Pedestal Bearing is integrated with the assembly file that you copied
from the c09 folder. Now, you will use this exploded state to generate the exploded drawing
view.

1. Choose DRAWING > Views to display the VIEW TYPE submenu.

2. Choose General > Full View > No Xsec > Exploded > Scale > Done from the VIEW
TYPE submenu. You are prompted to specify a center point.

3. Select a point on the left of the drawing sheet. The SEL STATE submenu is displayed.
Select the EXP1 check box if it is not selected by default and choose Done.

The Message Input Window is displayed and you are prompted to specify the scale for
the drawing view.

4. Enter a value of 0.025 in the Message Input Window and press ENTER. The Orientation
dialog box is displayed with the default view of the exploded assembly. But, you need the
isometric view of the exploded assembly.

5. Select the Preferences option from the Type drop-down list in the Orientation dialog
box.
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Figure 12-12  Exploded isometric view of the assembly

6. Select the Isometric option from the Default Orientation drop-down list. The isometric
view of the exploded assembly is displayed. Choose OK from the Orientation dialog box.

7. Turn off the display of the datums from the Datum Display toolbar. If the model is not
properly placed inside the boundaries of the drawing sheet, double-click on the drawing
view and place it as shown in Figure 12-12.

8. Erase the text Scale 0.025 from the drawing sheet because it is not needed. You can erase
the text by selecting it and then hold down the right mouse button to display the shortcut
menu. From the shortcut menu choose the Erase option.

Creating the BOM
1. Choose Info > Bill of Materials from the menu bar. The BOM dialog box is displayed. In

this dialog box, the Top Level radio button is selected by default. Choose OK to display
the INFORMATION WINDOW.

2. In this window, choose File > Save As from the menu bar. The Save a Copy dialog box
is displayed. The name of the BOM file is by default displayed in the New Name edit box.

3. Choose OK to exit the Save a Copy dialog box. Choose the Close button to close the
INFORMATION WINDOW.

Tip: You can also create and save the BOM in the Assembly mode and then insert it
in the drawing mode.
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The BOM file named pedestalbearing.bom is saved in the current working directory.

Placing the BOM in the Drawing
1. Choose Insert > Note from the menu bar. The NOTE TYPES submenu is displayed.

2. Choose No Leader > File > Horizontal > Standard > Default > Make Note. Specify the
placement point for the BOM on the drawing sheet close to the top right corner. The
Open dialog box is displayed.

3. Select the All files option from the Type drop-down list.

4. Select the pedestalbearing.bom from the Open dialog box to open. The bom file is placed
on the drawing sheet, but this information contained in the file is not what is needed.

5. Choose Done/Return from the NOTE TYPES submenu.

Editing the Text
You need to edit the text in the BOM. The BOM that you generated does not convey the
required information of the drawing and the identification of the components that constitutes
the assembly.

1. Select the text so that it turns red in color. Now, hold down the right mouse button to
display the shortcut menu.

2. Choose the Properties option from the shortcut menu. The Enter Text dialog box is
displayed.

3. Choose the Editor button from the Enter Text dialog box. The Notepad window is
displayed. Delete the first two lines and all the text starting from point number 9 in this
window.

4. In line number 2 in the notepad, change Assembly to Number, PEDESTALBEARING to
Quantity, and contains to Type. After Type, type and add Name.

5. In line number 3, after 3:, type 1 such that the number 1 is middle aligned with Number.
Similarly, below 1 type 2, below 2 type 3, and so on.

6. Using the SPACEBAR (longest key on the keyboard)  middle align the numbers under
Quantity.

7. Using the DELETE key, middle align Part with Type.

8. Similarly, middle align the Name list.

9. Choose File > Exit to exit the Notepad window. You are prompted to save the changes
made. Choose the Yes button and choose OK from the Enter Text dialog box.
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mMove the BOM if it overlaps the boundary of the drawing sheet by double-clicking on it.

Entering Text in the Title Block and Adding Balloons
1. Choose DRAWING > Table > Enter Text from the Menu Manager and then select the

top row to enter the text. The Message Input Window is displayed and you are prompted
to enter text.

2. Enter Pedestal Bearing Assembly in the Message Input Window and press ENTER twice.

3. Select the cell that is in the first column and second row. The Message Input Window is
displayed.

4. Enter Scale: and press ENTER. Now, enter 0.025 in the Message Input Window and
press ENTER twice. The text Scale: 0.025 is in two lines in the title block, therefore you
entered them as two lines.

Similarly, enter the text in all the remaining cells one by one as shown in Figure 12-13.

5. Choose Done/Return from the TABLE submenu.

6. Add the balloons to the assembly by choosing Insert > Balloon from the menu bar. The
NOTE TYPES submenu is displayed.

7. Choose Leader > Enter > Horizontal > Standard > Default > Make Note from the
NOTE TYPES submenu in the Menu Manager. The ATTACH TYPE submenu is
displayed. The On Entity > Arrow Head option is selected by default.

8. Select an edge of the Brasses close to the back face and then press the middle mouse
button on the screen where the balloon will be placed, see Figure 12-13. The Message
Input Window is displayed. Enter 3 and press ENTER twice.

9. Choose the Make Note option from the NOTE TYPES submenu. The ATTACH TYPE
submenu is displayed. The On Entity > Arrow Head option is selected by default. Select
an edge of the Cap and press the middle mouse button on the screen where the note will
be placed, see Figure 12-13. The Message Input Window is displayed. Enter 2 and press
ENTER twice.

10. Choose the Make Note option from the NOTE TYPES submenu. The ATTACH TYPE
submenu is displayed. The On Entity > Arrow Head option is selected by default. Select
an edge of the Casting and press the middle mouse button on the screen where the note
will be placed, see Figure 12-13. The Message Input Window is displayed. Enter 1 and
press ENTER twice.

Tip: If the text you need to enter is in two lines then press ENTER after entering the
first line in the Message Input Window and then enter the second line. Now, after
entering the second line press ENTER twice.
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Similarly, place the remaining balloons. The sheet after placing the BOM and adding the
balloons should look similar to the one shown in Figure 12-13.

Saving the Drawing File
1. Choose the Save the active object button from the Top Toolchest to save the drawing file.

2. The Message Input Window is displayed. Press ENTER.

Closing the Window
The drawing file is saved and now you can exit the Drawing Mode.

1. Choose the Close option from the Window menu in the menu bar.

Note
The occurrence of the components in BOM depends on the order in which they were assembled in
the assembly. In other words, the component placed first will occur first in the BOM.

In this tutorial you will create a format of size A and add the title block in the format. You will
retrieve the format in the Drawing mode and generate the exploded isometric view of the
Shock assembly created in Tutorial 1 of Chapter 9. Also, add the assembly Bill of Material and
the Balloons to the drawing view as shown in Figure 12-14.    (Estimated time: 45 min)

Tutorial 2

Figure 12-13  The drawing view of the assembly showing the BOM and balloons
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The following steps outline the procedure to complete this tutorial:

a. Open a new file in the Format mode, create the format of the drawing, and add the title
block in the format.

b. Save the format file and then close it.

c. Open a new drawing file in the Drawing mode, select the shockassembly.asm as the model,
and retrieve the format that you had created.

d. Create and save the BOM.

e. Generate the exploded isometric view of the assembly and add BOM and balloons to
the drawing.

The working directory was selected in Tutorial 1, and therefore there is no need to select the
working directory again. But if you still want to select the working directory, choose the Set
Working Directory option from the File menu. The Select Working Directory dialog box is
displayed. Set the working directory to C:/ProE/c12.

Copy all the components of the Shock assembly and the assembly file named
shockassembly.asm from the c09 folder in the current working directory. This is because the
assembly file with all the files of the components should lie in the folder in which the drawing
file will be stored.

Figure 12-14  The drawing view of the exploded assembly with BOM
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Creating the Format File
As mentioned in the tutorial description, you need to create a format of A size that will be
retrieved later to create the drawing view of the shockassembly.

1. Choose the Create a new object button from the Top Toolchest, the New dialog box is
displayed.

2. Select the Format radio button from the Type area in the New dialog box and name the
file as Format2. Choose OK from the New dialog box.

The New Format dialog box is displayed.

3. The Empty radio button in the Specify template area and the Landscape button in the
Orientation area of the New Format dialog box are selected by default. If they are not,
you need to select them.

4. Select A from the Standard Size drop-down list in the Size area and then choose OK to
proceed to the Format mode. Note, that a sheet of size A is displayed on the screen. This
is evident from the text displayed below the sheet on the screen.

Creating Format
1. Choose FORMAT > Tools > Offset > Ent Chain from the Menu Manager and then one

by one select all the four border lines of the sheet that is displayed in the format file.
Choose Done Sel from the GET SELECT submenu after you have made the selection.

2. An arrow is displayed pointing outwards. The arrow displays the direction of offset. Since
you need to offset the lines in the opposite direction, therefore, enter -0.25 in the Message
Input Window and press ENTER. Choose Done/Return from the TOOLS submenu.

3. Choose FORMAT > Table > Create from the Menu Manager to display the TABLE
CREATE submenu.

4. Choose Ascending > Leftward > By Length from the TABLE CREATE submenu in the
Menu Manager and then choose Vertex from the GET POINT submenu.

5. Select the lower right corner of the new rectangle created by offsetting the border lines.
The corner of the new rectangle is selected because the title block will be created such that
it is attached to the new rectangle. Next, you need to enter the dimensions for the title
block.

6. Enter the width of the first column as 3.2 and press ENTER. Similarly, enter the width of
the second column as 1.2 in the Message Input Window and press ENTER. You are
prompted to enter the width for next column. Press ENTER.

Now, you are prompted to enter the height for the first row.

7. Enter the height of the first row as 0.5, the second as 0.5, the third as 1, and the fourth as
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Figure 12-15  Format with the title block

0.7 in the Message Input Window. Press ENTER twice. Choose Done/Return from the
TABLE submenu.

The title block created will be similar to the one shown in Figure 12-15. Note the difference
between the title block shown in Figure 12-14 and that shown in Figure 12-15. You need to
modify the title block that you have created so that it is similar to the one shown in
Figure 12-14.

8. Choose FORMAT > Table > Modify Table to display the TABLE MODIFY submenu.

9. Choose Merge from this submenu, the Rows & Cols option is selected by default in the
TABLE MERGE submenu. Select the first row and the second row of the first column to
merge.

The table after merging the rows and columns should look similar to the one shown in
Figure 12-16.

10. Choose Mod Rows/Cols option from the TABLE submenu in the Menu Manager to display
the ROW/COL OPTS submenu. Choose the Justify option from the ROW/COL OPTS
submenu. Now, you need to specify the alignment of the text that will be entered later in
the title block.

11. Select Left > Middle from the HOR JUST TXT submenu and then one by one select
both the  columns. Choose Done/Return from the TABLE submenu.
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Saving the Format File
You need to save the format file that you have created so that you can use it as a template in the
Drawing mode where you will generate the exploded drawing view of the Shock assembly. The
file will be stored in the .frm file format.

1. Choose the Save the active object button from the Top Toolchest. The Message Input
Window is displayed with the name of the file that you had entered earlier. Press ENTER.

2. Close the current window by choosing Window > Close from the menu bar.

Creating a New Drawing File
You need to create a new drawing file to generate the exploded drawing view of the Shock
assembly.

1. Choose the Create a new object button to display the New dialog box. Select the Drawing
radio button and specify the name of the drawing as c12tut2 and then choose OK. The
New Drawing dialog box is displayed.

2. If in the Default Model area SHOCKASSEMBLY.ASM is not displayed, choose the Browse
button and select the assembly file named shockassembly.asm.

3. Select the Empty with format radio button from the Specify Template area in the New
Drawing dialog box.

4. Select FORMAT2 from the Format drop-down list. If the FORMAT2 is not available in

Figure 12-16  Modified title block
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mthe drop-down list, choose the Browse button to locate the FORMAT2. Choose OK to

exit the New Drawing dialog box.

Generating the Exploded Drawing View
In Tutorial 1 of Chapter 9 you had created the exploded view of the Shock assembly in the
Assembly mode. The name of the exploded view that you specified was EXP1. Hence, the
exploded view of the Shock assembly is integrated with the assembly file that you copied from
the c09 folder. Now, you will use this exploded state to generate the exploded drawing view.

1. Choose DRAWING > Views from the Menu Manager to display the VIEW TYPE
submenu.

2. Choose General > Full View > No Xsec > Exploded > Scale > Done from the VIEW
TYPE submenu. You are prompted to specify a centerpoint.

3. Select a point on the left side on the drawing sheet. The SEL STATE submenu is displayed.
Select the EXP1 check box if it is not selected by default and choose Done.

The Message Input Window is displayed and you are prompted to specify the scale for
the drawing view.

4. Enter a value of 0.004 in the Message Input Window and press ENTER. The Orientation
dialog box is displayed with the default view of the exploded assembly. But, you need the
isometric view of the exploded assembly.

5. Select the Preferences option from the Type drop-down list in the Orientation dialog
box.

6. Select the Isometric option from the Default Orientation drop-down list. The isometric
view of the exploded assembly is displayed. Choose OK from the Orientation dialog box.

7. Turn off the display of the datums from the Datum Display toolbar. If the model is not
placed properly inside the boundaries of the drawing sheet, double-click on the drawing
view and place it as shown in Figure 12-17.

8. Erase the text Scale 0.004 from the drawing sheet because it is not needed. You can erase
the text by selecting it and then hold down the right mouse button to display the shortcut
menu. From the shortcut menu choose the Erase option.

Creating the BOM
1. Choose Info > Bill of Materials from the menu bar. The BOM dialog box is displayed. In

this dialog box, the Top Level radio button is selected by default. Choose OK to display
the INFORMATION WINDOW.

2. In this window, choose the File > Save As option from the menu bar. The Save a Copy
dialog box is displayed. The name of the BOM file is displayed by default in the New
Name edit box.
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3. Choose OK to exit the Save a Copy dialog box. Choose the Close button to close the
INFORMATION WINDOW.

The BOM file named shockassembly.bom is saved in the current working directory.

Placing the BOM in the Drawing
1. Choose Insert > Note from the menu bar. The NOTE TYPES submenu is displayed.

2. Choose No Leader > File > Horizontal > Standard > Default > Make Note. Specify the
placement point for the BOM on the drawing sheet close to the top right corner.

The Open dialog box is displayed.

3. Select the All files option from the Type drop-down list.

4. Select shockassembly.bom from the Open dialog box to open. The bom file is placed on
the drawing sheet, but this information contained in the file is not what is needed.

5. Choose Done/Return from the NOTE TYPES submenu.

Editing the Text
The BOM that you generated does not link the name of the parts with the drawing view.
Hence, you need to edit the BOM according to your need.

Figure 12-17  Exploded isometric view of the assembly
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m1. Select the text so that it turns red in color. Now, hold down the right mouse button to

display the shortcut menu.

2. Choose the Properties option from the shortcut menu. The Enter Text dialog box is
displayed.

3. Choose the Editor button from the Enter Text dialog box. The Notepad window is
displayed. Delete the first two lines and all the text starting from point number 11 from
this window.

4. In line number 2 in the notepad, change Assembly to Number, SHOCKASSEMBLY to
Quantity, and contains to Type. After Type, type and add Name.

5. In line number 3, after 3:, type 1 such that the number 1 is middle aligned with Number.
Similarly, below 1 type 2, below 2 type 3, and so on.

6. Using the SPACEBAR (longest key on the keyboard) middle align the numbers under
Quantity.

7. Using the DELETE key, middle align Part with Type.

8. Similarly, middle align the Name list.

9. Choose File > Exit to exit the Notepad window. You are prompted to save the changes
made. Choose the Yes button and choose OK from the Enter Text dialog box.

Move the BOM if it overlaps the boundary of the drawing sheet by double-clicking on it.

Entering Text in the Title Block and Adding Balloons
1. Choose DRAWING > Table > Enter Text from the Menu Manager and then select the

cell from the first row and the second column. The Message Input Window is displayed
and you are prompted to enter the text.

2. Enter Shock assembly in the Message Input Window and press ENTER twice.

3. Now, select the cell from the second row and the second column. The Message Input
Window is displayed. Enter CADCIM Technologies and press ENTER twice.

Similarly, enter the text in all the remaining cells one by one as shown in Figure 12-18.

4. Choose Done/Return from the TABLE submenu.

5. Add the balloons to the assembly by choosing Insert > Balloon from the menu bar. The
NOTE TYPES submenu is displayed.

6. Choose Leader > Enter > Horizontal > Standard > Default > Make Note from the
NOTE TYPES submenu in the Menu Manager. The ATTACH TYPE submenu is
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Figure 12-18  The drawing view of the assembly showing the BOM and title block

displayed. The On Entity > Arrow Head option is selected by default.

7. Choose the Make Note option. The ATTACH TYPE submenu is displayed. The On Entity
> Arrow Head option is selected by default.

8. Select an edge of the Pivot close to the back face and then press the middle mouse button
on the screen where the note will be placed, see Figure 12-18. The Message Input Window
is displayed. Enter 3 and press ENTER twice.

9. Choose the Make Note option. The ATTACH TYPE submenu is displayed. The On Entity
> Arrow Head option is selected by default.

10. Select an edge of the Bushing and press the middle mouse button on the screen where the
note will be placed, see Figure 12-18. The Message Input Window is displayed. Enter 2
and press ENTER twice.

11. Choose the Make Note option. The ATTACH TYPE submenu is displayed. The On Entity
> Arrow Head option is selected by default.

12. Select an edge of the U-Support and press the middle mouse button on the screen where
the note will be placed, see Figure 12-18. The Message Input Window is displayed. Enter
1 and press ENTER twice.

Similarly, place the remaining balloons. The sheet after placing the BOM and adding the
balloons should look similar to the one shown in Figure 12-18.
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1. Choose the Save the active object button from the Top Toolchest to save the drawing file.

2. The Message Input Window is displayed. Press ENTER.

Closing the Window
The drawing file is saved and now you can exit the Drawing Mode.
1. Choose the Close option from the Window menu in the menu bar.

Answer the following questions and then compare your answers to the answers given at the
end of this chapter.

1. The Select one item at a time - shift to gather more than one item. button in the Right
Toolchest is used to select any item from the drawing view or the drawing view itself to
modify. (T/F)

2. Pro/ENGINEER provides you with some standard drawing formats for generating the
drawing views. (T/F)

3. Pro/ENGINEER allows you to create the user-defined formats. (T/F)

4. The assembly BOM can be directly used in the Drawing mode. (T/F)

5. Only one drawing sheet is available in one drawing file. (T/F)

6. The __________ option of the TOOLS submenu is used to move the selected draft entity.

7. The __________ option of the TABLE submenu is used to enter text material in the selected
cell.

8. The __________ dialog box is used to edit the text.

9. The __________ key from the keyboard can also be used to delete any draft entity.

10. The __________ submenu is used to draw tables in the Drawing mode.

Self-Evaluation Test
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m Answer the following questions.

1. Which of the following options from the TABLE submenu is used to delete the entire
table?

(a) Delete (b) Create
(c) Copy (d) Pagination

2. Which of the following options in the TOOLS submenu is used to move a draft entity?

(a) Rotate (b) Group
(c) Translate (d) Rescale

3. Which of the following buttons on the Right Toolchest enables to draw the geometric
entities continuously?

(a) Create lines. (b) Create circle.
(c) Enable sketching chain. (d) None

4. Which of the following radio buttons is selected to create a user-defined format for the
drawing sheet?

(a) Part (b) Format
(c) Drawing (d) None

5. Which of the following menus in the menu bar has the Close option to close the current
window?

(a) Info (b) Window
(c) View (d) None

6. You can open more than one windows in Pro/ENGINEER. (T/F)

7. It is not possible to draw splines in the Drawing mode. (T/F)

8. There are two types of drafting in Pro/ENGINEER: Generative drafting and Interactive
drafting. (T/F)

9. You can import a text file in the Drawing mode. (T/F)

10. The Relate Obj option is used to add or remove notes, surface symbols, or gtols from the
selected dimension. (T/F)

Review Questions
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Figure 12-19  Drawing for Exercise 1

Create a format of size A and then retrieve it to place the top, front, and an exploded isometric
view of the Cross Head assembly created in Exercise 1 of Chapter 9. Add the assembly BOM
and the balloons to the drawing view as shown in Figure 12-19.

  (Estimated time: 45 min)

Answers to the Self-Evaluation Test
1 - T, 2 - T, 3 - T, 4 - T, 5 - F, 6 - Translate, 7- Enter Text, 8 - Enter Text, 9 - DELETE,
10 - TABLE CREATE.

Exercise 1

Exercise


