
Chapter 9

Assembly Modeling

After completing this chapter you will be able to:

• Apply different assembly constraints.
• Assemble the components of the assembly.
• Create the simplified representation for viewing various components of assembly.
• Edit the assembly constraints after assembling.
• Modify the components of the assembly within the assembly.
• Create the exploded state of the assembly.
• Add the offset lines to the exploded components.
• Use the Bill Of Material in the assemblies.

Learning Objectives
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ASSEMBLY MODELING
Mostly the designs consist of more than one component that are assembled together at their
relative working positions. These assembly designs are created in the Assembly mode of
Pro/ENGINEER. To proceed to the assembly mode, choose the Create a new object button
from the Top Toolchest. The New dialog box is displayed, select the Assembly radio button
from the Type area and then select the Design radio button from the Sub-type area as shown
in Figure 9-1. Specify the name of the assembly in the Name edit box and choose OK.

Before proceeding with this chapter, it is very important for you to understand the following
terms:

Bottom-up Approach. This is the method of assembling the components in which the
components created as different parts in the Part mode are assembled in the current assembly
file.

Top-down Approach. This is the method of assembling the components in which the
components of the assembly are created in the same assembly file.

Package. It is the state in which the component that is being assembled is not fully constrained
and thus is not rigidly placed at its actual location.

Placement Constraints. The placement constraints are the constraints that are used to rigidly

Figure 9-1  Selecting the Assembly mode from
the New dialog box
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constraints are also called the assembly constraints. Generally, these constraints are used in
combinations in order to constrain all the six degrees of freedom of a component.

PLACEMENT CONSTRAINTS
The assembly constraints are available in the Component Placement dialog box that is discussed
later in this chapter. The placement constraints that are available in Pro/ENGINEER are
discussed next.

Automatic
When you choose this constrain, Pro/ENGINEER assumes the constraint and apply it according
to the type of entity selected. For example, if you select axes of two component to assemble
then Pro/ENGINEER will understand that you want to apply the Align constraint and the
Align constraint will be applied to the two components.

Mate
The Mate placement constraint allows you to make two selected planes, datum planes, planar
faces, or a combination of datum plane and planar face coplanar with respect to each other.
The faces or datums selected may or may not be in contact with each other.

There are three options that the Mate constraint is used in combination with. It is used with
Offset, Coincident, and Oriented constraints.

Mate Offset
If you need to keep the two selected surfaces or planes at some distance apart then you can use
the Mate constraint with some offset value. The offset distance between the two coplanar faces
can have a positive or a negative value. Figure 9-2 shows the faces that are selected to apply the
Mate Offset constraint. Figure 9-3 shows the component assembled at an offset distance from
the selected surface.

Mate Coincident
The Mate Coincident combination of constraints allow you to make two selected planes or

Figure 9-2  Components before assembling Figure 9-3  Components after assembling
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surfaces coplanar to each other. Figure 9-4 shows the surfaces that are selected to mate. Figure 9-5
shows the components after assembling.

Mate Oriented
The Mate Oriented combination of constraints is used when you want to mate two surfaces or
planes or a combination of two and at the same time you want to orient some other surfaces or
planes of the two components to face in the same direction. Figure 9-6 shows the planar
surfaces that are selected to mate and Figure 9-7 shows the components after assembling.

Align
The Align constraint is used to assemble two components by making the selected faces or
planes coplanar such that the aligned faces or planes are facing in the same direction. Apart
from planes and planar faces, you can also select datum axes, datum points, edges, or vertices
for applying the Align constraint.

There are three options that the Align constraint is used in combination with. It is used with
Offset, Coincident, and Oriented constraints.

Figure 9-4  Components before assembling Figure 9-5  Components after assembling

Figure 9-7  Components after assemblingFigure 9-6  Components before assembling



Assembly Modeling      9-5

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
. 

F
. 

F
. 

F
. 

F
. 

F o
r 

e
n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r
o

r 
e

n
g

in
e

e
ri

n
g

 s
e

r v
ic

e
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

vi
ce

s,
 c

o
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
vi

ce
s,

 c
o

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
mAlign Offset

The Align Offset combination of constraints is similar to the Align Coincidence combination
of constraints with the only difference that you can also specify the offset distance between the
aligning entities. The offset value can be positive or negative. Figure 9-8 shows the faces to
align offset and Figure 9-9 shows the components after applying the constraints.

Align Coincident
The Align Coincident combination of constraints is used to assemble two components by
making the selected faces or planes coplanar such that the aligned faces or planes are facing in
the same direction. Figure 9-10 shows the faces that are selected to align. Figure 9-11 shows
the components after assembling.

Align Oriented
The Align Oriented combination of constraints makes the two selected surfaces or planes or
the combination of both to face in the same direction. Figure 9-12 shows the constraints applied
on the two components and Figure 9-13 shows the two components after applying constraint.

Figure 9-9  Components after applying
constraints

Figure 9-8  Components before applying
constraints

Figure 9-10  Components before applying
constraints

Figure 9-11  Components after applying constraints



9-6     Pro/ENGINEER for Designers
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

e
ch

n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
. 

F
. 

F
. 

F
. 

F
. 

F o
r 

o
nl

in
e

 t
ra

in
in

g
, 

co
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
o

r 
o

nl
in

e
 t

ra
in

in
g

, 
co

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

o
r 

o
nl

in
e

 t
ra

in
in

g
, 

co
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
o

r 
o

nl
in

e
 t

ra
in

in
g

, 
co

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

o
r 

o
nl

in
e

 t
ra

in
in

g
, 

co
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m

Insert
The Insert constraint is used to assemble the revolved components. Applying this constraint
allows the revolved component, holes, or a combination of both to share the same orientation
of the central axis. Figure 9-14 shows the faces to insert and Figure 9-15 shows the parts after
assembling.

Coord Sys
The Coord Sys constraint aligns the coordinate system of the first component with the
coordinate system of the second component.

Tangent
The Tangent constraint is used to make the selected circular face tangent to the other selected
face or plane and at the same time make them coplanar.

Figure 9-13  Components after applying constraintsFigure 9-12  Components before applying
constraints

Figure 9-15  Parts after assemblingFigure 9-14  Parts before assembling
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mPnt On Line

The Pnt On Line constraint is used to align the selected datum point or the vertex on the first
part with the selected edge, datum axis, or datum curve on the second part.

Pnt On Srf
The Pnt On Srf constraint is used to align the selected datum point or vertex on the first part
with the selected surface or datum plane on the second part.

Edge On Srf
The Edge On Srf constraint is used to align the selected edge of the first part with the selected
surface or datum plane on the second part.

Default
The Default constraint is used to assemble the component in the assembly by aligning
the default coordinate system of the component with the default coordinate system of
the assembly. If the assembly has the assembly datum planes then the part datum

planes are aligned with the assembly datum planes.

Fix
The Fix component to current position. button pack the two components and displays
that the two components are fully constrained.

ASSEMBLY DATUM PLANES
When you enter the assembly environment, the three default assembly datum planes are
displayed on the graphics screen. If you do not want the assembly datum planes to be displayed
then while opening a new file you need to clear the Use default template check box. Generally,
it is advised to use the assembly datum planes as the first feature of the assembly and then
assemble the components of the assembly taking the reference of these assembly datum planes.
Using the datum planes as the first feature helps you during the modification of the assembly.
Some of the advantages of using the assembly datum planes are: the components of the assembly
can be redefined in such a way that the components placed later can be made the first
component, the first component can be replaced by some other component, and the placement
constraint of the first component can be modified.

ASSEMBLING THE COMPONENTS
The components in the assembly can be placed parametrically or nonparametrically. If the
components are placed using the placement constraints, it is called parametric assembly and
if the components are packaged, it is called nonparametric assembly.

To assemble the components parametrically, choose ASSEMBLY > Component > Assemble.
The Open dialog box is displayed. Once you select the part to assemble from the Open dialog
box, the Component Placement dialog box will be displayed as shown in Figure 9-16.

The Component Placement dialog box has multiple functions. This dialog box is used for
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both constrained and packaged placement of
components. There are two tabs in this dialog
box, the Place tab and the Move tab. The options
under these tabs are discussed next.

Show component in a
separate window while
specifying constraints

This button is used to display the
component to be assembled in a
separate window. When you choose this

button, a new window will open displaying the
component to be assembled. It is easy to view
the component to be assembled and the
assembly in separate windows. This prevents
cluttering of the components in a single window.

However, there is a limitation when you use the
assembly and the component to be assembled
in separate windows. While applying constraints
to the components if the components are in the
same window they change their orientation as
you apply the constraints thus giving you idea
of the next constraint to be applied. In other
words, you can easily find out which degree of
freedom of the component is constrained and
which needs to be constrained.

Show component in the
assembly window while
specifying constraints

This button is used to display the component to be assembled in the assembly itself.
As you apply the constraint, the component in the assembly changes its position
corresponding to the constraints.

Place Tab
The options that are available in the Place tab of the Component Placement dialog box are
discussed next.

Constraints Area
This area displays all the constraints applied to the component along with the offset value (if
any) in the order in which they were applied. In the Component Placement dialog box, this
area is of great importance. It is recommended to check this area after applying a constraint.
Check that the constraint you intended to apply is listed in this area.

Figure 9-16  The Place tab of the Component
Placement dialog box
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mYou will notice a check box on the extreme right in the Constraints area. After you apply a

constraint, the check box is automatically selected and now you cannot move the component
in the degree of freedom that is locked by the constraint applied. However, if the check box is
cleared, the constrained degree of freedom is unlocked. Moving the component after applying
constraints and before fully constraining the components by using the Component Placement
dialog box and as well as using the combination of mouse and keyboard is discussed later in
the chapter. The options in this area are discussed next.

Type drop-down list
This drop-down list displays all the placement constraints that are available to assemble
the component. You can select the constraints from this drop-down list to assemble
components in an assembly. The different constraints that are available in this drop-down
list were explained earlier.

Offset drop-down list
This drop-down list is used to specify the offset value (if any) for the placement constraint.
This drop-down list has two more options, Coincident and Orient. The Coincident and
Orient options are used in combination with Mate and Align options.

Specify a new constraint button
This button is chosen to add a constraint to assemble the components. When you
choose this button, the GET SELECT submenu is displayed.

Remove the selected constraint button
This button is chosen to delete the constraint that is already applied. The constraint
that is selected in the Constraints area is deleted when you choose this button.

Change orientation of constraint
This constraint button is used to reverse the orientation of the constraint applied.
This button is used only after a constraint is applied to the components.

Component Reference Area
The button under this area is chosen to select the reference for specifying the placement
constraint on the component to be assembled. When you choose this button, the GET SELECT
submenu is displayed.

Assembly Reference Area
The button under this area is chosen to select the reference for specifying the placement
constraint on the assembly. This button is automatically chosen when you have finished
specifying the reference on the component to be placed.

Placement Status Area
This area displays the placement status of the component in the assembly. The status displayed
in this area is usually partially constrained or fully constrained. If you choose OK from the
Component Placement dialog box when the status displayed is Partially Placed, then in the
Model Tree the component assembled is displayed with a mark on it.
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Move Tab
The options under the Move tab can be used only if
you have selected the Show component in the assembly
window while specifying constraints button. This tab
is used to move a component along degree of freedom
that is not restricted. The Move tab is shown in
Figure 9-17 and the options under this tab are discussed
next.

Motion Type Area
The options under this area are discussed next.

Translate
This radio button is selected to move the
component from its current location in the
assembly. However, remember that the
component can be moved only along the degrees
of freedom that are not restricted.

Rotate
This radio button is selected to rotate the
component in the assembly along its
available degrees of freedom.

Adjust
This radio button is selected to pack a component
with reference to the assembly. The message “ Select
surface on packaged component to adjust to ref
plane.” is displayed in the Message Area when you
select this radio button.

Motion Reference Area
The drop-down list under this area displays the
references that can be used for the motion of the component. The options provided under
this drop-down list are discussed next:

View Plane
This option uses the view plane as the reference for the motion of the component.

Figure 9-17  The Move tab of the
Component Placement dialog box

Tip: It is recommended to use CTRL+ALT+left mouse button to translate a component
and CTRL+ALT+middle mouse button to rotate a component. It is always easy to
use the above combinations to move the component rather than switching to a separate
tab in the Component Placement dialog box and using its options to move a
component. Direct manipulation of the component can speed up the process of locating
the component correctly in the assembly and establishing constraints.
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This option allows you to select a planar surface or a datum plane that you want to use
as reference for the motion of the component.

Entity/Edge
This option allows you to select a straight edge, an axis, or a datum curve as the reference
for the motion of the component.

Plane Normal
This option allows you to select a plane normal to which will be the allowed motion of the
component.

2 Points
This option is used to select two datum points that will specify the direction for the
movement of the component.

Cycs
This option is used to select the coordinate system to specify the motion of the component.
When you select this option, three buttons appear besides this drop-down list. These
buttons are X, Y, and Z. These buttons are used to specify the axis of the selected coordinate
system for specifying the direction of motion.

Motion Increments Area
Translation
This drop-down list is used to select the predefined increment values by which the
component will be moved along the direction specified using the options in the Motion
Reference drop-down list.

Rotation
This drop-down list is used to select the predefined increment angles by which the
component will be moved along the direction specified using the options in the Motion
Reference drop-down list.

Position Area
Relative
These boxes display the coordinates of the current position of the component.

Undo
This button is chosen to undo the changes made using the options in the Move tab.

Redo
This button is chosen to reinstate the changes that were removed using the Undo button.

Preview
This button is used to preview the component in the assembly before it is actually assembled.
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Figure 9-19  Move dialog box

Figure 9-18  PACKAGE submenu

Packaging the Components
Sometimes, you do not know the exact location of a
component in the assembly or you want to specify the exact
location later. In such cases, you can nonparametrically place
the component in the assembly. This method of
nonparametrically placing the components in the assembly
is called Packaging. There are two methods to package a
component in an assembly. The first method is to use the
menus in the Menu Manager. The second method to package
a component is to assemble the component using the
Component Placement dialog box and then before fully
constraining it exit the dialog box.

To package the component, choose ASSEMBLY >
Component > Package. When you choose this option, the
PACKAGE submenu will be displayed as shown in
Figure 9-18. This submenu provides the following
options:

Add
The Add option is used to add the component to be
packaged. You can open a new component using the
Open dialog box, select it from the assembly, or select
the last component from the assembly to assemble again.

When you select the component from the Open dialog
box, the Move dialog box is displayed as shown in
Figure 9-19. After you have specified the location of
component in the assembly file, choose OK to place
the component and close the Move dialog box. The
options under this dialog box are the same as those
under the Move tab of the Component Placement
dialog box. However, remember that you can move only
the packaged component using this option.

Move
The Move option is used to move the packaged
component to a new location. When you choose this
option, the Move dialog box will be displayed as shown
in Figure 9-19.

Finalize
As mentioned earlier, the packaged components are not
assembled parametrically. Hence, packaging does not relate the component with its neighboring
components in the assembly. Once the location of the component is decided then it can be
finalized. The Finalize option is used to finalize the location of the packaged component.
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Component Placement dialog box will be displayed when you select the packaged component.
You can parametrically assemble the component by adding the placement constraints to the
component using this dialog box.

CREATING SIMPLIFIED REPRESENTATIONS
As you know that the assembly designs consist of not only one part or component but a number
of parts and subassemblies. The number of the components in the assembly is directly
proportional to the complicacy of the assembly. More the number of components, the more
complicated will be the assembly. Therefore, huge assemblies like the inside of a CPU tend to
become very complicated when all the chips, cables, and other parts are assembled. Also, if the
outer body of the CPU is assembled then the inside components will not be displayed. So
there have to be some means to temporarily remove certain components that are not desired
at some point of time from the current display or force them to be displayed in the wireframe
so that you can see through them. This method to remove some components from the current
display is called Simplified Representation.

To create a simplified representation, choose ASSEMBLY > Simplfd
Rep. The SIMPLFD REP menu will be displayed, choose the Create
option. You will be prompted to specify the name of the simplified
representation in the Message Input Window. A default name
appears in this window that you can accept or you can give a desired
name. Press ENTER or choose the Accept value button. The
DEFAULT RULE menu is displayed as shown in Figure 9-20.
Pro/ENGINEER allows you to create the following types of
simplified representations:

Master Representation
When you choose the Master Rep option from the DEFAULT RULE
submenu, the EDIT REP submenu is displayed as shown in
Figure 9-21. In this type of simplified representation, the selected
component will be removed from the current display if you choose
the Exclude option from the EDIT REP submenu. However, the
component remains in the memory of Pro/ENGINEER and is even
displayed in the Model Tree. This component can be, at any point
of time, forced to be displayed again. Figure 9-22 shows the
master representation using the Exclude option from the EDIT
REP submenu. The figure shows a butterfly valve assembly in which
the Body is removed from the current display. This kind of
representation helps in assembling the components inside the body,
like the plate and the screw in this case.

Figure 9-20  DEFAULT
RULE submenu

Figure 9-21  EDIT REP
submenu

Tip: The components that are packaged in an assembly are displayed in the Model
Tree with a mark on them.
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Graphics Representation
When you choose the Graphics Rep option from the DEFAULT RULE submenu, the EDIT
REP submenu is displayed as shown in Figure 9-23. The Master Rep option is selected by
default. In this type of simplified representation all the unselected components will be displayed
as the wireframe model as shown in Figure 9-24. This type of representation is generally used
for assembling the components inside some other component. This type of simplified
representation also reduces the regeneration time in case of large assemblies. However,
remember that the components that are displayed as the wireframe model in the graphic
representation cannot be modified, redefined, or referenced.

Figure 9-22  The Master Representation of an assembly

Figure 9-23  EDIT REP
submenu

Figure 9-24  The Graphics Representation of an assembly
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mGeometry Representation

When you choose the Geometry Rep option from the DEFAULT
RULE submenu, the EDIT REP submenu is displayed as shown in
Figure 9-25. The Master Rep option is selected by default. In this
type of simplified representation the complete geometry of the
components is displayed in the current model display style. This
type of the simplified representation takes a long time for
regeneration. The components that are not selected in this type
of representation cannot be modified. However, these components
can be redefined.

REDEFINING THE COMPONENTS OF
THE ASSEMBLY
Sometimes, after you have assembled the components of the
assembly, you may need to modify or redefine the location or the
placement constraints of the components. This is done by choosing
ASSEMBLY > Component > Redefine. When you choose this option, you will be prompted
to select the component to be redefined. When you select the component to be redefined, all
the components assembled after the selected component will become invisible and the
Component Placement dialog box will be displayed. You can modify the existing placement
constraints or add new constraints using this dialog box.

The components can also be redefined using the shortcut menu that is displayed when you
right-click on the component in the Model Tree and then choose the Redefine option. When
you choose to redefine the component using the Model Tree, the Component Placement
dialog box will be displayed directly. You can also right-click on the component to be
redefined on the graphics screen, and choose the Redefine option from the shortcut menu
that is displayed.

REORDERING THE COMPONENTS
The order of assembling the components can be changed by choosing ASSEMBLY >
Component > Reorder. When you choose this option, you will be prompted to select the
component to be reordered. When you select a component to reorder, a message will be
displayed in the Message Area that specifies the components before which you can insert the
selected component.

Figure 9-25  EDIT REP
submenu

Tip: You can also reorder the components in an assembly by using the Model Tree.
This can be done by selecting the component in the Model Tree and then dragging it
at the position where it can be placed. It should be noted that this method of reordering
does not let you know where the component can be placed and where it cannot be
placed. However, the parent component of the selected child component gets highlighted
when you start dragging the child component. This means, if a component has a
parent then the parent is also reordered with the child. This should be noted that in a
Model Tree, the parent component will always occur before its child component .
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SUPPRESSING/RESUMING THE COMPONENTS
If you do not want certain components of the assembly to appear in the current display as well
as in the drawing views then you can suppress them. To suppress the components choose
ASSEMBLY > Component > Suppress. Similarly, the suppressed components can be resumed
by choosing ASSEMBLY > Component > Resume.

The components can also be suppressed/resumed using the shortcut menu that is displayed
when you right-click on the component in the Model Tree or graphics screen. In the shortcut
menu, choose Suppress to suppress and Resume to resume the components.

REPLACING COMPONENTS
The existing components of the assembly that are assembled using the assembly constraints
can be replaced with some other component if necessary. To replace the component, choose
ASSEMBLY > Component > Adv Utils > Replace. The REPLACE COMP menu and the
Replace Component dialog box will be displayed and you will be prompted to select the
component to be replaced. The new component can be selected using the Browse button of
the Replace Component dialog box. The new component selected will be displayed in the
Browse edit box. The new component can be assembled using a family table, an interchange
assembly, by layout, or manually. After you have selected one of these options, choose Apply
from the Replace Component dialog box. Now, choose Done from the REPLACE COMP
menu to display the Component Placement dialog box for adding the placement constraints.

ASSEMBLING REPEATED COPIES OF A COMPONENT
Sometimes, the assembly design demands for the assembling of a particular component more
than once. One option is that every time you should assemble the component and add the
placement constraints all over again. However, this is a very tedious and time consuming
process especially in the assemblies that have a large number of similar components. Therefore,
to solve this problem, Pro/ENGINEER provides you with an option of assembling the multiple
copies of the components. To repeat a component in an assembly, choose ASSEMBLY >
Component Adv Utils > Repeat. When you choose this, the Repeat Component dialog box
will be displayed as shown in Figure 9-26 and you will be prompted to select the component
that has to be repeated in the assembly. The options in the Repeat Component dialog box are
discussed next.

Component Area
The button in this area is chosen to select the component whose multiple copies are to be
assembled. The name of the selected component is displayed in the edit box provided in this
area.

Variable Assembly Refs Area
The Variable Assembly Refs area displays the placement constraints that are applied on the
selected component. You can keep the placement constraints that should be present for the
new component and modify the remaining constraints by selecting them from this area. The
field in this area consists of the following columns.
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The Type column displays the type of placement
constraints that are applied to the selected
component.

CompRef
The CompRef column displays the references on
the component that were used to assemble the
component. In case you want to change this for
the new component, select this constraint and
then choose the Add button. Now, select a
reference on the assembly. A copy of the selected
component will be added to the assembly at a
new location. Similarly, to add another copy,
choose Done Sel in the GET SELECT menu and
then repeat this procedure.

AsmRef
The AsmRef column displays the reference on
the assembly that was used to assemble the
selected component.

Place Component Area
The Placement Component area displays the new
added references for the newly placed copies of
the selected component.

Add
The  Add button is chosen to add the required references for the new copy of the selected
component. This button will be available only when you select one of the constraints from the
Variable Assembly Refs area.

Remove
The Remove button is chosen to remove the selected reference from the new component. This
button is available only when you select one of the references from the Place Component area.

MODIFYING THE COMPONENTS OF THE ASSEMBLY
Sometimes, during or after the assembly of the components, you may need to modify the
dimensions of the components. The modification in the dimensions of the components can be
directly made in the Assembly mode and you do not need to open the part file to make the
modifications. You can even redefine the selected feature in the Assembly mode itself. The
methods used to modify and redefine the features are discussed below.

Figure 9-26  Repeat Component dialog box
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Modifying the Dimensions of a Feature of a Component
The dimensions of a selected feature of the component can be modified by choosing
ASSEMBLY > Modify > Mod Dim. When you choose this, you will be prompted to select the
feature whose dimensions you want to modify or the dimension to modify. All the dimensions
associated with the feature will be displayed upon selecting the feature. Remember that the
part has to be regenerated to view the effect of the modification.

Redefining a Feature of a Component
The option to redefine the features in the Assembly mode is available only for the parts or for
the skeleton models. Therefore, to redefine the features, choose ASSEMBLY > Modify to
display the ASSEM MOD submenu. In this submenu choose Mod Part or Mod Skel and then
select the part or the skeleton model. As soon as you select the part, the MODIFY PART
submenu will be displayed. In this submenu choose Feature to display the PART FEAT
submenu. Now, from this submenu you can choose Redefine and then select the feature to be
redefined.

CREATING THE EXPLODED STATE
Generally, the assembly designs consist of a large number of components. Some of these
components are visible after they are assembled and some of them are not visible. This is
because the components that are assembled outside are visible but the components that are
assembled inside some other components are not visible. This is a very misleading state and
may confuse the viewer as he cannot view all the components. However, to eliminate this
confusing state, generally an exploded view is provided along with the assembled view. The
exploded view is a state in which all the components are moved from their actual location so
that they are visible as shown in Figure 9-27. The exploded state can be created by choosing
Create from the EXPLD STATE menu displayed upon choosing ASSEMBLY > ExplodeState
from the Menu Manager. Specify the name of the exploded state in the Message Input Window
to display the Explode Position dialog box shown in Figure 9-28. This dialog box provides
you the following options to move the components from their actual location.

Motion Type Area
Translate
This radio button when selected allows you to move a component on the graphics screen from
its position in the assembly.

Copy Pos
This option is used to restore the exploded component at its original location. This radio
button when selected prompts you to select a component whose position you want to copy. For
example, a component is exploded and is moved away from the assembly on the graphics
screen and you want to assemble it back to its original position. Select the Copy Pos radio
button, you will be prompted to select a component to copy the position from. Select a
component from the assembly. Now, you are prompted to select a component to move. Select
the exploded component that is moved away from the assembly. The selected component will
be assembled at its original position in the assembly.
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Figure 9-27  The exploded state of an assembly

Default Expld
This radio button when selected prompts you to
select a component. When you select a component
from the assembly, the component is exploded
from the assembly to a default position on the
graphics screen.

Reset
The Reset radio button is used to set the selected
component to its original location in the assembly.

Motion Reference Area
View Plane
The View Plane option is used to specify the
current view plane (that is the screen of the
monitor) as the reference for exploding the
selected component.

Sel Plane
The Sel Plane option is used to select a datum
plane or a planar face for specifying the reference
for the motion of the component. When you
choose this option, you will be prompted to select Figure 9-28  Explode Position dialog box
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the datum plane or a planar face and then you will be prompted to select the component to
move.

Entity/Edge
The Entity/Edge option is selected by default and is used to select a linear edge or an axis for
specifying the reference direction for exploding the component.

Plane Normal
The Plane Normal option is used to select a planar face or a datum plane, normal to which
will be the reference for exploding the components.

2 Points
The 2 Points option is used to select two datum points or two vertices to specify the reference
direction for exploding the components.

C-sys
The C-sys option is used to select one of the axes of the selected coordinate system for specifying
the reference direction for exploding the components.

Note
If you have not created an exploded state of an assembly, a default explode state is available
when you choose View > Explode from the menu bar. To redisplay the unexploded state, choose
Unexplode from the View menu.

CREATING THE OFFSET LINES
The offset lines are the lines that are used to display the actual path and direction of the
mating components. These lines are generally used for easy visualization of the exploded
components of the assemblies. The exploded state of an assembly using the offset lines is
shown in Figure 9-29. However, remember that there should exist an exploded state in which
the offset lines will be created. The offset lines are created using the OFFSET LINES menu
that is displayed by choosing ASSEMBLY > ExplodeState > Redefine > Done > Offset
Lines from the Menu Manager. Choose Create from the OFFSET LINES submenu to display
the Entity Select submenu. The Entity Select submenu provides you with the following options
for selecting the objects for creating the offset lines.

Note
The combination ASSEMBLY > ExplodState > Redefine > Done > Offset > Lines allows
you to specify the explode state on which you need to add the offset lines. The combination
ASSEMBLY > Modify > Mod Expld > Offset Lines adds the offset lines to the current
explode state of the assembly.

Axis
The Axis option is used to select the axis of the components for creating the offset lines.
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Figure 9-29  The exploded state of an assembly with offset lines

Surface Norm
The Surface Norm option is used to create the offset lines normal to the selected surface at
the specified point.

Edge/Curve
The Edge/Curve option is used to select an edge or a curve for creating the offset lines.

Note
The offset lines are automatically made invisible once you display the unexploded state of the
assembly.

THE BILL OF MATERIAL
The Bill Of Material or the BOM is the tabular representation
of all the components of the assembly along with the
information associated with them. The information can be
such as the material of the components, the additional note
with the components, and so on. Pro/ENGINEER provides
you with a readymade BOM that can be directly utilized. This
BOM is automatically updated during the assembly of the
components. The BOM can be viewed using the BOM dialog
box shown in Figure 9-30 that is displayed by choosing Bill
of Materials from the Info menu in the menu bar. The options
in this dialog box are discussed next. Figure 9-30  BOM dialog box
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Select Model Area
The options provided under the Select Model area are used to select the type of assembly
whose BOM has to be displayed. These options are discussed next.

Top Level
The Top Level radio button is used to select the top level assembly for displaying the BOM.

Subassembly
The Subassembly radio button is used to select the subassembly for displaying the BOM.
When you select this option, the button available under this area will be available and you will
be prompted to select the subassembly.

Include Area
Skeletons
The Skeletons check box is selected so that the skeletons, if any, in the assembly should also be
included in the BOM.

Unplaced
The Unplaced check box is selected to include the unplaced components in the BOM.

After you have selected the options in the BOM dialog box, choose OK to display the
information window that displays the BOM for the selected assembly as shown in Figure 9-31.
You can save this file and later retrieve it in the Drawing mode to display the BOM in the
drawing views of the assembly.

Note
When you work on Pro/ENGINEER there are two memories you are working on. The first is the
memory of Pro/ENGINEER and the second is of the computer system that is called the hard disk.
Pro/ENGINEER memory is called In Session and can be erased as discussed in Introduction
chapter. The In Session memory is emptied once you exit Pro/ENGINEER. When you choose
the Save the active object button on the File toolbar to save, the object on the graphic screen is
permanently saved in the working directory and can only be removed by deleting.
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Figure 9-31  The BOM information for the selected assembly

Tutorial 1
TUTORIALS

In this tutorial you will create all the components of the Shock assembly and then assemble
them as shown in Figure 9-32. Also create an exploded state of the assembly displaying the
offset lines as shown in Figure 9-33.  The BOM is shown in Figure 9-34. The dimensions of the
components are shown in Figure 9-35 through Figure 9-42.       (Estimated time: 2 hrs)

The following steps outline the procedure to create the given assembly:

a. Create all the components of the assembly as separate part files in the Part mode.

b. Assemble all the components one by one by applying assembly constraints.

Before you start creating the components, set the working directory to
C:\ProE\c09\Shockassembly. Also, make sure that the c09 directory exists inside the ProE
directory. If these directories do not exist, create them and set the working directory.
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Figure 9-33  The exploded state of the Shock assembly

Figure 9-32  The Shock assembly
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Figure 9-34  The Bill Of Material for the Shock assembly

Figure 9-36  Dimensions for PivotFigure 9-35  Dimensions for Bracket
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Figure 9-41  Dimensions for Hexagonal boltFigure 9-40  Dimensions for Washer

Figure 9-38  Dimensions for Bushing Figure 9-39  Dimensions for Self-locking nut

Figure 9-37  Dimensions for U-Support
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Figure 9-42  Dimensions for Castle nut

Creating the Components for Assembly
The given assembly is created by using the bottom-up approach. As mentioned earlier, in
bottom-up approach assemblies, the components are created as separate files and are placed
in the assembly file. Therefore, you first need to create the components of the assembly.

1. Create all the components of the assembly as separate part files and save them in the
current working directory.

2. Close the part files if opened.

Creating New Assembly File
All the components that you have created are assembled in an assembly file having an extension
.asm. You need to open a new assembly file to assemble the components.

1. Choose the Create a new object button from the File toolbar to display the New dialog
box.

2. Select the Assembly radio button in the Type area of the New dialog box. In the Sub-type
area of the New dialog box, the Design radio button is selected by default. Enter the
name of the assembly in the Name edit box as SHOCKASSEMBLY.

Note
Make sure that in the New dialog box, the Use default template check box is selected. If this
check box is not selected then you will not be able to use the template provided by Pro/ENGINEER.
Hence, in that case you will need to create the default datum planes by choosing the Insert a
datum plane. button from the Right Toolchest.

3. Choose OK from the New dialog box to proceed to the assembly environment.
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Tip: Viewing the components in separate windows helps the user to locate the references
for the assembly constraints easily and also the user has independent viewing control
over the two windows. You can spin, pan, and zoom the component in their respective
windows.

Assembling the U-Support with the Default Datum Planes
When you choose OK from the New dialog box, the three default datum planes are displayed
on the graphics screen and the Model Tree is displayed on the left of the graphics screen. You
can turn off the display of the Model Tree by choosing the Model Tree on/off button. Now,
you can start assembling the components.

1. Choose ASSEMBLY > Component > Assemble from the Menu Manager. The Open
dialog box is displayed.

2. Select u-support from the Open dialog box and choose the Open button. The
Component Placement dialog box is displayed with the Show component in the
assembly window while specifying constraints button selected by default.

Since the Show component in the assembly window while specifying constraints button
is selected by default, the U-Support is placed with the default datum planes by assuming
some assembly constraints.

As discussed earlier, when you open a component to assemble, there are two display modes
in which the component can be displayed. These two display modes are controlled by two
buttons at the top in the Component Placement dialog box. However, you will use the
display mode in which the component is displayed in a separate window called the
Component Window.

3. Choose the Show component in a separate window while specifying constraints
button. The subwindow is displayed on the left of the graphics screen with the
U-Support. You will notice that the component is still displayed on the graphics
screen. This is because the Show component in the assembly window while specifying
constraints button is still selected in the Component Placement dialog box.

4. Choose the Show component in the assembly window while specifying
constraints button from the Component Placement dialog box. Now, the
component is not displayed on the graphics screen.

You can drag the window to a desired position so that you can view the prompt messages
of both the windows. You can also use the keyboard and mouse button combinations to
zoom in and zoom out the component in the two windows and to spin the models
individually.

5. Choose Assemble component at a default location button from the Component
Placement dialog box.

As discussed earlier, the Assemble component at a default location button aligns the
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assembling the first component of the assembly with the default datum planes were
discussed earlier.

6. The Placement Status area shows Fully Constrained. Choose OK. The Component
Placement dialog box is closed and the U-Support is assembled with the default datum
planes.

Assembling the Bushing with the U-Support
The next component you need to assemble is the Bushing.

1. Choose ASSEMBLY > Component > Assemble from the Menu Manager to display the
Open dialog box.

2. Select bushing and choose Open to display the Component Placement dialog box. The
component is displayed in the Component Window. You may need to drag the Component
Window so that you can view the prompts in the Message Area.

3. Select the Mate option from the Type drop-down list in the Constraints area of the
Component Placement dialog box to add the mate constraint. You are prompted to select
a mating surface.

4. Select the planar surface of the Bushing shown in Figure 9-43.

5. Select the left inner face of the U-Support
as the other face to add the mate
constraint as shown in Figure 9-43. Now,
you are prompted that the component is
not fully constrained but can be
packaged. But, you need to fully
constrain the components.

6. Select the Align option from the Type
drop-down list to add the align
constraint.

7. Select the axis of the Bushing as shown
in Figure 9-43 to add the Align
constraint.

8. Select the axis of the hole on the vertical face of the U-Support shown in Figure 9-43. The
Placement Status area shows Fully Constrained.

Note that the Allow Assumptions check box is selected. This means that Pro/ENGINEER
has assumed one or more constraints to fully define the assembly. If you clear the Allow
Assumptions check box, the Partially Constrained message is displayed in the Placement
Status area. Therefore, let Pro/ENGINEER assume the constraints and let the Allow

Figure 9-43  Constraints and the location to apply
them
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Tip: The arrow in the Component Placement dialog box under the Component
Reference area is used to make selections. If you have made a wrong selection then
you can choose this arrow to display the GET SELECT menu and make the selection
again.

Figure 9-44  The U-Support assembled with the Bushing

Assumptions check box be selected.

9. You can preview the assembly of the U-Support and the Bushing by choosing the Preview
button from the Component Placement dialog box. The bushing is displayed as a wireframe
model in the assembly. Choose OK.

The two components are assembled as shown in Figure 9-44.

10. The next instance of the Bushing can be placed directly using the Repeat option. Choose
ASSEMBLY > Component > Adv Utils > Repeat to display the Repeat Component
dialog box. You will be prompted to select a component in the current assembly to repeat.

11. Select the Bushing from the graphics screen because it is the component that needs to
be repeated.

When you select this component, the Mate and Align constraints will be displayed in the
Variable Assembly Refs area.

12. Select the Mate constraint from this area and then choose the Add button.

13. Select the inner right face of the U-Support as the mating face. The copy of the Bushing
will be assembled as shown in Figure 9-45. Choose Confirm from the Repeat Component
dialog box.
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Assembling the Pivot with the Bushing
The next component that you need to assemble is the Pivot.

1. Choose ASSEMBLY > Component > Assemble to display the Open dialog box.

2. Select pivot and choose Open to display the Component Placement dialog box.

3. Select the Mate option from the Type drop-down list to add the mate constraint. You are
prompted to select a mating surface.

4. Select the face of the Bushing shown in Figure 9-46 to add the mate constraint.

5. Select the front face of the Pivot shown in Figure 9-46 to add the mate constraint.

6. Select the Align option from the Type drop-down list to add the align constraint.

7. Select the axis of the Bushing shown in Figure 9-46.

8. Select the central axis of the Pivot shown in Figure 9-46. The Fully Constrained message
is displayed in the Placement Status area of the Component Placement dialog box. But
note that the Allow Assumptions check box is selected. This suggests that Pro/ENGINEER
has assumed some constraints to constrain the Pivot with the Bushing.

9. Choose the Preview button from the Component Placement dialog box. The orientation

Figure 9-45  Assembled Bushings and the U-Support

Tip: If the display of datum axis is turned on, the datum axis will not be displayed in
the subwindow until you choose View > Repaint from menu bar.
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Figure 9-46  Constraints and the location to apply them

of the Pivot with the Bushing is not what is required. Hence you need to clear the Allow
Assumptions check box and define one more constraint.

10. Clear the Allow Assumptions check box by selecting it from the Component Placement
dialog box. Now, the Partially Constrained message is displayed in the Placement Status
area.

11. To add a constraint, choose the Specify a new constraint button from the
Constraints area in the Component Placement dialog box. The GET SELECT
submenu is displayed.

12. Select the field in the Offset column. The field will be changed into a drop-down list.
Select the Oriented option from the drop-down list and select the top face of the Pivot
shown in Figure 9-46.

13. Now, select the upper horizontal face of the U-Support shown in Figure 9-46. The message
displayed in the Placement Status area is Fully Constrained. Choose the Preview button
from the Component Placement dialog box. Choose OK.

Note
If the surface is oriented toward the bottom side, choose the Change orientation of the constraint
button from the Component Placement dialog box.

The assembly after placing the Pivot should look similar to the one shown in Figure 9-47.

Suppressing Features
Next, you need to suppress both the Bushings and the Pivot. This is because as the components
in the assembly increases, the clarity on the graphics screen reduces. Also, more the number of
components, more are the datum planes. Thus it becomes difficult to make selections on the
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Figure 9-47  Assembled view of the Pivot, U-Support, and the Bushing

components. However, when you suppress a component, its datum planes are also suppressed
and the complications on the graphics screen are reduced.

1. Spin the model and select the first bushing from the graphics screen and hold down the
right mouse button to display the shortcut menu. Choose Suppress from the shortcut
menu to suppress the component.

The WARNING: window is displayed. Choose OK. The Pivot will also get suppressed
because it was dependent on the first bushing.

2. Similarly, suppress the other Bushing to make the assembly of the other components easy.

Note
Very often you will need to use the datum planes and the datum axes to assemble the components.
Therefore, you will need to turn their display on or off from the Datum Display toolbar whenever
required.

Assembling the Bracket with the Assembly
The next component you need to assemble is the Bracket.

1. .Choose ASSEMBLY > Component > Assemble to display the Open dialog box.

2. Open the bracket to display the Component Placement dialog box.

3. Select the Mate option from the Type drop-down list to add the mate constraint.

4. Select the upper face of the cylindrical feature as the first face to add the mate constraint
and then select the bottom central horizontal face of the U-Support as the other mating
face shown in Figure 9-48.
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Figure 9-48  Constraints and the location to apply them

5. Select the Align option from the Type drop-down list to add the align constraint.

6. Select the axis of the Bracket to add the align constraint and then select the axis of the
U-Support as shown in Figure 9-48.

Note
If the GET SELECT menu is not displayed, choose the Specify a new constraint button from
the Component Placement dialog box to display the GET SELECT menu and to add a new
constraint.

7. Select the field in the Offset column. The field will be changed into a drop-down list.
Select the Oriented option from the drop-down list and select the faces as shown in
Figure 9-48.

8. Choose OK from the Component Placement dialog box. The assembled Bracket is shown
in Figure 9-49.

Assembling the Washer with the Assembly
The next component that you will assemble is the Washer.

1. .Choose ASSEMBLY > Component > Assemble to display the Open dialog box.

2. Open the washer to display the Component Placement dialog box.

3. Select the Mate option from the Type drop-down list to add the mate constraint. The
GET SELECT submenu is displayed.

4. Select the top face of the Washer as the first face to add the mate constraint and then select
the bottom face of the Bracket as the other mating face.
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5. Select the Align option from the Type drop-down list.

Note
Sometimes when you select a reference from a component to apply a constraint, the Message
Input Window is displayed and you are prompted to specify the offset value for the constraint
applied. Enter a value of 0 in the Message Input Window if the offset distance is not required.

6. Select the axis of the Washer and then select the axis of the cylindrical feature on the
Bracket.

7. Choose the Quit Sel option from the GET SELECT menu.

8. Select the Allow Assumptions check box. The message displayed in the Placement Status
area is Fully Placed.

You have defined two constraints for the Washer and the Bracket, but you need to define
one more constraint that will constrain the rotatory degree of freedom of the Washer. That
is why you selected the Allow Assumptions check box. You can also restrict the rotatory
movement of the Washer by selecting a datum plane that is perpendicular to the direction
of rotation of the Washer and orient it with a plane or planar surface parallel to the
selected datum plane.

The washer is assembled to the Bracket as shown in Figure 9-50.

Inserting the Hexagonal Bolt in the Assembly
The next component that you will assemble is the Hexagonal Bolt.

1. .Choose ASSEMBLY > Component > Assemble to display the Open dialog box.

Figure 9-49  Assembled view of the Bracket with the U-Support
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2. Open the hexagonalbolt to display the Component Placement dialog box.

3. Select the Mate option from the Type drop-down list to add the mate constraint. The
GET SELECT submenu is displayed.

4. Select the inner face of the head of the Hexagonal bolt and then select the outer left face
of the U-Support as the other mating face.

5. Select the Align option from the Type drop-down list.

6. Select the axis of the Hexagonal bolt and then select the axis of the shaft feature on the
U-Support.

7. Clear the Allow Assumptions check box and then choose the Specify a new constraint
button. Select the field in the Offset column. The field will be changed into a drop-down
list. Select the Oriented option from the drop-down list.

8. Out of six faces of the head of the Hexagonal bolt, select any one face and then select the
top face of the Bracket. The Placement Status area shows Fully Constrained. Choose
OK. The Hexagonal bolt is inserted in the assembly as shown in Figure 9-51.

Assembling Other Components
Similarly, assemble the Castlenut and the Self-locking nut.

Unsuppressing the Components
All the components are assembled to their required positions. Now, you need to unsuppress
the components that were suppressed.

Figure 9-50  Assembled view of the Washer with the Bracket
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Figure 9-52  Completed assembly with all the components

1. Choose ASSEMBLY > Component > Resume. The RESUME submenu is displayed.
Select the All option and choose Done. The completed assembly is shown in Figure 9-52.

Creating the Exploded State of the Assembly
To clearly view all the components in an assembly you need to create an exploded state of the
assembly.

Figure 9-51  Assembly after assembling the hexagonal bolt

Tip: You can also view the default exploded state of an assembly by choosing the
Explode option from the View menu in the menu bar.
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1. Choose ASSEMBLY > ExplodeState > Create. The Message Input Window is displayed
with a default name of the exploded state.

2. Enter the name of the exploded state as EXP1 in the Message Input Window. Press
ENTER or choose the Accept value button. The Explode Position dialog box is displayed.

The Translate radio button is selected by default in the Motion Type area of the Explode
Position dialog box. The Entity/Edge option is selected by default in the Motion Reference
drop-down list. The Smooth option is selected by default in the Translation drop-down
list. The GET SELECT menu is displayed and you are prompted to select an axis or edge
as the motion reference

3. Using the Query Bin, select the axis of the cylindrical feature on the Bracket to specify the
direction for the motion of all the components.

4. After selecting the axis of the Spacer, select the Self-locking nut and move it. Note that the
Self-locking nut is moving along its axis only. Place the Self locking nut at an appropriate
position. You are prompted to select another component to move.

5. Select the Washer and Bracket to move in the direction as shown in Figure 9-53. Now, you
need to move the Castle nut, the two Bushings, the Hexagonal bolt, and the Pivot together
as one component along the vertical axis selected earlier.

6. Choose the Preferences button from the Explode Position dialog box. The Preferences
dialog box is displayed. Select the Move Many radio button and choose Close.

7. Select the Castle nut, the two Bushings, the Hexagonal bolt, and the Pivot. The selected
components turn red in color. You may need to spin the assembly using the CTRL+middle
mouse button to make selections.

8. After selecting the above-mentioned components, choose the Default option from the
Saved view list button. The assembly orients to its default orientation.

9. Press the middle mouse button and select the Pivot to place all the selected components as
shown in Figure 9-53.

10. After moving all the components to the desired positions, choose OK from the Explode
Position dialog box. The MOD EXPLODE submenu is displayed.

11. Choose the Position option from the submenu. The Explode Position dialog box is
displayed. Select the axis of the Hexagonal bolt and move Bushings, Hexagonal bolt, and
Castle nut as shown in Figure 9-54.

12. After moving the components, choose OK from the Explode Position dialog box. The
MOD EXPLODE submenu is displayed.

13. Choose the Offset Lines option from the MOD EXPLODE submenu. The OFFSET LINES
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Figure 9-54  Exploded state of the assembly

submenu is displayed. Choose the Create option from the OFFSET LINES submenu.
The Entity Select submenu is displayed and the Axis option is selected by default.

14. Select the axis of the Self-locking nut and then select the axis of the shaft feature on the
U-support. The blue colored offset line is created.

15. Similarly, select the axes of the other components to create the offset lines displaying the
path and direction of the mating components as shown in Figure 9-55.

16. After creating all the offset lines, choose Done/Return from the MOD EXPLODE submenu

Figure 9-53  Creating the exploded state
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and then choose Done/Return from the EXPLD STATE submenu.

Saving the Assembly
You need to save the assembly because you may need it later.

1. Choose the Save the active object button from the File toolbar and save the model.

Closing the Window
Now, you have saved the assembly and the window can be closed.

1. Choose the Close option from the Window menu in the menu bar.

In this tutorial you will create all the components of the Pedestal Bearing assembly and then
assemble them as shown in Figure 9-56. You will also create the exploded state shown in
Figure 9-57 displaying the offset lines. The BOM is shown in Figure 9-58. The dimensions of
the components are shown in Figure 9-59 through Figure 9-62.

      (Estimated time: 2 hrs)

Figure 9-55  Displaying the offset lines in the exploded state

Tip: To unexplode the assembly, choose the Unexplode option from the View menu in
the menu bar.

Tutorial 2
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Figure 9-56  Assembly of the Pedestal Bearing

Figure 9-57  The exploded state of the Pedestal Bearing
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Figure 9-59  Dimensions for Casting Figure 9-60  Dimensions for Cap

Figure 9-58  The Bill Of Material for Pedestal Bearing
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The following steps outline the procedure to create the given assembly:

a. Create all the components of the assembly as separate part files in the Part mode.

b. Assemble the components one by one by applying assembly constraints.

Set the working directory to C:\ProE\c09\Pedestalbearing.

Creating the Components for Assembly
To create the assembly all the components must be created first and then they will be assembled
at their respective positions. All the components will be created in the Part mode. You will use
the bottom-up approach of assembly creation.

1. Create all the components of the assembly as separate files and save them in the current
working directory.

Figure 9-62  Dimensions for the components of the assembly

Figure 9-61  Dimensions for the Brasses
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2. Close the part files if opened.

Creating New Assembly File
All the components that you have created are assembled in an assembly file having an extension
.asm. You need to open a new assembly file to create an assembly of all the components.

1. Choose the Create a new object button from the File toolbar to display the New dialog
box.

2. Select the Assembly radio button in the Type area of the New dialog box. In the Sub-type
area of the New dialog box the Design radio button is selected by default. Enter the name
of the assembly in the Name edit box as PEDESTALBEARING.

3. Choose OK to proceed to the Assembly environment.

Assembling the Casting with the Default Datum Planes
When you choose OK from the New dialog box, the three default datum planes are displayed
on the graphics screen and the Model Tree is displayed on the left of the graphics screen. If
the display of the Model Tree was turned off in the previous tutorial then the Model Tree will
not appear. Now, you can start assembling the components.

1. Choose ASSEMBLY > Component > Assemble. The Open dialog box is displayed.

2. Select casting from the Open dialog box and choose the Open button. The Component
Placement dialog box is displayed with the Show component in the assembly window
while specifying constraints button selected by default.

Since, the Show component in the assembly window while specifying constraints button
is selected by default, therefore, the Casting is placed with the default datum planes.

As discussed earlier, there are two display modes in which the component can be displayed
when you open a component to assemble. These two display modes are controlled by two
buttons at the top in the Component Placement dialog box. However, in this tutorial you
will use the display mode in which the component is displayed with the assembly in the
same window.

Note
If the datum planes are displayed on the graphics screen, you need to turn their display off by
choosing the Datum planes on/off button from the Datum Display toolbar. This is because the
datum planes clutter on the graphics screen and then the selection of the references for applying
assembly constraints is made difficult. You can turn their display on when the datum planes are
required.

5. Select Assemble component at a default location button from the Component
Placement dialog box.

6. The Placement Status area shows Fully Constrained. Choose OK. The Component
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mPlacement dialog box is closed and the Casting is assembled with the default datum

planes.

Assembling the Cap with the Casting
First the Cap will be assembled with the Casting.

1. Choose ASSEMBLY > Component > Assemble to display the Open dialog box.

2. Select the cap and choose Open to display the Component Placement dialog box.

3. Select the Mate option from the Type drop-down list. You are prompted to select a mating
surface.

4. Select the top face of the Casting as the first mating face. Now, use the CTRL+ALT+middle
mouse button to rotate the Cap and then select the lower flat face of the Cap as the other
mating face as shown in Figure 9-62.

The CTRL+ALT+middle mouse button is used to spin the component to be assembled
with the assembly and the CTRL+ALT+left mouse button is used to move the component.
However, to spin the assembly you can use the CTRL+middle mouse button.

5. Enter a value of 4 in the Message Input Window. If this window is not displayed then
select the Offset drop-down list and select 0.0. Now, enter offset distance of 4 and press
ENTER.

6. Choose the Specify a new constraint button and then select the Align option from the
Type drop-down list.

7. Select the axis of the left hole on the Casting as the first aligning axis and then select the
axis of the left hole on the Cap as the second aligning axis as shown in Figure 9-62.

Note that in the Component Placement dialog box, the Allow Assumptions check box is
selected and the Cap is assembled to the Casting. The status displayed in the Placement
Status area is Fully Constrained. This means that Pro/ENGINEER assumed some
constraints and has assembled the two components. Although, you can now confirm the
assembly by exiting the Component Placement dialog box, you will not accept the
default constraints. You will define one more constraint to assemble the two components.
However, while assembling the previous component if you cleared the Allow Assumptions
check box then it will not be selected and the status will be Partially Constrained.

8. Clear the Allow Assumptions check box by selecting it. The status displayed in the
Placement Status area is Partially Constrained.

The Cap is still assembled to the Casting. To know which degree of freedom of the Cap
with the Casting is not constrained, perform the next step.

9. Use CTRL+ALT+middle mouse button to move the Cap. You will notice that the second



9-46     Pro/ENGINEER for Designers
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

©
 C

A
D

C
IM

 T
©

 C
A

D
C

IM
 T

e
ch

n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
e

ch
n
o

lo
g

ie
s,

 U
S

A
. 

F
. 

F
. 

F
. 

F
. 

F o
r 

o
nl

in
e

 t
ra

in
in

g
, 

co
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
o

r 
o

nl
in

e
 t

ra
in

in
g

, 
co

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

o
r 

o
nl

in
e

 t
ra

in
in

g
, 

co
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m
o

r 
o

nl
in

e
 t

ra
in

in
g

, 
co

nt
a

ct
 s

a
le

s@
ca

d
ci

m
.c

o
m

o
r 

o
nl

in
e

 t
ra

in
in

g
, 

co
nt

a
ct

 s
a

le
s@

ca
d

ci
m

.c
o

m

hole of both the Cap and the Casting needs to be aligned.

10. If the Automatic option is not displayed in the Type drop-down list, choose Specify a new
constraint button from the Constraints area in the Component Placement dialog box.
The GET SELECT submenu is displayed. Select the Align option from the Type drop-down
list.

11. Align the axis of the right hole on the Casting with the axis of the right hole on the Cap by
selecting them as shown in Figure 9-63. The Placement Status area shows Fully
Constrained. Choose OK to exit the Component Placement dialog box.

12. After assembling the Cap, the assembly should look similar to the one shown in Figure 9-64.

Figure 9-63  Constraints used for assembling the components

Figure 9-64  After assembling the Cap with the Casting
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You need to suppress the Cap because the next component has to be assembled with the
Casting. When you suppress the Cap from the assembly, it becomes easier to assemble the new
component in the assembly. The Cap will be unsuppressed later.

1. Select the Cap from the assembly on the graphics screen and hold down the right mouse
button to display the shortcut menu. Choose the Suppress option. You are prompted to
confirm the suppression. Choose OK.

Assembling the Brasses with the Casting
Next, you need to assemble the Brasses with the Casting.

1. Choose ASSEMBLY > Component > Assemble to display the Open dialog box.

2. Select brasses and choose Open to display the Component Placement dialog box.

3. Select the Mate option from the Type drop-down list and mate the face of the Brasses with
that of the Casting as shown in Figure 9-65.

4. Select the Mate option from the Type drop-down list and mate the face of the Brasses with
that of the Casting as shown in Figure 9-65.

5. Select the Insert option from the Type drop-down list and insert the oil hole of the Brasses
into that of the Casting as shown in Figure 9-65. You will notice that the Brasses assemble
with the wrong orientation. Also, some more constraints are left to be defined.

6. Use CTRL+ALT+left mouse button to move the Brasses and then select the Align option
from the Type drop-down list.

7. Select the TOP datum plane from the Brasses and then select the face of the Casting
shown in Figure 9-65. The red arrow is displayed and you are prompted to enter the offset

Figure 9-65  Constraints used for assembling the components
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Figure 9-67  The final Pedestal Bearing assembly

distance in the direction of the arrow.

8. Enter a distance of -4 in the Message Input Window and press ENTER. The Placement
Status area shows Fully Constrained.

9. If the join feature of the oil hole is at the top then choose the Change orientation
of the constraint button from the Component Placement dialog box. The oil
hole is now oriented correctly. Choose OK to exit the Component Placement
dialog box.

After assembling the Brasses, the assembly should look similar to the one shown in
Figure 9-66.

10. Similarly, assemble the remaining components and then resume the components that
were suppressed earlier. The final assembly is shown in Figure 9-67.

Figure 9-66  Inserting the Brasses in the assembly
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To view all the components in an assembly clearly, you need to create an exploded state of the
assembly.

1. Choose ASSEMBLY > ExplodeState > Create. The Message Input Window is displayed
with a default name of the exploded state.

2. Enter the name of the exploded state as EXP1 in the Message Input Window. Press
ENTER or choose the Accept value button. The Explode Position dialog box is displayed.

The Translate radio button is selected by default in the Motion Type area of the Explode
Position dialog box. The Entity/Edge option is selected by default in the Motion Reference
drop-down list. The Smooth option is selected by default in the Translation drop-down
list. The GET SELECT menu is displayed and you are prompted to select an axis or edge
as the motion reference.

3. You may need to invoke the Query Sel option from the GET SELECT menu to select the
axis of the Square headed bolt. Using the Query Bin select the central axis of the Square
headed bolt to specify the direction of motion of the components and then move the
Square headed bolts, Nuts, Cap, Lock Nuts, and Casting as shown in Figure 9-68.

4. After moving the above components along the axis of the Square headed bolt, choose OK
from the Explode Position dialog box. The MOD EXPLODE submenu is displayed.

5. Choose the Position option from the submenu. The Explode Position dialog box is
displayed.

6. Select the axis of the Brasses and select it to move as shown in Figure 9-68.

7. After moving the components, choose OK from the Explode Position dialog box. The
MOD EXPLODE submenu is displayed.

Figure 9-68  The Exploded Pedestal Bearing assembly
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8. Choose the Offset Lines option from the MOD EXPLODE submenu. The OFFSET LINES
submenu is displayed.

9. Choose the Create option from the OFFSET LINES submenu. The Entity Select submenu
is displayed and the Axis option is selected by default.

10. Select the axes of the two Nuts and the Square headed bolts to create the offset lines as
shown in Figure 9-69.

11. Now, spin the model and select the axis of the oil hole on the Cap from the lower curved
surface and then select the axis of the upper oil hole on the Brasses to create the offset
lines between them. Similarly, create the offset lines between the lower oil hole on the
Brasses and that on the Casting as shown in Figure 9-69.

Note
You can delete or modify an offset line by using the Delete and Modify options respectively from
the OFFSET LINES submenu.

12. The final assembly after creating the offset lines in the exploded state should look similar
to the one shown in Figure 9-69.

13. After creating all the offset lines, choose Done/Return from the MOD EXPLODE submenu
and then choose Done/Return from the EXPLD STATE submenu.

Figure 9-69  Exploded state of the assembly displaying the offset lines
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You need to save the assembly because you may need it later.

1. Choose the Save the active object button from the File toolbar and save the assembly.

Closing the Window
Now, you have saved the assembly and the window can be closed.

1. Choose the Close option from the Window menu in the menu bar.

Answer the following questions and then compare your answers to the answers given at the
end of this chapter.

1. When you select a datum plane for applying the mate constraint then you will have to
specify whether you want to select the yellow side or the red side of the datum plane to be
coplanar with the other face or datum plane. (T/F)

2. The exploded view is a state in which all the components are moved from their actual
location so that they are visible. (T/F)

3. The dimensions of a feature cannot be modified in the Assembly mode. (T/F)

4. You can display the unexploded state of the assembly by choosing Unexplode from the
View menu. (T/F)

5. The offset lines are automatically made invisible once you display the unexploded state of
the assembly. (T/F)

6. In the _____________ type of simplified representation the selected component will be
removed from the current display.

7. The ______________ type of simplified representation reduces the regeneration time in
case of large assemblies.

8. The ____________ constraint is similar to the Mate constraint with only difference being
that this constraint allows you to specify some offset distance between the two coplanar
faces.

9. The __________ constraint is used to assemble the circular components.

10. The ___________ is the tabular representation of all the components of the assembly
along with the information associated with them.

Self-Evaluation Test
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1. Which constraint is used to align the selected datum point or vertex on the first part with
the selected surface or datum plane on the second part?

(a) Orient (b) Pnt on Srf
(c) Edge on Srf (d) Tangent

2. When the assembly is constrained fully the message displayed in the Placement Status
area of the Component Placement dialog box is.

(a) Partially constrained (b) Fully constrained
(c) Completely constrained (d) None of the above

3. In which of the following types of simplified representation the complete geometry of the
components is displayed in the current model display style?

(a) Geometry representation (b) Graphics representation
(c) Master representation (d) None of the above

4. Which constraint is used to assemble two components by making the selected faces or
planes coplanar such that the mating faces or planes are facing in same direction?

(a) Insert (b) Orient
(c) Tangent (d) Align

5. The unexploded state of an assembly can be displayed by choosing Unexplode from
which of the following menu in the menu bar?

(a) View (b) File
(c) Info (d) Window

6. A component of an assembly that is assembled using the assembly constraints cannot be
replaced with some other component. (T/F)

7. If you want some component of an assembly to disappear from the display it can be
achieved. (T/F)

8. Offset lines can only be created in the exploded state of an assembly. (T/F)

9. The order of assembling the components in an assembly can be changed. (T/F)

10. The Pro/ENGINEER provides you with a readymade BOM that can be directly used. (T/F)

Review Questions
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Figure 9-70 The Crosshead assembly

Exercise 1

Exercise

In this exercise you will create all the components of the Crosshead assembly and then assemble
them as shown in Figure 9-70. Also you will create an exploded state shown in Figure 9-71
displaying the offset lines. The dimensions of the components are shown in Figure 9-72 through
Figure 9-76.       (Estimated time: 2 hrs)
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Figure 9-72  Front view and the right side view of the Body

Figure 9-74  Dimensions for Piston RodFigure 9-73  Dimensions of Keep Plate

Figure 9-71  The exploded state of Crosshead assembly
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Figure 9-76  Dimensions for Nut

Figure 9-75  Dimensions for the Brasses and Bolt

Answers to the Self-Evaluation Test
1 - T, 2 - T, 3 - F, 4 - T, 5 - T, 6 - Master representation, 7 - Graphics representation, 8 - Mate
offset, 9 - Insert, 10 - BOM.


