Chapter 2

Working with Splines

Learning Objectives

After completing this chapter, you will be able to:
* Work with spline primitives

* Understand spline modeling techniques

* Create geometries using Generators
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INTRODUCTION

In computer graphics, a spline is a line formed by connecting a sequence of vertices lying in 3D
space. Although, it is formed in 3D space, it has no depth. A spline is not visible on rendering.
You can create complete parametric spline primitives (with pre-defined shapes) as well as empty
splines whose shapes can be defined interactively in the viewport. You can use splines to create
complex geometries using Generator objects in CINEMA 4D. Generators are CINEMA 4D’s
most powerful modeling tools.

TUTORIALS

Before you start tutorials of this chapter, you need to download the c02_cinema4d_s24_tut.zip file
from www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects >
MAXON CINEMA 4D > MAXON CINEMA 4D S$24: A Tutorial Approach

Next, you need to extract the contents of the zip file. To do so, navigate to the Documents folder
and create a new folder in it with the name ¢4ds24. Next, you need to browse to \Documents\
c4ds24 and create a new folder in it with the name c02. Then, extract the contents of the zip
file in this folder.

Tutorial 1

In this tutorial, you will create 3D model of a door lock system with the help of splines
and generators. The final output of the model is shown in Figure 2-1.
(Expected time: 35 min)

Figure 2-1 The model of door lock system

The following steps are required to complete this tutorial:

Set the viewport background.

Create the base of the door lock system.
Create the key hole.

Create the handle.

Change the background color of the scene.
Save and render the scene.
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Setting the Viewport Background

In this section, you will set the background image in the Front viewport.
1. Choose File > New Project from the main menu; a new scene is displayed.

2. Press the middle mouse button in the Perspective viewport; all viewports are displayed. Next,
hover the cursor over the Front viewport and then press MMB to maximize it. Alternatively,
choose Cameras > Front from the Menu in editor view, as shown in Figure 2-2; the Front
viewport is maximized.

im.com

3. Choose Options > Configure from the Menu in editor view, as shown in Figure 2-3; the
Viewport [Front] settings are displayed in the Attribute Manager. In the Attribute Manager,
choose the Back button; the Back area is displayed. In this area, choose the browse button
next to the Image text box, as shown in Figure 2-4; the Open File dialog box is displayed.
Browse to \Documents\c4#ds24\c02\keyhole.jpg. Next, choose the Open button; the keyhole.jpg
is opened as the background image in the Front viewport.
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Options | Filter

1on visi

Safe Frames

Cameras

Shadow Hinting

Front

P Configure..

Figure 2-2 Choosing the Front option from the Figure 2-3 Choosing the
Menuw in editor view Configure option from
the Menw in editor view
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4.

Creating the Base of the Door Lock System | spime
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Figure 2-4 Choosing the browse button next to the Image text box

In the Back area, clear the Keep Aspect Ratio check box and then set the parameters as
follows:

Offset X: 122 Offset Y: 2 Size X: 445
Size Y: 500

The Configure option available in the Options menu of the Menu in editor view is used
to edit the settings of the respective viewport. It applies to all viewports. The options in
the Back area are used to place the reference image at the desired location as the viewport
background. The Image text box displays the location of the loaded file. Any image with a
recognizable format can be loaded in CINEMA 4D.

The Offset X option is used to move the reference image horizontally.

The Offset Y option is used to move the reference image vertically.

spline V&

|

The Size X and Size Y options are used to scale the reference image.

In this section, you will create the base of the door lock system using [

the Rectangle tool.

1.

/4

2.

Choose Create > Spline from the main menu; a cascading menu is
displayed. Next, choose Rectangle from it, as shown in Figure 2-5;
a rectangle is created in all the viewports. Also, Rectangle is added
to the Object Manager.

Note
The spline primitives are parametric in nature as their attributes such
as height, radius, and so on can be altered in the Attribute Manager.

N

Figure 2-5 Choosing
Make sure that Rectangle is selected in the Object Manager. In the  Rectangle from the
Attribute Manager, make sure the Object button is chosen and then  Create menu
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enter 121 and 465 in the Width and Height spinners, respectively, of the Object Properties
area, refer to Figure 2-6.

Attributes Layers Structure

! Mode Edit User Data <« T q V Iil @ EI

D Rectangle Object [Rectangle]

: Object
Object Properties
0 v i B

© Height 465 cm

. Rounding D

' Radius

0 e
. Reverse D

Figure 2-6 Setting the width and height of the rectangle

By default, the value of these parameters is set to 400. As a result, a square is displayed in
the viewport.

Next, you will extrude the rectangle.

~ Note

@ You can change the units of parametric objects. 1o do so, choose Mode > Project in the Attribute

Manager; the Project area is displayed in the Attribute Manager. Make sure the Project Settings
button is chosen in this area. In the Project Settings area, by default Centimeters is selected in
the drop-down list located next to the Project Scale spinner. You can select any other unit from
the drop-down list as per your requirement.

3. Choose the Extrude tool from the Command palette, as shown in Figure 2-7; Extrude is
added to the Object Manager, refer to Figure 2-8.

24 = | = iew  Object Bookmarks L ¢ [+
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[ Rectangle n:

Figure 2-7 Choosing Extrude from the flyout Figure 2-8 Extrude added to the Object Manager

4. Select Rectangle in the Object Manager. Press and hold the left mouse button on Rectangle
and drag the cursor to Extrude in the Object Manager; Rectangle is connected to Extrude in
the Object Manager. Also, Rectangle is extruded in the Perspective viewport.

5. Select Extrude in the Object Manager. In the Attribute Manager, choose the Objects button;
the Objects Properties area is displayed. In this area, enter 25 in the Offset spinner; Rectangle
is extruded in the Perspective viewport, as shown in Figure 2-9.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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On pressing and holding the left mouse button on Extrude, a flyout is displayed with various
tools. You can use these tools to create complex models with relatively less number of control
points. Models created using these tools can be converted into polygons.

The Extrude tool is used to extrude the spline in any direction. The effect of this tool is
only visible when the spline is connected to the Extrude object.

Creating the Keyhole

In this section, you will create a keyhole using the Spline Pen tool.

1. Make sure the Front viewport is maximized. Choose the Spline Pen tool from the Command
Palette, refer to Figure 2-10; the shape of the cursor changes, as shown in Figure 2-11.

Camera =°

Figure 2-9 Rectangle extruded in Figure 2-10 Choosing Spline Pen
the Perspective viewport from the Command Palette

2. In the Front viewport, draw the shape of the keyhole on the reference image, as shown in
Figure 2-12. You will notice that Spline is also added to the Object Manager.

3. Invoke the Move tool from the Command Palette and select the points of Spline. Next, edit
the shape of Spline to give it the shape of a keyhole, as shown in the reference image, refer
to Figure 2-12.

4. 'To edit the shape of Spline, right-click on the points one by one and choose the desired
option from the shortcut menu displayed. To further edit the shape, right-click on the edges
of Spline and choose the desired option to add points, modify the shape of the edges, and
so on. You can also use the Spline Pen tool to move and edit points on the line.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com

5. Select Spline in the Object Manager. In the Attribute Manager, make sure that the Object
button is chosen. In the Object Properties area, make sure the Close Spline check box is
selected. Next, choose the Basic button in the Attribute Manager; the Basic Properties area
is displayed. In this area, enter keyhole in the Name text box; Spline is renamed as keyhole
in the Object Manager, as shown in Figure 2-13.
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Note
The spline also closes if you click on the furst point of the spline.

i

—

. e
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Figure 2-11 The changed shape of the cursor Figure 2-12 Shape of the keyhole
= File Edit View Object Bookmarks Q. GV E
/" keyhole
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Figure 2-13 Spline renamed as keyhole

6. Press F1; the Perspective viewport is maximized. Choose Extrude from the Command Palette,
as shown in Figure 2-14; Extrude.l is added to the Object Manager. Next, drag keyhole on
Extrude.1 in the Object Manager; keyhole is connected to Extrude.1.

Figure 2-14 Choosing Extrude from the Command Palette

7. Select Extrude.l in the Object Manager. Next, choose the Object button in the Attribute
Manager, if it is not already chosen; the Object Properties area is displayed. In this area,
enter 40 in the Z spinner of the Movement parameter; the keyhole is extruded.

t www.cadcim.com
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8.
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In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. In
this area, enter -5.409 in the P . Z spinner. Figure 2-15 displays keyhole in the Perspective
viewport.

Figure 2-15 keyhole extruded in the Perspective viewport

Press and hold the left mouse button on the Subdivision Surface tool in the Command
Palette; a flyout is displayed. Next, choose Boole from the flyout, as shown in Figure 2-16;
Boole is added to the Object Manager. Now, select Extrude.1 and drag the cursor to Boole;
Extrude.1 is connected to Boole.

% Instance

’ Boole

Figure 2-16 Choosing Boole from the flyout

. In the Object Manager, select Extrude and press and hold the left mouse button; the shape of

the cursor is changed. Next, drag Extrude to Boole; Extrude is connected to Boole, as shown in
Figure 2-17. Also, keyhole is subtracted from Extrude and a hole is created in the Perspective
viewport, as shown in Figure 2-18.

The Boole tool is used to subtract two or more objects to create a hole in the object. Mostly,
this tool is used to perform operations on splines and polygon primitives.
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Figure 2-17 Extrude connected to Boole

Figure 2-18 The hole created in the Perspective viewport
Creating the Handle

In this section, you will create the handle of the door using the Spline Pen tool.

1. Press F4; the Front viewport is maximized. Choose Spline
Pen from the Command Palette; the shape of the cursor is

changed. J

2. In the Front viewport, draw the shape of the door handle on
the reference image, refer to Figure 2-19. You will notice that
Spline is added to the Object Manager. Make sure that the Close \
Spline check box is selected in the Object Properties area in the
Attribute Manager.

)

3. In the Attribute Manager, choose the Basic button; the
Basic Properties area is displayed. In this area, type Handle in Figure 2-19 Handle placed
the Name text box; the name of Spline changes to Handle in the in the front viewport
Object Manager.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Figure 2-19 displays Handle placed in the Front viewport.

4. Press F1; the Perspective viewport is maximized. Next, choose Extrude from the Command

Palette; Extrude is added to the Object Manager. Now, select Handle in the Object Manager
and drag Handle to Extrude; Handle is connected to Extrude and is extruded in the Perspective
viewport, as shown in Figure 2-20.

Figure 2-20 Handle extruded in the Perspective viewport

5. Select Extrude in the Object Manger. Next, choose the Object button in the Attribute Manager
and then set 18 in the Offset spinner.

6. In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. In
this area, set the parameters as follows:

P.X:-30.7 P.Y:18.1 P.Z:-45
Spline
P.X, P.Y, and P . Z parameters are used to specify the Generator
position values of X, Y, and Z axes. The S . X, S.Y,and S.Z
parameters are used to specify the scale values of X, Y, and
Z axes. Similarly, the R.X, R .Y, and R . Z parameters are
used to specify the rotational values of X, Y, and Z axes.

Next, you will create the joint between the handle and the
base of the door.

7. Press F2; the Top viewport is maximized. Next, choose
Create > Spline from the main menu; a cascading menu is
displayed. Choose Circle from it, as shown in Figure 2-21;
a circle is created in the Top viewport and Circle is added to
the Object Manager.

< =leH®D0< 6|00 06

&

Figure 2-21 Choosing Circle
[from the main menu
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8.

10.

11.

12.

13.

14.

Make sure that Circle is selected in the Object Manager. Next, in the Attribute Manager,
choose the Basic button. In the Basic Properties area, type Joint in the Name text box;
Circle is renamed as Joint in the Attribute Manager. Next, choose the Coord button; the
Coordinates area is displayed. In this area, set the parameters as follows:

P.Y: 81.591 R.P:90

Choose the Object button in the Attribute Manager; the Object Properties area is displayed.
In this area, enter 20 in the Radius spinner.

Press F1; the Perspective viewport is maximized. Make sure that joint is selected in the Object
Manager. Now, create a copy of Joint by pressing both the CTRL key and the left mouse
button. Now, drag the cursor and release the left mouse button; a copy of joint is created
in the Object Manager with the name Joint. I. You can also create a copy in the viewport by
CTRL dragging.

Make sure that Jomnt.1 is selected in the Object Manager. In the Attribute Manager, make
sure that the Coordinates area is displayed and enter -24.05 in the P . Z spinner. Figure 2-22
shows the position of Joint and Joint.1 in the Perspective viewport.

Next, you will create the surface of the joints.

Press and hold the left mouse button on the Extrude
tool in the Command Palette; a flyout is displayed.
Next, choose the Loft tool from it; Lofi is added to the
Object Manager.

Press F5; all viewports are displayed. Select Joint and Joint
Joint.I in the Object Manager by using the SHIFT
key and then press and hold the left mouse button

Joint.1

and drag the cursor on Loft; the Joint and joint.1 are
connected to the Loft in the Object Manager. Also, a
surface is created. Figure 2-23 displays the surface in
all viewports.

Figure 2-22 The position of Joint and
Joint. 1 displayed in the Perspective
viewport

Next, you will group the surfaces together.

In the Object Manager, select Boole, Extrude, and Lofi

by using the CTRL key. Next, choose Group Objects from the Object menu in the Object
Manager, refer to Figure 2-24; all selected objects are grouped and Null is added to the Object
Manager. Rename Null as Door Lock by double-clicking its label in the Object Manager.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Figure 2-23 Joint and Joint.1 lofied to create a surface
Changing the Background Color of the Scene

In this section, you will change the background color of the scene.

1. Choose Create > Environment from the main menu; a cascading menu is displayed. Choose
the Background option from it, as shown in Figure 2-25; Background is added to the Object
Manager.

Craate | Modes Select Tools  Mesh

Generator

Environment »

[® Environment
K

&
L]

Bake as Alembic

L Bake as Alembic + Delete

Figure 2-24 Choosing Group Objects  Figure 2-25 Choosing the Background
from the Object menu option from the main menu

The Background option is used to change the background with the color or image which
is only visible in the render view.

Next, you will change the background color to white.
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Make sure Background is selected in the Object Manager, as shown in Figure 2-26. In the
Attribute Manager, choose the Basic button; the Basic Properties area is displayed. In this
area, select On from the Display Color drop-down list. On doing so, the Color parameter
is activated, as shown in Figure 2-27. By default, the white color is selected in this spinner.
As a result, the background color changes to white.

Mode Edit User Data <« 'T Q ? @] @

@ Background Object [Background]
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. Display Color

. Color

Figure 2-26 The Background Object Figure 2-27 The Display Color
selected in the Object Manager parameter activated

The options in the Use Color drop-down list are used to determine whether the selected
objects in the viewport use the color assigned to them or not. You need to select the On
option from the Use Color drop-down list to ensure that the display color is used even if
the materials are applied to it.

Saving and Rendering the Scene
In this section, you will save and render the scene. You can also view the final render of the scene
by downloading the file ¢c02_cinema4d_s24_rndr.zip from www.cadcim.com. The path of the file is
mentioned at the beginning of the chapter.

1.

Choose File > Save Project as from the main menu; the Save File dialog box is displayed.
In this dialog box, browse to the location |Documentslc4ds241c02.

Enter c02tutl in the File name text box and then choose the Save button.

In the Perspective viewport, set the camera angle using the Viewport Navigation Tools located
at the top right of the Perspective viewport. Next, choose the Render to Picture Viewer tool
from the Command Palette. Alternatively, press SHIFT'+R; the Picture Viewer window is
displayed, as shown in Figure 2-28.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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The Render to Picture Viewer tool is used to render the scene in the Picture Viewer window.
The Picture Viewer window is also known as the output window in CINEMA 4D. It is used
to view the output of the scene as well as to save it.

Next, you will save the rendered image.

Figure 2-28 The Picture Viewer window

4. In the Picture Viewer window, choose File > Save Image as, as shown in Figure 2-29; the
Save dialog box is displayed, as shown in Figure 2-30.

Figure 2-29 Choosing the Save as option from the File menu

The Save Image as option is used to save a scene or an image sequence in the format based
on your requirement. The Save dialog box is displayed with specific parameters which helps
you in saving the still image or image sequence in an uncompressed format.

5. In the Save dialog box, select JPEG from the Format drop-down list and then choose the
OK button; the Save Dialog dialog box is displayed. Next, browse to |Documents\c4ds24\c02.
In the File Name text box, type c02_tutl_rndr. Next, choose the Save button; the rendered
image is saved at the desired location.
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The output of the model is shown in Figure 2-1.

@ save X
Type
Depth

Name.

Stereoscopic

O Layers [l Alpha Channel
O sound

Advanced Settings (Flatten layers)
(0 Save AB Compare [JUse Filter

[ Rescale

I Lock Original Pixel Width/Height Ratio
Pixel Width/Height
|

— |

Figure 2-30 The Save dialog box

Tutorial 2

In this tutorial, you will create a hand bag with the help of splines and generators. The final
output of the model is shown in Figure 2-31. (Expected time: 25 min)

Figure 2-31 The model of a
hand bag

The following steps are required to complete this tutorial:

a. Create the shape of the hand bag.
b. Create the handles of the hand bag.
c. Create text on the hand bag.

t www.cadcim.com
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d. Change the background color of the scene.

€.

Save and render the scene.

Creating the Shape of the Hand Bag
In this section, you will create the shape of the hand bag using the Spline tool.

1.

Choose File > New Project from the menu bar; a new scene is started. Next, choose Create
> Spline from the main menu; a cascading menu is displayed. Choose Rectangle from the
menu; a rectangle is created in the Perspective viewport and Rectangle is added to the Object
Manager.

Make sure that Rectangle is selected in the Object Manager. In the Attribute Manager, choose
the Object button; the Object Properties area is displayed. In this area, set the values of the
parameters as follows:

Width: 980 Height: 340

In the Object Properties area, select the Rounding check box and enter 55 in the Radius
spinner. Next, select the XZ option from the Plane drop-down list.

In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. In
this area, set the parameters as follows:

P.X:1.6 P.Z:-4

After entering the values, Rectangle is placed in the Perspective viewport, as shown in
Figure 2-32.

Make sure that Rectangle is selected in the Object Manager. Press and hold the left mouse
button and the CTRL key and then drag and drop the cursor in the empty space above it;
the copy of Rectangle is created in the Perspective viewport and added to the Object Manager
with the name Rectangle.1, as shown in Figure 2-33.

= File Edit View Object Bookmarks 4 ¢ )/ [+

| Recanglet -

O Rectangle n:

Figure 2-32 Rectangle placed in the Figure 2-33 Rectangle.1 added to the Object
Perspective viewport Manager
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6.

Make sure that Rectangle.1 is selected in the Object Manager. In the Attribute Manager, make
sure that the Object button is chosen. In the Object Properties area, set the parameters as

follows:

Width: 730 Height: 129

In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. In

this area, enter 286.8 in the P . Y spinner.

After entering the values, Rectangle.1 is placed in the Perspective viewport, as shown in

Figure 2-34.

Make sure that Rectangle.1 is selected in the Object
Manager. Press and hold the left mouse button and the
CTRL key and then drag and drop the cursor in the
empty space; a copy of the Rectangle.1 is created and
added to the Object Manager with the name Rectangle.2,
as shown in Figure 2-35.

Make sure that Rectangle.2 is selected in the Object
Manager. In the Attribute Manager, make sure that
the Object button is chosen. In the Object Properties
area, set the parameters as follows:

Width: 815 Height: 165

Make sure that the Rounding check box is selected and
enter 82.5 in the Radius spinner.

Figure 2-34 Rectangle.1 placed in
the Perspective viewport

= File Edit View Object Bookmarks 4 357 [+

[ Rectangle.1 B:

i

Figure 2-35 Rectangle.2 added to the Object Manager

10. In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. In
this area, enter -3.66 in the P . Y spinner. After entering the values, Rectangle.2 is placed in

the Perspective viewport, as shown in Figure 2-36.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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11.

12.

13.

14.

15.

Figure 2-36 Rectangle.2 placed in the Perspective viewport

Make sure that Rectangle.2 is selected in the Object Manager. Next, press and hold the left
mouse button and the CTRL key and then drag and drop the cursor in the empty space; a
copy of Rectangle.2 is created and added to the Object Manager with the name Rectangle.3,
as shown in Figure 2-37.

Make sure that Rectangle.3 is selected in the Object Manager. In the Attribute Manager, make
sure that the Object button is chosen. In the Object Properties area, set the parameters as
follows:

Width: 527 Height: 55
Clear the Rounding check box.

In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. In
this area, set the parameters as follows:

P.X:-1.9 P.Y:647.4

After entering the values, Rectangle.3 is placed in the Perspective viewport, as shown in
Figure 2-38.

Press and hold the left mouse button on the Extrude tool in the Command Palette; a flyout
is displayed. Choose the Loft tool from the flyout, as shown in Figure 2-39; Loft is added to
the Object Manager.

In the Object Manager, select Rectangle.2. Next, drag and drop Rectangle.2 on Loft; Rectangle.2
is connected to Loft, as shown in Figure 2-40. Also, Rectangle.? is lofted with a surface in the
Perspective viewport.
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File Edit View Object ~  Bookmarks 4 )/ [+
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Figure 2-37 Rectangle.3 added to the Object Figure 2-38 Rectangle.3 placed in
Manager the Perspective viewport

Figure 2-39 Choosing Loft from the flyout

Figure 2-40 Rectangle.2 connected to Loft in the Object Manager

16. Connect Rectangle.1, Rectangle.3, and Rectangle to Lofi in the Object Manager in the order
as shown in Figure 2-41; a lofted surface resembling the shape of a hand bag is created in
the Perspective viewport, as shown in Figure 2-42.

Iim.com
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4.

1.

= File Edit View Object Bookmarks < 7 [+
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l—n Rectangle.1 M4 2

Figure 2-41 Rectangle, Rectangle.1, and Rectangle.3  Figure 2-42  All rectangles lofied in
connected to Loft the Perspective viewport

Creating the Handles of the Hand Bag

In this section, you will create the handles of the bag using the Lathe tool.

Choose Create > Spline from the main menu; a cascading menu is displayed. Choose
Circle from it; a circle is created in the Perspective viewport and Circle is added to the Object
Manager.

Make sure Circle is selected in the Object Manager. In the Attribute Manager, make sure
that the Object button is chosen. In the Object Properties area, enter 8 in the Radius
spinner. Also, make sure that the XY option is selected in the Plane drop-down list. Next,
choose the Coord button; the Coordinates area is displayed. In the Coordinates area, set
the parameters as follows:

P . X:242.63 P.Y:293.5 P.Z7:-110.8
Press and hold the left mouse button on the Extrude tool in the Command Palette; a flyout

is displayed. Choose the Lathe tool from the flyout, as shown in Figure 2-43; Lathe is added
to the Object Manager, refer to Figure 2-44.

Figure 2-43 Choosing Lathe from the flyout

In the Object Manager, drag Circle and drop it on Lathe; Circle is connected to Lathe, as
shown in Figure 2-44.
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The Lathe tool is used to rotate the profile curve on the Y-axis of the local axis system of
the shape. It is used to generate a revolved surface.

File Edit View Object Bookmarks 4 ¢ Y/ [+

Figure 2-44 Circle connected to Lathe in the Object Manager

5. Select Lathe in the Object Manager. In the Attribute Manager, choose the Object button;
the Object Properties area is displayed. In this area, enter 75 in the Subdivision spinner
and 227 in the Angle spinner.

6. Choose the Coord button; the Coordinates area is displayed. In this area, set the parameters

as follows:

P.X: 5.715 P.Y: 634.142 P.Z: 291.176
S.X: 0.87 S.7:1.62 R . H: 90
R.P: 90 R . B:-90

Figure 2-45 displays the hand bag with its handle. Next, you will create a copy of the handle.

7. Select Lathe in the Object Manager. Press and hold the left mouse button along with the
CTRL key; the shape of the cursor is changed, as shown in Figure 2-46. Next, drag Lathe in
the empty space above it and then release the left mouse button; a copy of Lathe is added
with the name Lathe.I to the Object Manager.

= Fle Edit View Object Bookmarks L <7 [+

Figure 2-45 The handle of the
hand bag created in the Object Manager

Figure 2-46 The changed shape of the cursor
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8.

Make sure that Lathe.1 is selected in the Object Manager and the Coord button is chosen
in the Object Manager. In the Coordinates area of the Attribute Manager, enter 282.25 in
the P . Z spinner.

Creating Text on the Hand Bag

In this section, you will create text on the hand bag using the Extrude tool.

1.

b

Press and hold the left mouse button on the Spline Pen tool in the Command Palette; a
flyout is displayed. Choose the Text Spline tool from the flyout; Text Spline is created in the
Perspective viewport and added to the Object Manager.

Make sure that Text Spline is selected in the Object Manager. In the Attribute Manager, choose
the Object button. In the Object Properties area, set the parameters as follows:

Text: S&S Height: 274
Vertical Spacing: 11

Horizontal Spacing: 5

The Text edit box in the Object Properties area is used to write the text in the viewport.
You can also type multiple lines. The Height parameter is used to determine the height of
the text displayed in the viewport. The Horizontal Spacing parameter is used to determine
the horizontal spaces or gaps between the characters. The Vertical Spacing parameter is
used to determine the vertical spaces or gaps between the characters.

In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. In
this area, set the parameters as given next:

P . X:-249.402 P.Y:354.604
P.7:-109.475 R.P:-12

The text is placed in the Perspective viewport, as shown
in Figure 2-47. Next, you will extrude the text.

Choose the Extrude tool from the Command Palette;
Extrude is added to the Object Manager.

In the Object Manager, drag Text Spline and drop it on
Extrude; Text Spline is connected to Extrude, as shown in
Figure 2-48. Also, Text Spline is extruded in the Perspective
viewport, refer to Figure 2-49.

Figure 2-47 The text placed in the
Perspective viewport
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Figure 2-48 Text connected to Extrude in Figure 2-49 The extruded text on the
the Object Manager hand bag

Changing the Background Color of the Scene
To change the background color of the scene to white in the final output, follow the steps given
in Tutorial 1 of Chapter 2.

Saving and Rendering the Scene
In this section, you will save and render the scene. You can also view the final render of the scene
by downloading the file ¢c02_cinema4d_s24_rndr.zip from www.cadcim.com. The path of the file is
mentioned at the beginning of the chapter.

1. Choose File > Save Project as from the main menu; the Save File dialog box is displayed.
In this dialog box, browse to the location |Documents|c4ds241c02.

2. Enter c02tut2 in the File name text box and then choose the Save button.
3. In the Perspective viewport, set the camera angle using the Viewport Navigation Tools
located on the extreme top right of the Perspective viewport. Next, you need to render the

scene. For rendering, refer to Tutorial 1.

Figure 2-31 displays the final output.

Tutorial 3
In this tutorial, you will create a cigar pipe with the help of splines and the Loft generator. The
final output of the model is shown in Figure 2-50. (Expected time: 25 min)

The following steps are required to complete this tutorial:

a. Set the viewport background.
b. Define the shape of the pipe.
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C.

Create geometry of the pipe.

d. Change the background color of the scene.

€.

Save and render the scene.

Figure 2-50 The model of the cigar pipe

Setting the Viewport Background

In this section, you will set a background image in the Front viewport.

1.

Choose File > New Project from the main menu, a new scene is displayed. Press F4; the
Front viewport is maximized.

In the Front viewport, choose Options > Configure from the Menu in editor view; the
Viewport [Front] settings are displayed in the Attribute Manager. In the Attribute Manager,
choose the Back button, if it is not already chosen; the Back area is displayed. In this area,
choose the browse button next to the Image text box; the Open File dialog box is displayed.
Browse to |Documents\c4ds24\c02\pipe.jpg. Next, choose the Open button; the pipe.jpg is placed
as the background image in the Front viewport.

Enter 75 in the Transparency spinner.

Defining the Shape of the Pipe
In this section, you will define the shape of the pipe using the Circle spline.

1.

Choose Create > Spline > Circle from the main menu bar; Circle is displayed in the Front
viewport.

Make sure Circle is selected in the Object Manager and the Object button is chosen in the
Attribute Manager. In the Object Properties area of the Attribute Manager, select XZ from
the Plane drop-down list.

In the Attribute Manager, select the Ellipse check box and then enter 7 and 27.846 in the
Radius and Radius Y spinners, respectively.
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4.

Choose the Coord button and then specify the values for the following parameters:

P .X:375.332 P .Y:168.154 R . H:90

After entering the values Circle is placed at the end of the pipe, as shown in Figure 2-51.
Double click on Circle in the Object Manager and rename the object as Ellipse.

In the Object Manager, create a copy of Ellipse using CTRL; a duplicate copy of Ellipse is
created with the name Ellipse.1.

Make sure Ellipse.1 is selected in the Object Manger. In the Attribute Manager, choose
the Object button and then enter 8 and 24.818 in the Radius and Radius Y spinners,

respectively.

In the Attribute Manager, choose the Coord button and then specify the following values
for the following parameters:

P . X:344.115 P.Y:167.142 R . H: 90

After entering the values Ellipse.1 is placed next to the Ellipse, as shown in Figure 2-52.

Figure 2-51 Ellipse displayed in the
Front viewport Front viewport

Figure 2-52 Ellipse.1 displayed in the

Create a Circle spline as done in steps 1 through 2. In the Attribute Manager, make sure the
Object button is chosen and then enter 18.477 in the Radius spinner. Choose the Coord
button and then specify the values for the following parameters:

P . X:313.585 P.Y:165.525 R . H: 90

After entering the values, Circle is displayed in the Front viewport, as shown in Figure 2-53.

Iim.com
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Figure 2-53 Circle displayed in the Front viewport

10. Create more copies of Circle and then use the values given in Table 2-1 to create the profile
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of the pipe:

Table 2-1 Values used for creating the profile of the pipe
Spline Radius P.X P.Y R.B
Circle.1 21 220 152 70
Circle.2 28 88 73 56
Circle.3 32 83 66 56
Circle 4 36 78 59 56
Circle.5 41 17 8 50
Circle.6 46 9.377 4 50
Circle.7 42 4 -2.3 50
Circle.8 50 -95 -82 57
Circle.9 87 -180 -115 112
Circle.10 118 -254 -66 150
Circle.11 91 -253 41 180

Creating Geometry of the Pipe

After entering the values, the profile of the pipe is completed, as shown in Figure 2-54.

In this section, you will create the shape of the pipe using the Loft generator.

1. Choose Create > Generator > Loft from the menu bar; Lofi is displayed in the Object
Manager.
2. Select Ellipse in the Object Manager and then press and hold down SHIFT. Next, click on

Circle. 11 to select all splines and then release SHIFT.
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Options  Filter

Figure 2-54 The profile of the pipe displayed

3. Press and hold the left mouse button and then drag the splines to Lofi; all splines are
connected to Lofl, refer to Figure 2-55. Also, shape of the pipe is displayed in the scene, as
shown in Figure 2-56.

Figure 2-55 The splines connected with Lofl

4. Press F1 to activate the Perspective viewport.

5. Make sure Loft is selected in the Object Manager and then choose the Caps button in the
Attribute Manager; the Caps area is displayed.

6. In this area, clear the Start Cap and End Cap check boxes, as shown in Figure 2-57.
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< L (OF] View Cameras Display

Figure 2-56 The shape of the pipe displayed

Figure 2-57 The pipe with the fillet caps displayed

Next, you will modify the end part of the pipe to maintain the flow of the geometry.

7. Select Circle in the Object Manager and then make sure the Object button is chosen in the
Attribute Manager. Set the value 9.652 for the Radius parameter.

8. Select Ellipse in the Object Manager and make sure the Object button is chosen in the
Attribute Manager. Next, set the values 1.757 and 12.231 for the Radius and Radius Y
spinners, respectively. Similarly, set the values 4.178 and 12.962 for the Radius and Radius
Y spinners, respectively, for Ellipse.1. After entering the values, the modified shape of the
pipe is displayed, refer Figure 2-50.
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Changing the Background Color of the Scene
To change the background color of the scene to white in the final output, follow the steps given
in Tutorial 1.
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Saving and Rendering the Scene
In this section, you will save and render the scene. You can also view the final render of the scene
by downloading the file c02_cinema4d_s24_rndrzip from www.cadcim.com. The path of the file is
mentioned at the beginning of the chapter.

1.

Choose File > Save Project as from the main menu; the Save File dialog box is displayed.
In this dialog box, browse to the location |Documents\c4ds241c02.

Enter c02tut3 in the File name text box and then choose the Save button.
In the Perspective viewport, set the camera angle using the Viewport Navigation Tools
located on the extreme top right of the Perspective viewport. Next, you need to render the

scene. For rendering, refer to Tutorial 1.

Figure 2-50 displays the final output.

Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1.

Which of the following tools is used to create complex models using relatively less number
of control points?

(a) Spline Pen (b) Extrude
(c) Move (d) None of these

Which of the following tools is used to extrude a spline object or a curve?

(a) Spline Pen (b) Loft
(c) Extrude (d) All of these

Which of the following combinations of shortcut keys is used to render a scene?

(a) ALT+Q (b) CTRL+D
(c) SHIFT+R (d) None of these
The tool in the Command Palette is used to subtract two or more objects from

an object to create a hole in that object.

The option in the Options menu is used to edit the settings of the respective
viewport.

The Angle parameter in the
the angle of rotation of the spline.

area of the Attribute Manager is used to define

The Viewport Navigation Tools are located at the top right corner of the viewport. (T/F)
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The Background tool is used to change the foreground with the color or the image which
is visible only in the render view. (T/F)

The R . P parameter in the Attribute Manager is used to determine the rotational values of
the X axis. (1/F)

Review Questions

Answer the following questions:

1.

Which of the following tools is used to revolve a profile curve about the Y axis of the local
axis system of the spline shape?

(a) Lathe (b) Subdivision Surface
(c) Spline Pen (d) None of these
P

Which of the following tools is used to create text in the viewport in CINEMA 4D?

(a) Lathe (b) Text Spline
(c) Spline Pen (d) Render to Picture Viewer
The parameter of the Background object is used to select the background color

of the scene for the rendering purpose.
By default, the height of a rectangle spline primitive is set to

The dialog box consists of specific parameters which help you in saving a still
image or image sequence in an uncompressed format.

CINEMA 4D consists of default predefined curves known as spline primitives. (T/F)

The Render to Picture Viewer tool is used to render a scene or model in a separate window.
(T/F)

The Picture Viewer window is also known as the output window in CINEMA 4D. (T/F)

The default units of measurement in CINEMA 4D can be changed from the drop-down list
located next to the Project Scale spinner in the Project Settings area. (1/F)

10. The ALT+G key combination is used to group objects in the Object Manager. (1/F)

EXERCISES

The rendered output of the model used in the following exercises can be accessed by downloading
the ¢02_cinema4d_s24_exr.zip file from www.cadcim.com. The path of the file is as follows:
Textbooks > Animation and Visual Effects > MAXON CINEMA 4D > MAXON CINEMA 4D $24: A
Tutorial Approach
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Using various Generators and spline modeling tools, create the model of a chair, as shown in
Figure 2-58. (Expected time: 25 min)

Using various Generators and spline modeling tools, create the model of a table clock, as shown
in Figure 2-59. (Expected time: 45 min)

N

Figure 2-58 The model of a chair ~ Figure 2-59 The model of a table clock
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Answers to Self-Evaluation Test
1.b, 2. ¢, 3. ¢, 4. Boole, 5. Configure, 6. Object Properties, 7. T, 8. F, 9. F



