
Systems, Hierarchy, 
and Kinematics

 Learning Objectives
After completing this chapter, you will be able to:
• Create a Ring Array system
• Create a Sunlight system 
• Create a Daylight system
• Understand hierarchy and kinematics
• Create a bone system
• Understand IK solver, interactive IK, and applied IK
• Create a biped system
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INTRODUCTION
In 3ds Max, Systems is an object set that consists of objects, linkages,

Figure 16-1  The Systems in the 
Command Panel

 
and controllers. There are five types of systems: Bones, Ring Ar-
ray, Sunlight, Daylight, and Biped, refer to Figure 16-1. These 
systems help you to create complex animations with much ease.

To create the systems, choose Create > Systems in the Command 
Panel; the Standard option will be displayed in the drop-down 
list. Also, the Object Type rollout will be displayed, as shown in 
Figure 16-1. There are various tools in the Object Type rollout to 
create systems. In this chapter,  you will learn to create and modify 
different types of systems using these tools. 

Creating a Ring Array System
  Command Panel:	 Create > Systems > Standard > Object Type rollout > Ring Array	

A Ring Array system consists of a number of boxes in a circular pattern with a dummy object 
placed at its center, refer to Figure 16-2.     

The dummy object is a wireframe box with a pivot point at its center. The pivot point is used as a 
center for transformations such as rotation and movement. Note that the dummy object cannot 
be rendered. You will learn more about the dummy objects in the later chapters.  

To create a Ring Array system, choose the Ring Array tool from Create > Systems > Standard > 
Object Type rollout in the Command Panel; the Name and Color and Parameters rollouts will 
be displayed. Next, in the Top viewport, press and hold the left mouse button to specify the 
center of the Ring Array system, and then drag the cursor to define the radius of the array. Next, 
release the left mouse button; a dummy object will be created at the center. Also, four boxes will 
be created in a circular pattern around it, as shown in Figure 16-2. To modify the parameters of 
the Ring Array system, use the options in the Parameters rollout. This rollout is discussed next.  

Parameters Rollout
To modify the parameters of a Ring Array system, select one of the boxes in the viewport 
and choose the Motion tab in the Command Panel; the Parameters rollout will be displayed, 
as shown in Figure 16-3. Set the value in the Radius spinner to specify the radius of the Ring 
Array system. Set the value in the Amplitude spinner to specify the amplitude of ring’s sine 
curve. It is a height offset from the local origin of the dummy object located at the center. Set 
the value in the Cycles spinner to specify the number of peaks in the ring’s curve of the Ring 
Array system. Set the value in the Phase spinner to offset the phase of the wave. If you set the 
whole numbers in this spinner, then the Ring Array system will not be affected, only the decimal 
values will affect the Ring Array system. Set the value in the Number spinner to specify the 
number of boxes in the Ring Array system.  	

      
Note
To modify the parameters of the Ring Array system, you need to choose the Motion tab in the 
Command Panel. However, if you need to modify the parameters of only the boxes in the Ring 
Array system, then choose the Modify tab in the Command Panel.
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Figure 16-3  The Parameters 
rollout in the Motion tab

Figure 16-2  The Ring Array system 

Using Different Objects in a Ring Array System 
You can replace the boxes in a Ring Array system with other objects. To do so, first create a Ring 
Array system and then create an object in the viewport with which you want to replace the boxes 
in the Ring Array system. Make sure that the Ring Array system and the object you want to 
replace are selected in the viewport. Next, choose the Curve Editor tool from the Main Toolbar; 
the Track View -Curve Editor dialog box will be displayed. The hierarchy tree on the left of this 
dialog box controls the objects in the viewport. In the hierarchy tree, select the name of the object 
with which you want to replace the boxes of the Ring Array system, as shown in Figure 16-4, and 
then right-click on it; a quad menu will be displayed. Choose the Copy option from the quad 
menu. Next, select one of the boxes in the hierarchy tree, as shown in Figure 16-5. Right-click 
on it and choose the Paste option from the quad menu; the Paste dialog box will be displayed, 
as shown in Figure 16-6. Select the Copy or Instance radio button in the Paste as area. Also, 
select the Replace all instances check box in the Paste Target area to replace all boxes of the 
Ring Array system with the same object. Then, choose the OK button; the boxes in the Ring 
Array system will be replaced by the object created in the viewport, as shown in Figure 16-7.                 

Animating a Ring Array System
You can animate the radius, amplitude, cycles, and phase of a Ring Array system. To do so, 
choose the Toggle Auto Key Mode button from animation playback controls, and then modify 
the parameters in the Parameters rollout at different frames. The parameters will be available 
only at the time of creation of the Ring Array system and are not available in the Modify panel. 
Choose the Toggle Auto Key Mode button again to exit the animation mode. 

To apply any transformation such as rotation, move, or scale to the Ring Array system, you need 
to select the dummy object. Also, you can apply the modifiers to the boxes of the Ring Array 
system. The modifier that you apply to any one of the boxes will be applied automatically to 
the other boxes of the Ring Array system.    
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Figure 16-4  The object selected 
in the hierarchy tree to replace the 
boxes of the Ring Array system 

Figure 16-5  The box selected in 
the hierarchy tree to be replaced 
with the object

Figure 16-6  The Paste dialog box Figure 16-7  The boxes of the Ring Array system 
replaced with the object (teapot)

Creating a Sunlight System
  Command Panel:	 Create > Systems > Standard > Object Type rollout > Sunlight	

The Sunlight system is used to produce the light effects similar to the geographically accurate 
effects of the sun over the earth at a particular location, time, and so on, refer to Figures 16-8 
and 16-9. You can also animate the position of the sun to get a better idea of the shadows cast 
by sun at different positions. The Sunlight system uses a directional light. 

To create a Sunlight system in the scene, choose the Sunlight tool from Create > Systems > 
Standard > Object Type rollout in the Command Panel; the Name and Color and Control 
Parameters rollouts will be displayed. Next, in the Top viewport, press and hold the left mouse 
button at the center of the scene to specify the center of the Sunlight system and then drag the 
cursor to define the radius of the system. Release the left mouse button; a compass rose will be 
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created in the viewports, refer to Figure 16-10. Now, drag the cursor up or down to specify the 
distance of the directional light from the compass rose and then click on the screen to set the 
distance; the compass rose and the directional light will be created in the viewports, refer to 
Figure 16-10. Next, left-click in any of the viewport to exit the Sunlight tool. 

Figure 16-8  The scene after creating 
the Sunlight system

Figure 16-9  The scene after changing 
the position of the sun

                  

Figure 16-10  The Sunlight system in all viewports

By default, the name of the light and the compass rose will be Sun001 and Compass001, 
respectively. To modify the parameters of the Sunlight system, you need to use the options in 
the Control Parameters rollout. This rollout is discussed next.

Control Parameters Rollout    
To modify the parameters of the Sunlight system, select Sun001 in the viewport and 
choose the Motion tab in the Command Panel; the Control Parameters rollout will be 
displayed, as shown in Figure 16-11. The options in this rollout are discussed next. 
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Note
After selecting Sun001 in the viewport if you choose the Modify tab instead of the Motion tab in 
the Command Panel, then the rollouts of the directional light will be displayed.     

On choosing  the Motion tab, the settings of the sun are displayed, refer to 

Figure 16-11  The Control 
Parameters rollout

Figure 16-11. On the top of this rollout, there are two text boxes: 
Azimuth and Altitude. The Azimuth text box indicates the compass 
direction of the sun in degrees. The Altitude text box indicates the 
height of the sun above the horizon in degrees. The values displayed 
in these text boxes depend on the other settings in the Control 
Parameters rollout. The different areas in this rollout are discussed 
next.

Time Area
The options in this area are used to set the time, date, and time 
zone. Set the values in the Hours, Mins., and Secs. spinners to 
specify the time of the day. Set the values in the Month, Day, 
and Year spinners to specify the date. Set the value in the Time 
Zone spinner to specify the time zone. The value in this spinner 
ranges from -12 to 12.

Location Area
The options in this area are used to set the geographical location 
of the scene. Choose the Get Location button; the Geographic 
Location dialog box will be displayed, as shown in Figure 16-12. You can select the continent 
from the Map drop-down list in this dialog box; the respective map will be displayed. Now, 
select the location or the city for the scene from the City area on the left side of this dialog 
box and then choose the OK button; the selected location will be displayed in the text box 
below the Get Location button in the Control Parameters rollout. Also, the position of 
Sun001 will be changed in the viewport according to the selected location. If you change the 
location, then the values in the Latitude and Longitude spinners will also change accordingly.

Site Area
The options in this area are used to set the direction of compass rose. Set the value in the 
Orbital Scale spinner to define the distance between the Sun001 and Compass001. Set the 
value in the North Direction spinner to define the rotational direction of the compass rose 
in the scene.

To modify the radius of the compass rose, select the Compass001 in the viewport, and then choose 
the Modify tab; the Parameters rollout will be displayed, as shown in Figure 16-13. Next, set 
the value in the Radius spinner; the radius of the compass rose will change.  

Creating a Daylight System
  Menu bar:	 	 Create > Systems > Daylight system				     
  Command Panel:	 Create > Systems > Standard > Object Type rollout > Daylight	

The Daylight system is similar to the Sunlight system with the difference that the Daylight system 
uses a combination of two lights, namely sunlight and skylight. You can use the IES sun or target 



Systems, Hierarchy, and Kinematics		         16-7

direct light (standard light) as the sunlight in the Daylight system. The IES sky light or skylight 
(standard light) can be used as the skylight in the Daylight system. 

Figure 16-12  The Geographic Location dialog box Figure 16-13  The 
Parameters rollout

To create a Daylight system in your scene, choose the Daylight tool from Create > Systems > 
Standard > Object Type rollout in the Command Panel; the Daylight System Creation message 
box will be displayed. This message box prompts you to use the Logarithmic Exposure Control, 
as shown in Figure 16-14. Choose the Yes button in this message box. 

Figure 16-14  The Daylight System Creation message box

Next, create the Daylight system using the same method as discussed for the Sunlight system; a 
compass rose and a combination of the sunlight and skylight will be displayed in the viewports, as 
shown in Figure 16-15. By default, the name of the light and the compass rose will be Daylight001 
and Compass001, respectively. The Daylight001 light consists of two lights, namely sunlight and 
skylight. To modify the parameters of the Daylight system, you need to use the options in the 
Control Parameters rollout. This rollout is discussed next.
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Figure 16-15  The Daylight system created in viewports

Control Parameters Rollout    
To modify the parameters of the Daylight system, select the Daylight001 in the viewport and 
choose the Motion tab in the Command Panel; the Control Parameters rollout will be displayed. 
Most of the options in this rollout are the same as those discussed for the Sunlight system. 

Additionally, there is a Manual radio button on the top of this rollout. By default, this radio 
button is cleared and therefore, you can modify the parameters using the options displayed in 
the Control Parameters rollout. On selecting the Manual radio button, you can manually set 
the position of the light in the viewport. Also, you can manually set the intensity of the light by 
setting the value in the Multiplier spinner in the Intensity/Color/Attenuation rollout. To do so, 
select the Daylight001 in the viewport. Choose the Modify tab in the Command Panel; various 
rollouts will be displayed in the Modify panel. Most of the rollouts are same as those discussed 
in Chapter 11. The Daylight Parameters rollout is discussed next.  

Daylight Parameters Rollout
The options in this rollout are used to select the type of sunlight and

Figure 16-16  The Daylight 
Parameters rollout

 
the skylight used in the Daylight system, refer to Figure 16-16. The 
Active check box on the right of the Sunlight label is selected by 
default. It is used to turn on the sunlight in the viewport. You can 
select the light to be used as the sunlight from this drop-down list 
located below Sunlight label.

The Active check box on the right of the Skylight label is selected 
by default. It is used to turn on the skylight in the viewport. Select 
the option to be used as skylight from this drop-down list located 
below the Skylight label.
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In the Position area, the Date, Time and Location radio button is selected by default. It is used 
to set the time, date, and location of the Daylight system. Choose the Setup button; the Control 
Parameters rollout will be displayed in the Motion tab, where you can set the time, location, 
and other parameters of the Daylight system in this rollout. Select the Manual radio button in 
the Position area to manually set the position and intensity of the Daylight001 in the viewport. 
Select the Weather Data File radio button to derive the angle and intensity of the sun from a 
weather data (EPW) file.

Note
When you select required sunlight or skylight option from the drop-down list,  corresponding rollouts  
with options to modify the selected light will be displayed.

HIERARCHY AND KINEMATICS
The ability to link objects together to create a chain is known as hierarchy. When you create 
a complex computer animation then the hierarchy is the most important tool to simplify the 
animation process. In a hierarchy, the movement, rotation, or scaling of an object is controlled 
by another object. It creates a parent-child relationship that is very similar to a family tree. The 
object that is being controlled is known as the child object and the object that controls another 
object is known as the parent object. The parent object is controlled by a superior parent object, 
known as the ancestor object of the first child object. The child object that does not have any 
child is known as the leaf object. The parent object that is superior to all objects in a hierarchy 
is known as the root object.

When you create an animation by moving, rotating, or scaling the parent object, the 
transformations will automatically be transferred to its child objects. In this case, there is no 
need to create separate animation for the child objects. For example, if you have created a car 
model in which main body of the car is parent object while all other parts of the car are child 
objects, then transformation applied to main body of the car will automatically be transferred 
to all other parts of the car. 

A hierarchy is basically used to simplify a complex animation. With this feature, you can link a 
number of objects to a single object and transfer its animation to the linked objects. It is also very 
useful for creating the character animation. In 3ds Max, there are two methods for animating the 
forward kinematics (FK) and inverse kinematics (IK) hierarchies. These hierarchies are created 
by linking the objects. The inverse kinematics is more advanced than the forward kinematics. 
These kinematics are discussed next. 

Forward and Inverse Kinematics 
In forward kinematics, the child objects are animated based on the transformations in the 
parent object. It is a one-way system in which if a parent object moves, then the child objects 
will also move. But, if the child objects move, then the parent object will not be affected. In 
other words, you can control the top object of the hierarchy to animate the entire chain. While 
creating a hierarchy, the forward kinematics is created by default. The inverse kinematics (IK) 
is just opposite of the forward kinematics. In inverse kinematics, you can animate an object at 
the bottom of the hierarchy to control the entire chain. In this kinematics, if you move a child 
object, then the movement will be transferred to each ancestor in the hierarchy.             
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Creating a Hierarchy 
To create a hierarchy, you need to link the objects that will generate a chain. First, create 
the objects in the viewport that you need to link together. Then, decide which one of 
them will be the parent object and which one will be the child object. Next, select one 

of the child objects in the viewport and then choose the Select and Link tool from the Main 
Toolbar. Now, move the cursor over the child object; the cursor will get changed, refer to Figure 
16-17. Then, press and hold the left mouse button on the child object and drag the cursor to 
the parent object; a dotted line will be displayed between the child and parent objects, as shown 
in Figure 16-17. Next, release the left mouse button over the parent object; the parent object 
will blink for a second and will be linked to the child object. Next, choose the Select Object tool 
to exit the command. You can link more than one child objects to the parent object using the 
same procedure. Now, move the parent object in the viewport, 

To unlink the child object, select the child object in the viewport and then choose the  
Unlink Selection tool from the Main Toolbar.

Hierarchy Tab
The Hierarchy tab is used to modify hierarchical linkage between the objects. To do so, 
select a linkage from the hierarchical linkage in the viewport and choose the Hierarchy 
tab in the Command Panel. The Pivot button is chosen by default in the Hierarchy tab. 

As discussed in the earlier chapters, the options displayed on choosing the Pivot button are 
used to adjust the pivot point of the object. Choose the Link Info button in the Hierarchy tab; 
the Locks and Inherit rollouts will be displayed, as shown in Figure 16-18. 

Figure 16-17  The child object linked to the 
parent object using the Select and Link tool

Figure 16-18  The Link Info button  
chosen in the Hierarchy tab
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The options in the Locks rollout are used to lock the transformations of an object about any of its 
local axes. In the Locks rollout, there are three areas, Move, Rotate, and Scale. Each area has X, 
Y, and Z check boxes. To lock a transform, select the corresponding check boxes in these areas. 
The options in the Inherit rollout are used to control the transforms that the child objects 
inherit from the parent object. In this rollout, there are three areas, Move, Rotate, and Scale. 
Each area has X, Y, and Z check boxes. By default, all check boxes in each area are selected. 
As a result, the child object inherits all transforms on all axes. To restrict the child object to 
inherit the transformation of the parent object, first select the child object and then clear the 
corresponding check box from the respective area. 

Creating Bones System
  Command Panel:	 Create > Systems > Standard > Object Type rollout > Bones	

The bones system is created by linking the bones and joints in a hierarchy. You can animate 
and transform this hierarchy either using the forward kinematics or the inverse kinematics. 
However, animating the bones system using the inverse kinematics is easier. You can animate 
any type of  the characters as well as the machineries using the bones system. To create bones 
system, choose the Bones tool from Create > Systems > Standard > Object Type rollout in the 
Command Panel; the Name and Color, IK Chain Assignment, and Bone Parameters rollouts 
will be displayed. Next, click any of the viewport to create the base of the hierarchy. Now, move 
the cursor up or down to define the length of the bone and click in the viewport again to end 
the creation of the first bone. Similarly, start creating the second bone. Repeat the same process 
to continue the creation of hierarchy. Next, right-click in the viewport to exit the command; a 
hierarchy of bones will be created, as shown in Figure 16-19. When you right-click to exit the 
command, a small bone will be created at the end of the hierarchy. This small bone is used at 
the time of assigning an IK about which you will learn later in this chapter.

Figure 16-19  The hierarchy of bones created
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Note
When you create bones in the viewport, first bone will be the parent bone and others will be the 
child bones of the first bone. The bones created in continuation form a hierarchy of bones. Also, 
the bone created first will be at the top in the hierarchy and the bone created last will be at the 
bottom in the hierarchy. 

To modify the appearance of bone in the viewport, select the bone in the viewport and then 
choose the Modify tab in the Command Panel; the Bones Parameters rollout will be displayed. 
This rollout is discussed next.

Bones Parameters Rollout 
There are two areas in this rollout to modify the appearance of bones, refer to Figure 16-20. 
These areas are discussed next.

Bone Object Area
The Bone Object area comprises of some tools. Set the values in the Width and Height 
spinners to specify the width and height of the selected bone. Set the value in the Taper 
spinner to specify the taper amount of the bone in percentage.   

Bone Fins Area
The options in this area are used to add fins to the bones to increase

Figure 16-20  The Bone 
Parameters rollout

 
their thickness, refer to Figure 16-21. Fins help in improving the 
animation of bulky characters. Select the Side Fins, Front Fin, and 
Back Fin check boxes to add fins on the sides, front, and back of 
the bones, respectively. Set the values in the Size, Start Taper, and 
End Taper spinners to specify the size, start taper, and end taper 
values of the fins.  

Making the Bones Visible on Rendering
By default, the bones created in the viewport will not be visible at 
rendering. To make them visible, select the bones in the viewport 
and right-click on them; a quad menu will be displayed. Choose the 
Object Properties option; the Object Properties dialog box will be 
displayed. By default, the General tab is chosen in this dialog box. 
In the Rendering Control area, select the Renderable check box and 
then choose the OK button to exit the Object Properties dialog box; 
the bones will be visible at rendering. 

Modifying the Bones
Generally, the length of the bones is set while creating them in the 
viewport. After creating them, if you need to edit the length and other 
properties of the bones, then select the bone in the viewport. Choose Animation > Bone Tools 
from the menu bar; the Bone Tools dialog box will be displayed, as shown in Figure 16-22. The 
rollouts in this dialog box are discussed next.
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Figure 16-22  The Bone Tools 
dialog box

Figure 16-21  The bones with the fins added to 
them

Bone Editing Tools Rollout
The areas in this rollout are used to set the geometry and color of the selected bones. These 
areas are discussed next.

Bone Pivot Position Area
The Bone Edit Mode button in this area is used to edit the length and position of the bone 
in the viewport. To do so, choose the Bone Edit Mode button and then choose the Select 
and Move tool and move the bone along any axes in the viewport.

Bone Tools Area
The Bone Tools area consists of different buttons that are used to create, remove, delete, 
and refine the bones. Choose the Create Bones button from this area; the Bones tool in 
the Command Panel will be activated, which can be used to create a bone in the viewport. 
If you choose the Create End button, a small bone will be created at the end of the bone 
system. You can choose the Remove Bone button to remove the selected bone. When you 
remove a bone, its parent bone stretches to cover the pivot point of the removed bone. 
Choose the Connect Bones button to connect the selected bone to another bone in the 
viewport. Choose the Delete Bone button to delete the selected bone and also to remove its 
parent-child relationship. Choose the Reassign Root button; the selected bone will become 
the parent bone in the hierarchy. To split the selected bone, choose the Refine button and 
then select a bone in the viewport; the bone will split. Choose the Mirror button; the Bone 
Mirror dialog box will be displayed. Set the parameters in this dialog box and choose the 
OK button; the selected bone will be mirrored in the viewport.     

Bone Coloring Area
The options in this area are used to modify the color of the bone.
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Fin Adjustment Tools Rollout 
The options in the Fin Adjustment Tools rollout are used to modify the settings of the fins of 
the selected bones in the viewport. 

Object Properties Rollout
In this rollout, set the parameters for other objects to be used as bones in the viewport. First, 
select the hierarchy in the viewport and then expand the Object Properties rollout in the Bone 
Tools dialog box. Now, select the Bone On check box; the selected objects in the hierarchy will 
behave as bones.   

Understanding IK Solver, Interactive IK, and Applied IK
An IK Solver creates an inverse kinematic solution to rotate and position the links in a hierarchy. It 
applies an IK controller to each bone for controlling the motion of the child objects in a linkage. 
The hierarchy to which an IK solver is applied will be animated interactively. The behavior and 
controls on the linkage depend on the type of IK solver that you have selected. 

In an Interactive IK, the IK solution is applied only to the specified keyframes. To apply the 
Interactive IK, select the end of the hierarchy in the viewport and then choose the Hierarchy 
tab in the Command Panel. Next, choose the IK button in the Hierarchy tab and then choose 
the Interactive IK button in the Inverse Kinematics rollout. Next, apply the transforms to the 
bones in the system.  

The Applied IK is used to create the accurate motion in the hierarchy of linked objects. In this 
case, you need to bind the end of a hierarchy to the animated follow objects. After binding, select 
any object in your kinematic chain and choose the Apply IK button in the Inverse Kinematics 
rollout of the Hierarchy tab in the Command Panel; the IK solution will be calculated for each 
frame in the animation and it will create transform keys for every object in the IK chain.                

Creating a Bone Hierarchy with an IK Solver  
To create a bone system with an IK solver, choose the Bones tool from Create > Systems > 
Standard > Object Type rollout in the Command Panel; the Name and Color, IK Chain 
Assignment, and Bone Parameters rollouts will be displayed. In the IK

Figure 16-23  The IK 
Chain Assignment 
rollout

 
Chain Assignment rollout, select the required IK solver from the IK 
Solver drop-down list. Then, select the Assign To Children check box, 
refer to Figure 16-23. Next, create bones in the viewport as discussed 
earlier; the selected IK solver will automatically be applied to them. 

You can also apply the IK solvers after creating the hierarchy of the bones. 
To do so, select the bone in the hierarchy and then choose Animation > 
IK Solvers from the menu bar; a cascading menu will be displayed. Now, 
choose the required IK solver from the cascading menu and then select 
another bone in the hierarchy in the viewport to define the IK chain.
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Creating a Biped System     
 Command Panel:	 Create > Systems > Standard > Object Type rollout > Biped  

The Biped system is used to create a biped model that has a two-legged figure. It is used to animate 
the characters such as humans and animals. To create a biped system, choose the Biped tool 
from Create > Systems > Standard > Object Type rollout in the Command Panel; the Name 
and Color and Create Biped rollouts will be displayed. In the Top viewport, press and hold the 
left mouse button, and then drag the cursor to define the height of the biped model. Release the 
left mouse button; the biped model will be displayed in all viewports, as shown in Figure 16-24. 

Figure 16-24  The biped model displayed in viewports

Choose the Select by Name tool from the Main Toolbar to view the names of all bones in the 
biped system; the Select From Scene dialog box will be displayed. Make sure that the Display 
Bones button is chosen in the dialog box to display the names of the biped bones. Among all 
the bones in a biped system, the Bip001 bone is the root bone.

You can modify the biped parameters before creating the biped model using the Create  
Biped rollout displayed on invoking the Biped tool. However, to modify the biped 
model after creating it, select the Bip001 bone in the biped model. Choose the Motion 
tab in the Command Panel; various rollouts will be displayed. In the Biped rollout, choose the 
Figure Mode button; the Structure rollout will be displayed. Now, expand the Structure rollout 
to modify the parameters of the biped model. Most of the options in the Structure rollout are 
same as in the Create Biped rollout. The Create Biped rollout is discussed next.     

 Note
Before creating a biped model, you need to create a character mesh and then you need to put the 
biped model in it to animate the character mesh created.
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Create Biped Rollout
The options in this rollout are used to define the method of creation of a biped system. You can 
also modify the number of bones in different parts of the body using this rollout. The areas in 
this rollout are discussed next.

Creation Method Area
The radio buttons in this area are used to define the method of creation of the biped system. 
The Drag Height radio button is selected by default. It is used to create the biped system as 
discussed earlier. If you select the Drag Position radio button, then to create a biped system, 
you need to press and hold the left mouse button and move the mouse in the viewport to 
set the position of the biped model, and then release the left mouse button.

The text box in the Root Name area displays the name of the root bone that is superior to 
all parent bones. 

Body Type Area
The drop-down list in this area is used to select the type of body of the biped model. By 
default, the Skeleton option is selected in this drop-down list and it is used to create a 
skeleton in the viewport. Select the Male, Female, or Classic option from the drop-down 
list to create a biped model based on the character in the scene; the biped model will be 
created, as shown in Figure 16-25. Set the values in the Neck Links, Spine Links, and other 
spinners to set the number of bones in the biped model.    

Figure 16-25  The male, female, classic, and skeleton type 
biped models 

Note
Biped body parts cannot be removed but you can hide unwanted parts of the biped.
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TUTORIALS
Tutorial 1

In this tutorial, you will create an animated scene to study the shadow pattern according to the 
position of the sun over the earth at a particular location, date, and time. The shadow at one 
of the frames is shown in Figure 16-26. 		                      	       (Expected time: 30 min)

Figure 16-26  The shadow pattern in the 
scene

The following steps are required to complete this tutorial:

a.	 Create the project folder.	
b.	 Create a ground and a tree.
c.	 Create the camera.
d.	 Create the Sunlight system.
e.	 Animate the Sunlight system.
f.	 Save and render the scene. 
   
Creating the Project Folder
Create a new project folder with the name c16_tut1 at \Documents\3dsmax2022 and then save the 
file with the name c16tut1, as discussed in Tutorial 1 of Chapter 2.

Creating a Ground and a Tree
In this section, you will create the ground by using the Plane tool. 

1.	 Choose the Plane tool from Standard Primitives and create a plane in the Top viewport, 
as discussed earlier. 

2.	 Change the name of the plane to ground. Also, assign the grass material to it, as discussed 
in the earlier chapters.   

3.	 Choose the Foliage tool from Create > Geometry > AEC Extended in the Command Panel 
and create a tree in the Top viewport, as discussed earlier. Set the height of the tree according 
to ground. Align the tree at the center of the ground in all viewports, refer to Figure 16-27.
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Creating the Camera
In this section, you will create the camera in the scene by using the Free camera tool. 

1.	 Choose the Free tool from Create > Cameras > Standard > Object Type rollout in the 
Command Panel to create a free camera in the viewport. 

2.	 Create a Free camera in the Front viewport. The camera is automatically named as Camera001. 
Align the Camera001 in all viewports, refer to Figure 16-27.  

Figure 16-27  Alignment of the Camera001 in viewports 

	 You need to press the C key in the Perspective viewport to display the camera view. Adjust 
the camera view as per your requirements.

Creating the Sunlight System
In this section, you will create the Sunlight system by using the Sunlight tool. 

1.	 Choose the Zoom tool and zoom out the Top viewport to make room for creating the Sunlight 
system.	

2.	 Choose Create > Systems in the Command Panel; various tools are displayed in the Object 
Type rollout. Choose the Sunlight tool from the Object Type rollout.

3.	 In the Top viewport, press and hold the left mouse button at the center of the scene to specify 
the center of the Sunlight system and then drag the cursor to define the radius of the system. 
Now, release the left mouse button; a compass rose is created. Now, drag the cursor again 
and click in the viewport to set the distance of the light from the compass rose, as shown in 
Figure 16-28; the compass rose and the directional light are created in the viewports. Next, 
right-click in the viewport to exit the command.
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Figure 16-28  The Sunlight system created in viewports

	 The compass rose and the directional light are automatically named as Compass001 and 
Sun001, respectively.

4.	 Choose the Zoom Extents All tool to see the objects in every viewport.

Animating the Sunlight System
In this section, you will study the shadow pattern to change the position of Sun001 at different 
frames in the time slider.  

1.	 Choose the Time Configuration button from the timeline; the Time
Configuration dialog box is displayed. In the End Time spinner of the Animation 
area, set the value to 500. Now, choose the OK button; the total number of frames 
in the track bar is increased. 

2.	 Select Sun001 in any viewport and choose the Motion tab in the Command Panel; the 
Control Parameters rollout is displayed.	

	 By default, the Sunlight system is placed at the latitude of San Francisco, CA. Also, the sun 
is set at 12 hours. You can modify the location of the sun in the Location area by choosing 
the Get Location button.

	 Next, you need to change the position of Sun001 by modifying the time given in the Time 
area of the Control Parameters rollout.

3.	 Drag the time slider to frame 0. In the Time area of the Control Parameters rollout, set the 
value in the Hours spinner to 7 and press ENTER. 

4.	 Make sure that Sun001 is selected in the viewport. Choose the Toggle Auto Key Mode 
button to enter the animation mode; the track bar, the Toggle Auto Key Mode button, and 
the active viewport turn red.  
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5.	 Drag the time slider to frame 40, as shown in Figure 16-29. In the Time area of the 
Control Parameters rollout, set the value in the Hours spinner to 8; the arrows of the Hours, 
Mins., and Secs. spinners turn red.

Figure 16-29  The time slider at frame 40

6.	 Drag the time slider to frame 80. In the Time area of the Control Parameters rollout, set 
the value in the Hours spinner to 9.

7.	 Drag the time slider to 40-frames increments and increase the time in the Hours spinner by 
one hour at each increment. Continue this process until the value in the Hours spinner is 
set to 18. Note that, at this point, the last frame number should be 440.

8.	 Choose the Toggle Auto Key Mode button again to turn off the animation mode.

9.	 Choose the Play Animation button to view the effect of the Sunlight system in Camera 
viewport.

Saving and Rendering the Scene
In this section, you will save the scene and then render it. You can also view the final rendered 
image sequence by downloading the c16_3dsmax_2022_rndr.zip file from www.cadcim.com. The 
path of the file is as follows: Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds 
Max 2022: A Comprehensive Guide

1.	 Change the background color of the scene to blue, as discussed in earlier chapters.

2.	 Choose Save from the File menu.

3.	 For rendering the scene, refer to Tutorial 1 of Chapter 14. 
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	 After the completion of the rendering process, the final output of the animation is saved in 
the AVI format at the specified location. You can view the final output of the animation by 
opening the corresponding AVI file.  

Tutorial 2
In this tutorial, you will create the footsteps animation of a biped model. The footsteps animation 
at a frame is shown in Figure 16-30.                                                     (Expected time: 45 min)    	
  									            

Figure 16-30  The biped model animation

The following steps are required to complete this tutorial:

a.	 Create the project folder.	
b.	 Create a biped model.
c.	 Create the footsteps animation for the model.
d.	 Save and render the scene.

Creating the Project Folder
Create a new project folder with the name c16_tut2 at \Documents\3dsmax2022 and then save the 
file with the name c16tut2, as discussed in Tutorial 1 of Chapter 2.

Creating a Biped Model
In this section, you will create a biped model by using the Biped tool.

1.	 Activate the Top viewport. Then, choose the Biped tool from Create > Systems > Standard > 
Object Type rollout in the Command Panel; various rollouts are displayed. 

2.	 In the Create Biped rollout, select the Drag Position radio button in the Creation Method 
area and click at the center of the Top viewport; a biped model is displayed in all viewports.
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	 All bones in the biped model are named automatically. The Bip001 bone is the root bone 
in the hierarchy and is selected by default after the creation of the model.

  	
3.	 Choose the Zoom Extents All tool; the biped model is displayed in the viewports, as shown 

in Figure 16-31. 

Figure 16-31  The biped model displayed in viewports

Creating the Footsteps Animation for the Model
In this section, you will create the footsteps animation for the biped model. 

1.	 Make sure that Bip001 is selected in the viewport and choose the Motion tab in the Command 
Panel; various rollouts are displayed. 

2.	 Expand the Biped rollout and then choose the Footstep Mode button; the Footstep
Creation, Footstep Operations, and Dynamics & Adaptation rollouts are displayed, 
as shown in Figure 16-32. 

  
3.	 Choose the Zoom tool and zoom out the Top viewport until one-fourth of the original 

biped model is visible. Also, set the view of the Top viewport using the Pan tool, as shown 
in Figure 16-33.   

4.	 In the Footstep Creation rollout, make sure that the Walk button is chosen. 	        

5.	 Choose the Create Footsteps (at current frame) button in the Footstep Creation rollout and 
then move the cursor over the Top viewport; the shape of the cursor changes. Now, click in 
the Top viewport to create the footsteps, as shown in Figure 16-34. 
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6.	 Choose the Select and Move tool and align the footsteps in the

Figure 16-32  The rollouts 
displayed after choosing the
Footstep Mode button 

 
Top viewport, as shown in Figure 16-35. Also, rotate some of the 
footsteps by 45-degree in the clockwise direction, as shown in 
Figure 16-36. 

	 Next, you need to create keys for the animation of biped model.

7.	 In the Footstep Operations rollout, choose the Create Keys 
for Inactive Footsteps button; keys are created for the biped 
animation according to the footsteps. 

8.   Choose the Select Object tool and then choose the Zoom Extents 
All tool. 

9.	 Now, activate the Perspective viewport and choose the Play 
Animation button; the biped model starts moving according to 
the footsteps created, refer to Figure 16-37.

10.	 If you want to add more footsteps in the viewport, then choose 
the Select by Name tool; the Select From Scene dialog box is 
displayed. Now, select Bip001 bone and choose the OK button to close the dialog box.

Figure 16-33  The Top viewport after using 
the Zoom and Pan tools

Figure 16-34  The footsteps created in 
the Top viewport 

Figure 16-35  The footsteps aligned 
using the Select and Move tool

Figure 16-36  The footsteps after rotating them 
in the Top viewport

11.	 Choose the Motion tab in the Command Panel if not already chosen and then choose the 
Footstep Mode button in the Biped rollout.
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12.	 In the Footstep Creation rollout, make sure the Walk button is chosen and then  
choose the Create Footsteps (append) button. 

Figure 16-37  The biped model moving after choosing the Play Animation button

13.	 Move the cursor over the Top viewport; the shape of the cursor changes. Now, create 
additional footsteps in the Top viewport and align them as required, as shown in Figure 16-38. 

Figure 16-38  New footsteps created in the 
Top viewport

14.	 In the Footstep Operations rollout, choose the Create Keys for Inactive Footsteps button; 
keys are created for the biped animation according to the newly created footsteps. 

15. Choose the Select Object tool and then the Zoom Extents All tool. 

16.	 Activate the Perspective viewport and choose the Play Animation button; the biped model 
starts moving according to the newly created footsteps, as shown in Figure 16-39.



Systems, Hierarchy, and Kinematics		         16-25

Figure 16-39  The biped model moving according to the newly created footsteps

	 Next, you will create multiple footsteps automatically.

17.	 Now, you need to hide the biped model in the scene. To do so, press CTRL+A to select all 
bone objects in the scene and then CTRL+click on Bip001 footsteps in the Scene Explorer. 
Right click; a quad-menu is displayed. Select the Hide Selection option from the Quad 
menu. 

	 Next, create another biped model in the viewport, as discussed in the previous section and 
then choose the Zoom Extents All tool to view it in the viewports.

18.	 Expand the Biped rollout in the Motion panel, if it is not already expanded. Choose the 
Footstep Mode button in this rollout.

19.	 In the Footstep Creation rollout, choose the Run button.    
                                               		   
20.	 Choose the Create Multiple Footsteps button in the Footstep Creation rollout; the 

Create Multiple Footsteps: Run dialog box is displayed. 

21.	 In the General area of this dialog box, set the value 6 in the Number of Footsteps spinner 
to specify the number of footsteps and then choose the OK button. You can also set other 
parameters in the Create Multiple Footsteps: Run dialog box, as required.

	 Next, you need to create keys for the biped model.

22.	 In the Footstep Operations rollout, choose the Create Keys for Inactive Footsteps button; 
keys are created for the biped animation. 

23. Choose the Zoom Extents All tool. 
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24.	 Activate the Perspective viewport and choose the Play Animation button; the biped model 
starts running, as shown in Figure 16-40.

Figure 16-40  The running biped model in viewports

Note
When you create keys for the biped model, various keys are created automatically for each bone in the 
biped model. Therefore, you can modify the keys created for arms, legs, spine, and head according 
to the animation you want to create for the biped model. To do so, select a bone in the viewport; 
the keys created for the selected bone are displayed in the track bar. Now, choose the Toggle Auto 
Key Mode button and modify the bone using the transforms such as move, rotate, and scale on 
the keys in the track bar.  

	
25.	 Make sure that Bip002 bone of the biped model is selected in the viewport and the Motion 

tab is chosen in the Command Panel. 

26.	 Choose the Save File button in the Biped rollout; the Save As dialog box is  
displayed. Browse to the folder in which you want to save the file. Enter Run as the 
name of the animation file in the File name text box and make sure that the (*.BIP) 
option is selected in the Save as type drop-down list.

27.	 Choose the Save button; the animation of the biped model is saved with the name Run.bip 
at the specified location. Now, you can use the same biped animation for another scene.

	 Next, you will load the biped animation from the saved BIP file.

28.	 Hide Bip002 and unhide Bip001. Choose the Select by Name tool; the Select From Scene 
dialog box is displayed. Now, select Bip001 bone and choose the OK button to close the 
dialog box.
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29.	 Choose the Motion tab in the Command Panel. In the Biped rollout, choose the 
Load File button; the Open dialog box is displayed. Browse to the Run.bip file, 
select the file, and then choose the Open button; the animation saved in the Run.bip 
file is loaded into the biped model. 

30.	 Choose the Play Animation button; the biped model starts running, as shown in Figure 16-41. 

Figure 16-41  The Bip001 in running position after loading the Run.bip file

Saving and Rendering the Scene
In this section, you will save the scene and then render it. You can also view the final rendered 
image sequence by downloading the file c16_3dsmax_2022_rndr.zip from www.cadcim.com. The 
path of the file is as follows: Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds 
Max 2022: A Comprehensive Guide

1. 	 Change the background color of the scene to white, as discussed in Tutorial 1 of Chapter 2.

2.	 Choose Save from the File menu.

3.	 For rendering, refer to Tutorial 1 of Chapter 14.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter: 

1.	 Which of the following lights can be used as sunlight in the Daylight system? 

		  (a) IES Sun 	 			   (b) Free Spot 
		  (c) Omni 				    (d) IES Sky
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2.	 Which of the following lights is used as skylight in the Daylight system?

		  (a) IES Sky 	 			   (b) Target Spot
		  (c) Free Spot				    (d) Omni

3.	 Which of the following tools is used to create a bone system in Autodesk 3ds Max?

		  (a) Bones		  		  (b) Biped		
		  (c) Point		  		  (d) Dummy

4.	 Which of the following rollouts is used to modify the parameters of the Daylight system?
	
		  (a) Control Parameters			   (b) IK Chain Assignment
		  (c) Parameters		  		  (d) All of these

5.	 The Daylight system uses a combination of two lights, namely __________ and __________.

6.	 In __________ kinematics, you can animate the object at the bottom of the hierarchy to 
control the entire chain. 

7.	 To modify the parameters of the Ring Array system, you need to choose the __________ tab 
in the Command Panel. 

8.	 The Systems are used to combine objects, linkages, and controllers to create an object set 
that will have all these features. (T/F)	

9.	 A dummy object in the Ring Array system cannot be rendered. (T/F)

10.	 The ability to link objects together to create a chain is known as hierarchy. (T/F)

 Review Questions 
Answer the following questions:

1.	 Which of the following options is used to create an inverse kinematic solution to rotate and 
position the links in a hierarchy? 

		  (a) IK Solver	 			   (b) Interactive IK
		  (c) Applied IK				    (d) All of these

2.	 Which of the following options is used to create an inverse kinematic solution only for the 
specified keyframes?

		  (a) IK Solver		  		  (b) Interactive IK
		  (c) Applied IK				    (d) All of these
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3.	 Which of the following options is used to create an accurate motion in the hierarchy of linked 
objects? 

		  (a) IK Solver		  		  (b) Interactive IK
		  (c) Applied IK				    (d) All of these

4.	 Which of the following systems is used to create a hierarchical linkage of bones and joints?

		  (a) Biped system	 		  (b) Ring Array system
		  (c) Sunlight system			   (d) Daylight system

5.	 The __________ tab is used to modify the hierarchical linkage between the objects. 

6.	 You can animate and transform the hierarchy of bones using the __________ as well as the 
__________.

7.	 The options in the __________ rollout are used to set the fins of the selected bones  in the 
viewport. 

8.	 You cannot replace the boxes in a Ring Array system with other objects. (T/F)

9.	 You can generate the light effect using a Sunlight system according to the position of the 
sun over the earth at a particular location, date, and time. (T/F)

10.	 In forward kinematics, if a parent object moves, then the child objects will also move 
accordingly. (T/F)

EXERCISE
The rendered output of the scene used in the following exercise can be accessed by downloading 
the c16_3dsmax_2022_exr.zip file from www.cadcim.com. The path of the file is as follows: Textbooks > 
Animation and Visual Effects > 3ds Max > Autodesk 3ds Max 2022: A Comprehensive Guide

Exercise 1
Create an animated merry-go-round using the Ring Array system. The position of the swing at 
different frames is shown in Figures 16-42 through 16-44.              (Expected time: 25 min) 
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Figure 16-43  Model to be created in 
Exercise 1(view 2)

Figure 16-42  Model to be created in 
Exercise 1(view 1)

Figure 16-44  Model to be created in 
Exercise 1 (view 3)

Hints:

1.	 Create the merry-go-round using Extended Primitives. 

2.	 Link the parts of the merry-go-round with the dummy objects of the Ring Array system. 

3.	 Replace the boxes of the Ring Array system with the merry-go-round using the Curve Editor 
(Open) tool. 

4.	 Animate the dummy object accordingly. 

Answers to Self-Evaluation Test
1. a, 2. a, 3. a, 4. a, 5. sunlight, skylight, 6. inverse, 7. Motion, 8. T, 9. T, 10. T


