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Preface

Autodesk Revit 2022 for Structure

Autodesk Revit is a Building Information Modeling software developed by Autodesk. The
structural tools in Revit are primarily used in structural engineering and they help the users to
design structural models using both parametric 3D modeling and 2D drafting elements. The
Revit building information model comprises of a physical representation of a building which is
fully associated with analytical representation. The building information model in Revit can be
used for structural designing, production of drawings, coordination of the project, and also for
third party structural analysis application.

The Exploring Autodesk Revit 2022 for Structure textbook explains the concepts and principles
of Revit Structure through practical examples, tutorials, and exercises. This enables the users to
harness the power of BIM with Autodesk Revit for their specific use. In this textbook, the author
emphasizes on physical modeling, analytical modeling, rebar modeling, and quantity scheduling.
Also, this textbook covers the various stages involved in analyzing the model in Robot Structural
Analysis software. This textbook is specially meant for professionals and students in structural
engineering, civil engineering, and allied fields in the building industry.

In this textbook, special emphasis has been laid on the concepts of structural modeling, which
have been explained using relevant graphical examples and illustrations. The accompanying
tutorials and exercises, which relate to the real world projects, help you understand the usage
and abilities of the tools available in Autodesk Revit for Structure. Along with the main text,
the chapters have been punctuated with tips and notes to make various concepts clear, thereby
enabling you to create your own innovative projects.

As you go through this textbook, you will work on tutorials and exercises that can be used to
build a complete project. Each of these tutorials and exercises, though complete in themselves,
will be a step toward accomplishing the larger projects.

The main features of this textbook are as follows:

* Project-based Approach
The author has adopted a project-based approach and the learn-by-doing theme throughout
the textbook. This approach guides the users through the process of creating the designs
given in the tutorials.

* Real-World Designs as Projects
The author has used real-world building designs and architectural examples as projects in
this textbook so that the users can correlate them to the real-time designs.

* Tips and Notes
Additional information related to various topics is provided to the users in the form of tips
and notes.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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* Learning Objectives
The first page of every chapter summarizes the topics that are covered in that chapter.

* Self-Evaluation Test, Review Questions, and Exercises
The chapter ends with Self-Evaluation Test so that the users can assess their knowledge of
the chapter. The answers to Self-Evaluation Test are given at the end of the chapter. Also,
the Review Questions and Exercises are given at the end of the chapters and they can be
used by the instructors as test questions and exercises.

* Heavily Illustrated Text

The text in this book is heavily illustrated with about 200 line diagrams and screen capture
images.

Symbols Used in the Book

Note
/ The author has provided additional information to the users about the topic being
@ discussed in the form of notes.
Tip
O Special information and techniques are provided in the form of tips that help in
: increasing the efficiency of the users.
New
N This symbol indicates that the command or tool being discussed is new in the
Wem ‘\‘ current release of Autodesk Revit
Enhanced

5 2N This symbol indicates that the command or tool being discussed has been enhanced
%@w in this release.

Formatting Conventions Used in the Textbook

Please refer to the following list for the formatting conventions used in this textbook.

*  Names of tools, buttons, options, browser, Example: The Beam tool, the Modify button,
palette, panels, and tabs are written in the Structure panel, the Home tab, the
boldface. Properties palette, Project Browser, and so on.

* Names of dialog boxes, drop-downs, Example: The Options dialog box, the
drop-down lists, list boxes, areas, edit Column drop-down in the Structure panel of
boxes, check boxes, and radio buttons are the Structure tab, the Name edit box in the
written in boldface. Name dialog box, the Chain check box in the

Options Bar, and so on.

* Values entered in edit boxes are written Example: Enter 4’ in the Offset edit box.
in boldface.
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* Names of the files saved are italicized. Example: ¢c03_Industrial-Complex_tut2.rvt

Ribbon: Modify | (Elements / Components) > Modify > Move
Shortcut Keys: MV

*  When you select an element or a component, a contextual tab is displayed depending
upon the entity selected. In this textbook, this contextual tab is referred to as
Modify | (Elements / Components)

Naming Conventions Used in the Textbook

Tool
If you click on an item in a panel of the ribbon and a command is invoked to create/edit an
object or perform some action, then that item is termed as tool.

For example:
Beam tool, Structural Column tool, Isolated tool
Filled Region tool, Trim/Extend to Corner tool, Rotate tool

If you click on an item in a panel of the ribbon and a dialog box is invoked wherein you can set
the properties to create/edit an object, then that item is also termed as tool, refer to Figure 1.

For example:
Load Family tool, Beam tool, Wall tool
Structural Wall tool, Visibility/Graphics tool

m e e o= o ® . TS Autodesk Revit 2022 - Template2 - Floor Plan: AGround Floor-J

File Architecture  Structure  Steel  Precast Systems Inset  Annotate  Analyze  Massing &Site  Collaborate  View  Manage  Add-Ins
- o
Bnoh - (0 &) 0 A DI/J D‘ﬂ T R [@G
T . i i ® -
— & Ll k2 _ == 93 ]

= Slat - ‘&= & - - —. oo ol M —
Modi | + [ =
® ™ o @ wa B0 T g2x < 8§

Select = Properties  Clipboard Geometry Madify View  Measure  Create

Figure 1 Tools in the ribbon

Button

The item in a dialog box that has a 3d shape like a button is termed as button. For example,
OK button, Cancel button, Apply button, and so on. If the item in a ribbon is used to exit a tool
or a mode, it is also termed as button. For example, Modify button, Finish Edit Mode button,
Cancel Edit Mode button, and so on; refer to Figure 2.
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j Legend 1 [ A.Grour rowser - Template2
Press F1 for more help Floor Plans (Floor Plan
- AGround Floor-Gt

et
(el

Figure 2 Choosing the Finish Edit Mode button

Dialog Box
In this textbook, different terms are used for referring to the components of a dialog box. Refer
to Figure 3 for the terminology used.

Options X
; Tabs
General Configure
Tools and analyses:
User Interface th Area
Structure tab and tools ~
Graphics Steel tab and tools
Structural analysis and tools
Hardware Systems tab: mechanical tools
) Mechanical analysis tools Check box
File Locations Systems tab: electrical tools
Rend Electrical analysis tools
endenng Systems tab: piping tools
Check Spelling Piping analysis tools
Massing & Site tab and tools v
SteeringWheels
Keyboard Shortcuts: Customize... -1 Button
ViewCube
Double-click Options: Customize...
Macros
Tooltip assistance: | Normal —_— Drop-down

list
Enable Recent Files page at startup

Ribbon tab switching behavior
After clearing a selection or after exting...
Project Environment: | Return to the previous tab ~
Family Editor: | Stay on the Modify tab w

Display the contextual tab on selection

Visual experience
Active theme: |Light ~

[ use hardware graphics acceleration if available

Figure 3 The components of a dialog box
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Drop-down

A drop-down is one in which a set of common tools are grouped together for creating an
object or performing some action. You can identify a drop-down with a down arrow on it. These
drop-downs are given a name based on the tools grouped in them. For example, Wall drop-down,
Component drop-down, Region drop-down, and so on; refer to Figure 4.

ST Steel  Precast  Systems  Insert  Annotate  Analyze  Massing &5ite  Collaborate View  Manage  Add-Ins

Wall ~ [l Truss % & @ ) l H#E Area [ Fabric Sheet @ AN
o
Column Brace Path Cover I
% Connection Isolated Wall | Slab | Rebar “‘3 Component IL"
Floor - [[[] Beam System T B Fabric Area &1 Rebar Coupler T =1
Structure s Connection * s Foundatiq ht ~ Model
‘Q Structural Foundation: Slab
I
L5
X [ EGround | Jro =" - R 1
Structural Foundation: Slab
\ Adds a foundation slab to the building model.
1 (General) 7]
Foundation slabs da not require support from other structural
- elements. Use foundation slabs to model slabs on a grade or
Inar-General (Fine) | PR Edit Type [ S

Figure 4 Choosing a tool from the drop-down

Drop-down List

A drop-down list is the one in which a set of options are grouped together. You can set various
parameters using these options. You can identify a drop-down list with a down arrow on it. For
example, Type Selector drop-down list, Units drop-down list, and so on; refer to Figure 5.

Options

Options are the items that are available in shortcut menus, drop-down lists, dialog boxes,
drop-down lists, and so on. For example, choose the Zoom In Region option from the shortcut
menu displayed on right-clicking in the drawing area; refer to Figure 6.

Properties X

W Shapes-Column
W10X49

[search L

I Concrete-Rectangular-Column

12x18
[ 1sx2s
g
24 x 3 Concrete-Rectangular-Column
I W Sha Cancel
Repeat [Hide Elements]
WBX‘I Recent Commands >
L Flip Section
W10X Goto View
| W10X — Ratatrs —
[ rdeinvien[y 5 Eements
W12X Override Graphics in View > Category
— Create Similar By Filter...
W14X: BTy
| C Select Previous
- Select Al Instances >
Figure 5 Selecting an option from the Type Figure 6 Choosing an option from

Selector drop-down list the shortcut menu
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Free Companion Website

It has been our constant endeavor to provide you the best textbooks and services at affordable
price. In this endeavor, we have come out with a Free Companion website that will facilitate
the process of teaching and learning of Autodesk Revit 2022 for Structure. If you purchase this
textbook, you will get access to the files on the Companion website.

The resources available for the faculty and students in this website are as follows:

Faculty Resources
* Technical Support
You can get online technical support by contacting techsupport@cadcim.com.

* Instructor Guide
Solutions to all review questions and exercises in the textbook are provided in this guide to
help the faculty members test the skills of the students.

¢ Revit Files
The Revit files used in tutorials and exercises are available for free download.

Student Resources
* Technical Support
You can get online technical support by contacting techsupport@cadcim.com.

* Revit Files
The Revit files (.rvt) used in tutorials and examples are available for free download.

* Learning Resources
Additional learning resources at hitps://revitxperts.blogspot.com

Ifyou face any problem in accessing these files, please contact the publisher at sales@cadcim.com
or the author at stickoo@pnw.edu or tickoo525@gmail.com.

Video Courses

CADCIM offers video courses in CAD, CAE Simulation, BIM, Civil/GIS, and Animation domains
onvarious e-Learning/Video platforms. To enroll for the video courses, please visit the CADCIM
website using the following link: https://www.cadcim.com/video-courses.

Stay Connected

You can now stay connected with us through Facebook and Twitter to get the latest information
about our textbooks, videos, and teaching/learning resources. To stay informed of such updates,
follow us on Facebook (www.facebook.com/cadcim) and Twitter (@cadcimtech). You can also
subscribe to our You Tube channel (www.youtube.com/cadcimtech) to get the information about
our latest video tutorials.



