
Chapter 2

Drawing Sketches 
in the Sketcher 

Workbench-I
 Learning Objectives  
After completing this chapter, you will be able to:
• Understand the Sketcher workbench of CATIA V5-6R2020
• Start a new file in the Part workbench
• Invoke the Sketcher workbench
• Set up the Sketcher workbench
• Understand the terms used in the Sketcher workbench
• Draw sketches using the tools in the Sketcher workbench
• Use some of the drawing display tools
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THE SKETCHER WORKBENCH
Most components designed using CATIA V5-6R2020 are a combination of sketched features, 
placed features, and derived features. Placed features are created without drawing a sketch 
whereas sketched features require a sketch that defines its shape. Generally, the base feature of 
any design is a sketched feature. For example, refer to the solid model of a chain link shown in 
Figure 2-1. The base sketch to create this solid model is shown in Figure 2-2.

Figure 2-1  Solid model of the chain link Figure 2-2  Base sketch for the solid model

The Sketcher workbench provides the space and tools to draw the sketches of the solid model. 
Generally, the first sketch drawn to start the design is called the base sketch which is then 
converted into a base feature. However, once you get familiar with the advanced options of 
CATIA V5, you will also be able to use a derived feature or a derived part as the base feature. 
In this chapter, you will learn more about the sketching tools in the Sketcher workbench that 
are used for drawing and displaying the sketches.

To draw a sketch, invoke the Sketcher workbench by choosing the Sketch tool from the Sketcher 
toolbar. Next, select a plane to draw the sketch. Draw the sketch and proceed to the Part Design 
or Wireframe and Surface Design workbench to convert it into a solid model or a surface model.

STARTING A NEW FILE
When you start CATIA V5-6R2020, the initial interface of CATIA V5-6R2020 is displayed as 
shown in Figure 2-3. Start a new file in the Part Design workbench. 

Choose Part Design from Start > Mechanical Design; the New Part dialog box will be displayed, 
as shown in Figure 2-4. Enter part name in the Enter part name edit box and select the Enable 
hybrid design radio button if not selected by default. Choose the OK button; a Part Design 
workbench will be displayed. Alternatively, choose New from the File menu; the New dialog 
box will be displayed, as shown in Figure 2-5. Select Part from the List of Types list box in the 
New dialog box or write the word Part in the Selection edit box available in this dialog box.  
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Figure 2-3  Initial interface of CATIA V5-6R2020

Figure 2-5  The New dialog boxFigure 2-4  The New Part dialog box

Next, choose OK button; the New Part dialog box will be displayed. Enter the file name in the 
Enter part name edit box and choose the OK button; a new file in the Part Design workbench 
will be displayed on the screen, as shown in Figure 2-6. The standard tools like the Specification 
tree, Compass, and Geometry Axes will help you complete the design. The Specification tree is 
displayed on the top left corner of the screen. The Compass is displayed on the top right corner 
while the Geometry Axes is displayed on the bottom right corner of the screen.

If you select the Enable hybrid design check box in the New Part dialog box, you will be able 
to work in a hybrid design mode. In this design mode, part body includes solid, wireframe, 
and surface elements. The color of the PartBody node icon will be green in both hybrid and 
non-hybrid design modes. But, when both design modes are opened together, the color of the 
PartBody node icon will be displayed as green in the hybrid design mode and as gray in the 
non hybrid design mode. 
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	 Note
The color of the PartBody node icon will be gray only when the Enable hybrid design inside 
part bodies and bodies check box is selected in the Hybrid design area of the Part Document 
tab of the Part Infrastructure sub-node of the Infrastructure node in the Options dialog box.

 

Figure 2-6  A new file opened in the Part Design workbench

If you select the Create a geometrical set check box, you will be able to create a geometrical set 
as well as a new part. Geometrical set created with this option is located above the Part Body 
node in the specification tree.

If you select the Create an ordered geometrical set check box, you will able to create an ordered 
geometrical set as well as a new part. The ordered geometrical set created using this option are 
located under the PartBody node in the specification tree.

If you clear the Enable hybrid design check box from the New Part dialog box, the new file 
will start in the conventional design mode. 

Note
1. In this textbook, the hybrid design mode has been used. Therefore, it is recommended that you 
keep the Enable hybrid design check box selected whenever you start a new file.

2. You can hide the Compass, the Specification tree, or the Geometry Axis by using the View menu. 
By default, check marks are displayed on the left of Geometry, Specifications, and Compass in 
the menu bar indicating their display is turned on. Choose these options again to turn off their 
display. The display of these tools should be turned off only when the geometry area is too small to 
view the model, else it is recommended that you do not hide these standard tools. You can also use 
the F3 key to toggle the display of the Specification tree.
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INVOKING THE SKETCHER WORKBENCH
Sketch is the basic step to create the base feature of a solid 

Figure 2-7  The Sketcher sub-toolbar

model. In CATIA V5, a sketch is drawn in the Sketcher 
workbench. To invoke the Sketcher workbench, choose the 
down arrow on the lower right corner of the Sketcher 
toolbar; the Sketcher sub-toolbar will appear, as shown in 
Figure 2-7. The two buttons in the Sketcher sub-toolbar 
are Sketch and Positioned Sketch. The next section focuses 
on invoking the Sketcher workbench using these two 
buttons.

Invoking the Sketcher Workbench using the Sketch Tool
To invoke the Sketcher workbench using this method, choose the Sketch tool from the 
Sketcher sub-toolbar; you will be prompted to select a plane, a planar face, or a sketch. 
Select a plane from the three default planes in the Specification tree or from the geometry 

area; the Sketcher workbench will be invoked and the selected plane will be oriented parallel 
to the screen, refer to Figure 2-8. Also, you will be prompted to select an object or a command. 
The sketching components that are displayed in the geometry area are discussed later in this 
chapter. 

Figure 2-8  The Sketcher workbench invoked on selecting a plane as the sketching plane

	 Note
Remember once the Sketcher workbench is invoked, you will stay in the Select mode till you exit 
the Sketcher workbench. To exit, choose the Exit workbench  tool from the Workbench toolbar.   
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Invoking the Sketcher Workbench using the Positioned 
Sketch Tool

In CATIA V5, you can also create a user-defined absolute axis while invoking the Sketcher 
workbench by using the Positioned Sketch tool. To invoke the Sketcher workbench using 
this option, choose the Positioned Sketch tool from the Sketcher sub-toolbar; the Sketch 

Positioning dialog box will be displayed, as shown in Figure 2-9. Also, you will be prompted to 
select a plane, a planar face, a sketch, an axis system, or two lines. You can set the absolute axis 
by using the options in this dialog box. 

Figure 2-9  The Sketch Positioning 
dialog box

SETTING THE SKETCHER WORKBENCH
After invoking the Sketcher workbench, you need to set the workbench as per the sketching or 
drawing requirements. These requirements include modifying units, grid settings, and so on. 
The next section focuses on setting these parameters.

Modifying Units
To modify units, invoke the Options dialog box by choosing Options from the Tools menu. 
Next, click on the + sign on the left of the General option to expand the tree, if it is not already 
expanded. Choose the Parameters and Measure option; the tabs corresponding to this selection 
appear on the right in the Options dialog box. Next, choose the Units tab. The Options dialog 
box after choosing the Units tab is shown in Figure 2-10.

You can set the units for length, angle, time, mass, and so on, by using the options in the Units 
area. After specifying the value of the units, choose the OK button from the Options dialog box.
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Figure 2-10  The Options dialog box with the Units tab chosen

Modifying the Grid Settings
When you invoke the Sketcher workbench, two types of lines are displayed in the geometry 
area: one in the horizontal direction and the other in the vertical direction. These horizontal 
and vertical lines are continuous and dotted lines. The spacing between two continuous lines is 
called primary spacing and the spacing between two dotted lines is called graduation. The mesh 
that is formed due to the intersection of these lines in the horizontal and vertical directions is 
called grid. In other words, primary spacing and graduation define the grid.

By default, the value of the Graduations parameter is set to 10 in both horizontal and vertical 
directions. The default value of the Primary spacing parameter is 100mm. Though you can 
change the Primary spacing and Graduations values in the horizontal and vertical directions 
individually, yet it is recommended not to change them. If the values of Primary spacing or 
Graduations in the horizontal direction are different from those in the vertical direction, then 
the Grid will be distorted. To change the values of Primary spacing and Graduations, choose 
Options from the Tools menu; the Options dialog box will be displayed. Choose the Mechanical 
Design node from the tree on the left of the dialog box. Next, choose the Sketcher option to 
display the Sketcher tab on the right in the Options dialog box, refer to Figure 2-11. 
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Figure 2-11  The Options dialog box with the Sketcher option chosen

The edit boxes of Primary spacing and Graduations on the right of the H row are already 
enabled. Here, H refers to the horizontal direction. To enable the edit boxes of Primary spacing 
and Graduations under the V row, select the Allow Distortions check box. Here, V refers to 
the vertical direction. Next, enter the values in the edit boxes corresponding to the H and V 
directions and then choose the OK button; the newly formed Grid will be applied to the Sketcher 
workbench. Note, henceforth all the files that you open or start in the Sketcher workbench will 
use these values for Grid.

UNDERSTANDING SKETCHER TERMS
Before learning about the sketching tools, it is important for you to understand some of the 
terms used in the Sketcher workbench. These terms are discussed next.

Specification Tree
The Specification tree is a manager that keeps track of all operations performed on the model. 
When you invoke the Sketcher workbench, a new member or branch, Sketch.1, is added to the 
Specification tree under the PartBody node. Click on the + sign on the left of the PartBody to 
expand it; you can view the Sketch.1 member of the Specification tree. A + sign is associated with 
the Sketch.1 on the branch. Click on this sign once to further expand the branch. Figure 2-12 
shows the expanded Specification tree. 
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Figure 2-12  The expanded Specification tree 

Various levels under Sketch.1 in the Specification tree are discussed next.

AbsoluteAxis
In the Sketcher workbench, the default horizontal and vertical axes passing from the origin (0,0) 
to infinity are referred to as AbsoluteAxis. These axes will be highlighted in the geometry area, 
when AbsoluteAxis is selected from the Specification tree. Notice the + sign available on the 
left of AbsoluteAxis in the Specification tree. Click on this + sign once to expand the branch 
by one level. The levels associated with this branch are discussed next. 

Tip
While expanding the branch of the Specification tree, if the branch lines are accidentally clicked 
then the Specification tree will get activated. Consequently, the geometry area will be frozen. 
Now, zooming and panning will resize or reposition the Specification tree instead of the geometry 
view. The geometry area can be activated again by clicking on the branch line again or on the 
Geometry Axis available on the bottom right corner of the geometry area.

Origin
The Origin in the Sketcher workbench is the point where the absolute horizontal axis 
intersects the absolute vertical axis. The coordinates for Origin are (0,0). It is widely used 
while applying dimensional constraints to the sketches. You will learn more about dimensional 
constraints in later chapters.

HDirection
The direction parallel to horizontal axis is referred as HDirection and is mostly used to 
constrain a sketch. It is represented by H icon in the drawing window and displayed as 
HDirection in the Specification tree.
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VDirection
The direction parallel to vertical axis is referred to as VDirection and is mostly used to 
constrain a sketch.

The branches of the Specification tree will increase as the design process continues. You will 
learn more about the branches associated with the Specification tree in the Sketcher workbench 
while drawing and constraining sketches.

Grid
This option is used to display or hide the Graduations and Primary Spacing lines from 
the graphic area. To activate or deactivate it, choose the Grid button from the Visualization 
toolbar which appears only when you are in the Sketcher workbench.

Snap to Point
This option is used to snap to the point of intersection of the primary spacing and the 
graduation lines while sketching. By default, the snap mode is active. To activate or 
deactivate it, choose the Snap to Point button from the Sketch tools toolbar which appears 

only when you invoke the Sketcher workbench.

Construction/Standard Element
An element that is not a part of the profile while creating features and is used only as a 
reference or to constrain the elements of the sketch in the Sketcher workbench, is called 
a Construction element. This element can be used only in the Sketcher workbench. A 

Standard element is one that takes part in the feature creation. Depending on the requirement 
of the design, you can convert a standard element into a construction element or vice-versa 
using the Construction/Standard Element button. 

Select Toolbar
While drawing a sketch, you often need to select some elements. The tools 

Figure 2-13  The 
Select toolbar

required to make a selection are available in the Select toolbar, as shown in 
Figure 2-13. Various tools such as Select, Rectangle Selection Trap, and so on 
are available in this toolbar. By default, the Select tool is activated in the 
sketcher workbench unless any other tool or object is selected.

The tools in the Select toolbar can be invoked by choosing the down arrow on the lower-right of 
the Select toolbar. When you click on the down arrow, the Select sub-toolbar will be displayed, 
as shown in Figure 2-14. The methods of selecting an entity using the tools in the Select toolbar 
are discussed next.

Note
You can detach a sub-toolbar by dragging the vertical/horizontal line displayed at its top or its 
extreme left and placing it in the geometry area. On doing so, it will act as a toolbar. Therefore, 
in this textbook, the sub-toolbar will be referred by the name of the toolbar that will be obtained by 
detaching from the parent toolbar.
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Figure 2-14  The Select sub-toolbar

Select
This tool allows you to make a selection of the elements. As you move the arrow cursor 
near the element with the Select tool activated, the arrow cursor will be replaced with a 
hand cursor. Click on the element to select it.

Rectangle Selection Trap
This tool is used to select entities by creating a selection trap. A trap is a rectangular box 
drawn by dragging the mouse to define the diagonally opposite corners. All the objects 
that lie completely inside the selection trap are selected. This tool is active by default. If 

not, choose the Rectangle Selection Trap tool from the Select toolbar. Note that this method 
of selection will not allow you to start creating trap from the top of an entity.

Selection trap above Geometry
This tool works same as the Rectangle Selection Trap tool with the only difference that 
this tool allows you to start creating trap from the top of given sketched entity.

Intersecting Rectangle Selection Trap
The Intersecting Rectangle Selection Trap tool is similar to the Selection trap above 
Geometry tool. The difference between them is that this tool allows you to select elements 
of a sketch that are inside or are intersected by the trap. To create an intersecting trap, 

choose the Intersecting Rectangle Selection Trap tool from the Select toolbar. Next, specify 
the first corner and then drag the mouse to specify the second corner.
 
Polygon Selection Trap

This method includes selection of elements by drawing a closed polygon as the selection 
trap. You can select the elements of a sketch that are completely inside the polygon by 
using this method. To use this method, choose the Polygon Selection Trap tool from the 

Select toolbar and draw a closed polygon by specifying its adjacent corners. The polygon creation 
can be terminated by double-clicking in the geometry area.

Free Hand Selection Trap
This method includes selection of elements by dragging the mouse to draw a free sketch 
across them. The elements intersected by the free sketch are selected.
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Outside Rectangle Selection Trap
This method is used to select the elements that are outside the selection trap. The elements 
that are intersected by the trap are not selected.

Outside Intersecting Rectangle Selection Trap
The elements that are outside the selection trap or are intersected by the selection trap 
are selected by using this method.
 

Inferencing Lines
The inferencing lines are temporary lines that are used to track a particular point on the 
screen. When a sketching tool is selected in the sketcher environment, the inferencing lines 
are automatically displayed from the endpoints of the sketched elements or from the origin. 
Consider a case in which you want to draw a line such that its endpoint is tangent to the circle. 
Specify the start point of the line and then move the cursor in the direction tangent to the circle. 
You will note that the inference line is shown tangent to the existing circle. Next, specify the 
endpoint of the line. Figure 2-15 shows the use of the inferencing line to draw a tangent line. 
The inferencing lines are available only in the sketcher workbench.

Figure 2-15  Use of inferencing line to draw a tangent line

DRAWING SKETCHES USING SKETCHER TOOLS
The tools to draw the sketches in the Sketcher workbench are available in the Profile toolbar. 
Most of the tools have a down arrow indicating that they have some more tools. To access these 
tools, click on the arrow and choose them from the sub-toolbar. As mentioned earlier, the name 
of the sub-toolbar will be the name of the toolbar that will be obtained by detaching it from the 
parent toolbar. The procedure to draw sketches using the sketch tools is discussed next.

Drawing Lines
  Menubar: 	 Insert  > Profile > Line > Line	     
  Toolbar:  	 Profile > Line sub-toolbar > Line	   		     

The Line tool is one of the basic sketching tools in the Sketcher workbench. The general 
definition of a line is the shortest distance between two points. As CATIA V5 is parametric 
in nature, it allows user to first draw a line of any length at any angle and then change 
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it to the desired length and angle. To draw a line, choose the Line tool from the Profile toolbar. 
The methods to draw a line in CATIA V5 are discussed next. 

Drawing Lines by Specifying Points in the Geometry Area
To draw a line by specifying points in the geometry area, choose the Line tool from the Profile 
toolbar. You will observe that as you move the cursor in the geometry area, the coordinates 
corresponding to the current location of the cursor are displayed above it.

On invoking the Line tool, you will be prompted to select a point or click to locate the start 
point of the line. The prompt sequence will be displayed in the current information area of the 
status bar below the geometry area. Click anywhere in the geometry area to specify the start 
point of the line; you will be prompted to specify the endpoint. Move the cursor away from the 
start point. On doing so, a rubber band line will be attached to the cursor. Click anywhere in the 
geometry area to specify the endpoint of the line. Figure 2-16 shows the line drawn by selecting 
points from the geometry area. The orange color of the line indicates that it is selected. Click 
anywhere on the screen to end the selection mode. 

Figure 2-16  The line drawn by selecting its 
start and end points from the geometry area 

Note
A line in CATIA V5 consists of three geometric elements: start point, line segment, and endpoint. 
The start point and endpoint are construction elements while the line segment is a standard element.

Drawing Lines by Using the Sketch tools Toolbar
Lines can also be drawn using the Sketch tools toolbar, which expands when you invoke the Line 
tool. Figure 2-17 shows the Sketch tools toolbar after invoking the Line tool. The two methods 
to draw a line using the Sketch tools toolbar are discussed next.

Figure 2-17  The expanded Sketch tools toolbar displayed after invoking the Line tool



2-14	                                 CATIA V5-6R2020 for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Drawing Lines by Entering the Values of the Start and End Points
To draw a line using the start point and endpoint values, invoke the Line tool. On doing 
so, the Sketch tools toolbar will expand. In the H and V edit boxes, specify the horizontal 
and vertical coordinate values of the start point, respectively, and then press ENTER; you 
will be prompted to select the endpoint. Specify values in the H and V edit boxes and press 
ENTER again; a line will be drawn in the geometry area corresponding to the values entered 
in the start point and endpoint edit boxes. Also, the horizontal and vertical dimensions of 
the start point and endpoint with respect to the origin are displayed. On completion of the 
line, you will observe that the Sketch tools toolbar is compressed to its original size after 
the line is drawn. The color of the created line is orange indicating that it is selected. To 
end the selection mode, click anywhere in the geometry area. The line will appear green 
in color which means that it is fully constrained. You will learn more about constraints in 
the later chapters.

Similarly, you can draw a line by specifying the start point and by entering the length and 
angle values. The positive angular value is measured in counterclockwise direction with 
respect to the H axis and the negative angular value is measured in clockwise direction with 
respect to the H axis.

	 Note
As the Dimensional Constraints button is chosen in the Sketch tools toolbar, the specified 
dimension values for the start point and the endpoint will be displayed. Let these values remain 
in the geometry area. 

You will also notice that the color of the construction elements such as the start and endpoints of 
the line is gray. This suggests that the element is fully constrained. 

Drawing Lines with a Symmetrical Extension
To draw a line with a symmetrical extension, invoke the Line tool and choose the 
Symmetrical Extension tool from the expanded Sketch tools toolbar. When you 
draw the line using this option, its total length is double the distance you have moved 
while specifying the start point and the endpoint. 

In CATIA V5, a few more types of lines such as the infinite line, bisecting line, line normal to 
curve, and bi-tangent line can be drawn. To draw these lines, choose the down arrow on the 
right of the Line tool from the Profile toolbar; the Line sub-toolbar will appear, as shown in 
Figure 2-18. The types of lines that can be drawn using the tools available in the Line sub-toolbar 
are discussed next.

Figure 2-18  The Line sub-toolbar
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Tip 
The Grid button in the Visualization toolbar is used to toggle the display of the grid. 
While sketching, you can choose the Grid button any time to turn on or off the display 
of the grid.

Drawing Infinite Lines
  Menubar: 	 Insert > Profile > Line > Infinite Line	        
  Toolbar:  	 Profile > Line sub-toolbar > Infinite Line 	       

To draw an infinite line, invoke the Infinite Line tool from the Line sub-toolbar in the 
Profile toolbar; the Sketch tools toolbar will expand. You can draw a horizontal infinite 
line, vertical infinite line, and infinite line passing through any two points by using the 
options in this toolbar. 

Drawing Bi-Tangent Lines
  Menubar: 	 Insert > Profile > Line > Bi-Tangent Line		      
  Toolbar:  	 Profile > Line sub-toolbar > Bi-Tangent Line	    

A line that is tangent to any two curved entities is called bi-tangent lines. The curved 
entities can be circle, ellipse, arc, conic, and spline. You will learn more about these curved 
geometries later in this chapter. To draw a bi-tangent line, invoke the Bi-Tangent Line 

tool from the Line sub-toolbar in the Profile toolbar. Next, select the first curved geometry and 
then select the second curved geometry; a line will be drawn between the two selected curved 
elements. Also, the coincidence symbol will be displayed at the endpoints of the bi-tangent line. 
These are the coincidence constraints. You will learn more about these constraints in the later 
chapters.

Drawing Bisecting Lines
  Menubar:  	 Insert  > Profile > Line > Bisecting Line		     
  Toolbar:  	 Profile > Line sub-toolbar > Bisecting Line	   

A bisecting line passes through the intersection of two non-parallel lines, such that the 
angle formed between them is divided equally. The intersection point of the non-parallel 
lines can be actual or apparent obtained by extending the lines virtually. To draw a 
bisecting line, invoke the Bisecting Line tool from the Line sub-toolbar in the Profile 
toolbar. Select the first line and then select the second line; a bisecting line of infinite 
length will be drawn.

			 
Drawing Lines Normal to a Curve
  Menubar:  	 Insert > Profile > Line > Line Normal To Curve 	          
  Toolbar:  	 Profile > Line sub-toolbar > Line Normal To Curve	        

To draw a line normal to a curve, invoke the Line Normal To Curve tool from the Line 
sub-toolbar in the Profile toolbar; you will be prompted to select the curve. Specify the 
start point of the line anywhere on the periphery of the curve; you will be prompted to 

specify the other end point of the line. Click to specify the endpoint; a line normal to it will be 
drawn.
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Drawing Center Lines
  Menubar:	 Insert > Profile > Axis	         
  Toolbar: 	 Profile > Axis 		         

You can draw a center line in CATIA V5 using the Axis tool. Generally, this tool is used 
to create the axis for the revolved feature. You will learn more about the revolved features 
in the later chapters. To draw an axis, invoke the Axis tool from the Profile toolbar; the 

Sketch tools toolbar will expand and you will be prompted to specify the start point of the axis. 
Click in the geometry area to specify the start point; you will be prompted to specify the endpoint 
of the axis. Move the cursor and click to specify the endpoint; an axis with the specified points 
will be displayed in the geometry area, as shown in Figure 2-19. You can also draw an axis by 
entering the parameters in the respective edit boxes of the expanded Sketch tools toolbar. 

Drawing Rectangles, Oriented Rectangles, and 
Parallelograms
CATIA V5 provides some set of tools that help you draw predefined profiles faster. These tools 
are grouped together in the Predefined Profile sub-toolbar. To view this sub-toolbar, choose 
the arrow on the right of the Rectangle tool in the Profile toolbar; the Predefined Profile 
sub-toolbar will be displayed, as shown in Figure 2-20. The tools in this toolbar are Rectangle, 
Oriented Rectangle, Parallelogram, and so on. Some of these tools are discussed here and the 
remaining will be discussed in the next chapter.

Figure 2-19  An axis drawn in the geometry 
area

Figure 2-20  The Predefined Profile sub-toolbar

Drawing Rectangles
 Menubar:	 Insert > Profile > Predefined Profile > Rectangle	   	    
 Toolbar: 	 Profile > Predefined Profile sub-toolbar > Rectangle 	   

To draw a rectangle, invoke the Rectangle tool from the Predefined Profile sub-toolbar, 
refer to Figure 2-20; the Sketch tools toolbar will expand and you will be prompted to 
specify the first point for the rectangle. Click in the geometry area to specify the first 

point or the first corner of the rectangle; you will be prompted to specify the second point. Move 
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the cursor away from the first point in the geometry area; preview of the rectangle is displayed. 
Click to specify the diagonally opposite corner of the rectangle. You can also draw a rectangle 
by entering the values in the Sketch tools toolbar. On drawing a rectangle by using this method, 
you will notice that dimensions and constraints are applied to the resulting rectangle. You will 
learn more about dimensioning and constraining in the later chapters.

Drawing Oriented Rectangles
 Menubar:  	 Insert > Profile > Predefined Profile > Oriented Rectangle		     
 Toolbar:  	 Profile > Predefined Profile sub-toolbar > Oriented Rectangle 	    

To draw an oriented rectangle, invoke the Oriented Rectangle tool from the Predefined 
Profile sub-toolbar in the Profile toolbar; you will be prompted to specify the start point. 
Click in the geometry area to specify it; you will be prompted to specify the end point of 

the first side. Move the cursor away from the first point in any direction and specify the end 
point of the first side; you will be prompted to define the second side. The angle formed between 
the line and horizontal reference is called the orientation angle of the rectangle. 

Also, the symbol of the perpendicular constraint will be displayed between the lines. You will 
learn more about constraints in later chapters. Click in the geometry area to specify the third 
corner of the rectangle. Figure 2-21 shows the oriented rectangle being drawn.

Figure 2-21  Oriented rectangle being drawn by specifying the corner points

	 Note
You can also use the Sketch tools toolbar to enter the coordinate values for the first, second, and 
third corners in the respective edit boxes. To specify the orientation of the rectangle, enter the value 
of the orientation angle in the A edit box of the Sketch tools toolbar. Once you have specified the 
values, you need to press the ENTER key to accept them.

Drawing Parallelograms
  Menubar:	 Insert > Profile > Predefined Profile > Parallelogram	      
  Toolbar: 	 Profile > Predefined Profile sub-toolbar > Parallelogram	     

A parallelogram is a quadrilateral whose opposite sides are parallel to each other. To 
draw it, invoke the Parallelogram tool from the Predefined Profile sub-toolbar in the 
Profile toolbar; the Sketch tools toolbar will expand and you will be prompted to specify 
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the start point of the parallelogram. Click in the geometry area to specify its first corner; you 
will be prompted to specify the end point of its first side. On moving the cursor away from the 
first corner, you will notice a line attached to the cursor. The line represents the first side of the 
parallelogram. Click in the geometry area to specify the endpoint of the line; you will be then 
prompted to specify the second side. Move the cursor away from the second corner; preview of 
the parallelogram will be displayed. Click to specify the second side of the parallelogram; the 
parallelogram will be created, as shown in Figure 2-22. 

Note
In CATIA V5, you can use the Sketch tools toolbar to enter the coordinate values of the corner 
points of the parallelogram. You can also enter the values for width, angle, and height of the 
parallelograms in the respective edit boxes in the expanded Sketch tools toolbar.

Figure 2-22  A parallelogram created by specifying the corner points

Creating Points
A point is defined as the geometrical element that has no magnitude of length, width, 
or thickness. It is only specified by its position. In CATIA V5, you can create points by 
clicking in the geometry area or by specifying the coordinates. You can also locate an 

intersection point or project a point on an element. To invoke any of the tools for creating a 
point, choose the down arrow on the right of the Point tool in the Profile toolbar; the Point 
sub-toolbar will be displayed, as shown in Figure 2-23. The methods for creating points are 
discussed next.

Figure 2-23  The Point sub-toolbar
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Creating Points by Clicking
  Menubar: 	 Insert > Profile > Point > Point			       
  Toolbar: 	 Profile > Point sub-toolbar > Point by Clicking	    

To create points by clicking, invoke the Point by Clicking tool from the Point sub-toolbar 
in the Profile toolbar; the Sketch tools toolbar will expand and you will be prompted 
to click to create the point. Click anywhere in the geometry area to create the point. You 

can also enter the horizontal and vertical coordinate values in the H and V edit boxes of the 
Point Coordinates area displayed in the expanded Sketch tools toolbar. You can create points 
by defining their coordinates using the other options in the Point sub-toolbar.

Creating Points by using Coordinates
  Menubar: 	 Insert > Profile > Point > Point by Using Coordinates	     
  Toolbar: 	 Profile > Point sub-toolbar > Point by Using Coordinates	    

To create points by using coordinates, invoke the Point by

Figure 2-24  The Point Definition 
dialog box

Using Coordinates tool from the Point sub-toolbar in 
the Profile toolbar; the Point Definition dialog box will 

be  displayed, as shown in Figure 2-24. In this dialog box, you 
can use either cartesian (H and V) or polar coordinates to 
define a point. You can also select a previously created point 
as a reference for the point you want to create. On choosing 
the Cartesian tab, you need to specify H and V parameters or 
use the corresponding spinners. On choosing the Polar tab, 
you need to specify the values for Radius and Angle in the 
corresponding edit boxes.

Creating Equidistant Points
  Menubar: 	 Insert > Profile > Point > Equidistant Points	     
  Toolbar: 	 Profile > Point sub-toolbar > Equidistant Points	    

To create equidistant points on a line, curve, or between

Figure 2-25 The Equidistant 
Point Definition dialog box

 
two points, invoke the Equidistant Points tool from the 
Point sub-toolbar in the Profile toolbar; you will be 

prompted to select the origin point or a curve on which the 
points are to be created. Select the object; the Equidistant Point 
Definition dialog box will appear, as shown in Figure 2-25. 
Specify the number of  equidistant points to be created in the 
New Points spinner. If you select a line or a curve and then 
click on the extremity of that line or curve, the options in the 
Parameters drop-down will become available. You can select 
the Points & Length option from this drop-down. By using 
this option, you can specify the number of points and length 
in the New Points and Length spinners, respectively. If you 
select the Points & Spacing option, you can specify the number 
of points and spacing between the points in the New Points and Spacing spinners, respectively. 
If you choose the Spacing & Length option, you can specify the spacing and length for the 
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points. Choose the Reverse Direction button to reverse the direction of the points if required. 
Choose OK to create equidistant points, refer to Figure 2-26. 

Figure 2-26  The equidistant points created on the line

Creating Intersection Points
  Menubar: 	 Insert > Profile > Point > Intersection Point	     
  Toolbar: 	 Profile > Point sub-toolbar > Intersection Point	    

To create points at the intersection of the selected elements, invoke the Intersection Point 
tool from the Point sub-toolbar of the Profile toolbar. On doing so, you will be prompted 
to select the set of the elements to be intersected with another element. Select the set of 

the elements; the intersection points will be created on the intersection of the selected elements, 
as shown in Figure 2-27.

Figure 2-27  The intersection points created on the curve

Creating Projection Points
  Menubar: 	 Insert > Profile > Point > Projection Point	     
  Toolbar: 	 Profile > Point sub-toolbar > Projection Point	    

You can create one or more points by projecting points onto a curve element. To create 
projection points on a curve, select the points that are to be projected and choose the 
Projection Point tool from the Point sub-toolbar in the Profile toolbar; you will be 

prompted to select the element on which the selected points will be projected. Select the curve; 
the points will be projected automatically on it and construction lines representing the direction 
of the projection will also appear in the graphics area. The projection options available in the 
Sketch tools toolbar are discussed next.
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Orthogonal Projection

This option is selected by default. Select the points and then select the curve. All the 
selected points will be projected on the curve according to a normal direction on this curve, 
as shown in Figure 2-28.

Along a Direction

Choose the Along a Direction option from the Sketch tools toolbar. Select a point and 
then define the position of the point on the curve; the selected points will get projected 
along the given direction, as shown in Figure 2-29.

Figure 2-28  The projection points created 
using the Orthogonal Projection option

Figure 2-29  The projection points created 
using the Along a Direction option

Aligning Points
  Menubar: 	 Insert > Profile > Point > Align Points	     
  Toolbar: 	 Profile > Point sub-toolbar > Align Points	   

You can use this tool to align points in a particular direction. Choose the Align Points 
tool from the Point sub-toolbar in the Profile toolbar and select all the points that you 
want to align; a small arrow indicating the direction of alignment will be displayed at the 

origin point. The direction of this arrow will change with respect to the pointer position in the 
graphics area, refer to Figure 2-30.

By default, the Along a Direction button is chosen in the Sketch tools toolbar. If you want to 
change the origin point, choose the Change Origin Point button in the Sketch tools toolbar 
and select a point to make it the origin point. If you choose the Horizontal Alignment button 
then the points will be aligned horizontally. Similarly, choose the Vertical Alignment button to 
align the points vertically. In the Sketch tools toolbar, choose the Align along selected linear 
element  button and select the line; the points will be aligned along the direction of the selected 
line, as shown in Figure 2-31.
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Figure 2-30  The point alignment direction Figure 2-31  The points aligned along the line

Drawing Circles 
You can draw a circle in CATIA by defining its center and radius, by specifying three points on 
its periphery, by using coordinates or so on. All the tools to draw a circle in CATIA are grouped 
in the Circle sub-toolbar. To view the Circle sub-toolbar, choose the down arrow on the right 
of the Circle tool in the Profile toolbar; the Circle sub-toolbar will be displayed, as shown in 
Figure 2-32. The tools available in this sub-toolbar will help you to draw various types of circles 
and arcs. Different methods to draw circles and arcs are discussed next.

Figure 2-32  The Circle sub-toolbar

 

Drawing Circles using the Circle Tool
  Menubar: 	 Insert > Profile > Circle > Circle		    
  Toolbar: 	 Profile > Circle sub-toolbar > Circle	   

To draw a circle using this method, invoke the Circle tool from the Circle sub-toolbar; 
you will be prompted to specify its center. Click anywhere in the geometry area to specify 
the center point; you will be prompted to specify a point that determines the radius of 

the circle. Move the cursor away from the center point to specify the radius; preview of the circle 
will be displayed. Click in the geometry area to define its radius.

Note
You can also draw a circle by specifying the coordinates of its center point in the Circle Center 
edit box and the radius value in the R edit box of the expanded Sketch tools toolbar.
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Drawing a Three Point Circle
  Menubar: 	 Insert > Profile > Circle > Three Point Circle	     
  Toolbar: 	 Profile > Circle sub-toolbar > Three Point Circle	    

In CATIA V5, a circle can also be drawn by specifying any three points that will lie on its 
circumference. To draw a three point circle, invoke the Three Point Circle tool from the 
Circle sub-toolbar in the Profile toolbar; the Sketch tools toolbar will expand and you 

will be prompted to specify the start point of the circle. Click anywhere in the geometry area to 
specify the start point; you will be prompted to specify the second point through which the circle 
will pass. As you move the cursor away from the first point, a dotted line that originates from 
the first point and moves along with the cursor will be displayed. This is the chord of the circle. 
Click in the geometry area to specify the second point on the circle; you will be then prompted 
to specify the last point. As you move the cursor to specify the third point, preview of the circle 
will be displayed. Click to specify the third point to create the circle. 

Note
You can also enter radius value in the R edit box of the expanded Sketch tools toolbar. Remember 
that when you enter radius value, the other two points that lie on the circle should be specified 
within the reach of the radius value.

Drawing Circles using Coordinates
  Menubar:  	 Insert > Profile > Circle > Circle Using Coordinates	    
  Toolbar:  	 Profile > Circle sub-toolbar > Circle Using Coordinates	   

In CATIA V5, a circle can also be drawn by specifying the absolute coordinate values for 
the center and the radius. To do so, invoke the Circle Using Coordinates tool from the 
Circle sub-toolbar in the Profile toolbar; the Circle Definition dialog box will be 

displayed, as shown in Figure 2-33. You can specify the coordinate values of the center point 
and radius using the options in this dialog box.

Figure 2-33  The Circle Definition dialog box

Drawing Tri-Tangent Circles
  Menubar: 	 Insert > Profile > Circle > Tri-Tangent Circle	    
  Toolbar:	 Profile > Circle sub-toolbar > Tri-Tangent Circle	   

A tri-tangent circle is the one that is tangent to three sketched elements. The circle thus 
formed has a tangent relation with all the three elements. To draw it, you first need to 
draw three elements which can be lines, circles, ellipses, arcs, or any geometrical element 
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with which a circle can form a tangent relation. Next, invoke the Tri-Tangent Circle tool from 
the Circle sub-toolbar in the Profile toolbar and select the three elements one by one; a circle 
tangent to all these three elements will be displayed in the geometry area. Also, you will notice 
that some constraints are applied to the circle. You will learn more about them in the later 
chapters.

Note
The location of the elements to be selected for creating a tri-tangent circle is important because 
its creation depends on the orientation of these selected elements. Also, the tangents are created 
as close as possible to the point where you click to select the elements. In case the element has to 
be extended to fulfill the need of the tangent relation, CATIA V5 will form a circle tangent at an 
apparent intersection.

Drawing Arcs
An arc is a geometric element that forms a sector of a circle or ellipse. Each arc must include 
at least two points. The tools to draw arcs are available in the Circle sub-toolbar. In CATIA V5, 
there are three methods to draw arcs. These methods are discussed next.

Drawing Arcs by Defining the Center Point
  Menubar:  	 Insert > Profile > Circle > Arc	         
  Toolbar:  	 Profile > Circle sub-toolbar > Arc	       

To draw an arc by defining its center point, invoke the Arc tool from the Circle 
sub-toolbar in the Profile toolbar; you will be prompted to specify the center point. Click 
to specify the arc center; you will be prompted to define the radius and start point of the 

arc. Move the cursor away from the center point; the preview of the circle is displayed in the 
geometry area. Click to specify the start point of the arc; you will be then prompted to specify 
the endpoint of the arc. As you move the cursor, preview of the arc is displayed, as shown in 
Figure 2-34. Click in the geometry area to specify the endpoint.

Figure 2-34  An arc drawn by defining its center point 
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Drawing Three Point Arcs
  Menubar:	 Insert > Profile > Circle > Three Point Arc	    
  Toolbar:  	 Profile > Circle sub-toolbar > Three Point Arc	   

To draw a three point arc, choose the Three Point Arc tool from the Circle sub-toolbar 
in the Profile toolbar; you will be prompted to specify the start point of the arc. Click 
anywhere in the geometry area to specify the start point; you will be prompted to select 

the second point through which the arc will pass. As you move the cursor away from the first 
point, a dotted chord will be displayed. Click to specify the second point; you will be prompted 
to specify the endpoint of the arc. As you move the cursor away to specify this point, the preview 
of the arc is displayed. Click in the geometry area to specify the endpoint. Figure 2-35 shows  
first, second, and third points being selected to draw a three point arc.
 

Figure 2-35  Selecting points to draw a three point arc

Drawing Three Point Arc Starting with Limits
  Menubar:  	 Insert > Profile > Circle > Three Point Arc Starting With Limits	    
  Toolbar:  	 Profile > Circle sub-toolbar > Three Point Arc Starting With Limits	   

While drawing a three point arc starting with limits, you can first specify the start point 
and the endpoint of the arc and then the third point anywhere on it. To draw this arc, 
invoke the Three Point Arc Starting With Limits tool from the Circle sub-toolbar in the 

Profile toolbar; you will be prompted to specify the start point of the arc. Click in the geometry 
area to specify the start point; you will be prompted to specify the endpoint of the arc. Move 
the cursor away from the start point and click to specify the endpoint; you will be prompted to 
specify the second point through which the arc will pass. As you move the cursor to specify this 
point, the preview of the arc will be displayed. Click to specify the point on the arc. Figure 2-36 
shows the selection of first, second, and third points to draw an arc using this option.
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Figure 2-36  Selecting points to draw an arc using the Three Point 
Arc Starting With Limits tool

Drawing Profiles
  Menubar:	 Insert > Profile > Profile	         
  Toolbar:  	 Profile > Profile		          

In CATIA V5, a profile is defined as a combination of continuous lines and arcs. Drawing 
a continuous line means that the line automatically starts at the endpoint of the previous 
line. A profile can be an open or a closed contour. To draw the profile, invoke the Profile 

tool from the Profile toolbar; the Sketch tools toolbar will expand and the Line tool will be 
chosen in it. Also, you will be prompted to select the start point of the profile. 

Click anywhere in the geometry area to specify the start point. Next, move the cursor away from 
the first point; a rubber-band line will get attached to the cursor with its first point fixed to the 
point you had specified. Click anywhere in the geometry area to specify the endpoint of the line 
or the second point of the profile. Move the cursor away from the second point to draw the second 
line that is in continuation with the first line. You will notice that the second line originates from 
the endpoint of the first line. Click anywhere in the geometry area to specify the endpoint of 
the second line or the third point of the profile. To exit the Profile tool after drawing an open 
profile, choose the Profile tool again. If you draw a closed profile, you do not need to exit the 
Profile tool by choosing the Profile tool from the Profile toolbar. The tool will be automatically 
terminated when you specify the point to close the profile. Figure 2-37 shows an open profile.

You will notice that the expanded Sketch tools toolbar has three buttons: Line, Tangent Arc, and 
Three Point Arc, as shown in Figure 2-38. When you invoke the Profile tool, the Line button 
will be chosen by default. The profile that you have been drawing so far, using the Profile tool, 
is a combination of continuous lines. The process to draw an arc in continuation with the line 
using the Profile tool is discussed next.
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Figure 2-37  An open profile drawn using the Profile tool

Figure 2-38  The Sketch tools toolbar displayed on selecting the Profile tool

Drawing a Tangent Arc using the Profile Tool
To draw a tangent arc in continuation with the line, invoke the Profile tool from the Profile 
toolbar. You will notice that the Tangent Arc button is disabled. This is because you first need to 
draw at least one line. After drawing the line, the Tangent Arc button will get enabled. Choose 
the Tangent Arc button from the expanded Sketch tools toolbar; the preview of the arc will be 
displayed in the geometry area and you will be prompted to specify the endpoint of the arc. Click 
in the geometry area to specify the endpoint, an arc and tangent to the line will be drawn and 
displayed in the geometry area. Figure 2-39 shows a tangent arc being drawn using the Profile 
tool. After drawing the arc, the Line tool will again be chosen in the Sketch tools toolbar and 
you will be prompted to specify the endpoint of the current line.

Alternatively, you can invoke the Profile tool and specify the start and end points of the line 
segment. While specifying the end point, hold and drag the left mouse button; an orange color 
rectangle gets attached to the cursor. Release the left mouse button; a tangent arc to the line 
will get drawn.
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Figure 2-39  A tangent arc being drawn using the Profile tool

Drawing Three Point Arcs using the Profile Tool
To draw a three point arc using the Profile tool, invoke this tool from the Profile toolbar. You 
will notice the Three Point Arc button available in the Sketch tools toolbar. Draw a line using 
the Profile tool. Now, instead of specifying the third point of the profile, choose the Three Point 
Arc button from the expanded Sketch tools toolbar; you will be prompted to specify the second 
point of the arc. Remember that the first point of the three point arc is the endpoint of the line 
you have drawn. Click in the geometry area to specify the second point of the arc; you will be 
prompted to specify the last point. Move the cursor and click to specify it; the three point arc 
will be displayed in the geometry area. Also, the Profile tool will be still active and you will be 
prompted to specify the endpoint of the current line. You can choose the Profile tool again to 
exit the Profile tool or continue with the tool by specifying more points in the geometry area.

DRAWING DISPLAY TOOLS
The drawing display tools for viewing drawing elements or geometries are available in the View 
toolbar as shown in Figure 2-40. The basic tools such as Fly Mode, Fit All In, Pan, Zoom In, 
Zoom Out, Zoom Area, Rotate, Normal View, and Hide/Show are discussed next. You will learn 
about the remaining tools in the later chapters. 

Figure 2-40  The View toolbar
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Fly Mode
 Toolbar:	 View > Fly Mode       

The Fly Mode tool is used to view sketched elements in flying mode. On choosing this 
button, you will enter into the mode and notice that five new buttons are added to this 
toolbar namely, Examine Mode, Turn Head, Fly, Accelerate, and Decelerate.

On choosing the Fly button and by clicking the left mouse button in the graphics window, you 
will begin to fly forward in the chosen direction. Dragging the mouse in left, right, top, and 
down direction while holding the left button changes the direction accordingly. The Accelerate 
and Decelerate buttons are used to increase and decrease the flying speed and the Examine 
Mode button is used to exit the fly mode.

Note
When you switch to fly mode, the Parallel view changes into the Perspective view. To switch back 
to the Parallel view, choose View > Render Style > Parallel. 

Fit All In
  Menubar:	 View > Fit All In	          
  Toolbar:  	 View > Fit All In	         

The Fit All In tool is used to display all sketched elements or geometries in the visible 
space. Note, if a drawing consists of dimensions that are beyond the visible space, invoking 
this tool will also include them in the visible space. You will learn more about dimensions 
in the later chapters.

Pan
  Menubar:	 View > Pan	     
  Toolbar:  	 View > Pan 	    

The Pan tool is used to drag the current view in the geometry area. This option is generally 
used to display the elements or part of the elements that are outside the geometry area 
without actually changing the magnification of the current drawing. This is similar to 
holding a portion of the sketch and dragging it across the geometry area.

Zoom In
  Menubar:	 View > Modify > Zoom In	  
  Toolbar:  	 View > Zoom In		             

The Zoom In tool is used to zoom in the sketches in increments. Choose this button once 
to zoom in the sketch. 
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Zoom Out
  Menubar:  	 View > Modify > Zoom Out	  
  Toolbar: 	 View > Zoom Out		

The Zoom Out tool is used to zoom out of the sketch in increments. Choose this button 
once from the View toolbar to zoom out of the sketch. 

Tip
You can also dynamically zoom in or zoom out an entity by selecting the Zoom In Out option 
from the View menu. To zoom in using this option, press and hold the left mouse button and 
then drag the mouse upward. To zoom out of the sketches, press and hold the left mouse button 
and then drag the mouse downward. The tool is automatically terminated once you release 
the mouse button.

Zoom Area
  Menubar:	  View > Zoom Area	

The Zoom Area tool is used to define an area which is to be magnified and viewed in the available 
geometry area. The area is defined using the two diagonal points of a rectangular box in the 
geometry area. Choose the Zoom Area option from the View menu and press and hold the left 
mouse button to specify the first corner point. Then, drag the mouse to specify the other corner 
point of the box. The area that is enclosed inside the window will be magnified and displayed.

Normal View
  Menubar:  	 View > Modify > Normal View	     
  Toolbar: 	 View > Normal View		     

The Normal View tool is used to orient the view normal to the view direction. If, the 
current view is already normal to the view direction and you choose the Normal View 
button from the View toolbar; the viewing plane will be reversed. In other words, on 

choosing this button, if  the front plane is the current viewing plane; the back plane will become 
active for viewing. 

Note
1. By default, whenever you invoke the Sketcher workbench without defining any particular 
orientation, the positive horizontal reference direction will point toward the right of the geometry 
area and also towards its upper area. If you choose the Normal View button, the direction of 
the horizontal reference will be reversed by 180-degree. This means that the positive horizontal 
reference direction will point toward the left of the geometry area. Note that the vertical reference 
direction remains unchanged.

2. While working in the Sketcher workbench, you can choose the Normal View button to orient 
the sketch normal to the sketching plane. 
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Create Multi View
  Toolbar:  	 View > Create Multi-View	   

The Create Multi-View tool is used to split the geometry area into four viewports. These 
viewports can be used to display different views of the model. To restore the single 
viewport configuration, choose this tool again.

Hide/Show Geometric Elements
  Menubar:	 View > Hide/Show > Hide/Show	        
  Toolbar:  	 View > Hide/Show		        

The Hide/Show tool is used to hide sketcher elements or geometric elements from the 
current display. To do so, invoke this tool by choosing the Hide/Show button from the 
View toolbar; you will be prompted to select an element. Click on the element to be 
hidden from the geometry area. You will notice that the selected element is no longer 
visible. 

Swap Visible Space
The hidden elements are stored in a space different from the current display space. To 
view the space where the hidden elements are stored, invoke the Swap visible space tool 
from the View toolbar; you will notice that the background of the current geometry area 

changes to green and only the hidden elements are visible. Invoke the Hide/Show tool and 
select the hidden elements to be redisplayed in the visible space. To return to the geometry area, 
choose the Swap visible space button again. Note that when you hide an element, only its display 
is turned off, but it still participates in the feature creation.

Tip
If you draw a sketch in the space containing the hidden elements, it will not be visible there. 
It will only be displayed after you return to the visible geometry area.

TUTORIALS
Tutorial 1

In this tutorial, you will draw the sketch of the model shown in Figure 2-41. The sketch of the 
model is shown in Figure 2-42. Do not dimension the sketch. The solid model and its dimensions 
are shown for your reference only.                                		        (Expected time: 20 min)
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Figure 2-41  The solid model for Tutorial 1 Figure 2-42  The sketch for the solid model

The following steps are required to complete this tutorial:

a.	 Start CATIA V5 and then start a new Part file.
b.	 Draw the sketch of the model using the Profile and Circle tools.	
c.	 Save the sketch and close the file.

Starting a New Part File
1. 	 Start CATIA V5 by double-clicking on the shortcut icon of CATIA V5-6R2020 on the desktop 

of your computer; a new file, Product1 is started.

2.	 Next, choose Start > Mechanical Design > Part Design from

Figure 2-43  The New Part 
dialog box

 
the menu bar; the New Part dialog box is displayed, as shown 
in Figure 2-43.

3.	 Enter C02_Tut1 as the name of the file in the Enter part name 
edit box.

4.	 Select the Enable hybrid design check box from the New Part 
dialog box if not selected.

5.	 Choose the OK button; a new file in the Part Design workbench 
is started.

6.	 Choose the Sketch tool from the Sketcher toolbar and then select the yz plane from the 
Specification tree as the sketching plane; the Sketcher workbench screen is displayed, as 
shown in Figure 2-44.
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Figure 2-44  The Sketcher workbench screen 

	 In this tutorial, you need to draw the sketch in two parts: first draw the outer loop and 
second draw the inner circle in the Sketcher workbench. 

Drawing the Outer Loop of the Sketch
	 In this section, you need to draw the outer loop of the sketch using the Profile tool. In the 

sketch, the lower left corner of the sketch will be coincident with the origin. The resulting 
sketch will be in the first quadrant.

1.	 Choose the Profile tool from the Profile toolbar.	
			           
2.	 Choose the Snap to Point button from the Sketch tools toolbar if not chosen.

3.	 Move the cursor to the location whose coordinates are (0, 0) (at the origin) and click to 
specify the start point of the line. Note that the coordinates of the point are displayed on 
the cursor.

4.	 Move the cursor horizontally toward right, the line turns blue. Click to specify the endpoint 
of the line where the coordinates are 120,0.

	
Note
The constraints that get automatically applied to the sketch drawn will be explained in the later 
chapters. 

5.	 Move the cursor vertically upward and click to specify the endpoint of the line when the 
value of the coordinates is 120,10.

6.	 Move the cursor horizontally toward the left and click to specify the endpoint of the line 
when the value of the coordinates is 90,10.
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7.	 Move the cursor vertically upward and click to specify the endpoint of the line when the 
value of the coordinates is 90,30.

	 After drawing these four lines, you need to draw a tangent arc using the Tangent Arc tool.

8.	 Choose the Tangent Arc tool from the Sketch tools toolbar to switch to the Tangent 
Arc mode.

	
Note
If the Sketch tools toolbar is not displayed in the graphics area then right-click on any of the 
available toolbars and select the Sketch tools from the shortcut menu displayed, the Sketch tools 
toolbar will become available in the graphics area.

9.	 Move the cursor to the location whose coordinates are 30, 30 and specify the endpoint of 
the tangent arc at that location. Note that, after specifying the endpoint of the tangent arc, 
the Line mode is activated and a line is attached to the cursor again.

Note
While drawing an arc, you will notice that the inferencing lines are displayed in the geometry area. 
These lines indicate the relations that they can have with other entities.

10.	 Move the cursor vertically downward and click to specify the endpoint of the line when the 
value of the coordinates is 30,10.

11.	 Move the cursor horizontally toward the left and click to specify the endpoint of the line 
when the value of the coordinates is 0,10.

12.	 Move the cursor vertically downward and click to specify the endpoint of the line such that 
the endpoint is coincident to the start point of the first line.

	 The sketch after drawing the outer loop is shown in Figure 2-45. In this figure, the constraints 
are hidden for better visualization.

Figure 2-45  The sketch after drawing the outer loop

Drawing the Inner Loop of the Sketch
	 The inner loop of the sketch consists of a circle. You need to draw the circle using the Circle 

tool such that it is concentric to the arc of the outer loop. 
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1.	 Choose the Circle button from the Profile toolbar.

2.	 Move the cursor to the center point of the circular arc and click to specify the center point 
of the circle.

3.	 Enter 15 as the radius value of the circle in the R edit box provided in the Sketch tools 
toolbar and press ENTER.

	 The final sketch after drawing the inner loop is shown in Figure 2-46. Note that in this 
figure, the display of constraints is turned on.

Figure 2-46  The final sketch for Tutorial 1

Saving the Sketch
After completing the sketch, you need to save it.  

1.	 Choose the Save button from the Standard toolbar to invoke the Save As dialog box. Using 
this dialog box, create a folder named CATIA inside the C: drive. Then create the folder 
c02 inside the CATIA folder.

2.	 Next, choose the Save button; the file is saved at C:\CATIA\c02.

3.    Close the part file by choosing File > Close from the menu bar.

Tutorial 2
In this tutorial, you will draw the sketch of the model shown in Figure 2-47. The sketch is shown 
in Figure 2-48. Do not dimension the sketch. The solid model and its dimensions are shown for 
your reference only.				       	                      (Expected time: 20 min)
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Figure 2-47  The solid model for Tutorial 2 Figure 2-48  The sketch for the solid model

	 The following steps are required to complete this tutorial:

a.	 Start a new Part file.
b.	 Draw the sketch of the model using the Rectangle, Profile, and Circle tools.
c.    Save the sketch and close the file.

Starting a New Part File
	 If you are starting a new session of CATIA, close the default Product file.

1.	 Choose File > New from the menu bar; the New dialog  box is displayed, as shown in 
Figure 2-49. Alternatively, choose the New tool from the Standard toolbar to invoke the 
New dialog box.

2.	 In this dialog box, select Part from the List of Types list box

Figure 2-49  The New dialog box

 
and then choose the OK button; the New Part dialog box 
is displayed. 

3.	 Enter c02tut2 as the name of the file in the Enter part 
name edit box and choose the OK button from the New 
Part dialog box; the new Part file opens in the Part Design 
workbench.

4.	 Choose the Sketch tool from the Sketcher toolbar and 
then select the yz plane from the Specification tree as the 
sketching plane; the Sketcher workbench is invoked.

	 In this tutorial, you need to draw the sketch in two parts. 
Initially, you need to draw the outer loop of the sketch, a rectangle, and then the inner 
loops of the sketch, which consist of four circular holes and an elongated hole. First, draw 
an elongated hole using the Profile tool and then the four holes using the Circle tool.
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Drawing the Outer Loop of the Sketch
	 In this section, you need to draw the outer loop of the sketch using the Rectangle tool.

1.	 Choose the Rectangle tool from the Profile toolbar.				       

2.	 Move the cursor to the location whose coordinates are -60,-50 and click to specify the lower 
left corner of the rectangle.

3.	 Move the cursor to the location whose coordinates are 60,50 and click to specify the upper 
right corner of the rectangle. Figure 2-50 shows the outer loop of the sketch drawn using 
the Rectangle tool.

Figure 2-50  The outer loop of the sketch

Drawing the Inner Loop of the Sketch
	 After drawing the outer loop of the sketch, Now, you need to draw its inner loop. 

1.	 Choose the Profile tool from the Profile toolbar.

2.	 Move the cursor to the location whose coordinates are -30,10 and click to specify this point 
as the start point of the line.

3.	 Move the cursor horizontally toward the right and click to specify the endpoint of the line 
where the coordinates are 30,10.

	 Next, you need to draw a tangent arc by switching over to the Tangent Arc option  
using the Sketch tools toolbar.

4.	 Choose the Tangent Arc tool from the Sketch tools toolbar to switch over to the Tangent 
Arc mode.

5.	 Move the cursor to the location whose coordinates are 30,-10 and click to specify this point 
as the endpoint of the tangent arc.
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	 Note that after specifying the endpoint of the tangent arc, the Line mode is activated and 
the line is attached to the cursor again.

6.	 Move the cursor to the location whose coordinates are -30,-10 and click to specify the 
endpoint of the line.

7.	 Choose the Tangent Arc tool from the Sketch tools toolbar to switch to the Tangent Arc 
mode.

8.	 Move the cursor to the start point of the first horizontal line and then click to specify the 
endpoint of the arc when it snaps to the start point.

	 The sketch of the elongated hole is shown in Figure 2-51. In this figure, the constraints are 
hidden for better visualization.

Figure 2-51  The sketch of the elongated hole

9.	 Choose the Circle tool from the Profile toolbar.

10.	 Move the cursor to the location whose coordinates are 40, 30 and click to specify the center 
point of the circle.

11.	 Enter 10 as the radius value for the circle in the R edit box of the Sketch tools toolbar and 
press ENTER; you will notice that a radius dimension is displayed attached to the circle. 

 
12.	 Choose the Circle tool from the Profile toolbar.

13.	 Move the cursor to the location whose coordinates are 40,-30 and click to specify the center 
point of the circle.

14.	 Enter 10 as the radius value for the circle in the R edit box of the Sketch tools toolbar and 
press ENTER.

15.	 Similarly, draw the other two circles. The coordinates of the center point of the other two 
circles are -40, 30 and -40, -30, respectively. The final sketch with the display of constraints 
turned on is shown in Figure 2-52.
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Figure 2-52  The final sketch

Saving the Sketch
1.	 Choose the Save tool from the Standard toolbar to invoke the Save As dialog box.  

Browse to the folder named c02 that you created in the first tutorial of this chapter.

2.	 Choose the Save button; the file is saved at C:\CATIA\c02.

3. 	 Next, close the part file by choosing File > Close from the menu bar.

Tutorial 3
In this tutorial, you will draw the sketch of the model shown in Figure 2-53. The sketch of the 
model is shown in Figure 2-54. Do not dimension the sketch. The solid model and its dimensions 
are shown for your reference only.  	                                             (Expected time: 20 min)	
                        		    

Figure 2-53  The solid model for Tutorial 3 Figure 2-54  The sketch of the model
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	 The following steps are required to complete this tutorial:

a.	 Start a new Part file.
b.	 Draw the sketch of the model using the Profile and Rectangle tools.
c.	 Save and close the file.

Starting a New Part File
1.	 Choose File > New from the menu bar; the New dialog box is displayed. 

2.	 In the New dialog box, select Part from the List of Types list box and choose the OK button; 
the New Part dialog box is displayed. 

3.	 Enter c02tut3 as the name of the file in the Enter part name edit box. Retaining rest of the 
default settings in the New Part dialog box, choose the OK button; a new Part file opens 
in the Part Design workbench.

4.	 Choose the Sketch tool from the Sketcher toolbar and then select the yz plane as the 
sketching plane to invoke the Sketcher workbench.

	 Now, you need to draw the sketch in two parts: first the outer loop and then the inner cavity.

Drawing the Outer Loop of the Sketch
	 In this section, you need to draw the outer loop of the sketch using the Profile tool. Start 

drawing the outer loop from the lower left corner of the sketch. It is recommended that 
you keep the origin in the middle of the sketch drawn as it will reduce the time required for 
constraining and dimensioning the sketches. Also, it will help you capture the design intent 
easily.

1.	 Choose the Profile tool from the Profile toolbar. 

2.	 Click to specify the start point of the line at the location whose coordinates are -40,-30 and 
then move the cursor horizontally toward the right; you will notice that the line turns blue.

3.	 Move the cursor to the location whose coordinates are 40,-30. Click to specify the endpoint 
of the line; a rubber band line is attached to the cursor.

4.	 Move the cursor vertically upward and click to specify the endpoint of the second line whose 
coordinates are 40,-20. 

5.	 Move the cursor horizontally toward the left where the coordinates are 30,-20 and click to 
specify the endpoint of the third line.

	 After drawing these three lines, you need to draw a tangent arc using the Tangent Arc button 
from the Sketch tools toolbar.

6.	 Choose the Tangent Arc tool from the Sketch tools toolbar. 
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7.	 Move the cursor to the location whose coordinates are 20,

Figure 2-55  The sketch after drawing 
three lines and a tangent arc

-10 and click to specify the endpoint of the tangent 
arc; the Line mode is activated and the line gets 
attached to the cursor again. Figure 2-55 shows the 
sketch after drawing three lines and a tangent arc. In 
this figure, the constraints are hidden for better 
visualization.

8.	 Move the cursor vertically upward to the location whose 
coordinates are 20,10 and then click to specify the 
endpoint of the line at this location.

	 Next, you need to draw a tangent arc using the Tangent Arc button from the Sketch tools 
toolbar.

9.	 Choose the Tangent Arc tool from the Sketch tools toolbar; the Tangent Arc mode is 
activated.

10.	 Move the cursor to the location whose coordinates are 30, 20 and click to specify the endpoint 
of the tangent arc. As soon as, you specify the end point of the tangent arc, the Line mode 
is activated again.

11.	 Move the cursor horizontally toward the right and click to specify the endpoint of the line 
when the coordinates are 40,20.

12.	 Move the cursor vertically upward and click to specify the endpoint of the line when the 
coordinates are 40,30.

13.	 Move the cursor horizontally toward the left and click to specify the endpoint of the line 
when the coordinates are -40,30.

14.	 Move the cursor vertically downward and click to specify the endpoint of the line when the 
coordinates are -40,20.

15.	 Move the cursor horizontally toward the right and click to specify the endpoint of the line 
where the coordinates are -30,20.

	 Next, you need to draw a tangent arc by choosing the Tangent Arc tool from the Sketch 
tools toolbar.

16.	 Choose the Tangent Arc button from the Sketch tools toolbar; the Tangent Arc mode is 
activated.

17.	 Move the cursor to the location whose coordinates are -20,10 and click to specify the endpoints 
of the arc at this location; the Line mode is activated and line is attached to the cursor.

18.	 Move the cursor vertically downward and specify the endpoint of the line when the 
coordinates are -20,-10.
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19.	 Switch to the Tangent Arc mode by choosing the Tangent Arc tool from the Sketch tools 
toolbar and then move the cursor to the location whose coordinates are -30,-20 and click 
to specify the endpoint of the tangent arc at this location.

20.	 Move the cursor horizontally toward the left and

Figure 2-56  The sketch after drawing the 
outer loop and hiding the constraints

 
click to specify the endpoint of the line where the 
coordinates are -40,-20.

21.	 Move the cursor vertically downward and click to 
specify the endpoint of the line when it snaps to 
the start point of the outer loop. The sketch after 
drawing the outer loop and hiding the constraints 
is shown in Figure 2-56.

Drawing the Inner Cavity of the Sketch
	 After drawing the outer loop of the sketch, you need to draw its inner rectangular cavity 

using the Rectangle tool.

1.	 Choose the Rectangle tool from the Profile toolbar.

2.	 Move the cursor to the location whose coordinates are -10,10 and click to specify the upper-left 
corner of the rectangle at this location.

3.	 Move the cursor to the location whose coordinates are

Figure 2-57  The final sketch after 
drawing the inner loop

 
10,-10 and click to specify the lower-right corner of the 
rectangle at this location.

4.	 Choose the Fit All In button from the View toolbar to 
fit the sketch into the geometry area.

	 The final sketch after drawing the inner loop is shown 
in Figure 2-57. Note that in this figure, the display of 
constraints has been turned on.

Saving the Sketch
After completing the sketch, you need to save it.  

1.	 Choose the Save tool from the Standard toolbar to invoke the Save As dialog box. 
Browse the c02 folder that you created in the last tutorial.

2.	 Next, choose the Save button from this dialog box; the file is saved at C:\CATIA\c02.

3.	 Close the part file by choosing File > Close from the menu bar.
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Tutorial 4
In this tutorial, you will draw the sketch of the model shown in Figure 2-58. The sketch of the 
model is shown in Figure 2-59. Do not dimension the sketch. The solid model and its dimensions 
are shown for your reference only.	                            	      (Expected time: 30 min)
  

Figure 2-58  The solid model for Tutorial 4 Figure 2-59  The sketch of the model

	 The following steps are required to complete this tutorial:

a.	 Start CATIA V5 and then start a new Part file.
b.	 Draw the sketch of the model using Line, Arc, and Circle tools.
c.	 Save and close the file.

Starting CATIA V5 and then a New Part File
1.	 Choose File > New from the menu bar; the New dialog box is displayed.

2.	 In this dialog box, select Part from the List of Types list box and choose the OK button; 
the New Part dialog box is displayed. 

3.	 In the New Part dialog box, enter c02tut4 as the name of the file in the Enter part name 
edit box. Accept the rest of the default setting in the New Part dialog box and choose the 
OK button; a new Part file opens in the Part Design workbench.

4.	 Choose the Sketch tool from the Sketcher toolbar and then select the yz plane as the 
sketching plane to invoke the Sketcher workbench.

	 Now, you need to draw the sketch in two parts: first as the outer loop and second as the 
inner circle.

Drawing the Outer Loop of the Sketch
	 In this section, you need to draw the sketch symmetrically around the origin because it will 

reduce the time required for constraining and dimensioning it. You will draw the outer loop 
of the sketch using the Line and Arc tools. 
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1.	 Invoke the Line tool by choosing the Line tool from the Profile toolbar.

2.	 Choose the Snap to Point button from the Sketch tools toolbar if not chosen.

3.	 Move the cursor in the third quadrant; the coordinates of the point are displayed above the 
cursor. 

4.	 Click to specify the point whose coordinates are -50,-30. Next, move the cursor horizontally 
toward the right.

	
	 It is evident from Figure 2-59 that the length of the first horizontal line at the lower left 

corner of the sketch is 30mm. Therefore, you need to move the cursor until the length of 
the line is shown as 30mm in the L edit box of the Sketch tools toolbar.

5.	 Click to draw the line when the L edit box displays a value of 30mm

	 After drawing the first horizontal line, you will notice that a Horizontal constraint is applied 
to it. Note that the line is still selected and displayed in orange. Click anywhere in the 
geometry area to remove it from the selection set. 

	 As soon as you specify the endpoint of the line, the Line tool gets terminated. Therefore, 
you need to choose the Line tool again and again to draw multiple lines. You can avoid it 
by double-clicking on the Line tool in the Profile toolbar. On doing so, the Line tool will 
not terminate until you press the ESC key twice.

6.	 Double-click on the Line tool to invoke the Line tool and select the endpoint of the first 
horizontal line.

7.	 Press the TAB key twice to highlight the value displayed in the L edit box of the Sketch 
tools toolbar. Enter 8 in this edit box and then press the ENTER key.

 
8.	 Now, move the cursor vertically upward and click when a vertical line is displayed in blue; 

a vertical line of length 8mm is drawn. You will notice that this line is no longer in the 
selection mode and you are prompted to select the start point of the next line. This happens 
because of double-clicking on the Line tool. It keeps the Line tool active until another tool 
is invoked.

9.	 Select the endpoint of the vertical line as the start point of the second horizontal line. Enter 
75 in the L edit box of the Sketch tools toolbar and press ENTER. Now, move the cursor 
horizontally toward the right and click when a horizontal line is displayed; the second 
horizontal line of length 75mm is drawn.

10.	 Select the endpoint of the second horizontal line as the start point of the second vertical 
line and move the cursor vertically downward. Click when the L edit box displays a value 
of 8mm; the second vertical line of length 8mm is drawn.

11.	 Select the endpoint of the second vertical line as the start point of the third horizontal line 
and move the cursor horizontally toward the right. Click to draw the line when the length 
in the L edit box shows a value of 45mm.
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12.	 Select the endpoint of the previous line as the start point of the third vertical line and move 
the cursor vertically upward. Click to draw the line when the L edit box displays a value of 
50mm; the third vertical line of length 50mm is drawn.

	
	 Next, you need to draw a three point arc using the Three Point Arc tool.

13.	 Choose the Three Point Arc tool from the Circle sub-toolbar.                                    

14.	 Select the start point of the arc as the endpoint of the previous vertical line.

15.	 Move the cursor to the point whose coordinates are 70, 50. These coordinates are displayed 
in the Sketch tools toolbar and also on the top of the cursor. Now, click in the geometry 
area to specify the second point. 

16.	 Move the cursor to a location 40,20 in the geometry area to specify the third point of the 
arc and then click; the coordinate values are displayed on the top of the cursor.

	 This draws the arc of the outer loop. The arc is in the selection mode. Click anywhere in 
the geometry area to exit the selection mode. 

17.	 Now, to continue drawing the outer loop, you need to invoke the Line tool again. Double-click 
on the Line tool in the Profile toolbar to invoke the Line tool.

18.	 Select the endpoint of the arc as the start point of the fourth vertical line. Move the cursor 
vertically downward  and click to draw the line when the length in the L edit box shows a 
value of 20mm in the Sketch tools toolbar.

	 The fourth vertical line of length 20mm is drawn. You will notice that the line is no longer 
in the selection mode and you are prompted to specify the start point of the next line.

19.	 Select the endpoint of the previous line as the start point of the fourth horizontal line. Move 
the cursor horizontally toward the left. Click to draw the line when the length in the L edit 
box shows a value of 80mm in the Sketch tools toolbar.

	 The fourth horizontal line of length 80mm is drawn. Note that the line is green in color 
because it passes through the origin.

20. Select the endpoint of the previous line as the start point of the inclined line. Move the 
cursor such that the line is drawn at an angle of  225°. The current angle is displayed in the 
A edit box of the Sketch tools toolbar. Click when a vertical inferencing line is displayed 
between the endpoint of the inclined line and the start point of the first horizontal line; a 
horizontal inclined line of 10 unit is drawn.

21.	 Select the endpoint of the inclined line as the start point of the next line. Move the cursor 
vertically downward and click when the L edit box displays a value of 20mm. Next, press 
the ESC key to exit the active tool.
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	 This completes the sketch of the outer loop. It is recommended that you modify the geometry 
area such that the sketch fits inside the screen. This can be done by using the Fit All In tool.

22.	 Choose the Fit All In button from the View toolbar to fit the current sketch into the screen. 
The completed outer loop of the sketch is shown in Figure 2-60. Note that in this figure, the 
display of constraints and dimensions is turned off using the Hide/Show tool for clarity.

Figure 2-60  The completed  outer loop of the sketch

Drawing the Inner Circle
	 Now, you need to draw a circle using the Circle tool.
 
1.	 Choose the Circle tool from the Circle sub-toolbar to invoke it; you are prompted  

to define the center point of the circle.

2.	 Move the cursor to the point whose coordinates are 70, 20. Click when the cursor snaps to 
this point. 

3.	 Move the cursor horizontally toward the right and click when the R edit box of the Sketch 
tools toolbar displays a value of 15mm. Click anywhere in the geometry area to remove the 
circle from the selection.

	 The final sketch after drawing the circle is shown in Figure 2-61. Note that in this figure, 
the display of the constraints has been turned on.

Figure 2-61  The final sketch for Tutorial 4
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Saving and Closing the Sketch
1.	 Choose the Save tool from the Standard toolbar to invoke the Save As dialog box. Browse 

to the c02 folder that you created in the first tutorial.

2.	 Choose the Save button; the file is saved at C:\CATIA\c02.			          

3.	 Close the part file by choosing File > Close from the menu bar.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 You can convert a sketched element into a construction element by using the __________ 
tool.

2.	 To draw a rectangle at an angle, you need to use the __________ tool.

3.	 The rectangle is considered as a combination of individual __________. 

4.	 The __________ tool is used to draw continuous lines.

5.	 Using the __________ tool, you can create a circle by specifying the coordinates of its center 
point.

 
6.	 __________ are temporary lines that are used to track a particular point on the screen.

7.	 The base feature of any design is a sketched feature which is created by drawing the sketch. 
(T/F)

8.	 You can draw an arc while working with the Profile tool. (T/F)

9.	 To enter the Sketcher workbench, you need to choose the Sketch tool. (T/F)

10.	 When you open a file that has been saved in the sketching environment, it opens in the part 
modeling environment. (T/F)

 Review Questions 
Answer the following questions:

1.	 In CATIA V5, a combination of which of the following elements is considered as a 
rectangle? 	

		  (a) Lines				    (b) Arcs
		  (c) Splines				    (d) None of these
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2.	 Which of the following tools is not available in the Predefined Profile sub-toolbar?

		  (a) Rectangle			   	 (b) Oriented Rectangle
		  (c) Parallelogram			   (d) Circle
	
3.	 Which one of the following elements will not be considered while converting a sketch into 

a feature?

		  (a) Sketched circles			   (b) Sketched lines
		  (c) Construction elements		  (d) None of these

4.	 Which one of the following tools is available in the Line toolbar?

		  (a) Line				   	 (b) Infinite Line
		  (c) Bisecting Line	 		  (d) All of these

5.	 In which workbench of CATIA V5, you can draw the sketches that can be used to create 
features?

		  (a) Part				   	 (b) Assembly
		  (c) Shape			   	 (d) None of these

6.	 The 3 point arc is the arc that is drawn by defining a start point, an endpoint, and a point 
on the arc. (T/F)

7.	 The Parallelogram tool is available in the Predefined Profile sub-toolbar. (T/F)

8.	 The Symmetrical Extension button when chosen from the Sketch tools toolbar draws a 
simple line. (T/F)

9.	 In CATIA V5, circles are drawn by specifying the center point of the circle and then entering 
radius value in the dialog box that is displayed. (T/F)

10.	 When you start CATIA V5, a file in the Product workbench is started by default. (T/F)

EXERCISES

Exercise 1
Draw the sketch of the model shown in Figure 2-62. The sketch to be drawn is shown in 
Figure 2-63. Do not dimension it. The solid model and dimensions are shown for reference.	
									               (Expected time: 30 min)
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Figure 2-62  The solid model for Exercise 1 Figure 2-63  The sketch of the model

Exercise 2
Draw the sketch of the model shown in Figure 2-64. The sketch to be drawn is shown in Figure 2-65. 
Do not dimension it. The solid model and dimensions are shown for reference.			 
	  			     					           (Expected time: 30 min)

Figure 2-64  The solid model for Exercise 2 Figure 2-65  The sketch of the model

Exercise 3
Draw the sketch of the model shown in Figure 2-66. The sketch to be drawn is shown in 
Figure 2-67. Do not dimension it. The solid model and dimensions are shown for reference.	
									              (Expected time: 15 min)
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Figure 2-66  The solid model for Exercise 3 Figure 2-67  The sketch of the model

Exercise 4
Draw the sketch of the model shown in Figure 2-68. The sketch to be drawn is shown in 
Figure 2-69. Do not dimension it. The solid model and dimensions are shown for reference.	
						       			         (Expected time: 30 min)

Figure 2-68  The solid model for Exercise 4 Figure 2-69  The sketch of the model

Answers to Self-Evaluation Test
1. Construction/Standard Element, 2. Oriented Rectangle, 3. lines,  4. Profile, 5. Circle Using 
Coordinates, 6. Inferencing lines, 7. T, 8. T, 9. T, 10. F


