
Chapter 16

Using Advanced 
Features

Learning Objectives
After completing this chapter, you will be able to:
• Add structural components to a project
• Create multiple design options
• Create area schemes and area plans
• Create color schemes
• Use project phasing tools
• Link building models and share coordinates
• Share projects using worksets
• Purge unused elements from the project file
• Organize the Project Browser
• Generate solar studies
• Understand Point Cloud
• Publish views to DWF
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INTRODUCTION 
This chapter describes the advanced features of Revit such as adding structural components, 
creating design options using the phasing tools, and worksharing methodology. With the help 
of these advanced features, you can easily add structural components to a building model using 
various tools and in-built components. You can also create various design options based on the 
project requirement, and also use the area analysis tools to analyze and generate area plans for 
the building model. 

In this chapter, you will learn to represent the phase-wise development of a project, link 
independently developed projects to each other, and share their coordinates using the project 
sharing and linking tools. Also, the concept of worksets, which enables multiple users to work on 
a single project and interoperability of Revit Architecture with other program such as Autodesk 
3ds Max has been discussed in the chapter.

CREATING STRUCTURAL COMPONENTS
Structural components describe the structural system of a building project. The use of some 
of these elements, such as walls, floors, roof, stairs, and so on has been discussed in the earlier 
chapters. The structural components may or may not comprise the basic structural support system 
of a building project. For example, in a multistory building project, steel framing components 
can form the basic support system and the walls can be non-load bearing. Therefore, it may be 
necessary to specify and differentiate between the structural and architectural components for 
some projects.

You can add structural components before or after creating the building model. For example, 
you can first generate an architectural building model for a multistory building and then add 
structural components to it, or you can generate the building model over a framework of 
structural components. The structural property of a wall is represented by its Structural Usage 
instance parameter, and the wall function is represented by its Wall Function type parameter. 
For instance, by default, the Basic Wall: Generic- 8” Masonry wall has the value Non-bearing 
for the Structural Usage instance parameter. For load bearing structures, you can convert this 
non-bearing wall into a bearing wall by changing its Structural Usage instance parameter to 
any of the following parameters: Bearing, Shear, or Structural combined. 

 
The structural components that can be created in a Revit building model are broadly classified 
into the following three categories: 

Structural Walls		  Walls used for foundation, retaining, or as shear walls
Structural Columns		  Structural components for vertical support
Structural Beams and Braces	 Components providing connecting ties
Structural Foundations		 Components providing support to the superstructure of the  
				    building

Figure 16-1 shows the structural components for a project.
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Figure 16-1 The structural elements for a project
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Creating Structural Walls
There are four types of functions that can be assigned to a parametric wall. The functions that 
can be assigned to the wall are interior, exterior, retaining, and foundation. The interior or 
exterior wall functions have been described in the earlier chapters. A structural wall differs from 
a non-structural wall only in its structural usage. The four structural usage options are: 

Non-bearing		  Walls supporting only their own weight or are used to divide spaces
Bearing	 	 Walls supporting a vertical load in addition to their own weight
Shear			   Walls supporting a lateral thrust of shear
Structural combined	 Walls serving more than one purpose
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Tip
While using structural elements, you can choose the Structural Settings button (represented 
by an inclined arrow) from the Structure panel of the Structure tab; the Structural Settings 
dialog box will be displayed. In this dialog box, you can set the parameters to control the 
representation of structural elements in a project file. You can also use the Structural-Default.rte 
template file that contains the view properties and range settings specifically for working with 
the structural elements.

Sketching Retaining Walls
To sketch a retaining wall, invoke the Wall: Structural tool from Structure > Structure 
> Wall drop-down; the Modify | Place Structural Wall tab will be displayed. In the                             
Properties palette, select the Basic Wall: Retaining -12” Concrete option (for Metric Basic 
Wall: Retaining -300mm Concrete) from the Type Selector drop-down list. After selecting the 
retaining wall option from the Type Selector drop-down list, you can sketch a retaining wall in 
the plan or 3D view. You can also convert a sketched interior, exterior, or foundation wall into 
a retaining wall. To do so, select the wall and choose the Edit Type button in the Properties 
palette; the Type Properties dialog box will be displayed. The Function type parameter in the 
Type Properties dialog box describes the current function of the wall. Click in the Value column 
of the Wall Function type parameter and select the Retaining option from the drop-down list. 
Then choose Apply and OK buttons, the structural wall is modified to the retaining wall. 

Note
When you use a retaining wall or modify the function of a wall to make it a retaining wall, it is 
automatically set to non-room bounding.

Sketching Foundation Walls
Foundation walls can be sketched by choosing the Wall: Structural tool and then selecting 
the foundation wall type from the Type Selector drop-down list. By default, the Basic Wall: 
Foundation - 12” Concrete option is selected from the drop-down list. The foundation wall can 
be sketched in the plan or 3D view. Note that if the foundation walls are sketched in the plan 
view, a warning that the foundation walls are not visible in the view in which they were sketched. 
This warning is displayed because the foundation walls, unlike any other non-structural wall, 
are created with the current level as the top constraint. This means that they are sketched 
downward and are not visible in the current level. To view the sketched foundation walls, change 
the View Range instance property of the current view. To do so, click on the view name in the 
Project Browser; the instance properties of the selected view will be displayed in the Properties 
palette. In the Properties palette, choose the Edit button in the Value column of the View 
Range instance parameter; the View Range dialog box will be displayed. In the Primary Range 
section of the View Range dialog box, change the Bottom and View Depth parameters to Level 
Below to enable the visibility of the foundation walls in the current view.
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Note
The Structural Usage parameter for a sketched foundation wall is automatically set to Bearing.

You can modify the instance and type properties of a foundation wall after you create it. To do 
so, select the foundation wall from the drawing; the instance properties will be displayed in the 
Properties palette, as shown in Figure 16-2. You can modify the height of the foundation wall 
by entering a value in the Base Offset parameter. The type properties of the foundation wall 
can be modified by using the Edit Type button in the Properties palette.

Figure 16-2  The instance properties of a typical foundation wall

Creating Structural Columns
Structural columns can be placed in the plan or 3D view. You can place a single structural 
column or multiple structural columns by selecting the grid intersection. To add a structural 
column, invoke the Column tool from the Structure panel of the Structure tab; the Modify | 
Place Structural Column tab will be displayed, as shown in Figure 16-3. In this tab, you can 
choose the Load Family button from the Mode panel and then load the additional structural 
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columns from the Structural Columns folder in the US Imperial folder. Based on the material 
specification, four subfolders Concrete, Precast Concrete, Steel, and Wood have been provided 
to load the structural columns from the column families.

Figure 16-3  The Modify / Place Structural Column tab 

Select the desired type from the Type Selector drop-down list in the Properties palette and  
add the structural columns to the building model. Note that before you add the structural 
columns, you should set up a structural grid. Now, to add a single structural column after setting 
up the structural grid, move the cursor near the grid intersection; the cursor will snap to the 
intersection. Click to add the column; the selected structural column will be attached to the 
cursor. To add a column aligned to an inclined grid, press SPACEBAR; the column toggles 
parallel and perpendicular to the highlighted grid, refer to Figure 16-4. You can press the 
SPACEBAR repeatedly until the desired alignment is displayed, and then click to add the column 
at the desired alignment. You can also select the Rotate after placement check box available in 
Options Bar to enable the rotation of the structural column after its placement. You can select 
the Height or Depth option from the first drop-down list available in the Options Bar. Set the 
level or constraint for the column height using the other drop-down list. To specify the depth 
or height of the column based on the project requirement, select the Unconnected option from 
the other drop-down list.

Figure 16-4  Adding a structural column at an inclined grid intersection

Note
Like structural walls, structural columns are also placed from top to bottom. To view them in the 
current plan view, modify the Bottom clip plane setting for the View Range parameter.
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Adding Multiple Structural Columns
To add multiple columns at grid intersections, choose the At Grids tool from the Multiple  
panel of the Modify | Place Structural Column tab; the Modify | Place Structural Column > 
At Grid Intersection tab will be displayed and you will be prompted to select the grid lines to 
place the structural columns at grid intersections. Select the desired grid lines; the selected grid 
lines will be highlighted and the columns will be displayed at intersections, as shown in 
Figure 16-5. Next, choose the Finish button from the Multiple panel; the multiple structural 
columns will be added to the selected grid intersections.

Figure 16-5  Multiple structural columns added to a grid

Adding Structural Columns inside Architectural Columns 
The At Columns tool available in the Multiple panel of the Modify | Place Structural 
Column tab enables you to add structural columns inside the existing architectural columns. 
After invoking this tool, select an individual architectural column or multiple architectural 
columns; the structural columns automatically snap to the center of the architectural 
columns. Choose the Finish button from the Multiple panel of the Modify | Place Structural 
Column > At Architectural Columns tab to complete the process.
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Adding Structural Beams and Braces
Beams are structural components that connect the columns or the structural walls. Beams can 
be joined to the structural bearing walls if their structural usage property is set to bearing or 
structural combined. You can add beams individually or by selecting the grids along which they 
are required. 

To add a structural beam, invoke the Beam tool from the Structure panel of the Structure tab. 
After invoking this tool, select the beam type from the Type Selector drop-down list in the 
Properties palette. To load additional beams, choose the Load Family button from the Mode 
panel of the Modify | Place Beam tab; the Load Family dialog box will be displayed. In this 
dialog box, the Structural Framing folder will display various files related to various types of 
concrete, steel, and wooden beam families. Choose the required family and then choose the 
Open button to load the family in the Type Selector drop-down list. Now, in the Modify | Place 
Beam tab, you can choose the On Grids tool from the Multiple panel to select multiple grids 
along which the required beams can be placed. The Placement Plane drop-down list available in 
the Options Bar can be used to select the level for adding beams. The options in the Structural 
Usage drop-down list in the Options Bar can be used to select the usage of the beam. By default, 
Automatic is selected in this drop-down list. As a result, Revit determines the usage based on 
the structural components that the beam connects. The Chain check box can be used to add 
a chain of beams. Select the 3D Snapping check box to snap to different points in a 3D view. 
To sketch a beam, specify the start point and the endpoint for the beam in the drawing area. 

Braces are diagonal members that connect beams and columns. They can be created by snapping 
the cursor to the structural components. Usually, braces are placed in framing elevation views. 
These views show the general arrangement and sizes of structural components as an arrangement 
of lines and are quite similar to interior views. To create a framing elevation view, invoke the 
Framing Elevation tool from View > Create > Elevation drop-down. Now, select a structural 
grid from the drawing; the framing elevation of that section will be created. You can view the 
elevation from the Elevations (Interior Elevations) head in the Project Browser. After opening 
a framing elevation view from the Project Browser, you can add braces to the columns. To do so, 
invoke the Brace tool from the Structure panel of the Structure tab. Select the brace type from 
the Type Selector drop-down list in the Properties palette. You can choose the Load Family 
button from the Mode panel of the Modify |Place Brace tab to load additional braces from 
the Structural Framing folder. Move the cursor to the desired location in the framing elevation 
and use the snap options to sketch the braces. The braces are displayed as lines in the framing 
elevation. You can view the added braces and other structural components in the 3D view. 

Tip
When you load families of structural elements using the Load Family button, the Load 
Family dialog box displays a type catalog. This enables you to select and load only specific 
family types. This decreases the file size, and also reduces the number of entries in the Type 
Selector drop-down list. Also, once the structural elements have been added to a level, you can 
use the Copy and Paste tools from the Clipboard panel to copy the elements to multiple levels.
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Cutting Openings in Beams, Braces, and Columns
Revit allows you to cut openings in structural members such as beams, braces, and columns. You 
can cut an opening in a structural member after selecting planes. Every structural member (Beam, 
Brace, and Column) shows two planes: horizontal and vertical. These planes are perpendicular to 
each other, as shown in Figures 16-6 and 16-7. You can also lay ducts and pipes passing through 
the beams and columns by creating the openings of the corresponding shape. You can create 
different shapes of openings using different sketching tools.

Figure 16-7  The horizontal plane of the beamFigure 16-6  The vertical plane of the beam

To cut an opening, choose the By Face tool from the Opening

Figure 16-8  Structural beams with 
a circular opening and a rectangular 
opening with a fillet

 
panel of the Architecture tab; you will be prompted to select 
a planar face of the member. Move your cursor over the 
member; the planes will be highlighted in green. To select 
the required plane, click in the drawing when the plane is 
highlighted; the screen will enter the sketch mode. Draw 
an opening in the structural member using any sketching 
tool available in the Draw panel of the Modify | Create 
Opening Boundary tab. In Revit, you can also create 
a rectangular opening with a fillet. To do so, invoke the 
Rectangle sketching tool in the Draw panel and select the 
Radius check box from the Options Bar. Specify the radius 
for the fillet in the Radius edit box and sketch the opening 
in the member. Next, choose the Finish Edit Mode button 
from the Mode panel. Figure 16-8 shows a circular opening 
and a rectangular opening with a fillet in structural beams.

GENERATING MULTIPLE DESIGN OPTIONS
In Revit, the Design Options tool provides you with the flexibility of choosing several alternatives 
for your design. As a designer, you need to come up with multiple design ideas, so that you can 
select the best option that suits the functional, aesthetical, and economical requirement of your 
project. Therefore, you need to develop and evaluate several design options and then execute 
the best possible design option for your project. 
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The Design Options tool helps you speed up your project by providing you the options to create 
and develop several alternatives of a single model. For example, you can use the Design Options 
tool to develop three options of a Kitchen for a residential layout, featuring different materials 
and space utilization. In such a case, you can create individual details and documentations like 
drawings, schedules, cost summaries based on the quantity of materials, and so on for these 
three design options that you have created for the existing kitchen project. These drawings and 
documentations help you select the best option that meets your project requirement.

To use the Design Options tool, first you need to create an option set and then the option in 
the basic building model. The option set refers to a set of alternatives devised for creating a 
particular design or subject. For example, if you have three design options for building a kitchen 
on the first floor of a residential project, then they will form one option set with three different 
options. You can name the option set as Kitchen_FF and its design options as Island_Kitchen, 
Closed_L_Shaped Kitchen, and Closed_U_Shaped Kitchen. One of the design options can be 
made the primary design option in the specified option set. You can have a number of design 
options in a single design option set. 

The purpose of using design options is to enable you to develop and study multiple design 
alternatives for a single model and pick the best one for the final layout. You can delete or 
archive the rejected design options once you have picked up the right one.

Generating Design Options for a Project
The Design Options tool is used to generate design options for a project. Invoke this tool from 
the Design Options panel in the Manage tab; the Design Options dialog box will be displayed. 
To generate a new design option set, choose the New button in the Option Set section of the 
Design Options dialog box; a new option set will be added to the left pane. Next, to add a new 
option in this option set, choose the New button from the Option section. You can also rename 
an option set by using the Rename button in the Option Set section. Figure 16-9 shows various 
design options in the Design Options dialog box. 

After creating the design option sets and options, you can add building components for each 
option. To do so, select the design option in the Design Options dialog box and then choose 
the Edit Selected button from the Edit area. Next, choose the Close button to close the Design 
Options dialog box; any element introduced in the building model will be added to the selected 
option. You can also cut and paste components from the main model to a design option. After 
editing the building model and completing the design option, you can again choose the Design 
Options tool to view the design. The Now Editing text box in the Design Options dialog box 
displays the name of the option to be edited. The Finish Editing button is used to complete 
the editing of a design option. After creating multiple design option sets, you can assign the 
desired option set as the primary option set by selecting it and choosing the Accept Primary 
button in the Design Options dialog box.
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Figure 16-9  The Design Options dialog box with the design option sets and design 
options created 

Presenting Design Options
After creating the design options, you can compare and present them to clients. To do so, create 
multiple copies of the view of a design option, and set the visibility setting for each view. You can 
use the Visibility/Graphics tool to control the visibility of a design option in each view. Select 
the view from the Project Browser and right-click. Next, choose Duplicate View > Duplicate 
from the shortcut menu; the copy of the view will be created. You may create a number of copies 
of the view based on the number of design options generated. Use the shortcut menu to rename 
each view based on the design option it represents. 

Tip
While using the Design Options tool, you need to keep in mind that the view-specific elements 
such as dimensions and text cannot be added to the design options. Also, you need to be careful 
in keeping all dependent elements in the same design option.

Next, choose the Manage tab and then select the required design option from the Active Design 
Option drop-down list in the Design Options panel; the selected design option will be displayed 
in the view. This process needs to be repeated for each view in which you want to show a different 
option. You can then add the appropriate views to the sheet and present the design options to 
the client. You can also use the Pick to Edit tool from the Design Options panel to select the 
design option that requires editing.
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USING AREA ANALYSIS TOOLS
The area analysis tools are used to analyze and 

Figure 16-10  Various tools in the Area                 
drop-down

represent different area types. These tools can also 
be used to create area schemes such as gross building 
area, rentable area, and area plans. You can access 
these tools from the Area drop-down in the Room 
& Area panel of the Architecture tab, as shown in 
Figure 16-10.

Note
You can also generate area schemes for the design 
options developed for a project.

Area Schemes
Area Schemes are the standards that you set to calculate the area of an enclosed boundary with 
a specific space. You can use the Area tool from the Area drop-down to differentiate the spaces 
based on their usage. You can create and implement various types of area schemes in your current 
project based on the local standards that are followed for the area calculation.

You can create multiple area measurement schemes. To do so, invoke the Area and Volume 
Computations tool from the Room & Area panel of the Architecture tab; the Area and        
Volume Computations dialog box will be displayed. In this dialog box, choose the Area Schemes 
tab; the options in this tab will be displayed, as shown in Figure 16-11. 

By default, the following two areas are created in the Area Schemes tab:

Gross Building 		  Total built-up area of the building

Rentable			   Area measurements based on the calculated floor area using  
   				    the standard rules
The Gross Building area scheme cannot be modified. However, you can modify the Rentable area 
scheme. You can also add a new area scheme by choosing the New button then, add description 
or rename it using the Description column. You can then proceed to create its area plan. You 
can use the Delete button in the Area Schemes tab of the Area and Volume Computations 
dialog box to delete an existing area scheme.
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Figure 16-11  The Area and Volume Computations dialog box

Area Plans
The Area Plan tool is used to create area plans. Area plans are views that describe the subject of 
the area scheme. You can create a number of area plans for a single area scheme. For example, 
a rentable area scheme can be created for a commercial project and then you can create the 
area plans showing the rentable area for each level. Each area plan has distinct area boundaries, 
tags, and color fills. 

To create an area plan, invoke the Area Plan tool from Architecture > Room & Area > Area  
drop-down; the New Area Plan dialog box will be displayed, as shown in Figure 16-12. In this 
dialog box, the Type drop-down list displays the available area schemes. The Area Plan views 
list box displays the existing levels for which the area plans can be created. To create area plans 
for more than one level, select multiple levels in this dialog box. When you select multiple levels, 
Revit creates separate area plans for each level and groups them by the area scheme in the Project 
Browser. If the Do not duplicate existing views check box is selected, Revit will use the same 
views to generate the area plans. If you clear this check box, Revit will create the copies of the 
views. After specifying all options in the New Area Plan dialog box, choose the OK button; the 
Revit message box will appear and you will be prompted to choose the method for specifying the 
area boundary. You can choose the Yes button to automatically create an area boundary associated 
with the external walls or choose the No button to manually sketch the area boundary lines. 
When you choose the Yes button, Revit places the boundary lines along the exterior walls of the 
building model, thus forming a closed loop. In the Gross Building Area scheme, the boundary 
line will be placed on the exterior face of the exterior walls, whereas in case of the Rentable Area 
scheme, the boundary line will be placed on the interior face of the exterior walls. Finally, the 
created area plan will be added in the Project Browser under the Area Plans head. 
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The area scheme is also mentioned along with the 

Figure 16-12  The New Area Plan dialog box

area plan title. You can create area boundaries 
either by picking the walls or by manually 
sketching the boundary lines. To sketch an area 
boundary, invoke the Area Boundary tool from 
Architecture > Room & Area drop-down; the 
options to sketch the area boundary will be 
displayed in the Draw panel of the Modify | 
Place Area Boundary tab. In the Options Bar, 
the Apply Area Rules check box is selected by 
default. As a result, the area rules will be applied 
to the area boundary and Revit Architecture will 
automatically change the position of the wall 
boundary when you change the area. On 
clearing the Apply Area Rules check box, the 
Offset edit box and the Lock check box will be 
displayed. You can enter the desired offset 
distance for the area boundary line in the Offset 
edit box and select the Lock check box to lock 
the position of the area boundary. After creating 
the area boundary line, you need to create the 
area for the boundary line. To do so, invoke the 
Area tool from the Room and Area panel of the 
Architecture tab; the Modify | Place Area tab 
will be displayed. Move the cursor inside the 
area boundary line; the area boundary will be 
displayed along with a tag. In the Tag on 
Placement panel of the Modify | Place Area 
tab, the Tag on Placement tool is chosen by 
default. As a result, the area tag will be displayed along with the area boundary. If you do not 
need the area tag to be displayed along with the area boundary, do not choose the Tag on 
Placement tool. On choosing the Tag on Placement tool, you can set various options in the 
Options Bar. From the drop-down list located at left of the Options Bar, you can select the 
Horizontal, Vertical, or Model option. After selecting the desired option, you can select the 
Leader check box to attach a leader along with the tag. From the Area drop-down list, either 
select an existing area or select the New option to create a new area. After selecting the desired 
options from the Options Bar, click inside the area boundary; the area will expand to the extents 
of the boundaries and the new area will be created. 

If you have placed an area without a tag, you can place the tag using the Tag Area tool. To do 
so, invoke the Tag Area tool from Architecture > Room & Area > Tag Area drop-down. On 
doing so, the Modify | Place Area Tag tab will be displayed. In the Properties palette, select 
the desired area tag type from the Type Selector drop-down list and then choose the Edit Type 
button to display the Type Properties dialog box. In this dialog box, select a suitable option 
for the Leader Arrowhead parameter from the drop-down list displayed in the Value field 
corresponding to it. Next, choose OK; the Type Properties dialog box will be closed and the 
specified parameter will be assigned to the tag. Now, in the Options Bar, you can select the 
Leader check box to display the leader line along with the area tag annotation. After specifying 
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the options in the Modify |Place Area Tag tab, move the cursor within a closed space in the 
area boundary, Revit will automatically calculate its area. At this stage, click to add the area tag. 
Figure 16-13 shows an example of area boundaries and area tags added to a residential project. 
You can click on the area tag and rename each space.

Figure 16-13  The area boundaries and the area tags added to a residential project

Number Parameter for Areas
The Number parameter is an instance parameter. It can be accessed in the Properties palette 
of the selected area. Whenever you add an area to a project, the area is automatically numbered. 
This new parameter can also be added to schedules. You can modify the value of the Number 
parameter of any area in the Properties palette. If you assign the same values to the Number 
parameter of two rooms, a warning message will be displayed.  
 

Area Schedules
Once you have added area tags to the spaces and renamed them appropriately, you can proceed 
to create area schedules. To do so, invoke the Schedule/Quantities tool from View > Create > 
Schedules drop-down; the New Schedule dialog box will be displayed. In this dialog box, the 
Category list box displays the area schemes created in the project. Select the desired area scheme 
from this list and ensure that the Schedule building components radio button is selected. 
Choose the OK button in the New Schedule dialog box; the Schedule Properties dialog box 
will be displayed. Select and add the parameters to be included in the scheduled fields from 
the Available fields area, as shown in Figure 16-14. 

You can also use the Fields, Filter, Sorting/Grouping, Formatting, and Appearance tabs available 
in the Schedule Properties dialog box to set the properties of the area schedule. Next, choose 
the OK button; the Modify Schedule/Quantities tab will be displayed and the created schedule 
will be displayed in the drawing area. Add it to the drawing sheet for the presentation of the 
area schemes. Figure 16-15 shows an example of an area schedule.
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Figure 16-15  An example of a created 
area schedule

Figure 16-14  The Schedule Properties dialog box

COLOR SCHEMES
Color schemes are used to represent and categorize different areas in the project graphically by 
using color codes. In other words, color schemes are used to color the rooms and areas in a view. 
You can create color schemes and then apply them to different plan views. You can create different 
color schemes for the first and second floors of a building. A color scheme can be created based 
on a specific category such as Gross area, Rentable area, or an instance property of the room or 
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area such as room perimeter, number, or name. You can also create a color scheme depending 
on the utilization of different rooms in a building. For example, you can assign different colors 
to represent areas such as office, storage, or accounts. Then, you can add a color scheme legend 
to help you identify different areas by the colors assigned to them. 

Creating Color Schemes 
Before creating a color scheme, the rooms and areas should be defined in the plan view. You can 
create a color scheme based on any parameter of a room or an area. For example, if you want 
to create a color scheme for rooms on the basis of room number, room area, or names, make 
sure that the rooms are numbered and named in the plan view.

To create a color scheme, choose the Color Schemes tool from the Room & Area panel in 
the Architecture tab; the Edit Color Scheme dialog box is invoked, as shown in Figure 16-16. 
Alternatively, you can display the Edit Color Scheme dialog box by choosing the <none> 
button displayed in the value column corresponding to the Color Scheme parameter in the 
Properties palette for the current view. Now, in the Schemes area of the Edit Color Scheme 
dialog box, select the category for the color scheme from the Category drop-down list. Next, 
choose the Duplicate button in the Schemes area; the New color scheme dialog box will be 
displayed. Specify the name for the color scheme in the dialog box and choose the OK button; 
the name will be added in the Schemes area. Enter a title for the color scheme legend in the 
Title edit box in the Scheme Definition area. Next, select the parameter for the color scheme 
from the Color drop-down list; a message prompting you to make a new color scheme will be 
displayed. Choose the OK button to continue. Note that the options in the Color drop-down 
list will vary depending on the category selected. 

Note
Make sure you select the correct parameter from the Color drop-down list to create a color scheme. 
The values for the parameters should be predefined. For example, if you select the Area parameter 
to create a color scheme for a plan view, then the areas must be predefined and tagged in the view.

In the Edit Color Scheme dialog box, the By value radio button is selected by default. As a 
result, the color schemes are created based on the values of the selected parameter. Select the By 
range radio button to create a color scheme based on certain ranges of parameter values. The 
By range radio button will be available only when you select Area or Perimeter from the Color 
drop-down list in the Scheme Definition area. On selecting the By range radio button, the Edit 
Format button will be enabled and the unit format used for the parameter will be displayed on 
the right. Choose the Edit Format button; the Format dialog box will be displayed. The Use 
Project Settings check box is selected by default. Clear the Use project settings check box in 
the Format dialog box; the options in the dialog box will be enabled. Select the required values 
for the Units and Rounding options to set the format of the Area and Perimeter units. Choose 
the OK button; the scheme definition values will be added in the columns. You can modify the 
values in the columns as required. The columns displayed in the Scheme Definition area are 
discussed next.
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Figure 16-16  The Edit Color Scheme dialog box 

At Least
This column specifies the lowest value of a range.

Less Than
This column specifies the least value of a range and cannot be modified.

Caption
This column specifies the legend text for the range. Click in the column and edit the text.

Visible
This column indicates the visibility of the value in the color scheme legend. By default, the 
Visible check box is selected indicating that the values are visible in the legend. Clear the check 
box in the column to make the value invisible in the color scheme legend.

Color
This column specifies the color assigned to the range/ class interval. Click on the default color 
value in the Color column; the Color dialog box will be displayed. Select the required color 
and choose the OK button; the selected color will be applied to the range/ class interval and 
displayed in the column.

Fill Pattern
This column specifies the fill pattern assigned to a value by default. Click on the default value in 
the column and click on the down arrow displayed on the right. Select the suitable fill pattern 
from the drop-down list displayed.
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Preview
This column displays the preview of the color and pattern used for a particular range.

In Use
This column indicates that if a particular value from a range of values is in use in the project, 
you cannot modify the values in this column.

To move a row up or down in the Scheme Definition area, choose the Move Rows Up/Down 
buttons on the left. These buttons will be available only after selecting the By Value radio button. 
To add a new value to the color scheme, choose the Add Value button on the left; the New 
Color Scheme entry dialog box will be displayed. In this dialog box, enter a name in the Name 
edit box; a new scheme will be added. By default, the check box displayed in the value column 
corresponding to the Visible column remains selected. As a result, the added color schemes will 
be applied to rooms. You can clear this check box if you do not want to apply color schemes to 
rooms and areas from the linked files. Choose the OK button after creating the color scheme.
 
Applying a Color Scheme
To apply a color scheme in the required plan view, you can use the Properties palette of the 
current view. In the Properties palette of the current view, choose the <none > button in 
the value column of the Color Scheme parameter; the Edit Color Scheme dialog box will be 
displayed. In this dialog box, select the required color scheme and choose the OK button. The 
colors will be applied to the areas or rooms based on the color scheme selected. 

Now, to apply the color scheme in the project view, click on the value field corresponding to the 
Color Scheme Location parameter in the Properties palette; a drop-down list will be displayed. 
You can select any one of the options from Background and Foreground. On selecting the 
Foreground option, all the elements in the area or room such as furniture or walls, except the 
columns, will be colored. On selecting the Background option only the background or the floor 
will be colored.

Adding Color Scheme Legends
The color scheme legends help you identify different rooms and areas through different colors 
assigned to them. The color scheme legends are included in the Annotation Tag category. You 
can place multiple color scheme legends anywhere in the plan view. The color scheme legend 
belongs to the annotation category and is affected by the Annotation crop region. If you do not 
want to place the color scheme legend on the view, you can exclude it by adjusting the Annotation 
crop region of that view.

To add a color fill legend, choose the Color Fill Legend tool from the Color Fill panel of the 
Annotate tab; the Modify|Place Color Fill Legend tab will be displayed. In this tab, select the  
color scheme from the Type Selector drop-down list and then click in the drawing area to place 
the legend; the color scheme legend will be placed in the drawing view. Figure 16-17 shows 
a floor plan view with a color scheme and the color scheme legend for the rooms. The color 
scheme is created based on the area occupied by each room.
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Figure 16-17  Color scheme with a color scheme legend representing 
different areas 

 

You can drag and stretch the color scheme legend by using the drag symbol displayed after 
selecting the color scheme legend. Figure 16-18 shows an example of using a color fill scheme 
based on the occupancy of the building.

Figure 16-18  An example of color scheme based on the occupancy of the building

Modifying Color Scheme  
To modify a color scheme, select the existing color scheme legend and choose Scheme > Edit 
Scheme from the Modify Color Fill Legends tab; the Edit Color Scheme dialog box will be 
displayed. Modify the colors, fill patterns, title, parameter, and other values as required and 
choose the Apply button to view the changes. Choose the OK button to retain the changes.
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Modifying Color Scheme Legends
To modify the color scheme legends, select the existing color scheme legend and drag the blue 
circular drag control to move the color swatches into new columns. Next, drag the cursor down 
to move the color swatches into one column. To modify the type properties of the selected color 
scheme legend, choose the Edit Type button in the Properties palette; the Type Properties 
dialog box will be displayed. In this dialog box, you can modify various parameters related to the 
text, swatches, and various elements in the Color Fill legend. After modifying the parameters, 
choose the OK button to close the dialog box. You can also hide the title of the color scheme 
legend by clearing the Show Title check box in the Type Properties dialog box.

MASKING REGIONS 
While working in an architectural project, sometimes it becomes difficult to demarcate between 
different visible elements due to overlapping of lineworks. Therefore, to reduce the congestion 
of lineworks and interference of unwanted elements in your drawing, it is necessary to hide or 
obscure them in the view.

You can overcome the problem of overlapping and congestion of lineworks by using the Masking 
Region tool. By using this tool, you can add the masking regions to a project, detail family, or 
model family. The Masking Region tool has an advantage over the Region tool in a way that it 
can help maintain the visual display of Revit family information and maintain the visual accuracy 
after the files are imported or exported to other AutoCAD based applications. Masking region 
can be used in 2D model as well as for 2D and 3D Revit families including detail elements and 
annotations.

To add a masking region to a project, open the required plan view and then invoke the 
Masking Region tool from Annotate > Detail > Region drop-down; the Modify | Create Masking 
Region Boundary tab will be displayed and the screen will enter into the sketch mode. Sketch 
the masking region and then choose the Finish Edit Mode button from the Mode panel; the 
Modify | Detail Items tab will be displayed. In this tab, you can edit the boundary of the masking 
region by choosing the Edit Boundary tool from the Mode panel.     

You can add a masking region to a detail family or a model family in the family editor. To do so, 
open the detail family or the model family in the family editor and then choose the Masking 
Region tool from the Detail panel of the Annotate tab; the Modify | Create Masking Region 
Boundary tab will be displayed. You can use various sketching tools from the Draw panel of this 
tab to sketch the masking region. Note that the masking region should be a closed loop geometry. 
After sketching the masking region, you can control its visibility in any model family when the 
model family is loaded into the project and placed in the drawing. To do so, you can use the 
instance properties of the masking region displayed in the Properties palette. In this palette, 
clear the Visible parameter check box to hide the masking region in a view or select the check 
box to make it visible in the project. To set the detail level at which the masking region will be 
displayed, choose the Edit button in the Value column for the Visibility/Graphical Overrides 
parameter; the Family element visibility settings dialog box will be displayed. Set the detail 
level for the masking region in the Detail Levels area of the dialog box and then choose the OK 
button. To set the masking region at the detail plane of the view, select the Draw in Foreground 
check box in the Properties palette. To draw the masking region on the work plane on which 
it is sketched, clear the Draw in Foreground check box.
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Adding Masking Regions to a Project
To mask or obscure any element in a project, open the floor plan view and choose the Masking 
Region tool from Annotate > Detail > Region drop-down; the screen will enter the sketch mode. 
Choose the required sketching tool from the Draw panel, select the line type from the Line 
Style drop-down list, and then sketch the masking regions in the closed loops. After sketching 
the masking regions, choose the Finish Edit Mode button from the Mode panel of the Modify 
|Create Masking Region Boundary tab. Figure 16-19 shows the plumbing fixtures such as tub 
and sink masked in the drawing.

Figure 16-19  Masking regions added to tub and sink

Adding Masking Regions to a Detail Family
While creating and defining a detail family, you can add a masking region to it so that when you 
load it into a project, it can obscure or hide the elements which are interfering with it. To add a 
masking region to a detail family, open the floor plan view and choose the Masking Region tool 
from the Detail panel of the Annotate tab, while you are working in the Revit Family Editor. On 
doing so, the Modify | Create Masking Region Boundary tab will be displayed for sketching 
and editing the masking region. Next, choose the required sketching tool from the Draw panel. 
Then, sketch the masking region over the detail family in a closed loop. Next, in the Properties 
palette, you can clear the check box in the Value column for the Visible instance parameter to 
disable the masking region boundaries. As a result, when you load the family into the project, 
the masking region will not be visible.     

Masking regions help in improving the visibility of the detail family in a project. For example, if 
you are creating a detail family elevation for a display unit, you can add a masking region to it. 
The shape of the masking region needs to fit the geometry of the model over which it is being 
used, in such a way that it obscures the visibility of other elements like walls and fixtures behind 
it, when the detail family is placed in the elevation of your project.
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Adding Masking Regions to a Model Family
You can create and define a masking region for a model family in the same way as you do for the 
detail family. While creating a masking region for a model family, you can control the position 
of the plane where it is drawn by using the Draw in Foreground instance parameter in the 
Properties palette of the masking region. If you clear the check box in the value column of the 
Draw in Foreground instance parameter, then you can draw the masking region at the work 
plane where the model family was created. If you select this check box, then you can draw the 
masking region at a plane of the model family that is nearest to you in the view. 

CREATING DISPLACED VIEW					  
In Autodesk Revit 2020, the Displace Elements tool is used to create a displaced view of an 
element or group of elements. The element or group of elements of which a displaced view is 
created is called the displacement set. The displaced view of element is used to see the internal 
parts of the building which are obstructed due to roofs, and walls of the building. This helps 
the designer to view the 3D model of the building more closely. This tool is used to move the 
displacement set along the X, Y, and Z axes upto a specified distance away from a model.   

To create displace views in a project choose {3D} from the 3D View in the Project Browser 
and then use the View Cube tool from the drawing and align the current view to front view. 
After aligning, select all the elements above the ground floor; the Modify | Multi Select tab 
will be displayed. In this tab, choose the Displace Elements tool from the View panel as shown 
in Figure 16-20; the Modify | Displacement set tab will be displayed. Also, in the drawing 
area, the xyz icon will be displayed. The xyz icon help drag the selected elements in X, Y, or Z 
directions. On doing so, the element will get displaced to the desired direction. Alternatively, 
in the Properties palette, you can enter desired value in the value field corresponding to the 
X, Y, or Z instance parameter. Now, choose the Modify button in the Select panel to clear the 
selection. After displacing element, trace the path of the displaced element. To do so, choose 
the Path tool from the Displacement Sets panel; the cursor will change its shape. Move the 
cursor on the building element in the displacement sets, a dotted line will appear. Click to add 
the path. Figure 16-21 shows the path of the building added in the displacement sets. Now, you 
can modify the inside elements if required. After modifying, the inside elements of a building, 
you can reset the building model. To do so, choose the Reset button from the Displacement 
Sets panel; the building will reset to its original position.

Figure 16-20  The Displace Elements tool in the Modify / Multi Select tab
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Figure 16-21  The highlighted path added in a building 
model

USING PROJECT PHASING TOOLS
In some architectural projects, building works need to be carried out in phases. Phases represent 
the time periods over which a project is to be executed. One of the examples of such a project is 
building a large institutional complex that requires the construction work of different buildings 
within the stipulated time. Another example can be an interior renovation project, in which 
certain building components may need to be constructed and demolished over a number of 
stages or phases. Revit enables the architects and the interior designers to represent phases in 
the views of a building model. Using the phasing tools, you can generate 3D views that show the 
phase-wise addition or demolition of building components and the resulting building model 
as well.

Understanding Phasing Concepts 
To use the phasing tools in Revit, you first need to understand the basic concepts of the working 
of these tools and their usage. You can create any number of phases for a project and specify 
them for the building elements. Revit allows you to specify phasing for views and also for the 
building components. Each new building component added to a project has the Phase Created 
and Phase Demolished instance parameters associated with it. These instance properties can 
be modified. The Phase Created instance parameter indicates the phase during which the 
element will be added and the Phase Demolished instance parameter shows the phase in which 
it will be demolished. By default, you can assign one of the following values for these instance 
parameters in a building element: 

New		  Element created in the current phase
Existing	 Element created in an earlier phase and continues to exist in the current 		
		  phase
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Demolished	 Element created in an earlier phase and demolished in the current phase
Temporary	 Element created and demolished in the current phase

Creating Phases and Setting Phase Filters
When you open a new project, by default, it has two predefined phases, Existing and New 
Construction. You can specify any number of additional phases in a project. To do so, choose 
the Phases tool from the Phasing panel of the Manage tab; the Phasing dialog box will be 
displayed, as shown in Figure 16-22. This dialog box displays two predefined phases. You can 
rename these phases by clicking in the Name column and then entering a new name.

The Before and After buttons in the Insert area of the Phasing dialog box are used to add new 
phases before and after a selected phase. The new phases added can suitably be renamed and 
arranged according to their time period, from the past to the future. 

Figure 16-22  The Phasing dialog box 

You can choose the Previous or Next button from the Combine with area of the Phasing dialog 
box to combine the selected phase with the previous or next phase in the Project Phases list. 
The phases cannot be rearranged after they have been created. The appearance of building 
components in various phases can be controlled by setting phase filters. A phase filter is a tool 
that determines the visibility of a building element in a view, based on its phase condition. The 
Phase Filters tab in the Phasing dialog box displays the preloaded phase filters. The description 
of these filters is given next.

Show All		  Shows the new, existing, demolished, and temporary components in 
			   that particular phase. Components demolished in the earlier phases 
			   are not displayed
Show Complete		 Shows the components in the last phase 
Show Demo+New	 Shows the demolished and new components
Show New		  Shows the elements added to a particular phase
Show Previous+Demo	 Shows the existing and demolished components
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Show Previous+New	 Shows the existing and new components
Show Previous Phase	 Shows all components from the previous phase

You can use the New button to add new phase filters and set the parameters for the same. Set the 
parameters for the display of components in different phases using the Graphic Overrides tab.

Specifying Phases for Project Views
To create project views for different phases, you need to create the copies of the project view. 
Right-click on the name of the project view in the Project Browser, and then choose Duplicate 
View > Duplicate from the shortcut menu to create a duplicate view. Open each project view 
and set its phasing parameters. Click on the project view and then from the Properties palette 
select appropriate options from the drop-down lists corresponding to the Phase Filter and Phase 
parameters. Revit applies the rules for the specified phase filter and displays the components 
that belong to the selected phase, in the current project view. This procedure can be adopted 
for all copies of the project view. You can display components for each phase of a project.

Using the Demolish Tool to Specify Phases for Building Elements
Choose the Demolish tool from the Phasing panel of the Manage tab to demolish components. 
When you demolish a component, it appears as a dashed line in the view in which it was 
demolished. Set the appropriate phase filter to display the demolished components in other 
project views. When you select an element from the drawing area, the value for the Phase 
Demolished parameter in the Properties palette indicates the phase in which the component 
was demolished. You can prepare demolition plans for the building elements in each phase.

LINKING BUILDING MODELS AND SHARING 
COORDINATES
Some large projects may require you to develop independent building models and later combine 
them into a comprehensive project. For example, in a large educational campus project, you may 
need to independently develop the building models of the administrative building, academic 
complex, faculty residences, student accommodation, and so on, and later add them into a 
single host project file. You can do so by using Revit’s linking and sharing coordinates tools that 
enable you to link models and share their coordinates within a single host project file. These 
tools also enable you to work on building models in other project files. When you link projects, 
you need to share the coordinates of the host model with the linked model so that the linked files 
retain their positions. To do so, invoke the Acquire Coordinates tool from Manage > Project 
Locations > Coordinates drop-down and then select the linked project in your drawing. On 
selecting the linked project, the origin of the linked project’s shared coordinate becomes the 
origin of the host project’s shared coordinates. Revit Architecture provides the flexibility and 
easy management of the linked models by enhancing the linking of the models and organizing 
the linked files in the Project Browser. You can easily access the linked files, the nested link files, 
and the Link Manager from the Project Browser. The nested Revit links are also listed under 
the Revit Links head with the host link in the Project Browser.
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Linking or Importing Models
To link or import one project to the other, open the host project file and choose the Insert tab, 
options in this tab will be displayed, as shown in Figure 16-23. You can choose the options from 
the Import or Link panel of the Insert tab depending upon the file format to be imported or 
linked. Before you import or link any file, make sure that the file contains the data and geometry 
that are compatible with Revit Architecture. To link .dwg, .dwf, .skp, .dgn, and other files, choose 
the Link CAD tool from the Link panel of the Insert tab; the Link CAD Formats dialog box 
will be displayed, as shown in Figure 16-24. In this dialog box, select the file type from the Files 
of type drop-down list. Next, browse to the required location and select the file. The options in 
this dialog box are discussed next.

Figure 16-23  The linking and the importing options in the Insert tab

Figure 16-24  The Link CAD Formats dialog box 

Linking or Importing Files 
In Revit Architecture, you can link or import the CAD files to the current project. If a CAD 
file is linked to a project, all changes made in it will simultaneously be updated in the project. 
However, if you import a file in a project, it will remain unchanged, irrespective of any changes 
made in the file linked to the project.
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To link a CAD file to a project, choose the Link CAD tool from the Link panel of the Insert tab 
of the ribbon; the Link CAD Formats dialog box will be displayed. Select the desired CAD file 
and then choose Open; the selected CAD file will be displayed and linked to the Revit project 
file. Similarly, you can import a CAD file to a project. To do so, choose the Import CAD tool 
from the Import panel of the Insert tab; the Import CAD Formats dialog box will be displayed. 
Select the desired CAD file and choose Open; the selected file will be imported to the Revit file.  
   
While importing or linking a CAD file to your project, you can control its availability either in all 
views or only in the current view. If you select the Current view only check box in the Import 
CAD Formats or Link CAD Formats dialog box, you can import or link the drawing in the CAD 
format only in the active Revit Architecture view. However, if you clear the check box, you can 
import the drawing in the CAD format in all views of Revit Architecture. In this case, the lines 
and geometries of the drawing will be imported without the text.

The Layers/Levels drop-down list in the Import CAD Formats or Link CAD Formats dialog 
box allows you to specify the layers to be imported from the linked file. On selecting All from 
the Layers/Levels drop-down list, all layers will be imported or linked. The Visible options in 
this list allow you to import or link the visible layers in the view. The Specify option allows you 
to import the specified layers and levels in the project.

Note
If you need to display layers of the linked files that were not selected or visible initially, you can get 
them by deleting the present link and relinking the file.
 

Assigning Colors to Imported or Linked Files  
In Revit Architecture, you can import or link files in various colors. The Color drop-down 
list in the Import CAD Formats or Link CAD Formats dialog box allows you to link various  
colors to the displayed files. The options in this drop-down list are discussed next.

Black and white
If this option is selected, the file will be imported in black and white.

Preserve colors
If this option is selected, you can retain the original colors of the file.

Invert colors
If this option is selected, the color of the objects will be inverted. As a result, the dark colored 
objects will be converted to light colored objects and vice-versa. This option is useful for 
improving the clarity of lines and texts of the imported files to make them reader-friendly.

Positioning Imported Files
While importing or linking files to Revit Architecture, it is important that the imported geometries 
and texts are placed at correct position. Revit allows you to align the imported or linked files to the 
current geometry by providing various options  in the Positioning drop-down list of the Import 
CAD Formats or Link CAD Formats dialog box. Depending on the project requirement, you 
can position the imported or linked files automatically or manually in the host project. Various 
positioning options that can be used to position the imported file automatically are given next.
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Auto - Center to Center		 Revit will place the center of the footprint of the imported 	
			   model geometry at the center of the model.

Auto - Origin to Origin		 The   world     origin   of    the    imported model  geometry   will   be    aligned  
				    to the internal origin of the host model.

To place the linked model manually, select any of the following options from the Positioning 
drop-down list: 

Manual - Origin 		  The origin of the linked or imported project will be attached  
				    to the cursor.

Manual - Center	 	 The center of the linked project will be attached to the  
				    cursor.

You can place the origin or the base point of the imported or linked files at the selected level by 
selecting the options from the Place at drop-down list. You can also select the Orient to View 
check box to place the linked or imported file at the same orientation as that of the current view.

Note
Revit uses the coordinate system for its project, but this system is not visible to users. The center of 
the linked project is the geometric center of its footprint and may change with the change in the 
model geometry.

Setting Units for Imported or Linked Files 
You can set the measurement unit of the imported geometry using the Import units drop-down 
list available in the Import CAD Formats or Link CAD Formats dialog box. If you select the 
Auto-Detect option, the imported or linked files will be inserted in the unit in which they were 
created. For example, if you import a file that has been created in AutoCAD using Imperial 
(English) as its default unit, Revit will automatically adopt feet and inches as the units for 
the imported geometry in the current project. Similarly, you can select other units from the 
Import-units drop-down list as per your project requirement. 

Linking Revit Models
To link or import the Revit files, choose the Link Revit tool from the Link panel of the Insert tab; 
the Import/Link RVT dialog box will be displayed, as shown in Figure 16-25. In this dialog box, 
navigate to the desired folder and select the file to be linked to the host project; the preview 
image of the selected project file will be displayed in the Preview pane. Choose the Open button 
to open the file. Select the appropriate positioning option from the Positioning area to position 
the model automatically or manually in the host project.

Linked Revit Models in the Project Browser
The linked Revit models are listed in the Project Browser under the Revit Links head. You can 
access the linked model files from the Project Browser. You can also link a new file from the 
Project Browser. To do so, select Revit Links sub-node in the Project Browser and right-click; 
a shortcut menu will be displayed. Choose New Link from the shortcut menu; the Import/Link 
RVT dialog box will be displayed. Select the file to be linked from this dialog box. Similarly, you 
can access the link manager by choosing Manage Links from the shortcut menu and manage 
the links. You can also open the linked model in the project by dragging it from the Project 
Browser and dropping it in the project view.
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Figure 16-25  The Import/Link RVT dialog box 

Nested Linked Models
If you import a Revit model that already contains a linked file, the linked file becomes a nested 
link file. You can control the visibility of the nested linked models in the host project file. When 
you link a file, by default, the nested link model will not be displayed in the host project file and 
the Nested Links Invisible message box will be displayed, as shown in Figure 16-26, indicating 
that the elements in the linked model will not be visible in the project view. This message is 
displayed because by default the Overlay value is set for the Reference Type option in the 
Manage Links dialog box. To display the nested link model in the host model, open the parent 
link view in which the file is linked and choose the Manage Links tool in the Import panel 
of Insert tab; the Manage Links dialog box will be displayed. Choose the Revit tab from the 
dialog box; the name of the linked file will be displayed in the Linked Name column. Click in 
the Reference Type column and change the value in this column to Attachment. Now, link the 
parent model file to the host project; the nested linked model will be displayed in the project. 
If you do not want to display the nested model elements in the host project, accept the default 
Overlay option. When you select the Overlay option, Revit does not load the linked model when 
its host is linked to another model. The following example explains the use of the Overlay and 
Attachment options in linking models. Example: Project A consists of a single horizontal wall, as 
shown in Figure 16-27. The project A is imported and linked to the project B that consists of a 
single vertical wall. Figure 16-28 shows the Project B and Figure 16-29 shows the project A linked 
to the project B. The project B becomes a host for project A and project A becomes a link for 
project B. Now, the project B along with the linked project A (consisting of both horizontal and 
vertical walls) is imported to another project, Project C, which consists of a single inclined wall. 
In this case, the project A (consisting of a horizontal wall) becomes a nested link. Figure 16-30 
shows the project C after linking with the project B. You will notice that the horizontal wall of 
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project A will not be displayed in the project C. This is because the Overlay option is selected 
in the Reference Type column of the Manage Links dialog box. To display the horizontal wall 
of the project A (nested model) in the project C, open the project B parent view, consisting of 
vertical and horizontal walls. Next, choose the Manage Links tool from the Link panel in the 
Insert tab; the Manage Links dialog box will be displayed. Choose the Revit tab in the dialog 
box; the project A will be displayed in the Linked File column. Select the Attachment option 
for the linked project A in the Reference Type column and choose the OK button. Close the 
parent view and import the project B into the project C. Now, the horizontal wall of the project 
A (nested link) will be displayed in the project C, as shown in Figure 16-31. The project A will 
also be added in the Project Browser as the nested link under the parent project B, as shown 
in Figure 16-32.

Figure 16-26  The Nested Links Invisible message box

Figure 16-27  Project A consisting of a horizontal wall

Figure 16-28  Project B consisting of a vertical wall Figure 16-29  Project A linked to project B
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Figure 16-30  The host project B linked to project 
C with the Overlay option selected

Figure 16-31  Project B linked to Project C after 
selecting the Attachment option for project A

Figure 16-32  Project A added as a nested link 
with parent project B in the Project Browser

Converting Linked Models to Groups - Binding Links
You can convert the linked Revit models into groups in the host project. You can do so by binding 
the linked model with the host project, thereby making it a part of the host project. After binding 
the linked model, the model geometry will be transformed into a group, and therefore making 
changes in the host project will be easier for you. To bind and group a linked model, select 
the linked model in the drawing; the Modify | RVT Links tab will be displayed. Choose the 
Bind Link tool from the Link panel; the Bind Link Options dialog box will be displayed, as 
shown in Figure 16-33. In the dialog box, select the Attached Details, Levels, and Grids check 
boxes to include them in the group and then choose the OK button; the linked model will be 
converted into a group. If there is any group in the project with the same name as that of the 
linked Revit model, a dialog box with a message will be displayed prompting you to replace the 
group. Choose Yes to replace the existing group or choose No to rename the group. On choosing 
Yes, another dialog box with a message to remove the link will be displayed, as shown in Figure 
16-34. Choose the Remove Link button in the dialog box to remove the link or choose the OK 
button to remove it later; the linked model will be transformed into a group and listed in the 
Project Browser under the Groups head.
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Figure 16-33  The Bind Link Options dialog box

                              

Figure 16-34  The message box displayed on binding the link

Controlling the Visibility of Linked and Nested Linked Models 
You can control the visibility of the linked and nested Revit linked models in the host project 
file. Also, you can control the visibility settings, detail level, and display settings of the building 
elements in the linked project. To modify the visibility settings in the host project, open the view 
in which the visibility settings are to be modified. Choose the Visibility/ Graphics tool from the 
Graphics panel in the View tab; the Visibility/Graphic Overrides dialog box will be displayed. 
The Revit Links tab in this dialog box displays the linked projects, as shown in Figure 16-35. 
This tab will be displayed only when the files are linked in your project. Click on the project 
name to display the categories of components in the building model. Use the Halftone and 
Display Settings columns to modify the visibility settings and filters of the components of each 
linked project. The By Host View button in the Display Settings column can be used to control 
the visibility of the nested links, phases, and phase filters.

Click in the Display Settings column; the RVT Link Display Settings dialog box will be displayed. 
Choose the Basics tab from the dialog box. If you select the By host view radio button in this 
tab, the nested linked model will be able to use the same visibility and graphics settings as in 
the host view. On selecting the By linked view radio button, the nested linked model adopt the 
visibility settings of the parent model to which it was linked originally. On selecting this radio 
button, the Linked view drop-down list will be enabled. You can select the view in which you 
want to display the linked model from this list. 
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On selecting the Custom radio button, all the options in the Basics tab will be enabled. From 
the Nested links drop-down list, select the By parent link option to apply the visibility settings 
of the parent model to the nested link model. If you select By linked view from the drop-down 
list, the visibility and graphics override settings of the top level nested model will be applied to 
the linked model. The top level model is the first nested linked model. In the example explained 
earlier, project A will be the top-level nested model. Choose the Apply button to view the changes 
in the project and then choose the OK button.

Figure 16-35  The Revit Links tab of the Visibility/Graphic Overrides dialog box 

Managing Links
Revit enables you to manage links between the host and the linked projects. To do so, choose 
the Manage Links tool from the Link panel of the Insert tab; the Manage Links dialog box 
will be displayed with a list of linked projects, as shown in Figure 16-36.
 
The Status column in the Manage Links dialog box informs whether the linked project file is 
loaded in the host project. The Reference Type column in the dialog box provides you with 
the options to display or hide the nested linked Revit models. The default Overlay value in 
the Reference Type column restricts the loading and display of the nested linked models in the 
host project. The Positions Not Saved column of the dialog box indicates whether the linked 
models location is saved in its shared coordinate system or not. The shared coordinates take care 
of the mutual positions of multiple interlinked files. The Saved Path column shows the path of 
the linked file on your computer. The Path Type column is used to specify whether the saved 
path of the linked file is relative or absolute. It is recommended to keep the linked path relative 
because it enables Revit to trace and re-establish the link, in case the host and linked projects 
are moved to a different folder.
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Figure 16-36  The Manage Links dialog box 

Including Elements of Linked Models in Schedules
In Autodesk Revit, you can include different model elements from a linked file such as walls, 
doors, windows, and so on into a schedule. To do so, select the existing schedule of the 
current project from the Schedules/Quantities(all) head in the Project Browser; the instance 
properties of the selected schedule will be displayed in the Properties palette. In the value 
column of the palette, choose Edit in the Fields parameter; the Schedule Properties dialog 
box will be displayed. Select the Include elements in Linked files check box to include the 
elements from a linked file, if required. To include project information from a linked file, select 
Project Information from the Select available fields from drop-down list. Select the example  
explained earlier, project A will be the top-level nested model. Choose the Apply button to view 
the changes in the project and then choose the OK button.

Applying the Color Schemes of the Host Model to Rooms and 
Areas of the Linked Models 
In Autodesk Revit, you can apply the color scheme assigned to the rooms and areas in the host 
file to the rooms and areas in the linked file. To do so, choose the Color Schemes tool from the 
Room & Area panel of the Architecture tab; the Edit Color Scheme dialog box will be displayed. 
In this dialog box, make sure that the Include Elements from linked files check box is selected 
in the Options area. Choose the OK button to close the dialog box. Next, choose the Visibility/
Graphics tool from the Graphics panel of the View tab; the Visibility/Graphic Override dialog 
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box will be displayed for the current view. Next, choose the Revit Links tab from the dialog box. 
Select the linked model to which you want to apply the color scheme of the host file. Choose the 
default By Host View button in the Display Settings column; the RVT Links Display Settings 
dialog box will be displayed. You can select the By host view or Custom radio button in this 
dialog box if the linked model consists of rooms. However, if the linked model consists of only 
areas, select the Custom radio button. On selecting the Custom radio button, all options in the 
Basics tab will be enabled. From the Linked view drop-down list, select the view of the linked 
model to which you want to apply the color scheme. Next, from the Color Fill drop-down list, 
select the By host view option. Choose the Apply button to apply the changes. Next, choose 
the OK button to close the dialog box. 

You can also display the room areas and the area boundary of the linked file in the host project. 
To do so, open the parent view that contains the linked model and select the By linked view 
radio button in the RVT Links Display Settings dialog box. Select the required plan view 
from the Linked View drop-down list and choose the OK button; the room areas and the area 
boundaries in the linked model will be displayed in the host file.

Copying Linked Model Elements 
You can copy the elements of the linked model to the host model. To do so, move the cursor 
over the linked model and press TAB to highlight the required elements, in case the file has a 
nested link. Click on the element when it is highlighted and choose the Copy to Clipboard tool 
from the Clipboard panel of the Modify | RVT Links tab. Next, open the host file in which 
you want to paste the element and choose the Paste from Clipboard tool from the Clipboard 
panel; the linked model file from which you have selected the element will be displayed in the 
Project Browser under the Revit Links head. You can place the element either by clicking at 
the required location in the drawing area or by dragging the linked model from the Project 
Browser and dropping it in the drawing area. 

WORKSHARING CONCEPTS
Worksharing is a method of distributing work among people involved in a project, and 
accomplishing it within the stipulated period of time. In Worksharing, each person involved 
in the project is assigned a task that has to be accomplished through proper planning and by 
coordinating with the other members of the team.

In a large scale building project, worksharing is the most important method to finish the 
project in time and meet the quality requirements that are set during the process. Generally, in 
a large-scale building project, worksharing is based on the specialization of work. For example, 
professionals like Structural Engineers, Architects, Interior Architects, Electrical Engineers, and 
Plumbing Engineers can be involved in their respective fields to accomplish the project. So, 
the distribution of work at the primary stage is made on the basis of the area of specialization. 
Each professional has his own set of work to perform for the accomplishment of the project. 
Therefore, worksharing is an important process that is needed to be implemented efficiently 
to complete the project in time.  
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Worksharing Using Workset Tools 
In Autodesk Revit, you work in an integrated single file model. This implies that all the 
construction related information and documents are available in a single model file and this 
forms the basis of the worksharing process.

The process of worksharing can be implemented using the Worksets tool. Worksets are a collection 
of building elements such as walls, doors, windows, and others that define the domain and 
ownership of the user in a project. For example, a project may contain building elements like 
beams, columns, furniture, walls, doors, and so on. In a worksharing environment, you can 
assign each element to a workset, which defines its ownership to the user, thereby restricting 
other users to change or modify it in the project without prior permission. Therefore, only one 
user can edit a workset at a time. 

When you start a new Revit Architecture project, the worksharing is not activated by default 
because the software assumes that you are working in a single user environment. When you 
transform your project from a single user to a multi-tasking environment, you need to understand 
the concept of central file system and the utility of using the worksets. A central file is a master 
file of the project and stores the entire building information of the building and its model. This 
file is connected and shared by all other files representing individual users and it monitors the 
progress of the entire project. The files that are shared and connected to the central file are 
called local files. These files are the copy of the central file and are saved on the individual 
users workstation locally. These files can also be saved in a specified network location, thereby 
differentiating them from the central file. These local files act as an interfacing mechanism for 
working on the central file. 

Process of Worksharing 
With the start of the new project, you start creating the basic building geometry like the shell 
of the model with basic detailing. But as the project progresses, you underscore the need of 
sharing the project with multiple users for which you need to speed up the process of work 
toward completion. To invite multiple users to work in your project, you save the file that you 
have worked as a central file in a network location and make copies of it in the local hard drives 
of individual team members. By doing so, you divide the work into different parts. Everybody will 
start working with the copied central file from his or her individual workstation. Before starting 
with the file, each member working in the project is instructed to rename the copied central 
file in their individual hard drive location and then open it in Revit Architecture to proceed 
further. The flow diagram in Figure 16-37 explains in brief the process of worksharing in brief.

Elements in each separate file are tied to the ownership rule linked to the central file. This 
restricts individual team members to edit an element in his or her local file, which is owned by 
someone in local files. In the worksharing process, the central file behaves as the controller of 
all elements that are shared by members. 
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Figure 16-37  Flow diagram explaining the Worksharing process

Using Worksets Tool
To enable the process of worksharing choose the Worksets tool from the Manage Collaboration 
panel of the Collaborate tab. Autodesk Revit displays the Worksets dialog box, as shown in 
Figure 16-38.

In the Worksets dialog box, there are five different columns, Name, Editable, Owner, Borrowers, 
and Opened, as shown in Figure 16-39. The Name column displays the worksets that are defined 
or predefined in the project. The Editable column shows the status of the modification of elements 
and components of the workset in the project. The Owner column specifies the ownership of 
the particular workset in the project. The ownership of the workset refers to the name of the 
user who had created it. This name refers to the user of the master file or the user of the local 
file. By default, Revit Architecture denotes the name of the user, which is determined by the 
log-on name of the operating system. In Revit, before enabling the workset, you can change 
the username. To do so, choose the Options button from the File menu; the Options dialog 
box will be displayed. In this dialog box, choose the General tab and specify a new name in the 
Username edit box, as shown in Figure 16-39.



Using Advanced Features							           16-39

Figure 16-38  The Worksets dialog box displaying different columns

Figure 16-39  The Options dialog box 
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The Borrowers column in the Worksets dialog box displays the name of the user currently using 
the elements of the worksets that do not belong to him or her. In this process, the owner or any 
other user can only use the borrowed worksets, if the borrower allows to do so.

The Opened column is used to select a workset definition. There are two options in this column: 
Yes and No. These options can be used to control the visibility of elements in a group. By default, 
all worksets in the Worksets dialog box are assigned the Yes option. It means all elements and 
components of these worksets are visible in the file. But, if you choose the No option, the visibility 
of elements and components of worksets will be disabled. 

The Visible in View column allows you to show workset in all views. This column carries 
checkboxes corresponding to the Shared Level and Grids and Workset 1 Name parameters. 
These check boxes are selected by default. On clearing these check boxes, the workset will not 
be displayed in any view.

You can select various options from the Active workset drop-down list located at the top in the 
Worksets dialog box. This drop-down list is used to select those worksets that are user defined 
and have the status Yes in the Opened column of the Worksets dialog box. Select the appropriate 
workset available in the drop-down list to make it current. If you select the Gray Inactive Workset 
Graphics check box, the elements that do not belong to the active workset will turn gray in the 
drawing area and the active elements will be displayed in black. If you clear this check box, all 
elements in the drawing area, irrespective of whether they are active or inactive, will turn black.

To create a new workset definition, choose the New button in the Worksets dialog box; the New 
Workset dialog box will be displayed, as shown in Figure 16-40. Enter the name of the workset 
in the Enter new workset name edit box and choose the OK button to return to the Worksets 
dialog box.

Figure 16-40  The New Workset dialog box

The Delete button in the Worksets dialog box is used to completely remove the selected 
workset. You can delete only that workset definition which is editable. When you choose the 
Delete button, the Delete Workset dialog box will be displayed, as shown in Figure 16-41. This 
dialog box can be used to delete the elements belonging to the deleted workset or to move these 
elements to a different workset definition. If you select the Deleted radio button in this dialog 
box, elements that belong to the workset being deleted, will be deleted. Similarly, if you want 
to move these elements to a different workset, select the Moved to radio button and then select 
the appropriate workset from the Moved to drop-down list. Choose the OK button to return to 
the Worksets dialog box. You can rename the editable worksets. To do so, select the workset in 
the Name column and choose the Rename button; the Rename dialog box will be displayed. 
Specify a name in the New edit box to change the name of the selected workset. The Open and 
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Close buttons in the Worksets dialog box are used to change the status of the selected workset 
in the Opened column to Yes and No, respectively. Similarly, the Editable and Non Editable 
buttons can also be used to change the status of the selected workset in the Editable column 
to Yes and No, respectively. While using the Workset for the first time, if you choose the Non 
Editable button before saving the file to the central file, the Revit warning message box will be 
displayed. This message box warns you to save your file to central file.

Figure 16-41  The Delete Workset dialog box

In Autodesk Revit, you can define four different types of worksets. These worksets are 
User-Created, Family, Project Standards, and View worksets. These Worksets are explained next 
in detail.

User-Created Workset
A user can define and modify this workset as per the requirements. As a user, you can create 
your own workset and assign different elements and components to it. When you invoke 
the Worksets dialog box, two worksets, Shared Levels and Grids and Workset1 are created 
by default. The Shared Levels and Grids workset is automatically defined for the existing 
levels and grids in your drawing and the Workset1 workset is defined for all elements and 
components created by you.

View Workset
In Revit Architecture, each view has a dedicated view workset that contains a dedicated view 
property and view-specific elements like dimensions, tags, text, and others. To display view 
worksets in the Worksets dialog box, you need to select the Views check box in the Show 
area of this dialog box.

The view-specific elements cannot be moved to other worksets. To own a view in a workset, 
select the view from the Project Browser and click the right mouse button over it; a cascading 
menu will be displayed. Choose the Make Workset Editable option from it to own the view 
in the workset. 

Family Workset 
When you load a family into your project, a workset is automatically created for it. You can 
view the family workset by selecting the Families check box in the Show area of the Worksets 
dialog box. To own a family, select it in the Worksets dialog box and change the default 
option No in the Editable column to Yes from the available drop-down list.
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Project Standards Workset
The project standards worksets are used to set projects. You can view these worksets by select-
ing the Project Standards check box in the Worksets dialog box. In the Worksets dialog box, 
you can own a particular workset by changing the default option No in the Editable column 
to Yes from the available drop-down list for the selected workset. Materials, Line Styles, 
and Callout Tags are good examples of these worksets. 

Once you have created and edited your workset, you can exit the Worksets dialog box by choosing 
the OK button from it. You can disable the worksharing in the project by choosing the Disable 
Worksharing tool from the expanded Workset panel of the Collaborate tab.
 
Synchronizing with Central 
If you choose Save from the File menu after enabling the worksets for the first time, the Save 
File as Central message box will be displayed. On choosing the Yes button from this message 
box, the current project file will become the central file. If you choose the No button, a message 
box will be displayed informing that the file is not saved. Choose the Close button from this 
message box to close it. To save the file as a central file, choose Save As > Project from the File 
menu; the Save As dialog box will be displayed. Browse to a different location, specify a name 
in the File name edit box, and then choose Save; the file will be saved as a central file. Now, 
you can synchronize a project with the central file. To do so, choose the Synchronize Now tool 
from Collaborate > Synchronize > Synchronize with Central drop-down, as shown in Figure 
16-42; the current project will be synchronized with the central file. As a result, all changes made 
to the current file will reflect in the central file as well. 

Figure 16-42  Choosing the Synchronize Now 
tool from the Collaborate tab

Note
A central file is a master project file that stores the information about the ownership of all worksets 
in a project. The central file should not be used for working when there is only one user. 

Creating a Local File
While using a workset, you do not need to be connected to the system network to save the 
changes. For this, Autodesk Revit allows you to work on a local file of the portion of the building 
model file. A local file can be created by opening the central file and using the Save As tool to 
create a project file. This local file is only accessible to the user. The team member can work on 
the file and save it to the central file at regular intervals. The changes made to the workset are 
then propagated to all team members through the central file.
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Saving Methodology in Worksharing 
While working in a worksharing environment, it is important to learn the methods of saving 
your files. There are two methods of saving a file and sharing your files with others by saving a 
local file and synchronizing with the central file. You can save your file as a local file by choosing  
Save from the File menu. The Save option is generally used to save the local file. Using this 
method, you can just secure the work that you have done without affecting the worksharing 
process. The other method is to synchronize the file with central. The Synchronize with Central 
option is used to publish the work in the central file. The moment you synchronize your file to 
central, you acquire the changes made by other team members to their local models, provided 
they had also saved their files to the central file at that particular interval.
  
In Revit Architecture, you can synchronize a local file with the central file by choosing the 
Synchronize Now tool or the Synchronize and Modify Settings tool from the Synchronize panel. 
If you choose the Synchronize Now tool, the current project file will be saved to central. On 
choosing the Synchronize and Modify Settings tool, the Synchronize with Central dialog box 
will be displayed. This dialog box allows you to customize the way you save your file to central. 
In the Synchronize with Central dialog box, the Central Model Location text box shows the 
path for the central file in the network. You can use the Browse button to change the path, if 
required. After synchronizing the required file with central, you can use various check boxes to 
relinquish borrowed elements and various worksets, if required. The Comment text box in the 
Synchronize with Central dialog box allows you to publish the message throughout the team 
members regarding the changes you made in the particular session. 

Reloading Files
In a worksharing environment, it is necessary to update your model corresponding to the changes 
made and saved to the central file by other team members. To do so, choose the Reload Latest 
tool from the Synchronize panel of the Collaborate tab. Alternatively, press RL in the keyboard 
to reload the file with the latest changes made in it.  

Element Ownership Concepts 
In a worksharing environment, you need to know about the status of ownership of a particular 
element or workset in the project. To check the status of ownership of an element, select it and 
check whether you can modify or reposition it. If you own the element, it will be highlighted in 
blue and can be modified and repositioned. In case, you do not own the element that you have 
selected, it will be highlighted in red, but with a blue icon attached to it indicating it cannot be 
modified. 

In Autodesk Revit, you can use color to visualize the status of workshared elements. To do so, 
choose the Worksharing Display Off option from the View Control Bar and then select various 
options from the flyout displayed. You can use these options to customize the display modes to 
visually distinguish the following in a view: borrowed elements, current element owners, model 
updates, and element checkout status. 
  
In Revit Architecture, it is easy to retain the ownership status of a particular element or 
a component. There are several methods to get the ownership of a particular element or a workset 
and that discussed next. One of the common methods of owning an element or a component 
is by trying to move or edit it. If you do so, Autodesk Revit facilitates you to own it, provided it 
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is not owned by anyone else in the worksharing environment. You can also get the ownership 
of an element by clicking the left mouse button over the blue icon that is displayed along with 
it. Next, to modify or edit an element, select it and click on the right mouse button and then 
choose the Make Elements Editable option from the shortcut menu displayed. In context to 
ownership, you need to know other concepts like Borrowing Elements, Placing Requests, and 
Granting Requests. These concepts are discussed next. Sometimes, you or your team member 
may need to take the ownership of some of the elements within a particular workset rather than 
the entire workset. In such a situation, you can borrow elements from other users. To do so, 
select the element to be borrowed and click on the blue icon displayed with the element; the 
Revit 2020 dialog box will be displayed with a warning message regarding the ownership of the 
element. This message box also informs you to place request to the owner to use it in your file. 
Choose the Place Request button in the dialog box to request the owner to grant permission 
for using the element. On doing so, the Check Editability Grants dialog box will be invoked. 
Choose the Check Now button from the dialog box to check the status of the request made and 
choose the Continue button to resume the work.

Autodesk Revit also provides you with the flexibility to borrow components from worksets that 
are not editable by a team member. This is possible by getting permission from the user of the 
component, and then, the borrowed elements or components can be edited, saved to central, 
and relinquished.  In this release, the process of granting or denying permission to borrow an 
element or a component for editing it has been made more fast and interactive.

PURGING UNUSED ELEMENT FAMILIES 
The Purge Unused tool enables you to unload families and family types from the project file. 
This reduces the file size to a considerable extent. However, in case the worksets have been 
enabled, they must be opened to use this tool.

Invoke the Purge Unused tool from the Settings panel of the Manage tab; the Purged unused 
dialog box will be displayed, as shown in Figure 16-43. It displays the list of element categories 
that can be unloaded. You can select the families, groups, or annotation types and choose the 
OK button to purge them. You can also use the Check All and Check None buttons for the 
selection. In Autodesk Revit, you can also purge unused materials.
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Figure 16-43  The Purge unused dialog box

TRANSFERRING PROJECT STANDARDS
The Transfer Project Standards tool allows you to copy and paste project standards from one 
project to another. The project standards that can be transferred include family types, materials, 
view templates, and object types.  

To transfer project standards, you first need to open the source and target projects. In the target 
project, choose the Transfer Project Standards tool from the Settings panel of the Manage tab. 
On doing so, the Select Items To Copy dialog box will be displayed, as shown in Figure 16-44. 
Select the source project from the Copy from drop-down list. From the list box in the dialog 
box, select the required project standards to be copied. Now, choose the OK button; the selected 
project standards of the source project will be copied to the target project.
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Figure 16-44  The Select Items To Copy dialog box

ORGANIZING THE PROJECT BROWSER
Autodesk Revit also enables you to organize the Project 

Figure 16-45  An example of 
organised Project Browser 

Browser based on the documents to be prepared for the 
project. Invoke the Browser Organization tool from View > 
Windows > User Interface drop-down; the Browser 
Organization dialog box is displayed. The Views tab of this 
dialog box displays the parameters that can be selected 
for organizing the browser. 

The Sheets tab can be used to view the sheets created for a 
project in the Project Browser. You can select an option to 
display the sheets. For example, you can rename the sheets 
created for a construction document package based on their 
sheet numbers. You can also select the Sheet Prefix check 
box in the Sheets tab to arrange the sheet display in the 
Project Browser. Figure 16-45 shows the Project Browser 
with such an arrangement.

GENERATING SHADOWS 
Another powerful feature provided in Autodesk Revit is the automatic generation of shadows 
based on the location of the sun with respect to the building. Shadows can be generated in the 
plan, elevation, section, or 3D view. To use this feature, open the view and click on the inclined 
arrow symbol (Graphic Display Options) in the Graphics panel of the View tab. On doing so, 
the Graphic Display Options dialog box will be displayed. In this dialog box, select the Cast 
Shadows check box. The intensity and direction of the shadow can also be controlled by using 
various options from Graphic Display Options dialog box. You can also choose the Shadow 
On button from the View Control Bar to generate shadows in the view.
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REVIT ARCHITECTURE SOLAR STUDIES 
Revit Architecture’s solar study helps you visualize and analyze the position of Sun and solar 
effects on buildings and sites in the real world at a specified time, date, duration, and location. 
You can analyze the effect of the Sun on the same building at different locations, such as Boston 
or Melbourne, by changing the location of the building from Boston to Melbourne. The Solar 
Study tools in Revit Architecture provide you with a wide range of locations to view the Sun and 
shadow effects on the same building or site but at different locations by generating the solar 
studies. Revit Architecture allows you to generate a still solar study in a single frame depicting 
the shadows at a specified date and time. It can also generate an animated three-dimensional 
solar study consisting of multiple frames depicting the shadow movements for a specified 
duration of time.

These solar studies help you analyze the amount and impact of the natural sunlight and shadows 
on the building and the site at a particular time in a day and at a particular location. It also 
helps you study the amount of lighting inside the building during different times of a day and 
year, at a particular location.

Generating Still Solar Study
You can generate a still solar study to see the shadow patterns based on the location of the 
building, or the azimuth and altitude of the Sun from the horizontal surface. To generate a 
still solar study, open the floor plan view or the site plan view. In the Properties palette of 
the opened view, set the value of the Orientation parameter to True North and choose the 
Apply button. Next, choose the Rotate True North tool from Manage > Project Location > 
Position drop-down; a rotation symbol will be displayed in the drawing area. In the Options 
Bar, specify the rotation angle in the Angle from Project to True North edit box. This angle 
specified in the edit box will be the angle difference of the building from the Project North 
direction to the True North direction. You can rotate the building to the East or West of the 
True North direction. Open the 3D view of the building and adjust the view of the building 
as required. Choose the View tab and then choose the inclined arrow symbol in the Graphics 
panel; the Graphic Display Options dialog box will be displayed, as shown in Figure 16-46.
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Figure 16-46  The Graphic Display Options dialog box

In the Model Display area of this dialog box, you can select an option from the Style drop-down 
list to specify the visual style of the model in the drawing area. In this drop-down list the Hidden 
Line option will be selected by default. The other options in this drop-down list are: Wireframe, 
Hidden Line, Shaded, Consistent Colors, and Realistic. The Show Edges check box will be 
disabled if you select Wireframe, Hidden Line, or Consistent Colors in the Style drop-down 
list. If this check box is active and selected then the edges of the model will be displayed in the 
Shaded or Realistic view style. The transparency of the surfaces of the model in the Shaded or 
Realistic view style, can be changed by the Transparency slider. The Silhouettes drop-down list 
is used to specify a line style that will help create a silhouette in the model. In the Shadows area, 
you can select the Cast Shadows check box to display shadows of a building model in a 3D view. 
You can select the Show Ambient Shadows check box to display shadow in the building model 
due to ambient light. In the Lighting area of the Graphic Display Options dialog box, choose 
the button on the right of the Sun Setting text; the Sun Settings dialog box will be displayed. 
By default, the Lighting radio button is selected in this dialog box. Select the Still radio button 
and in the Settings area and then set the time and date for the solar study in the Date and Time 
edit boxes. To specify the location for the solar study, choose the button on the right of the 
Location edit box; the Location Weather and Site dialog box will be displayed. In the Location 
tab of the dialog box, select the Default City List option from the Define Location by drop-
down list. On doing so, the options to set the locations will be displayed below this drop-down 
list. Specify the latitude and longitude in the Latitude and Longitude edit boxes for a precise 
solar study or select a city from the City drop-down list. Next, choose the OK button to close 
the Location Weather and Site dialog box. In the Sun Settings dialog box, clear the Ground 
Plane at Level check box to view the shadow pattern on the terrain. If you want the shadows to 
fall at a particular level or at the entry level, select the Ground Plane at Level check box and 
then select a level from the drop-down list displayed below it. Next, choose the OK button to 
return to the Graphic Display Options dialog box.
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If you want to create a solar study based on the azimuth and altitude of the Sun from the 
horizontal surface, select the Lighting radio button in the Sun Settings dialog box and specify 
the azimuth and altitude for the solar study. After you have specified the settings for the solar 
study, choose the OK button.

Tip
You can invoke the Graphic Display Options dialog box and control the display of shadows 
from the View Control Bar at the lower left corner of the screen.

Next, in the Lighting area of the Graphic Display Options dialog box, set the intensity of the sun, 
ambient light, and shadows by using the Sun, Ambient Light, and Shadows sliders, respectively. 
You can save the settings in the Graphic Display Options dialog box as a template. To do so, 
choose the Save as View Template button; the New View Template dialog box will be displayed. 
In this dialog box, enter a name for the settings in the Name edit box and choose the OK button; 
the View Templates dialog box will be displayed. In the View Properties area of this dialog 
box, you can use various options to edit the view properties of the current setting. Now, choose 
the OK button in the View Templates dialog box to close it. In the Graphic Display Options 
dialog box, choose the OK button to notice the shadows based on the specified date, time, and 
location. The shadow pattern generated in a Still solar study at the same location at different 
time during a day is shown in Figures 16-47 through 16-51. The options in the Photographic 
Exposure area helps you to create realistic appearances of objects in Realistic and Raytrace 
view style. On selecting the Realistic view style from the Style drop-down list, the Enabled check 
box is activated. Select the Enable check box; the options in the Exposure section are enabled. 
In the Exposure section, you can either select the Automatic radio button to enable automatic 
exposure of the model. Alternatively, you can select the Manual radio button. On doing so, the 
Value slider will be enabled where you can adjust exposure needed in the model. To improve 
the appearance of the model and make it more realistic, you can choose the Color Correction 
button corresponding to the Image parameter. On doing so, the Color Correction dialog box 
will be displayed. In this dialog box, you can adjust the values of Highlights, Shadow Intensity, 
Color Saturation, and White Point parameters by using their respective sliders. After setting 
the parameters, choose OK to close the Color Correction dialog box and return to Graphic 
Display Options dialog box.

Figure 16-47  After sunrise at around 6 AM Figure 16-48  In the morning at 10.25 AM
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Figure 16-49  In the afternoon at 1.25 PM Figure 16-50  In the evening at 4.30 PM 

Figure 16-51  During sunset at 6.55 PM

In the Graphic Display Options dialog box, you can use the options in the Background area 
to set the background of the displayed view. In the Background area, you can select any of 
the four options from the Background drop-down list: Sky, Gradient, Image, and None. On 
selecting the Sky option from the Background drop-down list, the Ground Color parameter 
will be displayed under it. Choose the swatch corresponding to the Ground Color parameter; 
the Color dialog box will be displayed. Select a desired color from this dialog box and choose 
OK. The color of the sky will be set as per your selection and will be applied in the project view. 
On selecting the Gradient option from the Background drop-down list, three parameters: Sky 
Color, Horizon Color, and Ground Color are displayed under it. For each of these, you can 
choose different colors by using the Color dialog box. On selecting the Image option from the 
Background drop-down list, the Customize Image button will be displayed under it. Choose 
this button; the Background Image dialog box will be displayed. You can use this dialog box to 
apply an image to the background. After selecting an image and specifying the settings, choose 
OK; the Background Image dialog box will be closed and the Graphic Display Options dialog 
box will be displayed. In this dialog box, choose Apply and OK buttons to apply the display 
settings to the view.
 

Creating an Animated Solar Study
In Revit Architecture, you can also create an animated single-day or multi-day solar study. The 
single-day solar study generates the animation of shadow movements for a specified period of 
time in a single day and at a particular location. For example, you can create a solar study from 
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6 AM to 7 PM on August 15 in Boston. The multi-day solar study helps you create an animation 
of shadow movements at a fixed time of a day, but for specified number of days at a particular 
location. For example, you can create a solar study at 2 PM from August 15 to August 20, 2012 
in Boston.

To generate a single-day solar study, open the 3D view of the building model and click on the 
inclined arrow symbol in the Graphics panel of the View tab; the Graphic Display Options  
dialog box will be displayed. Make sure the Cast Shadows check box is selected in the dialog 
box. Choose the button on the right of the Sun Setting text; the Sun Settings dialog box will 
be displayed, as shown in Figure 16-52. Select the Single Day radio button; the options of 
sun settings for single day will be displayed in the Sun Settings dialog box. Select any of the 
predefined sun and shadow settings from the Presets list box. You can also define your own 
sun and shadow settings and name them by choosing the Duplicate button. The name of the 
setting will be listed in the list box. Specify the settings for the solar study in the Settings area as 
explained earlier and choose the OK button in the Sun Settings dialog box. Now, choose the OK 
button from the Graphic Display Options dialog box to apply the settings to the project view.

Figure 16-52  The Sun Settings dialog box

Animation Preview
To preview the solar study animation, choose the Shadows On button from the View Control 
Bar. Now, choose the Preview Solar Study option from the Sun Path button. Choose the Play 
button from Options Bar to play the animation. You will notice the shadow movements in 
multiple frames at a specified time. You can use the Previous Key Frame and Next Key Frame 
buttons from the Options Bar to move the animation back or forward by 10 frames. To view a 
particular frame of the animation, enter the frame number in the Frame edit box. Choose the 
Next Frame or Previous Frame button to view the previous or the next frame. Similarly, you can 
create the multi-day animation by selecting the Multi-Day radio button from the Sun Settings 
dialog box. In this dialog box, specify the time, location, and dates for the days for which you 
need to generate the solar study. 
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Exporting the Solar Study Animation
You can save and export the solar study animation and share it with clients and owners. To export 
the solar study animation, choose Export > Images and Animations > Solar Study from the 
File menu; the Length/Format dialog box will be displayed, as shown in Figure 16-53. Select 
the Frame range radio button and set the number of frames to be exported by setting the 
suitable values in the Start and End spinners in the Output Length area. The animation in 
that particular range of frames will be exported. You can also set the speed of the animation 
by setting suitable value in the Frames/sec spinner. The All frames radio button is selected to 
export the complete animation. In the Format area, select the graphics style from the Visual 
Style drop-down list. Specify the dimensions in pixels or zoom percentage to specify the frame 
size in the exported file. Choose the OK button to display the Export Animated Solar Study 
dialog box, as shown in Figure 16-54.

Figure 16-53  The Length/Format dialog box

In the Save in drop-down list, navigate to the required location to save the file. Enter the file 
name of the file in the File name edit box. Select the file format from the Files of type drop-down 
list to save the file.

Next, choose the Save button. If you have saved the file using the AVI file format, the Video 
Compression dialog box will be displayed on choosing the Save button. Choose the OK button 
to accept the default option in the dialog box; the animation file will be processed frame by 
frame and finally it will be saved as an AVI format at the specified location.
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Figure 16-54  The Export Animated Solar Study dialog box

POINT CLOUD								        
Point Cloud is a collection of point data in X, Y, and Z ordinates. This data is collected by 3D 
scanners. These 3D scanned point clouds are then used to create 3D revit models. These point 
cloud files are inserted in the Revit project to modify the existing condition of a building.

Inserting a Point Cloud File 
Point cloud files are .rcp and .rcs type format files. If the file is in raw format such as .pcg or .las 
format, then you will be prompted to index the data. The .rcp and .rcs format files are indexed 
point cloud files which are inserted in a Revit project.  

To directly use the .rcp or .rcs format file in a project, invoke the Point Cloud tool from the Link 
panel of the Insert tab; the Link Point Cloud dialog box will be displayed. In the Link Point 
Cloud dialog box, navigate to the location of files from the Look in drop-down list. Select the 
desired type of file format from the Files of Type drop-down list. After selecting the type of 
file from the list, select the desired position of file from the Positioning drop-down list located 
at the lower right corner of the Link Point Cloud dialog box. Now, choose the Open button; 
Revit retrives the current version of the point cloud file and links the .rcp and .rcs format files 
in the project.

If the files are in raw format, you will be prompted to index the data. To do so, choose the Point 
Cloud tool from the Link panel of the Insert tab; the Link Point Cloud dialog box will be 
displayed. In this dialog box, insert the raw format file type and then choose the Open button; 
the File Not Indexed window will be displayed prompting you to create the new .rcp or .rcs 
format file. Choose the Yes button in this dialog box; the Point Cloud File Indexing dialog 
box will be displayed. Now, to convert the raw data into the .rcs or .rcp format, choose the Start 
Indexing button; the file will be converted. As the indexing process finishes, choose the Close 
button; the dialog box will be closed. Now, the file is converted into an .rcp format. Choose the 
Point Cloud tool again to insert the new indexed file in the project.  
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Point Cloud Visibility 
To view a point cloud in a project, invoke the Visibility/ Graphic tool from the Graphics panel 
of the View tab; the Visibility/Graphics Overrides for <current view> dialog box will be 
displayed. In this dialog box, choose the Point Cloud tab. Next, in the Visibility column of 
this tab, you can select or clear the checkbox corresponding to the selected point cloud file to 
show or hide the point cloud in the view, respectively. You can also assign the color for each 
point cloud in the model. To do so, choose the RGB button; the Point Cloud Color Mode 
dialog box will be displayed. In the Point display area of this dialog box, by default, the RGB 
option is selected in the Color Mode drop-down list. On selecting any other color option in the 
drop-down list, the Settings area, and the Clear Overrides button at the bottom of the dialog 
box will be activated. Specify the required settings in the Settings area. You can also choose 
the Clear Overrides button to restore the previous settings. Next, choose the OK button; the 
dialog box will be closed.

Using Point Cloud File in a Project 
In Autodesk Revit, after inserting the point cloud file, you will use that file in the project. This file 
helps the user to provide a higher level of visual appearance of existing condition of a building. 
To capture the existing building, laser scanners are used to sample point from the surface of the 
existing building and saves that data as point cloud. The data collected by the laser scanner is 
huge. Thus, Revit links a point cloud as a reference rather than embedding the complete file. 
Now, you can modify the existing building condition easily and the work performance will be 
also be improved due to better visibility.

REVIT INTEROPERABILITY 
Autodesk Revit is quite compatible with CAD-based programs. You can create your own 
designs in Revit Architecture and then export them into other programs for visualization and 
creating photorealistic renderings of your designs. Revit is user-friendly, parametric, flexible, 
and compatible features help you create and implement your designs better and faster. Revit 
Architecture supports a wide range of file formats, thereby enabling the files to be imported and 
exported to other programs such as Autodesk 3ds Max, Autodesk Inventor, Revit Structures, 
Revit MEP, SketchUp, Microstation, and so on.

Interoperability with Autodesk 3ds Max
You can export a 3D view from Revit to Autodesk 3ds Max through DWG format to create 
photorealistic renderings and visualizations. The interoperability of Revit with 3ds Max has 
improved in the following ways:

1.	 Before exporting the views, you can use the section box to restrict the unwanted content in 
the file to be exported to Autodesk 3ds Max. The section box has been enhanced to enable 
you to switch to 2D view while modifying the section box size for the 3D view. Reducing the 
amount of data from the file reduces the size, thus making the importing and exporting of 
data faster and easier. 
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2.    The objects that have different materials assigned to different surfaces in Revit Architecture 
and the objects that have a complex geometry are exported in 3D view as ACIS solids. When 
such objects are imported in 3ds Max, they display different materials assigned to different 
surfaces unlike the previous releases that showed only one material for the entire ACIS solid.

3.	 The files exported from Revit and imported into 3ds Max show the Revit Material Names, 
unlike the Material names that used to be displayed for the materials in the previous releases.

4.	 To export drawings from Revit to 3ds Max, you do not need to use the plug-in anymore, as 
this functionality has been incorporated in 3ds Max.

Revit - 3ds Max Workflow
The main steps followed to export a Revit project to 3ds Max are discussed next.

Create a 3D view for the project to be exported to 3ds Max. Choose Export > CAD Formats > 
DWG files /DXF files /DGN files / ACIS (SAT) files from the File menu; the DWG Export dialog 
box will be displayed. Export the file using the DWG format in the DWG Export dialog box. 

In Autodesk 3ds Max, import or link the DWG file using the File Link Manager option by 
choosing References > Manage Links from the File menu. Linking the file will allow you to 
make changes in the project design in Revit and then update it in 3ds Max automatically, without 
making the same changes again in 3ds Max. If you do not want to update the design, then just 
import the file. Make the final adjustments in the materials for rendering and then render the 
view. Before you export the project from Revit to 3ds Max, limit the model geometry using the 
section box and turn off the visibility of the elements or the element categories that will not 
be used for rendering. For example, while rendering the exterior view, you should turn off the 
visibility of the elements in the interior of the building. Also, set the detail level for the view. 
By reducing the detail in a Revit view, the number of objects and the size of the DWG file will 
be reduced. After you have reduced the unwanted content of the file, you can export the file to 
3ds Max as DWG file, ACIS solids or by creating a layer mapping template.

Interoperability with Trimble SketchUp
Revit Architecture supports SKP files. You can create your design in Revit and then export it to 
Trimble SketchUp. Similarly, you can import the design from Trimble SketchUp and link it to 
Revit. Trimble SketchUp is best suited for modeling and visualization. You can work on your 
designs using both Revit and SketchUp. If you want to quickly create a model of your design, 
assign materials and visualize it, then you can use SketchUp and then Revit Architecture to modify 
the designs. If you want to create a design, and at the same time, want to analyze and document 
the results, you should start your design in Revit and then use SketchUp at a later stage when 
you need to add materials and visualization. Trimble SketchUp along with Google Earth helps 
you place your models on the web using the real world coordinates and share it with world using 
the 3D Ware house feature of SketchUp that helps you to search, share and store 3D models. 
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Exporting a Drawing from Revit to SketchUp
Before you export the drawing from Revit to SketchUp, reduce the unwanted drawing file by using 
the section box, turn off the visibility of the elements, and set the detail levels for the elements. 
Next, create an export template or a layer mapping file to save the layer settings for the drawing 
to be exported. These settings are customized to be used with SketchUp. After creating the 
template, choose Export > CAD Formats > DWG files from the File menu; the DWG Export 
dialog box will be displayed, as shown in Figure 16-55. On selecting the Modify Export Setup 
option from the Select Export Setup drop-down list in this dialog box; the Modify DWG/DXF 
Export Setup dialog box will be displayed. After setting the required views and other options, 
choose the OK button in this dialog box, and then choose the Next button in the DWG Export 
dialog box, the Export CAD Formats - Save to Target Folder dialog box will be displayed. In 
this dialog box, navigate to the required location to save the file, and select the DWG format. 
Next, enter the name of the file in the File name/prefix edit box and choose the OK button; 
the file will be exported to the specified location in the DWG format. Now, you can transfer and 
import the DWG file in SketchUp.

Figure 16-55  The DWG Export dialog box

Creating a Layer Mapping File for Layer Settings
Creating a layer mapping file or template file helps you to save the layer settings. These settings 
are customized for the drawing to be exported to SketchUp. To create a layer mapping file, 
choose Export > CAD Formats > DWG files from the File menu; the DWG Export dialog box 
will be displayed, refer to Figure 16-55. In this dialog box, choose the Modify Export Setup 
button; the Modify DWG/DXF Export Setup dialog box will be displayed, as shown in Figure 
16-56. In this dialog box, ensure that the Layers tab is chosen and then select an option from 
the Export layer options drop-down list to set the layer mapping for the file to be exported. 
After selecting an option from the Export layer options drop-down list, you can select an option 
from the Load layers from standards drop-down list to specify the standard to be followed for 
the layer mapping set. Now, choose the OK button; the dialog box will be closed and the layer 
mapping for the exported file will be set.
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Figure 16-56  The Modify DWG/DXF Export Setup dialog box for creating a 
layer mapping file

Publishing Tips in Revit 2020
Revit Architecture allows you to export the 2D and 3D project views to Design Web Format (DWF). 
DWF provides you with an alternative of Portable Drawing Format (PDF) to publish your project 
views. The advantages of using the DWF are given below:

1.	 You can print the same DWF file using any printer since the DWF file is not device 		
specific.

2.	 You can share the DWF files electronically through emails because of their smaller 		
size.

3.	 The DWF files are generally one-twentieth the size of the original DWG files.

4.	 You can publish all your data in one DWF file instead of multiple DWG files.

5.	 You can place your designs on web using the Google search engine.

6.	 You can share your files irrespective of the versions of AutoCAD.

7.	 You can decide what to publish in DWF file and avoid the sharing of the original files.
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8.	 You can see models clearly in a DWF file by zooming in the DWF files.

9.	 You can use a 3D viewer to view designs in DWF files.

10.	 Using the DWF files, you can share your designs in a much secure and easy way. You can 
share your designs even with people who do not use Revit Architecture.

Revit Architecture has the functionality of setting the default zoom option to Fit To Page in the 
Print SetUp dialog box. Therefore, you can avoid inclusion of a cropped portion of a 2D view 
into the DWF file. Also, you can publish rooms, areas, and room boundaries along with walls 
and other elements.

ROUTE ANALYSIS							           
The route analysis allows you to find out the shortest path and the quickest time of traversing 
between two defined points in a model.  Using this analysis, you can design your space to prevent 
any obstacle in the path of traverse between spaces in the model.

To perform the route analysis, you can use the Path of  Travel tool in the Route Analysis panel 
of the Analyze tab. You can use this tool to create a path in a plan view. The path of the model 
will then be generated based on the model elements acting as obstacles along the path of travel. 
The path of travel will be generated on the basis of the shortest distance between the start and 
the end points of the created path. Also, when the path generates, the model elements acting 
as obstacles in the travel path will be avoided.

Note:
The path of a travel can be used for a single level and considers  horizontal distance on the plane 
of the path of travel.

Creating a Travel Path
Open a plan view and then choose the Path of  Travel tool in the Route Analysis panel of the 
Analyze tab; the Modify | Place Path of Travel contextual tab will be displayed. In this tab, you 
can  select an option from the Line Style drop down in the Line Style panel to specify a line type  
to the path of travel. Also, you can choose the Tag on Placement button from the Tag panel to 
enable the display of tag along with the path of travel. After choosing an appropriate option click
to specify the start point of the path and then click to specify the end of the path. On doing so, 
a path of travel will be generated as the shortest travel distance between the two specified points 
avoiding model element obstacles in the path of travel, as shown in Figure 16-57. After the path 
is generated, you can make changes to the route by modifying the model categories that are 
considered obstacles to the path of travel. The settings for the route analysis can be modified 
by using the Route Analysis Settings dialog box. After the setting is modified, the travel path 
can be updated by using the Update tool that can be applied by selecting the travel path.
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Figure 16-57  Path of travel displayed in a 
model

Modifying Properties of the Path
After creating the path you can view and modify the instance proprieties of  the path. To do so, 
select the path created; the instance properties of the path will be displayed in the Properties 
palette, as shown in Figure 16-58. In this palette, you can select an option from the drop-down 
list corresponding to the Line Style parameter to change the line pattern of the selected path. 
The Speed, View Name, Level, Time, and Length are read-only parameters and cannot be 
modified. You can assign a value to the Mark parameter that can be used for reference in the 
schedules and tags created for the path of travel.

Figure 16-58  Partial view of the Properties 
pallete displaying the instance properties of the 
travel path
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Setting the Travel Path
After creating the path you can modify the route of the path based on the obstacles that you 
choose to come in its traverse. To modify the settings of the obstacles in the path, choose the 
Route Analysis Settings button in the Route Analysis panel of the Analyze tab. On doing so, 
the Route Analysis Settings dialog box is displayed as shown in Figure 16-59. 

Figure 16-59  The Route Analysis Settings 
dialog box

In the Revit will never consider the following as obstacles: area select the In addition, do 
not consider these model categories as obstacles, even when visible: check box to enable the 
check boxes in the display area to be selected or cleared. By selecting the check boxes in the 
display area you select the categories of the objects in the model to behave as an obstacle to the 
path while generating it. As such, Revit will not consider the element of the particular category 
as an obstacle and will guide the path to reverse to it.
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TUTORIALS
In the following two tutorials, you will combine the projects created in this book. In the first 
tutorial, you will create two facade options for the Apartment 1 project. In the second tutorial, 
you will combine the Elevator and Stair Lobby and the Apartment 2 project to create a cluster of 
apartments. You will then link the cluster to the Site Layout project created earlier in Chapter 9. 

Tutorial 1							          Apartment 1

In this tutorial, you will create two design options for the exterior facade. The first option uses 
18” x 18” (for Metric 450 x 450 mm) square structural columns and beams, as shown in Figure 
16-60. The distance between these members is shown in Figure 16-61 and Figure 16-62. The 
second design option is created using 12” X 12” (for Metric 300 x 300mm) square concrete 
columns and 12” X 24” rectangular concrete beams, as shown in Figure 16-63. The distances 
between the structural members and some other dimensions are shown in Figures 16-64. You 
can assume the missing dimensions for this tutorial. 						    
	                             					           (Expected time: 45 min)

Note
In this tutorial, the usage of structural elements has been given only as an example for creating 
the design options for a facade. Their general usage in a project should, however, depend on their 
placement. 

	

Figure 16-60  The 3D view for creating structural elements for Design Option 1
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Figure 16-61  The sketch plan for creating structural elements for Design Option 1

The following steps are required to complete this tutorial:

a.	 Create the design options in the Apartment 1 project.
b.	 Add structural elements to the Design Option 1, refer to Figures 16-60 through 16-62.
c.	 Add structural elements to the Design Option 2.
d.    Save the project using the Save As tool.
		  For Imperial	 c16_Apartment1_tut1.rvt
		  For Metric	 M_c16_Apartment1_tut1.rvt
e.	 Close the project using the Close tool.

Creating Design Options 
	 In this section of the tutorial, you will first create the two design options and then add 

elements to each of them.
	
1. 	 Choose Open > Project from the File menu and open the c15_Apartment1_tut1.rvt file (for 

Metric M_c15_Apartment1_tut1.rvt file) created in Tutorial 1 of Chapter 15. You can also 
download this file from https://www.cadcim.com. The path of the file is as follows: Textbooks > 
Civil/GIS > Revit Architecture > Exploring Autodesk Revit 2020 for Architecture.

2.	 Double-click on First Floor in the Floor Plans head of the Project Browser to open the 
corresponding floor plan in the drawing window.

3.	 Choose the Manage tab and then choose the Design Options tool from the Design Options 
panel; the Design Options dialog box is displayed.
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4. 	 In the Design Options dialog box, choose the New button from the Option Set area; the 
Option 1 node with Option 1(primary) subhead is displayed in the left side pane of Design 
Option dialog box.

Note
The headings for the Option Set, Edit, and Option areas in the Design Options dialog box will 
disappear on creating a new option set. To locate these areas in the dialog box, refer to Figure 16-9 in 
this chapter.

   
5.	 In the Option area, choose the New button to create Option 2 under the Option Set 1.

6.	 Select Option Set 1 and choose the Rename button in the Option Set area; the Rename 
dialog box is displayed. Enter Facade Options in the New edit box and choose OK; the 
Option Set 1 node is renamed to Facade Options.

7.	 Similarly, rename Option 1(primary) as 18”X18” columns (450 x 450 mm for metric) and 
Option 2 as 12”X12” (300 x 300 mm for metric) columns.

8.	 Select the option 18”X18” columns (primary) and choose the Edit Selected button from 
the Edit area; the drawing area turns into edit mode for the selected design option.

9.	 Now, choose the Close button to close the Design Options dialog box.

Figure 16-62  The north elevation view for creating structural elements for Design Option 1 
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Figure 16-63 The 3D view for creating structural elements for Design Option 2

Figure 16-64  The sketch plan for creating structural elements for Design Option 2 
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Adding Structural Components to Design Option 1
	 In this section of the tutorial, you will load and add structural columns in Design Option 1. 

1. 	 You need to add the structural columns to the drawing. To do so, choose the Structural 
Column tool from Architecture > Build > Column drop-down; the Modify | Place 
Structural Column tab is displayed. 

2.  From the Mode panel, choose the Load Family tool; the Load Family dialog box is displayed.
 

3.	 In the Load Family dialog box, choose US Imperial > Structural Columns > Concrete 
folder (for Metric US Metric > Structural Columns > Concrete folder) and select the 
Concrete-Square-Column.rfa file (for Metric M_Concrete-Square-Column.rfa file). Next, choose 
Open; the Concrete-Square-Column family (for Metric M_Concrete-Square-Column family) 
is loaded into the project file. 

4.	 From the Type Selector drop-down list in the Properties palette, select Concrete-Square-
Column: 18 x 18 (for Metric M_Concrete-Square-Column: 450 x 450mm).

5.	 Move the cursor near the top right corner of the floor plan and click when the vertical 
dimension in the upward direction displays 5’-0” (1500 mm) and the wall centerline is 
displayed, as shown in Figure 16-65. Now, exit from the Modify | Place Structural Column 
tab by choosing the Modify button from the Select panel.

6.	 In the 3D Views head in the Project Browser, double-click on {3D}.

7.	 Select the added structural column to display its instance properties in the Properties palette. 
In the Properties palette, click in the value field of the Base Level instance parameter and 
select the First Floor option from the drop-down list displayed, if it is not selected by default.

8.	 Click on the value field of the Top Level instance parameter and select Roof from the 
drop-down list displayed. In the value fields of the Base Offset and Top Offset instance 
parameters, enter 0’0” (0 mm) and -6” (-150 mm), respectively.

9.	 Choose the Apply button from the Properties palette; the specified instance parameters are 
assigned to the selected column.

10.	 Open the First Floor plan view. Select the structural column and make its copies, refer to 
Figure 16-58. To make copies, choose the Copy tool from the Modify panel of the Modify| 
Structural Columns tab and select the Multiple checkbox from the Options Bar and create 
copies in the horizontal direction at the specified dimension, refer to Figure 16-58.

11.	 Now, choose the Modify button from the Select panel to clear the selection.

12.	 Repeat the procedure followed in step 10 to draw the column in vertical direction, refer to 
Figure 16-58. After adding all columns as per the sketch plan, choose the Modify button 
from the Select panel. 

	
13.	 To add beams to the columns, choose the Beam tool from the Structure panel of the Structure 

tab.
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Figure 16-65  Adding structural elements to the Design Option 1

14.	 On invoking the Beam tool, the Modify | Place Beam tab is displayed. In this tab, choose  
the Load Family tool from the Mode panel; the Load Family dialog box is displayed. 

15.	 In this dialog box, choose US Imperial > Structural Framing > Concrete folder (for 
Metric US Metric > Structural Framing > Concrete folder) and then select the Concrete-
Rectangular Beam.rfa file (for Metric M_Concrete-Rectangular Beam.rfa file), and then choose 
Open; the Concrete - Rectangular Beam family (for Metric M_Concrete - Rectangular 
Beam) is loaded in the project.

16.	 In the Properties palette, notice that the Concrete-Rectangular Beam 16 x 32 type (for 
Metric M_Concrete-Rectangular Beam 400 x 800mm) is selected by default in the Type 
Selector drop-down list. Next, choose the Edit Type button; the Type Properties dialog 
box for the selected beam type is displayed.

17.	 Choose the Duplicate button; the Name dialog box is displayed. Enter 18 x 18 (for Metric 
450 x 450mm) in the Name edit box and choose OK; the Name dialog box closes. 

18.	 In the Type Properties dialog box, modify the values for b and h type parameters to 1’ 6” 
(450 mm) respectively and choose the OK button to assign the specified value to the new 
type and close the Type Properties box.

19.	 In the Options Bar, select the Level: Second Floor option from the Placement Plane drop-
down list.



Using Advanced Features							           16-67

20.	 Sketch the horizontal beam between the two columns, as shown in Figure 16-66. Ignore the 
warning displayed.

Figure 16-66  Adding the horizontal structural beam to the Design Option 1

21.	 Similarly, sketch the vertical beam between the two columns. Again, ignore the warning. 
After sketching the vertical beam, choose the Modify button; the current selection is cleared. 

22.	 In the Project Browser, double-click on {3D} under the 3D Views head; the default 3D 
view of the project is displayed in the drawing area.

23.	 Right-click on the ViewCube tool; a shortcut menu is displayed. Choose Orient to a Direction 
> Northeast Isometric from the shortcut menu; the current view reorients toward the 
northeast isometric view, as shown in Figure 16-67.

24.	 Select the two beams using the CTRL key; the Modify | Structural Framing tab is displayed. 
Now, choose the Copy to Clipboard tool from the Clipboard panel; the selected beams are 
copied to the clipboard.  

25.	 To paste the copied beams, choose the Aligned to Selected Levels tool from the Paste 
drop-down in the Clipboard panel; the Select Levels dialog box is displayed.  
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Figure 16-67  The 3D view of the added structural elements

26.	 In this dialog box, select the Third Floor, Fourth Floor, and Roof options using the CTRL 
key and then choose the OK button to paste the beams at the selected levels. Now, choose 
the Modify button to exit the current selection.

27.	 Select the beams at the roof level and use the drag controls to complete the beam. You will 
use the East and North Elevation views to drag and extend the beams. After this step, the 
3D view should appear similar to the illustration shown in Figure 16-68.

Figure 16-68  The 3D view of the copied structural beams
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	 Similarly, you can add other smaller beams between the levels and the beams perpendicular 
to the walls, based on the given sketch plan and 3D View for Option 1. You may need to 
convert the exterior wall to bearing. 

28.	 In the Project Browser, double-click on the Second Floor; to display the corresponding 
view.

29.	 Invoke the Floor: Architectural tool from Architecture >Build > Floor drop-down and 
add the floor slab between the exterior wall and the columns on the two sides at the second 
floor level, as shown in Figure 16-69. After you create the floor, Autodesk Revit displays a 
prompt box. Choose the No button to keep the walls detached from the slabs created in this 
design option. 

30.	 Choose the Sketch Path tool from the Architecture > Circulation > Railing drop-down 
and then create the default railing on the second floor between the structural columns, as 
shown in the 3D view for Design Option 1, refer to Figure 16-60. 

 
31.	 After creating the railing and the floor, select them; the Modify | Multi-Select tab is displayed. 

Choose the Copy to Clipboard tool from the Clipboard panel of the Modify | Multi-Select tab; 
the selected elements are copied to the clipboard.

32.	 Choose the Aligned to Selected Levels tool from the Modify | Multi-Select > Clipboard > 
Paste drop-down; the Select Levels dialog box is displayed. From this dialog box, select 
the Fourth Floor option and then choose OK; the Select Levels dialog box closes and the 
selected element gets pasted. Choose the Modify button to exit the current selection.

Figure 16-69  A foor slab added using the Floor tool

33.	 Choose the Manage tab and then choose the Design Options tool from the Design Options 
panel; the Design Options dialog box is displayed.
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34.	 In this dialog box, choose the Finish Editing button from the Edit area and then choose 
the Close button; the Design Options dialog box closes and the 3D view appears similar 
to the view given for Option 1, refer to Figure 16-68. Notice that the Main Model option 
is selected in the Active Design Option drop-down list that is displayed below the Pick to 
Edit button in the Design Options panel of the Manage tab.

Adding Structural Components to Design Option 2
	 In this section of the tutorial, you will create elements to Design Option 2. In general, you 

can use two methods to create elements to a design option. The first method is to create the 
elements as they were created in the previous option. The second method is to copy elements 
from Option 1 to Option 2 and then modify them based on the given project parameters. 
You will use the second method in this tutorial.

1.	 To start adding element to the design option, choose the Design Options tool from the 
Design Options panel of the Manage tab; the Design Options dialog box is displayed; as 
shown in Figure 16-70. In this dialog box, select the 18” X 18” columns (primary) (for 
Metric 450 x 450 mm columns(primary)) choose the Edit Selected button. Next, choose 
the Close button; the Design Option dialog box is closed.

Figure 16-70  The Design Option dialog box

2.	 Select all elements created in Design Option 1, including columns, beams, floors, and 
railings  and choose the Copy to Clipboard tool from the Clipboard panel of the Modify 
| Multi-Select tab and then choose the Manage tab.

3.	 In this tab, select the 12”X 12” columns (for Metric 300 x 300mm columns) option from 
the Active Design Option drop-down list in the Design Options panel. Notice that from 
the current view, the elements of the previous design option disappear.
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4.	 Choose the Modify tab and then choose the Aligned to Same Place tool from the Paste 
drop-down in the Clipboard panel. Notice that the copied elements of Design Option 1 are 
pasted in Design Option 2.  

5.	 Select all the column and by using the Type Selector drop-down list in the Properties 
palette, replace all Concrete-Square-Column 18” X 18” (for Metric M_Concrete-Square-
Column 450 x 450mm) types with Concrete-Square-Column 12” X 12”types (for Metric 
Concrete-Square-Column 300 x 300mm type). Similarly, select all the beams and replace 
all Concrete-Rectangular Beam : 18” X 18” beams with Concrete-Rectangular Beam: 

       12” X 24” beams. 

6.	 Use the drag control to extend the beams, wherever necessary, such that they completely 
lie over the column. You may need to work in various views to select and extend the beams 
based on the given 3D view for Design Option 2.

7.	 Similarly, select the railings and edit them such that they span between the columns. Also, 
modify their properties to match the given railing profile. Assume the dimensions for the 
railing and baluster placement.

8.	 Select and extend the floor slabs at the second and fourth floors up to the beams. Now, 
the 3D view of the project should resemble the views given for creating Design Option 2, 
refer to Figures 16-63 through 16-65.

9.	 Choose the Design Options tool from the Design Options panel in the Manage tab to 
invoke the Design Options dialog box. Choose the Finish Editing button from this dialog 
box. Choose the Close button to close the dialog box.

Saving the Project
       In this section, you will save the project file using the Save As tool.

1. 	 Now, choose Save As > Project from the File menu; the Save As dialog box is displayed. 
Enter c16_Apartment1_tut1.rvt (for Metric M_c16_Apartment1_tut1.rvt) in the File name 
edit box of the Save As dialog box.

2.   Choose Save; the Save As dialog closes and the file is saved. 

Note
You will not close the project file for Apartment 1 project at this stage as this file will be required 
for the next tutorial for building the Apartment Complex.  

 

Tutorial 2 				                   Apartment Complex
In this tutorial, you will generate the Apartment Complex project by copying and pasting the 
elements of the Elevator and Stair Lobby and Apartment 2 projects into the Apartment project. Edit 
them to attach to the Apartment project. Group them into an apartment cluster, as shown in 
Figure 16-71. Save the project file as Apartment Cluster.rvt. Use all latest project files for this 
tutorial.
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In the Site Plan file created in Exercise 1 of Chapter 9, link the Apartment Cluster and the Club 
project based on Figure 16-72. Save the project file as Apartment Complex.rvt.
							                         (Expected time: 45 min)

Figure 16-71  The sketch plan showing the cluster of apartments 

 Note
The tools used to copy/paste and link projects have been given to describe their general usage in 
a project. These tools should, however, be used based on the project parameters and intent.	

The following steps are required to complete this tutorial

a.	 Copy and paste elements of the Elevator and Stair Lobby project and the Apartment 2 project 
to the base file, refer to Figures 16-73 through 16-76.

b.	 Group the projects and use the modifying tools to create the Apartment Cluster project, refer 
to Figure 16-77.

c.	 Open the Site Plan project and link the Apartment Cluster and the Club project using the 
Import/Link tool, refer to Figures 16-78 and 16-79.

d.    Save the project using the Save As tool.
		  For Imperial	 c16_ApartmentComplex_tut2.rvt
		  For Metric	 M_c16_ApartmentComplex_tut2.rvt
e.	 Close the project using the Close tool.
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Figure 16-72  The sketch plan for linking Apartment Cluster and Club project to the Site 
Plan project

Copying the Elements of the Elevator and Stair Lobby and Apartment 2 
and Pasting in a New Project
	 In this section of the tutorial, you will first copy and paste the elements of the Elevator and 

Stair Lobby and the Apartment 2 projects into the Apartment 1 project. For this, you need to 
group all the elements in each project before inserting them into the base file. You will also 
edit the walls of the former project in order to attach them to the latter, based on the layout 
plan given for the apartment cluster.

1.	 Choose Open > Project from the File menu and open the c11_ElevatorandStairLobby_ex2.rvt 
file (for Metric  M_c11_ElevatorandStairLobby_ex2.rvt) created in Exercise 2 of Chapter 11. 
You can also download this file from https://www.cadcim.com. The path of the file is as follows: 
Textbooks > Civil/GIS > Revit Architecture > Exploring Autodesk Revit 2020 for Architecture

2.	 Open the {3D} view from the Project Browser and select all elements created in the project. 
Now, choose the Create Group tool from the Create panel of the Modify | Multi-Select 
tab; the Autodesk Revit 2020 message box is displayed.  

3.	 In this message box, choose OK; the Create Model Group dialog box is displayed. In this 
dialog box, ensure that Group 1 is entered in the Name edit box and then choose the OK 
button; the Create Model Group dialog box closes and the selected elements are highlighted 
in a group. 



16-74			                                  Exploring Autodesk Revit 2020 for Architecture

4.	 Next, you need to copy the created group to the clipboard. To do so, ensure that the new 
group is selected and then choose the Copy to Clipboard tool from the Clipboard panel 
of the Modify | Model Groups tab; the selected group is copied to the clipboard.

5. 	 Open the c16_Apartment1_tut1.rvt file (for Metric M_c16_Apartment1_tut1.rvt file) and 
double-click on the First Floor plan view; the corresponding view is displayed. Next, choose 
the Modify tab. In this tab, choose the Paste from Clipboard tool from the Clipboard panel; 
the Duplicate Types dialog box is displayed. Choose the OK button from the dialog box; 
the copied elements of the Elevator and Stair Lobby project are displayed in the drawing area.

6.	 Zoom out the current view and place the elements of the Elevator and Stair Lobby project 
anywhere outside the Apartment 1 project profile.

7.	 Choose the Move tool from the Modify panel of the Modify | Model Groups tab and move 
the selected elements using the object snaps, as shown in Figure 16-73. Ignore any warning 
message at this stage.

8.	 Open the c08_Apartment2_ex1.rvt project file (For Metric M_c08_Apartment2_ex1.rvt project 
file) and choose Site from the Project Browser. Now, select all elements (except the 
annotations) displayed in the view and choose the Create Group tool from the Create panel 
of the Modify | Multi Select tab. Then group the selected elements with the default name. 
Now, ensure that the group is selected and then choose the Copy to Clipboard tool from 
the Clipboard panel of the Modify | Model Groups tab.

9.	 Choose the c16_ Apartment1_tut1-Floor Plan: First Floor option (for Metric M_c16_ 
Apartment1_tut1-Floor Plan: First Floor) from View > Windows > Switch Windows 
drop-down; the Apartment 1 project is displayed.

Figure 16-73  Moving the elements of the Elevator and Stair Lobby project  



Using Advanced Features							           16-75

10.	 In the Apartment 1 project,  choose the Modify  tab.  In this  tab,  choose 
the Paste from Clipboard tool from the Clipboard panel; the Duplicate Types dialog box 
is displayed. Choose the OK button from the dialog box. Now, place the Apartment 2 elements 
anywhere outside the profile of the existing project.

11.	 Next, you need to change the orientation of the pasted elements of the Apartment 2 project. 
To do so, ensure that the elements of the Apartment 2 project are selected and then choose 
the Rotate tool from the Modify panel of the Modify | Model Groups tab.

12.	 Use the Rotate tool to rotate the elements of the Apartment 2 project clockwise by 90 
degrees, refer to Figure 16-74.

13.	 Ensure that the elements of the Apartment 2 project are selected, and then choose the 
       Mirror - Draw Axis tool from the Modify panel of the Modify| Model Groups tab. In the 

Options Bar, ensure that the Copy check box is cleared. Now, draw the axis of reflection 
along the horizontal axis that passes through the centre of the Apartment 2 project. On doing 
so, the Apartment 2 project gets mirrored in its own central horizontal axis.

14.	 Ensure that the elements of the Apartment 2 project are selected. Then, choose the Move 
tool from the Modify panel of the Modify | Model Groups tab and move the elements, as 
shown in Figure 16-74. Ignore any warning message at this stage. Next, choose the Modify 
button from the Select panel.

15.	 Now, you need to ungroup the elements of the Elevator and Stair Lobby project. To do so, 
select the elements of the Elevator and Stair Lobby project from the drawing and then choose 
the Ungroup tool from the Group panel of the Modify| Model Groups tab; the selected 
group is ungrouped and you will notice that the Modify | Model Groups tab is replaced by 
the Modify | Multi-Select tab. 

 

Figure 16-74  Moving the elements of the Apartment 2 project  
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16.	 Choose the Modify button from the Select panel and zoom into the area that shows the 
overlapping walls, refer to Figure 16-75. Next, select the wall of the Elevator and Stair Lobby 
project that overlaps with the wall of the Apartment 1 project and use the drag control to 
stretch the walls to their intersection. Similarly, select the other wall of the Elevator and Stair 
Lobby project that intersects with the wall of Apartment 2 project and use the drag control to 
stretch it to the intersection point. Use the Split Element tool to create a split in the wall 
that is common to the Elevator and Stair Lobby project and the Apartment 1 project, as shown 
in Figure 16-76. 

17.  Next, select the overlapping wall of the Elevator and Stair Lobby project near the entrance of 
the Apartment 2 project, refer to Figure 16-75 and choose the Delete tool from the Modify 
panel of the Modify | Walls tab; the selected walls are deleted.

18.  Now, you need to save the project file. To do so, choose Save As > Project; the Save As 
dialog box is displayed. Enter c16_Apartment_Cluster_tut2 (for Metric M_c16_Apartment_
Cluster_tut2) in the File name edit box and then choose Save; the Save As dialog box closes 
and the project file is saved with the specified name.

Figure 16-75  The overlapping walls  

Figure 16-76 The split created to separate the walls 
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Creating the Apartment Cluster
1.	 Choose Site from the Floor Plans head in the Project Browser and then select all elements 

(except annotations) of the Apartment 1 project. Next, choose the Create Group tool from 
the Create panel of the Modify | Multi-Select tab; the Create Model Group dialog box is 
displayed. 

2.	 In the Create Model Group dialog box, enter Apartment 1 in the Name edit box and choose 
OK; the selected elements of Apartment 1 project are highlighted as a group. Choose the 
Modify button from the Select panel to clear the current selection. 

3.	 Similarly, select the grouped elements of the Apartment 2 project and rename the group as 
Apartment 2.

4.	 Choose First Floor from the Floor Plans head of the Project Browser and then select the 
Apartment 1 group along with the Apartment 2 group; the Modify | Model Groups tab is 
displayed.

5.	 Choose the Mirror - Pick Axis tool from the Modify panel and mirror the selected 
groups along the vertical reference line of the center of the Elevator and Stair Lobby project. 
Alternatively, you can choose the Mirror - Draw Axis tool and mirror the selected group by 
drawing a vertical axis along the center of the circular wall. Ignore any warning message at 
this stage. Choose the Modify button from the Select panel to clear the current selection.

Note
After mirroring the Apartment 1 and Apartment 2 projects, you will use the drag controls to 	
remove the overlapping of walls, if created.    

6.	 Next, you need to mirror the Design Option 1 of the Apartment 1 project. To do so, choose 
Site from the Floor Plans head in the Project Browser and choose the Manage tab. Next, 
select the 18”x18” columns option from the Active Design Options drop-down list in the  
Design Options panel; the elements of the selected Design Option are highlighted.  

7.	 Select the elements created in the 18” X 18” columns option (for Metric 450 X 450mm 
columns). Invoke the Mirror - Pick Axis tool from the Modify | Multi-Select tab and then 
mirror the selected elements along the same vertical axis as selected in Step 5. Choose the 
Modify button from the Select panel to clear the current selection.

8.	 Now, choose First Floor from the Floor Plans head in the Project Browser and then select 
the Main Model option from the Active Design Option drop-down list in the Design Options 
panel of the Manage tab. Next, select all elements of the project and mirror them along the 
horizontal axis. The horizontal axis should be defined by the wall centerlines of the south 
walls of the Apartment 2 project, as shown in the cluster plan of this tutorial, refer to Figure 
16-71. Ignore any warning message during the mirroring process. After mirroring the 
selected elements, choose the Modify button from the Select panel to clear the current 
selection.

9.	 You will also mirror the elements created for Design Option 1, separately in the Site view. 
Use the drag control to complete the overlapping walls. After completing this step, the 
northeast 3D view should appear similar to the illustration shown in Figure 16-77.
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10.	 Next, select the Main Model option from the Active Design Option drop-down list in the 
Manage tab and then choose the Purge Unused tool from the Settings panel of the Manage 
tab. Then, choose the OK button from the Purge unused dialog box to purge all the unused 
elements and annotations.

11.	 Choose Save As from the File menu and save the Apartment_Cluster project (for Metric  
M_Apartment_Cluster project).

Figure 16-77  The northeast 3D view for the apartment cluster

Linking the Apartment Cluster and the Club Projects to the Site
1.	 Open the Site Plan project created in Tutorial 1 of Chapter 9.

2.	 Choose the Manage tab and then choose the Transfer Project Standards tool from 
the Settings panel; the Select Items To Copy dialog box is displayed. Ensure that the 
c16_Apartment _Cluster_tut2 option is selected in the Copy from drop-down list. Choose 
the OK button; the Duplicate Types message box is displayed. This message box displays 
the list of element types that are duplicated in the projects.

3.	  Choose the New Only button to return to the Site Plan project.

4.	 Navigate to the Apartment _Cluster project and choose Close from the File menu; the Apartment 
Cluster project is closed.

5.	 In the Site Plan project, choose the Insert tab and then choose the Link Revit tool from the 
Link panel; the Import/Link RVT dialog box is displayed.

6.	 Select the Apartment_ Cluster. rvt project file (for Metric M_Apartment_ Cluster_. rvt project 
file)and then select the Manual - Base point option from the Positioning drop-down list. 
Choose the Open button; the Import/Link RVT dialog box closes and the selected file is 
displayed in the drawing area. 
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7.	 Place the Apartment Cluster project over the building pad at the location shown in Figure 16-78. 
You may need to use the Move tool to align the linked model. The exact location is not 
important for this tutorial.

8.	 Select the linked model and choose the Array tool from the Modify panel of the 
Modify | RVT Links tab. Create two more copies of the model using the Radial tool with 
center of the model as the center of the site.

Figure 16-78  Placing the linked Apartment 1 project over the building pad

9.	 Similarly, link and place the c14_Club_tut2.rvt file (for Metric M_c14_Club_tut2.rvt file)and 
place it into the Site Plan project, as shown in Figure 16-79.

10.	 Create a mirror copy of the Club project along the vertical axis.

11.	 You will notice that all the linked projects have been placed at the base level, Level 1. Select 
all the linked models and move them vertically upward by 10’0”(3000mm) using the elevation 
views. The site plan of the completed project appears similar to the sketch view given for the 
site plan of this tutorial. The 3D view of the project looks similar to the illustration given 
in Figure 16-80.
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Figure 16-79  Placing the linked Club project over the building pad

Figure 16-80  The 3D view of the completed Apartment Complex project

Saving the Project
       In this section, you will save the project file using the Save As tool.

1.	 Choose Save As > Project from the File menu and save the file as Apartment 
Complex (for Metric M_Apartment Complex).

2.	 Choose Close from the File menu to close the project file.
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Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:
	
1.	 The __________ tool is used to create area schemes. 

2.	 The __________ tool is used to link revit projects.

3.	 You can use the __________ tool to purge or remove unused elements from an Autodesk 
Revit project.

4.	 The __________ tool is used to enable worksets in a project file.

5.	 The __________ tool can be used to organize the Project Browser.

6.     Structural columns can be aligned along the inclined grid lines using the SPACEBAR. (T/F)

7.	 You can add structural columns to the multiple grid intersection by using the At Grids tool. 
(T/F)

8.	 You cannot create multiple design options in the same Autodesk Revit project. (T/F)

9.	 When a project is linked, its elements can be edited in the base project. (T/F)

10.	 You cannot control the visibility of elements of a linked project. (T/F)

Review Questions
Answer the following questions:

1.	 Which of the following tools is used to share projects between project teams?

		  a) Link Revit				    b) Worksets
		  c) Export		  		  d) Purge Unused

2.	 Which of the following tools is used to create a structural column? 

		  a) Wall		  			   b) Stairs
		  c) Railing	 			   d) Structural Column

3.	 Which of the following tools is used to remove unused elements and annotations from a 
project file?

			 
		  a) Purged Unused			   b) Delete
		  c) Demolish				    d) Cut

4.	 The Transfer Project Standards tool can be used to link project files. (T/F)
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5.	 The Manage Links tool can be used to reload a linked project. (T/F)

6.	 You can create a number of option sets under each design option. (T/F)

7.	 Structural columns are created downward from the specified level. (T/F)

8.	 The Workset tool can be used to subdivide and share a large project into smaller projects. (T/F)

9.	 You can use the Color Fill tool to create color plans describing their spatial usage in a 
building plan. (T/F)

10.	 The Phasing tool enables you to divide a project into various development phases. (T/F)

EXERCISES
Exercise 1							            Apartment 2

Modify the Apartment Cluster project (for Metric  M_Apartment_Cluster project) created in the 
Tutorial 1 of this chapter. Add structural elements for the Apartment 2 exterior wall, based on 
the sketch plan shown in Figure 16-81 and the sketch elevation, as shown in Figure 16-82. Use 
18”x18” columns to generate the facade. The 3D view should appear similar to the illustration 
given in Figure 16-83. Modify the Apartment 2 project file and reinsert the elements into the 
Apartment Cluster file. 	                                                                        (Expected time: 45 min)

Save the file as-
		  For Imperial	 c16_apartment_cluster_ex1.rvt 
		  For Metric 	 M_c16_apartment_cluster_ex1.rvt)

Figure 16-82  Sketch elevation for adding structural elements to the Apartment 2 project
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Figure 16-83  The 3D view of the completed Apartment Complex project

Exercise 2						     Apartment Complex

Create the 3D perspective views of the Apartment Complex project, based on the view shown in 
Figures 16-84 and 16-85. Also, render the perspective views.  
								                       (Expected time: 30 min)
Save the file as exercise1_apartment_cluster.rvt (for Metric M_exercise1_apartment_cluster.rvt)

Figure 16-84  First 3D perspective view of the Apartment Complex project
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Figure 16-85  Partial 3D perspective view of the Apartment Complex project

Answers to Self-Evaluation Test
1. T, 2. T, 3. F, 4. F, 5. F, 6. Area and Volume Computations, 7. Link Revit, 8. Purge Unused, 
9. Worksets, 10. Browser Organization


